ResizeKit2.NET

ResizeKit2.NET

ResizeKit2.NET Reference

Form Resizing Component

Newtone Corporation
Honchou 2-2-15, Shangrila Honchou 1F
Nagaoka City, Niigata Prefecture
940-0076, JAPAN
Telephone: +(81)258-86-6954
Fax: +(81)258-86-6964
https://www.imagekit.com
iksupport@imagekit.com


Overview

The ResizeKit Control

Automatically adjusts the size of the controls and fonts displayed on the form in proportion to changes in the form size or screen resolution. The size of the form when it is initially displayed and the amount that the form can be enlarged or reduced can be set.

Simply paste the control on the form. Redesign or adding code is not necessary.

To use the ResizeKit, simply place the control on the form and recompile the program. Established programs can easily become size (and screen resolution) independent.

Be sure to:
* Set the AutoSize property of the Form to False.
* Set the AutoScaleMode property of the Form to None.
* Set the Anchor property of each control to be placed on Form to AnchorStyles.Top and AnchorStyles.Left (default value).
* The cell size of the DataGridView control is not subject to resizing. (Font size is subject to resizing.)

Use the control's AutoSizeColumnsMode and AutoSizeRawsMode properties to resize cells.
* Each control of ReportViewer and MonthCalendar is not subject to resizing.
* Third-party controls may not be eligible for resizing.

Simple sample programs included


Installation

ResizeKit2.NET

Installing the ResizeKit2.NET

To install the ResizeKit2.NET, download and execute the appropriate installer for your programming environment. The ResizeKit2.NET installation includes an assembly for .NET Framework 2.0 to 3.5 and another assembly for .NET Framework 4.0 and above. Please be sure to use the appropriate assembly for your development environments.

The trial version of the ResizeKit2.NET is fully functional and will work for approximately 30 days from the time of installation. The retail version license must be activated on the PC where the ResizeKit2.NET is installed. See below for more details about activation.

IMPORTANT: After installing the retail version, you will be prompted to activate the license. You have 2 weeks to activate the retail license after which the ResizeKit2.NET will stop working until the license is activated.

How to activate your ResizeKit2.NET License:
License activation is the final step in correctly installing your product. The License Activation tool will automatically start when the product is installed. You can activate the license during installation or choose to activate it later. If you choose to activate later, you can do so at any time by running the License Activation tool (LicenseActivation.exe) found in the "Tool" folder under the directory where the product is installed. If the license is not activated within 2 weeks of installation, the product will stop working until the license is activated. You can activate a license online or offline.

Online Activation:

To activate a license online, use the License Activation tool (LicenseActivation.exe) and select the "Online" radio button. The License Activation tool uses the Product ID and Serial Number that you received when you purchased the product. Enter the Product ID and Serial Number in the License Activation tool and click "Add License". Your license will be activated online in a matter of few minutes.

During online activation, the Product ID and Serial Number as well as a unique Confirmation ID that is generated by the License Activation tool are transmitted to our license activation server. No other information except for the Product ID, Serial Number, and Confirmation ID are transmitted. Once this information is confirmed by our server, the product will be automatically activated. The status of your activation will appear in the License Activation tool.

Before uninstalling the ResizeKit2.NET, you must remove the license from the machine where it was activated. If the license is not removed it will remain even after the product has been uninstalled. Until that license is removed, that product cannot be activated on another machine. To remove the license, run the License Activation tool and click the "Remove License" button.

Offline Activation:

License activation can also be performed offline via email. To activate a license offline, run the License Activation tool and select the "Offline" radio button. Send the Product ID, Serial Number, and the Confirmation ID shown in the License Activation tool to Newtone Corporation at rssupport@imagekit.com. Once we receive the Product ID, Serial Number, and the Confirmation ID, we will send you a License Key which you will enter in the License Activation tool.

To remove a license offline, run the License Activation tool and select the "Offline" radio button. Enter the Product ID and Serial Number in the License Activation tool and click the "Remove License" button. Then send the Product ID, Serial Number, and the Confirmation ID shown in the License Activation tool to Newtone Corporation at rssupport@imagekit.com. Please allow 3 to 5 working days for the license to be removed.

Questions:

Please contact Newtone Corporation at rssupport@imagekit.com if you have any questions about activation or if you have any problems activating your product.


Deployment

ResizeKit2.NET

Deploying applications containing the ResizeKit2.NET

When distributing applications that use the ResizeKit2. NET, the "Newtone.ResizeKit.Win.ResizeKitNET.dll" file must be deployed with the your application.


Newtone.ResizeKit2NET Support

ResizeKit2.NET

User Registration and Technical Support

User Registration:

Please be sure to register your ResizeKit2.NET. User registration allows you to develop and distribute applications containing the ResizeKit2.NET. Registered users may also receive support from our technical staff and also receive discounts on upgrades for the ResizeKit2.NET or when purchasing our other products.

To register, please send the following information to register@imagekit.com:

The name of the developer using the ResizeKit2.NET
Your contact information including address and email address
The ResizeKit2.NET serial number

Technical Support:

Technical support is free to registered users and is available by email or fax only.

We periodically release updates and maintanence releases for the ResizeKit2.NET. Registered users can download these updates from the ResizeKit suppoert section of our web site at:

https://www.imagekit.com

Registered users are provided with a username and password. If you are not yet registered, please send us your name, address, email address and product serial number at the email address given above

To contact us:

Newtone Corporation
Honchou 2-2-15, Shangrila Honchou 1F
Nagaoka City, Niigata Prefecture
940-0076, JAPAN
Telephone: +(81)258-86-6954
Fax: +(81)258-86-6964
Email: rssupport@imagekit.com


ResizeKit2.NET LICENSE AGREEMENT

ResizeKit2.NET LICENSE AGREEMENT

IMPORTANT- READ CAREFULLY BEFORE INSTALLING THE SOFTWARE.

This License Agreement (this "AGREEMENT") contains the terms and conditions regarding your use of the SOFTWARE (as defined below) and material limitations to your rights in that regard. You should read this AGREEMENT carefully.

By installing the ResizeKit2.NET software (hereinafter the "SOFTWARE"), you are accepting the following AGREEMENT.

I. THIS AGREEMENT.

1. Software Covered by this AGREEMENT.

This AGREEMENT governs your use of the Newtone Corporation ("Newtone") SOFTWARE enclosed either as part of a SOFTWARE installer or otherwise accompanied herewith. The term "SOFTWARE" includes, to the extent provided by Newtone: 1) any revisions, updates and/or upgrades thereto; 2) any data, image or executable files, databases, data engines, computer software, or similar items customarily used or distributed with computer software products; 3) anything in any form whatsoever intended to be used with or in conjunction with the SOFTWARE; and 4) any associated media, documentation (including physical, electronic and online) and printed materials (the "Documentation").

2. This AGREEMENT is a legal agreement between you and Newtone.

If you are acting as an agent of a company or another legal person, such as an officer or other employee acting for your employer, then "you" and "your" mean your principal, the entity or other legal person for whom you are acting. However, importantly, even if you are acting as an agent for another, you may still be personally liable for violation of laws such as copyright infringement.

This AGREEMENT is a legal agreement between you and Newtone. You intend to be legally bound to this AGREEMENT to the same extent as if Newtone and you physically signed this AGREEMENT. By installing, copying, or otherwise using the SOFTWARE, you agree to be bound by the terms and conditions contained in this AGREEMENT. If you do not agree to all of the terms and conditions contained in this AGREEMENT, you may not install or use the SOFTWARE. If you have already installed or begun to install the SOFTWARE you should cancel any install in progress and uninstall the SOFTWARE. If you do not agree to all of these terms and conditions, then you must promptly return the uninstalled SOFTWARE to the place from which you purchased it in accordance with the return policies of that place.

II. YOUR LICENSE TO DEVELOP AND TO DISTRIBUTE.

Detailed below, this AGREEMENT pertains to three licenses: 1) a license to use the SOFTWARE to develop other software products (the "PC Developer License"); 2) a license to use and/or distribute the Developed Software (the "Runtime Distribution License"); and 3) a license to use and/or distribute the Developed Software on a Network Server (the "Server Runtime License"). All of these licenses (individually and collectively, the "Licenses") are explained and defined in more detail below.

1. Definitions. Terms and their respective meanings as used in this AGREEMENT:

"Developer" means a person using the SOFTWARE in accordance with the terms and conditions of this AGREEMENT.

"Network Server" means a computer with one or more computer central processing units (CPU's) that operates for the purpose of serving other computers logically or physically connected to it, including, but not limited to, other computers connected to it on an internal network, intranet or the Internet. "Server" means a type of Network Server that serves other computers more particularly connected to it over an intranet or the Internet.

"Developed Software" means those computer software products that are developed by or through the use of the SOFTWARE. "Developed Server Software" means those Developed Software products that reside logically or physically on at least one Server and are operated (executed therein) by the Server's central processing unit(s) (CPU). "Developed Desktop Software" means those Developed Software products that are not Developed Server Software, including, for example, standalone applications. "Redistributable Files" means the SOFTWARE files or other portions of the SOFTWARE that are provided by Newtone and are identified as such in the Documentation for distribution by you with the Developed Software. "Developer" means a person using the SOFTWARE in accordance with the terms and conditions of this AGREEMENT.

"PC" is a computer on which the SOFTWARE is installed.

"PC Developer" is the use of one licensed copy of the SOFTWARE on one PC by one concurrent Developer.

"PC Developer License" defines the right to use the SOFTWARE for development purposes. Every machine installing, running and/or using the SOFTWARE for development purposes must have a licensed copy and its appropriate license.

"Subscription period" is the period during which an active subscription agreement exists as confirmed in writing by Newtone, usually at the moment of subscription purchase.

2. Your PC Developer License.

You are hereby granted a limited, royalty-free, non-exclusive right to use the SOFTWARE to design, develop, and test Developed Software, on the express condition that, and only for so long as, you fully comply with all terms and conditions of this AGREEMENT.

The SOFTWARE is licensed to you on a per PC Developer License basis.

The each PC Developer License means that one Developer may install one copy of the SOFTWARE for use in designing, testing and creating Developed Software on one computer with a single set of input devices, restricting the use of the SOFTWARE to a maximum of three concurrent user. Conversely, you may not install or use the SOFTWARE on a computer that is a network server or a computer at which the SOFTWARE is used by more than one Developer. You may not network the SOFTWARE or any component part of it, where it is or may be used by more than one Developer unless you purchase an additional PC Developer License for each Developer. You must purchase another separate license to the SOFTWARE in order to add additional developer seats if the additional developers are accessing the SOFTWARE on a computer network. If the SOFTWARE is used to create Developed Server Software, then you must have a separate Server Runtime License for each Server where copies of the Developed Server Software exist. (See 4. Your Server Runtime License below)

In all cases, you may not use Newtone's name, logo, or trademarks to market your Developed Software without the express written consent of Newtone; agree to indemnify, hold harmless, and defend Newtone, its suppliers and resellers, from and against any claims or lawsuits, including lawyer's fees that may arise from the use or distribution of your Developed Software; you may use the SOFTWARE only to create Developed Software that is significantly different than the SOFTWARE.

3. Your Runtime Distribution License.

License to Distribute Developed Desktop Software. Subject to the terms and conditions in this AGREEMENT, you are granted the license to use and to distribute Developed Desktop Software on a royalty-free basis, provided that the Developed Desktop Software incorporates the SOFTWARE as an integral part of the Developed Software in machine language compiled format (customarily an ".exe", or ".dll", etc.). You may not distribute, bundle, wrap or subclass the SOFTWARE as Developed Software which, when used in a "design time" development environment, exposes the programmatic interface of the SOFTWARE. You may distribute, on a royalty-free basis, Redistributable Files with Developed Desktop Software only.

4. Your Server Runtime License.

Subject to the terms and conditions in this AGREEMENT, you are granted the license to use and to distribute Developed Server Software, provided that you purchase one Server Runtime License for each Network Server operating the Developed Server Software (and/or Redistributable Files called or otherwise used directly by the Developed Server Software).

5. License Serial Number.

Upon purchase of the SOFTWARE a unique serial number (the "Serial Number") is provided by Newtone either electronically or via the delivery channel. The Serial number provides a means to Register the SOFTWARE. The Serial Number is subject to the restrictions set forth in this AGREEMENT and may not be disclosed or distributed either with your Developed Software or in any other way. The disclosure or distribution of the Serial Number shall constitute a breach of this AGREEMENT, the effect of which shall be the automatic termination and revocation of all the rights granted herein.

6. Updates/Upgrades.

Subject to the terms and conditions of this AGREEMENT, the Licenses are perpetual. Updates, bug fixes and upgrades to the SOFTWARE may be provided by Newtone at their discretion at timely intervals only during the Subscription period though Newtone does not commit to providing such updates or upgrades, and, if so provided by Newtone, are provided upon the terms and conditions offered at that time by Newtone.

7. Evaluation, Trial, or Beta Copy.

If you are using an "evaluation copy", a "trial" copy, a "Beta" copy, or similar version of the SOFTWARE, specifically designated as such by Newtone on its website or otherwise, then the Licenses are limited as follows: a) you are granted a license to use the SOFTWARE for a period of thirty (30) days counted from the day of installation (the "Evaluation Period"); b) upon completion of the Evaluation Period, you shall either i) delete the SOFTWARE from the computer containing the installation, or you may ii) contact Newtone or one of its authorized dealers to purchase a license of the SOFTWARE, which is subject to the terms and limitations contained herein. The "evaluation copy", "trial" copy, "Beta" copy, or similar version of the SOFTWARE is for evaluation purposes only and may not be used to create any Developed Software and if created may not be distributed or used for any purpose including commercial purposes.

III. INTELLECTUAL PROPERTY.

1. Copyright.

You agree that all right, title, and interest in and to the SOFTWARE (including, but not limited to, any images, photographs, code examples and text incorporated into the SOFTWARE), and any copies of the SOFTWARE, and any copyrights and other intellectual properties therein or related thereto are owned exclusively by Newtone, except to the limited extent that Newtone may be the rightful license holder of certain third-party technologies incorporated into the SOFTWARE. The SOFTWARE is protected by copyright laws and international treaty provisions. The SOFTWARE is licensed to you, not sold to you. Newtone reserves all rights not otherwise expressly and specifically granted to you in this AGREEMENT.

2. Backups.

You may make one copy the SOFTWARE solely for backup or archival purposes.

3. General Limitations.

You may not reverse engineer, decompile, or disassemble the SOFTWARE.

4. Software Transfers.

You may not rent or lease the SOFTWARE. You may transfer the SOFTWARE to another computer, provided that it is completely removed from the computer from which it was transferred. You may permanently transfer all of your rights under the AGREEMENT, provided that you obtain expressed written permission from Newtone and that you retain no copies, that you transfer all the SOFTWARE (including all component parts, the media and printed materials, any dates, upgrades, this AGREEMENT and, if applicable, the Certificate of Authenticity), and that the recipient agrees to the terms and conditions of this AGREEMENT as provided herein. Newtone must be notified in writing prior to the license transfers where the company of the recipient is different to that of the original licensee. If the SOFTWARE is an update or upgrade, any transfer must include all prior versions of the SOFTWARE.

5. Termination.

Without prejudice to any other rights it may have, Newtone may terminate this AGREEMENT and the Licenses if you fail to comply with the terms and conditions contained herein. In such an event, you must destroy all copies of the SOFTWARE and all of its component parts.

IV. DISCLAIMER and WARRANTIES

1. Disclaimer

Newtone's entire liability and your exclusive remedy under this AGREEMENT shall be, at Newtone's sole option, either (a) return of the price paid for the SOFTWARE; (b) repair the SOFTWARE through updates distributed online. Newtone cannot and does not guarantee that any functions contained in the Software will meet your requirements, or that its operations will be error free. The entire risk as to the Software performance or quality, or both, is solely with the user and not Newtone. You assume responsibility for the selection of the component to achieve your intended results, and for the installation, use, and results obtained from the SOFTWARE.

2. Warranty.

Newtone makes no warranty, to the maximum extent permitted by law, either implied or expressed, including with-out limitation any warranty with respect to this Software documented here, its quality, performance, or fitness for a particular purpose. In no event shall Newtone be liable to you for damages, whether direct or indirect, incidental, special, or consequential arising out the use of or any defect in the Software, even if Newtone has been advised of the possibility of such damages, or for any claim by any other party. All other warranties of any kind, either express or implied, including but not limited to the implied warranties of merchantability and fitness for a particular purpose, are expressly excluded.

V. MISCELLANEOUS.

1. This is the Entire Agreement.

This AGREEMENT (including any addendum or amendment to this AGREEMENT included with the SOFTWARE) is the final, complete and exclusive statement of the entire agreement between you and Newtone relating to the SOFTWARE. This AGREEMENT supersedes any prior and contemporaneous proposals, purchase orders, advertisements, and all other communications in relation to the subject matter of this AGREEMENT, whether oral or written. No terms or conditions, other than those contained in this AGREEMENT, and no other understanding or agreement which in any way modifies these terms and conditions, shall be binding upon the parties unless entered into in writing executed between the parties, or by other non-oral manner of agreement whereby the parties objectively and definitively act in a manner to be bound (such as by continuing with an installation of the SOFTWARE, "clicking-through" a questionnaire, etc.) Employees, agents and other representatives of Newtone are not permitted to orally modify this AGREEMENT.

2. You Indemnify Newtone.

You agree to indemnify, hold harmless, and defend Newtone and its suppliers and resellers from and against any and all claims or lawsuits, including attorney's fees, that arise or result from this AGREEMENT.

3. Interpretation of this AGREEMENT.

If for any reason a court of competent jurisdiction finds any provision of this AGREEMENT, or any portion thereof, to be unenforceable, that provision of this AGREEMENT will be enforced to the maximum extent permissible so as to effect the intent of the parties, and the remainder of this AGREEMENT will continue in full force and effect. Formatives of defined terms shall have the same meaning of the defined term. Failure by either party to enforce any provision of this AGREEMENT will not be deemed a waiver of future enforcement of that or any other provision. Except as otherwise required or superseded by law, this AGREEMENT is governed by the laws of JAPAN. If the SOFTWARE was acquired outside of JAPAN, then local law may apply.


ResizeKit class

Newtone.ResizeKit.Win

Newtone.ResizeKit.Win.ResizeKit Class

The main class for the WinForm ResizeKit control.

For a list of members of the ResizeKit class, please refer to ResizeKit Members

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Newtone.ResizeKit.Win
public class ResizeKit : System.Windows.Forms.Control

Explanation

The ResizeKit control resizes all controls placed on a Windows Form. When the form's size changes the ResizeKit control will change the size of the contols on that form by the same proportion.

Necessary Conditions

Namespace : Newtone.ResizeKit.Win

Assembly : Newtone.ResizeKit.Win.ResizeKitNET.dll

Reference

ResizeKit Members


ResizeKit Members

Newtone.ResizeKit.Win.ResizeKit Members

ResizeKit Overview

Constructor

ResizeKit Constructor Initializes a new instance of the ResizeKit class.

Public Properties

NoResizeControls | Gets or sets the controsl that will be exclueded from resizing.
NoResizeFontControls | Gets or sets the controls whose fonts will be excluded from resizing.
ResizeEnabled | Enables the ResizeKit functionality.
ResizeFontEnabled | Sets whether or not the fonts of the controls on the form will be resized

Public Events

ResizeEnd This event fires after the form has been resized

Reference

Newtone.ResizeKit.Win.ResizeKit


ResizeKit Constructor

Newtone.ResizeKit.Win.ResizeKit Constructor

Initializes a new instance of the ResizeKit class.

[Visual Basic]Public Sub New()
[C#]public ResizeKit()

Explanation

Placing the ResizeKit control on a Windows Form will create an instance of the ResizeKit. It is also possible to create an instance of the ResizeKit using code (without placing the control on the form). Instances can be created in this way when using MDI child forms etc.

Example

Place the following code within the Form Load event

                [Visual Basic.NET]
                Dim rk = New Newtone.ResizeKit.Win.ResizeKit()
                Me.Controls.Add(rk)

                [Visual C#.NET]
                Newtone.ResizeKit.Win.ResizeKit rk = new Newtone.ResizeKit.Win.ResizeKit();
                this.Controls.Add(rk);

Reference

ResizeKit Members | Newtone.ResizeKit


NoResizeControls property

Newtone.ResizeKit.Win.ResizeKit.NoResizeControls Property

This property sets the controls that will be excluded from resizing.

[Visual Basic]Public Property NoResizeControls As String()
[C#]public string[] NoResizeControls {get; set;}

Property Value

Array of string type values representing control names

Default value is Nothing/null

Explanation

The NoResizeControls property refers to a control that does not resize even though the form is resized.

Control names which do not resize are set as an array of character strings. If the ResizeEnabled property is False, all controls will not be resized regardless of the value in this property.

Reference


NoResizeFontControls Property

Newtone.ResizeKit.Win.ResizeKit.NoResizeFontControls Property

This property sets the names of the controls on the form whose fonts will be excluded from resizing.

[Visual Basic]Public Property NoResizeFontControls As String()
[C#]public string[] NoResizeFontControls {get; set;}

Property Value

An array of string type values representing the control names

Defaullt value is Nothing/null

Explanation

The NoResizeFontControls property sets the controls whose fonts will be excluded from resizing.

Even if the ResizeFontEnabled property is set to True, the fonts for controls specified in the NoResizeFontControls property will not be resized.

Reference


ResizeEnabled property

Newtone.ResizeKit.Win.ResizeKit.ResizeEnabled Property

Gets or sets whether to enable the resize function.

[Visual Basic]Public Property ResizeEnabled As Boolean
[C#]public bool ResizeEnabled {get; set;}

Property Value

True ：Enable resize function

False：Disable resize function

Default value is True.

Explanation

If this property is set to False, each control on the form will not be resized even if the form size is changed.

If this property is False all controls will not be resized regardless of value in NoResizeControls property.

Reference


ResizeFontEnabled property

Newtone.ResizeKit.Win.ResizeKit.ResizeFontEnabled Property

This property sets whether or not the fonts of the controls will be resized.

[Visual Basic]Public Property ResizeFontEnabled As Boolean
[C#]public bool ResizeFontEnabled {get; set;}

Property Value

True：Allows fonts to be resized.

False：Disables font resizing.

Default value is True.

Explanation

If this property is set to False, the font on the controls will not be resized even if each control is resized.

If this property is False, the fonts of all controls are not resized regardless of the value of the NoResizeFontControls property.

Reference


ResizeEnd event

Newtone.ResizeKit.Win.ResizeKit.ResizeEnd Event

This event fires after the form has been resized.

[Visual Basic]Public Event ResizeEnd As ResizeEventHandler
[C#]public event ResizeEventHandler ResizeEnd;

Event Data

The event handler receives an argument of type ResizeEventArgs .

Explanation

Code placed within this event will execute after the form resize completes.

Reference


ResizeEventArgs class

Newtone.ResizeKit.Win.ResizeKit.ResizeEventArgs Class

Provides data of ResizeEnd event.

[Visual Basic]Public Class ResizeEventArgs Inherits System.EventArgs
[C#]public class ResizeEventArgs：System.EventArgs

Explanation

Properties | Type | Explanation
ScaleX | System.Double | The magnification of the width of the resized form relative to the width of the form at initial display (Width of form after resizing / width of form at initial display)
ScaleY | System.Double | The magnification of the height of the resized form relative to the height of the form at initial display (Height of form after resizing / height of form at initial display)

Reference


ResizeEventHandler delegate

Newtone.ResizeKit.Win.ResizeKit.ResizeEventHandler Delegate

This represents the delegate that handles the ResizeEnd Event
[Visual Basic]Public Delegate Sub ResizeEventHandler(ByVal sender As Object, ByVal e As Newtone.ResizeKit.Win.ResizeKit.ResizeEventArgs)
[C#]public delegate void ResizeEventHandler(object sender, Newtone.ResizeKit.Win.ResizeKit.ResizeEventArgs e);

Parameters

sender
Event source
e
Event data is retrieved in ResizeEventArgs

Reference