Newtone.ImageKit.WPF

ImageKit WPF X

ImageKit WPF X Class Library

ImageKit WPF X Class Library

Newtone Corporation
3-5-1 Jyonaicho Leben Nagaoka 204
Nagaoka City, Niigata Prefecture
940-0061, JAPAN
Telephone: +(81)258-86-6954
Fax: +(81)258-86-6964
https://www.imagekit.com
iksupport@imagekit.com


Notifications

ImageKit.WPF

Notifications of Copyright

The ImageKit.WPF X incorporates the following software:

LibTiff.Net

Copyright (c) 2008-2011, Bit Miracle
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

Neither the name of the Bit Miracle nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL BIT MIRACLE BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


Effect class

Newtone.ImageKit.Wpf

Newtone.ImageKit.WPF.Effect Class

This class exposes properties and methods for processing imaging effects (effect filters, transformations, conversions, etc).
For a list of all members of this type, see Effect Members.

System.Object
Newtone.ImageKit.WPF

public class Effect : Object

Explanation

This class exposes properties and methods for processing imaging effects (effect filters, transformations, conversions, etc).

Requirements

Namespace : Newtone.ImageKit.WPF

Assembly : Newtone.ImageKit.WPFX.Effect.dll

See Also

Effect Members


Effect Members

Newtone.ImageKit.WPF.Effect All Members

Effect Overview

Constructor

Effect constructor Creates a new instance of the Effect Class

Public Properties

DestinationImage | The image created after executing an effect method is set into this property.
DestinationMask | The mask image returned when an image created after executing an effect
ErrorStatus | Retrieves the type of error that has been generated.
Inside | Determines whether the area inside the selected area will be processed or the area outside the selected area will be processed
Point | Sets the coordinates of a polygonal area on the image where an effect will be processed
Rect | Sets the bounding rectangle defining an ellipse on the image where an effect will be processed
SelectMode | Sets the type of area that will be processed on the image
SourceImage | Sets the source image used by the effect class
SourceMask | Sets the image handle for the input mask image

Public Methods

Affine | Corrects a warped raster image
AntiAlias | Smoothes edges in raster images
AutoSelectImage | Uses a specified color (RGB value), compares this value to pixels in the image and selects areas of the image that have that color. From this selection, this method creates a new image and mask image.
Blur | Blurs a raster image
Canvas | Produces a canvas effect on the raster image
CheckSecretImage | Retrieves the digital watermark from a raster image
CombineCmykImage | Creates a single raster image from seperate bmp images representing each of the CMYK planes
CombineRGBAImage | Creates a 32-bit RGBA image from an image and an alpha channel
CombineRgbImage | Creates a single raster image from seperate bmp images representing each of the RGB planes
CombineYccImage | Creates a single raster image from seperate bmp images representing each of the YCrCb planes
ConvertColor | Converts images from one bit count to another
CustomFilter | Creates a custom effects filter for raster images
CutRectImage | Copies that portion of a raster image that is specified by the selected rectangle
Deskew | Repairs a skewed image.
Emboss | Creates an emboss effect on a raster image
EndBitmapAccess | Allows access to pixels in the Device Independent Bitmap (DIB)
GetBitmapPixel | Retrieves the RGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB)
GlassTile | Creates an glass tile effect on a raster image
Layer | Layers two raster images together
Lens | Creates a lens like effect on a raster image
Mosaic | Creates a mosiac effect on a raster image
MotionBlur | Creates a motion blur effect on a raster image
OilPaint | Produces an effect similar to an oil painting on the image
Outline | Produces an outline effect on the image
Panorama | Composes a panorama image from two raster images
PasteImage | Pastes a raster image into another raster image
RemoveNoise | Reduces the image noise in raster images
RemoveRedEye | Removes "red eye" from images by converting reddish colors within the selected area to another specified color
Resize | Changes the size of a raster image
RGBGamma | Uses gamma correction to adjust the RGB values of a raster image
RGBLevel | Increases (or decreases) the RGB values of a raster image
RGBReverse | Reverses the RGB values of a raster image
RGBSpline | Uses spline function to modifiy the RGB values of a raster image
Ripple | Produces a ripple like effect on a raster image
Rotate (Overloaded method) | Rotates raster images including 32 bit color images with alpha channel
SelectImage | Defines an area on a raster image and create a new image and mask image from that area
SetBitmapPixel | Sets the RGB value and the palette number of a specified pixel in the Device Independent Bitmap (DIB)
SetBrightness | Adjusts the brightness of a raster image
SetChroma | Adjusts the chrominance of a raster image
SetContrast | Adjusts the contrast of a raster image
SetGray | Changes a raster image to gray
SetSecretImage | Sets a digital watermark image or digital watermark text into a raster image
Sharpen | Modifies sharpness in a raster image
SplitCmykImage | Splits a raster image into seperate images, one for each CMYK plane
SplitRGBAImage | Splits a 32 bit RGBA image into a 24 bit RGB image and a 8 bit alpha channel
SplitRgbImage | Splits a raster image into seperate images, one for each RGB plane
SplitYccImage | Splits a raster image into seperate images, one for each YCrCb plane
StartBitmapAccess | Allows access to pixels in the Device Independent Bitmap (DIB)
UnifyColor | Allows you to convert a range in colors in a raster image into one color
Waves | Creates a wave like effect on a raster image
WhirlPinch | Produces an interesting effect similar to pinching a raster image then twisting your fingers
YCCGamma | Uses gamma correction to adjust the YCrCb values of a raster image
YCCLevel | Increases (or decreases) the YCrCb values of a raster image
YCCReverse | Reverses the YCrCb values of a raster image
YCCSpline | Uses spline function to modifiy the YCrCb values of a raster image

Public Event

Progress Generated when an effect is being processed

See Also

Effect Class


ImageKit.Effect Constructor

Newtone.ImageKit.WPF.Effect Constructor

This initializes a new instance of the Effect class.

[Visual Basic]
Public Sub New()
[C#]
public Effect()

See Also

Effect Class | Effect Members


DestinationImage property

Newtone.ImageKit.WPF.Effect.DestinationImage Property

This property retrieves the image created after executing an Effect process.

[Visual Basic]
Public Property DestinationImage As System.Drawing.Image
[C#]
public System.Drawing.Image DestinationImage {get; set;}

Property Value

The image object on which an Effect has been processed

Explanation

The DestinationImage property retrieves the image created after executing an Effect process.

See Also

Effect Class | Effect Members


DestinationMask property

Newtone.ImageKit.WPF.Effect.DestinationMask Property

This property retrieves the mask image used when processing an effect.

[Visual Basic]
Public ReadOnly Property DestinationMask As System.Drawing.Image
[C#]
public System.Drawing.Image DestinationMask {get;}

Property Value

Image Class

Explanation

This property retrieves the mask image used when processing an effect. The mask image must be a 1-bit color black and white image which is the same size as the image it masks.

See Also

Effect Class | Effect Members


ErrorStatus property

Newtone.ImageKit.WPF.Effect.ErrorStatus Property

This property refers to the types of errors that can occur when using the Effect class library.

[Visual Basic]
Public ReadOnly Property ErrorStatus As Error
[C#]
public Error ErrorStatus {get;}

Property Value

Read only

Explanation

The ErrorStatus property refers to the types of errors that can occur when using the Effect class library. The value is of type Error enumeration.

See Also

Effect Class | Effect Members


Inside property

Newtone.ImageKit.WPF.Effect.Inside Property

This property determines whether the area inside the selected area will be processed or the area outside the selected area will be processed.

[Visual Basic]
Public Property Inside As Boolean
[C#]
public bool Inside {get; set;}

Property Value

When true, the area inside the selected area will be processed. When false, the area outside the selected area will be processed.

Explanation

The Inside property determines whether the area inside the selected area will be processed or the area outside the selected area will be processed. This property is enabled when the SelectMode property is set to EffectMask, EffectPolygon, or EffectEllipse.

See Also

Effect Class | Effect Members


Point property

Newtone.ImageKit.WPF.Effect.Point Property

This property sets the coordinates values for the points defining the polygon area on the image that will be processed by an effect

[Visual Basic]
Public Property Point As System.Drawing.Point
[C#]
public System.Drawing.Point[] Point {get; set;}

Property Value

The values of the coordinate points of a polygon on the image (must be 2 or more points)

Explanation

The Point property sets the coordinates values for the points defining the polygon area on the image that will be processed by an effect. This property is enabled when the SelectMode property is set to EffectPolygon. The origin (0,0) for the coordinate space is at the top left.

See Also

Effect Class | Effect Members


Rect property

Newtone.ImageKit.WPF.Effect.Rect Property

This property sets the coordinates of a rectangle on the image. This rectangle is used by the CutRectImage method or used to process an elliptical area on the image.

[Visual Basic]
Public Property Rect As System.Drawing.Rectangle
[C#]
public System.Drawing.Rectangle Rect {get; set;}

Property Value

The coordinates of the bounding rectangle

Explanation

The Rect property sets the coordinates of a rectangle on the image. This rectangle is used by the CutRectImage method or used to process an elliptical area on the image. The origin (0,0) for the coordinate space is at the top left. This property is enabled when the SelectMode property is set to EffectEllipse.

See Also

Effect Class | Effect Members


SelectMode property

Newtone.ImageKit.WPF.Effect.SelectMode Property

This property sets the type of area that will be processed on the image.

[Visual Basic]
Public Property SelectMode As AreaSelectMode
[C#]
public AreaSelectMode SelectMode {get; set;}

Property Value

This value is of enumeration type AreaSelectMode

Explanation

The SelectMode property sets the type of area that will be processed on the image.

See Also

Effect Class | Effect Members


SourceImage property

Newtone.ImageKit.WPF.Effect.SourceImage Property

This property sets the source image used by the effect class.

[Visual Basic]
Public Property SourceImage As System.Drawing.Image
[C#]
public System.Drawing.Image SourceImage {get; set;}

Property Value

The source image used by the effect class

Explanation

The SourceImage property sets the source image used by the effect class.

See Also

Effect Class | Effect Members


SourceMask property

Newtone.ImageKit.WPF.Effect.SourceMask Property

This property refers to the image handle for the input mask image.

[Visual Basic]
Public Property SourceMask As System.Drawing.Image
[C#]
public System.Drawing.Image SourceMask {get; set;}

Property Value

This property value is of type Image Class

Explanation

The SourceMask property refers to the image handle for the input mask image. The image set in this property must be 1 bit black and white image, the same size as the image it masks. White areas in the mask image are enabled, whereas black areas in the mask are disabled.

See Also

Effect Class | Effect Members


Affine method

Newtone.ImageKit.WPF.Effect.Affine Method

This method corrects a warped raster image.

[Visual Basic] Public Function Affine() As Boolean
[C#] public bool Affine();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Affine method corrects a warped raster image. To execute the Affine method, set the image handle of the image in the SourceImage property. The area on the image to be processed is determined by the coordinates for 4 points which are set in the Point property.

The Affine method supports 1, 4, 8, 16, 24, and 32 bit color images. If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


AntiAlias method

Newtone.ImageKit.WPF.Effect.AntiAlias Method

This method smoothes edges in raster images.

[Visual Basic]
Public Function AntiAlias() As Boolean
[C#]
public bool AntiAlias();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The AntiAlias method smoothes edges in raster images.

To execute the AntiAlias method, set the image handle of the image in the SourceImage property. The AntiAlias method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the AntiAlias method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


AutoSelectImage method

Newtone.ImageKit.WPF.Effect.AutoSelectImage Method

This method uses a specified color (RGB value), compares this value to pixels in the image and selects areas of the image that have that color. From this selection, This method creates a new image and mask image.

[Visual Basic]
Public Function AutoSelectImage(red As Byte, green As Byte, blue As Byte, mode As Integer, level As Integer) As Boolean
[C#]
public bool AutoSelectImage(byte red, byte green, byte blue, int mode, int level);

Parameters

red
Specifies the red value of the color that will be selected (From 0 to 255)

green
Specifies the green value of the color that will be selected (From 0 to 255)

blue
Specifies the blue value of the color that will be selected (From 0 to 255)

mode
Comparison mode (0:RGB, 1:CrCb, 2:Y)

level
Level of Allowance (From 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The AutoSelectImage method uses a specified color (RGB value), and selects areas of the image that have that color. To execute the AutoSelectImage method, set the image handle of the image in the SourceImage property. The AutoSelectImage method supports 1, 4, 8, 16, 24, and 32 bit images.

The Mode parameter sets the type of color comparison used to select portions of the image. When the Mode parameter is other than 0 (i.e. CrCb or Y) then all RGB values are converted to YCrCb values and compared. The Level parameter controls the range of RGB values that will be selected. If the Level value is 0, then only those pixels that have the save RGB value as that specified in the Red, Green, and Blue parameters will be selected.

As the Level parameter increases, the range of RGB values that will be selected increases. For example, if Level = 10 and Red, Green, and Blue = 100 respectively, then all pixels with an RGB value between (90,90,90) and (110,110,110) will be selected.

Before executing the AutoSelectImage method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To process the total image, set the SelectMode property to EffectAll
  2. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  3. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Set the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property, and the mask image set in the DestinationMask property will be set.

See Also

Effect Class | Effect Members


Blur method

Newtone.ImageKit.WPF.Effect.Blur Method

This method blurs a raster image.

[Visual Basic]
Public Function Blur(level As Integer) As Boolean
[C#]
public bool Blur(int level);

Parameters

level
The strength of the bluring function (From 1 to 20). As the Level increases, the strength of the blur increases.

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Blur method blurs a raster image. As the Level parameter increases, the strength of the blur increases. To execute the Blur method, set the image handle of the image in the SourceImage property. The Blur method supports 8-bit grayscale, 16, 24, and 32 bit images.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Set the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


Canvas method

Newtone.ImageKit.WPF.Effect.Canvas Method

This method produces a canvas effect on the raster image.

[Visual Basic]
Public Function Canvas(direction As Integer, depth As Integer) As Boolean
[C#]
public bool Canvas(int direction, int depth);

Parameters

direction
The direction of the canvas pattern (0:From top to right, 1: From top to left, 2: From bottom to left, 3: From bottom to right)

depth
Depth of the canvas pattern (From 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Canvas method produces a canvas effect on the raster image. To execute the Canvas method, set the image handle of the image in the SourceImage property. The Canvas method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the Canvas method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


CheckSecretImage method

Newtone.ImageKit.WPF.Effect.CheckSecretImage Method

This method retrieves the digital watermark from a raster image.

[Visual Basic]
Public Function CheckSecretImage(keyImage As System.Drawing.Image, secretImage As System.Drawing.Image, level As Integer) As Boolean
[C#]
public bool CheckSecretImage(System.Drawing.Image keyImage, System.Drawing.Image secretImage, int level);

Parameters

keyImage
The original image. This is the image without a digital watermark that is used as a key to compare to another image and check if a watermark exists (24 bit color images only).

secretImage
The image that contains the watermark (24 bit color images only)

level
The level at which to retrieve the watermark (From -20 to 20)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CheckSecretImage method retrieves the digital watermark from an image whose watermark has been set with the SetSecretImage method. It CANNOT retrieve other types of watermarks.

The Level parameter should be set to a value that is the same as or slighly smaller than the Level at which the watermark was embedded into the image using the SetSecretImage method. Using a Level to retrieve the watermark that differs significantly from the Level at which the watermark was set will result in no watermark being retrieved. Furthermore, the orginal image and the watermarked image must be exactly the same size. If either image has been resized, no watermark can be retrieved.

If successful the resulting raster image handle is set in the SourceImage property. The CheckSecretImage method supports only 24 bit color images. The resulting image has a black background with the digital watermark appearing in white. (It is a 1-bit image that is the same size as the images set in keyImage and secretImage.)

See Also

Effect Class | Effect Members


CombineCmykImage method

Newtone.ImageKit.WPF.Effect.CombineCmykImage Method

This method creates a single raster image from seperate bmp images representing each of the CMYK planes

[Visual Basic]
Public Function CombineCmykImage(cyan As System.Drawing.Image, magenta As System.Drawing.Image, yellow As System.Drawing.Image, black As System.Drawing.Image, destinationImage As System.Drawing.Image) As Boolean
[C#]
public bool CombineCmykImage(System.Drawing.Image cyan, System.Drawing.Image magenta, System.Drawing.Image yellow, System.Drawing.Image black, ref System.Drawing.Image destinationImage) ;

Parameters

cyan
The 8 bit grayscale image representing the C plane

magenta
The 8 bit grayscale image representing the M plane

yellow
The 8 bit grayscale image representing the Y plane

black
The 8 bit grayscale image representing the K plane

destinationImage
The 24 bit color raster image created from the combination of the above C, M, Y, and K plane images

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CombineCmykImage method creates a single raster image from seperate bmp images representing each of the CMYK planes. The various images representing each of the CMYK planes are 8 bit grayscale. If successful, the resulting image created by combining these C, M, Y, and K plane images is a 24 bit color raster image and is set in the destinationImage parameter.

See Also

Effect Class | Effect Members


CombineRGBAImage method

Newtone.ImageKit.WPF.Effect.CombineRGBAImage Method

This method creates a 32-bit RGBA image from an image and an alpha channel.

[Visual Basic]
Public Function CombineRGBAImage As Boolean
[C#]
public bool CombineRGBAImage();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CombineRGBAImage method creates a 32-bit RGBA image from an image and an alpha channel. To execute the CombineRGBAImage method, set the image handle of the image in the SourceImage property (1, 4, 8, 16, 24, or 32 bit image) and set the alpha channel image handle into the SourceMask property (1 bit color or 8 bit grayscale image).

If successful the resulting RGBA 32-bit image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


CombineRgbImage method

Newtone.ImageKit.WPF.Effect.CombineRgbImage Method

This method creates a single raster image from seperate bmp images representing each of the RGB planes

[Visual Basic]
Public Function CombineRgbImage(red As System.Drawing.Image, green As System.Drawing.Image, blue As System.Drawing.Image, destinationImage As System.Drawing.Image) As Boolean
[C#]
public bool CombineRgbImage(System.Drawing.Image red, System.Drawing.Image green, System.Drawing.Image blue, ref System.Drawing.Image destinationImage) ;

Parameters

red
The 8 bit grayscale image representing the R plane

green
The 8 bit grayscale image representing the G plane

blue
The 8 bit grayscale image representing the B plane

destinationImage
The 24 bit color raster image created from the combination of the above R, G, and B plane images

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CombineRgbImage method creates a single raster image from seperate bmp images representing each of the RGB planes. The various images representing each of the RGB planes are 8 bit grayscale. If successful, the resulting image created by combining these R, G, and B plane images is a 24 bit color raster image and is set in the destinationImage parameter.

See Also

Effect Class | Effect Members


CombineYccImage method

Newtone.ImageKit.WPF.Effect.CombineYccImage Method

This method creates a single raster image from seperate bmp images representing each of the YCrCb planes

[Visual Basic]
Public Function CombineYccImage(yb As System.Drawing.Image, cr As System.Drawing.Image, cb As System.Drawing.Image, destinationImage As System.Drawing.Image) As Boolean
[C#]
public bool CombineYccImage(System.Drawing.Image yb, System.Drawing.Image cr, System.Drawing.Image cb, ref System.Drawing.Image destinationImage) ;

Parameters

yb
The 8 bit grayscale image representing the Y plane

cr
The 8 bit grayscale image representing the Cr plane

cb
The 8 bit grayscale image representing the Cb plane

destinationImage
The 24 bit color raster image created from the combination of the above Y, Cr, and Cb plane images

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CombineYccImage method creates a single raster image from seperate bmp images representing each of the YCrCb planes. The various images representing each of the YCrCb planes are 8 bit grayscale. If successful, the resulting image created by combining these Y, Cr, and Cb plane images is a 24 bit color raster image and is set in the destinationImage parameter.

See Also

Effect Class | Effect Members


ConvertColor method

Newtone.ImageKit.WPF.Effect.ConvertColor Method

This method converts images from one bit count to another.

[Visual Basic]
Public Function ConvertColor(pixelType As Integer, fixPalette As Boolean, dithering As Boolean, level As Integer) As Boolean
[C#]
public bool ConvertColor(int PixelType, bool FixedPal, bool dithering, int level);

Parameters

pixelType
The number of bits per pixel (1, 4, 8, 16, 24, 32, 40, 80) after the conversion
* 4 represents 4 bit color, 40 is for 4 bit grayscale, 8 is for 8 bit color, and 80 is for 8 bit grayscale

fixPalette
Fixed palette settings (Use when decreasing or increasing to 1, 4, or 8 bit color)
false: Uses a created palette most suitable for the image
true: Uses a fixed palette

dithering
Sets the dither (error diffusion) (Use when decreasing to 1, 4, or 8 bit color or 4 bit grayscale)
false: Does not dither
true: Dithers

level
Threshold value settings (Use when decreasing to 1 bit images)
0 to 255

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The ConvertColor method changes the number of colors (also known as the bit count) of a raster image.

To execute the ConvertColor method, set the image handle of the image in the SourceImage property. This method supports 1, 4, 8, 16, 24, and 32 bit images. When decreasing the number of colors of an image to 1 bit color, if the RGB value (an average of the red, green, and blue values) is less than the threshold value, the palette is set to 0, otherwise it is set to 1.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


CustomFilter method

Newtone.ImageKit.WPF.Effect.CustomFilter Method

This method allows you to create a custom effects filter for raster images.

[Visual Basic]
Public Function CustomFilter(matrix(,) As Integer, div As Integer, level As Integer, red As Boolean, green As Boolean, blue As Boolean) As Boolean
[C#]
public bool CustomFilter(int[,] matrix, int div, int level, bool red, bool green, bool blue);

Parameters

matrix
9x9 matrix (an array of 81 items ranging from 0 to 80)

div
The division factor

level
The bias factor (from 0 to 255, as this factor increases, the color becomes brighter)

red
To process the red plane, set to True, otherwise set to False

green
To process the green plane, set to True, otherwise set to False

blue
To process the blue plane, set to True, otherwise set to False

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CustomFilter method allows you to create a custom effects filter for raster images. An effects filter alters each pixel's color based on its current color and the colors of any neighboring pixels. (See the explanation of the filter matrix below.)

To execute the CustomFilter method, set the image handle of the image in the SourceImage property. The CustomFilter method supports 8-bit grayscale, 16, 24, and 32 bit images.

When processing a grayscale image the Red, Green and Blue parameter values are disabled.

Before executing the CustomFilter method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

The filter consists of an array of coefficients called a filter matrix. A filter processes an image on a pixel-by-pixel basis. Each pixel's color value is multiplied by the coefficient in the matrix center, and any pixels within the matrix are multiplied by the corresponding coefficients. The sum of the products becomes the target pixel's new value. To make the filter matrix, it is necessary to create an array containing 80 elements and set the appropriate coefficient values in the array elements. The formula used to calculate the target pixel's value is given below:

Where F is the output value of the target pixel, Pi is a pixel in the grid, and Ci is a coefficient in the matrix. Div is the division factor which allows you to achieve effects that would otherwise require decimal coefficients. Level is a bias factor. You use the bias to shift the value of each pixel by a fixed amount. As the bias factor increases, the resultant color is brighter. Bias adjustments are particularly useful for creating embossing effects.

Some sample matrix are given below:

See Also

Effect Class | Effect Members


CutRectImage method

Newtone.ImageKit.WPF.Effect.CutRectImage Method

This method copies that portion of a raster image that is specified by the selected rectangle.

[Visual Basic]
Public Function CutRectImage As Boolean
[C#]
public bool CutRectImage();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CutRectImage method allows you to copy a portion of a raster image without using a mask image. (If you wish to use a mask image, please refer to the SelectImage method).

To execute the CutRectImage method, set the image handle of the image in the SourceImage property and specify the area to be copied by setting the Rect property. The CutRectImage method supports 1, 4, 8, 16, 24, and 32 bit images.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


Deskew method

Newtone.ImageKit.Win

Newtone.ImageKit.Win.ImageKit.Effect.Deskew Method

This method repairs a skewed image.

[Visual Basic] Public Function Deskew(bWhite As Boolean) As Boolean
[C#] public bool Deskew(bool bWhite);

Parameters

bWhite

Sets whether the new area created by deskew will be white or black (True: the area will be white; False: the area will be black)

This method supports 1 bit color only and is disabled for other bitcounts

Return Value

Returns True if successful, otherwise returns False

See Also

Effect Class | Effect Members


Emboss method

Newtone.ImageKit.WPF.Effect.Emboss Method

This method creates an emboss effect on a raster image.

[Visual Basic]
Public Function Emboss(pattern As Integer, edge As Integer, level As Integer) As Boolean
[C#]
public bool Emboss(int pattern, int edge, int level);

Parameters

pattern
Sets the direction of the emboss (0: Left to Right, 1: Top Left to Bottom Right, 2: Top to Bottom, 3: Top Right to Bottom Left, 4: Right to Left, 5: Bottom Right to Top Left, 6: Bottom to Top, 7: Bottom Left to Top Right)

edge
Sets the depth of the emboss (from 1 to 5; where 5 is the deepest emboss)

level
Sets the brightness of the emboss (from 0 to 255; where 255 is the brightest)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Emboss method creates an emboss effect on a raster image. To execute the Emboss method, set the image handle of the image in the SourceImage property. The Emboss method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the Emboss method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


EndBitmapAccess method

Newtone.ImageKit.WPF.Effect.EndBitmapAccess Method

This method is used to allow access to pixels in the Device Independent Bitmap (DIB). This method is to be used in conjunction with the StartBitmapAccess method.

[Visual Basic]
Public Function EndBitmapAccess(imgNo As Integer) As Boolean
[C#]
public bool EndBitmapAccess(int imgNo);

Parameters

imgNo
The image number (from -1 to 99)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The EndBitmapAccess method is to be used in conjunction with the StartBitmapAccess method. To execute the EndBitmapAccess method, set the image handle of the image in the SourceImage property. The EndBitmapAccess method supports 1, 4, 8, 16, 24, and 32 bit images.

To access the bitmap and manipulate pixel data, you must use the following methods as a group:

StartBitmapAccess
|
GetBitmapPixel, SetBitmapPixel
|
EndBitmapAccess

Example

The following code starts access to the DIB, then loops through each pixel in the image, using the GetBitmapPixel method to retrieve the pixels' rgb values. Then those values are reversed and set using the SetBitmapPixel method (For 1, 16, 24, or 32 bit images).

[Visual Basic]
Dim IkEffect As Newtone.ImageKit.WPF.Effect
Dim Ret As Boolean
Dim i As Long, j As Long
Dim PalNo As Integer, Red As Integer, Green As Integer, Blue As Integer

IkEffect = New Newtone.ImageKit.WPF.Effect

If IkEffect.SourceImage = Nothing Then Exit Sub
Ret = IkEffect.StartBitmapAccess(0)
If Ret = False Then Exit Sub

For i = 0 To IkEffect.SourceImage.Height - 1
  For j = 0 To IkEffect.SourceImage.Width - 1
    Ret = IkEffect.GetBitmapPixel(0, j, i, PalNo, Red, Green, Blue)
    If Image.GetPixelFormatSize(IkEffect.SourceImage.PixelFormat) = 1 Then
      If PalNo <> 0 Then
        PalNo = 0
      Else
        PalNo = 1
      End If
    Else If Image.GetPixelFormatSize(IkEffect.SourceImage.PixelFormat) > 8 Then
      Blue = 255 - Blue
      Green = 255 - Green
      Red = 255 - Red
    End If
    Ret = IkEffect.SetBitmapPixel(0, j, i, PalNo, Red, Green, Blue)
  Next j
Next i

Ret = IkEffect.EndBitmapAccess(0)

See Also

Effect Class | Effect Members


GetBitmapPixel method

Newtone.ImageKit.WPF.Effect.GetBitmapPixel Method

This method retrieves the RGB values (or ARGB values) and palette number of the specified pixel in the Device Independent Bitmap (DIB).

Overloaded list:

Retrieves RGB values and palette number from specified pixel

[Visual Basic]
Public Function GetBitmapPixel(imgNo As Integer, x As Integer, y As Integer, palette As Byte, red As Byte, green As Byte, blue As Byte) As Boolean
[C#]
public bool GetBitmapPixel(int imgNo, int x, int y, ref byte palette, ref byte red, ref byte green, ref byte blue);

Retrieves ARGB values and palette number from specified pixel

[Visual Basic]
Public Function GetBitmapPixel(imgNo As Integer, x As Integer, y As Integer, palette As Byte, alpha As Byte, red As Byte, green As Byte, blue As Byte) As Boolean
[C#]
public bool GetBitmapPixel(int imgNo, int x, int y, ref byte palette, ref byte alpha, ref byte red, ref byte green, ref byte blue);

See Also

Effect Class | Effect Members


GetBitmapPixel method

Newtone.ImageKit.WPF.Effect.GetBitmapPixel Method

This method retrieves the ARGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB).

[Visual Basic]
Public Function GetBitmapPixel(imgNo As Integer, x As Integer, y As Integer, palette As Byte, alpha As Byte, red As Byte, green As Byte, blue As Byte) As Boolean
[C#]
public bool GetBitmapPixel(int imgNo, int x, int y, ref byte palette, ref byte alpha, ref byte red, ref byte green, ref byte blue);

Parameters

imgNo
The image number (from -1 to 99)

x,y
The x,y coordinates of the specified pixel

palette
The palette number of the specified pixel

alpha
The alpha component of the ARGB value of the specified pixel

red
The red component of the ARGB value of the specified pixel

green
The green component of the ARGB value of the specified pixel

blue
The blue component of the ARGB value of the specified pixel

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetBitmapPixel method retrieves the ARGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB). For 1, 4, and 8 bit images, the applicable values are set in the Palette parameter. For 16, 24, and 32 bit images, the applicable values are set in the red, green, and blue parameters.

The image used is the image set in the StartBitmapAccess method.

To access the bitmap and manipulate pixel data, you must use the following methods as a group:

StartBitmapAccess
|
GetBitmapPixel, SetBitmapPixel
|
EndBitmapAccess

Example

The following code starts access to the DIB, then loops through each pixel in the image, using the GetBitmapPixel method to retrieve the pixels' rgb values. Then those values are reversed and set using the SetBitmapPixel method (For 1, 16, 24, or 32 bit images).

[Visual Basic]
Dim IkEffect As Newtone.ImageKit.WPF.Effect
Dim Ret As Boolean
Dim i As Long, j As Long
Dim PalNo As Integer, Red As Integer, Green As Integer, Blue As Integer

IkEffect = New Newtone.ImageKit.WPF.Effect

If IkEffect.SourceImage = Nothing Then Exit Sub
Ret = IkEffect.StartBitmapAccess(0)
If Ret = False Then Exit Sub

For i = 0 To IkEffect.SourceImage.Height - 1
  For j = 0 To IkEffect.SourceImage.Width - 1
    Ret = IkEffect.GetBitmapPixel(0, j, i, PalNo, Red, Green, Blue)
    If Image.GetPixelFormatSize(IkEffect.SourceImage.PixelFormat) = 1 Then
      If PalNo <> 0 Then
        PalNo = 0
      Else
        PalNo = 1
      End If
    Else If Image.GetPixelFormatSize(IkEffect.SourceImage.PixelFormat) > 8 Then
      Blue = 255 - Blue
      Green = 255 - Green
      Red = 255 - Red
    End If
    Ret = IkEffect.SetBitmapPixel(0, j, i, PalNo, Red, Green, Blue)
  Next j
Next i

Ret = IkEffect.EndBitmapAccess(0)

See Also

Effect Class | Effect Members


GetBitmapPixel method

Newtone.ImageKit.WPF.Effect.GetBitmapPixel Method

This method retrieves the RGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB).

[Visual Basic]
Public Function GetBitmapPixel(imgNo As Integer, x As Integer, y As Integer, palette As Byte, red As Byte, green As Byte, blue As Byte) As Boolean
[C#]
public bool GetBitmapPixel(int imgNo, int x, int y, ref byte palette, ref byte red, ref byte green, ref byte blue);

Parameters

imgNo
The image number (from -1 to 99)

x,y
The x,y coordinates of the specified pixel

palette
The palette number of the specified pixel

red
The red component of the RGB value of the specified pixel

green
The green component of the RGB value of the specified pixel

blue
The blue component of the RGB value of the specified pixel

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetBitmapPixel method retrieves the RGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB). For 1, 4, and 8 bit images, the applicable values are set in the Palette parameter. For 16, 24, and 32 bit images, the applicable values are set in the red, green, and blue parameters.

The image used is the image set in the StartBitmapAccess method.

To access the bitmap and manipulate pixel data, you must use the following methods as a group:

StartBitmapAccess
|
GetBitmapPixel, SetBitmapPixel
|
EndBitmapAccess

Example

The following code starts access to the DIB, then loops through each pixel in the image, using the GetBitmapPixel method to retrieve the pixels' rgb values. Then those values are reversed and set using the SetBitmapPixel method (For 1, 16, 24, or 32 bit images).

[Visual Basic]
Dim IkEffect As Newtone.ImageKit.WPF.Effect
Dim Ret As Boolean
Dim i As Long, j As Long
Dim PalNo As Integer, Red As Integer, Green As Integer, Blue As Integer

IkEffect = New Newtone.ImageKit.WPF.Effect

If IkEffect.SourceImage = Nothing Then Exit Sub
Ret = IkEffect.StartBitmapAccess(0)
If Ret = False Then Exit Sub

For i = 0 To IkEffect.SourceImage.Height - 1
  For j = 0 To IkEffect.SourceImage.Width - 1
    Ret = IkEffect.GetBitmapPixel(0, j, i, PalNo, Red, Green, Blue)
    If Image.GetPixelFormatSize(IkEffect.SourceImage.PixelFormat) = 1 Then
      If PalNo <> 0 Then
        PalNo = 0
      Else
        PalNo = 1
      End If
    Else If Image.GetPixelFormatSize(IkEffect.SourceImage.PixelFormat) > 8 Then
      Blue = 255 - Blue
      Green = 255 - Green
      Red = 255 - Red
    End If
    Ret = IkEffect.SetBitmapPixel(0, j, i, PalNo, Red, Green, Blue)
  Next j
Next i

Ret = IkEffect.EndBitmapAccess(0)

See Also

Effect Class | Effect Members


GlassTile method

Newtone.ImageKit.WPF.Effect.GlassTile Method

This method creates an glass tile effect on a raster image.

[Visual Basic]
Public Function GlassTile(xSize As Integer, ySize As Integer) As Boolean
[C#]
public bool GlassTile(int xSize, int ySize);

Parameters

xSize
Sets the width of each glass tile (from 10 to 100)

ySize
Sets the height of each glass tile (from 10 to 100)

Return Value

Returns True if successful. Returns False if successful.

Explanation

The GlassTile method produces an effect similar to glass tile on the image. To execute the GlassTile method, set the image handle of the image in the SourceImage property. The GlassTile method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the GlassTile method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


Layer method

Newtone.ImageKit.WPF.Effect.Layer Method

This method layers two raster images together.

[Visual Basic]
Public Function Layer(bottomImage As System.Drawing.Image, topImage As System.Drawing.Image, transLevel As Integer, transColor As Boolean, transRed As Byte, transGreen As Byte, transBlue As Byte, backRed As Byte, backGreen As Byte, backBlue As Byte, x As Integer, y As Integer, clip As Boolean, alpha As Boolean) As Boolean
[C#]
public bool Layer(System.Drawing.Image bottomImage, System.Drawing.Image topImage, int transLevel, bool transColor, byte transRed, byte transGreen, byte transBlue, byte backRed, byte backGreen, byte backBlue, int x, int y, bool clip, bool alpha);

Parameters

bottomImage
The image on which another image is layered (The image on the bottom). Supports 1, 4, 8, 16, 24, 32 bit images.

topImage
The image to be layered (The image on the top). Supports 1, 4, 8, 16, 24, 32 bit images.

transLevel
The level of transparency of topImage (From 0 to 255, as this value increases the image of topImage becomes visible)

transColor
Sets whether or not topImage has a transparent color. (False(0): No transparent color, True(non zero): Has transparent color)

transRed
Sets the red component of the RGB value of the transparent color for topImage (from 0 to 255)

transGreen
Sets the green component of the RGB value of the transparent color for topImage (from 0 to 255)

transBlue
Sets the blue component of the RGB value of the transparent color for topImage (from 0 to 255)

backRed
Sets the red component of the RGB value of the background color (from 0 to 255) This is the area of the image that is not part of either bottomImage or topImage

backGreen
Sets the green component of the RGB value of the background color (from 0 to 255) This is the area of the image that is not part of either bottomImage or topImage

backBlue
Sets the blue component of the RGB value of the background color (from 0 to 255) This is the area of the image that is not part of either bottomImage or topImage

x,y
The coordinates of the attachment location (in pixels)

clip
Sets whether or not the image is clipped (False(0): No clipping, True(nonzero) clipping)

alpha
Sets whether or not alpha channel is used ifalse: Does not use alpha channel, True: Uses alpha channel

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Layer method layers two raster images together. The upper left corner of the TopImage is attached to the BottomImage at the x,y coordinate location.

If the Clip parameter is set to True, the size of the created image is the same as the BottomImage. Any portions of the TopImage that extend beyond the BottomImage will be clipped. If the Clip parameter is set to False, the size of the created image is the same as the combination of the two images. Any areas of the created image that are not in either the BottomImage or the TopImage will be the color set in the BackRed, BackGreen, and BackBlue parameters. If the TransColor parameter is set to True, the color set by the TransRed, TransGreen, and TransBlue parameters will be a transparent color.

When the Alpha parameter is True, the raster image set in the TopImage parameter must be a 32-bit RGBA image (A refers to an alpha channel containing a mask image). Note: When the Aalpha parameter is True, the TransLevel parameter is disabled.

If successful the resulting raster image data is set in the DestinationImage property.

The output will be a 24 bit image. However, if either bottomImage or topImage is a 32 bit image, then the output will be a 32 bit image.

See Also

Effect Class | Effect Members


Lens method

Newtone.ImageKit.WPF.Effect.Lens Method

This method creates a lens like effect on a raster image.

[Visual Basic]
Public Function Lens(refract As Double, backColor As Boolean, red As Byte, green As Byte, blue As Byte) As Boolean
[C#]
public bool Lens(double refract, bool backColor, byte red, byte green, byte blue);

Parameters

refract
Sets the lens magnification (Greater than 1)

backColor
Sets whether or not the area outside of the lens effect is painted a particular color [True: the area is painted, False: the area is not painted]

red
Sets the red component of the color painted in the area outside the lens (from 0 to 255)

green
Sets the green component of the color painted in the area outside the lens (from 0 to 255)

blue
Sets the Blue component of the color painted in the area outside the lens (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Lens method produces a lens like effect on a raster image. To execute the Lens method, set the image handle of the image in the SourceImage property. The Lens method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the Lens method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


Mosaic method

Newtone.ImageKit.WPF.Effect.Mosaic Method

This method creates a mosaic effect on a raster image.

[Visual Basic]
Public Function Mosaic(xSize As Integer, ySize As Integer) As Boolean
[C#]
public bool Mosaic(int xSize, int ySize);

Parameters

xSize
The width of the mosaic (in pixels)

ySize
The height of the mosaic (in pixels)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Mosaic method creates a mosaic effect on a raster image. To execute the Mosaic method, set the image handle of the image in the SourceImage property. The Mosaic method supports 1, 4, 8, 16, 24, and 32 bit images.

If both of the values set in the XSize and YSize parameters are less than 1, this method does not produce an mosaic effect on a raster image.

Before executing the Mosaic method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members

>


MotionBlur method

Newtone.ImageKit.WPF.Effect.MotionBlur Method

This method creates a motion blur effect on a raster image.

[Visual Basic]
Public Function MotionBlur(mode As Integer, length As Integer, angle As Integer) As Boolean
[C#]
public bool MotionBlur(int mode, int length, int angle);

Parameters

mode
Sets the type of blur (0: Linear, 1: Radial, 2: Zoom)

length
Sets the length of the blur (from 0 to 255)

angle
Sets the angle of the blur (in degrees from 0 to 360)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The MotionBlur method creates a motion blur effect on a raster image. The Mode parameter determines the type of motion blur.

Mode=0 (Linear blur)
This motion blur simulates the image shifting. The Length parameter sets the magnitude of the shift. The Angle parameter determines the direction of the shift. The major directions of the Angle parameter are as follows: Angle=0 -> a shift to the left; Angle= 90 -> a shift down; Angle= 180 -> a shift to the right; Angle= 270-> a shift up.

Mode=1 (Radial blur)
This motion blur simulates the image spinning by the number of degrees set in the Angle parameter. The Length parameter is ineffective.

Mode=2 (Zoom blur)
This motion blur simulates the image zooming in by the length set in the Length parameter. The Angle parameter is ineffective.

To execute the MotionBlur method, set the image handle of the image in the SourceImage property. The MotionBlur method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the MotionBlur method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


OilPaint method

Newtone.ImageKit.WPF.Effect.OilPaint Method

This method produces an effect similar to an oil painting on the image.

[Visual Basic]
Public Function OilPaint(mode As Integer, size As Integer) As Boolean
[C#]
public bool OilPaint(int mode, int size);

Parameters

mode
Sets the processing mode (0:Process by RGB, 1:Process by Luminance (Brightness))

size
Sets brush stroke size (from 1 to 100)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The OilPaint method produces an effect similar to an oil painting on the image.

To execute the OilPaint method, set the image handle of the image in the SourceImage property. The OilPaint method supports 8 bit grayscale,
16, 24, and 32 bit images.

Before executing the OilPaint method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


Outline method

Newtone.ImageKit.WPF.Effect.Outline Method

This method produces an outline effect on the image.

[Visual Basic]
Public Function Outline(plane As Integer, mode As Integer, level As Integer) As Boolean
[C#]
public bool Outline(int plane, int mode, int level);

Parameters

plane
Sets which plane will be used to process the outline (0:Y, 1:R, 2:G, 3:B)

mode
Sets the edge filtering function used to process the outline (0:Differential, 1:Roberts, 2:Sobel)

level
Sets the brightness at which an outline is drawn (from 0 to 100)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Outline method produces an outline of a raster image by identifying and displaying only the "edges" within the image. In general, the luminance plane is most commonly used. (Plane parameter = 0). In this case, differences in brightness are used to identify edges. However, the red plane, green plane or blue plane can also be used to identify an edge So, for example, if the red plane is used (Plane parameter = 1) then differences in the R values would be used to identify the edges within an image.

The Mode parameter determines how an edge is identified. The Level parameter determines at which value an edge will be displayed. When the Differential Operator is used, the differences between the pixel values (either brightness, red, green, or blue) are calculated and then depending on the value of the Level parameter, the edges are displayed. The Differential Operator evaluates these difference in a horizontal and/or vertical direction. The Roberts Operator also uses a differential calculation, but evaluates these differences at a 45 degree orientation. The Sorbel Operator is very similar to the above two operators except that with Sorbel there is an additional correction for images that have a lot of complexity.

To execute the Outline method, set the image handle of the image in the SourceImage property. The Outline method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the Outline method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


Panorama method

Newtone.ImageKit.WPF.Effect.Panorama Method

This method composes a panorama image from two raster images.

[Visual Basic]
Public Function Panorama(bottomImage As System.Drawing.Image, topImage As System.Drawing.Image, cutMode As Integer, x11 As Integer, y11 As Integer, x12 As Integer, y12 As Integer, x21 As Integer, y21 As Integer, x22 As Integer, y22 As Integer, red As Byte, green As Byte, blue As Byte) As Boolean
[C#]
public bool Panorama(System.Drawing.Image bottomImage, System.Drawing.Image topImage, int cutMode, int x11, int y11, int x12, int y12, int x21, int y21, int x22, int y22, int red, byte green, byte blue);

Parameters

bottomImage
The image on which another image is attached (24 bit only)

topImage
The raster image that is attached (24 bit only)

cutMode
Sets whether or not topImage parameter will be cut at the attachment location and if so which portion of topImage parameter will be cut
For horizontal attachments (0: no cut, 1: cut left portion, 2: cut right portion)
For vertical attachments (0: no cut, 1: cut lower portion, 2: cut upper portion)

x11,y11
The location of the first point of attachment for bottomImage (in pixels)

x12,y12
The location of the second point of attachment for bottomImage (in pixels)

x21,y21
The location of the first point of attachment for topImage (in pixels)

x22,y22
The location of the second point of attachment for topImage (in pixels)

red
Sets the red component of the RGB value of the background color (from 0 to 255) This is the area of the panorama image that is not part of either bottomImage or topImage

green
Sets the green component of the RGB value of the background color (from 0 to 255) This is the area of the panorama image that is not part of either bottomImage or topImage

blue
Sets the blue component of the RGB value of the background color (from 0 to 255) This is the area of the panorama image that is not part of either bottomImage or topImage

Return Value

Returns True if successful. Returns False if successful.

Explanation

The Panorama method composes a panorama from two raster images.

To execute the Panorama method, set the image handle of the base image into the BottomImage parameter. Set the image handle of the image you wish to attach to the base image into the TopImage parameter. Set the attachment location on BottomImage and TopImage. The Panorama method will attach the TopImage to the BottomImage at the location specified.

The cutMode parameter determines if any portion of TopImage will be cut off. If CutMode=0 then no portion of TopImage will be cut.

If the attachment is horizontal, i.e. the first attachment point is to the left of the second attachment point, then if CutMode=1, the portion of topImage to the left of the attachment location will be cut off. If CutMode=2, the portion of topImage to the right of the attachment location will be cut off.

If the attachment is vertical, i.e. the first attachment point is to the above the second attachment point, then if CutMode=1, the portion of topImage below the attachment location will be cut off. If CutMode=2, the portion of topImage above the attachment location will be cut off.

If successful the resulting raster image data is set in the DestinationImage property.

This method only supports 24 bit images.

See Also

Effect Class | Effect Members


PasteImage method

Newtone.ImageKit.WPF.Effect.PasteImage Method

This method pastes a raster image into another raster image.

[Visual Basic]
Public Function PasteImage(bottomImage As System.Drawing.Image, angle As Integer, xTurn As Boolean, yTurn As Boolean, transLevel As Integer, transColor As Boolean, transRed As Byte, transGreen As Byte, transBlue As Byte, backRed As Byte, backGreen As Byte, backBlue As Byte, x As Integer, y As Integer, clip As Boolean) As Boolean
[C#]
public bool PasteImage(System.Drawing.Image bottomImage, int angle, bool xTurn, bool yTurn, int transLevel, bool transColor, byte transRed, byte transGreen, byte transBlue, byte backRed, byte backGreen, byte backBlue, int x, int y, bool clip);

Parameters

bottomImage
The handle of the base image. This is the image onto which another image is pasted (supports 1, 4, 8, 16, 24, 32 bit images)

angle
Angle of rotation (-35999 to 35999, in 1/100 degree units)

xTurn
Reversal of the x axis (False(0): no reversal, True (nonzero): reversal)

yTurn
Reversal of the y axis (False(0): no reversal, True (nonzero): reversal)

transLevel
The level of transparency (from 0 to 255, as this value increases, the image referred to by the SourceImage property becomes visible)

transColor
Sets whether or not there is a transparent color in the image referred to by the SourceImage property (False(0)No transparent color, True(nonzero):transparent color)

transRed
Sets the red component of the transparent color in the image referred to by the SourceImage property (from 0 to 255)

transGreen
Sets the green component of the transparent color in the image referred to by the SourceImage property (from 0 to 255)

transBlue
Sets the blue component of the transparent color in the image referred to by the SourceImage property (from 0 to 255)

backRed
Sets the red component of the background color. This color is drawn in the area not in either the image referred to by the SourceImage property or the Handle image (from 0 to 255)

backGreen
Sets the green component of the background color. This color is drawn in the area not in either the image referred to by the SourceImage property or the Handle image (from 0 to 255)

backBlue
Sets the blue component of the background color. This color is drawn in the area not in either the image referred to by the SourceImage property or the Handle image (from 0 to 255)

x,y
The attachment coordinates (in pixels)

Clip
Sets whether or not the image is clipped (False(0): no clipping, True (nonzero): clipping)

Return Value

Returns True if successful. Returns True if unsuccessful.

Explanation

The PasteImage method pastes one raster image into another raster image. The base image, (the image that another image is pasted into) is set into the BottomImage parameter. The image you want to paste into the base image is set in the SourceImage property. If using a mask image (to determine an area on the image to be processed), then set the image handle of the mask image in the SourceMask property. The PasteImage method supports 1, 4, 8, 16, 24, 32 bit images.

If successful the resulting raster image data is set in the DestinationImage property.

The Angle, xTurn, and yTurn parameters apply to the images in the SourceImage property and SourceMask property. The x,y parameters determine the coordinates on the base image (the image in the bottomImage parameter) where the CENTER of the SourceImage and SourceMask images are pasted. When the Clip parameter is True, the result is the same size as the base image (the image in the BottomImage parameter) and any excess is clipped. When the TransColor parameter is True, the color specified in the TransRed, TransGreen and TransBlue parameters is transparent.

The output image will be a 24 bit image. However, if bottomImage or the image you want to paste into the base image is a 32 bit image, then the output image will be a 32 bit image.

See Also

Effect Class | Effect Members


RemoveNoise method

Newtone.ImageKit.WPF.Effect.RemoveNoise Method

This method reduces the image noise in raster images.

[Visual Basic]
Public Function RemoveNoise(mode As Integer, level As Integer) As Boolean
[C#]
public bool RemoveNoise(int mode, int level);

Parameters

mode
Sets the mode of noise reduction (0: Median luminance method, 1:Noise reduction for each RGB plane)

level
Sets the level of noise reduction for the RGB mode (from 0 to 255, effective when Mode is 1)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RemoveNoise method reduces the image noise in raster images. When Mode is 1, the value of the level is enabled. As the Level parameter value increases the level of noise decreases.

To execute the RemoveNoise method, set the image handle of the image in the SourceImage property. The RemoveNoise method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the RemoveNoise method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


RemoveRedEye method

Newtone.ImageKit.WPF.Effect.RemoveRedEye Method

This method removes "red eye" from images by converting reddish colors within the selected area to another specified color.

[Visual Basic]
Public Function RemoveRedEye(red As Byte, green As Byte, blue As Byte, error As Integer) As Boolean
[C#]
public bool RemoveRedEye(byte red, byte green, byte blue, int error);

Parameters

red
Sets the red component for the specified color after the red eye removal (from 0 to 255)

green
Sets the green component for the specified color after the red eye removal (from 0 to 255)

blue
Sets the blue component for the specified color after the red eye removal (from 0 to 255)

error
Sets a margin of error for converting colors within the selected area. Any colors falling outside this margin of error will be converted to the color specifed by the Red, Green, and Blue parameters (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RemoveRedEye method removes "red eye" from images by converting colors within the selected area to another specified color. The error parameter sets a margin of error for colors within the selected area. Any color whose red value falls outside this margin of error will be converted to the color specifed by the Red, Green and Blue parameters. As the Error parameter value increases only colors closer to pure red will be converted. As the Error parameter decreases, a wider and wider range of "reddish" colors will be converted.

To execute the RemoveRedEye method, set the image handle of the image in the SourceImage property. The RemoveRedEye method supports 16, 24, and 32 bit images.

Before executing the RemoveRedEye method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


Resize method

Newtone.ImageKit.WPF.Effect.Resize Method

This method changes the size of a raster image.

[Visual Basic]
Public Function Resize(xSize As Integer, ySize As Integer, mode As Boolean) As Boolean
[C#]
public bool Resize(int xSize, int ySize, bool mode);

Parameters

xSize
The width of the new image (in pixels)

ySize
The height of the new image (in pixels)

mode
Sets whether Interpolation is used (False (0): does not interpolate, True (nonzero): interpolates)
If true, when enlarging the image, the linear interpolation method is used, when reducing the image, the average method is used
The interpolation can be used for 8 bit grayscale, 16, 24, and 32 bit images

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Resize method changes the size of the original image to the size specified. When the Mode parameter is false (No interpolation) then changes in size can adversely affect the quality of the Image.

To execute the Resize method, set the image handle of the image in the SourceImage property. The Resize method supports 1, 4, 8, 16, 24, and 32 bit color images. If using mask image, set the image handle into the SourceMask property.

If successful the resulting raster image data is set in the DestinationImage property. If the SourceMask property contains a valid image handle, then the resulting mask image will be set in the DestinationMask property.

See Also

Effect Class | Effect Members


RGBGamma method

Newtone.ImageKit.WPF.Effect.RGBGamma Method

This method uses gamma correction to adjust the RGB values of a raster image.

[Visual Basic]
Public Function RGBGamma(red As Double, green As Double, blue As Double) As Boolean
[C#]
public bool RGBGamma(double red, double green, double blue);

Parameters

red
The gamma factor for the red plane

green
The gamma factor for the green plane

blue
The gamma factor for the blue plane

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBGamma method uses gamma correction to adjust the RGB values and overall brightness of a raster image. The formula used to calculate the output is given below:

Where x is the input RGB value, y is the output RGB value and bright is the gamma factor for the red, green and blue planes (The Red, Green, and Blue parameters respectively).

When the Red, Green, and Blue parameters all equal 0, the input RGB values and output RGB values are equal meaning there is no change in the image. As the Red, Green, or Blue parameters increase in a positive direction, the output RGB values become lower than the input RGB values. As the Red, Green, or Blue parameters increase in a negative direction, the output RGB values become higher than the input RGB values. Please refer to the diagram below which shows the change in RGB values for a gamma factor of 1 and also for a gamma factor of -1.

To execute the RGBGama method, set the image handle of the image in the SourceImage property. The RGBGamma method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the RGBGamma method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


RGBLevel method

Newtone.ImageKit.WPF.Effect.RGBLevel Method

This method increases (or decreases) the RGB values of a raster image.

[Visual Basic]
Public Function RGBLevel(red As Integer, green As Integer, blue As Integer) As Boolean
[C#]
public bool RGBLevel(int red, int green, int blue);

Parameters

red
Sets the shift in the red component of the RGB value (from -255 to 255)

green
Sets the shift in the green component of the RGB value (from -255 to 255)

blue
Sets the shift in the blue component of the RGB value (from -255 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBLevel method increases or decreases the RGB values in a raster image. As the values of the Red, Green, or Blue parameters increase, the image becomes brighter. As those values decrease, the image becomes darker. If the Red, Green, or Blue parameters are 0, the image is not altered.

To execute the RGBLevel method, set the image handle of the image in the SourceImage property. The RGBLevel method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the RGBLevel method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


RGBReverse method

Newtone.ImageKit.WPF.Effect.RGBReverse Method

This method reverses the RGB values of a raster image.

[Visual Basic]
Public Function RGBReverse(red As Boolean, green As Boolean, blue As Boolean) As Boolean
[C#]
public bool RGBReverse(bool red, bool green, bool blue);

Parameters

red
Reverses the red component of the RGB value (False: does not reverse value, True: reverses value)

green
Reverses the green component of the RGB value (False: does not reverse value, True: reverses value)

blue
Reverses the blue component of the RGB value (False: does not reverse value, True: reverses value)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBReverse method reverses the RGB values of a raster image. If the Red, Green, or Blue parameters are True, then that component of the RGB value is reversed. So, for example, the reverse of a red component = 255 would be a red component = 0 (Red = 255 - Red).

To execute the RGBReverse method, set the image handle of the image in the SourceImage property. The RGBReverse method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the RGBReverse method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


RGBSpline method

Newtone.ImageKit.WPF.Effect.RGBSpline Method

This method uses spline function to modifiy the RGB values of a raster image.

[Visual Basic]
Public Function RGBSpline(spline As Point, red As Boolean, green As Boolean, blue As Boolean) As Boolean
[C#]
public bool RGBSpline(Point[] spline, bool red, bool green, bool blue);

Parameters

spline
Arrays of RGB values defining the x and y coordinates of points on the RGBSpline curve (from 0 to 255). The number of coordinates in the array ranges from 3 to 10

red
Affects the red component of the RGB value (False: does not affect the red component, True: affects the red component)

green
Affects the green component of the RGB value (False: does not affect the green component, True: affects the green component)

blue
Affects the blue component of the RGB value (False: does not affect the red component, True: affects the blue component)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBSpline method uses a spline function to modify the RGB values of a raster image. A spline function is a method of interpolating values that lay in between data points. In other words it produces a smooth curve from a limited set of points.

The RGBSpline method allows you to define the relationship between the input RGB values in the original image and output RGB values in the newly created image. You do this by specifying a set of coordinate points where the input RGB values are the x coordinates and the output RGB values are the y coordinates. These coordinate points are stored in arrays and passed to the RGBSpline method through the Spline parameter. The RGBSpline method then interpolates a "smooth" curve from these coordinate points. The graphic representation of this relationship between input RGB and output RGB values is known as the RGBSpline curve. A sample RGBSpline curve is shown in the diagram below:

In the above diagram, the default RGBSpline curve represents no change between input RGB values and output RGB values. In this case, the newly created image is exactly the same as the orginal image. The red RGBSpline curve represents an increase in contrast between the original image and the newly created image. It was generated from the following points:

Point (x values,y values)
-----------------------------------------------------
Point A (0,0)
Point B (64,32)
Point C (128,128)
Point D (192,160)
Point E (255,255)

At the midpoint of the RGBSpline curve, the input RGB value of 128 equals the output RGB value of 128. At points below the midpoint, however, the output RGB values are lower than the input RGB values. This means that dark colors become darker. Conversely, at points above the midpoint, output RGB values are higher than input RGB values. This means that light colors become lighter. This particular RGBSpline curve therefore increases the contrast of the image.

An RGBSpline curve that decreases contrast could be defined with the following points:

Point (x values,y values)
----------------------------------------------------
Point A (0,0)
Point B (64, 96)
Point C (128,128)
Point D (225, 192)
Point E (255,255)

To execute the RGBSpline method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The RGBSpline method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the RGBSpline method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


Ripple method

Newtone.ImageKit.WPF.Effect.Ripple Method

This method produces a ripple like effect on a raster image.

[Visual Basic]
Public Function Ripple(amplitude As Double, waveLength As Double, phase As Double, backColor As Boolean, reflect As Boolean, red As Byte, green As Byte, blue As Byte) As Boolean
[C#]
public bool Ripple(double amplitude, double waveLength, double phase, bool backColor, bool reflect, byte red, byte green, byte blue);

Parameters

amplitude
Sets the amplitude or height of the ripples. As this value increases the ripples become higher

waveLength
Sets the wavelength or distance from the crest of one wave to the crest of the next wave. As this value increases there are few ripples produced

phase
Sets the phase or shift in the wave cycle

backColor
Sets whether empty spaces are filled with color from adjacent pixels or from the color set as a background color [False: spaces filled with background color, True:spaces filled with the color of the adjacent pixels]

reflect
Causes a reflective effect from one ripple to the next (Best used with small amplitudes) [False:No reflection, True: reflection]

red
The red component of the background color (from 0 to 255)

green
The green component of the background color (from 0 to 255)

blue
The blue component of the background color (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Ripple method produces a ripple like effect on a raster image.

To execute the Ripple method, set the image handle of the image in the SourceImage property. The Ripple method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the Ripple method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


Rotate method

Newtone.ImageKit

Newtone.ImageKit.WPF.Effect.Rotate Method

This is an overloaded method that rotates a raster image.

Note: The following two methods have different arguments and also process the rotation differently. Because of this there is a difference in the time it takes to rotate the image depending on the image, environment, and conditions, etc. Even if your image does not have an alpha channel, you may find that using the second Rotate method is faster in some circumstances..

Overload List

This method rotates a raster image.

[Visual Basic] Public Function Rotate(angle As Integer, xTurn As Boolean, yTurn As Boolean, mode As Boolean, red As Byte, green As Byte, blue As Byte, clip As Boolean) As Boolean
[C#] public bool Rotate(int angle, bool xTurn, bool yTurn, bool mode, byte red, byte green, byte blue, bool clip);

This method rotates a raster image. Use this method for 32 bit images with an alpha channel. The alpha channel information is enabled.

[Visual Basic] Public Function Rotate(angle As Integer, xTurn As Boolean, yTurn As Boolean, mode As Boolean, alpha As Byte, red As Byte, green As Byte, blue As Byte, clip As Boolean) As Boolean
[C#] public bool Rotate(int angle, bool xTurn, bool yTurn, bool mode, byte alpha, byte red, byte green, byte blue, bool clip)

See Also

Effect Class | Effect Members


Rotate1 method

Newtone.ImageKit

Newtone.ImageKit.WPF.Effect.Rotate1 Method

This method rotates a raster image.

[Visual Basic] Public Function Rotate(angle As Integer, xTurn As Boolean, yTurn As Boolean, mode As Boolean, red As Byte, green As Byte, blue As Byte, clip As Boolean) As Boolean
[C#] public bool Rotate(int angle, bool xTurn, bool yTurn, bool mode, byte red, byte green, byte blue, bool clip);

Parameters

angle
Angle of rotation (-35999 to 35999, in 1/100 degree units)

xTurn
Reverses image along the x axis (False: no reversal, True: reversal)

yTurn
Reverses image along the y axis (False: no reversal, True: reversal)

mode
Sets whether on not linear interpolation is used (False: does not interpolate, True: interpolates)
Interpolation is enabled for 8 bit grayscale, 16, 24, and 32 bit images only

red
The red component of the background color (from 0 to 255)

green
The green component of the background color (from 0 to 255)

blue
The blue component of the background color (from 0 to 255)

clip
Sets whether or not the image is clipped (False: no clipping, True: clipping)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Rotate method rotates a raster image. If the Angle parameter value is positive, the image is rotated counterclockwise, if the Angle parameter value is negative, the image is rotated clockwise. When the Clip parameter is True and the rotated image is larger than the original, the excess areas are cut.

To execute the Rotate method, set the image handle of the image in the SourceImage property. The Rotate method supports 1, 4, 8, 16, 24, and 32 bit images. It is possible to rotate a mask image at the same time that the image is rotated. If this is the case, set the image handle of the mask image to be processed in the SourceMask property.

If successful the resulting raster image data is set in the DestinationImage property. If a mask image is used, the mask image should be set in the SourceMask property. The resulting mask image will be set in the DestinationMask property.

See Also

Effect Class | Effect Members


Rotate1 method

Newtone.ImageKit.WPF

Newtone.ImageKit.WPF.Effect.Rotate2 Method

This method rotates a raster image. For 32 bit images containing an alph channel, use this method.

[Visual Basic]Public Function Rotate(angle As Integer, xTurn As Boolean, yTurn As Boolean, mode As Boolean, alpha As Byte, red As Byte, green As Byte, blue As Byte, clip As Boolean) As Boolean
[C#]public bool Rotate(int angle, bool xTurn, bool yTurn, bool mode, byte alpha, byte red, byte green, byte blue, bool clip);

Parameters

angle
Angle of rotation (-35999 to 35999, in 1/100 degree units)

xTurn
Reverses image along the x axis (False: no reversal, True: reversal)

yTurn
Reverses image along the y axis (False: no reversal, True: reversal)

mode
Sets whether on not linear interpolation is used (False: does not interpolate, True: interpolates)
Interpolation is enabled for 8 bit grayscale, 16, 24, and 32 bit images only

alpha
The alpha component of the background color of a 32 bit image (from 0 to 255)

red
The red component of the background color (from 0 to 255)

green
The green component of the background color (from 0 to 255)

blue
The blue component of the background color (from 0 to 255)

clip
Sets whether or not the image is clipped (False: no clipping, True: clipping)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

This Rotate method rotates a raster image. If the image is a 32 bit image with a valid alpha channel, use this method. If the Angle parameter value is positive, the image is rotated counterclockwise, if the Angle parameter value is negative, the image is rotated clockwise. When the Clip parameter is True and the rotated image is larger than the original, the excess areas are cut.

To execute the Rotate method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Rotate method supports 1, 4, 8, 16, 24, and 32 bit images.

If the Rotate method is successful and the DestinationImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Rotate method is successful and the DestinationImage property is False, the resulting image will be set in the DestinationImage property.

If the original image is a 32 bit image, then the result will be a 32 bit image. All other bitcounts will result in a 24 bit color image. Please use the ConvertColor method to change the image to the appropriate bitcount.

See Also

Effect Class | Effect Members


SelectImage method

Newtone.ImageKit.WPF.Effect.SelectImage Method

This method allows you to define an area on a raster image and create a new image and mask image from that area.

[Visual Basic]
Public Function SelectImage(red As Byte, green As Byte, blue As Byte) As Boolean
[C#]
public bool SelectImage(byte red, byte green, byte blue);

Parameters

red
The red component of the color painted outside the area selected (from 0 to 255)

green
The green component of the color painted outside the area selected (from 0 to 255)

blue
The blue component of the color painted outside the area selected (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SelectImage method allows you to select an area on a raster image and create a new image and mask image from this selected area.

To execute the SelectImage method, set the image handle of the image in the SourceImage property. The SelectImage method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the SelectImage method, you must set the area on the image that will be affected.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property. The resulting mask image is set in the DestinationMask property. The color defined by the Red, Green, and Blue parameters wil be painted in the resulting image in the area that is outside the selected area. The resulting mask image set in the DestinationMask property will be a black and white, 1 bit color image where the selected area is white and the area outside of the select area is black.

Note: To select a portion of an image, without creating a mask image, please use the CutRectImage method. This method is much faster than the SelectImage method.

See Also

Effect Class | Effect Members


SetBitmapPixel method

Newtone.ImageKit.WPF.ImageKit.Effect.SetBitmapPixel Method

This method sets the RGB values (or ARGB values) and palette number of the specified pixel in the Device Independent Bitmap (DIB).

Overloaded list:

Retrieves RGB values and palette number from specified pixel

[Visual Basic] Public Function SetBitmapPixel(imgNo As Integer, x As Integer, y As Integer, palette As Byte, red As Byte, green As Byte, blue As Byte) As Boolean
[C#] public bool SetBitmapPixel(int imgNo, int x, int y, byte palette, byte red, byte green, byte blue);

Retrieves ARGB values and palette number from specified pixel

[Visual Basic] Public Function SetBitmapPixel(imgNo As Integer, x As Integer, y As Integer, palette As Byte, alpha As Byte, red As Byte, green As Byte, blue As Byte) As Boolean
[C#] public bool SetBitmapPixel(int imgNo, int x, int y, byte palette, byte alpha, byte red, byte green, byte blue);

See Also

Effect Class | Effect Members


SetBitmapPixel method

Newtone.ImageKit.WPF.Effect.SetBitmapPixel Method

This method sets the ARGB value and the palette number of a specified pixel in the Device Independent Bitmap (DIB).

[Visual Basic]
Public Function SetBitmapPixel(imgNo As Integer, x As Integer, y As Integer, palette As Byte, alpha As Byte, red As Byte, green As Byte, blue As Byte) As Boolean
[C#]
public bool SetBitmapPixel(int imgNo, int x, int y, byte palette, byte alpha, byte red, byte green, byte blue);

Parameters

imgNo
The image number (from -1 to 99)

x,y
The x,y coordinates of the specified pixel

palette
The palette number of the specified pixel

alpha
The alpha component of the ARGB value of the specified pixel

red
The red component of the ARGB value of the specified pixel

green
The green component of the ARGB value of the specified pixel

blue
The blue component of the ARGB value of the specified pixel

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetBitmapPixel method sets the ARGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB). For 1, 4, and 8 bit images, the applicable values are set in the Palette parameter. For 16, 24, and 32 bit images, the applicable values are set in the Red, Green, and Blue parameters. The image uses is the image set in theStartBitmapAccess method.

To access the DIB and manipulate pixel data, you must use the following methods as a group:

StartBitmapAccess
|
GetBitmapPixel, SetBitmapPixel
|
EndBitmapAccess

Example

The following code starts access to the DIB, then loops through each pixel in the image, using the GetBitmapPixel method to retrieve the pixels' rgb values. Then those values are reversed and set using the SetBitmapPixel method (For 1, 16, 24, or 32 bit images).

[Visual Basic]
Dim Ret As Boolean
Dim i As Long, j As Long
Dim PalNo As Integer, Red As Integer, Green As Integer, Blue As Integer

Ret = ImageKit1.GetImageType()
If Ret = False Then Exit Sub
Ret = ImageKit1.Effect.StartBitmapAccess()
If Ret = False Then Exit Sub

For i = 0 To ImageKit1.Image.Height - 1
  For j = 0 To ImageKit1.Image.Width - 1
    Ret = ImageKit1.Effect.GetBitmapPixel(j, i, PalNo, Red, Green, Blue)
    If ImageKit1.BitCount = 1 Then
      If PalNo <> 0 Then
        PalNo = 0
      Else
        PalNo = 1
      End If
    Else If ImageKit1.BitCount > 8 Then
      Blue = 255 - Blue
      Green = 255 - Green
      Red = 255 - Red
    End If
    Ret = ImageKit1.Effect.SetBitmapPixel(j, i, PalNo, Red, Green, Blue)
  Next j
Next i

Ret = ImageKit1.Effect.EndBitmapAccess()
ImageKit1.Refresh()

See Also

Effect Class | Effect Members


SetBitmapPixel method

Newtone.ImageKit.WPF.Effect.SetBitmapPixel Method

This method sets the RGB value and the palette number of a specified pixel in the Device Independent Bitmap (DIB).

[Visual Basic]
Public Function SetBitmapPixel(imgNo As Integer, x As Integer, y As Integer, palette As Byte, red As Byte, green As Byte, blue As Byte) As Boolean
[C#]
public bool SetBitmapPixel(int imgNo, int x, int y, byte palette, byte red, byte green, byte blue);

Parameters

imgNo
The image number (from -1 to 99)

x,y
The x,y coordinates of the specified pixel

palette
The palette number of the specified pixel

red
The red component of the RGB value of the specified pixel

green
The green component of the RGB value of the specified pixel

blue
The blue component of the RGB value of the specified pixel

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetBitmapPixel method sets the RGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB). For 1, 4, and 8 bit images, the applicable values are set in the Palette parameter. For 16, 24, and 32 bit images, the applicable values are set in the Red, Green, and Blue parameters. The image uses is the image set in theStartBitmapAccess method.

To access the DIB and manipulate pixel data, you must use the following methods as a group:

StartBitmapAccess
|
GetBitmapPixel, SetBitmapPixel
|
EndBitmapAccess

Example

The following code starts access to the DIB, then loops through each pixel in the image, using the GetBitmapPixel method to retrieve the pixels' rgb values. Then those values are reversed and set using the SetBitmapPixel method (For 1, 16, 24, or 32 bit images).

[Visual Basic]
Dim Ret As Boolean
Dim i As Long, j As Long
Dim PalNo As Integer, Red As Integer, Green As Integer, Blue As Integer

Ret = ImageKit1.GetImageType()
If Ret = False Then Exit Sub
Ret = ImageKit1.Effect.StartBitmapAccess()
If Ret = False Then Exit Sub

For i = 0 To ImageKit1.Image.Height - 1
  For j = 0 To ImageKit1.Image.Width - 1
    Ret = ImageKit1.Effect.GetBitmapPixel(j, i, PalNo, Red, Green, Blue)
    If ImageKit1.BitCount = 1 Then
      If PalNo <> 0 Then
        PalNo = 0
      Else
        PalNo = 1
      End If
    Else If ImageKit1.BitCount > 8 Then
      Blue = 255 - Blue
      Green = 255 - Green
      Red = 255 - Red
    End If
    Ret = ImageKit1.Effect.SetBitmapPixel(j, i, PalNo, Red, Green, Blue)
  Next j
Next i

Ret = ImageKit1.Effect.EndBitmapAccess()
ImageKit1.Refresh()

See Also

Effect Class | Effect Members


SetBrightness method

Newtone.ImageKit.WPF.Effect.SetBrightness Method

This method adjusts the brightness of a raster image.

[Visual Basic]
Public Function SetBrightness(level As Integer) As Boolean
[C#]
public bool SetBrightness(int level);

Parameters

level
Brightness Level (-255 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetBrightness method adjusts the brightness of the image. Setting the Level parameter to negative values will result in a darker image. Setting the Level parameter to positive values will result in a brighter image. The Level parameter can have a value ranging from -255 to 255. When the Level parameter is 0, there is no change in the image brightness.

To execute the SetBrightness method, set the image handle of the image in the SourceImage property. The SetBrightness method supports 4, 8, 16, 24, and 32 bit images.

Before executing the SetBrightness method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


SetChroma method

Newtone.ImageKit.WPF.Effect.SetChroma Method

This method adjusts the chrominance of a raster image.

[Visual Basic]
Public Function SetChroma(level As Integer) As Boolean
[C#]
public bool SetChroma(int level);

Parameters

level
Chrominance Level (-100 to 1000)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetChroma method adjusts the chrominance of the image. Chrominance refers to the color element of the image whereas Luminance refers to the brightness element. You can adjust the chrominance by using the Level parameter which can have a value ranging from -100 to 1000. When the Level parameter is 0, there is no change in the image color. As the level becomes negative, the colors in the image become less vivid. When the Level parameter reaches -100 the chrominance element is negated leaving only the Luminance element. This is grayscale. Conversely, as the Level parmeter increases from 0, the colors become more vivid.

To execute the SetChroma method, set the image handle of the image in the SourceImage property. The SetChroma method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the SetChroma method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


SetContrast method

Newtone.ImageKit.WPF.Effect.SetContrast Method

This method adjusts the contrast of a raster image.

[Visual Basic]
Public Function SetContrast(level As Integer) As Boolean
[C#]
public bool SetContrast(int level);

Parameters

level
Contrast Level (-100 to 100)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetContrast method adjusts the contrast of the image. You can adjust the contrast by using the Level parameter which can have a value ranging from -100 to 100. When the Level parameter is 0, there is no change in the image contrast. When the Level parameter values are negative, contrast decreases. When the Level parameter values are positive, the contrast increases.

To execute the SetContrast method, set the image handle of the image in the SourceImage property. The SetContrast method supports 4, 8, 16, 24, and 32 bit images.

Before executing the SetContrast method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


SetGray method

Newtone.ImageKit.WPF.Effect.SetGray Method

This method changes a raster image to gray.

[Visual Basic]
Public Function SetGray As Boolean
[C#]
public bool SetGray();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetGray method allows you to convert a raster image to gray.

To execute the SetGray method, set the image handle of the image in the SourceImage property. The SetGray method supports 1, 4, 8, 16, 24, and 32 bit images. Note: the SetGray method will convert a raster image to gray without changing the bitcount. A 24 bit color image, for example, is coverted to gray but is still 24 bit color. To change an image to 8-bit grayscale, please use the ConvertColor method.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


SetSecretImage method

Newtone.ImageKit.WPF.Effect.SetSecretImage Method

This method sets a digital watermark image or digital watermark text into a raster image.

[Visual Basic]
Public Function SetSecretImage(sourceImage As System.Drawing.Image, maskImage As System.Drawing.Image, text As String, font As Font, rect As Rectangle, level As Long) As Boolean
[C#]
public bool SetSecretImage(System.Drawing.Image sourceImage, System.Drawing.Image maskImage, String text, Font font, Rectangle rect, int level);

Parameters

sourceImage
The image handle of the original image (24 bit color images only) The watermark will be set on this image

maskImage
The image handle of the digital watermark (1 bit color image)

text
Sets the digital watermark text (the length of text can be up to 127 bytes)

font
Sets the font

rect
The coordinates of the rectangle where the text is to be attached to sourceImage (in pixels)

level
Sets the level of "detection" for the watermark (-20 to 20)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetSecretImage method sets a digital watermark into a raster image. It can set either a 1 bit color image or text as the watermark. The value of the Level parameter determines how "detectable" the digitable watermark will be. As the Level parameter increases in a positive direction, the digital watermark becomes brighter. As it increases in a negative direction, the digital watermark becomes darker.

If the maskImage parameter is set, the image referred to by the maskImage parameter will be set as the digital watermark. In this case the top left corner of the maskImage will be attached to the sourceImage at the coordinate location determined by the Rect parameter. If the maskImage parameter is 0, then the Text set in the Text parameter will be used as the digital watermark. It will be placed within a rectangular area on the sourceImage as determined by the Rect parameter.

If successful the resulting raster image handle is set in the DestinationImage property. The resulting image will be a 24 bit image.

See Also

Effect Class | Effect Members

>


Sharpen method

Newtone.ImageKit.WPF.Effect.Sharpen Method

This method modifies sharpness in a raster image.

[Visual Basic]
Public Function Sharpen(level As Integer) As Boolean
[C#]
public bool Sharpen(int level);

Parameters

level
Sets the degree of sharpness (from 0 to 100, sharpness increases as the level increases)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Sharpen method modifies the sharpness of a raster image. As the Level parameter value increases the sharpness increases and the image becomes clearer.

To execute the Sharpen method, set the image handle of the image in the SourceImage property. The Sharpen method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the Sharpen method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


SplitCmykImage method

Newtone.ImageKit.WPF.Effect.SplitCmykImage Method

This method splits a 24 bit color raster image into seperate bmp images representing each of the CMYK color planes.

[Visual Basic]
Public Function SplitCmykImage(sourceImage As System.Drawing.Image, cyan As System.Drawing.Image, magenta As System.Drawing.Image, yellow As System.Drawing.Image, black As System.Drawing.Image) As Boolean
[C#]
public bool SplitCmykImage(System.Drawing.Image sourceImage, ref System.Drawing.Image cyan, ref System.Drawing.Image magenta, ref System.Drawing.Image yellow, ref System.Drawing.Image black) ;

Parameters

sourceImage
The 24 bit image to be split into seperate color planes

cyan
An 8 bit grayscale bmp image representing the C plane

magenta
An 8 bit grayscale bmp image representing the M plane

yellow
An 8 bit grayscale bmp image representing the Y plane

black
An 8 bit grayscale bmp image representing the K plane

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SplitCmykImage method splits a 24 bit color raster image into seperate bmp images representing each of the CMYK color planes. The 24 bit color image to be split is set into the sourceImage parameter. If successful, the image is split into 8 bit grayscale bmp images and set in the respective cyan, megenta, yellow. and black parameters

See Also

Effect Class | Effect Members


SplitRGBAImage method

Newtone.ImageKit.WPF.Effect.SplitRGBAImage Method

This method splits a 32 bit RGBA image into a 24 bit RGB image and a 8 bit alpha channel.

[Visual Basic]
Public Function SplitRGBAImage As Boolean
[C#]
public bool SplitRGBAImage();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SplitRGBAImage method splits a 32 bit RGBA image into a 24 bit RGB image and a 8 bit alpha channel. To execute the SplitRGBAImage method, set the image handle of the 32-bit RGBA image in the SourceImage property.

If successful the resulting RGB 24-bit image data is set in the DestinationImage property and the alpha channel 8-bit grayscale image is set in the DestinationMask property.

See Also

Effect Class | Effect Members


SplitRgbImage method

Newtone.ImageKit.WPF.Effect.SplitRgbImage Method

This method splits a 24 bit color raster image into seperate bmp images representing each of the RGB color planes.

[Visual Basic]
Public Function SplitRgbImage(sourceImage As System.Drawing.Image, red As System.Drawing.Image, green As System.Drawing.Image, blue As System.Drawing.Image) As Boolean
[C#]
public bool SplitRgbImage(System.Drawing.Image sourceImage, ref System.Drawing.Image red, ref System.Drawing.Image green, ref System.Drawing.Image blue) ;

Parameters

sourceImage
The 24 bit image to be split into seperate RGB color planes

red
An 8 bit grayscale bmp image representing the red plane

green
An 8 bit grayscale bmp image representing the green plane

blue
An 8 bit grayscale bmp image representing the blue plane

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SplitRgbImage method splits a 24 bit color raster image into seperate bmp images representing each of the RGB color planes. The 24 bit color image to be split is set into the sourceImage parameter. If successful, the image is split into 8 bit grayscale bmp images and set in the respective red, green, and blue parameters.

See Also

Effect Class | Effect Members


SplitYccImage method

Newtone.ImageKit.WPF.Effect.SplitYccImage Method

This method splits a 24 bit color raster image into seperate bmp images representing each of the YCrCb color planes.

[Visual Basic]
Public Function SplitYccImage(sourceImage As System.Drawing.Image, yb As System.Drawing.Image, cr As System.Drawing.Image, cb As System.Drawing.Image) As Boolean
[C#]
public bool SplitYccImage(System.Drawing.Image sourceImage, ref System.Drawing.Image yb, ref System.Drawing.Image cr, ref System.Drawing.Image cb) ;

Parameters

sourceImage
The 24 bit image to be split into seperate color planes

yb
An 8 bit grayscale bmp image representing the Y plane

cr
An 8 bit grayscale bmp image representing the Cr plane

cb
An 8 bit grayscale bmp image representing theCb plane

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SplitYccImage method splits a 24 bit color raster image into seperate bmp images representing each of the YCrCb color planes. The 24 bit color image to be split is set into the sourceImage parameter. If successful, the image is split into 8 bit grayscale bmp images and set in the respective y, cr, and cb parameters

See Also

Effect Class | Effect Members


StartBitmapAccess method

Newtone.ImageKit.WPF.Effect.StartBitmapAccess Method

The StartBitmapAccess method is used to allow access to pixels in the Device Independent Bitmap (DIB). This method is to be used in conjunction with the EndBitmapAccess method.

[Visual Basic]
Public Function StartBitmapAccess (imgNo As Integer) As Boolean
[C#]
public bool StartBitmapAccess(int imgNo);

Parameters

imgNo
The image number (from -1 to 99)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The StartBitmapAccess method is used to allow access to pixels in the Device Independent Bitmap (DIB). This method is to be used in conjunction with the EndBitmapAccess method.

To execute the StartBitmapAccess method, set the image handle of the image in the SourceImage property. This method supports 1, 4, 8, 16, 24, and 32 bit images.

To access the DIB and manipulate pixel data, you must use the following methods as a group:

StartBitmapAccess
|
GetBitmapPixel, SetBitmapPixel
|
EndBitmapAccess

Example

The following code starts access to the DIB, then loops through each pixel in the image, using the GetBitmapPixel method to retrieve the pixels' rgb values. Then those values are reversed and set using the SetBitmapPixel method (For 1, 16, 24, or 32 bit images).

[Visual Basic]
Dim IkEffect As Newtone.ImageKit.WPF.Effect
Dim Ret As Boolean
Dim i As Long, j As Long
Dim PalNo As Integer, Red As Integer, Green As Integer, Blue As Integer

IkEffect = New Newtone.ImageKit.WPF.Effect

If IkEffect.SourceImage = Nothing Then Exit Sub
Ret = IkEffect.StartBitmapAccess(0)
If Ret = False Then Exit Sub

For i = 0 To IkEffect.SourceImage.Height - 1
  For j = 0 To IkEffect.SourceImage.Width - 1
    Ret = IkEffect.GetBitmapPixel(0, j, i, PalNo, Red, Green, Blue)
    If Image.GetPixelFormatSize(IkEffect.SourceImage.PixelFormat) = 1 Then
      If PalNo <> 0 Then
        PalNo = 0
      Else
        PalNo = 1
      End If
    Else If Image.GetPixelFormatSize(IkEffect.SourceImage.PixelFormat) > 8 Then
      Blue = 255 - Blue
      Green = 255 - Green
      Red = 255 - Red
    End If
    Ret = IkEffect.SetBitmapPixel(0, j, i, PalNo, Red, Green, Blue)
  Next j
Next i

Ret = IkEffect.EndBitmapAccess(0)

See Also

Effect Class | Effect Members


UnifyColor method

Newtone.ImageKit.WPF.Effect.UnifyColor Method

This method allows you to convert a range in colors in a raster image into one color. This method is useful when using transparent colors.

[Visual Basic]
Public Function UnifyColor(red As Byte, green As Byte, blue As Byte, error As Integer) As Boolean
[C#]
public bool UnifyColor(byte red, byte green, byte blue, int error);

Parameters

red
The red component of the color to be unified (from 0 to 255)

green
The green component of the color to be unified (from 0 to 255)

blue
The blue component of the color to be unified (from 0 to 255)

error
Sets the range of RGB values that will be unified (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The UnifyColor method allows you to unify a range of colors in a raster image. This is very useful when using transparancy. The Red, Green, and Blue parameters define the unified color. The Error parameter sets the range of colors that will be unified into the single color. So, for example, if you set the Red, Green and Blue parameter each to 128 and the Error parameter to 10, all colors ranging from RGB(118,118,118) to RGB(138,138,138) will be changed to RGB(128,128,128).

To execute the UnifyColor method, set the image handle of the image in the SourceImage property. The UnifyColor method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the UnifyColor method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


Waves method

Newtone.ImageKit.WPF.Effect.Waves Method

This method creates a wave like effect on a raster image.

[Visual Basic]
Public Function Waves(direction As Integer, type As Integer, period As Integer, amplitude As Integer, phase As Double, edge As Integer, red As Byte, green As Byte, blue As Byte) As Boolean
[C#]
public bool Waves(int direction, int type, int period, int amplitude, double phase, int edge, byte red, byte green, byte blue);

Parameters

direction
Sets the direction of the waves (0: horizontal, 1: vertical)

type
Sets the type of wave (0:sin wave, 1: sawtooth)

period
Sets the length of the wave (more than 0)

amplitude
Sets the size of the wave (more than 0)

phase
Sets the phase or shift in the wave cycle (from 0.0 to 1.0)

edge
Sets the type of edge(0: background color, 1:adjoining pixel color, 2 wrap around)

red
Sets the red component of the background color (from 0 to 255)

green
Sets the green component of the background color (from 0 to 255)

blue
Sets the blue component of the background color (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Waves method creates a wave like effect on a raster image.

To execute the Waves method, set the image handle of the image in the SourceImage property. The Waves method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the Waves method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


WhirlPinch method

Newtone.ImageKit.WPF.Effect.WhirlPinch Method

This method produces an interesting effect similar to pinching a raster image then twisting your fingers.

[Visual Basic]
Public Function WhirlPinch(whirl As Double, pinch As Double, radius As Double, red As Integer, green As Integer, blue As Integer) As Boolean
[C#]
public bool WhirlPinch(double whirl, double pinch, double radius, short red, short green, short blue);

Parameters

whirl
Sets the number of degrees of the twisting effect

pinch
Sets the "strength" of the pinch

radius
Sets the size of the area affected by the twisting effect (more than 0)

red
Sets the red component of the background color (from 0 to 255)

green
Sets the green component of the background color (from 0 to 255)

blue
Sets the blue component of the background color (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The WhirlPinch method creates an effect similar to pinching a raster image and then twisting your fingers. The Whirl parameter sets the number of degrees of the twisting effect. A value of 360 would mean that the twisting effect makes one complete revolution. The Radius parameter sets the size of the twisting effect on the image. As the Radius parameter increases in size, it affects larger areas on the image. Values of 2 or more could mean the the radius of the twisting effect is larger than the image itself. In this case the background color is used to fill any spaces that are outside of the orginal image. It is recommended that you set a Radius value of less than 1 so that the area affected remains within the image, then experiment with the Whirl parameter to get the desired effect. The Pinch parameter does exactly that, it pinches the area in the center of the twisting effect. A Pinch parameter of 1 will bring all of the colors together in the center. Values greater than 1 can "tear" the image in which case the background color is painted in the center.

To execute the WhirlPinch method, set the image handle of the image in the SourceImage property. The WhirlPinch method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the WhirlPinch method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


YCCGamma method

Newtone.ImageKit.WPF.Effect.YCCGamma Method

This method uses gamma correction to adjust the YCrCb values of a raster image.

[Visual Basic]
Public Function YCCGamma(yb As Double, cr As Double, cb As Double) As Boolean
[C#]
public bool YCCGamma(double yb, double cr, double cb);

Parameters

yb
The gamma factor for the Y plane

cr
The gamma factor for the Cr plane

cb
The gamma factor for the Cb plane

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCGamma method uses gamma correction to adjust the YCrCb values and overall brightness of a raster image. The formula used to calculate the output is given below:

Where x is the input YCrCb value, y is the output YCrCb value and bright is the gamma factor for the Y, Cr and Cb planes. (The Yb, Cr, and Cb parameters respectively).

When the Yb, Cr, and Cb parameters all equal 0, the input RGB values and output YCrCb values are equal meaning there is no change in the image. As the Yb, Cr, and Cb parameters increase in a positive direction, the output YCrCb values become lower than the input YCrCb values. As the Yb, Cr, and Cb parameters increase in a negative direction, the output YCrCb values become higher than the input YCrCb values. Please refer to the diagram below which shows the change in YCrCb values for a gamma factor of 1 and also for a gamma factor of -1.

To execute the YCCGamma method, set the image handle of the image in the SourceImage property. The YCCGamma method supports 1, 4, 8, 16, 24, and 32 bit images.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


YCCLevel method

Newtone.ImageKit.WPF.Effect.YCCLevel Method

This method increases (or decreases) the YCrCb values of a raster image.

[Visual Basic]
Public Function YCCLevel(yb As Integer, cr As Integer, cb As Integer) As Boolean
[C#]
public bool YCCLevel(int yb, int cr, int cb);

Parameters

yb
Sets the shift in the Y component (luminance) of the YCrCb value (from -255 to 255)

cr
Sets the shift in the Cr component (chrominance) of the YCrCb value (from -255 to 255)

cb
Sets the shift in the Cb component (chrominance) of the YCrCb value (from -255 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCLevel method increases or decreases the YCrCb values in a raster image. Y represents luminance, Cr and Cb represent chrominance. As the values of the Yb, Cr, or Cb parameters increase, the image becomes brighter. As those values decrease, the image becomes darker. If the Yb, Cr, or Cb parameters are 0, the image is not altered.

To execute the YCCLevel method, set the image handle of the image in the SourceImage property. The YCCLevel method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the YCCLevel method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


YCCReverse method

Newtone.ImageKit.WPF.Effect.YCCReverse Method

This method reverses the YCrCb values of a raster image.

[Visual Basic]
Public Function YCCReverse(yb As Boolean, cr As Boolean, cb As Boolean) As Boolean
[C#]
public bool YCCReverse(bool yb, bool cr, bool cb);

Parameters

yb
Reverses the Y component (luminance) of the YCrCb value (False: does not reverse value, True: reverses value)

cr
Reverses the Cr component (chrominance) of the YCrCb value (False: does not reverse value, True: reverses value)

cb
Reverses the Cb component (chrominance) of the YCrCb value (False: does not reverse value, True: reverses value)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCReverse method reverses the YCrCb values of a raster image. If the Yb, Cr, or Cb parameters are True, then that component of the YCrCb value is reversed. So, for example, the reverse of a Yb component = 255 would be a Yb component = 0 (Yb = 255 - Yb).

To execute the YCCReverse method, set the image handle of the image in the SourceImage property. The YCCReverse method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the YCCReverse method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


YCCSpline method

Newtone.ImageKit.WPF.Effect.YCCSpline Method

This method uses spline function to modifiy the YCrCb values of a raster image.

[Visual Basic]
Public Function YCCSpline(spline As Point, yb As Boolean, cr As Boolean, cb As Boolean) As Boolean
[C#]
public bool YCCSpline(Point[] spline, bool yb, bool cr, bool cb);

Parameters

spline
Arrays of YCrCb values defining the x and y coordinates of points on the YCCSpline curve (from 0 to 255). The number of coordinates in the array ranges from 3 to 10

yb
Affects the Y component (luminance) of the YCrCb value (False(0): does not affect the Y component, True( nonzero): affects the Y component)

cr
Affects the Cr component (chrominance) of the YCrCb value (False(0): does not affect the Cr component, True( nonzero): affects the Cr component)

cb
Affects the Cb component (chrominance) of the YCrCb value (False(0): does not affect the Cb component, True( nonzero): affects the Cb component)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCSpline method uses a spline function to modify the YCrCb values of a raster image. A spline function is a method of interpolating values that lay in between data points. In other words it produces a smooth curve from a limited set of points.

The YCCSpline method allows you to define the relationship between the input YCrCb values in the original image and output YCrCb values in the newly created image. You do this by specifying a set of coordinate points where the input YCrCb values are the x coordinates and the output YCrCb values are the y coordinates. These coordinate points are stored in arrays and passed to the YCCSpline method through the Spline parameter. The YCCSpline method then interpolates a "smooth" curve from these coordinate points. The graphic representation of this relationship between input YCrCb and output YCrCb values is known as the YCCSpline curve. A sample YCCSpline curve is shown in the diagram below:

In the above diagram, the Cr default YCCSpline curve represents no change between input YCrCb values and output YCrCb values. In this case, the newly created image is exactly the same as the orginal image. The red YCCSpline curve represents an increase in contrast between the original image and the newly created image. It was generated from the following points:

Point (x values,y values)
-----------------------------------------------------
Point A (0,0)
Point B (64,32)
Point C (128,128)
Point D (192,160)
Point E (255,255)

At the midpoint of the Yb YCCSpline curve, the input YCrCb value of 128 equals the output YCrCb value of 128. At points below the midpoint, however, the output YCrCb values are lower than the input YCrCb values. This means that dark colors become darker. Conversely, at points above the midpoint, output YCrCb values are higher than input YCrCb values. This means that light colors become lighter. This particular YCCSpline curve therefore increases the contrast of the image.

An YCCSpline curve that decreases contrast could be defined with the following points:

Point (x values,y values)
----------------------------------------------------
Point A (0,0)
Point B (64, 96)
Point C (128,128)
Point D (225, 192)
Point E (255,255)

To execute the YCCSpline method, set the image handle of the image in the SourceImage property. The YCCSpline method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the YCCSpline method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the DestinationImage property.

See Also

Effect Class | Effect Members


Progress event

Newtone.ImageKit.WPF.Effect.Progress Event

This event is generated when an effect is being processed

[Visual Basic]
 Public Event Progress As  ProgressEventHandler
[C#]
 public event  ProgressEventHandler  Progress;

Explanation

The Progress event is generated when an effect is being processed. The event handler takes parameters of type ProgressEventArgs.

To cancel a process, set the Cancel property of the ProgressEventHandler to True.

See Also

Effect Class | Effect Members


ScanNoiseFilter enum

Newtone.ImageKit.WPF.AreaSelectMode Enum

This refers to the type of area that will be processed on the image.

public enum AreaSelectMode

Public Members

Member | Value | Explanation
EffectMask | 0 | A mask handle is used to determine the area to be processediThe value set in the SourceMask property is enabledj
EffectAll | 1 | The total image is processed
EffectPolygon | 2 | A polygonal area, selected on the image, is processediThe value set in the Point property is enabledj
EffectEllipse | 3 | An elliptical shape, selected on the image, is processediThe value set in the Rect property is enabledj

See Also

Effect Class | Effect Members


IkFile class

Newtone.ImageKit.WPF.IkFile Class

This class exposes properties, methods, and events for loading and saving image files.

For a list of all members of this type, see IkFile Members.

System.Object
Newtone.ImageKit.WPF
public class IkFile : Object

Explanation

This class exposes properties, methods, and events for loading and saving image files. This class also provides support for various types of image file formats.

Requirements

Namespace : Newtone.ImageKit.WPF

Assembly : Newtone.ImageKit.WPFX.File.dll

See Also

IkFile Members


ImageKit.File Members

Newtone.ImageKit.WPF.IkFile Members

IkFile Overview

Constructor

IkFile Constructor Initializes a new instance of the IkFile class

Public Properties

BackgroundBlue | Sets the blue component (RGB) of the background color in a vector image.
BackgroundGreen | Sets the green component (RGB) of the background color in a vector image.
BackgroundPaint | Sets the background color for a vector image.
BackgroundRed | Set the red component (RGB) of the background color for a vector image.
CreationTimeDay | Refers to the day when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeHour | Refers to the hour when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeMinute | Refers to the minute when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeMonth | Refers to the month when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeSecond | Refers to the second when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeYear | Refers to the year when the file was created. Retrieved after executing the GetImageFileType method.
ErrorStatus | Retrieves the try of error that has been generated.
ExifAutoRotate | Sets whether to automatically adjust and display the direction of photos taken with a smartphone.
FileBitCount | Refers to the bit count of the image. Retrieved after executing the GetImageFileType or GetImagefileTypeFromRawData methods.
FileExtention | Sets the file type initially displayed by the OpenFileDialog and SaveFileDialog methods
FileHeight | ers to the height of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileImageSize | Refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileMaxPage | Refers to the number of pages of a multi-page image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileName | Sets the name of the image file (full path) to be loaded or saved
FilePath | Sets the folder initially displayed by the OpenFileDialog and SaveFileDialog methods
FileSize | Refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileType | Refers to the type of image format. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileWidth | Refers to the width of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileWidthByte | Refers to the number of bytes per line in the image. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileXdpi | Refers to the horizontal resolution of the image. (number of pixels per horizontal inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileYdpi | Refers to the vertical resolution of the image. (number of pixels per vertical inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
JpegQuality | Sets the quality coefficient when an image is saved in JPEG, Tiff (JPEG compression), or FPX (JPEG compression) file formats
JpegSubsampling | Sets the YCrCb subsampling ratios when saving an image in JPEG format
LastAccessTimeDay | Refers to the day when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeHour | Refers to the hour when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeMinute | Refers to the number of minutes when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeMonth | Refers to the month when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeSecond | Refers to the number of seconds when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeYear | Refers to the year when the file was last accessed. Retrieved after executing the GetImageFileType method
LastWriteTimeDay | Refers to the day when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeHour | Refers to the hour when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeMinute | Refers to the number of minutes when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeMonth | Refers to the month when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeSecond | Refers to the number of seconds when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeYear | Refers to the year when the file was last modified. Retrieved after executing the GetImageFileType method
LoadPage | Sets the page to be loaded when a multi-page image file (FPX, GIF, or TIFF) image is loaded
MinIsBlack | Sets whether Tiff images, saved in 1 bit color, will be white mode or black mode
RawData | Sets the byte array of the Raw data for the image to be loaded or saved
VectorHeight | Sets the height of a vector image when the image is loaded
VectorWidth | Sets the width of a vector image when the image is loaded

Public Methods

AppendTiffImage | Appends a page to the end of a multipage tiff image
DeletePageFromMultipageTiff | Deletes a page from a multipage tiff image
GetImageFileType | Retrieves various information aobut the image file
GetImageFileTypeFromRawData | Retrieves various information from raw image data
InsertPageIntoMultipageTiff | Insserts a page into a multipage tiff image
LoadImageFromFile | Loads image data from a file
LoadImageFromRawData | Loads DIB image data from raw data
LoadRawDataFromFile | Loads raw image data from file
LoadRawDataFromStream | Loads raw image data from stream
MergeTiffImages | Combines tiff files contained in a specified folder and saves them as a single multipage tiff file.
ModifyPageInMultipageTiff | Modifies a specified page of an existing multipage tiff file.
OpenFileDialog | Displays the "Open" dialog box which includes the file preview and information functions. This dialog box is used to select an image file to be opened.
SaveFileDialog | Displays the "Save" dialog box which includes the file preview function. This dialog box is used to select an image file to be saved.
SaveImageToFile | Saves image data to a file
SaveImageToRawData | Saves image data as raw data
SaveRawDataToFile | Saves raw data to a file
SaveRawDataToStream | Saves the raw image data to stream.

Public Events

Progress Generated when a file is being loaded or saved

Hierarchy Property

Exif | Exposes properties of the Exif(JPEG) file's main and thumbnail image
PDF | Exposes properties to save images in PDF format

Also See

IkFile Class


ImageKit.File Constructor

Newtone.ImageKit.WPF.IkFile Constructor

This initializes a new instance of the IkFile class.

[Visual Basic] Public Sub New()
[C#] public IkFile()

See Also

IkFile Class | IkFile Members


BackgroundPaint property

Newtone.ImageKit.WPF.IkFile.BackgroundPaint Property

This property sets whether or not the background color in vector images is enabled.

[Visual Basic]
Public WriteOnly Property BackgroundPaint As Boolean
[C#]
public bool BackgroundPaint {set;}

Property Value

Value | Explanation
True | Sets the background color
False | Does not set the background color

Explanation

The BackgroundPaint property sets whether or not the background color in vector images is enabled. To set the background color, set the appropriate values in the BackgroundBlue, BackgroundGreen, and BackgroundRed properties.

See Also

IkFile Class | IkFile Members


BackgroundBlue property

Newtone.ImageKit.WPF.IkFile.BackgroundBlue Property

This property sets the blue component of the background color (RGB values) when saving a vector image.

[Visual Basic]
Public WriteOnly Property BackgroundBlue As Byte
[C#]
public byte BackgroundBlue {set;}

Property Value

The values can range from 0 to 255

Explanation

The BackgroundBlue property sets the blue componento of the background color (RGB values) when saving a vector image.

See Also

IkFile Class | IkFile Members


BackgroundGreen property

Newtone.ImageKit.WPF.IkFile.BackgroundGreen Property

This property sets the blue component (RGB values) of the background color when saving a vector image.

[Visual Basic]
Public WriteOnly Property BackgroundGreen As Byte
[C#]
public byte BackgroundGreen {set;}

Property Value

The values can range from 0 to 255

Explanation

The BackgroundGreen property sets the blue component (RGB values) of the background color when saving a vector image.

See Also

IkFile Class | IkFile Members


BackgroundRed property

Newtone.ImageKit.WPF.IkFile.BackgroundRed Property

This property sets the red component of the background color (RGB values) when saving a vector image.

[Visual Basic]
Public WriteOnly Property BackgroundRed As Byte
[C#]
public byte BackgroundRed {set;}

Property Value

The values can range from 0 to 255

Explanation

The BackgroundRed property sets the red component of the background color (RGB values) when saving a vector image.

See Also

IkFile Class | IkFile Members


CreationTimeDay property

Newtone.ImageKit.WPF.IkFile.CreationTimeDay Property

This property refers to the day when the file was created. Retrieved after executing the GetImageFileTypemethod.

[Visual Basic]
Public ReadOnly Property CreationTimeDay As Integer
[C#]
public int CreationTimeDay {get;}

Property Value

The day when the file was created

Explanation

The CreationTimeDay property refers to the day when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


CreationTimeHour property

Newtone.ImageKit.WPF.IkFile.CreationTimeHour Property

This property refers to the hour when the file was created. Retrieved after executing the GetImageFileTypemethod.

[Visual Basic]
Public ReadOnly Property CreationTimeHour As Integer
[C#]
public int CreationTimeHour {get;}

Property Value

The hour when the file was created

Explanation

The CreationTimeHour property refers to the hour when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


CreationTimeMinute property

Newtone.ImageKit.WPF.IkFile.CreationTimeMinute Property

This property refers to the number of minutes when the file was created. Retrieved after executing the GetImageFileTypemethod.

[Visual Basic]
Public ReadOnly Property CreationTimeMinute As Integer
[C#]
public int CreationTimeMinute {get;}

Property Value

The minute when the file was created

Explanation

The CreationTimeMinute property refers to the number of minutes when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


CreationTimeMonth property

Newtone.ImageKit.WPF.IkFile.CreationTimeMonth Property

This property refers to the month when the file was created. Retrieved after executing the GetImageFileTypemethod.

[Visual Basic]
Public ReadOnly Property CreationTimeMonth As Integer
[C#]
public int CreationTimeMonth {get;}

Property Value

The month when the file was created

Explanation

The CreationTimeMonth property refers to the month when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


CreationTimeSecond property

Newtone.ImageKit.WPF.IkFile.CreationTimeSecond Property

This property refers to the number of seconds when the file was created. Retrieved after executing the GetImageFileTypemethod.

[Visual Basic]
Public ReadOnly Property CreationTimeSecond As Integer
[C#]
public int CreationTimeSecond {get;}

Property Value

The number of seconds when the file was created

Explanation

The CreationTimeSecond property refers to the number of seconds when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


CreationTimeYear property

Newtone.ImageKit.WPF.IkFile.CreationTimeYear Property

This property refers to the year when the file was created. Retrieved after executing the GetImageFileTypemethod.

[Visual Basic]
Public ReadOnly Property CreationTimeYear As Integer
[C#]
public int CreationTimeYear {get;}

Property Value

The year when the file was created

Explanation

The CreationTimeYear property refers to the year when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


ErrorStatus property

Newtone.ImageKit.WPF.IkFile.ErrorStatus Property

This property refers to the types of errors that can occur when using the File class library.

[Visual Basic]
Public ReadOnly Property ErrorStatus As Error
[C#]
public Error ErrorStatus {get;}

Property Value

Read only

Explanation

This property refers to the types of errors that can occur when using the File class library. This property refers to the members of the Error enum.

See Also

IkFile Class | IkFile Members


ExifAutoRotate property

Newtone.ImageKit.WPF.IkFile.ExifAutoRotate Property

This property sets whether to automatically adjust and display the direction of photos taken with a smartphone.

[Visual Basic]
Public Property ExifAutoRotate As Boolean
[C#]
public bool ExifAutoRotate {get; set;}

Property Value

Value | Explanation
True | Adjusts the orientation automatically
False | Display in the original orientation. (Default)

Explanation

This property sets whether to automatically adjust and display the direction of photos taken with a smartphone.

When this property is True when loaded with the LoadImageFromFile or LoadImageFromRawData method, the orientation of the photo taken with a smartphone, digital camera, etc. is automatically adjusted and displayed based on the information of MainOrientation of Exif.

See Also

IkFile Class | IkFile Members


FileBitCount property

Newtone.ImageKit.WPF.IkFile.FileBitCount Property

This property refers to the bit count of the image. Retrieved after executing the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property FileBitCount As Integer
[C#]
public int FileBitCount {get;}

Property Value

1F 2 colors (i.e.Black and White)
4F 16 colors
8F 256 colors
16F 16 bit color
24F 24bit color
32F 32bit color

Explanation

The FileBitCount property refers to the bit count of the image. Retrieved after executing the GetImageFileType or GetImageFileTypeFromRawData method.

This property is disabled for vector images.

See Also

IkFile Class | IkFile Members


FileExtension property

Newtone.ImageKit.WPF.IkFile.FileExtension Property

This property sets the file type initially displayed by the OpenFileDialog and SaveFileDialog methods.

[Visual Basic]
Public Property FileExtension As String
[C#]
public string FileExtension {get; set;}

Property Value

The FileExtension is the file type (i.e. jpg, bmp)

Explanation

The FileExtension property sets the file type initially displayed by the OpenFileDialog and SaveFileDialog methods.

When you execute the OpenFileDialog and SaveFileDialog methods, the "Open" dialog box and "Save" dialog box will be displayed. The FileExtension property sets which file extentions will be listed in the "Files of type" drop down menu at the bottom of the dialog box.

By default the "Open" dialog box and the "Save" dialog box display all file types in a given folder. They also display the term "All Files" along with all image file extentions supported by the ImageKit in the "Files of type" drop down menu at the bottom of the dialog box. By setting the FileExtension property, you can determine which file extentions will be listed in the "Files of type" drop down menu and thereby influence the types of files that will be displayed in the "Open" dialog box and "Save" dialog box.

To set the FileExtension property, start with the file explanation followed by a "|" symbol as a delimeter and the the file extensions to be displayed. When listing multiple file extensions, use a comma (;) to delimit them. If an empty string ("") is set into the FileExtension property then the file types will be "all files". If an empty string is set into the FilePath property, then the current direct directory will be displayed when the dialog opens.

There is no distinction made between upper case or lower case letters so that "BMP" is treated as the same as "bmp".

Example

The code below illustlates how to set the default folder to "C:\Images" and to set the file types to "BMP", "JPG and PNG", and "All Files":

[Visual Basic.NET]
Dim Ik_File As Newtone.ImageKit.WPF.IkFile

Private Sub Form1_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
  Ik_File = New Newtone.ImageKit.WPF.IkFile
End Sub

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
  Dim fname As String

  Ik_File.FilePath = "c:\images"
  Ik_File.FileExtension = "Bitmap Files|*.bmp|Jpeg,Png Files|*.jpg;*.png|All Files|*.*"
  fname = Ik_File.OpenFileDialog()
  PictureBox1.Image = New Bitmap(fname)
End Sub

[Visual C#.NET]
private Newtone.ImageKit.WPF.IkFile Ik_File;

private void Form1_Load(object sender, System.EventArgs e)
{
  Ik_File = new Newtone.ImageKit.WPF.IkFile();
}

private void button1_Click(object sender, System.EventArgs e)
{
  Ik_File.FilePath = "c:\\Images";
  Ik_File.FileExtension = "Bitmap Files|*.bmp|Jpeg,Png Files|*.jpg;*.png|All Files|*.*";
  string fname = Ik_File.OpenFileDialog();
  pictureBox1.Image = new Bitmap(fname);
}

See Also

IkFile Class | IkFile Members


FileHeight property

Newtone.ImageKit.WPF.IkFile.FileHeight Property

This property refers to the height of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property FileHeight As Integer
[C#]
public int FileHeight {get;}

Property Value

The height of the image in pixels

Explanation

The FileHeight property refers to the height of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.

If there is no size information saved in the image file, 0 will be set into this property.

See Also

IkFile Class | IkFile Members


FileImageSize property

Newtone.ImageKit.WPF.IkFile.FileImageSize Property

This property refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property FileImageSize As Integer
[C#]
public int FileImageSize {get;}

Property Value

The size of the image file

Explanation

The FileImageSize property refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

This property isn't used for vector images.

See Also

IkFile Class | IkFile Members


FileMaxPage property

Newtone.ImageKit.WPF.IkFile.FileMaxPage Property

This property refers to the number of pages of a multi-page image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property FileMaxPage As Integer
[C#]
public int FileMaxPage {get;}

Property Value

The number of pages of a multi-page image file

Explanation

The FileMaxPage property refers to the number of pages of a multi-page image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

This property isn't used for vector images.

See Also

IkFile Class | IkFile Members


FileName property

Newtone.ImageKit.WPF.IkFile.FileName Property

This property sets the name of the image file (full path) to be loaded or saved.

[Visual Basic]
Public Property FileName As String
[C#]
public string FileName {get; set;}

Property Value

The name of the image file (full path)

Explanation

The FileName property sets the name of the image file (full path) to be loaded or saved.

See Also

IkFile Class | IkFile Members


FilePath property

Newtone.ImageKit.WPF.IkFile.FilePath Property

This property sets the folder initially displayed by the OpenFileDialog and SaveFileDialog methods.

[Visual Basic]
Public Property FilePath As String
[C#]
public string FilePath {get; set;}

Property Value

The FilePath is the folder name

Explanation

The FilePath property sets the folder initially displayed by the OpenFileDialog and SaveFileDialog methods.

When you execute the OpenFileDialog and SaveFileDialog methods, the "Open" dialog box and "Save" dialog box will be displayed. The FilePath property allows you to set the folder that is accessed when the "Open" dialog box and "Save" dialog box are displayed.

When setting the FileExtension property, start with the file explanation followed by a "|" symbol as a delimeter and the the file extensions to be displayed. When listing multiple file extensions, use a comma (;) to delimit them. If an empty string ("") is set into the FileExtension property then the file types will be "all files". If an empty string is set into the FilePath property, then the current direct directory will be displayed when the dialog opens.

There is no distinction made between upper case or lower case letters so that "BMP" is treated as the same as "bmp".

Example

The code below illustlates how to set the default folder to "C:\Images" and to set the file types to "BMP", "JPG and PNG", and "All Files":

[Visual Basic.NET] Dim Ik_File

As Newtone.ImageKit.WPF.IkFile Private Sub Form1_Load(ByVal sender As Object, ByVal e As System.EventArgs)
  Handles MyBase.Load Ik_File =
New Newtone.ImageKit.WPF.IkFile

End Sub Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
  Handles Button1.Click Dim fname

  As String Ik_File.FilePath
  = "c:\images" Ik_File.FileExtension = "Bitmap Files|*.bmp|Jpeg,Png Files|*.jpg;*.png|All
  Files|*.*" fname =
  Ik_File.OpenFileDialog() PictureBox1.Image = New
Bitmap(fname) End

Sub [Visual
C#.NET] private Newtone.ImageKit.WPF.IkFile

Ik_File; private void Form1_Load(object sender, System.EventArgs
e)
  { Ik_File = new
Newtone.ImageKit.WPF.IkFile();

} private void button1_Click(object sender, System.EventArgs
e)
  { Ik_File.FilePath =
  "c:\\Images"; Ik_File.FileExtension = "Bitmap Files|*.bmp|Jpeg,Png Files|*.jpg;*.png|All Files|*.*";
  string fname = Ik_File.OpenFileDialog();
  pictureBox1.Image = new Bitmap(fname);
}

See Also

IkFile Class | IkFile Members


FileSize property

Newtone.ImageKit.WPF.IkFile.FileSize Property

This property refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property FileSize As Integer
[C#]
public int FileSize {get;}

Property Value

The size of the image file

Explanation

The FileSize property refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

If file size information is not saved in the image file, 0 will be set into this property.

See Also

IkFile Class | IkFile Members


FileType property

Newtone.ImageKit.WPF.IkFile.FileType Property

This property refers to the type of image format. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property FileType As TypeOfFile
[C#]
public TypeOfFile FileType {get;}

Property Value

This value is of type TypeOfFile

Explanation

The FileType property refers to the type of image format. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

Note: TIFF(GROUP3-1D) is the same as MH. TIFF(GROUP3-2D) is the same as MR. TIFF(GROUP4) is the same as MMR. The ImageKit.NET supports Exif version 2.1
If an unsupported image format is loaded into the ImageKit Control, the FileType property will return 0.

See Also

IkFile Class | IkFile Members


FileWidth property

Newtone.ImageKit.WPF.IkFile.FileWidth Property

This property refers to the width of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property FileWidth As Integer
[C#]
public int FileWidth {get;}

Property Value

The width of the image in pixels

Explanation

The FileWidth property refers to the width of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.

If there is no width information saved in the image file then 0 will be set into this property.

See Also

IkFile Class | IkFile Members


FileWidthByte property

Newtone.ImageKit.WPF.IkFile.FileWidthByte Property

This property refers to the number of bytes per line in the image. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property FileWidthByte As Integer
[C#]
public int FileWidthByte {get;}

Property Value

The number of bytes per line in the image

Explanation

The FileWidthByte property refers to the number of bytes per line in the image. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

This property isn't used for vector images.

See Also

IkFile Class | IkFile Members


FileXdpi property

Newtone.ImageKit.WPF.IkFile.FileXdpi Property

The FileXdpi property refers to the horizontal resolution of the image. (number of pixels per horizontal inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property FileXdpi As Integer
[C#]
public int FileXdpi {get;}

Property Value

The horizontal resolution of the image (number of pixels per horizontal inch)

Explanation

The FileXdpi property refers to the horizontal resolution of the image. (number of pixels per horizontal inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

If there is no resolution information in the image file, 0 will be set into this property.

See Also

IkFile Class | IkFile Members


FileYdpi property

Newtone.ImageKit.WPF.IkFile.FileYdpi Property

The FileYdpi property refers to the vertical resolution of the image. (number of pixels per vertical inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property FileYdpi As Integer
[C#]
public int FileYdpi {get;}

Property Value

The vertical resolution of the image (number of pixels per vertical inch)

Explanation

The FileYdpi property refers to the vertical resolution of the image. (number of pixels per vertical inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

If there is no resolution information in the image file, 0 will be set into this property.

See Also

IkFile Class | IkFile Members


JpegQuality property

Newtone.ImageKit.WPF.IkFile.JpegQuality Property

This property sets the quality coefficient when an image is saved in JPEG, Tiff (JPEG compression), or FPX (JPEG compression) file formats.
[Visual Basic]
Public Property JpegQuality As Integer
[C#]
public int JpegQuality {get; set;}

Property Value

0 to 100 (75 is recommended)

Explanation

The JpegQuality property sets the quality coefficient when an image is saved in JPEG, Tiff (JPEG compression), or FPX (JPEG compression) file formats.

Default value is 75. As this value decreases the size of the image file decreases but so does the quality of the image. Conversely, as the quality coefficient increases the quality of the image and the image file size also increase.

See Also

IkFile Class | IkFile Members


LastAccessTimeDay property

Newtone.ImageKit.WPF.IkFile.LastAccessTimeDay Property

This property refers to the day when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic]
Public ReadOnly Property LastAccessTimeDay As Integer
[C#]
public int LastAccessTimeDay {get;}

Property Value

The day when the file was last accessed

Explanation

The LastAccessTimeDay property refers to the day when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


LastAccessTimeHour property

Newtone.ImageKit.WPF.IkFile.LastAccessTimeHour Property

This property refers to the hour when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic]
Public ReadOnly Property LastAccessTimeHour As Integer
[C#]
public int LastAccessTimeHour {get;}

Property Value

The hour when the file was last accessed

Explanation

The LastAccessTimeHour property refers to the hour when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


LastAccessTimeMinute property

Newtone.ImageKit.WPF.IkFile.LastAccessTimeMinute Property

This property refers to the number of minutes when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic]
Public ReadOnly Property LastAccessTimeMinute As Integer
[C#]
public int LastAccessTimeMinute {get;}

Property Value

The number of minutes when the file was last accessed

Explanation

The LastAccessTimeHour property refers to the number of minutes when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


LastAccessTimeMonth property

Newtone.ImageKit.WPF.IkFile.LastAccessTimeMonth Property

This property refers to the month when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic]
Public ReadOnly Property LastAccessTimeMonth As Integer
[C#]
public int LastAccessTimeMonth {get;}

Property Value

The month when the file was last accessed

Explanation

The LastAccessTimeMonth property refers to the month when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


LastAccessTimeSecond property

Newtone.ImageKit.WPF.IkFile.LastAccessTimeSecond Property

This property refers to the number of seconds when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic]
Public ReadOnly Property LastAccessTimeSecond As Integer
[C#]
public int LastAccessTimeSecond {get;}

Property Value

The number of seconds when the file was last accessed

Explanation

The LastAccessTimeSecond property refers to the number of seconds when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


LastAccessTimeYear property

Newtone.ImageKit.WPF.IkFile.LastAccessTimeYear Property

This property refers to the year when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic]
Public ReadOnly Property LastAccessTimeYear As Integer
[C#]
public int LastAccessTimeYear {get;}

Property Value

The year when the file was last accessed

Explanation

The LastAccessTimeYear property refers to the year when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


LastWriteTimeDay property

Newtone.ImageKit.WPF.IkFile.LastWriteTimeDay Property

This property refers to the day when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic]
Public ReadOnly Property LastWriteTimeDay As Integer
[C#]
public int LastWriteTimeDay {get;}

Property Value

The day when the file was last modified

Explanation

The LastWriteTimeDay property refers to the day when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


LastWriteTimeHour property

Newtone.ImageKit.WPF.IkFile.LastWriteTimeHour Property

This property refers to the hour when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic]
Public ReadOnly Property LastWriteTimeHour As Integer
[C#]
public int LastWriteTimeHour {get;}

Property Value

The hour when the file was last modified

Explanation

The LastWriteTimeHour property refers to the hour when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


LastWriteTimeMinute property

Newtone.ImageKit.WPF.IkFile.LastWriteTimeMinute Property

This property refers to the number of minutes when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic]
Public ReadOnly Property LastWriteTimeMinute As Integer
[C#]
public int LastWriteTimeMinute {get;}

Property Value

The number of minutes when the file was last modified

Explanation

The LastWriteTimeMinute property refers to the number of minutes when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


LastWriteTimeMonth property

Newtone.ImageKit.WPF.IkFile.LastWriteTimeMonth Property

This property refers to the month when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic]
Public ReadOnly Property LastWriteTimeMonth As Integer
[C#]
public int LastWriteTimeMonth {get;}

Property Value

The month when the file was last modified

Explanation

The LastWriteTimeMonth property refers to the month when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


LastWriteTimeSecond property

Newtone.ImageKit.WPF.IkFile.LastWriteTimeSecond Property

This property refers to the number of seconds when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic]
Public ReadOnly Property LastWriteTimeSecond As Integer
[C#]
public int LastWriteTimeSecond {get;}

Property Value

The number of seconds when the file was last modified

Explanation

The LastWriteTimeSecond property refers to the number of seconds when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


LastWriteTimeYear property

Newtone.ImageKit.WPF.IkFile.LastWriteTimeYear Property

This property refers to the year when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic]
Public ReadOnly Property LastWriteTimeYear As Integer
[C#]
public int LastWriteTimeYear {get;}

Property Value

The year when the file was last modified

Explanation

The LastWriteTimeYear property refers to the year when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

IkFile Class | IkFile Members


LoadPage property

Newtone.ImageKit.WPF.IkFile.LoadPage Property

This property sets the page to be loaded when a multi-page image file (FPX or TIFF) image is loaded.

[Visual Basic]
Public Property LoadPage As Integer
[C#]
public int LoadPage {get; set;}

Property Value

The number of the page of a mutli-page image file

The first page is 0. (For FPX format the base image is also 0)

Explanation

The LoadPage property sets the page to be loaded when a multi-page image file (FPX or TIFF) image is loaded.

In the TIFF file formats, numerous images can be stored in one multi-page image file. In the FPX file format, images of different resolutions can be stored in one multi-resolution image file.

The LoadPage property is used when loading a particular page from a multi-page image file into the memory. If there is no page set in the LoadPage property, after executing the LoadImageFromFile method or the LoadImageFromRawData method, False(0) is returned.

See Also

IkFile Class | IkFile Members


MinIsBlack property

Newtone.ImageKit.WPF.IkFile.MinIsBlack Property

This property sets whether Tiff images, saved in 1 bit color, will be saved in white-mode monochrome or black-mode monochrome

[Visual Basic]
Public Property MinIsBlack As Boolean
[C#]
public bool MinIsBlack {get; set;}

Property Value

Value | Explanation
True (default) | Tiff images saved in 1 bit color will be white-mode monochrome (0 = black)
False | Tiff images saved in 1 bit color will be black-mode monochrome (0 = white)

Explanation

The MinIsBlack property sets whether Tiff images, saved in 1 bit color, will be saved in white-mode monochrome or black-mode monochrome. When this property is True, the PhotometricInterpretation tag value is 1, which means that black=0 and the image is "white-mode" monochrome. When this property is False, the PhotometricInterpretation tag value is 0, which means that white=0 and the image is "black-mode" monochrome.

See Also

IkFile Class | IkFile Members


RawData property

Newtone.ImageKit.WPF.IkFile.RawData Property

This property sets the byte array of the Raw data for the image to be loaded or saved.

[Visual Basic]
Public Property RawData As Byte()
[C#]
public byte[] RawData {get; set;}

Property Value

The byte array of the Raw data for the image to be loaded or saved

Explanation

The RawData property sets the byte array of the Raw data for the image to be loaded or saved.

After executing the LoadRawDataFromFile method, the raw data is set to this property. After executing the SaveRawDataToFile method, the raw data set to this property is saved to a file.

To disable the image referred to by this property, please set null (in Visual Basic, Nothing) to this property.

See Also

IkFile Class | IkFile Members


VectorHeight property

Newtone.ImageKit.WPF.IkFile.VectorHeight Property

This property sets the height of a vector image when the image is loaded.

[Visual Basic]
Public Property VectorHeight As Integer
[C#]
public int VectorHeight {get; set;}

Property Value

The VectorHeight property sets the height of the vector image (in pixels).

Default value is 0.

Explanation

The VectorHeight property property sets the height of a vector image when the image is loaded.

For EMF and WMF images

If the VectorHeight property or the VectorWidth property is set to a value of 0 or less, the size defined in each file header will be used.

Note: When the vector image is loaded, the ratio of the height and width of the original image is maintained and the largest pixel size of the image is scaled within the area defined by the VectorHeight and VectorWidth properties.

See Also

IkFile Class | IkFile Members


VectorWidth property

Newtone.ImageKit.WPF.IkFile.VectorWidth Property

This property sets the width of a vector image when the image is loaded.

[Visual Basic]
Public Property VectorWidth As Integer
[C#]
public int VectorWidth {get; set;}

Property Value

The VectorWidth property sets the width of the vector image (in pixels).

Default value is 0.

Explanation

The VectorWidth property sets the width of a vector image when the image is loaded.

For EMF and WMF images

If the VectorHeight property or the VectorWidth property is set to a value of 0 or less, the size defined in each file header will be used.

Note: When the vector image is loaded, the ratio of the height and width of the original image is maintained and the largest pixel size of the image is scaled within the area defined by the VectorHeight property or the VectorWidth properties.

See Also

IkFile Class | IkFile Members


AppendTiffImage Method

Newtone.ImageKit.WPF.IkFile.AppendTiffImage Method

This method adds a page to the end of a multipage tiff and saves it to file.

[Visual Basic] Public Function AppendTiffImage(Val As Newtone.ImageKit.SaveFileType, SaveImage As Image) As Boolean
[C#] public bool AppendTiffImage(Newtone.ImageKit.SaveFileType Val, Image SaveImage);

Parameters

Val
The image format of the saved image (of type Newtone.ImageKit.SaveFileType)

SaveImage
The image to be saved

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The AppendTiffImage method adds a page to the end of a multipage tiff and saves it to file. The image set in the SaveImage parameter will be added as the last page in the Tiff file set in the FileName property. If no image file is set in the FileName property then the AppendTiffImage will save the image set in the SaveImage parameter as a single page Tiff image.

Then AppendTiffImage method is enabled when a Tiff image format is set in the Val parameter. It is possible for different pages in the multipage Tiff file to have different Tiff compression formats. If a file format other than a Tiff format is chosen for the Val parameter, or if the image file set in the FileName property is not a Tiff file, then the AppendTiffImage method will fail and return a value of False. The image set in the SaveImage parameter need not be a Tiff image but there are issues regarding the bitcount that must be considered. See explanation below.

Regarding tiff compression and image bitcounts:
Depending on the tiff compression choosen, images with certain bitcounts may not be able to be saved. In this case, errors may result. Below is a table listing the tiff compression and the bitcounts that are possible with that compression

Format | Compatible Bitcount
Tiff (Uncompressed) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32.
Tiff (Group 3-1D) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32. Important: On Windows Vista, only 1 bit images are supported. All other bitcounts will fail
Tiff (Group 4) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32. Important: On Windows Vista, only 1 bit images are supported. All other bitcounts will fail
Tiff (Packbits) | 1, 24.
Tiff (LZW) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32.

Tiff Group3-1D are the same format as MH. Tiff Group4 are the same format as MMR.
In Uncompressed and LZW formats, 16 bit images are converted to 24 bit images.

Examples

The following code will load a 1 bit BMP image, convert it to a Tiff G4 image and append it to the end of a multipage Tiff file

[Visual Basic.NET]
Dim ik_file As Newtone.ImageKit.WPF.IkFile = New Newtone.ImageKit.WPF.IkFile()
ik_file.FileName = "1bitBMP.bmp"
If ik_file.LoadImageFromFile() = False Then Exit Sub

ik_file.FileName = "MultiTiff.tif" 'The multipage tiff file where the image is appended and saved
ik_file.AppendTiffImage(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4,
                app_img)
ik_file.Dispose()

[Visual C#.NET]
Newtone.ImageKit.WPF.IkFile ik_file = New Newtone.ImageKit.WPF.IkFile();
ik_file.FileName = "1bitBMP.bmp";
if (!ik_file.LoadImageFromFile()) return;

ik_file.FileName = "MultiTiff.tif"; //The multipage tiff file where the image is appended and saved
ik_file.AppendTiffImage(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4,
                app_img);
ik_file.Dispose();

Also See

IkFile Class | IkFile Members


DeletePageFromMultipageTiff Method

Newtone.ImageKit.WPF.IkFile.DeletePageFromMultipageTiff Method

This method deletes the specified page from a multipage tiff file.

[Visual Basic] Public Function DeletePageFromMultipageTiff(deletePage As Integer) As Boolean
[C#] public bool DeletePageFromMultipageTiff(int deletePage);

Parameters

deletePage
The page to be deleted

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DeletePageFromMultipageTiff method deletes the specified page from a multipage tiff file. The Tiff file is set in the FileName property. The page to be deleted from this file is set in the deletePage parameter. This method is enabled when the deletePage parameter has a value of 1 or more and the image set in the FileName property has a page corresponding to that number.

If the image set in the FileName property is not a valid Tiff image or if the deletePage parameter has a value of 0 or less or if the number a pages in the Tiff file is less than the value set in the deletePage parameter then this method will fail and return False.

Also See

IkFile Class | IkFile Members


GetImageFileType method

Newtone.ImageKit.WPF.IkFile.GetImageFileType Method

This method retrieves information about the image and sets this into the following properties:
Comment, CreationTimeDay, CreationTimeHour, CreationTimeMinute, CreationTimeMonth, CreationTimeSecond, CreationTimeYear, Exif, FileBitCount, FileHeight, FileWidth, FileImageSize, FileMaxPage, FileSize, FileType, FileWidthByte, FileXdpi, FileYdpi, Interlace, LastAccessTimeDay, LastAccessTimeHour, LastAccessTimeMinute, LastAccessTimeMonth, LastAccessTimeSecond, LastAccessTimeYear, LastWriteTimeDay, LastWriteTimeHour, LastWriteTimeMinute, LastWriteTimeMonth, LastWriteTimeSecond, LastWriteTimeYear
[Visual Basic]
Public Function GetImageFileType() As Boolean
[C#]
public bool GetImageFileType() ;

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetImageFileType method retrieves information about the image and sets this into the following properties:
Comment, CreationTimeDay, CreationTimeHour, CreationTimeMinute, CreationTimeMonth, CreationTimeSecond, CreationTimeYear, Exif, FileBitCount, FileHeight, FileWidth, FileImageSize, FileMaxPage, FileSize, FileType, FileWidthByte, FileXdpi, FileYdpi, Interlace, LastAccessTimeDay, LastAccessTimeHour, LastAccessTimeMinute, LastAccessTimeMonth, LastAccessTimeSecond, LastAccessTimeYear, LastWriteTimeDay, LastWriteTimeHour, LastWriteTimeMinute, LastWriteTimeMonth, LastWriteTimeSecond, LastWriteTimeYear

To execute this method the appropriate value must first be set into the FileName property. If the image is a multi-page image file then the LoadPage property must also be set. If the image is a multi-page image file then properties other than FileMaxPage and FileSize will relate to the page specified in the LoadPage property. For all image file formats except TIFF, the Comment property relates to the whole image file, regardless of whether it is a multi-page image file or not. For more details, please refer to the specific property information. For more details, please refer to the specific property information.

Note: Even if the file format is supported, if no value has been set then that property will return a 0 or an empty string.

See Also

IkFile Class | IkFile Members


GetImageFileTypeFromRawData method

Newtone.ImageKit.WPF.IkFile.GetImageFileTypeFromRawData Method

This method retrieves information from the raw image data and sets that information into the following properties:
Comment, CreationTimeDay, CreationTimeHour, CreationTimeMinute, CreationTimeMonth, CreationTimeSecond, CreationTimeYear, Exif, FileBitCount, FileHeight, FileWidth, FileImageSize, FileMaxPage, FileSize, FileType, FileWidthByte, FileXdpi, FileYdpi, Interlace

[Visual Basic]
Public Function GetImageFileTypeFromRawData() As Boolean
[C#]
public bool GetImageFileTypeFromRawData() ;

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetImageFileTypeFromRawData method retrieves information from the raw image data and sets that information into the following properties:
Comment, CreationTimeDay, CreationTimeHour, CreationTimeMinute, CreationTimeMonth, CreationTimeSecond, CreationTimeYear, Exif, FileBitCount, FileHeight, FileWidth, FileImageSize, FileMaxPage, FileSize, FileType, FileWidthByte, FileXdpi, FileYdpi, Interlace

To execute this method the appropriate value must first be set into the RawData and LoadPage property. If the image is a multi-page image file then properties other than FileMaxPage and FileSize will relate to the page specified in the LoadPage property. For all image file formats except TIFF, the Comment property relates to the whole image file, regardless of whether it is a multi-page image file or not. For more details, please refer to the specific property information.

Note: Even if the file format is supported, if no value has been set then that property will return a 0 or an empty string.

This method is the same as retrieving information from the image file using the GetImageFileType, however the properties related to "File Created", "File Accessed", and "File Modified" will have a value of 0.

See Also

IkFile Class | IkFile Members


InsertPageIntoMultipageTiff Method

Newtone.ImageKit.WPF.IkFile.InsertPageIntoMultipageTiff Method

This method inserts a page into a multipage tiff.

[Visual Basic] Public Function InsertPageIntoMultipageTiff(Val As Newtone.ImageKit.SaveFileType, SaveImage As Image, insertPage As Integer) As Boolean
[C#] public bool InsertPageIntoMultipageTiff(Newtone.ImageKit.SaveFileType Val, Image SaveImage, int insertPage);

Parameters

Val
The image format of the saved image (of type Newtone.ImageKit.SaveFileType)

SaveImage
The image to be saved

insertPage
The location where the page is inserted

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The InsertPageIntoMultipageTiff method inserts a page into a multipage tiff. The image set in the SaveImage parameter will be inserted into the Tiff file set in the FileName property at the page location set in the insertPage parameter. This method is enabled when the insertPage parameter is set to 1 or more. If the value of the insertPage parameter is greater than the number of pages in the multipage Tiff, then image set in the SaveImage parameter will be added to the end of the multipage Tiff file. The new multipage tiff file will be saved in the location specified by the FileName property.

If no image file is set in the FileName property then the InsertPageIntoMultipageTiff will return False.

The InsertPageIntoMultipageTiff method is enabled when a Tiff image format is set in the Val parameter. It is possible for different pages in the multipage Tiff file to have different Tiff compression formats. If a file format other than a Tiff format is chosen for the Val parameter, if the insertPage parameter is set to 0 or less, or if the image file set in the FileName property is not a Tiff file, then the InsertPageIntoMultipageTiff method will fail and return a value of False. The image set in the SaveImage parameter need not be a Tiff image but there are issues regarding the bitcount that must be considered. See explanation below.

Regarding tiff compression and image bitcounts:
Depending on the tiff compression choosen, images with certain bitcounts may not be able to be saved. In this case, errors may result. Below is a table listing the tiff compression and the bitcounts that are possible with that compression

Format | Compatible Bitcount
Tiff (Uncompressed) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32.
Tiff (Group 3-1D) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32. Important: On Windows Vista, only 1 bit images are supported. All other bitcounts will fail
Tiff (Group 4) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32. Important: On Windows Vista, only 1 bit images are supported. All other bitcounts will fail
Tiff (Packbits) | 1, 24.
Tiff (LZW) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32.

Tiff Group3-1D are the same format as MH. Tiff Group4 are the same format as MMR.
In Uncompressed and LZW formats, 16 bit images are converted to 24 bit images.

Examples

The following code will load a 1 bit BMP image, convert it to a Tiff G4 image and insert it into a multipage Tiff file

[Visual Basic.NET]
Dim ik_file As Newtone.ImageKit.IfFile = New Newtone.ImageKit.WPF.IkFile()
ik_file.FileName = "1bitBMP.bmp"
If ik_file.LoadImageFromFile() = False Then Exit Sub

ik_file.FileName = "MultiTiff.tif" 'The multipage tiff file where the image is inserted and saved
ik_file.InsertPageIntoMultipageTiff(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4,
                PictureBox1.Image, 3)
                ik_file.Dispose()

[Visual C#.NET]
Newtone.ImageKit.WPF.IkFile ik_file = New Newtone.ImageKit.WPF.IkFile();
ik_file.FileName = "1bitBMP.bmp";
if (!ik_file.LoadImageFromFile()) return;

ik_file.FileName = "MultiTiff.tif"; //The multipage tiff file where the image is inserted and saved
ik_file.InsertPageIntoMultipageTiff(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4,
                pictureBox1.Image, 3);
                ik_file.Dispose();

Also See

IkFile Class | IkFile Members


LoadImageFromFile method

Newtone.ImageKit.WPF.IkFile.LoadImageFromFile Method

This method loads image data from a file.

[Visual Basic]
Public Function LoadImageFromFile(Val As LoadFileType) As Image
[C#]
public Image LoadImageFromFile(LoadFileType Val) ;

Parameters

Val
The format of the image to be loaded.
The value is of type LoadFileType

Return Value

Returns the loaded image if successful.

Explanation

The LoadImageFromFile method loads image data from a file. The FileName property sets the file to be loaded. If successful, the loaded image is returned. If the image is a multi-page image file, set the page to be loaded in the LoadPage property.

Executing the LoadImageFromFile method will set the image information in the same properties as executing the GetImageFileType method.

16 bit BMP and TIFF files:
16 bit BMP and TIFF files can be loaded but the loaded image data will converted to 32 bit image data. Saving the data will result in a 32 bit image.

ImageKit.NET Plugin:
Because standard .NET Framework does not support the following image formats, the ImageKit.NET Plugin (Dll files) are required when using JPEG2000, FPX, PCX, DXF, SVG, or SXF formats.

Regarding FlashPix:
Flashpix image files are multi-resolution image files with a tiled composition. Flashpix files store image data in a hierarchy from the original image at the highest level. Each subsequent level contains the same image with horizontal and vertical resolution half that of the image in the level above. This allows editing and printing at the optimum resolution. Each resolution image is divided in to 64x64 tiles. Each tiled image can be uncompressed, JPEG compression, or single color compression.

Example

The following sample code loads the image data from a file and shows it to the PictureBox.

[Visual Basic.NET]
Dim CancelFlag As Boolean

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
  Dim Ik_File As Newtone.ImageKit.WPF.IkFile
  Dim LoadImg As Image

  CancelFlag = False
  Ik_File = New Newtone.ImageKit.WPF.IkFile
  AddHandler Ik_File.Progress, AddressOf Me.File_Progress

  Ik_File.FileName = Ik_File.OpenFileDialog()
  LoadImg = Ik_File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.Load)
  If LoadImg = Nothing Then Exit Sub

  PictureBox1.Image = LoadImg
End Sub

'Cancel button
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
  CancelFlag = True
End Sub

'Generates the Progress event
Private Sub File_Progress(ByVal sender As Object, ByVal e As Newtone.ImageKit.ProgressEventArgs)
  ProgressBar1.Value = e.Percent

  'To accept a cancel
  Application.DoEvents()

  If CancelFlag = True Then
    e.Cancel = True   'Cancel
  Else
    e.Cancel = False
  End If
End Sub

[Visual C#.NET]
private bool CancelFlag;

private void button1_Click(object sender, System.EventArgs e)
{
  Newtone.ImageKit.WPF.IkFile Ik_File = new Newtone.ImageKit.WPF.IkFile();
  Ik_File.Progress += new Newtone.ImageKit.ProgressEventHandler(File_Progress);

  CancelFlag = false;
  Ik_File.FileName = Ik_File.OpenFileDialog();
  Image LoadImg = Ik_File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.Load);
  if (LoadImg == null) return;

  pictureBox1.Image = LoadImg;
}

//Cancel button
private void button2_Click(object sender, System.EventArgs e)
{
  CancelFlag = true;
}

//Generates progress event
private void File_Progress(object sender, Newtone.ImageKit.ProgressEventArgs e)
{
  progressBar1.Value = e.Percent;

  //To accept a cancel
  Application.DoEvents();

  if (CancelFlag)
    e.Cancel = true; // Cancel
  else
    e.Cancel = false;
}

See Also

IkFile Class | IkFile Members


LoadImageFromRawData method

Newtone.ImageKit.WPF.IkFile.LoadImageFromRawData Method

This method loads DIB image data from raw data.

[Visual Basic]
Public Function LoadImageFromRawData(Val As LoadFileType) As Image
[C#]
public Image LoadImageFromRawData(LoadFileType Val) ;

Parameters

Val
The format of the image to be loaded
This value is of type LoadFileType

Return Value

Returns the loaded image if successful

Explanation

The LoadImageFromRawData method uses the raw image data set into the RawData property and converts it to DIB image data. When the raw image data is a multipage image, set the page to be loaded in the LoadPage property.

Executing the LoadImageFromRawData method will set the image information in the same properties as executing the GetImageFileTypeFromRawData method.

16 bit BMP and TIFF files:
16 bit BMP and TIFF files can be loaded but the loaded image data will converted to 32 bit image data. Saving the data will result in a 32 bit image.

ImageKit.NET Plugin
Because standard .NET Framework does not support the following image formats, the ImageKit.NET Plugin (Dll files) are required when using JPEG2000, FPX, PCX, DXF, SVG, or SXF formats.

See Also

IkFile Class | IkFile Members


LoadRawDataFromFile method

Newtone.ImageKit.WPF.IkFile.LoadRawDataFromFile Method

This method loads raw image data from file.

[Visual Basic]
Public Function LoadRawDataFromFile() As Boolean
[C#]
public bool LoadRawDataFromFile() ;

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The LoadRawDataFromFile method loads raw image data from file.

The LoadRawDataFromFile method loads the file set in the FileName property and then sets the raw data in the RawData property.

See Also

IkFile Class | IkFile Members


LoadRawDataFromStream method

Newtone.ImageKit.WPF.IkFile.LoadRawDataFromStream Method

This method loads raw image data from stream.

[Visual Basic]
Public Function LoadRawDataFromStream(Val As MemoryStream)
[C#]
public void LoadRawDataFromStream(MemoryStream Val) ;

Parameters

Val
The raw data loaded from the MemoryStream

Return Value

None

Explanation

This method loads raw image data from stream. The data returned in the Val parameter is set into the RawData property.

See Also

IkFile Class | IkFile Members


MergeTiffImages Method

Newtone.ImageKit

Newtone.ImageKit.WPF.IkFile.MergeTiffImages Method

This method combines tiff files contained in a specified folder and saves them as a single multipage tiff file.

[Visual Basic] Public Function MergeTiffImages(Directory As String, Append As Boolean) As Boolean
[C#] public bool MergeTiffImages(string Directory, bool Append);

Parameters

Directory
The name of the folder containing the image files to be combined (full path)

Append
Sets whether or not existing files will be appended or overwritten

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The MergeTiffImages method combines tiff files contained in a specified folder and saves them as a single multipage tiff file.

The Directory parameter sets the folder where the tiff files reside. The FileName property sets the name of the multipage tiff file that is created. The order of the pages of the created multipage tiff file is determined by the order of the filenames of the individual tiff files contained in the Directory folder.

If the file set in the FileName property is an existing file, then if the Append parameter is true, the newly created multipage tiff file will be appended to this existing file. If the Append parameter is false, then a new file is created by overwriting the existing file.

Only images in tiff format that exist in the Directory folder be merged and saved. The tiff compression format or each tiff image will be preserved in the multipage tiff image that is created. The tiff compression formats will not be changed.

The types of tiff images that can be saved are based on the types listed in the Newtone.ImageKit.SaveFileType enumeration.

If non-tiff images exist in the specified folder, an error is not generated. Those non-tiff images will be skipped and not included in the multipage tiff file that is created.

If the specified folderhas subfolders, the tiff images in these subfolders will also be merged into the multipage tiff file.

If a multipage tiff file exists in the specified folder, each page of this multipage tiff image will be included and saved along with any other individual tiff images contained in the folder.

Also See

IkFile Class | IkFile Members


ModifyPageInMultipageTiff Method

Newtone.ImageKit

Newtone.ImageKit.WPF.IkFile.ModifyPageInMultipageTiff Method

This method modifies a specified page of an existing multipage tiff file.

[Visual Basic] Public Function ModifyPageInMultipageTiff(Val As Newtone.ImageKit.SaveFileType, SaveImage As Image, modifyPage As Integer) As Boolean
[C#] public bool ModifyPageInMultipageTiff(Newtone.ImageKit.SaveFileType Val, Image SaveImage, int modifyPage);

Parameters

Val
The image format of the image used to modify the page (of type Newtone.ImageKit.SaveFileType)

SaveImage
The image used to modify the page

modifyPage
The page that is modified

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The ModifyPageInMultipageTiff method modifies a specified page of an existing multipage tiff file. The image set in the SaveImage parameter will be used to modify the page, specified by the modifyPage parameter, of an existing Tiff file set in the FileName property. This method is enabled when the modifyPage parameter is set to 1 or more. This method is only enabled when the image set into the Val parameter is a Tiff image. The compression format of each page of the multipage tiff file to be created and the compression format set in the argument Val are valid even if different compression formats are mixed. If the value of the modifyPage parameter is greater than the number of pages in the multipage Tiff, if the value of the modifyPage parameter is 0 or less, if the file set in the FileName property doesn't exist or is not a tiff file, then the ModifyPageInMultipageTiff method will fail and False will be returned.

If a valid image is set in SaveImage parameter, then that image will replace the image in the existing page specified in the modifyPage parameter.

Regarding tiff compression and image bitcounts:
Each compression format has its own number of bits that can be saved. Please note that an error will occur if you try to save a bit number that is outside the range of bits allowed. The following table shows the number of bits that can be saved.

Format | Compatible Bitcount
Tiff (Uncompressed) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32.
Tiff (Group 3-1D) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32. Important: On Windows Vista, only 1 bit images are supported. All other bitcounts will fail
Tiff (Group 4) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32. Important: On Windows Vista, only 1 bit images are supported. All other bitcounts will fail
Tiff (Packbits) | 1, 24.
Tiff (LZW) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32.

Tiff Group3-1D are the same format as MH. Tiff Group4 are the same format as MMR.
In Uncompressed and LZW formats, 16 bit images are converted to 24 bit images.

Examples

Example #1:
The following code will convert the image loaded into the PictureBox control to a Tiff image in G4 format, change it to the image on page 3 of the multipage tiff file currently loaded into the ImageKit control, and save it.

[Visual Basic.NET]
Dim ik_file As Newtone.ImageKit.IkFile = New Newtone.ImageKit.IkFile()

ik_file.FileName = "MultiTiff.tif" 'The saved tiff file
ik_file.ModifyPageInMultipageTiff(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, PictureBox1.Image, 3)

[Visual C#.NET]
Newtone.ImageKit.IkFile ik_file = new Newtone.ImageKit.IkFile();

ik_file.FileName = "MultiTiff.tif"; //The saved tiff file
ik_file.ModifyPageInMultipageTiff(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, pictureBox1.Image, 3);

Example #2:
Convert the BMP file loaded by the IkFile class to a Tiff image in G4 format, change it to the image of the third page of an existing multi Tiff file, and save it.

[Visual Basic.NET]
Dim ik_file As Newtone.ImageKit.IkFile = New Newtone.ImageKit.IkFile()

ik_file.FileName = "1bitBMP.bmp"
Dim mdfy_img As Image = ik_file.LoadImageFromFile();
If mdfy_img = Nothing Then Exit Sub

ik_file.FileName = "MultiTiff.tif" 'The saved tiff file
ik_file.ModifyPageInMultipageTiff(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, mdfy_img, 3)

[Visual C#.NET]
Newtone.ImageKit.IkFile ik_file = new Newtone.ImageKit.IkFile();

ik_file.FileName = "1bitBMP.bmp";
Image mdfy_img = ik_file.LoadImageFromFile();
if (mdfy_img == null) return;

ik_file.FileName = "MultiTiff.tif"; //The saved tiff file
ik_file.ModifyPageInMultipageTiff(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, mdfy_img, 3);

Also See

IkFile Class | IkFile Members


OpenFileDialog method

Newtone.ImageKit.WPF.IkFile.OpenFileDialog Method

This methods displays the "Open" dialog box which includes the file preview and information functions. This dialog box is used to select an image file to be opened.

[Visual Basic]
Public Function OpenFileDialog() As Boolean
[C#]
public bool OpenFileDialog() ;

Parameters

None

Return Value

Returns True if "Open" is selected. Returns False if "Cancel" is selected.

Explanation

The OpenFileDialog method displays the "Open" dialog box which includes the file preview and information functions. This dialog box is used to select an image file to be opened.

If the Open button is clicked, then the file name and path are set into the FileName property.

See Also

IkFile Class | IkFile Members


SaveFileDialog method

Newtone.ImageKit.WPF.IkFile.SaveFileDialog Method

This methods displays the "Save" dialog box which includes the file preview function. This dialog box is used to select an image file to be saved.

[Visual Basic]
Public Function SaveFileDialog() As Boolean
[C#]
public bool SaveFileDialog() ;

Parameters

None

Return Value

Returns True if "Save" is selected. Returns False if "Cancel" is selected.

Explanation

The SaveFile method displays the "Save" dialog box which includes the file preview function. This dialog box is used to select a directory and file name into which the image date is to be saved.

When the "Save" button is clicked the file name and path are set into the FileName property.

See Also

IkFile Class | IkFile Members


SaveImageToFile method

Newtone.ImageKit.WPF.IkFile.SaveImageToFile Method

This methods saves image data to a file.

[Visual Basic]
Public Function SaveImageToFile(Val As SaveFileType, SaveImage As Image) As Boolean
[C#]
public bool SaveImageToFile(SaveFileType Val, Image SaveImage) ;

Parameters

Val
The image format used to save the image
This value is of type SaveFileType

SaveImage
The saved image

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SaveImageToFile method saves image data to a file. The image set in the SaveImage parameter will be saved in the location specified by the FileNameproperty.

Below is a list of other properties that should be set when saving files in the these formats...

Format | Explanation
FPX | The Comment property should be set. If the Val parameter is SaveFPXJpeg then the JpegQuality property should also be set.
GIF | The Comment property should be set.
JPEG | The Comment, JpegQuality, and JpegSubsampling properties should be set.
JPEG Progress | The Comment, JpegQuality, and JpegSubsampling properties should be set.
JPEG2000 | The Comment, JPEG2000CodeBlockHeight, JPEG2000CodeBlockWidth, JPEG2000NumResLevel, JPEG2000PrecinctHeight, JPEG2000PrecinctWidth, JPEG2000Reversible, JPEG2000Size, JPEG2000TileHeight, and JPEG2000TileWidth properties should be set.
PNG | The Comment property should be set.
TIFF | The TiffAppend property should be set. After the image has been saved, please execute the CloseMultiTiff method.

With certain raster image formats, it is only possible to save images of a particular bitcount. Errors can be generated if an image of unsupported bitcount is saved. Below is a list of supported bitcounts when saving each type of raster image.

Name | Explanation
BMP (Uncompressed) | 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
BMP (Compressed) | 4,8
JPEG (Standard DCT) | 24 bit color. 8 bit grayscale may be saved only with the ImageKit.NET Plugin (Win32 Dll files) Note: When the ImageKit.NET Plugin (Win32 Dll files) are present, 8 bit grayscale and 24 bit color images can be saved in JPEG. Attempting to save images of other bitcounts will result in an error. If the ImageKit.NET Plugin (Win32 Dll files) are not present, all images will be converted to 24 bit color and saved in JPEG.
JPEG (Progressive DCT) | 8 bit grayscale, 24
GIF | 1, 4, 8 Note: If the ImageKit.NET Plugin (Win32 Dll files) are not present, all images will be saved in 8 bit GIF
TIFF (Uncompressed) | 1, 4, 8, 16, 24 (Does not include 16 bit grayscale)
TIFF (GROUP3-1D) | 1
TIFF (GROUP4) | 1
TIFF (PACKBITS) | 1
TIFF (LZW) | 1, 4, 8, 16, 24 (Does not include 16 bit grayscale)
TIFF (JPEG) | 1, 4, 8, 16 (Does not include 16 bit grayscale), 24, 32 * Although the above bitcounts are supported, the saved image will be 24 bit color
PNG | 1,4,8,24
FPX (Uncompressed) | 8 bit grayscale, 24
FPX (Single Color Compressed) | 8 bit grayscale, 24
FPX (JPEG Compression) | 8 bit grayscale, 24
JPEG2000 (Part1) | 8 bit grayscale, 24
JPEG2000 (Code Stream) | 8 bit grayscale, 24

Note: The following image formats are not supported by standard .NET Framework. Therefore, the ImageKit.NET Plugin (Win32 Dll files) are required when saving images in: BMP Compressed, Saving Jpeg 8 bit grayscale, JpegProgressive, JPEG2000, FPX file formats.

WMF and EMF images cannot be read and displayed in standard .NET framework but rather are converted to raster image data and displayed. As such, even though the file extensions are .wmf or .emf, these images can only be saved as raster images.

Example

Sample code for converting a BMP image file into a 24 bit JPEG image file:

[Visual Basic.NET]
ImageKit1.File.FileName = "Newtone.bmp"
If ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.LoadBMP) = False Then Exit Sub
If ImageKit1.GetImageType() = False Then Exit Sub
If ImageKit1.BitCount <> 24 Then
If ImageKit1.Effect.ConvertColor(24, False, False, 0) = False Then Exit Sub
End If

ImageKit1.File.FileName = "Newtone.jpg"
ImageKit1.File.SaveImageToFile(Newtone.ImageKit.SaveFileType.SaveJPEG, Nothing)

[Visual C#.NET]
ImageKit1.File.FileName = "Newtone.bmp";
if (!ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.LoadBMP)) return;
if (!ImageKit1.GetImageType()) return;
if (ImageKit1.BitCount <> 24))
{
    if (!ImageKit1.Effect.ConvertColor(24, false, false, 0)) return;
}

ImageKit1.File.FileName = "Newtone.jpg";
ImageKit1.File.SaveImageToFile(Newtone.ImageKit.SaveFileType.SaveJPEG, null);

Also See

IkFile Class | IkFile Members


SaveImageToRawData method

Newtone.ImageKit.WPF.IkFile.SaveImageToRawData Method

This method saves image data as raw data.

[Visual Basic]
Public Function SaveImageToRawData(Val As SaveFileType, SaveImage As Image) As Boolean
[C#]
public bool SaveImageToRawData(SaveFileType Val, Image SaveImage) ;

Parameters

Val
The format of image to be saved
The value is of type SaveFileType

SaveImage
The saved image

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SaveImageToRawData method saves image data as raw data.

The image set in the SaveImage parameter will be saved as raw data and set into the RawData property.

Below is a list of other properties that should be set when saving files in the these formats...

FPX | The Comment property should be set. If the Val parameter is SaveFPXJpeg then the JpegQuality property should also be set.
GIF | The Comment property should be set.
JPEG | The Comment, JpegQuality, and JpegSubsampling properties should be set.
JPEG Progress | The Comment, JpegQuality, and JpegSubsampling properties should be set.
JPEG2000 | The Comment, JPEG2000CodeBlockHeight, JPEG2000CodeBlockWidth, JPEG2000NumResLevel, JPEG2000PrecinctHeight, JPEG2000PrecinctWidth, JPEG2000Reversible, JPEG2000Size, JPEG2000TileHeight, and JPEG2000TileWidth properties should be set.
PNG | The Comment property should be set.
TIFF | The TiffAppend property should be set.

Though there are differences when saving raw image data, the process is nearly the same as the SaveImageToFile method.

With certain raster image formats, it is only possible to save images of a particular bitcount. Errors can be generated if an image of unsupported bitcount is saved. Below is a list of supported bitcounts when saving each type of raster image.

Name | Explanation
BMP (Uncompressed) | 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
BMP (Compressed) | 4,8
JPEG (Standard DCT) | 24 bit color. 8 bit grayscale may be saved only with the ImageKit.NET2 Plugin (Win32 Dll files) Note: When the ImageKit9 Dll files are present, 8 bit grayscale and 24 bit color images can be saved in JPEG. Attempting to save images of other bitcounts will result in an error. If the ImageKit.NET2 Plugin (Win32 Dll files) are not present, all images will be converted to 24 bit color and saved in JPEG.
JPEG (Progressive DCT) | 8 bit grayscale, 24
GIF | 1, 4, 8 Note: If the ImageKit.NET2 Plugin (Win32 Dll files) are not present, all images will be saved in 8 bit GIF
TIFF (Uncompressed) | 1, 4, 8, 16, 24 (Does not include 16 bit grayscale)
TIFF (GROUP3-1D) | 1
TIFF (GROUP4) | 1
TIFF (PACKBITS) | 1
TIFF (LZW) | 1, 4, 8, 16, 24 (Does not include 16 bit grayscale)
TIFF (JPEG) | 1, 4, 8, 16 (Does not include 16 bit grayscale), 24, 32 * Although the above bitcounts are supported, the saved image will be 24 bit color
PNG | 1,4,8,24
FPX (Uncompressed) | 8 bit grayscale, 24
FPX (Single Color Compressed) | 8 bit grayscale, 24
FPX (JPEG Compression) | 8 bit grayscale, 24
PCX | 1,4,8,24
JPEG2000 (Part1) | 8 bit grayscale, 24
JPEG2000 (Code Stream) | 8 bit grayscale, 24

Note

The following image formats are not supported by standard .NET Framework. Therefore, the ImageKit.NET2 Plugin (Win32 Dll files) are required when saving images in: BMP Compressed, Saving Jpeg 8 bit grayscale, JpegProgressive, JPEG2000, FPX file formats.

WMF and EMF images cannot be read and displayed in standard .NET framework but rather are converted to raster image data and displayed. As such, even though the file extensions are .wmf or .emf, these images can only be saved as raster images.

Example

Sample code for converting a BMP image file into a 24 bit JPEG image file and saving it as raw data:

[Visual Basic.NET]
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
  Dim LoadImg As Image
  Dim Ik_File As Newtone.ImageKit.WPF.IkFile
  Ik_File = New Newtone.ImageKit.WPF.IkFile

  Ik_File.FileName = "Newtone.bmp"
  LoadImg = Ik_File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.LoadBMP)
  If LoadImg = Nothing Then Exit Sub

  Ik_File.FileName = "Newtone.jpg"
  Ik_File.SaveImageToRawData(Newtone.ImageKit.SaveFileType.SaveJPEG, LoadImg)
End Sub

[Visual C#.NET]
private void button1_Click(object sender, System.EventArgs e)
{
  Newtone.ImageKit.WPF.IkFile Ik_File = new Newtone.ImageKit.WPF.IkFile();

  Ik_File.FileName = "Newtone.bmp";
  Image LoadImg = Ik_File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.LoadBMP);
  if (LoadImg == null) return;

  Ik_File.FileName = "Newtone.jpg";
  Ik_File.SaveImageToRawData(Newtone.ImageKit.SaveFileType.SaveJPEG, LoadImg);
}

See Also

IkFile Class | IkFile Members


SaveRawDataToFile method

Newtone.ImageKit.WPF.IkFile.SaveRawDataToFile Method

This methods saves raw data to a file.

[Visual Basic]
Public Function SaveRawDataToFile() As Boolean
[C#]
public bool SaveRawDataToFile() ;

Parameters

None

Return Value

Returns True if successful. Returns False if successful.

Explanation

The SaveRawDataToFile method saves raw data to a file. The raw data set in the RawData property is saved to a file set in the FileName property.

See Also

IkFile Class | IkFile Members


SaveRawDataToStream method

Newtone.ImageKit.WPF.IkFile.SaveRawDataToStream Method

This method saves the raw image data to stream.

[Visual Basic]
Public Function SaveRawDataToStream() As MemoryStream
[C#]
public MemoryStream SaveRawDataToStream() ;

Parameters

None

Return Value

Returns the content of the RawData property in a memory stream

Explanation

The SaveRawDataToStream method saves the raw image data, set in the RawData property, to stream.

See Also

IkFile Class | IkFile Members


Progress event

Newtone.ImageKit.WPF.IkFile.Progress Event

This event is generated when a file is being loaded or saved.

[Visual Basic]
 Public Event Progress As  ProgressEventHandler
[C#]
 public event  ProgressEventHandler  Progress;

Explanation

The Progress event is generated when the LoadRawDataFromFile, SaveRawDataFromFile, LoadImageFromFile, or SaveImageFromFile methods are executed.

The event handler takes arguments of type ProgressEventArgs. To cancel a process, set the Cancel property of the ProgressEventHandler to True.

See Also

IkFile Class | IkFile Members


ImageKit.File Members

Newtone.ImageKit.WPF.IkFile.Exif All Members

Public Properties

Altitude0 | The altitude in meters where the image was taken. This is the numerator.
Altitude1 | The altitude in meters where the image was taken. This is the denominator.
ApertureValue0 | The numerator for the lens aperature value
ApertureValue1 | The denominator for the lens aperature value
BrightnessValue0 | The numerator for the brightness value
BrightnessValue1 | The denominator for the brightness value
ColorSpace | Color space information
ComponentsConfiguration | Refers to the color of each color plane in the Exif image arranged in order from the 1st plane to the 4th plane
CompressedBitsPerPixel0 | The numerator for the compression mode used for a compressed image. (bits/pixel)
CompressedBitsPerPixel1 | The denominator for the compression mode used for a compressed image. (bits/pixel)
DateTimeDigitized | The date and time of digital data generation
DateTimeOriginal | The date and time of original data generation
ExposureBiasValue0 | The numerator for the exposure bias value
ExposureBiasValue1 | The denominator for the exposure bias value
ExposureIndex0 | The numerator for the exposure index selected on the camera or input device at the time the image was captured
ExposureIndex1 | The denominator for the exposure index selected on the camera or input device at the time the image was captured
ExposureProgram | Refers to the class of the program used by the camera to set exposure when the image was taken
ExposureTime0 | The numerator for the exposure time
ExposureTime1 | The denominator for the exposure time
FileSource | Indicates the image source
Flash | Indicates the flash firing status and the flash return status
FlashEnergy0 | The numerator for the strobe energy at the time the image was captured
FlashEnergy1 | The denominator for the strobe energy at the time the image was captured
FlashPixVersion | Refers to the version of the FlashPix format supported
FNumber0 | The numerator for the F number value
FNumber1 | The denominator for the F number value
FocalLength0 | The numerator for the focal length of the lens
FocalLength1 | The denominator for the focal length of the lens
FocalPlaneResolutionUnit | The units of measurement of the focal plane
FocalPlaneXResolution0 | The numerator of the horizontal focal plane resolution
FocalPlaneXResolution1 | The denominator of the horizontal focal plane resolution
FocalPlaneYResolution0 | The numerator of the vertical focal plane resolution
FocalPlaneYResolution1 | The denominator of the vertical focal plane resolution
GPSVersion | Refers to the GPS tag version (i.e. "2000")
ISOSpeedRatings | Indicates the ISO Speed and ISO Latitude of the camera or input device
Latitude | Refers to the latitude direction where the image was taken. (i.e. "N" or "S")
LatitudeD0 | The latitude in degrees where the image was taken. This is the numerator
LatitudeD1 | The latitude in degrees where the image was taken. This is the denominator
LatitudeM0 | The latitude in minutes where the image was taken. This is the numerator
LatitudeM1 | The latitude in minutes where the image was taken. This is the denominator
LatitudeS0 | The latitude in seconds where the image was taken. This is the numerator
LatitudeS1 | The latitude in seconds where the image was taken. This is the denominator
LightSource | Refers to the type of light source
Longitude | Refers to the longitude direction where the image was taken. (i.e. "E" or "W")
LongitudeD0 | The longitude in degrees where the image was taken. This is the numerator
LongitudeD1 | The longitude in degrees where the image was taken. This is the denominator
LongitudeM0 | The longitude in minutes where the image was taken. This is the numerator
LongitudeM1 | The longitude in minutes where the image was taken. This is the denominator
LongitudeS0 | The longitude in seconds where the image was taken. This is the numerator
LongitudeS1 | The longitude in seconds where the image was taken. This is the denominator
MainArtist | Refers to the camera owner, photographer, or creator of the primary image
MainCopyright | Refers to the copyright information for the primary image
MainDateTime | Refers to the date and time that the primary image was created
MainImageDescription | Refers to the character string giving the title of the primary image
MainMake | Refers to the manufacturer of the recording equipment that generated the primary image
MainModel | Refers to the model name or model number of the equipment that generated the primary image
MainOrientation | Refers to the image orientation of the primary image as viewed in terms of rows and columns
MainResolutionUnit | The unit of measurement for XResolution and YResolution in the primary image
MainSoftware | Refers to the name and version of the software used to generate the primary image
MainXResolution0 | Refers to the number of pixels per MainResolutionUnit in the primary image in the horizontal direction. (This value is the numerator)
MainXResolution1 | Refers to the number of pixels per MainResolutionUnit in the primary image in the horizontal direction. (This value is the denominator)
MainYCbCrPositioning | Refers to the position of chrominance components (CbCr) in relation to the luminance component (Y) in the primary image
MainYResolution0 | Refers to the number of pixels per MainResolutionUnit in the primary image in the vertical direction. (This value is the numerator)
MainYResolution1 | Refers to the number of pixels per MainResolutionUnit in the primary image in the vertical direction. (This value is the denominator)
MakerNote | Comments of the manufacturer of the Exif writer
MapDatum | Refers to the name of the map data used
MaxApertureValue0 | The numerator for the smallest F value of the lens
MaxApertureValue1 | The denominator for the smallest F value of the lens
MeteringMode | Refers to the metering mode
PixelXDimension | Refers to the width of the image
PixelYDimension | Refers to the height of the image
SceneType | Indicates the type of scene
SensingMethod | Refers to the image sensor type on the camera or input device
ShutterSpeedValue0 | The numerator for the shutter speed
ShutterSpeedValue1 | The denominator for the shutter speed
SpectralSensitivity | Refers to the spectral sensitivity of each channel of the camera used
SubjectDistance0 | The numerator for the distance to the subject
SubjectDistance1 | The denominator for the distance to the subject
SubjectLocationX | Refers to the horizontal location of the main subject in the scene
SubjectLocationY | Refers to the vertical location of the main subject in the scene
SubSecTime | Records fractions of a second for the MainDateTime property
SubSecTimeDigitized | Records fractions of a second for the DateTimeDigitized property
SubSecTimeOriginal | Records fractions of a second for the DateTimeOriginal property
ThumbnailArtist | Refers to the camera owner, photographer, or creator of the thumbnail image
ThumbnailCompression | Refers to the compression method for the thumbnail image
ThumbnailCopyright | Refers to the copyright information for the thumbnail image
ThumbnailDateTime | Refers to the date and time that the thumbnail image was created
ThumbnailImageDescription | Refers to the character string giving the title of the thumbnail image
ThumbnailMake | Refers to the manufacturer of the recording equipment that generated the thumbnail image
ThumbnailModel | Refers to the model name or model number of the equipment that generated the thumbnail image
ThumbnailOrientation | Refers to the image orientation of the thumbnail image as viewed in terms of rows and columns
ThumbnailResolutionUnit | The unit of measurement for XResolution and YResolution in the thumbnail image
ThumbnailSoftware | Refers to the name and version of the software used to generate the thumbnail image
ThumbnailXResolution0 | Refers to the number of pixels per ThumbResolutionUnit in the thumbnail image in the horizontal direction. (This value is the numerator)
ThumbnailXResolution1 | Refers to the number of pixels per ThumbResolutionUnit in the thumbnail image in the horizontal direction. (This value is the denominator)
ThumbnailYCbCrPositioning | Refers to the position of chrominance components (CbCr) in relation to the luminance component (Y) in the thumbnail image
ThumbnailYResolution0 | Refers to the number of pixels per ThumbResolutionUnit in the thumbnail image in the vertical direction. (This value is the numerator)
ThumbnailYResolution1 | Refers to the number of pixels per ThumbResolutionUnit in the thumbnail image in the vertical direction. (This value is the denominator)
UserComment | Comments or keywords that the Exif user can place on the image
UserCommentID | An identification code (8 bytes) that occurs at the start of the UserComment tag
Version | Refers to the version of the Exif Standard supported

See Also

IkFile Class


Altitude0 property

Newtone.ImageKit.WPF.IkFile.Exif.Altitude0 Property

The altitude in meters where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property Altitude0 As Integer
[C#] public int Altitude0 {get;}

Property Value

Altitude0 is the numerator for altitude in meters

Altitude1 is the denominator for altitude in meters

Altitude = Altitude0 / Altitude1

Explanation

The Altitude0 property refers to the altitude in meters where the image was taken. This is the numerator. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

This property is related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


Altitude1 property

Newtone.ImageKit.WPF.IkFile.Exif.Altitude1 Property

The altitude in meters where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property Altitude1 As Integer
[C#] public int Altitude1 {get;}

Property Value

Altitude0 is the numerator for altitude in meters

Altitude1 is the denominator for altitude in meters

Altitude = Altitude0 / Altitude1

Explanation

The Altitude1 property refers to the altitude in meters where the image was taken. This is the denominator. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

This property is related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


ApertureValue0 property

Newtone.ImageKit.WPF.IkFile.Exif.ApertureValue0 Property

The property value can be retrieved by executing the File.GetImageFileType or theFile.GetImageFileTypeFromRawData methods.

[Visual Basic] Public ReadOnly Property ApertureValue0 As Integer
[C#] public int ApertureValue0 {get;}

Property Value

ApertureValue0 is the numerator for the lens aperature value
ApertureValue1 is the denominator for the lens aperature value
The lens aperature value (unit is the APEX value) = ApertureValue0 / ApertureValue1

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


ApertureValue1 property

Newtone.ImageKit.WPF.IkFile.Exif.ApertureValue1 Property

The property value can be retrieved by executing the File.GetImageFileType or theFile.GetImageFileTypeFromRawData methods.

[Visual Basic] Public ReadOnly Property ApertureValue1 As Integer
[C#] public int ApertureValue1 {get;}

Property Value

ApertureValue0 is the numerator for the lens aperature value

ApertureValue1 is the denominator for the lens aperature value

The lens aperature value (unit is the APEX value) = ApertureValue0 / ApertureValue1

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


BrightnessValue0 property

Newtone.ImageKit.WPF.IkFile.Exif.BrightnessValue0 Property

This property refers to the brightness value. This is the numerator.

[Visual Basic] Public ReadOnly Property BrightnessValue0 As Integer
[C#] public int BrightnessValue0 {get;}

Property Value

BrightnessValue0 is the numerator for the brightness value

BrightnessValue1 is the denominator for the brightness value

The brightness value (unit is the APEX value) = BrightnessValue0 / BrightnessValue1

Ordinarily brightness is given in the range from -99.99 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


BrightnessValue1 property

Newtone.ImageKit.WPF.IkFile.Exif.BrightnessValue1 Property

This property refers to the brightness value. This is the denominator.

[Visual Basic] Public ReadOnly Property BrightnessValue1 As Integer
[C#] public int BrightnessValue1 {get;}

Property Value

BrightnessValue0 is the numerator for the brightness value

BrightnessValue1 is the denominator for the brightness value

The brightness value (unit is the APEX value) = BrightnessValue0 / BrightnessValue1

Ordinarily brightness is given in the range from -99.99 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


ColorSpace property

Newtone.ImageKit.WPF.IkFile.Exif.ColorSpace Property

This property refers to the color space information in the Exif image.

[Visual Basic] Public ReadOnly Property ColorSpace As Integer
[C#] public int ColorSpace {get;}

Property Value

Value | Explanation
1 | sRGB

Explanation

The ColorSpace property refers to the color space information in the Exif image.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the special characteristics of the image.

See Also

IkFile Class | IkFile.Exif Members


ComponentsConfiguration property

Newtone.ImageKit.WPF.IkFile.Exif.ComponentsConfiguration Property

This property refers to the color of each color plane in the Exif image arranged in order from the 1st plane to the 4th plane.

[Visual Basic] Public ReadOnly Property ComponentsConfiguration As String
[C#] public string ComponentsConfiguration {get;}

Property Value

Value | Explanation
0 | does not exist
1 | Y
2 | Cb
3 | Cr
4 | R
5 | G
6 | B

The default value for RGB is "4560" , for JPEG is "1230".

Explanation

The ComponentsConfiguration property refers to the color of each color plane in the Exif image arranged in order from the 1st plane to the 4th plane.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the image color planes. This tag is provided for cases when image data uses planes other than Y,Cr,Cb and to enable support of other sequences.

See Also

IkFile Class | IkFile.Exif Members


CompressedBitsPerPixel0 property

Newtone.ImageKit.WPF.IkFile.Exif.CompressedBitsPerPixel0 Property

This property refers to the compression mode used for a compressed Exif image. This is the numerator.

[Visual Basic] Public ReadOnly Property CompressedBitsPerPixel0 As Integer
[C#] public int CompressedBitsPerPixel0 {get;}

Property Value

CompressedBitsPerPixel0 is the numerator for the compression mode

CompressedBitsPerPixel1 is the denominator for the compression mode

The compression mode = CompressedBitsPerPixel0 / CompressedBitsPerPixel1 (bit/pixel units)

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property refers to the compression mode used for a compressed Exif image.

See Also

IkFile Class | IkFile.Exif Members


CompressedBitsPerPixel1 property

Newtone.ImageKit.WPF.IkFile.Exif.CompressedBitsPerPixel1 Property

This property refers to the compression mode used for a compressed Exif image. This is the denominator.

[Visual Basic] Public ReadOnly Property CompressedBitsPerPixel1 As Integer
[C#] public int CompressedBitsPerPixel1 {get;}

Property Value

CompressedBitsPerPixel0 is the numerator for the compression mode

CompressedBitsPerPixel1 is the denominator for the compression mode

The compression mode = CompressedBitsPerPixel0 / CompressedBitsPerPixel1 (bit/pixel units)

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property refers to the compression mode used for a compressed Exif image.

See Also

IkFile Class | IkFile.Exif Members


DateTimeDigitized property

Newtone.ImageKit.WPF.IkFile.Exif.DateTimeDigitized Property

This property refers to the time when the image data was stored as digital data.

[Visual Basic] Public ReadOnly Property DateTimeDigitized As String
[C#] public string DateTimeDigitized {get;}

Property Value

DateTimeDigitized is the date and time when the image was stored as digital data.

The format is "YYYY:MM:DD HH:MM:SS" with the time shown in 24 hour format, and the date and time separated by one blank character.

Example: "1996:09:01 09:15:30"

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the date and time.

the DateTimeDigitized and the DateTimeOriginal properties refer to the time when the original image data was generated and when this data was stored as digital data. If, for example, an image was captured by a DSC (Digital Still Camera) and at the same the file was recorded, then the DateTimeDigitized and the DateTimeOriginal will have the same contents.

See Also

IkFile Class | IkFile.Exif Members


DateTimeOriginal property

Newtone.ImageKit.WPF.IkFile.Exif.DateTimeOriginal Property

This property refers to the time when the original image data was generated.

[Visual Basic] Public ReadOnly Property DateTimeOriginal As String
[C#] public string DateTimeOriginal {get;}

Property Value

DateTimeOriginal is the data and time when the original image data was generated.

The format is "YYYY:MM:DD HH:MM:SS" with the time shown in 24 hour format, and the date and time separated by one blank character.

Example: "1996:09:01 09:15:30"

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the date and time.

The DateTimeDigitized and the DateTimeOriginal properties refer to the time when the original image data was generated and when this data was stored as digital data. If, for example, an image was captured by a DSC (Digital Still Camera) and at the same the the file was recorded, then the DateTimeDigitized and the DateTimeOriginal will have the same contents.

See Also

IkFile Class | IkFile.Exif Members


ExposureBiasValue0 property

Newtone.ImageKit.WPF.IkFile.Exif.ExposureBiasValue0 Property

This property relates to the exposure bias. This is the numerator.

[Visual Basic] Public ReadOnly Property ExposureBiasValue0 As Integer
[C#] public int ExposureBiasValue0 {get;}

Property Value

ExposureBiasValue0 is the numerator for the exposure bias value

ExposureBiasValue1 is the denominator for the exposure bias value

The exposure bias value (unit is the APEX value) = ExposureBiasValue0 / ExposureBiasValue1

Ordinarily exposure bias is given in the range from -99.99 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


ExposureBiasValue1 property

Newtone.ImageKit.WPF.IkFile.Exif.ExposureBiasValue1 Property

This property relates to the exposure bias. This is the denominator.

[Visual Basic] Public ReadOnly Property ExposureBiasValue1 As Integer
[C#] public int ExposureBiasValue1 {get;}

Property Value

ExposureBiasValue0 is the numerator for the exposure bias value

ExposureBiasValue1 is the denominator for the exposure bias value

The exposure bias value (unit is the APEX value) = ExposureBiasValue0 / ExposureBiasValue1

Ordinarily exposure bias is given in the range from -99.99 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


ExposureIndex0 property

Newtone.ImageKit.WPF.IkFile.Exif.ExposureIndex0 Property

This property relates to the exposure index selected on the camera or input device at the time the image was captured. This is the numerator.

[Visual Basic] Public ReadOnly Property ExposureIndex0 As Integer
[C#] public int ExposureIndex0 {get;}

Property Value

ExposureIndex0 is the numerator for the exposure index.

ExposureIndex1 is the denominator for the exposure index.

The exposure index = ExposureIndex0 / ExposureIndex1. This indicates the exposure index selected on the camera or input device at the time the image was captured.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


ExposureIndex1 property

Newtone.ImageKit.WPF.IkFile.Exif.ExposureIndex1 Property

This property relates to the exposure index selected on the camera or input device at the time the image was captured. This is the denominator.

[Visual Basic] Public ReadOnly Property ExposureIndex1 As Integer
[C#] public int ExposureIndex1 {get;}

Property Value

ExposureIndex0 is the numerator for the exposure index.

ExposureIndex1 is the denominator for the exposure index.

The exposure index = ExposureIndex0 / ExposureIndex1. This indicates the exposure index selected on the camera or input device at the time the image was captured.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


ExposureProgram property

Newtone.ImageKit.WPF.IkFile.Exif.ExposureProgram Property

This property refers to the class of the program used by the camera to set exposure when the image was taken.

[Visual Basic] Public ReadOnly Property ExposureProgram As Integer
[C#] public int ExposureProgram {get;}

Property Value

Value | Explanation
0 | Not defined
1 | Manual
2 | Normal program
3 | Aperture priority
4 | Shutter priority
5 | Creative program (biased toward depth of field)
6 | Action program (biased toward fast shutter speed)
7 | Portrait mode (for closeup photos with the background out of focus)
8 | Landscape mode (for landscapes with the background in focus

Explanation

The ExposureProgram property refers to the class of the program used by the camera to set exposure when the image was taken.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


ExposureTime0 property

Newtone.ImageKit.WPF.IkFile.Exif.ExposureTime0 Property

This property is the numerator for the exposure time.

[Visual Basic] Public ReadOnly Property ExposureTime0 As Integer
[C#] public int ExposureTime0 {get;}

Property Value

ExposureTime0 is the numerator for the exposure time.

ExposureTime1 is the denominator for the exposure time.

Exposure time (in seconds) = ExposureTime0 / ExposureTime1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


ExposureTime1 property

Newtone.ImageKit.WPF.IkFile.Exif.ExposureTime1 Property

This property is the denominator for the exposure time.

[Visual Basic] Public ReadOnly Property ExposureTime1 As Integer
[C#] public int ExposureTime1 {get;}

Property Value

ExposureTime0 is the numerator for the exposure time.

ExposureTime1 is the denominator for the exposure time.

Exposure time (in seconds) = ExposureTime0 / ExposureTime1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


FileSource property

Newtone.ImageKit.WPF.IkFile.Exif.FileSource Property

FileSource indicates the image source. If a DSC (Digital Still Camera) recorded the image, this value will be set to 3 indicating that the image was recorded on a DSC.

[Visual Basic] Public ReadOnly Property FileSource As Integer
[C#] public int FileSource {get;}

Property Value

FileSource indicates the image source. If a DSC (Digital Still Camera) recorded the image, this value will be set to 3 indicating that the image was recorded on a DSC.

Explanation

The FileSource property refers to the image source.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


Flash property

Newtone.ImageKit.WPF.IkFile.Exif.Flash Property

This property indicates the flash firing status and the flash return status.

[Visual Basic] Public ReadOnly Property Flash As Integer
[C#] public int Flash {get;}

Property Value

This property value is recorded when the image is taken with a strobe light (flash).

Bit 0 indicates the flash firing status, and bits 1 and 2 indicate the flash return status.

Values for bit 0 indicate whether the flash fired.

0b = Flash did not fire

1b = Flash fired

Values for bits 1 and 2 indicate the return status

00b = No strobe return detection function

01b = Reserved

10b = Strobe return light not detected

11b = Strobe return light detected

Resulting flash tag values (in hexadecimal notation)

0x0000 = Flash did not fire

0x0001 = Flash fired

0x0005 = Strobe return light not detected

0x0007 = Strobe return light detected

* In Visual Basic an &H is used instead of 0x.

Explanation

The Flash property indicates the flash firing status and the flash return status.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


FlashEnergy0 property

Newtone.ImageKit.WPF.IkFile.Exif.FlashEnergy0 Property

This property is the numerator for the strobe energy at the time the image was captured.

[Visual Basic] Public ReadOnly Property FlashEnergy0 As Integer
[C#] public int FlashEnergy0 {get;}

Property Value

FlashEnergy0 is the numerator for the flash energy.

FlashEnergy1 is the denominator for the flash energy.

Flash energy (in BCPS) = FlashEnergy0 / FlashEnergy1. This indicates the strobe energy at the time the image was captured as measured in Beam Candle Power Seconds.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


FlashEnergy1 property

Newtone.ImageKit.WPF.IkFile.Exif.FlashEnergy1 Property

This property is the denominator for the strobe energy at the time the image was captured.

[Visual Basic] Public ReadOnly Property FlashEnergy1 As Integer
[C#] public int FlashEnergy1 {get;}

Property Value

FlashEnergy0 is the numerator for the flash energy.

FlashEnergy1 is the denominator for the flash energy.

Flash energy (in BCPS) = FlashEnergy0 / FlashEnergy1. This indicates the strobe energy at the time the image was captured as measured in Beam Candle Power Seconds.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


FlashPixVersion property

Newtone.ImageKit.WPF.IkFile.Exif.FlashPixVersion Property

This property refers to the version of the FlashPix format supported. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FlashPixVersion As String
[C#] public string FlashPixVersion {get;}

Property Value

FlashPixVersion is the FlashPix format version supported by a FPRX file (i.e. "1000").

Explanation

The FlashPixVersion property refers to the version of the FlashPix format supported. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property is derived from the image tags related to the Exif version.

See Also

IkFile Class | IkFile.Exif Members


FNumber0 property

Newtone.ImageKit.WPF.IkFile.Exif.FNumber0 Property

This property is the numerator for the F number value.

[Visual Basic] Public ReadOnly Property FNumber0 As Integer
[C#] public int FNumber0 {get;}

Property Value

FNumber0 is the numerator for the FNumber

FNumber1 is the denominator for the FNumber

The FNumber = FNumber0 / FNumber1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeMem methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


FNumber1 property

Newtone.ImageKit.WPF.IkFile.Exif.FNumber1 Property

This property is the denominator for the F number value.

[Visual Basic] Public ReadOnly Property FNumber1 As Integer
[C#] public int FNumber1 {get;}

Property Value

FNumber0 is the numerator for the FNumber

FNumber1 is the denominator for the FNumber

The FNumber = FNumber0 / FNumber1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeMem methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


FocalLength0 property

Newtone.ImageKit.WPF.IkFile.Exif.FocalLength0 Property

This property is the numerator for the focal length of the lens.

[Visual Basic] Public ReadOnly Property FocalLength0 As Integer
[C#] public int FocalLength0 {get;}

Property Value

FocalLength0 is the numerator for the focal length of the lens

FocalLength1 is the denominator for the focal length of the lens

The actual focal length of the lens (in mm) = FocalLength0 / FocalLength1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


FocalLength1 property

Newtone.ImageKit.WPF.IkFile.Exif.FocalLength1 Property

This property is the denominator for the focal length of the lens.

[Visual Basic] Public ReadOnly Property FocalLength1 As Integer
[C#] public int FocalLength1 {get;}

Property Value

FocalLength0 is the numerator for the focal length of the lens

FocalLength1 is the denominator for the focal length of the lens

The actual focal length of the lens (in mm) = FocalLength0 / FocalLength1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


FocalPlaneResolutionUnit property

Newtone.ImageKit.WPF.IkFile.Exif.FocalPlaneResolutionUnit Property

This property refers to the units of measurement for focal plane resolution in the primary and thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FocalPlaneResolutionUnit As Integer
[C#] public int FocalPlaneResolutionUnit {get;}

Property Value

The FocalPlaneResolutionUnit is the unit of measurement for FocalPlaneXResolution and FocalPlaneYResolution.

The FocalPlaneResolutionUnit is FocalPlaneXResolution0 / FocalPlaneXResolution1 and FocalPlaneYResolution0 / FocalPlaneYResolution1.

Value | Explanation
2 | Inches
3 | Centimeters

Explanation

The FocalPlaneResolutionUnit property refers to the units of measurement for focal plane resolution in the primary and thumbnail images.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


FocalPlaneXResolution0 property

Newtone.ImageKit.WPF.IkFile.Exif.FocalPlaneXResolution0 Property

This property refers to the horizontal focal plane resolution.

[Visual Basic] Public ReadOnly Property FocalPlaneXResolution0 As Integer
[C#] public int FocalPlaneXResolution0 {get;}

Property Value

The FocalPlaneXResolution is the number of pixels in the image horizontal direction per FocalPlaneResolutionUnit on the camera focal plane.

The FocalPlaneXResolution0 is the numerator for the FocalPlaneXResolution.

The FocalPlaneXResolution1 is the denominator for the FocalPlaneXResolution.

The FocalPlaneResolutionUnit = FocalPlaneXResolution0 / FocalPlaneXResolution1

Explanation

The FocalPlaneXResolution0 property refers to the horizontal focal plane resolution.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


FocalPlaneXResolution1 property

Newtone.ImageKit.WPF.IkFile.Exif.FocalPlaneXResolution1 Property

This property refers to the horizontal focal plane resolution.

[Visual Basic] Public ReadOnly Property FocalPlaneXResolution1 As Integer
[C#] public int FocalPlaneXResolution1 {get;}

Property Value

The FocalPlaneXResolution is the number of pixels in the image horizontal direction per FocalPlaneResolutionUnit on the camera focal plane.

The FocalPlaneXResolution0 is the numerator for the FocalPlaneXResolution.

The FocalPlaneXResolution1 is the denominator for the FocalPlaneXResolution.

The FocalPlaneResolutionUnit = FocalPlaneXResolution0 / FocalPlaneXResolution1

Explanation

The FocalPlaneXResolution1 property refers to the horizontal focal plane resolution.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


FocalPlaneYResolution0 property

Newtone.ImageKit.WPF.IkFile.Exif.FocalPlaneYResolution0 Property

This property refers to the vertical plane resolution.

[Visual Basic] Public ReadOnly Property FocalPlaneYResolution0 As Integer
[C#] public int FocalPlaneYResolution0 {get;}

Property Value

The FocalPlaneYResolution is the number of pixels in the image vertical direction per FocalPlaneResolutionUnit on the camera focal plane.

The FocalPlaneYResolution0 is the numerator for the FocalPlaneYResolution.

The FocalPlaneYResolution1 is the denominator for the FocalPlaneYResolution.

The FocalPlaneResolutionUnit = FocalPlaneYResolution0 / FocalPlaneYResolution1

Explanation

The FocalPlaneYResolution0 property refers to the vertical focal plane resolution.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


FocalPlaneYResolution1 property

Newtone.ImageKit.WPF.IkFile.Exif.FocalPlaneYResolution1 Property

This property refers to the vertical focal plane resolution.

[Visual Basic] Public ReadOnly Property FocalPlaneYResolution1 As Integer
[C#] public int FocalPlaneYResolution1 {get;}

Property Value

The FocalPlaneYResolution is the number of pixels in the image vertical direction per FocalPlaneResolutionUnit on the camera focal plane.

The FocalPlaneYResolution0 is the numerator for the FocalPlaneYResolution.

The FocalPlaneYResolution1 is the denominator for the FocalPlaneYResolution.

The FocalPlaneResolutionUnit = FocalPlaneYResolution0 / FocalPlaneYResolution1

Explanation

The FocalPlaneXResolution1 property refers to the horizontal focal plane resolution.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


GPSVersion property

Newtone.ImageKit.WPF.IkFile.Exif.GPSVersion Property

This property refers to the GPS tag version (i.e. "2000"). The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property GPSVersion As String
[C#] public string GPSVersion {get;}

Property Value

The GPS tag version (i.e. "2000")

Explanation

The GPSVersion property refers to the GPS tag version (i.e. "2000"). The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property is derived from the image tags related to the Exif version.

See Also

IkFile Class | IkFile.Exif Members


ISOSpeedRatings property

Newtone.ImageKit.WPF.IkFile.Exif.ISOSpeedRatings Property

This property indicates the ISO Speed and ISO Latitude of the camera or input device.

[Visual Basic] Public ReadOnly Property ISOSpeedRatings As Integer
[C#] public int ISOSpeedRatings {get;}

Property Value

Indicates the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232xiv

Explanation

The ISOSpeedRatings property indicates the ISO Speed and ISO Latitude of the camera or input device.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


LatitudeD0 property

Newtone.ImageKit.WPF.IkFile.Exif.LatitudeD0 Property

This property refers to latitude in degrees where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LatitudeD0 As Integer
[C#] public int LatitudeD0 {get;}

Property Value

LatitudeD0 is the latitude in degrees where the image was taken. This is the numerator.

LatitudeD1 is the latitude in degrees where the image was taken. This is the denominator.

The latitude in degrees = LatitudeD0 / LatitudeD1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


LatitudeD1 property

Newtone.ImageKit.WPF.IkFile.Exif.LatitudeD1 Property

This property refers to latitude in degrees where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LatitudeD1 As Integer
[C#] public int LatitudeD1 {get;}

Property Value

LatitudeD0 is the latitude in degrees where the image was taken. This is the numerator.

LatitudeD1 is the latitude in degrees where the image was taken. This is the denominator.

The latitude in degrees = LatitudeD0 / LatitudeD1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


LatitudeM0 property

Newtone.ImageKit.WPF.IkFile.Exif.LatitudeM0 Property

This property refers to latitude in minutes where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LatitudeM0 As Integer
[C#] public int LatitudeM0 {get;}

Property Value

LatitudeM0 is the latitude in minutes where the image was taken. This is the numerator.

LatitudeM1 is the latitude in minutes where the image was taken. This is the denominator.

The latitude in minutes = LatitudeM0 / LatitudeM1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


LatitudeM1 property

Newtone.ImageKit.WPF.IkFile.Exif.LatitudeM1 Property

This property refers to latitude in minutes where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LatitudeM1 As Integer
[C#] public int LatitudeM1 {get;}

Property Value

LatitudeM0 is the latitude in minutes where the image was taken. This is the numerator.

LatitudeM1 is the latitude in minutes where the image was taken. This is the denominator.

The latitude in minutes = LatitudeM0 / LatitudeM1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


LatitudeS0 property

Newtone.ImageKit.WPF.IkFile.Exif.LatitudeS0 Property

This property refers to latitude in seconds where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LatitudeS0 As Integer
[C#] public int LatitudeS0 {get;}

Property Value

LatitudeS0 is the latitude in minutes where the image was taken. This is the numerator.

LatitudeS1 is the latitude in minutes where the image was taken. This is the denominator.

The latitude in minutes = LatitudeS0 / LatitudeS1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


LatitudeS1 property

Newtone.ImageKit.WPF.IkFile.Exif.LatitudeS1 Property

This property refers to latitude in seconds where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LatitudeS1 As Integer
[C#] public int LatitudeS1 {get;}

Property Value

LatitudeS0 is the latitude in seconds where the image was taken. This is the numerator.

LatitudeS1 is the latitude in seconds where the image was taken. This is the denominator.

The latitude in minutes = LatitudeS0 / LatitudeS1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


Latitude property

Newtone.ImageKit.WPF.IkFile.Exif.Latitude Property

This property refers to the latitude direction where the image was taken. (i.e. "N" or "S")

[Visual Basic] Public ReadOnly Property Latitude As String
[C#] public string Latitude {get;}

Property Value

Latitude is the latitude direction where the image was taken. (i.e. "N" or "S")

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


LongitudeD0 property

Newtone.ImageKit.WPF.IkFile.Exif.LongitudeD0 Property

This property refers to longitude in degrees where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LongitudeD0 As String
[C#] public string LongitudeD0 {get;}

Property Value

LongitudeD0 is the longitude in degrees where the image was taken. This is the numerator.

LongitudeD1 is the latitude in degrees where the image was taken. This is the denominator.

The longitude in degrees = LongitudeD0 / LongitudeD1

Explanation

The LongitudeD0 property refers to longitude in degrees where the image was taken. This is the numerator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


LongitudeD1 property

Newtone.ImageKit.WPF.IkFile.Exif.LongitudeD1 Property

This property refers to longitude in degrees where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LongitudeD1 As String
[C#] public string LongitudeD1 {get;}

Property Value

LongitudeD0 is the longitude in degrees where the image was taken. This is the numerator.

LongitudeD1 is the latitude in degrees where the image was taken. This is the denominator.

The longitude in degrees = LongitudeD0 / LongitudeD1

Explanation

The LongitudeD1 property refers to longitude in degrees where the image was taken. This is the denominator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


LongitudeM0 property

Newtone.ImageKit.WPF.IkFile.Exif.LongitudeM0 Property

This property refers to longitude in minutes where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LongitudeM0 As String
[C#] public string LongitudeM0 {get;}

Property Value

LongitudeM0 is the longitude in minutes where the image was taken. This is the numerator.

LongitudeM1 is the latitude in minutes where the image was taken. This is the denominator.

The longitude in minutes = LongitudeM0 / LongitudeM1

Explanation

The LongitudeM0 property refers to longitude in minutes where the image was taken. This is the numerator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


LongitudeM1 property

Newtone.ImageKit.WPF.IkFile.Exif.LongitudeM1 Property

This property refers to longitude in minutes where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LongitudeM1 As String
[C#] public string LongitudeM1 {get;}

Property Value

LongitudeM0 is the longitude in minutes where the image was taken. This is the numerator.

LongitudeM1 is the latitude in minutes where the image was taken. This is the denominator.

The longitude in minutes = LongitudeM0 / LongitudeM1

Explanation

The LongitudeM1 property refers to longitude in minutes where the image was taken. This is the denominator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


LongitudeS0 property

Newtone.ImageKit.WPF.IkFile.Exif.LongitudeS0 Property

This property refers to longitude in seconds where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LongitudeS0 As String
[C#] public string LongitudeS0 {get;}

Property Value

LongitudeS0 is the longitude in seconds where the image was taken. This is the numerator.

LongitudeS1 is the latitude in seconds where the image was taken. This is the denominator.

The longitude in minutes = LongitudeS0 / LongitudeS1

Explanation

The LongitudeS0 property refers to longitude in seconds where the image was taken. This is the numerator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


LongitudeS1 property

Newtone.ImageKit.WPF.IkFile.Exif.LongitudeS1 Property

This property refers to longitude in seconds where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LongitudeS1 As String
[C#] public string LongitudeS1 {get;}

Property Value

LongitudeS0 is the longitude in seconds where the image was taken. This is the numerator.

LongitudeS1 is the latitude in seconds where the image was taken. This is the denominator.

The longitude in minutes = LongitudeS0 / LongitudeS1

Explanation

The LongitudeS1 property refers to longitude in seconds where the image was taken. This is the denominator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


MapDatum property

Newtone.ImageKit.WPF.IkFile.Exif.MapDatum Property

This property refers to the name of the map data used.
[Visual Basic] Public ReadOnly Property MapDatum As String
[C#] public string MapDatum {get;}

Property Value

MapDatum is the name of the map data used

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


LightSource property

Newtone.ImageKit.WPF.IkFile.Exif.LightSource Property

This property refers to the type of light source.

[Visual Basic] Public ReadOnly Property LightSource As Integer
[C#] public int LightSource {get;}

Property Value

Value | Explanation
0 | Unknown
1 | Daylight
2 | Fluorescent
3 | Tungsten
17 | Standard light A
18 | Standard light B
19 | Standard light C
20 | D55
21 | D65
22 | D75
255 | Other

Explanation

The LightSource property refers to the type of light source.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


Longitude property

Newtone.ImageKit.WPF.IkFile.Exif.Longitude Property

This property refers to the longitude direction where the image was taken. (i.e. "E" or "W")

[Visual Basic] Public ReadOnly Property Longitude As String
[C#] public string Longitude {get;}

Property Value

Longitude is the longitude direction where the image was taken. (i.e. "E" or "W")

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

IkFile Class | IkFile.Exif Members


MainInfo property

Newtone.ImageKit.WPF.IkFile.Exif.MainArtist Property

This property refers to the information about the artist's name.

[Visual Basic] Public ReadOnly Property MainArtist As String
[C#] public string MainArtist {get;}

Property Value

MainArtist refers to the camera owner, photographer, or creator of the primary image

Explanation

The MainArtist property refers to the information about the artist's name.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

IkFile Class | IkFile.Exif Members


MainCopyright property

Newtone.ImageKit.WPF.IkFile.Exif.MainCopyright Property

This property refers to the information about the copyright.

[Visual Basic] Public ReadOnly Property MainCopyright As String
[C#] public string MainCopyright {get;}

Property Value

MainCopyright refers to the copyright information for the primary image

Explanation

The MainCopyright property refers to the information about the copyright.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

IkFile Class | IkFile.Exif Members


MainDateTime property

Newtone.ImageKit.WPF.IkFile.Exif.MainDateTime Property

This property refers to the information about the date and time.

[Visual Basic] Public ReadOnly Property MainDateTime As String
[C#] public string MainDateTime {get;}

Property Value

MainDateTime refers to the date and time that the primary image was created. The format is "YYYY:MM:DD HH:MM:SS" with the time shown in 24-hour format and the date and time separated by one blank character

Example: "1996:09:01 09:15:30"

Explanation

The MainDateTime property refers to the information about the date and time.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

IkFile Class | IkFile.Exif Members


MainImageDescription property

Newtone.ImageKit.WPF.IkFile.Exif.MainImageDescription Property

This property refers to the information about the image description.

[Visual Basic] Public ReadOnly Property MainImageDescription As String
[C#] public string MainImageDescription {get;}

Property Value

MainImageDescription refers to the character string giving the title of the primary image

Explanation

The MainImageDescription property refers to the information about the image description.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

IkFile Class | IkFile.Exif Members


MainMake property

Newtone.ImageKit.WPF.IkFile.Exif.MainMake Property

This property refers to the information about the manufacturer's name.

[Visual Basic] Public ReadOnly Property MainMake As String
[C#] public string MainMake {get;}

Property Value

MainMake refers to the manufacturer of the recording equipment that generated the primary image

Explanation

The MainMake property refers to the information about the manufacturer's name.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

IkFile Class | IkFile.Exif Members


MainModel property

Newtone.ImageKit.WPF.IkFile.Exif.MainModel Property

This property refers to the information about the model name or model number of the equipment.

[Visual Basic] Public ReadOnly Property MainModel As String
[C#] public string MainModel {get;}

Property Value

MainModel refers to the model name or model number of the equipment that generated the primary image

Explanation

The MainModel property refers to the information about the model name or model number of the equipment.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

IkFile Class | IkFile.Exif Members


MainSoftware property

Newtone.ImageKit.WPF.IkFile.Exif.MainSoftware Property

This property refers to the information about the software.

[Visual Basic] Public ReadOnly Property MainSoftware As String
[C#] public string MainSoftware {get;}

Property Value

MainSoftware refers to the name and version of the software used to generate the primary image

Explanation

The MainSoftware property refers to the information about the software.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

IkFile Class | IkFile.Exif Members


MainResolutionUnit property

Newtone.ImageKit.WPF.IkFile.Exif.MainResolutionUnit Property

This property refers to the units of measurement for focal plane resolution in the primary image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property MainResolutionUnit As Integer
[C#] public int MainResolutionUnit {get;}

Property Value

The MainResolutionUnit is the unit of measurement for MainXResolution and MainYResolution in the primary image.

The MainResolutionUnit is MainXResolution0 / MainXResolution1 and MainYResolution0 / MainYResolution1

Value | Explanation
2 | Inches
3 | Centimeters

Explanation

The MainResolutionUnit property refers to the units of measurement for focal plane resolution in the primary image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


MainXResolution0 property

Newtone.ImageKit.WPF.IkFile.Exif.MainXResolution0 Property

This property refers to the number of pixels per resolution unit in the primary images.

[Visual Basic] Public ReadOnly Property MainXResolution0 As Integer
[C#] public int MainXResolution0 {get;}

Property Value

The MainXResolution is the number of pixels per MainResolutionUnit in the primary image in the horizontal direction.

The MainXResolution0 is the numerator for the MainResolutionUnit.

The MainXResolution1 is the denominator for the MainResolutionUnit.

The MainResolutionUnit = MainXResolution0 / MainXResolution1

Explanation

The MainXResolution0 property refers to the number of pixels per resolution unit in the primary images. The property value is derived from the image tags relating to image data structure. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

See Also

IkFile Class | IkFile.Exif Members


MainXResolution1 property

Newtone.ImageKit.WPF.IkFile.Exif.MainXResolution1 Property

This property refers to the number of pixels per resolution unit in the primary images.

[Visual Basic] Public ReadOnly Property MainXResolution1 As Integer
[C#] public int MainXResolution1 {get;}

Property Value

The MainXResolution is the number of pixels per MainResolutionUnit in the primary image in the horizontal direction.

The MainXResolution0 is the numerator for the MainResolutionUnit.

The MainXResolution1 is the denominator for the MainResolutionUnit.

The MainResolutionUnit = MainXResolution0 / MainXResolution1

Explanation

The MainXResolution1 property refers to the number of pixels per resolution unit in the primary images. The property value is derived from the image tags relating to image data structure. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

See Also

IkFile Class | IkFile.Exif Members


MainYCbCrPositioning property

Newtone.ImageKit.WPF.IkFile.Exif.MainYCbCrPositioning Property

This property refers to the position of chrominance components (CbCr) in relation to the luminance component (Y).

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property MainYCbCrPositioning As Integer
[C#] public int MainYCbCrPositioning {get;}

Property Value

Value | Explanation
1 | Centered
2 | Co-sited

Explanation

The MainYCbCrPositioning property refers to the position of chrominance components (CbCr) in relation to the luminance component (Y). The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags relating to primary image data structure.

See Also

IkFile Class | IkFile.Exif Members


MainYResolution0 property

Newtone.ImageKit.WPF.IkFile.Exif.MainYResolution0 Property

This property refers to the number of pixels per resolution unit in the primary images.

[Visual Basic] Public ReadOnly Property MainYResolution0 As Integer
[C#] public int MainYResolution0 {get;}

Property Value

The MainYResolution is the number of pixels per MainResolutionUnit in the primary image in the vertical direction.

The MainYResolution0 is the numerator for the MainResolutionUnit.

The MainYResolution1 is the denominator for the MainResolutionUnit.

The MainResolutionUnit = MainYResolution0 / MainYResolution1

Explanation

The MainYResolution0 property refers to the number of pixels per resolution unit in the primary images. The property value is derived from the image tags relating to image data structure. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

See Also

IkFile Class | IkFile.Exif Members


MainYResolution1 property

Newtone.ImageKit.WPF.IkFile.Exif.MainYResolution1 Property

This property refers to the number of pixels per resolution unit in the primary images.

[Visual Basic] Public ReadOnly Property MainYResolution1 As Integer
[C#] public int MainYResolution1 {get;}

Property Value

The MainYResolution is the number of pixels per MainResolutionUnit in the primary image in the vertical direction.

The MainYResolution0 is the numerator for the MainResolutionUnit.

The MainYResolution1 is the denominator for the MainResolutionUnit.

The MainResolutionUnit = MainYResolution0 / MainYResolution1

Explanation

The MainYResolution1 property refers to the number of pixels per resolution unit in the primary images. The property value is derived from the image tags relating to image data structure. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

See Also

IkFile Class | IkFile.Exif Members


MakerNote property

Newtone.ImageKit.WPF.IkFile.Exif.MakerNote Property

This property value is derived from the image tags relating to user information.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property MakerNote As String
[C#] public string MakerNote {get;}

Property Value

The MakerNote property value is derived from the image tag for manufacturers of Exif writers to record any desired information.

Explanation

The MakerNote property value is derived from the image tags relating to user information.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

IkFile Class | IkFile.Exif Members


MaxApertureValue0 property

Newtone.ImageKit.WPF.IkFile.Exif.MaxApertureValue0 Property

This property refers to the smallest F value of the lens. This is the numerator.

[Visual Basic] Public ReadOnly Property MaxApertureValue0 As Integer
[C#] public int MaxApertureValue0 {get;}

Property Value

MaxApertureValue0 is the numerator for the smallest F value of the lens

MaxApertureValue1 is the denominator for the smallest F value of the lens

The smallest F value of the lens (unit is the APEX value) = MaxApertureValue0 / MaxApertureValue1

Ordinarily the smallest F value of the lens is given in the range from 00.00 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


MaxApertureValue1 property

Newtone.ImageKit.WPF.IkFile.Exif.MaxApertureValue1 Property

This property refers to the smallest F value of the lens. This is the denominator.

[Visual Basic] Public ReadOnly Property MaxApertureValue1 As Integer
[C#] public int MaxApertureValue1 {get;}

Property Value

MaxApertureValue0 is the numerator for the smallest F value of the lens

MaxApertureValue1 is the denominator for the smallest F value of the lens

The smallest F value of the lens (unit is the APEX value) = MaxApertureValue0 / MaxApertureValue1

Ordinarily the smallest F value of the lens is given in the range from 00.00 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


MeteringMode property

Newtone.ImageKit.WPF.IkFile.Exif.MeteringMode Property

This property refers to the metering mode. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.
[Visual Basic] Public ReadOnly Property MeteringMode As Integer
[C#] public int MeteringMode {get;}

Property Value

Value | Explanation
0 | Unknown
1 | Average
2 | CounterWeightedAverage
3 | Spot
4 | MultiSpot
5 | Pattern
6 | Partial
255 | Other

Explanation

The MeteringMode property refers to the metering mode. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method. This property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


MainOrientation property

Newtone.ImageKit.WPF.IkFile.Exif.MainOrientation Property

This property refers to the image orientation viewed in terms of rows and columns. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property MainOrientation As Integer
[C#] public int MainOrientation {get;}

Property Value

Value | Explanation
1 | The 0th row is at the visual top of the image, and the 0th column is the visual left hand side
2 | The 0th row is at the visual top of the image, and the 0th column is the visual right hand side
3 | The 0th row is at the visual bottom of the image, and the 0th column is the visual right hand side
4 | The 0th row is at the visual bottom of the image, and the 0th column is the visual left hand side
5 | The 0th row is at the visual left hand side of the image, and the 0th column is the visual top
6 | The 0th row is at the visual right hand side of the image, and the 0th column is the visual top
7 | The 0th row is at the visual right hand side of the image, and the 0th column is the visual bottom
8 | The 0th row is at the visual left hand side of the image, and the 0th column is the visual bottom

Explanation

The MainOrientation property refers to the image orientation viewed in terms of rows and columns.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags relating to primary image data structure.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailOrientation property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailOrientation Property

This property refers to the image orientation viewed in terms of rows and columns. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property ThumbnailOrientation As Integer
[C#]
public int ThumbnailOrientation {get;}

Property Value

Value | Explanation
1 | The 0th row is at the visual top of the image, and the 0th column is the visual left hand side
2 | The 0th row is at the visual top of the image, and the 0th column is the visual right hand side
3 | The 0th row is at the visual bottom of the image, and the 0th column is the visual right hand side
4 | The 0th row is at the visual bottom of the image, and the 0th column is the visual left hand side
5 | The 0th row is at the visual left hand side of the image, and the 0th column is the visual top
6 | The 0th row is at the visual right hand side of the image, and the 0th column is the visual top
7 | The 0th row is at the visual right hand side of the image, and the 0th column is the visual bottom
8 | The 0th row is at the visual left hand side of the image, and the 0th column is the visual bottom

Explanation

The ThumbnailOrientation property refers to the image orientation viewed in terms of rows and columns.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags relating to thumbnail image data structure.

See Also

IkFile Class | IkFile.Exif Members


PixelXDimension property

Newtone.ImageKit.WPF.IkFile.Exif.PixelXDimension Property

This property refers to the width of the image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property PixelXDimension As Integer
[C#] public int PixelXDimension {get;}

Property Value

PixcelXDimension is the valid width of the image

Explanation

The PixcelXDimension property refers to the width of the image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to the image configuration.

See Also

IkFile Class | IkFile.Exif Members


PixelYDimension property

Newtone.ImageKit.WPF.IkFile.Exif.PixelYDimension Property

This property refers to the height of the image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property PixelYDimension As Integer
[C#] public int PixelYDimension {get;}

Property Value

PixcelYDimension is the valid height of the image

Explanation

The PixcelYDimension property refers to the height of the image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to the image configuration.

See Also

IkFile Class | IkFile.Exif Members


SceneType property

Newtone.ImageKit.WPF.IkFile.Exif.SceneType Property

This property refers to the type of scene.

[Visual Basic] Public ReadOnly Property SceneType As Integer
[C#] public int SceneType {get;}

Property Value

SceneType indicates the type of scene. If a DSC recorded the image, this value will be set to 1 indicating that the image was directly photographed.

Explanation

The SceneType property refers to the type of scene.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


SensingMethod property

Newtone.ImageKit.WPF.IkFile.Exif.SensingMethod Property

This property refers to the image sensor type on the camera or input device. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SensingMethod As Integer
[C#] public int SensingMethod {get;}

Property Value

Value | Explanation
1 | Not defined
2 | One-chip color area sensor
3 | Two-chip color area sensor
4 | Three-chip color area sensor
5 | Color sequential area sensor
7 | Trilinear sensor
8 | Color sequential linear sensor

Explanation

The SensingMethod property refers to the image sensor type on the camera or input device. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


ShutterSpeedValue0 property

Newtone.ImageKit.WPF.IkFile.Exif.ShutterSpeedValue0 Property

This property is the numerator for the shutter speed. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ShutterSpeedValue0 As Integer
[C#] public int ShutterSpeedValue0 {get;}

Property Value

ShutterSpeedValue0 is the numerator for the shutter speed

ShutterSpeedValue1 is the denominator for the shutter speed

The shutter speed (unit is the APEX value) = ShutterSpeedValue0 / ShutterSpeedValue1

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The ShutterSpeedValue0 property is the numerator for the shutter speed. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


ShutterSpeedValue1 property

Newtone.ImageKit.WPF.IkFile.Exif.ShutterSpeedValue1 Property

This property is the denominator for the shutter speed. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ShutterSpeedValue1 As Integer
[C#] public int ShutterSpeedValue1 {get;}

Property Value

ShutterSpeedValue0 is the numerator for the shutter speed

ShutterSpeedValue1 is the denominator for the shutter speed

The shutter speed (unit is the APEX value) = ShutterSpeedValue0 / ShutterSpeedValue1

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The ShutterSpeedValue1 property is the denominator for the shutter speed. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


SpectralSensitivity property

Newtone.ImageKit.WPF.IkFile.Exif.SpectralSensitivity Property

This property refers to the spectral sensitivity of each channel of the camera used. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SpectralSensitivity As String
[C#] public string SpectralSensitivity {get;}

Property Value

The value is an ASCII string commpatible with the standard xiii developed by the ASTM Technical committee.

Explanation

The SpectralSensitivity property referes to the spectral sensitivity of each channel of the camera used. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


SubjectDistance0 property

Newtone.ImageKit.WPF.IkFile.Exif.SubjectDistance0 Property

This property is the numerator for the distance to the subject. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubjectDistance0 As Integer
[C#] public int SubjectDistance0 {get;}

Property Value

SubjectDistance0 is the numerator for the distance to the subject.

SubjectDistance1 is the denominator for the distance to the subject.

The distance to the subject (in meters) = SubjectDistance0 / SubjectDistance1

Explanation

The SubjectDistance0 property is the numerator for the distance to the subject. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


SubjectDistance1 property

Newtone.ImageKit.WPF.IkFile.Exif.SubjectDistance1 Property

This property is the denominator for the distance to the subject. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubjectDistance1 As Integer
[C#] public int SubjectDistance1 {get;}

Property Value

SubjectDistance0 is the numerator for the distance to the subject.

SubjectDistance1 is the denominator for the distance to the subject.

The distance to the subject (in meters) = SubjectDistance0 / SubjectDistance1

Explanation

The SubjectDistance1 property is the numerator for the distance to the subject. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


SubjectLocationX property

Newtone.ImageKit.WPF.IkFile.Exif.SubjectLocationX Property

This property refers to the location of the main subject in the scene. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubjectLocationX As Integer
[C#] public int SubjectLocationX {get;}

Property Value

The SubjectLocationX is the horizontal coordinate of the center of the main subject of the scene

The SubjectLocationY is the vertical coordinate of the center of the main subject of the scene

Explanation

The SubjectLocationX refers to the location of the main subject in the scene. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


SubjectLocationY property

Newtone.ImageKit.WPF.IkFile.Exif.SubjectLocationY Property

This property refers to the location of the main subject in the scene. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubjectLocationY As Integer
[C#] public int SubjectLocationY {get;}

Property Value

The SubjectLocationX is the horizontal coordinate of the center of the main subject of the scene

The SubjectLocationY is the vertical coordinate of the center of the main subject of the scene

Explanation

The SubjectLocationY refers to the location of the main subject in the scene. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


SubSecTime property

Newtone.ImageKit.WPF.IkFile.Exif.SubSecTime Property

This property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property SubSecTime As String
[C#]
public string SubSecTime {get;}

Property Value

The SubSecTime property records fractions of seconds for the MainDateTime property.

For example, if the subsecond data is 0.130 then

SubSecTime = "130"

Explanation

The SubSecTime property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to date and time.

See Also

IkFile Class | IkFile.Exif Members


SubSecTime property

Newtone.ImageKit.WPF.IkFile.Exif.SubSecTimeDigitized Property

This property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property SubSecTimeDigitized As String
[C#]
public string SubSecTimeDigitized {get;}

Property Value

The SubSecTimeDigitized property records fractions of seconds for the DateTimeDigitized property.

For example, if the subsecond data is 0.130 then

SubSecTimeDigitized = "130"

Explanation

The SubSecTimeDigitized property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to date and time.

See Also

IkFile Class | IkFile.Exif Members


SubSecTime property

Newtone.ImageKit.WPF.IkFile.Exif.SubSecTimeOriginal Property

This property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property SubSecTimeOriginal As String
[C#]
public string SubSecTimeOriginal {get;}

Property Value

The SubSecTimeOriginal property records fractions of seconds for the DateTimeOriginal property.

For example, if the subsecond data is 0.130 then

SubSecTimeOriginal = "130"

Explanation

The SubSecTimeOriginal property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to date and time.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailCompression property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailCompression Property

This property refers to the compression method for the thumbnail image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property ThumbnailCompression As Integer
[C#]
public int ThumbnailCompression {get;}

Property Value

Value | Explanation
1 | Uncompressed
6 | JPEG compression

Explanation

The ThumbnailCompression property refers to the compression method for the thumbnail image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

When the thumbnail is Jpeg compression data, the return value will be 6.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailArtist property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailArtist Property

This property refers to the information about the artist's name. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property ThumbnailArtist As String
[C#]
public string ThumbnailArtist {get;}

Property Value

ThumbnailArtist refers to the camera owner, photographer, or creator of the Thumbnail image

Explanation

The ThumbnailArtist property refers to the information about the artist's name. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailCopyright property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailCopyright Property

This property refers to the information about the copyright. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property ThumbnailCopyright As String
[C#]
public string ThumbnailCopyright {get;}

Property Value

ThumbnailCopyright refers to the copyright information for the Thumbnail image

Explanation

The ThumbnailCopyright property refers to the information about the copyright. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailDateTime property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailDateTime Property

This property refers to the information about the date and time. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property ThumbnailDateTime As String
[C#]
public string ThumbnailDateTime {get;}

Property Value

ThumbnailDateTime refers to the date and time that the Thumbnail image was created. The format is "YYYY:MM:DD HH:MM:SS" with the time shown in 24-hour format and the date and time separated by one blank character

Example: "1996:09:01 09:15:30"

Explanation

The ThumbDateTime property refers to the information about the date and time. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailImageDescription property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailImageDescription Property

This property refers to the information about the image description. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property ThumbnailImageDescription As String
[C#]
public string ThumbnailImageDescription {get;}

Property Value

ThumbnailImageDescription refers to the character string giving the title of the Thumbnail image

Explanation

The ThumbnailImageDescription property refers to the information about the image description. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailMake property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailMake Property

This property refers to the information about the manufacturer's name. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property ThumbnailMake As String
[C#]
public string ThumbnailMake {get;}

Property Value

ThumbnailMake refers to the manufacturer of the recording equipment that generated the Thumbnail image

Explanation

The ThumbnailMake property refers to the information about the manufacturer's name. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailModel property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailModel Property

This property refers to the information about the model name or model number of the equipment. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property ThumbnailModel As String
[C#]
public string ThumbnailModel {get;}

Property Value

ThumbnailModel refers to the model name or model number of the equipment that generated the Thumbnail image

Explanation

The ThumbnailModel property refers to the information about the model name or model number of the equipment. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailSoftware property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailSoftware Property

This property refers to the information about the software. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property ThumbnailSoftware As String
[C#]
public string ThumbnailSoftware {get;}

Property Value

ThumbnailSoftware refers to the name and version of the software used to generate the Thumbnail image

Explanation

The ThumbnailSoftware property refers to the information about the software. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailResolutionUnit property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailResolutionUnit Property

This property refers to the units of measurement for focal plane resolution in the thumbnail image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailResolutionUnit As Integer
[C#] public int ThumbnailResolutionUnit {get;}

Property Value

The ThumbnailResolutionUnit is the unit of measurement for ThumbnailXResolution and ThumbnailYResolution in the thumbnail image.

The ThumbnailResolutionUnit is ThumbnailXResolution0 / ThumbnailXResolution1 and ThumbnailYResolution0 / ThumbnailYResolution1

Value | Explanation
2 | Inches
3 | Centimeters

Explanation

The ThumbnailResolutionUnit property refers to the units of measurement for focal plane resolution in the thumbnail image.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailXResolution0 property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailXResolution0 Property

This property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailXResolution0 As Integer
[C#] public int ThumbnailXResolution0 {get;}

Property Value

The ThumbnailXResolution is the number of pixels per ThumbnailResolutionUnit in the thumbnail image in the horizontal direction.

The ThumbnailXResolution0 is the numerator for the ThumbnailResolutionUnit.

The ThumbnailXResolution1 is the denominator for the ThumbnailResolutionUnit.

The ThumbnailResolutionUnit = ThumbnailXResolution0 / ThumbnailXResolution1.

Explanation

The ThumbnailXResolution0 property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property is derived from the Exif thumbnail image tags related to resolution.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailXResolution1 property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailXResolution1 Property

This property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailXResolution1 As Integer
[C#] public int ThumbnailXResolution1 {get;}

Property Value

The ThumbnailXResolution is the number of pixels per ThumbnailResolutionUnit in the thumbnail image in the horizontal direction.

The ThumbnailXResolution0 is the numerator for the ThumbnailResolutionUnit.

The ThumbnailXResolution1 is the denominator for the ThumbnailResolutionUnit.

The ThumbnailResolutionUnit = ThumbnailXResolution0 / ThumbnailXResolution1.

Explanation

The ThumbnailXResolution1 property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property is derived from the Exif thumbnail image tags related to resolution.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailYCbCrPositioning property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailYCbCrPositioning Property

This property refers to the position of chrominance components (CbCr) in relation to the luminance component (Y).

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailYCbCrPositioning As Integer
[C#] public int ThumbnailYCbCrPositioning {get;}

Property Value

Value | Explanation
1 | Centered
2 | Co-sited

Explanation

The ThumbnailYCbCrPositioning property refers to the position of chrominance components (CbCr) in relation to the luminance component (Y). The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags relating to thumbnail image data structure.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailYResolution0 property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailYResolution0 Property

This property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailYResolution0 As Integer
[C#] public int ThumbnailYResolution0 {get;}

Property Value

The ThumbnailYResolution is the number of pixels per ThumbnailResolutionUnit in the thumbnail image in the vertical direction.

The ThumbnailYResolution0 is the numerator for the ThumbnailResolutionUnit.

The ThumbnailYResolution1 is the denominator for the ThumbnailResolutionUnit.

The ThumbnailResolutionUnit = ThumbnailYResolution0 / ThumbnailYResolution1.

Explanation

The ThumbnailYResolution0 property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property is derived from the Exif thumbnail image tags related to resolution.

See Also

IkFile Class | IkFile.Exif Members


ThumbnailYResolution1 property

Newtone.ImageKit.WPF.IkFile.Exif.ThumbnailYResolution1 Property

This property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailYResolution1 As Integer
[C#] public int ThumbnailYResolution1 {get;}

Property Value

The ThumbnailYResolution is the number of pixels per ThumbnailResolutionUnit in the thumbnail image in the vertical direction.

The ThumbnailYResolution0 is the numerator for the ThumbnailResolutionUnit.

The ThumbnailYResolution1 is the denominator for the ThumbnailResolutionUnit.

The ThumbnailResolutionUnit = ThumbnailYResolution0 / ThumbnailYResolution1.

Explanation

The ThumbnailYResolution1 property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property is derived from the Exif thumbnail image tags related to resolution.

See Also

IkFile Class | IkFile.Exif Members


UserComment property

Newtone.ImageKit.WPF.IkFile.Exif.UserComment Property

This property value is derived from the image tags relating to user information.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property UserComment As String
[C#]
public string UserComment {get;}

Property Value

The UserComment tag is identified based on an UserCommentID code in a fixed 8-byte area at the start of the tag data area. The unused portion of the area is padded with NULL("00.H").

Character Code | Code Designation (8 Bytes) | References
ASCII | 0x41,0x53,0x43,0x49,0x49,0x00,0x00,0x00 | ITU-T T.50 IA5x
JIS | 0x4A,0x49,0x53,0x00,0x00,0x00,0x00,0x00 | JIS X0208-1990xi
Unicode | 0x55,0x4E,0x49,0x43,0x4F,0x44,0x45,0x00 | Unicode Standard xii
Undefined | 0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00 | Undefined

In Visual Basic, please replace 0x with &H

Explanation

The UserComment property value is derived from the image tags relating to user information. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

IkFile Class | IkFile.Exif Members


UserCommentID property

Newtone.ImageKit.WPF.IkFile.Exif.UserCommentID Property

This property value is derived from the image tags relating to user information.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property UserCommentID As String
[C#]
public string UserCommentID {get;}

Property Value

The UserComment tag is identified based on an UserCommentID code in a fixed 8-byte area at the start of the tag data area. The unused portion of the area is padded with NULL("00.H").

Character Code | Code Designation (8 Bytes) | References
ASCII | 0x41,0x53,0x43,0x49,0x49,0x00,0x00,0x00 | ITU-T T.50 IA5x
JIS | 0x4A,0x49,0x53,0x00,0x00,0x00,0x00,0x00 | JIS X0208-1990xi
Unicode | 0x55,0x4E,0x49,0x43,0x4F,0x44,0x45,0x00 | Unicode Standard xii
Undefined | 0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00 | Undefined

In Visual Basic, please replace 0x with &H

Explanation

The UserCommentID property value is derived from the image tags relating to user information. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

IkFile Class | IkFile.Exif Members


Version property

Newtone.ImageKit.WPF.IkFile.Exif.Version Property

This property refers to the version of the Exif Standard supported. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic]
Public ReadOnly Property Version As String
[C#]
public string Version {get;}

Property Value

Version is the Exif version supported. (Example: "0210")

Explanation

The Version property refers to the version of the Exif Standard supported. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif version.

See Also

IkFile Class | IkFile.Exif Members


ImageKit.File.Pdf Members

Newtone.ImageKit.WPF.IkFile.Pdf Members

Public Properties

DocumentHeight | Sets the height of the saved PDF document
DocumentSize | Sets the size of the saved PDF document
DocumentWidth | Sets the width of the saved PDF document
Landscape | Sets whether the saved PDF will have a landscape or protrait orientation
SaveFileName | Sets the file name (full path) when saving the PDF document

Public Methods

AddImage | Adds an image to a PDF document
AddPage | Adds a page to the PDF document
End | Completes the PDF document
EndPage | Ends the page that was added with the AddPage method
Start | Starts the PDF document

Also See

IkFile Class


DocumentHeight property

Newtone.ImageKit.WPF.IkFile.Pdf.DocumentHeight Property

This property sets the height of the saved PDF document.

[Visual Basic] Public Property DocumentHeight As int
[C#] public int DocumentHeight {get; set;}

Property Value

The height in mm of the saved PDF document

Explanation

The DocumentHeight property sets the height of the saved PDF document.

Please set this property before executing the AddPage method.

imageKit1.File.Pdf.DocumentHeight = 200;
imageKit1.File.Pdf.AddPage();

To specify a standard height and width for the PDF document, please see the DocumentSize property.

Also See

IkFile Class | IkFile.Pdf Members


DocumentSize property

Newtone.ImageKit.WPF.IkFile.Pdf.DocumentSize Property

This property sets the size of the saved PDF document.

[Visual Basic] Public Property DocumentSize As String
[C#] public String DocumentSize {get; set;}

Property Value

The following are supported setting values:

A0, A1, A2, A3, A4, A5, A6, A7, A8, A9, A10
B0, B1, B2, B3, B4, B5, B6, B7, B8, B9
LETTER, LEGAL

Explanation

The DocumentSize property sets the size of the saved PDF document.

Please set this property before executing the AddPage method.

imageKit1.File.Pdf.DocumentSize = "a4";
imageKit1.File.Pdf.AddPage();

When the DocumentSize property is set, it is not necessary to set the DocumentHeight or DocumentWidth properties.

Also See

IkFile Class | IkFile.Pdf Members


DocumentWidth property

Newtone.ImageKit.WPF.IkFile.Pdf.DocumentWidth Property

This property sets the width of the saved PDF document

[Visual Basic] Public Property DocumentWidth As int
[C#] public int DocumentWidth {get; set;}

Property Value

The width in mm of the saved PDF document

Explanation

The DocumentWidth property sets the width of the saved PDF document

Please set this property before executing the AddPage method.

imageKit1.File.Pdf.DocumentWidth = 200;
imageKit1.File.Pdf.AddPage();

To specify a standard height and width for the PDF document, please see the DocumentSize property.

Also See

IkFile Class | IkFile.Pdf Members


Landscape property

Newtone.ImageKit.WPF.IkFile.Pdf.Landscape Property

This property sets whether the saved PDF will have a landscape or protrait orientation.

[Visual Basic] Public Property Landscape As Boolean
[C#] public bool Landscape {get; set;}

Property Value

True: PDF will have a landscape orientation
False: PDF will have a protrait orientation
Default value is False

Explanation

The Landscape property sets whether the saved PDF will have a landscape or protrait orientation. When this property is True and a PDF is saved whose size is set in the DocumentSize property, the PDF document will have a landscape orientation. If this property is False, the PDF will have a protrait orientation.

Note: After setting the DocumentSize property, if you set the DocumentHeight and DocumentWidth properties, those two settings will take precedence and the DocumentSize property and this Landscape property will be ignored.

Also See

IkFile Class | IkFile.Pdf Members


SaveFileName property

Newtone.ImageKit.WPF.IkFile.Pdf.SaveFileName Property

This property sets the file name (full path) when saving the PDF document

[Visual Basic] Public Property SaveFileName As String
[C#] public String SaveFileName {get; set;}

Property Value

A string containing the file name and path where the pdf will be saved

Explanation

The SaveFileName property sets the file name (full path) when saving the PDF document

Also See

IkFile Class | IkFile.Pdf Members


AddImage method

Newtone.ImageKit.WPF.IkFile.Pdf.AddImage Method

This method adds an image to a PDF document.

[Visual Basic]
Public Function AddImage(ImageFile As String, x As Integer, y As Integer, width As Integer, height As Integer) As Boolean
Public Function AddImage(ImageData As Image, x As Integer, y As Integer, width As Integer, height As Integer) As Boolean
Public Function AddImage(ImageArray As Byte(), x As Integer, y As Integer, width As Integer, height As Integer) As Boolean
[C#]
public bool AddImage(String ImageFile, int x, int y, int width, int height);
public bool AddImage(Image ImageData, int x, int y, int width, int height);
public bool AddImage(Byte[] ImageArray, int x, int y, int width, int height);

Parameters

Parameter Name | Explanation
ImageFilePath | The image file that is to be added to the PDF
ImageData | The image data
ImageArray | The image data
x | The horizontal position of the BOTTOM LEFT corner of the added image (in mm)
y | The vertical position of the BOTTOM LEFT corner of the added image (in mm)
width | The width of the image in mm (Note: This does not denote an x coordinate. It is the width of the image!)
height | The height of the image in mm (Note: This does not denote an y coordinate. It is the height of the image!)

Return Value

Returns True if successful, otherwise returns False

Explanation

The AddImage method adds an image to a PDF document.

The image formats supported are BMP (1, 4, 8, and 24 bit) and JPEG.

The image specified by the SaveFileName property will be saved in pdf format.

The AddImage method should be used with the other PDF methods in the following order: Start, AddPage, AddImage, EndPage, and End.

Example

Also see the example on the Start method page.

AddImage method examples:

[Visual C#.NET]
//Loads an image file and creats a pdf
imageKit1.File.Pdf.AddImage("Image.jpg", 0, 0, 200, 200);

//Loads the image from file
Image img = Image.FromFile("Image.bmp");
//creats the pdf
imageKit1.File.Pdf.AddImage(img, 0, 0, 100, 100);

//Loads the image from file
imageKit1.File.FileName ="sample.jpg";
imageKit1.File.LoadImageFromFile(LoadFileType.Load);
//setts the image data into the imageKit1.File.RawData property
imageKit1.File.SaveImageToRawData(SaveFileType.SaveJPEG, imageKit1.Image);
//Creats the pdf
imageKit1.File.Pdf.AddImage(imageKit1.File.RawData, 0, 0, 100, 100);

Also See

IkFile Class | IkFile.Pdf Members


AddPage method

Newtone.ImageKit.WPF.IkFile.Pdf.AddPage Method

This method adds a page to the PDF document

[Visual Basic] Public Function AddPage() As Boolean
[C#] public bool AddPage();

Parameters

None

Return Value

Returns True if successful, otherwise returns False

Explanation

The AddPage method adds a page to the PDF document. Once the page has been added, use the AddImage method to add an image to the page. The image formats supported are BMP and JPEG.

The PDF document will be saved in the file and path specified by the SaveFileName property.

The AddPage method should be used with the other PDF methods in the following order: Start, AddPage, AddImage, EndPage, End

Example

Also see the example on the Start method page.

AddPage example:

[Visual C#.NET]
imageKit1.File.Pdf.SaveFileName = "test.pdf";
imageKit1.File.Pdf.Start();
//Adds a B5 sized page
imageKit1.File.Pdf.DocumentSize = "B5";
imageKit1.File.Pdf.AddPage();
//adds and image to that page
imageKit1.File.Pdf.AddImage("Image.jpg", 0, 0, 100, 100);
imageKit1.File.Pdf.EndPage();
//adds a A4 sized page
imageKit1.File.Pdf.DocumentSize = "a4";
imageKit1.File.Pdf.AddPage();
//adds an image to that page
imageKit1.File.Pdf.AddImage("Image.bmp", 0, 0, 100, 100);
imageKit1.File.Pdf.EndPage();
imageKit1.File.Pdf.End();

Also See

IkFile Class | IkFile.Pdf Members


End method

Newtone.ImageKit.WPF.IkFile.Pdf.End Method

This method completes the PDF document

[Visual Basic] Public Function End() As Boolean
[C#] public bool End();

Parameters

None

Return Value

Returns True if successful, otherwise returns False

Explanation

The End method completes the PDF document

The PDF document will be saved in the file and path specified by the SaveFileName property.

The End method should be used with the other PDF methods in the following order: Start, AddPage, AddImage, EndPage, End.

Example

See the example on the Start method page.

Also See

IkFile Class | IkFile.Pdf Members


EndPagee method

Newtone.ImageKit.WPF.IkFile.Pdf.EndPage Method

This method ends the page that was added with the AddPage method

[Visual Basic] Public Function EndPage() As Boolean
[C#] public bool EndPage();

Parameters

None

Return Value

Returns True if successful, otherwise returns False

Explanation

The EndPage method ends the page that was added with the AddPage method

The PDF document will be saved in the file and path specified by the SaveFileName property.

The End method should be used with the other PDF methods in the following order: Start, AddPage, AddImage, EndPage, End.

Example

See the example on the Start method page.

Also See

IkFile Class | IkFile.Pdf Members


Start method

Newtone.ImageKit.WPF.IkFile.Pdf.Start Method

This method starts the PDF document

[Visual Basic] Public Function Start() As Boolean
[C#] public bool Start();

Parameters

None

Return Value

Returns True if successful, otherwise returns False

Explanation

The Start method starts the PDF document

The image formats supported are BMP and JPEG

The PDF document will be saved in the file and path specified by the SaveFileName property.

The Start method should be used with the other PDF methods in the following order: Start, AddPage, AddImage, EndPage, End.

Example

Saving a Jpeg image in a PDF

[Visual Basic.NET]

'load the image "sample.jpg"
imageKit1.File.FileName = "sample.jpg"
imageKit1.File.LoadImageFromFile(LoadFileType.Load)
'set the image data into the imageKit1.File.RawData property
imageKit1.File.SaveImageToRawData(SaveFileType.SaveJPEG,imageKit1.Image)

'create the pdf
imageKit1.File.Pdf.SaveFileName = "sample.pdf"

imageKit1.File.Pdf.DocumentSize = "a4"
imageKit1.File.Pdf.Start()
imageKit1.File.Pdf.AddPage()
imageKit1.File.Pdf.AddImage(imageKit1.File.RawData, 0, 0, 100, 100)
imageKit1.File.Pdf.EndPage()
imageKit1.File.Pdf.End()

[Visual C#.NET]

//load the image "sample.jpg"
imageKit1.File.FileName ="sample.jpg";
imageKit1.File.LoadImageFromFile(LoadFileType.Load);
//set the image data into the imageKit1.File.RawData property
imageKit1.File.SaveImageToRawData(SaveFileType.SaveJPEG, imageKit1.Image);

//create the pdf
imageKit1.File.Pdf.SaveFileName = "sample.pdf";
imageKit1.File.Pdf.DocumentSize = "a4";
imageKit1.File.Pdf.Start();
imageKit1.File.Pdf.AddPage();
imageKit1.File.Pdf.AddImage(imageKit1.File.RawData, 0, 0, 100, 100);
imageKit1.File.Pdf.EndPage();
imageKit1.File.Pdf.End();

Also See

IkFile Class | IkFile.Pdf Members


SaveFileType enum

Newtone.ImageKit.WPF.SaveFileType Enum

This refers to the type of image to be saved.

public enum SaveFileType

Publlic Members

Member | Value | Explanation
SaveBMP | 0 | BMP Uncompressed
SaveBMPRLE | 1 | ImageKit WPF does not support this format
SaveJPEG | 2 | JPEG Standard DCT
SaveJPEGProgress | 3 | ImageKit WPF does not support this format
SaveGIF | 4 | GIF
SaveTIFFNoncompressed | 5 | TIFF Uncompressed
SaveTIFFCcittrle | 6 | ImageKit WPF does not support this format
SaveTIFFGroup3_1D | 7 | TIFF Group3-1D
SaveTIFFGroup3_2D | 8 | ImageKit WPF does not support this format
SaveTIFFGroup4 | 9 | TIFF Group4
SaveTIFFPackbits | 10 | TIFF Packbits
SaveTIFFLZW | 11 | TIFF LZW
SavePNG | 12 | PNG
SaveFPXNoncompressed | 13 | ImageKit WPF does not support this format
SaveFPXSingleColor | 14 | ImageKit WPF does not support this format
SaveFPXJpeg | 15 | ImageKit WPF does not support this format
SavePCX | 16 | ImageKit WPF does not support this format
SaveWMF | 17 | ImageKit WPF does not support this format
SaveEMF | 18 | ImageKit WPF does not support this format
SaveDXF | 19 | ImageKit WPF does not support this format
SaveSVG | 20 | ImageKit WPF does not support this format
SaveJPEG2000 | 21 | ImageKit WPF does not support this format
SaveJPEG2000Stream | 22 | ImageKit WPF does not support this format
SaveSXFP21 | 23 | ImageKit WPF does not support this format
SaveSXFSFC | 24 | ImageKit WPF does not support this format
SaveTiffJpeg | 25 | Tiff Jpeg Compression

See Also

IkFile Class | IkFile Members


TypeOfFile enum

Newtone.ImageKit.WPFTypeOfFile Enum

This refers to the types of image file.

public enum TypeOfFile

Public Members

Member | Value | Explanation
TypeBMP | 1 | BMP
TypeBMPRLE4 | 2 | ImageKit WPF does not support this format
TypeBMPRLE8 | 3 | ImageKit WPF does not support this format
TypeJPEG | 4 | JPEG Standard DCT
TypeJPEGProgress | 5 | ImageKit WPF does not support this format
TypeGIF | 6 | GIF
TypeGIF89 | 7 | GIF 89a
TypeTIFFNoncompressed | 8 | TIFF Uncompressed
TypeTIFFCcittrle | 9 | TIFF Ccittrle
TypeTIFFGroup3_1D | 10 | TIFF Group3-1D
TypeTIFFGroup3_2D | 11 | TIFF Group3-2D
TypeTIFFGroup4 | 12 | TIFF Group4
TypeTIFFPackbits | 13 | TIFF Packbits
TypeTIFFLZW | 14 | TIFF LZW
TypePNG | 15 | PNG
TypeFPXNoncompressed | 16 | ImageKit WPF does not support this format
TypeFPXSingleColor | 17 | ImageKit WPF does not support this format
TypeFPXJpeg | 18 | ImageKit WPF does not support this format
TypePCX | 19 | ImageKit WPF does not support this format
TypeWMF | 20 | WMF
TypeEMF | 21 | EMF
TypeDXF | 22 | ImageKit WPF does not support this format
TypeEXIF | 23 | Exif (JPEG)
TypeSVG | 24 | ImageKit WPF does not support this format
TypeJPEG2000 | 25 | ImageKit WPF does not support this format
TypeJPEG2000Stream | 26 | ImageKit WPF does not support this format
TypeSXFP21 | 27 | ImageKit WPF does not support this format
TypeSXFSFC | 28 | ImageKit WPF does not support this format
TypeTIFFJPEG | 29 | Tiff Jpeg
TypeTIFFZIP | 30 | TIFF ZIP

See Also

IkFile Class | IkFile Members


Ftp class

Newtone.ImageKit.WPF.Ftp Class

This class accesses data to the ftp protocol.

For a list of all members of this type, see Ftp Members.

System.Object
Newtone.ImageKit.WPF
public class Ftp : Object

Explanation

This class provides the functionalities to upload and download the files.

Note This class supports URI starting with the scheme extension, "ftp:".

Requirements

Namespace : Newtone.ImageKit.WPF

Assembly : Newtone.ImageKit.WPFX.File.dll

See Also

Ftp Members


Ftp Members

Newtone.ImageKit.WPF.Ftp All Members

Ftp Overview

Public Constructor

Ftp Constructor Initializes a new instance of the Ftp class

Public Properties

Credentials | Provides the authentication information for the Ftp server
ErrorStatus | Retrieves the types of errors that can occur when using the Ftp control
Passive | Sets whether or not passive mode connectivity is enabled
Proxy | Sets the proxy information to access to the Ftp server
StatusCode | Sets the proxy information to access to the Ftp server
Timeout | Sets the timeout value for the given request

Public Methods

DeleteFile | Deletes the file from the FTP server with specified URI
DownloadFile | Downloads data from the FTP server with specified URI to local file
DownloadFileToByteArray | Downloads data from a file on the FTP server to a byte array
RenameFile | Renames a file at the specified URI
UploadByteArrayToFile | Uploads upload data in a byte array to a file on the FTP server
UploadFile | Uploads the existing file to the FTP server with specified URI

Public Events

Progress Generated when a file is being transferred

See Also

Ftp Class


ImageKit.Ftp Constructor

Newtone.ImageKit.WPF.Ftp Constructor

This constructor initializes a new instance of the Ftp class.

[Visual Basic] Public Sub New()
[C#] public Ftp()

See Also

Ftp Class | Ftp Members


Credentials property

Newtone.ImageKit.WPF.Ftp.Credentials Property

This property provides the authentication information for the request.

[Visual Basic] Public Property Credentials As System.Net.ICredentials
[C#] public System.Net.ICredentials Credentials {get; set;}

Property Value

System.Net.ICredentials contains the authentication information associated with the request.

The default value is null (in Visual Basic, Nothing).

Explanation

The Credentials property provides the authentication information for the request.

See Also

Ftp Class | Ftp Members


ErrorStatus property

Newtone.ImageKit.WPF.Ftp.ErrorStatus Property

This property retrieves the types of errors that can occur when using the Ftp control.

[Visual Basic] Public ReadOnly Property ErrorStatus As Newtone.ImageKit.Error
[C#] public Newtone.ImageKit.Error ErrorStatus {get;}

Property Value

Retrieve only

Explanation

The ErrorStatus property retrieves the types of errors that can occur when using the Ftp control.

This property refers to the members of the Error enum.

See Also

Ftp Class | Ftp Members


Passive property

Newtone.ImageKit.WPF.Ftp.Passive Property

This property sets whether or not passive mode connectivity is enabled.

[Visual Basic] Public Property Passive As Integer
[C#] public int Passive {get; set;}

Property Value

Value | Explanation
True | Passive mode connectivity
False | Active mode connectivity (default)

Explanation

The Passive property sets whether or not passive mode connectivity is enabled.

This property is refered to by executing the Download or UploadFile method.

See Also

Ftp Class | Ftp Members


Proxy property

Newtone.ImageKit.WPF.Ftp.Proxy Property

This property sets the proxy used to communicate with the Ftp server.

[Visual Basic]
Public Property Proxy As System.Net.IWebProxy
[C#]
public System.Net.IWebProxy Proxy {get; set;}

Property Value

The WebProxy instance used to communicate with the server. The default value is null (in Visual Basic, Nothing).

Explanation

The Proxy property sets the WebProxy instance that communicates with the FTP server. If a proxy server isn't used, please set null (in Visual Basic, Nothing).

See Also

Ftp Class | Ftp Members


StatusCode property

Newtone.ImageKit.WPF.Ftp.StatusCode Property

This property retrieves the FTP status value

[Visual Basic] Public Property StatusCode As System.Net.FtpStatusCode
[C#] public System.Net.FtpStatusCode StatusCode {get; set;}

Property Value

An System.Net.FtpStatusCode value

Explanation

The StatusCode property retrieves the FTP status value.

See Also

Ftp Class | Ftp Members


Timeout property

Newtone.ImageKit.WPF.Ftp.Timeout Property

This property sets the number of milliseconds before a request times out.

[Visual Basic]
Public Property Timeout As Integer
[C#]
public int Timeout {get; set;}

Property Value

The number of milliseconds to wait for a request. The default value is 60000 miliseconds.

Explanation

The Timeout property sets the number of milliseconds before a request times out.

See Also

Ftp Class | Ftp Members


DeleteFile method

Newtone.ImageKit.WPF.Ftp.DeleteFile Methods

This method deletes the file on the FTP server.

Overload list

This method deletes the file on the FTP server with specified URI.

[Visual Basic] Public Function DeleteFile(String) As Boolean
[C#] public bool DeleteFile(string)

This method deletes the file on the FTP server with specified URI.

[Visual Basic] Public Function DeleteFile(System.Uri) As Boolean
[C#] public bool DeleteFile(System.Uri)

This method deletes the file on the FTP server with specified host name and path name.

[Visual Basic] Public Function DeleteFile(String, String) As Boolean
[C#] public bool DeleteFile(string, string)

This method deletes the file on the FTP server with specified host name, path name and port number.

[Visual Basic] Public Function DeleteFile(String, String, Integer) As Boolean
[C#] public bool DeleteFile(string, string, int)

See Also

Ftp Class | Ftp Members


DeleteFile method

Newtone.ImageKit.WPF.Ftp.DeleteFile Method

This method deletes the file on the FTP server with specified URI.

[Visual Basic] Public Function DeleteFile(ByVal remoteAddress As String) As Boolean
[C#] public bool DeleteFile(string remoteAddress);

Parameters

remoteAddress
URI

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DeleteFile method deletes the file on the FTP server with specified URI.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = _ftp.DeleteFile("ftp://www.newtone.co.jp/test/test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = _ftp.DeleteFile("ftp://www.newtone.co.jp/test/test.jpg");

See Also

Ftp Class | Ftp Members


DeleteFile method

Newtone.ImageKit.WPF.Ftp.DeleteFile Method

This method deletes the file on the FTP server with specified URI.

[Visual Basic] Public Function DeleteFile(ByVal remoteAddress As System.Uri) As Boolean
[C#] public bool DeleteFile(System.Uri remoteAddress);

Parameters

remoteAddress
URI

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DeleteFile method deletes the file on the FTP server with specified URI.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = _ftp.DeleteFile(New Uri("ftp://www.newtone.co.jp/test/test.jpg"))

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp(); bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = _ftp.DeleteFile(new Uri("ftp://www.newtone.co.jp/test/test.jpg"));

See Also

Ftp Class | Ftp Members


DeleteFile method

Newtone.ImageKit.WPF.Ftp.DeleteFile Method

This method deletes the file on the FTP server with specified host name and path name.

[Visual Basic] Public Function DeleteFile(ByVal remoteHost As String, ByVal remotePath As String) As Boolean
[C#] public bool DeleteFile(string remoteHost, string remotePath);

Parameters

remoteHost
Domain name in DNS style, or IP Address
remotePath
The name of the remote path

Return Value

Returns True if successful. Returns False if successful.

Explanation

The DeleteFile method deletes the file on the FTP server with specified host name and path name.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = _ftp.DeleteFile("www.newtone.co.jp", "test/test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = _ftp.DeleteFile("www.newtone.co.jp", "test/test.jpg");

See Also

Ftp Class | Ftp Members


DeleteFile method

Newtone.ImageKit.WPF.Ftp.DeleteFile Method

This method deletes the file on the FTP server with specified host name, path name and port number.

[Visual Basic] Public Function DeleteFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal remotePort As Integer) As Boolean
[C#] public bool DeleteFile(string remoteHost, string remotePath, int remotePort);

Parameters

remoteHost
Domain name in DNS style, or IP address
remotePath
The name of the remote path
remotePort
IP port number

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DeleteFile method deletes the file on the FTP server with specified host name, path name and port number.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET] Dim _ftp As
New Newtone.ImageKit.WPF.Ftp Dim Ret
As Boolean 'Username and
password _ftp.Credentials = New NetworkCredential("user",
"password") 'Deletes the
file Ret = _ftp.DeleteFile("www.newtone.co.jp", "test/test.jpg",

21) [Visual
C#.NET] Newtone.ImageKit.WPF.Ftp _ftp = new
Newtone.ImageKit.WPF.Ftp(); bool
Ret; //Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = _ftp.DeleteFile("www.newtone.co.jp", "test/test.jpg", 21);

See Also

Ftp Class | Ftp Members


DownloadFile method

Newtone.ImageKit.WPF.Ftp.DownloadFile Methods

This method downloads data on the FTP server to a local file.

Overload list

This method downloads data on the FTP server with specified URI to a local file.

[Visual Basic] Public Function DownloadFile(String, String) As Boolean
[C#] public bool DownloadFile(string, string)

This method downloads data on the FTP server with specified URI to a local file.

[Visual Basic] Public Function DownloadFile(System.Uri, String) As Boolean
[C#] public bool DownloadFile(System.Uri, string)

This method downloads data on the FTP server with specified host name and path name to a local file.

[Visual Basic] Public Function DownloadFile(String, String, String) As Boolean
[C#] public bool DownloadFile(string, string, string)

This method downloads data on the FTP server with specified host name, path name and port number to a local file.

[Visual Basic] Public Function DownloadFile(String, String, Integer, String) As Boolean
[C#] public bool DownloadFile(string, string, int, string)

See Also

Ftp Class | Ftp Members


DownloadFile method

Newtone.ImageKit.WPF.Ftp.DownloadFile Method

This method downloads data on the FTP server with specified URI to a local file.

[Visual Basic] Public Function DownloadFile(ByVal remoteAddress As String, ByVal localFileName As String) As Boolean
[C#] public bool DownloadFile(string remoteAddress, string localFileName);

Parameters

remoteAddress
The URI of the file to be downloaded
localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DownloadFile method downloads data on the FTP server with specified URI to a local file.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
_ftp.Passive = True
'Downloads the file
Ret = _ftp.DownloadFile("ftp://www.newtone.co.jp/test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
_ftp.Passive = true;
//Downloads the file
Ret = _ftp.DownloadFile("ftp://www.newtone.co.jp/test/test.jpg", @"c:\test\test.jpg");

See Also

Ftp Class | Ftp Members


DownloadFile method

Newtone.ImageKit.WPF.Ftp.DownloadFile Method

This method downloads data on the FTP server with specified URI to a local file.

[Visual Basic] Public Function DownloadFile(ByVal remoteAddress As System.Uri, ByVal localFileName As String) As Boolean
[C#] public bool DownloadFile(System.Uri remoteAddress, string localFileName);

Parameters

remoteAddress
The URI of the file to be downloaded
localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DownloadFile method downloads data on the FTP server with specified URI to a local file.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
_ftp.Passive = True
'Downloads the file
Ret = _ftp.DownloadFile(New Uri("ftp://www.newtone.co.jp/test/test.jpg"), "c:\test\test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
_ftp.Passive = true;
//Downloads the file
Ret = _ftp.DownloadFile(new Uri("ftp://www.newtone.co.jp/test/test.jpg"), @"c:\test\test.jpg");

See Also

Ftp Class | Ftp Members


DownloadFile method

Newtone.ImageKit.WPF.Ftp.DownloadFile Method

This method downloads data on the FTP server with specified host name and path name to a local file.

[Visual Basic] Public Function DownloadFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal localFileName As String) As Boolean
[C#] public bool DownloadFile(string remoteHost, string remotePath, string localFileName);

Parameters

remoteHost
Domain name in DNS style, or IP address
remotePath
The name of the remote path
localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DownloadFile method downloads data on the FTP server with specified host name and path name to a local file.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
_ftp.Passive = True
'Downloads the file
Ret = _ftp.DownloadFile("www.newtone.co.jp", "test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
_ftp.Passive = true;
//Downloads the file
Ret = _ftp.DownloadFile("www.newtone.co.jp", "test/test.jpg", @"c:\test\test.jpg");

See Also

Ftp Class | Ftp Members


DownloadFile method

Newtone.ImageKit.WPF.Ftp.DownloadFile Method

This method downloads data on the FTP server with the specified host name, path name and port number to a local file.

[Visual Basic] Public Function DownloadFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal remotePort As Integer, ByVal localFileName As String) As Boolean
[C#] public bool DownloadFile(string remoteHost, string remotePath, int remotePort, string localFileName);

Parameters

remoteHost
Domain name in DNS style, or IP address
remotePath
The name of the remote path
remotePort
IP port number
localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DownloadFile method downloads data on the FTP server with the specified host name, path name and port number to a local file.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
_ftp.Passive = True
'Downloads the file
Ret = _ftp.DownloadFile("www.newtone.co.jp", "test/test.jpg", 21, "c:\test\test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
_ftp.Passive = true;
//Downloads the file
Ret = _ftp.DownloadFile("www.newtone.co.jp", "test/test.jpg", 21, @"c:\test\test.jpg");

See Also

Ftp Class | Ftp Members


FtpDownloadFileToByteArray method

Newtone.ImageKit.WPF.Ftp.DownloadFileToByteArray Method

These methods download data from a file on the server to a byte array.

List of overloaded methods

Downloads data in a byte array from the remote server specified by the URI.

[Visual Basic] Public Function FtpDownloadFileToByteArray(String) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(string)

Downloads data in a byte array from the remote server specified by the URI.

[Visual Basic] Public Function FtpDownloadFileToByteArray(System.Uri) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(System.Uri)

Downloads data in a byte array from the remote server specified by a host name and path.

[Visual Basic] Public Function FtpDownloadFileToByteArray(String, String) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(string, string)

Downloads data in a byte array from the remote server specified by a host name, path, and port number.

[Visual Basic] Public Function FtpDownloadFileToByteArray(String, String, Integer) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(string, string, int)

See Also

Ftp Class | Ftp Members


FtpDownloadFileToByteArray method

Newtone.ImageKit.WPF.Ftp.DownloadFileToByteArray Method

This method downloads a file on the remote server to a byte array

[Visual Basic] Public Function DownloadFileToByteArray(ByVal remoteAddress As String) As Byte()
[C#] public byte[] DownloadFileToByteArray(string remoteAddress);

Parameters

remoteAddress

The URI to the download file on the remote server

Return Value

Returns data in a byte array if successful, otherwise returns null (Nothing in Visual Basic)

Explanation

The DownloadFileToByteArray method downloads a file on the remote server to a byte array

This method is enabled for FTP protocol.

Example:

[Visual Basic.NET]

Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Data As Byte()
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Passive mode
_ftp.Passive = True
'Downloads the file to byte array
Data = _ftp.DownloadFileToByteArray("ftp://www.newtone.co.jp/test/test.jpg")

[Visual C#.NET]

Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
byte[] Data;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Passive mode
_ftp.Passive = true;
//Downloads the file to byte array
Data = _ftp.DownloadFileToByteArray("ftp://www.newtone.co.jp/test/test.jpg");

See Also

Ftp Class | Ftp Members

</html


DownloadFileToByteArray method

Newtone.ImageKit.WPF.Ftp.DownloadFileToByteArray Method

This method downloads a file on the remote server to a byte array

[Visual Basic] Public Function FtpDownloadFileToByteArray(ByVal remoteAddress As System.Uri) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(System.Uri remoteAddress);

Parameters

remoteAddress

The URI to the download file on the remote server

Return Value

Returns data in a byte array if successful, otherwise returns null (Nothing in Visual Basic)

Explanation

The FtpDownloadFileToByteArray method downloads a file on the remote server to a byte array

This method is enabled for FTP protocol.

Example

[Visual Basic.NET]

Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Data As Byte()
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Passive mode
_ftp.Passive = True
'Downloads the file to byte array
Data = _ftp.DownloadFileToByteArray(New Uri("ftp://www.newtone.co.jp/test/test.jpg"))

[Visual C#.NET]

Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
byte[] Data;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Passive mode
_ftp.Passive = true;
//Downloads the file to byte array
Data = _ftp.DownloadFileToByteArray(new Uri("ftp://www.newtone.co.jp/test/test.jpg"));

See Also

Ftp Class | Ftp Members


DownloadFileToByteArray method

meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
Newtone.ImageKit.Wpf

Newtone.ImageKit.WPF.Ftp.DownloadFileToByteArray Method

This method downloads data in a byte array from the remote server specified by a host name and path.

[Visual Basic] Public Function FtpDownloadFileToByteArray(ByVal remoteHost As String, ByVal remotePath As String) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(string remoteHost, string remotePath);

Parameters

remoteHost

DNS style name or IP Address

remotePath

Path on the remote server

Return Value

Returns data in a byte array if successful, otherwise returns null (Nothing in Visual Basic)

Explanation

The DownloadFileToByteArray method downloads data in a byte array from the remote server specified by a host name and path.

This method is enabled for FTP protocol.

Example

[Visual Basic.NET]

Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Data As Byte()
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Passive mode
_ftp.Passive = True
'Downloads the file to byte array
Data = _ftp.DownloadFileToByteArray("www.newtone.co.jp", "test/test.jpg")

[Visual C#.NET]

Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
byte[] Data;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Passive mode
_ftp.Passive = true;
//Downloads the file to byte array
Data = _ftp.DownloadFileToByteArray("www.newtone.co.jp", "test/test.jpg");

See Also

Ftp Class | Ftp Members


DownloadFileToByteArray method

Newtone.ImageKit.WPF.Ftp.DownloadFileToByteArray Method

This method downloads data in a byte array from the remote server specified by a host name, path, and port number.

[Visual Basic] Public Function FtpDownloadFileToByteArray(ByVal remoteHost As String, ByVal remotePath As String, ByVal remotePort As Integer) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(string remoteHost, string remotePath, int remotePort);

Parameters

remoteHost

DNS style name or IP Address

remotePath

Path on the remote server

remotePort

IP port number

Return Value

Returns True if successful, otherwise returns False

Explanation

The DownloadFileToByteArray method downloads data in a byte array from the remote server specified by a host name, path, and port number.

This method is enabled for FTP protocol.

Example

[Visual Basic.NET]

Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Data As Byte()
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Passive mode
_ftp.Passive = True
'Downloads the file to byte array
Data = _ftp.DownloadFileToByteArray("www.newtone.co.jp", "test/test.jpg", 21)

[Visual C#.NET]

byte[] Data;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Passive mode
ImageKit.File.FtpPassive = true;
//Downloads the file to byte array
Data = ImageKit.File.FtpDownloadFileToByteArray("www.newtone.co.jp", "test/test.jpg", 21);

See Also

Ftp Class | Ftp Members


RenameFile method

Newtone.ImageKit.WPF.Ftp.RenameFile Methods

This method renames the file on the FTP server.

Overload list

This method renames the file on the FTP server with specified URI.

[Visual Basic] Public Function RenameFile(String, String) As Boolean
[C#] public bool RenameFile(string, string)

This method renames the file on the FTP server with specified URI.

[Visual Basic] Public Function RenameFile(System.Uri, String) As Boolean
[C#] public bool RenameFile(System.Uri, string)

This method renames the file on the FTP server with specified host name and path name.

[Visual Basic] Public Function RenameFile(String, String, String) As Boolean
[C#] public bool RenameFile(string, string, string)

This method renames the file on the FTP server with specified host name, path name and port number.

[Visual Basic] Public Function RenameFile(String, String, Integer, String) As Boolean
[C#] public bool RenameFile(string, string, int, string)

See Also

Ftp Class | Ftp Members


RenameFile method

Newtone.ImageKit.WPF.Ftp.RenameFile Method

This method renames the file on the FTP server with specified URI.

[Visual Basic] Public Function RenameFile(ByVal remoteAddress As String, ByVal newRemotePath As String) As Boolean
[C#] public bool RenameFile(string remoteAddress, string newRemotePath);

Parameters

remoteAddress
URI
newRemotePath
The name of the new remoth path

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RenameFile method renames the file on the FTP server with specified URI.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Renames the file
Ret = _ftp.RenameFile("ftp://www.newtone.co.jp/test/test.jpg", "test/test1.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Renames the file
Ret = _ftp.RenameFile("ftp://www.newtone.co.jp/test/test.jpg", "test/test1.jpg");

See Also

Ftp Class | Ftp Members


RenameFile method

Newtone.ImageKit.WPF.Ftp.RenameFile Method

This method renames the file on the FTP server with specified URI.

[Visual Basic] Public Function RenameFile(ByVal remoteAddress As System.Uri, ByVal newRemotePath As String) As Boolean
[C#] public bool RenameFile(System.Uri remoteAddress, string newRemotePath);

Parameters

remoteAddress
URI
newRemotePath
The name of the new remote path

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RenameFile method renames the file on the FTP server with specified URI.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Renames the file
Ret = _ftp.RenameFile(New Uri("ftp://www.newtone.co.jp/test/test.jpg"), "test/test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Renames the file
Ret = _ftp.RenameFile(new Uri("ftp://www.newtone.co.jp/test/test.jpg"), "test/test1.jpg");

See Also

Ftp Class | Ftp Members


RenameFile method

Newtone.ImageKit.WPF.Ftp.RenameFile Method

This method renames the file on the FTP server with specified host name and path name.

[Visual Basic] Public Function RenameFile(ByVal remoteHost As String, ByVal oldRemotePath As String, ByVal newRemotePath As String) As Boolean
[C#] public bool RenameFile(string remoteHost, string oldRemotePath, string newRemotePath);

Parameters

remoteHost
Domain name in DNS style, or IP address
oldRemotePath
The old remote filename and path
newRemotePath
The new remote filename and path

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RenameFile method renames the file on the FTP server with specified host name and path name.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Renames the file
Ret = _ftp.RenameFile("www.newtone.co.jp", "test/test.jpg", "test/test1.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Renames the file
Ret = _ftp.RenameFile("www.newtone.co.jp", "test/test.jpg", "test/test1.jpg");

See Also

Ftp Class | Ftp Members


RenameFile method

Newtone.ImageKit.WPF.Ftp.RenameFile Method

This method renames the file on the FTP server with specified host name, path name and port number.

[Visual Basic] Public Function RenameFile(ByVal remoteHost As String, ByVal oldRemotePath As String, ByVal remotePort As Integer, ByVal newRemotePath As String) As Boolean
[C#] public bool RenameFile(string remoteHost, string oldRemotePath, int remotePort, string newRemotePath);

Parameters

remoteHost
Domain name in DNS style, or IP address
oldRemotePath
The old remote filename and path
remotePort
IP port number
newRemotePath
The new remote filename and path

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RenameFile method renames the file on the FTP server with specified host name, path name and port number.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Renames the file
Ret = _ftp.RenameFile("www.newtone.co.jp", "test/test.jpg", 21, "test/test1.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Renames the file
Ret = _ftp.RenameFile("www.newtone.co.jp", "test/test.jpg", 21, "test/test1.jpg");

See Also

Ftp Class | Ftp Members


UploadFile method

Newtone.ImageKit.WPF.Ftp.UploadFile Methods

This method uploads the existing file to the FTP server.

Overload list

This method uploads the existing file to the FTP server with specified URI.

[Visual Basic] Public Function UploadFile(String, String) As Boolean
[C#] public bool UploadFile(string, string)

This method uploads the existing file to the FTP server with specified URI.

[Visual Basic] Public Function UploadFile(System.Uri, String) As Boolean
[C#] public bool UploadFile(System.Uri, string)

This method uploads the existing file to the FTP server with specified host name and path name.

[Visual Basic] Public Function UploadFile(String, String, String) As Boolean
[C#] public bool UploadFile(string, string, string)

This method uploads the existing file to the FTP server with specified host name, path name and port number.

[Visual Basic] Public Function UploadFile(String, String, Integer, String) As Boolean
[C#] public bool UploadFile(string, string, int, string)

See Also

Ftp Class | Ftp Members


UploadFile method

Newtone.ImageKit.WPF.Ftp.UploadFile Method

This method uploads the existing file to the FTP server with specified URI.

[Visual Basic] Public Function UploadFile(ByVal remoteAddress As String, ByVal localFileName As String) As Boolean
[C#] public bool UploadFile(string remoteAddress, string localFileName);

Parameters

remoteAddress
The URI where the file is uploaded
localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The UploadFile method uploads the existing file to the FTP server with specified URI.

This method is effecitive for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
_ftp.Passive = True
'Uploads the file
Ret = _ftp.UploadFile("ftp://www.newtone.co.jp/test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
_ftp.Passive = true;
//Uploads the file
Ret = _ftp.UploadFile("ftp://www.newtone.co.jp/test/test.jpg", @"c:\test\test.jpg");

See Also

Ftp Class | Ftp Members


UploadFile method

Newtone.ImageKit.WPF.Ftp.UploadFile Method

This method uploads the existing file to the FTP server with specified URI.

[Visual Basic] Public Function UploadFile(ByVal remoteAddress As System.Uri, ByVal localFileName As String) As Boolean
[C#] public bool UploadFile(System.Uri remoteAddress, string localFileName);

Parameters

remoteAddress
The URI where the file will be uploaded
localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The UploadFile method uploads the existing file to the FTP server with specified URI.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
_ftp.Passive = True
'Uploads the file
Ret = _ftp.UploadFile(New Uri("ftp://www.newtone.co.jp/test/test.jpg"), "c:\test\test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
_ftp.Passive = true;
//Uploads the file
Ret = _ftp.UploadFile(new Uri("ftp://www.newtone.co.jp/test/test.jpg"), @"c:\test\test.jpg");

See Also

Ftp Class | Ftp Members


UploadFile method

Newtone.ImageKit.WPF.Ftp.UploadFile Method

This method uploads the existing file to the FTP server with specified host name and path name.

[Visual Basic] Public Function UploadFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal localFileName As String) As Boolean
[C#] public bool UploadFile(string remoteHost, string remotePath, string localFileName);

Parameters

remoteHost
Domain name in DNS style, or IP address
remotePath
The name of the remote path
localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The UploadFile method uploads the existing file to the FTP server with specified host name and path name.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
_ftp.Passive = True
'Uploads the file
Ret = _ftp.UploadFile("www.newtone.co.jp", "test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
_ftp.Passive = true;
//Uploads the file
Ret = _ftp.UploadFile("www.newtone.co.jp", "test/test.jpg", @"c:\test\test.jpg");

See Also

Ftp Class | Ftp Members


UploadFile method

Newtone.ImageKit.WPF.Ftp.UploadFile Method

This method uploads the existing file to the FTP server with specified host name, path name and port number.

[Visual Basic] Public Function UploadFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal remotePort As Integer, ByVal localFileName As String) As Boolean
[C#] public bool UploadFile(string remoteHost, string remotePath, int remotePort, string localFileName);

Parameters

remoteHost
Domain name in DNS style, or IP address
remotePath
The name of the remote path
remotePort
IP port number
localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The UploadFile method uploads the existing file to the FTP server with specified host name, path name and port number.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
_ftp.Passive = True
'Uploads the file
Ret = _ftp.UploadFile("www.newtone.co.jp", "test/test.jpg", 21, "c:\test\test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
_ftp.Passive = true;
//Uploads the file
Ret = _ftp.UploadFile("www.newtone.co.jp", "test/test.jpg", 21, @"c:\test\test.jpg");

See Also

Ftp Class | Ftp Members


Ftp.UploadByteArrayToFile Method

Newtone.ImageKit.WPF.Ftp.UploadByteArrayToFile Method

These methods upload data in a byte array to a file on the remote server.

List of overloaded methods

Uploads data in a byte array to a file on the remote server specified by the URI

[Visual Basic] Public Function FtpUploadByteArrayToFile(String, Byte()) As Boolean
[C#] public bool FtpUploadByteArrayToFile(string, byte[])

Uploads data in a byte array to a file on the remote server specified by the URI

[Visual Basic] Public Function FtpUploadByteArrayToFile(System.Uri, Byte()) As Boolean
[C#] public bool FtpUploadByteArrayToFile(System.Uri, byte[])

Uploads data in a byte array to a file on the remote server specified by a host name and path.

[Visual Basic] Public Function FtpUploadByteArrayToFile(String, String, Byte()) As Boolean
[C#] public bool FtpUploadByteArrayToFile(string, string, byte[])

Uploads data in a byte array to a file on the remote server specified by a host name, path, and port number.

[Visual Basic] Public Function FtpUploadByteArrayToFile(String, String, Integer, Byte()) As Boolean
[C#] public bool FtpUploadByteArrayToFile(string, string, int, byte[])

See Also

Ftp Class | Ftp Members


Ftp.UploadByteArrayToFile method

Newtone.ImageKit.WPF.Ftp.UploadByteArrayToFile Method

This method uploads data in a byte array to a file on the remote server specified by the URI

[Visual Basic] Public Function UploadByteArrayToFile(ByVal remoteAddress As String, ByVal data As Byte()) As Boolean
[C#] public bool UploadByteArrayToFile(string remoteAddress, byte[] data);

Parameters

remoteAddress

The Upload URI

data

Data in a byte array

Return Value

Returns True if successful, otherwise returns False

Explanation

The UploadByteArrayToFile method uploads data in a byte array to a file on the remote server specified by the URI

This method is enabled for FTP protocol.

Example

[Visual Basic.NET]

Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Passive mode
_ftp.Passive = Tru
Ret = _ftp.UploadByteArrayToFile("ftp://www.newtone.co.jp/test/test.jpg", data)

[Visual C#.NET]

Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Passive mode
_ftp.Passive = true;
Ret = _ftp.UploadByteArrayToFile("ftp://www.newtone.co.jp/test/test.jpg", data);

See Also

Ftp Class | Ftp Members


FtpUploadByteArrayToFile Method

Newtone.ImageKit.WPF.Ftp.UploadByteArrayToFile Method

This method uploads data in a byte array to a file on the remote server specified by a URI.

[Visual Basic] Public Function UploadByteArrayToFile(ByVal remoteAddress As System.Uri, ByVal data As Byte()) As Boolean
[C#] public bool UploadByteArrayToFile(System.Uri remoteAddress, byte[] data);

Parameters

remoteAddress

The upload Uri

data

The data in byte array

Return Value

Returns True if successful, otherwise returns False

Explanation

The UploadByteArrayToFile method uploads data in a byte array to a file on the remote server specified by a URI.

The method is enabled for FTP protocol.

Example

[Visual Basic.NET]

Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Passive mode
_ftp.Passive = True
Ret = _ftp.UploadByteArrayToFile(New Uri("ftp://www.newtone.co.jp/test/test.jpg"), data)

[Visual C#.NET]

Ret = _ftp.UploadByteArrayToFile(New Uri("ftp://www.newtone.co.jp/test/test.jpg"), data)
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Passive mode
_ftp.Passive = true;
Ret = _ftp.UploadByteArrayToFile(new Uri("ftp://www.newtone.co.jp/test/test.jpg"), data);

See Also

Ftp Class | Ftp Members


FtpUploadByteArrayToFile method

Newtone.ImageKit.WPF.Ftp.UploadByteArrayToFile Method

This method uploads a byte array to a file on the remote server specified by a host name and path.

[Visual Basic] Public Function UploadByteArrayToFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal data As Byte()) As Boolean
[C#] public bool UploadByteArrayToFile(string remoteHost, string remotePath, byte[] data);

Parameters

remoteHost

DNS style domain name or IP address

remotePath

Path to the file on the remote server

data

Data in byte array

Return Value

Returns True if successful, otherwise returns False

Explanation

The UploadByteArrayToFile method uploads a byte array to a file on the remote server specified by a host name and path.

This method is enabled for FTP protocol.

Example

[Visual Basic.NET]

Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Passive mode
_ftp.Passive = True
Ret = _ftp.UploadByteArrayToFile("www.newtone.co.jp", "test/test.jpg", data)

[Visual C#.NET]

Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Passive mode
_ftp.Passive = true;
Ret = _ftp.UploadByteArrayToFile("www.newtone.co.jp", "test/test.jpg", data);

See Also

Ftp Class | Ftp Members


Ftp.UploadByteArrayToFile method

Newtone.ImageKit.WPF.Ftp.UploadByteArrayToFile Method

This method uploads data in a byte array to a file on the remote server specified by a host name, path, and port number.

[Visual Basic] Public Function UploadByteArrayToFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal remotePort As Integer, ByVal data As Byte()) As Boolean
[C#] public bool UploadByteArrayToFile(string remoteHost, string remotePath, int remotePort, byte[] data);

Parameters

remoteHost

DNS style domain name or IP Address

remotePath

Remote path to file on the server

remotePort

IP port number

data

Data in byte array

Return Value

Returns True if successful, otherwise returns False

Explanation

The UploadByteArrayToFile method uploads data in a byte array to a file on the remote server specified by a host name, path, and port number.

This method is enabled for FTP protocol.

Example

[Visual Basic.NET]

Dim _ftp As New Newtone.ImageKit.WPF.Ftp
Dim Ret As Boolean
'Username and password
_ftp.Credentials = New NetworkCredential("user", "password")
'Passive mode
_ftp.Passive = True
Ret = _ftp.UploadByteArrayToFile("www.newtone.co.jp", "test/test.jpg", 21, data)

[Visual C#.NET]

Newtone.ImageKit.WPF.Ftp _ftp = new Newtone.ImageKit.WPF.Ftp();
bool Ret;
//Username and password
_ftp.Credentials = new NetworkCredential("user", "password");
//Passive mode
_ftp.Passive = true;
Ret = _ftp.UploadByteArrayToFile("www.newtone.co.jp", "test/test.jpg", 21, data);

See Also

Ftp Class | Ftp Members


Progress event

Newtone.ImageKit.WPF.Ftp.Progress Event

This event is generated when a file is being transferred.

[Visual Basic] Public Event Progress As ProgressEventHandler
[C#] public event ProgressEventHandler Progress;

Explanation

The event handler receives arguments of type ProgressEventArgs

This event is generated when executing the DownloadFile, DownloadFileToByteArray, UploadByteArrayToFile, and UploadFile methods.

To cancel the process, set the Cancel property of the ProgressEventHandler to true.

See Also

Ftp Class | Ftp Members


Http class

Newtone.ImageKit.WPF.Http Class

This class accesses data to the http or https protocol.

For a list of all members of this type, see Http Members.

System.Object
Newtone.ImageKit.WPF
public class Http : Object

Explanation

This class provides the functionalities to uploads and downloads the files.
Note This class supports URI starting with the scheme extension, "http:" or "https:".

Requirements

Namespace : Newtone.ImageKit.WPF

Assembly : Newtone.ImageKit.WPFX.File.dll

See Also

Http Members


Http Members

Newtone.ImageKit.WPF.Http All Members

Http Overview

Public Constructor

Http Constructor Initializes a new instance of the Http class

Public Properties

Credentials | Provides the authentication information for the request
ErrorStatus | Retrieves the types of errors that can occur when using the Http control
Headers | Sets or retrieves the Http Header name-value pair collection from the request
Method | Sets the Http method for the request.
Proxy | Sets the proxy information to access to the internet resources
StatusCode | Retrieves the Http status value
Timeout | Sets the timeout value for the given request
UserAgent | Sets or retrieves the User-Agent Http header

Public Methods

DeleteFile | Deletes the file on the Http server with specified URI
DownloadFile | Downloads data on the Http server with specified URI to a local file
DownloadFileToByteArray | Downloads a file to byte array from the remote server
UploadFile | Uploads the file to the Http server with specified URI
UploadByteArrayToFile | Uploads data in a byte array to a file on the remote server

Public Event

Progress Generated when the file is being transferred.

See Also

Http Class


ImageKit.Http Constructor

Newtone.ImageKit.WPF.Http Constructor

This constructor initializes a new instance of the Http class.

[Visual Basic] Public Sub New()
[C#] public Http()

See Also

Http Class | Http Members


Credentials property

Newtone.ImageKit.WPF.Http.Credentials Property

This property provides the authentication information for the request.

[Visual Basic] Public Property Credentials As System.Net.ICredentials
[C#] public System.Net.ICredentials Credentials {get; set;}

Property Value

System.Net.ICredentials contains the authentication information associated with the request.

The default value is null (in Visual Basic, Nothing).

Explanation

The Credentials property provides the authentication information for the request.

See Also

Http Class | Http Members


ErrorStatus property

Newtone.ImageKit.WPF.Http.ErrorStatus Property

This property retrieves the types of errors that can occur when using the Http control.

[Visual Basic] Public ReadOnly Property ErrorStatus As Newtone.ImageKit.WPF.Error
[C#] public Newtone.ImageKit.WPF.Error ErrorStatus {get;}

Property Value

Retrieve only

Explanation

The ErrorStatus property retrieves the types of errors that can occur when using the Http control.

This property refers to the members of the Error enum.

See Also

Http Class | Http Members


Headers property

Newtone.ImageKit.WPF.Http.Headers Property

This property sets or retrieves the Http Header name-value pair collection from the request.

[Visual Basic] Public Property Headers As System.Net.WebHeaderCollection
[C#] public System.Net.WebHeaderCollection Headers {get; set;}

Property Value

The Http Header name-value pair collection

Explanation

The Headers property sets or retrieves the Http Header's name-value pair collection from the request. Set this property prior to executing the UploadFile or UploadByteArrayToFile methods.

NOTE: When setting this property the only recognized values are "Content-Disposition" and "Cookie"

See Also

Http Class | Http Members


Method property

Newtone.ImageKit.WPF.Http.Method Property

This property sets the Http method for the request.

[Visual Basic] Public Property Method As String
[C#] public string Method {get; set;}

Property Value

Values of "POST" and "PUT" may be set.

The default value is null (Nothing in Visual Basic)

Explanation

The Method property sets the Http method for the request. Before executing the UploadFile or the UploadByteArrayToFile methods, please set this property to "POST" or "PUT".

See Also

Http Class | Http Members


Proxy property

Newtone.ImageKit.WPF.Http.Proxy Property

This property sets the proxy used to communicate with the Http server.

[Visual Basic]
Public Property Proxy As IWebProxy
[C#]
public IWebProxy Proxy {get; set;}

Property Value

The WebProxy instance used to communicate with the server. The default value is null (in Visual Basic, Nothing).

Explanation

The Proxy property sets the WebProxy instance that communicates with the HTTP server. If a proxy server isn't used, please set null (in Visual Basic, Nothing)

See Also

Http Class | Http Members


Http.StatusCode property

Newtone.ImageKit.WPF.Http.StatusCode Property

This property retrieves the Http status value

[Visual Basic] Public Property StatusCode As System.Net.HttpStatusCode
[C#] public System.Net.HttpStatusCode StatusCode {get; set;}

Property Value

An HttpStatusCode value

Explanation

The StatusCode property retrieves the Http status value.

See Also

Http Class | Http Members


Timeout property

Newtone.ImageKit.WPF.Http.Timeout Property

This property sets the number of milliseconds before a request times out.

[Visual Basic] Public Property Timeout As Integer
[C#] public int Timeout {get; set;}

Property Value

he number of milliseconds to wait for a request. The default value is 60000 miliseconds.

Explanation

The Timeout property sets the number of milliseconds before a request times out.

See Alsp

Http Class | Http Members


Http.UserAgent property

Newtone.ImageKit.WPF.Http.UserAgent Property

This property sets or retrieves the User-Agent Http header.

[Visual Basic] Public Property UserAgent As String
[C#] public string UserAgent {get; set;}

Property Value

The User-agent HTTP header value. Default is null (Nothing in Visual Basic)

See Also

Http Class | Http Members


DeleteFile method

Newtone.ImageKit.WPF.Http.DeleteFile Methods

This method deletes the file on the Http server.

Overload list

This method deletes the file on the Http server with specified URI.

[Visual Basic] Public Function DeleteFile(String) As Boolean
[C#] public bool DeleteFile(string)

This method deletes the file on the Http server with specified URI.

[Visual Basic] Public Function DeleteFile(System.Uri) As Boolean
[C#] public bool DeleteFile(System.Uri)

This method deletes the file on the Http server with specified scheme, host name and path name.

[Visual Basic] Public Function DeleteFile(String, String, String) As Boolean
[C#] public bool DeleteFile(string, string, string)

See Also

Http Class | Http Members


DeleteFile method

Newtone.ImageKit.WPF.Http.DeleteFile Method

This method deletes the file on the Http server with specified URI.

[Visual Basic] Public Function DeleteFile(ByVal remoteAddress As String) As Boolean
[C#] public bool DeleteFile(string remoteAddress);

Parameters

remoteAddress
URI

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DeleteFile method deletes the file on the Http server with specified URI.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim _http As New Newtone.ImageKit.WPF.Http
Dim Ret As Boolean
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = _http.DeleteFile("http://www.newtone.co.jp/test/test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
bool Ret;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = _http.DeleteFile("http://www.newtone.co.jp/test/test.jpg");

See Also

Http Class | Http Members


DeleteFile method

Newtone.ImageKit.WPF.Http.DeleteFile Method

This method deletes the file on the Http server with specified URI.

[Visual Basic] Public Function DeleteFile(ByVal remoteAddress As System.Uri) As Boolean
[C#] public bool DeleteFile(System.Uri remoteAddress);

Parameters

remoteAddress
URI

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DeleteFile method deletes the file on the Http server with specified URI.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim _http As New Newtone.ImageKit.WPF.Http
Dim Ret As Boolean
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = _http.DeleteFile(New Uri("http://www.newtone.co.jp/test/test.jpg"))

[Visual C#.NET]
Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
bool Ret;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = _http.DeleteFile(new Uri("http://www.newtone.co.jp/test/test.jpg"));

See Also

Http Class | Http Members


DeleteFile method

Newtone.ImageKit.WPF.Http.DeleteFile Method

This method deletes the file on the Http server with specified scheme, host name and path name.

[Visual Basic] Public Function DeleteFile(ByVal scheme As String, ByVal remoteHost As String, ByVal remotePath As String) As Boolean
[C#] public bool DeleteFile(string scheme, string remoteHost, string remotePath);

Parameters

scheme
Internet access protocol ("http" or "https")
remoteHost
Domain name in DNS style, or IP address
remotePath
The name of the remote path

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DeleteFile method deletes the file on the Http server with specified scheme, host name and path name.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim _http As New Newtone.ImageKit.WPF.Http
Dim Ret As Boolean
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = _http.DeleteFile("http", "www.newtone.co.jp", "test/test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
bool Ret;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = _http.DeleteFile("http", "www.newtone.co.jp", "test/test.jpg");

See Also

Http Class | Http Members


DownloadFile method

Newtone.ImageKit.WPF.Http.DownloadFile Methods

This method downloads data on the Http server to a local file.

Overload list

This method downloads data on the Http server with specified URI to a local file.

[Visual Basic] Public Function DownloadFile(String, String) As Boolean
[C#] public bool DownloadFile(string, string)

This method downloads data on the Http server with specified URI to a local file.

[Visual Basic] Public Function DownloadFile(System.Uri, String) As Boolean
[C#] public bool DownloadFile(System.Uri, string)

This method downloads data on the Http server with specified scheme, host name and path name to a local file.

[Visual Basic] Public Function DownloadFile(String, String, String, String) As Boolean
[C#] public bool DownloadFile(string, string, string, string)

See Also

Http Class | Http Members


DownloadFile method

Newtone.ImageKit.WPF.Http.DownloadFile Method

This method downloads data on the Http server with specified URI to a local file.

[Visual Basic] Public Function DownloadFile(ByVal remoteAddress As String, ByVal localFileName As String) As Boolean
[C#] public bool DownloadFile(string remoteAddress, string localFileName);

Parameters

remoteAddress
The URI of the file on the server to be downloaded
localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DownloadFile method downloads data on the Http server with specified URI to a local file.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim _http As New Newtone.ImageKit.WPF.Http
Dim Ret As Boolean
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'Downloads the file
Ret = _http.DownloadFile("http://www.newtone.co.jp/test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
bool Ret;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//Downloads the file
Ret = _http.DownloadFile("http://www.newtone.co.jp/test/test.jpg", @"c:\test\test.jpg");

See Also

Http Class | Http Members


DownloadFile method

Newtone.ImageKit.WPF.Http.DownloadFile Method

This method downloads data on the Http server with specified URI to a local file.

[Visual Basic] Public Function DownloadFile(ByVal remoteAddress As System.Uri, ByVal localFileName As String) As Boolean
[C#] public bool DownloadFile(System.Uri remoteAddress, string localFileName);

Parameters

remoteAddress
The URI of the file on the server to be downloaded
localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DownloadFile method downloads data on the Http server with specified URI to a local file.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim _http As New Newtone.ImageKit.WPF.Http
Dim Ret As Boolean
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'Downloads the file
Ret = _http.DownloadFile(New Uri("http://www.newtone.co.jp/test/test.jpg"), "c:\test\test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
bool Ret;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//Downloads the file
Ret = _http.DownloadFile(new Uri("http://www.newtone.co.jp/test/test.jpg"), @"c:\test\test.jpg");

See Also

Http Class | Http Members


DownloadFile method

Newtone.ImageKit.WPF.Http.DownloadFile Method

This method downloads data on the Http server to a local file using the specified scheme, host name and path name.

[Visual Basic]
Public Function DownloadFile(ByVal scheme As String, ByVal remoteHost As String, ByVal remotePath As String, ByVal localFileName As String) As Boolean
[C#]
public bool DownloadFile(string scheme, string remoteHost, string remotePath, string localFileName);

Parameters

scheme
Internet access protocol ("http" or "https")

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DownloadFile method downloads data on the Http server to a local file using the specified scheme, host name and path name.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim _http As New Newtone.ImageKit.WPF.Http
Dim Ret As Boolean
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'Downloads the file
Ret = _http.DownloadFile("http", "www.newtone.co.jp", "test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
bool Ret;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//Downloads the file
Ret = _http.DownloadFile("http", "www.newtone.co.jp", "test/test.jpg", @"c:\test\test.jpg");

See Also

Http Class | Http Members


DownloadFileToByteArray method

Newtone.ImageKit.WPF.Http.DownloadFileToByteArray Method

These methods download a file to byte array from the remote server.

List of overloaded methods

Downloads a file to byte array from the remote server specified by the URI

[Visual Basic] Public Function DownloadFileToByteArray(String) As Byte()
[C#] public byte[] DownloadFileToByteArray(string)

Downloads a file to byte array from the remote server specified by the URI

[Visual Basic] Public Function DownloadFileToByteArray(System.Uri) As Byte()
[C#] public byte[] DownloadFileToByteArray(System.Uri)

Downloads a file to byte array from the remote server specified by a scheme, host name, and path.

[Visual Basic] Public Function DownloadFileToByteArray(String, String, String) As Byte()
[C#] public byte[] DownloadFileToByteArray(string, string, string)

See Also

Http Class | Http Members


DownloadFileToByteArray method

Newtone.ImageKit.WPF.Http.DownloadFileToByteArray Method

This method downloads a file to byte array from the remote server specified by the URI

[Visual Basic] Public Function DownloadFileToByteArray(ByVal remoteAddress As String) As Byte()
[C#] public byte[] DownloadFileToByteArray(string remoteAddress);

Parameters

remoteAddress

The URI to the download file on the remote server

Return Value

Returns data in a byte array if successful, otherwise returns null (Nothing in Visual Basic)

Explanation

The DownloadFileToByteArray method downloads a file to byte array from the remote server specified by the URI.

This method is enabled for HTTP or HTTPS protocol.

Example

[Visual Basic.NET]

Dim _http As New Newtone.ImageKit.WPF.Http
Dim Data As Byte()
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'Downloads file
Data = _http.DownloadFileToByteArray("http://www.newtone.co.jp/test/test.jpg")

[Visual C#.NET]

Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
byte[] Data;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//Downloads file
Data = _http.DownloadFileToByteArray("http://www.newtone.co.jp/test/test.jpg");

See Also

Http Class | Http Members


DownloadFileToByteArray method

Newtone.ImageKit.WPF.Http.DownloadFileToByteArray Method

This method downloads a file to byte array from the remote server specified by the URI

[Visual Basic] Public Function DownloadFileToByteArray(ByVal remoteAddress As System.Uri) As Byte()
[C#] public byte[] DownloadFileToByteArray(System.Uri remoteAddress);

Parameters

remoteAddress

The URI to the download file on the remote server

Return Value

Returns data in a byte array if successful, otherwise returns null (Nothing in Visual Basic)

Explanation

The DownloadFileToByteArray method downloads a file to byte array from the remote server specified by the URI.

This method is enabled for HTTP or HTTPS protocol.

Example

[Visual Basic.NET]

Dim _http As New Newtone.ImageKit.WPF.Http
Dim Data As Byte()
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'Downloads file
Data = _http.DownloadFileToByteArray(New Uri("http://www.newtone.co.jp/test/test.jpg"))

[Visual C#.NET]

Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
byte[] Data;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//Downloads file
Data = _http.DownloadFileToByteArray(new Uri("http://www.newtone.co.jp/test/test.jpg"));

See Also

Http Class | Http Members


DownloadFileToByteArray method

Newtone.ImageKit.WPF.Http.DownloadFileToByteArray Method

This method downloads a file to byte array from the remote server specified by a scheme, host name, and path.

[Visual Basic] Public Function DownloadFileToByteArray(ByVal scheme As String, ByVal remoteHost As String, ByVal remotePath As String) As Byte()
[C#] public byte[] DownloadFileToByteArray(string scheme, string remoteHost, string remotePath);

Parameters

scheme

Internet Access Protocol ("http" or "https")

remoteHost

DNS style domain name or IP address

remotePath

Remote server name

Return Value

Returns data in a byte array if successful, otherwise returns null (Nothing in Visual Basic)

Explanation

The DownloadFileToByteArray method downloads a file to byte array from the remote server specified by a scheme, host name, and path.

This method is enabled for HTTP or HTTPS protocol.

Example:

[Visual Basic.NET]

Dim _http As New Newtone.ImageKit.WPF.Http
Dim Data As Byte()
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'Download file
Data = _http.DownloadFileToByteArray("http", "www.newtone.co.jp", "test/test.jpg")

[Visual C#.NET]

Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
byte[] Data;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//Download file
Data = _http.DownloadFileToByteArray("http", "www.newtone.co.jp", "test/test.jpg");

See Also

Http Class | Http Members


UploadFile method

Newtone.ImageKit.WPF.Http.UploadFile Methods

This method uploads the file to the Http server.

Overload list

This method uploads the file to the Http server with specified URI.

[Visual Basic] Public Function UploadFile(String, String) As Boolean
[C#] public bool UploadFile(string, string)

This method uploads the file to the Http server with specified URI.

[Visual Basic] Public Function UploadFile(System.Uri, String) As Boolean
[C#] public bool UploadFile(System.Uri, string)

This method uploads the file to the Http server with specified scheme, host name and path name.

[Visual Basic] Public Function UploadFile(String, String, String, String) As Boolean
[C#] public bool UploadFile(string, string, string, string)

See Also

Http Class | Http Members


UploadFile method

Newtone.ImageKit.WPF.Http.UploadFile Method

This method uploads the file to the Http server with specified URI.

[Visual Basic] Public Function UploadFile(ByVal remoteAddress As String, ByVal localFileName As String) As Boolean
[C#] public bool UploadFile(string remoteAddress, string localFileName);

Parameters

remoteAddress
The URI where the file is to be uploaded
localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The UploadFile method uploads the file to the Http server with specified URI.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim _http As New Newtone.ImageKit.WPF.Http
Dim Ret As Boolean
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'Uploads the file
Ret = _http.UploadFile("http://www.newtone.co.jp/test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
bool Ret;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//Uploads the file
Ret = _http.UploadFile("http://www.newtone.co.jp/test/test.jpg", @"c:\test\test.jpg");

See Also

Http Class | Http Members


UploadFile method

Newtone.ImageKit.WPF.Http.UploadFile Method

This method uploads the file to the Http server with specified URI.

[Visual Basic] Public Function UploadFile(ByVal remoteAddress As System.Uri, ByVal localFileName As String) As Boolean
[C#] public bool UploadFile(System.Uri remoteAddress, string localFileName);

Parameters

remoteAddress
The URI where the file is to be uploaded
localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The UploadFile method uploads the file to the Http server with specified URI.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim _http As New Newtone.ImageKit.WPF.Http
Dim Ret As Boolean
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'Uploads the file
Ret = _http.UploadFile(New Uri("http://www.newtone.co.jp/test/test.jpg"), "c:\test\test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
bool Ret;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//Uploads the file
Ret = _http.UploadFile(new Uri("http://www.newtone.co.jp/test/test.jpg"), @"c:\test\test.jpg");

See Also

Http Class | Http Members


UploadFile method

Newtone.ImageKit.WPF.Http.UploadFile Method

This method uploads the file to the Http server with specified scheme, host name and path name.

[Visual Basic] Public Function UploadFile(ByVal scheme As String, ByVal remoteHost As String, ByVal remotePath As String, ByVal localFileName As String) As Boolean
[C#] public bool UploadFile(string scheme, string remoteHost, string remotePath, string localFileName);

Parameters

scheme
Internet access protocol ("http" or "https")
remoteHost
Domain name in DNS style, or IP address
remotePath
The name of the remote path
localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The UploadFile method uploads the file to the Http server with specified scheme, host name and path name.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim _http As New Newtone.ImageKit.WPF.Http
Dim Ret As Boolean
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'Uploads the file
Ret = _http.UploadFile("http", "www.newtone.co.jp", "test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
bool Ret;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//Uploads the file
Ret = _http.UploadFile("http", "www.newtone.co.jp", "test/test.jpg", @"c:\test\test.jpg");

See Also

Http Class | Http Members


UploadByteArrayToFile method

Newtone.ImageKit.WPF.Http.UploadByteArrayToFile Method

These methods upload data in a byte array to a file on the remote server.

List of overloaded methods

Uploads data in a byte array to a file on the remote server specified by the URI

[Visual Basic] Public Function HttpUploadByteArrayToFile(String, Byte()) As Boolean
[C#] public bool HttpUploadByteArrayToFile(string, byte[])

Uploads data in a byte array to a file on the remote server specified by the URI

[Visual Basic] Public Function HttpUploadByteArrayToFile(System.Uri, Byte()) As Boolean
[C#] public bool HttpUploadByteArrayToFile(System.Uri, byte[])

Uploads data in a byte array to a file on the remote server specified by a scheme, host name, and path.

[Visual Basic] Public Function HttpUploadByteArrayToFile(String, String, String, String) As Boolean
[C#] public bool HttpUploadByteArrayToFile(string, string, string, string)

See Also

Http Class | Http Members


UploadByteArrayToFile method

Newtone.ImageKit.WPF.Http.UploadByteArrayToFile Method

This method uploads data in a byte array to a file on the remote server specified by the URI

[Visual Basic] Public Function UploadByteArrayToFile(ByVal remoteAddress As String, ByVal data As Byte()) As Boolean
[C#] public bool UploadByteArrayToFile(string remoteAddress, byte[] data);

Parameters

remoteAddress

Upload URI

data

Data in byte array

Return Value

Returns True if successful, otherwise returns False

Explanation

The UploadByteArrayToFile method uploads data in a byte array to a file on the remote server specified by the URI

This method is enabled for HTTP or HTTPS protocol.

Example

[Visual Basic.NET]

Dim _http As New Newtone.ImageKit.WPF.Http
Dim Ret As Boolean
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'When using "POST"
_http.Method = "POST"
_http.Headers.Set("Content-Disposition", "form-data; name=""file""; filename=""test.jpg""")
Ret = _http.UploadByteArrayToFile(New Uri("http://www.newtone.co.jp/test/upload.php"), data)
'When using "PUT"
'_http.Method = "PUT"
'Ret = _http.UploadByteArrayToFile(New Uri("http://www.newtone.co.jp/test/test.jpg"), data)

[Visual C#.NET]

Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
bool Ret;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//When using "POST"
_http.Method = "POST";
_http.Headers.Set("Content-Disposition", "form-data; name=\"file\"; filename=\"test.jpg\"");
Ret = _http.UploadByteArrayToFile(new Uri("http://www.newtone.co.jp/test/upload.php"), data);
//When using "PUT"
//_http.Method = "PUT";
//Ret = _http.UploadByteArrayToFile(new Uri("http://www.newtone.co.jp/test/test.jpg"), data);

See Also

Http Class | Http Members


UploadByteArrayToFile method

Newtone.ImageKit.WPF.Http.UploadByteArrayToFile Method

This method uploads data in a byte array to a file on the remote server specified by the URI

[Visual Basic] Public Function UploadByteArrayToFile(ByVal remoteAddress As System.Uri, ByVal data As Byte()) As Boolean
[C#] public bool UploadByteArrayToFile(System.Uri remoteAddress, byte[] data);

Parameters

remoteAddress

Upload URI

data

Data in byte array

Return Value

Returns True if successful, otherwise returns False

Explanation

The UploadByteArrayToFile method uploads data in a byte array to a file on the remote server specified by the URI

This method is enabled for HTTP or HTTPS protocol.

Example

[Visual Basic.NET]

Dim _http As New Newtone.ImageKit.WPF.Http
Dim Ret As Boolean
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'When using "POST"
_http.Method = "POST"
_http.Headers.Set("Content-Disposition", "form-data; name=""file""; filename=""test.jpg""")
Ret = _http.UploadByteArrayToFile(New Uri("http://www.newtone.co.jp/test/upload.php"), data)
'When using "PUT"
'_http.Method = "PUT"
'Ret = _http.UploadByteArrayToFile(New Uri("http://www.newtone.co.jp/test/test.jpg"), data)

[Visual C#.NET]

Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
bool Ret;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//When using "POST"
_http.Method = "POST";
_http.Headers.Set("Content-Disposition", "form-data; name=\"file\"; filename=\"test.jpg\"");
Ret = _http.UploadByteArrayToFile(new Uri("http://www.newtone.co.jp/test/upload.php"), data);
//When using "PUT"
//_http.Method = "PUT";
//Ret = _http.UploadByteArrayToFile(new Uri("http://www.newtone.co.jp/test/test.jpg"), data);

See Also

Http Class | Http Members


UploadByteArrayToFile method

Newtone.ImageKit.WPF.Http.UploadByteArrayToFile Method

This method uploads data in a byte array to a file on the remote server specified by a scheme, host name, and path.

[Visual Basic] Public Function UploadByteArrayToFile(ByVal scheme As String, ByVal remoteHost As String, ByVal remotePath As String, ByVal ByVal data As Byte()) As Boolean
[C#] public bool UploadByteArrayToFile(string scheme, string remoteHost, string remotePath, byte[] data);

Parameters

scheme

Internet Access Protocol ("http" or "https")

remoteHost

DNS style domain name or IP address

remotePath

The upload path on the remote server

data

Data in byte array

Return Value

Returns True if successful, otherwise returns False

Explanation

The UploadByteArrayToFile method uploads data in a byte array to a file on the remote server specified by a scheme, host name, and path.

This method is enabled for HTTP or HTTPS protocol.

Example

[Visual Basic.NET]

Dim _http As New Newtone.ImageKit.WPF.Http
Dim Ret As Boolean
'Username and password
_http.Credentials = New NetworkCredential("user", "password")
'When using "POST"
_http.Method = "POST"
_http.Headers.Set("Content-Disposition", "form-data; name=""file""; filename=""test.jpg""")
Ret = _http.UploadByteArrayToFile("http", "www.newtone.co.jp", "test/upload.php", data)
'When using "PUT"
'_http.Method = "PUT"
'Ret = _http.UploadByteArrayToFile("http", "www.newtone.co.jp", "test/test.jpg", data)

[Visual C#.NET]

Newtone.ImageKit.WPF.Http _http = new Newtone.ImageKit.WPF.Http();
bool Ret;
//Username and password
_http.Credentials = new NetworkCredential("user", "password");
//When using "POST"
_http.Method = "POST";
_http.Headers.Set("Content-Disposition", "form-data; name=\"file\"; filename=\"test.jpg\"");
Ret = _http.UploadByteArrayToFile("http", "www.newtone.co.jp", "test/upload.php", data);
//When using "PUT"
//_http.Method = "PUT";
//Ret = _http.UploadByteArrayToFile("http", "www.newtone.co.jp", "test/test.jpg", data);

See Also

Http Class | Http Members


Progress event

Newtone.ImageKit.WPF.Http.Progress Event

This event is generated when the file is being transferred.

[Visual Basic] Public Event Progress As ProgressEventHandler
[C#] public event ProgressEventHandler Progress;

Explanation

The event handler receives arguments of type ProgressEventArgs.

This event is generated when the DownloadFile, DownloadFileToByteArray, UploadByteArrayToFile and UploadFile methods are executed.

To cancel the process, set the Cancel property of the ProgressEventHandler to true.

See Also

Http Class | Http Members


OCR class

Newtone.ImageKit.WPF.OCR Class

This class accesses OCR functionality.

For a list of all members of this type, see OCR Members.

System.Object
Newtone.ImageKit.WPF
public class OCR : Object

Explanation

This class is used to convert an image of text, read by a scanner or digital camera, into text data.

If executing the OCR functions in a language that is not supported by your environment, you will need to install the language package and then add that language to Windows under "Settings - Time and Language - Language and Region".

The minimum size of an image that can be read is 40 x 40 pixels and the maximum is 2600 x 2600 pixels, respectively.

Requirements

Namespace : Newtone.ImageKit.WPF

Assembly : Newtone.ImageKit.WPF.OCR.dll

Framework: .NET Framework 4.5 or higher

See Also

OCR Members


OCR Members

Newtone.ImageKit.WPF.OCR All Members

OCR Overview

Public Constructor

OCR Constructor Initializes a new instance of the OCR class

Public Properties

ErrorStatus | Get the type of error that occurred using the OCR class library.
Language | Sets the language used for text recognition
OutText | Obtains the string converted to text by the ImageToText method

Public Methods

ImageToText Converts the image containing text characters into text data

Public Events

GetOCRText Generated after the OCR process is complete

See Also

OCR Class


ImageKit.OCR Constructor

Newtone.ImageKit.WPF

Newtone.ImageKit.WPF.OCR Constructor

This constructor initializes a new instance of the OCR class.

[Visual Basic] Public Sub New()
[C#] public OCR()

See Also

OCR Class | OCR Members


ErrorStatus property

Newtone.ImageKit.WPF

Newtone.ImageKit.WPF.OCR.ErrorStatus Property

This property gets the type of error that occurred using the OCR class library.

[Visual Basic]
Public ReadOnly Property ErrorStatus As Error
[C#]
public Error ErrorStatus {get;}

Property Value

Retrieve value of type Error

Explanation

The ErrorStatus property retrieves the type of Error that occurred using the OCR class library.

See Also

OCR Class | OCR Members


Language property

Newtone.ImageKit.WPF

Newtone.ImageKit.WPF.OCR.Language Property

This property sets the language used for text recognition.

[Visual Basic]
Public Property Language As String
[C#]
public string Language {get; set;}

Property Value

BCP-47 Language Tag

Explanation

The Language property sets the language used for text recognition. This property value indicates the language used for text recognition when converting image data to text using the ImageToText method. The value is a BCP-47 language tag (e.g., "ja", "en", "zh", etc.)

If executing the OCR functions in a language that is not supported by your environment, you will need to install the language package and then add that language to Windows under "Settings - Time and Language - Language and Region".

See Also

OCR Class | OCR Members


OutText property

Newtone.ImageKit.WPF

Newtone.ImageKit.WPF.OCR.OutText Property

This property obtains the string converted to text by the ImageToText method.

[Visual Basic]
Public Property OutText As String
[C#]
public string OutText {get;}

Property Value

The converted text string

Explanation

The OutText property obtains the string converted to text by the ImageToText method. When the ImageToText method executes, the GetOCRText event fires. The image data is converted to text data within this event and once the event completes, the resulting text data is set into the OutText property. For this reason, there may be a slight delay before the text data is obtained by the OutText while the OCR process converts image data into text data.

The OutText property acquires the complete text data when the GetOCRText event completes. If you want to get the result immediately after the ImageToText method has executed, retrieve it within the GetOCRText event.

See Also

OCR Classs | OCR Members


ImageToText Method

Newtone.ImageKit.WPF

Newtone.ImageKit.WPF.OCR.ImageToText Method

This method converts the image containing text characters into text data.

[Visual Basic]
Public Sub ImageToText()
[C#]
public void ImageToText();

Return Value

None

Explanation

The ImageToText method converts the image containing text characters into text data. The resulting text data is set into the OutText property.

NOTE: The text data will be set into the OutText property after the GetOCRText event has completed. For this reason, there may be a slight delay while the OCR process is occurring within the GetOCRText event before the text data is set into the OutText property. If you wish to obtain the text data immediately after the ImageToText method is executed, retrieve it within the GetOCRText event.

If the method fails, the OutText property is set to "".

If executing the OCR functions in a language that is not supported by your environment, you will need to install the language package and then add that language to Windows under "Settings - Time and Language - Language and Region".

The minimum size of an image that can be read is 40 x 40 pixels and the maximum is 2600 x 2600 pixels, respectively.

Example

[C#]
public MainWindow()
{
InitializeComponent();

objOCR = new OCR();
objOCR.GetOcrText += OCR_Event;
}

public void OCR_Event(object sender, OCREventArgs e)
{
textBlock.Text = e.OcrText;
}

private void button1_Click(object sender, RoutedEventArgs e)
{
objOCR.Language = "ja";
objOCR.ImageToText(imagekit.Image);
}

See Also

OCR Class | OCR Members


GetOCRText Event

Newtone.ImageKit.WPF

Newtone.ImageKit.WPF.OCR.GetOCRText Event

This event is generated after the OCR process is complete.

[Visual Basic]
Public Event GetOCRText As OCREventHandler
[C#]
public event OCREventHandler GetOCRText

Event Data

The event handler receives arguments of type OCREventArgs.

Explanation

Within the GetOCRText event, the created text can be referenced by an argument of type OCREventArgs.

Example Code

[C#]
public MainWindow()
{
InitializeComponent();

objOCR = new OCR();
objOCR.GetOcrText += OCR_Event;
}

public void OCR_Event(object sender, OCREventArgs e)
{
textBlock.Text = e.OcrText;
}

private void button1_Click(object sender, RoutedEventArgs e)
{
objOCR.Language = "ja";
objOCR.ImageToText(imagekit.Image);
}

See Also

OCR Class | OCR Members


Scan class

Newtone.ImageKit.WPF.Scan Class

This class retrieved data from TWAIN supported scan devices.

For a list of all members of this type, see Scan Members.

System.Object
Newtone.ImageKit.WPF
public class Scan : Object

Explanation

This class enables image data to be retrieved from TWAIN scan devices. Supported capabilities of TWAIN devices can also be retrieved.

IMPORTANT:
On a 64 bit operating system, make sure your TWAIN scan driver supports 64 bit when using a target platform of AnyCpu or x64!

Requirements

Namespace : Newtone.ImageKit.Wpf

Assembly : Newtone.ImageKit.WPFX.Scan.dll

See Also

Scan Members


Scan Members

Newtone.ImageKit.WPF.Scan All Members

Scan Overview

Public Constructor

Scan Constructor Initializes a new instance of the Scan class

Public Properties

AdjustGamma | Sets the Gamma coefficient.
AutoBright | Sets whether or not automatic brightness is enabled.
BitDepth | Sets the number of bits per pixel in the scanned image
BitDepthReduction | Sets the method used to reduce the bit depth when scanning in 1 bit color
Border | Removes the black borders, formed during scanning or copying, from around the images
BorderColor | Sets the color used during border correction
BorderDetection | Enables automatic border detection
Brightness | Sets the scan brightness
ColorBWRatio | Sets the allowable ratio of color pixels in a document for the scanner to scan in black and white
Compression | Sets the compression method used when an image is transferred via memory
ContainerType | Retrieves the container type of Capability specified
Contrast | Sets the scan contrast
Count | Retrieves the number of scanned images
CurrentIndex | Retrieves the index of the current value
DataSourceName | Sets the name of the scan device
DefaultIndex | Retrieves the index of the default value
DllFileName | Sets the TWAIN Dll filename
Deskew | Sets whether or not deskew is enabled
DllFileName | Sets the name of the TWAIN Dll file to be used
DropoutColor | Sets the dropout color
DynamicThreshold | Sets the dynamic threshold level
ErrorStatus | Refers to the type of error
ExtendedUserInterface | Sets whether or not the extended user interface is used
FileFormat | Sets the file format when saving a file using file transfer.
FileName | Sets the file name when saving a file using file transfer or using memory transfer with compression
FocusPosition | Sets the focus position
Gamma | Sets the gamma correction
Halftone | Sets the halftone
Highlight | Sets the scanning highlight
IgnoreBackColor | Sets whether or not the background color of the document is ignored when automatically determining whether to scan in black and white or in color
ImageFilter | Sets the image filter
ImageMerge | Sets the double sided merge mode
Indicator | Sets whether or not the indicator is displayed when scanning
InformationFileName | Sets the information file where the scan settings, set in the scan manufacturer's scan driver interface, are saved
JpegQuality | Sets the JpegQuality when using file or memory transfer with JPEG compression
Mode | Sets the scanning mode
MoireFilter | Sets the level for the Moire filter
NoiseFilter | Sets the noise reduction filter
Orientation | Sets the orientation of the paper
OverScan | Enables "over scan" capabilities enlarging the scan area
PageCount | Sets the number of images to be scanned
PaperSize | Sets the size of the paper
PixelType | Sets the type of image scanned
Rect | Sets the scanning position
RemoveHole | Sets whether or not hole removal is performed
RotateBack | Sets whether or not the back side of the page is rotated when scanning on both sides using an ADF
Rotation | Sets the rotation angle for the scanned image
ScanningSpeed | Increases the speed at which a document is scanned
Shadow | Sets the shadow
Sharpness | Sets the level of sharpness
SkipBlankPage | Sets whether or not a blank page will be skipped.
SkipBlankThreshold | Sets the threshold value to determine if a blank page is included with pages to be scanned and whether that blank page should be skipped
TextEnhancement | Sets the type of text enhancement used
Threshold | Sets the scanning threshold
Transfer | Sets whether native, file, or memory transfer is used
Unit | Sets the units of measurement
UserInterface | Sets whether the scan driver's user interface is used or if a custom built user interface is used
Value | Retrieves the value supported for the specified capability
XResolution | Sets the horizontal scan resolution
XScaling | Sets the horizontal scaling (magnification)
YResolution | Sets the vertical scan resolution
YScaling | Sets the vertical scaling (magnification)

Public Methods

ClearProperty | Resets the scan control properties
CloseDataSource | Closes the scan device
Execute | Retrieves an image from a TWAIN scan device
GetBitDepth | Retrieves the bit depth supported by the scan device
GetCapabilityEnumToSingle | Retrieves the possible setting values for a specified property of the scan device
GetCapabilityEnumToString | Retrieves the possible setting values for a specified property of the scan device
GetCapabilityRange | Retrieves the range of possible setting values for a specified functionality of the scan device
GetCurrentDataSource | Retrieves information about the scan device currently being selected
GetDataSources | Retrieves information about the specified scan device
GetMinimumSize | Retrieves the smallest size that can be scanned with a given scan device
GetPhysicalSize | Retrieves the largest physical size that can be scanned with a given scan device
Initialize | Starts the TWAIN process
IsCapabilitySupported | Confirms whether or not a functionality is supported by the scan device
IsOpenDataSource | Checks whether or not the scan device is open
OpenDataSource | Opens the scan device
SelectDataSource | Selects the scan device
Terminate | Ends the TWAIN process

Public Events

AfterScan | Generated after an image is scanned with the scan device
BeforeScan | Generated just before an image is scanned with the scan device
Scanning | Generated when an image is being scanned by the scan device

See Also

Scan Class


ImageKit.Scan Constructor

Newtone.ImageKit.WPF.Scan Constructor

This initializes a new instance of the Scan class.

[Visual Basic] Public Sub New()
[C#] public Scan()

See Also

Scan Class | Scan Members


AdjustGamma property

Newtone.ImageKit.WPF.Scan.AdjustGamma Property

This property sets the Gamma coefficient. (UserInterface=Suppress)

[Visual Basic] Public WriteOnly Property AdjustGamma As Integer
[C#] public int AdjustGamma {set;}

Property Values

0: Gamma Coefficient is 1.0

1: Gamma Coefficient is 1.8

The default value is 0

Explanation

The AdjustGamma property sets the Gamma coefficient. This property is enabled for certain Epson scanners. Setting this property to 1 makes the scanned image brighter.

This property is enabled when the UserInterface property is set to Suppress. To find out if your datasource supports gamma adjustment, please refer to the IsCapabilitySupported method.

See Also

Scan Class | Scan Members


AutoBright property

Newtone.ImageKit.WPF.Scan.AutoBright Property

This property sets whether the automatic brightness adjustment is enabled. (UserInterface=Suppress)

[Visual Basic] Public Property AutoBright As Boolean
[C#] public bool AutoBright {get; set;}

Property Values

True: Brightness is automatically adjusted

False: Brightness adjustment is manual

The default value is False

Explanation

The AutoBright property sets whether the automatic brightness adjustment is enabled. When true, brightness is adjusted automatically. When false or when this capability is not supported, the Brightness property will be enabled.

This property is enabled when the UserInterface property is set to Suppress. To find out if your datasource supports AutoBright, please refer to the IsCapabilitySupported method or the GetCapabilityEnumToSingle method.

See Also

Scan Class | Scan Members


BitDepth property

Newtone.ImageKit.WPF.Scan.BitDepth Property

This property sets the number of bits per pixel in the scanned image.

[Visual Basic]Public Property BitDepth As Integer
[C#]public int BitDepth {get; set;}

Property Value

When the PixelType property is BW, the BitDepth is 1

When the PixelType property is Gray, the BitDepth is 4, 8, 12, 14, or 16

When the PixelType property is RGB, the BitDepth is 24, 36, 42, or 48

When the PixelType property is Palette, the BitDepth is 4 or 8

When the PixelType property is Automation, the BitDepth is 24

Retrieve only

Explanation

The BitDepth property sets the number of bits per pixel in the scanned image. This property is only enabled when the UserInterface property is Suppress. Note: If a digital camera image or other scan device does not support this functionality, then this property is disabled.

To retrieve the range of possible bit depth settings for a scan device, execute the GetBitDepth method. When scanning in 12, 14, 16, 36, 42, or 48 bit color, please set the Transfer property to Memory. If an error is returned for a value that the scan device is supposed to support, please set 0 into the BitDepth property in which case the bit depth default value indicated by the PixelType property will be used.

See Also

Scan Class | Scan Members


BitDepthReduction property

Newtone.ImageKit.WPF.Scan.BitDepthReduction Property

This property sets the method used to reduce the bit depth when scanning in 1 bit color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property BitDepthReduction As Newtone.ImageKit.WPF.ScanBitDepthRedution
[C#]public Newtone.ImageKit.WPF.ScanBitDepthRedution BitDepthReduction {set;}

Property Value

This value is of enum type ScanBitDepthReduction

Explanation

The BitDepthReduction property sets the method used to reduce the bit depth when scanning in 1 bit color. This property is enabled when the UserInterface property is Suppress and the PixelType property is BW. Note: The BitDepthReduction property is disabled when using a digital camera.

When the BitDepthReduction property is Threshold, the Threshold property is enabled (In some scan devices the Brightness property is enabled). When the BitDepthReduction property is Halftone, the HalfTone, Brightness, and Contrast properties are enabled.

To retrieve the value of the BitDepthReduction property that is supported by the scan device, please execute the GetCapabilityEnumToSingle method. In the case where the scan device does not support the BitDepthReduction functionality, but supports either Threshold or HalfTone, then set this property to Threshold or Halftone whichever the case may be.

See Also

Scan Class | Scan Members


Border property

Newtone.ImageKit.WPF.Scan.Border Property

This property removes the black borders, formed during scanning or copying, from around the images. This property is only enabled when using a custom-built user interface (UserInterface= 2).

[Visual Basic] Public Property Border As Integer
[C#] public int Border {get; set;}

Property Value

Epson Scan Driver (Border Correction for Epson scanners is called "Edge Fill")

Value | Explanation
0 | Border correction is not used
1 | Border correction is used

Panasonic Scan Driver (Border Removal)

Value | Explanation
0 | Border is not removed
1 | Border is removed - automatic mode (Detects the edges of the document area and corrects to the width specified)
2 | Border is removed - fixed mode (Corrects uniformly from the edges of the image to the width specified)

Default value is 0.

Explanation

The Border property removes the black borders, formed during scanning or copying, from around the images and is enabled for Epson and Panasonic scan drivers only. This property sets whether or not border correction is used. For Epson scanners, border correction is known as "Edge Fill". For Panasonic scanners border correction is known as "Border Removal".

If the Border property is 1 or more, then the color set in the BorderColor property is used as the fill color.

The Border property is enabled with the UserInterface property is set to Suppress. To check whether or not border correction is supported, please refer to the IsCapabilitySupported method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


BorderColor property

Newtone.ImageKit.WPF.Scan.BorderColor Property

This property sets the color used during border correction. This property is only enabled when using a custom-built user interface (UserInterface= 2).

[Visual Basic] Public Property BorderColor As Integer
[C#] public int BorderColor {get; set;}

Property Value

Epson Scan Driver (Border Correction for Epson scanners is called "Edge Fill")

Value | Explanation
0 | White
1 | Black

Panasonic Scan Driver (Border Removal)

Value | Explanation
0 | Document border color used (the color of the area near the edge of the document)
1 | Document background color used
2 | White

Default value is 0.

Explanation

The Border property sets the color used during border correction. It is enabled for Epson and Panasonic scan drivers only.

If the Border property is 1 or more, then the color set in the BorderColor property is used as the fill color.

The BorderColor property is enabled with the UserInterface property is set to Suppress.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


BorderDetection property

Newtone.ImageKit.WPF.Scan.BorderDetection Property

This property enables automatic border detection. This property is only enabled when using a custom-built user interface (UserInterface= 2).

[Visual Basic]Public WriteOnly Property BorderDetection As Boolean
[C#]public bool BorderDetection {set;}

Property Value

Value | Explanation
True | Automatic border detection is enabled
False | Automatic border detection is disabled

Explanation

The BorderDetection property enables automatic border detection. The document plate scan area will automatically be set according to paper size. This property is only enabled when the UserInterface property is Suppress and the PaperSize property is UndefinedSize (or values of 1000 or more). Note: If a digital camera image or other scan device does not support this functionality, then this property is disabled. To find out if the datasource supports this functionality, please execute the IsCapabilitySupported method.

See Also

Scan Class | Scan Members


Brightness property

Newtone.ImageKit.WPF.Scan.Brightness Property

This property sets the scan brightness. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).
[Visual Basic] Public WriteOnly Property Brightness As Integer
[C#] public int Brightness {set;}

Property Value

From -1000 to 1000 (default value is 0)

For Fujitsu PFU scan devices, when the PixelType property is Automation, GrayAndBW, or RGBAndBW, the value range for Brightness is from -127 to 127.

Explanation

The Brightness property sets the scan brightness. This property is only enabled when the UserInterface property is Suppress and the AutoBright property is set to false.

Note: There are cases when the PixelType property is BW, and depending on the BitDepthReduction property value the Brightness property has no affect. See below.

The Brightness property is okay

When PixelType = BW and the BitDepthReduction = Threshold (*) or Halftone.

When the PixelType = Gray, RGB, or Palette
(*) This is used with the datasource where the function of the threshold is refered to by brightness (ex. the data source that does not support Threshold)

Note: This property is disabled for digital cameras and scanners that do not support these functions. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method or the GetCapabilityRange method.

See Also

Scan Class | Scan Members


ColorBWRatio property

Newtone.ImageKit.WPF.Scan.ColorBWRatio Property

This property sets the allowable ratio of color pixels in a document for the scanner to scan in black and white. Beyond this value, the scanner will scan in rgb color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property ColorBWRatio As Single
[C#]public float ColorBWRatio {set;}

Property Value

The value range is from 0.01 to 50.00 in percentage units.

Default value is 1.

Explanation

The ColorBWRatio property is useful in determining whether or not to scan in RGB color or black and white. This property sets the allowable ratio of color pixels in a document for the scanner to scan in black and white. Beyond this value, the scanner will scan in rgb color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

ENABLED FOR PANASONIC SCAN DRIVERS ONLY

The default value is one, meaning that the scanner will scan in rgb color. The allowable range that can be set in the ColorBWRatio property is from 0.01 to 50.00 percent. As the value of this property increases, a larger proportion of pixels in the document must be color before the scanner will scan in rgb color. This property is only enabled when the UserInterface property is Suppress, and the PixelType property is Automation.

See Also

Scan Class | Scan Members


Compression property

Newtone.ImageKit.WPF.Scan.Compression Property

This property sets the compression method used when an image is transferred via memory.

[Visual Basic]Public Property Compression As Newtone.ImageKit.WPF.ScanCompression
[C#]public Newtone.ImageKit.WPF.ScanCompression Compression {get; set;}

Property Value

This value is of enum type ScanCompression

Explanation

The Compression property sets the compression method used when an image is transferred via memory. When scanning with a custom user interface (with the scan driver's user interface suppressed), be sure to set appropriate values in the PixelType and the BitDepth properties. For example, Tiff group 3 or 4 compression images must be 1 bit black and white; JPEG compression images must be either 8 bit grayscale or 24 bit color.

For details about the different methods for transferring images, please refer to the Transfer property. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. Depending on the datasource, uncompressed may be the only file transfer compression method available.

See Also

Scan Class | Scan Members


ContainerType property

Newtone.ImageKit.WPF.Scan.ContainerType Property

This property retrieves the container type of Capability specified.

[Visual Basic] Public ReadOnly Property ContainerType As Integer
[C#] public int ContainerType {get;}

Property Value

Value | Explanation
0 | Failed method
3 | Array Type
4 | Enumeration Type
5 | Single Type
6 | Range Type

Explanation

The ContainerType property retrieves the type of container for Capability specified. By executing the GetCapabilityEnumToSingle, GetCapabilityEnumToString, and GetCapabilityRange, the values are set in this property.

See Also

Scan Class | Scan Members


Brightness property

Newtone.ImageKit.WPF.Scan.Contrast Property

This property sets the scan contrast. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Contrast As Integer
[C#] public int Contrast {set;}

Property Value

From -1000 to 1000 (default value is 0)

For Fujitsu PFU scan devices, when the PixelType property is Automation, GrayAndBW, or RGBAndBW, the value range for Contrast is from -127 to 127.

Explanation

The Contrast property sets the scan contrast. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

Note: There are cases when the PixelType property is BW and depending on the BitDepthReduction property value the Contrast property has no affect. See below.

The Contrast property is okay

When PixelType = BW and the BitDepthReduction = Halftone.

When the PixelType = Gray, RGB, or Palette

Note: This property is disabled for digital cameras and scanners that do not support these functions. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method or the GetCapabilityRange method.

See Also

Scan Class | Scan Members


Count property

Newtone.ImageKit.WPF.Scan.Count Property

This property retrieves the number of scanned images.
[Visual Basic] Public ReadOnly Property Count As Integer
[C#] public int Count {get;}

Property Value

The number of scanned images

Explanation

The Count property retrieves the number of scanned images. After executing the Execute method, the value is set in this property.

See Also

Scan Class | Scan Members


CurrentIndex property

Newtone.ImageKit.WPF.Scan.CurrentIndex Property

This property retrieves the index of the current value.

[Visual Basic] Public ReadOnly Property CurrentIndex As Integer
[C#] public int CurrentIndex {get;}

Property Value

The index of the current value

Explanation

The CurrentIndex property retrieves the index of the current value. When the GetCapabilityEnumToSingle method, theGetCapabilityEnumToString method, or the GetDataSources method is executed, the retrieved values are set in an array. This property retrieves the index in the array that refers to the current value. If any of the above methods fail, -1 will be set in the CurrentIndex property.

See Also

Scan Class | Scan Members


DataSourceName property

Newtone.ImageKit.WPF.Scan.DataSourceName Property

This property sets the name of the scan device. This property is only enabled when using a custom-built user interface (UerInterface=Suppress).

[Visual Basic]Public Property DataSourceName As String
[C#]public string DataSourceName {set;}

Property Value

The name of the scan device

Explanation

The DataSourceName property sets the name of the scan device. This property is only enabled when using a custom-built user interface (UerInterface=Suppress). The DataSourceName property must be set prior to executing the OpenDataSource or the Execute methods. However, if the Execute method is executed after the OpenDataSource method then the DataSourceName property value will be disregarded. If the DataSourceName property is not set, the scan device selected by the SelectDataSource method will be used.

See Also

Scan Class | Scan Members


DefaultIndex property

Newtone.Win.ImageKit

Newtone.ImageKit.WPF.Scan.DefaultIndex Property

This property retrieves the index of the default value

[Visual Basic] Public ReadOnly Property DefaultIndex As Integer
[C#] public int DefaultIndex {get;}

Property Value

This property retrieves the index of the default value

Explanation

When the GetCapabilityEnumToSingle method or the GetCapabilityEnumToString method are executed the values are returned in an array. The DefaultIndex property retrieves the index that refers to the default value. If the above methods fail, -1 will be set in this property.

See Also

Scan Class | Scan Members


DllFileName property

Newtone.ImageKit.WPF.Scan.DllFileName Property

This property sets the TWAIN Dll filename.

[Visual Basic] Public Property DllFileName As String
[C#] public string DllFileName {get; set;}

Property Value

The TWAIN Dll filename

Explanation

The DllFileName property sets the filename for the TWAIN Dll. If your application is a 32 bit application that uses the twain_32.dll (Windows Folder) or if the application is a 64 bit application that uses the 64 bit TWAINDSM.dll (Windows\System32 Folder), then it is not necessary to set the filename in the DllFileName property. The ImageKit will use these TWAIN DLL files by default. However if your 32 bit application uses the 32 bit TWAINDSM.dll file, then you must set that file name into DllFileName property.

For the DllFileName property to take effect, please set this prior to executing the Initialize method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Deskew property

Newtone.ImageKit.WPF.Scan.Deskew Property

This method sets whether or not deskew is enabled. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property Deskew As Integer
[C#]public int Deskew {set;}

Property Value

Value | Explanation
0 | Deskew is disabled
1 | Deskew is enabled
2 | Deskew is enabled (with smoothing)

Explanation

The Deskew method sets whether or not deskew is enabled when scanning. This property is only enabled when the UserInterface property is Suppress. Note: If a digital camera image or other scan device does not support this functionality, then this property is disabled. The Deskew property is enabled when the PaperSize property is set to UndefinedSize (or values of 1000 or more). However, there are cases, depending on the datasource, when the Deskew property is enabled for other paper sizes as well.

Deskew with smoothing is only available for certain Panasonic scan drivers (memory transfer uncompressed mode only).

To find out if the datasource supports this functionality, please execute the IsCapabilitySupported method.

See Also

Scan Class | Scan Members


DropoutColor property

Newtone.ImageKit.WPF.Scan.DropoutColor Property

This Property sets the dropout color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property DropoutColor As Newtone.ImageKit.WPF.ScanDropoutColor
[C#]public Newtone.ImageKit.WPF.ScanDropoutColor DropoutColor {set;}

Property Value

This value is of enum type ScanDropoutColor

Explanation

The DropoutColor property sets the dropout color. This property is only enabled when the UserInterface property is Suppress, and the PixelType property is either BW or Gray. Note: If a digital camera image or other scan device does not support this functionality, then this property is disabled. To disable the dropout color, please set this property to None or White. To find out if the datasource supports this functionality, please execute the GetCapabilityEnumToSingle method.

See Also

Scan Class | Scan Members


DynamicThreshold property

Newtone.ImageKit.WPF.Scan.DynamicThreshold Property

This method sets the dynamic threshold level. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property DynamicThreshold As Integer
[C#]public int DynamicThreshold {set;}

Property Value

Value | Explanation
0 | None
1 | Bright
2 | A little brighter
3 | Standard
4 | A little darker
5 | Dark

Explanation

The DynamicThreshold property sets the dynamic threshold level.

DynamicThreshold is only available on certain Panasonic scan drivers

Dyanamic threshold functionality allows you to scan text and images clearly with optimum quality. This property is enabled when the UserInterface property is Suppress and PixelType property is BW. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. When setting the DynamicThreshold property to 1 or more, then the values set in the BitDepthReduction, HalfTone, Sharpness , and Threshold properties will be disabled.

See Also

Scan Class | Scan Members


ErrorStatus property

Newtone.ImageKit.WPF.Scan.ErrorStatus Property

This property refers to the types of errors that can occur when using the Scan control.

[Visual Basic] Public ReadOnly Property ErrorStatus As Newtone.ImageKit.Error
[C#] public Newtone.ImageKit.Error ErrorStatus{get;}

Property Value

Read only

Explanation

The values are of type Error.

See Also

Scan Class | Scan Members


ExtendedUserInterface property

Newtone.ImageKit.WPF.Scan.ExtendedUserInterface Property

This property sets whether or not the extended user interface is used.

[Visual Basic]Public WriteOnly Property ExtendedUserInterface As Integer
[C#]public int ExtendedUserInterface {set;}

Property Value

Value | Explanation
0 | Start up the UserInterface mode that was last used
1 | Start up the professional mode
2 | Start up the automatic mode
3 | Start up the home mode
4 | Start up the automatic mode (with no error messages and supressed UI)
5 | Start up office mode

Explanation

The ExtendedUserInterface property sets whether or not the extended user interface is used.

Extended UserInterface mode is available only for certain Epson scan drivers

The ExtendedUserInterface property settings are only possible when displayed with the standard "EPSON Scan" user interface. For example: In ES Series, all settings except 2 and 4 are possible. In the GT Series, all settings except 5 is possible when not connected to the ADF but if the ADF is connected then settings 2 or 4 are also not possible. The ExtendedUserInterface property is enabled when the UserInterface property is Show or ShowandClose. To retrieve the value supported by your datasource, execute the GetCapabilityEnumToSingle method.

See Also

Scan Class | Scan Members


FileFormat property

Newtone.ImageKit.WPF.Scan.FileFormat Property

This property sets the file format when saving a file using file transfer.

[Visual Basic]Public Property FileFormat As Newtone.ImageKit.WPF.ScanFileFormat
[C#]public Newtone.ImageKit.WPF.ScanFileFormat FileFormat {get; set;}

Property Value

This value is of type ScanFileFormat

Explanation

The FileFormat property sets the file format when saving a file using file transfer. Please set at appropriate value in the Compression property for the file format set here. Note that depending on the datasource, only uncompressed mode is possible when using file transfer. To retrieve the values supported by the datasource, please execute the GetCapabilityEnumToSingle method.

See Also

Scan Class | Scan Members


FileName property

Newtone.ImageKit.WPF.Scan.FileName Property

This property sets the file name when saving a file using file transfer or using memory transfer with compression.

[Visual Basic]Public WriteOnly Property FileName As String
[C#]public string FileName {set;}

Property Value

The file name of the saved file

Explanation

The FileName property sets the file name when saving a file using file transfer or using memory transfer with compression. When the Transfer property is File or Memory and the Compression property is set to values other than None then the file will be saved according to the FileName property. (up to 255 bytes). If the FileName property is set with an empty string, null, or Nothing then the file cannot be saved. When using file transfer mode the a FileName property MUST be set. When the UserInterface property is Suppress and the Mode property is DocumentPlate, the file will be saved according to the FileName property. However, for other settings, a four digit series of numbers will be added just before the file extention. (i.e. Image.bmp will be Image0001.bmp).

See Also

Scan Class | Scan Members


FocusPosition property

Newtone.ImageKit.WPF.Scan.FocusPosition Property

This property sets the focus position of the scan. (UserInterface= Suppress)

[Visual Basic] Public WriteOnly Property FocusPosition As Integer
[C#]public int FocusPosition {set;}

Propery Value

Focal Position
Default value is 0.

Explanation

The FocusPosition property adjusts the focus position of the scan. This property is enabled when using Epson scanners.

Value ranges vary from one scanner to another and are in units of 0.1 mm. For example to move the focus position by 1 mm, set a value of 10 in this property.

The FocusPosition property is enabled when the UserInterface property is set to Suppress. To get information on whether or not the datasource supports focus position, use the GetCapabilityRange method.

See Also

Scan Class | Scan Members


Gamma property

Newtone.ImageKit.WPF.Scan.Gamma Property

This property sets the gamma correction. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property Gamma As Single
[C#]public float Gamma {set;}

Property Value

The default value is 2.2.

Explanation

The Gamma property sets the gamma correction for the scan. This property is enabled when the UserInterface property is Suppress. However, the Gamma property is disabled when using a digital camera or when the datasource does not support this functionality. To retrieve the values supported, please execute the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Class | Scan Members


Halftone property

Newtone.ImageKit.WPF.Scan.Halftone Property

This property sets the halftone. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property Halftone As String
[C#]public string Halftone {set;}

Property Value

The halftone name

Explanation

The HalfTone property sets the halftone. This property is enabled when the UserInterface property is Suppress, the PixelType property is BW, and the BitDepthReduction property is Halftone. However, the Halftone property is disabled when using a digital camera or when the datasource does not support this functionality. To retrieve the values supported, please execute the GetCapabilityEnumToString method.

See Also

Scan Class | Scan Members


Highlight property

Newtone.ImageKit.WPF.Scan.Highlight Property

This property sets the scanning highlight. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property Highlight As Integer
[C#]public int Highlight {set;}

Property Value

From 0 to 255

The Highlight property sets the highlight. (Default value is 255)

Explanation

The Highlight property sets the scanning highlight. This property is enabled when the UserInterface property is Suppress and the PixelType property value is other than BW. However, the Highlight property is disabled when using a digital camera or when the datasource does not support this functionality. To retrieve the values supported, please execute the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.WPF.Scan


IgnoreBackColor property

Newtone.ImageKit.WPF.Scan.IgnoreBackColor Property

This property sets whether or not the background color of the document is ignored when automatically determining whether to scan in black and white or in color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property IgnoreBackColor As Boolean
[C#]public bool IgnoreBackColor {set;}

Property Value

Value | Explanation
True | Ignore the back color
False | Does not ignore the back color (Default)

Explanation

The IgnoreBackColor property sets whether or not the background color of the document is ignored when automatically determining whether to scan in black and white or in color.

IgnoreBackColor is only available with certain Panasonic scan drivers

This property is enabled when the UserInterface property is Suppress and the PixelType property is Automation.

See Also

Scan Class | Scan Members


ImageFilter property

Newtone.ImageKit.WPF.Scan.ImageFilter Property

This property sets the image filter. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property ImageFilter As Newtone.ImageKit.WPF.ScanImageFilter
[C#]public Newtone.ImageKit.WPF.ScanImageFilter ImageFilter {set;}

Property Value

This value is of enum type ScanImageFilter

Explanation

The ImageFilter property sets the image filter, which can improve image quality. LOWPASS is recommended for haftone images, BANDPASS for images that include text, and HIGHPASS for images that include lines. The ImageFilter property is enabled when the UserInterface property is Suppress. Note that the ImageFilter property is disabled when using a digital camera or when the datasource does not support this functionality. To retrieve the values supported, please execute the GetCapabilityEnumToSingle method.

See Also

Scan Class | Scan Members


ImageMerge property

Newtone.ImageKit.WPF.Scan.ImageMerge Property

This property sets the double sided merge mode. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property ImageMerge As Newtone.ImageKit.WPF.ScanImageFilter
[C#] public Newtone.ImageKit.WPF.ScanImageFilter ImageMerge {set;}

Property Value

This value is of type ScanImageMerge

Explanation

The ImageMerge property sets the double sided merge mode. When using ADF duplex scanning, a value other than None for this property will merge the front and back images into a single image. Default value is None. This property is enabled when the UserInterface property is set to Suppress and the Mode property is set to ADFBothSide. Keep in mind that rotation settings will affect the output.

To find out if the datasource supports this property, execute the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Indicator property

Newtone.ImageKit.WPF.Scan.Indicator Property

This property sets whether or not the indicator is displayed when scanning. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property Indicator As Boolean
[C#]public bool Indicator {set;}

Property Value

Value | Explanation
True | The indicator is displayed
False | The indicator is not displayed

Explanation

The Indicator property sets whether or not the indicator is displayed when scanning. This property is enabled when the UserInterface property is Suppress.

Note: The Indicator property is disabled for scan devices that do not support this function.

See Also

Scan Class | Scan Members


InformationFileName property

Newtone.ImageKit.WPF.Scan.InformationFileName Property

This property sets the information file where the scan settings, set in the scan manufacturer's scan driver interface, are saved. Saved information can be loaded from the InformationFile and used in your custom built scan interface.

[Visual Basic] Public Property InformationFileName As String
[C#] public string InformationFileName {get; set;}

Property Value

The filename of the file where the scan settings are saved

Explanation

The InformationFileName property sets the information file where the scan settings, set in the scan manufacturer's scan driver interface, are saved. Saved information can be loaded from the InformationFile and used in your custom built scan interface. To use the InformationFileName property, the scan driver's user interface must be used once but after that all those settings can be loaded into a custom built scan interface. Also, if an infomation file exists containing previous setting information, the setting information is loaded and displayed in the UI (making it possible to check the previously saved contents).

Examples

The following code will save the settings used in the scan driver's user interface in the information file and load those setting from the file.

[Visual Basic.NET]
Dim Ret As Boolean
Dim Scan As New Newtone.ImageKit.WPF.Scan

Scan.UserInterface = ScanUserInterface.SetOnly
Scan.InformationFileName = "ui.dat"
                'If the file already exists, the settings will be loaded and displayed in the
                UI.
Ret = Scan.Execute()
if Ret = False Then Exit Sub

Scan.Transfer = ScanTransfer.Memory
Scan.Compression = ScanCompression.None
Scan.UserInterface = ScanUserInterface.Suppress
Scan.Mode = ScanMode.InformationFile
Ret = Scan.Execute()

[Visual C#.NET]
bool Ret;
Newtone.ImageKit.WPF.Scan scan = new Newtone.ImageKit.WPF.Scan();

scan.UserInterface = ScanUserInterface.SetOnly;
scan.InformationFileName = "ui.dat";
                //If the file already exists, the settings will be loaded and displayed in the
                UI.
Ret = scan.Execute();
if (!Ret) return;

scan.Transfer = ScanTransfer.Memory;
scan.Compression = ScanCompression.None;
scan.UserInterface = ScanUserInterface.Suppress;
scan.Mode = ScanMode.InformationFile;
Ret = scan.Execute();

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


JpegQuality property

Newtone.ImageKit.WPF.Scan.JpegQuality Property

This property sets the JpegQuality when using file or memory transfer with JPEG compression.

[Visual Basic] Public WriteOnly Property JpegQuality As Integer
[C#] public int JpegQuality {set;}

Property Value

-4F undefined
-3F Low quality
-2F Middle quality
-1F High quality
0 to 100

Explanation

The JpegQuality property sets the JpegQuality when using file or memory transfer with JPEG compression. This property is enabled when theTransfer property is File or Memory and the Compression property is Jpeg. The possible setting values supported by a scan device can be retrieved using the the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Class | Scan Members


Mode property

Newtone.ImageKit.WPF.Scan.Mode Property

This property sets the scanning mode. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public Property Mode As Newtone.ImageKit.WPF.ScanMode
[C#]public Newtone.ImageKit.WPF.ScanMode Mode {get; set;}

Property Value

This value is of enum type ScanMode

Explanation

The Mode property sets the scanning mode. This property is enabled when the UserInterface is Suppress. When the Mode property is CameraArray or CameraThumbnailArray, the array values passed to the Execute method are enabled, otherwise these array values are disabled.

Note: Even if the scan device being used supports duplex scanning, some scan drivers will not fully support duplex scanning when the user interface is suppressed (UserInterface=Suppress).

See Also

Scan Class | Scan Members


MoireFilter property

Newtone.ImageKit.WPF.Scan.MoireFilter Property

This property sets the level for the Moire filter. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property MoireFilter As Integer
[C#] public int MoireFilter {set;}

Property Value

For Epson Scan Drivers
Value | Explanation
0 | None
1 | Standard (This can be used for general settings)
2 | 85lpi (This can be used for Newspapers)
3 | 133lpi (This can be used for Magazines and Catalogs)
4 | 175lpi (This can be used for Pictures)

For Canon DR Scan Drivers
Value | Explanation
1 | None
2 | High scan speed
3 | High scan quality

Explanation

The MoireFilter property sets the level for removal of moire interference. This property is enabled when the UserInterface property is Suppress.

The Moire filter is enabled for certain Epson and Canon DR scan drivers. When using an Epson scanner, the datasource will be "Epson Scan" which will allow the above settings. Note that some Epson scanners, depending on the version, allow for only "on / off" settings. In this case the ImageKit will accept values of 0 or nonzero.

When using a Canon DR scanner, this property is enabled when the scan resolution is set to 300dpi or less. This property is disabled when the scan datasource does not support Moire filter.

See Also

Scan Class | Scan Members


NoiseFilter property

Newtone.ImageKit.WPF.Scan.NoiseFilter Property

This property sets the noise reduction filter. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property NoiseFilter As ScanNoiseFilter
[C#]public ScanNoiseFilter NoiseFilter {set;}

Property Value

This value is of enum type ScanNoiseFilter

Explanation

The NoiseFilter property sets the noise reduction filter for black and white images. This property is enabled when the UserInterface property is Suppress however it is disabled when using a digital camera. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method.

See Also

Scan Class | Scan Members


Orientation property

Newtone.ImageKit.WPF.Scan.Orientation Property

This property sets the orientation of the paper. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public Property Orientation As Newtone.ImageKit.WPF.ScanOrientation
[C#]public Newtone.ImageKit.WPF.ScanOrientation Orientation {get; set;}

Property Value

This value is of enum type ScanOrientation

Explanation

The Orientation property sets the orientation of the paper. Orientation starts at 0 degrees and rotates clockwise. This allows you to do things like rotate the scan output from the document plate or scan pages from an ADF where the pages are inserted 'on their side', etc. This property is enabled when the UserInterface property is Suppress.

Note: This property is disabled for digital cameras and scanners that do not support this function. The possible setting values supported by a scan device can be retrieved using theGetCapabilityEnumToSingle method. To determine whether TextOrientationRecognition is supported by a scan device, please use the IsCapabilitySupported method.

For datasources that support TextOrientationRecognition, if the result of the specified TextOrientationRecognition is not correct, try changing the orientation of the paper.

See Also

Scan Class | Scan Members


OverScan property

Newtone.ImageKit.WPF.Scan.OverScan Property

This property enables "over scan" capabilities enlarging the scan area. (UserInterface=Suppress)

[Visual Basic] Public WriteOnly Property OverScan As Newtone.ImageKit.WPF.ScanOverScan
[C#] public Newtone.ImageKit.WPF.ScanOverScan OverScan {set;}

Property Values

A member of the ScanOverScan enumeration

Explanation

The OverScan property is useful when the scanned paper is not properly centered. This property allows the scan area (the Rect property or the PaperSize property) to be increased.

This property is enabled when the UserInterface property is set to Suppress. This property is disabled when using a digital camera or if the document scanner's driver does not support this capability.

To check if the datasource supports overscan, use the GetCapabilityEnumToSingle method.

See Also

Scan Class | Scan Members


PageCount property

Newtone.ImageKit.WPF.Scan.PageCount Property

This property sets the number of images to be scanned. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property PageCount As Integer
[C#] public int PageCount {set;}

Property Value

Value | Explanation
0 or less | Scans all images (ADF, digital camera)
1 or more | Scans the specified number of images

Default value is -1.

Explanation

The PageCount property sets the number of images to be scanned. This property is enabled when the UserInterface property is Suppress. To scan all of the images in the ADF or digital camera, set this property to 0 or less. To specify the number of images to be scanned, set that number in the PageCount property. When retrieving images from a digital camera using an array, pleaes refer to the Execute method to be the same as the number of elements in the array. When the Mode property is ADFBothSide, even if an odd number is set into the PageCount property, the number of pages scanned will be an even number (so as to scan both sides of the paper).

The PageCount property is disabled when the UserInterface property is NOT Suppress or when using the document plate to scan. For Panasonic scanners, when the PixelType property is GrayAndBW or RGBAndBW, even if the PageCount property value is 1 or more, the specified number of images are scanned.

Note: Not all scan devices support this functionality. In some cases where the scan device does not support this function or does not correctly support this function, after the number of images specified by the PageCount property have been scanned, the scanning procedure is canceled. Depending on the type of equipment, paper could be left inside the scan device or ADF.

See Also

Scan Class | Scan Members


PaperSize property

Newtone.ImageKit.WPF.Scan.PaperSize Property

This property sets the size of the paper. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property PaperSize As Newtone.ImageKit.WPF.ScanPaperSize
[C#] public Newtone.ImageKit.WPF.ScanPaperSize PaperSize {set;}

Property Value

This value is of enum type ScanPaperSize

Explanation

The PaperSize property sets the size of the paper. This property is enabled when the UserInterface property is Suppress. However this property is disabled when using a digital camera. To enable the Rect property, set the PaperSize property to UserSize or a negative value.

Depending on the datasource (scan driver), using a user defined paper size (UserSize) and setting the scan area, may still result in a start position of the scan being incorrect. If that is the case, please use one of the above constant values listed in the ScanPaperSize enum (1 or more) for the paper size and set this to a NEGATIVE value. (Please refer to the example code below).

Note: Please set the PaperSize property to a size supported by the datasource (scan driver) or set it to the largest supported paper size. With some datasources the PaperSize property has no effect. Please refer to the scan manufacturer for details.

The possible PaperSize settings supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. For scan devices that only support a fixed paper size or do not support paper size settings set this property to UserSize.

When PaperSize is set to "UndefinedSize" (1000), the paper size is automatically detected then the document is scanned, however, with scanners that can only detect one dimension (either height or width) there are cases when the automatic detection does not work properly. When theTransfer property is Memory, there are some cases the scan may fail. If that is the case, please set the Transfer property to Native. To find out if "UndefinedSize" paper size is supported by the datasource, please execute the IsCapabilitySupported method.

If undefined paper size is supported and you have set UndefineSize into the PaperSize property but the auto detection of the paper's size isn't correct, you can try the following:
Set the BorderDetection property to true. If this still doesn't work and you are using a PFU scan driver then try the next step.
Add the largest possible paper size to the end of the UndefinedSize setting in the PaperSize property. For example, if the largest size you can set for the scanner is A3 then set
PaperSize = ScanPaperSize.UndefinedSize + 11. (See ScanPaperSize enum for those values)

Example

( The PaperSize is set to UserSize and the scan area is set but the scan position is wrong ) < /P>

[Visual Basic.NET]
ImageKit1.Scan.UserInterface = ScanUserInterface.Suppress
ImageKit1.Scan.Unit = ScanUnit.Inch
ImageKit1.Scan.PaperSize = ScanPaperSize.UserSize
ImageKit1.Scan.Rect = new RectangleF(0, 0, CSng(6.9), CSng(10.2))

[Visual C#.NET]
imageKit1.Scan.UserInterface = ScanUserInterface.Suppress;
imageKit1.Scan.Unit = ScanUnit.Inch;
imageKit1.Scan.PaperSize = ScanPaperSize.UserSize;
imageKit1.Scan.Rect = new RectangleF(0, 0, (float)6.9, (float)10.2);

( The PaperSize is set to one of the above constants with a NEGATIVE value --> the scan position is correct)< /P>

[Visual Basic.NET]
ImageKit1.Scan.UserInterface = ScanUserInterface.Suppress ImageKit1.Scan.Unit
= ScanUnit.Inch ImageKit1.Scan.PaperSize
= -3 '
US Letter size ImageKit1.Scan.Rect =
new RectangleF(0, 0, CSng(6.9), CSng(10.2)) [Visual C#.NET]

imageKit1.Scan.UserInterface =
ScanUserInterface.Suppress; imageKit1.Scan.Unit =
ScanUnit.Inch; imageKit1.Scan.PaperSize =
(ScanPaperSize)(-3); // US Letter size
imageKit1.Scan.Rect = new RectangleF(0, 0, (float)6.9, (float)10.2);

See Also

Scan Class | Scan Members


PixelType property

Newtone.ImageKit.WPF.Scan.PixelType Property

This property sets the type of image scanned. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public Property PixelType As Newtone.ImageKit.WPF.ScanPixelType
[C#]public Newtone.ImageKit.WPF.ScanPixelType PixelType {get; set;}

Property Value

This value is of enum type ScanPixelType

Explanation

The PixelType property sets the type of image scanned. This property is enabled when the UserInterface is Suppress. This property is disabled for digital cameras and scanners that do not support this function. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. Whether or not Automation, GrayAndBW, or RGBAndBW is supported, please check with the IsCapabilitySupportedmethod.

See Also

Scan Class | Scan Members


Rect property

Newtone.ImageKit.WPF.Scan.Rect Property

This property sets the scanning position. This property is enabled when using a custom-built user interface (UserInterface=Suppress).
[Visual Basic] Public Property Rect As System.Drawing.RectangleF
[C#] public System.Drawing.RectangleF Rect {get; set;}

Property Value

The value of this property depends on the Unit property setting. The minimum value is 0.

Explanation

The Rect property sets the scanning position of the area on the image to be scanned. This property value is enabled when the UserInterface property is Suppress and the PaperSize property is 0. (This property value is disabled when theUserInterface property is not Suppress, the PaperSize property value is 1 or more, and using a digital camera.)

After the scan has completed, the exact dimensions (in the units specified in the Unit property) of the actual area scanned are reset into the value of the Rect property. If the PaperSize property is set to UndefinedSize (or values of 1000 or more) or if the scan driver interface is automatically determining the paper size then actual scan may be the largest possible scan size or some other size depending on the scan driver. When using the default value of the datasource, set the RectangleF constructor with all parameter values set to 0 or use RectangleF.Empty.

See Also

Scan Class | Scan Members


RemoveHole property

Newtone.ImageKit.WPF.Scan.RemoveHole Property

This property sets hole removal. (UserInterface=Suppress)

[Visual Basic] Public WriteOnly Property RemoveHole As Integer
[C#] public int RemoveHole {set;}

Property Value

0: Does not remove holes

1: Holes are removed

The default value is 0

Explanation

The RemoveHole property sets whether or not hole removal is performed. This property is enabled for certain Canon DR scan drivers, Epson scanners, and Panasonic scanners.

The UserInterface property must be set to Suppress. If using a digital camera or if this capability is not supported by the scan driver, then this property is disabled.

To check whether the scanner supports this capability, use the IsCapabilitySupported method.

See Also

Scan Class | Scan Members


RotateBack property

Newtone.ImageKit.WPF.Scan.RotateBack Property

This property sets whether or not the back side of the page is rotated when scanning on both sides using an ADF.

[Visual Basic] Public WriteOnly Property RotateBack As Integer
[C#] public int RotateBack {set;}

Property Value

Value | Explanation
0 | Do not rotate the back side of pages
1 | Rotate the back side of pages 180 degrees

Explanation

The RotateBackproperty sets whether or not the back side of the page is rotated when scanning on both sides using an ADF.

Enabled for Epson scan drivers "EPSON Scan", however "EPSON Scan" Ver.1.x does not support sizes bigger than A4. "Epson Scan" configuration "Match front and back images during duplex scanning" is the same as RotateBack = 1.

This property is enabled when the UserInterface is Suppress and Mode property is ADFBothSide. This property is disabled for digital cameras and scan devices that do not support this function. The possible setting values supported by a scan device can be retrieved using the IsCapabilitySupported method.

See Also

Scan Class | Scan Members


Rotation property

Newtone.ImageKit.WPF.Scan.Rotation Property

This property sets the angle of rotation for the scanned image.

[Visual Basic] Public WriteOnly Property Rotation As Integer
[C#] public int Rotation {set;}

Property Value

From -360 degrees to 360 degrees
Default value is 0.

Explanation

The Rotation property sets the angle of rotation for the scanned image. Positive values rotate the image in a clockwise direction. Negative values rotate the image in a counter clockwise direction.

This property is enabled when the UserInterface property is set to Suppress. The Rotation property is similiar to the Orientation property but when the Orientation property will only accept a value of 0 (ScanOrientation.Rotate0) then use the Rotation property instead.

Some scan devices support both Orientation and Rotation. Depending on the scan device, BOTH property values are used to rotate the image (resulting in a "double rotation") or only the Rotation property value is enabled and the Orientation value is ignored. In such cases, it is recommended to set the Rotation property to values other than zero and set the Orientation property to 0 (ScanOrientation.Rotate0).

If the Orientation property is set to 1000 (ScanOrientation.TextOrientationRecognition), if the datasource is a digital camera, of if the scan device does not support rotation, then the Rotation property is disabled. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method or the GetCapabilityRange method.

See Also

Scan Class | Scan Members


ScanningSpeed property

Newtone.ImageKit.WPF.Scan.ScanningSpeed Property

This property increases the speed at which a document is scanned. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property ScanningSpeed As Integer
[C#]public int ScanningSpeed {set;}

Property Value

For Epson scan drivers

Value | Explanation
0 | For quality
1 | For speed

For Panasonic scan drivers

Value | Explanation
0 | Slow
1 | Normal
2 | Fast

Explanation

The ScanningSpeedproperty increases the speed at which a document is scanned.

Scanning speed is available only for certain Epson and Panasonic scanners

This property is enabled when the UserInterface is Suppress. Note: Increasing the speed at which the scan drivers scan a document can result in reduced quality. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method.

See Also

Scan Class | Scan Members


Shadow property

Newtone.ImageKit.WPF.Scan.Shadow Property

This property sets the shadow. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).
[Visual Basic]Public WriteOnly Property Shadow As Integer
[C#]public int Shadow {set;}

Property Value

From 0 to 255 (Default value is 0)

Explanation

The Shadow property sets the shadow. This property is enabled when the UserInterface property is Suppress.

The Shadow property is disabled if the PixelType property is BW.

Note: This property is disabled for digital cameras and scanners that do not support this function. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Class | Scan Members


Sharpness property

Newtone.ImageKit.WPF.Scan.Sharpness Property

This property sets the level of sharpness. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property Sharpness As Integer
[C#]public int Sharpness {set;}

Property Value

Epson scan driver (unsharp mask)

Value | Explanation
0 | None
1 | Weak
2 | Normal
3 | Strong

Panasonic scan driver (quality)

Value | Explanation
0 | None
1 | Smooth
2 | Low
3 | Standard
4 | High

Explanation

The Sharpness property sets the level of sharpness.

Sharpness is enabled for certain Epson and Panasonic scan drivers only. When using an Epson scanner, the datasource will be "Epson Scan" which will allow the above gradated settings. Note that some Epson scanners, depending on the version, allow for only "on / off" settings. In this case the ImageKit will accept values of 0 or nonzero.

For Epson scanners, the "unsharp mask" is used and for Panasonic scanners "image quality" is used.

This property is enabled when the UserInterface is Suppress. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method.

See Also

Scan Class | Scan Members


SkipBlankPage property

Newtone.ImageKit.WPF.Scan.SkipBlankPage Property

This property sets whether or not a blank page will be skipped. (UserInterface=Suppress)

[Visual Basic] Public WriteOnly Property SkipBlankPage As Integer
[C#] public int SkipBlankPage {set;}

Property Value

-2: The blank page is not skipped

-1: The blank page is skipped

For Canon DR scan drivers

0: The blank page is not skipped

1: The blank page is skipped

Epson scan drivers

0: The blank page is not skipped

1: The blank page is skipped (low level)

2: The blank page is skipped (medium level)

3: The blank page is skipped (high level)

Explanation

The SkipBlankPage property sets whether or not a blank page will be skipped. If the datasource supports this capability, setting this property to -1 will enable SkipBlankPage.

When using Canon DR scan drivers or Panasonic scan drivers, set the SkipBlankThreshold property. When using a Canon DR scan driver to skip blank pages, the Mode property should be set to ADFOneSide. When SkipBlankPage is enabled, even though the Mode property is ADFOneSide, both sides will be scanned.

When using an Epson scanner and skipping blank pages, set the SkipBlankPage property to a value of -1 or values of 1 or more. When the SkipBlankPage is -1, the default TWAIN capability will be used. Setting the SkipBlankPage property to values of 1 or more will allow the Epson capability to be used. In this case, set the AdjustGamma property to 1. When the AdjustGamma property is 0, the skip blank page functionality does not work properly in all cases. Also, if the AdjustGamma capability is not supported, you can use the default -1 value for SkipBlankPage but because the page may be darker than it should, skipping blank pages may not work as expected. In that case, you can make adjustments to darkness using the Brightnessand Gamma properties.

This property is enabled when the UserInterface property is set to Suppress. If using a digital camera or if the scan driver does not support this capability, this property will be disabled.

To check if the scanner supports this property use the GetCapabilityEnumToSingle or the GetCapabilityRange methods.

See Also

Scan Class | Scan Members


SkipBlankThreshold property

Newtone.ImageKit.WPF.Scan.SkipBlankThreshold Property

This property sets the threshold value to determine if a blank page is included with pages to be scanned and whether that blank page should be skipped. (UserInterface= Suppress)

[Visual Basic] Public WriteOnly Property SkipBlankThreshold As Single
[C#] public float SkipBlankThreshold {set;}

Property Value

For Canon DR Scan drivers:

Values can be set in % units from 0.1 to 20.0

For Panasonic scan drivers

Values can be set in % units from 0.01 to 5.00

The default value is 1

Explanation

The SkipBlankThreshold property sets the threshold value to determine if a blank page is included with the pages to be scanned and whether that blank page should be skipped. This property is enabled only for Canon DR scan drivers and Panasonic scan drivers. For Canon DR scanners, as this property value gets smaller, the likelihood that a page is recognized as blank increases. For Panasonic scanners, as this property value gets larger, the likelihood that a page is recognized as blank increases.

This property is enabled when the UserInterface property is set to Suppress and the SkipBlankPage property is set to -1 or 1.

See Also

Scan Class | Scan Members


TextEnhancement property

Newtone.ImageKit.WPF.Scan.TextEnhancement Property

This property sets the type of text enhancement used. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public Property TextEnhancement As Integer
[C#] public int TextEnhancement {get; set;}

Property Value

Canon DR Scan Driver

Value | Explanation
0 | Text enhancement is not used (default)
1 | Text enhancement is used
2 | Advanced text enhancement is used
3 | High speed text enhancement is used
4, 5 | Advanced text enhancement II is used. (Value depends on the functions used)
6 | Active Threshold

Epson Scan Driver

Value | Explanation
0 | Character distinction is not used. (default)
1 | Standard character distinction is used
2 | Strong character distinction is used

Explanation

The TextEnhancement property sets what type of text enhancement is used. The default value is 0.

This property is enabled for Canon DR scan drivers and Epson scan drivers only. For Canon DR drivers, the PixelType property must be BW and the BitDepthReduction property must be Threshold. Canon DR drivers refer to this functionality as "text enhancement". Epson scan drivers refer to it as "character distinction". The different levels of character distinction are available on Epson Scan ver 5.0 scan drivers or higher.

This property is enabled when the UserInterface property is set to Suppress. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. For some Epson scanners, only settings of enabled and disabled are allowed. In that case, the ImageKit will accept 0 as disabled and non-zero as enabled. If the datasource doesn't support this function then the value is ignored.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Threshold property

Newtone.ImageKit.WPF.Scan.Threshold Property

This property sets the scanning threshold. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property Threshold As Integer
[C#]public int Threshold {set;}

Property Value

From 0 to 255 (Default value is 128)

Explanation

The Threshold property sets the scanning threshold. This property is only enabled when the UserInterface property is Suppress.

The Threshold property requires that the PixelType property be BW and the BitDepthReduction property be Threshold. For scan devices that use brightness instead of threshold, the Brightness property value will be used.

Note: This property is disabled for digital cameras and scanners that do not support this function. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Class | Scan Members


Transfer property

Newtone.ImageKit.WPF.Scan.Transfer Property

This property sets whether native, file, or memory transfer is used.

[Visual Basic]Public Property ScanTransfer As Newtone.ImageKit.Transfer
[C#]public Newtone.ImageKit.WPF.ScanTransfer Transfer {get; set;}

Property Value

This value is enum type ScanTransfer

Explanation

The TransferMode property sets whether native, file, or memory transfer is used. It is necessary to set this property prior to executing the Execute method. The possible transfer methods supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. Scanning events are generated for the memory transfer mode only.

See Also

Scan Class | Scan Members


Unit property

Newtone.ImageKit.WPF.Scan.Unit Property

This property sets the units of measurement when scanning with a custom built user interface (UserInterface=Suppress).

[Visual Basic]Public Property Unit As Newtone.ImageKit.WPF.ScanUnit
[C#]public Newtone.ImageKit.WPF.ScanUnit Unit {get; set;}

Property Value

This value is of enum type ScanUnit

Default value is Inch.

Explanation

The Unit property sets the units of measurement used to set the scanning area. This property is enabled when the UserInterface is Suppress. The Rect property values will use the unit of measurement set in the Unit property.

Although the Unit property is disabled when the UserInterface is NOT Suppress, when scanning, the units of measurement of the scan are returned to this property. To retrieve the values of the Unit property supported by the scan device, execute the GetCapabilityEnumToSingle method.

See Also

Scan Class | Scan Members


UserInterface property

Newtone.ImageKit.WPF.Scan.UserInterface Property

This property sets whether the scan driver's user interface is used when scanning or if a custom built user interface is used.

[Visual Basic]Public Property UserInterface As Newtone.ImageKit.WPF.ScanUserInterface
[C#]public Newtone.ImageKit.WPF.ScanUserInterface UserInterface {get; set;}

Property Value

This value is of enum type ScanUserInterface

Explanation

The UserInterface property sets whether the scan driver's user interface is used when scanning or if a custom built user interface is used.

See Also

Scan Class | Scan Members


Value property

Newtone.ImageKit.WPF.Scan.Value Property

Retrieves the value for the specified scan capability.

[Visual Basic] Public ReadOnly Property Value As Integer
[C#] public int Value {get;}

Property Value

The property values depend on the ScanCapability parameter　of the IsCapabilitySupported method.

Parameter | The setting value
Document feeder function (FeederEnabled) | 0: cannot be used, 1: feeder can be used
The function that checks whether or not there is paper in the document feeder ( FeederLoaded) | 0: there is no paper, 1: there is paper
Indicator | 0: cannot use indicator, 1: can use indicator
UI control function (UIControllable) | 0: must use manufacturer's UI only, 1: manufacturer's UI can be suppressed
The function that checks the device's operating state(DeviceOnline) | 0: Device is not responding, 1: Device is operating
The function that transfers thumbnail images (ThumbnailEnabled) | 0: cannot transfer thumbnails, 1: can transfer thumbnails
Duplex scanning with the document feeder (Duplex) | 0: can not scan both sides, 1: can scan both sides at once, 2: can scan both sides but takes two scans
EnableDataSourceOnly | 0: Cannot display setting interface, 1: Setting interface can be displayed
CustomDataSourceData | 0: Not possible to retrieve or set UI value, 1: Can retrieve or set value in UI
Automatic Brightness (AutoBright) | 0: Automatic brightness cannot be used, 1: Automatic brightness can be used.
The undefined size (UndefinedImageSize) | In general, 0: undefined size cannot be used, 1: undefined size can be used. However, with certain Epson scan drivers the following values are set, 0: undefined size cannot be used, 1: possible only with document plate, 2: possible only with ADF, 3: possible with both document plate and ADF
How many images are in a digital camera (ImageDataSet) | the returned number is the number of images
BorderDetection | 0: border detection is not possible, 1: border detection is possible
Deskew | 0: cannot use deskew, 1: can use deskew, 2: can use deskew with smoothing 2 is only available for certain Panasonic scan drivers. In that case, 1 can be used.
Automatic rotation (AutomaticRotate) | 0: Automatic rotation not possible, 1: Automatic rotation possible. Standard TWAIN capability
Automatically recognize color or B&W (AutomaticColorEnabled) | 0: AutomaticColorEnabled is not possible, 1: AutomaticColorEnabled is possible. Standard TWAIN capability.
The maximum resolution when using a moire filter (MoireFilterMaxResolution) | the value is that maximum resolution Available only for certain Epson scan drivers
RotateBack when using ADF in duplex mode (RotateBack) | 0: rotating the back side is not possible, 1: rotating the back side is possible Available only for certain Epson "Epson Scan" scan drivers
Automatically detecting ratio of BW/Color (PixelAutomation) | 0: cannot automatically detect BW/Color, 1: can automatically detect BW/Color Available only for certain Panasonic scan drivers
MultiStream | 0: multi-stream is not possible, 1: multi-stream is possible (Multi-stream is where 1 scan of the document plate results in retrieving two images of different pixel types) Available only for certain Panasonic scan drivers
TextOrientationRecognition or Automatic rotation | 0: Cannot use remove punch hole, 1: Remove punch hole is possible Available only for certain Canon DR or Panasonic scan drivers. Canon DR scan drivers use "Text Orientation Recognition" whereas Panasonic scan drivers use "Automatic Image Orientation".
Punch hole removal (RemoveHole) | 0: Automatic orientation based on text or automatic rotation is not possible, 1: Automatic orientation based on text or automatic rotation is possible. Available only for certain Canon DR, Epson, PFU, or Panasonic scan drivers.
Border adjustment (Border) | 0: Cannot adjust border, 1: Can adjust border Available only for certain Epson or Panasonic scan drivers
Gamma adjustment (AdjustGamma) | 0: Cannot adjust gamma, 1: Can adjust gamma. Available only for certain Epson scan drivers.

Explanation

The property values will be set after the IsCapabilitySupported method is executed. If the return value of the IsCapabilitySupported method is False, then -1 is set in the Value property.

See Also

Scan Class | Scan Members


XResolution property

Newtone.ImageKit.WPF.Scan.XResolution Property

This property sets the horizontal scan resolution. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public Property XResolution As Integer
[C#]public int XResolution {get; set;}

Property Value

The horizontal and vertical scan resolution are set in DPI units.

XResolution is the horizontal scan resolution

Explanation

The XResolution property sets the horizontal scan resolution. This property is enabled when the UserInterface property is Suppress. When the UserInterface property is NOT Suppress or when a digital camera is being used, these properties are disabled. The range of resolution and the resolution values supported by the scan device can be retrieved by executing the GetCapabilityEnumToSingle or the GetCapabilityRange method. To use the scan device default resolution values, set this property to -1.

Note: Although it is possible to set different values for the horizontal and vertical resolution, some datasources (scanner drivers) do not support different values for horizontal and vertical resolution. In such cases, either the horizontal resolution or the vertical resolution will be enabled. To retrieve the actual resolution, refer to the XResolution and YResolution properties within the BeforeScan event or after executing the Execute method.

See Also

Scan Class | Scan Members


XScaling property

Newtone.ImageKit.WPF.Scan.XScaling Property

This property sets the horizontal scaling (magnification). This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property XScaling As Single
[C#] public float XScaling {set;}

Property Value

XScaling is the horizontal scaling

Default value is 1.0

Explanation

The XScaling property sets the horizontal scaling (magnification). This property is only enabled when the UserInterface property is Suppress. If the UserInterface is set to a value other than Suppress or if a digital camera is being used, this property is disabled. The range and values of scaling supported by the scan device can be retrieved by executing the GetCapabilityEnumToSingle or the GetCapabilityRange method.

To scan in actual size, set the XScaling and YScaling properties to 1.0

Note: Although it is possible to set different values for horizontal and vertical scaling some datasources (scan drivers) do not support this. In such cases, either the horizontal scaling value or the vertical scaling value will be used.

See Also

Scan Class | Scan Members


YResolution property

Newtone.ImageKit.WPF.Scan.YResolution Property

This property sets the vertical scan resolution. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public Property YResolution As Integer
[C#] public int YResolution {get; set;}

Property Value

The horizontal and vertical scan resolution are set in DPI units.

YResolution is the vertical scan resolution

Explanation

The YResolution property sets the vertical scan resolution. This property is enabled when the UserInterface property is Suppress. When the UserInterface property is NOT Suppress or when a digital camera is being used, this property is disabled. The resolution values and range supported by the scan device can be retrieved by executing the GetCapabilityEnumToSingle or the GetCapabilityRange method. To use the scan device default resolution values, set this property to -1.

Note: Although it is possible to set different values for the horizontal and vertical resolution, some datasources (scanner drivers) do not support different values for horizontal and vertical resolution. In such cases, either the horizontal resolution or the vertical resolution will be enabled. To retrieve the actual resolution, refer to the XResolution and YResolutionproperties within the BeforeScan event or after executing the Execute method.

See Also

Scan Class | Scan Members


YScaling property

Newtone.ImageKit.WPF.Scan.YScaling Property

This property sets the vertical scaling (magnification). This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property YScaling As Single
[C#] public float YScaling {set;}

Property Value

YScaling is the vertical scaling

Default value is 1.0

Explanation

The YScaling property sets the vertical scaling (magnification). This property is only enabled when the UserInterface property is Suppress. If the UserInterface is set to a value other than Suppress or if a digital camera is being used, this property is disabled. The range and values of scaling supported by the scan device can be retrieved by executing the GetCapabilityEnumToSingle or the GetCapabilityRange method.

To scan in actual size, set the XScaling and YScaling properties to 1.0

Note: Although it is possible to set different values for horizontal and vertical scaling some datasources (scan drivers) do not support this. In such cases, either the horizontal scaling value or the vertical scaling value will be used.

See Also

Scan Class | Scan Members


ClearProperty method

Newtone.ImageKit.WPF.Scan.ClearProperty Method

This method resets the scan control properties.

[Visual Basic]Public Sub ClearProperty()
[C#]public void ClearProperty();

Return Value

None

Explanation

The ClearProperty method resets all property values to their default values (Doesn't include specialized referenced properties).

See Also

Scan Class | Scan Members


CloseDataSource method

Newtone.ImageKit.WPF.Scan.CloseDataSource Method

This method closes the scan datasource (scan device).

[Visual Basic]Public Function CloseDataSource() As Boolean
[C#]public bool CloseDataSource();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CloseDataSource method closes the datasource that was opened by the OpenDataSource method.

Prior to executing the CloseDataSource and OpenDataSource methods, you must execute the Initialize method.

See Also

Scan Class | Scan Members


Execute method

Newtone.ImageKit.WPF.Scan.Execute Method

This method retrieves an image from a TWAIN datasource (scan device).

[Visual Basic] Public Function Execute() As Boolean Public Function Execute(ByVal index() As Integer) As Boolean
[C#] public bool Execute(); public bool Execute(int[] index);

Parameters

index
An array containing the image indexes (used with a digial camera)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Execute method retrieves an image from a TWAIN datasource (scan device). Events (BeforeScan, AfterScan, Scanning) are generated before, during, and after the scan so it is possible to write processing code in each of these stages of the scan process.

The Index parameter is enabled only when the UserInterface property is Suppress and the Mode property is set for a digital camera. However, in other situations where this array of index values is not needed, please use methods which doesn't have any parameters. The Index parameter is used to specify which image is retrieved from the digital camera (the index parameter is enabled when the Mode property is CameraArray or CameraThumbnailArray).

For example, to retrieve the 5th and 8th image from a digital camera, set the Index array parameter to

Dim Index(1) As Integer

Index(0) = 5

Index(1) = 8

Some scan devices do not support these functions. In such cases, only the supported functions are used to scan the image.

Prior to executing the Execute method, you must execute the Initialize method.

If the OpenDataSource method is executed prior to the Execute method, then while the scan device is open, other applications can not use that scan device and it becomes the exclusive datasource for this execution.

The following properties should be set prior to executing the Execute method

[Required properties]

  • DataSourceName - if this property is blank, then select the scan device by executing the Select method. Note: If the OpenDataSource method is executed prior to executing the DataSourceName method then the DataSourceName is disabled and the open scan device is used.
  • Transfer
  • Compression
  • UserInterface
  • (ExtendedUserInterface) - This property is required only when using Epson scanner drivers.

[These properties may be required depending on the settings]

  • FileFormat
  • FileName
  • JpegQuality

[If the UserInterface property is Suppress and Mode property is InforamtionFile]

  • Mode
  • PageCount
  • Unit

[If the UserInterface property is Suppress and Mode property is NOT InforamtionFile]

  1. When using a scanner, it is recommended that the following properties be set when the UserInterface property is Suppress:
    AdjustGamma, AutoBright, BitDepth, BitDepthReduction, Border, BorderColor, BorderDetection, Brightness, ColorBWRatio, Contrast, Deskew , DropoutColor, DynamicThreshold, FocusPosition, Gamma, HalfTone, Highlight, IgnoreBackColor, ImageFilter, ImageMerge, Indicator, Mode, MoireFilter, NoiseFilter, Orientation, OverScan, PageCount, PaperSize, PixelType, RemoveHole, RotateBack, Rotation, ScanningSpeed, Shadow, Sharpness, Threshold, SkipBlankPage, SkipBlankThreshold, TextEnhancement, Unit, Unit, XResolution, XScaling, YResolution, YScaling, PaperSize<=0: Rect

    Note: The AdjustGamma, Border, BorderColor, ColorBWRatio, DynamicThreshold, FocusPosition, IgnoreBackColor, MoireFilter, RemoveHole, RotateBack, ScanningSpeed, Sharpness, SkipBlankPage, SkipBlankThreshold, TextEnhancement properties are sometimes disabled depending on the scan driver.
  2. When using a digital camera, it is recommended that these properties be set:
    Mode, PageCount (when the Index parameter is unnecessary), Unit

    <The following properties are set after the scan has executed>

    BitDepth, Compression, ErrorStatus, FileFormat (when using file transfer method), PixelType , Rect, Count, Unit, XResolution, YResolution

    For details, please refer to the respective properties' explanations.

    Important points when using a custom built user interface (UserInterface = Suppress)

    When UserInterface is Suppress, depending on the scan device and the property values set, the scan can fail. For the most part the causes for scan failure when the UserInterface is Suppress can be traced to the following:

    1. The scan units set are not supported by the scan device. The supported scan unit values can be retrieved using the GetCapabilityEnumToSingle method.
    2. The pixel type set is not supported by the scan device. The supported pixel type values can be retrieved using the GetCapabilityEnumToSingle method.
    3. The bit count set is not supported by the scan device. The supported bit count values can be retrieved using the GetBitDepth method.
    4. The resolution set is not supported by the scan device. The supported resolution values can be retrieved using the GetCapabilityEnumToSingle or the GetCapabilityRange methods.
    5. The paper size set is not supported by the scan device. The supported values can be retrieved using the GetCapabilityEnumToSingle method.
      1. If settings for paper size are not supported at all, then set the PaperSize property to UserSize and set the appropriate scan area in the Rect property. If the scan area is not correctly set (i.e. it is smaller than the minimum or larger than the maximum), the scan can fail. The proper scan area values can be retrieved using the GetMinimumSize and GetPhysicalSize methods.
      2. If paper size settings are supported and the scan still fails, check to make sure the PaperSize property is set to a value other than UserSize.

Example

Scan using the scan driver's user interface

[Visual Basic.NET]
Dim Ret As Boolean
Dim Scan As New Newtone.ImageKit.WPF.Scan
AddHandler Scan.AfterScan, AddressOf Scan_AfterScan

Ret = Scan.Initialize(Me.Handle, 1, 0, "1.00", "NEWTONE Corp.", "ImageKit", "ImageKit.NET Scan Sample")
If Ret = false Then Exit Sub
Scan.ClearProperty()
Scan.Transfer = ScanTransfer.Memory
Scan.Compression = ScanCompression.None
Scan.UserInterface = ScanUserInterface.Show
Scan.DataSourceName = "EPSON TWAIN Pro"
Ret = Scan.Execute()
Ret = Scan.Terminate()

'event
Private Sub Scan_AfterScan(ByVal sender As System.Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs)
  If Not (e.Bitmap1 Is Nothing) Then
    e.Bitmap1.Save(e.ImageNumber.ToString("d02") + ".bmp", System.Drawing.Imaging.ImageFormat.Bmp)
  End If
End Sub

[Visual C#.NET]
bool Ret;
Newtone.ImageKit.WPF.Scan scan = new Newtone.ImageKit.WPF.Scan();
scan.AfterScan += new Newtone.ImageKit.AfterScanEventHandler(scan_AfterScan);

Ret = scan.Initialize(this.Handle, 1, 0, "1.00", "NEWTONE Corp.", "ImageKit", "ImageKit.NET Scan Sample");
if (!Ret) return;
scan.ClearProperty();
scan.Transfer = ScanTransfer.Memory;
scan.Compression = ScanCompression.None;
scan.UserInterface = ScanUserInterface.Show;
scan.DataSourceName = "EPSON TWAIN Pro";
Ret = scan.Execute();
Ret = scan.Terminate();

//event
private void scan_AfterScan(object sender, Newtone.ImageKit.AfterScanEventArgs e)
{
  if (e.Bitmap1 != null)
    e.Bitmap1.Save(e.ImageNumber.ToString("d02") + ".bmp", System.Drawing.Imaging.ImageFormat.Bmp);
}

See Also

Scan Class | Scan Members


GetBitDepth method

Newtone.ImageKit.WPF.Scan.GetBitDepth Method

This method retrieves the bit depth supported by the scan device.

[Visual Basic] Public Function GetBitDepth() As Integer()
[C#] public int[] GetBitDepth();

Return Value

An array containing the bit depths supported by the scan device (Returns null[C#] or Nothing[VB.NET] if unsuccessful).

Explanation

The GetBitDepth method retrieves the bit depth supported by the scan device. To retrieve the bit depth, the PixelType and DataSourceName property must be set. If the DataSourceName property is blank, then prior to executing this method, please execute the SelectDataSource method. (Note: If the OpenDataSource method has been executed then the DataSourceName is disabled and the opened scan device will be used). The supported bit depth retrieved by the GetBitDepth method depends on the value set in the PixelType property. Therefore the PixelType property must also be set. Please set the values supported by the scan device into the PixelType property. Likewise, depending on the type of transfer method that has been set (memory transfer or native transfer) the possible compression methods may be different. You should therefore set the Transfer property value prior to retrieving the possible compression methods.

Prior to executing the GetBitDepth method, you must execute the Initialize method.

If the OpenDataSource method is executed prior to the GetBitDepth method, then while the scan device is open, other applications can not use that scan device and it becomes the exclusive datasource for this execution.

See Also

Scan Class | Scan Members


GetCapabilityEnumToSingle method

Newtone.ImageKit.WPF.Scan.GetCapabilityEnumToSingle Method

This method retrieves the possible setting values for a specified property of the scan device.

[Visual Basic] Public Function GetCapabilityEnumToSingle(ByVal capability As Newtone.ImageKit.WPF.ScanCapability) As Single()
[C#] public float[] GetCapabilityEnumToSingle(Newtone.ImageKit.WPF.ScanCapability capability);

Parameters

capability
The number for the retrieved capability (Values are of type ScanCapability enumeration)

Return Value

An array of supported values (Returns null [C#] or Nothing [Visual Basic] if unsuccessful).

Explanation

The GetCapabilityEnumToSingle method retrieves the possible setting values for a specified property of the scan device. To retrieve the possible setting values for a property it is first necessary to set the DataSourceName property. If the DataSourceName property is blank then please execute the SelectDataSource method prior to executing the GetCapabilityEnumToSingle method. (Note: If the OpenDataSource method is executed prior to the GetCapabilityEnumToSingle method the the DataSourceName is disabled and the open datasource is used).

Depending on your scanner, the resolution values that are possible may be different according to the pixel type value (i.e. according to whether the pixel type is 1 bit color, 24 bit color, etc.) Because of this, it is recommended that you you set the PixelType property prior to retrieving the possible values for horizontal and vertical resolution. Likewise, depending on the type of transfer method that has been set (memory transfer or native transfer) the compression methods that are possible for a given scanner may be different. You should therefore set the Transfer property value prior to retrieving the possible compression methods.

To execute the GetCapabilityEnumToSingle method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetCapabilityEnumToSingle method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

After executing the GetCapabilityEnumToSingle method, the values are set into the ContainerType, CurrentIndex, and DefaultIndex properties.

Content of the Returned Value

Parameter | Return Value
Compression | A member of type ScanCompression enumeration
PixelType | A member of type ScanPixelType enumeration
Unit | A member of type ScanUnit enumeration
Transfer | A member of type ScanTransfer enumeration
FeederEnabled | The possible values to enable feeder (0: document plate; 1: feeder) *1
Indicator | The possible Indicator values *1
ThumbnailEnabled | The possible values to enable thumbnails *1
DuplexEnabled | The possible values to enable duplex scanning (0: single side; 1: duplex) *1
AutoBright | The possible values for automatic brightness *1
Brightness | The possible brightness setting values
Contrast | The possible contrast setting values
Filter | The possible filter setting values
Gamma | The possible gamma setting values
Highlight | The possible hightlight setting values
ImageFileFormat | A member of type ScanFileFormat enumeration
DropoutColor | A member of type ScanDropoutColor enumeration
Orientation | A member of type ScanOrientation enumeration
Shadow | The possible shadow setting values
XResolution | The possible horizontal resolution setting values
YResolution | The possible vertical resolution setting values
Rotation | The possible totation setting values
PaperSize | A member of type ScanPaperSize enumeration
Threshold | The possible threshold setting values
XScaling | The possible horizontal scaling setting values
YScaling | The possible vertical scaling setting values
BitDepthReduction | A member of type ScanBitDepthRedution enumeration
UndefinedImageSize | The possible undefined image size values *1
ImageFilter | A member of type ScanImageFilter enumeration
NoiseFilter | A member of type ScanNoiseFilter enumeration
OverScan | A member of type ScanOverScan enumeration
BorderDetection | The possible BorderDetection values *1
Deskew | The possible Deskew values *1
AutomaticRotate | The possible AutomaticRotate values (including TWAIN standard values) *1
JpegQuality | The possible Jpeg quality setting values
AutoSize | The possible page size recognition setting values
AutomaticColorEnabled | The possible values to enable automatic color *1
ScanningSpeed

This is enabled only for certain Epson and Panasonic scanners
(1) Epson Scan Drivers - 0: For Quality, 1: For Speed
(2) Panasonic Scan Drivers - 0: Slow, 1: Normal, 2: Fast
MoireFilter

This is enabled only for certain Epson and Canon DR scanners
(1) For Epson Scan - 0: None, 1: Standard, 2: 85lpi (For Newspapers), 3: 133lpi (for Magazines and Catalogs), 4: 175lpi (for Photographs)

(2) For Canon DR - 1: None, 2: High Speed, 3: High Quality
Sharpness

This is enabled only for certain Epson and Panasonic scanners
For Epson scanners, the "unsharp mask" is used and for Panasonic scanners "image quality" is used.

(1)Epson Scan Drivers - 0F None, 1: Weak 2: Normal (default), 3: Strong
(2)Panasonic Scan Drivers - 0: None, 1: Smooth, 2: Low, 3: Standard, 4: High
ExtendedUserInterface

This is enabled only for certain Epson scanners
0: Starts up the UserInterface that was last used, 1: Starts up the professional mode, 2: Starts up the automatic mode, 3: Starts up the home mode, 4: Starts up the automatic mode (with no error messages and supressed UserInterface), 5: Starts up office mode
DynamicThreshold This is enabled only for certain Panasonic scanners
0: None, 1: Bright, 2: A little brighter, 3: Standard, 4: A little darker, 5: Dark

When ContainerType = 3, the value is returned but the CurrentIndex and DefaultIndex are not enabled.
When ContainerType = 4, the value is returned and the array index referring to the CurrentIndex and DefaultIndex contain the current and default values.
When ContainerType = 5, the array index 0 contains the current value (default value)
When ContainerType = 6, the array index 0 contains the minimum value, the index 1 contains the maximum value, the index 2 contains the step value, the index 3 contains the default value, the index 4 contains the current value which can be various different values. This is the same result as executing theGetCapbilityRange method.

*1 For TWAIN 2.0 datasources and above the retrieved values will be all the possible settings. For ContainerType 3,4, and 6, the retrieved value will be the value of the current setting.

See Also

Scan Class | Scan Members


GetCapabilityEnumToString method

Newtone.ImageKit.WPF.Scan.GetCapabilityEnumToString Method

This method retrieves the possible setting values for a specified property of the scan device.

[Visual Basic] Public Function GetCapabilityEnumToString(ByVal capability As Newtone.ImageKit.WPF.ScanCapability) As String()
[C#] public string[] GetCapabilityEnumToString(Newtone.ImageKit.WPF.ScanCapability capability);

Parameters

capability
The number for the retrieved capability (Value is of type ScanCapability enumeration)

Return Value

An array of supported values (Returns null [C#] or Nothing [Visual Basic] if unsuccessful).

Explanation

The GetCapabilityEnumToString method retrieves the possible setting values for a specified property of the scan device. To retrieve the possible setting values for a property it is first necessary to set the DataSourceName property. If the DataSourceName property is blank then please execute the SelectDataSource method prior to executing the GetCapabilityEnumToString method. (Note: If the OpenDataSource method is executed prior to the GetCapabilityEnumToString method the the DataSourceName is disabled and the open datasource is used).

To execute the GetCapabilityEnumToString method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetCapabilityEnumToString method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

After executing this method, the values are set into the ContainerType, CurrentIndex, and DefaultIndex properties.

Content of the Returned Value

Parameter | Return Value
Halftone | The possible setting values

When the capability is Halftone, the returned values reflect the possible halftone values that can be set.

When ContainerType = 3, the value is returned but the CurrentIndex and DefaultIndex are not enabled.
When ContainerType = 4, the value is returned and the array index referring to the CurrentIndex and DefaultIndex contain the current and default values.
When ContainerType = 5, the array index 0 contains the current value
When ContainerType = 6, there is no return value.

See Also

Scan Class | Scan Members


GetCapabilityRange method

Newtone.ImageKit.WPF.Scan.GetCapabilityRange Method

This method retrieves the range of possible setting values for a specified functionality of the scan device.

[Visual Basic] Public Function GetCapabilityRange(ByVal capability As Newtone.ImageKit.WPF.ScanCapability) As Newtone.ImageKit.CapabilityRange
[C#] public Newtone.ImageKit.CapabilityRange GetCapabilityRange(Newtone.ImageKit.WPF.ScanCapability capability);

Parameters

capability
The number for the retrieved functionality in hexidecimal notation (value is of type ScanCapability)

Return Value

The CapabilityRange class (Returns null[C#] or Nothing[Visual Basic] if unsuccessful)

Explanation

The GetCapabilityRange method retrieves the range of possible setting values for a specified functionality of the scan device. To retrieve the range of possible values for a setting, the DataSourceName property must be set. If the DataSourceName property is blank then prior to executing this method, please execute the SelectDataSource method. (If the OpenDataSource method has been executed, the DataSourceName is disabled and the open scan device will be used.)

Depending on your scanner, the resolution values that are possible may be different according to the pixel type value (i.e. according to whether the pixel type is 1 bit color, 24 bit color, etc.) Because of this, it is recommended that you you set the PixelType property prior to retrieving the possible values for horizontal and vertical resolution.

To execute the GetCapabilityRange method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetCapabilityRange method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

After executing this method, the value is set into the ContainerType property.

Contents of the return value

Parameter | Return Value
Brightness | Range Information
Contrast | Range Information
Gamma | Range Information
Highlight | Range Information
Shadow | Range Information
XResolution | Range Information
YResolution | Range Information
Rotation | Range Information
Threshold | Range Information
XScaling | Range Information
YScaling | Range Information
SkipBlankPage (AutoDiscardBlankPages) | Range Information (including Twain Standard Capability)
JpegQuality | Range Information
Sharpness | Range Information Enabled when using Canon DR, Epson, or Panasonic scan drivers. In Canon DR drivers this is called "Edge Adjustment". In Epson drivers, it is called "Unsharpness". In Panasonic drivers, it is called "Image Quality".
SkipBlankPage | Range Information
FocusPosition | Range Information Enabled for Epson scan drivers.

When ContainerType = 3 or 4, then the number of elements in the list is set into the Maximum property for the CapabilityRange class. Use this number and execute theGetCapabilityEnumToSingle method.
When ContainerType = 5, then the current value is set into the Current property for the CapabilityRange class and the default value is set into the Default property.
When ContainerType = 6, then values are set into the Current, Default, Maximum, Minimum, and Step properties.

See Also

Scan Class | Scan Members


GetCurrentDataSource method

Newtone.ImageKit.WPF.Scan.GetCurrentDataSource Method

This method retrieves information about the scan device currently being selected.

[Visual Basic]Public Function GetCurrentDataSource() As Newtone.ImageKit.DataSourceInformation
[C#]public Newtone.ImageKit.DataSourceInformation GetCurrentDataSource();

Return Value

The DataSourceInformation class (Returns null[C#] or Nothing[Visual Basic] if unsuccessful).

Explanation

The GetCurrentDataSource method retrieves information about the scan device currently being selected. If successful, information about the scan device is set in the following properties: Manufacturer, ProductFamily, ProductName, ProtocolMajor, ProtocolMinor, MajorVersion, MinorVersion, and Information of the DataSourceInformation class.

To execute the GetCurrentDataSource method, you must first execute the Initialize method.

See Also

Scan Class | Scan Members


GetDataSources method

Newtone.ImageKit.WPF.Scan.GetDataSources Method

This method retrieves information about the specified scan device, such as manufacturer, product name, etc.

[Visual Basic] Public Function GetDataSources() As Newtone.ImageKit.DataSourceInformation()
[C#] public Newtone.ImageKit.DataSourceInformation[] GetDataSources();

Return Value

Value is an array of the DataSourceInformation class. (Returns null [C#] or Nothing [Visual Basic] if unsuccessful).

Explanation

The GetDataSources method retrieves information about the specified scan device, such as manufacturer, product name, etc. If successful, the installed datasources (scan devices) are returned and the index of the current datasource is set in the CurrentIndex property.

To execute the GetDataSources method, you must first execute the Initialize method.

See Also

Scan Class | Scan Members


GetMinimumSize method

Newtone.ImageKit.WPF.Scan.GetMinimumSize Method

This method retrieves the smallest size that can be scanned with a given scan device.

[Visual Basic] Public Function GetMinimumSize() As SizeF Public Function GetMinimumSize(ByVal dpiX As Integer, ByVal dpiY As Integer) As SizeF
[C#] public SizeF GetMinimumSize(); public SizeF GetMinimumSize(int dpiX, int dpiY);

Parameters

dpiX
The horizontal resolution (in dots per inch)
dpiY
The vertical resolution (in dots per inch)

Return Value

The smallest size (If unsuccessful. the Width and Height parameters of the SizeF structure returns 0)

Explanation

The GetMinimumSize method retrieves the smallest size that can be scanned with a given scan device. To retrieve the smallest size the DataSourceName, Mode, and Unit properties must be set. If the DataSourceName property is blank then prior to executing this method, please execute the SelectDataSource method. (If the OpenDataSource method has been executed, the DataSourceName is disabled and the open scan device will be used.) Set the Mode property from 0 to 2 and set the Unit to values supported by the datasource (scan device). The Width and Height parameters of the SizeF structure will return values depending on the Mode and Unit properties.

To execute the GetMinimumSize method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetMinimumSize method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

See Also

Scan Class | Scan Members


GetPhysicalSize method

Newtone.ImageKit.WPF.Scan.GetPhysicalSize Method

This method retrieves the largest physical size that can be scanned with a given scan device.

[Visual Basic] Public Function GetPhysicalSize() As SizeF Public Function GetPhysicalSize(ByVal dpiX As Integer, ByVal dpiY As Integer) As SizeF
[C#] public SizeF GetPhysicalSize(); public SizeF GetPhysicalSize(int dpiX, int dpiY);

Parameters

dpiX
Horizontal Resolution (in dots per inch)
dpiY
Vertical Resolution (in dots per inch)

Return Value

The largest physical size (if unsuccessful, the Width and Height properties of the SizeF structure returns 0)

Explanation

The GetPhysicalSize method retrieves the largest physical size that can be scanned with a given scan device. To retrieve the largest physical size the DataSourceName, Mode, and Unit properties must be set. If the DataSourceName property is blank then prior to executing this method, please execute the SelectDataSource method. (If the OpenDataSource method has been executed, the DataSourceName is disabled and the open scan device will be used.) Set the Mode property from 0 to 2 and set the Unit to values supported by the datasource (scan device). The Width and Height parameters of the SizeF structure will return values depending on the Mode and Unit properties. If Unit is set to Pixel and no parameter is passed then the current resolution (dpi) will be used.

To execute the GetPhysicalSize method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetPhysicalSize method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

See Also

Scan Class | Scan Members


Initialize method

Newtone.ImageKit.WPF.Scan.Initialize Method

This method starts the TWAIN process.

[Visual Basic]Public Function Initialize(ByVal hWnd As IntPtr, ByVal majorNumber As Integer, ByVal minorNumber As Integer, ByVal versionInfomation As String, ByVal manufacturer As String, ByVal productFamily As String, ByVal productName As String) As Boolean
[C#]public bool Initialize(IntPtr hWnd, int majorNumber, int minorNumber, string versionInfomation, string manufacturer, string productFamily, string productName);

Parameters

hWnd
The form window handle
majorNumber
The major version number of the application (If the version is 1.00, then this value will be 1)
minorNumber
The minor version number of the application (If the version is 1.00, then this value will be 0)
versionInfomation
The application version information (up to 32 bytes)
manufacturer
The name of the manufacturer of the application (up to 32 bytes)
productFamily
The application's product family name (up to 32 bytes)
productName
The application's product name (up to 32 bytes)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Initialize method starts the TWAIN process. When using TWAIN functions, the Initialize method must be executed. MajorNumber, MinorNumber, VersionInfomation, Manufacturer, ProductFamily, ProductName parameters are used to notify TWAIN of various information about the application.

See Also

Scan Class | Scan Members


IsCapabilitySupported method

Newtone.ImageKit.WPF.Scan.IsCapabilitySupported Method

This method confirms whether or not a functionality is supported by the datasource (scan device).

[Visual Basic] Public Function IsCapabilitySupported(ByVal capability As Newtone.ImageKit.WPF.ScanCapability) As Boolean
[C#] public bool IsCapabilitySupported(Newtone.ImageKit.WPF.ScanCapability capability);

Parameters

capability
The number for the retrieved functionality in hexadecimal (A member of ScanCapability)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The IsCapabilitySupported method confirms whether or not a functionality is supported by the datasource (scan device). To retrieve the supported range for a functionality, the DataSourceName property must be set. If the DataSourceName property is blank then prior to executing this method, please execute the SelectDataSource method. (If the OpenDataSource method has been executed, the DataSourceName is disabled and the open scan device will be used.

To execute the IsCapabilitySupported method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the IsCapabilitySupportedmethod then the open datasource cannot be used by another application until that datasource (scan device) is closed.

After executing this method, the values are set in the Value property.

The values set in the Value property:

Parameter | The setting value
Document feeder function (FeederEnabled) | 0: cannot be used (document plate can be used), 1: feeder can be used, 2: both document plate and feeder can be used
The function that checks whether or not there is paper in the document feeder (FeederLoaded) | 0: there is no paper, 1: there is paper
Indicator | 0: cannot use indicator, 1: can use indicator
UI control function ( UIControllable ) | 0: must use manufacturer's UI only, 1: manufacturer's UI can be suppressed
The function that checks whether the device's operating state (DeviceOnline) | 0: Device does not respond, 1: Device is operating
The function that transfers thumbnail images (ThumbnailEnabled) | 0: cannot transfer thumbnails, 1: can transfer thumbnails
Duplex scanning with the document feeder is supported (Duplex) | 0: 0: can not scan both sides, 1: can scan both sides at once, 2: can scan both sides but takes two scans
EnableDataSourceOnly | 0: Cannot display setting interface, 1: Setting interface can be displayed
CustomDataSourceData | 0: Not possible to retrieve or set UI value, 1: Can retrieve or set value in UI
Automatic Brightness (AutoBright) | 0: Automatic brightness cannot be used, 1: Automatic brightness can be used.
The undefined size (UndefinedImageSize) | In general, 0: undefined size cannot be used, 1: undefined size can be used. However, with certain Epson scan drivers the following values are set, 0: undefined size cannot be used, 1: possible only with document plate, 2: possible only with ADF, 3: possible with both document plate and ADF
How many images are in a digital camera (ImageDataSet) | the returned number is the number of images
BorderDetection | 0: border detection is not possible, 1: border detection is possible
Deskew | 0: cannot use deskew, 1: can use deskew, 2: can use deskew with smoothing 2 is only available for certain Panasonic scan drivers. In that case, 1 can be used.
the maximum resolution when using a moire filter (MoireFilterMaxResolution) | the value is that maximum resolution Available only for certain Epson scan drivers
RotateBack when using ADF in duplex mode (RotateBack) | 0: rotating the back side is not possible, 1: rotating the back side is possible Available only for certain Epson "Epson Scan" scan drivers
Automatically detecting ratio of BW/Color (PixelAutomation) | 0: cannot automatically detect BW/Color, 1: can automatically detect BW/Color Available only for certain Panasonic, Canon DR, and PFU (Fujitsu) scan drivers
MultiStream | 0: multi-stream is not possible, 1: multi-stream is possible (Multi-stream is where 1 scan of the document plate results in retrieving two images of different pixel types) Available only for certain Panasonic scan drivers
TextOrientationRecognition or Automatic rotation | 0: Automatic orientation based on text is not possible, 1: Automatic orientation based on text is possible Available only for certain Canon DR or Panasonic scan drivers. Canon DR scan drivers use "Text Orientation Recognition" whereas Panasonic scan drivers use "Automatic Image Orientation".
Punch hole removal (RemoveHole) | 0: Cannot use remove punch hole, 1: Remove punch hole is possible Available only for certain Canon DR, Epson, PFU, or Panasonic scan drivers.
Border adjustment (Border) | 0: Cannot adjust border, 1: Can adjust border Available only for certain Epson or Panasonic scan drivers.
Gamma adjustment (AdjustGamma) | 0: Cannot adjust gamma, 1: Can adjust gamma. Available only for certain Epson scan drivers.

If the return value of the IsCapabilitySupported method is False, then -1 is set in the Value property.

See Also

Scan Class | Scan Members


IsOpenDataSource method

Newtone.ImageKit.WPF.Scan.IsOpenDataSource Method

This method checks whether or not the scan devices are open.

[Visual Basic]Public Function IsOpenDataSource() As Boolean
[C#]public bool IsOpenDataSource();

Return Value

Returns True when open. Returns False when not open.

Explanation

The IsOpenDataSource method checks whether or not the scan devices are open. If the OpenDataSource method is executed prior to the IsOpenDataSource method and the scan devices are open then the return value of this method is True.

See Also

Scan Class | Scan Members


OpenDataSource method

Newtone.ImageKit.WPF.Scan.OpenDataSource Method

This method opens the scan datasource (scan device).

[Visual Basic]Public Function OpenDataSource() As Boolean
[C#]public bool OpenDataSource();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The OpenDataSource method opens the datasource set in the DataSourceName property. If the DataSourceName property is blank, please execute the SelectDataSource method prior to executing the OpenDataSource method. (When the DataSourceName property is blank, null, or Nothing, the datasource is selected by the SelectDataSource method).

Note: After the OpenDataSource method has been executed, the datasource remains open until the CloseDataSource method is executed and other applications will not be able to be used.

Prior to executing the OpenDataSource and CloseDataSource methods, you must execute the Initialize method.

See Also

Scan Class | Scan Members


SelectDataSource method

Newtone.ImageKit.WPF.Scan.SelectDataSource Method

This method selects the scan device.

[Visual Basic]Public Function SelectDataSource() As Newtone.ImageKit.DataSourceInformation
[C#]public Newtone.ImageKit.DataSourceInformation SelectDataSource();

Return Value

The DataSourceInformation class (Returns null[C#] or Nothing[VB.NET] if unsuccessful or canceled.

Explanation

The SelectDataSource method selects the scan device. When this method is executed, the installed TWAIN drivers are listed in a dialog box and can be selected. If successful, information about the scan device is set in the following properties: Manufacturer, ProductFamily, ProductName, ProtocolMajor, ProtocolMinor, MajorVersion, MinorVersion, and Information of the DataSourceInformation class.

Prior to executing the SelectDataSource method, you must execute the Initialize method.

See Also

Scan Class | Scan Members


Terminate method

Newtone.ImageKit.WPF.Scan.Terminate Method

This method ends the TWAIN process.

[Visual Basic]Public Function Terminate() As Boolean
[C#]public bool Terminate();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Terminate method ends the TWAIN process. This method must be used in conjunction with the Initialize method.

See Also

Scan Class | Scan Members


AfterScan event

Newtone.ImageKit.WPF.Scan.AfterScan Event

This event is generated after an image is scanned with the scan device.

[Visual Basic]Public Event AfterScan As AfterScanEventHandler
[C#]public event AfterScanEventHandler AfterScan;

Event Data

The event handler receives arguments of type AfterScanEventArgs

Explanation

The AfterScanevent is generated after an image is scanned with the scan device. Information about the actual image data transfered in this event can be referenced through the AfterScanEventArgs arguments.

When the Dispose arguement is true, the scanned image data (Bitmap1 and Bitmap2) is disposed after this event fires so if you want to use this image data in any way, you must make a copy of the scanned image in the memory or save it in an image file. When the Dispose argument is false the scanned image data (Bitmap1 and Bitmap2) will not be disposed.

(1) When using native transfer or when using memory transfer without compression:

If the scanned image is 1, 4, 8, or 24 bits then the image is set in Bitmap1 and Bitmap2 will be null (Nothing in Visual Basic). If the scanned image is 12, 14, or 16 bit grayscale or 36, 42, or 48 bit color then the image will be set in Bitmap2 and the Bitmap2 image data will be converted to 8 bit grayscale or 24 bit color and that will be set in Bitmap1. In this case, if the Bitmap1 memory cannot be allocated it will be null (Nothing in Visual Basic)

(2) When using memory transfer with compression:

The scanned image is set into RawData. Both Bitmap1 and Bitmap2 will be null (Nothing in Visual Basic)

(3) When using file transfer:

Both Bitmap1 and Bitmap2 will be null (Nothing in Visual Basic). The file will be saved in the location specified by FileName

When Scan.UserInterface property is set to Suppress and the Scan.Unit property is Pixel, there are cases in which the resolution of Bitmap1 and Bitmap2 will be 1. To cancel scanning set the Cancel property to True.

Example

The following code displays the image scanned.

[Visual Basic.NET]
Private Scan As Newtone.ImageKit.WPF.Scan

Private Sub Form1_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Scan = New Newtone.ImageKit.WPF.Scan
    ' Events
    AddHandler Scan.BeforeScan, AddressOf Scan_BeforeScan
    AddHandler Scan.Scanning, AddressOf Scan_Scanning
    AddHandler Scan.AfterScan, AddressOf Scan_AfterScan
    ' Initialization
    Scan.Initialize(Me.Handle, 1, 0, "ImageKit.NET Sample", "NEWTONE Corp.", "ImageKit", "ImageKit.NET")
End Sub

Private Sub Scan_AfterScan(ByVal sender As Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs)
    If e.Bitmap1 Is Nothing Then Exit Sub

    If Not (pictureBox1.Image Is Nothing) Then
         PictureBox1.Image.Dispose()
    End If
    PictureBox1.Image = e.Bitmap1.Clone()
End Sub

[Visual C#.NET]
private Newtone.ImageKit.WPF.Scan scan;

private void Form1_Load(object sender, System.EventArgs e)
{
    scan = new Newtone.ImageKit.WPF.Scan();
    // Events
    scan.BeforeScan += new Newtone.ImageKit.BeforeScanEventHandler(scan_BeforeScan);
    scan.Scanning += new Newtone.ImageKit.ProgressEventHandler(scan_Scanning);
    scan.AfterScan += new Newtone.ImageKit.AfterScanEventHandler(scan_AfterScan);
    // Initialization
    scan.Initialize(this.Handle, 1, 0, "ImageKit.NET Sample", "NEWTONE Corp.", "ImageKit", "ImageKit.NET");
}

private void scan_AfterScan(object sender, Newtone.ImageKit.AfterScanEventArgs e)
{
    if (e.Bitmap1 == null) return;

    if (pictureBox1.Image != null)
        pictureBox1.Image.Dispose();

    pictureBox1.Image = (Image)e.Bitmap1.Clone();
}

See Also

Scan Class | Scan Members


BeforeScan event

Newtone.ImageKit.WPF.Scan.BeforeScan Event

This event is generated just before an image is scanned with the scan device.

[Visual Basic]Public Event BeforeScan As BeforeScanEventHandler
[C#]public event BeforeScanEventHandler BeforeScan;

Event Data

The event handler receives arguments of type BeforeScanEventArgs

Explanation

The BeforeScan event is generated just before an image is scanned with the scan device. Information about the actual image data transfered in this event can be referenced through the BeforeScanEventArgs arguments.

Regarding properties of the BeforeScanEventArgs class

If setting the Scan.PaperSize property to UndefinedSize (or values of 1000 or more), the values for the Width and Height properties of this class can be set to -1.
To cancel, set the Scan.Cancel property to True within this event.

See Also

Scan Class | Scan Members


Scanning event

Newtone.ImageKit.WPF.Scan.Scanning Event

This event is generated when an image is being scanned by the scan device.

[Visual Basic] Public Event Scanning As ProgressEventHandler
[C#] public event ProgressEventHandlerScanning;

Event Data

The event handler receives arguments of type ProgressEventArgs

Explanation

This event is generated when an image is being scanned by the scan device. To retreive the percentage that the current process has completed within this event, refer to the ProgressEventArgs arguments.

The Scanning event is only enabled when using memory transfer. It is not generated when native transfer or file transfer is used. Also, when memory transfer is used, if compression is used and the BeforeScan event's Width and Height properties of the BeforeScanEventArgs class have a value of -1, then the Scanning event is not generated.

Regarding properties of the ProgressEventArgs class:

The Percent property can retrieve the percentage of process completed; to cancel, set the Cancel property to True within this event.

See Also

Scan Class | Scan Members


ScanBitDepthReduction enum

Newtone.ImageKit.WPF.ScanBitDepthReduction Enum

This enumeration refers to the method used to reduce the bit depth when scanning in 1 bit color.

public enum ScanBitDepthReduction

Public Members

Member | Value | Explanation
Threshold | 0 | Threshold
Halftone | 1 | Halftone
CustomHalftone | 2 | Custom halftone *1
Diffusion | 3 | Diffusion

Explanation

*1 This is a TWAIN setting that is not supported by the ImageKit.NET.

See Also

Scan Members | Newtone.ImageKit


ScanCapability enum

Newtone.ImageKit.WPF.ScanCapability Enum

This enumeration refers to the types of Capability.

public enum ScanCapability

Public Members

Member | Value | Explanation
Compression | 256 | Compression method
PixelType | 257 | Pixel type
Unit | 258 | The units of measurement
Transfer | 259 | Transfer method
FeederEnabled | 4098 | Document feeder function
FeederLoaded | 4099 | The function that checks whether or not there is paper in the document feeder
Indicator | 4107 | Indicator
UIControllable | 4110 | UI control function
DeviceOnline | 4111 | The function that checks the device's operating state
ThumbnailEnabled | 4113 | The function that transfers thumbnail images
Duplex | 4114 | Duplex scanning with the document feeder is supported
DuplexEnabled | 4115 | Duplex scanning with the document feeder is enabled
EnableDataSourceUIOnly | 4116 | Display setting interface
CustomDataSourceData | 4117 | Retrieve or set UI values
AutoBright | 4352 | Automatic brightness adjustment
Brightness | 4353 | Brightness
Contrast | 4355 | Contrast
Fiter | 4358 | Filter
Gamma | 4360 | Gamma
Halftone | 4361 | Halftone
Highlight | 4362 | Highlight
ImageFileFormat | 4364 | ImageFileFormat
DropoutColor | 4366 | DropoutColor
Orientation | 4368 | Paper orientation
Shadow | 4371 | Shadow
XResolution | 4376 | The horizontal scan resolution
YResolution | 4377 | The vertical scan resolution
PaperSize | 4386 | PaperSize
Threshold | 4387 | Threshold
XScaling | 4388 | The horizontal scaling
YScaling | 4389 | The vertical scaling
BitDepthReduction | 4396 | The method used to reduce the bit depth when scanning in 1 bit color
UndefinedImageSize | 4397 | The undefined size
ImageDataSet | 4398 | How many images are in a digital camera
AutoDiscardBlankPages | 4404 | Automatically skip blank pages (Standard Twain Capability)
ImageFilter | 4423 | ImageFilter
NoiseFilter | 4424 | NoiseFilter
BorderDetection | 4432 | BorderDetection
Deskew | 4433 | Deskew
AutomaticRotate | 4434 | Automatic rotation
JpegQuality | 4435 | JpegQuality
AutoSize | 4438 | Auto page size recognition
AutomaticColorEnabled | 4441 | Auto color recognition
ImageMerge | 4444 | Double sided composition
ScanningSpeed | 61441 | ScanningSpeed
MoireFilter | 61442 | MoireFilter
MoireFilterMaxResolution | 61443 | The maximum resolution when using a moire filter
Sharpness | 61444 | Sharpness
RotateBack | 61445 | RotateBack when using ADF in duplex mode
ExtendedUserInterface | 61446 | ExtendedUserInterface
DynamicThreshold | 61447 | DynamicThreshold
PixelAutomation | 61448 | Automatically detecting ratio of BW/Color
MultiStream | 61449 | MultiStream
TextOrientationRecognition | 61450 | Automatically recognizes orientation from text.
SkipBlankPage | 61451 | Automatically skips blank pages.
RemoveHole | 61452 | Automatically removes punch holes.
FocusPosition | 61453 | FocusPostion
TextEnhancement | 61454 | TextEnhancement
Border | 61455 | Border Functions
AdjustGamma | 61456 | Gamma Adjustmen

See Also

Scan Members | Newtone.ImageKit


ScanCompression enum

Newtone.ImageKit.WPF.ScanCompression Enum

This enumeration refers to the compression method used when an image is transferred via memory.
public enum ScanCompression

Public Members

Member | Value | Explanation
None | 0 | Uncompressed
Packbits | 1 | PACKBITS (TIFF or PICT)
Group3_1D | 2 | GROUP3 1D (TIFF)
Group3_1D_EOL | 3 | GROUP3 1D End Of Line (TIFF)
Group3_2D | 4 | GROUP3 2D (TIFF)
Group4 | 5 | GROUP4 (TIFF)
Jpeg | 6 | JPEG (TIFF or JFIF or SPIFF)
Lzw | 7 | LZW (TIFF)
Jbig | 8 | JBIG (TIFF or SPIFF)
Png | 9 | PNG
Rle4 | 10 | RLE4 (BMP)
Rle8 | 11 | RLE8 (BMP)
BitFields | 12 | BITFIELDS (BMP)

Explanation

The values 2, 3, 4, and 5 are in FAX[CCITT] format. The values 10, 11 and 12 are in BMP format. Parenthesis () in the explanation section refers to the image file format when the file is transferred.

See Also

Scan Members | Newtone.ImageKit


ScanDropoutColor enum

Newtone.ImageKit.WPF.ScanDropoutColor Enum

This enumeration refers to the dropout color.

public enum ScanDropoutColor

Public Members

Member | Value | Explanation
Red | 0 | Red
Green | 1 | Green
Blue | 2 | Blue
None | 3 | None
White | 4 | White
UV | 5 |
IR | 6 |

See Also

Scan Members | Newtone.ImageKit


ScanFileFormat enum

Newtone.ImageKit.WPF.ScanFileFormat Enum

This enumeration refers to the file format when saving a file using file transfer.

public enum ScanFileFormat

Public Members

Member | Value | Explanation
Tiff | 0 | TIFF
Pict | 1 | PICT
Bmp | 2 | BMP
Xbm | 3 | XBM
Jfif | 4 | JPEG
Fpx | 5 | FlashPix
TiffMulti | 6 | TIFF Multi
Png | 7 | PNG
Spiff | 8 | JPEG, JBIG
Exif | 9 | EXIF
Pdf | 10 | Pdf
Jp2 | 11 | JPEG 2000 Part 1
Jpx | 13 | JPEG 2000 Part 2
Dejavu | 14 | Dejavu

See Also

Scan Members | Newtone.ImageKit


ScanImageFilter enum

Newtone.ImageKit.WPF.ScanImageFilter Enum

This enumeration refers to the image filter.

public enum ScanImageFilter

Public Members

Member | Value | Explanation
None | 0 | None
Auto | 1 | Automation
LowPass | 2 | *1
BandPass | 3 | *2
HighPass | 4 | *3
Text | 3 | *2
FineLine | 4 | *3

Explanation

*1 LOWPASS is recommended for haftone images
*2 BANDPASS is recommended for images that include text
*3 HIGHPASS is recommended for images that include lines

See Also

Scan Members | Newtone.ImageKit


ScanImageMerge enum

Newtone.ImageKit.WPF.ScanImageMerge Enum

This enumeration refers to the image merge.

public enum ScanImageMerge

Public Members

Member | Value | Explanation
None | 0 | Images from both sides of the document are not merged
FrontOnTop | 1 | The front image is on top and the back image is on the bottom
BottomOnTop | 2 | The back image is on top and the front image is on the bottom
FontOnLeft | 3 | The front image is on the right and the back image is on the left
FontOnRight | 4 | The front image is on the left and the back image is on the right

See Also

Scan Members | Newtone.ImageKit


ScanMode enum

Newtone.ImageKit.WPF.ScanMode Enum

This enumeration refers to the scanning mode.

public enum ScanMode

Public Members

Member | Value | Explanation
DocumentPlate | 0 | Document plate
ADFOneSide | 1 | ADF Simplex
ADFBothSide | 2 | ADF Duplex
Camera | 3 | The original images in the digital camera
CameraArray | 4 | The original images in the digital camera (using an array)
CameraThumbnail | 5 | The thumbnail images in the digital camera
CameraThumbnailArray | 6 | The thumbnail images in the digital camera (using an array)

See Also

Scan Members | Newtone.ImageKit


ScanNoiseFilter enum

Newtone.ImageKit.WPF.ScanNoiseFilter Enum

This enumeration refers to the noise reduction filter.
public enum ScanNoiseFilter

Public Members

Member | Value | Explanation
None | 0 | None
Auto | 1 | Automatic
LonePixel | 2 |
MajorityRule | 3 |

See Also

Scan Members | Newtone.ImageKit


ScanOrientation enum

Newtone.ImageKit.WPF.ScanOrientation Enum

This enumeration refers to the orientation of the paper.
public enum ScanOrientation

Public Members

Member | Value | Explanation
Rotate0 | 0 | 0 degrees
Rotate90 | 1 | 90 degrees
Rotate180 | 2 | 180 degrees
Rotate270 | 3 | 270 degrees
Portrait | 0 | Portrait
Landscape | 3 | Landscape
TextOrientationRecognition | 1000 | Text Orienation Recognition (*1, *2) or automatic rotation

Explanation

TextOrientationRecognition detects the text orientation in scanned images and rotates the images in 90 degree increments to normalize text orientation. Canon DR scan drivers use "Text Orientation Recognition" whereas Panasonic scan drivers use "Automatic Image Orientation".

*1 Enabled for certain Canon DR scan drivers.
*2 Enabled for cetain Panasonic scan drivers.

See Also

Scan Members | Newtone.ImageKit


ScanOverScan enum

Newtone.ImageKit.WPF.ScanOverScan Enum

This enumeration lists the possible overscan values.

public enum ScanOverScan

Public Members

member Name | Value | Explanation
None | 0 | No overscan will occur
Auto | 1 | The device controls what kind of overscan will occur
TopBottom | 2 | Vertical overscan will occur
LeftRight | 3 | Horizontal overscan will occur
All | 4 | Both horizontal and vertical overscan will occur.

See Also

Scan Members | Newtone.ImageKit


ScanPaperSize enum

Newtone.ImageKit.WPF.ScanPaperSize Enum

This enumeration refers to the size of the paper.
public enum ScanPaperSize

Public Members

Member | Value | Explanation
UserSize | 0 | User defined size
A4Letter | 1 | A4 letter 210mm x 297mm
B5Letter | 2 | B5 letter 182mm x 257mm
USLetter | 3 | US letter 8.5" x 11.0" (216mm x 280mm)
USLegal | 4 | US legal 11.0" x 17.0" (216mm x 356mm)
A5 | 5 | A5 148mm x 210mm
B4 | 6 | ISO B4 250mm x 353mm
B6 | 7 | ISO B6 125mm x 176mm
USLedger | 9 | US ledger 11.0" x 17.0" (280mm x 432mm)
USExecutive | 10 | US exective 7.25" x 10.5" (184mm x 267mm)
A3 | 11 | A3 297mm x 420mm
B3 | 12 | ISO B3 353mm x 500mm
A6 | 13 | A6 105mm x 148mm
C4 | 14 | C4 229mm x 324mm
C5 | 15 | C5 162mm x 229mm
C6 | 16 | C6 114mm x 162mm
FourA0 | 17 | 4A0 1682mm x 2378mm
TwoA0 | 18 | 2A0 1189mm x 1682mm
A0 | 19 | A0 841mm x 1189mm
A1 | 20 | A1 594mm x 841mm
A2 | 21 | A2 420mm x 594mm
A4 | 1 | A4 210mm x 297mm
A7 | 22 | A7 74mm x 105mm
A8 | 23 | A8 52mm x 74mm
A9 | 24 | A9 37mm x 52mm
A10 | 25 | A10 26mm x 37mm
ISOB0 | 26 | ISO B0 1000mm x 1414mm
ISOB1 | 27 | ISO B1 707mm x 1000mm
ISOB2 | 28 | ISO B2 500mm x 707mm
ISOB3 | 12 | ISO B3 353mm x 500mm
ISOB4 | 6 | ISO B4 250mm x 353mm
ISOB5 | 29 | ISO B5 176mm x 250mm
ISOB6 | 7 | ISO B6 125mm x 176mm
ISOB7 | 30 | ISO B7 88mm x 125mm
ISOB8 | 31 | ISO B8 62mm x 88mm
ISOB9 | 32 | ISO B9 44mm x 62mm
ISOB10 | 33 | ISO B10 31mm x 44mm
JISB0 | 34 | JIS B0 1030mm x 1456mm
JISB1 | 35 | JIS B1 728mm x 1030mm
JISB2 | 36 | JIS B2 515mm x 728mm
JISB3 | 37 | JIS B3 364mm x 515mm
JISB4 | 38 | JIS B4 257mm x 364mm
JISB5 | 2 | JIS B5 182mm x 257mm
JISB6 | 39 | JIS B6 128mm x 182mm
JISB7 | 40 | JIS B7 91mm x 128mm
JISB8 | 41 | JIS B8 64mm x 91mm
JISB9 | 42 | JIS B9 45mm x 64mm
JISB10 | 43 | JIS B10 32mm x 45mm
C0 | 44 | C0 917mm x 1297mm
C1 | 45 | C1 648mm x 917mm
C2 | 46 | C2 458mm x 648mm
C3 | 47 | C3 324mm x 458mm
C7 | 48 | C7 81mm x 114mm
C8 | 49 | C8 57mm x 81mm
C9 | 50 | C9 40mm x 57mm
C10 | 51 | C10 28mm x 40mm
USStatement | 52 | US statement 5.5" x 8.5" (140mm x 216mm)
BusinessCard | 53 | Business card 90mm x 55mm
UndefinedSize | 1000 | Undefined size

See Also

Scan Members | Newtone.ImageKit


ScanPixelType enum

Newtone.ImageKit.WPF.ScanPixelType Enum

This enumeration refers to the type of image scanned.

public enum ScanPixelType

Public Members

Member | Value | Explanation
BW | 0 | Black and White
Gray | 1 | Grayscale
RGB | 2 | RGB color
Palette | 3 | Palette color
CMY | 4 | CMY color *1
CMYK | 5 | CMYK color *1
YUV | 6 | YUV color *1
YUVK | 7 | YUVK color *1
CIEXYZ | 8 | CIEXYZ color *1
Automation | 1000 | Automation (1bit or 24bit)
GrayAndBW | 1001 | Black and White 1 bit Color and Grayscale *2, *5
RGBAndBW | 1002 | Black and White 1 bit Color and RGB *2, *5

Explanation

Automation distinguishes between "black and white" or RGB color when scanning the document plate.

*1 Not supported when the UserInterface property is suppressed.
*2 Enabled for certain Panasonic scanners
*3 Enabled for certain Canon DR scanners.
*4 Enabled for certain Epson scanners.
*5 Enabled for certain PFU (Fujitsu) scan drivers.

See Also

Scan Members | Newtone.ImageKit


ScanTransfer enum

Newtone.ImageKit.WPF.ScanTransfer Enum

This enumeration refers to the transfer method.

public enum ScanTransfer

Public Members

Member | Value | Explanation
Native | 0 | Native (Transferred as DIB)
File | 1 | File
Memory | 2 | Memory (Transferred in block units)
File2 | 3 | File2 *1

Explanation

*1 The ImageKit does not support transfer method 3 (File2)

See Also

Scan Members | Newtone.ImageKit


ScanUnit enum

Newtone.ImageKit.WPF.ScanUnit Enum

This enumeration refers to the units of measurement.

public enum ScanUnit

Public Members

Member | Value | Explanation
Inch | 0 | Inches
Centimeter | 1 | Centimeters
Pica | 2 | Pica
Point | 3 | Points
Twip | 4 | twips
Pixel | 5 | Pixels

See Also

Scan Members | Newtone.ImageKit


ScanUserInterface enum

Newtone.ImageKit.WPF.ScanUserInterface Enum

This enumeration refers to the user interface and how it will be used.
public enum ScanUserInterface

Public Members

Member | Value | Explanation
Show | 0 | The scan device manufacturer's user interface is displayed. It is not closed after the scan is complete
ShowandClose | 1 | The scan device manufacturer's user interface is displayed. It is closed after the scan is complete
Suppress | 2 | The scan device manufacturer's user interface is suppressed. A custom built user interface is used

See Also

Scan Members | Newtone.ImageKit


ProgressEventArgs class

Newtone.ImageKit

Newtone.ImageKit.WPF.ProgressEventArgs Class

This provides data of the Progress and the Scanning events.

[Visual Basic] Public Class ProgressEventArgs Inherits EventArgs
[C#] public class ProgressEventArgsF EventArgs

Explanation

Property | Type | Explanation
Cancel | Boolean (Visual Basic) bool(C#) | Sets whether or not the loading or saving an image is canceled
Percent | Integer (Visual Basic) int(C#) | The percent of completion of the current process


ProgresstEventHandler delegate

Newtone.ImageKit

Newtone.ImageKit.WPF.ProgressEventHandler Delegate

The Progress event for scanning methods.
[Visual Basic] Public Delegate Sub ProgressEventHandler(ByVal sender As Object, ByVal e As ProgressEventArgs)
[C#] public delegate void ProgressEventHandler(object sender, ProgressEventArgs e);

Parameters

sender The event source

e The ProgressEventArgs containing Event Data


ScanMode enum

Newtone.ImageKit

Newtone.ImageKit.WPF.Error Enum

Refers to the error status

public enum Error

Public Members

Member | Value | Explanation
None | 0 | No error has occurred
Cancel | 1 | The process was canceled
ETC | 2 | An unspecified error has occurred
Memory | 3 | A memory error has occurred
Support | 4 | This function is not supported
Value | 5 | An incorrect value has been set
File | 6 | The file is incorrect or corrupted
Image | 7 | The image is incorrect or corrupted
Twain32Load | 8 | Twain_32.dll can not load. This is no longer supported but is here for backward compatibility. In the ImageKit.NET3, use TwainLoad
TwainLoad | 8 | Twain_32.dll or the TwainDSM.dll could not load.
Draw | 9 | An error has occurred while drawing on or displaying an image
ImageSupport | 10 | That image format is not supported
Step | 11 | The order of execution is incorrect
ADFNoPaper | 12 | There is no paper in the ADF
DigitalCameraNoImage | 13 | There are no images in the digital camera (UI suppressed only)
DllUnload | 14 | The DLL is not loaded
Trans | 15 | Transmission error
FileNotFound | 16 | Cannot find file
FileCorrupt | 17 | The file is corrupted
Timeout | 18 | A timeout has occurred. The process has been cancelled
TransDenied | 19 | The username and/or password is incorrect. Access denied.
FileOpen | 20 | Cannot open file
FileCreate | 21 | Cannot create file
FileWrite | 22 | Cannot save file
FileRead | 23 | Cannot load file
NoImage | 24 | There is no image data to display
Directory | 25 | Directory related error
FileSave | 26 | File could not be saved
PDFFileCreate | 27 | PDF file could not be created
PDFAddPage | 28 | Page could not be added to PDF file
PDFAddImage | 29 | Image could not be added to PDF file
ThumbnailConfigFile | 50 | The ConfigFile is not set
ThumbnailImageDirectory | 51 | The ImageDirectory is not set
ThumbnailThumbImageDirectory | 52 | The ThumbnailImageDirectory is not set
ThumbnailImageFileExtension | 53 | The ImageFileExtension is not set
ThumbnailImageWidth | 54 | The Imagewidth is not set
ThumbnailImageHeight | 55 | The Imageheight is not set
Twain32Entry | 101 | There is no entry point for the Twain_32.dll. This is no longer used but is kept for backward compatibility. Use TwainEntry instead.
TwainEntry | 101 | There is no entry point for the Twain_32.dll or the TwainDSM.dll
DsmOrDsOpen | 102 | The data source manager and the data source haven't been opened or can't be open
NoDataSource | 103 | There is no data source
MaxConnections | 104 | The data source is already connected to the maximum number of applications
Operation | 105 | An error has occurred in the data source or in the data source manager
BadProtocol | 106 | An unconfirmed triplet has occurred (TWAIN - DG_XXX/DAT_XXX/MSG_XXX)
DeviceOnline | 107 | Check the scan device's operating state
PaperJam | 108 | Paper is jammed in the feeder
PaperDoubleFeed | 109 | Multiple sheets of paper have been fed into the feeder
BadResolution | 110 | The resolution is incorrect
CoverOpen | 111 | The cover is open
DamagedCorner | 112 | A corner of the document is damaged
FocusError | 113 | A focus error occurred during the scan
DocTooLight | 114 | The document is too light
DocTooDark | 115 | The document is too dark
NoMedia | 116 | Image information could not retrieved or transferred
DirectX | 201 | The DirectX environment is not correct
Connect | 202 | Unable to connect to the device
Interface | 203 | COM interface related error has occurred
UnsupportedLanguage | 300 | Languages not supported by the OCR function
TrialExpired | 900 | The trial version has been expired
Activation | 901 | License confirmation failed


CloseMultiTiff method

Newtone.ImageKit.WPF.IkFile.CloseMultiTiff Method

This method closes the file when a multipage tiff file is saved.

[Visual Basic]
Public Function CloseMultiTiff() As Boolean
[C#]
public bool CloseMultiTiff() ;

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CloseMultiTiff method closes the file when a multipage tiff file is saved. This method should by used when the TiffAppend property is set to True and after the SaveImageToFile method has been executed.

Please refer to the sample code on the TiffAppend property page.

Also See

IkFile Class | IkFile Members


Comment property

Newtone.ImageKit.WPF.IkFile.Comment Property

This property sets the comment that can be saved in some types of image files. By executing the GetImageFileType or the GetImageFileTypeFromRawData method, any comments that exist in an image are retrieved.

[Visual Basic]
Public Property Comment As String
[C#]
public string Comment {get; set;}

Property Value

The comment string (Maximum length:1023 bytes)

Explanation

The Comment property sets the comment that can be saved in some types of image files. By executing the GetImageFileType or the GetImageFileTypeFromRawData method, any comments that exist in an image are retrieved.

The type of comment and its syntax depends on the file format. The following image file formats support comments and their syntax is given below. If the particular image file does not support a comment, then this property is ignored for those image files.

Name | Explanation
FPX | Title+0x0d+Subtitle+0x0d+Author+0x0d+Comment+0x0d
GIF | Comment
JPEG | Comment
JPEG2000 | Title+0x0d+Subtitle+0x0d+Author+0x0d+Comment+0x0d
PNG | Title+0x0d+Author+0x0d+Explanation+0x0d+Copyright+0x0d+DateTime+0x0d+Software+0x0d+Waiver+0x0d+Warning+0x0d+Input Devices+0x0d+Comment+0x0d
TIFF | Document Name+0x0d+Image Explanation+0x0d+Page Name+0x0d+Software+0x0d+Date Time+0x0d+Author+0x0d

Note: please enter a blank string into any unnecessary fields.

* In Visual Basic, replace the 0x with &H.

To use this property, you must have the appropriate ImageKit.NET Plugin (Win32 Dll files).

See Also

IkFile Class | IkFile Members


Interlace property

Newtone.ImageKit.WPF.IkFile.Interlace Property

This property sets interlacing when saving an image as a GIF or PNG image. By executing the GetImageFileType or GetImageFileTypeFromRawData method, the Interlace property value can be retrieved.

[Visual Basic]
Public Property Interlace As Boolean
[C#]
public bool Interlace {get; set;}

Property Value

Value | Explanation
True | Interlace
False | Non interlace

Explanation

The Interlace property sets interlacing when saving an image as a GIF or PNG image. By executing the GetImageFileType or GetImageFileTypeFromRawData method, the Interlace property value can be retrieved.

To use this property, you must have the appropriate ImageKit9 DLL files.

See Also

IkFile Class | IkFile Members


JPEG2000CodeBlockHeight property

Newtone.ImageKit.WPF.IkFile.JPEG2000CodeBlockHeight Property

This property sets the height of the JPEG2000 format code block size.

[Visual Basic]
Public Property JPEG2000CodeBlockHeight As Integer
[C#]
public int JPEG2000CodeBlockHeight {get; set;}

Property Value

The height of the JPEG2000 code block size

Explanation

The JPEG2000CodeBlockHeight property sets or retrieves the height of the JPEG2000 format code block size. The default value is 0.

The JPEG2000 format code block size is measured by 2 to certain power (from 2 to 10). So setting the JPEG2000CodeBlockHeight property to 3 would mean the vertical code block size is 23 . This property value is used when images are saved in JPEG2000 file format.

To use this property, you must have the appropriate ImageKit.NET Plugin (Win32 Dll files).

See Also

IkFile Class | IkFile Members


JPEG2000CodeBlockWidth property

Newtone.ImageKit.WPF.IkFile.JPEG2000CodeBlockWidth Property

This property sets the width of the JPEG2000 format code block size.

[Visual Basic]
Public Property JPEG2000CodeBlockWidth As Integer
[C#]
public int JPEG2000CodeBlockWidth {get; set;}

Property Value

The width of the JPEG2000 code block size

Explanation

The JPEG2000CodeBlockWidth property sets or retrieves the width of the JPEG2000 format code block size. The default value is 0.

The JPEG2000 format code block size is measured by 2 to certain power (from 2 to 10). So setting the JPEG2000CodeBlockWidth property to 3 would mean the horizontal code block size is 23 . This property value is used when images are saved in JPEG2000 file format.

To use this property, you must have the appropriate ImageKit.NET Plugin (Win32 Dll files).

See Also

IkFile Class | IkFile Members


JPEG2000NumResLevel property

Newtone.ImageKit.WPF.IkFile.JPEG2000NumResLevel Property

This property sets the level of the JPEG2000 format resolution.

[Visual Basic]
Public Property JPEG2000NumResLevel As Integer
[C#]
public int JPEG2000NumResLevel {get; set;}

Property Value

The resolution level (from 0)

Explanation

The JPEG2000NumResLevel property sets the level of the JPEG2000 format resolution. The default value is 0.

The JPEG2000 format code block size is measured by 2 to certain power (from 2 to 10). This property value is used when images are saved in JPEG2000 file format.

To use this property, you must have the appropriate ImageKit.NET Plugin (Win32 Dll files).

See Also

IkFile Class | IkFile Members


JPEG2000PrecinctHeight property

Newtone.ImageKit.WPF.IkFile.JPEG2000PrecinctHeight Property

This property sets the height of the JPEG2000 format precinct size.

[Visual Basic]
Public Property JPEG2000PrecinctHeight As Integer
[C#]
public int JPEG2000PrecinctHeight {get; set;}

Property Value

The height of the JPEG2000 precinct size

Explanation

The JPEG2000PrecinctHeight property sets or retrieves the height of the JPEG2000 format precinct size. The default value is 0.

The JPEG2000 format precinct size is measured by 2 to certain power (from 0 to 15). So setting the JPEG2000PrecinctHeight property to 3 would mean the vertical precinct size is 23. This property value is used when images are saved in JPEG2000 file format.

To use this property, you must have the appropriate ImageKit.NET Plugin (Win32 Dll files).

See Also

IkFile Class | IkFile Members


JPEG2000PrecinctWidth property

Newtone.ImageKit.WPF.IkFile.JPEG2000PrecinctWidth Property

This property sets the width of the JPEG2000 format precinct size.

[Visual Basic]
Public Property JPEG2000PrecinctWidth As Integer
[C#]
public int JPEG2000PrecinctWidth {get; set;}

Property Value

The width of the JPEG2000 precinct size

Explanation

The JPEG2000PrecinctWidth property sets or retrieves the height of the JPEG2000 format precinct size. The default value is 0.

The JPEG2000 format precinct size is measured by 2 to certain power (from 0 to 15). So setting the JPEG2000PrecinctWidth property to 3 would mean the horizontal precinct size is 23. This property value is used when images are saved in JPEG2000 file format.

To use this property, you must have the appropriate ImageKit.NET Plugin (Win32 Dll files).

See Also

IkFile Class | IkFile Members


JPEG2000Reversible property

Newtone.ImageKit.WPF.IkFile.JPEG2000Reversible Property

This property sets whether or not the JPEG2000 lossless compression is reversible.

[Visual Basic]
Public Property JPEG2000Reversible As Boolean
[C#]
public bool JPEG2000Reversible {get; set;}

Property Value

Value | Explanation
True | The compression is reversible
False | The compression is not reversible

Explanation

The JPEG2000Reversible property sets whether or not the JPEG2000 lossless compression is reversible. When true, file size will be bigger but since lossless compression is used there will be no degradation in image quality.

This property value is used when images are saved in JPEG2000 file format.

To use this property, you must have the appropriate ImageKit.NET Plugin (Win32 Dll files).

See Also

IkFile Class | IkFile Members


JPEG2000Size property

Newtone.ImageKit.WPF.IkFile.JPEG2000Size Property

This property sets the size of the file when saved in JPEG2000 format.

[Visual Basic]
Public Property JPEG2000Size As Double
[C#]
public double JPEG2000Size {get; set;}

Property Value

The size of the saved image as a factor of the size of the uncompressed image

Explanation

The JPEG2000Size property sets the size of the file when saved in JPEG2000 format.

When this property is 0.01, for example, it means that the file size will be 1/100th the size of the uncompressed file. The default value is 0 meaning no compression is used.

The JPEG2000Size property is enabled when the JPEG2000Reversible property is false. This property value is used when images are saved in JPEG2000 file format.

To use this property, you must have the appropriate ImageKit.NET Plugin (Win32 Dll files).

See Also

IkFile Class | IkFile Members


JPEG2000TileHeight property

Newtone.ImageKit.WPF.IkFile.JPEG2000TileHeight Property

This property sets the height of the JPEG2000 format tile size.

[Visual Basic]
Public Property JPEG2000TileHeight As Integer
[C#]
public int JPEG2000TileHeight {get; set;}

Property Value

The height of the JPEG2000 tile size (in pixels)

Explanation

The JPEG2000TileHeight property sets or retrieves the height of the JPEG2000 format tile size. The default value is 0.

This property value is used when images are saved in JPEG2000 file format.

To use this property, you must have the appropriate ImageKit.NET Plugin (Win32 Dll files).

See Also

IkFile Class | IkFile Members


JPEG2000TileWidth property

Newtone.ImageKit.WPF.IkFile.JPEG2000TileWidth Property

This property sets the width of the JPEG2000 format tile size.

[Visual Basic]
Public Property JPEG2000TileWidth As Integer
[C#]
public int JPEG2000TileWidth {get; set;}

Property Value

The width of the JPEG2000 tile size (in pixels)

Explanation

The JPEG2000TileWidth property sets or retrieves the width of the JPEG2000 format tile size. The default value is 0.

This property value is used when images are saved in JPEG2000 file format.

To use this property, you must have the appropriate ImageKit.NET Plugin (Win32 Dll files).

See Also

IkFile Class | IkFile Members


JpegSubsampling property

Newtone.ImageKit.WPF.IkFile.JpegSubsampling Property

This property sets the YCrCb subsampling ratios when saving an image in JPEG format.

[Visual Basic]
Public Property JpegSubsampling As JpegSubsamplingKind
[C#]
public JpegSubsamplingKind JpegSubsampling {get; set;}

Property Value

This value is of type JpegSubsamplingKind

Explanation

The JpegSubsampling property sets the YCrCb subsampling ratios when saving an image in JPEG format. Since the Y (luminance or brightness) plane contains more important information about the image than does the CrCb (chrominance or color) planes, it is possible to reduce the size of the CrCb planes without a great sacrifice in quality thereby reducing the size of the image. A ratio for Y:Cr:Cb of 4:4:4 represents no reduction in size whereas a ratio of 4:1:1 represents a reduction in size of 50%.

This property is enabled when the image is 24 bit color and the image is saved as a JPEG image.

To use this property, you must have the appropriate ImageKit.NET Plugin (Win32 Dll files).

See Also

IkFile Class | IkFile Members


TiffAppend property

Newtone.ImageKit.WPF.IkFile.TiffAppend Property

This property sets whether or not an image saved in TIFF format is appended to an existing multi-page TIFF image or saved as a separate image.

[Visual Basic]
Public Property TiffAppend As Boolean
[C#]
public bool TiffAppend {get; set;}

Property Value

True: Multi-page TIFF image (The image will be appended to the end of an existing TIFF image)
False: Single TIFF image (Each image file contains only one image)

Explanation

The TiffAppend property sets whether or not an image saved in TIFF format is appended to an existing multi-page TIFF image or saved as a separate image.

This property can be set when saving an image in TIFF format. When this property is set to True and the SaveImageToFile method is executed, you must then execute the CloseMultiTiff method.

Example

Saving multiple image files into one multipage tiff file

[Visual Basic.NET]
Dim I As Integer
ImageKit2.File.FileName = "abc.tif" 'the name of the file
ImageKit2.File.TiffAppend = True 'Set multipage tiff
ImageKit1.LayerNumber = -1
ImageKit1.File.LoadPage = 0
'combining images 001.jpg thru 005.jpg into one
For I = 1 To 5
  ImageKit1.File.FileName = I.ToString("d03") + ".jpg" 'Filename
  ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.Load)
  ImageKit2.File.SaveImageToFile(Newtone.ImageKit.SaveFileType.SaveTIFFNoncompressed, ImageKit1.Image)
Next I
'When the TiffAppend=True and
'the File.SaveImageToFile method is executed,
'you must execute the CloseMultiTiff method
ImageKit2.File.CloseMultiTiff()

[Visual C#.NET]
int i;
imageKit2.File.FileName = "abc.tif"; //the name of the file
imageKit2.File.TiffAppend = true; //Set multipage tiff
imageKit1.LayerNumber = -1;
imageKit1.File.LoadPage = 0;
//combining images 001.jpg thru 005.jpg into one
for (i = 1; i <= 5; i++)
{
  imageKit1.File.FileName = i.ToString("d03") + ".jpg"; //Filename
  imageKit1.File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.Load);
  imageKit2.File.SaveImageToFile(Newtone.ImageKit.SaveFileType.SaveTIFFNoncompressed, imageKit1.Image);
}
//When the TiffAppend=True and
//the File.SaveImageToFile method is executed,
//you must execute the CloseMultiTiff method
imageKit2.File.CloseMultiTiff();

Also See

IkFile Class | IkFile Members


JpegSubsamplingKind enum

Newtone.ImageKit.WPF.JpegSubsamplingKind Enum

This refers to the types of YCrCb subsumpling when saving images in JPEG format.

public enum JpegSubsamplingKind

Public Members

Member | Value | Explanation
JS411 | 0 | Y:Cr:Cb 4:1:1
JS422 | 1 | Y:Cr:Cb 4:2:2
JS444 | 2 | Y:Cr:Cb 4:4:4

See Also

IkFile Class | IkFile Members


LoadFileType enum

Newtone.ImageKit.WPF.LoadFileType Enum

This refers to the type of image to be loaded.

public enum LoadFileType

Public Members

Member | Value | Explanation
Load | 0 | Automation
LoadBMP | 1 | BMP
LoadJPEG | 2 | JPEG
LoadGIF | 3 | GIF
LoadTIFF | 4 | TIFF
LoadPNG | 5 | PNG
LoadFPX | 6 | FPX
LoadPCX | 7 | PCX
LoadWMF | 8 | WMF
LoadEMF | 9 | EMF
LoadDXF | 10 | DXF
LoadSVG | 11 | SVG
LoadJPEG2000 | 12 | JPEG2000
LoadSXFP21 | 13 | SXF p21
LoadSXFSFC | 14 | SXF sfc

See Also

IkFile Class | IkFile Members


OCREventArgs Class

Newtone.ImageKit.WPF

Newtone.ImageKit.WPF.OCR.OCREventArgs Class

This class provides data for the GetOCRText event.

[Visual Basic]
Public Class OCREventArgs Inherits System.EventArgs
[C#]
public class OCREventArgs：System.EventArgs

Explanation

Property | Type | Explanation
OCRText | string | Retrieves the OCR converted text

See Also

OCR Class | OCR Members


OCREventHandler Delegate

Newtone.ImageKit.WPF

Newtone.ImageKit.WPF.OCR.OCREventHandler Delegate

This delegate represents a method that handles GetOcrText events.

[Visual Basic]
Public Delegate Sub OCREventHandler(ByVal sender As Object, ByVal e As Newtone.ImageKit.WPF.OCREventArgs)
[C#]
public delegate void OCREventHandler(object sender, Newtone.ImageKit.WPF.OCREventArgs e);

Parameters

sender
Event source
e
OCREventArgs that contains event data.

See Also

OCR Class | OCR Members


AfterScanEventArgs class

Newtone.ImageKit.WPF.AfterScanEventArgs Class

This class provides data of the AfterScan Event.

[Visual Basic]
 Public Class AfterScanEventArgs Inherits System.EventArgs
[C#]
 public class AfterScanEventArgsFSystem.EventArgs

Explanation

Property | Type | Explanation
Bitmap1 | System.Drawing.Bitmap | Retrieves the Bitmap class for 1, 4, 8, and 24 bit images. When using file transfer, this is null (Nothing in Visual Basic)
Bitmap2 | System.Drawing.Bitmap | Retrieves the Bitmap class for 16 bit grayscale and 48 bit color images. When using file transfer, this is null (Nothing in Visual Basic)
BitOrder | [Visual Basic] Integer [C#] int | Refers to whether the bits in each byte of the scanned image start from the left or start from the right. 0: Start from the right (LSB), 1: Start from the left (MSB)
Cancel | [Visual Basic] Boolean [C#] bool | Sets whether or not the scan process is canceled. By setting this property to True, the process can be canceled.
Dispose | [Visual Basic] Boolean [C#] bool | Sets whether or not the Bitmap1 and Bitmap2 resource will be disposed after the event has finished. When this arguement is set to true, the Bitmap1 and Bitmap2 resource will be disposed. When this arguement is set to false, these resources will not be disposed. The default value is true.
FileName | [Visual Basic] String [C#] string | Sets the file name when saving a file using file transfer
ImageNumber | [Visual Basic] Integer [C#] int | The number of images scanned
RawData | [Visual Basic] Byte() [C#] byte[] | Retrieves the byte array when scanning with memory transfer compression mode. When using native or file transfer or non-compressed mode, this returns null (Nothing in Visual Basic)

See Also

Scan Class | Scan Members


BeforeScanEventArgs class

Newtone.ImageKit.WPF.BeforeScanEventArgs Class

This class provides data of the BeforeScan event.

[Visual Basic]
 Public Class BeforeScanEventArgs Inherits System.EventArgs
[C#]
 public class BeforeScanEventArgsFSystem.EventArgs

Explanation

Property | Type | Explanation
BitDepth | [Visual Basic] Integer [C#] int | Retrieves the image bitcount. Scanning in 12 or 14 bit grayscale results in 16 bit grayscale. Scanning in 36 or 42 bit color results in 48 bit color.
Cancel | [Visual Basic] Boolean [C#] bool | Sets whether or not the scan process is canceled. By setting this property to True, the process can be canceled.
Compression | Newtone.ImageKit.WPF.ScanCompression | Sets the compression method used when an image is transferred via memory
Height | [Visual Basic] Integer [C#] int | The height of the image that will be transferred in pixels
ImageNumber | [Visual Basic] Integer [C#] int | Refers to the number of images that have been scanned
PixelType | Newtone.ImageKit.WPF.ScanPixelType | Sets the type of image scanned
Width | [Visual Basic] Integer [C#] int | The width of the image that will be transferred in pixels
XResolution | [Visual Basic] Single [C#] float | Sets the horizontal scan resolution *1
YResolution | [Visual Basic] Single [C#] float | Sets the vertical scan resolution *1

            *1

Although the TWAIN specifications allow scan units to be inches or centimeters,
                depending on the datasource (scan device) the scan units settings are ignored
                and DPI is used. Furthermore, if scan units are set to pixels, there are cases
                where the datasource will return a value of 1 as these resolution properties.

See Also

Scan Class | Scan Members


CapabilityRange Members

Newtone.ImageKit.WPF.CapabilityRange All Members

CapabilityRange Overview

Constructor

CapabilityRange Constructor Initializes a new instance of the CapabilityRange class

Public Properties

Current | Refers to the current setting for a specified functionality
Default | Refers to the default setting for a specified functionality
Maximum | Refers to the maximum setting for a specified functionality
Minimum | Refers to the minimum setting for a specified functionality
Step | Refers to a range of possible setting values for the specified functionality

See Also

Scan Members | Newtone.ImageKit


DataSourceInformation Members

Newtone.ImageKit.WPF.DataSourceInformation All Members

DataSourceInformation Overview

Constructor

DataSourceInformation Constructor Initializes a new instance of the DataSourceInformation class

Public properties

Information | Refers to the scan device's version information
MajorVersion | Refers to the major version number of the scan device
Manufacturer | Refers to to the scan device manufacturer's name
MinorVersion | Refers to the minor version number of the scan device
ProductFamily | Refers to the scan device product family name
ProductName | Refers to the scan device product name
ProtocolMajor | Refers to the TWAIN major version number
ProtocolMinor | Refers to the TWAIN minor version number

See Also

Scan Members | Newtone.ImageKit


AfterScanEventHandler delegate

Newtone.ImageKit.WPF.AfterScanEventHandler Delegate

This refers to the methods to process the AfterScan event.

[Visual Basic] Public Delegate Sub AfterScanEventHandler(ByVal sender As Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs)
[C#] public delegate void AfterScanEventHandler(object sender, Newtone.ImageKit.AfterScanEventArgs e);

Parameters

sender
Event source
e
The AfterScanEventArgs containing event data

See Also

Scan Class | Scan Members


BeforeScanEventHandler delegate

Newtone.ImageKit.WPF.BeforeScanEventHandler Delegate

This refers to the methods to process the BeforeScan event.

[Visual Basic] Public Delegate Sub BeforeScanEventHandler(ByVal sender As Object, ByVal e As Newtone.ImageKit.BeforeScanEventArgs)
[C#] public delegate void BeforeScanEventHandler(object sender, Newtone.ImageKit.BeforeScanEventArgs e);

Parameters

sender
Event source
e
The BeforeScanEventArgs containing event data

See Also

Scan Class | Scan Members


Current property

Newtone.ImageKit.CapabilityRange.Current Property

This property refers to the current setting for a specified functionality as retrieved by the Newtone.ImageKit.WPF.Scan.GetCapabilityRange method.

[Visual Basic]Public ReadOnly Property Current As Single
[C#]public float Current {get;}

Property Value

The current setting for that functionality

Explanation

The Current property refers to the current setting for a specified functionality as retrieved by the Newtone.ImageKit.WPF.Scan.GetCapabilityRange method.

See Also

CapabilityRange Members | Newtone.ImageKit


Default property

Newtone.ImageKit.CapabilityRange.Default Property

This property refers to the default setting for a specified functionality as retrieved by the Newtone.ImageKit.WPF.Scan.GetCapabilityRange method.

[Visual Basic]Public ReadOnly Property Default As Single
[C#]public float Default {get;}

Property Value

The default setting for that functionality (The setting when the device is turned on)

Explanation

The Default property refers to the default setting for a specified functionality as retrieved by the the Newtone.ImageKit.WPF.Scan.GetCapabilityRange method.

See Also

CapabilityRange Members | Newtone.ImageKit


Maximum property

Newtone.ImageKit.CapabilityRange.Maximum Property

This property refers to the maximum setting for a specified functionality as retrieved by the Newtone.ImageKit.WPF.Scan.GetCapabilityRange method.

[Visual Basic]Public ReadOnly Property Maximum As Single
[C#]public float Maximum {get;}

Property Value

The maximum setting for that functionality

Explanation

The Maximum property refers to the maximum setting for a specified functionality as retrieved by the Newtone.ImageKit.WPF.Scan.GetCapabilityRange method.

See Also

CapabilityRange Members | Newtone.ImageKit


Minimum property

Newtone.ImageKit.CapabilityRange.Minimum Property

This property refers to the minimum setting for a specified functionality as retrieved by the Newtone.ImageKit.WPF.Scan.GetCapabilityRange method.

[Visual Basic]Public ReadOnly Property Minimum As Single
[C#]public float Minimum {get;}

Property Value

The minimum setting for that functionality

Explanation

The Minimum property refers to the minimum setting for a specified functionality as retrieved by the Newtone.ImageKit.WPF.Scan.GetCapabilityRange method.

See Also

CapabilityRange Members | Newtone.ImageKit


Step property

Newtone.ImageKit.CapabilityRange.Step Property

This property refers to the information retrieved by the Newtone.ImageKit.WPF.Scan.GetCapabilityRange method, which can retrieve a range of possible setting values for the specified functionality in the scan device.

[Visual Basic]Public ReadOnly Property Step As Single
[C#]public float Step {get;}

Property Value

The size of the steps in the settings from Minimum to Maximum

Explanation

The Step property refers to the information retrieved by the Newtone.ImageKit.WPF.Scan.GetCapabilityRange method, which can retrieve a range of possible setting values for the specified functionality in the scan device.

See Also

CapabilityRange Members | Newtone.ImageKit


Information property

Newtone.ImageKit.DataSourceInformation.Information Property

This property refers to the scan device's version information as retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource method or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

[Visual Basic]Public ReadOnly Property Information As String
[C#]public string Information {get;}

Property Value

The scan device's version information

Explanation

The SourceVersionInfo property refers to the scan device's version information as retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource method, the Newtone.ImageKit.WPF.Scan.GetDataSources method or the Newtone.ImageKit.WPF.Scan.SelectDataSource method.

See Also

DataSourceInformation Members | Newtone.ImageKit


MajorVersion property

Newtone.ImageKit.DataSourceInformation.MajorVersion Property

This property refers to various information about the scan device as retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource method or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

[Visual Basic]Public ReadOnly Property MajorVersion As Integer
[C#]public int MajorVersion {get;}

Property Value

The major version number of the scan device

Explanation

This property refers to various information about the scan device as retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource method or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit


Manufacturer property

Newtone.ImageKit.DataSourceInformation.Manufacturer Property

This property refers to to the scan device manufacturer's name as retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

[Visual Basic]Public ReadOnly Property Manufacturer As String
[C#]public string Manufacturer {get;}

Property Value

The scan device manufacturer's name

Explanation

The Manufacturer property refers to various information about the scan device as retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit


MinorVersion property

Newtone.ImageKit.DataSourceInformation.MinorVersion Property

This property refers to the minor version number of the scan device as retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource method or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

[Visual Basic]Public ReadOnly Property MinorVersion As Integer
[C#]public int MinorVersion {get;}

Property Value

The minor version number of the scan device

Explanation

The MinorVersion property refers to the minor version number of the scan device as retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource method or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit


ProductFamily property

Newtone.ImageKit.DataSourceInformation.ProductFamily Property

This property refers to the scan device product family name as retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource method or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

[Visual Basic]Public ReadOnly Property ProductFamily As String
[C#]public string ProductFamily {get;}

Property Value

The scan device product family name

Explanation

This property refers to the scan device product family name as retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource method or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit


ProductName property

Newtone.ImageKit.DataSourceInformation.ProductName Property

This property refers to the scan device product name as retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource method or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

[Visual Basic]Public ReadOnly Property ProductName As String
[C#]public string ProductName {get;}

Property Value

The scan device product name

Explanation

The ProductName property refers to the scan device product name as retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource method or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit


ProtocolMajor property

Newtone.ImageKit.DataSourceInformation.ProtocolMajor Property

This property refers to the TWAIN major version number as retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource method or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

[Visual Basic]Public ReadOnly Property ProtocolMajor As Integer
[C#]public int ProtocolMajor {get;}

Property Value

The the major version number of the TWAIN specification supported by the scan device

Explanation

The ProtocolMajor property refers to the TWAIN major version number as retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource method or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit


ProtocolMinor property

Newtone.ImageKit.DataSourceInformation.ProtocolMinor Property

This property refers to the TWAIN minor version numberas retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource method or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

[Visual Basic]Public ReadOnly Property ProtocolMinor As Integer
[C#]public int ProtocolMinor {get;}

Property Value

The minor version number of the TWAIN specification supported by the scan device

Explanation

The ProtocolMinor property refers to the TWAIN minor version numberas retrieved by the Newtone.ImageKit.WPF.Scan.GetCurrentDataSource method or the Newtone.ImageKit.WPF.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit