Newtone.ImageKit X

ImageKit.NET X

ImageKit.NET X Reference

ImageKit.NET X Reference

Newtone Corporation
Honchou 2-2-15, Shangrila Honchou 1F
Nagaoka City, Niigata Prefecture
940-0076, JAPAN
Telephone: +(81)258-86-6954
Fax: +(81)258-86-6964
https://www.imagekit.com
iksupport@imagekit.com


ImageKit.NET X Installation and Activation

To install the ImageKit.NET X, download and execute the appropriate installer for your programming environment.

The trial version of the ImageKit.NET X is fully functional and will work for approximately 30 days from the time of installation. The retail version license must be activated on the PC where the ImageKit.NET X is installed. See below for more details about activation.

IMPORTANT: After installing the retail version, you will be prompted to activate the license. You have 2 weeks to activate the retail license after which the ImageKit.NET X will stop working until the license is activated.

How to activate your ImageKit.NET X License:
License activation is the final step in correctly installing your product. The License Activation tool will automatically start when the product is installed. You can activate the license during installation or choose to activate it later. If you choose to activate later, you can do so at any time by running the License Activation tool (Activation.exe) found in the "Tool" folder under the directory where the product is installed. If the license is not activated within 2 weeks of installation, the product will stop working until the license is activated. You can activate a license online or offline.

Online Activation:

To activate a license online, use the License Activation tool (Activation.exe) and select the "Online" radio button. The License Activation tool uses the Product ID and Serial Number that you received when you purchased the product. Enter the Product ID and Serial Number in the License Activation tool and click "Add License". Your license will be activated online in a matter of few minutes.

During online activation, the Product ID and Serial Number as well as a unique Confirmation ID that is generated by the License Activation tool are transmitted to our license activation server. No other information except for the Product ID, Serial Number, and Confirmation ID are transmitted. Once this information is confirmed by our server, the product will be automatically activated. The status of your activation will appear in the License Activation tool.

Before uninstalling the ImageKit.NET X, you must remove the license from the machine where it was activated. If the license is not removed it will remain even after the product has been uninstalled. Until that license is removed, that product cannot be activated on another machine. To remove the license, run the License Activation tool and click the "Remove License" button.

Offline Activation:

License activation can also be performed offline via email. To activate a license offline, run the License Activation tool and select the "Offline" radio button. Send the Product ID, Serial Number, and the Confirmation ID shown in the License Activation tool to Newtone Corporation at iksupport@imagekit.com. Once we receive the Product ID, Serial Number, and the Confirmation ID, we will send you a License Key which you will enter in the License Activation tool.

To remove a license offline, run the License Activation tool and select the "Offline" radio button. Enter the Product ID and Serial Number in the License Activation tool and click the "Remove License" button. Then send the Product ID, Serial Number, and the Confirmation ID shown in the License Activation tool to Newtone Corporation at iksupport@imagekit.com. Please allow 3 to 5 working days for the license to be removed.

Questions:

Please contact Newtone Corporation at iksupport@imagekit.com if you have any questions about activation or if you have any problems activating your product.


Deployment

ImageKit.NET X

How To Deploy Applications Containing ImageKit.NET3 Functionality

To deploy an application containing ImageKit.NET X functionality, be sure to include the following files with the application:

Using the ImageKit Control in a WinForm Application, include the following files:
Newtone.ImageKit.NETX.ImageKit.dll
Newtone.ImageKit.NETX.Common.dll
Newtone.ImageKit.NETX.Effect.dll
Newtone.ImageKit.NETX.File.dll
Newtone.ImageKit.NETX.Scan.dll

Using the ToolBarStandard Control in a WinForm Application, include the following files:
Newtone.ImageKit.NETX.ToolBarStardard.dll
Newtone.ImageKit.NETX.ImageKit.dll
Newtone.ImageKit.NETX.Common.dll
Newtone.ImageKit.NETX.File.dll

Using the ToolBarAnnotation Control in a WinForm Application, include the following files:
Newtone.ImageKit.NETX.ToolBarAnnotation.dll
Newtone.ImageKit.NETX.ImageKit.dll
Newtone.ImageKit.NETX.Common.dll

Using the ToolBarSetupLines Control in a WinForm Application, include the following files:
Newtone.ImageKit.NETX.ToolBarSetupLines.dll
Newtone.ImageKit.NETX.ImageKit.dll
Newtone.ImageKit.NETX.Common.dll

Using the ToolBarSetupObjects Control in a WinForm Application, include the following files:
Newtone.ImageKit.NETX.ToolBarSetupObjects.dll
Newtone.ImageKit.NETX.ImageKit.dll
Newtone.ImageKit.NETX.Common.dll

Using the Thumbnail Control in a WinForm Application, include the following files
Newtone.ImageKit.NETX.Thumbnail.dll
Newtone.ImageKit.NETX.Common.dll
Newtone.ImageKit.NETX.File.dll

Using the WebCamera Control in a WinForm Application, include the following files
Newtone.ImageKit.NETX.WebCamera.dll
Newtone.ImageKit.NETX.Common.dll

Distributing applications that use ImageKit.NET X functions but do not use any the ImageKit.NET X Controls must include the following files
Newtone.ImageKit.NETX.Common.dll (Absolutely necessary)
Newtone.ImageKit.NETX.File.dll (Necessary if processing a file)
Newtone.ImageKit.NETX.Effect.dll (Necessary if processing an effect)
Newtone.ImageKit.NETX.Scan.dll (Necessary if using a TWAIN device to retrieve image data)


Contacting Us

ImageKit.NET X

Where To Get Technical Support

Please feel free to contact us if you have any questions or comments about us or our products.

Newtone Corporation
Honchou 2-2-15, Shangrila Honchou 1F
Nagaoka City, Niigata Prefecture
940-0076, JAPAN
Telephone: +(81)258-86-6954
Fax: +(81)258-86-6964

Website: https://www.imagekit.com

Email: iksupport@imagekit.com

When contacting us for technical support, please include the following information.

User Information

Name - The name of the person who is registered to receive support.

Product Information

Product name
Version number
Product Serial Number - provided by the vendor when the ImageKit was purchased.
The DLL file time stamp.

Development Environment Information

Operating system
Development container
If your inquiry involves a scanner or digital camera, please include the model and version number of that TWAIN device.

Inquiries

Please explain the circumstances or conditions under which the problem or question exists. This explanation should be made as clearly and concisely as possible. If it is difficult to explain the problem in writing, please feel free to attach a small sample program that illustrates the problem. However, make sure that all programming not directly related to the issue at hand is eliminated from the program before sending it to us. Furthermore, please compress all sample programs into ZIP compression format before sending.

Note

Support is only available to REGISTERED users. For more information about user registration,see our web site at https://www.imagekit.com/registration.html


Newtone.ImageKit.Web

ImageKit.NET X

ImageKit.NET X Structure

ImageKit.NET X Assembly Files

The following are the ImageKit.NET X assembly files

Newtone.ImageKit.NETX.ImageKit.dll (WinForm ImageKit Control)
Newtone.ImageKit.NETX.ToolBarStandard.dll (WinForm ToolBarStandard Control)
Newtone.ImageKit.NETX.ToolBarAnnotation.dll (WinForm ToolBarAnnotation Control)
Newtone.ImageKit.NETX.ToolBarSetupLines.dll (WinForm ToolBarSetupLines Control)
Newtone.ImageKit.NETX.ToolBarSetupObjects.dll (WinForm ToolBarSetupObjects Control)
Newtone.ImageKit.NETX.Thumbnail.dll (WinForm Thumbnail Control)
Newtone.ImageKit.NETX.WebCamera.dll (WinForm WebCamera Control)

Newtone.ImageKit.NETX.Common.dll (WinForm Class Library)
Newtone.ImageKit.NETX.Effect.dll (WinForm Class Library)
Newtone.ImageKit.NETX.File.dll (WinForm Class Library)
Newtone.ImageKit.NETX.Scan.dll (WinForm Class Library)

ImageKit.NET X Assembly Structure

Each Control is associated with the following files:

The WinForm Controls:

Newtone.ImageKit.NETX.ImageKit.dll
|--- Newtone.ImageKit.NETX.Common.dll
|--- Newtone.ImageKit.NETX.File.dll
|--- Newtone.ImageKit.NETX.Scan.dll
|--- Newtone.ImageKit.NETX.Effect.dll

Newtone.ImageKit.NETX.ToolBarStandard.dll
|--- Newtone.ImageKit.NETX.ImageKit.dll
|--- Newtone.ImageKit.NETX.Common.dll
|--- Newtone.ImageKit.NETX.File.dll

Newtone.ImageKit.NETX.ToolBarAnnotation.dll
|--- Newtone.ImageKit.NETX.ImageKit.dll
|--- Newtone.ImageKit.NETX.Common.dll

Newtone.ImageKit.NETX.ToolBarSetupLines.dll
|--- Newtone.ImageKit.NETX.ImageKit.dll
|--- Newtone.ImageKit.NETX.Common.dll

Newtone.ImageKit.NETX.ToolBarSetupObjects.dll
|--- Newtone.ImageKit.NETX.ImageKit.dll
|--- Newtone.ImageKit.NETX.Common.dll

Newtone.ImageKit.NETX.Thumbnail.dll
|--- Newtone.ImageKit.NETX.Common.dll
|--- Newtone.ImageKit.NETX.File.dll

Newtone.ImageKit.NETX.WebCamera.dll
|--- Newtone.ImageKit.NETX.Common.dll

Regarding NUPKG packages

ImageKit.NET X includes the following NUPKG packages, so when developing an application that uses ImageKit.NET X in Visual Studio, please use the following packages by incorporating them into your project.

ImageKit.NETX ImageKit.1.0.0.nupkg
ImageKit.NETX Thumbnail.1.0.0.nupkg
ImageKit.NETXToolBarAnnotation.1.0.0.nupkg
ImageKit.NETXToolBarSetupLines.1.0.0.nupkg
ImageKit.NETXToolBarSetupObjects.1.0.0.nupkg
ImageKit.NETXToolBarStandard.1.0.0.nupkg
ImageKit.NETXWebCamera.1.0.0.nupkg


ImageKit.NET X LICENSE AGREEMENT

ImageKit.NET X LICENSE AGREEMENT

IMPORTANT- READ CAREFULLY BEFORE INSTALLING THE SOFTWARE.

This License Agreement (this "AGREEMENT") contains the terms and conditions regarding your use of the SOFTWARE (as defined below) and material limitations to your rights in that regard. You should read this AGREEMENT carefully.

By installing the ImageKit.NET X software (hereinafter the "SOFTWARE"), you are accepting the following AGREEMENT.

I. THIS AGREEMENT.

1. Software Covered by this AGREEMENT.

This AGREEMENT governs your use of the Newtone Corporation ("Newtone") SOFTWARE enclosed either as part of a SOFTWARE installer or otherwise accompanied herewith. The term "SOFTWARE" includes, to the extent provided by Newtone: 1) any revisions, updates and/or upgrades thereto; 2) any data, image or executable files, databases, data engines, computer software, or similar items customarily used or distributed with computer software products; 3) anything in any form whatsoever intended to be used with or in conjunction with the SOFTWARE; and 4) any associated media, documentation (including physical, electronic and online) and printed materials (the "Documentation").

2. This AGREEMENT is a legal agreement between you and Newtone.

If you are acting as an agent of a company or another legal person, such as an officer or other employee acting for your employer, then "you" and "your" mean your principal, the entity or other legal person for whom you are acting. However, importantly, even if you are acting as an agent for another, you may still be personally liable for violation of laws such as copyright infringement.

This AGREEMENT is a legal agreement between you and Newtone. You intend to be legally bound to this AGREEMENT to the same extent as if Newtone and you physically signed this AGREEMENT. By installing, copying, or otherwise using the SOFTWARE, you agree to be bound by the terms and conditions contained in this AGREEMENT. If you do not agree to all of the terms and conditions contained in this AGREEMENT, you may not install or use the SOFTWARE. If you have already installed or begun to install the SOFTWARE you should cancel any install in progress and uninstall the SOFTWARE. If you do not agree to all of these terms and conditions, then you must promptly return the uninstalled SOFTWARE to the place from which you purchased it in accordance with the return policies of that place.

II. YOUR LICENSE TO DEVELOP AND TO DISTRIBUTE.

Detailed below, this AGREEMENT pertains to three licenses: 1) a license to use the SOFTWARE to develop other software products (the "PC Developer License"); 2) a license to use and/or distribute the Developed Software (the "Runtime Distribution License"); and 3) a license to use and/or distribute the Developed Software on a Network Server (the "Server Runtime License"). All of these licenses (individually and collectively, the "Licenses") are explained and defined in more detail below.

1. Definitions. Terms and their respective meanings as used in this AGREEMENT:

"Developer" means a person using the SOFTWARE in accordance with the terms and conditions of this AGREEMENT.

"Network Server" means a computer with one or more computer central processing units (CPU's) that operates for the purpose of serving other computers logically or physically connected to it, including, but not limited to, other computers connected to it on an internal network, intranet or the Internet. "Server" means a type of Network Server that serves other computers more particularly connected to it over an intranet or the Internet.

"Developed Software" means those computer software products that are developed by or through the use of the SOFTWARE. "Developed Server Software" means those Developed Software products that reside logically or physically on at least one Server and are operated (executed therein) by the Server's central processing unit(s) (CPU). "Developed Desktop Software" means those Developed Software products that are not Developed Server Software, including, for example, standalone applications. "Redistributable Files" means the SOFTWARE files or other portions of the SOFTWARE that are provided by Newtone and are identified as such in the Documentation for distribution by you with the Developed Software. "Developer" means a person using the SOFTWARE in accordance with the terms and conditions of this AGREEMENT.

"PC" is a computer on which the SOFTWARE is installed.

"PC Developer" is the use of one licensed copy of the SOFTWARE on one PC by one concurrent Developer.

"PC Developer License" defines the right to use the SOFTWARE for development purposes. Every machine installing, running and/or using the SOFTWARE for development purposes must have a licensed copy and its appropriate license.

"Subscription period" is the period during which an active subscription agreement exists as confirmed in writing by Newtone, usually at the moment of subscription purchase.

2. Your PC Developer License.

You are hereby granted a limited, royalty-free, non-exclusive right to use the SOFTWARE to design, develop, and test Developed Software, on the express condition that, and only for so long as, you fully comply with all terms and conditions of this AGREEMENT.

The SOFTWARE is licensed to you on a per PC Developer License basis.

The each PC Developer License means that one Developer may install one copy of the SOFTWARE for use in designing, testing and creating Developed Software on one computer with a single set of input devices, restricting the use of the SOFTWARE to a maximum of three concurrent user. Conversely, you may not install or use the SOFTWARE on a computer that is a network server or a computer at which the SOFTWARE is used by more than one Developer. You may not network the SOFTWARE or any component part of it, where it is or may be used by more than one Developer unless you purchase an additional PC Developer License for each Developer. You must purchase another separate license to the SOFTWARE in order to add additional developer seats if the additional developers are accessing the SOFTWARE on a computer network. If the SOFTWARE is used to create Developed Server Software, then you must have a separate Server Runtime License for each Server where copies of the Developed Server Software exist. (See 4. Your Server Runtime License below)

In all cases, you may not use Newtone's name, logo, or trademarks to market your Developed Software without the express written consent of Newtone; agree to indemnify, hold harmless, and defend Newtone, its suppliers and resellers, from and against any claims or lawsuits, including lawyer's fees that may arise from the use or distribution of your Developed Software; you may use the SOFTWARE only to create Developed Software that is significantly different than the SOFTWARE.

3. Your Runtime Distribution License.

License to Distribute Developed Desktop Software. Subject to the terms and conditions in this AGREEMENT, you are granted the license to use and to distribute Developed Desktop Software on a royalty-free basis, provided that the Developed Desktop Software incorporates the SOFTWARE as an integral part of the Developed Software in machine language compiled format (customarily an ".exe", or ".dll", etc.). You may not distribute, bundle, wrap or subclass the SOFTWARE as Developed Software which, when used in a "design time" development environment, exposes the programmatic interface of the SOFTWARE. You may distribute, on a royalty-free basis, Redistributable Files with Developed Desktop Software only.

4. Your Server Runtime License.

Subject to the terms and conditions in this AGREEMENT, you are granted the license to use and to distribute Developed Server Software, provided that you purchase one Server Runtime License for each Network Server operating the Developed Server Software (and/or Redistributable Files called or otherwise used directly by the Developed Server Software).

5. License Serial Number.

Upon purchase of the SOFTWARE a unique serial number (the "Serial Number") is provided by Newtone either electronically or via the delivery channel. The Serial number provides a means to Register the SOFTWARE. The Serial Number is subject to the restrictions set forth in this AGREEMENT and may not be disclosed or distributed either with your Developed Software or in any other way. The disclosure or distribution of the Serial Number shall constitute a breach of this AGREEMENT, the effect of which shall be the automatic termination and revocation of all the rights granted herein.

6. Updates/Upgrades.

Subject to the terms and conditions of this AGREEMENT, the Licenses are perpetual. Updates, bug fixes and upgrades to the SOFTWARE may be provided by Newtone at their discretion at timely intervals only during the Subscription period though Newtone does not commit to providing such updates or upgrades, and, if so provided by Newtone, are provided upon the terms and conditions offered at that time by Newtone.

7. Evaluation, Trial, or Beta Copy.

If you are using an "evaluation copy", a "trial" copy, a "Beta" copy, or similar version of the SOFTWARE, specifically designated as such by Newtone on its website or otherwise, then the Licenses are limited as follows: a) you are granted a license to use the SOFTWARE for a period of thirty (30) days counted from the day of installation (the "Evaluation Period"); b) upon completion of the Evaluation Period, you shall either i) delete the SOFTWARE from the computer containing the installation, or you may ii) contact Newtone or one of its authorized dealers to purchase a license of the SOFTWARE, which is subject to the terms and limitations contained herein. The "evaluation copy", "trial" copy, "Beta" copy, or similar version of the SOFTWARE is for evaluation purposes only and may not be used to create any Developed Software and if created may not be distributed or used for any purpose including commercial purposes.

III. INTELLECTUAL PROPERTY.

1. Copyright.

You agree that all right, title, and interest in and to the SOFTWARE (including, but not limited to, any images, photographs, code examples and text incorporated into the SOFTWARE), and any copies of the SOFTWARE, and any copyrights and other intellectual properties therein or related thereto are owned exclusively by Newtone, except to the limited extent that Newtone may be the rightful license holder of certain third-party technologies incorporated into the SOFTWARE. The SOFTWARE is protected by copyright laws and international treaty provisions. The SOFTWARE is licensed to you, not sold to you. Newtone reserves all rights not otherwise expressly and specifically granted to you in this AGREEMENT.

2. Backups.

You may make one copy the SOFTWARE solely for backup or archival purposes.

3. General Limitations.

You may not reverse engineer, decompile, or disassemble the SOFTWARE.

4. Software Transfers.

You may not rent or lease the SOFTWARE. You may transfer the SOFTWARE to another computer, provided that it is completely removed from the computer from which it was transferred. You may permanently transfer all of your rights under the AGREEMENT, provided that you obtain expressed written permission from Newtone and that you retain no copies, that you transfer all the SOFTWARE (including all component parts, the media and printed materials, any dates, upgrades, this AGREEMENT and, if applicable, the Certificate of Authenticity), and that the recipient agrees to the terms and conditions of this AGREEMENT as provided herein. Newtone must be notified in writing prior to the license transfers where the company of the recipient is different to that of the original licensee. If the SOFTWARE is an update or upgrade, any transfer must include all prior versions of the SOFTWARE.

5. Termination.

Without prejudice to any other rights it may have, Newtone may terminate this AGREEMENT and the Licenses if you fail to comply with the terms and conditions contained herein. In such an event, you must destroy all copies of the SOFTWARE and all of its component parts.

IV. DISCLAIMER and WARRANTIES

1. Disclaimer

Newtone's entire liability and your exclusive remedy under this AGREEMENT shall be, at Newtone's sole option, either (a) return of the price paid for the SOFTWARE; (b) repair the SOFTWARE through updates distributed online. Newtone cannot and does not guarantee that any functions contained in the Software will meet your requirements, or that its operations will be error free. The entire risk as to the Software performance or quality, or both, is solely with the user and not Newtone. You assume responsibility for the selection of the component to achieve your intended results, and for the installation, use, and results obtained from the SOFTWARE.

2. Warranty.

Newtone makes no warranty, to the maximum extent permitted by law, either implied or expressed, including with-out limitation any warranty with respect to this Software documented here, its quality, performance, or fitness for a particular purpose. In no event shall Newtone be liable to you for damages, whether direct or indirect, incidental, special, or consequential arising out the use of or any defect in the Software, even if Newtone has been advised of the possibility of such damages, or for any claim by any other party. All other warranties of any kind, either express or implied, including but not limited to the implied warranties of merchantability and fitness for a particular purpose, are expressly excluded.

V. MISCELLANEOUS.

1. This is the Entire Agreement.

This AGREEMENT (including any addendum or amendment to this AGREEMENT included with the SOFTWARE) is the final, complete and exclusive statement of the entire agreement between you and Newtone relating to the SOFTWARE. This AGREEMENT supersedes any prior and contemporaneous proposals, purchase orders, advertisements, and all other communications in relation to the subject matter of this AGREEMENT, whether oral or written. No terms or conditions, other than those contained in this AGREEMENT, and no other understanding or agreement which in any way modifies these terms and conditions, shall be binding upon the parties unless entered into in writing executed between the parties, or by other non-oral manner of agreement whereby the parties objectively and definitively act in a manner to be bound (such as by continuing with an installation of the SOFTWARE, "clicking-through" a questionnaire, etc.) Employees, agents and other representatives of Newtone are not permitted to orally modify this AGREEMENT.

2. You Indemnify Newtone.

You agree to indemnify, hold harmless, and defend Newtone and its suppliers and resellers from and against any and all claims or lawsuits, including attorney's fees, that arise or result from this AGREEMENT.

3. Interpretation of this AGREEMENT.

If for any reason a court of competent jurisdiction finds any provision of this AGREEMENT, or any portion thereof, to be unenforceable, that provision of this AGREEMENT will be enforced to the maximum extent permissible so as to effect the intent of the parties, and the remainder of this AGREEMENT will continue in full force and effect. Formatives of defined terms shall have the same meaning of the defined term. Failure by either party to enforce any provision of this AGREEMENT will not be deemed a waiver of future enforcement of that or any other provision. Except as otherwise required or superseded by law, this AGREEMENT is governed by the laws of JAPAN. If the SOFTWARE was acquired outside of JAPAN, then local law may apply.


Notifications

ImageKit.NET X

Notifications of Copyright

The ImageKit.NET X incorporates the following software:

LibTiff.Net

Copyright (c) 2008-2011, Bit Miracle
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

Neither the name of the Bit Miracle nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL BIT MIRACLE BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


ImageKit.NET X Programming Guide

Programming Guide

The following guide provides explanations and illustrative examples to enable you to use the ImageKit X properties and methods.

Links are provided to relevant properties and methods used in the code.

For more information about programming with the ImageKit X, be sure to check the example projects included under the Examples folder in the directory where the ImageKit X is installed.


ImageKit X Programing Guide

Loading And Displaying Image Files

This example loads an image file and displays it in the ImageKit Control.

To load an image, specify it in the FileName property. Then use the LoadImageFromFile method to load the image.
Finally, specify the display mode using the DisplayMode property and call the Display method.

Example Code

[Visual Basic.NET]

'Specify the image file and load it
ImageKit1.File.FileName = "BMP.bmp"
ImageKit1.File.LoadImageFromFile()

'Set the display mode and display the image
ImageKit1.DisplayMode = Newtone.ImageKit.Win.DisplayMode.Scale
ImageKit1.Display()

[Visual C#.NET]

//Specify the image file and load it
ImageKit1.File.FileName = "BMP.bmp";
ImageKit1.File.LoadImageFromFile();

//Set the display mode and display the image
ImageKit1.DisplayMode = Newtone.ImageKit.Win.DisplayMode.Scale;
ImageKit1.Display();

Relevant Properties

ImageKit.DisplayMode
ImageKit.File.FileName

Relevant Methods

ImageKit.File.OpenFileDialog (Used to display the "Open File" Dialog and read the file.)
ImageKit.File.LoadImageFromFile
 ImageKit.Display


ImageKit X Programing Guide

Saving Image Files

This sample saves an image to file.

To save an image, specify the image in the FileName property and save it using the SaveImageToFile method. If the specified file already exists, it will be overwritten.
The image format is specified in the first argument of the SaveImageToFile method.

You can save the image currently loaded into the ImageKit control by specifying "null" or ImageKit1.Image in the second parameter of the SaveImageToFile method. You can also save other images directly by specifying them in the same way. For example, the code below saves the image currently displayed in a PictureBox control. It saves this image in the JPG format.

Example Code

[Visual Basic.NET]

ImageKit1.File.FileName = "JPG.jpg"
ImageKit1.File.SaveImageToFile(Newtone.ImageKit.SaveFileType.SaveJPEG, PictureBox1.Image)

[Visual C#.NET]

ImageKit1.File.FileName = "JPG.jpg";
ImageKit1.File.SaveImageToFile(Newtone.ImageKit.SaveFileType.SaveJPEG, PictureBox1.Image);

Relevant Properties

ImageKit.File.FileName

Relevant Methods

ImageKit.File.SaveFileDialog (Used to display the "Save File" Dialog and specify the save file name.)
ImageKit.File.SaveImageToFile


ImageKit X Programing Guide

Using Toolbars

There are four types of ToolBar controls which you can use in combination with the ImageKit control by pasting them into a Windows Form. Associate the ImageKit control with the TargetImageKit property of each ToolBar.

With these ToolBars, you can take advantage of various annotation features without writing any code.

The types of ToolBars and the functions that each ToolBar has are as follows:

ToolBarStandard

A toolbar control with buttons that allow you to make basic settings for the editing and annotation functions of the ImageKit control.
It is possible to make basic settings related to editing and annotation of the target ImageKit control.
It also includes a button that has a function to read and save image files.

The ToolBarStandard control contains the following elements:

File Related
The "Open Image File" button: Opens and displays the image file in the target ImageKit control. You can achieve a series of actions similar to executing the ImageKit.File.LoadImageFromFile method.
The "Save Image File" button: Saves the image displayed in the target ImageKit control to a file. You can achieve a series of actions similar to executing the ImageKit.File.SaveImageToFile method.
Annotation file related
The "Open Annotation File" button: Opens the annotation file, reads the edit / annotation information and displayed in the target ImageKit control. You can achieve the same behavior as executing the ImageKit.Edit.LoadAnnotationFile method.
The "Save Annotation File" button: Saves the edit / annotation information drawn on the target ImageKit control to the annotation file. You can achieve the same behavior as executing the ImageKit.Edit.SaveAnnotationFile method.
Annotation Related Basic Settings
The "Line / Border Thickness Setting" box / button: Enter values directly into the textbox or press arrows to increase / decrease the value, this sets the value of the ImageKit control's ImageKit.Edit.PenWidth property.
The "Line / Text Color" button: Displays the color dialog of the target ImageKit control and sets the ImageKit.Edit.ForeColor property. The set color will be the button color.
The "Line / Text Color Opacity" box / button: Enter values directly in the textbox or press arrows to increase / decrease the value, this sets the value of the ImageKit control's ImageKit.Edit.ForeColorOpacity property.
The "Background Color" button: Displays the color dialog of the target ImageKit control and sets the ImageKit.Edit.BackColor property. The set color will be the button color.
The "Background Color Opacity" Box / Button: Enter values directly into the textbox or press arrows to increase / decrease the value, this sets the value of the ImageKit control's ImageKit.Edit.BackColorOpacity property.
The"Fill" button: Sets the ImageKit control's ImageKit.Edit.Fill property. True / False is indicated by whether or not the button is pressed.

ToolBarAnnotation

It is a toolbar control with buttons that can operate the editing and annotation functions of the ImageKit control.

You can edit and annotate the target ImageKit control.

The ToolBarAnnotation control contains the following elements:

Annotation Related Items
The "Select" button: Sets the target ImageKit control's ImageKit.Edit.EditKind property to KindOfEdit.Select.
The "MultiSelect" button: Sets the target ImageKit control's ImageKit.Edit.EditKind property to KindOfEdit.MultiSelect.
The "Line" button: Sets the target ImageKit control's ImageKit.Edit.EditKind property to KindOfEdit.Line.
The "Polyline" button: Sets the target ImageKit control's ImageKit.Edit.EditKind property to KindOfEdit.Polyline.
The "Polygon" button: Sets the target ImageKit control's ImageKit.Edit.EditKind property to KindOfEdit.Polygon.
The "Rectangle" button: Sets the target ImageKit control's ImageKit.Edit.EditKind property to KindOfEdit.Rectangle.
The "RoundRectangle" button: Sets the target ImageKit control's ImageKit.Edit.EditKind property to KindOfEdit.RoundRectangle.
The "Ellipse" button: Sets the target ImageKit control's ImageKit.Edit.EditKind property to KindOfEdit.Ellipse.
The "Pen" button: Sets the target ImageKit control's ImageKit.Edit.EditKind property to KindOfEdit.Pen.
The "Image" button: Sets the target ImageKit control's ImageKit.Edit.EditKind property to KindOfEdit.Image.
The "Text" button: Sets the target ImageKit control's ImageKit.Edit.EditKind property to KindOfEdit.Text.
The "Stamp" button: Sets the target ImageKit control's ImageKit.Edit.EditKind property to KindOfEdit.Stamp.
Edit Related Items
These buttons perform the same functions as right clicking the ImageKit control and displaying the context menu or as executing a method. These buttons are still enabled even when the ImageKit.Edit.ContextMenuEnabled property is False. For more about the functions the buttons below can do, please see the ImageKit.Edit.ContextMenuEnabled property.
"Select All / Deselect All" button
"Delete" button
"Cut" button
"Copy" button
"Paste" button
The position where the image is pasted is the position where you right-clicked on the ImageKit control immediately before pressing this button (or the upper left of the control's display area if you have never right-clicked), which is the upper left position of the object's reference.
"Move To The Front" button
"Move Forward One" button
"Move Back One" button
"Move To The Back" button
"Undo" button
"Redo" button
"Property" button
Other Edit Related Items
"Rasterize (Embed)" button: The object drawn on the target image kit control is embedded in the image to make one raster image. This has the same effect as executing the ImageKit.Edit.DrawEditedObjectsToImage method.
"Clear All Objects" button: Deletes all objects drawn on the target ImageKit control. This has the same effect as executing the ImageKit.Edit.ClearAllObjects method.

ToolBarSetupLines

It is a toolbar control with buttons etc. that can set the line related annotation function for the ImageKit control. You can set properties related to drawing straight lines, continuous lines, polygons, and pen objects of the target ImageKit control.

The ToolBarSetupLines control contains the following elements:

Line shape, style related
"Double line" button: Sets the ImageKit.Edit.DoubleLine property. Only valid for straight line objects.
"Close pen line" button: Sets the ImageKit.Edit.ClosePenLine property. Only valid for pen objects.
"Dashed line style" combo box: Sets the ImageKit.Edit.DashStyle property.
"Starting cap style" combo box: Sets the ImageKit.Edit.StartLineCap property. Valid only for straight lines, polylines, and pen objects.
"End point cap style" combo box: Sets the ImageKit.Edit.EndLineCap property. Valid only for straight lines, polylines, and pen objects.
"Joining style" combo box: Sets the ImageKit.Edit.LineJoin property. Valid only for polylines, polygons, and pen objects.
Arrow Related Items (valid only for straight line / continuous line objects)
"Start Arrow Cap" button: Sets the ImageKit.Edit.StartArrowCap property.
"Start Arrow Cap Filled" button: Sets the ImageKit.Edit.StartArrowCapFilled property.
"Start Arrow Size" box / button: Sets the ImageKit.Edit.StartArrowCapSize property. Enter values directly in the text box or by increasing / decreasing value button.
"End Arrow Cap" button: Sets the ImageKit.Edit.EndArrowCap property.
"End Arrow Cap Filled" button: Sets the ImageKit.Edit.EndArrowCapFilled property.
"End Arrow Size" box / button: Sets the ImageKit.Edit.EndArrowCapSize property. Enter values directly in the text box or by increasing / decreasing value button.

ToolBarSetupObjects

This toolbar control has buttons etc. that can set annotation functions other than line related annotation functions of ImageKit control. You can set properties related to the drawing of the target ImageKit control's rectangle, rounded rectangle, ellipse, pasted image, text, and stamp object.

The ToolBarSetupObjects control contains the following elements:

Rectangle, rounded rectangle, ellipse, pasted image related
"Keep aspect ratio" button: Sets the ImageKit.Edit.AspectRatio property. Valid only for rectangles, rounded rectangles, ellipses, and paste image objects.
"Rounded Rectangle Rounded Radius" box/button: Sets the ImageKit.Edit.RoundRectangleRadius property. Enter values directly in the text box or by increasing / decreasing value button.
Text / Stamp related
"Font" button: Displays the font dialog and sets the following properties for the ImageKit control: ImageKit.Edit.FontBold property, ImageKit.Edit.FontItalic property, ImageKit.Edit.FontName property, ImageKit.Edit.FontSize property, ImageKit.Edit.FontStrikeout property, ImageKit.Edit.FontUnderline property.
"Word Wrap" button: Sets the ImageKit.Edit.WordWrap property.
"Vertical Text" button: Sets the ImageKit.Edit.VerticalText property.
"Right To Left" button: Sets the ImageKit.Edit.RightToLeft property.
"Border" button: Sets the ImageKit.Edit.Border property.
"Border Color" button: Sets the ImageKit.Edit.BorderColor property.
"Border Color Opacity" box/button: Sets the ImageKit.Edit.BorderColorOpacity property. Enter values directly in the text box or by increasing / decreasing value button.
"Border shape" combo box: Sets the ImageKit.Edit.BorderShape property. Only valid for stamp objects.
"Character position" combo box: Sets the ImageKit.Edit.TextAlign property. Only valid for stamp objects.


ImageKit X Programing Guide

Annotating Without Using Toolbars

How to use Annotation methods without using the ImageKit's Standard Toolbar control

Example Code

In this example, we use code to perform the same functions that Toolbar buttons perform and draw an object.

[Visual Basic.NET]

'When using Annotation functions, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

'Use the color dialog to set the color of the line or text
Dim colDialog As New ColorDialog()
If (colDialog.ShowDialog = Windows.Forms.DialogResult.OK) Then
ImageKit1.Edit.ForeColor = colDialog.Color
End If

'Set the width of the pen
ImageKit1.Edit.PenWidth = 10

'Set the type of object to Polyline (when drawing an object with the mouse)
'When drawing with a method, as shown below, it is not necessary to set the KindOfEdit property.
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Polyline

'Draw Polylines with methods without using the mouse
Dim pts As Point() = {New Point(0, 0), New Point(10, 50), New Point(50, 10)}
ImageKit1.Edit.DrawPolyline(pts)

'Embed the objects into the base image (rasterize them)
ImageKit1.Edit.DrawEditedObjectsToImage()

'Select the third object and delete it
ImageKit1.Edit.SelectObject(3)
ImageKit1.Edit.DeleteSelectedObjects()

[Visual C#.NET]

//When using Annotation functions, the following property must be set to True.
ImageKit1.Edit.EditEnabled = true;

//Use the color dialog to set the color of the line or text
ColorDialog colDialog = new ColorDialog();
if (colDialog.ShowDialog == Windows.Forms.DialogResult.OK)
{
ImageKit1.Edit.ForeColor = colDialog.Color;
}

//Set the width of the pen
ImageKit1.Edit.PenWidth = 10;

//Set the type of object to Polyline (when drawing an object with the mouse)
//When drawing with a method, as shown below, it is not necessary to set the KindOfEdit property.
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Polyline;

//Draw Polylines with methods without using the mouse
Point[] pts = { new Point(0, 0), new Point(10, 50), new Point(50, 10) };
ImageKit1.Edit.DrawPolyline(pts);

//Embed the objects into the base image (rasterize them)
ImageKit1.Edit.DrawEditedObjectsToImage();

//Select the third object and delete it
ImageKit1.Edit.SelectObject(3);
ImageKit1.Edit.DeleteSelectedObjects();

Relevant Properties

ImageKit.Edit.EditKind
ImageKit.Edit.ForeColor
ImageKit.Edit.BackColor
ImageKit.Edit.PenWidth
ImageKit.Edit.Fill

Relevant Methods

ImageKit.Edit.DrawLine
ImageKit.Edit.DrawPolyline
ImageKit.Edit.DrawPolygon
ImageKit.Edit.DrawRectangle
ImageKit.Edit.DrawEllipse
ImageKit.Edit.DrawRoundRectangle
ImageKit.Edit.PasteImage
ImageKit.Edit.DrawText
ImageKit.Edit.DrawStamp
ImageKit.Edit.SelectObject
ImageKit.Edit.SelectAllObjects
ImageKit.Edit.DeleteSelectedObjects
ImageKit.Edit.CutSelectedObjects
ImageKit.Edit.CopySelectedObjects
ImageKit.Edit.PasteCopiedObjects
ImageKit.Edit.MoveToFront
ImageKit.Edit.MoveForwardOne
ImageKit.Edit.MoveBackOne
ImageKit.Edit.MoveToBack
ImageKit.Edit.Undo
ImageKit.Edit.Redo
ImageKit.Edit.DrawEditedObjectsToImage
ImageKit.Edit.ClearAllObjects


ImageKit X Programing Guide

Drawing Arrows

Arrows are drawn using straight or polyline objects with the Start/End ArrowCap, Start/End ArrowCapSize, and Start/End ArrowCapFilled properties set.

The start point and end point can be set independently. In addition, these settings can be changed even after drawing by using the SelectedObjectStartArrowCap, the SelectedObjectEndArrowCap, the SelectedObjectStartArrowCapSize, the SelectedObjectEndArrowCapSize, the SelectedObjectStartArrowCapFilled, and the SelectedObjectEndArrowCapFilled properties.

How To Draw An Arrow

Example Code

Set the start point to a regular arrow and the end point to a filled triangular arrow.

The same thing can be done using Toolbar Controls. See Using Toolbars

[Visual Basic.NET]

'When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

'Set a Line Object
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Line
ImageKit1.Edit.PenWidth = 10
ImageKit1.Edit.ForeColor = Color.Blue

'Set StartArrowCap
ImageKit1.Edit.StartArrowCap = True
'Set Start Arrow Cap size
ImageKit1.Edit.StartArrowCapSize = 20
'Do not fill the StartArrowCap
ImageKit1.Edit.StartArrowCapFilled = False

'Set EndArrowCap
ImageKit1.Edit.EndArrowCap = True
'Set End Arrow Cap size
ImageKit1.Edit.EndArrowCapSize = 30
'Fill the EndArrowCap
ImageKit1.Edit.EndArrowCapFilled = True

'After this, draw a straight line with the mouse or method

[Visual C#.NET]

//When using Annotation function, the following property must be set to true.
ImageKit1.Edit.EditEnabled = true;

//Set a Line Object
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Line;
ImageKit1.Edit.PenWidth = 10;
ImageKit1.Edit.ForeColor = Color.Blue;

//Set StartArrowCap
ImageKit1.Edit.StartArrowCap = true;
//Set Start Arrow Cap size
ImageKit1.Edit.StartArrowCapSize = 20;
//Do not fill the StartArrowCap
ImageKit1.Edit.StartArrowCapFilled = false;

//Set EndArrowCap
ImageKit1.Edit.EndArrowCap = true;
//Set End Arrow Cap size
ImageKit1.Edit.EndArrowCapSize = 30;
//Fill the EndArrowCap
ImageKit1.Edit.EndArrowCapFilled = true;

//After this, draw a straight line with the mouse or method

Relevant Properties

ImageKit.Edit.StartArrowCap
ImageKit.Edit.StartArrowCapSize
ImageKit.Edit.StartArrowCapFilled
ImageKit.Edit.EndArrowCap
ImageKit.Edit.EndArrowCapSize
ImageKit.Edit.EndArrowCapFilled
ImageKit.Edit.SelectedObjectStartArrowCap
ImageKit.Edit.SelectedObjectStartArrowCapSize
ImageKit.Edit.SelectedObjecttartArrowCapFilled
ImageKit.Edit.SelectedObjectEndArrowCap
ImageKit.Edit.SelectedObjectEndArrowCapSize
ImageKit.Edit.SelectedObjectEndArrowCapFilled


ImageKit X Programing Guide

Drawing Decorated Text with Outlines, Shadows, and Gradient Text Color

Set the DesignedTextEnabled property to True and configure the associated property values to draw decorated text.

Additionally, these settings can be changed even after drawing.

Example of drawing:

Code Example

Draws text with borders, shadows, and gradient.

[Visual Basic.NET]

'When using the annotation feature, the following properties need to be set to True.
ImageKit1.Edit.EditEnabled = True

'Set the drawing object to text
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Text
ImageKit1.Edit.Fill = False

'Enable decorated text
ImageKit1.Edit.DesignedTextEnabled = True

'Settings for text border
ImageKit1.Edit.TextBorderWidth = 10
ImageKit1.Edit.TextBorderColor = Color.Yellow

'Text color and gradient
ImageKit1.Edit.ForeColor = Color.Red
ImageKit1.Edit.ForeColor2 = Color.Blue
ImageKit1.Edit.TextLinearGradientMode = LinearGradientMode.Horizontal

'Settings for text shadow
ImageKit1.Edit.TextShadowColor = Color.Gray
ImageKit1.Edit.TextShadowBlur = 5
ImageKit1.Edit.TextShadowColorOpacity = 50
ImageKit1.Edit.TextShadowOffsetX = 10
ImageKit1.Edit.TextShadowOffsetY = 10

'After this, draw the text using mouse, keyboard operations, or methods

[Visual C#.NET]
//※When using the annotation function, you need to set the following properties to True
ImageKit1.Edit.EditEnabled = true;

ImageKit1.Edit.Fill = false;
//Set the drawing object to text
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Text;

//Enable decorated text
ImageKit1.Edit.DesignedTextEnabled = true;

//Settings for text border
ImageKit1.Edit.TextBorderWidth = 10;
ImageKit1.Edit.TextBorderColor = Color.Yellow;

//Text color and gradient
ImageKit1.Edit.ForeColor = Color.Red;
ImageKit1.Edit.ForeColor2 = Color.Blue;
ImageKit1.Edit.TextLinearGradientMode = LinearGradientMode.Horizontal;

//Settings for text shadow
ImageKit1.Edit.TextShadowColor = Color.Gray;
ImageKit1.Edit.TextShadowBlur = 5;
ImageKit1.Edit.TextShadowColorOpacity = 50;
ImageKit1.Edit.TextShadowOffsetX = 10;
ImageKit1.Edit.TextShadowOffsetY = 10;

//After this, draw the text using mouse, keyboard operations, or methods

◆ Reference Properties

ImageKit.Edit.DesignedTextEnabled
ImageKit.Edit.TextBorderColor
ImageKit.Edit.TextBorderColorOpacity
ImageKit.Edit.TextBorderWidth
ImageKit.Edit.ForeColor2
ImageKit.Edit.TextLinearGradientMode
ImageKit.Edit.TextShadowBlur
ImageKit.Edit.TextShadowColor
ImageKit.Edit.TextShadowColorOpacity
ImageKit.Edit.TextShadowOffsetX
ImageKit.Edit.TextShadowOffsetY
ImageKit.Edit.SelectedObjectTextBorderColor
ImageKit.Edit.SelectedObjectTextBorderColorOpacity
ImageKit.Edit.SelectedObjectTextBorderWidth
ImageKit.Edit.SelectedObjectForeColor2
ImageKit.Edit.SelectedObjectTextLinearGradientMode
ImageKit.Edit.SelectedObjectTextShadowBlur
ImageKit.Edit.SelectedObjectTextShadowColor
ImageKit.Edit.SelectedObjectTextShadowColorOpacity
ImageKit.Edit.SelectedObjectTextShadowOffsetX
ImageKit.Edit.SelectedObjectTextShadowOffsetY


ImageKit X Programing Guide

Drawing Dashed Lines

Dashed lines can be used when drawing straight lines, polylines, polygons, and pen objects by setting the DashStyle property. Multiple types of dashed line are possible.

You can set the DashStyle property to DashStyle.Custom and define custom dash patterns using the DashPattern property to draw custom dashed line patterns. Additionally, these settings can be modified even after drawing using the SelectedObjectDashStyle and SelectedObjectDashPattern properties.

How to draw a dashed line with DashStyle: DashDotDot

How to draw a dashed line with custom DashStyle: { 2.0F, 1.0F, 2.0F, 1.0F, 2.0F, 2.0F }

Example Code

Set the polyline dashed line style to "DashDotDot":

The same thing can be done using Toolbar Controls. See Using Toolbars section for information on the toolbar.

[Visual Basic.NET]

'When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

'Set the object to polyline
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Polyline
ImageKit1.Edit.PenWidth = 10
ImageKit1.Edit.ForeColor = Color.Red

'Set the line style
ImageKit1.Edit.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot

'After this, draw a polyline with the mouse or method

[Visual C#.NET]

//When using Annotation function, the following property must be set to true.
ImageKit1.Edit.EditEnabled = true;

//Set the object to polyline
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Polyline;
ImageKit1.Edit.PenWidth = 10;
ImageKit1.Edit.ForeColor = Color.Red;

//Set the line style
ImageKit1.Edit.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;

//After this, draw a polyline with the mouse or method

Relevant Properties

ImageKit.Edit.DashStyle
ImageKit.Edit.DashPattern
ImageKit.Edit.SelectedObjectDashStyle
ImageKit.Edit.SelectedObjectDashPattern

Reference Sample Project

\Examples\WinForm\CSharp or VB.NETAnnotation Samples\EditToolBar


ImageKit X Programing Guide

Drawing Double Lines

To draw a double line, use a straight line object and set the DoubleLine property to True.

By setting the DoubleLineWidth1 and DoubleLineWidth2 properties, you can adjust the thickness and spacing ratio of each line.

Additionally, these settings can be modified even after drawing using the SelectedObjectDoubleLine, SelectedObjectDoubleLineWidth1, and SelectedObjectDoubleLine, SelectedObjectDoubleLineWidth2 properties.

Drawing a double line + arrow
DoubleLineWidth1:33
DoubleLineWidth2:33

Drawing a double line with different widths
DoubleLineWidth1:50
DoubleLineWidth2:20

Example Code

Set the Line Object for double lines

The same thing can be done using Toolbar Controls. See Using Toolbars.

[Visual Basic.NET]

'When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

'Set a Line Object
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Line
ImageKit1.Edit.PenWidth = 10
ImageKit1.Edit.ForeColor = Color.Red

'Set double line
ImageKit1.Edit.DoubleLine = True

'After this, draw a straight line with the mouse or method

[Visual C#.NET]

//When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = true;

//Set a Line Object
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Line;
ImageKit1.Edit.PenWidth = 10;
ImageKit1.Edit.ForeColor = Color.Red;

//Set double line
ImageKit1.Edit.DoubleLine = true;

//After this, draw a straight line with the mouse or method

Relevant Properties

ImageKit.Edit.DoubleLine
ImageKit.Edit.DoubleLineWidth1
ImageKit.Edit.DoubleLineWidth2
ImageKit.Edit.SelectedObjectDoubleLine
ImageKit.Edit.SelectedObjectDoubleLineWidth1
ImageKit.Edit.SelectedObjectDoubleLineWidth2

Reference Sample Project

\Examples\WinForm\CSharp or VB.NETAnnotation Samples\EditToolBar


ImageKit X Programing Guide

Line Join Style For Polylines and Polygons

The LineJoin property allows you to set the joining style for straight and continuous line objects. Multiple join styles are possible.

You can also change these settings after drawing with the SelectedObjectLineJoin property.

Line Join Style Example

Example Code

Set the polyline joining style to "Round".

The same thing can be done using Toolbar Controls. See Using Toolbars.

[Visual Basic.NET]

'When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

'Set object to polyline
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Polyline
ImageKit1.Edit.PenWidth = 10
ImageKit1.Edit.ForeColor = Color.Red

'Set linejoin style
ImageKit1.Edit.LineJoin = System.Drawing.Drawing2D.LineJoin.Round

'After this, draw a polyline using the mouse or executing a method

[Visual C#.NET]

//When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = true;

//Set object to polyline
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Polyline;
ImageKit1.Edit.PenWidth = 10;
ImageKit1.Edit.ForeColor = Color.Red;

//Set linejoin style
ImageKit1.Edit.LineJoin = System.Drawing.Drawing2D.LineJoin.Round;

//After this, draw a polyline with the mouse or method

Relevant Properties

ImageKit.Edit.LineJoin
ImageKit.Edit.SelectedObjectLineJoin


ImageKit X Programing Guide

Set Object Opacity

Set object opacity by using the ForeColorOpacity, BackColorOpacity, and BorderColorOpacity properties.

These properties are set with a value between 0 and 100 (%), which indicates "opacity". The higher the value, the higher the opacity. 0 is completely transparent (not displayed), 100 is completely opaque.

You can also change these settings after drawing using the SelectedObjectForeColorOpacity, SelectedObjectBackColorOpacity, and SelectedObjectBorderColorOpacity properties.

Transparency Example

Example Code

Sets the background of the text object to be partially transparent.

The same thing can be done using Toolbar Controls. See Using Toolbars.

[Visual Basic.NET]

'When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

'Set the object to Text Object
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Text
ImageKit1.Edit.Border = False
ImageKit1.Edit.FontName = "CooperBlack"
ImageKit1.Edit.FontSize = 20
ImageKit1.Edit.ForeColor = Color.Black
ImageKit1.Edit.BackColor = Color.Yellow
'Set background transparency to 50%
ImageKit1.Edit.BackColorOpacity = 50

'After this, draw the text using the mouse or executing a method

[Visual C#.NET]

//When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = true;

//Set the object to Text Object
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Text;
ImageKit1.Edit.Border = false;
ImageKit1.Edit.FontName = "CooperBlack";
ImageKit1.Edit.FontSize = 20;
ImageKit1.Edit.ForeColor = Color.Black;
ImageKit1.Edit.BackColor = Color.Yellow;
//Set background transparency to 50%
ImageKit1.Edit.BackColorOpacity = 50;

//After this, draw the text using the mouse or executing a method

Relevant Properties

ImageKit.Edit.ForeColorOpacity
ImageKit.Edit.BackColorOpacity
ImageKit.Edit.BorderColorOpacity
ImageKit.Edit.SelectedObjectForeColorOpacity
ImageKit.Edit.SelectedObjectBackColorOpacity
ImageKit.Edit.SelectedObjectBorderColorOpacity


ImageKit X Programing Guide

Draw a Stamp Object

Use a stamp object to draw with the BorderShape property set to Ellipse, the VerticalText property set to True, and the TextAlign property set to Center.

You can also change these settings after drawing with the SelectedObjectBorderShape, SelectedObjectVerticalText, and SelectedObjectTextAlign properties.

Stamp Example:

Example Code

How to set the Stamp object

The same thing can be done using Toolbar Controls. See Using Toolbars.

[Visual Basic.NET]

'When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

'Set annotation object to Stamp
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Stamp
ImageKit1.Edit.Fill = False
ImageKit1.Edit.BorderWidth = 5
ImageKit1.Edit.ForeColor = Color.Red
ImageKit1.Edit.BorderColor = Color.Red
'Make the border shape of the stamp elliptical
ImageKit1.Edit.BorderShape = Newtone.ImageKit.Win.Ellipse
'Write vertical text
ImageKit1.Edit.VerticalText = True
'Center the character's position
ImageKit1.Edit.TextAlign = Newtone.ImageKit.Win.Center

'After this, draw the stamp with the mouse or method

[Visual C#.NET]

//When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = true;
//Set annotation object to Stamp
ImageKit1.Edit.EditKind = Newtone.ImageKit.Win.KindOfEdit.Stamp;
ImageKit1.Edit.Fill = false;
ImageKit1.Edit.BorderWidth = 5;
ImageKit1.Edit.ForeColor = Color.Red;
ImageKit1.Edit.BorderColor = Color.Red;
//Make the border shape of the stamp elliptical
ImageKit1.Edit.BorderShape = Newtone.ImageKit.Win.Ellipse;
//Write vertical text
ImageKit1.Edit.VerticalText = true;
//Center the character's position
ImageKit1.Edit.TextAlign = Newtone.ImageKit.Win.Center;

//After this, draw the stamp with the mouse or method

Relevant Properties

ImageKit.Edit.BorderShape
ImageKit.Edit.VerticalText
ImageKit.Edit.TextAlign
ImageKit.Edit.SelectedObjectBorderShape
ImageKit.Edit.SelectedObjectVerticalText
ImageKit.Edit.SelectedObjectTextAlign


ImageKit X Programing Guide

Draw Line object and transform 45 and 90 degrees

Line objects can be drawn /transformed by holding down the Shift key and moving the mouse.

When drawing a Line object, placing the second point determines whether the line is 0/180 degress, or 45 / 90 degrees.

For transformations, use the mouse to grab the block on the rectangle surrounding the line object and move it. If you grab the blocks at one of the corners, this will transform the line 45 degrees. If you use the mouse to grab the blocks on the sides, the Line object will be transformed by 0 or 180 degrees. If you grab the blocks on the top or bottom, the Line object transforms 90 degress.

Code Example

Creating rectangle / ellipse / rounded rectangle objects while maintaining the aspect ratio.

[When drawing the object]

Set the EditKind property to Line, determine the first point, then hold down the Shift key to determine the position of the second point.

[When transforming the object]

Select a Line object, grab one of the blocks and hold down the Shift key while moving the mouse.

(* After drawing / transforming, release the Shift key after mouse-up.)

Using code to transform a Line object

[Visual Basic.NET]

'When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

[When drawing the object]
'Set required properties such as color and line thickness
.
.
.

'Set the Point argument and draw the Line object
'* Example of drawing a 45 degree line
Dim drawPoints As Point() = {New Point(10, 50), New Point(110, 150)}
ImageKit1.Edit.DrawLine(drawPoints)

[When transforming the object]
'Select the object to be transformed (assuming the target object number is 3)
ImageKit1.Edit.SelectObject(3)

'Set the SelectedObjectDrawPoints property so that Point is drawn at 45 degrees
'* Example of setting the angle to 45 degrees while keeping the upper left position as it is
Dim newPoints As Point() = { ImageKit1.Edit.SelectedObjectDrawPoints(0), _
New Point(ImageKit1.Edit.SelectedObjectDrawPoints(0).X + 200, _
ImageKit1.Edit.SelectedObjectDrawPoints(0).Y + 200) }
ImageKit1.Edit.SelectedObjectDrawPoints = newPoints

[Visual C#.NET]

//When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = true;

[When drawing the object]
//Set required properties such as color and line thickness
.
.
.

//Set the Point argument and draw the Line object
//* Example of drawing a 45 degree line
Point[] newPoindrawPointsts = {new Point(10, 50), new Point(210, 250)};
ImageKit1.Edit.DrawLine(drawPoints);

[When transforming the object]
//Select the object to be transformed (assuming the target object number is 3)
ImageKit1.Edit.SelectObject(3);

//Set the SelectedObjectDrawPoints property so that Point is drawn at 45 degrees
//* Example of setting the angle to 45 degrees while keeping the upper left position as it is
Point[] newPoints = { ImageKit1.Edit.SelectedObjectDrawPoints[0],
new Point(ImageKit1.Edit.SelectedObjectDrawPoints[0].X + 200,
ImageKit1.Edit.SelectedObjectDrawPoints[0].Y + 200) };
ImageKit1.Edit.SelectedObjectDrawPoints = newPoints;

Relevant Properties

ImageKit.Edit.SelectedObjectDrawPoints

Relevant Methods

ImageKit.Edit.SelectObject
ImageKit.Edit.DrawLine


ImageKit X Programing Guide

Resize rectangle / ellipse / rounded rectangle objects while maintaining the current aspect ratio

Set the AspectRatio property to True when transforming, then hold down the Shift key while manipulating the mouse.

Example Operation and Code

Transforms a rectangle / ellipse / rounded rectangle object while maintaining the aspect ratio.

Using Mouse To Resize Object

(1) Set the ImageKit1.Edit.AspectRatio property to True
(2)Select a single object, grab one of the four corner blocks and hold down the Shift key while moving the mouse.

(* You can change the behavior by pressing or releasing the Shift key even during mouse operation.)
(* When finished, release the Shift key after mouse-up.)

Using Code To Resize Object

[Visual Basic.NET]

'When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

'Select the object to be transformed (assuming the target object number is 3)
ImageKit1.Edit.SelectObject(3)
'* When using code, the value of the AspectRatio property does not matter.

'Set the configuration coordinates after transformation (keep the upper left position and increase the size by 1.5 times while maintaining the aspect ratio)
Dim newPoints As Point() = { ImageKit1.Edit.SelectedObjectDrawPoints(0), _
New Point(ImageKit1.Edit.SelectedObjectDrawPoints(1).X * 1.5, _
ImageKit1.Edit.SelectedObjectDrawPoints(1).Y * 1.5) }
ImageKit1.Edit.SelectedObjectDrawPoints = newPoints

[Visual C#.NET]

//When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = true;

//Select the object to be transformed (assuming the target object number is 3)
ImageKit1.Edit.SelectObject(3);
//* In the case of code, the value of the AspectRatio property does not matter.

//Set the configuration coordinates after transformation (keep the upper left position and increase the size by 1.5 times while maintaining the aspect ratio)
Point[] newPoints = { ImageKit1.Edit.SelectedObjectDrawPoints[0],
new Point(Convert.ToInt32(ImageKit1.Edit.SelectedObjectDrawPoints[1].X * 1.5),
Convert.ToInt32(ImageKit1.Edit.SelectedObjectDrawPoints[1].Y * 1.5)) };
ImageKit1.Edit.SelectedObjectDrawPoints = newPoints;

Relevant Properties

ImageKit.Edit.AspectRatio
ImageKit.Edit.SelectedObjectDrawPoints

Relevant Methods

ImageKit.Edit.SelectObject


ImageKit X Programing Guide

Draw and transform objects with an aspect ratio of 1:1

To make objects with aspect ratio of 1:1, move the mouse while holding down the Shift key when drawing / transforming. For rectangles / ellipses / rounded rectangles, set the AspectRatio property to False before using the mouse to draw the object.

For PasteImage objects, set the AspectRatio property to False when drawing and the SelectedObjectAspectRatio property when transforming. For Text and Stamp objects, set the WordWrap property to False when drawing and the SelectedObjectWordWrap property to False when transforming.

Example Code

Draws or transforms images, background fill texts, and stamps with squares, perfect circles, rounded squares, and an aspect ratio of 1: 1.

Drawing and transforming using the mouse

[When drawing / pasting]

Square / Round / Rounded Square

(1) Set the ImageKit1.Edit.EditKind property to Newtone.ImageKit.Win.KindOfEdit.Rectangle / Ellipse / RoundRectangle (* For ellipses and rectangles, the value of the AspectRatio property is irrelevant)
(2) Draw while holding down the Shift key

Square image》 (1) Set the ImageKit1.Edit.EditKind property to Newtone.ImageKit.Win.KindOfEdit.Image2) Set the ImageKit1.Edit.AspectRatio property to False
(3) Specify the pasting range while holding down the Shift key.
(4) Select and paste (4) Select and paste the image file in the dialog box

Text stamp with 1: 1 aspect ratio (background fill)
(1) Set the ImageKit1.Edit.EditKind property to Newtone.ImageKit.Win.KindOfEdit.Text / StampgeKit1.Edit.WordWrap property to False
(* Set the Newtone.ImageKit.Win.KindOfEdit.Fill property to True for background fill with text)
(3) Specify the drawing range while holding down the Shift key (* Press the Shift key before mouse down to specify the range.)
(4) Enter text and click outside the range to confirm

(* After specifying the drawing / pasting range, release the Shift key after mouse-up.)

[When transforming]

[When transforming]

Square / Round / Rounded Square
(1) Set the ImageKit1.Edit.AspectRatio property to Falsendependently, grab o(2) Select the drawn object independently, grab one of the blocks at the four corners, and hold down the Shift key while transforming.

Square image
(1) Select the pasted image object independently and set the ImageKit1.Edit.SelectedObjectAspectRatio property to False.hold down the Shift (2) Grab one of the four corner blocks and hold down the Shift key while transforming.

Text stamp with 1: 1 aspect ratio (background fill)
(1) Select the pasted text / stamp object independently and set the ImageKit1.Edit.SelectedObjectWordWrap property to False.Shift key while transforming.

(* This operation is possible even if it is not a square / circle / rounded square when drawing / pasting. Conversely, even if it is drawn / pasted as a square / circle / rounded square, press the Shift key when transforming. If you do not press it, the aspect ratio will not be 1: 1.
You can also change the behavior by pressing and releasing the Shift key even during mouse operation. )

(* After transforming, release the Shift key after mouse-up.)

When drawing and transforming with code

[Visual Basic.NET]

'When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

[When drawing objects]
'Required only for PasteImage objects (for ellipses, rectangles and texts, the value of the AspectRatio property is irrelevant)
ImageKit1.Edit.AspectRatio = False
'Required only for text / stamps (for ellipses, rectangles and images, the value of the WordWrap property is irrelevant)
ImageKit1.Edit.WordWrap = False

'Set required properties such as color and line thickness
       ・
       ・
       ・
'Draw with the same value for the width and height of the argument Rectangle (example of drawing with height and width 100px at the position of x = 10, y = 50)
Dim drawRect As Rectangle = New Rectangle(10, 50, 100, 100)
Dim drawRectF As RectangleF = New RectangleF(10, 50, 100, 100) 'For Text/Stamp objects

'For squares / circles / rounded squares
ImageKit1.Edit.DrawRectangle/DrawEllipse/DrawRoundRectangle(drawRect)
'For PasteImage object
ImageKit1.Edit.PasteImage("imagefile.jpg", drawRect)
'For Text / Stamp objects
ImageKit1.Edit.DrawText(drawRectF)

[At the time of tranformation]
'Select the object to be transformed (assuming the target object number is 3)
ImageKit1.Edit.SelectObject(3)

'For rectangles / ellipses / rounded rectangles, the value of the AspectRatio property is irrelevant when transforming with code.
'The following settings are required for PasteImage objects
ImageKit1.Edit.SelectObjectAspectRatio = False
'The following settings are required only for Text / Stamp objects
ImageKit1.Edit.SelectObjectWordWrap = False

'Set the configuration coordinates after the size change (height / width 200px at the position of x = 10, y = 50)
Dim newPoints As Point() = {New Point(10, 50), New Point(210, 250)}
ImageKit1.Edit.SelectedObjectDrawPoints = newPoints

[Visual C#.NET]

//When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = true;

[When drawing objects]
//Required only for PasteImage objects (for ellipses, rectangles and texts, the value of the AspectRatio property is irrelevant)
ImageKit1.Edit.AspectRatio = false;
//Required only for text / stamps (for ellipses, rectangles and images, the value of the WordWrap property is irrelevant)
ImageKit1.Edit.WordWrap = False

//Set required properties such as color and line thickness
       ・
       ・
       ・
//Draw with the same value for the width and height of the argument Rectangle (example of drawing with height and width 100px at the position of x = 10, y = 50)
Rectangle drawRect = new Rectangle(10, 50, 100, 100);
RectangleF drawRectF = new RectangleF(10F, 50F, 100F, 100F); //For text/stamp objects

//For squares / circles / rounded squares
ImageKit1.Edit.SelectObjectDrawPoints/DrawEllipse/DrawRoundRectangle(drawRect);
//For PasteImage objects
ImageKit1.Edit.PasteImage("imagefile.jpg", drawRect);
'For text / stamp objects
RectangleF drawRectF = new RectangleF(10F, 50F, 100F, 100F); //Draw at height and width 100px at x = 10, y = 50
ImageKit1.Edit.DrawText(drawRectF)

[At time of transformation]
//Select the object to be transformed (assuming the target object number is 3)
ImageKit1.Edit.SelectObject(3);

//For rectangles / ellipses / rounded rectangles, the value of the AspectRatio property is irrelevant when transforming with code.
//The following settings are required only for PasteImage objects
ImageKit1.Edit.SelectObjectAspectRatio = false;
//The following settings are required only for Text / Stamp objects
ImageKit1.Edit.SelectObjectWordWrap = false;

//Set the configuration coordinates after size change (height and width 200px at the position of x = 10, y = 50)
Point[] newPoints = {new Point(10, 50), new Point(210, 250)};
ImageKit1.Edit.SelectedObjectDrawPoints = newPoints;

Relevant Properties

ImageKit.Edit.AspectRatio
ImageKit.Edit.WordWrap
ImageKit.Edit.SelectedObjectAspectRatio
ImageKit.Edit.SelectedObjectWordWrap
ImageKit.Edit.SelectedObjectDrawPoints

Relevant Methods

ImageKit.Edit.DrawRectangle
ImageKit.Edit.DrawEllipse
ImageKit.Edit.DrawRoundRectangle
ImageKit.Edit.DrawText
ImageKit.Edit.PasteImage
ImageKit.Edit.SelectObject


ImageKit X Programing Guide

Retrieve and set object properties using code

Get and set the component (property) of the selected object with code without using the property dialog.

Code Example

(1) Select an object in code and change its color.
(2) Change some properties of certain objects that meet specified conditions.

[Visual Basic.NET]

'When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

'(1) Select the third object and change its line / text color to red.
ImageKit1.Edit.SelectObject(3)
ImageKit1.Edit.SelectedObjectForeColor = Color.Red

'(2) Of the multiple drawn objects, the text of the text object is acquired and stored in the array.
Dim str_list As New List(Of String)()

'In the following usage, the selected rectangle will flicker normally, but if this property
'is set to True, the selected rectangle will not be displayed, so it will not flicker.
ImageKit1.Edit.HideSelectionBorder = True

Dim i As Integer
For i = 0 To ImageKit1.Edit.NumberOfObjects
'Select objects one by one
ImageKit1.Edit.SelectObject(i + 1)
'If the selected object is text, add that text to the array
If (ImageKit1.Edit.SelectedObjectKind = Newtone.ImageKit.Win.KindOfEdit.Text) Then
str_list.Add(ImageKit1.Edit.SelectedObjectText)
End If
Next

'Deselect an object
ImageKit1.Edit.DeselectObjects()

[Visual C#.NET]

//When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = true;

//(1) Select the third object and change its line / text color to red.
ImageKit1.Edit.SelectObject(3);
ImageKit1.Edit.SelectedObjectForeColor = Color.Red;

//(2) Of the multiple drawn objects, the text of the text object is acquired and stored in the array.
List<string> str_list = new List<string>();

//In the following usage, the selected rectangle will flicker normally, but if this property
//is set to True, the selected rectangle will not be displayed, so it will not flicker.

ImageKit1.Edit.HideSelectionBorder = true;

for (int i = 0; i < ImageKit1.Edit.NumberOfObjects; i++)
{
//Select objects one by one
ImageKit1.Edit.SelectObject(i + 1);
//If the selected object is text, add that text to the array
if (ImageKit1.Edit.SelectedObjectKind == Newtone.ImageKit.Win.KindOfEdit.Text)
str_list.Add(ImageKit1.Edit.SelectedObjectText);
}

//Deselect an object
ImageKit1.Edit.DeselectObjects();

Relevant Properties

ImageKit.Edit.NumberOfObjects
ImageKit.Edit.HideSelectionBorder
ImageKit.Edit.SelectedObjectKind
ImageKit.Edit.SelectedObjectForeColor
ImageKit.Edit.SelectedObjectText

Relevant Methods

ImageKit.Edit.SelectObject
ImageKit.Edit.DeselectObjects


ImageKit X Programing Guide

Save Annotation Objects In An Annotation File

Save the annotation objects drawn on the base image into a dedicated annotation file by executing the SaveAnnotationFile method.

The saved information can be loaded on another basic image even after the project is finished.

The same thing can be done using Toolbar Controls. See Using Toolbars

Example Code

Saves the annotation information currently drawn on the base image.

[Visual Basic.NET]

'When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

'Annotation file name (extension can be decided arbitrarily)
ImageKit1.Edit.AnnotationFileName = "annotation1.xml"
'Save to annotation file
ImageKit1.Edit.SaveAnnotationFile()

[Visual C#.NET]

//When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = true;

//Annotation file name (extension can be decided arbitrarily)
ImageKit1.Edit.AnnotationFileName = "annotation1.xml";
//Save to annotation file
ImageKit1.Edit.SaveAnnotationFile();

Relevant Properties

ImageKit.Edit.AnnotationFileName

Relevant Methods

ImageKit.Edit.SaveAnnotationFile


ImageKit X Programing Guide

Read the saved annotation information and draw it on the image.

The annotation information saved in the dedicated annotation file is read by the LoadAnnotationFile method and drawn on the basic image.

Annotations can be loaded on to different base images than when the annotations were saved.

The same thing can be done using Toolbar Controls. See Using Toolbars.

Example Code

Saves the annotation information that is currently drawn on the ImageKit control.

[Visual Basic.NET]

'When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

'Saved annotation file name
ImageKit1.Edit.AnnotationFileName = "annotation1.xml"
'Save to annotation file
ImageKit1.Edit.LoadAnnotationFile()

[Visual C#.NET]

//When using Annotation function, the following property must be set to True.
ImageKit1.Edit.EditEnabled = true;

//Saved annotation file name
ImageKit1.Edit.AnnotationFileName = "annotation1.xml";
//Save to annotation file
ImageKit1.Edit.LoadAnnotationFile();

Relevant Properties

ImageKit.Edit.AnnotationFileName

Relevant Methods

ImageKit.Edit.LoadAnnotationFile


ImageKit X Programing Guide

Customizing Toolbars

Change the image and order of the buttons on the toolbar, select and reconfigure the buttons you want to use, and get button events.

Each button is of type System.Windows.Forms.ToolStripButton and can be retrieved and set using that property type.

Example Code

Change the image used in the ToolBarAnnotation's button of the PasteImage object and change the button order.

[Visual Basic.NET]

'Describe the following in the Form Load event etc.
'* When using annotation functions, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

'Change the button image of "Paste image object"
toolBarAnnotation1.ButtonImage.ImageTransparentColor = Color.Magenta
toolBarAnnotation1.ButtonImage.Image = Image.FromFile("\\img.bmp")

'Clear the contents
toolBarAnnotation1.Items.Clear()

'Create a ToolStripItem to use only some buttons and place them in a different order
Dim items As ToolStripItem() = New ToolStripItem() { _
toolBarAnnotation1.ButtonImage, _
toolBarAnnotation1.ButtonRectangle, _
toolBarAnnotation1.ButtonText, _
toolBarAnnotation1.ButtonSelect, _
toolBarAnnotation1.ButtonDelete, _
toolBarAnnotation1.ButtonProperties _
}

'In the toolbar the order of button configuration and arrangement as set above
toolBarAnnotation1.Items.AddRange(items)

'Get click event for text button
AddHandler toolBarAnnotation1.ButtonText.Click, AddressOf ButtonText_Click

'Text button click event
Private Sub ButtonText_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
'The contents of the event
End Sub

[Visual C#.NET]
//Describe the following in the Form Load event etc.
//* When using annotation functions, the following property must be set to True.
ImageKit1.Edit.EditEnabled = true;

//Change the button image of "PasteImage object"
toolBarAnnotation1.ButtonImage.ImageTransparentColor = Color.Magenta;
toolBarAnnotation1.ButtonImage.Image = Image.FromFile("\\img.bmp");

//Clear the contents
toolBarAnnotation1.Items.Clear();

//Create a ToolStripItem to use only some buttons and place them in a different order
ToolStripItem[] items = new ToolStripItem[] {
toolBarAnnotation1.ButtonImage,
toolBarAnnotation1.ButtonRectangle,
toolBarAnnotation1.ButtonText,
toolBarAnnotation1.ButtonSelect,
toolBarAnnotation1.ButtonDelete,
toolBarAnnotation1.ButtonProperties
};

//In the toolbar the order of button configuration and arrangement as set above
toolBarAnnotation1.Items.AddRange(items);

//Get click event for text button
toolBarAnnotation1.ButtonText.Click += new EventHandler(ButtonText_Click);

//Text button's click event
void ButtonText_Click(object sender, EventArgs e)

{
//The contents of the event
}

Relevant Properties

ToolBarAnnotation.ButtonImage

Refer here for all other toolbar button properties and related properties,
ToolBarStandard Members
ToolBarAnnotation Members
ToolBarSetupLines Members
ToolBarSetupObjects Members


CustomizeContextMenu.htm

ImageKit X Programing Guide

Using A Custom Context Menu

This example illustates how to display a custom context menu by right clicking on the ImageKit Control.

The custom context menu will have items labeled "Change Color", "Rotate", "Copy and Paste", and "Properties".

Custom Context Menu

The steps to accomplish this are:
1. Place a System.Window.Forms.ContextMenuStrip control on your form.
2. Add four TooStripMenuItems and label them "Change color" "Rotate" "Copy and paste" "Properties".
3. Set the click events.

Code Example

[Visual Basic.NET]

'Write the following code in the Form Load event etc.
'* The EditEnabled property must be set to True when using annotation functions.
ImageKit1.Edit.EditEnabled = True

'Assign contextMenuStrip1 to the ImageKit control's ContextMenuStrip property
ImageKit1.Edit.ContextMenuEnabled = False
ImageKit1.ContextMenuStrip = contextMenuStrip1

'Add Events

'When custom context menu 1 is clicked, make the color of the selected object red
Private Sub Change Color ToolStripMenuItem_Click (ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Change Color ToolStripMenuItem.Click
ImageKit1.Edit.SelectedObjectForeColor = Color.Red
End Sub

'When custom context menu 2 is clicked, rotate the selected object +30 degrees
Private Sub Rotating ToolStripMenuItem_Click (ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Rotating ToolStripMenuItem.Click
ImageKit1.Edit.SelectedObjectAngle + = 30
End Sub

'When custom context menu 3 is clicked, copy the selected object and paste it at the position where the upper left coordinates are (50, 50)
Private Sub Copy and Paste ToolStripMenuItem_Click (ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Copy and Paste ToolStripMenuItem.Click
ImageKit1.Edit.CopySelectedObjects ()
ImageKit1.Edit.PasteCopiedObjects (50, 50)'* The upper left is the position of (50, 50) when the angle is 0, so it may look different if it is rotating.
End Sub

'When custom context menu 4 is clicked, display the property dialog for the selected object
Private Sub Property ToolStripMenuItem_Click (ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Property ToolStripMenuItem.Click
ImageKit1.Edit.ShowPropertyDialog ()
End Sub

[Visual C#.NET]

//Write the following code in the Form Load event etc.
//* The EditEnabled property must be set to True when using annotation functions.
ImageKit1.Edit.EditEnabled = true;

//Assign contextMenuStrip1 to the ImageKit control's ContextMenuStrip property
ImageKit1.Edit.ContextMenuEnabled = false;
ImageKit1.ContextMenuStrip = contextMenuStrip1;

//Add Events

//When custom context menu 1 is clicked, make the color of the selected object red
private void
                Change Color ToolStripMenuItem_Click(object sender, EventArgs e)
{
ImageKit1.Edit.SelectedObjectForeColor = Color.Red;
}

//When custom context menu 2 is clicked, rotate the selected object +30 degrees
private void Rotate ToolStripMenuItem_Click(object sender, EventArgs e)
{
ImageKit1.Edit.SelectedObjectAngle += 30;
}

//When custom context menu 3 is clicked, copy the selected object and paste it at the position where the upper left coordinates are (50, 50)
private void Copy and Paste ToolStripMenuItem_Click(object sender, EventArgs e)
{
ImageKit1.Edit.CopySelectedObjects ();
ImageKit1.Edit.PasteCopiedObjects (50, 50); //* The upper left is the position of (50, 50) when the angle is 0, so it may look different if it is rotating.
}

//When custom context menu 4
                is clicked, display the property dialog for the selected object
private void Property ToolStripMenuItem_Click(object sender, EventArgs e)
{
ImageKit1.Edit.ShowPropertyDialog ();
}

Referenced Properties

ImageKit.Edit.ContextMenuEnabled


ImageKit X Programing Guide

Using a custom Property Dialog

Create a custom property dialog that will be displayed when you right click the ImageKit Control and select "Properties" in the editing context menu or when you click the "Properties" button in the ToolBarAnnotation toolbar.

Code Example

Display a dialog that sets the "Color/Text Color" and "Line Thickness"

* In addition to the main form, create a form (Form2) with a "Change color / text color" button and numericUpDown1 to set the line thickness.

Custom Dialog

[Visual Basic.NET]

* Description in the main form
'Declare the form to use to make the custom dialog
Private WithEvents myDialog As New Form2()

'Describe the following in the Form Load event of the main form.
'* When using annotation functions, the following property must be set to True.
ImageKit1.Edit.EditEnabled = True

'Set the your dialog into the CustomDialog property
ImageKit1.Edit.CustomDialog = myDialog
'Get the event that closes the custom dialog
AddHandler myDialog.FormClosed, AddressOf myDialog_FormClosed

'Get the contents of the object for display of the custom dialog (= myDialog (= Form2))
Private Sub ImageKit1_ObjectSelected(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ImageKit1.ObjectSelected
myDialog.ikForecolor = ImageKit1.Edit.SelectedObjectForeColor
myDialog.ikPenWidth = ImageKit1.Edit.SelectedObjectPenWidth
End Sub

'When the "OK" button is pressed in the custom dialog, the settings are reflected in the object.
Private Sub myDialog_FormClosed(ByVal sender As System.Object, ByVal e As System.Windows.Forms.FormClosedEventArgs)
If (myDialog.DialogResult = DialogResult.OK) Then
ImageKit1.Edit.SelectedObjectForeColor = myDialog.ikForecolor
ImageKit1.Edit.SelectedObjectPenWidth = myDialog.ikPenWidth
End If
End Sub

* Description in the property dialog (Form2)
'Declare variables for object properties
Friend ikForecolor As Color
Friend ikPenWidth As Integer

'On form load, set button text color and NumericUpDown value to current values
Private Sub Form2_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
button1.ForeColor = ikForecolor
numericUpDown1.Value = ikPenWidth
End Sub

'When the color button is pressed, a color dialog is displayed and the color is set.
Private Sub button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles button1.Click
Dim cd As New ColorDialog()

If (cd.ShowDialog() = DialogResult.OK) Then
button1.ForeColor = cd.Color
End If

cd.Dispose()
End Sub

'Reflect the contents set with the "OK" button
Private Sub button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles button2.Click
ikForecolor = button1.ForeColor
ikPenWidth = numericUpDown1.Value
End Sub

[Visual C#.NET]

//Declare the form to use to make the custom dialog
private Form2 myDialog = new Form2();

//Describe the following in the Form Load event of the main form.
//* When using annotation functions, the following property must be set to True.
ImageKit1.Edit.EditEnabled = true;

//Set the your dialog into the CustomDialog property
ImageKit1.Edit.CustomDialog = myDialog;
//Get the event that closes the custom dialog
myDialog.FormClosed += new FormClosedEventHandler(myDialog_FormClosed);

//Get the contents of the object for display of the custom dialog (= myDialog (= Form2))
private void ImageKit1_ObjectSelected(object sender, EventArgs e)
{
myDialog.ikForecolor = ImageKit1.Edit.SelectedObjectForeColor;
myDialog.ikPenWidth = ImageKit1.Edit.SelectedObjectPenWidth;
}

//When the "OK" button is pressed in the custom dialog, the settings are reflected in the object.
void myDialog_FormClosed(object sender, FormClosedEventArgs e)
{
if (myDialog.DialogResult == DialogResult.OK)
{
ImageKit1.Edit.SelectedObjectForeColor = myDialog.ikForecolor;
ImageKit1.Edit.SelectedObjectPenWidth = myDialog.ikPenWidth;
}
}

* Description in the property dialog (Form2)
//Declare variables for object properties
internal Color ikForecolor = Color.Black;
internal int ikPenWidth = 0;

//On form load, set button text color and NumericUpDown value to current values
Private Sub Form2_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
button1.ForeColor = ikForecolor;
numericUpDown1.Value = ikPenWidth;
End Sub

//When the color button is pressed, a color dialog is displayed and the color is set.
private void button1_Click(object sender, EventArgs e)
{
ColorDialog cd = new ColorDialog();

if (cd.ShowDialog() == DialogResult.OK)
button1.ForeColor = cd.Color;

cd.Dispose();
}

//Reflect the contents set with the "OK" button
private void button2_Click(object sender, EventArgs e)
{
ikForecolor = button1.ForeColor;
ikPenWidth = (int)numericUpDown1.Value;
}

Relevant Properties

ImageKit.Edit.CustomDialog
ImageKit.Edit.SelectedObjectForeColor
For a full list of properties, please see:
ImageKit.Edit Members


ImageKit X Programing Guide

Change The Color Depth (Bit Count) Of An Image

The example converts a 24 bit color image to 1 bit color.

It uses the ConvertColor method to change the color depth of the image loaded into the ImageKit control.

Example Code

Converts a 24-bit image to a 1-bit image with a threshold of 128, creating a palette that fits the image (without using a fixed palette). Dithering is disabled.

[Visual Basic.NET]

ImagKit1.File.FileName = "24bitBMP.bmp"
ImageKit1.File.LoadImageFromFile()

'Convert bitcount
ImageKit1.Effect.ConvertColor(1, False, False, 128)

'Display in scale display mode
ImageKit1.DisplayMode = Newtone.ImageKit.Win.DisplayMode.Scale
ImageKit1.Display()

[Visual C#.NET]

ImagKit1.File.FileName = "24bitBMP.bmp";
ImageKit1.File.LoadImageFromFile();

//Convert bitcount
ImageKit1.Effect.ConvertColor(1, false, false, 128);

//Display in scale display mode
ImageKit1.DisplayMode = Newtone.ImageKit.Win.DisplayMode.Scale;
ImageKit1.Display();

Relevant Methods

ImageKit.Effect.ConvertColor


ImageKit X Programing Guide

Copies A Portion Of An Image

This example copies a portion of the image displayed in ImageKit control using the CutRectImage method.

Example Code

Use the mouse to specify the area on the image that you want to copy. The copied image is set in the ImageKit.Image property and displayed

[Visual Basic.NET]

'(Images are already loaded in the ImageKit control)
'Disable annotation mode so that you can select an area on the image by dragging the mouse
ImageKit1.Edit.EditEnabled = False

'After selecting the area to be copied, execute the CutRectImage method)
'Set the selected area into the Effect.Rect property
ImageKit1.Effect.Rect = ImageKit1.Rect

'Execute the CutRectImage method
Dim ret As Boolean = ImageKit1.Effect.CutRectImage()
If Not ret Then Return

'Refresh ImageKit control to display the copied image
ImageKit1.Refresh()

[Visual C#.NET]

//(Images are already loaded in the ImageKit control)
//Disable annotation mode so that you can select an area on the image by dragging the mouse
ImageKit1.Edit.EditEnabled = false;

//After selecting the area to be copied, execute the CutRectImage method)
//Set the selected area into the Effect.Rect property
ImageKit1.Effect.Rect = ImageKit1.Rect;

//Execute the CutRectImage method
bool ret = ImageKit1.Effect.CutRectImage()
if (!ret) return;

//Refresh ImageKit control to display the copied image
ImageKit1.Refresh();

Relevant Properties

ImageKit.Rect
ImageKit.Edit.EditEnabled
ImageKit.Effect.Rect
ImageKit.Image

Relevant Methods

ImageKit.Effect.CutRectImage


ImageKit X Programing Guide

Paste another image on the image to make one image

The example uses the Layer method to combine two images into a single composite image.

Example Code

Paste using ImageKit3 so that the upper left corner of the ImageKit2 image is in the center position above the ImageKit1 image.

If the overall size of the pasted image is larger than the image in ImageKit1, the resulting image will be enlarged to contain both images. The areas not containing any image will be set the to background color. (In this case, to blue)

* It is also possible to clip the area extending beyond the size of the image in ImageKit1. The transparency level (opacity) of the pasted image can also be set.

[Visual Basic.NET]

'(Images are already loaded in the ImageKit1 and 2 controls)
'Paste execution (write the following in the button click event etc.)
ImageKit3.Effect.Layer(ImageKit1.Image, ImageKit2.Image, 0, False, 0, 0, 0, 0, 0, 255, ImageKit1.Image.Width / 2, ImageKit1.Image.Height / 2, False, False)

'* As shown below, the image to be combined can be created even if it is not loaded in the ImageKit control.
'Dim img As Image = Image.FromFile("e:\images\001.jpg")
'ImageKit3.Effect.Layer(img, PictureBox1.Image, ・・・)
'* Also, as shown below, either image can be the image of the ImageKit control itself that executes pasting.
'ImageKit3.Effect.Layer(ImageKit3.Image, ImageKit2.Image, ・・・)

'Display the result in scale mode
ImageKit3.DisplayMode = Newtone.ImageKit.Win.DisplayMode.Scale
ImageKit3.Display()

[Visual C#.NET]

//(Images are already loaded in the ImageKit1 and 2 controls)
//Paste execution (write the following in the button click event etc.)
ImageKit3.Effect.Layer(ImageKit1.Image, ImageKit2.Image, 0, false, 0, 0, 0, 0, 0, 255, Convert.ToInt32(ImageKit1.Image.Width / 2.0), Convert.ToInt32(ImageKit1.Image.Height / 2.0), false, false);

//* As shown below, the image to be combined can be created even if it is not loaded in the ImageKit control.
//Image img = Image.FromFile(@"e:\images\001.jpg");
//ImageKit3.Effect.Layer(img, PictureBox1.Image, ・・・);
//* Also, as shown below, either image can be the image of the ImageKit control itself that executes pasting.
//ImageKit3.Effect.Layer(ImageKit3.Image, ImageKit2.Image, ・・・);

//Display the result in scale mode
ImageKit3.DisplayMode = Newtone.ImageKit.Win.DisplayMode.Scale;
ImageKit3.Display();

Relevant Methods

ImageKit.Effect.Layer


ImageKit X Programing Guide

Load Multipage Tiff Image

This example loads a multipage tiff file from a specified page.

The FileName property sets the file and the LoadPage property specifies the page of the file to be loaded. The LoadImageFromFile method loads the file and the Display method displays it.

Example Code

[Visual Basic.NET]

ImageKit1.File.FileName = "MultiTiff.tif"
'Load the fourth page. (Index starts at 0)
ImageKit1.File.LoadPage = 3
Dim ret As Boolean
ret = ImageKit1.File.LoadImageFromFile()

'Get the total number of pages
Dim page_num As Integer
If ret = True Then
ImageKit1.File.GetImageFileType()
page_num = imageKit1.File.FileMaxPage
Enf If

'Set display mode to scale
ImageKit1.DisplayMode = Newtone.ImageKit.Win.DisplayMode.Scale
ImageKit1.Display()

[Visual C#.NET]

ImageKit1.File.FileName = "MultiTiff.tif";
ImageKit1.File.LoadImageFromFile();

//Load the fourth page. (Index starts at 0)
ImageKit1.File.LoadPage = 3;
bool ret = ImageKit1.File.LoadImageFromFile()

//Get the total number of pages
int page_num;
if (ret)
{
ImageKit1.File.GetImageFileType();
page_num = imageKit1.File.FileMaxPage;
}

//Set display mode to scale
ImageKit1.DisplayMode = Newtone.ImageKit.Win.DisplayMode.Scale;
ImageKit1.Display();

Relevant Properties

ImageKit.File.FileName
ImageKit.File.LoadPage
ImageKit.File.FileMaxPage
ImageKit.DisplayMode

Relevant Methods

ImageKit.File.GetImageFileType
ImageKit.File.LoadImageFromFile
ImageKit.Display


ImageKit X Programing Guide

Append An Image To A Multipage Tiff

This example appends an image to the end of a multipage tiff file.

Specify the file name with the FileName property and save it with the AppendTiffImage method. If the file specified by the FileName property is a multi-page Tiff file, it is added to the last page. If it is a single-page Tiff file, the image is added as the second page to create a multi-page Tiff file.

Example Code

The code below appends the image displayed in PictureBox to the end of a tiff file. The image data is converted to Tiff G4 compression.
Note that any valid image can be used. To insert the image loaded into the ImageKit control, us null or Nothing.

[Visual Basic.NET]

ImageKit1.File.FileName = "Tiff.tif"
ImageKit1.File.AppendTiffImage(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, pictureBox1.Image)
'(If you want to add the image currently loaded in the ImageKit control, set the second argument to Nothing)

[Visual C#.NET]

ImageKit1.File.FileName = "Tiff.tif";
ImageKit1.File.AppendTiffImage(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, pictureBox1.Image);
//(If you want to add the image currently loaded in the ImageKit control, set the second argument to null)

Relevant Properties

ImageKit.File.FileName

Relevant Methods

ImageKit.File.AppendTiffImage


ImageKit X Programing Guide

Insert Image Into Multipage Tiff

This example inserts the image into a multipage tiff file.

The FileName property specifies the multipage tiff image into which an image is inserted. The InsertPageIntoMultipageTiff method specifies the image type, the image to be inserted, and the page number where that page is inserted.

Example Code

The image displayed in PictureBox is added in G4 format to the 3rd page of the specified multipage tiff file.

Note that any valid image can be used. To insert the image loaded into the ImageKit control, us null or Nothing.

[Visual Basic.NET]

ImageKit1.File.FileName = "MultiTiff.tif" 'Multipage Tiff file
ImageKit1.File.InsertPageIntoMultipageTiff(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, pictureBox1.Image, 3)
'(Set the second argument to Nothing if you want to insert the image loaded into the ImageKit control)

[Visual C#.NET]

ImageKit1.File.FileName = "MultiTiff.tif"; //Multipage Tiff file
ImageKit1.File.InsertPageIntoMultipageTiff(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, pictureBox1.Image, 3);
//(Set the second argument to null if you want to insert the image loaded into the ImageKit control)

Relevant Properties

ImageKit.File.FileName

Relevant Methods

ImageKit.File.InsertPageIntoMultipageTiff


ImageKit X Programing Guide

Delete A Page From A Multipage Tiff

This example deletes page 3 of the specified file

Specify the file name with the FileName property and delete it with the DeletePageFromMultipageTiff method.

Example Code

[Visual Basic.NET]

ImageKit1.File.FileName = "MultiTiff.tif" 'Multipage tiff file
ImageKit1.File.DeletePageFromMultipageTiff(3)

[Visual C#.NET]

ImageKit1.File.FileName = "MultiTiff.tif"; //Multipage tiff file
ImageKit1.File.DeletePageFromMultipageTiff(3);

Relevant Properties

ImageKit.File.FileName

Relevant Methods

ImageKit.File.DeletePageFromMultipageTiff


ImageKit X Programing Guide

Saving Scanned Images

Capture the image with a scanner and save the captured image

IMPORTANT:
On a 64 bit operating system, make sure your TWAIN scan driver supports 64 bit when using a target platform of AnyCpu or x64!

Example Code

(1) Display the image captured from the scanner's and save the image.
(2)Save images scanned from an automatic document feeder (ADF).
* In these examples, only the minimum code examples are shown. Please refer to the reference and sample for various other scan-related settings.

[Visual Basic.NET]

'(1) Save the image captured from the document plate
'Click Button1 to execute scan
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
'Suppress the scanner's UI and scan the document plate
ImageKit1.Scan.UserInterface = Newtone.ImageKit.ScanUserInterface.Suppress
ImageKit1.Scan.Mode = Newtone.ImageKit.ScanMode.DocumentPlate

Dim ret As Boolean = ImageKit1.Scan.Execute()
If Not ret Then
MessageBox.Show("The scan failed. ErrorStauts = " + ImageKit1.ErrorStatus.ToString())
End If
End Sub

'Display the image captured by the ImageKit control's AfterScan event.
Private Sub ImageKit1_AfterScan(ByVal sender As Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs) Handles ImageKit1.AfterScan
ImageKit1.Image = e.Bitmap1
ImageKit1.DisplayMode = Newtone.ImageKit.Win.DisplayMode.Scale
ImageKit1.Display()
End Sub

'Click Button2 to display the save file dialog and save
Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
If Not ImageKit1.File.SaveFileDialog() Then Return
'Save as PNG
ImageKit1.File.SaveImageToFile(Newtone.ImageKit.SaveFileType.SavePNG, Nothing)
End Sub

'(2) Save images scanned by ADF
'Click Button1 to execute scan
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
'Suppress the manufacturer's UI and scan from the ADF (single-sided)
ImageKit1.Scan.UserInterface = Newtone.ImageKit.ScanUserInterface.Suppress
ImageKit1.Scan.Mode = Newtone.ImageKit.ScanMode.ADFOneSide

Dim ret As Boolean = ImageKit1.Scan.Execute()
If Not ret Then
MessageBox.Show("The scan failed. ErrorStauts = " + ImageKit1.ErrorStatus.ToString())
End If
End Sub

'In the AfterScan event of the ImageKit control, save the captured image continuously
Private Sub ImageKit1_AfterScan(ByVal sender As Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs) Handles ImageKit1.AfterScan
ImageKit1.Image = e.Bitmap1

'File name to save (example of numbering in the order of importing at the end of the file name)
ImageKit1.File.FileName = "scanned_image" + e.ImageNumber.ToString() + ".jpg"
'Save as JPG
ImageKit1.File.SaveImageToFile(Newtone.ImageKit.SaveFileType.SaveJPG, Nothing)
End Sub

[Visual C#.NET]

// (1) Save the image imported from the document plate
// Click Button1 to execute scan
private void button1_Click(object sender, EventArgs e)
{
//Suppress the manufacturer's UI and scan from the document plate
ImageKit1.Scan.UserInterface = Newtone.ImageKit.ScanUserInterface.Suppress;
ImageKit1.Scan.Mode = Newtone.ImageKit.ScanMode.DocumentPlate;

bool ret = ImageKit1.Scan.Execute();
if (!ret)
{
MessageBox.Show("The scan failed. ErrorStatus = " + ImageKit1.ErrorStatus.ToString());
}
}

//Display the image captured by the ImageKit control's AfterScan event in the ImageKit control
private void imageKit1_AfterScan(object sender, Newtone.ImageKit.AfterScanEventArgs e)
{
ImageKit1.Image = e.Bitmap1;
ImageKit1.DisplayMode = Newtone.ImageKit.Win.DisplayMode.Scale;
ImageKit1.Display();
}

// Click Button2 to display the save file dialog and save
private void button2_Click(object sender, EventArgs e)
{
if (!ImageKit1.File.SaveFileDialog())
return;
//Save as PNG
ImageKit1.File.SaveImageToFile(Newtone.ImageKit.SaveFileType.SavePNG, null);
}

//(2)Save images scanned from an ADF
// Click Button1 to execute scan
private void button1_Click(object sender, EventArgs e)
{
//Suppress the manufacturer's UI and scan from the ADF
ImageKit1.Scan.UserInterface = Newtone.ImageKit.ScanUserInterface.Suppress;
ImageKit1.Scan.Mode = Newtone.ImageKit.ScanMode.ADFOneSide;

bool ret = ImageKit1.Scan.Execute();
if (!ret)
{
MessageBox.Show("The scan failed. ErrorStauts = " + ImageKit1.ErrorStatus.ToString());
}
}

//In the AfterScan event of the ImageKit control, continue to save the captured image
private void imageKit1_AfterScan(object sender, Newtone.ImageKit.AfterScanEventArgs e)
{
ImageKit1.Image = e.Bitmap1;

//File name to save (example of numbering at the end of the file name in the order of importing)
ImageKit1.File.FileName = "scanned_image" + e.ImageNumber.ToString() + ".jpg";
//Save as JPG
ImageKit1.File.SaveImageToFile(Newtone.ImageKit.SaveFileType.SaveJPG, null);
}

Relevant Properties

ImageKit.Scan.UserInterface
ImageKit.Scan.Mode

Relevant Methods

ImageKit.Scan.Execute

Relevant Events

ImageKit.AfterScan

For other scan-related settings, see the other scan properties below and refer to the scan sample projects
ImageKit.Scan Members


ImageKit X Programing Guide

Scan Images And Save In Multipage Tiff

Save scanned images to multipage tiff files

IMPORTANT:
On a 64 bit operating system, make sure your TWAIN scan driver supports 64 bit when using a target platform of AnyCpu or x64!

The following explains how to save scanned images into multipag tiff format. When using an automatic document feeder (ADF) to continuously scan images, each scanned image can be saved in separate tiff images or saved as separate pages in single multipage tiff image.

Example Code

ADF scanned images are continuously added to the last page of a multipage tiff file and saved in G4 format.

Note: In order to make these examples easier to understand, only a minimum amount of code is used. For more robust scan applications, please refer to the Scan Interface properties and methods and also refer to the various scan sample projects included in the directory where the ImageKit X is installed.

[Visual Basic.NET]

'Click Button1 to execute scan
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
'Suppress the manufacturer's UI and scan from the ADF (single-sided)
ImageKit1.Scan.UserInterface = Newtone.ImageKit.ScanUserInterface.Suppress
ImageKit1.Scan.Mode = Newtone.ImageKit.ScanMode.ADFOneSide

'Because we are saving in G4 compression, the scanned images must be 1 bit color
ImageKit1.Scan.PixelType = Newtone.ImageKit.ScanPixelType.BW
ImageKit1.Scan.BitDepth = 1

'Tiff filename
'If the file already exists, the pages will be appended to the end of the existing file.
ImageKit1.File.FileName = "multi_tiff.tif"

Dim ret As Boolean = ImageKit1.Scan.Execute()
If Not ret Then
MessageBox.Show("The scan failed. ErrorStatus = " + ImageKit1.ErrorStatus.ToString())
End If
End Sub

'In the AfterScan event of the ImageKit control, add the captured image to the final page and save it.
Private Sub ImageKit1_AfterScan(ByVal sender As Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs) Handles ImageKit1.AfterScan
ImageKit1.Image = e.Bitmap1

'Save as multipage tiff
ImageKit1.File.AppendTiffImage(SaveFileType.SaveTIFFGroup4, Nothing)
End Sub

[Visual C#.NET]

//Click Button1 to execute scan
private void button1_Click(object sender, EventArgs e)
{
//Suppress the manufacturer's UI and scan from the ADF (single-sided)
ImageKit1.Scan.UserInterface = Newtone.ImageKit.ScanUserInterface.Suppress;lType.BW;
ImageKit1.Scan.Mode = Newtone.ImageKit.ScanMode.ADFOneSide;

//Because we are saving in G4 compression, the scanned images must be 1 bit color
ImageKit1.Scan.PixelType = Newtone.ImageKit.ScanPixelType.BW;
ImageKit1.Scan.BitDepth = 1;

//Tiff filename
//If the file already exists, the pages will be appended to the end of the existing file.
ImageKit1.File.FileName = "multi_tiff.tif"

bool ret = ImageKit1.Scan.Execute();
if (!ret)
{
MessageBox.Show("The scan failed. ErrorStauts = " + ImageKit1.ErrorStatus.ToString());
}
}

//In the AfterScan event of the ImageKit control, add the captured image to the final page and save it.
private void imageKit1_AfterScan(object sender, Newtone.ImageKit.AfterScanEventArgs e)
{
ImageKit1.Image = e.Bitmap1;

//Save as multipage tiff
ImageKit1.File.AppendTiffImage(SaveFileType.SaveTIFFGroup4, null);
}

Relevant Properties

ImageKit.Scan.UserInterface
ImageKit.Scan.Mode
ImageKit.Scan.PixelType
ImageKit.Scan.BitDepth

Relevant Methods

ImageKit.Scan.Execute
ImageKit.File.AppendTiffImage

Relevant Events

ImageKit.AfterScan

For other scan-related settings, see the other scan properties below and refer to the scan sample projects
ImageKit.Scan Members


ImageKit X Programing Guide

Scan Images And Save In PDF

Save scanned images to PDF

IMPORTANT:
On a 64 bit operating system, make sure your TWAIN scan driver supports 64 bit when using a target platform of AnyCpu or x64!

The following explains how to save scanned images into PDF documents. When using an automatic document feeder (ADF) to continuously scan images, each scanned image can be saved in separate PDF documents or saved as separate pages in single PDF document.

Example Code

Images are scanned with an automatic document feeder (ADF) and saved as separate pages of a single PDF document

Note: In order to make these examples easier to understand, only a minimum amount of code is used. For more robust scan applications, please refer to the Scan Interface properties and methods and also refer to the various scan sample projects included in the directory where the ImageKit X is installed.

[Visual Basic.NET]

'(1)Scan images with ADF, add pages in succession to a single PDF document
'Click Button1 to execute scan
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
'Suppress the manufacturer's UI and scan from the ADF (single-sided)
ImageKit1.Scan.UserInterface = Newtone.ImageKit.ScanUserInterface.Suppress
ImageKit1.Scan.Mode = Newtone.ImageKit.ScanMode.ADFOneSide
'The PDF filename
ImageKit1.File.Pdf.SaveFileName = "scanned_image.pdf"

'Paper orientation
ImageKit1.File.Pdf.Landscape = False
'Paper size
ImageKit1.File.Pdf.DocumentSize = "a4"

ImageKit1.File.Pdf.Start()

Dim ret As Boolean = ImageKit1.Scan.Execute()
If Not ret Then
MessageBox.Show("The scan failed. ErrorStatus = " + ImageKit1.ErrorStatus.ToString())
End If

ImageKit1.File.Pdf.End()
End Sub

'In the ImageKit control's AfterScan event, add a page and save the captured image
Private Sub ImageKit1_AfterScan(ByVal sender As Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs) Handles ImageKit1.AfterScan
ImageKit1.Image = e.Bitmap1

'The scanned data is in BMP format which is large in size, so here we are converting it to JPEG RawData.
ImageKit1.File.SaveImageToRawData(Newtone.ImageKit.SaveFileType.SaveJPEG, Nothing)

ImageKit1.File.Pdf.AddPage()
'Save as Byte() to PDF using AddImage method
ImageKit1.File.Pdf.AddImage(ImageKit1.File.RawData, 0, 0, ImageKit1.File.Pdf.DocumentWidth, ImageKit1.File.Pdf.DocumentHeight)
ImageKit1.File.Pdf.EndPage()
End Sub

'(2)Scan images with ADF, save each image in separate PDF files
'Click Button1 to execute scan
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
'Suppress the manufacturer's UI and scan from the ADF (single-sided)
ImageKit1.Scan.UserInterface = Newtone.ImageKit.ScanUserInterface.Suppress
ImageKit1.Scan.Mode = Newtone.ImageKit.ScanMode.ADFOneSide

Dim ret As Boolean = ImageKit1.Scan.Execute()
If Not ret Then
MessageBox.Show("The scan failed. ErrorStatus = " + ImageKit1.ErrorStatus.ToString())
End If
End Sub

'In the ImageKit control's AfterScan event, add a page and save the captured image
Private Sub ImageKit1_AfterScan(ByVal sender As Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs) Handles ImageKit1.AfterScan
ImageKit1.Image = e.Bitmap1

'File name to save PDF (In this example, we add a number to the end of the filename so that the previous PDF will not be overwritten.)
ImageKit1.File.Pdf.SaveFileName = "scanned_image" + e.ImageNumber.ToString() + ".pdf"
'Paper orientation
ImageKit1.File.Pdf.Landscape = False
'Paper size
ImageKit1.File.Pdf.DocumentSize = "a4"

ImageKit1.File.Pdf.Start()
ImageKit1.File.Pdf.AddPage()
'Embed the captured image on the entire page
ImageKit1.File.Pdf.AddImage(ImageKit1.File.RawData, 0, 0, ImageKit1.File.Pdf.DocumentWidth, ImageKit1.File.Pdf.DocumentHeight)
ImageKit1.File.Pdf.EndPage()
ImageKit1.File.Pdf.End()
End Sub

[Visual C#.NET]

//(1)Scan images with ADF, add pages in succession to
                    a single PDF document
//Click Button1 to execute scan
private void button1_Click(object sender, EventArgs e)
{
//Suppress the manufacturer's UI and scan from the ADF (single-sided)
ImageKit1.Scan.UserInterface = Newtone.ImageKit.ScanUserInterface.Suppress;
ImageKit1.Scan.Mode = Newtone.ImageKit.ScanMode.ADFOneSide;

//PDF Filename
ImageKit1.File.Pdf.SaveFileName = "scanned_image.pdf";

// Paper orientation
ImageKit1.File.Pdf.Landscape = false;
//Paper size
ImageKit1.File.Pdf.DocumentSize = "a4";

ImageKit1.File.Pdf.Start();

bool ret = ImageKit1.Scan.Execute();
if (!ret)
{
MessageBox.Show("The scan failed. ErrorStatus = " + ImageKit1.ErrorStatus.ToString());
}
ImageKit1.File.Pdf.End();
}

//In the ImageKit
                    control's AfterScan event, add a page and save the captured image
private void imageKit1_AfterScan(object sender, Newtone.ImageKit.AfterScanEventArgs e)
{
ImageKit1.Image = e.Bitmap1;

//The
                    scanned data is in BMP format which is large in size, so here we are converting it to JPEG RawData.
ImageKit1.File.SaveImageToRawData(Newtone.ImageKit.SaveFileType.SaveJPEG, null);

ImageKit1.File.Pdf.AddPage();
//Save
                    as Byte[] to PDF using AddImage method
ImageKit1.File.Pdf.AddImage(ImageKit1.File.RawData, 0, 0, ImageKit1.File.Pdf.DocumentWidth, ImageKit1.File.Pdf.DocumentHeight);
ImageKit1.File.Pdf.EndPage();
}

//(2)Scan images with ADF,
                    save each image in separate PDF files
//Click Button1 to execute scan
private void button1_Click(object sender, EventArgs e)
{
//Suppress the manufacturer's UI and scan from the ADF (single-sided)
ImageKit1.Scan.UserInterface = Newtone.ImageKit.ScanUserInterface.Suppress;
ImageKit1.Scan.Mode = Newtone.ImageKit.ScanMode.ADFOneSide;

bool ret = ImageKit1.Scan.Execute();
if (!ret)
{
MessageBox.Show("The scan failed. ErrorStauts = " + ImageKit1.ErrorStatus.ToString());
}
}

//In the ImageKit
                    control's AfterScan event, add a page and save the captured image
private void imageKit1_AfterScan(object sender, Newtone.ImageKit.AfterScanEventArgs e)
{
ImageKit1.Image = e.Bitmap1;

//File
                    name to save PDF (In this example, we add a number to the end of the filename so
                    that the previous PDF will not be overwritten.)
ImageKit1.File.Pdf.SaveFileName = "scanned_image" + e.ImageNumber.ToString() + ".pdf"
//Paper orientation
ImageKit1.File.Pdf.Landscape = false;
//Paper size
ImageKit1.File.Pdf.DocumentSize = "a4";

ImageKit1.File.Pdf.Start();
ImageKit1.File.Pdf.AddPage();
//Embed the captured image on the entire page
ImageKit1.File.Pdf.AddImage(ImageKit1.File.RawData, 0, 0, ImageKit1.File.Pdf.DocumentWidth, ImageKit1.File.Pdf.DocumentHeight);
ImageKit1.File.Pdf.EndPage();
ImageKit1.File.Pdf.End();
}

Relevant Properties

ImageKit.Scan.UserInterface
ImageKit.Scan.Mode
ImageKit.File.PDF.SaveFileName
ImageKit.File.PDF.Landscape
ImageKit.File.PDF.DocumentSize

Relevant Methods

ImageKit.Scan.Execute
ImageKit.File.PDF.Start
ImageKit.File.PDF.End
ImageKit.File.PDF.AddPage
ImageKit.File.PDF.AddImage
ImageKit.File.PDF.EndPage

Relevant Events

ImageKit.AfterScan

For other scan-related settings, see the other scan properties below and refer to the scan sample projects
ImageKit.Scan Members


ImageKit class

Newtone.ImageKit.Win

Newtone.ImageKit.Win.ImageKit Class

The main class for the WinForm ImageKit Control.

For a list of all members of this type, see ImageKit Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Newtone.ImageKit.Win

public class ImageKit : System.Windows.Forms.Control

Explanation

This ImageKit Control allows you to add image processing functionality to your applications. Load and save images, retrieve images from TWAIN scan devices, display images, apply image effects and transformations, draw to image, print and much more.

Requirements

Namespace : Newtone.ImageKit.Win

Assembly : Newtone.ImageKit.NETX.ImageKit.dll

See Also

ImageKit Members


ImageKit Members

Newtone.ImageKit.Win.ImageKit All Members

ImageKit Overview

Constructor

ImageKit Constructor Initializes a new instance of the ImageKit class.

Public Properties

Appearance | Sets the appearance of the ImageKit Control border
AutoIkSize | Sets whether or not the ImageKit Control will be resized to fit the size of the image
BitCount | The number of bits per pixel in the image
BorderColor | Sets the color of the ImageKit Control border when the Appearance property is Newtone.ImageKit.Win.AppearanceStyle.Flat
BorderVisible | Sets whether or not the ImageKit Control border is visible
ClickPointBlue | Refers to the blue value of the pixel at the clicked location in the base image in the ImageKit Control
ClickPointGreen | Refers to the green value of the pixel at the clicked location in the base image in the ImageKit Control
ClickPointRed | Refers to the red value of the pixel at the clicked location in the base image in the ImageKit Control
DefaultMouseCursor | Sets the default mouse cursor in the ImageKit Control
DisplayMode | Sets the display mode
DrawCenterX | Sets the x-coordinate of a point on an image that will be displayed from the center of the ImageKit Control
DrawCenterY | Sets the y-coordinate of a point on an image that will be displayed from the center of the ImageKit Control
DrawOnlyBaseImage | Sets whether or not only the base image is displayed in the ImageKit Control
DrawScaleX | Sets the horizontal magnification at which and image is displayed in the ImageKit Control
DrawScaleY | Sets the vertical magnification at which and image is displayed in the ImageKit Control
ErrorStatus | Refers to the types of errors that can occur when using the ImageKit Control
GifAnimationEnabled | Sets whether or not Gif animation is enabled and will be displayed
Grad | Sets whether or not graduation is displayed in the ImageKit control and sets the units of measurement for that graduation
GradBackgroundColor | Sets the background color for the graduation
GradColor | Sets the color of the graduation lines and text
Gray | Determines whether or not the image is grayscale
Grid | Sets whether or not a grid is displayed on the ImageKit control and sets the units of measurement of that grid
GridColor | Sets the color of the grid lines
GridSpace | Sets the size of the space between the grid lines
Image | Sets or retrieves the base image
ImageKind | Refers to the image type
ImageSize | Refers to the size of the image in bytes
ImageWidthByte | Refers to the number of bytes per line in the image
InvalidHatchColor | Sets the color of the hatch pattern shown in the ImageKit Control when an image is not displayed
InvalidHatchPattern | Sets the pattern that is displayed in that portion of the ImageKit control not covered by an image
IsDisplayed | Determines whether or not an image is currently displayed in the ImageKit control.
LayerNumber | Sets the image to be processed (either the base image or one of the layer images)
MouseDragImage | Sets whether or not the image in the ImageKit Control can be scrolled by dragging it with the mouse
MouseWheelDirection | Sets whether the mouse wheel can be used to scroll
PaletteCount | Refers to the number of palette colors for the image
PanWindowImageKit | Sets the ImageKit control which will be used as a PanWindow.
PanWindowMode | Sets whether or not an ImageKit control will be used as a PanWindow.
PriorityDisplaySpeed | Sets whether or not priority display speed is used.
Rect | Sets the rectangle selected on the base image with the mouse in the ImageKit Control
RectColor1 | Sets the one of the colors of the dotted line that distinguishes the selected area in the ImageKit Control
RectColor2 | Sets the one of the colors of the dotted line that distinguishes the selected area in the ImageKit Control
RectDraw | Sets whether an area can be selected on the base image in the ImageKit Control
RectDrawFix | Sets whether or not the selected area drawn on the base image in the ImageKit Control can be resized with the mouse
RectDrawRatio | Sets the ratio of the height to the width in the selected area drawn on the base image in the ImageKit Control
RectMouseCursor | Sets the shape of the mouse cursor when the mouse is dragged within the ImageKit Control
Refine1BitImage | This property is not supported in the ImageKit.NET3. It is maintained for backward compatibility.
RefineColorImage | This property is not supported in the ImageKit.NET3. It is maintained for backward compatibility.
RefineOnScroll | Sets whether or not high quality display is used when images are scrolled or dragged
ScaledImageAlign | Sets the display position of the image when the image is displayed in Scale display mode
ScaledStartDrawX | Sets the X coordinate in the ImageKit control where the top left corner of the image is displayed
ScaledStartDrawY | Sets the Y coordinate in the ImageKit control where the top left corner of the image is displayed
ScrollBar | Sets whether or not scroll bars are displayed on the ImageKit Control
ScrollValueH | Sets the horizontal value (in pixels) of the scroll for the image displayed in the ImageKit Control
ScrollValueV | Sets the vertical value (in pixels) of the scroll for the image displayed in the ImageKit Control
ShowImage | Sets whether or not the base image is displayed in the ImageKit Control
ShowPanWindowImage | Sets whether or not the base image is displayed in the Pan window
SlideFileExtension | Sets the file extension for the images displayed when the ImageKit control is in slide display mode.
SlideImageFileNameDisplayed | Retrieves the file name of the image currently displayed in the ImageKit control during slide display mode.
SlideImageNumberDisplayed | Retrieves the number of the image currently displayed in the ImageKit control during slide display mode.
SlideMode | Sets whether or not the ImageKit control is in slide display mode.
SlidePath | Sets the path to the folder for the images displayed in the ImageKit control during slide display mode.
SlidePixelPerMSec | Sets the speed at which images slide in the ImageKit control during slide display mode.
SlideReleaseTimeMax | Sets the maximum amount of time the mouse or a finger must be released before an image will not slide during slide display mode.
SlideRepeat | Sets whether or not the images will repeat during slide display mode.
StartCoordinatesFree | Allows an image, displayed in actual size, to be displayed in a custom position within the ImageKit control
StartDrawX | Sets the point on the image that will be displayed from the top left corner of the ImageKit Control
StartDrawY | Sets the point on the image that will be displayed from the top left corner of the ImageKit Control
ToolBar | This property is not supported in the ImageKit.NET3. It maintained for backward compatibility.
ToolTip | Sets the units of measurement at which the tool tip coordinates are displayed
Transparent | Enables the transparent color in the base image
TransparentBlue | Sets the blue value for the transparent color in the base (raster) image
TransparentGreen | Sets the green value for the transparent color in the base (raster) image
TransparentRed | Sets the red value for the transparent color in the base (raster) image

Public Methods

CalculateDistance | Calculates the distance between two points on the image.
ClearClipBoard | Clears the clipboard
ClearSlideImages | Clears the images used in the slide display mode
Display | Displays the image
GetFromClipBoard | Retrieves the raster image or the vector image from the clipboard
GetImageType | Sets the image information into various ImageKit properties
GetOneBitPaletteCount | Retrieves the number of 0 pixels and 1 pixels from a 1 bit color image
GetPalette | Retrieves the palette information for a raster image
IsClipBoardData | Checks whether or not there is clipboard data
ScrollImage | Scrolls the image
SetSlideMode | Creates the images used during slide display mode and enables slide display mode
SetToClipBoard | Copies a raster image to the clipboard
SlideBack | Moves the image in the slide display back by one image
SlideForward | Moves the image in the slide display forward by one image
SlideToFirst | Moves to the first image in the slide display mode
SlideToLast | Moves to the last image in the slide display mode
Zoom | Zooms in on the area specified in the image

Public Events

AfterScan | Generated after an image is scanned with the scan device
BeforeScan | Generated just before an image is scanned with the scan device
ClickOnPanWindow | Generated when the mouse cursor is inside the pan window and the left mouse button is pressed
EditKindChanged | Generated when the the Edit.EditKind property is changed
EndDispImage | Generated just after the image has been displayed
EndDrawObject | Generated just after an annotation object has been drawn
EndEditObject | Generated just after an annotation object has been edited
EndLoad | Generated after a file has loaded
EndSave | Generated after a file has finished being saved
GetDragDropFileName | Generated after an image is dragged and dropped into the ImageKit Control
MagnifierMouseDown | Generated when the mouse button is pressed inside the Magnifier
MagnifierMouseMove | Generated when the mouse cursor is moved within the Magnifier
MagnifierMouseUp | Generated when the mouse button is released inside the Magnifier
MouseDownImage | Generated when the mouse cursor is inside the image and the mouse button has been pressed
MouseDownSelectLayerImage | Generated when the mouse cursor is over a layer image and the mouse button is been pressed
MouseMoveImage | Generated when the mouse moves over the image
MouseUpImage | Generated when the mouse cursor is inside the image and the mouse button has been released
MouseUpSelectLayerImage | Generated when the mouse cursor is over a layer image and the mouse button is been released
MouseWheelDownImage | Generated when the mouse wheel is rolled down
MouseWheelUpImage | Generated when the mouse wheel is rolled up
MultiObjectsSelected | Generated when the MultiSelect tool is used to select annotation objects
ObjectSelected | Generated the moment an annotation object is selected
Progress | Generated when an effect is being processed or a file is being loaded or saved
Scanning | Generated when an image is being scanned by the scan device
ScrollDispImage | Generated when a scroll bar is used to scroll the image
StartDispImage | Generated just before the image is displayed
StartDrawObject | Generated the moment that the drawing of an annotation object has begun
StartEditObject | Generated the moment that the editing of an annotation object has begun
StartLoad | Generated before a file has started to load
StartSave | Generated when a file is saved
TextObjectBoxClick | Generated when the textbox, drawn by the text annotation object, is clicked

Hierarchical Properties

Edit | Exposes properties and methods for editing images using annotation objects
Effect | Exposes properties and methods for processing imaging effects (effect filters, transformations, conversions, etc)
File | Exposes properties and methods for processing image files
Layer | Exposes properties related to the 100 distinct image layers possible when displaying images in the ImageKit Control
Magnifier | Exposes properties and methods related to the magnifying glass display
PanWindow | Exposes properties and methods related to the pan window display
Scan | Exposes properties and methods related to using scan devices and digital cameras

See Also

Newtone.ImageKit.Win.ImageKit


ImageKit Constructor

Newtone.ImageKit.Win.ImageKit Constructor

This initializes a new instance of the ImageKit class.
[Visual Basic] Public Sub New()
[C#] public ImageKit()

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Appearance property

Newtone.ImageKit.Win.ImageKit.Appearance Property

This property sets the appearance of the ImageKit Control border.

[Visual Basic] Public Property Appearance As AppearanceStyle
[C#] public AppearanceStyle Appearance {get; set;}

Property Value

This value is of type AppearanceStyle

Explanation

The Appearance property sets the appearance of the ImageKit Control border. This property is only enabled when the BorderVisible property is set to True. When the Apperance property is set to Flat, the color of the border is determined by the BorderColor property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


AutoIkSize property

Newtone.ImageKit.Win.ImageKit.AutoIkSize Property

This property sets whether or not the ImageKit Control will be resized to fit the size of the image.

[Visual Basic] Public Property AutoIkSize As Boolean
[C#] public bool AutoIkSize {get; set;}

Property Value

Value | Explanation
True | The ImageKit Control will be resized to fit the size of the image
False (default) | The size of the ImageKit Control, as determined at design-time or at run-time by the Height and Width properties, will be maintained

Explanation

The AutoIkSize property sets whether or not the ImageKit Control will be resized to fit the size of the image. When true, the ImageKit Control's top, left position is maintained and the ImageKit Control's height and width are changed to fit the size of the image.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


BitCount property

Newtone.ImageKit.Win.ImageKit.BitCount Property

This property refers to the number of bits per pixel in the image set in the Image property.

[Visual Basic] Public ReadOnly Property BitCount As Integer
[C#] public int BitCount {get;}

Property Value

The number of bits per pixel in an image

Value | Explanation
1 | 2 color (i.e. Black and White)
4 | 16 color
8 | 256 color
16 | 16 bit color
24 | 24 bit color
32 | 32 bit color

Explanation

The BitCount property refers to the number of bits per pixel in the image. After setting the Image property, the BitCount property value is automatically updated. This property is not valid for vector images.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


BorderColor property

Newtone.ImageKit.Win.ImageKit.BorderColor Property

This property sets the color of the ImageKit Control border.

[Visual Basic] Public Property BorderColor As Color
[C#] public Color BorderColor {get; set;}

Property Value

The default value is "Black".

Explanation

The BorderColor property sets the color for the border of the ImageKit Control. This property is only enabled when the BorderVisible property is set to True. When the Appearance property is set to AppearanceStyle.Flat, the color set into this property is used.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


BorderVisible property

Newtone.ImageKit.Win.ImageKit.BorderVisible Property

This property sets whether or not the ImageKit Control border is visible.

[Visual Basic] Public Property BorderVisible As Boolean
[C#] public bool BorderVisible {get; set;}

Property Value

Value | Explanation
True (default) | The ImageKit Control border is visible
False | The ImageKit Control border is not visible

Explanation

This property sets whether or not the ImageKit Control border is visible. When this property is set to True, the value set into the Appearance property is used.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ClickPointBlue property

Newtone.ImageKit.Win.ImageKit.ClickPointBlue Property

This property, ClickPointRed and ClickPointGreen properties refers to the RGB value of the pixel at the clicked location in the base image in the ImageKit Control.

[Visual Basic] Public ReadOnly Property ClickPointBlue As Byte
[C#] public byte ClickPointBlue {get;}

Property Value

Values range from 0 to 255

Explanation

You can easily retrieve color information from the base image displayed in the ImageKit Control. All you need to do is to click on the color in the base image that you want to retrieve and the respective RGB values for that pixel are set in the ClickPointRed, ClickPointGreen and ClickPointBlue properties. The ClickPointBlue property refers to the blue value of the pixel at the clicked location in the base image in the ImageKit Control.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ClickPointGreen property

Newtone.ImageKit.Win.ImageKit.ClickPointGreen Property

This property, ClickPointRed and ClickPointBlue refers to the RGB value of the pixel at the clicked location in the base image in the ImageKit Control.

[Visual Basic] Public ReadOnly Property ClickPointGreen As Byte
[C#] public byte ClickPointGreen {get;}

Property Value

Values range from 0 to 255

Explanation

You can easily retrieve color information from the base image displayed in the ImageKit Control. All you need to do is to click on the color in the base image that you want to retrieve and the respective RGB values for that pixel are set in the ClickPointRed, ClickPointGreen and ClickPointBlue properties. The ClickPointGreen property refers to the green value of the pixel at the clicked location in the base image in the ImageKit Control.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ClickPointRed property

Newtone.ImageKit.Win.ImageKit.ClickPointRed Property

This property, ClickPointGreen and ClickPointBlue properties refers to the blue value of the pixel at the clicked location in the base image in the ImageKit Control.

[Visual Basic] Public ReadOnly Property ClickPointRed As Byte
[C#] public byte ClickPointRed {get;}

Property Value

Values range from 0 to 255

Explanation

You can easily retrieve color information from the base image displayed in the ImageKit Control. All you need to do is to click on the color in the base image that you want to retrieve and the respective RGB values for that pixel are set in the ClickPointRed, ClickPointGreen and ClickPointBlue properties. The ClickPointRed property refers to the blue value of the pixel at the clicked location in the base image in the ImageKit Control.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DefaultMouseCursor property

Newtone.ImageKit.Win.ImageKit.DefaultMouseCursor Property

This property sets the shape of the default cursor used within the ImageKit Control
[Visual Basic] Public Property DefaultMouseCursor As Cursor
[C#] public Cursor DefaultMouseCursor {get; set;}

Property Value

Values are of the .NET Framework Cursors Class

Default value: Cursors.Default

Explanation

This property sets the shape of the default cursor used within the ImageKit Control.

Example:

ImageKit1.DefaultMouseCurser = Cursors.WaitCursor

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DisplayMode property

Newtone.ImageKit.Win.ImageKit.DisplayMode Property

This property sets the display mode of the ImageKit Control.

[Visual Basic]Public ReadOnly Property DisplayMode As DisplayMode
[C#]public DisplayMode DisplayMode {get; set;}

Property Value

This value is of type DisplayMode

The default value is DisplayMode.Scale

Explanation

The DisplayMode property sets the display mode of the ImageKit Control. Set this property before executing the Display method. When the Edit.EditEnabled property is set to True, the DisplayMode property value of Stretch is ignored and the image is displayed in Scale DisplayMode.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DrawCenterX property

Newtone.ImageKit.Win.ImageKit.DrawCenterX Property

The DrawCenterX and DrawCenterY properties get or set the coordinates of a point on an image that will be displayed from the center of the ImageKit Control.

[Visual Basic] Public Property DrawCenterX As Integer
[C#] public int DrawCenterX {get; set;}

Property Values

DrawCenterX gets or sets the horizontal position of a point on an image that will be displayed from the center of the ImageKit Control (In pixels)

Explanation

The DrawCenterX and DrawCenterY properties get or set the coordinates of a point on an image that will be displayed from the center of the ImageKit Control. The DrawCenterX property determines the horizontal distance from the left side of the image. (Shown as X in the diagram below) and the DrawCenterY property determines the vertical distance from the top of the image (Shown as Y in the diagram below). To display the image, the Display method must be called.

To use the DrawCenterX and DrawCenterY properties, the image must be displayed in Actual Size and the StartDrawX and StartDrawY properties must not be set or must be set to 0. Furthermore, once the image is displayed, if the image is scolled, the DrawCenterX and DrawCenterY properties will be cleared and the point on the image shown at the top left corner of the ImageKit Control will be set in the StartDrawX and StartDrawY properties. To use the DrawCenterX and DrawCenterY properties again, you must reset the StartDrawX and StartDrawY properties to 0.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DrawCenterY property

Newtone.ImageKit.Win.ImageKit.DrawCenterY Property

The DrawCenterXand DrawCenterY properties get or set the coordinates of a point on an image that will be displayed from the center of the ImageKit Control.

[Visual Basic] Public Property DrawCenterY As Integer
[C#] public int DrawCenterY {get; set;}

Property Values

DrawCenterY gets or sets the vertical position of a point on an image that will be displayed from the center of the ImageKit Control (In pixels)

Explanation

The DrawCenterX and DrawCenterY properties get or set the coordinates of a point on an image that will be displayed from the center of the ImageKit Control. The DrawCenterY property determines the vertical distance from the top of the image. (Shown as Y in the diagram below) and the DrawCenterX property determines the horizontal distance from the left side of the image (Shown as X in the diagram below). To display the image, the Display method must be called.

To use the DrawCenterX and DrawCenterY properties, the image must be displayed in Actual Size and the StartDrawX and StartDrawY properties must not be set or must be set to 0. Furthermore, once the image is displayed, if the image is scolled, the DrawCenterX and DrawCenterY properties will be cleared and the point on the image shown at the top left corner of the ImageKit Control will be set in the StartDrawX and StartDrawY properties. To use the DrawCenterX and DrawCenterY properties again, you must reset the StartDrawX and StartDrawY properties to 0.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DrawOnlyBaseImage property

Newtone.ImageKit.Win.ImageKit.DrawOnlyBaseImage Property

This property sets whether or not only the base image is displayed in the ImageKit Control.

[Visual Basic] Public Property DrawOnlyBaseImage As Boolean
[C#] public bool DrawOnlyBaseImage {get; set;}

Property Value

Value | Explanation
True | Only the base image is displayed
False (default) | The base images and layer images are displayed

Explanation

The DrawOnlyBaseImage property sets whether or not only the base image is displayed in the ImageKit Control. If only the base image is displayed (the layer image isn't used), it increases the drawing speed.

The base image is the image pointed to by the Image property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DrawScaleX property

Newtone.ImageKit.Win.ImageKit.DrawScaleX Property

This property and DrawScaleY property set the magnification at which and image is displayed in the ImageKit Control. (Actual size display is 1 by default).

[Visual Basic] Public Property DrawScaleX As Double
[C#] public double DrawScaleX {get; set;}

Property Value

The magnification at which an image is displayed

Explanation

The DrawScaleX and DrawScaleY properties set the magnification at which and image is displayed in the ImageKit Control. (Actual size display is 1 by default). If the DrawScaleX and DrawScaleY properties equal 2, for example, then the image will be displayed a twice actual size. Likewise, if the the DrawScaleX and DrawScaleY properties equal 0.5, then the image will be displayed at half actual size. The DrawScaleX and DrawScaleY properties are only effective when the image is displayed in actual size display mode.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DrawScaleY property

Newtone.ImageKit.Win.ImageKit.DrawScaleY Property

This property and DrawScaleX property set the magnification at which and image is displayed in the ImageKit Control. (Actual size display is 1 by default).

[Visual Basic] Public Property DrawScaleY As Double
[C#] public double DrawScaleY {get; set;}

Property Value

The magnification at which an image is displayed

Explanation

The DrawScaleXand DrawScaleY properties set the magnification at which and image is displayed in the ImageKit Control. (Actual size display is 1 by default). If the DrawScaleX and DrawScaleY properties equal 2, for example, then the image will be displayed a twice actual size. Likewise, if the the DrawScaleX and DrawScaleY properties equal 0.5, then the image will be displayed at half actual size. The DrawScaleX and DrawScaleY properties are only effective when the image is displayed in actual size display mode.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ErrorStatus property

Newtone.ImageKit.Win.ImageKit.ErrorStatus Property

This property refers to the types of errors that can occur when using the ImageKit Control.

[Visual Basic] Public ReadOnly Property ErrorStatus As Newtone.ImageKit.Error
[C#] public Newtone.ImageKit.Error ErrorStatus {get;}

Property Value

The values are of type Error

Explanation

This property refers to the types of errors that can occur when using the ImageKit Control.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GifAnimationEnabled property

Newtone.ImageKit.Win.ImageKit.GifAnimationEnabled Property

This property sets whether or not Gif animation is enabled and will be displayed.

[Visual Basic] Public Property GifAnimationEnabled As Boolean
[C#] public bool GifAnimationEnabled {get; set;}

Property Value

Value | Explanation
True | The gif animation is enabled
False (default) | The gif animation is disabled

Explanation

The GifAnimationEnabled property sets whether or not gif animation is enabled and displayed. When this property is true and a Gif image contains animation, the animation will be displayed in the ImageKit control. When this property is false, and a Gif image is loaded with animation, the File.LoadPage property value will determine which page of the Gif file will be loaded.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Grad property

Newtone.ImageKit.Win.ImageKit.Grad Property

This property sets whether or not graduation is displayed in the ImageKit control and the units of measurement for that graduation.

[Visual Basic] Public Property Grad As LengthUnit
[C#] public LengthUnit Grad {get; set;}

Property Value

Non: Graduation is not displayed

Pixel: Graduation in pixel units

mm: Graduation in milimeter units

Inch: Graduation in inch units

Default value is Non

Explanation

The Grad property sets whether or not the ImageKit control displays graduation along the left side and the top of the ImageKit control. When this property is set to Non, no graduation is displayed. When other values are set in this property, they determine the units of measurement for the graduation. However, the Grad property cannot not display in millimeter units so if mm (millimeters) is set, the graduation will be displayed in centimeter units.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GradBackgroundColor property

Newtone.ImageKit.Win.ImageKit.GradBackgroundColor Property

This property sets the background color for the graduation.

[Visual Basic] Public Property GradBackgroundColor As Color
[C#] public Color GradBackgroundColor {get; set;}

Property Value

A value of type Color

Default value is RGB(236,233,216)

Explanation

The GradBackgroundColor property sets the background color for the graduation which is displayed on the left side and top of the ImageKit control.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GradColor property

Newtone.ImageKit.Win.ImageKit.GradColor Property

This property sets the forecolor of the graduation (The color of the lines and the text).

[Visual Basic] Public Property GradColor As Color
[C#] public Color GradColor {get; set;}

A value of type Color

The default value is black

Explanation

The GradColor property sets the forecolor of the graduation displayed on the left side and at the top of the ImageKit control. The forecolor sets the color of the lines and the text in the graduation.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Gray property

Newtone.ImageKit.Win.ImageKit.Gray Property

This property determines whether or not the image set in the Image property is grayscale.

[Visual Basic] Public ReadOnly Property Gray As Boolean
[C#] public bool Gray {get;}

Property Value

Value | Explanation
True | The image is grayscale
False | The image is not grayscale

Explanation

The Gray property determines whether or not the image set in the Image property is grayscale. When the Image property is set the Gray property is automatically refreshed. The Gray property is not enabled for vector images.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Grid property

Newtone.ImageKit.Win.ImageKit.Grid Property

This property sets whether or not a grid is displayed on the ImageKit control and the units of measurement of that grid

[Visual Basic] Public Property Grid As LengthUnit
[C#] public LengthUnit Grid {get; set;}

Property Value

Non: Graduation is not displayed

Pixel: Graduation in pixel units

mm: Graduation in milimeter units

Inch: Graduation in inch units

Default value is Non

Explanation

The Grid property sets whether or not a grid is displayed on the ImageKit control and the units of measurement of that grid. If Non is set in this property then the grid is not displayed. When other values are set in this property, they determine the units of measurement for the grid. The size of the space between the grid lines is determined by the GridSpace property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GridColor property

Newtone.ImageKit.Win.ImageKit.GridColor Property

This property sets the color of the grid lines.

[Visual Basic] Public Property GridColor As Color
[C#] public Color GridColor {get; set;}

A value of type Color

Default value is Color.Silver

Explanation

The GridColor property sets the color of the grid lines.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GridSpace property

Newtone.ImageKit.Win.ImageKit.GridSpace Property

This property sets the size of the space between the grid lines.

[Visual Basic] Public Property GridSpace As Double
[C#] public double GridSpace {get; set;}

The size of the space as double

the default value is 10.0

Explanation

The GridSpace property sets the size of the space between the grid lines. The units of measurement for the space is the same as set by the Grid property.

Note that the ImageKit control may automatically adjust the display of grid lines depending on the values set in this property and on the percent of scaling needed to display a particular image. For example, an image that has a height of 2000 pixels and a width of 1000 pixels is displayed in scale display mode with GridSpace=1 and Grid units in Pixels. This would result in 1000 grid lines being displayed vertically and 2000 displayed horizontally, thereby obscuring the image. To prevent this, the ImageKit control may automatically display fewer grid lines than are actually called for.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Image property

Newtone.ImageKit.Win.ImageKit.Image Property

This property sets or retrieves the base image.
[Visual Basic] Public Property Image As Image
[C#] public Image Image {get; set;}

Property Value

Base image object

Explanation

The Image property sets or retrieves the base image. Although it is possible to set the image directly into the Image property, if the LayerNumber property is set to -1 and the file is loaded then the image is automatically set in the Image property. To disable the image data, set the Image property to null (Nothing in Visual Basic).

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ImageKind property

Newtone.ImageKit.Win.ImageKit.ImageKind Property

This property refers to the image type.

[Visual Basic] Public ReadOnly Property ImageKind As KindOfImage
[C#] public KindOfImage ImageKind {get;}

Property Value

This value is of type KindOfImage

Explanation

The ImageKind property refers to the image type. When the Image property is set the values of the ImageKind property are automatically set.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ImageSize property

Newtone.ImageKit.Win.ImageKit.ImageSize Property

This property refers to the size of the image in bytes.

[Visual Basic] Public ReadOnly Property ImageSize As Integer
[C#] public int ImageSize {get;}

Property Value

The size of the image in bytes

Explanation

The ImageSize property refers to the size of the image in bytes. When the Image property is set the values of this property are automatically set.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ImageWidthByte property

Newtone.ImageKit.Win.ImageKit.ImageWidthByte Property

This property refers to the number of bytes per line in the image.

[Visual Basic] Public ReadOnly Property ImageWidthByte As Integer
[C#] public int ImageWidthByte {get;}

Property Value

The number of bytes per line in the image

Explanation

The ImageWidthByte property refers to the number of bytes per line in the image. When the Image property is set the values of the ImageWidthByte property are automatically set.

This property is not valid for vector data.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


InvalidHatchColor property

Newtone.ImageKit.Win.ImageKit.InvalidHatchColor Property

This property sets the color of the hatch pattern shown in the ImageKit Control when an image is not displayed.

[Visual Basic] Public Property InvalidHatchColor As Color
[C#] public Color InvalidHatchColor {get; set;}

Property Value

InvalidHatchColor - the color of the hatch pattern shown in the ImageKit Control when an image is not displayed

Explanation

The InvalildHatchColor property sets the color of the hatch pattern shown in the ImageKit Control when an image is not displayed. Color can be set using RGB (Red, Green, Blue) or the equivalent value. This property is enabled when the value of the InvalidHatchPattern property is more than 1.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


InvalidHatchPattern property

Newtone.ImageKit.Win.ImageKit.InvalidHatchPattern Property

This property sets the pattern that is displayed in that portion of the ImageKit control not covered by an image. You can see this pattern most clearly before you load an image.

[Visual Basic] Public Property InvalidHatchPattern As HatchPattern
[C#] public HatchPattern InvalidHatchPattern {get; set;}

Property Value

This value is of type HatchPattern

Explanation

This is the pattern that is displayed in that portion of the ImageKit control not covered by an image. You can see this pattern most clearly before you load an image. The default value is ShowHatch. When the InvallidHatchPattern property is set to ShowHatch, the hatch pattern is displayed in the color set in the InvalidHatchColor property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


IsDisplayed Property

Newtone.ImageKit.Win.ImageKit.IsDisplayed Property

This property determines whether or not an image is being displayed in the ImageKit control.

[Visual Basic]Public ReadOnly Proerty IsDisplayed As Boolean
[C#] public bool IsDisplayed {get;}

Property Value

True: An image is being displayed in the ImageKit control
False: An image is not being displayed in the ImageKit control

Explanation

The IsDisplayed property determines whether or not an image is being displayed in the ImageKit control. Even if an image is loaded and the Image property contains an image, if it is not being displayed, this value will be False.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


LayerNumber property

Newtone.ImageKit.Win.ImageKit.LayerNumber Property

The ImageKit Control allows you to load, save, and process several images simultaneously. This property gets and sets the image number for the image that has been or will be processed.

[Visual Basic] Public Property LayerNumber As Integer
[C#] public int LayerNumber {get; set;}

Property Value

The number of the image (default is -1). A value of -1 refers to the base image. Values from 0 to 99 refer to the various image layers

Explanation

The ImageKit Control allows you to load, save, and process several images simultaneously. The LayerNumber property property refers to the image number for the image that will be processed (or has been processed) when loading, saving, or applying an effect to an image. If you set the LayerNumber property to -1 and load the image, then the loaded image's image handle will be set into the Image property. If you set the LayerNumber property to a value other than -1 (i.e. from 0 to 99), then the image handle of the loaded image will be set into the Layer(LayerNumber).Image property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseDragImage property

Newtone.ImageKit.Win.ImageKit.MouseDragImage Property

This property sets whether or not the image in the ImageKit Control can be scrolled by dragging it with the mouse.

[Visual Basic] Public Property MouseDragImage As Boolean
[C#] public bool MouseDragImage {get; set;}

Property Value

Value | Explanation
True | The image can be scrolled with the mouse
False | The image cannot be scrolled with the mouse

Explanation

The MouseDragImage property sets whether or not the image in the ImageKit Control can be scrolled by dragging it with the mouse. When this property is set to True, the image can be scrolled with the mouse.

When the MouseDragImage property is True, annotation functions will be disabled even if the ImageKit.Edit.EditEnabled property is True. Therefore, if you are using the Annotation functions and you want to scroll the image with a mouse drag, set this property to True, then after the image has been dragged, reset this property to False and the Annotation functions will be enabled again.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseWheelDirection property

Newtone.ImageKit.Win.ImageKit.MouseWheelDirection Property

This property sets whether the mouse wheel can be used to scroll.

[Visual Basic] Public Property MouseWheelDirection As WheelDirection
[C#] public WheelDirection MouseWheelDirection {get; set;}

Property Valule

Value | Explanation
Disable | Disables scrolling with the mouse wheel
Vertical | Mouse scrolls in a vertical direction
Horizontal | Mouse scrolls in a horizontal direction

Explanation

The MouseWheelDirection property sets whether the mouse wheel can be used to scroll. To enable the mouse wheel to scroll, set this property to a value other than Disable.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


PaletteCount property

Newtone.ImageKit.Win.ImageKit.PaletteCount Property

This property refers to the number of palette colors for the image set to the Image property.

[Visual Basic] Public ReadOnly Property PaletteCount As Integer
[C#] public int PaletteCount {get;}

Property Value

The number of palette colors for the image

This property value is valid when the BitCount property is less than 8, otherwise 0 is returned.

Explanation

The PaletteCount property refers to the number of palette colors for the image. After setting the Image property, the value of the PaletteCount property is automatically set. This property is not valid for vector data.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


PanWindowImageKit property

Newtone.ImageKit.Win.ImageKit.PanWindowImageKit Property

This property sets which ImageKit control will be used as a pan window.

[Visual Basic]Public Property PanWindowImageKit As ImageKit
[C#]public ImageKit PanWindowImageKit {get; set;}

Property Value

ImageKit Control
Default value is null (Nothing).

Explanation

The PanWindowImageKit property sets which ImageKit control will be used as a pan window.

By setting the PanWindowMode property to True, one ImageKit control can be converted to a pan window and used by another ImageKit control. The PanWindowImageKit property associates one ImageKit control with the ImageKit control that has been converted to a pan window. In this case, when an image is loaded into the ImageKit control, the same image will automaticall appear in the pan window and can be scrolled, etc.

Example code that sets ImageKit2 to act as a pan window for ImageKit1

In VisualBasic.NET

ImageKit1.PanWindowImageKit = ImageKit2 'associates ImageKit1 with the ImageKit2
ImageKit2.PanWindowMode = True 'Sets ImageKit2 to act as a pan window

In C#.NET

ImageKit1.PanWindowImageKit = ImageKit2; //associates ImageKit1 with the ImageKit2
ImageKit2.PanWindowMode = true; //Sets ImageKit2 to act as a pan window

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


PanWindowImageKit property

Newtone.ImageKit.Win.ImageKit.PanWindowMode Property

This property converts an ImageKit control to a pan window.

[Visual Basic]Public Property PanWindowMode As Boolean
[C#]public bool PanWindowMode {get; set;}

Property Value

Value | Explanation
True | Converts the ImageKit control to a pan window
False | The ImageKit control is an ordinary ImageKit control (not a pan window)

Explanation

The PanWindowMode property converts an ImageKit control into a pan window. By setting this property to true, the ImageKit control will act as a pan window control for another ImageKit control and its properties can be set using the Pan Window interface properties. The PanWindowImageKit property associates an ImageKit control (parent control) with the pan window. Images loaded into the parent ImageKit control will automatically be displayed in the associated pan window control.

Note: The ImageKit.NET3 has a PanWindow interface which displays a Pan Window control as a seperate control in a separate window. To use the Pan Window interface and display the Pan Window control, the PanWindowMode property must be set to False. When the PanWindowMode property is true, an ImageKit control is used as a pan window and the Pan Window control cannot be used.

When the PanWindowMode property is true and an ImageKit control is converted into a pan window, its DisplayMode property will be Display.Scale. Images cannot be directly loaded into this converted ImageKit control. Only images loaded into the parent ImageKit control associated with this pan window will be displayed. Furthermore, Effect, Scan, and Annotation function will be disabled. In other words, ImageKit control converted into a pan window can only be used as a pan window for its associated parent ImageKit control.

Example code that sets ImageKit2 to act as a pan window for ImageKit1

In VisualBasic.NET

ImageKit1.PanWindowImageKit = ImageKit2
ImageKit1.ShowPanWindowImage = True 'Sets the image to be displayed in the pan window (in this case ImageKit2)
ImageKit2.PanWindowMode = True 'Converts ImageKit2 into a pan window
ImageKit2.PanWindow.Color = Color.Yellow 'Sets the background color for the pan window
ImageKit2.PanWindow.RectColor = Color.Red 'Sets the border color for the scroll rectangle in the pan window
ImageKit2.PanWindow.EnableClick = True 'When the mouse is clicked outside the rectangle in the pan window, the image displayed in the ImageKit control is scrolled to that position.
ImageKit2.PanWindow.RectMouseCursor = Cursor.Hand 'Sets the shape of the cursor in the pan window
ImageKit2.PanWindow.RectReverse = False 'reverses the color within the pan window rectangle

In C#.NET

ImageKit1.PanWindowImageKit = ImageKit2;
ImageKit1.ShowPanWindowImage = true; //Sets the image to be displayed in the pan window (in this case ImageKit2)
ImageKit2.PanWindowMode = true; //Converts ImageKit2 into a pan window
ImageKit2.PanWindow.Color = Color.Yellow; //Sets the background color for the pan window
ImageKit2.PanWindow.RectColor = Color.Red; //Sets the border color for the scroll rectangle in the pan window
ImageKit2.PanWindow.EnableClick = true; //When the mouse is clicked outside the rectangle in the pan window, the image displayed in the ImageKit control is scrolled to that position.
ImageKit2.PanWindow.RectMouseCursor = Cursor.Hand; //Sets the shape of the cursor in the pan window
ImageKit2.PanWindow.RectReverse = false; //reverses the color within the pan window rectangle

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


PriorityDisplaySpeed property

Newtone.ImageKit.Win.ImageKit.PriorityDisplaySpeed Property

This property sets whether or not images are displayed using priority display speed.

[Visual Basic] Public Property PriorityDisplaySpeed As Boolean
[C#] public bool PriorityDisplaySpeed {get; set;}

Property Value

Value | Explanation
True | Images are displayed using priority display speed
False (default) | Images are displayed as normal

Explanation

The PriorityDisplaySpeed property sets whether or not images are displayed using priority display speed.

When this property is true and an image is loaded or passed into the Image property, priority is given to displaying the image quickly. This can greatly increase the speed when displaying very large images or displaying images in multiple ImageKit controls at the same time. However, other functions like scrolling, zooming, dragging, or drawing annotations may be slowed down as a result.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Rect property

Newtone.ImageKit.Win.ImageKit.Rect Property

This property sets the rectangle selected on the base image in the ImageKit Control.

[Visual Basic]
Public Property Rect As Rectangle
[C#]
public Rectangle RectBottom {get; set;}

Property Value

The value is of type System.Drawing.Rectangle and represents a rectangle selected on the image displayed in the ImageKit Control

Explanation

The Rect property sets the rectangle selected on the image in the ImageKit Control. This property is enabled by setting the RectDraw property to True. In that case, the mouse can be used to select an area on the base image. The coordinates of this selected area are set into the Rect property.

It is also possible to set the Rect property directly. For example

ImageKit1.Rect = new Rectangle(100,100,200,200)

will set an selected area on the image whose top left corner is at (100,100) and that has a height and width of 200 respectively. For more information, please refer to the System.Drawing.Rectangle.

The color of the border for the selected area can be set using the RectColor1 and the RectColor2 properties.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


RectColor1 property

Newtone.ImageKit.Win.ImageKit.RectColor1 Property

This property and the RectColor2 property set the colors of the dotted line that distinguishes the selected area in the ImageKit Control.

[Visual Basic] Public Property RectColor1 As Color
[C#] public Color RectColor1 {get; set;}

Property Value

RectColor1 - one of the colors in the dotted line that distinguishes the selected area in the ImageKit Control.
RectColor2 - the other color in the dotted line that distinguishes the selected area in the ImageKit Control.

Explanation

The RectColor1 and the RectColor2 property set the colors of the dotted line that distinguishes the selected area in the ImageKit Control.

The RectColor1 and RectColor2 properties are enabled when the RectDraw property is true.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


RectColor2 property

Newtone.ImageKit.Win.ImageKit.RectColor2 Property

This property and the RectColor1 property set the colors of the dotted line that distinguishes the selected area in the ImageKit Control.

[Visual Basic] Public Property RectColor2 As Color
[C#] public Color RectColor2 {get; set;}

Property Value

RectColor1 - one of the colors in the dotted line that distinguishes the selected area in the ImageKit Control.
RectColor2 - the other color in the dotted line that distinguishes the selected area in the ImageKit Control.

Explanation

The RectColor1 and the RectColor2 property set the colors of the dotted line that distinguishes the selected area in the ImageKit Control.

The RectColor1 and the RectColor2 properties are enabled when the RectDraw property is true.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


RectDraw property

Newtone.ImageKit.Win.ImageKit.RectDraw Property

This property sets whether an area on the base image displayed in the ImageKit Control can be selected with the mouse.

[Visual Basic]
Public Property RectDraw As Boolean
[C#]
public bool RectDraw {get; set;}

Property Value

Value | Explanation
True (default) | An area on the image can be selected with the mouse
False | An area on the image cannot be selected with the mouse

Explanation

The RectDraw property sets whether an area on the base image displayed in the ImageKit Control can be selected with the mouse. When the RectDraw property is True, an area on the base image can be selected by dragging the mouse over the image. The coordinates of this selected area will be set into the Rect property.

The color of the selected area can be set using the RectColor1 and the RectColor2 properties.

When the Edit.EditEnabled property is True, the RectDraw property is disabled.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


RectDrawFix property

Newtone.ImageKit.Win.ImageKit.RectDrawFix Property

This property sets whether or not the selected area drawn on the base image in the ImageKit Control can be resized with the mouse.

[Visual Basic] Public Property RectDrawFix As Boolean
[C#] public bool RectDrawFix {get; set;}

Property Value

Value | Explanation
True | The selected area cannot be resized with the mouse
False | The selected area can be resized with the mouse

Explanation

The RectDrawFix property sets whether or not the selected area drawn on the base image in the ImageKit Control can be resized with the mouse. If the RectDrawFix property is True, the RectDraw property must also be True. This will fix the size of the selected area drawn on the base image in the ImageKit Control. It cannot be resized using the mouse. (It can however be moved with the mouse.) If this property is not set, the rectangular area can be resized with the mouse (Default value is False).

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


RectDrawRatio property

Newtone.ImageKit.Win.ImageKit.RectDrawRatio Property

When using the mouse to select an area on the image, this property sets the ratio of the height to the width in that selected area.

[Visual Basic] Public Property RectDrawRatio As Double
[C#] public double RectDrawRatio {get; set;}

Property Value

The ratio of the height to the width in the selected area (default value is 0 meaning ratio is not set)

Explanation

When using the mouse to select an area on the image, RectDrawRatio property sets the ratio of the height to the width in that selected area. For this property to be enabled, the RectDraw property must be True. When the RectDrawRatio property is 0 (default value) there is no set ratio between the height and width of the selected area. Since the ratio is defined as heigth/width, values of more than 1 mean that the height of the selected area will be greater than the width. Likewise values less than 1 mean the width will be greater than the length.

Example

Below is a code snippet that illustrates how to set the ratio of the height and width in the selected area to be the same as in the currently displayed image.

[Visual Basic]
Dim Ret As Boolean

ImageKit1.LayerNumber = -1
Ret = ImageKit1.GetImageType()
If Ret = False Then Exit Sub
ImageKit1.RectDrawRatio = ImageKit1.Height / ImageKit1.Width

[C#]
bool Ret;

ImageKit1.LayerNumber = -1;
Ret = ImageKit1.GetImageType();
if (Ret == False) return Ret;
ImageKit1.RectDrawRatio = ImageKit1.Height / ImageKit1.Width;

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


RectMouseCursor property

Newtone.ImageKit.Win.ImageKit.RectMouseCursor Property

This property sets the shape of the mouse cursor when the mouse is dragged within the ImageKit Control.

[Visual Basic] Public Property RectMouseCursor As Cursor
[C#] public Cursor RectMouseCursor {get; set;}

Property Value

The members of the Cursors class for .NET Framework

The default value is Cursors.SizeAll.

Explanation

The RectMouseCursor property sets the shape of the mouse cursor when the mouse is dragged within the ImageKit Control.

The following code illustrates how to set the shape of the mouse cursor to Hourglass:

ImageKit1.RectCursor = Cursors.WaitCursor

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


RefineOnScroll

Newtone.ImageKit.Win.ImageKit.RefineOnScroll Property

This property sets whether or not an image will be displayed in high quality when it is being scrolled or dragged.

[Visual Basic]Public Property RefineOnScroll As Boolean
[C#]public bool RefineOnScroll {get; set;}

Property Value

Value | Explanation
True | images will be displayed in high quality when scrolled or dragged
False (default) | images will be displayed as normal

Explanation

The RefineOnScroll property sets whether an image will be displayed in high quality when it is scrolled or dragged. This property is enabled only if the image is displayed by reducing its size to less than the actual size.

When the image is being scrolled or moved with the mouse, high quality will be automatically disabled so the image can be scrolled or moved quickly. Once the scrolling or movement has stopped, high quality will be automatically enabled. Depending on the PC's environment and the size of the image, there are cases where high quality display cannot be used. In that case, please set this property to False.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScaledImageAlign property

Newtone.ImageKit.Win.ImageKit.ScaledImageAlign Property

When the image is displayed in Scale display mode, this property sets the display position of the image.

[Visual Basic] Public Property ScaledImageAlign As Align
[C#] public Align ScaledImageAlign {get; set;}

Property Value

A value of type Align.

The default value is Align.Center

Explanation

When the image is displayed in Scale display mode, the ScaledImageAlign property sets the display position of the image.

When this property is set to Align.None, the ScaledStartDrawX and ScaledStartDrawY properties set the (x,y) coordinates on the ImageKit control where the top left corner of the image will be displayed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScaledStartDrawX property

Newtone.ImageKit.Win.ImageKit.ScaledStartDrawX Property

This property sets the X coordinate in the ImageKit control where the top left corner of the image is displayed.

[Visual Basic] Public Property ScaledStartDrawX As Integer
[C#] public int ScaledStartDrawX {get; set;}

Property Value

The X coordinate in the ImageKit control where the top left corner of the image is displayed

Explanation

When the display mode is set to Scale and the ScaledImageAlign property is set to Align .None, the ScaledStartDrawX property sets or retrieves the x coordinate location in the ImageKit control where the top left corner of the image displayed. The ScaledStartDrawX property value is represented as X in the image below:

Note: The StartDrawX property refers to the horizontal (x) coordinate on the image whereas the ScaledStartDrawX property refers to the horizontal (x) coordinate on the ImageKit control.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScaledStartDrawY property

Newtone.ImageKit.Win.ImageKit.ScaledStartDrawY Property

When Scale display mode is being used, this property sets the Y coordinate in the ImageKit control where the top left corner of the image is displayed.

[Visual Basic] Public Property ScaledStartDrawY As Integer
[C#] public int ScaledStartDrawY {get; set;}

Property Value

The Y coordinate in the ImageKit control where the top left corner of the image is displayed

Explanation

When the display mode is set to Scale and the ScaledImageAlign property is set to Align .None, the ScaledStartDrawY property sets or retrieves the y coordinate location in the ImageKit control where the top left corner of the image displayed. The ScaledStartDrawY property value is represented as Y in the image below:

Note: The StartDrawY property refers to the vertical (y) coordinate on the image whereas the ScaledStartDrawY property refers to the vertical (y) coordinate on the ImageKit control.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollBar property

Newtone.ImageKit.Win.ImageKit.ScrollBar Property

This property sets whether or not scroll bars are displayed on the ImageKit Control.

[Visual Basic] Public Property ScrollBar As Boolean
[C#] public bool ScrollBar {get; set;}

Property Value

Value | Explanation
True | Displays scroll bars on the Imagekit Control
False (default) | Does not display scroll bars on the Imagekit Control

Explanation

The ScrollBar property sets whether or not scroll bars are displayed on the ImageKit Control. When the ScrollBar property is True, if an image does not fit within the ImageKit Control, scroll bars will appear and can be used to scroll the image.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollValueH property

Newtone.ImageKit.Win.ImageKit.ScrollValueH Property

This property sets the horizontal value (in pixels) of the scroll for the image displayed in the ImageKit Control.

[Visual Basic] Public Property ScrollValueH As Integer
[C#] public int ScrollValueH {get; set;}

Property Value

The size of the scroll in pixels (must be 1 or more)

Explanation

The ScrollValueH property sets the horizontal value (in pixels) of the scroll for the image displayed in the ImageKit Control. To scroll vertically, set the ScrollValueV property. To scroll diagonally, set both of these properties. After setting these properties, execute the ScrollImage method.

These functions are particularly useful to link scrolling to a button click or other event. When the ScrollBar property is set to True to use scroll bars, the value of this property will be set into the SmallChange property for the scroll bars.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollValueV property

Newtone.ImageKit.Win.ImageKit.ScrollValueV Property

This property sets the vertical value (in pixels) of the scroll for the image displayed in the ImageKit Control.

[Visual Basic] Public Property ScrollValueV As Integer
[C#] public int ScrollValueV {get; set;}

Property Value

The size of the scroll in pixels (must be 1 or more)

Explanation

The ScrollValueV property sets the vertical value (in pixels) of the scroll for the image displayed in the ImageKit Control. To scroll horizontally, set the ScrollValueH property. To scroll diagonally, set both of these properties. After setting these properties, execute the ScrollImage method.

These functions are particularly useful to link scrolling to a button click or other event. When the ScrollBar property is set to True to use scroll bars, the value of this property will be set into the SmallChange property for the scroll bars.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ShowImage property

Newtone.ImageKit.Win.ImageKit.ShowImage Property

This property sets whether or not the base image is displayed in the ImageKit Control.

[Visual Basic]Public Property ShowImage As Boolean
[C#]public bool ShowImage {get; set;}

Property Value

The ShowImage property sets whether or not the base image is displayed in the ImageKit Control.

Value | Explanation
True | Displays the base image
False | Does not display the base image

Explanation

The ShowImage property sets whether or not the base image is displayed in the ImageKit Control. The base image is the image pointed to by the Image property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ShowPanWindowImage property

Newtone.ImageKit.Win.ImageKit.ShowPanWindowImage Property

This property sets whether or not the base image is displayed in the pan window.

[Visual Basic] Public Property ShowPanWindowImage As Boolean
[C#] public bool ShowPanWindowImage {get; set;}

Property Value

The ShowPanWindowImage property sets whether or not the base image is displayed in the pan window.

Value | Explanation
True | Displays the base image
False | Does not display the base image

Explanation

The ShowPanWindowImage property sets whether or not the base image is displayed in the pan window. The base image is the image pointed to by the Image property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


SlideFileExtension property

Newtone.ImageKit.Win.ImageKit.SlideFileExtension Property

This property sets the file extension for the image files that can be displayed in the ImageKit control's slide display mode.

[Visual Basic] Public Property SlideFileExtension As String
[C#] public string SlideFileExtension {get; set;}

Property Value

The SlideFileExtension is the file type (i.e. jpg, bmp)

Explanation

The SlideFileExtension property sets the file extension for the image files that can be displayed in the ImageKit control's slide display mode. The SlidePath property determines the folder containing the image files for the ImageKit control's slide display mode. The SlideFileExtension property sets the type of image (file extension) that will be displayed.

The ImageKit control's slide display mode can display any image format that can be loaded into the ImageKit control. JPEG2000 and FPX files require the ImageKit "plug in" to be displayed. When setting multiple file extensions in the SlideFileExtension propert, use a semicolon as a delimiter. For example: "bmp;jpg;tif;png".

For details, please refer to the SlideMode property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


SlideImageFileNameDisplayed property

Newtone.ImageKit.Win.ImageKit.SlideImageFileNameDisplayed Property

This property retrieves the filename of the image currently displayed in the ImageKit control during slide display mode.

[Visual Basic] Public ReadOnly Property SlideImageFileNameDisplayed As String
[C#] public string SlideImageFileNameDisplayed {get;}

Property Value

A string representing the filename of the currently displayed image

Explanation

The SlideImageFileNameDisplayed property retrieves the filename of the image currently displayed in the ImageKit control during slide display mode. If a multipage image is being displayed, the value will be:

filename + "-" + pagenumber

where pagenumber is a 3 digits long.

For example, if the third page of a multipage tif file called "abc.tif" is being displayed, the value retrieved will be "abc.tif-003"

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


SlideImageNumberDisplayed property

Newtone.ImageKit.Win.ImageKit.SlideImageNumberDisplayed Property

This property retrieves the image number of the currently displayed image when in slide display mode.

[Visual Basic] Public ReadOnly Property SlideImageNumberDisplayed As Integer
[C#] public int SlideImageNumberDisplayed {get;}

Property Value

The currently displayed image number
Default value is 0

Explanation

The SlideImageNumberDisplayed property retrieves the image number of the currently displayed image when the ImageKit control is in slide display mode.

When multipage images are displayed, each page is counted as if it is a separate image and assigned an image number.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


SlideMode property

Newtone.ImageKit.Win.ImageKit.SlideMode Property

This property sets whether or not the ImageKit control's slide display mode is enabled.

[Visual Basic] Public Property SlideMode As Boolean
[C#] public bool SlideMode {get; set;}

Property Value

True: Enables the ImageKit control's slide display mode
False: Uses regular display mode (disables the ImageKit control's slide display mode)
Default Value: False

Explanation

The SlideMode property sets whether or not the ImageKit control's slide display mode is enabled. When this property is True, the ImageKit control's slide display mode is enabled. The SlidePath property sets the folder containing the image files that will be displayed and the SlideFileExtension property sets the type of image files that will be displayed. When the slide mode is enabled, image files displayed in the ImageKit control can be changed by a touch-swipe or by a mouse drag. Images can also be changed executing the SlideForward, SlideBack, SlideToFirst, and SlideToLast methods.

When the SlideMode property is False and an image is being displayed in the ImageKit control and then the SlideMode property is set to True, the folder containing the image being displayed will be set in the SlidePath property.

Note: When the SlideMode property is True, the DisplayMode property is disabled and all images displayed in the ImageKit control during the slide display mode will be displayed in scale display (DisplayMode.Scale). In slide display mode, the area outside of the image and between images is set with the BackColor property. During slide display mode, the Edit.EditEnabled property is False and annotation functions are disabled. If during ordinary display mode, annotation objects are being displayed when the SlideMode property is set to True, the annotation objects will be disabled and not displayed.

Example

Set the image folder using the Folder Dialog and enable the slide display mode in the ImageKit1 control.

[Visual Basic.NET]
ImageKit1.SlideMode = True 'Turn Slide Mode On
ImageKit1.SlideFileExtension = "bmp;jpg;png;tif;wmf;gif" 'Set the image type for the slide display mode

Dim fd As FolderBrowserDialog = New FolderBrowserDialog()
fd.SelectedPath = Application.StartupPath

If (fd.ShowDialog() = DialogResult.OK) Then
ImageKit1.SlidePath = fd.SelectedPath 'Set the image folder using the Folder Dialog

'This allows the images to be repeated moving from the last image to
    the first image (or back again)
ImageKit1.SlideRepeat = True
ImageKit1.BackColor = Color.LightSkyBlue 'Set the backcolor

ImageKit1.SetSlideMode() 'Prepare the slide images and set the slide mode.
End If

fd.Dispose()

[Visual C#.NET]
imageKit1.SlideMode = true; //Turn Slide Mode On
imageKit1.SlideFileExtension = "bmp;jpg;png;tif;wmf;gif"; //Set the image type for the slide display mode

FolderBrowserDialog fd = new FolderBrowserDialog();
fd.SelectedPath = Application.StartupPath;

if (fd.ShowDialog() == DialogResult.OK)
{
imageKit1.SlidePath = fd.SelectedPath; //Set the image folder using the Folder Dialog

//This allows the images to be repeated moving from the last
    image to the first image (or back again)
imageKit1.SlideRepeat = true;
imageKit1.BackColor = Color.LightSkyBlue; //Set the backcolor
imageKit1.SetSlideMode(); //Prepare the slide images and set the slide mode.
}

fd.Dispose();

See Also

ImageKit Members Newtone.ImageKit.Win.ImageKit


SlidePath property

Newtone.ImageKit.Win.ImageKit.SlidePath Property

This property sets the folder containing the image files for the ImageKit control's slide display mode.

[Visual Basic] Public Property SlidePath As String
[C#] public string SlidePath {get; set;}

Property Value

A string designating the path the to folder for the image files
Default value is ""

Explanation

The SlidePath property sets the folder containing the image files for the ImageKit control's slide display mode. The slide display mode will not display images contained in subfolders within the folder set in this property.

For example code, please refer to the SlideMode property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


SlidePixelPerMSec property

Newtone.ImageKit.Win.ImageKit.SlidePixelPerMSec Property

This property sets speed at which images slide during slide display mode.

[Visual Basic] Public Property SlidePixelPerMSec As Integer
[C#] public int SlidePixelPerMSec {get; set;}

Property Value

The SlidePixelPerMSec is in units of pixels per milisecond.
Default value is 50 pixels per milisecond

Explanation

The SlidePixelPerMSec property sets speed at which images slide during slide display mode. The value of this property is in pixels per milisecond. The higher the value the faster the images will slide. The minimum value is 1. Values less than 1 will be assigned as 1.

The values of this property are by no means exact and should be considered as approximations only. Increasing the value from 50 to 100 would increase the sliding speed, though it may or may not be approximately twice as fast.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


SlideReleaseTimeMax property

Newtone.ImageKit.Win.ImageKit.SlideReleaseTimeMax Property

This property sets the maximum amount of time the mouse or a finger must be released before an image will not slide during slide display mode.

[Visual Basic] Public Property SlideReleaseTimeMax As Integer
[C#] public int SlideReleaseTimeMax {get; set;}

Property Value

A value of time in miliseconds
Default value is 20

Explanation

The SlideReleaseTimeMax property sets the maximum amount of time the mouse or a finger must be released before an image will not slide during slide display mode.

During slide display mode, images can be switched using a swipe of the finger or a mouse drag. This property sets the limit of time that a swipe or mouse drag must be completed to switch images. Evenif the finger or mouse drag is released within this amount of time, the swipe or mouse drag must move the image more than 2/3 the width of the ImageKit control.

The smallest value possible for this property is 1. Values less than one will be assigned a value of 1.

The values of this property are by no means exact and should be considered as approximations only.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


SlideRepeat property

Newtone.ImageKit.Win.ImageKit.SlideRepeat Property

This property sets whether or not, when in slide display mode, the images will repeat after the last image is displayed.

[Visual Basic] Public Property SlideRepeat As Boolean
[C#] public bool SlideRepeat {get; set;}

Property Value

True: Images will repeat
False: Images will not repeat
Default value: True

Explanation

The SlideRepeat property sets whether or not, when in slide display mode, the images will repeat after the last image is displayed. When this property is True, images will repeat. If the first image is being displayed and "slide back" is used then the last image will be displayed. If the last image is being displayed and "slide forward" is used, then the first image will be displayed. When this property is False, the images will not move from last to first or from first to last directly.

In addition to touch-slide and mouse drag, the SlideForward, SlideBack, SlideToFirst, and SlideToLast methods can be used to change images.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartCoordinatesFree property

Newtone.ImageKit.Win.ImageKit.StartCoordinatesFree Property

This property allows an image, displayed in actual size, to be displayed in a custom position within the ImageKit control.

[Visual Basic] Public Property StartCoordinatesFree As Boolean
[C#] public bool StartCoordinatesFree {get; set;}

Property Value

True: The image can be displayed in a custom position

False: The image cannot be displayed in a custom position

Default value is False

Explanation

The StartCoordinatesFree property allows an image, displayed in actual size, to be displayed in a custom position within the ImageKit control.

When StartCoordinatesFree property is True and the image's actual size is larger than the ImageKit control, negative values can be set in the StartDrawX and StartDrawY properties which will shift the image down and to the right in the ImageKit control. When StartCoordinatesFree property is False, setting negative values in the StartDrawX and StartDrawY properties will have not affect. (You can set positive values in the StartDrawX and StartDrawY properties at anytime regardless of StartCoordinatesFree property.

When StartCoordinatesFree property is True and the image is smaller than the ImageKit control, the StartCoordinatesFree property allows the image to be displayed in a position other than centered within the ImageKit control. This property is enabled with the Edit.EditEnabled property is False.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartDrawX property

Newtone.ImageKit.Win.ImageKit.StartDrawX Property

The StartDrawX and StartDrawY properties get or set the point on the image that will be displayed from the top left corner of the ImageKit Control.

[Visual Basic] Public Property StartDrawX As Integer
[C#] public int StartDrawX {get; set;}

Property Value

The horizontal position on the image that will be displayed from the left of the ImageKit Control.

Explanation

The StartDrawX and StartDrawY properties get or set the point on the image that will be displayed from the top left corner of the ImageKit Control. By setting the StartDrawX and StartDrawY properties, large images can be loaded into the ImageKit Control and displayed from a specified position on the image. StartDrawX and StartDrawY are enabled when the image is displayed in actual size. Furthermore, if DrawCenterX and DrawCenterY properties are set to values other than 0 then StartDrawX and StartDrawY properties are disabled.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartDrawY property

Newtone.ImageKit.Win.ImageKit.StartDrawY Property

The StartDrawX and StartDrawY properties get or set the point on the image that will be displayed from the top left corner of the ImageKit Control.

[Visual Basic] Public Property StartDrawY As Integer
[C#] public int StartDrawY {get; set;}

Property Value

The vertical position on the image that will be displayed from the left of the ImageKit Control.

Explanation

The StartDrawX and StartDrawY properties get or set the point on the image that will be displayed from the top left corner of the ImageKit Control. By setting the StartDrawX and StartDrawY properties, large images can be loaded into the ImageKit Control and displayed from a specified position on the image. StartDrawX and StartDrawY are enabled when the image is displayed in actual size. Furthermore, if DrawCenterX and DrawCenterY properties are set to values other than 0 then StartDrawX and StartDrawY properties are disabled.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ToolTip property

Newtone.ImageKit.Win.ImageKit.ToolTip Property

This property sets the units of measurement at which the tool tip coordinates are displayed.

[Visual Basic] Public Property ToolTip As LengthUnit
[C#] public LengthUnit ToolTip {get; set;}

Property Value

Value | Explanation
Non (default) | None (Does not display a tool tip)
Pixel | Pixels
mm | Millimeters
Inch | Inches

Explanation

The ToolTip property displays a tool tip when the mouse moves over the image in the ImageKit Control. The tool tip shows the x y coordinates for the location of the mouse cursor. When this property is set to Non, the tool tip will not be displayed. Values other than Non will set the tool tip units to pixels, millimeters, or inches respectively.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Transparent property

Newtone.ImageKit.Win.ImageKit.Transparent Property

This property enables the transparent color in the base (raster) image.

[Visual Basic] Public Property Transparent As Boolean
[C#] public bool Transparent {get; set;}

Property Value

Value | Explanation
True | The transparent color is enabled
False (default) | The transparent color is disabled

Explanation

The Transparent property enables the transparent color in the base (raster) image. When True, the color set in the TransparentBlue, TransparentGreen, and TransparentRed properties will appear as transparent when the base image is displayed in the ImageKit Control.

If the base image referred to by the Image property is a vector image then transparency is disabled.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


TransparentBlue property

Newtone.ImageKit.Win.ImageKit.TransparentBlue Property

The TransparentRed, TransparentGreen, and TransparentBlue properties are used to set a transparent color in the base (raster) image.

[Visual Basic] Public Property TransparentBlue As Byte
[C#] public byte TransparentBlue {get; set;}

Property Value

Values range from 0 to 255

Explanation

The TransparentRed, TransparentGreen, and TransparentBlue properties are used to set a transparent color in the base (raster) image. The ImageKit Control background will be seen in the areas of the image that are set to transparent. To set a transparent color in an image, the image must be either 8 bit color or 24 bit color. If a vector image is set in the base image, these properties are disabled.

Example

Below the code snippet illustrates how to set the transparent color to white: (in Visual Basic)

ImageKit1.Transparent = True
ImageKit1.TransparentBlue = 255
ImageKit1.TransparentGreen = 255
ImageKit1.TransparentRed = 255
ImageKit1.LayerNumber = -1
ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.Win.LoadFileType.Load)

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


TransparentGreen property

Newtone.ImageKit.Win.ImageKit.TransparentGreen Property

The TransparentRed, TransparentGreen, and TransparentBlue properties are used to set a transparent color in the base (raster) image.

[Visual Basic] Public Property TransparentGreen As Byte
[C#] public byte TransparentGreen {get; set;}

Property Value

Values range from 0 to 255

Explanation

The TransparentRed, TransparentGreen, and TransparentBlue properties are used to set a transparent color in the base (raster) image. The ImageKit Control background will be seen in the areas of the image that are set to transparent. To set a transparent color in an image, the image must be either 8 bit color or 24 bit color. If a vector image is set in the base image, these properties are disabled.

Example

Below the code snippet illustrates how to set the transparent color to white: (in Visual Basic)

ImageKit1.Transparent = True
ImageKit1.TransparentBlue = 255
ImageKit1.TransparentGreen = 255
ImageKit1.TransparentRed = 255
ImageKit1.LayerNumber = -1
ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.Win.LoadFileType.Load)

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


TransparentRed property

Newtone.ImageKit.Win.ImageKit.TransparentRed Property

The TransparentRed, TransparentGreen, and TransparentBlue properties are used to set a transparent color in the base (raster) image.

[Visual Basic] Public Property TransparentRed As Byte
[C#] public byte TransparentRed {get; set;}

Property Value

Values range from 0 to 255

Explanation

The TransparentRed, TransparentGreen, and TransparentBlue properties are used to set a transparent color in the base (raster) image. The ImageKit Control background will be seen in the areas of the image that are set to transparent. To set a transparent color in an image, the image must be either 8 bit color or 24 bit color. If a vector image is set in the base image, these properties are disabled.

Example

Below the code snippet illustrates how to set the transparent color to white: (in Visual Basic)

ImageKit1.Transparent = True
ImageKit1.TransparentBlue = 255
ImageKit1.TransparentGreen = 255
ImageKit1.TransparentRed = 255
ImageKit1.LayerNumber = -1
ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.Win.LoadFileType.Load)

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


CalculateDistance method

Newtone.ImageKit.Win.ImageKit.CalculateDistance Method

This method calculates the distance between two points on the image.

[Visual Basic]Public Function CalculateDistance(pt1 As Point, pt2 As Point, unit As LengthUnit, dpi As Integer) As Double
[C#]public double CalculateDistance(Point pt1, Point pt2, LengthUnit unit, int dpi);

Parameters

pt1
The Point value representing the coordinates of the first point

pt2
The Point value representing the coordinates of the second point

unit
A value of type LengthUnit representing the units of measurement

dpi
An integer representing the resolution of the image where the distance is measured

Return Value

Returns a value for the distance between the two points (Type: double)

Explanation

The CalculateDistance method calculates the distance between two points on the image. The distance is calcuated and the value returned is in units defined by the unit parameter. When unit is set to LengthUnit.mm or to LengthUnit.Inch, the value set in the dpi parameter is relevant to the calculation. When unit is set to Length.None, the result will be the same as when unit is set to LengthUnit.Pixel.

When using the MouseUpImage or the annotation object's SelectedObjectDrawPoints property, it is possible to set the two points by clicking on the displayed image.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ClearClipBoard method

Newtone.ImageKit.Win.ImageKit.ClearClipBoard Method

This method clears the clipboard.

[Visual Basic]Public Function ClearClipBoard()
[C#]public void ClearClipBoard();

Parameters

None

Return Value

None

Explanation

The ClearClipBoard method clears the clipboard.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ClearSlideImages method

Newtone.ImageKit.Win.ImageKit.ClearSlideImages Method

This method clears the images that were created for the slide display mode.

[Visual Basic] Public Function ClearSlideImages()
[C#] public void ClearSlideImages();

Parameter Value

None

Return Value

None

Explanation

The ClearSlideImages method clears the images that were created for the slide display mode. Executing this method also clears the SlidePath property. If you want to use the slide display mode again, you'll have to reset that property.

For details, please refer to the SlideMode property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Display method

Newtone.ImageKit.Win.ImageKit.Display Method

This method displays the image.

[Visual Basic]Public Function Display() As Boolean
[C#]public bool Display();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Display method displays the image in the ImageKit control according the the display mode set in the DisplayMode property.

When the DisplayMode property is set to Clear, the image is cleared from the ImageKit control. To display images in the ImageKit control again, you must execute the Display method. When the DisplayMode property is set to a value other than Clear and the ShowImage property is true, the image is displayed in that display mode. This includes both base and layer images. If the Edit.EditEnabled property is true, however, and the DisplayMode property is set to Stretch, the image will be displayed in Scale display mode.

Images are displayed in the following order: the base image first then the Layer images (the images with lower indexes are displayed before the image with higher indexes)

Note that if the base image is not set, then the Layer images are not displayed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GetFromClipBoard method

Newtone.ImageKit.Win.ImageKit.GetFromClipBoard Method

This method retrieves a raster image from the clipboard.

[Visual Basic] Public Function GetFromClipBoard() As Boolean
[C#] public bool GetFromClipBoard();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetFromClipBoard method retrieves a raster image from the clipboard.

If successful, the image will be set in the property referred to by the LayerNumber property (either the Image property or the Layer(LayerNumber).Image property)

Note: This method retrieves only raster images from the clipboard.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GetImageType method

Newtone.ImageKit.Win.ImageKit.GetImageType Method

The GetImageType method sets the various image information into the image's related property values.

[Visual Basic] Public Function GetImageType() As Boolean
[C#] public bool GetImageType();

Parameters

None

Return Value

Return True if successful. Return False if unsuccessful.

Explanation

The GetImageType method sets the various image information into the image's related property values. Depending on the LayerNumber property value, the information will be related to the image set in the Image property or the Layer(LayerNumber).Image property.

For the image referred to by the Image property

The following properties will be set: BitCount, Gray, ImageKind, ImageSize, ImageWidthByte, and PaletteCount

For the image referred to by the Layer(LayerNo).Image property

The following properties will be set: Layer(LayerNumber).BitCount, Layer(LayerNumber).Gray, Layer(LayerNumber).ImageKind, Layer(LayerNumber).ImageSize,
Layer(LayerNumber).ImageWidthByte, and Layer(LayerNumber).PaletteCount

Note: Even if you do not execute the GetImageType method, when an image is set into the Image property or the Layer(LayerNo).Image property, the image information is automatically set into these various properties.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GetOneBitPaletteCount method

Newtone.ImageKit.Win.ImageKit.GetOneBitPaletteCount Method

This method retrieves the number of 0 pixels and 1 pixels from a 1 bit color image.

Overloaded Method

[Visual Basic] Public Function GetOneBitPaletteCount(Pal0 As Integer, Pal1 As Integer, GetImg As Image) As Boolean
[C#] public bool GetOneBitPaletteCount(ref int Pal0, ref int Pal1, Image GetImg);

[Visual Basic] Public Function GetOneBitPaletteCount(Pal0 As Long, Pal1 As Long, GetImg As Image) As Boolean
[C#] public bool GetOneBitPaletteCount(ref long Pal0, ref long Pal1, Image GetImg);

Parameters

Pal0
The number of 0 pixels retrieved from a 1 bit color image palette

Pal1
The number of 1 pixels retrieved from a 1 bit color image palette

GetImg
The raster image

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetOneBitPaletteCount method retrieves the number of 0 pixels and 1 pixels from a 1 bit color image. This method is enabled for 1 bit color images only.

When the GetImg parameter contains a valid image

The image data that the GetImg parameter refers to will be processed.

When the GetImg parameter contains 0

The image data determined by the LayerNumber property will be processed. If the LayerNumber property is -1 (the base image) then the image data referred to by the Image property will be processed. If the value of the LayerNumber property is between 0 and 99 then the image data referred to by the Layer(LayerNumber).Imgae property will be processed.

For Palette color, please refer to the GetPalette method.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GetPalette method

Newtone.ImageKit.Win.ImageKit.GetPalette Method

This method retrieves the palette information for a raster image.

[Visual Basic] Public Function GetPalette(Red As Byte, Green As Byte, Blue As Byte, GetImg As Image) As Boolean
[C#] public bool GetPalette(ref byte []Red, ref byte []Green, ref byte []Blue, Image GetImg) ;

Parameters

Red
Array of the retrieved red palette information
(1)Visual Basic: the syntax of the argument is Red(0)
(2)C#: the syntax of the argument is ref Red[]

Green
Array of the retrieved green palette information
(1)Visual Basic: the syntax of the argument is Green(0)
(2)C#: the syntax of the argument is ref Green[]

Blue
Array of the retrieved blue palette information
(1)Visual Basic: the syntax of the argument is Blue(0)
(2)C#: the syntax of the argument is ref Blue[]

GetImg
The raster image

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetPalette method retrieves the palette information for a raster image.

When the GetImg parameter contains a valid image

The image data that the GetImg parameter refers to will be processed.

When the GetImg parameter contains 0

The image data determined by the LayerNumber property will be processed. If the LayerNumber property is -1 (the base image) then the image data referred to by the Image property will be processed. If the value of the LayerNumber property is between 0 and 99 then the image data referred to by the Layer(LayerNumber).Image property will be processed.

To find out how many items are in the various RGB arrays, please refer to the PaletteCount property. The PaletteCount property value is refreshed when ever an image handle is set into the Image property of the Layer(LayerNo).Image property. Use the GetImageType method to retrieve the PaletteCount property value.

Example

[Visual Basic]
Dim r() As Byte
Dim g() As Byte
Dim b() As Byte

ImageKit1.LayerNumber = -1
If ImageKit1.PaletteCount = 1 Then
  Exit Sub
End If

ReDim r(0 To ImageKit1.PaletteCount - 1)
ReDim g(0 To ImageKit1.PaletteCount - 1)
ReDim b(0 To ImageKit1.PaletteCount - 1)

ImageKit1.GetPalette r(0), g(0), b(0), Nothing

[C#]
byte[] r = new byte[imageKit1.PaletteCount];
byte[] g = new byte[imageKit1.PaletteCount];
byte[] b = new byte[imageKit1.PaletteCount];

imageKit1.LayerNumber := -1;
if (imageKit1.PaletteCount == 1) return false;
imageKit1.GetPalette(ref r, ref g, ref b, null);

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


IsClipBoardData method

Newtone.ImageKit.Win.ImageKit.IsClipBoardData Method

This method checks whether or not there is clipboard data.

[Visual Basic] Public Function IsClipBoardData()
[C#] public void IsClipBoardData();

Parameters

None

Return Value

Returns True (nonzero) if there is clipboard data, otherwise returns False.

Explanation

The IsClipBoardData method checks whether or not there is clipboard data.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollImage method

Newtone.ImageKit.Win.ImageKit.ScrollImage Method

This method scrolls the image according to the values set in the ScrollValueH and ScrollValueV properties.

[Visual Basic] Public Function ScrollImage(Direc As ScrollDirection) As Boolean
[C#] public bool ScrollImage(ScrollDirection Direc) ;

Parameters

Direc
This value is of ScrollDirection type.

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

This method scrolls the image according to the values set in the ScrollValueH and ScrollValueV properties.

The ScrollValueH and ScrollValueV properties must be set prior to executing this method.

Note: This method is only enabled when the image is displayed in actual size.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


SlidePath method

Newtone.ImageKit.Win.ImageKit.SetSlideMode Method

This method creates the images used during slide display mode and enables the slide display mode.

[Visual Basic] Public Function SetSlideMode() As Boolean
[C#] public bool SetSlideMode();

Parameter Value

None

Return Value

Returns True if successful, otherwise returns False

Explanation

The SetSlideMode method creates the images used during slide display mode and enables the slide display mode of the ImageKit control.

The amount of time it takes for this method to execute will depend on the number of images to be displayed, as determined by the SlidePath and SlideFileExtension properties, and by the sizes of these images.

For example code, please see the SlideMode property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


SetToClipBoard method

Newtone.ImageKit.Win.ImageKit.SetToClipBoard Method

This method copies a raster image to the clipboard.

[Visual Basic] Public Function SetToClipBoard() As Boolean
[C#] public bool SetToClipBoard() ;

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetToClipBoard method copies a raster image to the clipboard.

If successful, the image referred to by the LayerNumber property (either the Image property or the Layer(LayerNumber).Image property) will be copied to the clipboard.

If the image is a vector image, it will be converted to a raster image.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


SlideBack method

Newtone.ImageKit.Win.ImageKit.SlideBack Method

This method slides to the previous image.

[Visual Basic] Public Function SlideBack()
[C#] public void SlideBack();

Parameter Value

None

Return Value

None

Explanation

The SlideBack method slides to the previous image. If the image displayed is the first image in the folder, set by the SlidePath property, the SlideRepeat property will determine if this method will slide to the last image or will be ineffectual.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


SlideForward method

Newtone.ImageKit.Win.ImageKit.SlideForward Method

This method slides to the next image.

[Visual Basic] Public Function SlideForward()
[C#] public void SlideForward();

Parameter Value

None

Return Value

None

Explanation

The SlideForward method slides to the next image. If the image displayed is the last image in the folder, set by the SlidePath property, the SlideRepeat property will determine if this method will slide to the first image again or will be ineffectual.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


SlideToFirst method

Newtone.ImageKit.Win.ImageKit.SlideToFirst Method

This method slides to the first image.

[Visual Basic] Public Function SlideToFirst()
[C#] public void SlideToFirst();

Parameter Value

None

Return Value

None

Explanation

The SlideToFirst method slides to the first image. This is the first image in the folder, set by the SlidePath property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


SlideToLast method

Newtone.ImageKit.Win.ImageKit.SlideToLast Method

This method slides to the last image.

[Visual Basic] Public Function SlideToLast()
[C#] public void SlideToLast();

Parameter Value

None

Return Value

None

Explanation

The SlideToLast method slides to the last image. This is the last image in the folder, set by the SlidePath property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Zoom method

Newtone.ImageKit.Win.ImageKit.Zoom Method

This method zooms in on the area specified by the Left, Top, Right and Bottom parameters.

[Visual Basic] Public Function Zoom(Left As Integer, Top As Integer, Right As Integer, Bottom As Integer) As Boolean
[C#] public bool Zoom(int Left, int Top, int Right, int Bottom) ;

Parameters

Left
The left coordinate of the zoom area (in pixels)

Top
The top coordinate of the zoom area (in pixels)

Right
The right coordinate of the zoom area (in pixels)

Bottom
The bottom coordinate of the zoom area (in pixels)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Zoom method zooms (in or out) on the area specified by the above four parameters so that the area fills the ImageKit Control while maintaining the height to width aspect of the specified area. After the Zoom method has executed the DrawScaleX and DrawScaleY property values are recalculated.

Note: This method is only enabled when the image is displayed at actual size.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


AfterScan event

Newtone.ImageKit.Win.ImageKit.AfterScan Event

This event is generated after an image is scanned with the scan device.

[Visual Basic] Public Event AfterScan As AfterScanEventHandler
[C#] public event AfterScanEventHandler AfterScan;

Event Data

The event handler receives arguments of type AfterScanEventArgs.

Explanation

The AfterScanevent is generated after an image is scanned with the scan device. Information about the actual image data transfered in this event can be referenced through the AfterScanEventArgs arguments.

Regarding properties of the AfterScanEventArgs class:

This event is generated after an image is scanned with the scan device. When the Dispose argument is true, the scanned image data (Bitmap1 and Bitmap2) is disposed after this event fires so if you want to use this image data in any way, you must make a copy of the scanned image in the memory or save it in an image file. When the Dispose argument is false, the scanned image data (Bitmap1 and Bitmap2) is not disposed.

(1) When using native transfer or when using memory transfer without compression:

If the scanned image is 1, 4, 8, or 24 bits then the image is set in Bitmap1 and Bitmap2 will be null (Nothing in Visual Basic). If the scanned image is 12, 14, or 16 bit grayscale or 36, 42, or 48 bit color then the image will be set in Bitmap2 and the Bitmap2 image data will be converted to 8 bit grayscale or 24 bit color and that will be set in Bitmap1. In this case, if the Bitmap1 memory cannot be allocated it will be null (Nothing in Visual Basic)

(2) When using memory transfer with compression:

The scanned image is set into RawData. Both Bitmap1 and Bitmap2 will be null (Nothing in Visual Basic)

(3) When using file transfer:

Both Bitmap1 and Bitmap2 will be null (Nothing in Visual Basic). The file will be saved in the location specified by FileName

When Scan.UserInterface property is set to Suppress and the Scan.Unit property is Pixel, there are cases in which the resolution of Bitmap1 and Bitmap2 will be 1. To cancel scanning set the Cancel property to True.

Example

The following code displays the image scanned.

[Visual Basic.NET]
Private Sub ImageKit1_AfterScan(ByVal sender As Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs) Handles ImageKit1.AfterScan
   If (e.Bitmap1 Is Nothing) Then Exit Sub
   If Not (ImageKit1.Image Is Nothing) Then
      ImageKit1.Image.Dispose()
   End If
   ImageKit1.Image = e.Bitmap1.Clone()
   ImageKit1.Display(Newtone.ImageKit.Win.DisplayMode.Stretch)
End Sub

[Visual C#.NET]
private void imageKit1_AfterScan(object sender, Newtone.ImageKit.AfterScanEventArgs e)
{
   if (e.Bitmap1 == null) return;
   if (imageKit1.Image != null)
      imageKit1.Image.Dispose();

   imageKit1.Image = (Image)e.Bitmap1.Clone();
   imageKit1.Display(Newtone.ImageKit.Win.DisplayMode.Stretch);
}

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


BeforeScan event

Newtone.ImageKit.Win.ImageKit.BeforeScan Event

This event is generated just before an image is scanned with the scan device.

[Visual Basic] Public Event BeforeScan As BeforeScanEventHandler
[C#] public event BeforeScanEventHandler BeforeScan;

Event Data

The event handler receives arguments of type BeforeScanEventArgs

Explanation

The BeforeScan event is generated just before an image is scanned with the scan device. Information about the actual image data transfered in this event can be referenced through the BeforeScanEventArgs arguments.

Regarding properties of the BeforeScanEventArgs class:

When the Scan.PaperSize property is set to UndefinedSize (or values of 1000 or more), the values for the Width and Height properties of this class may become -1 in some cases. It is also possible that the values of the Width and Height properties become larger than the actual size of the document plate. Scan.PixelType property is set to Automation the BitDepth and PixelType values may be different from the actual image.

To cancel, set the Scan.Cancel property to True within this event.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ClickOnPanWindow event

Newtone.ImageKit.Win.ImageKit.ClickOnPanWindow Event

This event is generated when the mouse cursor is inside the pan window and the left mouse button is pressed.

[Visual Basic] Public Event ClickOnPanWindow As PointEventHandler
[C#] public event PointEventHandler ClickOnPanWindow;

Event Data

The event handler receives arguments of type PointEventArgs

Explanation

The ClickOnPanWindow event is generated when the mouse cursor is inside the pan window and the left mouse button is pressed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


EditKindChanged event

Newtone.ImageKit.Win.ImageKit.EditKindChanged Event

This event is generated when the Edit.EditKind property is changed.

[Visual Basic] Public Event EditKindChanged As System.EventHandler
[C#] public event System.EventHandler EditKindChanged;

Event Data

The event handler receives arguments of type System.EventArgs

Explanation

The EditKindChanged event is generated when the Edit.EditKind property is changed.

If there is code that you want to execute when the Edit.EditKind property changes, write that code in this event.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


EndDispImage event

Newtone.ImageKit.Win.ImageKit.EndDispImage Event

This event is generated just after the image has been displayed.

[Visual Basic] Public Event EndDispImage As DispEventHandler
[C#] public event DispEventHandler EndDispImage;

Event Data

The event handler receives arguments of type DispEventArgs

Explanation

The EndDispImage event is generated just after the image has been displayed.

If there are processes that you want to occur just after an image is displayed, then place that code within this event.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


EndDrawObject event

Newtone.ImageKit.Win.ImageKit.EndDrawObject Event

This event is generated just after an annotation object has been drawn.

[Visual Basic] Public Event EndDrawObject As AnnotationDrawEventHandler
[C#] public event AnnotationDrawEventHandler EndDispImage;

Event Data

The event handler receives arguments of type AnnotationDrawEventArgs

Explanation

The EndDrawObject event is generated just after an annotation object has been drawn.

If there are processes that you want to occur just after an annotation object has been drawn, then place that code within this event. This event is generated for annotation objects: line, polyline, polygon, rectangle, pen, text, stamp, and image.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


EndEditObject event

Newtone.ImageKit.Win.ImageKit.EndEditObject Event

This event is generated just after an annotation object has been edited.

[Visual Basic] Public Event EndEditObject As System.EventHandler
[C#] public event System.EventHandler EndEditObject;

Event Data

The event handler receives arguments of type System.EventArgs

Explanation

The EndEditObject event is generated just after an annotation object has been edited.

If there are processes that you want to occur just after an annotation object has been edited, then place that code within this event. Depending on the object that is selected, this event is generated: when the object is moved, when it is copied or cut, when the object's shape is changed, when the object is rotated, when the object's Z-Order is changed, when a copied object is pasted, and when an object's property values change, when Undo or Redo are used, when rasterizing an annotation into the image, when ClearEditHistory method is used. This event is generated whether a single object or multiple objects are selected.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


EndLoad event

Newtone.ImageKit.Win.ImageKit.EndLoad Event

This event is generated after a file has loaded.

[Visual Basic] Public Event EndLoad As FileEventHandler
[C#] public event FileEventHandler EndLoad;

Event Data

The event handler receives arguments of type FileEventArgs

Explanation

This event is generated after a file has loaded, i.e. when theFile.LoadRawDataFromFile or the File.LoadImageFromFile methods are executed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


EndSave event

Newtone.ImageKit.Win.ImageKit.EndSave Event

This event is generated after a file has finished being saved.

[Visual Basic] Public Event EndSave As FileEventHandler
[C#] public event FileEventHandler EndSave;

Event Data

The event handler receives arguments of type FileEventArgs

Explanation

The EndSave event is generated after a file has finished being saved, i.e. when theFile.SaveRawDataToFile method or the File.SaveImageToFile method have executed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GetDragDropFileName event

Newtone.ImageKit.Win.ImageKit.GetDragDropFileName Event

This event is generated after an image is dragged and dropped into the ImageKit Control.

[Visual Basic] Public Event GetDragDropFileName As FileEventHandler
[C#] public event FileEventHandler GetDragDropFileName;

Event Data

The event handler receives arguments of type FileEventArgs

Explanation

The GetDragDropFileName event is generated after an image is dragged and dropped into the ImageKit Control. This event will be generated when an image file is dragged from Windows Explorer or the thumbnail control and dropped into the ImageKit Control.

To enable this event, set the ImageKit Control's AllowDrop property to True. (AllowDrop is a standard .NET Framework property. See appropriate .NET Framework help for details)

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MagnifierMouseDown event

Newtone.ImageKit.Win.ImageKit.MagnifierMouseDown Event

This event is generated when the mouse button is pressed inside the Magnifier.

[Visual Basic] Public Event MagnifierMouseDown As MouseButtonEventHandler
[C#] public event MouseButtonEventHandler MagnifierMouseDown;

Event Data

The event handler receives arguments of type MouseButtonEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MagnifierMouseMove event

Newtone.ImageKit.Win.ImageKit.MagnifierMouseMove Event

This event is generated when the mouse cursor is moved within the Magnifier.

[Visual Basic] Public Event MagnifierMouseMove As MouseButtonEventHandler
[C#] public event MouseButtonEventHandler MagnifierMouseMove;

Event Data

The event handler receives arguments of type MouseButtonEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MagnifierMouseUp event

Newtone.ImageKit.Win.ImageKit.MagnifierMouseUp Event

This event is generated when the mouse button is released inside the Magnifier.

[Visual Basic] Public Event MagnifierMouseUp As MouseButtonEventHandler
[C#] public event MouseButtonEventHandler MagnifierMouseUp;

Event Data

The event handler receives arguments of type MouseButtonEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseDownImage event

Newtone.ImageKit.Win.ImageKit.MouseDownImage Event

This event is generated when the mouse cursor is inside the image and the mouse button has been pressed.

[Visual Basic] Public Event MouseDownImage As MouseUpDownEventHandler
[C#] public event MouseUpDownEventHandler MouseDownImage;

Event Data

The event handler receives arguments of type MouseUpDownEventArgs

Explanation

The MouseDownImage event is generated when the mouse cursor is inside the image and the mouse button has been pressed.

Note: The MouseDownImage event is generated before the standard MouseDown event.

This event is enabled when a valid image handle is set in the Image property or the Layer(LayerNumber).Image property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseDownSelectLayerImage event

Newtone.ImageKit.Win.ImageKit.MouseDownSelectLayerImage Event

This event is generated when the mouse cursor is over a layer image and the mouse button is been pressed.

[Visual Basic] Public Event MouseDownSelectLayerImage As MouseSelectEventHandler
[C#] public event MouseSelectEventHandler MouseDownSelectLayerImage;

Event Data

The event handler receives arguments of type MouseSelectEventArgs

Explanation

The MouseDownSelectLayerImage event is generated when the mouse cursor is over a layer image and the mouse button is been pressed. This event is enabled when an image is set in the Layer interface's Image property and the image exists in the location where the mouse is pressed. If there is more than one image layer at the location where the mouse button was pressed, the top most image will be selected.

For example if at the mouse down location there are two image layers as indicated by the Layer property index 0 and 3, the image layer corresponding to index 3 will be selected. (image layers with larger indexes are displayed above image layers with smaller indexes).

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseMoveImage event

Newtone.ImageKit.Win.ImageKit.MouseMoveImage Event

This event is generated when the mouse moves over the image.

[Visual Basic] Public Event MouseMoveImage As MouseUpDownEventHandler
[C#] public event MouseUpDownEventHandler MouseMoveImage;

Event Data

The event handler receives arguments of type MouseUpDownEventArgs

Explanation

The MouseMoveImage event is generated when the mouse moves over the image.

Note: The MouseMoveImage event is generated before the standard MouseMove event.

This event is enabled when a valid image handle is set in the Image property or the Layer(LayerNumber).Imgae property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseUpImage event

Newtone.ImageKit.Win.ImageKit.MouseUpImage Event

This event is generated when the mouse cursor is inside the image and the mouse button has been released.

[Visual Basic] Public Event MouseUpImage As MouseUpDownEventHandler
[C#] public event MouseUpDownEventHandler MouseUpImage;

Event Data

The event handler receives arguments of type MouseUpDownEventArgs

Explanation

The MouseUpImage event is generated when the mouse cursor is inside the image and the mouse button has been released.

Note: The MouseUpImage event is generated before the standard MouseUp event.

This event is enabled when the Image property or the Layer(LayerNumber).Image property contains a valid image handle.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseUpSelectLayerImage event

Newtone.ImageKit.Win.ImageKit.MouseUpSelectLayerImage Event

Generated when the mouse cursor is placed over a layer image and the mouse button is released.

[Visual Basic] Public Event MouseUpSelectLayerImage As MouseSelectEventHandler
[C#] public event MouseSelectEventHandler MouseUpSelectLayerImage;

Event Data

The event handler receives arguments of type MouseSelectEventArgs

Explanation

The MouseUpSelectLayerImage event is generated when the mouse cursor is over a layer image and the mouse button is released. This event is enabled when an image is set in the Layer interface's Image property and the image exists in the location where the mouse is released. If there is more than one layer image at the location where the mouse button was released, the top most image will be selected.

For example if at the mouse release location there are two image layers as indicated by the Layer property index 0 and 3, the image layer corresponding to index 3 will be selected. (image layers with larger indexes are displayed above image layers with smaller indexes).

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseWheelDownImage event

Newtone.ImageKit.Win.ImageKit.MouseWheelDownImage Event

This event is generated when the mouse wheel is rolled down.

[Visual Basic] Public Event MouseWheelDownImage As MouseWheelEventHandler
[C#] public event MouseWheelEventHandler MouseWheelDownImage;

Event Data

The event handler receives arguments of type MouseWheelEventArgs

Explanation

The MouseWheelDownImage event is generated when the mouse wheel is rolled down.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseWheelUpImage event

Newtone.ImageKit.Win.ImageKit.MouseWheelUpImage Event

This event is generated when the mouse wheel is rolled up.

[Visual Basic] Public Event MouseWheelUpImage As MouseWheelEventHandler
[C#] public event MouseWheelEventHandler MouseWheelUpImage;

Event Data

The event handler receives arguments of type MouseWheelEventArgs

Explanation

The MouseWheelUpImage event is generated when the mouse wheel is rolled up.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MultiObjectsSelected event

Newtone.ImageKit.Win.ImageKit.MultiObjectsSelected Event

This event is generated when the MultiSelect tool is used and an annotation object or multiple annotation objects are selected.

[Visual Basic] Public Event MultiObjectsSelected As System.EventHandler
[C#] public event System.EventHandler MultiObjectsSelected;

Event Data

The event handler receives arguments of type System.EventArgs

Explanation

The MultiObjectsSelected event is generated after the MultiSelect tool is used to select at least one annotation object and the mouse button is released.

If there are processes that you want to occur when an annotation object is selected using the MultiSelect tool, then place that code within this event. This event is generated only when selecting iannotation objects with the MultiSelect tool.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ObjectSelected event

Newtone.ImageKit.Win.ImageKit.ObjectSelected Event

This event is generated the moment an annotation object is selected.

[Visual Basic] Public Event ObjectSelected As System.EventHandler
[C#] public event System.EventHandler ObjectSelected;

Event Data

The event handler receives arguments of type System.EventArgs

Explanation

The ObjectSelected event is generated the moment an annotation object is selected.

If there are processes that you want to occur when an annotation object is selected, then place that code within this event. This event is generated only when selecting individual annotation objects.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Progress event

Newtone.ImageKit.Win.ImageKit.Progress Event

This event is generated when an effect is being processed or a file is being loaded or saved.

[Visual Basic] Public Event Progress As ProgressEventHandler
[C#] public event ProgressEventHandler Progress;

Event Data

The event handler receives arguments of type ProgressEventArgs

Explanation

This event is generated when an Effect method is executed or when a File method, such as theLoadRawDataFromFile, SaveRawDataFromFile, LoadImageFromFile, or SaveImageFromFile methods are executed.

To cancel a process, set the Effect.Cancel or File.Cancel property to True.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Scanning event

Newtone.ImageKit.Win.ImageKit.Scanning Event

This event is generated when an image is being scanned by the scan device.

[Visual Basic] Public Event Scanning As ProgressEventHandler
[C#] public event ProgressEventHandler Scanning;

Event Data

The event handler receives arguments of type ProgressEventArgs

Explanation

This event is generated when an image is being scanned by the scan device. To retreive the percentage that the current process has completed within this event, refer to the ProgressEventArgs arguments.

The Scanning event is only enabled when using memory transfer. It is not generated when native transfer or file transfer is used. Also, when memory transfer is used, if compression is used and the BeforeScan event's Width and Height properties of the BeforeScanEventArgs class have a value of -1, then the Scanning event is not generated.

Regarding properties of the ProgressEventArgs class: the Percent property can retrieve the percentage of process completed; to cancel, set the Cancel property to True within this event.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollDispImage event

Newtone.ImageKit.Win.ImageKit.ScrollDispImage Event

This event is generated when a scroll bar is used to scroll the image.

[Visual Basic] Public Event ScrollDispImage As ScrollDispEventHandler
[C#] public event ScrollDispEventHandler ScrollDispImage;

Event Data

The event handler receives arguments of type ScrollDispEventArgs.

Explanation

To generate this event, the image must be displayed in actual size and the ScrollBar property must be True.

Note: This event is not generated when a mouse drag is used to scroll the image (when the MouseDragImage property is true).

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartDispImage event

Newtone.ImageKit.Win.ImageKit.StartDispImage Event

This event is generated just before the image is displayed.

[Visual Basic] Public Event StartDispImage As DispEventHandler
[C#] public event DispEventHandler StartDispImage;

Event Data

The event handler receives arguments of type DispEventArgs.

Explanation

The StartDispImage event is generated just before the image is displayed.

If there are processes that you want to occur just before an image is displayed, place that code within this event.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartDrawObject event

Newtone.ImageKit.Win.ImageKit.StartDrawObject Event

This event is generated the moment that the drawing of an annotation object has begun.

[Visual Basic] Public Event StartDrawObject As AnnotationDrawEventHandler
[C#] public event AnnotationDrawEventHandler StartDrawObject;

Event Data

The event handler receives arguments of type AnnotationDrawEventArgs

Explanation

The StartDrawObject event is generated the moment that the drawing of an annotation object has begun.

If there are processes that you want to occur just before an annotation object is drawn, then place that code within this event. This event is generated when the following annotation objects are caused to be drawn using a mouse drag: line, polyline, polygon, rectangle, pen, text, stamp, and image. This event is not generated when objects are drawn by calling a drawing method.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartEditObject event

Newtone.ImageKit.Win.ImageKit.StartEditObject Event

This event is generated the moment that the editing of an annotation object has begun.

[Visual Basic] Public Event StartEditObject As System.EventHandler
[C#] public event System.EventHandler StartEditObject;

Event Data

The event handler receives arguments of type System.EventArgs

Explanation

The StartEditObject event is generated the moment that the editing of an annotation object has begun.

If there are processes that you want to occur when an annotation object has begun to be edited, then place that code within this event. This event is generated: when the object is moved, when the object's shape is changed, and when the object is rotated using a mouse drag. This event is not generated when objects are edited using the Edit interface (SelectObject....) methods.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartLoad event

Newtone.ImageKit.Win.ImageKit.StartLoad Event

This event is generated before a file has started to load.

[Visual Basic] Public Event StartLoad As FileEventHandler
[C#] public event FileEventHandler StartLoad;

Event Data

The event handler receives arguments of type FileEventArgs.

Explanation

The StartLoad event is generated before a file has started to load.

It is generated when the File.LoadRawDataFromFile or the File.LoadImageFromFile methods are executed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartSave event

Newtone.ImageKit.Win.ImageKit.StartSave Event

This event is generated when a file is saved.

[Visual Basic] Public Event StartSave As FileEventHandler
[C#] public event FileEventHandler StartSave;

Event Data

The event handler receives arguments of type FileEventArgs.

Explanation

The StartSave event is generated when a file is saved, i.e. when the File.SaveRawDataToFile method or the File.SaveImageToFile method are executed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


TextObjectBoxClick event

Newtone.ImageKit.Win.ImageKit.TextObjectBoxClick Event

This event is generated when text is being entered in the Text annotation object and the textbox used to enter that text is clicked.

[Visual Basic] Public Event TextObjectBoxClick As System.EventHandler
[C#] public event System.EventHandler TextObjectBoxClick;

Event Data

The event handler receives arguments of type System.EventArgs

Explanation

The TextObjectBoxClick event is generated when text is being entered in the Text annotation object and the textbox used to enter that text is clicked.

If there is code that you want to execute when the textbox is clicked, write that code in this event. For tablet PCs, it is common to write code that displays the soft keyboard when this textbox is clicked.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Align enum

Newtone.ImageKit.Win.Align Enum

This refers to the position of the image in the ImageKit control when displayed in Scale display mode.

public enum Align

Public Members

Member Name | Value | Explanation
None | 0 | The position of the image is determined by the ScaledStartDrawX and the ScaledStartDrawY properties. For standard objects, the position is the center.
Center | 1 | The image or text is displayed in the center of the ImageKit control or the specified area.
TopLeft | 2 | The image or text is displayed from the top left corner of the ImageKit control or the specified area.
MiddleLeft | 3 | The image or text is displayed from the left side of the ImageKit control or the specified area and centered vertically.
BottomLeft | 4 | The image or text is displayed from the bottom left corner of the ImageKit control or the specified area.
TopCenter | 5 | The image or text is displayed from the top of the ImageKit control or the specified area and centered horizontally.
BottomCenter | 6 | The image or text is displayed from the bottom of the ImageKit control or the specified area and centered horizontally.
TopRight | 7 | The image or text is displayed from the top right corner of the ImageKit control or the specified area.
MiddleRight | 8 | The image or text is displayed from the right side of the ImageKit control or the specified area and centered vertically.
BottomRight | 9 | The image or text is displayed from the bottom right corner of the ImageKit control or the specified area.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


AppearanceStyle enum

Newtone.ImageKit.Win.AppearanceStyle Enum

This refers to the appearance style of the ImageKit Control border

public enum AppearanceStyle

Public Members

Member | Value | Explanation
Flat | 0 | Flat
Lowered | 1 | Lowered
Raised | 2 | Raised

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DisplayMode enum

Newtone.ImageKit.Win.DisplayMode Enum

This refers to the types of the display mode.

public enum DisplayMode

Public Members

Member | Value | Explanation
Clear | 0 | Clears the image within the ImageKit Control
Scale | 1 | Scale display mode
Stretch | 2 | Stretch display mode
ActualSize | 3 | Actual size display mode
FitToWidth | 4 | Fit to Width
FitToHeight | 5 | Fit to Height

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


HatchPattern enum

Newtone.ImageKit.Win.HatchPattern Enum

This refers to the hatchpattern that is displayed in that portion of the ImageKit control not covered by an image.

public enum HatchPattern

Public Members

Member | Value | Explanation
NonHatch | 0 | Does not display the hatch pattern, instead, the color set in the BackColor property is used.
ShowHatch | 1 | Displays the hatch pattern
TransparentHatch | 2 | Does not display the hatch pattern, instead, the area is set to transparent

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


KindOfBrush enum

Newtone.ImageKit.Win.KindOfBrush Enum

This refers to the kind of brush used.

public enum KindOfBrush

Public Members

Member | Value | Explanation
Solid | 0 | A solid brush of type System.Drawing.SolidBrush.
HatchBrush | 1 | A hatch pattern brush of type System.Drawing.Drawing2D.HatchStyle
LinearGradientBrush | 2 | A gradient brush of type System.Drawing.Drawing2D.LinearGradientBrush
TextureBrush | 2 | A textured brush of type System.Drawing.TextureBrush

See Also

ImageKit Edit Members | Newtone.ImageKit.Win.ImageKit


KindOfEdit Enum

Newtone.ImageKit.Win.KindOfEdit Enum

This refers to types of annotation objects and functions

public enum KindOfEdit

Public Members

Member Name | Values | Explanation
Select | 0 | Selects an individual annotation object
MultiSelect | 1 | Selects multiple annotation objects
Line | 2 | Line object
Polyline | 3 | Polyline object
Polygon | 4 | Polygon object
Pen | 5 | Pen object
Rectangle | 6 | Rectangle object
Ellipse | 7 | Ellipse object
Text | 8 | Text object
Image | 9 | Image object
RoundRectangle | 10 | RoundRectangle object
Stamp | 11 | Stamp object
None | 99 | None (No object selected)

See Also

ImageKit Edit Members | Newtone.ImageKit.Win.ImageKit


KindOfImage enum

Newtone.ImageKit.Win.KindOfImage Enum

This refers to the image types set into the Image property

public enum KindOfImage

Public Members

Member | Value | Explanation
InvalidImage | 0 | Unknown
RasterImage | 1 | Raster image
VectorWMF | 2 | WMF
VectorEMF | 3 | EMF
VectorDXF | 4 | DXF
VectorSVG | 5 | SVG
VectorSXFP21 | 6 | SXF p21
VectorSXFSFC | 7 | SXF sfc

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


LengthUnit enum

Newtone.ImageKit.Win.LengthUnit Enum

This refers to the units of measurement at which the tool tip coordinates are displayed

public enum LengthUnit

Public Members

Member | Value | Explanation
None | 0 | None
Pixel | 1 | Pixels
mm | 2 | Millimeters
Inch | 3 | Inches

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MagnifierType enum

Newtone.ImageKit.Win.MagnifierType Enum

This refers to the shapes of the magnifier

public enum MagnifierType

Public Members

Member | Value | Explanation
RectangleMagnifier | 0 | Rectangle
EllipseMagnifier | 2 | Ellipse

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollDirection enum

Newtone.ImageKit.Win.ScrollDirection Enum

This refers to the direction to scroll the image

public enum ScrollDirection

Public Members

Member | Value | Explanation
UpLeft | 0 | UpLeft
Up | 1 | Up
UpRight | 2 | UpRight
Right | 3 | Right
DownRight | 4 | DownRight
Down | 5 | Down
DownLeft | 6 | DownLeft
Left | 7 | Left

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Shape enum

Newtone.ImageKit.Win.Shape Enum

This refers to the shape of the Stamp object's border

public enum Shape

Public Members

Member | Value | Explanation
Rectangle | 0 | Rectangle shape
RoundRectangle | 1 | Rounded rectangle shape
Ellipse | 2 | Elliptical shape

See Also

ImageKit Edit Members | Newtone.ImageKit.Win.ImageKit


ToolBarButtonSize Enum

Newtone.ImageKit.Win.ToolBarButtonSize Enum

This refers to the size of the buttons in the Newtone.ImageKit.Win.ToolBarStandard, Newtone.ImageKit.Win.ToolBarSetUpLines, Newtone.ImageKit.Win.ToolBarSetUpObjects, and Newtone.ImageKit.Win.ToolBarAnnotation controls

public enum ToolBarButtonSize

Public Members

Member Name | Value | Explanation
Small | 0 | Basic button size is 16 X 16 pixels
Middle | 1 | Basic button size is 24 X 24 pixels
Large | 2 | Basic button size is 32 X 32 pixels

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


WheelDirection enum

Newtone.ImageKit.Win.WheelDirection Enum

This refers to the direction of the mouse wheel

public enum WheelDirection

Public Members

Member | Value | Explanation
Disable | 0 | Disables scrolling with the mouse wheel
Vertical | 1 | Mouse scrolls in a vertical direction
Horizontal | 2 | Mouse scrolls in a horizontal direction

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Edit class

Newtone.ImageKit.Win.ImageKit.Edit

Newtone.ImageKit.Win.ImageKit.Edit Class

The Edit class contains the properties and methods for editing and annotating images. For a list of all members of the Edit class, please refer to Edit Members

Explanation

The ImageKit.NET3 ImageKit control implements a number of editing and annotation functions. These functions allow annotation objects to be drawn using the mouse or by executing various Edit methods. The annotation objects implemented by the Edit class are listed below:

  • Annotation objects include: Line (Arrow), Polyline (Arrow), Polygon, Rectangle, Round Rectangle, Ellipse, Pen, Text, Stamp and Image. These are the objects that can be drawn using the mouse or by executing various methods.
  • Annotation objects can be selected individually, can selected as a group, or all annotation objects can be selected. Annotation objects can be selected using the mouse. Objects can be selected by executing methods.
  • Annotation objects can be moved individually, as a group, or in their entirety. Annotation objects can be enlarged, reduced, and rotated (individually selected objects / multiple selected objects). This can be done on the control using the mouse or by changing property values.
  • Annotation objects can be deleted, copied, and pasted (individually, as a group, or in their entirety). Annotation objects can be moved to front or moved to back. After annotation objects have been drawn, their properties can be accessed and changed (individually selected objects only). This can be done by right clicking on the control to display the context menu, by changing property values, or by executing various methods.
  • Changes to annotation objects can be undone or redone. This is done by right clicking on the control to display the context menu or by executing various methods.
  • Annotation objects can be saved in a seperate annotation file. The saved annotation file can be loaded on the same image or a different image. This can also be done by executing a method.
  • Annotation objects drawn on the control can be rasterized and embedded into a raster image. This can be done by executing a method.

Using the mouse to draw annotation objects:

NOTE: Annotations are enabled only on the base image in the ImageKit control. For more information about using methods to draw annotation objects, please refer to explanation of those methods in the Help documentation under the Edit interface. For information about annotations and editing using various toolbar controls, please see the properties of these toolbar controls: Newtone.ImageKit.Win.ToolBarAnnotation, Newtone.ImageKit.Win.ToolBarSetUpLines, Newtone.ImageKit.Win.ToolBarSetUpObjects and Newtone.ImageKit.Win.ToolBarStandard.

  • Line Object
    1. Set the following properties: PenWidth, ForeColor, ForeColorOpacity, DoubleLine, StartLineCap, EndLineCap, DashPattern, DashStyle, StartArrowCap, StartArrowCapFilled, StartArrowCapSize, EndArrowCap, EndArrowCapFilled, EndArrowCapSize.
    2. Set the EditKind property to KindOfEdit.Line.
    3. Set the starting point of the line by left-clicking the mouse in the appropriate location on the image and while holding down the left mouse button drag the mouse across the image to draw the line. The endpoint of the line will be the location where the left mouse button was released. Holding down the Shift key while dragging the mouse will force the line to be drawn at angles of 0, ±45 and ±90 degrees
  • Polyline Object
    1. Set the following properties: PenWidth, ForeColor, ForeColorOpacity, StartLineCap, EndLineCap, DashPattern, DashStyle, LineJoin, StartArrowCap, StartArrowCapFilled, StartArrowCapSize, EndArrowCap, EndArrowCapFilled, EndArrowCapSize.
    2. Set the EditKind property to KindOfEdit.Polyline.
    3. Set the starting point of the polyline by left-clicking (and releasing) the mouse in the appropriate location on the image. Move the mouse to the location of the second point in the polyline. A line will be drawn connecting the starting point to the second point. Once the mouse is in the correct location for the second point, left-click the mouse again to draw the second point. Move the mouse to the location of the third point and left click the mouse to set that point. Continue in this way until all the points of the polyline have been drawn. When the endpoint of the polyline is determined, double click the left mouse button to stop drawing.
    4. When the ContextMenuEnable property is set to True, right-clicking will display the Context Menu which can be used to undo or redo line segments and return the annotation object to its prior state.
  • Polygon Object
    1. Set the following properties: PenWidth , ForeColor, ForeColorOpacity, Fill, BackColor, BackColorOpacity, CustomBrushEnabled, BrushKind, HatchStyle, CustomBrushColor1, CustomBrushColor2, LinearGradientMode, CustomBrushImageFileName, DashPattern, DashStyle, and LineJoin.
    2. Set the EditKind property to KindOfEdit.Polygon.
    3. Set the starting point of the polygon by left-clicking (and releasing) the mouse in the appropriate location on the image. Move the mouse to the location of the second point in the polygon. A line will be drawn connecting the starting point to the second point. Once the mouse is in the correct location for the second point, left-click the mouse again to draw the second point. Move the mouse to the location of the third point and left click the mouse to set that point. Continue in this way until all the points of the polygon have been drawn. When the last point of the polygon is determined, double click the left mouse button to set the last point and to draw a line segment from the last point to the start point.
    4. When the ContextMenuEnable property is set to True, right-clicking will display the Context Menu which can be used to undo or redo line segments and return the annotation to its prior state.
  • Rectangle, Round Rectangle, and Ellipse Objects
    1. Set the following properties: PenWidth, ForeColor, ForeColorOpacity, Fill, BackColor, BackColorOpacity, CustomBrushEnabled, BrushKind, HatchStyle, CustomBrushColor1, CustomBrushColor2, LinearGradientMode, CustomBrushImageFileName, RoundRectangleRadius.
    2. Set the EditKind property to KindOfEdit.Rectangle, to KindOfEdit.RoundRectangle, or to KindOfEdit.Ellipse as the case may be.
    3. Set the first corner of the rectangle that bounds the object by left-clicking the mouse in the appropriate location on the image. Hold the left mouse button down while dragging the mouse across the image. This will draw a rectangle that bounds the object. Releasing the left mouse button will set the opposite corner of the bounding rectangle. The rectangle object will be drawn on this bound rectangle, the round rectangle or ellipse objects will use this area as a bounding rectangle will be drawn within. Holding down the Shift key while drawing a rectangle or an ellipse, will make the object a square or circle respectively
  • Pen Object
    1. Set the following properties: PenWidth, ForeColor, ForeColorOpacity, StartLineCap, EndLineCap, DashPattern, DashStyle, LineJoin, ClosePenLine, CustomBrushEnabled, BrushKind, HatchStyle, CustomBrushColor1, CustomBrushColor2, LinearGradientMode, CustomBrushImageFileName.
    2. Set the EditKind property to KindOfEdit.Pen.
    3. Set the starting point for the pen by left-clicking the mouse in the appropriate location on the image. While holding down the left mouse button, move the mouse over the image to draw with the pen. When the mouse button is released, the pen object is completed.
  • Image Object
    1. Set the EditKind property to KindOfEdit.Image.
    2. Use the mouse to determine the location where the image will be pasted. Set one corner of the area by left-clicking the mouse in the appropriate location on the image and while holding down the left mouse button moving the mouse. When the left mouse button is released, the area where the image is pasted is determined and the "File" Dialog will be displayed.
    3. Select the image file that will be pasted and click the "Open" button in the "File" Dialog. The selected image will be pasted in the area determined in step 2. The image will be stretched to fit within this area. If the AspectRatio property is True, the pasted image will maintain the height to width ratio of the original image.

      NOTE: Only images that can be loaded into the ImageKit control can be pasted using Image annotation function. If an unsupported file is selected, the area drawn with the mouse in step 2 will be deleted and the annotation will be returned to the state prior to use of the Image object. Even if the selected image is of a supported format, if the area in which the image is to be pasted is too large and uses up available memory resources so the image cannot be displayed, a small image with a white background and red x will be displayed in its place. In this case, remove the Image object by selected "Delete" or "Undo" in the context menu and then create a small area to paste the image.
  • Text and Stamp Objects
    1. Set the following properties: FontName, FontSize, FontBold, FontItalic, FontStrikeout, FontUnderline, ForeColor, ForeColorOpacity, Fill, BackColor, BackColorOpacity, CustomBrushEnabled, BrushKind, HatchStyle, CustomBrushColor1, CustomBrushColor2, LinearGradientMode, CustomBrushImageFileName, WordWrap, PenWidth, Border, BorderColor, BorderColorOpacity, BorderShape (Stamp object only), TextAlign (Text object only), VerticalText and RightToLeft.
    2. Set the EditKind property to KindOfEdit.Text or to KindOfEdit.Stamp.
    3. Set the upper left corner of the location where you want to draw the Text or Stamp object by left-clicking the mouse and then while holding down the left mouse button move the mouse down and to the right. When you release the left mouse button, the text input area will be created on the image. When the& Fill property is True, the area will be filled with the color set in the BackColor property. When the Fill property is False, the text area background color will be the reverse of the RGB values set in the ForeColor property property. The final size of the Text or Stamp objects is automatically determined by the coordinates of the upper left corner of the text area, the font settings, and the text content and the WordWrap property setting. If the size of the object is not correct, the text area can be selected and the size of the text changed.
    4. Use the keyboard to enter the text that you want to draw. The Enter key will allow you to enter multiple lines of text.
    5. Once the text has been entered into the text area, clicking the mouse outside of the text area will set the text and draw it on the image. (The text content entered in this way is automatically set into the Text property.) If the SetTextOnRightClick property is True, right clicking within the text box will set the text into the Text object. If the SetTextOnInvalidAreaClick property is true, clicking on the ImageKit control in the area where no image is displayed (the invalid area the has a hatched pattern), will set the text into the Text object. When the Fill property is True, the background color of the text will be the color set in the BackColor property, the text color will be the color set in the ForeColor property, and the width of the text is determined by the PenWidth property.
  • Select
    1. Set the EditKind property to KindOfEdit.Select.
    2. Click on any of the annotation objects currently drawn on the image (*) and that object will be selected. Selected objects can be moved, their shape changed, content altered, etc. They can be rotated, deleted, cut, or copied.
      (*) The location that must be clicked in order for an annotation object to be selected is different depending on the object.
      Line Objects: Click on the line to select it.
      Polylines, Polygons, and Pen Objects: Click inside the object. Inside means within the area defined by the x coordinate of the left-most point, the y coordinated of the upper most point, the x coordinate of the right-most point and the y coordinate of the lowest point.
      Rectangle, RoundRectangle and Ellipse Objects: Click inside these objects.
      Text and Stamp Objects: Click inside these object's text area.
  • MultiSelect
    1. Set the EditKind property to KindOfEdit.MultiSelect.
    2. Dragging the mouse will draw the selection area for MultiSelect. All objects that have ALL of their points within this selection area will automatically be selected. All objects selected can be moved, deleted, cut, or copied. Holding down the Ctrl key allows you to click the objects that you want to select. Likewise, if you hold down the Ctrl key and click on object among several that have been selected, that object will be deselected.
    3. The selected objects can be moved, rotated, deleted, copied, and cut.
    4. Note that the area containing multi-selected objects can be enlarged or reduced in size while maintaining the relative positional relationship of the selected objects. (See the MultiResizeMinWidthEachObject property section.)
      1. * When reducing the multi-selection area, the minimum value of the area is the value of the MultiResizeMinHeight, MultiResizeMinWidth property, and the minimum size of each object is the value of the MultiResizeMinHeightEachObject, MultiResizeMinWidthEachObject property.
      2. * If the selected object contains a pasted image with AspectRatio True or a text stamp with WordWrap False, it will be as follows.
        1. -In case of enlargement / reduction by grasping the four corners: Enlargement / reduction is performed while maintaining the entire selection range and the aspect ratio of all selected objects.
        2. -In case of enlargement / reduction in the aspect ratio: The image text stamp that maintains the aspect ratio is enlarged / reduced in the drag direction while maintaining the aspect ratio.
      3. * If the selected object does not include a pasted image with AspectRatio True or a text stamp with WordWrap False, you can zoom in / out by grabbing the four corners in the entire selection range and in the drag direction for all selected objects. However, if you drag with the AspectRatio property set to True, it will be scaled while preserving the overall selection and the aspect ratio of all selected objects.
  • SelectAll / DeseleteAll
    1. Set the EditKind property to KindOfEdit.MultiSelect.
    2. Set the ContextMenuEnable property to True and then right-click anywhere in the ImageKit control to display the Context menu. Choose the "Select All" item and all annotation objects drawn on the image will automatically be selected. These selected objects can then be moved, deleted, or copied.
      Note: If not all objects have been selected, choosing the "Select All" item in the Context menu will select all of the objects. When all objects have been selected, they can be deselected by selecting the "Deselect All Objects" item in the Context menu.

      *When the SelectOnClick property is True, the Ctrl key cannot be used to multi-select objects.
    3. When the CanDeselectAllSelect property is True, the "AllSelect" state can be removed with a mouse click or mouse drag and objects can be selected or multiselected.
  • Moving Objects
    1. Set the EditKind property to KindOfEdit.Select or to KindOfEdit.MultiSelect.
    2. Moving the mouse cursor over an object that is in a selected state will cause the following pointer, [image] , to be displayed on the annotation object. Placing the mouse cursor over that pointer and pressing the left mouse button will allow you to grab the object and drag the object while holding down the left button. Releasing the left mouse button will place the annotation object at that location. When the EditByPoint property is True and the selected object is a Polyline, Polygon, or Pen objects, specific points can be moved with the mouse.
  • Changing Shapes of Objects
    1. Only single selected objects can have their shape changed. Set the& EditKind property to KindOfEdit.Select and select the object whose shape you want to change.
    2. Moving the mouse cursor over the selected object will change the pointers to one of the following, [image] , [image] , [image] , [image] in different locations on the object. Placing the mouse cursor on one of these locations and left clicking it with the mouse will allow you to change the shape of the object by dragging the mouse. When the EditByPoint property is True and the selected object is a Polyline, Polygon, or Pen objects, specific points can be moved with the mouse. When a point can be moved, the mouse cursor will change to [image]. Pressing the left mouse button will grasp the point and moving the mouse while pressing the mouse button will allow the point to be moved. Release the mouse button in the location where you want to place the point.

      Note: For Rectangle and Ellipse objects, when the AspectRatio property is True, holding the Shift key down while altering shape of the object will maintain the object's height/width ratio. When the AspectRatio property is False, holding the Shift key down while altering the shape of the object will restrict the Rectangle object to a square and will restrict the Ellipse object to a circle. When resizing an image, if the AspectRatio property is true, the original image's aspect ratio will be maintained while resizing.

      For Text and Stamp objects, the values of the ResizeTextOnCenter and WordWrap properties will affect how the objects can be resized. For details, please refer to the ResizeTextOnCenter property.
  • Rotating Objects
    1. Single and multiple selected objects can be rotated. Set the EditKind property to KindOfEdit.Select or KindOfEdit.MultiSelect and then select the object.
    2. Moving the mouse cursor over the corner of the selected object's selection area will change the pointer to one of the following, [image] , [image] , [image] , [image] . Placing the mouse cursor on one of these locations and left clicking the mouse will allow you to rotate the object. Releasing the mouse button set the rotated object.
  • Setting The Rectangle For Area Selection
    1. To set the rectangle that defines the selected area on the image, when the EditEnabled property is True, you must set the EditKind property to KindOfEdit.None and the ImageKit.RectDraw property to True. Then use a mouse drag to define the selected area or set the appropriate values directly into the ImageKit.Rect property. The rectangle selecting an area on the image can be retrieved by accessing the ImageKit.Rect property values.
    2. If the EditEnabled property is True and the EditKind property is set to any value other than KindOfEdit.None then an area on the image cannot be selected, even when the ImageKit.RectDraw property is True.
    3. When the EditEnabled property is False, simply setting the ImageKit.RectDraw property to True allows you to select an area on the image using a mouse drag or by setting values directly into the ImageKit.Rect property.

IMPORTANT: While editing, all annotation objects will be cleared if the EditEnabled property is set to False, or a new image is loaded into the ImageKit control, or the Image property changes. To save any annotation objects, execute the SaveAnnotationFile method to save the annotation information to XML file or execute the DrawEditedObjectsToImage method to rasterize the annotations and embed them into the image.

If the image displayed is larger than the ImageKit control and a Line, Rectangle, Ellipse, Pen, or Text object is selected, moved, changed, etc and the mouse is dragged beyond the ImageKit control, the image will automatically be scrolled according to the mouse movement.

For more information about the Context menu, please refer to the ContextMenuEnable property.

See Also

Edit Members


ImageKit.Edit Members

Newtone.ImageKit.Win.ImageKit.Edit Members

Edit Overview

Public Properties

AdjustIKN2AnnotationElements | Sets whether or not an annotation file created by the ImageKit.NET2 will be adjusted when it is loaded into the ImageKit.NET3. There are differences in the font size units of Text objects.
AnnotationFileName | Sets the name of the file that holds the annotation information
AntiAlias | Sets whether or not antialias smoothing is applied to the edges of objects.
AspectRatio | Sets whether or not an image pasted or altered with the Image annotation object will maintain the original image's aspect ratio.
BackColor | Sets the background color or fill color used by annotation objects
BackColorOpacity | Sets the level of opacity for the background color or fill color used by annotation objects
Border | Sets whether or not the Text and Stamp objects have a border
BorderColor | Sets the color of the Text and Stamp objects border
BorderColorOpacity | Sets the level of opacity for the border color of the Text and Stamp annotation objects
BorderShape | Sets the shape of the border for the Stamp annotation object
BrushKind | Sets the type of brush used for the custom brush
CanDeselectAllSelect | Sets whether or not a mouse click or mouse drag can remove the "AllSelect" state from a group of annotation objects
CanRedoCount | Retrieves the number of possible "redo" steps available to an annotation object
CanUndoCount | Retrieves the number of possible "undo" steps available to an annotation object
ClosePenLine | Sets whether or not, when drawing with a Pen object, the start point and end point are connected with a line
ContextMenuEnabled | Sets whether or not the context menu is enabled when an annotation object is right clicked
CopiedObjectsExists | Retrieves whether or not a copied or cut object exists
CurveTension | Sets the curve tension when drawing a curve using a Polyline object
CustomBrushColor1 | Sets the hatch pattern color or the start color for gradation when using the custom brush
CustomBrushColor2 | Sets the hatch pattern background color or the end color for gradation when using the custom brush
CustomBrushEnabled | Sets whether or not the custom brush is enabled.
CustomBrushImageFileName | Sets the file name for the image used in the custom brush when the BrushKind property is set to TextureBrush.
CustomDialog | Displays a custom property dialog instead of the ImageKit standard property dialog
DashPattern | Sets a custom dash pattern for straight lines, polylines, polygons, and pen objects.
DashStyle | Sets the style of the dash line used by the Line, Polyline, Polygon, and Pen objects
DeleteEmbeddedObjects | Sets whether or not, after embedding annotation objects into the image, those annotation objects will be deleted or will be kept
DesignedTextEnabled | Sets whether or not designed text functions are enabled
DialogAngleEnabled | Sets whether or not the textbox used to set the angle for the Text object is enabled in the Text object's property dialog
DialogAngleVisible | Sets whether or not the textbox used to set the angle for the Text object is displayed in the Text object's property dialog
DialogAspectRatioEnabled | Sets whether or not the "Maintain Aspect Ratio" checkbox is enabled in the property dialog
DialogAspectRatioVisible | Sets whether or not the "Maintain Aspect Ratio" checkbox is displayed in the property dialog
DialogBackColorEnabled | Sets whether or not the item used to set the back color is enabled in the property dialog
DialogBackColorOpacityEnabled | Sets whether or not the item used to set the back color opacity is enabled in the property dialog
DialogBackColorOpacityVisible | Sets whether or not the item used to set the back color opacity is displayed in the property dialog
DialogBackColorVisible | Sets whether or not the item used to set the back color is displayed in the property dialog
DialogBorderColorEnabled | Sets whether or not the item used to set the border color is enabled in the property dialog
DialogBorderColorOpacityEnabled | Sets whether or not the item used to set the border color opacity is enabled in the property dialog
DialogBorderColorOpacityVisible | Sets whether or not the item used to set the border color opacity is displayed in the property dialog
DialogBorderColorVisible | Sets whether or not the item used to set the border color is displayed in the property dialog
DialogBorderEnabled | Sets whether or not the checkbox used to set the border is enabled in the property dialog
DialogBorderShapeEnabled | Sets whether or not the item used to set the border shape for the Stamp object is enabled in the property dialog
DialogBorderShapeVisible | Sets whether or not the item used to set the border shape for the Stamp or Text object is displayed in the property dialog
DialogBorderVisible | Sets whether or not the checkbox used to set the border is displayed in the property dialog
DialogBrushKindEnabled | Sets whether or not the custom brush's BrushKind setting is enabled in the property dialog
DialogBrushKindVisible | Sets whether or not the combobox used to set the custom brush's BrushKind setting is displayed in the property dialog
DialogClosePenLineEnabled | Sets whether or not the checkbox used to set the "close pen line" is enabled in the property dialog
DialogClosePenLineVisible | Sets whether or not the checkbox used to set the "close pen line" is displayed in the property dialog
DialogCurveTensionEnabled | Sets whether or not the "Curve Tension" setting is enabled in the property dialog
DialogCurveTensionVisible | Sets whether or not the "Curve Tension" setting is visible in the property dialog
DialogCustomBrushColor1Enabled | Sets whether or not the custom brush's hatch pattern start color is enabled in the property dialog
DialogCustomBrushColor1Visible | Sets whether or not the item used to set the custom brush's hatch pattern start color is displayed in the property dialog
DialogCustomBrushColor2Enabled | Sets whether or not the custom brush's hatch pattern end color is enabled in the property dialog
DialogCustomBrushColor2Visible | Sets whether or not the item used to set the custom brush's hatch pattern end color is displayed in the property dialog
DialogCustomBrushImageFileNameEnabled | Sets whether or not the filename for the image, used by the custom brush when its set to texture, is enabled in the property dialog
DialogCustomBrushImageFileNameVisible | Sets whether or not the item, used to set the filename for the image used by the custom brush when its set to texture, is displayed in the property dialog
DialogCustomBrushVisible | Sets whether to display the custom brush settings collectively in the property dialog
DialogDashStyleEnabled | Sets whether or not the item used to set the dash style is enabled in the property dialog
DialogDashStyleVisible | Sets whether or not the item used to set the dash style is displayed in the property dialog
DialogDesignedTextVisible | Sets whether or not the designed text settings are displayed in the property dialog
DialogDoubleLineEnabled | Sets whether or not the doubleline checkbox for the Line object is enabled within the property dialog
DialogDoubleLineVisible | Sets whether or not the doubleline checkbox for the Line object is displayed within the property dialog
DialogEndArrowCapEnabled | Sets whether or not the checkbox used to set the end arrow cap is enabled in the property dialog
DialogEndArrowCapFilledEnabled | Sets whether or not the checkbox used to set the end arrow cap filled is enabled in the property dialog
DialogEndArrowCapFilledVisible | Sets whether or not the checkbox used to set the end arrow cap filled is displayed in the property dialog
DialogEndArrowCapSizedEnabled | Sets whether or not the item used to set the end arrow cap size is enabled in the property dialog
DialogEndArrowCapSizedVisible | Sets whether or not the item used to set the end arrow cap size is displayed in the property dialog
DialogEndArrowCapVisible | Sets whether or not the checkbox used to set the end arrow cap is displayed in the property dialog
DialogEndLineCapEnabled | Sets whether or not the item used to set the end line cap style is enabled in the property dialog
DialogEndLineCapVisible | Sets whether or not the item used to set the end line cap style is displayed in the property dialog
DialogFillEnabled | Sets whether or not the checkbox used to set "Fill" is enabled in the property dialog
DialogFillVisible | Sets whether or not the checkbox used to set "Fill" is displayed in the property dialog
DialogFontBoldEnabled | Sets whether or not the checkbox used to set bold fonts is enabled in the property dialog
DialogFontBoldVisible | Sets whether or not the checkbox used to set bold fonts is displayed in the property dialog
DialogFontItalicEnabled | Sets whether or not the checkbox used to set italic fonts is enabled in the property dialog
DialogFontItalicVisible | Sets whether or not the checkbox used to set italic fonts is displayed in the property dialog
DialogFontNameEnabled | Sets whether or not the item used to set the font name is enabled in the property dialog
DialogFontNameVisible | Sets whether or not the item used to set the font name is displayed in the property dialog
DialogFontSizeEnabled | Sets whether or not the item used to set the font size is enabled in the property dialog
DialogFontSizeVisible | Sets whether or not the item used to set the font size is displayed in the property dialog
DialogFontStrikeoutEnabled | Sets whether or not the checkbox used to set strikeout fonts is enabled in the property dialog
DialogFontStrikeoutVisible | Sets whether or not the checkbox used to set strikeout fonts is displayed in the property dialog
DialogFontUnderlineEnabled | Sets whether or not the checkbox used to set underlined fonts is enabled in the property dialog
DialogFontUnderlineVisible | Sets whether or not the checkbox used to set underlined fonts is displayed in the property dialog
DialogForeColor2Enabled | Sets whether or not the item used to set the text gradiation end color is enabled in the property dialog
DialogForeColor2Visible | Sets whether or not the item used to set the text gradiation end color is displayed in the property dialog
DialogForeColorEnabled | Sets whether or not the item used to set the fore color is enabled in the property dialog
DialogForeColorOpacityEnabled | Sets whether or not the item used to set the fore color opacity is enabled in the property dialog
DialogForeColorOpacityVisible | Sets whether or not the item used to set the fore color opacity is displayed in the property dialog
DialogForeColorVisible | Sets whether or not the item used to set the fore color is displayed in the property dialog
DialogHatchStyleEnabled | Sets whether or not to enable the custom brush's "hatch style" setting in the property dialog
DialogHatchStyleVisible | Sets whether or not the custom brush's "hatch style" setting is displayed in the property dialog
DialogImageFileNameEnabled | Sets whether or not the item used to set the image file name is enabled in the property dialog
DialogImageFileNameVisible | Sets whether or not the item used to set the image file name is displayed in the property dialog
DialogLinearGradientModeEnabled | Sets whether or not to enable the "gradation direction" setting for the custom brush's hatch pattern in the property dialog
DialogLinearGradientModeVisible | Sets whether or not the "gradation direction" setting for the custom brush's hatch pattern is displayed in the property dialog
DialogLineJoinEnabled | Sets whether or not the item used to set the line join style is enabled in the property dialog
DialogLineJoinVisible | Sets whether or not the item used to set the line join style is displayed in the property dialog
DialogMaxPenWidth | Sets the maximum pen width (and border) that will be allowed in the property dialog
DialogNotesEnabled | Sets whether or not the item used to set the notes for objects is enabled in the property dialog
DialogNotesVisible | Sets whether or not the item used to set the notes for objects is displayed in the property dialog
DialogPenWidthEnabled | Sets whether or not the item used to set the pen width is enabled in the property dialog
DialogPenWidthVisible | Sets whether or not the item used to set the pen width is displayed in the property dialog
DialogRefinePasteImageEnabled | Sets whether or not the checkbox used to set the "Refine PasteImage" is enabled in the property dialog
DialogRefinePasteImageVisible | Sets whether or not the checkbox used to set "Refine PasteImage" is displayed in the property dialog
DialogRightToLeftEnabled | Sets whether or not the checkbox used to set the "right to left" for text in the Text object is enabled in the property dialog
DialogRightToLeftVisible | Sets whether or not the checkbox used to set the "right to left" for text in the Text object is displayed in the property dialog
DialogRoundRectangleRadiusEnabled | Sets whether or not the item used to set the round rectangle radius for the RoundRectangle and Stamp objects is enabled in the property dialog
DialogRoundRectangleRadiusVisible | Sets whether or not the item used to set the round rectangle radius for the RoundRectangle and Stamp objects is displayed in the property dialog
DialogStartArrowCapEnabled | Sets whether or not the checkbox used to set the start arrow cap is enabled in the property dialog
DialogStartArrowCapFilledEnabled | Sets whether or not the checkbox used to set the start arrow cap filled is enabled in the property dialog
DialogStartArrowCapFilledVisible | Sets whether or not the checkbox used to set the start arrow cap filled is displayed in the property dialog
DialogStartArrowCapSizeEnabled | Sets whether or not the item used to set the start arrow cap size is enabled in the property dialog
DialogStartArrowCapSizeVisible | Sets whether or not the item used to set the start arrow cap size is displayed in the property dialog
DialogStartArrowCapVisible | Sets whether or not the checkbox used to set the start arrow cap is displayed in the property dialog
DialogStartLineCapEnabled | Sets whether or not the item used to set the start line cap style is enabled in the property dialog
DialogStartLineCapVisible | Sets whether or not the item used to set the start line cap style is displayed in the property dialog
DialogTextAlignEnabled | Sets whether or not the item used to set the text alignment for the Stamp object is enabled in the property dialog
DialogTextAlignVisible | Sets whether or not the item used to set the text alignment for the Stamp object is displayed in the property dialog
DialogTextBorderColorEnabled | Sets whether or not the item used to set the text border color is enabled in the property dialog
DialogTextBorderColorVisible | Sets whether or not the item used to set the text border color is displayed in the property dialog
DialogTextBorderWidthEnabled | Sets whether or not the item used to set the text border width is enabled in the property dialog
DialogTextBorderWidthVisible | Sets whether or not the item used to set the text border width is displayed in the property dialog
DialogTextEnabled | Sets whether or not the item used to set the text for the Text and Stamp objects is enabled in the property dialog
DialogTextLinearGradientModeEnabled | Sets whether or not the item used to set the text gradient direction is enabled in the property dialog
DialogTextLinearGradientModeVisible | Sets whether or not the item used to set the text gradient direction is displayed in the property dialog
DialogTextShadowColorEnabled | Sets whether or not the item used to set the text shadow color is enabled in the property dialog
DialogTextShadowColorVisible | Sets whether or not the item used to set the text shadow color is displayed in the property dialog.
DialogTextShadowOffsetEnabled | Sets whether or not the items used to set the text shadow offset are enabled in the property dialog
DialogTextShadowOffsetVisible | Sets whether or not the items used to set the text shadow offset are displayed in the property dialog
DialogTextVisible | Sets whether or not the item used to set the text for the Text and Stamp objects is displayed in the property dialog
DialogVerticalTextEnabled | Sets whether or not the checkbox used to set the vertical text for the Text and Stamp objects is enabled in the property dialog
DialogVerticalTextVisible | Sets whether or not the checkbox used to set the vertical text for the Text and Stamp objects is displayed in the property dialog
DialogWordWrapEnabled | Sets whether or not the checkbox used to set word wrap for the Text and Stamp objects is enabled in the property dialog
DialogWordWrapVisible | Sets whether or not the checkbox used to set word wrap for the Text and Stamp objects is displayed in the property dialog
DoubleLine | Sets whether or not the line in the Line, Polyline, Polygon, or Pen object is a double line
DoubleLineWidth1 | Sets the percentage of the thickness for the first of the double lines
DoubleLineWidth2 | Sets the percentage of the thickness for the second of the double lines
EditByPoint | Sets whether or not each point in a Polyline, Polygon, or Pen object can be edited
EditEnabled | Sets whether or not annotation functions are enabled
EditKind | Sets the kind of annotation object that is used
EditPolylinePointEnabled | Sets whether or not to allow points to be added, inserted, or deleted, in Polyline, Polygons, and Pen objects
EmbedSelectedObjects | Sets whether or not the only the selected objects are embedded (rasterized) into the
EnableTextDialog | Sets whether the text annotation object will display the text object's extended property dialog or the regular property dialog
EndArrowCap | Sets whether or not the end point of a Line or Polyline object has an arrow cap
EndArrowCapFilled | Sets whether or not the end point arrow cap of a Line or Polyline object will be filled
EndArrowCapSize | Sets the size of the end point arrow cap for the Line and Polyline objects
EndLineCap | Sets the style of the end line for the Line, Polyline, and Pen objects
Fill | Sets whether or not the annotation object will be filled with the background color
FontBold | Sets whether or not the font used is bold
FontItalic | Sets whether or not the font used is italics
FontName | Sets the font name used to draw text
FontSize | Sets the font size used to draw text
FontStrikeout | Sets whether or not the font used has strikeout lines
FontUnderline | Sets whether or not the font used is underlined
ForeColor | Sets the drawing color used for all annotation objects
ForeColor2 | Sets the end color used in the text gradient for the Text and Stamp annotation objects
ForeColorOpacity | Sets the drawing color used for all annotation objects
HatchStyle | Sets the hatch style of the custom brush
HideMultiSelectedPoints | Sets whether or not the points that indicate the individual objects within the multiselected area are displayed
HideSelectionBorder | Sets whether or not a "selection border" is hidden when an object is selected
HideTextShadow | Sets whether or not text shadows are hidden
HideTextShadowInEditing | Sets whether or not shadows are hidden when editing objects or drawing Pen, Polygon, and Polyline objects.
ImageFileExtension | When an image file is chosen for an image object and the File Dialog is displayed, this property sets the file type that first appears in the File Dialog
ImageFilePath | When an image file is chosen for an image object and the File Dialog is displayed, this property sets the folder that first appears in the File Dialog
ImeMode | Sets the ImeMode when entering Japanese text. (This property is not needed and may be ignored unless you are using Japanese operating systems)
IsWritingText | Retrieves whether or not text is being entered in a Text or Stamp annotation object
LimitAnnotationPosition | Sets whether or not an annotation object, when drawn, moved, enlarged, rotated, or pasted, is automatically positioned entirely within the image area
LimitDrawPosition | Sets whether or not an annotation object, when drawn, is automatically positioned entirely within the image area
LimitMovePosition | Sets whether or not an annotation object, when moved, is automatically positioned entirely within the image area
LimitPastePosition | Sets whether or not an annotation object, when pasted, is automatically positioned entirely within the image area
LimitRotatePosition | Sets whether or not an annotation object, when rotated, is automatically positioned entirely within the image area
LimitZoomPosition | Sets whether or not an annotation object, when enlarged, is automatically positioned entirely within the image area
LinearGradientMode | Sets the gradient direction for the custom brush when BrushKind is set to LinearGradientBrush
LineJoin | Sets the type of line join for Polyline, Polygon, and Pen objects
MultiResizeMinHeight | Sets the minimum height of the entire selection area when enlarging or reducing the area containing multiple selected objects
MultiResizeMinHeightEachObject | Sets the minimum height of each selected object when enlarging or reducing the area containing multiple selected objects.
MultiResizeMinWidth | Sets the minimum width of the entire selection area when enlarging or reducing the area containing multiple selected objects
MultiResizeMinWidthEachObject | Sets the minimum width of each selected object when enlarging or reducing the area containing multiple selected objects.
MultiSelectedObjectsArray | Retrieves the object numbers from multiple selected objects
MultiSelectedObjectsNumbers | Retrieves the object numbers from multiple selected objects. This property has been replaced by the MultiSelectedObjectsArray property. It is being maintained for backwards compatibility. Please use the MultiSelectedObjectsArray property.
Notes | Sets or retrieves the contents of an object's notes
NumberOfObjects | Retrieves the total number of annotation objects drawn on the image
PastePoint | Sets the top left coordinates of the location where an object will be pasted
PenWidth | Sets the width of the pen used for editing and for annotation objects
RefinePasteImage | Sets whether or not the Image object displays images in high quality
ResizeTextOnCenter | Determines how the text and stamp object's size will change when these objects are resized with the mouse
RightToLeft | Sets whether or not text in the Text and Stamp objects is displayed from right to left
RoundRectangleRadius | Sets the radius for the rounded corners of the RoundRectangle and Stamp objects
SaveAnnotationSelectedObjects | Sets whether or not only selected objects are saved to annotation file
SelectedObjectAngle | Sets the angle of the selected object
SelectedObjectAspectRatio | Sets whether or not the aspect ratio (the ratio of height to width) for the image displayed in the Image object is maintained
SelectedObjectBackColor | Sets the selected object's background color or fill color
SelectedObjectBackColorOpacity | Sets the level of opacity for the selected object's background color or fill color
SelectedObjectBorder | Sets whether or not the selected Text or Stamp object has a border
SelectedObjectBorderColor | Sets the border color of the selected Text or Stamp object
SelectedObjectBorderColorOpacity | Sets the level of opacity for the border color of the selected Text or Stamp object
SelectedObjectBorderShape | Sets the border shape of the selected Stamp annotation object
SelectedObjectBrushKind | Sets the brush type for the custom brush used in the selected object
SelectedObjectClosePenLine | Sets whether or not the selected Pen object's start and end points are connected with a line
SelectedObjectCurveTension | Sets the selected Polyline object's curve tension
SelectedObjectCustomBrushColor1 | Sets the hatch pattern color or the start color for gradation when using the custom brush for the selected object
SelectedObjectCustomBrushColor2 | Sets the hatch pattern color or the end color for gradiation when using the custom brush for the selected object
SelectedObjectCustomBrushImageFileName | Sets the file name for the image used in the custom brush when the BrushKind property is set to TextureBrush in the selected object
SelectedObjectDashPattern | Sets a custom dash line pattern used by a single selected object
SelectedObjectDashStyle | Sets the dash line used by the selected Line, Polyline, Polygon, and Pen objects
SelectedObjectDoubleLine | Sets whether or not the selected Line, Polyline, Polygon, or Pen object is set to double line
SelectedObjectDoubleLineWidth1 | Sets the percentage thickness of the first of the double lines for the selected object
SelectedObjectDoubleLineWidth2 | Sets the percentage thickness of the second of the double lines for the selected object
SelectedObjectDrawPoints | Sets the coordinate points of the selected object
SelectedObjectEndArrowCap | Sets whether or not the end point of a selected Line or Polyline object has an arrow cap
SelectedObjectEndArrowCapFilled | Sets whether or not the end point arrow cap of the selected Line or Polyline object will be filled
SelectedObjectEndArrowCapSize | Sets the size of the end point arrow cap for the selected Line and Polyline objects
SelectedObjectEndLineCap | Sets the style of the end line for the selected Line, Polyline, and Pen objects
SelectedObjectFill | Sets whether or not the selected object is being filled with the background color
SelectedObjectFontBold | Sets whether or not the font for the text of the selected Text or Stamp object is bold
SelectedObjectFontItalic | Sets whether or not the font for the text of the selected Text or Stamp object is italics
SelectedObjectFontName | Sets the font name used by the selected Text or Stamp object
SelectedObjectFontSize | Sets the size of the font used by the selected Text or Stamp object
SelectedObjectFontStrikeout | Sets whether or not the text in the selected Text or Stamp object uses a strikeout
SelectedObjectFontUnderline | Sets whether or not the text in the selected Text or Stamp object uses an underline
SelectedObjectForeColor | Sets the line color or text color of the selected object
SelectedObjectForeColor2 | Sets the end color of the text gradient for single-selected Text and Stamp objects
SelectedObjectForeColorOpacity | Sets the opacity level for the line color or text color of the selected object
SelectedObjectImageFileName | Sets the filename (full path) for the image used in the selected Image object
SelectedObjectHatchStyle | Sets the hatch style of the custom brush in the selected object
SelectedObjectKind | Retrieves the type of the object that is selected
SelectedObjectLinearGradientMode | Sets the gradient direction for the custom brush when BrushKind is set to LinearGradientBrush in the selected object
SelectedObjectLineJoin | Sets the type of line join for the selected Line, Polyline, and Pen objects
SelectedObjectNotes | Sets the content of the note for the selected object
SelectedObjectNumber | Retrieves the number of the selected object
SelectedObjectPenWidth | Sets the width of the lines (the pen width) of the selected object
SelectedObjectRefinePasteImage | Sets whether or not RefinePasteImage is used in the selected Image object
SelectedObjectRightToLeft | Sets whether or not text in the selected Text and Stamp objects is displayed from right to left
SelectedObjectRoundRectangleRadius | Sets the radius for the rounded corners of the selected RoundRectangle and Stamp objects
SelectedObjectStartArrowCap | Sets whether or not the start point of a selected Line or Polyline object has an arrow cap
SelectedObjectStartArrowCapFilled | Sets whether or not the start point arrow cap of the selected Line or Polyline object will be filled
SelectedObjectStartArrowCapSize | Sets the size of the start point arrow cap for the selected Line and Polyline objects
SelectedObjectStartLineCap | Sets the style of the start line for the selected Line, Polyline, and Pen objects
SelectedObjectText | Sets the content of the selected Text or Stamp object
SelectedObjectTextAlign | Sets the alignment for the text in the selected Stamp object
SelectedObjectTextBorderColor | Sets the text border color for single-selected Text and Stamp objects
SelectedObjectTextBorderColorOpacity | Sets the text border opacity for single-selected Text and Stamp objects
SelectedObjectTextBorderWidth | Sets the text border width for single-selected Text and Stamp objects
SelectedObjectTextLinearGradientMode | Sets the direction for the text gradient for single-selected Text and Stamp objects
SelectedObjectTextShadowBlur | Sets the degree of blur for the text shadow for single-selected objects
SelectedObjectTextShadowColor | Sets the text shadow color for single-selected objects
SelectedObjectTextShadowColorOpacity | Sets the percentage of text shadow opacity for single-selected objects
SelectedObjectTextShadowOffsetX | Sets the horizontal offset of text shadows for single-selected objects
SelectedObjectTextShadowOffsetY | Sets the vertical offset of text shadows for single-selected objects
SelectedObjectVerticalText | Sets whether or not the text in the selected Text or Stamp object is vertical text
SelectedObjectWordWrap | Sets whether or not the text in the selected Text or Stamp object has automatic word wrapping enabled
SelectOnClick | Sets whether or not single selection and multiple selection can be switched automatic by clicking or dragging objects with the mouse
SetTextOnInvalidAreaClick | Determines whether or not the text can be set into the Text / Stamp object by clicking in the unused area of the ImageKit control (The area with the hatched pattern outside of the displayed image)
SetTextOnRightClick | Determines whether or not the text can be set into the Text / Stamp object by right-clicking in the text box
ShowDialogOnDoubleClick | Sets whether or not an annotation object's property dialog will be displayed when the object is double clicked
StartArrowCap | Sets whether or not the start point of a Line or Polyline object has an arrow cap
StartArrowCapFilled | Sets whether or not the start point arrow cap of a Line or Polyline object will be filled
StartArrowCapSize | Sets the size of the start point arrow cap for the Line and Polyline objects
StartLineCap | Sets the style of the start line for the Line, Polyline, and Pen objects
Text | Sets the text drawn by the Text or Stamp object
TextAlign | Sets the alignment for the text drawn by the Stamp object
TextBorderColor | Sets the text border color
TextBorderColorOpacity | Sets the opacity for the text border
TextBorderWidth | Sets the width for the text border
TextBoxBackColor | Sets the background color of the text that is input in the Text and Stamp objects
TextBoxForeColor | Sets the color of the text that is input in the Text and Stamp objects
TextLinearGradientMode | Sets the direction for the text gradiation
TextShadowBlur | Sets the level of blur for the text shadow
TextShadowColor | Sets the color of the text shadow
TextShadowColorOpacity | Sets the opacity of the text shadow
TextShadowOffsetX | Sets the horizontal offset for the text shadow
TextShadowOffsetY | Sets the vertical offset for the text shadow
UndoMax | Sets the maximum allowable undo steps for annotation objects
VerticalText | Sets whether or not the text in the Text or Stamp object is vertical text
WordWrap | Sets whether or not word wrapping is used in the Text or Stamp object

Public Methods

ClearAllObjects | Deletes all annotation objects
ClearCopiedObjects | Deletes copied or cut objects from the clipboard
ClearEditHistory | Deletes the history of all drawing and editing changes made to annotation objects
CopySelectedObjects | Copies the selected object(s)
CutSelectedObjects | Cuts the selected object(s)
DelectSelectedObjects | Deletes the selected object(s)
DeleteSelectedObject | Deletes the selected object
DeselectObjects | Deselects all objects that are currently selected
DrawArc | Draws an arc or a fan shape
DrawEditedObjectsToImage | Embeds the annotation objects into a raster image
DrawEllipse | Draws an ellipse
DrawLine | Draws a line
DrawPolygon | Draws a polygon
DrawPolyline | Draws a polyline
DrawRectangle | Draws a rectangle
DrawRoundRectangle | Draws a round rectangle
DrawStamp | Overloaded method list. These methods draw a Stamp object. See DrawStamp(Point) and DrawStamp(RectangleF)
DrawText | Overloaded method list. These methods draw a Text object. See DrawText(Point) and DrawText(RectangleF)
LoadAnnotationFile | Loads annotation information from an existing annotation file and displays the annotation objects on the base image
MoveBackOne | Moves the selected object's Z-Order back one
MoveForwardOne | Moves the selected object's Z-Order forward one
MoveToBack | Moves the selected object to the back
MoveToFront | Moves the selected object to the front
PasteCopiedObjects | Pastes objects that have been copied
PasteImage | Creates an Image object and displays the specified image
Redo | Reverses an undo step
SaveAnnotationFile | Saves the annotation information to the annotation file
SelectAllObjects | Selects or deselects all of the annotation objects drawn
SelectMultiObjects | Selects multiple objects whose numbers are specified
SelectObject | Selects the object whose number is specified
ShowPropertyDialog | Displays a dialog that allows the properties of the selected annotation object to be changed
Undo | Removes the last change to the annotation object and returns it to its previous state

See Also

Newtone.ImageKit.Win.ImageKit


AdjustIKN2AnnotationElements property

Newtone.ImageKit.Win.ImageKit.Edit.AdjustIKN2AnnotationElements Property

This property sets whether or not an annotation file created by the ImageKit.NET2 will be adjusted when it is loaded into the ImageKit.NET3. There are differences in the font size units of Text objects.

[Visual Basic] Public Property AdjustIKN2AnnotationElements As Boolean
[C#] public bool AdjustIKN2AnnotationElements {get; set;}

Property Value

True: Automatically adjusts Text object font size.

False: Does not adjust Text object font size.

Default value is False

Explanation

The AdjustIKN2AnnotationElements property sets whether or not an annotation file created by the ImageKit.NET2 will be adjusted when it is loaded into the ImageKit.NET3. There are differences in the font size units of Text objects.

Annotation files created by the ImageKit.NET2 use points as the unit for font size in Text objects. When these annotation files are loaded into the ImageKit.NET3, the size of the text appears different because the ImageKit.NET3 Text objects uses pixel units for font size. When the AdjustIKN2AnnotationElements property is True, the appearance of the fonts in the Text object will be adjusted so that they look the same in the ImageKit.NET3 as in the ImageKit.NET2.

Note: The Annotation file's content will not be altered by this property. Only the appearance is adjusted when the annotation file is loaded into the ImageKit.NET3

Adjustments made to an annotation file outside of the ImageKit may not be altered by this property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


AnnotationFileName property

Newtone.ImageKit.Win.ImageKit.Edit.AnnotationFileName Property

This property sets the name of the file that holds the annotation information.

[Visual Basic] Public Property AnnotationFileName As String
[C#] public string AnnotationFileName {get; set;}

Property Value

The file name (full path)

Explanation

The AnnotationFileName property sets the name of the annotation file, which holds the annotation information. This file is used when executing the SaveAnnotationFile method or the LoadAnnotationFile method.

Although the annotation file is in xml format, any file extention may be used in the file name.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


AntiAlias property

Newtone.ImageKit.Win.ImageKit.Edit.AntiAlias Property

This property sets whether or not antialias smoothing is applied to the edges of objects. (Not applicable to the PasteImage object).

[Visual Basic] Public Property AntiAlias As Boolean
[C#] public bool AntiAlias {get; set;}

Property Value

True: AntiAlias is applied to all objects (except the PasteImage object)

False: AntiAlias is NOT applied.

Default value is False

Explanation

The AntiAlias propertysets whether or not antialias smoothing is applied to the edges of objects. (Not applicable to the PasteImage object).

Set this property to True to smooth the edges of angled rectangles, rounded rectangles, text / stamp objects with fills and borders, and diagonal parts of pens, polygons, multiple lines, and ellipse objects. WHen True, those jagged edges will be displayed more smoothly. However, smoothed edges may appear to be slightly blurred, so please set it according to the situation.

To smooth PasteImage objects, please use the RefinePasteImage property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


AspectRatio property

Newtone.ImageKit.Win.ImageKit.Edit.AspectRatio Property

This property sets whether or not an Image annotation object, when pasted or altered, will maintain the aspect ratio of the original image and whether or not a Rectangle, RoundRectangle and Ellipse annotation object, when altered, will maintain its aspect ratio.

[Visual Basic] Public Property AspectRatio As Boolean
[C#] public bool AspectRatio {get; set;}

Property Value

True: The object's aspect ratio or the aspect ratio of the image will be maintained
False: The image can be pasted or resized without regard to the aspect ratio
The default value is True

Explanation

The AspectRatio property sets whether or not certain annotation objects maintain their aspect ratio (height/width) when they are being resized. The annotation objects that are affected by the AspectRatio property are the Rectangle, RoundRectangle, and Ellipse objects. The AspectRatio property also sets whether or not an image being loaded into an Image annotation will maintain its aspect ratio.

How the AspectRatio property affects the annotation object depends on which object it applies to.

Rectangle, RoundRectangle, and Ellipse annotation objects:
When the AspectRatio property is true and the Rectangle, RoundRectangle, or Ellipse annotation objects are being resized, by pressing down the shift key while resizing the object with the mouse, the aspect ratio will be maintained. If the shift button is not pressed down, the aspect ratio is not maintained.

When the AspectRatio property is false and the Rectangle, RoundRectangle, or Ellipse annotation objects are being resized, by pressing down the shift key while resizing the object with the mouse, the aspect ratio will be 1:1. If the shift button is not pressed down, the aspect ratio is not maintained.

Image object
When the AspectRatio property is true and an Image annotation object is placed on the ImageKit control, the image loaded into the Image annotation object will keep its aspect ratio. In other words, the image will be "scaled" to fit within the image annotation object. When the AspectRatio property is false and an image annotation object is placed on the ImageKit control, the image will be stretched to fill the entire image annotation object. The image's original aspect ratio will not be maintained.

When an Image annotation object is resized using the mouse, the AspectRatio property has no affect. It is the SelectedObjectAspectRatio property that determines if the image's original aspect ratio will be maintained when the Image annotation object is being resized. When the SelectedObjectAspectRatio property is true and the image is resized using the mouse, the image's original aspect ratio will be maintained while it is being resized. When the SelectedObjectAspectRatio property is false and the image annotation object is being resized using the mouse, then the image object's aspect ratio will be 1:1.

To make changes to the aspect ratio after the object has been drawn, right click on the object to display the context menu or execute the ShowPropertyDialog method to display the property dialog.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


BackColor property

Newtone.ImageKit.Win.ImageKit.Edit.BackColor Property

This property sets the background color or fill color used by annotation objects or when editing.

[Visual Basic] Public Property BackColor As Color
[C#] public Color BackColor {get; set;}

Property Value

Value of type Color

Default value is White

Explanation

The BackColor property sets the background color or fill color used by annotation objects or when editing.

The BackColor property is enabled when the Fill property is true and becomes the fill color for the Rectangle, RoundRectangle, Ellipse, Polygon, and closed Pen objects and the background color for the Text object. This property is not used for the Line, Polyline, non-closed Pen, or Image objects.

To make changes to an object's back color after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or use the SelectedObjectBackColor property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


BackColorOpacity property

Newtone.ImageKit.Win.ImageKit.Edit.BackColorOpacity Property

This property sets the level of opacity for the background color or fill color used by annotation objects and when editing.

[Visual Basic] Public Property BackColorOpacity As Integer
[C#] public int BackColorOpacity {get; set;}

Property Value

Level of opacity

Default value is 100

Explanation

The BackColorOpacity property sets the level of opacity for the background color or fill color used by annotation objects and when editing.

The BackColorOpacity property is enabled when the Fill property is true and sets the opacity level for the fill color in the Rectangle, RoundRectangle, Ellipse, Polygon, and closed Pen objects and for the background color in the Text and Stamp objects. This property is not used for the Line, Polyline, non-closed Pen, or Image objects.

The value ranges from 0 to 100. As the value increases, opacity increases. 0 represents complete transparency, 100 represents complete opacity. Values less than 0 will be set to 0. Values greater than 100 will be set to 100.

To make changes to an object's back color opacity after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectBackColorOpacity property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


Border property

Newtone.ImageKit.Win.ImageKit.Edit.Border Property

This property sets whether or not a border is added to the Text or Stamp annotation objects.

[Visual Basic] Public Property Border As Boolean
[C#] public bool Border {get; set;}

Property Value

True: A border is added to the Text and Stamp annotation objects

False: A border is NOT added to thet Text and Stamp annotation objects

Default value is False

Explanation

The Border property sets whether or not a border is added to the Text and Stamp annotation objects.

When this property is True, and a Text or Stamp object is drawn, a border will be drawn around the object. The border color is determined by the BorderColor property and the border width is determined by the PenWidth property.

The Border property is only enabled for Text and Stamp annotation objects.

To make changes to the border after it is drawn around an object, right click on the object to display the context menu, execute the ShowPropertyDialog method to display the property dialog, or use the SelectedObjectBorder property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


BorderColor property

Newtone.ImageKit.Win.ImageKit.Edit.BorderColor Property

This property sets the border color used by the Text and Stamp annotation objects.

[Visual Basic] Public Property BorderColor As Color
[C#] public Color BorderColor {get; set;}

Property Value

Value of type Color

Default value is Black

Explanation

The BorderColor property sets the border color used by the Text and Stamp annotation objects.

This property is enabled when the Border property is True. It is enabled only for the Text and Stamp objects. It is disabled for all other annotation objects.

To make changes to the border color after it is drawn, right click on the Text or Stamp object to display the context menu, execute the ShowPropertyDialog method to display the property dialog, or set the SelectedObjectBorderColor property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


BorderColorOpacity property

Newtone.ImageKit.Win.ImageKit.Edit.BorderColorOpacity Property

This property sets the level of opacity for the border color of the Text and Stamp annotation objects.

[Visual Basic] Public Property BorderColorOpacity As Integer
[C#] public int BorderColorOpacity {get; set;}

Property Value

Level of opacity

Default value is 100

Explanation

The BorderColorOpacity property sets the level of opacity for the border color of the Text and Stamp annotation objects. It is disabled for all other annotation objects.

The BorderColorOpacity property is enabled when the Border property is true.

The value ranges from 0 to 100. As the value increases, opacity increases. 0 represents complete transparency, 100 represents complete opacity. Values less than 0 will be set to 0. Values greater than 100 will be set to 100.

To make changes to an object's border color opacity after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectBorderColorOpacity property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


BorderShape property

Newtone.ImageKit.Win.ImageKit.Edit.BorderShape Property

This property sets the shape of the border for the Stamp annotation object.

[Visual Basic] Public Property BorderShape As Shape
[C#] public Shape BorderShape {get; set;}

Property Value

Value of type Shape

Default value is Shape.RoundRectangle.

Explanation

The BorderShape property sets the shape of the border for the Stamp annotation object.

This property is enabled when the Border property is True. It is enabled only for Stamp object.

To make changes to the border shape after the Stamp object is drawn, right click on the Stamp object to display the context menu, execute the ShowPropertyDialog method to display the property dialog, or set the SelectedObjectBorderShape property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


BrushKind property

Newtone.ImageKit.Win.ImageKit.Edit.BrushKind Property

This property sets the type of brush used for the custom brush.

[Visual Basic] Public Property BrushKind As KindOfBrush
[C#] public BrushOfKind BrushKind {get; set;}

Property Value

A value of type KindOfBrush

Default value is KindOfBrush.Solid

Explanation

The BrushKind property sets the type of brush used for the custom brush.

When this property is KindOfBrush.Solid, the solid color used is the color set in the BackColor property.

For details on the custom brush, refer to the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


CanDeselectAllSelect property

Newtone.ImageKit.Win.ImageKit.Edit.CanDeselectAllSelect Property

This property sets whether or not a mouse click or mouse drag can remove the "AllSelect" state from a group of annotation objects.

[Visual Basic] Public Property CanDeselectAllSelect As Boolean
[C#] public bool CanDeselectAllSelect {get; set;}

Property Value

True: Mouse click or mouse drag will remove the "All Selected" state

False: Executing the DeselectObjects or executing SelectAllObjects method a second time the will remove the "All Selected" state.

Default value is False.

Explanation

The CanDeselectAllSelect property sets whether or not a mouse click or mouse drag can remove the "AllSelect" state from the group of annotation objects.

When using MultiSelect (KindOfEdit.MultiSelect) and choosing "SelectAll" from the ToolBarAnnotation or from the context menu, all annotation objects will be selected. All annotation objects can also be selected by executing the SelectAllObjects method. When this happens, the annotation objects are in an "All Selected" state and a mouse click or mouse drag affects all objects. To remove the "All Selected" state, you must execute the DeselectObjects or executing SelectAllObjects method a second time.

However, when the CanDeselectAllSelect property is True, a mouse click or a mouse drag will remove the "AllSelect" state from the group of annotation objects.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


CanRedoCount property

Newtone.ImageKit.Win.ImageKit.Edit.CanRedoCount Property

This property retrieves the number of "Redo" steps that an annotation object has available.

[Visual Basic] Public Property CanRedoCount As Integer
[C#] public int CanRedoCount {get;}

Property Value

The number of available "redo" steps. Value of type Integer

Default value is 0.

Explanation

The CanRedoCount property retrieves the number of "redo" steps that are availabe to an annotation object. A "redo" reverses an "undo" that has been made to an annotation object. When changes are made to an annotation object, the changes are saved in the order that they are made. An "undo" step will reverse a change that has been made. A "redo" step will reverse the "undo" step. By using "Undo" and "Redo" steps, you can move through the changes that have been made to an annotation object.

The maximum allowable "redo" steps is determined by the UndoMax property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


CanUndoCount property

Newtone.ImageKit.Win.ImageKit.Edit.CanUndoCount Property

This property retrieves the number of "Undo" steps that an annotation object has available.

[Visual Basic] Public Property CanUndoCount As Integer
[C#] public int CanUndoCount {get;}

Property Value

The number of available "undo" steps. Value of type Integer

Default value is 0.

Explanation

The CanUndoCount property retrieves the number of "undo" steps that are availabe to an annotation object. An "undo" removes a change made to an annotation object. Undo step are made in order of the changes from the newest change to the oldest change. When changes are made to an annotation object, the changes are saved in the order that they are made. An "undo" step will reverse a change that has been made. A "redo" step will reverse the "undo" step. By using "Undo" and "Redo" steps, you can move through the changes that have been made to an annotation object.

The maximum allowable "undo" steps is determined by the UndoMax property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


ClosePenLine property

Newtone.ImageKit.Win.ImageKit.Edit.ClosePenLine Property

This property sets whether or not, when drawing with a Pen object, the start point and end point are connected with a line.

[Visual Basic] Public Property ClosePenLine As Boolean
[C#] public bool ClosePenLine {get; set;}

Property Value

True: The start and end points are connected

False: The start and end points are not connected

Default value is False

Explanation

The ClosePenLine property sets whether or not, when drawing with the Pen object, the start point and end point are connected with a line. When drawing with a mouse drag, the line connecting the start and end points will be drawn when the mouse is released. The ClosePenLine property is only enabled for the Pen object.

When the ClosePenLine property is true and the Fill property is true, the closed pen line will be filled with the color set in the BackColor property at the opacity level set by the BackColorOpacity property.

To make changes to this property after it is drawn, right click on the Pen object to display the context menu, execute the ShowPropertyDialog method to display the property dialog, or set the SelectedObjectClosePenLine property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


ContextMenuEnable property

Newtone.ImageKit.Win.ImageKit.Edit.ContextMenuEnable Property

This property sets whether or not the context menu is enabled when editing and an annotation object is right clicked.

[Visual Basic] Public Property ContextMenuEnable As Boolean
[C#] public bool ContextMenuEnable {get; set;}

Property Value

True: Right clicking displays the ImageKit standard context menu

False Right clicking does not display the ImageKit standard context menu

Default value is True

Explanation

The ContextMenuEnable property sets whether or not the context menu is enabled when editing and an annotation object is right clicked.

When the ContextMenuEnable property is True, right clicking on the annotation object displays the ImageKit standard context menu. This context menu allows a variety of functions to be performed. When the ContextMenuEnable property is False, the ImageKit standard context menu is disabled. This is useful if you want to create your own custom context menu, which you set into the ImageKit control using the ContextMenuStrip property.

The following functions can be performed using the ImageKit control's standard context menu:

Select All / Delete All: All drawn objects can be selected / deleted. This is enabled when the EditKind property is set to KindOfEdit.MultiSelect.

Delete: Single selected objects, multiple selected objects, and all objects can be deleted. This is enabled when the EditKind property is set to KindOfEdit.Select or to KindOfEdit.MultiSelect and at least one object has been selected.

Cut: Single selected objects, multiple selected objects, and all objects can be cut. This is enabled when the EditKind property is set to KindOfEdit.Select or to KindOfEdit.MultiSelect and at least one object has been selected.

Copy: Single selected objects, multiple selected objects, and all objects can be copied. This is enabled when the EditKind property is set to KindOfEdit.Select or to KindOfEdit.MultiSelect and at least one object has been selected.

Paste: Any objects that have been cut or copied can be pasted. This is enabled when the EditKind property is set to KindOfEdit.Select or to KindOfEdit.MultiSelect and at least one object has been copied. Note that the location of the right-click that caused the context menu to be displayed is the location where the objects will be pasted.

MoveForwardOne: Moves the selected object's Z-Order value forward one. This is enabled when the EditKind property is set to KindOfEdit.Select.

MoveBackOne: Moves the selected object's Z-Order value back one. This is enabled when the EditKind property is set to KindOfEdit.Select.

MoveToFront: Moves the selected object to the front (changes the object's Z-Order value to be the largest value). This is enabled when the EditKind property is set to KindOfEdit.Select.

MoveToBack: Moves the selected object to the back (changes the object's Z-Order value to be the smallest value). This is enabled when the EditKind property is set to KindOfEdit.Select.

Undo: Removes the last change to an annotation object and returns it to the previous state prior to the change. This is enabled when the UndoMax property has a value set.

Redo: Removes the last undo step returning the annotation object to the state prior to the last Undo. This is enabled for the number of undo steps that have occurred.

Properties: Displays a dialog that allows the selected object's properties to be changed. This is enabled when the EditKind property is set to KindOfEdit.Select.

Annotations can still be made even though the ContextMenuEnable property is False and right clicking does not display the context menu.
This can be done with the following methods:

SelectAllObjects
DeleteSelectedObject
DeleteMultiSelectedObjects
CopySelectedObjects
CutSelectedObjects
PasteCopiedObjects
MoveForwardOne
MoveBackOne
MoveToFront
MoveToBack
Undo
Redo
ShowPropertyDialog

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


CopiedObjectsExists property

Newtone.ImageKit.Win.ImageKit.Edit.CopiedObjectsExists Property

This property retrieves whether or not a copied or cut object exists.

[Visual Basic] Public ReadOnly Property CopiedObjectsExists As Boolean
[C#] public bool CopiedObjectsExists {get;}

Property Value

True: A copied or cut object exists

False: A copied or cut object does not exist

Explanation

The CopiedObjectsExists property retrieves whether or not a copied or cut object exists.

This property can be used to confirm if copied objects exist in the clipboard before executing the ClearCopiedObjects method.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


CurveTension property

Newtone.ImageKit.Win.ImageKit.Edit.CurveTension Property

This property sets the curve tension when drawing a curve using a Polyline object.

[Visual Basic] Public Property CurveTension As Integer
[C#] public int CurveTension {get; set;}

Property Value

Integer value indicating curve tension

Default value is 0

Explanation

The CurveTension property sets the curve tension when drawing a curve using a polyline object. Use the tension specified in this property to draw a cardinal spline curve that passes through an array of Point structures that make up the Polyline objects.

The curve tension has 10 steps from 1 to 10. The higher the number, the looser the bend. If set to 0, it will not be curved, but a polyline consisting of continuous straight lines. If the value is less than 0, then the CurveTension property will be set to 0. If the value is 11 or more, the CurveTension property value will be set to 10.

To make changes to an object's curve tension after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectCurveTension property.

* It is not possible to set a detailed bends for each point, by using a combination of the EditByPoint and EditPolylinePointEnabled properties, some curve fine-tuning is possible.

Example

CurveTension = 0 CurveTension = 3 CurveTension = 6 CurveTension = 10

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


CustomBrushColor1 property

Newtone.ImageKit.Win.ImageKit.Edit.CustomBrushColor1 Property

This property sets the hatch pattern color or the start color for gradation when using the custom brush.

[Visual Basic] Public Property CustomBrushColor1 As System.Drawing.Color
[C#] public System.Drawing.Color CustomBrushColor1 {get; set;}

Property Value

Value of type System.Drawing.Color

Default value is System.Drawing.Color.Black

Explanation

The CustomBrushColor1 property sets the hatch pattern color when using BrushOfKind.HatchBrush. It also sets the start color for gradation when using the BrushOfKind.LinearGradientBrush.

To use a transparent color, set this property to Color.Transparent. It is also possible to use a partially transparent color by setting an alpha value using the System.Drawing.Color.FromArgb method.

For details on the custom brush, refer to the CustomBrushEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


CustomBrushColor2 property

Newtone.ImageKit.Win.ImageKit.Edit.CustomBrushColor2 Property

This property sets the hatch pattern background color or the end color for gradation when using the custom brush.

[Visual Basic] Public Property CustomBrushColor2 As System.Drawing.Color
[C#] public System.Drawing.Color CustomBrushColor2 {get; set;}

Property Value

Value of type System.Drawing.Color

Default value is System.Drawing.Color.White

Explanation

The CustomBrushColor2 property sets the hatch pattern background color when using BrushOfKind.HatchBrush. It also sets the end color for gradation when using the BrushOfKind.LinearGradientBrush.

To use a transparent color, set this property to Color.Transparent. It is also possible to use a partially transparent color by setting an alpha value using the System.Drawing.Color.FromArgb method.

For details on the custom brush, refer to the CustomBrushEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


CustomBrushEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.CustomBrushEnabled Property

This property sets whether or not the custom brush is enabled.

[Visual Basic] Public Property CustomBrushEnabled As Boolean
[C#] public bool CustomBrushEnabled {get; set;}

Property Value

True: The custom brush is enabled

False: The custom brush is not enabled

Default value is False

Explanation

The CustomBrushEnabled property sets whether or not the custom brush is enabled.

To enable the custom brush, set this property and the Fill property to True.

By setting this property to True, not only is the custom brush enabled for drawing, but the custom brush can be saved into an annotation file and loaded from an annotation file. Even if the object is drawn and read with CustomBrushEnabled property set to True, if it is set to False after drawing and reading, the object will be displayed with a solid fill pattern set by the BackColor property. However, setting the CustomBrushEnabled property to True again will enable the custom fill to be displayed.

Even when CustomBrushEnabled property is set to False and drawing or loading is done, it is possible to change the brush to a custom brush by selectng the object and using the object's property dialog and related properties displayed by setting the DialogCustomBrushVisible property to True.

Note: If you want to mix custom brush and solid brush, please set CustomBrushEnabled property to True and set the solid brush with BrushKind property.

The specifications of the custom brush function are as follows.

  • The objects that can use the custom brush are Rectangle, RoundRectangle, Ellipse, Text, Stamp, Polygon, and Pen (when ClosePenLine = True) objects for which the Fill property is valid.
  • The fill pattern is determined by the brushes set in the BrushKind property and the other property settings required for each brush.
    • For a solid brush, set the BrushKind property to a value of type System.Drawing.SolidBrush and set the BackColor property.
    • For a hatch brush, set the BrushKind property to a value of type System.Drawing.Drawing2D.HatchBrush and set the HatchStyle, CustomBrushColor1, and CustomBrushColor2 properties.
    • For a 2 color gradient brush, set the BrushKind property to a value of type System.Drawing.Drawing2D.LinearGradientBrush and set the CustomBrushColor1, CustomBrushColor2, and LinearGradientMode properties.
    • For a texture brush, set the BrushKind property to a value of type System.Drawing.TextureBrush and set the CustomBrushImageFileName property.
      Note: If each setting is not correct, it will not cause an error but there will be a solid fill using the System.Drawing.SolidBrush and BackColor property value.
  • It is not possible to set individual elements of HatchBrush such as line thickness, spacing, angle and pattern. (Only the default pattern of the System.Drawing.Drawing2D.HatchStyle enumeration are possible). In addition, the position and angle of the hatch pattern are not changed even if you move, rotate or resize the object filled with the hatch pattern.

    • Setting Value | Drawing example: Horizontal / Rotated
BrushKind = KindOfBrush.HatchBrush HatchStyle = HatchStyle.Cross CustomBrushColor1 = Color.Red CustomBrushColor2 = Color.Transparent | When rotated, the hatch pattern angle does not change. When the object size and position is changed, the hatch pattern size and interval spacing doesn't change.

  • The LinearGradientBrush is a two-color gradation display that matches the display range of each object, and the display changes according to the display scale of the ImageKit control and the size and position of the object. When an object is rotated, except for the Polygon and Pen objects whose gradation will not change, the direction of gradation is also rotated according to the rotation angle. This is bBecause Polygon and Pen objects are drawn by the coordinates of each point that constitutes them, and there is no angle of rotation. When Polygon and Pen objects are moved, rotated, or resized, the object will be filled with a solid color determined by the CustomBrushColor1 property.

    • Setting Value | Drawing example: Horizontal / Rotated
BrushKind = KindOfBrush.LinearGradientBrush HatchStyle = HatchStyle.Cross CustomBrushColor1 = Color.Red CustomBrushColor2 = Color.Blue LinearGradientMode = LinearGradientMode.Horizontal | For a rectangle object: The gradation angle changes according to the object's angle of rotation Changing the object's size and position changes the gradation. For a polygon object: Object rotation does not change gradation

  • The background image of TextureBrush is set using the CustomBrushImageFileName property. This background image is displayed in actual size (tiled) from the top left corner of the ImageKit control and therefore if the object is moved are resized, the background image of the TextureBrush does not change. When the object is rotated, the angle of the background image is not changed even if it is rotated as in the case of the Polygon and Pen objects, and the background image is also rotated according to the rotation angle in the case of other objects. (This is because Polygon and Pen objects are drawn by the coordinates of each point that constitutes them, and there is no "angle".)

    • Setting Value | Drawing example: Horizontal / Rotated
BrushKind = KindOfBrush.TextureBrush CustomBrushImageFileName = "arrow1.png" arrow1.png | For a rectangle object: The angle of the background image changes according to the angle of rotation of the object When the object's size and position change the size of the background image and its position does not change. For a polygon object: The angle of the background image does not change when the object is rotated.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


CustomBrushImageFileName property

Newtone.ImageKit.Win.ImageKit.Edit.CustomBrushImageFileName Property

This property sets the file name for the image used in the custom brush when the BrushKind property is set to TextureBrush.

[Visual Basic] Public Property CustomBrushImageFileName As String
[C#] public string CustomBrushImageFileName {get; set;}

Property Value

Value of type String

Default value is ""

Explanation

The CustomBrushImageFileName property sets the file name for the image used in the custom brush when the BrushKind property is set to TextureBrush.

For details, please refer to the CustomBrushEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


CustomDialog property

Newtone.ImageKit.Win.ImageKit.Edit.CustomDialog Property

This property allows you to display a custom property dialog.

[Visual Basic] Public Property CustomDialog As System.Windows.Forms.Form
[C#] public System.Windows.Forms.Form CustomDialog {get; set;}

Property Value

Value of type System.Windows.Forms.Form

Default value is Nothing (null)

Explanation

The CustomDialog property allows you to display a custom property dialog. By setting the CustomDialog property, the ImageKit standard property dialog will be disabled and your custom property dialog will be used. To display the ImageKit standard property dialog, set CustomDialog property to Nothing (null)

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DashPattern property

Newtone.ImageKit.Win.ImageKit.Edit.DashPattern Property

This property sets a custom dash pattern for straight lines, polylines, polygons, and pen objects.

[Visual Basic] Public Property DashPattern As Single()
[C#] public float[] DashPattern {get; set;}

Property Value

An array indicating the length of the dashed lines and blanks

The default value is {2.0F, 1.0F}.

Explanation

The DashStyle property sets a custom dash pattern for straight lines, polylines, polygons, and pen objects. When the DashStyle property is System.Drawing.Drawing2D.DashStyle.Custom, the dashed line pattern set in this property is valid.

The property is represented by the length relative to the line thickness, and the values are "first length, spacing, second length, next spacing ...".

* Example of setting the broken line of the pattern [---- --- ---] in (c #): ImageKit1.Edit.DashPattern = new float [] {2.0F, 1.0F, 2.0F, 1.0F, 2.0F, 2.0F};

The SelectedObjectDashPattern property allows you to change it even after drawing.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DashStyle property

Newtone.ImageKit.Win.ImageKit.Edit.DashStyle Property

This property sets the style of the dash line used by the Line, Polyline, Polygon, and Pen objects.

[Visual Basic] Public Property DashStyle As System.Drawing.Drawing2D.DashStyle
[C#] public System.Drawing.Drawing2D.DashStyle DashStyle {get; set;}

Property Value

Value of type System.Drawing.Drawing2D.DashStyle

Default value is System.Drawing.Drawing2D.DashStyle.Solid

Explanation

The DashStyle property sets the style of the dash line used by the Line, Polyline, Polygon, and Pen objects.

To change the dash style after the object has been drawn, right click on the selected object to display the context menu, execute the ShowPropertyDialog method, or set the SelectedObjectDashStyle property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DeleteEmbededObjects property

Newtone.ImageKit.Win.ImageKit.Edit.DeleteEmbededObjects Property

This property sets whether or not, after embedding annotation objects into the image, those annotation objects will be deleted or will be kept.

[Visual Basic] Public Property DeleteEmbededObjects As Boolean
[C#] public bool DeleteEmbededObjects {get; set;}

Property Value

True: After embedding, the annotation objects will be deleted

False: After embedding, the annotation objects will be kept

Explanation

The DeleteEmbededObjects property sets whether or not, after embedding annotation objects into the image, those annotation objects will be deleted or will be kept.

Annotation objects can be embedded (rasterized) into the image by clicking the "Embed Annotations" button in the ToolBar or by executing the DrawEditedObjectsToImage method.

When the DeleteEmbededObjects property is True, after annotation objects have been embedded into the image, those annotation objects are cleared and are not kept. This can be inconvenient if the annotation objects are still needed or if you want to save those annotation objects to annotation file.

When the DeleteEmbededObjects property is False, after annotation objects have been embedded into the image, those annotation objects are not cleared. They are kept and displayed on the image. This allows the objects to be moved, changed, saved to annotation file, etc.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DesignedTextEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DesignedTextEnabled Property

This property sets whether or not custom designed text functions are enabled.

[Visual Basic] Public Property DesignedTextEnabled As Boolean
[C#] public bool DesignedTextEnabled {get; set;}

Property Value

True: Designed text functions are enabled

False: Designed text functions are not enabled

Default value is False

Explanation

The DesignedTextEnabled property sets whether or not designed text functions are enabled.

When this property is True, it is possible to draw bordered text, shadowed text, or gradient text depending on the values of the relevant properties.

This feature is applicable to both text objects and stamp objects. By adjusting the values of the following properties, you can draw bordered text, shadowed text, and text with gradient colors.

Border-related properties: TextBorderColor, TextBorderColorOpacity, TextBorderWidth
Gradient-related properties: ForeColor2, TextLinearGradientMode
Shadow-related properties: TextShadowBlur, TextShadowColor, TextShadowColorOpacity, TextShadowOffsetX, TextShadowOffsetY

Elements of the text's design (such as borders, shadows, gradations) can be edited after they have been drawn by selecting the target object. In addition, text design related information can be saved and read from annotation files.

In the case of text with shadows, during object editing or operations involving drawing multiple lines, polygons, or pen objects, the display will be simplified (such as the shadow blur being removed) to prevent performance degradation. (The display will return to normal once the operation is completed.)

Custom Designed Text Example:

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogAngleEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogAngleEnabled Property

This property sets whether or not the textbox used to set the angle for the Text object is enabled in the Text object's property dialog.

[Visual Basic] Public Property DialogAngleEnabled As Boolean
[C#] public bool DialogAngleEnabled {get; set;}

Property Value

True: The textbox to set the Text object's "angle" is enabled

False: The textbox to set the Text object's "angle" is not enabled

Default value is True

Explanation

The DialogAngleEnabled property sets whether or not the textbox used to set the angle for the Text object is enabled in the Text object's property dialog.

When this property is false, the textbox used to set the angle is disabled and cannot be set.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogAngleVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogAngleVisible Property

This property sets whether or not the textbox used to set the angle for the Text object is displayed in the Text object's property dialog.

[Visual Basic] Public Property DialogAngleVisible As Boolean
[C#] public bool DialogAngleVisible {get; set;}

Property Value

True: The textbox to set the Text object's "angle" is displayed

False: The textbox to set the Text object's "angle" is not displayed

Default value is True

Explanation

The DialogAngleVisible property sets whether or not the textbox used to set the angle for the Text object is displayed in the Text object's property dialog.

When this property is false, the textbox used to set the angle is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogAspectRatioEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogAspectRatioEnabled Property

This property sets whether or not the "Maintain Aspect Ratio" checkbox is enabled in the property dialog.

[Visual Basic] Public Property DialogAspectRatioEnabled As Boolean
[C#] public bool DialogAspectRatioEnabled {get; set;}

Property Value

True: The "Maintain Aspect Ratio" checkbox is enabled

False: The "Maintain Aspect Ratio" checkbox is disabled

Default value is True

Explanation

The DialogAspectRatioEnabled property sets whether or not the "Maintain Aspect Ratio" checkbox is enabled in the property dialog.

When this property is False, the "Maintain Aspect Ratio" checkbox is disabled and cannot be set. This property is only enabled for Image objects that have been selected.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogAspectRatioVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogAspectRatioVisible Property

This property sets whether or not the "Maintain Aspect Ratio" checkbox is displayed in the property dialog.

[Visual Basic] Public Property DialogAspectRatioVisible As Boolean
[C#] public bool DialogAspectRatioVisible {get; set;}

Property Value

True: The "Maintain Aspect Ratio" checkbox is displayed

False: The "Maintain Aspect Ratio" checkbox is not displayed

Default value is True

Explanation

The DialogAspectRatioVisible property sets whether or not the "Maintain Aspect Ratio" checkbox is displayed in the property dialog.

When this property is False, the "Maintain Aspect Ratio" checkbox is not displayed. This property is only enabled for Image objects that have been selected.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogBackColorEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogBackColorEnabled Property

This property sets whether or not the item used to set the back color is enabled in the property dialog.

[Visual Basic] Public Property DialogBackColorEnabled As Boolean
[C#] public bool DialogBackColorEnabled {get; set;}

Property Value

True: The item used to set the back color is enabled

False: The item used to set the back color is disabled

Default value is True

Explanation

The DialogBackColorEnabled property sets whether or not the item used to set the back color is enabled in the property dialog.

When this property is false, the item used to set the back color is disabled and cannot be set.

When the selected object is a Line, Polyline, or Pen object, even if the DialogBackColorEnabled property is True, the "Back Color" item is disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogBackColorOpacityEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogBackColorOpacityEnabled Property

This property sets whether or not the item used to set the back color opacity is enabled in the property dialog.

[Visual Basic] Public Property DialogBackColorOpacityEnabled As Boolean
[C#] public bool DialogBackColorOpacityEnabled {get; set;}

Property Value

True: The item used to set the back color opacity is enabled

False: The item used to set the back color opacity is disabled

Default value is True

Explanation

The DialogBackColorOpacityEnabled property sets whether or not the item used to set the back color opacity is enabled in the property dialog.

When this property is false, the item used to set the back color opacity is disabled and cannot be set.

When the selected object is a Line, Polyline, or Pen object, even if the DialogBackColorOpacityEnabled property is True, the "Back Color Opacity" item is disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogBackColorOpacityVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogBackColorOpacityVisible Property

This property sets whether or not the item used to set the back color opacity is displayed in the property dialog.

[Visual Basic] Public Property DialogBackColorOpacityVisible As Boolean
[C#] public bool DialogBackColorOpacityVisible {get; set;}

Property Value

True: The item used to set the back color opacity is displayed

False: The item used to set the back color opacity is not displayed

Default value is True

Explanation

The DialogBackColorOpacityVisible property sets whether or not the item used to set the back color opacity is displayed in the property dialog.

When this property is false, the item used to set the back color opacity is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogBackColorVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogBackColorVisible Property

This property sets whether or not the item used to set the back color is displayed in the property dialog.

[Visual Basic] Public Property DialogBackColorVisible As Boolean
[C#] public bool DialogBackColorVisible {get; set;}

Property Value

True: The item used to set the back color is displayed

False: The item used to set the back color is not displayed

Default value is True

Explanation

The DialogBackColorVisible property sets whether or not the item used to set the back color is displayed in the property dialog.

When this property is false, the item used to set the back color is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogBorderColorEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogBorderColorEnabled Property

This property sets whether or not the item used to set the border color is enabled in the property dialog.

[Visual Basic] Public Property DialogBorderColorEnabled As Boolean
[C#] public bool DialogBorderColorEnabled {get; set;}

Property Value

True: The item used to set the border color is enabled

False: The item used to set the border color is disabled

Default value is True

Explanation

The DialogBorderColorEnabled property sets whether or not the item used to set the border color is enabled in the property dialog.

When this property is false, the item used to set the border color is disabled and cannot be set.

DialogBorderColorEnabled property is enabled for the Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogBorderColorOpacityEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogBorderColorOpacityEnabled Property

This property sets whether or not the item used to set the border color opacity is enabled in the property dialog.

[Visual Basic] Public Property DialogBorderColorOpacityEnabled As Boolean
[C#] public bool DialogBorderColorOpacityEnabled {get; set;}

Property Value

True: The item used to set the border color opacity is enabled

False: The item used to set the border color opacity is disabled

Default value is True

Explanation

The DialogBorderColorOpacityEnabled property sets whether or not the item used to set the border color opacity is enabled in the property dialog.

When this property is false, the item used to set the border color opacity is disabled and cannot be set.

DialogBorderColorOpacityEnabled property is enabled for the Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogBorderColorOpacityVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogBorderColorOpacityVisible Property

This property sets whether or not the item used to set the border color opacity is displayed in the property dialog.

[Visual Basic] Public Property DialogBorderColorOpacityVisible As Boolean
[C#] public bool DialogBorderColorOpacityVisible {get; set;}

Property Value

True: The item used to set the border color opacity is displayed

False: The item used to set the border color opacity is not displayed

Default value is True

Explanation

The DialogBorderColorOpacityVisible property sets whether or not the item used to set the border color opacity is displayed in the property dialog.

When this property is false, the item used to set the border color opacity is not displayed.

DialogBorderColorOpacityVisible property is enabled for the Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogBorderColorVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogBorderColorVisible Property

This property sets whether or not the item used to set the border color is displayed in the property dialog.

[Visual Basic] Public Property DialogBorderColorVisible As Boolean
[C#] public bool DialogBorderColorVisible {get; set;}

Property Value

True: The item used to set the border color is displayed

False: The item used to set the border color is not displayed

Default value is True

Explanation

The DialogBorderColorVisible property sets whether or not the item used to set the border color is displayed in the property dialog.

When this property is false, the item used to set the border color is not displayed.

DialogBorderColorVisible property is enabled for the Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogBorderEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogBorderEnabled Property

This property sets whether or not the checkbox used to set the border is enabled in the property dialog.

[Visual Basic] Public Property DialogBorderEnabled As Boolean
[C#] public bool DialogBorderEnabled {get; set;}

Property Value

True: The checkbox used to set the border is enabled

False: The checkbox used to set the border is disabled

Default value is True

Explanation

The DialogBorderEnabled property sets whether or not the checkbox used to set the border is enabled in the property dialog.

When this property is false, the checkbox used to set the border is disabled and cannot be set.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogBorderShapeEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogBorderShapeEnabled Property

This property sets whether or not the item used to set the border shape for the Stamp object is enabled in the property dialog.

[Visual Basic] Public Property DialogBorderShapeEnabled As Boolean
[C#] public bool DialogBorderShapeEnabled {get; set;}

Property Value

True: The item used to set the border shape is enabled

False: The item used to set the border shape is disabled

Default value is True

Explanation

The DialogBorderShapeEnabled property sets whether or not the item used to set the border shape for the Stamp object is enabled in the property dialog.

When this property is false, the item used to set the border shape is disabled and cannot be set.

This property is enabled only when a Stamp object is selected. If a Text object is selected, the item used to set the border shape is disabled even if the DialogBorderShapeEnabled property is True.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogBorderShapeVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogBorderShapeVisible Property

This property sets whether or not the item used to set the border shape for the Stamp or Text object is displayed in the property dialog.

[Visual Basic] Public Property DialogBorderShapeVisible As Boolean
[C#] public bool DialogBorderShapeVisible {get; set;}

Property Value

True: The item used to set the border shape is displayed

False: The item used to set the border shape is not displayed

Default value is True

Explanation

The DialogBorderShapeVisible property sets whether or not the item used to set the border shape for the Stamp or Text object is displayed in the property dialog.

When this property is false, the item used to set the border shape is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogBorderVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogBorderVisible Property

This property sets whether or not the checkbox used to set the border is displayed in the property dialog.

[Visual Basic] Public Property DialogBorderVisible As Boolean
[C#] public bool DialogBorderVisible {get; set;}

Property Value

True: The checkbox used to set the border is displayed

False: The checkbox used to set the border is not displayed

Default value is True

Explanation

The DialogBorderVisible property sets whether or not the checkbox used to set the border is displayed in the property dialog.

When this property is false, the checkbox used to set the border is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogBrushKindEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogBrushKindEnabled Property

This property sets whether or not the custom brush's BrushKind setting is enabled in the property dialog.

[Visual Basic] Public Property DialogBrushKindEnabled As Boolean
[C#] public bool DialogBrushKindEnabled {get; set;}

Property Value

True: The BrushKind settings are enabled in the property dialog

False: The BrushKind settings are not enabled in the property dialog

Default value is True

Explanation

The DialogBrushKindEnabled property sets whether or not the custom brush's BrushKind setting is enabled in the object's property dialog.

When this property is false, the combobox that allows you to set the BrushKind within the property dialog is disabled and cannot be set.

Note: If the CustomBrushEnabled property and the DialogCustomBrushVisible properties are not both true, then this item is not displayed in the property dialog.

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogBrushKindEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogBrushKindVisible Property

This property sets whether or not the combobox used to set the custom brush's BrushKind setting is displayed in the property dialog.

[Visual Basic] Public Property DialogBrushKindVisible As Boolean
[C#] public bool DialogBrushKindVisible {get; set;}

Property Value

True: The combobox used to se the custom brush's BrushKind is displayed.

False: The combobox used to se the custom brush's BrushKind is not displayed.

Default value is True

Explanation

The DialogBrushKindVisible property sets whether or not the combobox used to set the custom brush's BrushKind setting is displayed in the property dialog

Note: Even if this property is set to true, if both the CustomBrushEnabled property and the DialogCustomBrushVisible properties are not both true, then this item is not displayed in the property dialog.

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogClosePenLineEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogClosePenLineEnabled Property

This property sets whether or not the checkbox used to set the "close pen line" is enabled in the property dialog.

[Visual Basic] Public Property DialogClosePenLineEnabled As Boolean
[C#] public bool DialogClosePenLineEnabled {get; set;}

Property Value

True: The checkbox used to set the "close pen line" is enabled

False: The checkbox used to set the "close pen line" is disabled

Default value is True

Explanation

The DialogClosePenLineEnabled property sets whether or not the checkbox used to set the "close pen line" is enabled in the property dialog.

When this property is false, the checkbox used to set the "close pen line" is disabled and cannot be set.

The DialogClosePenLineEnabled property is enabled only when a Pen object is selected. Even if this property is true, if a Line, Polyline, or Polygon object is selected, the "close pen line" checkbox will be disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogClosePenLineVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogClosePenLineVisible Property

This property sets whether or not the checkbox used to set the "close pen line" is displayed in the property dialog.

[Visual Basic] Public Property DialogClosePenLineVisible As Boolean
[C#] public bool DialogClosePenLineVisible {get; set;}

Property Value

True: The checkbox used to set the "close pen line" is displayed

False: The checkbox used to set the "close pen line" is not displayed

Default value is True

Explanation

The DialogClosePenLineVisible property sets whether or not the checkbox used to set the "close pen line" is displayed in the property dialog.

When this property is false, the checkbox used to set the "close pen line" is not displayed.

The DialogClosePenLineVisible property is enabled when a Pen, Line, Polyline, or Polygon object is selected.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogCurveTensionEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogCurveTensionEnabled Property

This property sets whether or not the "Curve Tension" setting is enabled in the property dialog.

[Visual Basic] Public Property DialogCurveTensionEnabled As Boolean
[C#] public bool DialogCurveTensionEnabled {get; set;}

Property Value

True: The "Curve Tension" setting is enabled

False: The "Curve Tension" setting is disabled

Default value is True

Explanation

The DialogCurveTensionEnabled property sets whether or not the "Curve Tension" setting is enabled in the property dialog.

When this property is false, the "Curve Tension" is disabled and cannot be set.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogCurveTensionVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogCurveTensionVisible Property

This property sets whether or not the "Curve Tension" setting is visible in the property dialog.

[Visual Basic] Public Property DialogCurveTensionVisible As Boolean
[C#] public bool DialogCurveTensionVisible {get; set;}

Property Value

True: The "Curve Tension" setting is visible

False: The "Curve Tension" setting is not visible

Default value is True

Explanation

The DialogCurveTensionVisible property sets whether or not the "Curve Tension" setting is visible in the property dialog.

When this property is false, the "Curve Tension" setting is not displayed in the property dialog.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogCustomBrushColor1Enabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogCustomBrushColor1Enabled Property

This property sets whether or not the custom brush's hatch pattern start color is enabled in the property dialog.

[Visual Basic] Public Property DialogCustomBrushColor1Enabled As Boolean
[C#] public bool DialogCustomBrushColor1Enabled {get; set;}

Property Value

True: The hatch pattern start color is enabled in the property dialog.

False: The hatch pattern start color is not enabled in the property dialog.

Default value is True

Explanation

The DialogCustomBrushColor1Enabled property sets whether or not the custom brush's hatch pattern start color is enabled in the property dialog.

When this property is false, the button that allows you to set the start color for the hatch pattern used by the custom brush is not enabled within the property dialog and cannot be set.

Note: If the CustomBrushEnabled property and the DialogCustomBrushVisible properties are not both true, then this item is not displayed in the property dialog.

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogCustomBrushColor1Visible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogCustomBrushColor1Visible Property

This property sets whether or not the item used to set the custom brush's hatch pattern start color is displayed in the property dialog.

[Visual Basic] Public Property DialogCustomBrushColor1Visible As Boolean
[C#] public bool DialogCustomBrushColor1Visible {get; set;}

Property Value

True: The item used to set the hatch pattern start color is displayed in the property dialog.

False: The item used to set the hatch pattern start color is not displayed in the property dialog.

Default value is True

Explanation

The DialogCustomBrushColor1Visible property sets whether or not the item used to set the custom brush's hatch pattern start color is displayed in the property dialog.

When this property is false, the combobox used to set the customer brush's start color for the hatch pattern is not displayed in property dialog.

Note: Even if this property is true, if the CustomBrushEnabled property and the DialogCustomBrushVisible properties are not both true, then this item is not displayed in the property dialog.

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogCustomBrushColor2Enabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogCustomBrushColor2Enabled Property

This property sets whether or not the custom brush's hatch pattern end color is enabled in the property dialog.

[Visual Basic] Public Property DialogCustomBrushColor2Enabled As Boolean
[C#] public bool DialogCustomBrushColor2Enabled {get; set;}

Property Value

True: The hatch pattern end color is enabled in the property dialog.

False: The hatch pattern end color is not enabled in the property dialog.

Default value is True

Explanation

The DialogCustomBrushColor2Enabled property sets whether or not the custom brush's hatch pattern end color is enabled in the property dialog.

When this property is false, the button that allows you to set the end color for the hatch pattern used by the custom brush is not enabled within the property dialog and cannot be set.

Note: If the CustomBrushEnabled property and the DialogCustomBrushVisible properties are not both true, then this item is not displayed in the property dialog.

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogCustomBrushColor2Visible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogCustomBrushColor2Visible Property

This property sets whether or not the item used to set the custom brush's hatch pattern end color is displayed in the property dialog.

[Visual Basic] Public Property DialogCustomBrushColor2Visible As Boolean
[C#] public bool DialogCustomBrushColor2Visible {get; set;}

Property Value

True: The item used to set the hatch pattern end color is displayed in the property dialog.

False: The item used to set the hatch pattern end color is not displayed in the property dialog.

Default value is True

Explanation

The DialogCustomBrushColor2Visible property sets whether or not the item used to set the custom brush's hatch pattern end color is displayed in the property dialog.

When this property is false, the combobox used to set the customer brush's end color for the hatch pattern is not displayed in property dialog.

Note: Even if this property is true, if the CustomBrushEnabled property and the DialogCustomBrushVisible properties are not both true, then this item is not displayed in the property dialog.

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogCustomBrushImageFileNameEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogCustomBrushImageFileNameEnabled Property

This property sets whether or not the filename for the image, used by the custom brush when its set to texture, is enabled in the property dialog.

[Visual Basic] Public Property DialogCustomBrushImageFileNameEnabled As Boolean
[C#] public bool DialogCustomBrushImageFileNameEnabled {get; set;}

Property Value

True: The filename for the image is enabled in the property dialog.

False: The filename for the image is not enabled in the property dialog.

Default value is True

Explanation

The DialogCustomBrushImageFileNameEnabled property sets whether or not the filename for the image, used by the custom brush when its set to texture, is enabled in the property dialog.

When this property is false, the textbox used to set the filename is not enabled within the property dialog and cannot be set.

Note: If the CustomBrushEnabled property and the DialogCustomBrushVisible properties are not both true, then this item is not displayed in the property dialog.

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogCustomBrushImageFileNameVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogCustomBrushImageFileNameVisible Property

This property sets whether or not the item, used to set the filename for the image used by the custom brush when its set to texture, is displayed in the property dialog

[Visual Basic] Public Property DialogCustomBrushImageFileNameVisible As Boolean
[C#] public bool DialogCustomBrushImageFileNameVisible {get; set;}

Property Value

True: The item used to set the filename for the image is displayed in the property dialog.

False: The item used to set the filename for the image is not displayed in the property dialog.

Default value is True

Explanation

The DialogCustomBrushImageFileNameVisible property sets whether or not the item, used to set the filename for the image used by the custom brush when its set to texture, is displayed in the property dialog .

When this property is false, the textbox used to set the filename is not displayed within the property dialog.

Note: Even if this property is true, if the CustomBrushEnabled property and the DialogCustomBrushVisible properties are not both true, then this item is not displayed in the property dialog.

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogCustomBrushVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogCustomBrushVisible Property

This property sets whether to display the custom brush settings collectively in the property dialog.

[Visual Basic] Public Property DialogCustomBrushVisible As Boolean
[C#] public bool DialogCustomBrushVisible {get; set;}

Property Value

True: The custom brush settings are collectively displayed in the property dialog.

False: None of the custom brush settings are displayed in the property dialog.

Default value is True

Explanation

The DialogCustomBrushVisible property sets whether to display the custom brush settings collectively in the property dialog.

When this property is false, none of the items that relate to setting the custom brush will be displayed in the property dialog. If the DialogCustomBrushVisible property is true, the size of the property dialog may change. When this property is false, the property dialog will be its normal size.

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogDashStyleEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogDashStyleEnabled Property

This property sets whether or not the item used to set the dash style is enabled in the property dialog.

[Visual Basic] Public Property DialogDashStyleEnabled As Boolean
[C#] public bool DialogDashStyleEnabled {get; set;}

Property Value

True: The item used to set the dash style is enabled

False: The item used to set the dash style is disabled

Default value is True

Explanation

The DialogDashStyleEnabled property sets whether or not the item used to set the dash style is enabled in the property dialog.

When this property is false, the item used to set the dash style is disabled and cannot be set.

The DialogDashStyleEnabled property is enabled when a Line, Polyline, Polygon, or Pen object is selected.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogDashStyleVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogDashStyleVisible Property

This property sets whether or not the item used to set the dash style is displayed in the property dialog.

[Visual Basic] Public Property DialogDashStyleVisible As Boolean
[C#] public bool DialogDashStyleVisible {get; set;}

Property Value

True: The item used to set the dash style is displayed

False: The item used to set the dash style is not displayed

Default value is True

Explanation

The DialogDashStyleVisible property sets whether or not the item used to set the dash style is displayed in the property dialog.

When this property is false, the item used to set the dash style is not displayed.

The DialogDashStyleVisible property is enabled when a Line, Polyline, Polygon, or Pen object is selected.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogDesignedTextVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogDesignedTextVisible Property

This property sets whether or not the designed text settings are displayed in the property dialog.

[Visual Basic] Public Property DialogDesignedTextVisible As Boolean
[C#] public bool DialogDesignedTextVisible {get; set;}

Property Value

True: The designed text settings are displayed

False: The designed text settings are not displayed

Default value is True

Explanation

The DialogDesignedTextVisible property sets whether or not the designed text settings are displayed in the property dialog.

If this property is set to False, all settings related to text design are not displayed in the property dialog.

This property is valid only when the DesignedTextEnabled property is True and when a Text or Stamp object is selected.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogDoubleLineEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogDoubleLineEnabled Property

This property sets whether or not the checkbox used to set the double line is enabled in the property dialog.

[Visual Basic] Public Property DialogDoubleLineEnabled As Boolean
[C#] public bool DialogDoubleLineEnabled {get; set;}

Property Value

True: The checkbox used to set the double line is enabled

False: The checkbox used to set the double line is disabled

Default value is True

Explanation

The DialogDoubleLineEnabled property sets whether or not the checkbox used to set the double line is enabled in the property dialog.

When this property is False, the checkbox used to set the double line is disabled and cannot be set.

The DialogDoubleLineEnabled property is enabled for the Line object only. Even if this property is true and a Polyline, Polygon, or Pen object is selected, the double line checkbox will be disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogDoubleLineVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogDoubleLineVisible Property

This property sets whether or not the checkbox used to set the double line is displayed in the property dialog.

[Visual Basic] Public Property DialogDoubleLineVisible As Boolean
[C#] public bool DialogDoubleLineVisible {get; set;}

Property Value

True: The checkbox used to set the double line is displayed

False: The checkbox used to set the double line is not displayed

Default value is True

Explanation

The DialogDoubleLineVisible property sets whether or not the checkbox used to set the double line is displayed in the property dialog.

When this property is False, the checkbox used to set the double line is not displayed.

The DialogDoubleLineVisible property is enabled for the Line, Polyline, Polygon, and Pen object.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogEndArrowCapEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogEndArrowCapEnabled Property

This property sets whether or not the checkbox used to set the end arrow cap is enabled in the property dialog.

[Visual Basic] Public Property DialogEndArrowCapEnabled As Boolean
[C#] public bool DialogEndArrowCapEnabled {get; set;}

Property Value

True: The checkbox used to set the end arrow cap is enabled

False: The checkbox used to set the end arrow cap is disabled

Default value is True

Explanation

The DialogEndArrowCapEnabled property sets whether or not the checkbox used to set the end arrow cap is enabled in the property dialog.

When this property is False, the checkbox used to set the end arrow cap is disabled and cannot be set.

The DialogEndArrowCapEnabled property is enabled for the Line and Polyline objects. Even if this property is true and a Polygon or Pen object is selected, the end arrow cap checkbox will be disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogEndArrowCapFilledEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogEndArrowCapFilledEnabled Property

This property sets whether or not the checkbox used to set the end arrow cap filled is enabled in the property dialog.

[Visual Basic] Public Property DialogEndArrowCapFilledEnabled As Boolean
[C#] public bool DialogEndArrowCapFilledEnabled {get; set;}

Property Value

True: The checkbox used to set the end arrow cap filled is enabled

False: The checkbox used to set the end arrow cap filled is disabled

Default value is True

Explanation

The DialogEndArrowCapFilledEnabled property sets whether or not the checkbox used to set the end arrow cap filled is enabled in the property dialog.

When this property is False, the checkbox used to set the end arrow cap filled is disabled and cannot be set.

The DialogEndArrowCapFilledEnabled property is enabled for the Line and Polyline objects. Even if this property is true and a Polygon or Pen object is selected, the end arrow cap filled checkbox will be disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogEndArrowCapFilledVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogEndArrowCapFilledVisible Property

This property sets whether or not the checkbox used to set the end arrow cap filled is displayed in the property dialog.

[Visual Basic] Public Property DialogEndArrowCapFilledVisible As Boolean
[C#] public bool DialogEndArrowCapFilledVisible {get; set;}

Property Value

True: The checkbox used to set the end arrow cap filled is displayed

False: The checkbox used to set the end arrow cap filled is not displayed

Default value is True

Explanation

The DialogEndArrowCapFilledVisible property sets whether or not the checkbox used to set the end arrow cap filled is displayed in the property dialog.

When this property is False, the checkbox used to set the end arrow cap filled is not displayed.

The DialogEndArrowCapFilledVisible property is enabled for the Line, Polyline, Polygon, and Pen objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogEndArrowCapSizeEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogEndArrowCapSizeEnabled Property

This property sets whether or not the item used to set the end arrow cap size is enabled in the property dialog.

[Visual Basic] Public Property DialogEndArrowCapSizeEnabled As Boolean
[C#] public bool DialogEndArrowCapSizeEnabled {get; set;}

Property Value

True: The item used to set the end arrow cap size is enabled

False: The item used to set the end arrow cap size is disabled

Default value is True

Explanation

The DialogEndArrowCapSizeEnabled property sets whether or not the item used to set the end arrow cap size is enabled in the property dialog.

When this property is False, the item used to set the end arrow cap size is disabled and cannot be set.

The DialogEndArrowCapSizeEnabled property is enabled for the Line and Polyline objects. Even if this property is true and a Polygon or Pen object is selected, the end arrow cap size item will be disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogEndArrowCapSizeVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogEndArrowCapSizeVisible Property

This property sets whether or not the item used to set the end arrow cap size is displayed in the property dialog.

[Visual Basic] Public Property DialogEndArrowCapSizeVisible As Boolean
[C#] public bool DialogEndArrowCapSizeVisible {get; set;}

Property Value

True: The item used to set the end arrow cap size is displayed

False: The item used to set the end arrow cap size is not displayed

Default value is True

Explanation

The DialogEndArrowCapSizeVisible property sets whether or not the item used to set the end arrow cap size is displayed in the property dialog.

When this property is False, the item used to set the end arrow cap size is not displayed.

The DialogEndArrowCapSizeVisible property is enabled for the Line, Polyline, Polygon, and Pen objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogEndArrowCapVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogEndArrowCapVisible Property

This property sets whether or not the checkbox used to set the end arrow cap is displayed in the property dialog.

[Visual Basic] Public Property DialogEndArrowCapVisible As Boolean
[C#] public bool DialogEndArrowCapVisible {get; set;}

Property Value

True: The checkbox used to set the end arrow cap is displayed

False: The checkbox used to set the end arrow cap is not displayed

Default value is True

Explanation

The DialogEndArrowCapVisible property sets whether or not the checkbox used to set the end arrow cap is displayed in the property dialog.

When this property is False, the checkbox used to set the end arrow cap is not displayed.

The DialogEndArrowCapVisible property is enabled for the Line, Polyline, Polygon, and Pen objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogEndLineCapEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogEndLineCapEnabled Property

This property sets whether or not the item used to set the end line cap style is enabled in the property dialog.

[Visual Basic] Public Property DialogEndLineCapEnabled As Boolean
[C#] public bool DialogEndLineCapEnabled {get; set;}

Property Value

True: The item used to set the end line cap style is enabled

False: The item used to set the end line cap style is disabled

Default value is True

Explanation

The DialogEndLineCapEnabled property sets whether or not the item used to set the end line cap style is enabled in the property dialog.

When this property is False, the item used to set the end line cap style is disabled and cannot be set.

The DialogEndLineCapEnabled property is enabled for the Line, Polyline and Pen objects. Even if this property is true and a Polygon object is selected, the end line cap style item will be disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogEndLineCapVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogEndLineCapVisible Property

This property sets whether or not the item used to set the end line cap style is displayed in the property dialog.

[Visual Basic] Public Property DialogEndLineCapVisible As Boolean
[C#] public bool DialogEndLineCapVisible {get; set;}

Property Value

True: The item used to set the end line cap style is displayed

False: The item used to set the end line cap style is not displayed

Default value is True

Explanation

The DialogEndLineCapVisible property sets whether or not the item used to set the end line cap style is displayed in the property dialog.

When this property is False, the item used to set the end line cap style is not displayed.

The DialogEndLineCapVisible property is enabled for the Line, Polyline, Polygon, and Pen objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogFillEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogFillEnabled Property

This property sets whether or not the checkbox used to set "Fill" is enabled in the property dialog.

[Visual Basic] Public Property DialogFillEnabled As Boolean
[C#] public bool DialogFillEnabled {get; set;}

Property Value

True: The checkbox used to set "Fill" is enabled

False: The checkbox used to set "Fill" is disabled

Default value is True

Explanation

The DialogFillEnabled property sets whether or not the checkbox used to set "Fill" is enabled in the property dialog.

When this property is false, the checkbox used to set "Fill" is disabled and cannot be set.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogFillVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogFillVisible Property

This property sets whether or not the checkbox used to set "Fill" is displayed in the property dialog.

[Visual Basic] Public Property DialogFillVisible As Boolean
[C#] public bool DialogFillVisible {get; set;}

Property Value

True: The checkbox used to set "Fill" is displayed

False: The checkbox used to set "Fill" is not displayed

Default value is True

Explanation

The DialogFillVisible property sets whether or not the checkbox used to set "Fill" is displayed in the property dialog.

When this property is false, the checkbox used to set "Fill" is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogFontBoldEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogFontBoldEnabled Property

This property sets whether or not the checkbox used to set bold fonts is enabled in the property dialog.

[Visual Basic] Public Property DialogFontBoldEnabled As Boolean
[C#] public bool DialogFontBoldEnabled {get; set;}

Property Value

True: The checkbox used to set bold fonts is enabled

False: The checkbox used to set bold fonts is disabled

Default value is True

Explanation

The DialogFontBoldEnabled property sets whether or not the checkbox used to set bold fonts is enabled in the property dialog.

When this property is false, the checkbox used to set bold fonts is disabled and cannot be set.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogFontBoldVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogFontBoldVisible Property

This property sets whether or not the checkbox used to set bold fonts is displayed in the property dialog.

[Visual Basic] Public Property DialogFontBoldVisible As Boolean
[C#] public bool DialogFontBoldVisible {get; set;}

Property Value

True: The checkbox used to set bold fonts is displayed

False: The checkbox used to set bold fonts is not displayed

Default value is True

Explanation

The DialogFontBoldVisible property sets whether or not the checkbox used to set bold fonts is displayed in the property dialog.

When this property is false, the checkbox used to set bold fonts is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogFontItalicEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogFontItalicEnabled Property

This property sets whether or not the checkbox used to set italic fonts is enabled in the property dialog.

[Visual Basic] Public Property DialogFontItalicEnabled As Boolean
[C#] public bool DialogFontItalicEnabled {get; set;}

Property Value

True: The checkbox used to set italic fonts is enabled

False: The checkbox used to set italic fonts is disabled

Default value is True

Explanation

The DialogFontItalicEnabled property sets whether or not the checkbox used to set italic fonts is enabled in the property dialog.

When this property is false, the checkbox used to set italic fonts is disabled and cannot be set.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogFontItalicVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogFontItalicVisible Property

This property sets whether or not the checkbox used to set italic fonts is displayed in the property dialog.

[Visual Basic] Public Property DialogFontItalicVisible As Boolean
[C#] public bool DialogFontItalicVisible {get; set;}

Property Value

True: The checkbox used to set italic fonts is displayed

False: The checkbox used to set italic fonts is not displayed

Default value is True

Explanation

The DialogFontItalicVisible property sets whether or not the checkbox used to set italic fonts is displayed in the property dialog.

When this property is false, the checkbox used to set italic fonts is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogFontNameEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogFontNameEnabled Property

This property sets whether or not the item used to set the font name is enabled in the property dialog.

[Visual Basic] Public Property DialogFontNameEnabled As Boolean
[C#] public bool DialogFontNameEnabled {get; set;}

Property Value

True: The item used to set the font name is enabled

False: The item used to set the font name is disabled

Default value is True

Explanation

The DialogFontNameEnabled property sets whether or not the item used to set the font name is enabled in the property dialog.

When this property is false, the item used to set the font name is disabled and cannot be set.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogFontNameVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogFontNameVisible Property

This property sets whether or not the item used to set the font name is displayed in the property dialog.

[Visual Basic] Public Property DialogFontNameVisible As Boolean
[C#] public bool DialogFontNameVisible {get; set;}

Property Value

True: The item used to set the font name is displayed

False: The item used to set the font name is not displayed

Default value is True

Explanation

The DialogFontNameVisible property sets whether or not the item used to set the font name is displayed in the property dialog.

When this property is false, the item used to set the font name is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogFontSizeEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogFontSizeEnabled Property

This property sets whether or not the item used to set the font size is enabled in the property dialog.

[Visual Basic] Public Property DialogFontSizeEnabled As Boolean
[C#] public bool DialogFontSizeEnabled {get; set;}

Property Value

True: The item used to set the font size is enabled

False: The item used to set the font size is disabled

Default value is True

Explanation

The DialogFontSizeEnabled property sets whether or not the item used to set the font size is enabled in the property dialog.

When this property is false, the item used to set the font size is disabled and cannot be set.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogFontSizeVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogFontSizeVisible Property

This property sets whether or not the item used to set the font size is displayed in the property dialog.

[Visual Basic] Public Property DialogFontSizeVisible As Boolean
[C#] public bool DialogFontSizeVisible {get; set;}

Property Value

True: The item used to set the font size is displayed

False: The item used to set the font size is not displayed

Default value is True

Explanation

The DialogFontSizeVisible property sets whether or not the item used to set the font size is displayed in the property dialog.

When this property is false, the item used to set the font size is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogFontStrikeoutEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogFontStrikeoutEnabled Property

This property sets whether or not the checkbox used to set strikeout fonts is enabled in the property dialog.

[Visual Basic] Public Property DialogFontStrikeoutEnabled As Boolean
[C#] public bool DialogFontStrikeoutEnabled {get; set;}

Property Value

True: The checkbox used to set strikeout fonts is enabled

False: The checkbox used to set strikeout fonts is disabled

Default value is True

Explanation

The DialogFontStrikeoutEnabled property sets whether or not the checkbox used to set strikeout fonts is enabled in the property dialog.

When this property is false, the checkbox used to set strikeout fonts is disabled and cannot be set.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogFontStrikeoutVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogFontStrikeoutVisible Property

This property sets whether or not the checkbox used to set strikeout fonts is displayed in the property dialog.

[Visual Basic] Public Property DialogFontStrikeoutVisible As Boolean
[C#] public bool DialogFontStrikeoutVisible {get; set;}

Property Value

True: The checkbox used to set strikeout fonts is displayed

False: The checkbox used to set strikeout fonts is not displayed

Default value is True

Explanation

The DialogFontStrikeoutVisible property sets whether or not the checkbox used to set strikeout fonts is displayed in the property dialog.

When this property is false, the checkbox used to set strikeout fonts is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogFontUnderlineEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogFontUnderlineEnabled Property

This property sets whether or not the checkbox used to set underlined fonts is enabled in the property dialog.

[Visual Basic] Public Property DialogFontUnderlineEnabled As Boolean
[C#] public bool DialogFontUnderlineEnabled {get; set;}

Property Value

True: The checkbox used to set underlined fonts is enabled

False: The checkbox used to set underlined fonts is disabled

Default value is True

Explanation

The DialogFontUnderlineEnabled property sets whether or not the checkbox used to set underlined fonts is enabled in the property dialog.

When this property is false, the checkbox used to set underlined fonts is disabled and cannot be set.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogFontUnderlineVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogFontUnderlineVisible Property

This property sets whether or not the checkbox used to set underlined fonts is displayed in the property dialog.

[Visual Basic] Public Property DialogFontUnderlineVisible As Boolean
[C#] public bool DialogFontUnderlineVisible {get; set;}

Property Value

True: The checkbox used to set underlined fonts is displayed

False: The checkbox used to set underlined fonts is not displayed

Default value is True

Explanation

The DialogFontUnderlineVisible property sets whether or not the checkbox used to set underlined fonts is displayed in the property dialog.

When this property is false, the checkbox used to set underlined fonts is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogForeColor2Enabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogForeColor2Enabled Property

This property sets whether or not the item used to set the text gradiation end color is enabled in the property dialog.

[Visual Basic] Public Property DialogForeColor2Enabled As Boolean
[C#] public bool DialogForeColor2Enabled {get; set;}

Property Value

True: The item used to set the text gradiation end color is enabled

False: The item used to set the text gradiation end color is disabled

Default value is True

Explanation

The DialogForeColor2Enabled property sets whether or not the item used to set the text gradiation end color is enabled in the property dialog.

This property is valid only when the DesignedTextEnabled property is True. If this property is set to False, the text gradiation end color is disabled in the property dialog and cannot be set.

This property is only valid for Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogForeColor2Visible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogForeColor2Visible Property

This property sets whether or not the item used to set the text gradiation end color is displayed in the property dialog.

[Visual Basic] Public Property DialogForeColor2Visible As Boolean
[C#] public bool DialogForeColor2Visible {get; set;}

Property Value

True: The item used to set the text gradiation end color is displayed

False: The item used to set the text gradiation end color is not displayed

Default value is True

Explanation

The DialogForeColor2Visible property sets whether or not the item used to set the text gradiation end color is displayed in the property dialog.

This property is valid only when the DesignedTextEnabled property is True. If this property is set to False, the item used to set the text gradiation end color is not displayed in the property dialog.

This property is only valid for Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogForeColorEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogForeColorEnabled Property

This property sets whether or not the item used to set the fore color is enabled in the property dialog.

[Visual Basic] Public Property DialogForeColorEnabled As Boolean
[C#] public bool DialogForeColorEnabled {get; set;}

Property Value

True: The item used to set the fore color is enabled

False: The item used to set the fore color is disabled

Default value is True

Explanation

The DialogForeColorEnabled property sets whether or not the item used to set the fore color is enabled in the property dialog. Depending on the object selected, the fore color may be referred to as "line color" or "font color" in the property dialog.

When this property is false, the item used to set the fore color is disabled and cannot be set.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogForeColorOpacityEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogForeColorOpacityEnabled Property

This property sets whether or not the item used to set the fore color opacity is enabled in the property dialog.

[Visual Basic] Public Property DialogForeColorOpacityEnabled As Boolean
[C#] public bool DialogForeColorOpacityEnabled {get; set;}

Property Value

True: The item used to set the fore color opacity is enabled

False: The item used to set the fore color opacity is disabled

Default value is True

Explanation

The DialogForeColorOpacityEnabled property sets whether or not the item used to set the fore color opacity is enabled in the property dialog. Depending on the object selected, the fore color may be referred to as "line color opacity" or "font color opacity" in the property dialog.

When this property is false, the item used to set the fore color opacity is disabled and cannot be set.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogForeColorOpacityVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogForeColorOpacityVisible Property

This property sets whether or not the item used to set the fore color opacity is displayed in the property dialog.

[Visual Basic] Public Property DialogForeColorOpacityVisible As Boolean
[C#] public bool DialogForeColorOpacityVisible {get; set;}

Property Value

True: The item used to set the fore color opacity is displayed

False: The item used to set the fore color opacity is not displayed

Default value is True

Explanation

The DialogForeColorOpacityVisible property sets whether or not the item used to set the fore color opacity is displayed in the property dialog. Depending on the object selected, the fore color opacity may be referred to as "line color opacity" or "font color opacity" in the property dialog.

When this property is false, the item used to set the fore color opacity is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogForeColorVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogForeColorVisible Property

This property sets whether or not the item used to set the fore color is displayed in the property dialog.

[Visual Basic] Public Property DialogForeColorVisible As Boolean
[C#] public bool DialogForeColorVisible {get; set;}

Property Value

True: The item used to set the fore color is displayed

False: The item used to set the fore color is not displayed

Default value is True

Explanation

The DialogForeColorVisible property sets whether or not the item used to set the fore color is displayed in the property dialog. Depending on the object selected, the fore color may be referred to as "line color" or "font color" in the property dialog.

When this property is false, the item used to set the fore color is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogHatchStyleEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogHatchStyleEnabled Property

This property sets whether or not to enable the custom brush's "hatch style" setting in the property dialog.

[Visual Basic] Public Property DialogHatchStyleEnabled As Boolean
[C#] public bool DialogHatchStyleEnabled {get; set;}

Property Value

True: The custom brush's hatch style setting is enabled in the property dialog.

False: The custom brush's hatch style setting is not enabled in the property dialog.

Default value is True

Explanation

The DialogHatchStyleEnabled property sets whether or not to enable the custom brush's "hatch style" setting in the property dialog.

When this property is false, the combobox used to set the custom brush's hatch style is disabled in the property dialog and cannot be set.

Note: If the CustomBrushEnabled property and the DialogCustomBrushVisible properties are not both true, then this item is not displayed in the property dialog.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogHatchStyleVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogHatchStyleVisible Property

This property sets whether or not the custom brush's "hatch style" setting is displayed in the property dialog.

[Visual Basic] Public Property DialogHatchStyleVisible As Boolean
[C#] public bool DialogHatchStyleVisible {get; set;}

Property Value

True: The custom brush's hatch style setting is displayed in the property dialog.

False: The custom brush's hatch style setting is not displayed in the property dialog.

Default value is True

Explanation

The DialogHatchStyleVisible property sets whether or not the custom brush's "hatch style" setting is displayed in the property dialog.

When this property is false, the combobox used to set the custom brush's hatch style is not displayed in the property dialog and cannot be set.

Note: If the CustomBrushEnabled property and the DialogCustomBrushVisible properties are not both true, then this item is not displayed in the property dialog.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogImageFileNameEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogImageFileNameEnabled Property

This property sets whether or not the item used to set the image file name is enabled in the property dialog.

[Visual Basic] Public Property DialogImageFileNameEnabled As Boolean
[C#] public bool DialogImageFileNameEnabled {get; set;}

Property Value

True: The item used to set the image file name is enabled

False: The item used to set the image file name is disabled

Default value is True

Explanation

The DialogImageFileNameEnabled property sets whether or not the item used to set the image file name is enabled in the property dialog.

When this property is false, the item used to set the image file name is disabled and cannot be set.

This property is enabled when an Image object is selected.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogImageFileNameVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogImageFileNameVisible Property

This property sets whether or not the item used to set the image file name is displayed in the property dialog.

[Visual Basic] Public Property DialogImageFileNameVisible As Boolean
[C#] public bool DialogImageFileNameVisible {get; set;}

Property Value

True: The item used to set the image file name is displayed

False: The item used to set the image file name is not displayed

Default value is True

Explanation

The DialogImageFileNameVisible property sets whether or not the item used to set the image file name is displayed in the property dialog.

When this property is false, the item used to set the image file name is not displayed.

This property is enabled when an Image object is selected.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogLinearGradientModeEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogLinearGradientModeEnabled Property

This property sets whether or not to enable the "gradation direction" setting for the custom brush's hatch pattern in the property dialog.

[Visual Basic] Public Property DialogLinearGradientModeEnabled As Boolean
[C#] public bool DialogLinearGradientModeEnabled {get; set;}

Property Value

True: The "gradation direction" setting for the custom brush's hatch pattern is enabled in the property dialog.

False: The "gradation direction" setting for the custom brush's hatch pattern is disabled in the property dialog.

Default value is True

Explanation

The DialogLinearGradientModeEnabled property sets whether or not to enable the "gradation direction" setting for the custom brush's hatch pattern in the property dialog.

When this property is false, the combobox used to set the custom brush hatch pattern's "gradation direction" is disabled in the property dialog and cannot be set.

Note: If the CustomBrushEnabled property and the DialogCustomBrushVisible properties are not both true, then this item is not displayed in the property dialog.

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogLinearGradientModeVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogLinearGradientModeVisible Property

This property sets whether or not the "gradation direction" setting for the custom brush's hatch pattern is displayed in the property dialog.

[Visual Basic] Public Property DialogLinearGradientModeVisible As Boolean
[C#] public bool DialogLinearGradientModeVisible {get; set;}

Property Value

True: The "gradation direction" setting for the custom brush's hatch pattern is displayed in the property dialog.

False: The "gradation direction" setting for the custom brush's hatch pattern is not displayed in the property dialog.

Default value is True

Explanation

The DialogLinearGradientModeVisible property sets whether or not the "gradation direction" setting for the custom brush's hatch pattern is displayed in the property dialog.

When this property is false, the combobox used to set the custom brush hatch pattern's "gradation direction" is not displayed in the property dialog and cannot be set.

Note: If the CustomBrushEnabled property and the DialogCustomBrushVisible properties are not both true, then this item is not displayed in the property dialog.

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogLineJoinEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogLineJoinEnabled Property

This property sets whether or not the item used to set the line join style is enabled in the property dialog.

[Visual Basic] Public Property DialogLineJoinEnabled As Boolean
[C#] public bool DialogLineJoinEnabled {get; set;}

Property Value

True: The item used to set the line join style is enabled

False: The item used to set the line join style is disabled

Default value is True

Explanation

The DialogLineJoinEnabled property sets whether or not the item used to set the line join style is enabled in the property dialog.

When this property is False, the item used to set the line join style is disabled and cannot be set.

The DialogLineJoinEnabled property is enabled for the Polyline, Polygon, and Pen objects. Even if this property is true and a Line object is selected, the line join style item will be disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogLineJoinVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogLineJoinVisible Property

This property sets whether or not the item used to set the line join style is displayed in the property dialog.

[Visual Basic] Public Property DialogLineJoinVisible As Boolean
[C#] public bool DialogLineJoinVisible {get; set;}

Property Value

True: The item used to set the line join style is displayed

False: The item used to set the line join style is not displayed

Default value is True

Explanation

The DialogLineJoinVisible property sets whether or not the item used to set the line join style is displayed in the property dialog.

When this property is False, the item used to set the line join style is not displayed.

The DialogLineJoinVisible property is enabled for the Line, Polyline, Polygon, and Pen objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogMaxPenWidth property

Newtone.ImageKit.Win.ImageKit.Edit.DialogMaxPenWidth Property

This property sets the maximum pen width (and border) that will be allowed in the property dialog.

[Visual Basic] Public Property DialogMaxPenWidth As Integer
[C#] public int DialogMaxPenWidth {get; set;}

Property Value

The maximum allowable penwidth

Default value is 9999

Explanation

The DialogMaxPenWidth property sets the maximum pen width (and border) that will be allowed in the property dialog.

When selecting a single annotation object and displaying its properties dialog, the DialogMaxPenWidth property determines the maximum value that can be set in the pen width property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogNotesEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogNotesEnabled Property

This property sets whether or not the item used to set the notes for objects is enabled in the property dialog.

[Visual Basic] Public Property DialogNotesEnabled As Boolean
[C#] public bool DialogNotesEnabled {get; set;}

Property Value

True: The item used to set object's notes is enabled

False: The item used to set object's notes is disabled

Default value is True

Explanation

The DialogNotesEnabled property sets whether or not the item used to set the notes for objects is enabled in the property dialog.

When this property is false, the item used to set an object's notes is disabled and cannot be set.

This property is enabled for all selected objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogNotesVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogNotesVisible Property

This property sets whether or not the item used to set the notes for objects is displayed in the property dialog.

[Visual Basic] Public Property DialogNotesVisible As Boolean
[C#] public bool DialogNotesVisible {get; set;}

Property Value

True: The item used to set the notes is displayed

False: The item used to set the notes is not displayed

Default value is False

Explanation

The DialogNotesVisible property sets whether or not the item used to set the notes for the objects is displayed in the property dialog.

When this property is False, the item used to set the notes is not displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogPenWidthEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogPenWidthEnabled Property

This property sets whether or not the item used to set the pen width is enabled in the property dialog. Pen width is also referred to as "line width" or "border width".

[Visual Basic] Public Property DialogPenWidthEnabled As Boolean
[C#] public bool DialogPenWidthEnabled {get; set;}

Property Value

True: The item used to set the pen width is enabled

False: The item used to set the pen width is disabled

Default value is True

Explanation

The DialogPenWidthEnabled property sets whether or not the item used to set the pen width is enabled in the property dialog. Depending on the object selected, the pen width may be referred to as "line width" or "border width" in the property dialog.

When this property is false, the item used to set the pen width is disabled and cannot be set.

This property is enabled for all selected objects except the Image object.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogPenWidthVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogPenWidthVisible Property

This property sets whether or not the item used to set the pen width is displayed in the property dialog. Pen width is also referred to as "line width" or "border width".

[Visual Basic] Public Property DialogPenWidthVisible As Boolean
[C#] public bool DialogPenWidthVisible {get; set;}

Property Value

True: The item used to set the pen width is displayed

False: The item used to set the pen width is not displayed

Default value is True

Explanation

The DialogPenWidthVisible property sets whether or not the item used to set the pen width is displayed in the property dialog. Depending on the object selected, the pen width may be referred to as "line width" or "border width" in the property dialog.

When this property is false, the item used to set the pen width is not displayed.

This property is enabled for all selected objects except the Image object.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogRefinePasteImageEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogRefinePasteImageEnabled Property

This property sets whether or not the checkbox used to set the "Refine PasteImage" is enabled in the property dialog.

[Visual Basic] Public Property DialogRefinePasteImageEnabled As Boolean
[C#] public bool DialogRefinePasteImageEnabled {get; set;}

Property Value

True: The checkbox used to set the "Refine PasteImage" is enabled

False: The checkbox used to set the "Refine PasteImage" is disabled

Default value is True

Explanation

The DialogRefinePasteImageEnabled property sets whether or not the checkbox used to set "Refine PasteImage" is enabled in the property dialog.

When this property is False, the checkbox used to set the "Refine PasteImage" is disabled and cannot be set.

This property is enabled for the Image object only.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogRefinePasteImageVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogRefinePasteImageVisible Property

This property sets whether or not the checkbox used to set "Refine PasteImage" is displayed in the property dialog.

[Visual Basic] Public Property DialogRefinePasteImageVisible As Boolean
[C#] public bool DialogRefinePasteImageVisible {get; set;}

Property Value

True: The checkbox used to set "Refine PasteImage" is displayed

False: The checkbox used to set "Refine PasteImage" is not displayed

Default value is True

Explanation

The DialogRefinePasteImageVisible property sets whether or not the checkcox used to set "Refine PasteImage" is displayed in the property dialog.

When this property is False, the checkbox used to set "Refine PasteImage" is not displayed.

This property is enabled for the Image object only.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogRightToLeftEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogRightToLeftEnabled Property

This property sets whether or not the checkbox used to set the "right to left" for text in the Text object is enabled in the property dialog.

[Visual Basic] Public Property DialogRightToLeftEnabled As Boolean
[C#] public bool DialogRightToLeftEnabled {get; set;}

Property Value

True: The checkbox used to set the "right to left" is enabled

False: The checkbox used to set the "right to left" is disabled

Default value is True

Explanation

The DialogRightToLeftEnabled property sets whether or not the checkbox used to set the "right to left" for text in the Text object is enabled in the property dialog.

When this property if false, the checkbox used to set "right to left" in the Text object will be disabled and cannot be set.

This property is enabled for the Text object.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogRightToLeftVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogRightToLeftVisible Property

This property sets whether or not the checkbox used to set the "right to left" for text in the Text object is displayed in the property dialog.

[Visual Basic] Public Property DialogRightToLeftVisible As Boolean
[C#] public bool DialogRightToLeftVisible {get; set;}

Property Value

True: The checkbox used to set the "right to left" is displayed

False: The checkbox used to set the "right to left" is not displayed

Default value is True

Explanation

The DialogRightToLeftVisible property sets whether or not the checkbox used to set the "right to left" for text in the Text object is displayed in the property dialog.

When this property if false, the checkbox used to set "right to left" in the Text object will not be displayed.

This property is enabled for the Text object.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogRoundRectangleRadiusEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogRoundRectangleRadiusEnabled Property

This property sets whether or not the item used to set the round rectangle radius for the RoundRectangle and Stamp objects is enabled in the property dialog.

[Visual Basic] Public Property DialogRoundRectangleRadiusEnabled As Boolean
[C#] public bool DialogRoundRectangleRadiusEnabled {get; set;}

Property Value

True: The item used to set the round rectangle radius is enabled

False: The item used to set the round rectangle radius is disabled

Default value is True

Explanation

The DialogRoundRectangleRadiusEnabled property sets whether or not the item used to set the round rectangle radius for the RoundRectangle and Stamp objects is enabled in the property dialog.

When this property if false, the item used to set the round rectangle radius will be disabled and cannot be set.

This property is enabled for the RoundRectangle and Stamp objects. Even if the DialogRoundRectangleRadiusEnabled property is true, if the selected object is a Rectangle, Ellipse, or Text object, the round rectangle radius item will be disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogRoundRectangleRadiusEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogRoundRectangleRadiusEnabled Property

This property sets whether or not the item used to set the round rectangle radius for the RoundRectangle and Stamp objects is displayed in the property dialog.

[Visual Basic] Public Property DialogRoundRectangleRadiusEnabled As Boolean
[C#] public bool DialogRoundRectangleRadiusEnabled {get; set;}

Property Value

True: The item used to set the round rectangle radius is displayed

False: The item used to set the round rectangle radius is not displayed

Default value is True

Explanation

The DialogRoundRectangleRadiusEnabled property sets whether or not the item used to set the round rectangle radius for the RoundRectangle and Stamp objects is displayed in the property dialog.

When this property if false, the item used to set the round rectangle radius will be not be displayed.

This property is enabled for the RoundRectangle, Stamp, Rectangle, Ellipse, and Text objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogStartArrowCapEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogStartArrowCapEnabled Property

This property sets whether or not the checkbox used to set the start arrow cap is enabled in the property dialog.

[Visual Basic] Public Property DialogStartArrowCapEnabled As Boolean
[C#] public bool DialogStartArrowCapEnabled {get; set;}

Property Value

True: The checkbox used to set the start arrow cap is enabled

False: The checkbox used to set the start arrow cap is disabled

Default value is True

Explanation

The DialogStartArrowCapEnabled property sets whether or not the checkbox used to set the start arrow cap is enabled in the property dialog.

When this property is False, the checkbox used to set the start arrow cap is disabled and cannot be set.

The DialogStartArrowCapEnabled property is enabled for the Line and Polyline objects. Even if this property is true and a Polygon or Pen object is selected, the start arrow cap checkbox will be disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogStartArrowCapFilledEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogStartArrowCapFilledEnabled Property

This property sets whether or not the checkbox used to set the start arrow cap filled is enabled in the property dialog.

[Visual Basic] Public Property DialogStartArrowCapFilledEnabled As Boolean
[C#] public bool DialogStartArrowCapFilledEnabled {get; set;}

Property Value

True: The checkbox used to set the start arrow cap filled is enabled

False: The checkbox used to set the start arrow cap filled is disabled

Default value is True

Explanation

The DialogStartArrowCapFilledEnabled property sets whether or not the checkbox used to set the start arrow cap filled is enabled in the property dialog.

When this property is False, the checkbox used to set the start arrow cap filled is disabled and cannot be set.

The DialogStartArrowCapFilledEnabled property is enabled for the Line and Polyline objects. Even if this property is true and a Polygon or Pen object is selected, the start arrow cap filled checkbox will be disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogStartArrowCapFilledVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogStartArrowCapFilledVisible Property

This property sets whether or not the checkbox used to set the start arrow cap filled is displayed in the property dialog.

[Visual Basic] Public Property DialogStartArrowCapFilledVisible As Boolean
[C#] public bool DialogStartArrowCapFilledVisible {get; set;}

Property Value

True: The checkbox used to set the start arrow cap filled is displayed

False: The checkbox used to set the start arrow cap filled is not displayed

Default value is True

Explanation

The DialogStartArrowCapFilledVisible property sets whether or not the checkbox used to set the start arrow cap filled is displayed in the property dialog.

When this property is False, the checkbox used to set the start arrow cap filled is not displayed.

The DialogStartArrowCapFilledVisible property is enabled for the Line, Polyline, Polygon, and Pen objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogStartArrowCapSizeEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogStartArrowCapSizeEnabled Property

This property sets whether or not the item used to set the start arrow cap size is enabled in the property dialog.

[Visual Basic] Public Property DialogStartArrowCapSizeEnabled As Boolean
[C#] public bool DialogStartArrowCapSizeEnabled {get; set;}

Property Value

True: The item used to set the start arrow cap size is enabled

False: The item used to set the start arrow cap size is disabled

Default value is True

Explanation

The DialogStartArrowCapSizeEnabled property sets whether or not the item used to set the start arrow cap size is enabled in the property dialog.

When this property is False, the item used to set the start arrow cap size is disabled and cannot be set.

The DialogStartArrowCapSizeEnabled property is enabled for the Line and Polyline objects. Even if this property is true and a Polygon or Pen object is selected, the start arrow cap size checkbox will be disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogStartArrowCapSizeVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogStartArrowCapSizeVisible Property

This property sets whether or not the item used to set the start arrow cap size is displayed in the property dialog.

[Visual Basic] Public Property DialogStartArrowCapSizeVisible As Boolean
[C#] public bool DialogStartArrowCapSizeVisible {get; set;}

Property Value

True: The item used to set the start arrow cap size is displayed

False: The item used to set the start arrow cap size is not displayed

Default value is True

Explanation

The DialogStartArrowCapSizeVisible property sets whether or not the item used to set the start arrow cap size is displayed in the property dialog.

When this property is False, the item used to set the start arrow cap size is not displayed.

The DialogStartArrowCapSizeVisible property is enabled for the Line, Polyline, Polygon, and Pen objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogStartArrowCapVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogStartArrowCapVisible Property

This property sets whether or not the checkbox used to set the start arrow cap is displayed in the property dialog.

[Visual Basic] Public Property DialogStartArrowCapVisible As Boolean
[C#] public bool DialogStartArrowCapVisible {get; set;}

Property Value

True: The checkbox used to set the start arrow cap is displayed

False: The checkbox used to set the start arrow cap is not displayed

Default value is True

Explanation

The DialogStartArrowCapVisible property sets whether or not the checkbox used to set the start arrow cap is displayed in the property dialog.

When this property is False, the checkbox used to set the start arrow cap is not displayed.

The DialogStartArrowCapVisible property is enabled for the Line, Polyline, Polygon, and Pen objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogStartLineCapEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogStartLineCapEnabled Property

This property sets whether or not the item used to set the start line cap style is enabled in the property dialog.

[Visual Basic] Public Property DialogStartLineCapEnabled As Boolean
[C#] public bool DialogStartLineCapEnabled {get; set;}

Property Value

True: The item used to set the start line cap style is enabled

False: The item used to set the start line cap style is disabled

Default value is True

Explanation

The DialogStartLineCapEnabled property sets whether or not the item used to set the start line cap style is enabled in the property dialog.

When this property is False, the item used to set the start line cap style is disabled and cannot be set.

The DialogStartLineCapEnabled property is enabled for the Line, Polyline and Pen objects. Even if this property is true and a Polygon object is selected, the start line cap style item will be disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogStartLineCapVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogStartLineCapVisible Property

This property sets whether or not the item used to set the start line cap style is displayed in the property dialog.

[Visual Basic] Public Property DialogStartLineCapVisible As Boolean
[C#] public bool DialogStartLineCapVisible {get; set;}

Property Value

True: The item used to set the start line cap style is displayed

False: The item used to set the start line cap style is not displayed

Default value is True

Explanation

The DialogStartLineCapVisible property sets whether or not the item used to set the start line cap style is displayed in the property dialog.

When this property is False, the item used to set the start line cap style is not displayed.

The DialogStartLineCapVisible property is enabled for the Line, Polyline, Polygon, and Pen objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogTextAlignEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogTextAlignEnabled Property

This property sets whether or not the item used to set the text alignment for the Stamp object is enabled in the property dialog.

[Visual Basic] Public Property DialogTextAlignEnabled As Boolean
[C#] public bool DialogTextAlignEnabled {get; set;}

Property Value

True: The item used to set the text alignment is enabled

False: The item used to set the text alignment is disabled

Default value is True

Explanation

The DialogTextAlignEnabled property sets whether or not the item used to set the text alignment for the Stamp object is enabled in the property dialog.

When this property is False, the item used to set the text alignment is disabled and cannot be set.

The DialogTextAlignEnabled property is enabled for the Stamp object only. Even if this property is true and a Text object is selected the text alignment item will be disabled.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogTextAlignVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogTextAlignVisible Property

This property sets whether or not the item used to set the text alignment for the Stamp object is displayed in the property dialog.

[Visual Basic] Public Property DialogTextAlignVisible As Boolean
[C#] public bool DialogTextAlignVisible {get; set;}

Property Value

True: The item used to set the text alignment is displayed

False: The item used to set the text alignment is not displayed

Default value is True

Explanation

The DialogTextAlignVisible property sets whether or not the item used to set the text alignment for the Stamp object is displayed in the property dialog.

When this property is False, the item used to set the text alignment is not displayed.

The DialogTextAlignVisible property is enabled for the Stamp and Text objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogTextBorderColorEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogTextBorderColorEnabled Property

This property sets whether or not the item used to set the text border color is enabled in the property dialog.

[Visual Basic] Public Property DialogTextBorderColorEnabled As Boolean
[C#] public bool DialogTextBorderColorEnabled {get; set;}

Property Value

True: The item used to set the text border color is enabled

False: The item used to set the text border color is disabled

Default value is True

Explanation

The DialogTextBorderColorEnabled property sets whether or not the item used to set the text border color is enabled in the property dialog.

This property is valid only when the DesignedTextEnabled property is True. If this property is set to False, the text border color and text border opacity are disabled in the property dialog and cannot be set.

This property is only valid for Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogTextBorderColorVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogTextBorderColorVisible Property

This property sets whether or not the item used to set the text border color is displayed in the property dialog.

[Visual Basic] Public Property DialogTextBorderColorVisible As Boolean
[C#] public bool DialogTextBorderColorVisible {get; set;}

Property Value

True: The item used to set the text border color is displayed

False: The item used to set the text border color is not displayed

Default value is True

Explanation

The DialogTextBorderColorVisible property sets whether or not the item used to set the text border color is displayed in the property dialog.

This property is valid only when the DesignedTextEnabled property is True. If this property is set to False, the items used to set the text border color and text border opacity are not displayed in the property dialog.

This property is only valid for Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogTextBorderWidthEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogTextBorderWidthEnabled Property

This property sets whether or not the item used to set the text border width is enabled in the property dialog.

[Visual Basic] Public Property DialogTextBorderWidthEnabled As Boolean
[C#] public bool DialogTextBorderWidthEnabled {get; set;}

Property Value

True: The item used to set the text border width is enabled

False: The item used to set the text border width is disabled

Default value is True

Explanation

The DialogTextBorderWidthEnabled property sets whether or not the item used to set the text border width is enabled in the property dialog.

This property is valid only when the DesignedTextEnabled property is True. If this property is set to False, the text border width is disabled in the property dialog and cannot be set.

This property is only valid for Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogTextBorderWidthVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogTextBorderWidthVisible Property

This property sets whether or not the item used to set the text border width is displayed in the property dialog.

[Visual Basic] Public Property DialogTextBorderWidthVisible As Boolean
[C#] public bool DialogTextBorderWidthVisible {get; set;}

Property Value

True: The item used to set the text border width is displayed

False: The item used to set the text border width is not displayed

Default value is True

Explanation

The DialogTextBorderWidthVisible property sets whether or not the item used to set the text border width is displayed in the property dialog.

This property is valid only when the DesignedTextEnabled property is True. If this property is set to False, the item used to set the text border width is not displayed in the property dialog.

This property is only valid for Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogTextEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogTextEnabled Property

This property sets whether or not the item used to set the text for the Text and Stamp objects is enabled in the property dialog.

[Visual Basic] Public Property DialogTextEnabled As Boolean
[C#] public bool DialogTextEnabled {get; set;}

Property Value

True: The item used to set the text is enabled

False: The item used to set the text is disabled

Default value is True

Explanation

The DialogTextEnabled property sets whether or not the item used to set the text for the Text and Stamp objects is enabled in the property dialog.

When this property is False, the item used to set the text is disabled and cannot be set.

The DialogTextEnabled property is enabled for the Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogTextLinearGradientModeEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogTextLinearGradientModeEnabled Property

This property sets whether or not the item used to set the text gradient direction is enabled in the property dialog.

[Visual Basic] Public Property DialogTextLinearGradientModeEnabled As Boolean
[C#] public bool DialogTextLinearGradientModeEnabled {get; set;}

Property Value

True: The item used to set the text gradient direction is enabled

False: The item used to set the text gradient direction is disabled

Default value is True

Explanation

The DialogTextLinearGradientModeEnabled property sets whether or not the item used to set the text gradient direction is enabled in the property dialog.

This property is valid only when the DesignedTextEnabled property is True. If this property is set to False, the text gradient direction is disabled in the property dialog and cannot be set.

This property is only valid for Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogTextLinearGradientModeVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogTextLinearGradientModeVisible Property

This property sets whether or not the item used to set the text gradient direction is displayed in the property dialog.

[Visual Basic] Public Property DialogTextLinearGradientModeVisible As Boolean
[C#] public bool DialogTextLinearGradientModeVisible {get; set;}

Property Value

True: The item used to set the text gradient direction is displayed

False: The item used to set the text gradient direction is not displayed

Default value is True

Explanation

The DialogTextLinearGradientModeVisible property sets whether or not the item used to set the text gradient direction is displayed in the property dialog.

This property is valid only when the DesignedTextEnabled property is True. If this property is set to False, the item used to set the text gradient direction is not displayed in the property dialog.

This property is only valid for Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogTextShadowColorEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogTextShadowColorEnabled Property

This property sets whether or not the item used to set the text shadow color is enabled in the property dialog.

[Visual Basic] Public Property DialogTextShadowColorEnabled As Boolean
[C#] public bool DialogTextShadowColorEnabled {get; set;}

Property Value

True: The item used to set the text shadow color is enabled

False: The item used to set the text shadow color is disabled

Default value is True

Explanation

The DialogTextShadowColorEnabled property sets whether or not the item used to set the text shadow color is enabled in the property dialog.

This property is valid only when the DesignedTextEnabled property is True. If this property is set to False, the text shadow color and text shadow opacity are disabled in the property dialog and cannot be set.

This property is only valid for Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogTextShadowColorVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogTextShadowColorVisible Property

This property sets whether or not the item used to set the text shadow color is displayed in the property dialog.

[Visual Basic] Public Property DialogTextShadowColorVisible As Boolean
[C#] public bool DialogTextShadowColorVisible {get; set;}

Property Value

True: The item used to set the text shadow color is displayed

False: The item used to set the text shadow color is not displayed

Default value is True

Explanation

The DialogTextShadowColorVisible property sets whether or not the item used to set the text shadow color is displayed in the property dialog.

This property is valid only when the DesignedTextEnabled property is True. If this property is set to False, the items used to set the text shadow color and the text shadow opacity are not displayed in the property dialog.

This property is only valid for Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogTextShadowOffsetEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogTextShadowOffsetEnabled Property

This property sets whether or not the items used to set the text shadow offset are enabled in the property dialog.

[Visual Basic] Public Property DialogTextShadowOffsetEnabled As Boolean
[C#] public bool DialogTextShadowOffsetEnabled {get; set;}

Property Value

True: The items used to set the text shadow offset are enabled

False: The items used to set the text shadow offset are disabled

Default value is True

Explanation

The DialogTextShadowOffsetEnabled property sets whether or not the items used to set the text shadow offset is enabled in the property dialog.

This property is valid only when the DesignedTextEnabled property is True. If this property is set to False, the text shadow horizontal offset, the text shadow vertical offset, and the text shadow blur are all disabled in the property dialog and cannot be set.

This property is only valid for Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogTextShadowOffsetVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogTextShadowOffsetVisible Property

This property sets whether or not the items used to set the text shadow offset are displayed in the property dialog.

[Visual Basic] Public Property DialogTextShadowOffsetVisible As Boolean
[C#] public bool DialogTextShadowOffsetVisible {get; set;}

Property Value

True: The items used to set the text shadow offset are displayed

False: The items used to set the text shadow offset are not displayed

Default value is True

Explanation

The DialogTextShadowOffsetVisible property sets whether or not the items used to set the text shadow offset are displayed in the property dialog.

This property is valid only when the DesignedTextEnabled property is True. If this property is set to False, the items used to set the text shadow horizontal offset, the text shadow vertical offset, and the text shadow blur are not displayed in the property dialog.

This property is only valid for Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogTextVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogTextVisible Property

This property sets whether or not the item used to set the text for the Text and Stamp objects is displayed in the property dialog.

[Visual Basic] Public Property DialogTextVisible As Boolean
[C#] public bool DialogTextVisible {get; set;}

Property Value

True: The item used to set the text is displayed

False: The item used to set the text is not displayed

Default value is True

Explanation

The DialogTextVisible property sets whether or not the item used to set the text for the Text and Stamp objects is displayed in the property dialog.

When this property is False, the item used to set the text is not displayed.

The DialogTextVisible property is enabled for the Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogVerticalTextEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogVerticalTextEnabled Property

This property sets whether or not the checkbox used to set the vertical text for the Text and Stamp objects is enabled in the property dialog.

[Visual Basic] Public Property DialogVerticalTextEnabled As Boolean
[C#] public bool DialogVerticalTextEnabled {get; set;}

Property Value

True: The checkbox used to set the vertical text is enabled

False: The checkbox used to set the vertical text is disabled

Default value is True

Explanation

The DialogVerticalTextEnabled property sets whether or not the checkbox used to set the vertical text for the Text and Stamp objects is enabled in the property dialog.

When this property is False, the checkbox used to set the vertical text is disabled and cannot be set.

The DialogVerticalTextEnabled property is enabled for the Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogVerticalTextVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogVerticalTextVisible Property

This property sets whether or not the checkbox used to set the vertical text for the Text and Stamp objects is displayed in the property dialog.

[Visual Basic] Public Property DialogVerticalTextVisible As Boolean
[C#] public bool DialogVerticalTextVisible {get; set;}

Property Value

True: The checkbox used to set the vertical text is displayed

False: The checkbox used to set the vertical text is not displayed

Default value is True

Explanation

The DialogVerticalTextVisible property sets whether or not the checkbox used to set the vertical text for the Text and Stamp objects is displayed in the property dialog.

When this property is False, the checkbox used to set the vertical text is not displayed.

The DialogVerticalTextVisible property is enabled for the Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogWordWrapEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.DialogWordWrapEnabled Property

This property sets whether or not the checkbox used to set word wrap for the Text and Stamp objects is enabled in the property dialog.

[Visual Basic] Public Property DialogWordWrapEnabled As Boolean
[C#] public bool DialogWordWrapEnabled {get; set;}

Property Value

True: The checkbox used to set word wrap is enabled

False: The checkbox used to set word wrap is disabled

Default value is True

Explanation

The DialogWordWrapEnabled property sets whether or not the checkbox used to set word wrap for the Text and Stamp objects is enabled in the property dialog.

When this property is False, the checkbox used to set word wrap is disabled and cannot be set.

The DialogWordWrapEnabled property is enabled for the Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DialogWordWrapVisible property

Newtone.ImageKit.Win.ImageKit.Edit.DialogWordWrapVisible Property

This property sets whether or not the checkbox used to set word wrap for the Text and Stamp objects is displayed in the property dialog.

[Visual Basic] Public Property DialogWordWrapVisible As Boolean
[C#] public bool DialogWordWrapVisible {get; set;}

Property Value

True: The checkbox used to set word wrap is displayed

False: The checkbox used to set word wrap is not displayed

Default value is True

Explanation

The DialogWordWrapVisible property sets whether or not the checkbox used to set word wrap for the Text and Stamp objects is displayed in the property dialog.

When this property is False, the checkbox used to set word wrap is not displayed.

The DialogWordWrapVisible property is enabled for the Text and Stamp objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DoubleLine property

Newtone.ImageKit.Win.ImageKit.Edit.DoubleLine Property

This property sets whether or not the line drawn in the Line, Polyline, Polygon, or Pen object is a double line.

[Visual Basic] Public Property DoubleLine As Boolean
[C#] public bool DoubleLine {get; set;}

Property Value

True: The line is a "double line"

False: The line is NOT a "double line"

Default value is False

Explanation

The DoubleLine property sets whether or not the line drawn in the Line, Polyline, Polygon, or Pen object is a double line.

When this property is true and the line drawn will be a double line. The thickness and spacing of the two lines is determined by the DoubleLineWidth1 and DoubleLineWidth2 properties.

To make changes to the double line after it has been drawn, right click on the object to display the context menu, execute the ShowPropertyDialog method to display the property dialog, or set the SelectedObjectDoubleLine property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DoubleLineWidth1.htm property

Newtone.ImageKit.Win.ImageKit.Edit.DoubleLineWidth1.htm Property

This property sets the percentage of the thickness of the first double line.

[Visual Basic] Public Property DoubleLineWidth1 As Integer
[C#] public int DoubleLineWidth1 {get; set;}

Property Value

An integer value that indicates the percentage of line thickness

Default value is 33

Explanation

The DoubleLineWidth1 property sets the percentage of the thickness of the first double line when the DoubleLine property is set to True.

The DoubleLineWidth1 property refers to the percentage of the thickness of the first line when drawing a Line, Polyline, Polygon, or Pen object as a double line. The unit is percentage. The percentage of the thickness of each double line is determined by the value of this property and the value of the DoubleLineWidth2 property, and the remaining percentage is the width of the spacing between the two lines. The minimum value for this property is 10 and the maximum value is 80. If you set a value less than 10, the value will be 10, and if you set a value greater than 80, it will be 80. Also, if the sum of the values of this property and the DoubleLineWidth2 property exceeds 90, this property value takes precedence and the value of DoubleLineWidth2 property is automatically set to the value of [90 - DoubleLineWidth1 property value].

The values can be changed even after the objects have been drawn by right-clicking the object to display the context menu, by executing the ShowPropertyDialog method to display the propery dialog, or by setting the SelectedObjectDoubleLineWidth1 property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DoubleLineWidth2.htm property

Newtone.ImageKit.Win.ImageKit.Edit.DoubleLineWidth2.htm Property

This property sets the percentage of the thickness of the second double line.

[Visual Basic] Public Property DoubleLineWidth2 As Integer
[C#] public int DoubleLineWidth2 {get; set;}

Property Value

An integer value that indicates the percentage of line thickness

Default value is 33

Explanation

The DoubleLineWidth2 property sets the percentage of the thickness of the second double line when the DoubleLine property is set to True.

The DoubleLineWidth2 property refers to the percentage of the thickness of the second line when drawing a Line, Polyline, Polygon, or Pen object as a double line. The unit is percentage. The percentage of the thickness of each double line is determined by the value of this property and the value of the DoubleLineWidth1 property, and the remaining percentage is the width of the spacing between the two lines. The minimum value for this property is 10 and the maximum value is 80. If you set a value less than 10, the value will be 10, and if you set a value greater than 80, it will be 80. Also, if the sum of the values of this property and the DoubleLineWidth1 property exceeds 90, the value of the DoubleLineWidth1 property takes precedence and the value of DoubleLineWidth2 property is automatically set to the value of [90 - DoubleLineWidth1 property value].

The values can be changed even after the objects have been drawn by right-clicking the object to display the context menu, by executing the ShowPropertyDialog method to display the propery dialog, or by setting the SelectedObjectDoubleLineWidth2 property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


EditByPoint property

Newtone.ImageKit.Win.ImageKit.Edit.EditByPoint Property

This property sets whether or not each point in a Polyline, Polygon, or Pen object can be edited.

[Visual Basic] Public Property EditByPoint As Boolean
[C#] public bool EditByPoint {get; set;}

Property Value

True: Each point can be edited

False: Editing each point is not possible.

Default value is False

Explanation

The EditByPoint property sets whether or not each point in a Polyline, Polygon, or Pen object can be edited

When this property is True and the selected object is a Polyline, Polygon, or Pen object, the mouse can be used to select an individual point in the object and move it with the mouse. When False, individual points within the Polyline, Polygon, and Pen objects cannot be selected but the entire object can be selected, moved, rotated, and resized with the mouse.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


EditEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.EditEnabled Property

This property sets whether or not annotation functions are enabled.

[Visual Basic] Public Property EditEnabled As Boolean
[C#] public bool EditEnabled {get; set;}

Property Value

True: Annotation is enabled

False: Annotation is not enabled

Default value is False

Explanation

The EditEnabled property sets whether or not annotation functions are enabled.

When this property is True, the annotation functions listed on the Edit Overview page are enabled.

The RectDraw property takes precedence over the EditEnabled property. If both properties are true, dragging the mouse over the image will not draw a rectangle. Also, the MouseDragImage property takes precedence over the EditEnabled property. If both properties are True, then annotation functions are disabled and dragging the mouse on the image will scroll the image. If the EditEnabled property is True, the the RectDraw property is only enabled when the EditKind property is set to KindOfEdit.None.

When the EditEnabled property is set to False all existing annotataions not saved to an annotation file will be discarded.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


EditKind property

Newtone.ImageKit.Win.ImageKit.Edit.EditKind Property

This property sets the kind of annotation object that is used

[Visual Basic] Public Property EditKind As KindOfEdit
[C#] public KindOfEdit EditKind {get; set;}

Property Value

A value of type KindOfEdit

Explanation

The EditKind property sets the kind of annotation object that is used. This property is enabled when the EditEnabled is True.

The kinds of annotation objects that can be selected with the EditKind property are as follows:

For Drawing: The Line, ArrowLine, Polyline, ArrowPolyline, Polygon, Rectangle, RoundRectangle, Ellipse, Pen, Text, and Stamp objects.

For Selecting: The Select and MultiSelect objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


EditPolylinePointEnabled property

Newtone.ImageKit.Win.ImageKit.Edit.EditPolylinePointEnabled Property

This property sets whether or not to allow points to be added, inserted, or deleted, in Polyline, Polygons, and Pen objects.

[Visual Basic] Public Property EditPolylinePointEnabled As Boolean
[C#] public bool EditPolylinePointEnabled {get; set;}

Property Value

True: Points can be added, inserted or deleted

False: Points can not be added, inserted or deleted<

Default value is False

Explanation

The EditPolylinePointEnabled property sets whether or not to allow points to be added, inserted, or deleted, in Polyline, Polygons, and Pen objects.

By setting both this property and the EditByPoints property to True, it is possible to add, insert, and delete points when Polyline, Polygons, or Pen objects are selected.

Adding points: When an Polyline, Polygon, or Pen object has been selected, move the mouse over the last point in the object. When the cursor changes, right click to display the context menu. Select "Add" in the context menu. The last point of the object and the mouse position will be connected with a line segment. Move the mouse to the location where you want to put the point and double click the mouse. The new point will be added.

Inserting points: When an Polyline, Polygon, or Pen object has been selected, move the mouse over a point of the object. When the mouse cursors changes, right click to display the context menu. Select "Insert" in the context menu. A point will be inserted midway between the selected point and the next point.

Deleting points: When an Polyline, Polygon, or Pen object has been selected, move the mouse over a point of the object. When the mouse cursors changes, right click to display the context menu. Select "Delete" in the context menu. The selected point will be deleted.

Coordinates can be added, inserted, or deleted using the AddPolylinePoint, InsertPolylinePoint, and DeletePolylinePoint methods.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


EmbedSelectedObjects property

Newtone.ImageKit.Win.ImageKit.Edit.EmbedSelectedObjects Property

This property sets whether or not the only the selected objects are embedded (rasterized) into the image.

[Visual Basic] Public Property EmbedSelectedObjects As Boolean
[C#] public bool EmbedSelectedObjects {get; set;}

Property Value

True: Only selected objects will be embedded

False: All objects will be embedded

Default value is False

Explanation

The EmbedSelectedObjects property sets whether or not the only the selected objects are embedded (rasterized) into the image.

When this property is True and the DrawEditedObjectsToImage method is executed, only the selected annotation objects will be embedded into the image.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


EnableTextDialog property

Newtone.ImageKit.Win.ImageKit.Edit.EnableTextDialog Property

This property sets whether the text annotation object will display the text object's extended property dialog or the regular property dialog.

[Visual Basic] Public Property EnableTextDialog As Boolean
[C#] public bool EnableTextDialog {get; set;}

Property Value

True: Text object will display the extended property dialog

False: Text will display the regular property dialog

Default value is False

Explanation

The EnableTextDialog property sets whether the text annotation object will display the text object's extended property dialog or the regular property dialog.

When this property is True and a text annotation object has been selected, right clicking the text object and selecting "propeties" in the context menu or executing the ShowPropertyDialog method will display an extended property dialog, specially designed for the text annotation object.

This property is enabled only for the text annotation object. If another object is selected, even if this property is True, the special text object property dialog will not be displayed.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


EndArrowCap property

Newtone.ImageKit.Win.ImageKit.Edit.EndArrowCap Property

This property sets whether or not the end point of a Line or Polyline object has an arrow cap.

[Visual Basic] Public Property EndArrowCap As Boolean
[C#] public bool EndArrowCap {get; set;}

Property Value

True: The end point has an arrow cap

False: The end point does not have an arrow cap

Default value is False

Explanation

The EndArrowCap property sets whether or not the end point of a Line or Polyline object has an arrow cap.

When both the EndArrowCap property and the EndLineCap property are true, the EndArrowCap property will have priority.

To change an object after it has been drawn, select the object then right click to display the context menu, execute the ShowPropertyDialog method, or set the SelectedObjectEndArrowCap property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


EndArrowCapFilled property

Newtone.ImageKit.Win.ImageKit.Edit.EndArrowCapFilled Property

This property sets whether or not the end point arrow cap of a Line or Polyline object will be filled.

[Visual Basic] Public Property EndArrowCapFilled As Boolean
[C#] public bool EndArrowCapFilled {get; set;}

Property Value

True: The end point arrow cap is filled

False: The end point arrow cap is not filled

Default value is False

Explanation

The EndArrowCapFilled property sets whether or not the end point arrow cap of a Line or Polyline object is filled.

This property is enabled when the EndArrowCap property is True. The appearance of the end arrow cap when it is filled or not filled can be seen below:

To change an object after it has been drawn, select the object then right click to display the context menu, execute the ShowPropertyDialog method, or set the SelectedObjectEndArrowCapFilled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


EndArrowCapSize property

Newtone.ImageKit.Win.ImageKit.Edit.EndArrowCapSize Property

This property sets the size of the end point arrow cap for the Line and Polyline objects.

[Visual Basic] Public Property EndArrowCapSize As Integer
[C#] public int EndArrowCapSize {get; set;}

Property Value

The end point arrow cap size

Default value is 10

Explanation

The EndArrowCapSize property sets the size of the end point arrow cap for the Line and Polyline objects.

When the EndArrowCap property is True, the EndArrowCapSize property determines the size of the end arrow cap. As shown below, "L" represents the length of the end arrow cap in pixels:

To change an object after it has been drawn, select the object then right click to display the context menu, execute the ShowPropertyDialog method, or set the SelectedObjectEndArrowCapSize property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


EndLineCap property

Newtone.ImageKit.Win.ImageKit.Edit.EndLineCap Property

This property sets the style of the end line for the Line, Polyline, and Pen objects.

[Visual Basic] Public Property EndLineCap As System.Drawing.Drawing2D.LineCap
[C#] public System.Drawing.Drawing2D.LineCap EndLineCap {get; set;}

Property Value

A value of type System.Drawing.Drawing2D.LineCap

Default value is System.Drawing.Drawing2D.LineCap.Flat

Explanation

The EndLineCap property sets the style of the end line for the Line, Polyline, and Pen objects.

If the EndArrowCap property is true, it will take priority over the EndLineCap property.

To make changes to an end line cap after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectEndLineCap property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


Fill property

Newtone.ImageKit.Win.ImageKit.Edit.Fill Property

This property sets whether or not the annotation object will be filled with the background color.

[Visual Basic] Public Property Fill As Boolean
[C#] public bool Fill {get; set;}

Property Value

True: The object is filled with the background color

False The object is not filled with the backgroud color

Default value is False

Explanation

The Fill property sets whether or not the annotation object will be filled with the background color.

When True, the color set in the BackColor property will be used to fill the Polygon, Rectangle, RoundRectangle, and Ellipse objects and will be the background color for the Text and Stamp objects. The Line, Polyline, Pen, and Image objects do not use the Fill property.

To make changes to an object after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectFill property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


FontBold property

Newtone.ImageKit.Win.ImageKit.Edit.FontBold Property

This property sets whether or not the font used is bold.

[Visual Basic] Public Property FontBold As Boolean
[C#] public bool FontBold {get; set;}

Property Value

True: The font is bold

False: The font is not bold

Default value is False

Explanation

The FontBold property sets whether or not the font used is bold. Set this property before drawing the text.

To make changes to an object after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectFontBold property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


FontItalic property

Newtone.ImageKit.Win.ImageKit.Edit.FontItalic Property

This property sets whether or not the font used is italics.

[Visual Basic] Public Property FontItalic As Boolean
[C#] public bool FontItalic {get; set;}

Property Value

True: The font is italics

False: The font is not italics

Default value is False

Explanation

The FontItalic property sets whether or not the font used is italics. Set this property before drawing the text.

To make changes to an object after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectFontItalic property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


FontName property

Newtone.ImageKit.Win.ImageKit.Edit.FontName Property

This property sets the font name used to draw text.

[Visual Basic] Public Property FontName As String
[C#] public string FontName {get; set;}

Property Value

The string denoting the font name.

Default value is "Arial"

Explanation

The FontName property sets the font name used to draw text. Set this property before drawing the text.

To make changes to an object after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectFontName property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


FontSize property

Newtone.ImageKit.Win.ImageKit.Edit.FontSize Property

This property sets the font size used to draw text.

[Visual Basic] Public Property FontSize As Single
[C#] public float FontSize {get; set;}

Property Value

The value denoting the size of the font. (in pixels)

Default value is 16.0

Explanation

The FontSize property sets the font size used to draw text. The units of measure are pixels.

Set this property before drawing the text.

To make changes to an object after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectFontSize property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


FontStrikeout property

Newtone.ImageKit.Win.ImageKit.Edit.FontStrikeout Property

This property sets whether or not the font used has strikeout lines.

[Visual Basic] Public Property FontStrikeout As Boolean
[C#] public bool FontStrikeout {get; set;}

Property Value

True: The font has strikeout lines

False: The font does not have strikeout lines

Default value is False

Explanation

The FontStrikeout property sets whether or not the font used has strikeout lines. Set this property before drawing the text.

To make changes to an object after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectFontStrikeout property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


FontUnderline property

Newtone.ImageKit.Win.ImageKit.Edit.FontUnderline Property

This property sets whether or not the font used is underlined.

[Visual Basic] Public Property FontUnderline As Boolean
[C#] public bool FontUnderline {get; set;}

Property Value

True: The font is underlined

False: The font is not underlined

Default value is False

Explanation

The FontUnderline property sets whether or not the font used is underlined. Set this property before drawing the text.

To make changes to an object after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectFontUnderline property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


ForeColor property

Newtone.ImageKit.Win.ImageKit.Edit.ForeColor Property

This property sets the drawing color used for all annotation objects.

[Visual Basic] Public Property ForeColor As Color
[C#] public Color ForeColor {get; set;}

Property Value

Value of type Color

Default value is Black

Explanation

The ForeColor property sets the drawing color used for the Line, Polyline, Polygon, Pen, Rectangle, RoundRectangle, and Ellipse annotation objects. The Image object does not use this property. For the Text and Stamp objects, this ForeColor property sets the font color. Set this property before drawing the text.

To make changes to an object after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectForeColor property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


ForeColor2 property

Newtone.ImageKit.Win.ImageKit.Edit.ForeColor2 Property

This property sets the end color used in the text gradient for the Text and Stamp annotation objects.

[Visual Basic] Public Property ForeColor2 As Color
[C#] public Color ForeColor2 {get; set;}

Property Value

The gradient end color of type System.Drawing.Color

Default value is System.Drawing.Color.Black

Explanation

The ForeColor2 property sets the end color used in the text gradient for the Text and Stamp annotation objects.

This property is valid only when the DesignedTextEnabled property is True and designed text functions are enabled. If this property has the same value as the ForeColor property, there will be no gradation.

The range of the gradient is the drawing range of the text if there is no automatic line break (WordWrap=False), and the range of the text box if there is an automatic line break (WordWrap=True).

Even when gradients are enabled, the opacity of the entire string is determined by the value of the ForeColorOpacity property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


ForeColorOpacity property

Newtone.ImageKit.Win.ImageKit.Edit.ForeColorOpacity Property

This property sets the drawing color used for all annotation objects.

[Visual Basic] Public Property ForeColorOpacity As Integer
[C#] public int ForeColorOpacity {get; set;}

Property Value

The level of opacity.

Default value is 100

Explanation

The ForeColorOpacity property sets the opacity level for the font color used in the Line, Polyline, Polygon, Pen, Rectangle, RoundRectangle, and Ellipse objects. The Image object does not use this property. For the Text and Stamp objects, this ForeColor property sets the opacity of the font color.

Values range from 0 to 100, as the value increases opacity increases. 0 represents total transparency, 100 represents total opacity.

To make changes to an fore color opacity after the text has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectForeColorOpacity property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


HatchStyle property

Newtone.ImageKit.Win.ImageKit.Edit.HatchStyle Property

This property sets the hatch style of the custom brush.

[Visual Basic] Public Property HatchStyle As System.Drawing.Drawing2D.HatchStyle
[C#] public System.Drawing.Drawing2D.HatchStyle HatchStyle {get; set;}

Property Value

Value of type System.Drawing.Drawing2D.HatchStyle

Default value is System.Drawing.Drawing2D.HatchStyle.DiagonalCross

Explanation

The HatchStyle property sets the hatch style of the custom brush.

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


HideMultiSelectedPoints property

Newtone.ImageKit.Win.ImageKit.Edit.HideMultiSelectedPoints Property

This property sets whether or not the points that indicate the individual objects within the multiselected area are displayed.

[Visual Basic] Public Property HideMultiSelectedPoints As Boolean
[C#] public bool HideMultiSelectedPoints {get; set;}

Property Value

True: The points indicating individual objects within the multiselected area are hidden (The points are NOT displayed)

False: The points indicating individual objects within the multiselected area are NOT hidden (The points are displayed)

Default value is False

Explanation

The HideMultiSelectedPoints property sets whether or not the points that indicate the individual objects within the multiselected area are displayed. When this property is False and multiple objects are selected, each object within the selection area is indicated by points displayed at appropriate corners or borders of the objects. This is the default value. Setting the HideMultiSelectedPoints property to True will hide the points that indicate each individual object within the multiselected area. Setting this property to True is useful when a large number of complex objects are selected and displaying the points indicating each object would clutter the overall view of the multiple objects.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


HideSelectionBorder property

Newtone.ImageKit.Win.ImageKit.Edit.HideSelectionBorder Property

This property sets whether or not a "selection border" is hidden when an object is selected.

[Visual Basic] Public Property HideSelectionBorder As Boolean
[C#] public bool HideSelectionBorder {get; set;}

Property Value

True: A selection border is hidden (Selection border is NOT displayed)

False: A selection border is not hidden (Selection border is displayed)

Default value is False

Explanation

The HideSelectionBorder property sets whether or not the "selection border" is hidden when the object has been selected. When this property is False and an object is selected, the "selection border" around the object is displayed. This is the default. Setting the HideSelectBorder property to True will hide the "selection border" when an object is selected. When this property is True, objects cannot be selected with the mouse and can only be selected using the SelectObject method.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


HideTextShadow property

Newtone.ImageKit.Win.ImageKit.Edit.HideTextShadow Property

This property sets whether or not text shadows are hidden.

[Visual Basic] Public Property HideTextShadow As Boolean
[C#] public bool HideTextShadow {get; set;}

Property Value

True: Text shadows are hidden (NOT displayed)

False: Text shadows are displayed

Default value is False

Explanation

The HideTextShadow property sets whether or not text shadows are hidden.

When the DesignedTextEnabled property is True and text shadowing is enabled, setting the HideTextShadow property will hide the shadows.

If the image is large and contains many objects including Text and Stamp objects displaying shadows, performance may suffer when editing objects. In such cases, set this property to True to hide shadows. Shadows are displayed by default.

Note: Even if this property is set to True, the shadow display/hide will not be automatically switched before and after the operation. When using it, set this property to True in the StartDrawObject, StartEditObject events, etc. And write the code to return to False in the EndDrawObject, EndEditObject events, etc.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


HideTextShadowInEditing property

Newtone.ImageKit.Win.ImageKit.Edit.HideTextShadowInEditing Property

This property sets whether or not shadows are hidden when editing objects or drawing Pen, Polygon, and Polyline objects.

[Visual Basic] Public Property HideTextShadowInEditing As Boolean
[C#] public bool HideTextShadowInEditing {get; set;}

Property Value

True: Shadows are NOT displayed

False: Shadows are displayed

Default value is False

Explanation

The HideTextShadowInEditing property sets whether or not shadows are hidden when editing objects or drawing Pen, Polygon, and Polyline objects.

When the DesignedTextEnabled property is True and text shadowing is enabled, setting the HideTextShadowInEditing property will hide the shadows while editing objects or drawing Pen, Polygon, and Polyline objects.

If the image is large and there are many large objects, performance may suffer. In such cases, set this property to True to display shadows.

Shadows are displayed by default.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


ImageFileExtension property

Newtone.ImageKit.Win.ImageKit.Edit.ImageFileExtension Property

When an image file is chosen for an image object and the File Dialog is displayed, this property sets the file type that first appears in the File Dialog.

[Visual Basic] Public Property ImageFileExtension As String
[C#] public string ImageFileExtension {get; set;}

Property Value

The string representing the file type that first appears in the File Dialog

Explanation

When an image file is chosen for an image object and the File Dialog is displayed, the ImageFileExtension property sets the file type that first appears in the File Dialog.

The syntax is as follows: First is the explanation of the file type followed by a "|", then the file extension. If multiple file extensions appear after a single explanation, use a semicolon ";" between file extentions. For multiple explanations and file extensions, continue after the "|" with another explanation followed by "|" and so on. These will be added as seperate items in the combo box that appears in the File Dialog. If you put a blank string ("") in this property then the item "All Files" will appear in the combo box. Capital letters and lower case letters are treated as the same.

Examples:

If the default folder is "C:\Images" and the three items you want to appear are: "BMP", "JPG,PNG", and "All Files" then:

Visual Basic.NET:
ImageKit1.Edit.ImageFilePath = "c:\images"
ImageKit1.Edit.ImageFileExtension = "Bitmap Files | *.bmp | Jpeg, Png Files | *.jpg;*.png | All Files | *.*"

Visual C#.NET:
imageKit1.Edit.ImageFilePath = "c:\\images"
imageKit1.Edit.ImageFileExtension = "Bitmap Files
                | *.bmp | Jpeg, Png Files | *.jpg;*.png | All Files | *.*";

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


ImageFilePath property

Newtone.ImageKit.Win.ImageKit.Edit.ImageFilePath Property

When an image file is chosen for an image object and the File Dialog is displayed, this property sets the folder that first appears in the File Dialog.

[Visual Basic] Public Property ImageFilePath As String
[C#] public string ImageFilePath {get; set;}

Property Value

The string representing the folder that first appears in the File Dialog

Explanation

When an image file is chosen for an image object and the File Dialog is displayed, the ImageFilePath property sets the folder that first appears in the File Dialog.

If you set a blank string ("") in this property then the default folder appears in the File Dialog. The default folder is the current execution folder. Capital letters and lower case letters are treated as the same.

Examples:

If the default folder is "C:\Images" and the three items you want to appear are: "BMP", "JPG,PNG", and "All Files" then:

Visual Basic.NET:
ImageKit1.Edit.ImageFilePath = "c:\images"
ImageKit1.Edit.ImageFileExtension = "Bitmap Files | *.bmp | Jpeg, Png Files | *.jpg;*.png | All Files | *.*"

Visual C#.NET:
imageKit1.Edit.ImageFilePath = "c:\\images"
imageKit1.Edit.ImageFileExtension = "Bitmap Files
                | *.bmp | Jpeg, Png Files | *.jpg;*.png | All Files | *.*";

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


ImeMode property

Newtone.ImageKit.Win.ImageKit.Edit.ImeMode Property

This property sets the ImeMode when entering Japanese text. (This property is not needed and may be ignored unless you are using Japanese operating systems)

[Visual Basic] Public Property ImeMode As System.Windows.Forms.ImeMode
[C#] public System.Windows.Forms.ImeMode ImeMode {get; set;}

Property Value

System.Windows.Forms.ImeMode Value

The default value is System.Windows.Forms.ImeMode.Off.

Explanation

This property sets the ImeMode when entering Japanese text. (This property is not needed and may be ignored unless you are using Japanese operating systems)

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


IsWritingText property

Newtone.ImageKit.Win.ImageKit.Edit.IsWritingText Property

This property retrieves whether or not text is being entered in a Text or Stamp annotation object.

[Visual Basic] Public ReadOnly Property IsWritingText As Boolean
[C#] public bool IsWritingText {get;}

Property Value

True: Text is being entered in a Text or Stamp annotation object

False: Text is not being entered in a Text or Stamp annotation object

Default value is False

Explanation

The IsWritingText property retrieves whether or not text is being entered in a Text or Stamp annotation object.

When the mouse (or keyboard) is used to draw a Text or Stamp annotation object, as the mouse drag beings drawing the Text or Stamp object, this property value becomes True. It remains True until the text has been entered and the mouse is clicked outside of the Text or Stamp object. At that point the IsWritingText property becomes False. Also when text is being editing in a Text or Stamp object, the IsWritingText property becomes True until the mouse is clicked outside of the Text or Stamp annotation object or that object has been deleted. At that point the IsWritingText property becomes False again.

If, while editing the text in a Text or Stamp object, you click outside of that object and drag the mouse to create another Text or Stamp object, the IsWritingText property will remain True.

When a method is used to draw a Text object, this property will remain False.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


LimitAnnotationPosition property

Newtone.ImageKit.Win.ImageKit.Edit.LimitAnnotationPosition Property

This property sets whether or not an annotation object, when drawn, moved, enlarged, rotated, or pasted, is automatically positioned entirely within the image area.

[Visual Basic] Public Property LimitAnnotationPosition As Boolean
[C#] public bool LimitAnnotationPosition {get; set;}

Property Value

True: The annotation object is automatically positioned to be entirely within the image area

False: The annotation object is not automatically positioned and can be outside the image area

Default value is True

Explanation

The LimitAnnotationPosition property sets whether or not an annotation object, when drawn, moved, enlarged, rotated, or pasted, is automatically positioned entirely within the image area.

When the LimitAnnotationPosition property is True, regardless of the values set in the LimitDrawPosition property, LimitMovePosition property, LimitPastePosition property, LimitRotatePosition property, and LimitZoomPosition property, then when an object is drawn, moved, enlarged, rotated, or pasted, it will automatically be positioned so that the entire object is within the area of the image on which the annotation object is placed.

When the LimitAnnotationPosition property is False, whether or not the annotation object will be repositioned within the image area will depend on the values set in the the LimitDrawPosition property, LimitMovePosition property, LimitPastePosition property, LimitRotatePosition property, and LimitZoomPosition property.

NOTE: Even if the LimitAnnotationPosition property is True, if an annotation object is loaded from an annotation file and that annotation file defines the object's position outside the image area, the object will NOT automatically be repositioned.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


LimitDrawPosition property

Newtone.ImageKit.Win.ImageKit.Edit.LimitDrawPosition Property

This property sets whether or not an annotation object, when drawn, is automatically positioned entirely within the image area.

[Visual Basic] Public Property LimitDrawPosition As Boolean
[C#] public bool LimitDrawPosition {get; set;}

Property Value

True: The annotation object is automatically positioned to be entirely within the image area

False: The annotation object is not automatically positioned and can be outside the image area

Default value is True

Explanation

The LimitDrawPosition property sets whether or not an annotation object, when drawn, is automatically positioned entirely within the image area.

When the LimitDrawPosition property is True, when an object is drawn, it will automatically be positioned so that the entire object is within the area of the image on which the annotation object is placed. This property is valid only when the when the LimitAnnotationPosition property is False. If the LimitAnnotationPosition is True, the object will automatically be repositioned regardless of the value of the LimitDrawPosition property.

When the LimitDrawPosition property property is False AND the LimitAnnotationPosition property is False, the annotation object will not be repositioned when it is drawn and part or all of the annotation object may be drawn outside of the image area.

NOTE: If an annotation object is loaded from an annotation file and that annotation file defines the object's position outside the image area, the object will NOT be repositioned.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


LimitMovePosition property

Newtone.ImageKit.Win.ImageKit.Edit.LimitMovePosition Property

This property sets whether or not an annotation object, when moved, is automatically positioned entirely within the image area.

[Visual Basic] Public Property LimitMovePosition As Boolean
[C#] public bool LimitMovePosition {get; set;}

Property Value

True: The annotation object is automatically positioned to be entirely within the image area

False: The annotation object is not automatically positioned and can be outside the image area

Default value is True

Explanation

The LimitMovePosition property sets whether or not an annotation object, when moved, is automatically positioned entirely within the image area.

When the LimitMovePosition property is True, when an object is moved, it will automatically be positioned so that the entire object is within the area of the image on which the annotation object is placed. This property is valid only when the when the LimitAnnotationPosition property is False. If the LimitAnnotationPosition is True, the object will automatically be repositioned regardless of the value of the LimitMovePosition property.

When the LimitMovePosition property property is False AND the LimitAnnotationPosition property is False, the annotation object will not be repositioned when it is moved and part or all of the annotation object may be drawn outside of the image area.

NOTE: If an annotation object is loaded from an annotation file and that annotation file defines the object's position outside the image area, the object will NOT be repositioned.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


LimitPastePosition property

Newtone.ImageKit.Win.ImageKit.Edit.LimitPastePosition Property

This property sets whether or not an annotation object, when pasted, is automatically positioned entirely within the image area.

[Visual Basic] Public Property LimitPastePosition As Boolean
[C#] public bool LimitPastePosition {get; set;}

Property Value

True: The annotation object is automatically positioned to be entirely within the image area

False: The annotation object is not automatically positioned and can be outside the image area

Default value is True

Explanation

The LimitPastePosition property sets whether or not an annotation object, when pasted, is automatically positioned entirely within the image area.

When the LimitPastePosition property is True, when an object is pasted, it will automatically be positioned so that the entire object is within the area of the image on which the annotation object is placed. This property is valid only when the when the LimitAnnotationPosition property is False. If the LimitAnnotationPosition is True, the object will automatically be repositioned regardless of the value of the LimitPastePosition property.

When the LimitPastePosition property property is False AND the LimitAnnotationPosition property is False, the annotation object will not be repositioned when it is pasted and part or all of the annotation object may be drawn outside of the image area.

NOTE: If an annotation object is loaded from an annotation file and that annotation file defines the object's position outside the image area, the object will NOT be repositioned.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


LimitRotatePosition property

Newtone.ImageKit.Win.ImageKit.Edit.LimitRotatePosition Property

This property sets whether or not an annotation object, when rotated, is automatically positioned entirely within the image area.

[Visual Basic] Public Property LimitRotatePosition As Boolean
[C#] public bool LimitRotatePosition {get; set;}

Property Value

True: The annotation object is automatically positioned to be entirely within the image area

False: The annotation object is not automatically positioned and can be outside the image area

Default value is True

Explanation

The LimitRotatePosition property sets whether or not an annotation object, when rotated, is automatically positioned entirely within the image area.

When the LimitRotatePosition property is True, when an object is rotated, it will automatically be positioned so that the entire object is within the area of the image on which the annotation object is placed. This property is valid only when the when the LimitAnnotationPosition property is False. If the LimitAnnotationPosition is True, the object will automatically be repositioned regardless of the value of the LimitRotatePosition property.

When the LimitRotatePosition property property is False AND the LimitAnnotationPosition property is False, the annotation object will not be repositioned when it is rotated and part or all of the annotation object may be drawn outside of the image area.

NOTE: If an annotation object is loaded from an annotation file and that annotation file defines the object's position outside the image area, the object will NOT be repositioned.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


LimitZoomPosition property

Newtone.ImageKit.Win.ImageKit.Edit.LimitZoomPosition Property

This property sets whether or not an annotation object, when enlarged, is automatically positioned entirely within the image area.

[Visual Basic] Public Property LimitZoomPosition As Boolean
[C#] public bool LimitZoomPosition {get; set;}

Property Value

True: The annotation object is automatically positioned to be entirely within the image area

False: The annotation object is not automatically positioned and can be outside the image area

Default value is True

Explanation

The LimitZoomPosition property sets whether or not an annotation object, when enlarged, is automatically positioned entirely within the image area.

When the LimitZoomPosition property is True, when an object is enlarged, it will automatically be positioned so that the entire object is within the area of the image on which the annotation object is placed. This property is valid only when the when the LimitAnnotationPosition property is False. If the LimitAnnotationPosition is True, the object will automatically be repositioned regardless of the value of the LimitZoomPosition property.

When the LimitZoomPosition property property is False AND the LimitAnnotationPosition property is False, the annotation object will not be repositioned when it is enlarged and part or all of the annotation object may be drawn outside of the image area.

NOTE: If an annotation object is loaded from an annotation file and that annotation file defines the object's position outside the image area, the object will NOT be repositioned.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


LinearGradientMode property

Newtone.ImageKit.Win.ImageKit.Edit.LinearGradientMode Property

This property sets the gradient direction for the custom brush when BrushKind is set to LinearGradientBrush.

[Visual Basic] Public Property LinearGradientMode As System.Drawing.Drawing2D.LinearGradientMode
[C#] public System.Drawing.Drawing2D.LinearGradientMode LinearGradientMode {get; set;}

Property Value

Value of type System.Drawing.Drawing2D.LinearGradientMode
Horizontal (0): Gradation from left to right
Vertical (1): Gradation from left to right
ForwardDiagonal (2): Gradation from top left to bottom right
BackwardDiagonal (2): Gradation from top right to bottom left

Default value is System.Drawing.Drawing2D.LinearGradientMode.Horizontal

Explanation

The LinearGradientMode property sets the gradient direction for the custom brush when BrushKind is set to LinearGradientBrush

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


LineJoin property

Newtone.ImageKit.Win.ImageKit.Edit.LineJoin Property

This property sets the type of line join for Polyline, Polygon, and Pen objects.

[Visual Basic] Public Property LineJoin As System.Drawing.Drawing2D.LineJoin
[C#] public System.Drawing.Drawing2D.LineJoin LineJoin {get; set;}

Property Value

Value of type System.Drawing.Drawing2D.LineJoin

Default value is System.Drawing.Drawing2D.LineJoin.Round

Explanation

The LineJoin property sets the type of line join for Polyline, Polygon, and Pen objects.

To change the line join after the object has been drawn, right click on the object to display the context menu, execute the ShowPropertyDialog method to display the properties dialog, or set the SelectedObjectLineJoin property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


MultiResizeMinHeight property

Newtone.ImageKit.Win.ImageKit.Edit.MultiResizeMinHeight Property

This property sets the minimum height of the entire selection area when enlarging or reducing the area containing multiple selected objects.

[Visual Basic] Public Property MultiResizeMinHeight As Integer
[C#] public int MultiResizeMinHeight {get; set;}

Property Value

Integer value indicating height
Default value: 100 pixels

Explanation

The MultiResizeMinHeight property sets the minimum height of the entire selection area when enlarging or reducing the area containing multiple selected objects. The unit is pixels.

This property's minimum value is 10. Values of less than 10 will automatically set to 10. If the value of this property is set smaller than the value set in the MultiResizeMinHeightEachObject property, this property's value will automatically be set to the value of the MultiResizeMinHeightEachObject property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


MultiResizeMinHeightEachObject property

Newtone.ImageKit.Win.ImageKit.Edit.MultiResizeMinHeightEachObject Property

This property sets the minimum height of each selected object when reducing the size of the area containing multiple selected objects.

[Visual Basic] Public Property MultiResizeMinHeightEachObject As Integer
[C#] public int MultiResizeMinHeightEachObject {get; set;}

Property Value

Integer value indicating height
Default value: 100 pixels

Explanation

The MultiResizeMinHeightEachObject property sets the minimum height of each selected object when reducing the size of the area containing multiple selected objects. The unit is pixels.

This property value is common to all objects and cannot be set for each individual object. When multiple objects are selected and the selected area's size is reduced, if the height of each selected object reaches the value of this property, the height of the object will not be reduced any further.

Even if the total height of the multi-selected area has been reduced but the height of the entire selection area has not yet reached the value set in the MultiResizeMinHeight property, the vertical direction of the object will not shrink beyond the value set in the MultiResizeMinHeightEachObject property.

Resizing the multi-selected area basically retains the relative positional relationship of the objects contained within the selection area, but in some cases, the positional relationship of some objects may change.

Example

In this example, we grab the left side of the selection area and drag it to the right to reduce its size (This is a horizontal example, but the same applies to the vertical direction)

1. Because of this, the selection area shrinks from the left side to the right side. The relative positional relationship of the objects is preserved and their sizes are reduced.

2. The width of object [a] does not shrink any further because the width value of wd1 of object [a] is now the value of the MultiResizeWidthEachObject property. The overall width of the selection area is still larger than the value of the MultiResizeMinWidth property, so the selection area still shrinks in size. The relative positional relationship of the objects [a] [b] [c] also holds as in initial situation 1.

3. The total width value of wd2 has reached the value of the MultiResizeMinWidth property and the selection area cannot be reduced in size any further. The object [a] remains the width as explained in situation 2, but its position relative to [b] [c] has changed.

The minimum value for the MultiResizeMinHeightEachObject property is 10, and if you try to set it less than 10, it will be automatically set to 10. If the value set in the MultiResizeMinHeight property is smaller than the value set in this property, the value of the MultiResizeMinHeight property will be automatically set to the value of this property.

Also See>ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


MultiResizeMinWidth property

Newtone.ImageKit.Win.ImageKit.Edit.MultiResizeMinWidth Property

This property sets the minimum width of the entire selection area when enlarging or reducing the area containing multiple selected objects.

[Visual Basic] Public Property MultiResizeMinWidth As Integer
[C#] public int MultiResizeMinWidth {get; set;}

Property Value

Integer value indicating width
Default value: 100 pixels

Explanation

The MultiResizeMinWidth property sets the minimum width of the entire selection area when enlarging or reducing the area containing multiple selected objects. The unit is pixels.

This property's minimum value is 10. Values of less than 10 will automatically set to 10. If the value of this property is set smaller than the value set in the MultiResizeMinWidthEachObject property, this property's value will automatically be set to the value of the MultiResizeMinWidthEachObject property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


MultiResizeMinWidthEachObject property

Newtone.ImageKit.Win.ImageKit.Edit.MultiResizeMinWidthEachObject Property

This property sets the minimum width of each selected object when reducing the size of the area containing multiple selected objects.

[Visual Basic] Public Property MultiResizeMinWidthEachObject As Integer
[C#] public int MultiResizeMinWidthEachObject {get; set;}

Property Value

Integer value indicating width
Default value: 100 pixels

Explanation

The MultiResizeMinWidthEachObject property sets the minimum width of each selected object when reducing the size of the area containing multiple selected objects. The unit is pixels.

This property value is common to all objects and cannot be set for each individual object. When multiple objects are selected and the selected area's size is reduced, if the width of each selected object reaches the value of this property, the width of the object will not be reduced any further.

Even if the total width of the multi-selected area has been reduced but the width of the entire selection area has not yet reached the value set in the MultiResizeMinWidth property, the horizontal direction of the object will not shrink beyond the value set in the MultiResizeMinWidthtEachObject property.

Resizing the multi-selected area basically retains the relative positional relationship of the objects contained within the selection area, but in some cases, the positional relationship of some objects may change.

Example

In this example, we grab the left side of the selection area and drag it to the right to reduce its size (This is a horizontal example, but the same applies to the vertical direction)

1. Because of this, the selection area shrinks from the left side to the right side. The relative positional relationship of the objects is preserved and their sizes are reduced.

2. The width of object [a] does not shrink any further because the width value of wd1 of object [a] is now the value of the MultiResizeWidthEachObject property. The overall width of the selection area is still larger than the value of the MultiResizeMinWidth property, so the selection area still shrinks in size. The relative positional relationship of the objects [a] [b] [c] also holds as in initial situation 1.

3. The total width value of wd2 has reached the value of the MultiResizeMinWidth property and the selection area cannot be reduced in size any further. The object [a] remains the width as explained in situation 2, but its position relative to [b] [c] has changed.

The minimum value for the MultiResizeMinWidthEachObject property is 10, and if you try to set it less than 10, it will be automatically set to 10. If the value set in the MultiResizeMinWidth property is smaller than the value set in this property, the value of the MultiResizeMinWidth property will be automatically set to the value of this property.

Also See>ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


MultiSelectedObjectsArray property

Newtone.ImageKit.Win.ImageKit.Edit.MultiSelectedObjectsArray Property

This property retrieves the object numbers from multiple selected objects

[Visual Basic] Public ReadOnly Property MultiSelectedObjectsArray As Integer()
[C#] int[] MultiSelectedObjectsArray {get;}

Property Value

An integer array representing the numbers of the objects that have been selected

Explanation

The MultiSelectedObjectsArray property retrieves an array containing the object numbers of the multiple selected objects.

Object numbers of annotation objects assigned to the objects in the order that they are created. They are the object's z-order. When you use multi-select to select a group of annotation objects, the MultiSelectedObjectsArray property will return an array containing the object numbers from lowest to highest. The array starts with element [1]. Element [1] will contain the object number of the object lowest in z-order of all the objects that have been selected. In other words, this is the object "below" the other the other objects.

For example: The object number for the third object (or the object third in the z-order) selected is returned in [3].

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


MultiSelectedObjectsNumbers property

Newtone.ImageKit.Win.ImageKit.Edit.MultiSelectedObjectsNumbers Property

This property retrieves the object numbers from multiple selected objects

[Visual Basic] Public ReadOnly Property MultiSelectedObjectsNumbers As System.Collections.Generic.List(Of Integer)
[C#] public System.Collections.Generic.List< int > MultiSelectedObjectsNumbers {get;}

Property Value

Value representing the object number. Type System.Collections.Generic.List< int >

Explanation

This property has been replaced by the MultiSelectedObjectsArray property. This property is being maintained for backwards compatibility. Please use the MultiSelectedObjectsArray property instead of this property.

The MultiSelectedObjectsNumbers property retrieves the object numbers from multiple selected objects and generates a List.

The array starts with element [0]. Element [0] will contain the object number of the object lowest in z-order of all the objects that have been selected. In other words, this is the object "below" the other the other objects.

For example: The object number for the third object (or the object third in the z-order) selected is returned in [2].

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


Notes property

Newtone.ImageKit.Win.ImageKit.Edit.Notes Property

This property sets or retrieves the contents of an object's notes.

[Visual Basic] Public Property Notes As String
[C#] public string Notes {get; set;}

Property Value

The contents of an annotation object's notes (Type: string)

Default value is null (Nothing in Visual Basic)

Explanation

The Notes property sets or retrieves the contents of an object's note. Using this property, a note can be attached to each annotation object which can be used to store object specific information. The contents of the Notes property are not displayed and have no impact on the display of the object. It is merely a convenient place to store information about a particular object.

Because the contents of the Notes property is a string, it is useful for storing a variety object specific information. There are no internal limits to the length of the string this property can accept.

To make changes to the contents of the Notes property after the object has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectNotes property. To display the value of the Notes property in an object's "Property" dialog, set the DialogNotesVisible property to True.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


NumberOfObjects property

Newtone.ImageKit.Win.ImageKit.Edit.NumberOfObjects Property

This property retrieves the total number of annotation objects drawn on the image.

[Visual Basic] Public ReadOnly Property NumberOfObjects As Integer
[C#] public int NumberOfObjects {get;}

Property Value

An integer representing the number of annotation objects
Default value is 0.

Explanation

The NumberOfObjects property retrieves the total number of annotation objects drawn on the image.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


PastePoint property

Newtone.ImageKit.Win.ImageKit.Edit.PastePoint Property

This property sets the top left coordinates of the location where an object will be pasted.

[Visual Basic] Public Property PastePoint As System.Drawing.Point
[C#] public System.Drawing.Point PastePoint {get; set;}

Property Value

The top left coordinates where the object is pasted. Value of type System.Drawing.Point

Explanation

The PastePoint property sets the top left coordinates of the location where an object will be pasted.

This property applies to pasting objects using the Toolbar or PasteCopiedObjects method. When pasting objects using the context menu item, "Paste", the location where the object is pasted is determinde by the coordinates on the image where the mouse was "right clicked" to display the context menu.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


PenWidth property

Newtone.ImageKit.Win.ImageKit.Edit.PenWidth Property

This property sets the width of the pen used for editing and for annotation objects.

[Visual Basic] Public Property PenWidth As Integer
[C#] public int PenWidth {get; set;}

Property Value

The width of the pen in pixels

Default value is 1

Explanation

The PenWidth property sets the width of the pen used for editing and for annotation objects. This property determines the width of the line for the Line, Polyline, Polygon, Rectangle, RoundRectangle, Ellipse, and Pen objects. It also determines the width of the border for the Text and Stamp objects. The unit of measurement is pixel. This property does not apply to the Image object.

To make changes to the pen width after an object has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectPenWidth property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


RefinePasteImage property

Newtone.ImageKit.Win.ImageKit.Edit.RefinePasteImage Property

This property sets whether or not the Image object displays images in high quality.

[Visual Basic] Public Property RefinePasteImage As Boolean
[C#] public bool RefinePasteImage {get; set;}

Property Value

True: The Image object uses high quality
False: The Image object does not use high quality

Default value is True

Explanation

The RefinePasteImage property sets whether or not the Image object displays images in high quality. If your image contains text and you do not want the edges of the text to be "smoothed", then set this property to False. To change the RefinePasteImage after the object has been drawn, right click on the object to display the context menu, execute the ShowPropertyDialog method to display the properties dialog, or set the SelectedObjectRefinePasteImage property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


ResizeTextOnCenter property

Newtone.ImageKit.Win.ImageKit.Edit.ResizeTextOnCenter Property

This property determines how the text and stamp object's size will change when these objects are resized with the mouse.

[Visual Basic] Public Property ResizeTextOnCenter As Boolean
[C#] public bool ResizeTextOnCenter {get; set;}

Property Value

True: The object is resized around the center of the object

False: The object is resized using the point of the object's selection border that was "grabbed" with the mouse.

Default value is True

Explanation

The ResizeTextOnCenter property determines how the text and stamp object's size will change when these objects are resized with the mouse.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


RightToLeft property

Newtone.ImageKit.Win.ImageKit.Edit.RightToLeft Property

This property sets whether or not text in the Text and Stamp objects is displayed from right to left.

[Visual Basic] Public Property RightToLeft As Boolean
[C#] public bool RightToLeft {get; set;}

Property Value

True: Text is displayed from right to left
False: Text is displayed from left to right

Default value is False

Explanation

The RightToLeft property sets whether or not text in the Text and Stamp objects is displayed from right to left.

To change the text display after the object has been drawn, right click on the object to display the context menu, execute the ShowPropertyDialog method to display the properies dialog, or set the SelectedObjectRightToLeft property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


RoundRectangleRadius property

Newtone.ImageKit.Win.ImageKit.Edit.RoundRectangleRadius Property

This property sets the radius for the rounded corners of the RoundRectangle and Stamp objects.

[Visual Basic] Public Property RoundRectangleRadius As Integer
[C#] public int RoundRectangleRadius {get; set;}

Property Value

An integer value representing the radius for rounded corners

Default value is 10

Explanation

The RoundRectangleRadius property sets the radius for the rounded corners of the RoundRectangle and Stamp objects.

To change the radius after the object has been drawn, right click on the object to display the context menu, execute the ShowPropertyDialog method to display the properties dialog, or set the SelectedObjectRoundRectangleRadius property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SaveAnnotationSelectedObjects property

Newtone.ImageKit.Win.ImageKit.Edit.SaveAnnotationSelectedObjects Property

This property sets whether or not only selected objects are saved to annotation file.

[Visual Basic] Public Property SaveAnnotationSelectedObjects As Boolean
[C#] public bool SaveAnnotationSelectedObjects {get; set;}

Property Value

True: Only selected objects are saved to annotation file
False: All objects are saved to annotation file

Default value is False

Explanation

The SaveAnnotationSelectedObjects property sets whether or not only selected objects are saved to annotation file. When this property is True and the SaveAnnotationFile method is executed, only those objects that are selected at that time will be saved to annotation file.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectAngle property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectAngle Property

This property sets the angle of the selected object.

[Visual Basic] Public Property SelectedObjectAngle As Single
[C#] public float SelectedObjectAngle {get; set;}

Property Value

A value representing the angle of the object

Default value is 0

Explanation

The SelectedObjectAngle property sets the angle of the selected object. If the selected object is a Polyline, Polygon, or Pen object then this property value will be 0. (These objects are drawn with a location and coordinate information only. Angle information is ignored.)

When the EditKind property is set to a value other than KindOfEdit.Select or when no objects have been selected, this property value will be 0.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectAspectRatio property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectAspectRatio Property

This property sets whether or not the aspect ratio (the ratio of height to width) for the image displayed in the Image object is maintained.

[Visual Basic] Public Property SelectedObjectAspectRatio As Boolean
[C#] public bool SelectedObjectAspectRatio {get; set;}

Property Value

True: The image's aspect ratio is fixed

False: The image's aspect ratio is NOT fixed

Default value is True

Explanation

The SelectedObjectAspectRatio property sets whether or not the aspect ratio (the ratio of height to width) for the image displayed in the Image object is maintained.

When this property is True, and a image object is displayed in an Image object, the image's original height to width ratio will be maintained. When this property is false, the image will be stretched to fit the dimensions of the image annotation object.

When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not an Image object, the SelectedObjectAspectRatio property value will be False.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectBackColor property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectBackColor Property

This property sets the selected object's background color or fill color.

[Visual Basic] Public Property SelectedObjectBackColor As Color
[C#] public Color SelectedObjectBackColor {get; set;}

Property Value

A value of type Color representing the background or fill color.
Default value is Color.Empty

Explanation

The SelectedObjectBackColor property sets the selected object's background color or fill color.

This property is enabled when the selected object is the Rectangle, RoundedRectangle, Ellipse, Polygon, Text, or Stamp object. Otherwise this property is disabled.

When the EditKind property is set to values other than KindOfEdit.Select or when no object has been selected, this property value will be Color.Empty.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectBackColorOpacity property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectBackColorOpacity Property

This property sets the level of opacity for the selected object's background color or fill color.

[Visual Basic] Public Property SelectedObjectBackColorOpacity As Integer
[C#] public int SelectedObjectBackColorOpacity {get; set;}

Property Value

A value representing the level of opacity.
Default value is 100

Explanation

The SelectedObjectBackColorOpacity property sets the level of opacity for the selected object's background color or fill color.

This property is enabled when the selected object is the Rectangle, RoundedRectangle, Ellipse, Polygon, Text, or Stamp object. Otherwise this property is disabled.

When the EditKind property is set to values other than KindOfEdit.Select or when no object has been selected, this property value will be 100.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectBorder property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectBorder Property

This property sets whether or not the selected Text or Stamp object has a border.

[Visual Basic] Public Property SelectedObjectBorder As Boolean
[C#] public bool SelectedObjectBorder {get; set;}

Property Value

True: The selected Text object has a border

False: The selected Text object does NOT have a border

Default value is False

Explanation

The SelectedObjectBorder property sets whether or not the selected Text or Stamp object has a border.

It is enabled only when the selected object is a Text or Stamp object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Text or Stamp object, the SelectedObjectBorder property value will be False.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectBorderColor property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectBorderColor Property

This property sets the border color of the selected Text or Stamp object.

[Visual Basic] Public Property SelectedObjectBorderColor As Color
[C#] public Color SelectedObjectBorderColor {get; set;}

Property Value

Value of type Color

Default value is Black

Explanation

The SelectedObjectBorderColor property retrieves the border color of the selected Text or Stamp object.

This property refers to the border color of the selected Text or Stamp object. It is enabled only when the selected object is a Text or Stamp object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Text or Stamp object, the SelectedObjectBorderColor property value will be Color.Empty.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectBorderColorOpacity property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectBorderColorOpacity Property

This property sets the level of opacity for the border color of the selected Text or Stamp object.

[Visual Basic] Public Property SelectedObjectBorderColorOpacity As Integer
[C#] public int SelectedObjectBorderColorOpacity {get; set;}

Property Value

A value representing the level of opacity

Default value is 100

Explanation

The SelectedObjectBorderColorOpacity property sets the level of opacity for the border color of the selected Text or Stamp object.

This property refers to the level of opacity for the border color of the selected Text or Stamp object. It is enabled only when the selected object is a Text or Stamp object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Text or Stamp object, the SelectedObjectBorderColorOpacity property value will be 100.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectBorderShape property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectBorderShape Property

This property sets the border shape of the selected Stamp annotation object.

[Visual Basic] Public Property SelectedObjectBorderShape As Shape
[C#] public Shape SelectedObjectBorderShape {get; set;}

Property Value

Value of type Shape

Default value is Shape.RoundRectangle

Explanation

The SelectedObjectBorderShape property sets the border color of the selected Stamp annotation object.

This property refers to the border shape of the selected Stamp object. It is enabled only when the selected object is a Stamp object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Stamp object, the SelectedObjectBorderShape property value will be Shape.RoundRectangle.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectBrushKind property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectBrushKind Property

This property sets the brush type for the custom brush used in the selected object.

[Visual Basic] Public Property SelectedObjectBrushKind As KindOfBrush
[C#] public BrushOfKind SelectedObjectBrushKind {get; set;}

Property Value

A value of type KindOfBrush

Default value is KindOfBrush.Solid

Explanation

The SelectedObjectBrushKind property sets the type of brush used for the custom brush in the selected object.

For details on the custom brush, refer to the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectClosePenLine property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectClosePenLine Property

This property sets whether or not the selected Pen object's start and end points are connected with a line.

[Visual Basic] Public Property SelectedObjectClosePenLine As Boolean
[C#] public bool SelectedObjectClosePenLine {get; set;}

Property Value

True: The selected Pen object's start and end points are connected with a line

False: The selected Pen object's start and end points are NOT connected with a line

Default value is False

Explanation

The SelectedObjectClosePenLine property sets whether or not the selected Pen object's start and end points are connected with a line.

It is enabled only when the selected object is a Pen object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Pen object, the SelectedObjectClosePenLine property value will be False.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectCurveTension property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectCurveTension Property

This property sets the selected Polyline object's curve tension.

[Visual Basic] Public Property SelectedObjectCurveTension As Integer
[C#] public int SelectedObjectCurveTension {get; set;}

Property Value

Value: An integer representing the curve tension

Default value is 0

Explanation

The SelectedObjectCurveTension property sets the selected Polyline object's curve tension.

The value indicates the curve tension of a Polyline object that has been individually selected.

It is enabled only when the selected object is a Polyline object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Polyline object, the SelectedObjectCurveTension property value will be 0.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectCustomBrushColor1 property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectCustomBrushColor1 Property

This property sets the hatch pattern color or the start color for gradation when using the custom brush for the selected object.

[Visual Basic] Public Property SelectedObjectCustomBrushColor1 As System.Drawing.Color
[C#] public System.Drawing.Color SelectedObjectCustomBrushColor1 {get; set;}

Property Value

Value of type System.Drawing.Color

Default value is System.Drawing.Color.Black

Explanation

The SelectedObjectCustomBrushColor1 property sets the hatch pattern color when using BrushOfKind.HatchBrush in the selected object. It also sets the start color for gradation when using the BrushOfKind.LinearGradientBrush in the selected object.

To use a transparent color, set this property to Color.Transparent. It is also possible to use a partially transparent color by setting an alpha value using the System.Drawing.Color.FromArgb method.

For details on the custom brush, refer to the CustomBrushEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectCustomBrushColor2 property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectCustomBrushColor2 Property

This property sets the hatch pattern background color or the end color for gradation when using the custom brush for the selected object.

[Visual Basic] Public Property SelectedObjectCustomBrushColor2 As System.Drawing.Color
[C#] public System.Drawing.Color SelectedObjectCustomBrushColor2 {get; set;}

Property Value

Value of type System.Drawing.Color

Default value is System.Drawing.Color.White

Explanation

The SelectedObjectCustomBrushColor2 property sets the hatch pattern background color when using BrushOfKind.HatchBrush in the selected object. It also sets the end color for gradation when using the BrushOfKind.LinearGradientBrush in the selected object.

To use a transparent color, set this property to Color.Transparent. It is also possible to use a partially transparent color by setting an alpha value using the System.Drawing.Color.FromArgb method.

For details on the custom brush, refer to the CustomBrushEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectCustomBrushImageFileName property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectCustomBrushImageFileName Property

This property sets the file name for the image used in the custom brush when the BrushKind property is set to TextureBrush in the selected object.

[Visual Basic] Public Property SelectedObjectCustomBrushImageFileName As Stromg
[C#] public string SelectedObjectCustomBrushImageFileName {get; set;}

Property Value

Value of type String

Default value is ""

Explanation

The SelectedObjectCustomBrushImageFileName property sets the file name for the image used in the custom brush when the BrushKind property is set to TextureBrush in the selected object.

For details, please refer to the CustomBrushEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectDashPattern property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectDashPattern Property

This property sets a custom dash pattern for a single selected straight line, polyline, polygon, or pen object.

[Visual Basic] Public Property SelectedObjectDashPattern As Single
[C#] public float[] SelectedObjectDashPattern {get; set;}

Property Value

An array indicating the length of the dashed lines and blanks

The default value is {2.0F, 1.0F}.

Explanation

The SelectedObjectDashPattern property sets a custom dash pattern for a single selected straight line, polyline, polygon, or pen object.

When the SelectedObjectDashStyle property is System.Drawing.Drawing2D.DashStyle.Custom, the dashed line pattern set in this property is valid.

The property is represented by the length relative to the line thickness, and the values are "first length, spacing, second length, next spacing ...". This property cannot be set in the property dialog, so set it by writing the code.

* Example of setting the dash line of the pattern [---- --- ---] in (c #):
ImageKit1.Edit.SelectedObjectDashPattern = new float [] {2.0F, 1.0F, 2.0F, 1.0F, 2.0F, 2.0F};

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectDashStyle property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectDashStyle Property

This property sets the dash line used by the selected Line, Polyline, Polygon, and Pen objects.

[Visual Basic] Public Property SelectedObjectDashStyle As System.Drawing.Drawing2D.DashStyle
[C#] public System.Drawing.Drawing2D.DashStyle SelectedObjectDashStyle {get; set;}

Property Value

A value of type System.Drawing.Drawing2D.DashStyle

Default value is System.Drawing.Drawing2D.DashStyle.Solid

Explanation

The SelectedObjectDashStyle property sets the dash line used by the selected Line, Polyline, Polygon, and Pen objects.

It is enabled when the selected object is a Line, Polyline, Polygon, or Pen object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Line, Polyline, Polygon, or Pen object, the SelectedObjectDashStyle property value will be System.Drawing.Drawing2D.DashStyle.Solid.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectDoubleLine property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectDoubleLine Property

This property sets whether or not the selected object is set to double line.

[Visual Basic] Public Property SelectedObjectDoubleLine As Boolean
[C#] public bool SelectedObjectDoubleLine {get; set;}

Property Value

True: The selected Line object is set to double line.

False: The selected Line object is NOT set to double line.

Default value is False

Explanation

The SelectedObjectDoubleLine property sets whether or not the selected Line, Polyline, Polygon, or Pen object is set to double line.

It is enabled only when the selected object is a line object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a object, the SelectedObjectDoubleLine property value will be False.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectDoubleLineWidth1 property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectDoubleLineWidth1 Property

This property sets the percentage of the thickness of the first double line of the selected object.

[Visual Basic] Public Property SelectedObjectDoubleLineWidth1 As Integer
[C#] public int SelectedObjectDoubleLineWidth1 {get; set;}

Property Value

An integer value that indicates the percentage of line thickness

Default value is 33

Explanation

The SelectedObjectDoubleLineWidth1 property sets the percentage of the thickness of the first double line of the selected object when the DoubleLine is true. The unit is percentage. The percentage of the thickness of each double line is determined by the value of this property and the value of the DoubleLineWidth2 property, and the remaining percentage is the width of the spacing between the two lines. The minimum value for this property is 10 and the maximum value is 80. If you set a value less than 10, the value will be 10, and if you set a value greater than 80, it will be 80. Also, if the sum of the values of this property and the DoubleLineWidth2 property exceeds 90, this property value takes precedence and the value of DoubleLineWidth2 property is automatically set to the value of [90 - DoubleLineWidth1 property value].

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is a Line, Polyline, Polygon, or Pen object, this property value is the default value.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectDoubleLineWidth2 property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectDoubleLineWidth2 Property

This property sets the percentage of the thickness of the second double line of the selected object.

[Visual Basic] Public Property SelectedObjectDoubleLineWidth2 As Integer
[C#] public int SelectedObjectDoubleLineWidth2 {get; set;}

Property Value

An integer value that indicates the percentage of line thickness

Default value is 33

Explanation

The SelectedObjectDoubleLineWidth2 property sets the percentage of the thickness of the second double line of the selected object when the DoubleLine is true. The unit is percentage. The percentage of the thickness of each double line is determined by the value of this property and the value of the DoubleLineWidth1 property, and the remaining percentage is the width of the spacing between the two lines. The minimum value for this property is 10 and the maximum value is 80. If you set a value less than 10, the value will be 10, and if you set a value greater than 80, it will be 80. Also, if the sum of the values of this property and the DoubleLineWidth1 property exceeds 90, the DoubleLineWidth1 property value takes precedence and the value of this property is automatically set to the value of [90 - DoubleLineWidth1 property value].

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is a Line, Polyline, Polygon, or Pen object, this property value is the default value.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectDrawPoints property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectDrawPoints Property

This property sets the coordinate points of the selected object.

[Visual Basic] Public Property SelectedObjectDrawPoints As Point()
[C#] public Point[] SelectedObjectDrawPoints {get; set;}

Property Value

An array of type Point
Default value is null.

Explanation

The SelectedObjectDrawPoints property sets the coordinate points of the selected object as follows:

Line Object - The start point and end point are set. (The number of elements in the array = 2)
Rectangle, RoundRectangle, Text, Stamp, and Image Objects - The top left point and the bottom right point are set. (The number of elements in the array = 2)
Ellipse Object - The top left point and bottom right point of the ellipse's bounding rectangle are set. (The number of elements in the array = 2)
Polygon and Polyline Objects - The start point and end point for each straight line is set. (The number of elements in the list for the polygon will be the same as the number of straight lines. The number of elements in the array for the polyline will be the number of straight lines + 1.)
Pen Object - Because the pen object's drawing structure is a series of continuous short straight lines, the start point and end point for each straight line is set. (The number of elements in the array will be the number of straight lines + 1)

When the EditKind property is set to values other than KindOfEdit.Select or when no object has been selected, this property value will be null.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectEndArrowCap property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectEndArrowCap Property

This property sets whether or not the end point of a selected Line or Polyline object has an arrow cap.

[Visual Basic] Public Property SelectedObjectEndArrowCap As Boolean
[C#] public bool SelectedObjectEndArrowCap {get; set;}

Property Value

True: The end point of the selected Line or Polyline object has an arrow cap.

False: The end point of the selected Line or Polyline object does not have an arrow cap.

Default value is False

Explanation

The SelectedObjectEndArrowCap property sets whether or not the end point of a selected Line or Polyline object has an arrow cap.

It is enabled only when the selected object is a Line or Polyline object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Line or Polyline object, the SelectedObjectEndArrowCap property value will be False.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectEndArrowCapFilled property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectEndArrowCapFilled Property

This property sets whether or not the end point arrow cap of the selected Line or Polyline object will be filled.

[Visual Basic] Public Property SelectedObjectEndArrowCapFilled As Boolean
[C#] public bool SelectedObjectEndArrowCapFilled {get; set;}

Property Value

True: The end point arrow cap of the selected Line or Polyline object is filled

False: The end point arrow cap of the selected Line or Polyline object is not filled

Default value is False

Explanation

The SelectedObjectEndArrowCapFilled property sets whether or not the end point arrow cap of the selected Line or Polyline object is filled.

It is enabled only when the selected object is a Line or Polyline object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Line or Polyline object, the SelectedObjectEndArrowCapFilled property value will be False.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectEndArrowCapSize property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectEndArrowCapSize Property

This property sets the size of the end point arrow cap for the selected Line and Polyline objects.

[Visual Basic] Public Property SelectedObjectEndArrowCapSize As Integer
[C#] public int SelectedObjectEndArrowCapSize {get; set;}

Property Value

The end point arrow cap size of the selected Line or Polyline object

Default value is 10

Explanation

The SelectedObjectEndArrowCapSize property sets the size of the end point arrow cap for the selected Line and Polyline objects.

It is enabled only when the selected object is a Line or Polyline object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Line or Polyline object, the SelectedObjectEndArrowCapSize property value will be 10.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectEndLineCap property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectEndLineCap Property

This property sets the style of the end line for the selected Line, Polyline, and Pen objects.

[Visual Basic] Public Property SelectedObjectEndLineCap As System.Drawing.Drawing2D.LineCap
[C#] public System.Drawing.Drawing2D.LineCap SelectedObjectEndLineCap {get; set;}

Property Value

A value of type System.Drawing.Drawing2D.LineCap

Default value is System.Drawing.Drawing2D.LineCap.Flat

Explanation

The SelectedObjectEndLineCap property sets the style of the end line for the selected Line, Polyline, and Pen objects.

It is enabled when the selected object is a Line or Polyline object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Line or Polyline object, the SelectedObjectEndLineCap property value will be System.Drawing.Drawing2D.LineCap.Flat.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectFill property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectFill Property

This property sets whether or not the selected object is being filled with the background color.

[Visual Basic] Public Property SelectedObjectFill As Boolean
[C#] public bool SelectedObjectFill {get; set;}

Property Value

True: The selected object is being filled with the background color
False: The selected object is not being filled with the background color
Default value is False.

Explanation

The SelectedObjectFill property sets whether or not the selected object is being filled with the background color.

When the individually selected object is the Polygon, Rectangle, RoundRectangle, or Ellipse object, this property value refers to the whether the interior of the object is filled with the background color. When the selected object is the Text or Stamp object, this property value refers to whether the text background is filled with the background color. When the selected object is the Line, Polyline, Pen, or Image, this property is disabled.

When the EditKind property is set to a value other than KindOfEdit.Select or when no object has been selected, this property is False.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectFontBold property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectFontBold Property

This property sets whether or not the font for the text of the selected Text or Stamp object is bold.

[Visual Basic] Public Property SelectedObjectFontBold As Boolean
[C#] public bool SelectedObjectFontBold {get; set;}

Property Value

True: The font of the selected Text or Stamp object is bold
False: The font of the selected Text or Stamp object is not bold
Default value is False.

Explanation

The SelectedObjectFontBold property sets whether or not the font for the text of the selected Text or Stamp object is bold.

This property is only enabled when the selected object is a Text or Stamp object.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is not a Text or Stamp object, this property value is False.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectFontItalic property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectFontItalic Property

This property sets whether or not the font for the text of the selected Text or Stamp object is italics.

[Visual Basic] Public Property SelectedObjectFontItalic As Boolean
[C#] public bool SelectedObjectFontItalic {get; set;}

Property Value

True: The font of the selected Text or Stamp object is italics
False: The font of the selected Text or Stamp object is not italics
Default value is False.

Explanation

The SelectedObjectFontItalic property sets whether or not the font for the text of the selected Text or Stamp object is italics.

This property is only enabled when the selected object is a Text and Stamp object.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is not a Text or Stamp object, this property value is False.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectFontName property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectFontName Property

This property sets the font name used by the selected Text or Stamp object.

[Visual Basic] Public Property SelectedObjectFontName As String
[C#] public string SelectedObjectFontName {get; set;}

Property Value

The string representing the font name used by the Text or Stamp object.
Default value is null (Nothing in Visual Basic).

Explanation

The SelectedObjectFontName property sets the font name used by the selected Text or Stamp object. This property is enabled when the selected object is a Text or Stamp object.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is not a Text or Stamp object, this property value is null (Nothing in Visual Basic).

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectFontSize property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectFontSize Property

This property sets the size of the font used by the selected Text or Stamp object.

[Visual Basic] Public Property SelectedObjectFontSize As Single
[C#] public float SelectedObjectFontSize {get; set;}

Property Value

A value representing the size of the font. (In C#, this value is a float. In VB, this value is a single)
Default value is 0.

Explanation

The SelectedObjectFontSize property sets the size of the font used by the selected Text or Stamp object. The unit is pixels. This property is enabled when the selected object is the Text or Stamp object.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is not a Text or Stamp object, this property value is 0.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectFontStrikeout property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectFontStrikeout Property

This property sets whether or not the text in the selected Text or Stamp object uses a strikeout.

[Visual Basic] Public Property SelectedObjectFontStrikeout As Boolean
[C#] public bool SelectedObjectFontStrikeout {get; set;}

Property Value

True: The text uses a strikeout
False: The text does not use a strikeout
Default value is False.

Explanation

The SelectedObjectFontStrikeout property sets whether or not the text in the selected Text or Stamp object uses a strikeout.

This property is only enabled when the selected object is a Text or Stamp object.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is not a Text or Stamp object, this property value is False.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectFontUnderline property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectFontUnderline Property

This property sets whether or not the text in the selected Text or Stamp object uses an underline.

[Visual Basic] Public Property SelectedObjectFontUnderline As Boolean
[C#] public bool SelectedObjectFontUnderline {get; set;}

Property Value

True: The text uses an underline
False: The text does not use an underline
Default value is False.

Explanation

The SelectedObjectFontUnderline property sets whether or not the text in the selected Text or Stamp object uses an underline.

This property is only enabled when the selected object is a Text or Stamp object.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is not a Text or Stamp object, this property value is False.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectForeColor property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectForeColor Property

This property sets the line color or text color of the selected object.

[Visual Basic] Public Property SelectedObjectForeColor As Color
[C#] public Color SelectedObjectForeColor {get; set;}

Property Value

A value of type Color representing the line or text color.
Default value is Color.Empty

Explanation

The SelectedObjectForeColor property sets the line color or text color of the selected object.

This property is disabled when the selected object is the Image object.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is an Image object, this property value will be Color.Empty.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectForeColor property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectForeColor2 Property

This property sets the end color of the text gradient for single-selected Text and Stamp objects.

[Visual Basic] Public Property SelectedObjectForeColor2 As Color
[C#] public Color SelectedObjectForeColor2 {get; set;}

Property Value

A value of type System.Drawing.Color representing the end color for the text gradient

Default value is System.Drawing.Color.Black

Explanation

The SelectedObjectForeColor2 property sets the end color of the text gradient for single-selected Text and Stamp objects.

When the DesignedTextEnabled property is True, this property value can be set when the appropriate object is single-selected.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectForeColorOpacity property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectForeColorOpacity Property

This property sets the opacity level for the line color or text color of the selected object.

[Visual Basic] Public Property SelectedObjectForeColorOpacity As Integer
[C#] public int SelectedObjectForeColorOpacity {get; set;}

Property Value

The level of opacity for line or text color
Default value is 100

Explanation

The SelectedObjectForeColorOpacity property sets the opacity level for the line color or text color of the selected object.

This property is disabled when the selected object is the Image object.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is an Image object, this property value will be 100.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectHatchStyle property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectHatchStyle Property

This property sets the hatch style of the custom brush in the selected object.

[Visual Basic] Public Property SelectedObjectHatchStyle As System.Drawing.Drawing2D.HatchStyle
[C#] public System.Drawing.Drawing2D.HatchStyle SelectedObjectHatchStyle {get; set;}

Property Value

Value of type System.Drawing.Drawing2D.HatchStyle

Default value is System.Drawing.Drawing2D.HatchStyle.DiagonalCross

Explanation

The SelectedObjectHatchStyle property sets the hatch style of the custom brush in the selected object.

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectImageFileName property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectImageFileName Property

This property sets the filename for the image used in the selected Image object.

[Visual Basic] Public Property SelectedObjectImageFileName As String
[C#] public string SelectedObjectImageFileName {get; set;}

Property Value

The string representing the file name of the image used in the Image object. (Full path)
Default value is "" (an empty string)

Explanation

The SelectedObjectImageFileName property sets the filename for the image used in the selected Image object. If the selected Image object is a new Image object, this property will contain the image filename including the full path. If the selected Image object was loaded from an Annotation File, this property will contain the image filename without the path.

This property is only enabled when the selected object is the Image object.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is not an Image object, this property value is null (Nothing in Visual Basic).

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectKind property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectKind Property

This property retrieves the type of the object that is selected.

[Visual Basic] Public ReadOnly Property SelectedObjectKind As KindOfEdit
[C#] public KindOfEdit SelectedObjectKind {get;}

Property Value

A value of type KindOfEdit

Explanation

The SelectedObjectKind property retrieves the type of the object that is selected.

When the EditKind property is set to values other than KindOfEdit.Select or when no object has been selected, this property value is KindOfEdit.None.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectLinearGradientMode property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectLinearGradientMode Property

This property sets the gradient direction for the custom brush when BrushKind is set to LinearGradientBrush in the selected object.

[Visual Basic] Public Property SelectedObjectLinearGradientMode As System.Drawing.Drawing2D.LinearGradientMode
[C#] public System.Drawing.Drawing2D.LinearGradientMode SelectedObjectLinearGradientMode {get; set;}

Property Value

Value of type System.Drawing.Drawing2D.LinearGradientMode
Horizontal (0): Gradation from left to right
Vertical (1): Gradation from left to right
ForwardDiagonal (2): Gradation from top left to bottom right
BackwardDiagonal (2): Gradation from top right to bottom left

Default value is System.Drawing.Drawing2D.LinearGradientMode.Horizontal

Explanation

The SelectedObjectLinearGradientMode property sets the gradient direction for the custom brush when BrushKind is set to LinearGradientBrush in the selected object.

For details about the custom brush, please see the CustomBrushEnabled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectLineJoin property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectLineJoin Property

This property sets the type of line join for the selected Line, Polyline, and Pen objects.

[Visual Basic] Public Property SelectedObjectLineJoin As System.Drawing.Drawing2D.LineJoin
[C#] public System.Drawing.Drawing2D.LineJoin SelectedObjectLineJoin {get; set;}

Property Value

A value of type System.Drawing.Drawing2D.LineJoin

Default value is System.Drawing.Drawing2D.LineJoin.Round

Explanation

The SelectedObjectLineJoin property sets the type of line join for the selected Line, Polyline, and Pen objects.

It is enabled when the selected object is a Line, Polyline,or Pen object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Line, Polyline, or Pen object, the SelectedObjectLineJoin property value will be System.Drawing.Drawing2D.LineJoin.Round.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectNotes property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectNotes Property

This property sets the content of the note for the selected object.

[Visual Basic] Public Property SelectedObjectNotes As String
[C#] public string SelectedObjectNotes {get; set;}

Property Value

The string representing the contents of the selected object's note
Default value is null (Nothing in Visual Basic)

Explanation

The SelectedObjectNotes property sets the content of the note for the selected object. This property is only enabled when object has been selected.

When the EditKind property is set to values other than KindOfEdit.Select or when no object has been selected, this property value is null (Nothing in Visual Basic).

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectNumber property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectNumber Property

This property retrieves the number of the selected object.

[Visual Basic] Public ReadOnly Property SelectedObjectNumber As Integer
[C#] public int SelectedObjectNumber {get;}

Property Value

An integer representing the object number.
Default value is 0.

Explanation

The SelectedObjectNumber property retrieves the number of the selected object.

This property value also represents the z-order value for the selected object.

When the EditKind property is set to values other then KindOfEdit.Select or when no object has been selected, this property value is 0.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectPenWidth property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectPenWidth Property

This property sets the width of the lines (the pen width) of the selected object.

[Visual Basic] Public Property SelectedObjectPenWidth As Integer
[C#] public int SelectedObjectPenWidth {get; set;}

Property Value

An integer representing the width of the line (pen width)
Default value is 0.

Explanation

The SelectedObjectPenWidth property sets the width of the lines (the pen width) of the selected object (in pixels).

This property is disabled when the selected object is a Text, Stamp, or Image object.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is a Text, Stamp, or Image object, this property value is 0.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectRefinePasteImage property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectRefinePasteImage Property

This property sets whether or not RefinePasteImage is used in the selected Image object.

[Visual Basic] Public Property SelectedObjectRefinePasteImage As Boolean
[C#] public bool SelectedObjectRefinePasteImage {get; set;}

Property Value

True: The selected Image object uses high quality
False: The selected Image object does not use high quality

Default value is 0.

Explanation

The SelectedObjectRefinePasteImage property sets whether or not RefinePasteImage is used in the selected Image object.

This property is disabled when the selected object is not an Image object.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is not an Image object, this property value is True.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectRightToLeft property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectRightToLeft Property

This property sets whether or not text in the selected Text and Stamp objects is displayed from right to left

[Visual Basic] Public Property SelectedObjectRightToLeft As Boolean
[C#] public bool SelectedObjectRightToLeft {get; set;}

Property Value

True: The text in the selected Text and Stamp objects is displayed from right to left
False: The text in the selected Text and Stamp objects is NOT displayed from right to left
Default value is False.

Explanation

The SelectedObjectRightToLeft property sets whether or not the text in the selected Text and Stamp objects is displayed from right to left.

This property is only enabled when the selected object is a Text or Stamp object.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is not a Text or Stamp object, this property value is False.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectRoundRectangleRadius property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectRoundRectangleRadius Property

This property sets the radius for the rounded corners of the selected RoundRectangle and Stamp objects

[Visual Basic] Public Property SelectedObjectRoundRectangleRadius As Integer
[C#] public int SelectedObjectRoundRectangleRadius {get; set;}

Property Value

An integer value representing the radius for rounded corners

Default value is 10.

Explanation

The SelectedObjectRoundRectangleRadius property sets the radius for the rounded corners of the selected RoundRectangle and Stamp objects.

This property is only enabled when the selected object is a RoundRectangle or Stamp object.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is not a RoundRectangle or Stamp object, this property value is 10.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectStartArrowCap property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectStartArrowCap Property

This property sets whether or not the start point of a selected Line or Polyline object has an arrow cap.

[Visual Basic] Public Property SelectedObjectStartArrowCap As Boolean
[C#] public bool SelectedObjectStartArrowCap {get; set;}

Property Value

True: The start point of the selected Line or Polyline object has an arrow cap.

False: The start point of the selected Line or Polyline object does not have an arrow cap.

Default value is False

Explanation

The SelectedObjectStartArrowCap property sets whether or not the start point of a selected Line or Polyline object has an arrow cap.

It is enabled only when the selected object is a Line or Polyline object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Line or Polyline object, the SelectedObjectStartArrowCap property value will be False.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectStartArrowCapFilled property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectStartArrowCapFilled Property

This property sets whether or not the start point arrow cap of the selected Line or Polyline object will be filled.

[Visual Basic] Public Property SelectedObjectStartArrowCapFilled As Boolean
[C#] public bool SelectedObjectStartArrowCapFilled {get; set;}

Property Value

True: The start point arrow cap of the selected Line or Polyline object is filled

False: The start point arrow cap of the selected Line or Polyline object is not filled

Default value is False

Explanation

The SelectedObjectStartArrowCapFilled property sets whether or not the start point arrow cap of the selected Line or Polyline object is filled.

It is enabled only when the selected object is a Line or Polyline object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Line or Polyline object, the SelectedObjectStartArrowCapFilled property value will be False.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectStartArrowCapSize property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectStartArrowCapSize Property

This property sets the size of the start point arrow cap for the selected Line and Polyline objects.

[Visual Basic] Public Property SelectedObjectStartArrowCapSize As Integer
[C#] public int SelectedObjectStartArrowCapSize {get; set;}

Property Value

The start point arrow cap size of the selected Line or Polyline object

Default value is 10

Explanation

The SelectedObjectStartArrowCapSize property sets the size of the start point arrow cap for the selected Line and Polyline objects.

It is enabled only when the selected object is a Line or Polyline object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Line or Polyline object, the SelectedObjectStartArrowCapSize property value will be 10.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectStartLineCap property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectStartLineCap Property

This property sets the style of the start line for the selected Line, Polyline, and Pen objects.

[Visual Basic] Public Property SelectedObjectStartLineCap As System.Drawing.Drawing2D.LineCap
[C#] public System.Drawing.Drawing2D.LineCap SelectedObjectStartLineCap {get; set;}

Property Value

A value of type System.Drawing.Drawing2D.LineCap

Default value is System.Drawing.Drawing2D.LineCap.Flat

Explanation

The SelectedObjectStartLineCap property sets the style of the start line for the selected Line, Polyline, and Pen objects.

It is enabled when the selected object is a Line or Polyline object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Line or Polyline object, the SelectedObjectStartLineCap property value will be System.Drawing.Drawing2D.LineCap.Flat.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectText property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectText Property

This property sets the content of the selected Text or Stamp object.

[Visual Basic] Public Property SelectedObjectText As String
[C#] public string SelectedObjectText {get; set;}

Property Value

The string representing the selected Text or Stamp object content
Default value is null (Nothing in Visual Basic)

Explanation

The SelectedObjectText property sets the content of the selected Text or Stamp object. This property is only enabled when a Text or Stamp object has been selected.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is not a Text or Stamp object, this property value is null (Nothing in Visual Basic).

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectTextAlign property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectTextAlign Property

This property sets the alignment for the text in the selected Stamp object.

[Visual Basic] Public Property SelectedObjectTextAlign As Align
[C#] public Align SelectedObjectTextAlign {get; set;}

Property Value

The value of type Align representing the alignment for the text in the selected Stamp object
Default value is Align.Center

Explanation

The SelectedObjectTextAlign property sets the alignment for the text in the selected Stamp object. This property is only enabled when a Stamp object has been selected.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is not a Stamp object, this property value is Align.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectTextBorderColor property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectTextBorderColor Property

This property sets the text border color for single-selected Text and Stamp objects.

[Visual Basic] Public Property SelectedObjectTextBorderColor As Boolean
[C#] public bool SelectedObjectTextBorderColor {get; set;}

Property Value

A value of type System.Drawing.Color representing the end color for the text gradient

Default value is System.Drawing.Color.Black

Explanation

The SelectedObjectTextBorderColor property sets the border color for single-selected Text and Stamp objects.

When the DesignedTextEnabled property is True, this property value can be set when the appropriate object is single-selected.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectTextBorderColorOpacity property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectTextBorderColorOpacity Property

This property sets the text border opacity for single-selected Text and Stamp objects.

[Visual Basic] Public Property SelectedObjectTextBorderColorOpacity As Integer
[C#] public int SelectedObjectTextBorderColorOpacity {get; set;}

Property Value

Integer value representing opacity

Default value is 100%

Explanation

The SelectedObjectTextBorderColorOpacity property sets the border opacity for single-selected Text and Stamp objects. The unit is percent.

When the DesignedTextEnabled property is True, this property value can be set when the appropriate object is single-selected.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectTextBorderWidth property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectTextBorderWidth Property

This property sets the text border width for single-selected Text and Stamp objects.

[Visual Basic] Public Property SelectedObjectTextBorderWidth As Integer
[C#] public int SelectedObjectTextBorderWidth {get; set;}

Property Value

Integer value representing the width of the text borders in pixels

Default value is 0

Explanation

The SelectedObjectTextBorderWidth property sets the border width for single-selected Text and Stamp objects. The unit is pixels. The default value is 0.

When the DesignedTextEnabled property is True, this property value can be set when the appropriate object is single-selected.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectTextLinearGradientMode property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectTextLinearGradientMode Property

This property sets the direction for the text gradient for single-selected Text and Stamp objects.

[Visual Basic] Public Property SelectedObjectTextLinearGradientMode As System.Drawing.Drawing2D.LinearGradientMode
[C#] public System.Drawing.Drawing2D.LinearGradientMode SelectedObjectTextLinearGradientMode {get; set;}

Property Value

A System.Drawing.Drawing2D.LinearGradientMode value representing the text gradient direction

Default value is System.Drawing.Drawing2D.LinearGradientMode.Horizontal

Explanation

The SelectedObjectTextLinearGradientMode property sets the direction for the text gradient for single-selected Text and Stamp objects.

When the DesignedTextEnabled property is True, this property value can be set when the appropriate object is single-selected.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectTextShadowBlur Property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectTextShadowBlur Property

This property sets the degree of blur for the text shadow for single-selected objects.

[Visual Basic] Public Property SelectedObjectTextShadowBlur As Integer
[C#] public int SelectedObjectTextShadowBlur {get; set;}

Property Value

Integer value representing the degree of blur for text shadow

Default value is 0

Explanation

The SelectedObjectTextShadowBlur property sets the degree of blur for the text shadow for single-selected objects. The unit is Pixel.

When the DesignedTextEnabled property is True, the SelectedObjectTextShadowBlur property value can be retrieved and set when the target object is single selected. Only values less than or equal to the SelectedObjectTextShadowOffsetX property or SelectedObjectTextShadowOffsetY property, whichever is smaller, are valid for this property value.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectTextShadowColor Property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectTextShadowColor Property

This property sets the text shadow color for single-selected objects.

[Visual Basic] Public Property SelectedObjectTextShadowColor As System.Drawing.Color
[C#] public System.Drawing.Color SelectedObjectTextShadowColor {get; set;}

Property Value

System.Drawing.Color value representing the color of the text shadow

Default value is System.Drawing.Color.Gray

Explanation

The SelectedObjectTextShadowColor property sets the text shadow color for single-selected objects. The default value is System.Drawing.Color.Gray.

When the DesignedTextEnabled property is True, the SelectedObjectTextShadowColor property value can be retrieved and set for single selected objects.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectTextShadowColorOpacity Property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectTextShadowColorOpacity Property

This property sets the percentage of text shadow opacity for single-selected objects.

[Visual Basic] Public Property SelectedObjectTextShadowColorOpacity As Integer
[C#] public int SelectedObjectTextShadowColorOpacity {get; set;}

Property Value

A integer value representing the percentage of the text shadow opacity

Default value is 100

Explanation

The SelectedObjectTextShadowColorOpacity property sets the percentage text shadow opacity for single-selected objects. The units are percentage where 100% is completely opaque.

When the DesignedTextEnabled property is True, the SelectedObjectTextShadowColorOpacity property value can be retrieved and set for single selected objects.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectTextShadowOffsetX Property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectTextShadowOffsetX Property

This property sets the horizontal offset of text shadows for single-selected objects.

[Visual Basic] Public Property SelectedObjectTextShadowOffsetX As Integer
[C#] public int SelectedObjectTextShadowOffsetX {get; set;}

Property Value

A integer value representing the horizontal offset of text shadows

Default value is 0

Explanation

The SelectedObjectTextShadowOffsetX property sets the horizontal offset of text shadows for single-selected objects. The units are in pixels.

When the DesignedTextEnabled property is True, the SelectedObjectTextShadowOffsetX property value can be retrieved and set for single selected objects.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectTextShadowOffsetY Property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectTextShadowOffsetY Property

This property sets the vertical offset of text shadows for single-selected objects.

[Visual Basic] Public Property SelectedObjectTextShadowOffsetY As Integer
[C#] public int SelectedObjectTextShadowOffsetY {get; set;}

Property Value

A integer value representing the vertical offset of text shadows

Default value is 0

Explanation

The SelectedObjectTextShadowOffsetY property sets the vertical offset of text shadows for single-selected objects. The units are in pixels.

When the DesignedTextEnabled property is True, the SelectedObjectTextShadowOffsetY property value can be retrieved and set for single selected objects.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectVerticalText property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectVerticalText Property

This property sets whether or not the text in the selected Text or Stamp object is vertical text.

[Visual Basic] Public Property SelectedObjectVerticalText As Boolean
[C#] public bool SelectedObjectVerticalText {get; set;}

Property Value

True: The text in the selected Text or Stamp object is vertical text

False: The text in the selected Text or Stamp object is NOT vertical text

Default value is False

Explanation

The SelectedObjectVerticalText property sets whether or not the text in the selected Text or Stamp object is vertical text. This property is only enabled when a Text or Stamp object has been selected.

When the EditKind property is set to values other than KindOfEdit.Select, when no object has been selected, or when the selected object is not a Text or Stamp object, this property value is False.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectedObjectWordWrap property

Newtone.ImageKit.Win.ImageKit.Edit.SelectedObjectWordWrap Property

This property sets whether or not the text in the selected Text or Stamp object has automatic word wrapping enabled.

[Visual Basic] Public Property SelectedObjectWordWrap As Boolean
[C#] public bool SelectedObjectWordWrap {get; set;}

Property Value

True: The text has automatic word wrapping enabled

False: The text does not have automatic word wrapping enabled

Default value is True

Explanation

The SelectedObjectWordWrap property sets whether or not the text in the selected Text or Stamp object has automatically word wrapping.

This property is enabled only when the selected object is a Text or Stamp object. When the EditKind property is set to values other than KindOfEdit.Select, or when no object has been selected, or when the selected object is not a Text or Stamp object, the SelectedObjectWordWrap property value will be False.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectOnClick property

Newtone.ImageKit.Win.ImageKit.Edit.SelectOnClick Property

This property sets whether or not single selection and multiple selection can be switched automatic by clicking or dragging objects with the mouse.

[Visual Basic] Public Property SelectOnClick As Boolean
[C#] public bool SelectOnClick {get; set;}

Property Value

True: Single selection and multiple selection can be switched automatically

False: Single selection and multiple selection can not be switched automatically

Default value is True

Explanation

The SelectOnClick property sets whether or not single selection and multiple selection can be switched automatic by clicking or dragging objects with the mouse.

When this property is true and the EditKind property is either Select or MultiSelect, if the annotation object is clicked, the object will be single selected and the EditKind property will automatically be set to Select. Furthermore, when this property is true and the EditKind property is either Select or MultiSelect, if the mouse is dragged across one or more annotation objects, or the Ctrl key is held down and objects are selected, those multiple objects will be selected and the EditKind property will automatically be set to MultiSelect.

When this property is true, the Ctrl key can only be used to select multiple objects when using version 3.0.*.10303 (where the * is 2 or 4) or above.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SetTextOnInvalidAreaClick property

Newtone.ImageKit.Win.ImageKit.Edit.SetTextOnInvalidAreaClick Property

This property determines whether or not the text can be set into the Text / Stamp object by clicking in the unused area of the ImageKit control (The area with the hatched pattern outside of the displayed image).

[Visual Basic] Public Property SetTextOnInvalidAreaClick As Boolean
[C#] public bool SetTextOnInvalidAreaClick {get; set;}

Property Value

True: Clicking in the unused area of the ImageKit control (the area where no image is displayed) sets the text into the Text object.

False: Clicking in the unused area of the ImageKit control (the area where no image is displayed) does not set the text into the Text object.

Default value is False

Explanation

The SetTextOnInvalidAreaClick property property determines whether or not the text can be set into the Text / Stamp object by clicking in the unused area of the ImageKit control (The area with the hatched pattern outside of the displayed image).

By setting this property to True, it is possible to set the text into the Text / Stamp object by clicking the area outside the image displayed in the ImageKit control (The area with the hatched pattern outside of the displayed image).

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SetTextOnRightClick property

Newtone.ImageKit.Win.ImageKit.Edit.SetTextOnRightClick Property

This property determines whether or not the text can be set into the Text / Stamp object by right-clicking in the text box.

[Visual Basic] Public Property SetTextOnRightClick As Boolean
[C#] public bool SetTextOnRightClick {get; set;}

Property Value

True: Right-clicking in the text box sets the text into the Text object.

False: Right-clicking in the text box does not set the text into the Text object.

Default value is False

Explanation

The SetTextOnRightClick property determines whether or not the text can be set into the Text / Stamp object by right-clicking in the text box.

By setting this property to True, it is possible to set the text being input / edited into the Text / Stamp object by right-clicking the text box while inputting the text.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


ShowDialogOnDoubleClick property

Newtone.ImageKit.Win.ImageKit.Edit.ShowDialogOnDoubleClick Property

This property sets whether or not an annotation object's property dialog will be displayed when the object is double clicked.

[Visual Basic] Public Property ShowDialogOnDoubleClick As Boolean
[C#] public bool ShowDialogOnDoubleClick {get; set;}

Property Value

True: The annotation object's property dialog is displayed when the object is double clicked.

False: The annotation object's property dialog is NOT displayed when the object is double clicked.

Default value is False

Explanation

The ShowDialogOnDoubleClick property sets whether or not an annotation object's property dialog will be displayed when the object is double clicked.

When this property is True, double clicking the object will display the property dialog and works in the same way as selecting "Properties" in the context menu or executing the ShowPropertyDialog method.

The ShowDialogOnDoubleClick property is only enabled when the object is NOT selected. If an object is already selected the ShowDialogOnDoubleClick property is ignored for that object.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


StartArrowCap property

Newtone.ImageKit.Win.ImageKit.Edit.StartArrowCap Property

This property sets whether or not the start point of a Line or Polyline object has an arrow cap.

[Visual Basic] Public Property StartArrowCap As Boolean
[C#] public bool StartArrowCap {get; set;}

Property Value

True: The start point has an arrow cap

False: The start point does not have an arrow cap

Default value is False

Explanation

The StartArrowCap property sets whether or not the start point of a Line or Polyline object has an arrow cap.

When both the StartArrowCap property and the StartLineCap property are true, the StartArrowCap property will have priority.

To change an object after it has been drawn, select the object then right click to display the context menu, execute the ShowPropertyDialog method, or set the SelectedObjectStartArrowCap property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


StartArrowCapFilled property

Newtone.ImageKit.Win.ImageKit.Edit.StartArrowCapFilled Property

This property sets whether or not the start point arrow cap of a Line or Polyline object will be filled.

[Visual Basic] Public Property StartArrowCapFilled As Boolean
[C#] public bool StartArrowCapFilled {get; set;}

Property Value

True: The start point arrow cap is filled

False: The start point arrow cap is not filled

Default value is False

Explanation

The StartArrowCapFilled property sets whether or not the start point arrow cap of a Line or Polyline object is filled.

This property is enabled when the StartArrowCap property is True. The appearance of the start arrow cap when it is filled or not filled can be seen below:

To change an object after it has been drawn, select the object then right click to display the context menu, execute the ShowPropertyDialog method, or set the SelectedObjectStartArrowCapFilled property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


StartArrowCapSize property

Newtone.ImageKit.Win.ImageKit.Edit.StartArrowCapSize Property

This property sets the size of the start point arrow cap for the Line and Polyline objects.

[Visual Basic] Public Property StartArrowCapSize As Integer
[C#] public int StartArrowCapSize {get; set;}

Property Value

The start point arrow cap size

Default value is 10

Explanation

The StartArrowCapSize property sets the size of the start point arrow cap for the Line and Polyline objects.

When the StartArrowCap property is True, the StartArrowCapSize property determines the size of the start arrow cap. As shown below, "L" represents the length of the start arrow cap in pixels:

To change an object after it has been drawn, select the object then right click to display the context menu, execute the ShowPropertyDialog method, or set the SelectedObjectStartArrowCapSize property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


StartLineCap property

Newtone.ImageKit.Win.ImageKit.Edit.StartLineCap Property

This property sets the style of the start line for the Line, Polyline, and Pen objects.

[Visual Basic] Public Property StartLineCap As System.Drawing.Drawing2D.LineCap
[C#] public System.Drawing.Drawing2D.LineCap StartLineCap {get; set;}

Property Value

A value of type System.Drawing.Drawing2D.LineCap

Default value is System.Drawing.Drawing2D.LineCap.Flat

Explanation

The StartLineCap property sets the style of the start line for the Line, Polyline, and Pen objects.

If the StartArrowCap property is true, it will take priority over the StartLineCap property.

To make changes to an start line cap after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectStartLineCap property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


Text property

Newtone.ImageKit.Win.ImageKit.Edit.Text Property

This property sets the text drawn by the Text or Stamp object

[Visual Basic] Public Property Text As String
[C#] public string Text {get; set;}

Property Value

The text drawn by the Text or Stamp object

Explanation

The Text property sets the text drawn by the Text or Stamp object. When entering text directly within the Text or Stamp object area specified on the ImageKit control, the text will assume the appropriate properties set by the object. When using the DrawText method, the text will be drawn using the properties set prior to executing the drawing method.

To make changes to an object after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectText property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


TextAlign property

Newtone.ImageKit.Win.ImageKit.Edit.TextAlign Property

This property sets the alignment for the text drawn by the Stamp object

[Visual Basic] Public Property TextAlign As Align
[C#] public Align TextAlign {get; set;}

Property Value

A value of type Align that sets the text alignment in the Stamp object
The default value is Align.Center

Explanation

The TextAlign property sets the alignment for the text drawn by the Stamp object.

This property is enabled only for the Stamp object.

To make change the text alignment after the Stamp object has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectTextAlign property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


TextBorderColor property

Newtone.ImageKit.Win.ImageKit.Edit.TextBorderColor Property

This property sets the text border color.

[Visual Basic] Public Property TextBorderColor As System.Drawing.Color
[C#] public System.Drawing.Color TextBorderColor {get; set;}

Property Value

Value of type System.Drawing.Color representing the color of the text border

Default value is System.Drawing.Color.Black

Explanation

The TextBorderColor property sets the text border color.

This property is enabled when the DesignedTextEnabled property is set to True.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


TextBorderColorOpacity property

Newtone.ImageKit.Win.ImageKit.Edit.TextBorderColorOpacity Property

This property sets the opacity for the text border.

[Visual Basic] Public Property TextBorderColorOpacity As Integer
[C#] public int TextBorderColorOpacity {get; set;}

Property Value

In integer representing the percentage of opacity.

Default value is 100

Explanation

The TextBorderColorOpacity property sets the level of opacity for the text border. The units are percent. The default value is 100. A value of 0 is completely transparent. 100 is completely opaque. If you set a value less than 0, it will be set to 0, and if you set a value greater than 100, it will be set to 100.

This property is enabled when the DesignedTextEnabled property is set to True.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


TextBorderWidth property

Newtone.ImageKit.Win.ImageKit.Edit.TextBorderWidth Property

This property sets the width for the text border.

[Visual Basic] Public Property TextBorderWidth As Integer
[C#] public int TextBorderWidth {get; set;}

Property Value

In integer representing the width of the text border in pixels.

Default value is 0

Explanation

The TextBorderWidth property sets the width of the text border. The units are pixels. The default value is 0.

This property is enabled when the DesignedTextEnabled property is set to True.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


TextBoxBackColor property

Newtone.ImageKit.Win.ImageKit.Edit.TextBoxBackColor Property

This property sets the background color of the text that is input in the Text and Stamp objects.

[Visual Basic] Public Property TextBoxBackColor As Color
[C#] public Color TextBoxBackColor {get; set;}

Property Value

Value of type Color

Default value is Color.Empty

Explanation

The ForeColor property sets the background color of the text that is input in the Text and Stamp objects. It is valid when this property is set to a value other than Color.Empty. The value of this property is the background color for the text and the value of the TextBoxForeColor property is the color of the text.

When the value of this property is Color.Empty the text color will be the ForeColor property value and
1. If the Fill property is True, the background color will be the BackColor property value
2. If the Fill property is False, the background color will be the RGB inversion color of the ForeColor property value.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


TextBoxForeColor property

Newtone.ImageKit.Win.ImageKit.Edit.TextBoxForeColor Property

This property sets the color of the text that is input in the Text and Stamp objects.

[Visual Basic] Public Property TextBoxForeColor As Color
[C#] public Color TextBoxForeColor {get; set;}

Property Value

Value of type Color

Default value is Color.Empty

Explanation

The ForeColor property sets the color of the text that is input in the Text and Stamp objects. It is valid when this property is set to a value other than Color.Empty. The value of this property is the text color and the value of the TextBoxBackColor property is the background color.

When the value of this property is Color.Empty the text color will be the ForeColor property value and
1. If the Fill property is True, the background color will be the BackColor property value
2. If the Fill property is False, the background color will be the RGB inversion color of the ForeColor property value.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


TextLinearGradientMode property

Newtone.ImageKit.Win.ImageKit.Edit.TextLinearGradientMode Property

This property sets the direction for the text gradiation.

[Visual Basic] Public Property TextLinearGradientMode As System.Drawing.Drawing2D.LinearGradientMode
[C#] public System.Drawing.Drawing2D.LinearGradientMode TextLinearGradientMode {get; set;}

Property Value

A value of type System.Drawing.Drawing2D.LinearGradientMode
Horizontal (0): Gradation from left to right
Vertical (1): Gradation from left to right
ForwardDiagonal (2): Gradation from top left to bottom right
BackwardDiagonal (2): Gradation from top right to bottom left

Default value is System.Drawing.Drawing2D.LinearGradientMode.Horizontal

Explanation

The TextLinearGradientMode property sets the direction for the text gradiation. The range of the gradiation is the drawing range of the text if there is no automatic line break (WordWrap=False), and the range of the text box if there is an automatic line break (WordWrap=True).

This property is enabled when the DesignedTextEnabled property is set to True.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


TextShadowBlur property

Newtone.ImageKit.Win.ImageKit.Edit.TextShadowBlur Property

This property sets the level of blur for the text shadow.

[Visual Basic] Public Property TextShadowBlur As Integer
[C#] public int TextShadowBlur {get; set;}

Property Value

In integer representing the level of blur for the text shadow.

Default value is 0

Explanation

The TextShadowBlur property sets the level of blur for the text shadow. This property is enabled when the DesignedTextEnabled property is set to True.

The TextShadowBlur property is valid when both the TextShadowOffsetX property and the TextShadowOffsetY property are more than 0. However, the TextShadowBlur value cannot exceed the smallest value set in either of these two propertes. If a larger value is set in the TextShadowBlur property, the smallest value set in the TextShadowOffsetX property and the TextShadowOffsetY property will be used for the TextShadowBlur property. Setting a value less than 0 sets the property value to 0.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


TextShadowColor property

Newtone.ImageKit.Win.ImageKit.Edit.TextShadowColor Property

This property sets the color of the text shadow.

[Visual Basic] Public Property TextShadowColor As System.Drawing.Color
[C#] public System.Drawing.Color TextShadowColor {get; set;}

Property Value

An System.Drawing.Color representing the text shadow color.

Default value is System.Drawing.Color.Gray

Explanation

The TextShadowColor property sets the color of the text shadow. This property is enabled when the DesignedTextEnabled property is set to True.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


TextShadowColorOpacity property

Newtone.ImageKit.Win.ImageKit.Edit.TextShadowColorOpacity Property

This property sets the opacity of the text shadow.

[Visual Basic] Public Property TextShadowColorOpacity As Integer
[C#] public int TextShadowColorOpacity {get; set;}

Property Value

An integer representing the percent of the text shadow opacity.

Default value is 100.

Explanation

The TextShadowColorOpacity property sets the percentage of opacity of the text shadow. The units percent. Values are valid between 0 and 100. The lower the value, the more transparent. (0 is completely transparent, 100 is completely opaque.)

If a value less than 0 is set, the value will be 0, and if a value greater than 100 is set, the value will be 100.

This property is enabled when the DesignedTextEnabled property is set to True.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


TextShadowOffsetX property

Newtone.ImageKit.Win.ImageKit.Edit.TextShadowOffsetX Property

This property sets the horizontal offset for the text shadow.

[Visual Basic] Public Property TextShadowOffsetX As Integer
[C#] public int TextShadowOffsetX {get; set;}

Property Value

An integer representing the horizontal offset for text shadow.

Default value is 0.

Explanation

The TextShadowOffsetX property sets the horizontal offset for the text shadow. The units are pixels. If both this property and the TextShadowOffsetY property are set to 0, there will be no shadow. Values of less than 0 will be set to zero.

This property is enabled when the DesignedTextEnabled property is set to True.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


TextShadowOffsetY property

Newtone.ImageKit.Win.ImageKit.Edit.TextShadowOffsetY Property

This property sets the vertical offset for the text shadow.

[Visual Basic] Public Property TextShadowOffsetY As Integer
[C#] public int TextShadowOffsetY {get; set;}

Property Value

An integer representing the vertical offset for text shadow.

Default value is 0.

Explanation

The TextShadowOffsetY property sets the vertical offset for the text shadow. The units are pixels. If both this property and the TextShadowOffsetX property are set to 0, there will be no shadow. Values of less than 0 will be set to zero.

This property is enabled when the DesignedTextEnabled property is set to True.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


UndoMax property

Newtone.ImageKit.Win.ImageKit.Edit.UndoMax Property

This property sets the maximum allowable undo steps for annotation objects.

[Visual Basic] Public Property UndoMax As Integer
[C#] public int UndoMax {get; set;}

Property Value

Maximum number of allowable undo steps

Default value is 50

Maximum value is 100.

Explanation

The UndoMax property sets the maximum allowable undo steps for annotation objects.

An undo removes changes made to annotation objects in the order from the newest change to the oldest. This property sets the maximum number of undo steps that can be taken. If, for example, there have been 12 changes to an object, and the UndoMax property is set to 10, then you will only be allowed to remove the last 10 changes. The oldest two changes can no longer be "undone".

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


VerticalText property

Newtone.ImageKit.Win.ImageKit.Edit.VerticalText Property

This property sets whether or not the text in the Text or Stamp object is vertical text

[Visual Basic] Public Property VerticalText As String
[C#] public string VerticalText {get; set;}

Property Value

True: The text in the Text or Stamp object is vertical text
False: The text in the Text or Stamp object is NOT vertical text

The default value is False

Explanation

The VerticalText property sets whether or not the text in the Text or Stamp object is vertical text.

This property is enabled when the WordWrap property is True. Even if the VerticalText property is True, if the WordWrap property is False, the text will be horizontal.

To make changes to the text in the Text or Stamp object after it has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectVerticalText property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


WordWrap property

Newtone.ImageKit.Win.ImageKit.Edit.WordWrap Property

This property sets whether or not word wrapping is used in the Text or Stamp object.

[Visual Basic] Public Property WordWrap As Boolean
[C#] public bool WordWrap {get; set;}

Property Value

True: Word wrapping is used in the Text or Stamp object.

True: Word wrapping is not used in the Text or Stamp object. The entered text will continue on the same line unless the Enter key is used start a new line.

Default value is True

Explanation

The WordWrap property sets whether or not word wrapping is used in the Text or Stamp object. The default value is True

When the WordWrap property is True, text being entered into the Text or Stamp object is wrapped to a new line when the text reaches the end of the object. When this text is drawn to the image, it will be drawn as it appears in the Text object.

If the text is too large to be displayed fully within the dimensions of the object, the latter part of the text will not be displayed. To change the size of the object, select the Text or Stamp object and move the sides of the object (The top, right, left, or bottom sides). Text will continue to be wrapped within the object while you are adjusting its size. You can force text to a new line by using the Enter key.

Selecting the Text or Stamp object and moving the corners, will change the size of the object and the text size at the same time.

When the WordWrap property is False, the text will not be wrapped within the object. Text will continue on the same line until the Enter key is pressed. If the text is too long to appear in the object, only the portion currently being entered will be displayed. Once the text has been entered, all text will be drawn on the same line unless a new line was forced using the Enter key.

To change word wrapping for the text in the Text or Stamp object after the text has been drawn, select the object and right click to display the "context menu", execute the ShowPropertyDialog method, or set the SelectedObjectWordWrap property.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


ClearAllObjects method

Newtone.ImageKit.Win.ImageKit.Edit.ClearAllObjects Method

This method deletes all annotation objects.

[Visual Basic] Public Function ClearAllObjects()
[C#] public void ClearAllObjects();

Parameters

None

Return Value

None

Explanation

The ClearAllObjects method deletes all annotation objects.

Objects deleted using this method cannot be retrieved. If you want to be able to retrieve the deleted objects before executing this method set the EditKind property to KindOfEdit.MultiSelect, then right click to display the context menu and choose "Select All" or execute the SelectAllObjects method. After that, you can delete the objects and they will be retrievable using the context menu's "Paste" item or by executing the PasteCopiedObjects method.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


ClearCopiedObjects method

Newtone.ImageKit.Win.ImageKit.Edit.ClearCopiedObjects Method

This method clears copied or cut annotation objects from the clipboard.

[Visual Basic] Public Function ClearCopiedObjects() As Boolean
[C#] public bool ClearAllObjects();

Parameters

None

Return Value

Returns true if successful, otherwise returns False

Explanation

The ClearCopiedObjects method clears copied or cut annotation objects from the clipboard.

Before executing this method, it is possible to check if copied data exists in the clipboard by referring to the CopiedObjectsExists property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


ClearEditHistory method

Newtone.ImageKit.Win.ImageKit.Edit.ClearEditHistory Method

This method deletes the history of all drawing and editing changes made to annotation objects.

[Visual Basic] Public Function ClearEditHistory()
[C#] public void ClearEditHistory();

Parameters

None

Return Value

None

Explanation

The ClearEditHistory method deletes the history of all drawing and editing changes made to annotation objects.

Once executed, undos and redos are not possible on previous changes but will be able to be performed on changes that occur after this method has been executed.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


CopySelectedObjects method

Newtone.ImageKit.Win.ImageKit.Edit.CopySelectedObjects Method

This method copies the selected object(s).

[Visual Basic] Public Function CopySelectedObjects() As Boolean
[C#] public bool CopySelectedObjects();

Parameters

None

Return Value

Returns True if successful, otherwise returns False.

Explanation

The CopySelectedObjects copies the selected object(s).

Executing this method when the EditKind property is set to KindOfEdit.Select or to KindOfEdit.MultiSelect copies the selected objects to a buffer. The buffer can only hold the objects from the current execution of this method. If the CopySelectedObjects method is executed while data is contained in the buffer, that data will be cleared before the new data is copied. To paste the copied objects in the ImageKit control, right click to display the context menu and choose "Paste" or execute the PasteCopiedObjects method.

It is possible to copy objects from one ImageKit control and paste them into another ImageKit control.

To perform the same function as executing this method, right click the object and display the context menu then select "Copy". For more details about the context menu, please refer to ContextMenuEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


CutSelectedObjects method

Newtone.ImageKit.Win.ImageKit.Edit.CutSelectedObjects Method

This method cuts the selected object(s).

[Visual Basic] Public Function CutSelectedObjects() As Boolean
[C#] public bool CutSelectedObjects();

Parameters

None

Return Value

Returns True if successful, otherwise returns False.

Explanation

The CutSelectedObjects cuts the selected object(s).

Executing this method when the EditKind property is set to KindOfEdit.Select or to KindOfEdit.MultiSelect cuts the selected objects and copies them to a buffer. The buffer can only hold the objects from the current execution of this method. If the CutSelectedObjects method is executed while data is contained in the buffer, that data will be cleared before the new data is cut and copied to the buffer. To paste the cut objects in the ImageKit control, right click to display the context menu and choose "Paste" or execute the PasteCopiedObjects method.

It is possible to cut objects from one ImageKit control and paste them into another ImageKit control.

To perform the same function as executing this method, right click the object and display the context menu then select "Cut". For more details about the context menu, please refer to ContextMenuEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DeleteSelectedObject method

Newtone.ImageKit.Win.ImageKit.Edit.DeleteSelectedObject Method

This method deletes the selected object.

[Visual Basic] Public Function DeleteSelectedObject() As Boolean
[C#] public bool DeleteSelectedObject();

Parameters

None

Return Value

Returns True if successful, otherwise returns False.

Explanation

This method deletes the selected object.

When the EditKind property is set to KindOfEdit.Select and an object is selected, executing this method will delete that object. To bring back the object deleted by this method, right click the object and display the context menu, the select "Undo" or execute the Undo method.

To perform the same function as executing this method, right click the object and display the context menu then select "Delete". For more details about the context menu, please refer to ContextMenuEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DeselectObjects Method

Newtone.ImageKit.Win.ImageKit.Edit.DeselectObjects Method

This method deselects all objects that are currently selected.

[Visual Basic] Public Function DeselectObjects()
[C#] public void DeselectObjects();

Parameters

None

Return Value

None

Explanation

The DeselectObjects method deselects all objects that are currently selected.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DrawArc method

Newtone.ImageKit.Win.ImageKit.Edit.DrawArc Method

This method draws arcs, pie shapes, and chords using polylines and polygons.

[Visual Basic] Public Function DrawArc(center As Point, radius As Integer, startAngle As Integer, drawAngle As Integer, numPoints As Integer, pie As Boolean, close As Boolean) As Boolean
[C#] public bool DrawArc(Point center, int radius, int startAngle, int drawAngle, int numPoints, bool pie, bool close);

Parameters

center

Coordinates for the center of the arc

radius

The radius of the circle of which the arc is a segment. (pixels)

startAngle

The angle setting the start of the arc.

drawAngle

The angle defining the drawing of the arc. Arcs are drawn from the start angle and continue for the number of degrees set in the drawAngle parameter.

numPoints

The number of points along the arc used to draw the arc. (2 or more points)

pie

Sets whether an arc or a pie shape is drawn

close

Sets whether the arc is closed

Return Value

Returns True if successful, otherwise returns False.

Explanation

The DrawArc method draws arcs, pie shapes, and chords using polylines and polygons.

To draw an arc, set appropriate values in the PenWidth, ForeColor, ForeColorOpacity, LineJoin, DashStyle properties and the appropriate parameters.

When using the DrawArc method, it is not necessary to set the EditKind property, depending on the properties that are used with the DrawArc method, a polyline or polygon object will be used.

The startAngle and drawAngle parameters determine the amount of the circle that is drawn as an arc. 0 degrees is defined as a position directly vertical above the center point, i.e. 12 o'clock. Positive values for the startAngle and drawAngle are in the clockwise direction. Negative values for these angles are in the counter-clockwise direction. The range of values is from 0 to +- 359. Values above 360 degrees will be set as 360.

A radius value of less than 1, a drawAngle value of 0, and a numPoints value of less than 2 will result in an error and False will be returned.

To delete the arc drawn with the DrawArc method, right click the object and display the context menu, the select "Undo" or execute the Undo method. After the arc is drawn, it may be modified via the polyline or polygon annotation objects.

If a portion of the arc lies outside the ImageKit control and the LimitAnnotationPosition property or LimitDrawPosition property are true, the arc will be resized to fit completely within the ImageKit control. In some cases this may result in an annotation that is not an arc or fan shape.

Values for pie and close | pie: False, close: False | pie: False, close: True | pie: True, close: False | pie: True, close: True
Shape | Arc - polyline | Closed Arc - polyline | Fan Shape - polyline (center is start and end point) | Fan Shape - polygon
The type of object drawn | KindOfEdit.Polyline | KindOfEdit.Polygon | KindOfEdit.Polyline | KindOfEdit.Polygon
Other properties that can be set | StartLineCap EndLineCap StartArrowCap StartArrowCapFilled StartArrowCapSize EndArrowCap EndArrowCapFilled EndArrowCapSize | Fill | StartLineCap EndLineCap StartArrowCap StartArrowCapFilled StartArrowCapSize EndArrowCap EndArrowCapFilled EndArrowCapSize | Fill
Example of Object |  |  |  |

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DrawEditedObjectsToImage method

Newtone.ImageKit.Win.ImageKit.Edit.DrawEditedObjectsToImage Method

This method embeds the annotation objects into a raster image.

[Visual Basic] Public Function DrawEditedObjectsToImage() As Boolean
[C#] public bool DrawEditedObjectsToImage();

Parameters

None

Return Value

Returns True if successful, otherwise returns False.

Explanation

The DrawEditedObjectsToImage method embeds the annotation objects into a raster image.

When a raster image is loaded as the base image in the ImageKit control and annotation objects have been drawn, executing the DrawEditedObjectsToImage method will rasterize the annotation objects and embed them into the base raster image. The resulting image is a raster image and can be saved using the usual ImageKit save methods. When the EmbedSelectedObjects property is True, only the selected annotation objects will be embedded. If the EmbedSelectedObjects property is False, all annotation objects will be embedded.

NOTE: After annotation objects have been embedded into the image, if the DeleteEmbeddedObjects property is True , the annotation objects will be cleared. In this case, in order to keep the annotation objects, be sure to save them to annotation file prior to embedding them. If the DeleteEmbeddedObjects property is False, the annotation objects will not be cleared after they have been embedded into the image.

If this method is executed when no object exists or when the EmbedSelectedObjects property is True and no object is selected, the result is False.

This method supports only raster images. However, when a raster image is CMYK, or the image is a vector image (WMF or EMF), this method will not embed the annotation objects into the vector image. This method will be ignored and will return False, the original vector image will be displayed without the annotation objects. (Although it is possible to draw annotation objects on top of vector images, edit the annotation objects, save them to or load them from an annotation file, it is not possible to embed the annotation object into a vector image.)

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DrawEllipse method

Newtone.ImageKit.Win.ImageKit.Edit.DrawEllipse Method

This method draws an ellipse.

[Visual Basic] Public Function DrawEllipse(rect As Rectangle) As Boolean
[C#] public bool DrawEllipse(Rectangle rect);

Parameters

rect

The Rectangle structure that defines the bounding rectangle for the ellipse.

Return Value

Returns True if successful, otherwise returns False.

Explanation

The DrawEllipse method draws an ellipse. To draw an ellipse, set appropriate values in the PenWidth, ForeColor, ForeColorOpacity, BackColor, BackColorOpacity, and Fill properties. Set the Rectangle structure that defines the bounding rectangle for the ellipse in the DrawEllipse's rect parameter. When the DrawEllipse method is executed, the ellipse will be drawn. If a portion of the ellipse lies outside the ImageKit control and the LimitAnnotationPosition property or LimitDrawPosition property are true, the ellipse will be resized to fit completely within the ImageKit control.

To delete the ellipse drawn with the DrawEllipse method, right click the object and display the context menu, the select "Undo" or execute the Undo method.

The DrawEllipse method can be used without setting the EditKind property to KindOfEdit.Ellipse.

It is also possible to draw an ellipse by setting the EditKind property to KindOfEdit.Ellipse then, on the base image displayed in the ImageKit control, use the mouse. For more details, please refer to the Edit Overview.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DrawLine method

Newtone.ImageKit.Win.ImageKit.Edit.DrawLine Method

This method draws a line.

[Visual Basic] Public Function DrawLine(pt As Point()) As Boolean
[C#] public bool DrawLine(Point[] pt);

Parameters

pt

The array of type Point that set the two endpoints of the line.

Return Value

Returns True if successful, otherwise returns False.

Explanation

The DrawLine method draws a line. To draw a line, set appropriate values in the PenWidth, ForeColor, ForeColorOpacity, DoubleLine, StartLineCap, EndLineCap, DashStyle, StartArrowCap, StartArrowCapFilled, StartArrowCapSize, EndArrowCap, EndArrowCapFilled, and EndArrowCapSize properties. Set the array of type Point to designate the end points of the line in the DrawLine's pt parameter. There must be 2 or more Points set in the pt parameter. Note that if an array containing more that two Points is set in the pt parameter and error will not occur. The first two points will be used to draw the line and the others ignored. When the DrawLine method is executed, the line will be drawn. If a portion of the line lies outside the ImageKit control and the LimitAnnotationPosition property or LimitDrawPosition property are true, the line will be resized to fit completely within the ImageKit control.

To delete the line drawn with the DrawLine method, right click the object and display the context menu, the select "Undo" or execute the Undo method.

The DrawLine method can be used without setting the EditKind property to KindOfEdit.Line.

It is also possible to draw a line by setting the EditKind property to KindOfEdit.Line then, on the base image displayed in the ImageKit control, use the mouse. For more details, please refer to the Edit Overview.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DrawPolygon method

Newtone.ImageKit.Win.ImageKit.Edit.DrawPolygon Method

This method draws a polygon.

[Visual Basic] Public Function DrawPolygon(pt As Point()) As Boolean
[C#] public bool DrawPolygon(Point[] pt);

Parameters

pt

The array of type Point that designate the points of the polygon

Return Value

Returns True if successful, otherwise returns False.

Explanation

The DrawPolygon method draws a polygon. To draw a polygon, set appropriate values in the PenWidth, ForeColor, ForeColorOpacity, BackColor, BackColorOpacity, Fill, DashStyle, and LineJoin properties. Set the array of type Point to designate the points of the polygon in the DrawPolygon's pt parameter. There must be 3 or more Points set in the pt parameter. When the DrawPolygon method is executed, the polygon will be drawn. If a portion of the polygon lies outside the ImageKit control and the LimitAnnotationPosition property or LimitDrawPosition property are true, the polygon will be resized to fit completely within the ImageKit control.

To delete the polygon drawn with the DrawPolygon method, right click the object and display the context menu, the select "Undo" or execute the Undo method.

The DrawPolygon method can be used without setting the EditKind property to KindOfEdit.Polygon.

It is also possible to draw a polygon by setting the EditKind property to KindOfEdit.Polygon then, on the base image displayed in the ImageKit control, use the mouse. For more details, please refer to the Edit Overview.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DrawPolyline method

Newtone.ImageKit.Win.ImageKit.Edit.DrawPolyline Method

This method draws a polyline.

[Visual Basic] Public Function DrawPolyline(pt As Point()) As Boolean
[C#] public bool DrawPolyline(Point[] pt);

Parameters

pt

The array of type Point that designates the points of the polyline

Return Value

Returns True if successful, otherwise returns False.

Explanation

The DrawPolyline method draws a polyline. To draw a polyline, set appropriate values in the PenWidth, ForeColor, ForeColorOpacity, StartLineCap, EndLineCap, DashStyle, LineJoin, StartArrowCap, StartArrowCapFilled, StartArrowCapSize, EndArrowCap, EndArrowCapFilled, and EndArrowCapSize properties. Set the array of type Point to designate the points of the polyline in the DrawPolyline's pt parameter. There must be 2 or more Points set in the pt parameter. When the DrawPolyline method is executed, the polyline will be drawn. If a portion of the polyline lies outside the ImageKit control and the LimitAnnotationPosition property or LimitDrawPosition property are true, the polyline will be resized to fit completely within the ImageKit control.

To delete the polyline drawn with the DrawPolyline method, right click the object and display the context menu, the select "Undo" or execute the Undo method.

The DrawPolyline method can be used without setting the EditKind property to KindOfEdit.Polyline.

It is also possible to draw a polyline by setting the EditKind property to KindOfEdit.Polyline then, on the base image displayed in the ImageKit control, use the mouse. For more details, please refer to the Edit Overview.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DrawRectangle method

Newtone.ImageKit.Win.ImageKit.Edit.DrawRectangle Method

This method draws a rectangle.

[Visual Basic] Public Function DrawRectangle(rect As Rectangle) As Boolean
[C#]public bool DrawRectangle(Rectangle rect);

Parameters

rect

The Rectangle structure designating where the rectangle is drawn.

Return Value

Returns True if successful, otherwise returns False.

Explanation

The DrawRectangle method draws a rectangle. To draw a rectangle, set appropriate values in the PenWidth, ForeColor, ForeColorOpacity, BackColor, BackColorOpacity, and Fill properties. Set the values for the coordinate location and size of the rectangle in the DrawRectangle method's rect parameter. When the DrawRectangle method is executed, the rectangle will be drawn. If a portion of the rectangle lies outside the ImageKit control and the LimitAnnotationPosition property or LimitDrawPosition property are true, the rectangle will be resized to fit completely within the ImageKit control.

To delete the rectangle drawn with the DrawRectangle method, right click the object and display the context menu, the select "Undo" or execute the Undo method.

The DrawRectangle method can be used without setting the EditKind property to KindOfEdit.Rectangle.

It is also possible to draw a rectangle by setting the EditKind property to KindOfEdit.Rectangle then, on the base image displayed in the ImageKit control, use the mouse. For more details, please refer to the Edit Overview.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DrawRoundRectangle method

Newtone.ImageKit.Win.ImageKit.Edit.DrawRoundRectangle Method

This method draws a round rectangle.

[Visual Basic] Public Function DrawRoundRectangle(rect As Rectangle) As Boolean
[C#]public bool DrawRoundRectangle(Rectangle rect);

Parameters

rect

The Rectangle structure designating where the round rectangle is drawn.

Return Value

Returns True if successful, otherwise returns False.

Explanation

The DrawRoundRectangle method draws a round rectangle. To draw a round rectangle, set appropriate values in the PenWidth, ForeColor, ForeColorOpacity, BackColor, BackColorOpacity, Fill, and RoundRectangleRadius properties. Set the values for the coordinate location and size of the round rectangle in the DrawRoundRectangle method's rect parameter. When the DrawRoundRectangle method is executed, the round rectangle will be drawn. If a portion of the round rectangle lies outside the ImageKit control and the LimitAnnotationPosition property or LimitDrawPosition property are true, the round rectangle will be resized to fit completely within the ImageKit control.

To delete the round rectangle drawn with the DrawRoundRectangle method, right click the object and display the context menu, the select "Undo" or execute the Undo method.

The DrawRoundRectangle method can be used without setting the EditKind property to KindOfEdit.RoundRectangle.

It is also possible to draw a round rectangle by setting the EditKind property to KindOfEdit.RoundRectangle then, on the base image displayed in the ImageKit control, use the mouse. For more details, please refer to the Edit Overview.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DrawStamp Method Overload List

Newtone.ImageKit.Win.ImageKit.Edit.DrawStamp Method

These methods draw a Stamp object

Overload List

DrawStamp(Point)

This DrawStamp method will draw a Stamp object from the specified point. The object will be drawn on a single line unless a new line character is used to force a new line.

[Visual Basic] Public Property DrawStamp(Point) As Boolean
[C#] public bool DrawStamp(Point)

DrawStamp(RectangleF)

This DrawStamp method will draw a Stamp object, within the specified rectangle. The text will be wrapped to fit within the specified rectangle

[Visual Basic] Public Property DrawStamp(RectangleF) As Boolean
[C#] public bool DrawStamp(RectangleF)

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DrawStamp(Point) method

Newtone.ImageKit.Win.ImageKit.Edit.DrawStamp Method

This method draws a Stamp object from the specified point.

[Visual Basic] Public Function DrawStamp(pt As Point) As Boolean
[C#] public bool DrawStamp(Point pt);

Parameters

pt

The coordinates of type Point designating the top left corner of the Stamp object.

Return Value

Returns True if successful, otherwise returns False.

Explanation

This DrawStamp method draws a Stamp object from the specified point. Prior to executing this method, set appropriate values in the FontName, FontSize, FontBold, FontItalic, FontStrikeout, FontUnderline, ForeColor, ForeColorOpacity, BackColor, BackColorOpacity, Border, BorderColor, BorderColorOpacity, BorderShape, Fill, PenWidth, TextAlign, VerticalText, and RightToLeft properties. Then set the text to be drawn in the Text property.

Set the coordinates for the top left corner of the Stamp object in the DrawStamp method's pt parameter. When the DrawStamp method is executed, the Stamp object with the text that is set in the Text property will be drawn with its top left corner at that coordinate location. Text will be drawn on a single line unless a new line character is used.

This method will draw text, irrespective of the EditKind and WordWrap property values.

If the coordinates set in the pt parameter are outside the image displayed in the ImageKit control and the LimitAnnotationPosition property or the LimitDrawPosition property are set to True, the text will be repositioned so the coordinate location is within the image.

To delete the text drawn with the DrawStamp method, right click the object and display the context menu, the select "Undo" or execute the Undo method.

The DrawStamp method can be used without setting the EditKind property to KindOfEdit.Stamp. The WordWrap property does not affect the output of this method.

It is also possible to draw a Stamp object by setting the EditKind property to KindOfEdit.Stamp then, on the base image displayed in the ImageKit control, use the mouse and keyboard. For more details, please refer to the Edit Overview.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DrawStamp(RectangleF) method

Newtone.ImageKit.Win.ImageKit.Edit.DrawStamp Method

This method draws a Stamp object within the specified rectangle.

[Visual Basic] Public Function DrawStamp(rct As RectangleF) As Boolean
[C#] public bool DrawStamp(RectangleF rct);

Parameters

rct

A rectangle of type RectangleF designating the area within which the Stamp object is drawn.

Return Value

Returns True if successful, otherwise returns False.

Explanation

This DrawStamp method draws a Stamp object within the specified rectangle. Prior to executing this method, set appropriate values in the FontName, FontSize, FontBold, FontItalic, FontStrikeout, FontUnderline, ForeColor, ForeColorOpacity, BackColor, BackColorOpacity, Border, BorderColor, BorderColorOpacity, BorderShape, Fill, PenWidth, TextAlign, VerticalText, and RightToLeft properties. Then set the text to be drawn in the Text property.

Set the coordinates for the rectangle of the text object in the DrawStamp method's rct parameter. When the DrawStamp method is executed, the text set in the Text property will be drawn within the Stamp object. Text will automatically be word-wrapped to fit within the rectangle. If the text is too long for the specified rectangle, the latter part of the text will not be drawn. In this case, the extra text is not deleted and the entire text set in the Text property will be saved in the Stamp object.

This method will draw text, irrespective of the EditKind and WordWrap property values.

If the coordinates set in the rct parameter are outside the image displayed in the ImageKit control and the LimitAnnotationPosition property or the LimitDrawPosition property are set to True, the text will be repositioned so the coordinate location is within the image.

To delete the text drawn with the DrawStamp method, right click the object and display the context menu, the select "Undo" or execute the Undo method.

The DrawStamp method can be used without setting the EditKind property to KindOfEdit.Stamp.

It is also possible to draw text by setting the EditKind property to KindOfEdit.Stamp then, on the base image displayed in the ImageKit control, use the mouse and keyboard. For more details, please refer to the Edit Overview.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DrawText Method Overload List

Newtone.ImageKit.Win.ImageKit.Edit.DrawText Method

These methods draws a Text object

Overload List

DrawText(Point)

This DrawText method will draw a Text object from the specified point. The text will be drawn on a single line unless a new line character is used to force a new line.

[Visual Basic] Public Property DrawText(Point) As Boolean
[C#] public bool DrawText(Point)

DrawText(RectangleF)

This DrawText method will draw a Text object within the specified rectangle. Text will be wrapped to fit within the rectangle

[Visual Basic] Public Property DrawText(RectangleF) As Boolean
[C#] public bool DrawText(RectangleF)

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DrawText(Point) method

Newtone.ImageKit.Win.ImageKit.Edit.DrawText Method

This method draws a Text object from the specified point.

[Visual Basic] Public Function DrawText(pt As Point) As Boolean
[C#] public bool DrawText(Point pt);

Parameters

pt

The coordinates of type Point designating the top left corner of the Text object.

Return Value

Returns True if successful, otherwise returns False.

Explanation

This DrawText method draws a Text object from the specified point. Prior to executing this method, set appropriate values in the FontName, FontSize, FontBold, FontItalic, FontStrikeout, FontUnderline, ForeColor, ForeColorOpacity, BackColor, BackColorOpacity, Border, BorderColor, BorderColorOpacity, BorderShape, Fill, PenWidth, VerticalText, and RightToLeft properties. Then set the text to be drawn in the Text property. Set the coordinates for the top left corner of the Text object in the DrawText method's pt parameter. When the DrawText method is executed, the text set in the Text property will be drawn in the Text object at that coordinate location. Text will be drawn on a single line unless a new line character is used.

This method will draw text, irrespective of the EditKind and WordWrap property values.

If the coordinates set in the pt parameter are outside the image displayed in the ImageKit control and the LimitAnnotationPosition property or the LimitDrawPosition property are set to True, the text will be repositioned so the coordinate location is within the image.

To delete the text drawn with the DrawText method, right click the object and display the context menu, the select "Undo" or execute the Undo method.

The DrawText method can be used without setting the EditKind property to KindOfEdit.Text.

It is also possible to draw text by setting the EditKind property to KindOfEdit.Text then, on the base image displayed in the ImageKit control, use the mouse and keyboard. For more details, please refer to the Edit Overview.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


DrawText(RectangleF) method

Newtone.ImageKit.Win.ImageKit.Edit.DrawText Method

This method draws a Text object within the specified rectangle.

[Visual Basic] Public Function DrawText(rct As RectangleF) As Boolean
[C#] public bool DrawText(RectangleF rct);

Parameters

rct

A rectangle of type RectangleF designating the area within which the Text object is drawn.

Return Value

Returns True if successful, otherwise returns False.

Explanation

This DrawText method draws a Text object within the specified rectangle. Prior to executing this method, set appropriate values in the FontName, FontSize, FontBold, FontItalic, FontStrikeout, FontUnderline, ForeColor, ForeColorOpacity, BackColor, BackColorOpacity, Border, BorderColor, BorderColorOpacity, BorderShape, Fill, PenWidth, VerticalText, and RightToLeft properties. Then set the text to be drawn in the Text property.

Set the coordinates for the rectangle of the text object in the DrawText method's rct parameter. When the DrawText method is executed, the text set in the Text property will be drawn within that rectangle. Text will automatically be word-wrapped to fit within the rectangle. If the text is too long for the specified rectangle, the latter part of the text will not be drawn. In this case, the extra text is not deleted and the entire text set in the Text property will be saved in the Text object.

This method will draw text, irrespective of the EditKind and WordWrap property values.

If the coordinates set in the rct parameter are outside the image displayed in the ImageKit control and the LimitAnnotationPosition property or the LimitDrawPosition property are set to True, the text will be repositioned so the coordinate location is within the image.

To delete the text drawn with the DrawText method, right click the object and display the context menu, the select "Undo" or execute the Undo method.

The DrawText method can be used without setting the EditKind property to KindOfEdit.Text.

It is also possible to draw text by setting the EditKind property to KindOfEdit.Text then, on the base image displayed in the ImageKit control, use the mouse and keyboard. For more details, please refer to the Edit Overview.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


LoadAnnotationFile method

Newtone.ImageKit.Win.ImageKit.Edit.LoadAnnotationFile Method

This method loads annotation information from an existing annotation file and displays the annotation objects on the base image.

[Visual Basic] Public Function LoadAnnotationFile() As Boolean
[C#] public bool LoadAnnotationFile();

Parameters

None

Return Value

Returns True if successful, otherwise returns False.

Explanation

The LoadAnnotationFile method loads annotation information from an existing annotation file and displays the annotation objects on the base image.

To load annotation information, a base image must be loaded into the ImageKit control. Set the file name and path to an annotation file (a file previously created by the SaveAnnotationFile method) into the AnnotationFileName property and execute the LoadAnnotationFile method.

Note: Annotation files created on one base image can be loaded onto a different base image.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


MoveBackOne Method

Newtone.ImageKit.Win.ImageKit.Edit.MoveBackOne Method

This method moves the selected annotation object's Z-Order value back one.

[Visual Basic] Public Function MoveBackOne() As Boolean
[C#] public bool MoveBackOne();

Parameters

None

Return Value

Returns True if successful, otherwise returns False

Explanation

The MoveBackOne method moves the selected annotation object's Z-Order value back one. This method is enabled when the EditKind property has a value of KindOfEdit.Select and the object is selected. When multiple objects are displayed and this method is executed, the selected object's Z order value becomes smaller than the next object in the Z-Order and the object is "moved back one". To return an object that has been moved, right click the object and display the context menu, the select "Undo" or execute the Undo method and the object will be returned to its original Z order.

The MoveBackOne method can be executed using the context menu. Right click on the object to display the context menu and select "Move Back One". For more details about the context menu please refer to the ContextMenuEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


MoveForwardOne Method

Newtone.ImageKit.Win.ImageKit.Edit.MoveForwardOne Method

This method moves the selected annotation object's Z-Order value forward one.

[Visual Basic] Public Function MoveForwardOne() As Boolean
[C#] public bool MoveForwardOne();

Parameters

None

Return Value

Returns True if successful, otherwise returns False

Explanation

The MoveForwardOne method moves the selected annotation object's Z-Order value forward one. This method is enabled when the EditKind property has a value of KindOfEdit.Select and the object is selected. When multiple objects are displayed and this method is executed, the selected object's Z order value becomes larger than the next object in the Z-Order and the object is "moved forward one". To return an object that has been moved, right click the object and display the context menu, the select "Undo" or execute the Undo method and the object will be returned to its original Z order.

The MoveForwardOne method can be executed using the context menu. Right click on the object to display the context menu and select "Move Forward One". For more details about the context menu please refer to the ContextMenuEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


MoveToBack method

Newtone.ImageKit.Win.ImageKit.Edit.MoveToBack Method

This method moves the selected object to the back.

[Visual Basic] Public Function MoveToBack() As Boolean
[C#] public bool MoveToBack();

Parameters

None

Return Value

Returns True if successful, otherwise returns False.

Explanation

The MoveToBack method moves the selected object to the back. This method is enabled when the EditKind property has a value of KindOfEdit .Select and an object has been selected. When multiple objects are displayed and this method is executed, the selected object's Z order value becomes the smallest of all objects and the object is "moved to the back". To return an object that has been moved, right click the object and display the context menu, the select "Undo" or execute the Undo method and the object will be returned to its original Z order.

The MoveToBack method can be executed using the context menu. Right click on the object to display the context menu and select "Move To Back". For more details about the context menu please refer to the ContextMenuEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


MoveToFront method

Newtone.ImageKit.Win.ImageKit.Edit.MoveToFront Method

This method moves the selected object to the front.

[Visual Basic] Public Function MoveToFront() As Boolean
[C#] public bool MoveToFront();

Parameters

None

Return Value

Returns True if successful, otherwise returns False.

Explanation

The MoveToFront method moves the selected object to the front. This method is enabled when the EditKind property has a value of KindOfEdit .Select and an object has been selected. When multiple objects are displayed and this method is executed, the selected object's Z order value becomes the largest of all objects and the object is "moved to the front". To return an object that has been moved, right click the object and display the context menu, the select "Undo" or execute the Undo method and the object will be returned to its original Z order.

The MoveToFront method can be executed using the context menu. Right click on the object to display the context menu and select "Move To Front". For more details about the context menu please refer to the ContextMenuEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


PasteCopiedObjects method

Newtone.ImageKit.Win.ImageKit.Edit.PasteCopiedObjects Method

This method pastes objects that have been copied.

[Visual Basic] Public Function PasteCopiedObjects() As Boolean
[C#] public bool PasteCopiedObjects();

Parameters

None

Return Value

Returns True if successful, otherwise returns False.

Explanation

The PasteCopiedObjects method pastes objects that have been copied by the CopySelectedObjects method, by the CutSelectedObjects method, or by choosing "Copy" or "Cut" in the context menu. The objects will be pasted in the coordinate location set in the PastePoint property. If multiple objects have been copied then only when the EditKind property is set to KindOfEdit.MultiSelect can these multiple objects be pasted. If a single object has been copied then when the EditKind property is set to KindOfEdit.Select or set to KindOfEdit.MultiSelect the object can be pasted.

As long as the loaded image doesn't change after the annotation objects have been copied, the EditKind property can be changed and another object drawn, as long as the EditKind property is returned to the above values the copied object can be pasted. However, after copying objects, if another image is loaded, then it is not possible to paste the copied objects.

The top left corner of the copied object will be pasted at the coordinates specified in the PastePoint property. When multiple objects are copied, the most upper left objects top left corner will be pasted at the coordinates specified by the PastePoint property and the other objects will maintain the relative position as when they were copied. If any of the pasted objects are outside of the image displayed in the ImageKit control and the LimitAnnotationPosition or LimitedPastePosition properties are True, all pasted objects will automatically be repositioned to fit within the ImageKit control.

To remove the objects pasted with the PasteCopiedObjects method, right click on the objects and choose "Undo" in the context menu or execute the Undo method.

To perform the same function as executing this method, right click the object and display the context menu then select "Paste". For more details about the context menu, please refer to ContextMenuEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


PasteImage method

Newtone.ImageKit.Win.ImageKit.Edit.PasteImage Method

This method creates an Image object and displays the specified image.

[Visual Basic] Public Function PasteImage(filename As String, rect As Rectangle) As Boolean
[C#] public bool PasteImage(string filename, Rectangle rect);

Parameters

filename

The file name (full path) of the image to be displayed in the Image object

rect

The rectangle where the Image object is created

Return Value

Returns True if successful, otherwise returns False.

Explanation

The PasteImage method creates an Image object and displays the specified image.

The PasteImage's filename parameter contains the file name of the image that will be displayed in the Image object. Be sure to set the full path to the image. The PasteImage's rect parameter determines the location in the ImageKit control where the Image object will be created and this rectangle determines the size of the image. When the AspectRatio property is True the image will be displayed in the Image object while maintaining the image's height/width ratio. If the AspectRatio property is False, the image will be stretched to fill the Image object.

If a portion of the pasted image is outside of the ImageKit control and the LimitAnnotationPosition property and the LimitDrawPosition property are set to True, the image will be repositioned to fit completely within the ImageKit control.

To delete the image pasted with the PasteImage method, right click on the object and display the context menu, the select "Undo" or execute the Undo method.

The PasteImage method can be used without setting the EditKind property to KindOfEdit.Image.

It is also possible to paste an image by setting the EditKind property to KindOfEdit.Image then, on the base image displayed in the ImageKit control, use the mouse. For more details, please refer to the Edit Overview.

Note: All images that can be loaded into the ImageKit control can also be pasted with the PasteImage method. If the selected file cannot be pasted, False will be returned. If the area set in the rect parameter is too large for the available memory to paste the image there, a small white image with a red x will appear instead. Please deleted the image object using "Delete" or "Undo" in the context menu and paste a smaller image object.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


Redo method

Newtone.ImageKit.Win.ImageKit.Edit.Redo Method

This method reverses an undo step.

[Visual Basic] Public Function Redo() As Boolean
[C#] public bool Redo();

Parameters

None

Return Value

Returns True if successful, otherwise returns False.

Explanation

The Redo method reverses an undo step (the result of executing the Undo method or of choosing "Undo" in the context menu) and returns the annotation objects to the state prior to that undo. Reversing an undo step is called a "redo step". You can perform the same number of redo steps as undo steps.

If after several undo steps and redo steps, a new change is made to the annotation objects, the remaining redo steps cannot be performed. (see example below)

The CanRedoCount property can be used to retrieve the number of possible redos remaining. Executing the ClearEditHistory method resets the Undo/Redo count to zero.

To perform the same function as executing this method, right click the object and display the context menu then select "Redo". For more details about the context menu, please refer to ContextMenuEnabled property.

Example:
Suppose you have made 5 annotation changes in a row (State1 --> State2 --> State3 --> State4 --> State5)

You perform 4 undo steps either by executing the Undo method or by choosing the "Undo" item in the context menu. You are now at State1.

You now execute the Redo method 2 times putting you at State3.

Next you draw a new object (State6).

At this point State4 and State5 are unretrievable. The undo/redo steps will pass through the following states: State1 --> State2 --> State3 --> State6.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SaveAnnotationFile method

Newtone.ImageKit.Win.ImageKit.Edit.SaveAnnotationFile Method

This method saves the annotation information to the annotation file.

[Visual Basic] Public Function SaveAnnotationFile() As Boolean
[C#] public bool SaveAnnotationFile();

Parameters

None

Return Value

Returns True if successful, otherwise returns False.

Explanation

The SaveAnnotationFile method saves the information for all of the annotation objects drawn on the ImageKit Control's base image. This annotation information is saved in xml format into an annotation file according to the file name and path set in the AnnotationFileName property. Eventhough the annotation file is in xml format, the file extention does not have to be ".xml" but can be any extention of your choosing.

Files saved with the SaveAnnotationFile method can be loaded using the LoadAnnotationFile method which will redraw all of the annotation objects on top of the base image in the ImageKit Control.

Note: The annotation objects defined in the annotation file are independent of the image on which they are displayed. It is possible to load an annotation file onto a base image that is different from the image that was displayed when the annotation file was created.

Important: When an annotation file is saved, if the Image object is among the annotation objects being used, then a copy of the image that is being pasted in the Image object is made and saved in the same directory as the annotation file. When that annotation file is loaded, the copied image is the image displayed in the Image object. If the SaveAnnotationSelectedObjects property is True when this method is executed then only the objects selected at that time will be saved into the annotation file.

If you deploy an annotation file to another PC, simply deploy the copied image along with the annotation file and the Image object will display it with the need to adjust the path to the image used by the Image object. You can see how this is done by looking at the Image object's information in the saved annotation file. You will see that only the filename of the image used by the Image object is saved in the annotation file. If you edit this information by adding a path to a different image, that path will be used and that image will be loaded into the Image object.

If an image of the same name already exists in the folder where you are saving the annotation file, then that image will be overwritten.

If you are using multiple Image annotation objects and they load images from different directories but the images have the same filename, then the copied images will be saved with the following string appended to their filename:

"_**"

where ** is a two digit number starting from "01" up to "99".

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectAllObjects method

Newtone.ImageKit.Win.ImageKit.Edit.SelectAllObjects Method

This method selects or deselects all of the annotation objects drawn.

[Visual Basic] Public Function SelectAllObjects() As Boolean
[C#] public bool SelectAllObjects();

Parameters

None

Return Value

Returns True if successful, otherwise returns False.

Explanation

The SelectAllObjects method selects or deselects all of the annotation objects drawn. Even if the EditKind property is not set to KindOfEdit.MultiSelect, as a result of executing this method, the EditKind property will automatically be set to KindOfEdit.MultiSelect.

If this method is executed when no objects are selected or when only some objects have been selected, then all objects will be selected. If this method is executed when all objects have been selected, then all objects will be deselected.

When objects are selected, they may be deleted, moved, or copied.

Right clicking on the image displayed in the ImageKit Control brings up the context menu where you can choose "Select/Deselect All". This has the same effect as executing the SelectAllObjects method. For more details about the context menu, please refer to the ContextMenuEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectMultiObjects method

Newtone.ImageKit.Win.ImageKit.Edit.SelectMultiObjects Method

This method selects multiple objects whose numbers are specified in an array.

[Visual Basic] Public Function SelectMultiObjects(index As Integer()) As Boolean
[C#] public bool SelectMultiObjects(int[] index);

Parameters

index
An array of numbers of the images to be selected

Return Value

Returns True if successful, otherwise returns False.

Explanation

The SelectMultiObjects method selects multiple objects whose numbers are specified in the index parameter array.

The object numbers specified in the array do not have to be in order. (This method works in the same way as if you hold down the Ctrl key and click on multiple objects to select them.)

Even if the EditKind property is not set to KindOfEdit.MultiSelect, as a result of executing this method, the EditKind property will automatically be set to KindOfEdit.MultiSelect.

When using this method, if none of the objects corresponding to the object numbers specified in the index parameter exist, then this method will return False. However, if even one of the objects corresponding to the object numbers specified in the index parameter exists, then that object will be selected and this method will return True.

Example 1:
5 annotation objects exist. You have set these object numbers in the index parameter: {2, 3, 8}. Only the second and third object will be selected and this method will return True.

Example 2:
5 annotation objects exist. You have set these object numbers in the index parameter: {8, 10}. No objects will be selected and False will be returned.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


SelectObject Method

Newtone.ImageKit.Win.ImageKit.Edit.SelectObject Method

This method selects the object whose number is specified.

[Visual Basic] Public Function SelectObject(index As Integer) As Boolean
[C#]public bool SelectObject(int index);

Parameters

index

The number of the object to be selected.

Return Value

Returns True if successful, otherwise returns False.

Explanation

The SelectObject method selects the object whose number is specified. This method acts in the same way as clicking an object to select it.

This method is enabled when the EditKind property is set to a value of KindOfEdit.Select. Even if the EditKind property is set to a value other than KindOfEdit.Select, executing this method will result in the EditKind property being automatically set to KindOfEdit.Select.

Executing the SelectObject method sets the all relevant property values for the selected object whose names begin with "SelectObject....".

Below is a list of these properties:
SelectedObjectAngle, SelectedObjectAspectRatio, SelectedObjectBackColor, SelectedObjectBackColorOpacity, SelectedObjectBorder, SelectedObjectBorderColor, SelectedObjectBorderColorOpacity, SelectedObjectBorderShape, SelectedObjectClosePenLine, SelectedObjectDashStyle, SelectedObjectDoubleLine, SelectedObjectDrawPoints, SelectedObjectEndArrowCap, SelectedObjectEndArrowCapFilled, SelectedObjectEndArrowCapSize, SelectedObjectEndLineCap, SelectedObjectFill, SelectedObjectFontBold, SelectedObjectFontItalic, SelectedObjectFontName, SelectedObjectFontSize, SelectedObjectFontStrikeout, SelectedObjectFontUnderline, SelectedObjectForeColor, SelectedObjectForeColorOpacity, SelectedObjectImageFileName, SelectedObjectKind, SelectedObjectLineJoin, SelectedObjectNumber, SelectedObjectPenWidth, SelectedObjectRightToLeft, SelectedObjectRoundRectangleRadius, SelectedObjectStartArrowCap, SelectedObjectStartArrowCapFilled, SelectedObjectStartArrowCapSize, SelectedObjectStartLineCap, SelectedObjectText, SelectedObjectTextAlign, SelectedObjectVerticalText, SelectedObjectWordWrap.

If a number of an object that does not exist is set in this method's parameter, then this method will return False and the SelectedObjectNumber property will be set to 0.

Also See

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


ShowPropertyDialog method

Newtone.ImageKit.Win.ImageKit.Edit.ShowPropertyDialog Method

This method displays a dialog that allows the properties of the selected annotation object to be changed.

[Visual Basic] Public Function ShowPropertyDialog() As Boolean
[C#] public bool ShowPropertyDialog();

Parameters

None

Return Value

Returns True if successful, otherwise returns False

Explanation

The ShowPropertyDialog method displays a dialog that allows the properties of the selected annotation object to be changed.

When the EditKind property is set to KindOfEdit.Select and an annotation object has been selected, executing the ShowPropertyDialog method will display a dialog allowing that object's properties to be changed. The dialog displayed and the properties that can be changed will depend on the object that is selected. By setting property values for properties whose names start with "Dialog...Visible" or start with "Dialog....Enabled", you can determine which of an object's properties will be displayed / enabled in that object's Properties Dialog.

A full list of this properties is given below:

DialogAngleEnabled, DialogAngleVisible, DialogAspectRatioEnabled, DialogAspectRatioVisible, DialogBackColorEnabled, DialogBackColorOpacityEnabled, DialogBackColorOpacityVisible, DialogBackColorVisible, DialogBorderColorVisible, DialogBorderEnabled, DialogBorderShapeEnabled, DialogBorderShapeVisible, DialogBorderVisible, DialogClosePenLineEnabled, DialogClosePenLineVisible, DialogCurveTensionEnable, CurveTensionVisible, DialogDashStyleEnabled, DialogDashStyleVisible, DialogDoubleLineEnabled, DialogDoubleLineVisible, DialogEndArrowCapEnabled, DialogEndArrowCapFilledEnabled, DialogEndArrowCapFilledVisible, DialogEndArrowCapSizeEnabled, DialogEndArrowCapSizeVisible, DialogEndArrowCapVisible, DialogEndLineCapEnabled, DialogEndLineCapVisible, DialogFillEnabled, DialogFillVisible, DialogFontBoldEnabled, DialogFontBoldVisible, DialogFontItalicEnabled, DialogFontItalicVisible, DialogFontNameEnabled, DialogFontNameVisible, DialogFontSizeEnabled, DialogFontSizeVisible, DialogFontStrikeoutEnabled, DialogFontStrikeoutVisible, DialogFontUnderlineEnabled, DialogFontUnderlineVisible, DialogForeColorEnabled, DialogForeColorOpacityEnabled, DialogForeColorOpacityVisible, DialogForeColorVisible, DialogImageFileNameEnabled, DialogImageFileNameVisible, DialogLineJoinEnabled, DialogLineJoinVisible, DialogMaxPenWidth, DialogPenWidthEnabled, DialogPenWidthVisible, DialogRightToLeftEnabled, DialogRightToLeftVisible, DialogRoundRectangleRadiusEnabled, DialogRoundRectangleRadiusVisible, DialogStartArrowCapEnabled, DialogStartArrowCapFilledEnabled, DialogStartArrowCapFilledVisible, DialogStartArrowCapSizeEnabled, DialogStartArrowCapSizeVisible, DialogStartArrowCapVisible, DialogStartLineCapEnabled, DialogStartLineCapVisible, DialogTextAlignEnabled, DialogTextAlignVisible, DialogTextEnabled, DialogTextVisible, DialogVerticalTextEnabled, DialogVerticalTextVisible, DialogWordWrapEnabled, DialogWordWrapVisible,

Right clicking on the image displayed in the ImageKit Control brings up the context menu where you can choose "Properties". This has the same effect as executing the ShowPropertyDialog method. For more details about the context menu, please refer to the ContextMenuEnabled property. To suppress the standard Properties Dialog and display a custom dialog, please refer to the CustomDialog property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


Undo method

Newtone.ImageKit.Win.ImageKit.Edit.Undo Method

This method removes the last change to the annotation object and returns it to its previous state.

[Visual Basic] Public Function Undo() As Boolean
[C#] public bool Undo();

Parameters

None

Return Value

Returns True if successful, otherwise returns False.

Explanation

The Undo method removes the last change to the annotation object and returns it to its previous state.

Executing this method will delete the newest change made to the annotation objects and return them to the state prior to that last change. This is called an "undo step". Executing this method multiple times will continue removing changes until the number of undo steps defined in the UndoMax property has been reached. The Undo method will have no affect beyond the number of undo steps defined by the UndoMax property.

By using the Redo Method or by choosing "Redo" in the context menu, an undo step can be reversed. You can perform the same amount of redo steps as undo steps.

To perform the same function as executing this method, right click the object and display the context menu then select "Undo". For more details about the context menu, please refer to ContextMenuEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


Effect Members

Newtone.ImageKit.Win.ImageKit.Effect All Members

Public Properties

DestinationMask | Retrieves the mask image used when processing an effect
Inside | Determines whether the area inside the selected area will be processed or the area outside the selected area will be processed
Point | Sets the coordinates values for the points defining the polygon area on the image to be processed
Rect | Sets the coordinates of a rectangle on the image
SelectMode | Sets the type of area that will be processed on the image
SourceMask | Refers to the image handle for the input mask image

Public methods

Affine | Corrects a warped raster image
AntiAlias | Smoothes edges in raster images
AutoSelectImage | Uses a specified color (RGB value), compares this value to pixels in the image and selects areas of the image that have that color. From this selection, this method creates a new image and mask image.
Blur | Blurs a raster image
Canvas | Produces a canvas effect on the raster image
CheckSecretImage | Retrieves the digital watermark from a raster image
CombineRGBAImage | Creates a 32-bit RGBA image from an image and an alpha channel
ConvertColor | Converts images from one bit count to another
CustomFilter | Creates a custom effects filter for raster images
CutRectImage | Copies that portion of a raster image that is specified by the selected rectangle
Emboss | Creates an emboss effect on a raster image
EndBitmapAccess | Allows access to pixels in the Device Independent Bitmap (DIB)
GetBitmapPixel | Retrieves the RGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB)
GlassTile | Creates an glass tile effect on a raster image
Layer | Layers two raster images together
Lens | Creates a lens like effect on a raster image
Mosaic | Creates a mosiac effect on a raster image
MotionBlur | Creates a motion blur effect on a raster image
OilPaint | Produces an effect similar to an oil painting on the image
Outline | Produces an outline effect on the image
Panorama | Composes a panorama image from two raster images
PasteImage | Pastes a raster image into another raster image
RemoveNoise | Reduces the image noise in raster images
RemoveRedEye | Removes "red eye" from images by converting reddish colors within the selected area to another specified color
Resize | Changes the size of a raster image
RGBGamma | Uses gamma correction to adjust the RGB values of a raster image
RGBLevel | Increases (or decreases) the RGB values of a raster image
RGBReverse | Reverses the RGB values of a raster image
RGBSpline | Uses spline function to modifiy the RGB values of a raster image
Ripple | Produces a ripple like effect on a raster image
Rotate (Overloaded method) | Rotates raster images including 32 bit color images with alpha channel
SelectImage | Defines an area on a raster image and create a new image and mask image from that area
SetBitmapPixel | Sets the RGB value and the palette number of a specified pixel in the Device Independent Bitmap (DIB)
SetChroma | Adjusts the chrominance of a raster image
SetGray | Changes a raster image to gray
SetSecretImage | Sets a digital watermark image or digital watermark text into a raster image
Sharpen | Modifies sharpness in a raster image
SplitRGBAImage | Splits a 32 bit RGBA image into a 24 bit RGB image and a 8 bit alpha channel
StartBitmapAccess | Allows access to pixels in the Device Independent Bitmap (DIB)
UnifyColor | Allows you to convert a range in colors in a raster image into one color
Waves | Creates a wave like effect on a raster image
WhirlPinch | Produces an interesting effect similar to pinching a raster image then twisting your fingers
YCCGamma | Uses gamma correction to adjust the YCrCb values of a raster image
YCCLevel | Increases (or decreases) the YCrCb values of a raster image
YCCReverse | Reverses the YCrCb values of a raster image
YCCSpline | Uses spline function to modifiy the YCrCb values of a raster image

See Also

Newtone.ImageKit.Win.ImageKit


DestinationAsImageKitImage property

Newtone.ImageKit.Win.ImageKit.Effect.DestinationAsImageKitImage Property

This property determines whether or not the image, created by applying an Effect method, is set into the ImageKit.Image property.

[Visual Basic] Public Property DestinationAsImageKitImage As Boolean
[C#] public bool DestinationMask {get; set;}

Property Value

True: The image is set into the ImageKit.Image property
False: The image is set into the DestinationImage property

Default value is False

Explanation

The DestinationAsImageKitImage property determines whether or not the image, created by applying an Effect method, is set into the ImageKit.Image property. When this property is False, the image created by an Effect method is set into the DestinationImage property. This allows the original image in the ImageKit.Image property to be passed to an Effect method and remain unaffected after the method executes.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


DestinationImage property

Newtone.ImageKit.Win.ImageKit.Effect.DestinationImage Property

This property sets the image that results when an Effect method is executed.

[Visual Basic] Public Property DestinationImage As System.Drawing.Image
[C#] public System.Drawing.Image DestinationImage {get; set;}

Property Value

A type of System.Drawing.Image

Default value is null (Nothing)

Explanation

The DestinationImage property sets the image that results when an Effect method is executed. When the DestinationAsImageKitImage property is False, the image that is created by executing an Effect method is set into this property. If the DestinationAsImageKitImage property is True, the DestinationImage property will be null (Nothing) and instead, the created image will be set into the ImageKit.Image property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


DestinationMask property

Newtone.ImageKit.Win.ImageKit.Effect.DestinationMask Property

This property sets and retrieves the mask image used when an Effect method is executed.
[Visual Basic] Public Property DestinationMask As System.Drawing.Image
[C#] public System.Drawing.Image DestinationMask {get; set;}

Property Value

A type of System.Drawing.Image
Default value is null (Nothing)

Explanation

This property sets and retrieves the mask image used when an Effect method is executed. The mask image must be a 1-bit color black and white image which is the same size as the image it masks.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Inside property

Newtone.ImageKit.Win.ImageKit.Effect.Inside Property

This property determines whether the area inside the selected area will be processed or the area outside the selected area will be processed.

[Visual Basic]
Public Property Inside As Boolean
[C#]
public bool Inside {get; set;}

Property Value

When true, the area inside the selected area will be processed. When false, the area outside the selected area will be processed.

Explanation

The Inside property determines whether the area inside the selected area will be processed or the area outside the selected area will be processed. This property is enabled when the SelectMode property is set to EffectMask, EffectPolygon, or EffectEllipse.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Point property

Newtone.ImageKit.Win.ImageKit.Effect.Point Property

This property sets the coordinates values for the points defining the polygon area on the image that will be processed by an effect.
[Visual Basic]
Public Property Point As Point
[C#]
public Point[] Point {get; set;}

Property Value

The values of the coordinate points of a polygon on the image (must be 2 or more points) Explanation

The Point property sets the coordinates values for the points defining the polygon area on the image that will be processed by an effect. This property is enabled when the SelectMode property is set to EffectPolygon. The origin (0,0) for the coordinate space is at the top left.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Rect property

Newtone.ImageKit.Win.ImageKit.Effect.Rect Property

This property sets the coordinates of a rectangle on the image. This rectangle is used by the CutRectImage method or used to process an elliptical area on the image.

[Visual Basic]
Public Property Rect As Rectangle
[C#]
public Rectangle Rect {get; set;}

Property Value

The coordinates of the rectangle

Explanation

The Rect property sets the coordinates of a rectangle on the image. This rectangle is used by the CutRectImage method or used to process an elliptical area on the image.

The origin (0,0) for the coordinate space is at the top left. The Rect property can be set directly, for example,

ImageKit1.Effect.Rect = new Rectangle(100,100,200,200)

will set an area on the image whose top left corner is at (100,100) and that has a height and width of 200 respectively. For more information, please refer to the System.Drawing.Rectangle.

If the ImageKit.Rect property is set, it is possible to pass this rectangle directly into the Rect property like this:

ImageKit.Effect.Rect = ImageKit.Rect

The Rect property is used by the CutRectImage method or used to process an elliptical area on the image when the SelectMode property is set to EffectEllipse.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SelectMode property

Newtone.ImageKit.Win.ImageKit.Effect.SelectMode Property

This property sets the type of area that will be processed on the image.

[Visual Basic]
Public Property SelectMode As AreaSelectMode
[C#]
public AreaSelectMode SelectMode {get; set;}

Property Value

The value is of type AreaSelectMode

Explanation

The SelectMode property sets the type of area that will be processed on the image.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SourceMask property

Newtone.ImageKit.Win.ImageKit.Effect.SourceMask Property

This property refers to the image handle for the input mask image.

[Visual Basic]
Public Property SourceMask As Image
[C#]
public Image SourceMask {get; set;}

Property Value

Image class

Explanation

The SourceMask property refers to the image handle for the input mask image.

The mask image should be a black and white, 1 bit color image that is the same size as the image it masks. The white portions of the mask are enabled, the black portion are masked.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Affine method

Newtone.ImageKit.Win.ImageKit.Effect.Affine Method

This method corrects a warped raster image.

[Visual Basic] Public Function Affine() As Boolean
[C#] public bool Affine();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Affine method corrects a warped raster image. To execute the Affine method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The area on the image to be processed is determined by the coordinates for 4 points which are set in the Point property.

The Affine method supports 1, 4, 8, 16, 24, and 32 bit color images.

If the Affine method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Affine method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


AntiAlias method

Newtone.ImageKit.Win.ImageKit.Effect.AntiAlias Method

This method smoothes edges in raster images.

[Visual Basic] Public Function AntiAlias() As Boolean
[C#] public bool AntiAlias();

Parameters

Nane

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The AntiAlias method smoothes edges in raster images. To execute the AntiAlias method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The AntiAlias method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the AntiAlias method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If the AntiAlias method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the AntiAlias method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


AutoSelectImage method

Newtone.ImageKit.Win.ImageKit.Effect.AutoSelectImage Method

This method uses a specified color (RGB value), compares this value to pixels in the image and selects areas of the image that have that color. From this selection, This method creates a new image and mask image.

[Visual Basic] Public Function AutoSelectImage(red As Byte, green As Byte, blue As Byte, mode As Integer, level As Integer) As Boolean
[C#] public bool AutoSelectImage(byte red, byte green, byte blue, int mode, int level);

Parameters

red
Specifies the red value of the color that will be selected (From 0 to 255)

green
Specifies the green value of the color that will be selected (From 0 to 255)

blue
Specifies the blue value of the color that will be selected (From 0 to 255)

mode
Comparison mode (0:RGB, 1:CrCb, 2:Y)

level
Level of Allowance (From 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The AutoSelectImage method uses a specified color (RGB value), and selects areas of the image that have that color. To execute the AutoSelectImage method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The AutoSelectImage method supports 1, 4, 8, 16, 24, and 32 bit images.

The Mode parameter sets the type of color comparison used to select portions of the image. When the Mode parameter is other than 0 (i.e. CrCb or Y) then all RGB values are converted to YCrCb values and compared. The Level parameter controls the range of RGB values that will be selected. If the Level value is 0, then only those pixels that have the save RGB value as that specified in the Red, Green, and Blue parameters will be selected. As the Level parameter increases, the range of RGB values that will be selected increases. For example, if Level = 10 and Red, Green, and Blue = 100 respectively, then all pixels with an RGB value between (90, 90, 90) and (110, 110, 110) will be selected.

Before executing the AutoSelectImage method, you must set the area on the image that will be affected. There are 3 ways to do this.

  1. To process the total image, set the SelectMode property to EffectAll
  2. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  3. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Set the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If the AutoSelectImage method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the AutoSelectImage method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Blur method

Newtone.ImageKit.Win.ImageKit.Effect.Blur Method

This method blurs a raster image.

[Visual Basic] Public Function Blur(level As Integer) As Boolean
[C#] public bool Blur(int level);

Parameters

plevel
The strength of the bluring function (From 1 to 20). As the Level increases, the strength of the blur increases.

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Blur method blurs a raster image. As the Level parameter increases, the strength of the blur increases. To execute the Blur method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Blur method supports 8-bit grayscale, 16, 24, and 32 bit images.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Set the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If the Blur method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Blur method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Canvas method

Newtone.ImageKit.Win.ImageKit.Effect.Canvas Method

This method produces a canvas effect on the raster image.

[Visual Basic] Public Function Canvas(direction As Integer, depth As Integer) As Boolean
[C#] public bool Canvas(int direction, int depth);

Parameters

direction
The direction of the canvas pattern (0:From top to right, 1: From top to left, 2: From bottom to left, 3: From bottom to right)

depth
Depth of the canvas pattern (From 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Canvas method produces a canvas effect on the raster image. To execute the Canvas method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Canvas method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the Canvas method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If the Canvas method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Canvas method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


CheckSecretImage method

Newtone.ImageKit.Win.ImageKit.Effect.CheckSecretImage Method

This method retrieves the digital watermark from a raster image.

[Visual Basic] Public Function CheckSecretImage(keyImage As Image, secretImage As Image, level As Integer) As Boolean
[C#] public bool CheckSecretImage(Image keyImage, Image secretImage, int level);

Parameters

keyImage
The original image.
This is the image without a digital watermark.
It is used as a key to compare to another image and check if a watermark exists (24 bit color images only).

secretImage
The image that contains the watermark (24 bit color images only)

level
The level at which to retrieve the watermark (From -20 to 20)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CheckSecretImage method retrieves the digital watermark from an image whose watermark has been set with the SetSecretImage method. It CANNOT retrieve other types of watermarks.

The Level parameter should be set to a value that is the same as or slighly smaller than the Level at which the watermark was embedded into the image using the SetSecretImage method. Using a Level to retrieve the watermark that differs significantly from the Level at which the watermark was set will result in no watermark being retrieved. Furthermore, the orginal image and the watermarked image must be exactly the same size. If either image has been resized, no watermark can be retrieved.

If successful the resulting raster image handle is set in the Image property or the Layer(LayerNumber).Image property depending on the value set in the LayerNumber property. The CheckSecretImage method supports only 24 bit color images. The resulting image has a black background with the digital watermark appearing in white. (It is a 1-bit image that is the same size as the images set in keyImage and secretImage.)

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


CombineRGBAImage method

Newtone.ImageKit.Win.ImageKit.Effect.CombineRGBAImage Method

This method creates a 32-bit RGBA image from an image and an alpha channel.

[Visual Basic] Public Function CombineRGBAImage As Boolean
[C#] public bool CombineRGBAImage();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CombineRGBAImage method creates a 32-bit RGBA image from an image and an alpha channel. To execute the CombineRGBAImage method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property (1, 4, 8, 16, 24, or 32 bit image) and set the alpha channel image handle into the SourceMask property (1 bit color or 8 bit grayscale image).

If the PasteImage method is successful and the DestinationAsImageKitImage property is True, the resulting RGBA 32-bit image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the PasteImage method is successful and the DestinationAsImageKitImage property is False, the resulting RGBA 32-bit image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


ConvertColor method

Newtone.ImageKit.Win.ImageKit.Effect.ConvertColor Method

This method converts images from one bit count to another.

[Visual Basic] Public Function ConvertColor(pixelType As Integer, fixPalette As Boolean, dithering As Boolean, level As Integer) As Boolean
[C#] public bool ConvertColor(int PixelType, bool FixedPal, bool dithering, int level);

Parameters

pixelType
The number of bits per pixel (1, 4, 8, 16, 24, 32, 40, 80) after the conversion
* 4 represents 4 bit color, 40 is for 4 bit grayscale, 8 is for 8 bit color, and 80 is for 8 bit grayscale.

fixPalette
Fixed palette settings (Use when decreasing or increasing to 1, 4, or 8 bit color)
False: Uses a created palette most suitable for the image
True: Uses a fixed palette

dithering
Sets the dither (error diffusion) (Use when decreasing to 1, 4, or 8 bit color or 4 bit grayscale)
False(0): Does not dither
True(nonzero): Dithers

level
Threshold value settings (Use when decreasing to 1 bit images)
0 to 255

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The ConvertColor method changes the number of colors (also known as the bit count) of a raster image.

To execute the ConvertColor method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. When decreasing the number of colors of an image to 1 bit color, if the RGB value (an average of the red, green, and blue values) is less than the threshold value, the palette is set to 0, otherwise it is set to 1.

If the ConvertColor method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the ConvertColor method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

The ConvertColor method supports 1, 4, 8, 16, 24, and 32 bit images.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


CustomFilter method

Newtone.ImageKit.Win.ImageKit.Effect.CustomFilter Method

This method allows you to create a custom effects filter for raster images.

[Visual Basic] Public Function CustomFilter(matrix(,) As Integer, div As Integer, level As Integer, red As Boolean, green As Boolean, blue As Boolean) As Boolean
[C#] public bool CustomFilter(int[,] matrix, int div, int level, bool red, bool green, bool blue);

Parameters

matrix
9x9 matrix (an array of 81 items ranging from 0 to 80)

div
The division factor

level
The bias factor (from 0 to 255, as this factor increases, the color becomes brighter)

red
To process the red plane, set to True, otherwise set to False

green
To process the green plane, set to True, otherwise set to False

blue
To process the blue plane, set to True, otherwise set to False

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CustomFilter method allows you to create a custom effects filter for raster images. An effects filter alters each pixel's color based on its current color and the colors of any neighboring pixels. (See the explanation of the filter matrix below.)

To execute the CustomFilter method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The CustomFilter method supports 8-bit grayscale, 16, 24, and 32 bit images.

When processing a grayscale image the Red, Green and Blue parameter values are disabled.

Before executing the CustomFilter method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If the CustomFilter method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the CustomFilter method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

The filter consists of an array of coefficients called a filter matrix. A filter processes an image on a pixel-by-pixel basis. Each pixel's color value is multiplied by the coefficient in the matrix center, and any pixels within the matrix are multiplied by the corresponding coefficients. The sum of the products becomes the target pixel's new value. To make the filter matrix, it is necessary to create an array containing 80 elements and set the appropriate coefficient values in the array elements. The formula used to calculate the target pixel's value is given below:

Where F is the output value of the target pixel, Pi is a pixel in the grid, and Ci is a coefficient in the matrix. Div is the division factor which allows you to achieve effects that would otherwise require decimal coefficients. Level is a bias factor. You use the bias to shift the value of each pixel by a fixed amount. As the bias factor increases, the resultant color is brighter. Bias adjustments are particularly useful for creating embossing effects.

Some sample matrix are given below:

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


CutRectImage method

Newtone.ImageKit.Win.ImageKit.Effect.CutRectImage Method

This method copies that portion of a raster image that is specified by the selected rectangle.

[Visual Basic] Public Function CutRectImage As Boolean
[C#] public bool CutRectImage();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CutRectImage method allows you to copy a portion of a raster image without using a mask image. (If you wish to use a mask image, please refer to the SelectImage method).

To execute the CutRectImage method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property and specify the area to be copied by setting the Rect property. The CutRectImage method supports 1, 4, 8, 16, 24, and 32 bit images.

If the CutRectImage method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the CutRectImage method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Deskew method

Newtone.ImageKit.Win.ImageKit.Effect.Deskew Method

This method repairs a skewed image.

[Visual Basic] Public Function Deskew(bWhite As Boolean) As Boolean
[C#] public bool Deskew(bool bWhite);

Parameters

bWhite

Sets whether the new area created by deskew will be white or black (True: the area will be white; False: the area will be black)

This method supports 1 bit color only and will return False if executed on images of other bitcounts.

Return Value

Returns True if successful, otherwise returns False

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Emboss method

Newtone.ImageKit.Win.ImageKit.Effect.Emboss Method

This method creates an emboss effect on a raster image.

[Visual Basic] Public Function Emboss(pattern As Integer, edge As Integer, level As Integer) As Boolean
[C#] public bool Emboss(int pattern, int edge, int level);

Parameters

pattern
Sets the direction of the emboss (0: Left to Right, 1: Top Left to Bottom Right, 2: Top to Bottom, 3: Top Right to Bottom Left, 4: Right to Left, 5: Bottom Right to Top Left, 6: Bottom to Top, 7: Bottom Left to Top Right)

edge
Sets the depth of the emboss (from 1 to 5; where 5 is the deepest emboss)

level
Sets the brightness of the emboss (from 0 to 255; where 255 is the brightest)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Emboss method creates an emboss effect on a raster image. To execute the Emboss method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Emboss method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the Emboss method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If the Emboss method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Emboss method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


EndBitmapAccess method

Newtone.ImageKit.Win.ImageKit.Effect.EndBitmapAccess Method

This method is used to allow access to pixels in the Device Independent Bitmap (DIB). This method is to be used in conjunction with the StartBitmapAccess method.

[Visual Basic] Public Function EndBitmapAccess() As Boolean
[C#] public bool EndBitmapAccess();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The EndBitmapAccess method is to be used in conjunction with the StartBitmapAccess method.

To execute the EndBitmapAccess method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The EndBitmapAccess method supports 1, 4, 8, 16, 24, and 32 bit images.

To access the bitmap and manipulate pixel data, you must use the following methods as a group:

StartBitmapAccess
|
GetBitmapPixel, SetBitmapPixel
|
EndBitmapAccess

Example

The following code starts access to the DIB, then loops through each pixel in the image, using the GetBitmapPixel method to retrieve the pixels' rgb values. Then those values are reversed and set using the SetBitmapPixel method. (For 1, 16, 24, or 32 bit images)

[Visual Basic]
Dim Ret As Boolean
Dim i As Long, j As Long
Dim PalNo As Integer, Red As Integer, Green As Integer, Blue As Integer

Ret = ImageKit1.GetImageType()
If Ret = False Then Exit Sub
Ret = ImageKit1.Effect.StartBitmapAccess()
If Ret = False Then Exit Sub

For i = 0 To ImageKit1.Image.Height - 1
  For j = 0 To ImageKit1.Image.Width - 1
    Ret = ImageKit1.Effect.GetBitmapPixel(j, i, PalNo, Red, Green, Blue)
    If ImageKit1.BitCount = 1 Then
      If PalNo <> 0 Then
        PalNo = 0
      Else
        PalNo = 1
      End If
    Else If ImageKit1.BitCount > 8 Then
      Blue = 255 - Blue
      Green = 255 - Green
      Red = 255 - Red
    End If
    Ret = ImageKit1.Effect.SetBitmapPixel(j, i, PalNo, Red, Green, Blue)
  Next j
Next i

Ret = ImageKit1.Effect.EndBitmapAccess()
ImageKit1.Refresh()

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


GetBitmapPixel method

Newtone.ImageKit.Win.ImageKit.Effect.GetBitmapPixel Method

This method retrieves the RGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB).

[Visual Basic] Public Function GetBitmapPixel(x As Integer, y As Integer, palette As Byte, red As Byte, green As Byte, blue As Byte) As Boolean
[C#] public bool GetBitmapPixel(int x, int y, ref byte palette, ref byte red, ref byte green, ref byte blue);

Parameters

x,y
The x,y coordinates of the specified pixel

palette
The palette number of the specified pixel

red
The red component of the RGB value of the specified pixel

green
The green component of the RGB value of the specified pixel

blue
The blue component of the RGB value of the specified pixel

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetBitmapPixel method retrieves the RGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB). For 1, 4, and 8 bit images, the applicable values are set in the Palette parameter. For 16, 24, and 32 bit images, the applicable values are set in the red, green, and blue parameters.

The image to be processed is determined by the values set in the LayerNumber property.

To access the bitmap and manipulate pixel data, you must use the following methods as a group:

StartBitmapAccess
|
GetBitmapPixel, SetBitmapPixel
|
EndBitmapAccess

Example

The following code starts access to the DIB, then loops through each pixel in the image, using the GetBitmapPixel method to retrieve the pixels' rgb values. Then those values are reversed and set using the SetBitmapPixel method (For 1, 16, 24, or 32 bit images).

[Visual Basic]
Dim Ret As Boolean
Dim i As Long, j As Long
Dim PalNo As Integer, Red As Integer, Green As Integer, Blue As Integer

Ret = ImageKit1.GetImageType()
If Ret = False Then Exit Sub
Ret = ImageKit1.Effect.StartBitmapAccess()
If Ret = False Then Exit Sub

For i = 0 To ImageKit1.Image.Height - 1
    For j = 0 To ImageKit1.Image.Width - 1
    Ret = ImageKit1.Effect.GetBitmapPixel(j, i, PalNo, Red, Green, Blue)
    If ImageKit1.BitCount = 1 Then
        If PalNo <> 0 Then
        PalNo = 0
        Else
        PalNo = 1
        End If
    Else If ImageKit1.BitCount > 8 Then
        Blue = 255 - Blue
        Green = 255 - Green
        Red = 255 - Red
    End If
    Ret = ImageKit1.Effect.SetBitmapPixel(j, i, PalNo, Red, Green, Blue)
    Next j
Next i

Ret = ImageKit1.Effect.EndBitmapAccess()
ImageKit1.Refresh()

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


GlassTile method

Newtone.ImageKit.Win.ImageKit.Effect.GlassTile Method

This method creates an glass tile effect on a raster image.

[Visual Basic] Public Function GlassTile(xSize As Integer, ySize As Integer) As Boolean
[C#] public bool GlassTile(int xSize, int ySize);

Parameters

xSize
Sets the width of each glass tile (from 10 to 100)

ySize
Sets the height of each glass tile (from 10 to 100)

Return Value

Returns True if successful. Returns False if successful.

Explanation

The GlassTile method produces an effect similar to glass tile on the image. To execute the GlassTile method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The GlassTile method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the GlassTile method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If the GlassTile method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the GlassTile method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Layer method

Newtone.ImageKit.Win.ImageKit.Effect.Layer Method

This method layers two raster images together.

[Visual Basic] Public Function Layer(bottomImage As Image, topImage As Image, transLevel As Integer, transColor As Boolean, transRed As Byte, transGreen As Byte, transBlue As Byte, backRed As Byte, backGreen As Byte, backBlue As Byte, x As Integer, y As Integer, clip As Boolean, alpha As Boolean) As Boolean
[C#] public bool Layer(Image bottomImage, Image topImage, int transLevel, bool transColor, byte transRed, byte transGreen, byte transBlue, byte backRed, byte backGreen, byte backBlue, int x, int y, bool clip, bool alpha);

Parameters

bottomImage
The image on which another image is layered (The image on the bottom). Supports 1, 4, 8, 16, 24, 32 bit images.

topImage
The image to be layered (The image on the top). Supports 1, 4, 8, 16, 24, 32 bit images.

transLevel
The level of transparency of topImage (From 0 to 255, as this value increases the image of topImage becomes visible)

transColor
Sets whether or not topImage has a transparent color. (False(0): No transparent color, True(non zero): Has transparent color)

transRed
Sets the red component of the RGB value of the transparent color for topImage (from 0 to 255)

transGreen
Sets the green component of the RGB value of the transparent color for topImage (from 0 to 255)

transBlue
Sets the blue component of the RGB value of the transparent color for topImage (from 0 to 255)

backRed
Sets the red component of the RGB value of the background color (from 0 to 255) This is the area of the image that is not part of either bottomImage or topImage

backGreen
Sets the green component of the RGB value of the background color (from 0 to 255) This is the area of the image that is not part of either bottomImage or topImage

backBlue
Sets the blue component of the RGB value of the background color (from 0 to 255) This is the area of the image that is not part of either bottomImage or topImage

x,y
The coordinates of the attachment location (in pixels)

clip
Sets whether or not the image is clipped (False(0): No clipping, True(nonzero) clipping)

alpha
Sets whether or not alpha channel is used ifalse: Does not use alpha channel, True: Uses alpha channelj

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Layer method layers two raster images together. The upper left corner of the TopImage is attached to the BottomImage at the x,y coordinate location.

If the Clip parameter is set to True, the size of the created image is the same as the BottomImage. Any portions of the TopImage that extend beyond the BottomImage will be clipped. If the Clip parameter is set to False, the size of the created image is the same as the combination of the two images. Any areas of the created image that are not in either the BottomImage or the TopImage will be the color set in the BackRed, BackGreen, and BackBlue parameters. If the TransColor parameter is set to True, the color set by the TransRed, TransGreen, and TransBlue parameters will be a transparent color.

When the Alpha parameter is True, the raster image set in the TopImage parameter must be a 32-bit RGBA image (A refers to an alpha channel containing a mask image). Note: When the Aalpha parameter is True, the TransLevel parameter is disabled.

If the Layer method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Layer method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

The output will be a 24 bit image. However, if either bottomImage or topImage is a 32 bit image, then the output will be a 32 bit image.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Lens method

Newtone.ImageKit.Win.ImageKit.Effect.Lens Method

This method creates a lens like effect on a raster image.

[Visual Basic] Public Function Lens(refract As Double, backColor As Boolean, red As Byte, green As Byte, blue As Byte) As Boolean
[C#] public bool Lens(double refract, bool backColor, byte red, byte green, byte blue);

Parameters

refract
Sets the lens magnification (Greater than 1)

backColor
Sets whether or not the area outside of the lens effect is painted a particular color [True: the area is painted, False: the area is not painted]

red
Sets the red component of the color painted in the area outside the lens (from 0 to 255)

green
Sets the green component of the color painted in the area outside the lens (from 0 to 255)

blue
Sets the Blue component of the color painted in the area outside the lens (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Lens method produces a lens like effect on a raster image. To execute the Lens method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Lens method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the Lens method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If the Lens method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Lens method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Mosaic method

Newtone.ImageKit.Win.ImageKit.Effect.Mosaic Method

This method creates a mosaic effect on a raster image.

[Visual Basic] Public Function Mosaic(xSize As Integer, ySize As Integer) As Boolean
[C#] public bool Mosaic(int xSize, int ySize);

Parameters

xSize
The width of the mosaic (in pixels)

ySize
The height of the mosaic (in pixels)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Mosaic method creates a mosaic effect on a raster image. To execute the Mosaic method, set the image handle of the image in the Image property
or the Layer(LayerNumber).Image property. The Mosaic method supports 1, 4, 8, 16, 24, and 32 bit images.

If both of the values set in the XSize and YSize parameters are less than 1, this method does not produce an mosaic effect on a raster image.

Before executing the Mosaic method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If the Mosaic method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Mosaic method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


MotionBlur method

Newtone.ImageKit.Win.ImageKit.Effect.MotionBlur Method

This method creates a motion blur effect on a raster image.

[Visual Basic] Public Function MotionBlur(mode As Integer, length As Integer, angle As Integer) As Boolean
[C#] public bool MotionBlur(int mode, int length, int angle);

Parameters

mode
Sets the type of blur (0: Linear, 1: Radial, 2: Zoom)

length Sets the length of the blur (from 0 to 255)

angle Sets the angle of the blur (in degrees from 0 to 360)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The MotionBlur method creates a motion blur effect on a raster image. The Mode parameter determines the type of motion blur.

Mode=0 (Linear blur)
This motion blur simulates the image shifting. The Length parameter sets the magnitude of the shift. The Angle parameter determines the direction of the shift. The major directions of the Angle parameter are as follows: Angle=0 -> a shift to the left; Angle= 90 -> a shift down; Angle= 180 -> ashift to the right; Angle= 270-> a shift up.

Mode=1 (Radial blur)
This motion blur simulates the image spinning by the number of degrees set in the Angle parameter. The Length parameter is ineffective.

Mode=2 (Zoom blur)
This motion blur simulates the image zooming in by the length set in the Length parameter. The Angle parameter is ineffective.

To execute the MotionBlur method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The MotionBlur method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the MotionBlur method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If the MotionBlur method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the MotionBlur method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


OilPaint method

Newtone.ImageKit.Win.ImageKit.Effect.OilPaint Method

This method produces an effect similar to an oil painting on the image.

[Visual Basic] Public Function OilPaint(mode As Integer, size As Integer) As Boolean
[C#] public bool OilPaint(int mode, int size);

Parameters

mode
Sets the processing mode (0:Process by RGB, 1:Process by Luminance (Brightness))

size
Sets brush stroke size (from 1 to 100)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The OilPaint method produces an effect similar to an oil painting on the image.

To execute the OilPaint method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The OilPaint method supports
8 bit grayscale, 16, 24, and 32 bit images.

Before executing the OilPaint method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If the OilPaint method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the OilPaint method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Outline method

Newtone.ImageKit.Win.ImageKit.Effect.Outline Method

This method produces an outline effect on the image.

[Visual Basic] Public Function Outline(plane As Integer, mode As Integer, level As Integer) As Boolean
[C#] public bool Outline(int plane, int mode, int level);

Parameters

plane
Sets which plane will be used to process the outline (0:Y, 1:R, 2:G, 3:B)

mode
Sets the edge filtering function used to process the outline (0:Differential, 1:Roberts, 2:Sobel)

level
Sets the brightness at which an outline is drawn (from 0 to 100)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Outline method produces an outline of a raster image by identifying and displaying only the "edges" within the image. In general, the luminance plane is most commonly used. (Plane parameter = 0). In this case, differences in brightness are used to identify edges. However, the red plane, green plane or blue plane can also be used to identify an edge So, for example, if the red plane is used (Plane parameter = 1) then differences in the R values would be used to identify the edges within an image.

The Mode parameter determines how an edge is identified. The Level parameter determines at which value an edge will be displayed. When the Differential Operator is used, the differences between the pixel values (either brightness, red, green, or blue) are calculated and then depending on the value of the Level parameter, the edges are displayed. The Differential Operator evaluates these difference in a horizontal and/or vertical direction. The Roberts Operator also uses a differential calculation, but evaluates these differences at a 45 degree orientation. The Sorbel Operator is very similar to the above two operators except that with Sorbel there is an additional correction for images that have a lot of complexity.

To execute the Outline method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Outline method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the Outline method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If the Outline method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Outline method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Panorama method

Newtone.ImageKit.Win.ImageKit.Effect.Panorama Method

This method composes a panorama image from two raster images.

[Visual Basic] Public Function Panorama(bottomImage As Image, topImage As Image, cutMode As Integer, x11 As Integer, y11 As Integer, x12 As Integer, y12 As Integer, x21 As Integer, y21 As Integer, x22 As Integer, y22 As Integer, red As Byte, green As Byte, blue As Byte) As Boolean
[C#] public bool Panorama(Image bottomImage, Image topImage, int cutMode, int x11, int y11, int x12, int y12, int x21, int y21, int x22, int y22, int red, byte green, byte blue);

Parameters

bottomImage
the image on which another image is attached (24 bit only)

topImage
the raster image that is attached (24 bit only)

cutMode
Sets whether or not topImage parameter will be cut at the attachment location and if so which portion of topImage parameter will be cut
For horizontal attachments (0: no cut, 1: cut left portion, 2: cut right portion)
For vertical attachments (0: no cut, 1: cut lower portion, 2: cut upper portion)

x11,y11
The location of the first point of attachment for bottomImage (in pixels)

x12,y12
The location of the second point of attachment for bottomImage (in pixels)

x21,y21
The location of the first point of attachment for topImage (in pixels)

x22,y22
The location of the second point of attachment for topImage (in pixels)

red
Sets the red component of the RGB value of the background color (from 0 to 255).
This is the area of the panorama image that is not part of either bottomImage or topImage

green
Sets the green component of the RGB value of the background color (from 0 to 255).
This is the area of the panorama image that is not part of either bottomImage or topImage

blue
Sets the blue component of the RGB value of the background color (from 0 to 255).
This is the area of the panorama image that is not part of either bottomImage or topImage

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Panorama method composes a panorama from two raster images.

To execute the Panorama method, set the image handle of the base image into the BottomImage parameter. Set the image handle of the image you wish to attach to the base image into the TopImage parameter. Set the attachment location on BottomImage and TopImage. The Panorama method will attach the TopImage to the BottomImage at the location specified.

The cutMode parameter determines if any portion of TopImage will be cut off. If CutMode=0 then no portion of TopImage will be cut.

If the attachment is horizontal, i.e. the first attachment point is to the left of the second attachment point, then if CutMode=1, the portion of topImage to the left of the attachment location will be cut off. If CutMode=2, the portion of topImage to the right of the attachment location will be cut off.

If the attachment is vertical, i.e. the first attachment point is to the above the second attachment point, then if CutMode=1, the portion of topImage below the attachment location will be cut off. If CutMode=2, the portion of topImage above the attachment location will be cut off.

If the Panorama method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Panorama method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

This method only supports 24 bit images.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


PasteImage method

Newtone.ImageKit.Win.ImageKit.Effect.PasteImage Method

This method pastes a raster image into another raster image.

[Visual Basic] Public Function PasteImage(bottomImage As Image, angle As Integer, xTurn As Boolean, yTurn As Boolean, transLevel As Integer, transColor As Boolean, transRed As Byte, transGreen As Byte, transBlue As Byte, backRed As Byte, backGreen As Byte, backBlue As Byte, x As Integer, y As Integer, clip As Boolean) As Boolean
[C#] public bool PasteImage(Image bottomImage, int angle, bool xTurn, bool yTurn, int transLevel, bool transColor, byte transRed, byte transGreen, byte transBlue, byte backRed, byte backGreen, byte backBlue, int x, int y, bool clip);

Parameters

bottomImage
The handle of the bottom image. This is the image onto which another image is pasted (supports 1, 4, 8, 16, 24, 32 bit images)

angle
Angle of rotation (-35999 to 35999, in 1/100 degree units)

xTurn
Reversal of the x axis (False(0): no reversal, True (nonzero): reversal)

yTurn
Reversal of the y axis (False(0): no reversal, True (nonzero): reversal)

transLevel
The level of transparency (from 0 to 255, as this value increases, the top image becomes visible)

transColor
Sets whether or not there is a transparent color in the top image
(False(0)No transparent color, True(nonzero):transparent color)

transRed
Sets the red component of the transparent color in the top image (from 0 to 255)

transGreen
Sets the green component of the transparent color in the top image (from 0 to 255)

transBlue
Sets the blue component of the transparent color in the top image (from 0 to 255)

backRed
Sets the red component of the background color.
This color is drawn in the area not in either the top image bottom image (from 0 to 255)

backGreen
Sets the green component of the background color.
This color is drawn in the area not in either the top image bottom image (from 0 to 255)

backBlue
Sets the blue component of the background color.
This color is drawn in the area not in either the top image bottom image (from 0 to 255)

x,y
The attachment coordinates (in pixels)

Clip
Sets whether or not the image is clipped (False(0): no clipping, True (nonzero): clipping)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The PasteImage method pastes one raster image into another raster image. The bottom image, (the image that another image is pasted into) is set into the BottomImage parameter. The image you want to paste into the bottom image is set in the LayerNumber property (either the Image property or the Layer(LayerNumber).Image property). If using a mask image (to determine an area on the image to be processed), then set the image handle of the mask image in the SourceMask property. The PasteImage method supports 1, 4, 8, 16, 24, 32 bit images.

If the PasteImage method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the PasteImage method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

The Angle, xTurn, and yTurn parameters apply to the images in the LayerNumber property and SourceMask property. The x,y parameters determine the coordinates on the bottom image (the image in the bottomImage parameter) where the CENTER of the LayerNumber and SourceMask images are pasted. When the Clip parameter is True, the result is the same size as the bottom image (the image in the BottomImage parameter) and any excess is clipped. When the TransColor parameter is True, the color specified in the TransRed, TransGreen and TransBlue parameters is transparent.

The output image will be a 24 bit image. However, if either the bottom image or the top image are a 32 bit image, then the output image will be a 32 bit image.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


RemoveNoise method

Newtone.ImageKit.Win.ImageKit.Effect.RemoveNoise Method

This method reduces the image noise in raster images.

[Visual Basic] Public Function RemoveNoise(mode As Integer, level As Integer) As Boolean
[C#] public bool RemoveNoise(int mode, int level);

Parameters

mode
Sets the mode of noise reduction (0: Median luminance method, 1:Noise reduction for each RGB plane)

level
Sets the level of noise reduction for the RGB mode (from 0 to 255, effective when Mode is 1)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RemoveNoise method reduces the image noise in raster images. When Mode is 1, the value of the level is enabled. As the Level parameter value increases the level of noise decreases.

To execute the RemoveNoise method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The RemoveNoise method supports 1, 4, 8, 16, 24, and 32 bit images and 8 bit grayscale images.

Before executing the RemoveNoise method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If the RemoveNoise method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the RemoveNoise method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


RemoveRedEye method

Newtone.ImageKit.Win.ImageKit.Effect.RemoveRedEye Method

This method removes "red eye" from images by converting reddish colors within the selected area to another specified color.

[Visual Basic] Public Function RemoveRedEye(red As Byte, green As Byte, blue As Byte, error As Integer) As Boolean
[C#] public bool RemoveRedEye(byte red, byte green, byte blue, int error);

Parameters

red
Sets the red component for the specified color after the red eye removal (from 0 to 255)

green
Sets the green component for the specified color after the red eye removal (from 0 to 255)

blue
Sets the blue component for the specified color after the red eye removal (from 0 to 255)

error
Sets a margin of error for converting colors within the selected area. Any colors falling outside this margin of error will be converted to the color specifed by the Red, Green, and Blue parameters (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RemoveRedEye method removes "red eye" from images by converting colors within the selected area to another specified color. The error parameter sets a margin of error for colors within the selected area. Any color whose red value falls outside this margin of error will be converted to the color specifed by the Red, Green and Blue parameters. As the Error parameter value increases only colors closer to pure red will be converted. As the Error parameter decreases, a wider and wider range of "reddish" colors will be converted.

To execute the RemoveRedEye method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The RemoveRedEye method supports 16, 24, and 32 bit images.

Before executing the RemoveRedEye method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If the RemoveRedEye method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the RemoveRedEye method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Resize method

Newtone.ImageKit.Win.ImageKit.Effect.Resize Method

This method changes the size of a raster image.

[Visual Basic] Public Function Resize(xSize As Integer, ySize As Integer, mode As Boolean) As Boolean
[C#] public bool Resize(int xSize, int ySize, bool mode);

Parameters

xSize
The width of the new image (in pixels)

ySize
The height of the new image (in pixels)

mode
Sets whether Interpolation is used (False (0): does not interpolate, True (nonzero): interpolates)
When enlarging the image, the linear interpolation method is used, when reducing the image, the average method is used
The interpolation can be used for 8 bit grayscale, 16, 24, and 32 bit images

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Resize method changes the size of the original image to the size specified. When the Mode parameter is false (No interpolation) then changes in size can adversely affect the quality of the Image.

To execute the Resize method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Resize method supports 1, 4, 8, 16, 24, and 32 bit color images. If using mask image, set the image handle into the SourceMask property.

If the Resize method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Resize method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

If the SourceMask property contains a valid image handle, then the resulting mask image will be set in the DesinationMask property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


RGBGamma method

Newtone.ImageKit.Win.ImageKit.Effect.RGBGamma Method

This method uses gamma correction to adjust the RGB values of a raster image.

[Visual Basic] Public Function RGBGamma(red As Double, green As Double, blue As Double) As Boolean
[C#] public bool RGBGamma(double red, double green, double blue);

Parameters

red
The gamma factor for the red plane

green
The gamma factor for the green plane

blue
The gamma factor for the blue plane

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBGamma method uses gamma correction to adjust the RGB values and overall brightness of a raster image. The formula used to calculate the output is given below:

Where x is the input RGB value, y is the output RGB value and bright is the gamma factor for the red, green and blue planes. (The Red, Green, and Blue parameters respectively).

When the Red, Green, and Blue parameters all equal 0, the input RGB values and output RGB values are equal meaning there is no change in the image. As the Red, Green, or Blue parameters increase in a positive direction, the output RGB values become lower than the input RGB values. As the Red, Green, or Blue parameters increase in a negative direction, the output RGB values become higher than the input RGB values. Please refer to the diagram below which shows the change in RGB values for a gamma factor of 1 and also for a gamma factor of -1.

To execute the RGBGama method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The RGBGamma method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the RGBGamma method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If the RGBGamma method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the RGBGamma method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


RGBLevel method

Newtone.ImageKit.Win.ImageKit.Effect.RGBLevel Method

This method increases (or decreases) the RGB values of a raster image.

[Visual Basic] Public Function RGBLevel(red As Integer, green As Integer, blue As Integer) As Boolean
[C#] public bool RGBLevel(int red, int green, int blue);

Parameters

red
Sets the shift in the red component of the RGB value (from -255 to 255)

green
Sets the shift in the green component of the RGB value (from -255 to 255)

blue
Sets the shift in the blue component of the RGB value (from -255 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBLevel method increases or decreases the RGB values in a raster image. As the values of the Red, Green, or Blue parameters increase, the image becomes brighter. As those values decrease, the image becomes darker. If the Red, Green, or Blue parameters are 0, the image is not altered.

To execute the RGBLevel method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The RGBLevel method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the RGBLevel method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If the RGBLevel method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the RGBLevel method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


RGBReverse method

Newtone.ImageKit.Win.ImageKit.Effect.RGBReverse Method

This method reverses the RGB values of a raster image.

[Visual Basic] Public Function RGBReverse(red As Boolean, green As Boolean, blue As Boolean) As Boolean
[C#] public bool RGBReverse(bool red, bool green, bool blue);

Parameters

red
Reverses the red component of the RGB value (False: does not reverse value, True: reverses value)

green
Reverses the green component of the RGB value (False: does not reverse value, True: reverses value)

blue
Reverses the blue component of the RGB value (False: does not reverse value, True: reverses value)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBReverse method reverses the RGB values of a raster image. If the Red, Green, or Blue parameters are True, then that component of the RGB value is reversed. So, for example, the reverse of a red component = 255 would be a red component = 0 (Red = 255 - Red).

To execute the RGBReverse method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The RGBReverse method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the RGBReverse method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If the RGBReverse method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the RGBReverse method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


RGBSpline method

Newtone.ImageKit.Win.ImageKit.Effect.RGBSpline Method

This method uses spline function to modifiy the RGB values of a raster image.

[Visual Basic] Public Function RGBSpline(spline As Point, red As Boolean, green As Boolean, blue As Boolean) As Boolean
[C#] public bool RGBSpline(Point[] spline, bool red, bool green, bool blue);

Parameters

spline
Arrays of RGB values defining the x and y coordinates of points on the RGBSpline curve (from 0 to 255). The number of coordinates in the array ranges from 3 to 10

red
Affects the red component of the RGB value (False: does not affect the red component, True: affects the red component)

green
Affects the green component of the RGB value (False: does not affect the red component, True: affects the green component)

blue
Affects the blue component of the RGB value (False: does not affect the red component, True: affects the blue component)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBSpline method uses a spline function to modify the RGB values of a raster image.

The RGBSpline method uses a spline function to modify the RGB values of a raster image. A spline function is a method of interpolating values that lay in between data points. In other words it produces a smooth curve from a limited set of points.

The RGBSpline method allows you to define the relationship between the input RGB values in the original image and output RGB values in the newly created image. You do this by specifying a set of coordinate points where the input RGB values are the x coordinates and the output RGB values are the y coordinates. These coordinate points are stored in arrays and passed to the RGBSpline method through the Spline parameter. The RGBSpline method then interpolates a "smooth" curve from these coordinate points. The graphic representation of this relationship between input RGB and output RGB values is known as the RGBSpline curve. A sample RGBSpline curve is shown in the diagram below:

In the above diagram, the default RGBSpline curve represents no change between input RGB values and output RGB values. In this case, the newly created image is exactly the same as the orginal image. The red RGBSpline curve represents an increase in contrast between the original image and the newly created image. It was generated from the following points:

Point (x values,y values)
-----------------------------------------------------
Point A (0,0)
Point B (64,32)
Point C (128,128)
Point D (192,160)
Point E (255,255)

At the midpoint of the RGBSpline curve, the input RGB value of 128 equals the output RGB value of 128. At points below the midpoint, however, the output RGB values are lower than the input RGB values. This means that dark colors become darker. Conversely, at points above the midpoint, output RGB values are higher than input RGB values. This means that light colors become lighter. This particular RGBSpline curve therefore increases the contrast of the image.

An RGBSpline curve that decreases contrast could be defined with the following points:

Point (x values,y values)
----------------------------------------------------
Point A (0,0)
Point B (64, 96)
Point C (128,128)
Point D (225, 192)
Point E (255,255)

To execute the RGBSpline method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The RGBSpline method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the RGBSpline method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If the RGBSpline method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the RGBSpline method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Ripple method

Newtone.ImageKit.Win.ImageKit.Effect.Ripple Method

This method produces a ripple like effect on a raster image.

[Visual Basic]Public Function Ripple(amplitude As Double, waveLength As Double, phase As Double, backColor As Boolean, reflect As Boolean, red As Byte, green As Byte, blue As Byte) As Boolean
[C#]public bool Ripple(double amplitude, double waveLength, double phase, bool backColor, bool reflect, byte red, byte green, byte blue);

Parameters

amplitude
Sets the amplitude or height of the ripples. As this value increases the ripples become higher

waveLength
Sets the wavelength or distance from the crest of one wave to the crest of the next wave. As this value increases there are few ripples produced

phase
Sets the phase or shift in the wave cycle

backColor
Sets whether empty spaces are filled with color from adjacent pixels or from the color set as a background color [False: spaces filled with background color, True:spaces filled with the color of the adjacent pixels]

reflect
Causes a reflective effect from one ripple to the next (Best used with small amplitudes) [False:No reflection, True: reflection]

red
The red component of the background color (from 0 to 255)

green
The green component of the background color (from 0 to 255)

blue
The blue component of the background color (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Ripple method produces a ripple like effect on a raster image.

To execute the Ripple method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Ripple method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the Ripple method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If the Ripple method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Ripple method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Rotate method

Newtone.ImageKit.Win.ImageKit.Effect.Rotate Method

This is an overloaded method that rotates a raster image.

Note: The following two methods have different arguments and also process the rotation differently. Because of this there is a difference in the time it takes to rotate the image depending on the image, environment, and conditions, etc. Even if your image does not have an alpha channel, you may find that using the second Rotate method is faster in some circumstances..

Overload List

This method rotates a raster image.

[Visual Basic] Public Function Rotate(angle As Integer, xTurn As Boolean, yTurn As Boolean, mode As Boolean, red As Byte, green As Byte, blue As Byte, clip As Boolean) As Boolean
[C#] public bool Rotate(int angle, bool xTurn, bool yTurn, bool mode, byte red, byte green, byte blue, bool clip)

This method rotates a raster image. Use this method for 32 bit images with an alpha channel. The alpha channel information is enabled.

[Visual Basic] Public Function Rotate(angle As Integer, xTurn As Boolean, yTurn As Boolean, mode As Boolean, alpha As Byte, red As Byte, green As Byte, blue As Byte, clip As Boolean) As Boolean
[C#] public bool Rotate(int angle, bool xTurn, bool yTurn, bool mode, byte alpha, byte red, byte green, byte blue, bool clip)

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Rotate1 method

Newtone.ImageKit.Win.ImageKit.Effect.Rotate Method

This method rotates a raster image.

[Visual Basic]Public Function Rotate(angle As Integer, xTurn As Boolean, yTurn As Boolean, mode As Boolean, red As Byte, green As Byte, blue As Byte, clip As Boolean) As Boolean
[C#]public bool Rotate(int angle, bool xTurn, bool yTurn, bool mode, byte red, byte green, byte blue, bool clip);

Parameters

angle
Angle of rotation (-35999 to 35999, in 1/100 degree units)

xTurn
Reverses image along the x axis (False: no reversal, True: reversal)

yTurn
Reverses image along the y axis (False: no reversal, True: reversal)

mode
Sets whether on not linear interpolation is used (False: does not interpolate, True: interpolates)
Interpolation is enabled for 8 bit grayscale, 16, 24, and 32 bit images only

red
The red component of the background color (from 0 to 255)

green
The green component of the background color (from 0 to 255)

blue
The blue component of the background color (from 0 to 255)

clip
Sets whether or not the image is clipped (False: no clipping, True: clipping)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Rotate method rotates a raster image. If the Angle parameter value is positive, the image is rotated counterclockwise, if the Angle parameter value is negative, the image is rotated clockwise. When the Clip parameter is True and the rotated image is larger than the original, the excess areas are cut.

To execute the Rotate method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Rotate method supports 1, 4, 8, 16, 24, and 32 bit images. It is possible to rotate a mask image at the same time that the image is rotated. If this is the case, set the image handle of the mask image to be processed in the SourceMask property.

If the Rotate method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Rotate method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

When using a mask image, the mask image should be set in the SourceMask property. The resulting mask image will be set in the DesinationMask property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Rotate2 method

Newtone.ImageKit.Win.ImageKit.Effect.Rotate Method

This method rotates a raster image. For 32 bit images containing an alph channel, use this method.

[Visual Basic]Public Function Rotate(angle As Integer, xTurn As Boolean, yTurn As Boolean, mode As Boolean, alpha As Byte, red As Byte, green As Byte, blue As Byte, clip As Boolean) As Boolean
[C#]public bool Rotate(int angle, bool xTurn, bool yTurn, bool mode, byte alpha, byte red, byte green, byte blue, bool clip);

Parameters

angle
Angle of rotation (-35999 to 35999, in 1/100 degree units)

xTurn
Reverses image along the x axis (False: no reversal, True: reversal)

yTurn
Reverses image along the y axis (False: no reversal, True: reversal)

mode
Sets whether on not linear interpolation is used (False: does not interpolate, True: interpolates)
Interpolation is enabled for 8 bit grayscale, 16, 24, and 32 bit images only

alpha
The alpha component of the background color of a 32 bit image (from 0 to 255)

red
The red component of the background color (from 0 to 255)

green
The green component of the background color (from 0 to 255)

blue
The blue component of the background color (from 0 to 255)

clip
Sets whether or not the image is clipped (False: no clipping, True: clipping)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

This Rotate method rotates a raster image. If the image is a 32 bit image with a valid alpha channel, use this method. If the Angle parameter value is positive, the image is rotated counterclockwise, if the Angle parameter value is negative, the image is rotated clockwise. When the Clip parameter is True and the rotated image is larger than the original, the excess areas are cut.

To execute the Rotate method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Rotate method supports 1, 4, 8, 16, 24, and 32 bit images.

If the Rotate method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Rotate method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

If the original image is a 32 bit image, then the result will be a 32 bit image. All other bitcounts will result in a 24 bit color image. Please use the ConvertColor method to change the image to the appropriate bitcount.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SelectImage method

Newtone.ImageKit.Win.ImageKit.Effect.SelectImage Method

This method allows you to define an area on a raster image and create a new image and mask image from that area.

[Visual Basic] Public Function SelectImage(red As Byte, green As Byte, blue As Byte) As Boolean
[C#] public bool SelectImage(byte red, byte green, byte blue);

Parameters

red
The red component of the color painted outside the area selected (from 0 to 255)

green
The green component of the color painted outside the area selected (from 0 to 255)

blue
The blue component of the color painted outside the area selected (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SelectImage method allows you to select an area on a raster image and create a new image and mask image from this selected area.

To execute the SelectImage method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The SelectImage method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the SelectImage method, you must set the area on the image that will be affected.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image property. The resulting mask image is set in the DesinationMask property. The color defined by the Red, Green, and Blue parameters wil be painted in the resulting image in the area that is outside the selected area. The resulting mask image will be a black and white, 1 bit color image where the selected area is white and the area outside of the select area is black.

Note: To select a portion of an image, without creating a mask image, please use the CutRectImage method. This method is much faster than the SelectImage method.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SetBitmapPixel method

Newtone.ImageKit.Win.ImageKit.Effect.SetBitmapPixel Method

This method sets the RGB value and the palette number of a specified pixel in the Device Independent Bitmap (DIB)

[Visual Basic] Public Function SetBitmapPixel(x As Integer, y As Integer, palette As Byte, red As Byte, green As Byte, blue As Byte) As Boolean
[C#] public bool SetBitmapPixel(int x, int y, byte palette, byte red, byte green, byte blue);

Parameters

x,y
The x,y coordinates of the specified pixel

palette
The palette number of the specified pixel

red
The red component of the RGB value of the specified pixel

green
The green component of the RGB value of the specified pixel

blue
The blue component of the RGB value of the specified pixel

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetBitmapPixel method sets the RGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB). For 1, 4, and 8 bit images, the applicable values are set in the Palette parameter. For 16, 24, and 32 bit images, the applicable values are set in the Red, Green, and Blue parameters.

The image to be processed is determined by the values set in the LayerNumber property.

To access the DIB and manipulate pixel data, you must use the following methods as a group:

StartBitmapAccess
|
GetBitmapPixel, SetBitmapPixel
|
EndBitmapAccess

Example

The following code starts access to the DIB, then loops through each pixel in the image, using the GetBitmapPixel method to retrieve the pixels' rgb values. Then those values are reversed and set using the SetBitmapPixel method (For 1, 16, 24, or 32 bit images).

[Visual Basic]
            Dim Ret As Boolean
            Dim i As Long, j As Long
            Dim PalNo As Integer, Red As Integer, Green As Integer, Blue As Integer

            Ret = ImageKit1.GetImageType()
            If Ret = False Then Exit Sub
            Ret = ImageKit1.Effect.StartBitmapAccess()
            If Ret = False Then Exit Sub

            For i = 0 To ImageKit1.Image.Height - 1
              For j = 0 To ImageKit1.Image.Width - 1
                Ret = ImageKit1.Effect.GetBitmapPixel(j, i, PalNo, Red, Green, Blue)
                If ImageKit1.BitCount = 1 Then
                  If PalNo <> 0 Then
                    PalNo = 0
                  Else
                    PalNo = 1
                  End If
                Else If ImageKit1.BitCount > 8 Then
                  Blue = 255 - Blue
                  Green = 255 - Green
                  Red = 255 - Red
                End If
                Ret = ImageKit1.Effect.SetBitmapPixel(j, i, PalNo, Red, Green, Blue)
              Next j
            Next i

            Ret = ImageKit1.Effect.EndBitmapAccess()
            ImageKit1.Refresh()

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SetBrightness method

Newtone.ImageKit.Win.ImageKit.Effect.SetBrightness Method

This method adjusts the brightness of a raster image.

[Visual Basic] Public Function SetBrightness(level As Integer) As Boolean
[C#] public bool SetBrightness(int level);

Parameters

level
Brightness Level (-255 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetBrightness method adjusts the brightness of a raster image. Setting the Level parameter to negative values will result in a darker image. Setting the Level parameter to positive values will result in a brighter image. The Level parameter can have a value ranging from -255 to 255. When the Level parameter is 0, there is no change in the image brightness.

To execute the SetBrightness method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The value of the LayerNumber property will determine which image is processed. The SetBrightness method supports 4, 8, 16, 24, and 32 bit images.

If the SetBrightness method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the SetBrightness method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

Before executing the SetBrightness method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SetChroma method

Newtone.ImageKit.Win.ImageKit.Effect.SetChroma Method

This method adjusts the chrominance of a raster image.

[Visual Basic] Public Function SetChroma(level As Integer) As Boolean
[C#] public bool SetChroma(int level);

Parameters

level
Chrominance Level (-100 to 1000)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetChroma method adjusts the chrominance of the image. Chrominance refers to the color element of the image whereas Luminance refers to the brightness element. You can adjust the chrominance by using the Level parameter which can have a value ranging from -100 to 1000. When the Level parameter is 0, there is no change in the image color. As the level becomes negative, the colors in the image become less vivid. When the Level parameter reaches -100 the chrominance element is negated leaving only the Luminance element. This is grayscale. Conversely, as the Level parmeter increases from 0, the colors become more vivid.

To execute the SetChroma method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The value of the LayerNumber property will determine which image is processed. The SetChroma method supports 1, 4, 8, 16, 24, and 32 bit images.

If the SetChroma method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the SetChroma method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

Before executing the SetChroma method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SetContrast method

Newtone.ImageKit.Win.ImageKit.Effect.SetContrast Method

This method adjusts the contrast of a raster image.

[Visual Basic] Public Function SetContrast(level As Integer) As Boolean
[C#] public bool SetContrast(int level);

Parameters

level
Contrast Level (-100 to 100)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetContrast method adjusts the contrast of the image. You can adjust the contrast by using the Level parameter which can have a value ranging from -100 to 100. When the Level parameter is 0, there is no change in the image contrast. When the Level parameter values are negative, contrast decreases. When the Level parmeter values are positive, the contrast increases.

To execute the SetContrast method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The value of the LayerNumber property will determine which image is processed. The SetContrast method supports 4, 8, 16, 24, and 32 bit images.

If the SetContrast method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the SetContrast method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

Before executing the SetContrast method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SetGray method

Newtone.ImageKit.Win.ImageKit.Effect.SetGray Method

This method changes a raster image to gray.

[Visual Basic] Public Function SetGray As Boolean
[C#] public bool SetGray();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetGray method allows you to convert a raster image to gray.

To execute the SetGray method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The value of the LayerNumber property will determine which image is processed. The SetGray method supports 1, 4, 8, 16, 24, and 32 bit images. Note: the SetGray method will convert a raster image to gray without changing the bitcount. A 24 bit color image, for example, is coverted to gray but is still 24 bit color. To change an image to 8-bit grayscale, please use the ConvertColor method.

If the SetGray method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the SetGray method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SetSecretImage method

Newtone.ImageKit.Win.ImageKit.Effect.SetSecretImage Method

This method sets a digital watermark image or digital watermark text into a raster image.

[Visual Basic] Public Function SetSecretImage(sourceImage As Image, maskImage As Image, text As String, font As Font, rect As Rectangle, level As Long) As Boolean
[C#] public bool SetSecretImage(Image sourceImage, Image maskImage, String text, Font font, Rectangle rect, int level);

Parameters

sourceImage
The image handle of the original image (24 bit color images only) The watermark will be set on this image

maskImage
The image handle of the digital watermark (1 bit color image)

text
Sets the digital watermark text (the length of text can be up to 127 bytes)

font
Sets the font

rect
The coordinates of the rectangle where the text is to be attached to sourceImage (in pixels)

level
Sets the level of "detection" for the watermark (-20 to 20)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetSecretImage method sets a digital watermark into a raster image. It can set either a 1 bit color image or text as the watermark. The value of the Level parameter determines how "detectable" the digitable watermark will be. As the Level parameter increases in a positive direction, the digital watermark becomes brighter. As it increases in a negative direction, the digital watermark becomes darker.

If the maskImage parameter is set, the image referred to by the maskImage parameter will be set as the digital watermark. In this case the top left corner of the maskImage will be attached to the sourceImage at the coordinate location determined by the Rect parameter. If the maskImage parameter is 0, then the Text set in the Text parameter will be used as the digital watermark. It will be placed within a rectangular area on the sourceImage as determined by the Rect parameter.

If the Sharpen method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Sharpen method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

The resulting image is a 24 bit image.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Sharp method

Newtone.ImageKit.Win.ImageKit.Effect.Sharpen Method

This method modifies sharpness in a raster image.

[Visual Basic] Public Function Sharpen(level As Integer) As Boolean
[C#] public bool Sharpen(int level);

Parameters

level
Sets the degree of sharpness (from 0 to 100, sharpness increases as the level increases)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Sharpen method modifies the sharpness of a raster image. As the Level parameter value increase the sharpness increases and the image becomes clearer.

To execute the Sharpen method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Sharpen method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the Sharpen method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If the Sharpen method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Sharpen method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SplitRGBAImage method

Newtone.ImageKit.Win.ImageKit.Effect.SplitRGBAImage Method

This method splits a 32 bit RGBA image into a 24 bit RGB image and a 8 bit alpha channel.

[Visual Basic] Public Function SplitRGBAImage As Boolean
[C#] public bool SplitRGBAImage();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SplitRGBAImage method splits a 32 bit RGBA image into a 24 bit RGB image and a 8 bit alpha channel. To execute the SplitRGBAImage method, set the image handle of the 32-bit RGBA image in the Image property or the Layer(LayerNumber).Image property.

If the SplitRGBAImage method is successful and the DestinationAsImageKitImage property is True, the resulting RGB 24-bit image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the SplitRGBAImage method is successful and the DestinationAsImageKitImage property is False, the resulting RGB 24-bit image will be set in the DestinationImage property.

The alpha channel 8-bit grayscale image is set in the DesinationMask property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


StartBitmapAccess method

Newtone.ImageKit.Win.ImageKit.Effect.StartBitmapAccess Method

The StartBitmapAccess method is used to allow access to pixels in the Device Independent Bitmap (DIB). This method is to be used in conjunction with the EndBitmapAccess method.

[Visual Basic] Public Function StartBitmapAccess As Boolean
[C#] public bool StartBitmapAccess();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The StartBitmapAccess method is used to allow access to pixels in the Device Independent Bitmap (DIB). This method is to be used in conjunction with the EndBitmapAccess method.

To execute the StartBitmapAccess method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. This method supports 1, 4, 8, 16, 24, and 32 bit images.

To access the DIB and manipulate pixel data, you must use the following methods as a group:

StartBitmapAccess
|
GetBitmapPixel, SetBitmapPixel
|
EndBitmapAccess

Example

The following code starts access to the DIB, then loops through each pixel in the image, using the GetBitmapPixel method to retrieve the pixels' rgb values. Then those values are reversed and set using the SetBitmapPixel method (For 1, 16, 24, or 32 bit images).

[Visual Basic]

Dim Ret As Boolean
Dim i As Long, j As Long
Dim PalNo As Integer, Red As Integer, Green As Integer, Blue As Integer

Ret = ImageKit1.GetImageType()
If Ret = False Then Exit Sub
Ret = ImageKit1.Effect.StartBitmapAccess()
If Ret = False Then Exit Sub
For i = 0 To ImageKit1.Image.Height - 1
For j = 0 To ImageKit1.Image.Width - 1
Ret = ImageKit1.Effect.GetBitmapPixel(j, i, PalNo, Red, Green, Blue)
If ImageKit1.BitCount = 1 Then
If PalNo <> 0 Then
PalNo = 0
Else
PalNo = 1
End If
Else If ImageKit1.BitCount > 8 Then
Blue = 255 - Blue
Green = 255 - Green
Red = 255 - Red
End If
Ret = ImageKit1.Effect.SetBitmapPixel(j, i, PalNo, Red, Green, Blue)
Next j
Next i

Ret = ImageKit1.Effect.EndBitmapAccess()
ImageKit1.Refresh()

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


UnifyColor method

Newtone.ImageKit.Win.ImageKit.Effect.UnifyColor Method

This method allows you to convert a range in colors in a raster image into one color. This method is useful when using transparent colors.

[Visual Basic] Public Function UnifyColor(red As Byte, green As Byte, blue As Byte, error As Integer) As Boolean
[C#] public bool UnifyColor(byte red, byte green, byte blue, int error);

Parameters

red
The red component of the color to be unified (from 0 to 255)

green
The green component of the color to be unified (from 0 to 255)

blue
The blue component of the color to be unified (from 0 to 255)

error
Sets the range of RGB values that will be unified (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The UnifyColor method allows you to unify a range of colors in a raster image. This is very useful when using transparancy. The Red, Green, and Blue parameters define the unified color. The Error parameter sets the range of colors that will be unified into the single color. So, for example, if you set the Red, Green and Blue parameter each to 128 and the Error parameter to 10, all colors ranging from RGB(118,118,118) to RGB(138,138,138) will be changed to RGB(128,128,128).

To execute the UnifyColor method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The UnifyColor method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the UnifyColor method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If the UnifyColor method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the UnifyColor method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Waves method

Newtone.ImageKit.Win.ImageKit.Effect.Waves Method

This method creates a wave like effect on a raster image.

[Visual Basic] Public Function Waves(direction As Integer, type As Integer, period As Integer, amplitude As Integer, phase As Double, edge As Integer, red As Byte, green As Byte, blue As Byte) As Boolean
[C#] public bool Waves(int direction, int type, int period, int amplitude, double phase, int edge, byte red, byte green, byte blue);

Parameters

direction
Sets the direction of the waves (0: horizontal, 1: vertical)

type
Sets the type of wave (0:sin wave, 1: sawtooth)

period
Sets the length of the wave (more than 0)

amplitude
Sets the size of the wave (more than 0)

phase
Sets the phase or shift in the wave cycle.(from 0.0 to 1.0)

edge
Sets the type of edge(0: background color, 1:adjoining pixel color, 2 wrap around)

red
Sets the red component of the background color (from 0 to 255)

green
Sets the green component of the background color (from 0 to 255)

blue
Sets the blue component of the background color (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Waves method creates a wave like effect on a raster image.

To execute the Waves method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Waves method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the Waves method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If the Waves method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the Waves method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


WhirlPinch method

Newtone.ImageKit.Win.ImageKit.Effect.WhirlPinch Method

This method produces an interesting effect similar to pinching a raster image then twisting your fingers.

[Visual Basic] Public Function WhirlPinch(whirl As Double, pinch As Double, radius As Double, red As Integer, green As Integer, blue As Integer) As Boolean
[C#] public bool WhirlPinch(double whirl, double pinch, double radius, short red, short green, short blue);

Parameters

whirl
Sets the number of degrees of the twisting effect

pinch
Sets the "strength" of the pinch

radius
Sets the size of the area affected by the twisting effect (more than 0)

red
Sets the red component of the background color (from 0 to 255)

green
Sets the green component of the background color (from 0 to 255)

blue
Sets the blue component of the background color (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The WhirlPinch method creates an effect similar to pinching a raster image and then twisting your fingers. The Whirl parameter sets the number of degrees of the twisting effect. A value of 360 would mean that the twisting effect makes one complete revolution. The Radius parameter sets the size of the twisting effect on the image. As the Radius parameter increases in size, it affects larger areas on the image. Values of 2 or more could mean the the radius of the twisting effect is larger than the image itself. In this case the background color is used to fill any spaces that are outside of the orginal image. It is recommended that you set a Radius value of less than 1 so that the area affected remains within the image, then experiment with the Whirl parameter to get the desired effect. The Pinch parameter does exactly that, it pinches the area in the center of the twisting effect. A Pinch parameter of 1 will bring all of the colors together in the center. Values greater than 1 can "tear" the image in which case the background color is painted in the center.

To execute the WhirlPinch method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The WhirlPinch method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the WhirlPinch method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If the WhirlPinch method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the WhirlPinch method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


YCCGamma method

Newtone.ImageKit.Win.ImageKit.Effect.YCCGamma Method

This method uses gamma correction to adjust the YCrCb values of a raster image.

[Visual Basic] Public Function YCCGamma(yb As Double, cr As Double, cb As Double) As Boolean
[C#] public bool YCCGamma(double yb, double cr, double cb);

Parameters

yb
The gamma factor for the Y plane

cr
The gamma factor for the Cr plane

cb
The gamma factor for the Cb plane

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCGamma method uses gamma correction to adjust the YCrCb values and overall brightness of a raster image. The formula used to calculate the output is given below:

Where x is the input YCrCb value, y is the output YCrCb value and bright is the gamma factor for the Y, Cr and Cb planes. (The Yb, Cr, and Cb parameters respectively).

When the Yb, Cr, and Cb parameters all equal 0, the input RGB values and output YCrCb values are equal meaning there is no change in the image. As the Yb, Cr, and Cb parameters increase in a positive direction, the output YCrCb values become lower than the input YCrCb values. As the Yb, Cr, and Cb parameters increase in a negative direction, the output YCrCb values become higher than the input YCrCb values. Please refer to the diagram below which shows the change in YCrCb values for a gamma factor of 1 and also for a gamma factor of -1.

To execute the YCCGamma method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The YCCGamma method supports 1, 4, 8, 16, 24, and 32 bit images.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If the YCCGamma method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the YCCGamma method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


YCCLevel method

Newtone.ImageKit.Win.ImageKit.Effect.YCCLevel Method

This method increases (or decreases) the YCrCb values of a raster image.

[Visual Basic] Public Function YCCLevel(yb As Integer, cr As Integer, cb As Integer) As Boolean
[C#] public bool YCCLevel(int yb, int cr, int cb);

Parameters

yb
Sets the shift in the Y component (luminance) of the YCrCb value (from -255 to 255)

cr
Sets the shift in the Cr component (chrominance) of the YCrCb value (from -255 to 255)

cb
Sets the shift in the Cb component (chrominance) of the YCrCb value (from -255 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCLevel method increases or decreases the YCrCb values in a raster image. Y represents luminance, Cr and Cb represent chrominance. As the values of the Yb, Cr, or Cb parameters increase, the image becomes brighter. As those values decrease, the image becomes darker. If the Yb, Cr, or Cb parameters are 0, the image is not altered.

To execute the YCCLevel method, set the image handle of the image in theImage property or the Layer(LayerNumber).Image property. The YCCLevel method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the YCCLevel method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If the YCCLevel method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the YCCLevel method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


YCCReverse method

Newtone.ImageKit.Win.ImageKit.Effect.YCCReverse Method

This method reverses the YCrCb values of a raster image.

[Visual Basic] Public Function YCCReverse(yb As Boolean, cr As Boolean, cb As Boolean) As Boolean
[C#] public bool YCCReverse(bool yb, bool cr, bool cb);

Parameters

yb
Reverses the Y component (luminance) of the YCrCb value (False: does not reverse value, True: reverses value)

cr
Reverses the Cr component (chrominance) of the YCrCb value (False: does not reverse value, True: reverses value)

cb
Reverses the Cb component (chrominance) of the YCrCb value (False: does not reverse value, True: reverses value)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCReverse method reverses the YCrCb values of a raster image. If the Yb, Cr, or Cb parameters are True, then that component of the YCrCb value is reversed. So, for example, the reverse of a Yb component = 255 would be a Yb component = 0 (Yb = 255 - Yb).

To execute the YCCReverse method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The YCCReverse method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the YCCReverse method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If the YCCReverse method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the YCCReverse method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


YCCSpline method

Newtone.ImageKit.Win.ImageKit.Effect.YCCSpline Method

This method uses spline function to modifiy the YCrCb values of a raster image.

[Visual Basic] Public Function YCCSpline(spline As Point, yb As Boolean, cr As Boolean, cb As Boolean) As Boolean
[C#] public bool YCCSpline(Point[] spline, bool yb, bool cr, bool cb);

Parameters

spline
Arrays of YCrCb values defining the x and y coordinates of points on the YCCSpline curve (from 0 to 255).
The number of coordinates in the array ranges from 3 to 10

yb
Affects the Y component (luminance) of the YCrCb value (False(0): does not affect the Y component, True( nonzero): affects the Y component)

cr
Affects the Cr component (chrominance) of the YCrCb value (False(0): does not affect the Cr component, True( nonzero): affects the Cr component)

cb
Affects the Cb component (chrominance) of the YCrCb value (False(0): does not affect the Cb component, True( nonzero): affects the Cb component)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCSpline method uses a spline function to modify the YCrCb values of a raster image. A spline function is a method of interpolating values that lay in between data points. In other words it produces a smooth curve from a limited set of points.

The YCCSpline method allows you to define the relationship between the input YCrCb values in the original image and output YCrCb values in the newly created image. You do this by specifying a set of coordinate points where the input YCrCb values are the x coordinates and the output YCrCb values are the y coordinates. These coordinate points are stored in arrays and passed to the YCCSpline method through the Spline parameter. The YCCSpline method then interpolates a "smooth" curve from these coordinate points. The graphic representation of this relationship between input YCrCb and output YCrCb values is known as the YCCSpline curve. A sample YCCSpline curve is shown in the diagram below:

In the above diagram, the default YCCSpline curve represents no change between input YCrCb values and output YCrCb values. In this case, the newly created image is exactly the same as the orginal image. The red YCCSpline curve represents an increase in contrast between the original image and the newly created image. It was generated from the following points:

Point (x values,y values)
-----------------------------------------------------
Point A (0,0)
Point B (64,32)
Point C (128,128)
Point D (192,160)
Point E (255,255)

At the midpoint of the YCCSpline curve, the input YCrCb value of 128 equals the output YCrCb value of 128. At points below the midpoint, however, the output YCrCb values are lower than the input YCrCb values. This means that dark colors become darker. Conversely, at points above the midpoint, output YCrCb values are higher than input YCrCb values. This means that light colors become lighter. This particular YCCSpline curve therefore increases the contrast of the image.

An YCCSpline curve that decreases contrast could be defined with the following points:

Point (x values,y values)
----------------------------------------------------
Point A (0,0)
Point B (64, 96)
Point C (128,128)
Point D (225, 192)
Point E (255,255)

To execute the YCCSpline method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The YCCSpline method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the YCCSpline method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If the YCCSpline method is successful and the DestinationAsImageKitImage property is True, the resulting image will be set in the Image property or in the Layer(LayerNumber).Image property, according to the value set in the LayerNumber property.

If the YCCSpline method is successful and the DestinationAsImageKitImage property is False, the resulting image will be set in the DestinationImage property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


ImageKit.File Members

Newtone.ImageKit.Win.ImageKit.File All Members

Public Properties

BackgroundBlue | Sets the blue component (RGB) of the background color in a vector image.
BackgroundGreen | Sets the green component (RGB) of the background color in a vector image.
BackgroundPaint | Sets the background color for a vector image.
BackgroundRed | Set the red component (RGB) of the background color for a vector image.
Comment | Sets and retrieves a comment in certain image files
CreationTimeDay | Refers to the day when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeHour | Refers to the hour when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeMinute | Refers to the minute when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeMonth | Refers to the month when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeSecond | Refers to the second when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeYear | Refers to the year when the file was created. Retrieved after executing the GetImageFileType method.
FileBitCount | Refers to the bit count of the image. Retrieved after executing the GetImageFileType or GetImagefileTypeFromRawData methods.
FileExtension | Sets the file type initially displayed by the OpenFileDialog and SaveFileDialog methods
ExifAutoRotate | Sets whether to automatically adjust and display the direction of photos taken with a smartphone.
FileHeight | Refers to the height of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileImageSize | Refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileMaxPage | Refers to the number of pages of a multi-page image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileName | Sets the name of the image file (full path) to be loaded or saved
FilePath | Sets the folder initially displayed by the OpenFileDialog and SaveFileDialog methods
FileSize | Refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileType | Refers to the type of image format. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileWidth | Refers to the width of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileWidthByte | Refers to the number of bytes per line in the image. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileXdpi | Refers to the horizontal resolution of the image. (number of pixels per horizontal inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileYdpi | Refers to the vertical resolution of the image. (number of pixels per vertical inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FtpCredentials | Sets the credentials used to communicate with the FTP server
FtpPassive | Sets whether or not passive mode connectivity is enabled
FtpProxy | Sets the proxy used to communicate with the FTP server
FtpStatusCode | Retrieves the FTP status value
FtpTimeout | Sets the number of milliseconds to wait for a request
GifAnimation | This property is not supported in the ImageKit.NET3.
GifAnimationDelay | This property is not supported in the ImageKit.NET3.
HttpCredentials | Sets authentication information for the request
HttpProxy | Sets proxy information for the request
HttpStatusCode | Retrieves the Http status value
HttpTimeout | Sets the time-out value for the request
Interlace | This property is not supported in the ImageKit.NET3.
JPEG2000CodeBlockHeight | Sets the height of the JPEG2000 format code block size
JPEG2000CodeBlockWidth | Sets the width of the JPEG2000 format code block size
JPEG2000NumResLevel | Sets the level of the JPEG2000 format resolution
JPEG2000PrecinctHeight | Sets the height of the JPEG2000 format precinct size
JPEG2000PrecinctWidth | Sets the width of the JPEG2000 format precinct size
JPEG2000Reversible | Sets whether or not the JPEG2000 lossless compression is reversible
JPEG2000Size | Sets the size of the file when saved in JPEG2000 format
JPEG2000TileHeight | Sets the height of the JPEG2000 format tile size
JPEG2000TileWidth | Sets the width of the JPEG2000 format tile size
JpegQuality | Sets the quality coefficient when an image is saved in JPEG or FPX (JPEG compression) file formats
JpegSubsampling | Sets the YCrCb subsampling ratios when saving an image in JPEG format
LastAccessTimeDay | Refers to the day when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeHour | Refers to the hour when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeMinute | Refers to the number of minutes when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeMonth | Refers to the month when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeSecond | Refers to the number of seconds when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeYear | Refers to the year when the file was last accessed. Retrieved after executing the GetImageFileType method
LastWriteTimeDay | Refers to the day when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeHour | Refers to the hour when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeMinute | Refers to the number of minutes when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeMonth | Refers to the month when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeSecond | Refers to the number of seconds when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeYear | Refers to the year when the file was last modified. Retrieved after executing the GetImageFileType method
LoadPage | Sets the page to be loaded when a multi-page image file (FPX, GIF, or TIFF) image is loaded
MinIsBlack | Sets whether Tiff images, saved in 1 bit color, will be white mode or black mode.
PngAlphaChannel | This property is not supported in the ImageKit.NET3.
RawData | Sets the byte array of the Raw data for the image to be loaded or saved
TiffAppend | This property has been deprecated. Use the MethodAppendTiffImage method instead.
TiffColorSpace | This property is not supported in the ImageKit.NET3.
TiffSaveOneStrip | This property is not supported in the ImageKit.NET3.
Transparent | This property is not supported in the ImageKit.NET3.
TransparentBlue | This property is not supported in the ImageKit.NET3.
TransparentGreen | This property is not supported in the ImageKit.NET3.
TransparentRed | This property is not supported in the ImageKit.NET3.
VectorHeight | Sets the height of a vector image when the image is loaded
VectorWidth | Sets the width of a vector image when the image is loaded

Public Methods

AppendTiffImage | Adds a page to the end of a multipage tiff and saves it to file
CloseMultiTiff | This method is no longer needed. See the MethodAppendTiffImage method
CMYKBmpPlaneFileLoad | Loads a bmp file that has been saved in seperate CMYK planes
CMYKBmpPlaneFileSave | Saves a raster image into seperate CMYK planes. The saved images are in BMP format.
DeletePageFromMultipageTiff | Deletes the specified page from a multipage tiff file
FtpDeleteFile | Deletes a file from an FTP server
FtpDownloadFile | Downloads a file from an FTP server
FtpDownloadFileToByteArray | Downloads data from a file on an FTP server to a byte array
FtpRenameFile | Renames a file that exists on an FTP server
FtpUploadFile | Uploads a file to an FTP server
FtpUploadByteArrayToFile | Uploads data in a byte array to a file on an Ftp server
GetImageFileType | Retrieves information about the image and sets this information into various properties
GetImageFileTypeFromRawData | Retrieves information from the raw image data and sets that information into various properties
HttpDeleteFile | Deletes a file from an HTTP server
HttpDownloadFile | Downloads a file from an HTTP server
HttpDownloadFileToByteArray | Downloads data from a file from an HTTP server to a byte array
HttpUploadByteArrayToFile | Uploads data in a byte array to a file on an HTTP server
HttpUploadFile | Uploads a file to an HTTP server
HttpUploadFile | Uploads a file to an HTTP server
InsertPageIntoMultipageTiff | Inserts a page into a multipage tiff
LoadImageFromFile | Loads image data from a file.
LoadImageFromRawData | Loads DIB image data from raw data
LoadRawDataFromFile | Loads raw image data from file without converting it to DIB data
LoadRawDataFromStream | Loads raw image data from stream
MergeTiffImages | Combines tiff files contained in a specified folder and saves them as a single multipage tiff file.
ModifyPageInMultipageTiff | Modifies a specified page of an existing multipage tiff file.
OpenFileDialog | Displays the "Open" dialog box which includes the file preview and information functions. This dialog box is used to select an image file to be opened.
RGBBmpPlaneFileLoad | Loads a bmp file that has been saved in seperate RGB planes
RGBBmpPlaneFileSave | Saves a raster image into seperate RGB planes. The saved images are in BMP format.
SaveFileDialog | Displays the "Save" dialog box which includes the file preview function. This dialog box is used to select an image file to be saved.
SaveImageToFile | Saves image data to a file
SaveImageToRawData | Saves image data as raw data
SaveRawDataToFile | Saves raw data to a file
SaveRawDataToStream | Saves the raw image data to stream.
YCCBmpPlaneFileLoad | Loads a bmp file that has been saved in seperate YCrCb planes
YCCBmpPlaneFileSave | Saves a raster image into seperate YCrCb planes. The saved images are in BMP format.

Hierarchy Property

Exif | Exposes properties of the Exif(JPEG) file's main and thumbnail image
PDF | Exposes properties to save images in PDF format

See Also

Newtone.ImageKit.Win.ImageKit


BackgroundRGB property

Newtone.ImageKit.Win.ImageKit.File.BackgroundBlue Property

This property sets the blue component (RGB) of the background color in a vector image.

[Visual Basic] Public WriteOnly Property BackgroundBlue As Byte
[C#] public byte BackgroundBlue {set;}

Property Value

The values can range from 0 to 255

Explanation

The BackgroundBlue property sets the blue component (RGB) of the background color in a vector image.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


BackgroundRGB property

Newtone.ImageKit.Win.ImageKit.File.BackgroundGreen Property

This property sets the green component (RGB) of the background color in a vector image.

[Visual Basic] Public WriteOnly Property BackgroundGreen As Byte
[C#] public byte BackgroundGreen {set;}

Property Value

The values can range from 0 to 255

Explanation

The BackgroundGreen property sets the green component (RGB) of the background color in a vector image.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


BackgroundPaint property

Newtone.ImageKit.Win.ImageKit.File.BackgroundPaint Property

This property sets the background color for a vector image.

[Visual Basic] Public WriteOnly Property BackgroundPaint As Boolean
[C#] public bool BackgroundPaint {set;}

Property Value

Value | Explanation
True | Sets the background color
False | Does not set the background color

Explanation

The BackgroundPaint property sets the background color when saving a vector image. To set the background color, set the appropriate values in the BackgroundBlue, BackgroundGreen, and BackgroundRed properties.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


BackgroundRGB property

Newtone.ImageKit.Win.ImageKit.File.BackgroundRed Property

This property set the red component (RGB) of the background color for a vector image.

[Visual Basic] Public WriteOnly Property BackgroundRed As Byte
[C#] public byte BackgroundRed {set;}

Property Value

The values can range from 0 to 255

Explanation

The BackgroundRed property set the red component (RGB) of the background color for a vector image.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Comment property

Newtone.ImageKit.Win.ImageKit.File.Comment Property

This property sets the comment that can be saved in some types of image files. By executing the GetImageFileType or the GetImagefileTypeFromRawData methods, any comments that exist in an image are retrieved.

[Visual Basic] Public Property Comment As String
[C#] public string Comment {get; set;}

Property Value

The comment string (Maximum length:1023 bytes)

Explanation

The Comment property sets the comment that can be saved in some types of image files. By executing the GetImageFileType or the GetImageFileTypeFromRawData method, any comments that exist in an image are retrieved.

The type of comment and its syntax depends on the file format. The following image file formats support comments and their syntax is given below. If the particular image file does not support a comment, then this property is ignored for those image files.

Name | Explanation
FPX | Title+0x0d+Subtitle+0x0d+Author+0x0d+Comment+0x0d
GIF | Comment
JPEG | Comment
JPEG2000 | Title+0x0d+Subtitle+0x0d+Author+0x0d+Comment+0x0d
PNG | Title+0x0d+Author+0x0d+Explanation+0x0d+Copyright+0x0d+DateTime+0x0d+Software+0x0d+Waiver+0x0d+Warning+0x0d+Input Devices+0x0d+Comment+0x0d
TIFF | Document Name+0x0d+Image Explanation+0x0d+Page Name+0x0d+Software+0x0d+Date Time+0x0d+Author+0x0d

Note: please enter a blank string into any unnecessary fields. In Visual Basic, replace the 0x with &H.

To use this property, you must have the appropriate ImageKit.NET3 plugin Dll files (Win32 Dlls).

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CreationTime property

Newtone.ImageKit.Win.ImageKit.File.CreationTimeDay Property

This property refers to the day when the file was created. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property CreationTimeDay As Integer
[C#] public int CreationTimeDay {get;}

Property Value

The day when the file was created

Explanation

The CreationTimeDay property refers to the day when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CreationTime property

Newtone.ImageKit.Win.ImageKit.File.CreationTimeHour Property

This property refers to the hour when the file was created. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property CreationTimeHour As Integer
[C#] public int CreationTimeHour {get;}

Property Value

The hour when the file was created

Explanation

The CreationTimeHour property refers to the hour when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CreationTime property

Newtone.ImageKit.Win.ImageKit.File.CreationTimeMinute Property

This property refers to the number of minutes when the file was created. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property CreationTimeMinute As Integer
[C#] public int CreationTimeMinute {get;}

Property Value

The minute when the file was created

Explanation

The CreationTimeMinute property refers to the number of minutes when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CreationTime property

Newtone.ImageKit.Win.ImageKit.File.CreationTimeMonth Property

This property refers to the month when the file was created. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property CreationTimeMonth As Integer
[C#] public int CreationTimeMonth {get;}

Property Value

The month when the file was created

Explanation

The CreationTimeMonth property refers to the month when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CreationTime property

Newtone.ImageKit.Win.ImageKit.File.CreationTimeSecond Property

This property refers to the number of seconds when the file was created. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property CreationTimeSecond As Integer
[C#] public int CreationTimeSecond {get;}

Property Value

The number of seconds when the file was created

Explanation

The CreationTimeSecond property refers to the number of seconds when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CreationTime property

Newtone.ImageKit.Win.ImageKit.File.CreationTimeYear Property

This property refers to the year when the file was created. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property CreationTimeYear As Integer
[C#] public int CreationTimeYear {get;}

Property Value

The year when the file was created

Explanation

The CreationTimeYear property refers to the year when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileBitCount property

Newtone.ImageKit.Win.ImageKit.File.FileBitCount Property

This property refers to the bit count of the image. Retrieved after executing the GetImageFileType or GetImageFileTypeFromRawData methods.

[Visual Basic] Public ReadOnly Property FileBitCount As Integer
[C#] public int FileBitCount {get;}

Property Value

1: 2 colors (i.e.Black and White)
4: 16 colors
8: 256 colors
16: 16 bit color
24: 24bit color
32: 32bit color

Explanation

This property is disabled for vector images.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


ExifAutoRotate property

Newtone.ImageKit

Newtone.ImageKit.Win.ImageKit.File.ExifAutoRotate Property

This property sets whether to automatically adjust and display the direction of photos taken with a smartphone.

[Visual Basic] Public Property ExifAutoRotate As Boolean
[C#] public bool ExifAutoRotate {get; set;}

Property Value

Value | Explanation
True | Adjusts the orientation automatically
False | Display in the original orientation. (Default)

Explanation

This property sets whether to automatically adjust and display the direction of photos taken with a smartphone.

When this property is True when loaded with the LoadImageFromFile or LoadImageFromRawData method, the orientation of the photo taken with a smartphone, digital camera, etc. is automatically adjusted and displayed based on the information of MainOrientation of Exif.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileExtension property

Newtone.ImageKit.Win.ImageKit.File.FileExtension Property

This property sets the file type initially displayed by the OpenFileDialog and SaveFileDialog methods.

[Visual Basic] Public Property FileExtension As String
[C#] public string FileExtension {get; set;}

Property Value

The FileExtension is the file type (i.e. jpg, bmp)

Explanation

The FileExtension property sets the file type initially displayed by the OpenFileDialog and SaveFileDialog methods. When you execute the OpenFileDialog and SaveFileDialog methods, the "Open" dialog box and "Save" dialog box will be displayed. The FileExtension property sets which file extentions will be listed in the "Files of type" drop down menu at the bottom of the dialog box.

By default the "Open" dialog box and the "Save" dialog box display all file types in a given folder. They also display the term "All Files" along with all individual file extentions supported by the ImageKit in the "Files of type" drop down menu at the bottom of the dialog box. By setting the FileExtension property, you can determine which file extentions will be listed in this drop down menu and thereby influence the types of files that can be selected in the "Open" dialog box and "Save" dialog box.

To set the FileExtension property, start with the file explanation followed by a "|" symbol as a delimeter and the the file extensions to be displayed. When listing multiple file extensions, use a comma (;) to delimit them. If an empty string ("") is set into the FileExtension property then the file types will be "all files". If an empty string is set into the FilePath property, then the current directory will be displayed when the dialog opens.

There is no distinction made between upper case or lower case letters so that "BMP" is treated as the same as "bmp".

Example

The code below illustrates how to set the default folder to "C:\Images" and to set the file types to "BMP", "JPG and PNG", and "All Files":

[Visual Basic.NET]
ImageKit1.File.FilePath = "c:\images"
ImageKit1.File.FileExtension = "Bitmap files|.bmp;Jpeg,Png files|.jpg;*.png; All Files|*.*"

[Visual C#.NET]
ImageKit1.File.FilePath = "c:\\Images";
ImageKit1.File.FileExtension = "Bitmap files|.bmp;Jpeg,Png files|.jpg;*.png; All Files|*.*";

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileHeightWidth property

Newtone.ImageKit.Win.ImageKit.File.FileHeight Property

This property refers to the height of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileHeight As Integer
[C#] public int FileHeight {get;}

Property Value

The height of the image in pixels

Explanation

The FileHeight property refers to the height of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.

If the information cannot be retrieved from the file, 0 will be set in this property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileImageSize property

Newtone.ImageKit.Win.ImageKit.File.FileImageSize Property

This property refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileImageSize As Integer
[C#] public int FileImageSize {get;}

Property Value

The size of the image file

Explanation

TheFileImageSize property refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

This property is only enabled for raster images.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileMaxPage property

Newtone.ImageKit.Win.ImageKit.File.FileMaxPage Property

This property refers to the number of pages of a multi-page image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileMaxPage As Integer
[C#] public int FileMaxPage {get;}

Property Value

The number of pages of a multi-page image file

Explanation

The FileMaxPage property refers to the number of pages of a multi-page image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

This property is enabled for raster images.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileName property

Newtone.ImageKit.Win.ImageKit.File.FileName Property

This property sets the name of the image file (full path) to be loaded or saved.

[Visual Basic] Public Property FileName As String
[C#] public string FileName {get; set;}

Property Value

The name of the image file (full path)

Explanation

The FileName property sets the name of the image file (full path) to be loaded or saved.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FilePath property

Newtone.ImageKit.Win.ImageKit.File.FilePath Property

This property sets the folder initially displayed by the OpenFileDialog and SaveFileDialog methods.

[Visual Basic] Public Property FilePath As String
[C#] public string FilePath {get; set;}

Property Value

The FilePath is the folder name

Explanation

The FilePath property sets the folder initially displayed by the OpenFileDialog and SaveFileDialog methods.

When you execute the OpenFileDialog and SaveFileDialog methods, the "Open" dialog box and "Save" dialog box will be displayed. The FilePath property allows you to set the folder that is accessed when the "Open" dialog box and "Save" dialog box are displayed.

When setting the FileExtension property, start with the file explanation followed by a "|" symbol as a delimeter and the the file extensions to be displayed. When listing multiple file extensions, use a comma (;) to delimit them. If an empty string ("") is set into the FileExtension property then the file types will be "all files". If an empty string is set into the FilePath property, then the current direct directory will be displayed when the dialog opens.

There is no distinction made between upper case or lower case letters so that "BMP" is treated as the same as "bmp".

Example

The code below illustlates how to set the default folder to "C:\Images" and to set the file types to "BMP", "JPG and PNG", and "All Files":

[Visual Basic.NET]
ImageKit1.File.FilePath = "c:\images"
ImageKit1.File.FileExtension = "Bitmap files|*.bmp|Jpeg,Png files|*.jpg;*.png|All Files|*.*"

[Visual C#.NET]
ImageKit1.File.FilePath = "c:\\Images";
ImageKit1.File.FileExtension = "Bitmap files|*.bmp|Jpeg,Png files|*.jpg;*.png|All Files|*.*";

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileSize property

Newtone.ImageKit.Win.ImageKit.File.FileSize Property

This property refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileSize As Integer
[C#] public int FileSize {get;}

Property Value

The size of the image file

Explanation

The FileSize property refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

If the information cannot be retrieved from the file, 0 will be set into this property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileType property

Newtone.ImageKit.Win.ImageKit.File.FileType Property

This property refers to the image format. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileType As Newtone.ImageKit.TypeOfFile
[C#] public Newtone.ImageKit.TypeOfFile FileType {get;}

Property Value

This value is of type Newtone.ImageKit.TypeOfFile

Explanation

The FileType property refers to image format. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

Note: TIFF(GROUP3-1D) is the same as MH. TIFF(GROUP3-2D) is the same as MR. TIFF(GROUP4) is the same as MMR. The ImageKit.NET3 supports Exif version 2.1

If an unsupported image format is loaded into the ImageKit Control, the FileType property will return 0.

To use JPEG2000 and FPX images, you must have the appropriate ImageKit.NET3 Plugin (Win32 Dll files).

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileHeightWidth property

Newtone.ImageKit.Win.ImageKit.File.FileWidth Property

This property refers to the width of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileWidth As Integer
[C#] public int FileWidth {get;}

Property Value

The width of the image in pixels

Explanation

The FileWidth property refers to the width of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.

If the information cannot be retrieved from the file, 0 will be set into this property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileWidthByte property

Newtone.ImageKit.Win.ImageKit.File.FileWidthByte Property

This property refers to the number of bytes per line in the image. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileWidthByte As Integer
[C#] public int FileWidthByte {get;}

Property Value

The number of bytes per line in the image

Explanation

The FileWidthByte property refers to the number of bytes per line in the image. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

This property is enabled for raster images.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileXdpi property

Newtone.ImageKit.Win.ImageKit.File.FileXdpi Property

The FileXdpi property refers to the horizontal resolution of the image. (number of pixels per horizontal inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileXdpi As Integer
[C#] public int FileXdpi {get;}

Property Value

The horizontal resolution of the image (number of pixels per horizontal inch)

Explanation

The FileXdpi property refers to the horizontal resolution of the image. (number of pixels per horizontal inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

If the information cannot be retrieved from the file, 0 will be set in this property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileYdpi property

Newtone.ImageKit.Win.ImageKit.File.FileYdpi Property

The FileYdpi property refers to the vertical resolution of the image. (number of pixels per vertical inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileYdpi As Integer
[C#] public int FileYdpi {get;}

Property Value

The vertical resolution of the image (number of pixels per vertical inch)

Explanation

The FileYdpi property refers to the vertical resolution of the image. (number of pixels per vertical inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

If the information cannot be retrieved from the file, 0 will be set into this property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Credentials property

Newtone.ImageKit.Win.ImageKit.File.FtpCredentials Property

This property gets or sets the credentials used to communicate with the FTP server.

[Visual Basic] Public Property FtpCredentials As ICredentials
[C#] public ICredentials FtpCredentials {get; set;}

Property Value

An ICredentials instance; otherwise, a null reference (Nothing in Visual Basic) if the property has not been set.

Explanation

The FtpCredentials property gets or sets the credentials used to communicate with the FTP server.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Passive property

Newtone.ImageKit.Win.ImageKit.File.FtpPassive Property

This property sets whether or not passive mode connectivity is enabled.

[Visual Basic] Public Property FtpPassive As Boolean
[C#] public bool FtpPassive {get; set;}

Property Value

Value | Explanation
True | Passive mode connectivity
False | Active mode connectivity (default)

Explanation

The FtpPassive property sets whether or not passive mode connectivity is enabled.

This property is refered to by executing the FtpDownload or FtpUploadFile method.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Proxy property

Newtone.ImageKit.Win.ImageKit.File.FtpProxy Property

This property gets or sets the proxy used to communicate with the FTP server.
[Visual Basic] Public Property FtpProxy As IWebProxy
[C#] public IWebProxy FtpProxy {get; set;}

Property Value

An WebProxy instance responsible for communicating with the FTP server. The default value is null (Nothing in Visual Basic).

Explanation

The FtpProxy property gets or sets the proxy used to communicate with the FTP server.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpStatusCode property

Newtone.ImageKit.Win.ImageKit.File.FtpStatusCode Property

This property retrieves the FTP status value

[Visual Basic] Public Property FtpStatusCode As System.Net.FtpStatusCode
[C#] public System.Net.FtpStatusCode FtpStatusCode {get; set;}

Property Value

An FtpStatusCode value

Explanation

The FtpStatusCode property retrieves the FTP status value.

The FtpDeleteFile, FtpDownloadFile, FtpDownloadFileToByteArray, FtpRenameFile, FtpUploadByteArrayToFile, and FtpUploadFile methods all return FtpStatus values.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Timeout property

Newtone.ImageKit.Win.ImageKit.File.FtpTimeout Property

This property gets or sets the number of milliseconds to wait for a request.

[Visual Basic] Public Property FtpTimeout As Integer
[C#] public int FtpTimeout {get; set;}

Property Value

The number of milliseconds to wait before a request times out. The default value is 60000 milliseconds.

Explanation

The FtpTimeout property gets or sets the number of milliseconds to wait for a request. Timeout is the number of milliseconds that a synchronous request waits for a response.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpCredentials property

Newtone.ImageKit.Win.ImageKit.File.HttpCredentials Property

This property gets or sets authentication information for the request.
[Visual Basic] Public Property HttpCredentials As ICredentials
[C#] public ICredentials HttpCredentials {get; set;}

Property Value

This value contains the authentication credentials associated with the request. The default is a null reference (Nothing in Visual Basic).

Explanation

The HttpCredentials property gets or sets authentication information for the request. For more information please refer to the .NET Framework ICredentials interface.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Headers property

Newtone.ImageKit.Win.ImageKit.File.HttpHeaders Property

This property sets or retrieves the Http Header name-value pair collection from the request.

[Visual Basic] Public Property HttpHeaders As System.Net.WebHeaderCollection
[C#] public System.Net.WebHeaderCollection HttpHeaders {get; set;}

Property Value

The Http Header name-value pair collection

Explanation

The HttpHeaders property sets or retrieves the Http Header's name-value pair collection from the request. Set this property prior to executing the UploadFile or UploadByteArrayToFile methods.

NOTE: When setting this property the only recognized values are "Content-Disposition" and "Cookie"

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Method property

Newtone.ImageKit.Win.ImageKit.File.HttpMethod Property

This property sets the Http method for the request.

[Visual Basic] Public Property HttpMethod As String
[C#] public string HttpMethod {get; set;}

Property Value

Values of "POST" and "PUT" may be set.

The default value is null (Nothing in Visual Basic)

Explanation

The HttpMethod property sets the Http method for the request. Before executing the UploadFile or the UploadByteArrayToFile methods, please set this property to "POST" or "PUT".

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpProxy property

Newtone.ImageKit.Win.ImageKit.File.HttpProxy Property

This property gets or sets proxy information for the request.

[Visual Basic] Public Property HttpProxy As IWebProxy
[C#] public IWebProxy HttpProxy {get; set;}

Property Value

The WebProxy instance used to proxy the request. The default value is null (Nothing in Visual Basic).

Explanation

The HttpProxy property identifies the WebProxy object to use to process requests to Internet resources.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpStatusCode property

Newtone.ImageKit.Win.ImageKit.File.HttpStatusCode Property

This property retrieves the Http status value

[Visual Basic] Public Property StatusCode As System.Net.HttpStatusCode
[C#] public System.Net.HttpStatusCode StatusCode {get; set;}

Property Value

An HttpStatusCode value

Explanation

The HttpStatusCode property retrieves the Http status value.

The HttpDeleteFile, HttpDownloadFile, HttpDownloadFileToByteArray, HttpUploadByteArrayToFile, and HttpUploadFile methods all return HttpStatus values.

See Also

ImageKit.File ƒƒ“ƒo | Newtone.ImageKit.Win.ImageKit


HttpTimeout property

Newtone.ImageKit.Win.ImageKit.File.HttpTimeout Property

This property gets or sets the time-out value for the request.

[Visual Basic] Public Property HttpTimeout As Integer
[C#] public int HttpTimeout {get; set;}

Property Value

The number of milliseconds to wait before the request times out. The default value is 60000 milliseconds.

Explanation

The HttpTimeout property gets or sets the time-out value for the request. Timeout is the number of milliseconds that a subsequent synchronous request waits for a response

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpUserAgent property

Newtone.ImageKit.Win.ImageKit.File.HttpUserAgent Property

This property sets or retrieves the User-Agent Http header.

[Visual Basic] Public Property UserAgent As String
[C#] public string UserAgent {get; set;}

Property Value

The User-agent HTTP header value. Default is null (Nothing in Visual Basic)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000CodeBlockSize property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000CodeBlockHeight Property

This property sets the height of the JPEG2000 format code block size.

[Visual Basic] Public Property JPEG2000CodeBlockHeight As Integer
[C#] public int JPEG2000CodeBlockHeight {get; set;}

Property Value

The height of the JPEG2000 code block size

Explanation

The JPEG2000CodeBlockHeight property sets or retrieves the height of the JPEG2000 format code block size. The default value is 0.

The JPEG2000 format code block size is measured by 2 to certain power (from 2 to 10). So setting the JPEG2000CodeBlockHeight property to 3 would mean the vertical code block size is 23 . This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must use the ImageKit.NET3 Plugin (Win32 DLL files)..

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000CodeBlockSize property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000CodeBlockWidth Property

This property sets the width of the JPEG2000 format code block size.

[Visual Basic] Public Property JPEG2000CodeBlockWidth As Integer
[C#] public int JPEG2000CodeBlockWidth {get; set;}

Property Value

The width of the JPEG2000 code block size

Explanation

The JPEG2000CodeBlockWidth property sets or retrieves the height of the JPEG2000 format code block size. The default value is 0.

The JPEG2000 format code block size is measured by 2 to certain power (from 2 to 10). So setting the JPEG2000CodeBlockWidth property to 3 would mean the horizontal code block size is 23 . This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must use the ImageKit.NET3 Plugin (Win32 DLL files)..

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000NumResLevel property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000NumResLevel Property

This property sets the level of the JPEG2000 format resolution.

[Visual Basic] Public Property JPEG2000NumResLevel As Integer
[C#] public int JPEG2000NumResLevel {get; set;}

Property Value

The resolution level (from 0)

Explanation

The JPEG2000NumResLevel property sets the level of the JPEG2000 format resolution. The default value is 0.

This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must use the ImageKit.NET3 Plugin (Win32 DLL files)..

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000PrecinctHeight property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000PrecinctHeight Property

This property sets the height of the JPEG2000 format precinct size.

[Visual Basic] Public Property JPEG2000PrecinctHeight As Integer
[C#] public int JPEG2000PrecinctHeight {get; set;}

Property Value

The height of the JPEG2000 precinct size

Explanation

The JPEG2000PrecinctHeight property sets or retrieves the height of the JPEG2000 format precinct size. The default value is 0.

The JPEG2000 format precinct size is measured by 2 to certain power (from 0 to 15). So setting the JPEG2000PrecinctHeight property to 3 would mean the vertical precinct size is 23. This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must use the ImageKit.NET3 Plugin (Win32 DLL files)..

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000PrecinctWidth property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000PrecinctWidth Property

This property sets the width of the JPEG2000 format precinct size.

[Visual Basic] Public Property JPEG2000PrecinctWidth As Integer
[C#] public int JPEG2000PrecinctWidth {get; set;}

Property Value

The width JPEG2000 precinct size

Explanation

The JPEG2000PrecinctWidth property sets or retrieves the height of the JPEG2000 format precinct size. The default value is 0.

The JPEG2000 format precinct size is measured by 2 to certain power (from 0 to 15). So setting the JPEG2000PrecinctWidth property to 3 would mean the vertical precinct size is 23. This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must use the ImageKit.NET3 Plugin (Win32 DLL files)..

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000Reversible property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000Reversible Property

This property sets whether or not the JPEG2000 lossless compression is reversible.

[Visual Basic] Public Property JPEG2000Reversible As Boolean
[C#] public bool JPEG2000Reversible {get; set;}

Property Value

Value | Explanation
True | The compression is reversible
False | The compression is not reversible

Explanation

The JPEG2000Reversible property sets whether or not the JPEG2000 lossless compression is reversible. When true, file size will be bigger but since lossless compression is used there will be no degradation in image quality.

This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must use the ImageKit.NET3 Plugin (Win32 DLL files)..

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000Size property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000Size Property

This property sets the size of the file when saved in JPEG2000 format.

[Visual Basic] Public Property JPEG2000Size As Double
[C#] public double JPEG2000Size {get; set;}

Property Value

The size of the saved image as a factor of the size of the uncompressed image

Explanation

The JPEG2000Size property sets the size of the file when saved in JPEG2000 format.

When this property is 0.01, for example, it means that the file size will be 1/100th the size of the uncompressed file. The default value is 0 meaning no compression is used.

The JPEG2000Size property is enabled when the JPEG2000Reversible property is false. This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must use the ImageKit.NET3 Plugin (Win32 DLL files).

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000TileHeight property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000TileHeight Property

This property sets the height of the JPEG2000 format tile size.

[Visual Basic] Public Property JPEG2000TileHeight As Integer
[C#] public int JPEG2000TileHeight {get; set;}

Property Value

The height of the JPEG2000 tile size (in pixels)

Explanation

The JPEG2000TileHeight property sets or retrieves the height of the JPEG2000 format tile size. The default value is 0.

This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must use the ImageKit.NET3 Plugin (Win32 DLL files).

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000TileWidth property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000TileWidth Property

This property sets the width of the JPEG2000 format tile size.

[Visual Basic] Public Property JPEG2000TileWidth As Integer
[C#] public int JPEG2000TileWidth {get; set;}

Property Value

The width of the JPEG2000 tile size (in pixels)

Explanation

The JPEG2000TileWidth property sets or retrieves the width of the JPEG2000 format tile size. The default value is 0.

This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must use the ImageKit.NET3 Plugin (Win32 DLL files).

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JpegQuality property

Newtone.ImageKit.Win.ImageKit.File.JpegQuality Property

This property sets the quality coefficient when an image is saved in JPEG or FPX (JPEG compression) file formats.

[Visual Basic] Public Property JpegQuality As Integer
[C#] public int JpegQuality {get; set;}

Property Value

0 to 100 (75 is recommended)

Explanation

The JpegQuality property sets the quality coefficient when an image is saved in JPEG or FPX (JPEG compression) file formats.

Default value is 75. As this value decreases the size of the image file decreases but so does the quality of the image. Conversely, as the quality coefficient increase the quality of the iamge and the image file size also increase.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JpegSubsampling property

Newtone.ImageKit.Win.ImageKit.File.JpegSubsampling Property

This property sets the YCrCb subsampling ratios when saving an image in JPEG format.

[Visual Basic] Public Property JpegSubsampling As Newtone.ImageKit.JpegSubsamplingKind
[C#] public Newtone.ImageKit.JpegSubsamplingKind JpegSubsampling {get; set;}

Property Value

This value is of type Newtone.ImageKit.JpegSubsamplingKind

Explanation

The JpegSubsampling property sets the YCrCb subsampling ratios when saving an image in JPEG format. Since the Y (luminance or brightness) plane contains more important information about the image than does the CrCb (chrominance or color) planes, it is possible to reduce the size of the CrCb planes without a great sacrifice in quality thereby reducing the size of the image. A ratio for Y:Cr:Cb of 4:4:4 represents no reduction in size whereas a ratio of 4:1:1 represents a reduction in size of 50%.

This property is enabled when the image is 24 bit color and the image is saved as a JPEG image.

This property can only be used when loading or saving JPEG images with the ImageKit.NET3 Win32 Plugin

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastAccessTimeDay property

Newtone.ImageKit.Win.ImageKit.File.LastAccessTimeDay Property

This property refers to the day when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastAccessTimeDay As Integer
[C#] public int LastAccessTimeDay {get;}

Property Value

The day when the file was last accessed

Explanation

The LastAccessTimeDay property refers to the day when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastAccessTimeHour property

Newtone.ImageKit.Win.ImageKit.File.LastAccessTimeHour Property

This property refers to the hour when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastAccessTimeHour As Integer
[C#] public int LastAccessTimeHour {get;}

Property Value

The hour when the file was last accessed

Explanation

The LastAccessTimeHour property refers to the hour when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastAccessTimeMinute property

Newtone.ImageKit.Win.ImageKit.File.LastAccessTimeMinute Property

This property refers to the minute when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastAccessTimeMinute As Integer
[C#] public int LastAccessTimeMinute {get;}

Property Value

The number of minutes when the file was last accessed

Explanation

The LastAccessTimeMinute property refers to the minute when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastAccessTimeMonth property

Newtone.ImageKit.Win.ImageKit.File.LastAccessTimeMonth Property

This property refers to the month when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastAccessTimeMonth As Integer
[C#] public int LastAccessTimeMonth {get;}

Property Value

The month when the file was last accessed

Explanation

The LastAccessTimeMonth property refers to the month when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastAccessTimeSecond property

Newtone.ImageKit.Win.ImageKit.File.LastAccessTimeSecond Property

This property refers to the number of seconds when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastAccessTimeSecond As Integer
[C#] public int LastAccessTimeSecond {get;}

Property Value

The number of seconds when the file was last accessed

Explanation

The LastAccessTimeSecond property refers to the number of seconds when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastAccessTimeYear property

Newtone.ImageKit.Win.ImageKit.File.LastAccessTimeYear Property

This property refers to the year when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastAccessTimeYear As Integer
[C#] public int LastAccessTimeYear {get;}

Property Value

The year when the file was last accessed

Explanation

The LastAccessTimeYear property refers to the year when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastWriteTimeDay property

Newtone.ImageKit.Win.ImageKit.File.LastWriteTimeDay Property

This property refers to the day when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastWriteTimeDay As Integer
[C#] public int LastWriteTimeDay {get;}

Property Value

The day when the file was last modified

Explanation

The LastWriteTimeDay property refers to the day when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastWriteTimeHour property

Newtone.ImageKit.Win.ImageKit.File.LastWriteTimeHour Property

This property refers to the hour when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastWriteTimeHour As Integer
[C#] public int LastWriteTimeHour {get;}

Property Value

The hour when the file was last modified

Explanation

The LastWriteTimeDay property refers to the hour when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastWriteTime property

Newtone.ImageKit.Win.ImageKit.File.LastWriteTimeMinute Property

This property refers to the number of minutes when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastWriteTimeMinute As Integer
[C#] public int LastWriteTimeMinute {get;}

Property Value

The number of minutes when the file was last modified

Explanation

The LastWriteTimeDay property refers to the number of minutes when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastWriteTime property

Newtone.ImageKit.Win.ImageKit.File.LastWriteTimeMonth Property

This property refers to the month when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastWriteTimeMonth As Integer
[C#] public int LastWriteTimeMonth {get;}

Property Value

The month when the file was last modified

Explanation

The LastWriteTimeMonth property refers to the month when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastWriteTimeSecond property

Newtone.ImageKit.Win.ImageKit.File.LastWriteTimeSecond Property

This property refers to the number of seconds when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastWriteTimeSecond As Integer
[C#] public int LastWriteTimeSecond {get;}

Property Value

The number of seconds when the file was last modified

Explanation

The LastWriteTimeSecond property refers to the number of seconds when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastWriteTimeYear property

Newtone.ImageKit.Win.ImageKit.File.LastWriteTimeYear Property

This property refers to the year when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastWriteTimeYear As Integer
[C#] public int LastWriteTimeYear {get;}

Property Value

The year when the file was last modified

Explanation

The LastWriteTimeYear property refers to the year when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LoadPage property

Newtone.ImageKit.Win.ImageKit.File.LoadPage Property

This property sets the page to be loaded when a multi-page image file (FPX or TIFF) image is loaded.

[Visual Basic] Public Property LoadPage As Integer
[C#] public int LoadPage {get; set;}

Property Value

The number of the page of a mutli-page image file.

The first page is 0. (For FPX format the base image is also 0)

Explanation

The LoadPage property sets the page to be loaded when a multi-page image file (FPX or TIFF) image is loaded.

In the TIFF file formats, numerous images can be stored in one multi-page image file. In the FPX file format, images of different resolutions can be stored in one multi-resolution image file.

The LoadPage property is used when loading a particular page from a multi-page image file into the memory. If there is no page set in the LoadPage property, after executing the LoadImageFromFile method or the LoadImageFromRawData method, False(0) is returned.

To use FPX files, you must have the appropriate ImageKit.NET3 plugin Dll files (Win32 Dlls).

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


MinIsBlack property

Newtone.ImageKit.Win.ImageKit.File.MinIsBlack Property

This property sets whether Tiff images, saved in 1 bit color, will be saved in white-mode monochrome or black-mode monochrome

[Visual Basic] Public Property MinIsBlack As Boolean
[C#] public bool MinIsBlack {get; set;}

Property Value

Value | Explanation
True (default) | Tiff images saved in 1 bit color will be white-mode monochrome (0 = black)
False | Tiff images saved in 1 bit color will be black-mode monochrome (0 = white)

Explanation

The MinIsBlack property sets whether Tiff images, saved in 1 bit color, will be saved in white-mode monochrome or black-mode monochrome. When this property is True, the PhotometricInterpretation tag value is 1, which means that black=0 and the image is "white-mode" monochrome. When this property is False, the PhotometricInterpretation tag value is 0, which means that white=0 and the image is "black-mode" monochrome.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


RawData property

Newtone.ImageKit.Win.ImageKit.File.RawData Property

This property refers to the byte array of raw image data to be loaded or saved.

[Visual Basic] Public Property RawData As Byte()
[C#] public byte[] RawData {get; set;}

Property Value

A byte array of the raw image data

Explanation

The RawData property refers to the byte array of raw image data to be loaded or saved.

After executing the LoadRawDataFromFile method, the raw data is set to this property. After executing the SaveRawDataToFile method, the raw data set to this property is saved to a file.

To disable the image referred to by this property, please set null (in Visual Basic, Nothing) to this property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


VectorHeight property

Newtone.ImageKit.Win.ImageKit.File.VectorHeight Property

This property sets the height of a vector image when the image is loaded.

[Visual Basic] Public Property VectorHeight As Integer
[C#] public int VectorHeight {get; set;}

Property Value

The VectorHeight property sets the height of the vector image (in pixels). Default value is 0.

Explanation

The VectorHeight property property sets the height of a vector image when the image is loaded.

For EMF and WMF images

If the VectorHeight property or the VectorWidth property is set to a value of 0 or less, the size defined in each file header will be used.

Note: When the vector image is loaded, the ratio of the height and width of the original image is maintained and the largest pixel size of the image is scaled within the area defined by the VectorHeight and VectorWidth properties.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


VectorWidth property

Newtone.ImageKit.Win.ImageKit.File.VectorWidth Property

This property sets the width of a vector image when the image is loaded.

[Visual Basic] Public Property VectorWidth As Integer
[C#] public int VectorWidth {get; set;}

Property Value

The VectorWidth property sets the width of the vector image (in pixels). Default value is 0.

Explanation

The VectorWidth property sets the width of a vector image when the image is loaded.

For EMF and WMF images

If the VectorHeight property or the VectorWidth property is set to a value of 0 or less, the size defined in each file header will be used.

Note: When the vector image is loaded, the ratio of the height and width of the original image is maintained and the largest pixel size of the image is scaled within the area defined by the VectorHeight property or the VectorWidth properties.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


AppendTiffImage Method

Newtone.ImageKit.Win.ImageKit.File.AppendTiffImage Method

This method adds a page to the end of a multipage tiff and saves it to file.

[Visual Basic] Public Function AppendTiffImage(Val As Newtone.ImageKit.SaveFileType, SaveImage As Image) As Boolean
[C#] public bool AppendTiffImage(Newtone.ImageKit.SaveFileType Val, Image SaveImage);

Parameters

Val
The image format of the saved image (of type Newtone.ImageKit.SaveFileType)

SaveImage
The image to be saved

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The AppendTiffImage method adds a page to the end of a multipage tiff and saves it to file. The image set in the SaveImage parameter will be added as the last page in the Tiff file set in the FileName property. If no image file is set in the FileName property then the AppendTiffImage will save the image set in the SaveImage parameter as a single page Tiff image.

Then AppendTiffImage method is enabled when a Tiff image format is set in the Val parameter. It is possible for different pages in the multipage Tiff file to have different Tiff compression formats. If a file format other than a Tiff format is chosen for the Val parameter, or if the image file set in the FileName property is not a Tiff file, then the AppendTiffImage method will fail and return a value of False. The image set in the SaveImage parameter need not be a Tiff image but there are issues regarding the bitcount that must be considered. See explanation below.

When the SaveImage parameter contains a valid image:
The image set in the SaveImage parameter will be appended to and saved in the location set in the FileName property.

When the SaveImage parameter is null (Nothing in VisualBasic):
The image referred to by the ImageKit.LayerNumber property (i.e. If LayerNumber = -1, then the image set in the ImageKit.Image property or if LayerNumber = 0 thru 99, then the image set in the ImageKit.Layer(LayerNumber).Image property) will be appended to the image set in the FileName property and saved.

Regarding tiff compression and image bitcounts:
Depending on the tiff compression choosen, images with certain bitcounts may not be able to be saved. In this case, errors may result. Below is a table listing the tiff compression and the bitcounts that are possible with that compression

Format | Compatible Bitcount
Tiff (Uncompressed) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32.
Tiff (Group 3-1D) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32. Important: On Windows Vista, only 1 bit images are supported. All other bitcounts will fail
Tiff (Group 4) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32. Important: On Windows Vista, only 1 bit images are supported. All other bitcounts will fail
Tiff (Packbits) | 1, 24.
Tiff (LZW) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32.

Tiff Group3-1D are the same format as MH. Tiff Group4 are the same format as MMR.
In Uncompressed and LZW formats, 16 bit images are converted to 24 bit images.

Examples

The following code will load a 1 bit BMP image, convert it to a Tiff G4 image and append it to the end of a multipage Tiff file

[Visual Basic.NET]
ImagKit1.File.FileName = "1bitBMP.bmp"
If ImagKit1.File.LoadImageFromFile() = False Then Exit Sub

ImagKit1.File.FileName = "MultiTiff.tif" 'The multipage tiff file where the image is appended and saved
ImagKit1.File.AppendTiffImage(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, Nothing)

[Visual C#.NET]
ImagKit1.File.FileName = "1bitBMP.bmp";
if (!ImagKit1.File.LoadImageFromFile()) return;

ImagKit1.File.FileName = "MultiTiff.tif"; //The multipage tiff file where the image is appended and saved
ImagKit1.File.AppendTiffImage(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, null);

Also See

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CMYKBmpPlaneFileLoad method

Newtone.ImageKit.Win.ImageKit.File.CMYKBmpPlaneFileLoad Method

This method loads a bmp file that has been saved in seperate CMYK planes.

[Visual Basic] Public Function CMYKBmpPlaneFileLoad(CFileName As String, MFileName As String, YFileName As String, KFileName As String) As Boolean
[C#] public bool CMYKBmpPlaneFileLoad(string CFileName, string MFileName, string YFileName, string KFileName);

Parameters

CFileName
The filename of the C plane image to be loaded

MFileName
The filename of the M plane image to be loaded

YFileName
The filename of the Y plane image to be loaded

KFileName
The filename of the K plane image to be loaded

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CMYKBmpPlaneFileLoad method loads a bmp file that has been saved in seperate CMYK planes. The individual CMYK plane images must be 8 bit grayscale. The output image will be 24 bit color.

If successful, the output image will be set in the Image property or the Layer(LayerNumber).Imgae property according to the value set in the LayerNumber property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CMYKBmpPlaneFileSave method

Newtone.ImageKit.Win.ImageKit.File.CMYKBmpPlaneFileSave Method

This method saves a raster image into seperate CMYK planes. The saved images are in BMP format.

[Visual Basic] Public Function CMYKBmpPlaneFileSave(CFileName As String, MFileName As String, YFileName As String, KFileName As String, SaveImage As Image) As Boolean
[C#] public bool CMYKBmpPlaneFileSave(string CFileName, string MFileName, string YFileName, string KFileName, Image SaveImage);

Parameters

CFileName
The filename of the saved C plane image

MFileName
The filename of the saved M plane image

YFileName
The filename of the saved Y plane image

KFileName
The filename of the saved K plane image

SaveImage
The saved image

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CMYKBmpPlaneFileSave method saves a raster image into seperate CMYK planes. The saved images are in BMP format.

When the SaveImage parameter contains a valid image handle

The image set in the SaveImage parameter will be saved as four seperate images each corresponding to the various CMYK planes.

When the SaveImage parameter contains 0

The image referred to by the LayerNumber property (either the image set in the Image property or the image set in the Layer(LayerNumber).Imgae property as the case may be) will be saved as four seperate images each corresponding to the various CMYK planes.

Note: When the LayerNumber property is -1, the image set in the Image property is enabled. When the LayerNumber property has values from 0 to 99, the image set in the Layer(LayerNumber).Image property is enabled.

The input image (that image set in the SaveImage parameter) must be 24 bit color. The output images (corresponding to the various CMYK planes) will be 8 bit grayscale.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


DeletePageFromMultipageTiff Method

Newtone.ImageKit.Win.ImageKit.File.DeletePageFromMultipageTiff Method

This method deletes the specified page from a multipage tiff file.

[Visual Basic] Public Function DeletePageFromMultipageTiff(deletePage As Integer) As Boolean
[C#] public bool DeletePageFromMultipageTiff(int deletePage);

Parameters

deletePage
The page to be deleted

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DeletePageFromMultipageTiff method deletes the specified page from a multipage tiff file. The Tiff file is set in the FileName property. The page to be deleted from this file is set in the deletePage parameter. This method is enabled when the deletePage parameter has a value of 1 or more and the image set in the FileName property has a page corresponding to that number.

If the image set in the FileName property is not a valid Tiff image or if the deletePage parameter has a value of 0 or less or if the number a pages in the Tiff file is less than the value set in the deletePage parameter then this method will fail and return False.

Also See

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDeleteFile Methods

This method deletes the file on the FTP server.

Overload List

This method deletes a file on an FTP server specifying the remote URI.

[Visual Basic] Public Function FtpDeleteFile(String) As Boolean
[C#] public bool FtpDeleteFile(string)

This method deletes a file on an FTP server specifying the remote URI.

[Visual Basic] Public Function FtpDeleteFile(System.Uri) As Boolean
[C#] public bool FtpDeleteFile(System.Uri)

This method deletes a file on an FTP server specifying the host name and the remote URI.

[Visual Basic] Public Function FtpDeleteFile(String, String) As Boolean
[C#] public bool FtpDeleteFile(string, string)

This method deletes a file on an FTP server specifying the host name and the remote URI, and the port number.

[Visual Basic] Public Function FtpDeleteFile(String, String, Integer) As Boolean
[C#] public bool FtpDeleteFile(string, string, int)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDeleteFile Method

This method deletes a file on an FTP server specifying the remote URI.

[Visual Basic] Public Function FtpDeleteFile(ByVal remoteAddress As String) As Boolean
[C#] public bool FtpDeleteFile(string remoteAddress);

Parameters

remoteAddress

URI

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDeleteFile method deletes a file on an FTP server specifying the remote URI.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = ImageKit.File.FtpDeleteFile("ftp://www.newtone.co.jp/test/test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = ImageKit.File.FtpDeleteFile("ftp://www.newtone.co.jp/test/test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDeleteFile Method

This method deletes a file on an FTP server specifying the remote URI.

[Visual Basic] Public Function FtpDeleteFile(ByVal remoteAddress As System.Uri) As Boolean
[C#] public bool FtpDeleteFile(System.Uri remoteAddress);

Parameters

remoteAddress
URI

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDeleteFile method deletes a file on an FTP server specifying the remote URI.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = ImageKit.File.FtpDeleteFile(New Uri("ftp://www.newtone.co.jp/test/test.jpg"))

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = ImageKit.File.FtpDeleteFile(new Uri("ftp://www.newtone.co.jp/test/test.jpg"));

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDeleteFile Method

This method deletes a file on an FTP server specifying the host name and the remote URI.

[Visual Basic] Public Function FtpDeleteFile(ByVal remoteHost As String, ByVal remotePath As String) As Boolean
[C#] public bool FtpDeleteFile(string remoteHost, string remotePath);

Parameters

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDeleteFile method deletes a file on an FTP server specifying the host name and the remote URI..

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Deletes a file
Ret = ImageKit.File.FtpDeleteFile("www.newtone.co.jp", "test/test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Deletes a file
Ret = ImageKit.File.FtpDeleteFile("www.newtone.co.jp", "test/test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDeleteFile Method

This method deletes a file on an FTP server specifying the host name, the remote URI, and the port number.

[Visual Basic] Public Function FtpDeleteFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal remotePort As Integer) As Boolean
[C#] public bool FtpDeleteFile(string remoteHost, string remotePath, int remotePort);

Parameters

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

remotePort
IP port number

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDeleteFile method deletes a file on an FTP server specifying the host name, the remote URI, and the port number.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user","password")
'Deletes the file
Ret = ImageKit.File.FtpDeleteFile("www.newtone.co.jp", "test/test.jpg",21)

[C#]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = ImageKit.File.FtpDeleteFile("www.newtone.co.jp", "test/test.jpg", 21);

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFile Methods

These methods download a file from an FTP server.

Overload List

This method downloads a file from an FTP server specifying the remote URI and the local filename.

[Visual Basic] Public Function FtpDownloadFile(String, String) As Boolean
[C#] public bool FtpDownloadFile(string, string)

This method downloads a file from an FTP server specifying the remote URI and the local filename

[Visual Basic] Public Function FtpDownloadFile(System.Uri, String) As Boolean
[C#] public bool FtpDownloadFile(System.Uri, string)

This method downloads a file from an FTP server specifying the host name, the remote URI and the local filename

[Visual Basic] Public Function FtpDownloadFile(String, String, String) As Boolean
[C#] public bool FtpDownloadFile(string, string, string)

This method downloads a file from an FTP server specifying the host name, the remote URI, the port number, and the local filename

[Visual Basic] Public Function FtpDownloadFile(String, String, Integer, String) As Boolean
[C#] public bool FtpDownloadFile(string, string, int, string)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFile Method

This method downloads a file from an FTP server specifying the remote URI, and the local filename.

[Visual Basic] Public Function FtpDownloadFile(ByVal remoteAddress As String, ByVal localFileName As String) As Boolean
[C#] public bool FtpDownloadFile(string remoteAddress, string localFileName);

Parameters

remoteAddress
The URI of the file to be downloaded

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDownloadFile method downloads a file from an FTP server specifying the remote URI, and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Downloads the file
Ret = ImageKit.File.FtpDownloadFile("ftp://www.newtone.co.jp/test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Downloads the file
Ret = ImageKit.File.FtpDownloadFile("ftp://www.newtone.co.jp/test/test.jpg", @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFile Method

This method downloads a file from an FTP server specifying the remote URI, and the local filename.

[Visual Basic] Public Function FtpDownloadFile(ByVal remoteAddress As System.Uri, ByVal localFileName As String) As Boolean
[C#] public bool FtpDownloadFile(System.Uri remoteAddress, string localFileName);

Parameters

remoteAddress
The URI of the file to be downloaded

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDownloadFile method downloads a file from an FTP server specifying the remote URI, and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Downloads the file
Ret = ImageKit.File.FtpDownloadFile(New Uri("ftp://www.newtone.co.jp/test/test.jpg"), "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Downloads the file
Ret = ImageKit.File.FtpDownloadFile(new Uri("ftp://www.newtone.co.jp/test/test.jpg"), @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFile Method

This method downloads a file from an FTP server specifying the host name, the remote URI, and the local filename.

[Visual Basic] Public Function FtpDownloadFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal localFileName As String) As Boolean
[C#] public bool FtpDownloadFile(string remoteHost, string remotePath, string localFileName);

Parameters

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDownloadFile method downloads a file from an FTP server specifying the host name, the remote URI, and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'User name and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Downloads the file
Ret = ImageKit.File.FtpDownloadFile("www.newtone.co.jp", "test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//User name and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Downloads the file
Ret = ImageKit.File.FtpDownloadFile("www.newtone.co.jp", "test/test.jpg", @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFile Method

This method downloads a file from an FTP server specifying the host name, the remote URI, the port number, and the local filename.

[Visual Basic] Public Function FtpDownloadFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal remotePort As Integer, ByVal localFileName As String) As Boolean
[C#] public bool FtpDownloadFile(string remoteHost, string remotePath, int remotePort, string localFileName);

Parameters

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

remotePort
IP port number

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDownloadFile method downloads a file from an FTP server specifying the host name, the remote URI, the port number, and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'User name and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Downloads the file
Ret = ImageKit.File.FtpDownloadFile("www.newtone.co.jp", "test/test.jpg", 21, "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//User name and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Downloads the file
Ret = ImageKit.File.FtpDownloadFile("www.newtone.co.jp", "test/test.jpg", 21, @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDownloadFileToByteArray method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFileToByteArray Method

These methods download data from a file on the server to a byte array.

List of overloaded methods

Downloads data in a byte array from the remote server specified by the URI.

[Visual Basic] Public Function FtpDownloadFileToByteArray(String) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(string)

Downloads data in a byte array from the remote server specified by the URI.

[Visual Basic] Public Function FtpDownloadFileToByteArray(System.Uri) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(System.Uri)

Downloads data in a byte array from the remote server specified by a host name and path.

[Visual Basic] Public Function FtpDownloadFileToByteArray(String, String) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(string, string)

Downloads data in a byte array from the remote server specified by a host name, path, and port number.

[Visual Basic] Public Function FtpDownloadFileToByteArray(String, String, Integer) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(string, string, int)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDownloadFileToByteArray method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFileToByteArray Method

This method downloads a file on the remote server to a byte array

[Visual Basic] Public Function FtpDownloadFileToByteArray(ByVal remoteAddress As String) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(string remoteAddress);

Parameters

remoteAddress

The URI to the download file on the remote server

Return Value

Returns data in a byte array if successful, otherwise returns null (Nothing in Visual Basic)

Explanation

The FtpDownloadFileToByteArray method downloads a file on the remote server to a byte array

This method is enabled for FTP protocol.

Example:

[Visual Basic.NET]

Dim Data As Byte()
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Passive mode
ImageKit.File.FtpPassive = True
'Downloads the file to byte array
Data =
                ImageKit.File.FtpDownloadFileToByteArray("ftp://www.newtone.co.jp/test/test.jpg")

[Visual C#.NET]

byte[] Data;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Passive mode
ImageKit.File.FtpPassive = true;
//Downloads the file to byte array
Data =
                ImageKit.File.FtpDownloadFileToByteArray("ftp://www.newtone.co.jp/test/test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit

</html


FtpDownloadFileToByteArray method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFileToByteArray Method

This method downloads a file on the remote server to a byte array

[Visual Basic] Public Function FtpDownloadFileToByteArray(ByVal remoteAddress As System.Uri) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(System.Uri remoteAddress);

Parameters

remoteAddress

The URI to the download file on the remote server

Return Value

Returns data in a byte array if successful, otherwise returns null (Nothing in Visual Basic)

Explanation

The FtpDownloadFileToByteArray method downloads a file on the remote server to a byte array

This method is enabled for FTP protocol.

Example

[Visual Basic.NET]

Dim Data As Byte()
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Passive mode
ImageKit.File.FtpPassive = True
'Downloads the file to byte array
Data = ImageKit.File.FtpDownloadFileToByteArray(New Uri("ftp://www.newtone.co.jp/test/test.jpg"))

[Visual C#.NET]

byte[] Data;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Passive mode
ImageKit.File.FtpPassive = true;
//Downloads the file to byte array
Data = ImageKit.File.FtpDownloadFileToByteArray(new Uri("ftp://www.newtone.co.jp/test/test.jpg"));

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDownloadFileToByteArray method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFileToByteArray Method

This method downloads data in a byte array from the remote server specified by a host name and path.

[Visual Basic] Public Function FtpDownloadFileToByteArray(ByVal remoteHost As String, ByVal remotePath As String) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(string remoteHost, string remotePath);

Parameters

remoteHost

DNS style name or IP Address

remotePath

Path on the remote server

Return Value

Returns data in a byte array if successful, otherwise returns null (Nothing in Visual Basic)

Explanation

The FtpDownloadFileToByteArray method downloads data in a byte array from the remote server specified by a host name and path.

This method is enabled for FTP protocol.

Example

[Visual Basic.NET]

Dim Data As Byte()
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Passive mode
ImageKit.File.FtpPassive = True
'Downloads the file to byte array
Data = ImageKit.File.FtpDownloadFileToByteArray("www.newtone.co.jp", "test/test.jpg")

[Visual C#.NET]

byte[] Data;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Passive mode
ImageKit.File.FtpPassive = true;
//Downloads the file to byte array
Data = ImageKit.File.FtpDownloadFileToByteArray("www.newtone.co.jp", "test/test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDownloadFileToByteArray method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFileToByteArray Method

This method downloads data in a byte array from the remote server specified by a host name, path, and port number.

[Visual Basic] Public Function FtpDownloadFileToByteArray(ByVal remoteHost As String, ByVal remotePath As String, ByVal remotePort As Integer) As Byte()
[C#] public byte[] FtpDownloadFileToByteArray(string remoteHost, string remotePath, int remotePort);

Parameters

remoteHost

DNS style name or IP Address

remotePath

Path on the remote server

remotePort

IP port number

Return Value

Returns True if successful, otherwise returns False

Explanation

The FtpDownloadFileToByteArray method downloads data in a byte array from the remote server specified by a host name, path, and port number.

This method is enabled for FTP protocol.

Example

[Visual Basic.NET]

Dim Data As Byte()
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Passive mode
ImageKit.File.FtpPassive = True
'Downloads the file to byte array
Data = ImageKit.File.FtpDownloadFileToByteArray("www.newtone.co.jp", "test/test.jpg", 21)

[Visual C#.NET]

byte[] Data;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Passive mode
ImageKit.File.FtpPassive = true;
//Downloads the file to byte array
Data = ImageKit.File.FtpDownloadFileToByteArray("www.newtone.co.jp", "test/test.jpg", 21);

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpRenameFile method

Newtone.ImageKit.Win.ImageKit.File.FtpRenameFile Methods

These methods rename a file that exists on the FTP server.

Overload List

This method renames a file on an FTP server specifying the remote URI and the new remote filename.

[Visual Basic] Public Function FtpRenameFile(String, String) As Boolean
[C#] public bool FtpRenameFile(string, string)

This method renames a file on an FTP server specifying the remote URI and the new remote filename.

[Visual Basic] Public Function FtpRenameFile(System.Uri, String) As Boolean
[C#] public bool FtpRenameFile(System.Uri, string)

This method renames a file on an FTP server specifying the host, the remote URI and the new remote filename.

[Visual Basic] Public Function FtpRenameFile(String, String, String) As Boolean
[C#] public bool FtpRenameFile(string, string, string)

This method renames a file on an FTP server specifying the host name, the remote URI, the port number and the new remote filename

[Visual Basic] Public Function FtpRenameFile(String, String, Integer, String) As Boolean
[C#] public bool FtpRenameFile(string, string, int, string)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpRenameFile method

Newtone.ImageKit.Win.ImageKit.File.FtpRenameFile Method

This method renames a file on an FTP server specifying the remote URI and the new remote filename.
[Visual Basic] Public Function FtpRenameFile(ByVal remoteAddress As String, ByVal newRemotePath As String) As Boolean
[C#] public bool FtpRenameFile(string remoteAddress, string newRemotePath);

Parameters

remoteAddress
URI

newRemotePath
The new remote filename

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpRenameFile method renames a file on an FTP server specifying the remote URI and the new remote filename. This method is enabled for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret
As Boolean 'Username
and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Renames the file
Ret = ImageKit.File.FtpRenameFile("ftp://www.newtone.co.jp/test/test.jpg", "test/test1.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Renames the file
Ret = ImageKit.File.FtpRenameFile("ftp://www.newtone.co.jp/test/test.jpg", "test/test1.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpRenameFile method

Newtone.ImageKit.Win.ImageKit.File.FtpRenameFile Method

This method renames a file on an FTP server specifying the remote URI and the new remote filename.
[Visual Basic] Public Function FtpRenameFile(ByVal remoteAddress As System.Uri, ByVal newRemotePath As String) As Boolean
[C#] public bool FtpRenameFile(System.Uri remoteAddress, string newRemotePath);

Parameters

remoteAddress
URI

newRemotePath
The new remote filename

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpRenameFile method renames a file on an FTP server specifying the remote URI and the new remote filename. This method is enabled for the FTP proptocol.

Example

 [Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Renames the file
Ret = ImageKit.File.FtpRenameFile(New Uri("ftp://www.newtone.co.jp/test/test.jpg"), "test/test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Renames the file
Ret = ImageKit.File.FtpRenameFile(new Uri("ftp://www.newtone.co.jp/test/test.jpg"), "test/test1.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpRenameFile method

Newtone.ImageKit.Win.ImageKit.File.FtpRenameFile Method

This method renames a file on an FTP server specifying the host, the remote URI and the new remote filename.
[Visual Basic] Public Function FtpRenameFile(ByVal remoteHost As String, ByVal oldRemotePath As String, ByVal newRemotePath As String) As Boolean
[C#] public bool FtpRenameFile(string remoteHost, string oldRemotePath, string newRemotePath);

Parameters

remoteHost
Domain name in DNS style, or IP address

oldRemotePath
The remote URI

newRemotePath
The new remote filename

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpRenameFile method renames a file on an FTP server specifying the host name, the remote URI and the new remote filename. This method is enabled for the FTP proptocol.

Example

 [Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Renames the file
Ret = ImageKit.File.FtpRenameFile("www.newtone.co.jp", "test/test.jpg", "test/test1.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Renames the file
Ret = ImageKit.File.FtpRenameFile("www.newtone.co.jp", "test/test.jpg", "test/test1.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpRenameFile method

Newtone.ImageKit.Win.ImageKit.File.FtpRenameFile Method

This method renames a file on an FTP server specifying the host name, the remote URI, the port number and the new remote filename
[Visual Basic] Public Function FtpRenameFile(ByVal remoteHost As String, ByVal oldRemotePath As String, ByVal remotePort As Integer, ByVal newRemotePath As String) As Boolean
[C#] public bool FtpRenameFile(string remoteHost, string oldRemotePath, int remotePort, string newRemotePath);

Parameters

remoteHost
Domain name in DNS style, or IP address

oldRemotePath
The remote URI

remotePort
The IP port number

newRemotePath
The new remote filename

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpRenameFile method renames a file on an FTP server specifying the host name, the remote URI, the port number and the new remote filename. This method is enabled for the FTP proptocol.

Example

 [Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Renames the file
Ret = ImageKit.File.FtpRenameFile("www.newtone.co.jp", "test/test.jpg", 21,"test/test1.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Renames the file
Ret = ImageKit.File.FtpRenameFile("www.newtone.co.jp", "test/test.jpg", 21, "test/test1.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadByteArrayToFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadByteArrayToFile Method

These methods upload data in a byte array to a file on the remote server.

List of overloaded methods

Uploads data in a byte array to a file on the remote server specified by the URI

[Visual Basic] Public Function FtpUploadByteArrayToFile(String, Byte()) As Boolean
[C#] public bool FtpUploadByteArrayToFile(string, byte[])

Uploads data in a byte array to a file on the remote server specified by the URI

[Visual Basic] Public Function FtpUploadByteArrayToFile(System.Uri, Byte()) As Boolean
[C#] public bool FtpUploadByteArrayToFile(System.Uri, byte[])

Uploads data in a byte array to a file on the remote server specified by a host name and path.

[Visual Basic] Public Function FtpUploadByteArrayToFile(String, String, Byte()) As Boolean
[C#] public bool FtpUploadByteArrayToFile(string, string, byte[])

Uploads data in a byte array to a file on the remote server specified by a host name, path, and port number.

[Visual Basic] Public Function FtpUploadByteArrayToFile(String, String, Integer, Byte()) As Boolean
[C#] public bool FtpUploadByteArrayToFile(string, string, int, byte[])

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadByteArrayToFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadByteArrayToFile Method

This method uploads data in a byte array to a file on the remote server specified by the URI

[Visual Basic] Public Function FtpUploadByteArrayToFile(ByVal remoteAddress As String, ByVal data As Byte()) As Boolean
[C#] public bool FtpUploadByteArrayToFile(string remoteAddress, byte[] data);

Parameters

remoteAddress

The Upload URI

data

Data in a byte array

Return Value

Returns True if successful, otherwise returns False

Explanation

The FtpUploadByteArrayToFile method uploads data in a byte array to a file on the remote server specified by the URI

This method is enabled for FTP protocol.

Example

[Visual Basic.NET]

Dim Ret As Boolean
'Username and password
ImageKit1.File.FtpCredentials = New NetworkCredential("user", "password")
'Passive mode
ImageKit1.File.FtpPassive = True
Ret = ImageKit1.File.FtpUploadByteArrayToFile("ftp://www.newtone.co.jp/test/test.jpg", data)

[Visual C#.NET]

bool Ret;
//Username and password
ImageKit1.File.FtpCredentials = new NetworkCredential("user", "password");
//Passive mode
ImageKit1.File.FtpPassive = true;
Ret = ImageKit1.File.FtpUploadByteArrayToFile("ftp://www.newtone.co.jp/test/test.jpg", data);

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadByteArrayToFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadByteArrayToFile Method

This method uploads data in a byte array to a file on the remote server specified by a URI.

[Visual Basic] Public Function FtpUploadByteArrayToFile(ByVal remoteAddress As System.Uri, ByVal data As Byte()) As Boolean
[C#] public bool FtpUploadByteArrayToFile(System.Uri remoteAddress, byte[] data);

Parameters

remoteAddress

The upload Uri

data

The data in byte array

Return Value

Returns True if successful, otherwise returns False

Explanation

The FtpUploadByteArrayToFile method uploads data in a byte array to a file on the remote server specified by a URI.

The method is enabled for FTP protocol.

Example

[Visual Basic.NET]

Dim Ret As Boolean
'Username and password
ImageKit1.File.FtpCredentials = New NetworkCredential("user", "password")
'Passive mode
ImageKit1.File.FtpPassive = True
Ret = ImageKit1.File.FtpUploadByteArrayToFile(New
                Uri("ftp://www.newtone.co.jp/test/test.jpg"), data)

[Visual C#.NET]

bool Ret;
//Username and password
ImageKit1.File.FtpCredentials = new NetworkCredential("user", "password");
//Passive mode
ImageKit1.File.FtpPassive = true;
Ret = ImageKit1.File.FtpUploadByteArrayToFile(new
                Uri("ftp://www.newtone.co.jp/test/test.jpg"), data);

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadByteArrayToFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadByteArrayToFile Method

This method uploads a byte array to a file on the remote server specified by a host name and path.

[Visual Basic] Public Function FtpUploadByteArrayToFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal data As Byte()) As Boolean
[C#] public bool FtpUploadByteArrayToFile(string remoteHost, string remotePath, byte[] data);

Parameters

remoteHost

DNS style domain name or IP address

remotePath

Path to the file on the remote server

data

Data in byte array

Return Value

Returns True if successful, otherwise returns False

Explanation

The FtpUploadByteArrayToFile method uploads a byte array to a file on the remote server specified by a host name and path.

This method is enabled for FTP protocol.

Example

[Visual Basic.NET]

Dim Ret As Boolean
'Username and password
ImageKit1.File.FtpCredentials = New NetworkCredential("user", "password")
'Passive mode
ImageKit1.File.FtpPassive = True
Ret = ImageKit1.File.FtpUploadByteArrayToFile("www.newtone.co.jp", "test/test.jpg", data)

[Visual C#.NET]

bool Ret;
//Username and password
ImageKit1.File.FtpCredentials = new NetworkCredential("user", "password");
//Passive mode
ImageKit1.File.FtpPassive = true;
Ret = ImageKit1.File.FtpUploadByteArrayToFile("www.newtone.co.jp", "test/test.jpg", data);

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadByteArrayToFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadByteArrayToFile Method

This method uploads data in a byte array to a file on the remote server specified by a host name, path, and port number.

[Visual Basic] Public Function FtpUploadByteArrayToFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal remotePort As Integer, ByVal data As Byte()) As Boolean
[C#] public bool FtpUploadByteArrayToFile(string remoteHost, string remotePath, int remotePort, byte[] data);

Parameters

remoteHost

DNS style domain name or IP Address

remotePath

Remote path to file on the server

remotePort

IP port number

data

Data in byte array

Return Value

Returns True if successful, otherwise returns False

Explanation

The FtpUploadByteArrayToFile method uploads data in a byte array to a file on the remote server specified by a host name, path, and port number.

This method is enabled for FTP protocol.

Example

[Visual Basic.NET]

Dim Ret As Boolean
'Username and password
ImageKit1.File.FtpCredentials = New NetworkCredential("user", "password")
'Passive mode
ImageKit1.File.FtpPassive = True
Ret = ImageKit1.File.FtpUploadByteArrayToFile("www.newtone.co.jp",
                "test/test.jpg", 21, data)

[Visual C#.NET]

bool Ret;
//Username and password
ImageKit1.File.FtpCredentials = new NetworkCredential("user", "password");
//Passive mode
ImageKit1.File.FtpPassive = true;
Ret = ImageKit1.File.FtpUploadByteArrayToFile("www.newtone.co.jp",
                "test/test.jpg", 21, data);

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadFile Methods

These methods upload a file to an FTP server.

Overload List

This method uploads a file to an FTP server specifying the remote URI and the local filename.

[Visual Basic] Public Function FtpUploadFile(String, String) As Boolean
[C#] public bool FtpUploadFile(string, string)

This method uploads a file to an FTP server specifying the remote URI and the local filename.

[Visual Basic] Public Function FtpUploadFile(System.Uri, String) As Boolean
[C#] public bool FtpUploadFile(System.Uri, string)

This method uploads a file to an FTP server specifying the host name, the remote URI, and the local filename.

[Visual Basic] Public Function FtpUploadFile(String, String, String) As Boolean
[C#] public bool FtpUploadFile(string, string, string)

This method uploads a file to an FTP server with specifying the host name, the remote URI, the port number, and the local filename.

[Visual Basic] Public Function FtpUploadFile(String, String, Integer, String) As Boolean
[C#] public bool FtpUploadFile(string, string, int, string)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadFile Method

This method uploads a file to an FTP server specifying the remote URI and the local filename.

[Visual Basic] Public Function FtpUploadFile(ByVal remoteAddress As String, ByVal localFileName As String) As Boolean
[C#] public bool FtpUploadFile(string remoteAddress, string localFileName);

Parameters

remoteAddress
The URI where the file will be uploaded

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpUploadFile method uploads a file to an FTP server specifying the remote URI and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Uploads the file
Ret = ImageKit.File.FtpUploadFile("ftp://www.newtone.co.jp/test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Uploads the file
Ret = ImageKit.File.FtpUploadFile("ftp://www.newtone.co.jp/test/test.jpg", @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadFile Method

This method uploads a file to an FTP server specifying the remote URI and the local filename.

[Visual Basic] Public Function FtpUploadFile(ByVal remoteAddress As System.Uri, ByVal localFileName As String) As Boolean
[C#] public bool FtpUploadFile(System.Uri remoteAddress, string localFileName);

Parameters

remoteAddress
The URI where the file will be uploaded

localFileName
The filename and path of the local file to be uploaded

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpUploadFile method uploads a file to an FTP server specifying the remote URI and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Uploads the file
Ret = ImageKit.File.FtpUploadFile(New Uri("ftp://www.newtone.co.jp/test/test.jpg"), "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Uploads the file
Ret = ImageKit.File.FtpUploadFile(new Uri("ftp://www.newtone.co.jp/test/test.jpg"), @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadFile Method

This method uploads a file to an FTP server specifying the host name, the remote URI, and the local filename.

[Visual Basic] Public Function FtpUploadFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal localFileName As String) As Boolean
[C#] public bool FtpUploadFile(string remoteHost, string remotePath, string localFileName);

Parameters

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpUploadFile method uploads a file to an FTP server specifying the host name, the remote URI, and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Uploads the file
Ret = ImageKit.File.FtpUploadFile("www.newtone.co.jp", "test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Uploads the file
Ret = ImageKit.File.FtpUploadFile("www.newtone.co.jp", "test/test.jpg", @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadFile Method

This method uploads a file to an FTP server with specifying the host name, the remote URI, the port number, and the local filename.

[Visual Basic] Public Function FtpUploadFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal remotePort As Integer, ByVal localFileName As String) As Boolean
[C#] public bool FtpUploadFile(string remoteHost, string remotePath, int remotePort, string localFileName);

Parameters

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

remotePort
IP port number

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpUploadFile method uploads a file to an FTP server with specifying the host name, the remote URI, the port number, and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Uploads the file
Ret = ImageKit.File.FtpUploadFile("www.newtone.co.jp", "test/test.jpg", 21, "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Uploads the file
Ret = ImageKit.File.FtpUploadFile("www.newtone.co.jp", "test/test.jpg", 21, @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


GetImageFileType method

Newtone.ImageKit.Win.ImageKit.File.GetImageFileType Method

This method retrieves information about the image and sets this into the following properties:
Comment, CreationTimeDay, CreationTimeHour, CreationTimeMinute, CreationTimeMonth, CreationTimeSecond, CreationTimeYear, Exif, FileBitCount, FileHeight, FileWidth, FileImageSize, FileMaxPage, FileSize, FileType, FileWidthByte, FileXdpi, FileYdpi, LastAccessTimeDay, LastAccessTimeHour, LastAccessTimeMinute, LastAccessTimeMonth, LastAccessTimeSecond, LastAccessTimeYear, LastWriteTimeDay, LastWriteTimeHour, LastWriteTimeMinute, LastWriteTimeMonth, LastWriteTimeSecond, LastWriteTimeYear

[Visual Basic] Public Function GetImageFileType() As Boolean
[C#] public bool GetImageFileType();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetImageFileType method retrieves information about the image and sets this into the following properties:
Comment, CreationTimeDay, CreationTimeHour, CreationTimeMinute, CreationTimeMonth, CreationTimeSecond, CreationTimeYear, Exif, FileBitCount, FileHeight, FileWidth, FileImageSize, FileMaxPage, FileSize, FileType, FileWidthByte, FileXdpi, FileYdpi, LastAccessTimeDay, LastAccessTimeHour, LastAccessTimeMinute, LastAccessTimeMonth, LastAccessTimeSecond, LastAccessTimeYear, LastWriteTimeDay, LastWriteTimeHour, LastWriteTimeMinute, LastWriteTimeMonth, LastWriteTimeSecond, LastWriteTimeYear

To execute this method the appropriate value must first be set into the FileName property. If the image is a multi-page image file then the LoadPage property must also be set. If the image is a multi-page image file then properties other than FileMaxPage and FileSize will relate to the page specified in the LoadPage property. For all image file formats except TIFF, the Comment property relates to the whole image file, regardless of whether it is a multi-page image file or not. For more details, please refer to the specific property information.

Note: Even if the file format is supported, if no value has been set then that property will return a 0 or an empty string.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


GetImageFileTypeFromRawData method

Newtone.ImageKit.Win.ImageKit.File.GetImageFileTypeFromRawData Method

This method retrieves information from the raw image data and sets that information into the following properties:
Comment, CreationTimeDay, CreationTimeHour, CreationTimeMinute, CreationTimeMonth, CreationTimeSecond, CreationTimeYear, Exif, FileBitCount, FileHeight, FileWidth, FileImageSize, FileMaxPage, FileSize, FileType, FileWidthByte, FileXdpi, FileYdpi

[Visual Basic] Public Function GetImageFileTypeFromRawData() As Boolean
[C#] public bool GetImageFileTypeFromRawData();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetImageFileTypeFromRawData method retrieves information from the raw image data and sets that information into the following properties:
Comment, CreationTimeDay, CreationTimeHour, CreationTimeMinute, CreationTimeMonth, CreationTimeSecond, CreationTimeYear, Exif, FileBitCount, FileHeight, FileWidth, FileImageSize, FileMaxPage, FileSize, FileType, FileWidthByte, FileXdpi, FileYdpi

To execute this method the appropriate value must first be set into the RawData and LoadPage property. If the image is a multi-page image file then properties other than FileMaxPage and FileSize will relate to the page specified in the LoadPage property. For all image file formats except TIFF, the Comment property relates to the whole image file, regardless of whether it is a multi-page image file or not. For more details, please refer to the specific property information.

Note: Even if the file format is supported, if no value has been set then that property will return a 0 or an empty string.

This method is the same as retrieving information from the image file using the GetImageFileType, however the properties related to "File Created", "File Accessed", and "File Modified" will have a value of 0.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDeleteFile Methods

This method deletes a file from an Http server.

Overload List

This method deletes a file from an Http server specifying the remote URI.

[Visual Basic] Public Function HttpDeleteFile(String) As Boolean
[C#] public bool HttpDeleteFile(string)

This method deletes a file from an Http server specifying the remote URI.

[Visual Basic] Public Function HttpDeleteFile(System.Uri) As Boolean
[C#] public bool HttpDeleteFile(System.Uri)

This method deletes a file from an Http server specifying the protocol scheme, the host name and remote URI.

[Visual Basic] Public Function HttpDeleteFile(String, String, String) As Boolean
[C#] public bool HttpDeleteFile(string, string, string)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDeleteFile Method

This method deletes a file from an Http server specifying the remote URI.

[Visual Basic] Public Function HttpDeleteFile(ByVal remoteAddress As String) As Boolean
[C#] public bool HttpDeleteFile(string remoteAddress);

Parameters

remoteAddress
URI

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpDeleteFile method deletes a file from an Http server specifying the remote URI.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = ImageKit.File.HttpDeleteFile("http://www.newtone.co.jp/test/test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = ImageKit.File.HttpDeleteFile("http://www.newtone.co.jp/test/test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDeleteFile Method

This method deletes a file from an Http server specifying the remote URI.

[Visual Basic] Public Function HttpDeleteFile(ByVal remoteAddress As System.Uri) As Boolean
[C#] public bool HttpDeleteFile(System.Uri remoteAddress);

Parameters

remoteAddress
URI

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpDeleteFile method deletes a file from an Http server specifying the remote URI.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = ImageKit.File.HttpDeleteFile(New Uri("http://www.newtone.co.jp/test/test.jpg"))

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = ImageKit.File.HttpDeleteFile(new Uri("http://www.newtone.co.jp/test/test.jpg"));

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDeleteFile Method

This method deletes a file from an Http server specifying the protocol scheme, the host name and remote URI

[Visual Basic] Public Function HttpDeleteFile(ByVal scheme As String, ByVal remoteHost As String, ByVal remotePath As String) As Boolean
[C#] public bool HttpDeleteFile(string scheme, string remoteHost, string remotePath);

Parameters

scheme
Internet access protocol ("http" or "https")

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpDeleteFile method deletes a file from an Http server specifying the protocol scheme, the host name and remote URI.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = ImageKit.File.HttpDeleteFile("http", "www.newtone.co.jp", "test/test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = ImageKit.File.HttpDeleteFile("http", "www.newtone.co.jp", "test/test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDownloadFile Methods

This method downloads a file from an Http server.

Overload List

This method downloads a file from an Http server specifying the remote URI and a local filename.

[Visual Basic] Public Function HttpDownloadFile(String, String) As Boolean
[C#] public bool HttpDownloadFile(string, string)

This method downloads a file from an Http server specifying the remote URI and a local filename

[Visual Basic] Public Function HttpDownloadFile(System.Uri, String) As Boolean
[C#] public bool HttpDownloadFile(System.Uri, string)

This method downloads a file from an Http server specifying the potocol scheme, the host name, the remote URI, and a local filename.

[Visual Basic] Public Function HttpDownloadFile(String, String, String, String) As Boolean
[C#] public bool HttpDownloadFile(string, string, string, string)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDownloadFile Method

This method downloads a file from an Http server specifying the remote URI and a local filename

[Visual Basic] Public Function HttpDownloadFile(ByVal remoteAddress As String, ByVal localFileName As String) As Boolean
[C#] public bool HttpDownloadFile(string remoteAddress, string localFileName);

Parameters

remoteAddress
The URI of the file on the server

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpDownloadFile method downloads a file from an Http server specifying the remote URI and a local filename

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Downloads the file
Ret = ImageKit.File.HttpDownloadFile("http://www.newtone.co.jp/test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Downloads the file
Ret = ImageKit.File.HttpDownloadFile("http://www.newtone.co.jp/test/test.jpg", @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDownloadFile Method

This method downloads a file from an Http server specifying the remote URI and a local filename

[Visual Basic] Public Function HttpDownloadFile(ByVal remoteAddress As System.Uri, ByVal localFileName As String) As Boolean
[C#] public bool HttpDownloadFile(System.Uri remoteAddress, string localFileName);

Parameters

remoteAddress
The URI of the file on the server

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpDownloadFile method downloads a file from an Http server specifying the remote URI and a local filename

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Downloads the file
Ret = ImageKit.File.HttpDownloadFile(New Uri("http://www.newtone.co.jp/test/test.jpg"), "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Downloads the file
Ret = ImageKit.File.HttpDownloadFile(new Uri("http://www.newtone.co.jp/test/test.jpg"), @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDownloadFile Method

This method downloads a file from an Http server specifying the potocol scheme, the host name, the remote URI, and a local filename.

[Visual Basic] Public Function HttpDownloadFile(ByVal scheme As String, ByVal remoteHost As String, ByVal remotePath As String, ByVal localFileName As String) As Boolean
[C#] public bool HttpDownloadFile(string scheme, string remoteHost, string remotePath, string localFileName);

Parameters

scheme
Internet access protocol ("http" or "https")

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

localFileName
Local file name

Return Value

Returns True if successful. Returns False if successful.

Explanation

The HttpDownloadFile method downloads a file from an Http server specifying the potocol scheme, the host name, the remote URI, and a local filename.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Downloads the file
Ret = ImageKit.File.HttpDownloadFile("http", "www.newtone.co.jp", "test/test.jpg", @"c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Downloads the file
Ret = ImageKit.File.HttpDownloadFile("http", "www.newtone.co.jp", "test/test.jpg", @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDownloadFileToByteArray method

Newtone.ImageKit.Win.ImageKit.File.HttpDownloadFileToByteArray Method

These methods download a file to byte array from the remote server.

List of overloaded methods

Downloads a file to byte array from the remote server specified by the URI

[Visual Basic] Public Function HttpDownloadFileToByteArray(String) As Byte()
[C#] public byte[] HttpDownloadFileToByteArray(string)

Downloads a file to byte array from the remote server specified by the URI

[Visual Basic] Public Function HttpDownloadFileToByteArray(System.Uri) As Byte()
[C#] public byte[] HttpDownloadFileToByteArray(System.Uri)

Downloads a file to byte array from the remote server specified by a scheme, host name, and path.

[Visual Basic] Public Function HttpDownloadFileToByteArray(String, String, String) As Byte()
[C#] public byte[] HttpDownloadFileToByteArray(string, string, string)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDownloadFileToByteArray method

Newtone.ImageKit.Win.ImageKit.File.HttpDownloadFileToByteArray Method

This method downloads a file to byte array from the remote server specified by the URI

[Visual Basic] Public Function HttpDownloadFileToByteArray(ByVal remoteAddress As String) As Byte()
[C#] public byte[] HttpDownloadFileToByteArray(string remoteAddress);

Parameters

remoteAddress

The URI to the download file on the remote server

Return Value

Returns data in a byte array if successful, otherwise returns null (Nothing in Visual Basic)

Explanation

The HttpDownloadFileToByteArray method downloads a file to byte array from the remote server specified by the URI.

This method is enabled for HTTP or HTTPS protocol.

Example

[Visual Basic.NET]

Dim Data As Byte()
'Username and password
ImageKit1.File.HttpCredentials = New NetworkCredential("user", "password")
'Downloads file
Data =
                ImageKit1.File.HttpDownloadFileToByteArray("http://www.newtone.co.jp/test/test.jpg")

[Visual C#.NET]

byte[] Data;
//Username and password
ImageKit1.File.HttpCredentials = new NetworkCredential("user", "password");
//Downloads file
Data =
                ImageKit1.File.HttpDownloadFileToByteArray("http://www.newtone.co.jp/test/test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDownloadFileToByteArray method

Newtone.ImageKit.Win.ImageKit.File.HttpDownloadFileToByteArray Method

This method downloads a file to byte array from the remote server specified by the URI

[Visual Basic] Public Function HttpDownloadFileToByteArray(ByVal remoteAddress As System.Uri) As Byte()
[C#] public byte[] HttpDownloadFileToByteArray(System.Uri remoteAddress);

Parameters

remoteAddress

The URI to the download file on the remote server

Return Value

Returns data in a byte array if successful, otherwise returns null (Nothing in Visual Basic)

Explanation

The HttpDownloadFileToByteArray method downloads a file to byte array from the remote server specified by the URI.

This method is enabled for HTTP or HTTPS protocol.

Example

[Visual Basic.NET]

Dim Data As Byte()
'Username and password
ImageKit1.File.HttpCredentials = New NetworkCredential("user", "password")
'Downloads file
Data = ImageKit1.File.HttpDownloadFileToByteArray(New
                Uri("http://www.newtone.co.jp/test/test.jpg"))

[Visual C#.NET]

byte[] Data;
//Username and password
ImageKit1.File.HttpCredentials = new NetworkCredential("user", "password");
//Downloads file
Data = ImageKit1.File.HttpDownloadFileToByteArray(new
                Uri("http://www.newtone.co.jp/test/test.jpg"));

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDownloadFileToByteArray method

Newtone.ImageKit.Win.ImageKit.File.HttpDownloadFileToByteArray Method

This method downloads a file to byte array from the remote server specified by a scheme, host name, and path.

[Visual Basic] Public Function HttpDownloadFileToByteArray(ByVal scheme As String, ByVal remoteHost As String, ByVal remotePath As String) As Byte()
[C#] public byte[] HttpDownloadFileToByteArray(string scheme, string remoteHost, string remotePath);

Parameters

scheme

Internet Access Protocol ("http" or "https")

remoteHost

DNS style domain name or IP address

remotePath

Remote server name

Return Value

Returns data in a byte array if successful, otherwise returns null (Nothing in Visual Basic)

Explanation

The HttpDownloadFileToByteArray method downloads a file to byte array from the remote server specified by a scheme, host name, and path.

This method is enabled for HTTP or HTTPS protocol.

Example:

[Visual Basic.NET]

Dim Data As Byte()
'Username and password
ImageKit1.File.HttpCredentials = New NetworkCredential("user", "password")
'Download file
Data = ImageKit1.File.HttpDownloadFileToByteArray("http", "www.newtone.co.jp", "test/test.jpg")

[Visual C#.NET]

byte[] Data;
//Username and password
ImageKit1.File.HttpCredentials = new NetworkCredential("user", "password");
//Download file
Data = ImageKit1.File.HttpDownloadFileToByteArray("http", "www.newtone.co.jp", "test/test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpUploadByteArrayToFile method

Newtone.ImageKit.Win.ImageKit.File.HttpUploadByteArrayToFile Method

These methods upload data in a byte array to a file on the remote server.

List of overloaded methods

Uploads data in a byte array to a file on the remote server specified by the URI

[Visual Basic] Public Function HttpUploadByteArrayToFile(String, Byte()) As Boolean
[C#] public bool HttpUploadByteArrayToFile(string, byte[])

Uploads data in a byte array to a file on the remote server specified by the URI

[Visual Basic] Public Function HttpUploadByteArrayToFile(System.Uri, Byte()) As Boolean
[C#] public bool HttpUploadByteArrayToFile(System.Uri, byte[])

Uploads data in a byte array to a file on the remote server specified by a scheme, host name, and path.

[Visual Basic] Public Function HttpUploadByteArrayToFile(String, String, String, String) As Boolean
[C#] public bool HttpUploadByteArrayToFile(string, string, string, string)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpUploadByteArrayToFile method

Newtone.ImageKit.Win.ImageKit.File.HttpUploadByteArrayToFile Method

This method uploads data in a byte array to a file on the remote server specified by the URI

[Visual Basic] Public Function HttpUploadByteArrayToFile(ByVal remoteAddress As String, ByVal data As Byte()) As Boolean
[C#] public bool HttpUploadByteArrayToFile(string remoteAddress, byte[] data);

Parameters

remoteAddress

Upload URI

data

Data in byte array

Return Value

Returns True if successful, otherwise returns False

Explanation

The HttpUploadByteArrayToFile method uploads data in a byte array to a file on the remote server specified by the URI

This method is enabled for HTTP or HTTPS protocol.

Example

[Visual Basic.NET]

Dim Ret As Boolean
'Username and password
ImageKit1.File.HttpCredentials = New NetworkCredential("user", "password")
'When using "POST"
ImageKit1.File.HttpMethod = "POST"
ImageKit1.File.HttpHeaders.Set("Content-Disposition", "form-data; name=""file""; filename=""test.jpg""")
Ret = ImageKit1.File.HttpUploadByteArrayToFile("http://www.newtone.co.jp/test/upload.php", data)
'When using "PUT"
'ImageKit1.File.HttpMethod = "PUT"
'Ret = ImageKit1.File.HttpUploadByteArrayToFile("http://www.newtone.co.jp/test/test.jpg", data)

[Visual C#.NET]

bool Ret;
//Username and password
ImageKit1.File.HttpCredentials = new NetworkCredential("user", "password");
//When using "POST"
ImageKit1.File.HttpMethod = "POST";
ImageKit1.File.HttpHeaders.Set("Content-Disposition", "form-data; name=\"file\"; filename=\"test.jpg\"");
Ret = ImageKit1.File.HttpUploadByteArrayToFile("http://www.newtone.co.jp/test/upload.php", data);
//When using "PUT"
//ImageKit1.File.HttpMethod = "PUT";
//Ret = ImageKit1.File.HttpUploadByteArrayToFile("http://www.newtone.co.jp/test/test.jpg", data);

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpUploadByteArrayToFile method

Newtone.ImageKit.Win.ImageKit.File.HttpUploadByteArrayToFile Method

This method uploads data in a byte array to a file on the remote server specified by the URI

[Visual Basic] Public Function HttpUploadByteArrayToFile(ByVal remoteAddress As System.Uri, ByVal data As Byte()) As Boolean
[C#] public bool HttpUploadByteArrayToFile(System.Uri remoteAddress, byte[] data);

Parameters

remoteAddress

Upload URI

data

Data in byte array

Return Value

Returns True if successful, otherwise returns False

Explanation

The HttpUploadByteArrayToFile method uploads data in a byte array to a file on the remote server specified by the URI

This method is enabled for HTTP or HTTPS protocol.

Example

[Visual Basic.NET]

Dim Ret As Boolean
'Username and password
ImageKit1.File.HttpCredentials = New NetworkCredential("user", "password")
'When using "POST"
ImageKit1.File.HttpMethod = "POST"
ImageKit1.File.HttpHeaders.Set("Content-Disposition", "form-data;
                name=""file""; filename=""test.jpg""")
Ret = ImageKit1.File.HttpUploadByteArrayToFile(New
                Uri("http://www.newtone.co.jp/test/upload.php"), data)
'When using "PUT"
'ImageKit1.File.HttpMethod = "PUT"
'Ret = ImageKit1.File.HttpUploadByteArrayToFile(New
                Uri("http://www.newtone.co.jp/test/test.jpg"), data)

[Visual C#.NET]

bool Ret;
//Username and password
ImageKit1.File.HttpCredentials = new NetworkCredential("user", "password");
//When using "POST"
ImageKit1.File.HttpMethod = "POST";
ImageKit1.File.HttpHeaders.Set("Content-Disposition", "form-data;
                name=\"file\"; filename=\"test.jpg\"");
Ret = ImageKit1.File.HttpUploadByteArrayToFile(new
                Uri("http://www.newtone.co.jp/test/upload.php"), data);
//When using "PUT"
//ImageKit1.File.HttpMethod = "PUT";
//Ret = ImageKit1.File.HttpUploadByteArrayToFile(new
                Uri("http://www.newtone.co.jp/test/test.jpg"), data);

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpUploadByteArrayToFile method

Newtone.ImageKit.Win.ImageKit.File.HttpUploadByteArrayToFile Method

This method uploads data in a byte array to a file on the remote server specified by a scheme, host name, and path.

[Visual Basic] Public Function HttpUploadByteArrayToFile(ByVal scheme As String, ByVal remoteHost As String, ByVal remotePath As String, ByVal ByVal data As Byte()) As Boolean
[C#] public bool HttpUploadByteArrayToFile(string scheme, string remoteHost, string remotePath, byte[] data);

Parameters

scheme

Internet Access Protocol ("http" or "https")

remoteHost

DNS style domain name or IP address

remotePath

The upload path on the remote server

data

Data in byte array

Return Value

Returns True if successful, otherwise returns False

Explanation

The HttpUploadByteArrayToFile method uploads data in a byte array to a file on the remote server specified by a scheme, host name, and path.

This method is enabled for HTTP or HTTPS protocol.

Example

[Visual Basic.NET]

Dim Ret As Boolean
'Username and password
ImageKit1.File.HttpCredentials = New NetworkCredential("user", "password")
'When using "POST"
ImageKit1.File.HttpMethod = "POST"
ImageKit1.File.HttpHeaders.Set("Content-Disposition", "form-data;
                name=""file""; filename=""test.jpg""")
Ret = ImageKit1.File.HttpUploadByteArrayToFile("http", "www.newtone.co.jp",
                "test/upload.php", data)
'When using "PUT"
'ImageKit1.File.HttpMethod = "PUT"
'Ret = ImageKit1.File.HttpUploadByteArrayToFile("http", "www.newtone.co.jp",
                "test/test.jpg", data)

[Visual C#.NET]

bool Ret;
//Username and password
ImageKit1.File.HttpCredentials = new NetworkCredential("user", "password");
//When using "POST"
ImageKit1.File.HttpMethod = "POST";
ImageKit1.File.HttpHeaders.Set("Content-Disposition", "form-data;
                name=\"file\"; filename=\"test.jpg\"");
Ret = ImageKit1.File.HttpUploadByteArrayToFile("http", "www.newtone.co.jp",
                "test/upload.php", data);
//When using "PUT"
//ImageKit1.File.HttpMethod = "PUT";
//Ret = ImageKit1.File.HttpUploadByteArrayToFile("http", "www.newtone.co.jp",
                "test/test.jpg", data);

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpUploadFile Method

This method uploads a file to an Http server.

Overload List

This method uploads a file to an Http server specifying the remote URI and the local filename.

[Visual Basic] Public Function HttpUploadFile(String, String) As Boolean
[C#] public bool HttpUploadFile(string, string)

This method uploads a file to an Http server specifying the remote URI and the local filename.

[Visual Basic] Public Function HttpUploadFile(System.Uri, String) As Boolean
[C#] public bool HttpUploadFile(System.Uri, string)

This method uploads a file to an Http server specifying the access protocol, the remote host, the remote URI, and the local filename.

[Visual Basic] Public Function HttpUploadFile(String, String, String, String) As Boolean
[C#] public bool HttpUploadFile(string, string, string, string)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpUploadFile Method

This method uploads a file to an Http server specifying the remote URI and the local filename.

[Visual Basic] Public Function HttpUploadFile(ByVal remoteAddress As String, ByVal localFileName As String) As Boolean
[C#] public bool HttpUploadFile(string remoteAddress, string localFileName);

Parameters

remoteAddress
The URI where the file is to be uploaded

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpUploadFile method uploads a file to an Http server specifying the remote URI and the local filename.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Uploads the file
Ret = ImageKit.File.HttpUploadFile("http://www.newtone.co.jp/test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Uploads the file
Ret = ImageKit.File.HttpUploadFile("http://www.newtone.co.jp/test/test.jpg", @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpUploadFile Method

This method uploads a file to an Http server specifying the remote URI and the local filename.

[Visual Basic] Public Function HttpUploadFile(ByVal remoteAddress As System.Uri, ByVal localFileName As String) As Boolean
[C#] public bool HttpUploadFile(System.Uri remoteAddress, string localFileName);

Parameters

remoteAddress
The URI where the file is to be uploaded

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpUploadFile method uploads a file to an Http server specifying the remote URI and the local filename.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Uploads the file
Ret = ImageKit.File.HttpUploadFile(New Uri("http://www.newtone.co.jp/test/test.jpg"), "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Uploads the file
Ret = ImageKit.File.HttpUploadFile(new Uri("http://www.newtone.co.jp/test/test.jpg"), @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpUploadFile Method

This method uploads a file to an Http server specifying the access protocol, the remote host, the remote URI, and the local filename.

[Visual Basic] Public Function HttpUploadFile(ByVal scheme As String, ByVal remoteHost As String, ByVal remotePath As String, ByVal localFileName As String) As Boolean
[C#] public bool HttpUploadFile(string scheme, string remoteHost, string remotePath, string localFileName);

Parameters

scheme
Internet access protocol ("http" or "https")

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpUploadFile method uploads a file to an Http server specifying the access protocol, the remote host, the remote URI, and the local filename.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Uploads the file
Ret = ImageKit.File.HttpUploadFile("http", "www.newtone.co.jp", "test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Uploads the file
Ret = ImageKit.File.HttpUploadFile("http", "www.newtone.co.jp", "test/test.jpg", "c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


InsertPageIntoMultipageTiff Method

Newtone.ImageKit.Win.ImageKit.File.InsertPageIntoMultipageTiff Method

This method inserts a page into a multipage tiff.

[Visual Basic] Public Function InsertPageIntoMultipageTiff(Val As Newtone.ImageKit.SaveFileType, SaveImage As Image, insertPage As Integer) As Boolean
[C#] public bool InsertPageIntoMultipageTiff(Newtone.ImageKit.SaveFileType Val, Image SaveImage, int insertPage);

Parameters

Val
The image format of the saved image (of type Newtone.ImageKit.SaveFileType)

SaveImage
The image to be saved

insertPage
The location where the page is inserted

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The InsertPageIntoMultipageTiff method inserts a page into a multipage tiff. The image set in the SaveImage parameter will be inserted into the Tiff file set in the FileName property at the page location set in the insertPage parameter. This method is enabled when the insertPage parameter is set to 1 or more. If the value of the insertPage parameter is greater than the number of pages in the multipage Tiff, then image set in the SaveImage parameter will be added to the end of the multipage Tiff file. The new multipage tiff file will be saved in the location specified by the FileName property.

If no image file is set in the FileName property then the InsertPageIntoMultipageTiff will return False.

The InsertPageIntoMultipageTiff method is enabled when a Tiff image format is set in the Val parameter. It is possible for different pages in the multipage Tiff file to have different Tiff compression formats. If a file format other than a Tiff format is chosen for the Val parameter, if the insertPage parameter is set to 0 or less, or if the image file set in the FileName property is not a Tiff file, then the InsertPageIntoMultipageTiff method will fail and return a value of False. The image set in the SaveImage parameter need not be a Tiff image but there are issues regarding the bitcount that must be considered. See explanation below.

When the SaveImage parameter contains a valid image:
The image set in the SaveImage parameter will be inserted into the image set in the FileName property.

When the SaveImage parameter is null (Nothing in VisualBasic):
The image referred to by the ImageKit.LayerNumber property (i.e. If LayerNumber = -1, then the image set in the ImageKit.Image property or if LayerNumber = 0 thru 99, then the image set in the ImageKit.Layer(LayerNumber).Image property) will be inserted into the image set in the FileName property and saved.

Regarding tiff compression and image bitcounts:
Depending on the tiff compression choosen, images with certain bitcounts may not be able to be saved. In this case, errors may result. Below is a table listing the tiff compression and the bitcounts that are possible with that compression

Format | Compatible Bitcount
Tiff (Uncompressed) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32.
Tiff (Group 3-1D) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32. Important: On Windows Vista, only 1 bit images are supported. All other bitcounts will fail
Tiff (Group 4) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32. Important: On Windows Vista, only 1 bit images are supported. All other bitcounts will fail
Tiff (Packbits) | 1, 24.
Tiff (LZW) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32.

Tiff Group3-1D are the same format as MH. Tiff Group4 are the same format as MMR.
In Uncompressed and LZW formats, 16 bit images are converted to 24 bit images.

Examples

The following code will load a 1 bit BMP image, convert it to a Tiff G4 image and insert it into a multipage Tiff file

[Visual Basic.NET]
ImagKit1.File.FileName = "1bitBMP.bmp"
If ImagKit1.File.LoadImageFromFile() = False Then Exit Sub

ImagKit1.File.FileName = "MultiTiff.tif" 'The multipage tiff file where the image is inserted and saved
ImagKit1.File.InsertPageIntoMultipageTiff(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, Nothing, 3)

[Visual C#.NET]
ImagKit1.File.FileName = "1bitBMP.bmp";
if (!ImagKit1.File.LoadImageFromFile()) return;

ImagKit1.File.FileName = "MultiTiff.tif"; //The multipage tiff file where the image is inserted and saved
ImagKit1.File.InsertPageIntoMultipageTiff(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, null, 3);

Also See

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LoadImageFromFile method

Newtone.ImageKit.Win.ImageKit.File.LoadImageFromFile Method

This method loads image data from a file.

[Visual Basic] Public Function LoadImageFromFile() As Boolean
[C#] public bool LoadImageFromFile() ;

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The LoadImageFromFile method loads image data from a file. The FileName property sets the file to be loaded. If successful, the image data is set in either the Image property or the Layer(LayerNumber).Imgae property as determined by the value set in the LayerNumber property. If the image is a multi-page image file, set the page to be loaded in the LoadPage property. Executing this method will set image information in the same properties as executing the GetImageFileType method.

The supported image formats are BMP, JPEG, TIFF (uncompressed, GROUP3-1D, GROUP4, PACKBITS, LZW, JPEG compression (partially not supported)), PNG, GIF, JPEG2000, FPX, WMF, EMF.

For 16 bit BMP and TIFF files:
16 bit BMP and TIFF files can be loaded but the loaded image data will converted to 32 bit image data. Saving the data will result in a 32 bit image.

For BMP compression, JPEG2000 and FPX formats:
Because standard .NET Framework does not support these image formats, the ImageKit.NET3 Plugin (Win32 Dll files) are required.

For WMF and EMF files:
WMF and EMF images are treated as raster images after loading.

Regarding FlashPix:
Flashpix image files are multi-resolution image files with a tiled composition. Flashpix files store image data in a hierarchy from the original image at the highest level. Each subsequent level contains the same image with horizontal and vertical resolution half that of the image in the level above. This allows editing and printing at the optimum resolution. Each resolution image is divided in to 64x64 tiles. Each tiled image can be uncompressed, JPEG compression, or single color compression.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LoadImageFromRawData method

Newtone.ImageKit.Win.ImageKit.File.LoadImageFromRawData Method

This method loads DIB image data from raw data.

[Visual Basic] Public Function LoadImageFromRawData() As Boolean
[C#] public bool LoadImageFromRawData() ;

Parameters

None

Return Value

Returns True if successful. Returns False if successful.

Explanation

The LoadImageFromRawData method uses the raw image data set into the RawData property and converts it to DIB image data. This DIB image data is then set into either the Image or the Layer(LayerNumber).Image property depending on the value of the LayerNumber property.

When the raw image data is a multipage image, set the page to be loaded in the LoadPage property.

Executing the LoadImageFromRawData method will set image information in the same properties as executing the GetImageFileTypeFromRawData method.

The supported image formats are BMP, JPEG, TIFF (uncompressed, GROUP3-1D, GROUP4, PACKBITS, LZW, JPEG compression (partially not supported)), PNG, GIF, JPEG2000, FPX, WMF, EMF.

For 16 bit BMP and TIFF files:
16 bit BMP and TIFF files can be loaded but the loaded image data will converted to 32 bit image data. Saving the data will result in a 32 bit image.

For BMP compression, JPEG2000 and FPX formats:
Because standard .NET Framework does not support these image formats, the ImageKit.NET3 Plugin (Win32 Dll files) are required.

For WMF and EMF files:
WMF and EMF images are treated as raster images after loading.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LoadRawDataFromFile method

Newtone.ImageKit.Win.ImageKit.File.LoadRawDataFromFile Method

This method loads image data from a file without altering it (i.e. converting it to DIB data)

[Visual Basic] Public Function LoadRawDataFromFile() As Boolean
[C#] public bool LoadRawDataFromFile();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The LoadRawDataFromFile method loads image data from a file without altering it. The file to be loaded is determined by the FileName property. The loaded image data is set into the RawData property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LoadRawDataFromStream method

Newtone.ImageKit.Win.ImageKit.File.LoadRawDataFromStream Method

This method loads an image from stream

[Visual Basic] Public Function LoadRawDataFromStream(Val As MemoryStream)
[C#] public void LoadRawDataFromStream(MemoryStream Val);

Parameters

Val
The data loaded from the MemoryStream

Return Value

None

Explanation

This method loads an image from stream. The data returned in the Val parameter is set into the RawData property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


MergeTiffImages Method

Newtone.ImageKit.Win.ImageKit.File.MergeTiffImages Method

This method combines tiff files contained in a specified folder and saves them as a single multipage tiff file.

[Visual Basic] Public Function MergeTiffImages(Directory As String, Append As Boolean) As Boolean
[C#] public bool MergeTiffImages(string Directory, bool Append);

Parameters

Directory
The name of the folder containing the image files to be combined (full path)

Append
Sets whether or not existing files will be appended or overwritten

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The MergeTiffImages method combines tiff files contained in a specified folder and saves them as a single multipage tiff file.

The Directory parameter sets the folder where the tiff files reside. The FileName property sets the name of the multipage tiff file that is created. The order of the pages of the created multipage tiff file is determined by the order of the filenames of the individual tiff files contained in the Directory folder.

If the file set in the FileName property is an existing file, then if the Append parameter is true, the newly created multipage tiff file will be appended to this existing file. If the Append parameter is false, then a new file is created by overwriting the existing file.

Only images in tiff format that exist in the Directory folder be merged and saved. The tiff compression format or each tiff image will be preserved in the multipage tiff image that is created. The tiff compression formats will not be changed.

The types of tiff images that can be saved are based on the types listed in the Newtone.ImageKit.SaveFileType enumeration.

If non-tiff images exist in the specified folder, an error is not generated. Those non-tiff images will be skipped and not included in the multipage tiff file that is created.

If the specified folderhas subfolders, the tiff images in these subfolders will also be merged into the multipage tiff file.

If a multipage tiff file exists in the specified folder, each page of this multipage tiff image will be included and saved along with any other individual tiff images contained in the folder.

Also See

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


ModifyPageInMultipageTiff Method

Newtone.ImageKit.Win.ImageKit.File.ModifyPageInMultipageTiff Method

This method modifies a specified page of an existing multipage tiff file.

[Visual Basic] Public Function ModifyPageInMultipageTiff(Val As Newtone.ImageKit.SaveFileType, SaveImage As Image, modifyPage As Integer) As Boolean
[C#] public bool ModifyPageInMultipageTiff(Newtone.ImageKit.SaveFileType Val, Image SaveImage, int modifyPage);

Parameters

Val
The image format of the image used to modify the page (of type Newtone.ImageKit.SaveFileType)

SaveImage
The image used to modify the page

modifyPage
The page that is modified

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The ModifyPageInMultipageTiff method modifies a specified page of an existing multipage tiff file. The image set in the SaveImage parameter will be used to modify the page, specified by the modifyPage parameter, of an existing Tiff file set in the FileName property. This method is enabled when the modifyPage parameter is set to 1 or more. This method is only enabled when the image set into the Val parameter is a Tiff image. The compression format of each page of the multipage tiff file to be created and the compression format set in the argument Val are valid even if different compression formats are mixed. If the value of the modifyPage parameter is greater than the number of pages in the multipage Tiff, if the value of the modifyPage parameter is 0 or less, if the file set in the FileName property doesn't exist or is not a tiff file, then the ModifyPageInMultipageTiff method will fail and False will be returned.

If a valid image is set in SaveImage parameter, then that image will replace the image in the existing page specified in the modifyPage parameter.

If the SaveImage parameter is null (Nothing for VisualBasic): the LayerNumber property value will be used to specify whether the image set in the ImageKit.Image property or the layer images specified by the ImageKit.Layer(LayerNumber).Image property is used to replace the image in the existing page specified by the modifyPage parameter.
* LayerNumber = -1 sets the image in the ImageKit.Image property. LayerNumber = 0~99 sets the image in the ImageKit.Layer(LayerNumber).Image property.

Regarding tiff compression and image bitcounts:
Each compression format has its own number of bits that can be saved. Please note that an error will occur if you try to save a bit number that is outside the range of bits allowed. The following table shows the number of bits that can be saved.

Format | Compatible Bitcount
Tiff (Uncompressed) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32.
Tiff (Group 3-1D) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32. Important: On Windows Vista, only 1 bit images are supported. All other bitcounts will fail
Tiff (Group 4) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32. Important: On Windows Vista, only 1 bit images are supported. All other bitcounts will fail
Tiff (Packbits) | 1, 24.
Tiff (LZW) | 1, 4, 8, 16 (16 grayscale not supported), 24, 32.

Tiff Group3-1D are the same format as MH. Tiff Group4 are the same format as MMR.
In Uncompressed and LZW formats, 16 bit images are converted to 24 bit images.

Examples

Example #1:
The following code will convert the image loaded into the PictureBox control to a Tiff image in G4 format, change it to the image on page 3 of the multipage tiff file currently loaded into the ImageKit control, and save it.

[Visual Basic.NET]
ImagKit1.File.FileName = "MultiTiff.tif" 'The saved tiff file
ImagKit1.File.ModifyPageInMultipageTiff(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, PictureBox1.Image, 3)

[Visual C#.NET]
ImagKit1.File.FileName = "MultiTiff.tif"; //The saved tiff file
ImagKit1.File.ModifyPageInMultipageTiff(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, pictureBox1.Image, 3);

Example #2:
Convert the BMP file loaded into the ImageKit control to a Tiff image in G4 format, change it to the image of page 3 of the existing multi Tiff file, and save it.

[Visual Basic.NET]
ImagKit1.File.FileName = "1bitBMP.bmp"
If ImagKit1.File.LoadImageFromFile() = False Then Exit Sub

ImagKit1.File.FileName = "MultiTiff.tif" 'The saved tiff file
ImagKit1.File.ModifyPageInMultipageTiff(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, Nothing, 3)

[Visual C#.NET]
ImagKit1.File.FileName = "1bitBMP.bmp";
if (!ImagKit1.File.LoadImageFromFile()) return;

ImagKit1.File.FileName = "MultiTiff.tif"; //The saved tiff file
ImagKit1.File.ModifyPageInMultipageTiff(Newtone.ImageKit.SaveFileType.SaveTIFFGroup4, null, 3);

Also See

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


OpenFileDialog method

Newtone.ImageKit.Win.ImageKit.File.OpenFileDialog Method

This methods displays the "Open" dialog box which includes the file preview and information functions. This dialog box is used to select an image file to be opened.

[Visual Basic] Public Function OpenFileDialog() As Boolean
[C#] public bool OpenFileDialog();

Parameters

None

Return Value

Returns True if "Open" is selected. Returns False if "Cancel" is selected.

Explanation

The OpenFileDialog method displays the "Open" dialog box which includes the file preview and information functions. This dialog box is used to select an image file to be opened.

If the Open button is clicked, then the file name and path are set into the FileName property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


RGBBmpPlaneFileLoad method

Newtone.ImageKit.Win.ImageKit.File.RGBBmpPlaneFileLoad Method

This method loads a bmp file that has been saved in seperate RGB planes.

[Visual Basic] Public Function RGBBmpPlaneFileLoad(RedFileName As String, GreenFileName As String, BlueFileName As String) As Boolean
[C#] public bool RGBBmpPlaneFileLoad(string RedFileName, string GreenFileName, string BlueFileName);

Parameters

RedFileName
The filename of the R plane image to be loaded

GreenFileName
The filename of the G plane image to be loaded

BlueFileName
The filename of the B plane image to be loaded

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBBmpPlaneFileLoad method loads a bmp file that has been saved in seperate RGB planes. The individual RGB plane images are 8 bit grayscale and the output image is 24 bit color.

If successful, the output image will be set in the Image property or the Layer(LayerNumber).Imgae property according to the value set in the LayerNumber property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


RGBBmpPlaneFileSave method

Newtone.ImageKit.Win.ImageKit.File.RGBBmpPlaneFileSave Method

This method saves a raster image into seperate RGB planes. The saved images are in BMP format.

[Visual Basic] Public Function RGBBmpPlaneFileSave(RedFileName As String, GreenFileName As String, BlueFileName As StringASaveImage As Image) As Boolean
[C#] public bool RGBBmpPlaneFileSave(string RedFileName, string GreenFileName, string BlueFileName, Image SaveImage);

Parameters

RedFileName
The filename of the saved R plane image

GreenFileName
The filename of the saved G plane image

BlueFileName
The filename of the saved B plane image

SaveImage
The image handle of the image to be saved in 3 seperate RGB planes

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBBmpPlaneFileSave method saves a raster image into seperate RGB planes. The saved images are in BMP format.

When the SaveImage parameter contains a valid image handle

The image set in the SaveImage parameter will be saved as three seperate images each corresponding to the various RGB planes.

When the SaveImage parameter contains 0

The image referred to by the LayerNumber property (either the image set in the Image property or the image set in the Layer(LayerNumber).Image property as the case may be) will be saved as three seperate images each corresponding to the various RGB planes.

Note: When the LayerNumber property is -1, the image set in the Image property is enabled. When the LayerNumber property has values from 0 to 99, the image set in the Layer(LayerNumber).Image property is enabled.

The input image (that image set in the SaveImage parameter) must be 24 bit color. The output images (corresponding to the various RGB planes) will be 8 bit grayscale.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


SaveFileDialog method

Newtone.ImageKit.Win.ImageKit.File.SaveFileDialog Method

This methods displays the "Save" dialog box which includes the file preview function. This dialog box is used to select an image file to be saved.

[Visual Basic] Public Function SaveFileDialog() As Boolean
[C#] public bool SaveFileDialog();

Parameters

None

Return Value

Returns True if "Save" is selected. Returns False if "Cancel" is selected.

Explanation

The SaveFile method displays the "Save" dialog box which includes the file preview function. This dialog box is used to select a directory and file name into which the image date is to be saved.

When the "Save" button is clicked the file name and path are set into the FileName property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


SaveImageToFile method

Newtone.ImageKit.Win.ImageKit.File.SaveImageToFile Method

This methods saves image data to a file.

[Visual Basic] Public Function SaveImageToFile(Val As Newtone.ImageKit.SaveFileType, SaveImage As Image) As Boolean
[C#] public bool SaveImageToFile(Newtone.ImageKit.SaveFileType Val, Image SaveImage) ;

Parameters

Val
The image format used to save the image
This value is of type Newtone.ImageKit.SaveFileType

SaveImage
The saved image

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SaveImageToFile method saves image data to a file.

When the SaveImage parameter contains a valid image handle

The image set in the SaveImage parameter will be saved in the location specified by the FileName property.

When the SaveImage parameter contains 0

The image referred to by the LayerNumber property (either the image set in the Image property or the image set in the Layer(LayerNumber).Image property as the case may be) will be saved in the location specified by the FileName property.

Note: When the LayerNumber property is -1, the image set in the Image property is enabled. When the LayerNumber property has values from 0 to 99, the image set in the Layer(LayerNumber).Image property is enabled.

Below is a list of other properties that should be set when saving files in the these formats...

Format | Explanation
FPX | The Comment property should be set. If the Val parameter is SaveFPXJpeg then the JpegQuality property should also be set.
GIF | The Comment property should be set.
JPEG | The Comment, JpegQuality, and JpegSubsampling properties should be set.
JPEG Progress | The Comment, JpegQuality, and JpegSubsampling properties should be set.
JPEG2000 | The Comment, JPEG2000CodeBlockHeight, JPEG2000CodeBlockWidth, JPEG2000NumResLevel, JPEG2000PrecinctHeight, JPEG2000PrecinctWidth, JPEG2000Reversible, JPEG2000Size, JPEG2000TileHeight, and JPEG2000TileWidth properties should be set.
PNG | The Comment property should be set.
TIFF | To manipulate multipage tiff files, use one of the following methods: AppendTiffImage, DeletePageFromMultipageTiff, or InsertPageIntoMultipageTiff

With certain raster image formats, it is only possible to save images of a particular bitcount. Errors can be generated if an image of unsupported bitcount is saved. Below is a list of supported bitcounts when saving each type of raster image.

Name | Explanation
BMP (Uncompressed) | 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
BMP (Compressed) | 4,8
JPEG (Standard DCT) | 24 bit color. 8 bit grayscale may be saved only with the ImageKit.NET3 Plugin (Win32 Dll files) Note: When the ImageKit.NET3 Plugin (Win32 Dll files) are present, 8 bit grayscale and 24 bit color images can be saved in JPEG. Attempting to save images of other bitcounts will result in an error. If the ImageKit.NET3 Plugin (Win32 Dll files) are not present, all images will be converted to 24 bit color and saved in JPEG.
JPEG (Progressive DCT) | 8 bit grayscale, 24
GIF | 1, 4, 8 Note: If the ImageKit.NET3 Plugin (Win32 Dll files) are not present, all images will be saved in 8 bit GIF. Additionally, all are saved in GIF89a format.
TIFF (Uncompressed) | 1, 4, 8, 16, 24 (Does not include 16 bit grayscale)
TIFF (GROUP3-1D) | 1
TIFF (GROUP4) | 1
TIFF (PACKBITS) | 1
TIFF (LZW) | 1, 4, 8, 16, 24 (Does not include 16 bit grayscale)
TIFF (JPEG) | 1, 4, 8, 16 (Does not include 16 bit grayscale), 24, 32 * Although the above bitcounts are supported, the saved image will be 24 bit color
PNG | 1, 4, 8, 24, 32
FPX (Uncompressed) | 8 bit grayscale, 24
FPX (Single Color Compressed) | 8 bit grayscale, 24
FPX (JPEG Compression) | 8 bit grayscale, 24
JPEG2000 (Part1) | 8 bit grayscale, 24
JPEG2000 (Code Stream) | 8 bit grayscale, 24

Note: The following image formats are not supported by standard .NET Framework. Therefore, the ImageKit.NET3 Plugin (Win32 Dll files) are required when saving images in: BMP Compressed, Saving Jpeg 8 bit grayscale, JpegProgressive, JPEG2000, FPX file formats.

WMF and EMF images cannot be read and displayed in standard .NET framework but rather are converted to raster image data and displayed. As such, even though the file extensions are .wmf or .emf, these images can only be saved as raster images.

Example

Sample code for converting a BMP image file into a 24 bit JPEG image file:

[Visual Basic.NET]
ImageKit1.File.FileName = "Newtone.bmp"
If ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.LoadBMP) = False Then Exit Sub
If ImageKit1.GetImageType() = False Then Exit Sub
If ImageKit1.BitCount <> 24 Then
If ImageKit1.Effect.ConvertColor(24, False, False, 0) = False Then Exit Sub
End If

ImageKit1.File.FileName = "Newtone.jpg"
ImageKit1.File.SaveImageToFile(Newtone.ImageKit.SaveFileType.SaveJPEG, Nothing)

[Visual C#.NET]
ImageKit1.File.FileName = "Newtone.bmp";
if (!ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.LoadBMP)) return;
if (!ImageKit1.GetImageType()) return;
if (ImageKit1.BitCount <> 24))
{
    if (!ImageKit1.Effect.ConvertColor(24, false, false, 0)) return;
}

ImageKit1.File.FileName = "Newtone.jpg";
ImageKit1.File.SaveImageToFile(Newtone.ImageKit.SaveFileType.SaveJPEG, null);

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


SaveImageToRawData method

Newtone.ImageKit.Win.ImageKit.File.SaveImageToRawData Method

This method saves image data as raw data.

[Visual Basic] Public Function SaveImageToRawData(Val As Newtone.ImageKit.SaveFileType, SaveImage As Image) As Boolean
[C#] public bool SaveImageToRawData(Newtone.ImageKit.SaveFileType Val, Image SaveImage) ;

Parameters

Val
The image format used to save the image
This value is of type Newtone.ImageKit.SaveFileType

SaveImage
The saved image

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SaveImageToRawData method saves image data as raw data.

When the SaveImage parameter contains a valid image handle

The image set in the SaveImage parameter will be saved as raw data and set into the RawData property.

When the SaveImage parameter contains 0

The image referred to by the LayerNumber property (either the image set in the Image property or the image set in the Layer(LayerNumber).Image property as the case may be) will be saved as raw data and set into the RawData property.

Note: When the LayerNumber property is -1, the image set in the Image property is enabled. When the LayerNumber property has values from 0 to 99, the image set in the Layer(LayerNumber).Image property is enabled.

Below is a list of other properties that should be set when saving files in the these formats...

Format | Explanation
FPX | The Comment property should be set. If the Val parameter is SaveFPXJpeg then the JpegQuality property should also be set.
GIF | The Comment properties should be set.
JPEG | The Comment, JpegQuality, and JpegSubsampling properties should be set.
JPEG Progress | The Comment, JpegQuality, and JpegSubsampling properties should be set.
JPEG2000 | The Comment, JPEG2000CodeBlockHeight, JPEG2000CodeBlockWidth, JPEG2000NumResLevel, JPEG2000PrecinctHeight, JPEG2000PrecinctWidth, JPEG2000Reversible, JPEG2000Size, JPEG2000TileHeight, and JPEG2000TileWidth properties should be set.
PNG | The Comment property should be set.
TIFF | To manipulate multipage tiff files, use one of the following methods: AppendTiffImage, DeletePageFromMultipageTiff, or InsertPageIntoMultipageTiff

Though there are differences when saving raw image data, the process is nearly the same as the SaveImageToFile method.

With certain raster image formats, it is only possible to save images of a particular bitcount. Errors can be generated if an image of unsupported bitcount is saved. Below is a list of supported bitcounts when saving each type of raster image.

Name | Explanation
BMP (Uncompressed) | 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
BMP (Compressed) | 4, 8
JPEG (Standard DCT) | 24 bit color. 8 bit grayscale may be saved only with the ImageKit.NET3 Plugin (Win32 Dll files) Note: When the ImageKit.NET3 Plugin Dll files are present, 8 bit grayscale and 24 bit color images can be saved in JPEG. Attempting to save images of other bitcounts will result in an error. If the ImageKit.NET3 Dll files are not present, all images will be converted to 24 bit color and saved in JPEG.
JPEG (Progressive DCT) | 8 bit grayscale, 24
GIF | 1, 4, 8 Note: If the ImageKit.NETs Plugin (Win32 Dll files) are not present, all images will be saved in 8 bit GIF. Additionally, all are saved in GIF89a format.
TIFF (Uncompressed) | 1, 4, 8, 16, 24 (Does not include 16 bit grayscale)
TIFF (GROUP3-1D) | 1
TIFF (GROUP4) | 1
TIFF (PACKBITS) | 1
TIFF (LZW) | 1, 4, 8, 16, 24 (Does not include 16 bit grayscale)
TIFF (JPEG) | 1, 4, 8, 16 (Does not include 16 bit grayscale), 24, 32 * Although the above bitcounts are supported, the saved image will be 24 bit color
PNG | 1, 4, 8, 24, 32
FPX (Uncompressed) | 8 bit grayscale, 24
FPX (Single Color Compressed) | 8 bit grayscale, 24
FPX (JPEG Compression) | 8 bit grayscale, 24
JPEG2000 (Part1) | 8 bit grayscale, 24
JPEG2000 (Code Stream) | 8 bit grayscale, 24

Note: The following image formats are not supported by standard .NET Framework. Therefore, the ImageKit.NET3 Plugin (Win32 Dll files) are required when saving images in: BMP Compressed, Saving Jpeg 8 bit grayscale, JpegProgressive, JPEG2000, FPX file formats.

WMF and EMF images cannot be read and displayed in standard .NET framework but rather are converted to raster image data and displayed. As such, even though the file extensions are .wmf or .emf, these images can only be saved as raster images.

Example

Sample code for converting a BMP image file into a 24 bit JPEG image file:

[Visual Basic.NET]
ImageKit1.File.FileName = "Newtone.bmp"
If ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.LoadBMP) = False Then Exit Sub
If ImageKit1.GetImageType() = False Then Exit Sub
If ImageKit1.BitCount <> 24 Then
If ImageKit1.Effect.ConvertColor(24, False, False, 0) = False Then Exit Sub
End If

ImageKit1.File.FileName = "Newtone.jpg"
ImageKit1.File.SaveImageToRawData(Newtone.ImageKit.SaveFileType.SaveJPEG, Nothing)

[Visual C#.NET]
ImageKit1.File.FileName = "Newtone.bmp";
if (!ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.LoadBMP)) return;
if (!ImageKit1.GetImageType()) return;
if (ImageKit1.BitCount <> 24))
{
  if (!ImageKit1.Effect.ConvertColor(24, false, false, 0)) return;
}

ImageKit1.File.FileName = "Newtone.jpg";
ImageKit1.File.SaveImageToRawData(Newtone.ImageKit.SaveJPEG, null);

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


SaveRawDataToFile method

Newtone.ImageKit.Win.ImageKit.File.SaveRawDataToFile Method

This methods saves raw data to a file.

[Visual Basic] Public Function SaveRawDataToFile() As Boolean
[C#] public bool SaveRawDataToFile();

Parameters

None

Return Value

Returns True if successful. Returns False if successful.

Explanation

The SaveRawDataToFile method saves raw data to a file. The raw data set in the RawData property is saved to a file set in the FileName property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


SaveRawDataToStream method

Newtone.ImageKit.Win.ImageKit.File.SaveRawDataToStream Method

This method saves the raw image data to stream.
[Visual Basic] Public Function SaveRawDataToStream() As MemoryStream
[C#] public MemoryStream SaveRawDataToStream();

Parameters

None

Return Value

Returns the content of the RawData property in a memory stream

Explanation

The SaveRawDataToStream method saves the raw image data to stream.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


YCCBmpPlaneFileLoad method

Newtone.ImageKit.Win.ImageKit.File.YCCBmpPlaneFileLoad Method

This method loads a bmp file that has been saved in seperate YCrCb planes.

[Visual Basic] Public Function YCCBmpPlaneFileLoad(YFileName As String, CrFileName As String, CbFileName As String) As Boolean
[C#] public bool YCCBmpPlaneFileLoad(string YFileName, string CrFileName, string CbFileName);

Parameters

YFileName
The filename of the Y plane image to be loaded

CrFileName
The filename of the Cr plane image to be loaded

CbFileName
The filename of the Cb plane image to be loaded

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCBmpPlaneFileLoad method loads a bmp file that has been saved in seperate YCrCb planes. The individual YCrCb plane images are 8 bit grayscale and the output image is 24 bit color.

If successful, the output image will be set in the Image property or the Layer(LayerNumber).Image property according to the value set in the LayerNumber property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


YCCBmpPlaneFileSave method

Newtone.ImageKit.Win.ImageKit.File.YCCBmpPlaneFileSave Method

This method saves a raster image into seperate YCrCb planes. The saved images are in BMP format.

[Visual Basic] Public Function YCCBmpPlaneFileSave(YFileName As String, CrFileName As String, CbFileName As String, SaveImage As Image) As Boolean
[C#] public bool YCCBmpPlaneFileSave(string YFileName, string CrFileName, string CbFileName, Image SaveImage);

Parameters

YFileName
The filename of the saved Y plane image

CrFileName
The filename of the saved Cr plane image

CbFileName
The filename of the saved Cb plane image

SaveImage
The image handle of the image to be saved in 4 seperate YCrCb planes

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCBmpPlaneFileSave method saves a raster image into seperate YCrCb planes. The saved images are in BMP format.

When the SaveImage parameter contains a valid image handle

The image set in the SaveImage parameter will be saved as three seperate images each corresponding to the various YCrCb planes.

When the SaveImage parameter contains 0

The image referred to by the LayerNumber property (either the image set in the Image property or the image set in the Layer(LayerNumber).Image property as the case may be) will be saved as three seperate images each corresponding to the various YCrCb planes.

Note: When the LayerNumber property is -1, the image set in the Image property is enabled. When the LayerNumber property has values from 0 to 99, the image set in the Layer(LayerNumber).Image property is enabled.

The input image (that image set in the SaveImage parameter) must be 24 bit color. The output images (corresponding to the various YCrCb planes) will be 8 bit grayscale.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


ImageKit.File Members

Newtone.ImageKit.Win.ImageKit.File.Exif All Members

Public Properties

Altitude0 | The altitude in meters where the image was taken. This is the numerator.
Altitude1 | The altitude in meters where the image was taken. This is the denominator.
ApertureValue0 | The numerator for the lens aperature value
ApertureValue1 | The denominator for the lens aperature value
BrightnessValue0 | The numerator for the brightness value
BrightnessValue1 | The denominator for the brightness value
ColorSpace | Color space information
ComponentsConfiguration | Refers to the color of each color plane in the Exif image arranged in order from the 1st plane to the 4th plane
CompressedBitsPerPixel0 | The numerator for the compression mode used for a compressed image. (bits/pixel)
CompressedBitsPerPixel1 | The denominator for the compression mode used for a compressed image. (bits/pixel)
DateTimeDigitized | The date and time of digital data generation
DateTimeOriginal | The date and time of original data generation
ExposureBiasValue0 | The numerator for the exposure bias value
ExposureBiasValue1 | The denominator for the exposure bias value
ExposureIndex0 | The numerator for the exposure index selected on the camera or input device at the time the image was captured
ExposureIndex1 | The denominator for the exposure index selected on the camera or input device at the time the image was captured
ExposureProgram | Refers to the class of the program used by the camera to set exposure when the image was taken
ExposureTime0 | The numerator for the exposure time
ExposureTime1 | The denominator for the exposure time
FileSource | Indicates the image source
Flash | Indicates the flash firing status and the flash return status
FlashEnergy0 | The numerator for the strobe energy at the time the image was captured
FlashEnergy1 | The denominator for the strobe energy at the time the image was captured
FlashPixVersion | Refers to the version of the FlashPix format supported
FNumber0 | The numerator for the F number value
FNumber1 | The denominator for the F number value
FocalLength0 | The numerator for the focal length of the lens
FocalLength1 | The denominator for the focal length of the lens
FocalPlaneResolutionUnit | The units of measurement of the focal plane
FocalPlaneXResolution0 | The numerator of the horizontal focal plane resolution
FocalPlaneXResolution1 | The denominator of the horizontal focal plane resolution
FocalPlaneYResolution0 | The numerator of the vertical focal plane resolution
FocalPlaneYResolution1 | The denominator of the vertical focal plane resolution
GPSVersion | Refers to the GPS tag version (i.e. "2000")
ISOSpeedRatings | Indicates the ISO Speed and ISO Latitude of the camera or input device
Latitude | Refers to the latitude direction where the image was taken. (i.e. "N" or "S")
LatitudeD0 | The latitude in degrees where the image was taken. This is the numerator
LatitudeD1 | The latitude in degrees where the image was taken. This is the denominator
LatitudeM0 | The latitude in minutes where the image was taken. This is the numerator
LatitudeM1 | The latitude in minutes where the image was taken. This is the denominator
LatitudeS0 | The latitude in seconds where the image was taken. This is the numerator
LatitudeS1 | The latitude in seconds where the image was taken. This is the denominator
LightSource | Refers to the type of light source
Longitude | Refers to the longitude direction where the image was taken. (i.e. "E" or "W")
LongitudeD0 | The longitude in degrees where the image was taken. This is the numerator
LongitudeD1 | The longitude in degrees where the image was taken. This is the denominator
LongitudeM0 | The longitude in minutes where the image was taken. This is the numerator
LongitudeM1 | The longitude in minutes where the image was taken. This is the denominator
LongitudeS0 | The longitude in seconds where the image was taken. This is the numerator
LongitudeS1 | The longitude in seconds where the image was taken. This is the denominator
MainArtist | Refers to the camera owner, photographer, or creator of the primary image
MainCopyright | Refers to the copyright information for the primary image
MainDateTime | Refers to the date and time that the primary image was created
MainImageDescription | Refers to the character string giving the title of the primary image
MainMake | Refers to the manufacturer of the recording equipment that generated the primary image
MainModel | Refers to the model name or model number of the equipment that generated the primary image
MainOrientation | Refers to the image orientation of the primary image as viewed in terms of rows and columns
MainResolutionUnit | The unit of measurement for XResolution and YResolution in the primary image
MainSoftware | Refers to the name and version of the software used to generate the primary image
MainXResolution0 | Refers to the number of pixels per MainResolutionUnit in the primary image in the horizontal direction. (This value is the numerator)
MainXResolution1 | Refers to the number of pixels per MainResolutionUnit in the primary image in the horizontal direction. (This value is the denominator)
MainYCbCrPositioning | Refers to the position of chrominance components (CbCr) in relation to the luminance component (Y) in the primary image
MainYResolution0 | Refers to the number of pixels per MainResolutionUnit in the primary image in the vertical direction. (This value is the numerator)
MainYResolution1 | Refers to the number of pixels per MainResolutionUnit in the primary image in the vertical direction. (This value is the denominator)
MakerNote | Comments of the manufacturer of the Exif writer
MapDatum | Refers to the name of the map data used
MaxApertureValue0 | The numerator for the smallest F value of the lens
MaxApertureValue1 | The denominator for the smallest F value of the lens
MeteringMode | Refers to the metering mode
PixelXDimension | Refers to the width of the image
PixelYDimension | Refers to the height of the image
SceneType | Indicates the type of scene
SensingMethod | Refers to the image sensor type on the camera or input device
ShutterSpeedValue0 | The numerator for the shutter speed
ShutterSpeedValue1 | The denominator for the shutter speed
SpectralSensitivity | Refers to the spectral sensitivity of each channel of the camera used
SubjectDistance0 | The numerator for the distance to the subject
SubjectDistance1 | The denominator for the distance to the subject
SubjectLocationX | Refers to the horizontal location of the main subject in the scene
SubjectLocationY | Refers to the vertical location of the main subject in the scene
SubSecTime | Records fractions of a second for the MainDateTime property
SubSecTimeDigitized | Records fractions of a second for the DateTimeDigitized property
SubSecTimeOriginal | Records fractions of a second for the DateTimeOriginal property
ThumbnailArtist | Refers to the camera owner, photographer, or creator of the thumbnail image
ThumbnailCompression | Refers to the compression method for the thumbnail image
ThumbnailCopyright | Refers to the copyright information for the thumbnail image
ThumbnailDateTime | Refers to the date and time that the thumbnail image was created
ThumbnailImageDescription | Refers to the character string giving the title of the thumbnail image
ThumbnailMake | Refers to the manufacturer of the recording equipment that generated the thumbnail image
ThumbnailModel | Refers to the model name or model number of the equipment that generated the thumbnail image
ThumbnailOrientation | Refers to the image orientation of the thumbnail image as viewed in terms of rows and columns
ThumbnailResolutionUnit | The unit of measurement for XResolution and YResolution in the thumbnail image
ThumbnailSoftware | Refers to the name and version of the software used to generate the thumbnail image
ThumbnailXResolution0 | Refers to the number of pixels per ThumbResolutionUnit in the thumbnail image in the horizontal direction. (This value is the numerator)
ThumbnailXResolution1 | Refers to the number of pixels per ThumbResolutionUnit in the thumbnail image in the horizontal direction. (This value is the denominator)
ThumbnailYCbCrPositioning | Refers to the position of chrominance components (CbCr) in relation to the luminance component (Y) in the thumbnail image
ThumbnailYResolution0 | Refers to the number of pixels per ThumbResolutionUnit in the thumbnail image in the vertical direction. (This value is the numerator)
ThumbnailYResolution1 | Refers to the number of pixels per ThumbResolutionUnit in the thumbnail image in the vertical direction. (This value is the denominator)
UserComment | Comments or keywords that the Exif user can place on the image
UserCommentID | An identification code (8 bytes) that occurs at the start of the UserComment tag
Version | Refers to the version of the Exif Standard supported

See Also

Newtone.ImageKit.Win.ImageKit


Altitude0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.Altitude0 Property

The altitude in meters where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property Altitude0 As Integer
[C#] public int Altitude0 {get;}

Property Value

Altitude0 is the numerator for altitude in meters

Altitude1 is the denominator for altitude in meters

Altitude = Altitude0 / Altitude1

Explanation

The Altitude0 property refers to the altitude in meters where the image was taken. This is the numerator. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property is related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


Altitude1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.Altitude1 Property

The altitude in meters where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property Altitude1 As Integer
[C#] public int Altitude1 {get;}

Property Value

Altitude0 is the numerator for altitude in meters

Altitude1 is the denominator for altitude in meters

Altitude = Altitude0 / Altitude1

Explanation

The Altitude1 property refers to the altitude in meters where the image was taken. This is the denominator. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property is related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ApertureValue0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ApertureValue0 Property

The property value can be retrieved by executing the File.GetImageFileType or theFile.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ApertureValue0 As Integer
[C#] public int ApertureValue0 {get;}

Property Value

ApertureValue0 is the numerator for the lens aperature value
ApertureValue1 is the denominator for the lens aperature value
The lens aperature value (unit is the APEX value) = ApertureValue0 / ApertureValue1

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ApertureValue1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ApertureValue1 Property

The property value can be retrieved by executing the File.GetImageFileType or theFile.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ApertureValue1 As Integer
[C#] public int ApertureValue1 {get;}

Property Value

ApertureValue0 is the numerator for the lens aperature value

ApertureValue1 is the denominator for the lens aperature value

The lens aperature value (unit is the APEX value) = ApertureValue0 / ApertureValue1

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


BrightnessValue0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.BrightnessValue0 Property

This property refers to the brightness value. This is the numerator.

[Visual Basic] Public ReadOnly Property BrightnessValue0 As Integer
[C#] public int BrightnessValue0 {get;}

Property Value

BrightnessValue0 is the numerator for the brightness value

BrightnessValue1 is the denominator for the brightness value

The brightness value (unit is the APEX value) = BrightnessValue0 / BrightnessValue1

Ordinarily brightness is given in the range from -99.99 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


BrightnessValue1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.BrightnessValue1 Property

This property refers to the brightness value. This is the denominator.

[Visual Basic] Public ReadOnly Property BrightnessValue1 As Integer
[C#] public int BrightnessValue1 {get;}

Property Value

BrightnessValue0 is the numerator for the brightness value

BrightnessValue1 is the denominator for the brightness value

The brightness value (unit is the APEX value) = BrightnessValue0 / BrightnessValue1

Ordinarily brightness is given in the range from -99.99 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ColorSpace property

Newtone.ImageKit.Win.ImageKit.File.Exif.ColorSpace Property

This property refers to the color space information in the Exif image.

[Visual Basic] Public ReadOnly Property ColorSpace As Integer
[C#] public int ColorSpace {get;}

Property Value

Value | Explanation
1 | sRGB

Explanation

The ColorSpace property refers to the color space information in the Exif image.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the special characteristics of the image.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ComponentsConfiguration property

Newtone.ImageKit.Win.ImageKit.File.Exif.ComponentsConfiguration Property

This property refers to the color of each color plane in the Exif image arranged in order from the 1st plane to the 4th plane.

[Visual Basic] Public ReadOnly Property ComponentsConfiguration As String
[C#] public string ComponentsConfiguration {get;}

Property Value

Value | Explanation
0 | does not exist
1 | Y
2 | Cb
3 | Cr
4 | R
5 | G
6 | B

The default value for RGB is "4560" , for JPEG is "1230".

Explanation

The ComponentsConfiguration property refers to the color of each color plane in the Exif image arranged in order from the 1st plane to the 4th plane.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the image color planes. This tag is provided for cases when image data uses planes other than Y,Cr,Cb and to enable support of other sequences.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


CompressedBitsPerPixel0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.CompressedBitsPerPixel0 Property

This property refers to the compression mode used for a compressed Exif image. This is the numerator.

[Visual Basic] Public ReadOnly Property CompressedBitsPerPixel0 As Integer
[C#] public int CompressedBitsPerPixel0 {get;}

Property Value

CompressedBitsPerPixel0 is the numerator for the compression mode

CompressedBitsPerPixel1 is the denominator for the compression mode

The compression mode = CompressedBitsPerPixel0 / CompressedBitsPerPixel1 (bit/pixel units)

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property refers to the compression mode used for a compressed Exif image.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


CompressedBitsPerPixel1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.CompressedBitsPerPixel1 Property

This property refers to the compression mode used for a compressed Exif image. This is the denominator.

[Visual Basic] Public ReadOnly Property CompressedBitsPerPixel1 As Integer
[C#] public int CompressedBitsPerPixel1 {get;}

Property Value

CompressedBitsPerPixel0 is the numerator for the compression mode

CompressedBitsPerPixel1 is the denominator for the compression mode

The compression mode = CompressedBitsPerPixel0 / CompressedBitsPerPixel1 (bit/pixel units)

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property refers to the compression mode used for a compressed Exif image.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


DateTimeDigitized property

Newtone.ImageKit.Win.ImageKit.File.Exif.DateTimeDigitized Property

This property refers to the time when the image data was stored as digital data.

[Visual Basic] Public ReadOnly Property DateTimeDigitized As String
[C#] public string DateTimeDigitized {get;}

Property Value

DateTimeDigitized is the date and time when the image was stored as digital data.

The format is "YYYY:MM:DD HH:MM:SS" with the time shown in 24 hour format, and the date and time separated by one blank character.

Example: "1996:09:01 09:15:30"

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the date and time.

the DateTimeDigitized and the DateTimeOriginal properties refer to the time when the original image data was generated and when this data was stored as digital data. If, for example, an image was captured by a DSC (Digital Still Camera) and at the same the the file was recorded, then the DateTimeDigitized and the DateTimeOriginal will have the same contents.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


DateTimeOriginal property

Newtone.ImageKit.Win.ImageKit.File.Exif.DateTimeOriginal Property

This property refers to the time when the original image data was generated.

[Visual Basic] Public ReadOnly Property DateTimeOriginal As String
[C#] public string DateTimeOriginal {get;}

Property Value

DateTimeOriginal is the data and time when the original image data was generated.

The format is "YYYY:MM:DD HH:MM:SS" with the time shown in 24 hour format, and the date and time separated by one blank character.

Example: "1996:09:01 09:15:30"

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the date and time.

The DateTimeDigitized and the DateTimeOriginal properties refer to the time when the original image data was generated and when this data was stored as digital data. If, for example, an image was captured by a DSC (Digital Still Camera) and at the same the the file was recorded, then the DateTimeDigitized and the DateTimeOriginal will have the same contents.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ExposureBiasValue0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ExposureBiasValue0 Property

This property relates to the exposure bias. This is the numerator.

[Visual Basic] Public ReadOnly Property ExposureBiasValue0 As Integer
[C#] public int ExposureBiasValue0 {get;}

Property Value

ExposureBiasValue0 is the numerator for the exposure bias value

ExposureBiasValue1 is the denominator for the exposure bias value

The exposure bias value (unit is the APEX value) = ExposureBiasValue0 / ExposureBiasValue1

Ordinarily exposure bias is given in the range from -99.99 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ExposureBiasValue1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ExposureBiasValue1 Property

This property relates to the exposure bias. This is the denominator.

[Visual Basic] Public ReadOnly Property ExposureBiasValue1 As Integer
[C#] public int ExposureBiasValue1 {get;}

Property Value

ExposureBiasValue0 is the numerator for the exposure bias value

ExposureBiasValue1 is the denominator for the exposure bias value

The exposure bias value (unit is the APEX value) = ExposureBiasValue0 / ExposureBiasValue1

Ordinarily exposure bias is given in the range from -99.99 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ExposureIndex0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ExposureIndex0 Property

This property relates to the exposure index selected on the camera or input device at the time the image was captured. This is the numerator.

[Visual Basic] Public ReadOnly Property ExposureIndex0 As Integer
[C#] public int ExposureIndex0 {get;}

Property Value

ExposureIndex0 is the numerator for the exposure index.

ExposureIndex1 is the denominator for the exposure index.

The exposure index = ExposureIndex0 / ExposureIndex1. This indicates the exposure index selected on the camera or input device at the time the image was captured.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ExposureIndex1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ExposureIndex1 Property

This property relates to the exposure index selected on the camera or input device at the time the image was captured. This is the denominator.

[Visual Basic] Public ReadOnly Property ExposureIndex1 As Integer
[C#] public int ExposureIndex1 {get;}

Property Value

ExposureIndex0 is the numerator for the exposure index.

ExposureIndex1 is the denominator for the exposure index.

The exposure index = ExposureIndex0 / ExposureIndex1. This indicates the exposure index selected on the camera or input device at the time the image was captured.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ExposureProgram property

Newtone.ImageKit.Win.ImageKit.File.Exif.ExposureProgram Property

This property refers to the class of the program used by the camera to set exposure when the image was taken.

[Visual Basic] Public ReadOnly Property ExposureProgram As Integer
[C#] public int ExposureProgram {get;}

Property Value

Value | Explanation
0 | Not defined
1 | Manual
2 | Normal program
3 | Aperture priority
4 | Shutter priority
5 | Creative program (biased toward depth of field)
6 | Action program (biased toward fast shutter speed)
7 | Portrait mode (for clsoeup photos with the background out of focus)
8 | Landscape mode (for landscapes with the background in focus

Explanation

The ExposureProgram property refers to the class of the program used by the camera to set exposure when the image was taken.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ExposureTime0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ExposureTime0 Property

This property is the numerator for the exposure time.

[Visual Basic] Public ReadOnly Property ExposureTime0 As Integer
[C#] public int ExposureTime0 {get;}

Property Value

ExposureTime0 is the numerator for the exposure time.

ExposureTime1 is the denominator for the exposure time.

Exposure time (in seconds) = ExposureTime0 / ExposureTime1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ExposureTime1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ExposureTime1 Property

This property is the denominator for the exposure time.

[Visual Basic] Public ReadOnly Property ExposureTime1 As Integer
[C#] public int ExposureTime1 {get;}

Property Value

ExposureTime0 is the numerator for the exposure time.

ExposureTime1 is the denominator for the exposure time.

Exposure time (in seconds) = ExposureTime0 / ExposureTime1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FileSource property

Newtone.ImageKit.Win.ImageKit.File.Exif.FileSource Property

This property refers to the image source.

[Visual Basic] Public ReadOnly Property FileSource As Integer
[C#] public int FileSource {get;}

Property Value

FileSource indicates the image source. If a DSC (Digital Still Camera) recorded the image, this value will be set to 3 indicating that the image was recorded on a DSC.

Explanation

The FileSource property refers to the image source.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


Flash property

Newtone.ImageKit.Win.ImageKit.File.Exif.Flash Property

This property indicates the flash firing status and the flash return status.

[Visual Basic] Public ReadOnly Property Flash As Integer
[C#] public int Flash {get;}

Property Value

This property value is recorded when the image is taken with a strobe light (flash).

Bit 0 indicates the flash firing status, and bits 1 and 2 indicate the flash return status.

Values for bit 0 indicate whether the flash fired.

0b = Flash did not fire

1b = Flash fired

Values for bits 1 and 2 indicate the return status

00b = No strobe return detection function

01b = Reserved

10b = Strobe return light not detected

11b = Strobe return light detected

Resulting flash tag values (in hexadecimal notation)

0x0000 = Flash did not fire

0x0001 = Flash fired

0x0005 = Strobe return light not detected

0x0007 = Strobe return light detected

* In Visual Basic an &H is used instead of 0x.

Explanation

The Flash property indicates the flash firing status and the flash return status.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FlashEnergy0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FlashEnergy0 Property

This property is the numerator for the strobe energy at the time the image was captured.

[Visual Basic] Public ReadOnly Property FlashEnergy0 As Integer
[C#] public int FlashEnergy0 {get;}

Property Value

FlashEnergy0 is the numerator for the flash energy.

FlashEnergy1 is the denominator for the flash energy.

Flash energy (in BCPS) = FlashEnergy0 / FlashEnergy1. This indicates the strobe energy at the time the image was captured as measured in Beam Candle Power Seconds.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FlashEnergy1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FlashEnergy1 Property

This property is the denominator for the strobe energy at the time the image was captured.

[Visual Basic] Public ReadOnly Property FlashEnergy1 As Integer
[C#] public int FlashEnergy1 {get;}

Property Value

FlashEnergy0 is the numerator for the flash energy.

FlashEnergy1 is the denominator for the flash energy.

Flash energy (in BCPS) = FlashEnergy0 / FlashEnergy1. This indicates the strobe energy at the time the image was captured as measured in Beam Candle Power Seconds.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FlashPixVersion property

Newtone.ImageKit.Win.ImageKit.File.Exif.FlashPixVersion Property

This property refers to the version of the FlashPix format supported. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FlashPixVersion As String
[C#] public string FlashPixVersion {get;}

Property Value

FlashPixVersion is the FlashPix format version supported by a FPRX file (i.e. "1000").

Explanation

The FlashPixVersion property refers to the version of the FlashPix format supported. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif version.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FNumber0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FNumber0 Property

This property is the numerator for the F number value.

[Visual Basic] Public ReadOnly Property FNumber0 As Integer
[C#] public int FNumber0 {get;}

Property Value

FNumber0 is the numerator for the FNumber

FNumber1 is the denominator for the FNumber

The FNumber = FNumber0 / FNumber1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeMem methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FNumber1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FNumber1 Property

This property is the denominator for the F number value.

[Visual Basic] Public ReadOnly Property FNumber1 As Integer
[C#] public int FNumber1 {get;}

Property Value

FNumber0 is the numerator for the FNumber

FNumber1 is the denominator for the FNumber

The FNumber = FNumber0 / FNumber1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeMem methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FocalLength0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FocalLength0 Property

This property is the numerator for the focal length of the lens.

[Visual Basic] Public ReadOnly Property FocalLength0 As Integer
[C#] public int FocalLength0 {get;}

Property Value

FocalLength0 is the numerator for the focal length of the lens

FocalLength1 is the denominator for the focal length of the lens

The actual focal length of the lens (in mm) = FocalLength0 / FocalLength1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FocalLength1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FocalLength1 Property

This property is the numerator for the focal length of the lens.

[Visual Basic] Public ReadOnly Property FocalLength1 As Integer
[C#] public int FocalLength1 {get;}

Property Value

FocalLength0 is the numerator for the focal length of the lens

FocalLength1 is the denominator for the focal length of the lens

The actual focal length of the lens (in mm) = FocalLength0 / FocalLength1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FocalPlaneResolutionUnit property

Newtone.ImageKit.Win.ImageKit.File.Exif.FocalPlaneResolutionUnit Property

This property refers to the units of measurement for focal plane resolution in the primary and thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FocalPlaneResolutionUnit As Integer
[C#] public int FocalPlaneResolutionUnit {get;}

Property Value

The FocalPlaneResolutionUnit is the unit of measurement for FocalPlaneXResolution and FocalPlaneYResolution.

The FocalPlaneResolutionUnit is FocalPlaneXResolution0 / FocalPlaneXResolution1 and FocalPlaneYResolution0 / FocalPlaneYResolution1.

Value | Explanation
2 | Inches
3 | Centimeters

Explanation

The FocalPlaneResolutionUnit property refers to the units of measurement for focal plane resolution in the primary and thumbnail images.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FocalPlaneXResolution0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FocalPlaneXResolution0 Property

This property refers to the horizontal focal plane resolution.

[Visual Basic] Public ReadOnly Property FocalPlaneXResolution0 As Integer
[C#] public int FocalPlaneXResolution0 {get;}

Property Value

The FocalPlaneXResolution is the number of pixels in the image horizontal direction per FocalPlaneResolutionUnit on the camera focal plane.

The FocalPlaneXResolution0 is the numerator for the FocalPlaneXResolution.

The FocalPlaneXResolution1 is the denominator for the FocalPlaneXResolution.

The FocalPlaneResolutionUnit = FocalPlaneXResolution0 / FocalPlaneXResolution1

Explanation

The FocalPlaneXResolution0 property refers to the horizontal focal plane resolution.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FocalPlaneXResolution1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FocalPlaneXResolution1 Property

This property refers to the horizontal focal plane resolution. This is the denominator.

[Visual Basic] Public ReadOnly Property FocalPlaneXResolution1 As Integer
[C#] public int FocalPlaneXResolution1 {get;}

Property Value

The FocalPlaneXResolution is the number of pixels in the image horizontal direction per FocalPlaneResolutionUnit on the camera focal plane.

The FocalPlaneXResolution0 is the numerator for the FocalPlaneXResolution.

The FocalPlaneXResolution1 is the denominator for the FocalPlaneXResolution.

The FocalPlaneResolutionUnit = FocalPlaneXResolution0 / FocalPlaneXResolution1

Explanation

The FocalPlaneXResolution1 property refers to the horizontal focal plane resolution.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FocalPlaneYResolution0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FocalPlaneYResolution0 Property

This property refers to the vertical focal plane resolution.

[Visual Basic] Public ReadOnly Property FocalPlaneYResolution0 As Integer
[C#] public int FocalPlaneYResolution0 {get;}

Property Value

The FocalPlaneYResolution is the number of pixels in the image vertical direction per FocalPlaneResolutionUnit on the camera focal plane.

The FocalPlaneYResolution0 is the numerator for the FocalPlaneYResolution.

The FocalPlaneYResolution1 is the denominator for the FocalPlaneYResolution.

The FocalPlaneResolutionUnit = FocalPlaneYResolution0 / FocalPlaneYResolution1

Explanation

The FocalPlaneYResolution0 property refers to the vertical focal plane resolution.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FocalPlaneYResolution1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FocalPlaneYResolution1 Property

This property refers to the vertical focal plane resolution. This is the denominator.

[Visual Basic] Public ReadOnly Property FocalPlaneYResolution1 As Integer
[C#] public int FocalPlaneYResolution1 {get;}

Property Value

The FocalPlaneYResolution is the number of pixels in the image vertical direction per FocalPlaneResolutionUnit on the camera focal plane.

The FocalPlaneYResolution0 is the numerator for the FocalPlaneYResolution.

The FocalPlaneYResolution1 is the denominator for the FocalPlaneYResolution.

The FocalPlaneResolutionUnit = FocalPlaneYResolution0 / FocalPlaneYResolution1

Explanation

The FocalPlaneYResolution1 property refers to the vertical focal plane resolution.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


GPSVersion property

Newtone.ImageKit.Win.ImageKit.File.Exif.GPSVersion Property

This property refers to the GPS tag version (i.e. "2000"). The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property GPSVersion As String
[C#] public string GPSVersion {get;}

Property Value

The GPS tag version (i.e. "2000")

Explanation

The GPSVersion property refers to the GPS tag version (i.e. "2000"). The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif version.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ISOSpeedRatings property

Newtone.ImageKit.Win.ImageKit.File.Exif.ISOSpeedRatings Property

This property indicates the ISO Speed and ISO Latitude of the camera or input device.

[Visual Basic] Public ReadOnly Property ISOSpeedRatings As Integer
[C#] public int ISOSpeedRatings {get;}

Property Value

Indicates the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232xiv

Explanation

The ISOSpeedRatings property indicates the ISO Speed and ISO Latitude of the camera or input device.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


Latitude property

Newtone.ImageKit.Win.ImageKit.File.Exif.Latitude Property

This property refers to the latitude direction where the image was taken. (i.e. "N" or "S")

[Visual Basic] Public ReadOnly Property Latitude As String
[C#] public string Latitude {get;}

Property Value

Latitude is the latitude direction where the image was taken. (i.e. "N" or "S")

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LatitudeD0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LatitudeD0 Property

This property refers to latitude in degrees where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LatitudeD0 As Integer
[C#] public int LatitudeD0 {get;}

Property Value

LatitudeD0 is the latitude in degrees where the image was taken. This is the numerator.

LatitudeD1 is the latitude in degrees where the image was taken. This is the denominator.

The latitude in degrees = LatitudeD0 / LatitudeD1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LatitudeD1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LatitudeD1 Property

This property refers to latitude in degrees where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LatitudeD1 As Integer
[C#] public int LatitudeD1 {get;}

Property Value

LatitudeD0 is the latitude in degrees where the image was taken. This is the numerator.

LatitudeD1 is the latitude in degrees where the image was taken. This is the denominator.

The latitude in degrees = LatitudeD0 / LatitudeD1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LatitudeM0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LatitudeM0 Property

This property refers to latitude in minutes where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LatitudeM0 As Integer
[C#] public int LatitudeM0 {get;}

Property Value

LatitudeM0 is the latitude in minutes where the image was taken. This is the numerator.

LatitudeM1 is the latitude in minutes where the image was taken. This is the denominator.

The latitude in minutes = LatitudeM0 / LatitudeM1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LatitudeM1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LatitudeM1 Property

This property refers to latitude in minutes where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LatitudeM1 As Integer
[C#] public int LatitudeM1 {get;}

Property Value

LatitudeM0 is the latitude in minutes where the image was taken. This is the numerator.

LatitudeM1 is the latitude in minutes where the image was taken. This is the denominator.

The latitude in minutes = LatitudeM0 / LatitudeM1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LatitudeS0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LatitudeS0 Property

This property refers to latitude in seconds where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LatitudeS0 As Integer
[C#] public int LatitudeS0 {get;}

Property Value

LatitudeS0 is the latitude in minutes where the image was taken. This is the numerator.

LatitudeS1 is the latitude in minutes where the image was taken. This is the denominator.

The latitude in minutes = LatitudeS0 / LatitudeS1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LatitudeS1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LatitudeS1 Property

This property refers to latitude in seconds where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LatitudeS1 As Integer
[C#] public int LatitudeS1 {get;}

Property Value

LatitudeS0 is the latitude in seconds where the image was taken. This is the numerator.

LatitudeS1 is the latitude in seconds where the image was taken. This is the denominator.

The latitude in minutes = LatitudeS0 / LatitudeS1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LightSource property

Newtone.ImageKit.Win.ImageKit.File.Exif.LightSource Property

This property refers to the type of light source.

[Visual Basic] Public ReadOnly Property LightSource As Integer
[C#] public int LightSource {get;}

Property Value

Value | Explanation
0 | Unknown
1 | Daylight
2 | Fluorescent
3 | Tungsten
17 | Standard light A
18 | Standard light B
19 | Standard light C
20 | D55
21 | D65
22 | D75
255 | Other

Explanation

The LightSource property refers to the type of light source.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


Longitude property

Newtone.ImageKit.Win.ImageKit.File.Exif.Longitude Property

This property refers to the longitude direction where the image was taken. (i.e. "E" or "W")

[Visual Basic] Public ReadOnly Property Longitude As String
[C#] public string Longitude {get;}

Property Value

Longitude is the longitude direction where the image was taken. (i.e. "E" or "W")

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LongitudeD0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LongitudeD0 Property

This property refers to longitude in degrees where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LongitudeD0 As String
[C#] public string LongitudeD0 {get;}

Property Value

LongitudeD0 is the longitude in degrees where the image was taken. This is the numerator.

LongitudeD1 is the latitude in degrees where the image was taken. This is the denominator.

The longitude in degrees = LongitudeD0 / LongitudeD1

Explanation

The LongitudeD0 property refers to longitude in degrees where the image was taken. This is the numerator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LongitudeD1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LongitudeD1 Property

This property refers to longitude in degrees where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LongitudeD1 As String
[C#] public string LongitudeD1 {get;}

Property Value

LongitudeD0 is the longitude in degrees where the image was taken. This is the numerator.

LongitudeD1 is the latitude in degrees where the image was taken. This is the denominator.

The longitude in degrees = LongitudeD0 / LongitudeD1

Explanation

The LongitudeD1 property refers to longitude in degrees where the image was taken. This is the denominator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LongitudeM0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LongitudeM0 Property

This property refers to longitude in minutes where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LongitudeM0 As String
[C#] public string LongitudeM0 {get;}

Property Value

LongitudeM0 is the longitude in minutes where the image was taken. This is the numerator.

LongitudeM1 is the latitude in minutes where the image was taken. This is the denominator.

The longitude in minutes = LongitudeM0 / LongitudeM1

Explanation

The LongitudeM0 property refers to longitude in minutes where the image was taken. This is the numerator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LongitudeM1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LongitudeM1 Property

This property refers to longitude in minutes where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LongitudeM1 As String
[C#] public string LongitudeM1 {get;}

Property Value

LongitudeM0 is the longitude in minutes where the image was taken. This is the numerator.

LongitudeM1 is the latitude in minutes where the image was taken. This is the denominator.

The longitude in minutes = LongitudeM0 / LongitudeM1

Explanation

The LongitudeM1 property refers to longitude in minutes where the image was taken. This is the denominator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LongitudeS0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LongitudeS0 Property

This property refers to longitude in seconds where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LongitudeS0 As String
[C#] public string LongitudeS0 {get;}

Property Value

LongitudeS0 is the longitude in seconds where the image was taken. This is the numerator.

LongitudeS1 is the latitude in seconds where the image was taken. This is the denominator.

The longitude in minutes = LongitudeS0 / LongitudeS1

Explanation

The LongitudeS0 property refers to longitude in seconds where the image was taken. This is the numerator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LongitudeS1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LongitudeS1 Property

This property refers to longitude in seconds where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LongitudeS1 As String
[C#] public string LongitudeS1 {get;}

Property Value

LongitudeS0 is the longitude in seconds where the image was taken. This is the numerator.

LongitudeS1 is the latitude in seconds where the image was taken. This is the denominator.

The longitude in minutes = LongitudeS0 / LongitudeS1

Explanation

The LongitudeS1 property refers to longitude in seconds where the image was taken. This is the denominator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainArtist property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainArtist Property

This property refers to the information about the artist's name.

[Visual Basic] Public ReadOnly Property MainArtist As String
[C#] public string MainArtist {get;}

Property Value

MainArtist refers to the camera owner, photographer, or creator of the primary image

Explanation

The MainArtist property refers to the information about the artist's name.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainCopyright property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainCopyright Property

This property refers to the information about the copyright.

[Visual Basic] Public ReadOnly Property MainCopyright As String
[C#] public string MainCopyright {get;}

Property Value

MainCopyright refers to the copyright information for the primary image

Explanation

The MainCopyright property refers to the information about the copyright.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainDateTime property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainDateTime Property

This property refers to the information about the date and time.

[Visual Basic] Public ReadOnly Property MainDateTime As String
[C#] public string MainDateTime {get;}

Property Value

MainDateTime refers to the date and time that the primary image was created. The format is "YYYY:MM:DD HH:MM:SS" with the time shown in 24-hour format and the date and time separated by one blank character

Example: "1996:09:01 09:15:30"

Explanation

The MainDateTime property refers to the information about the date and time.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainImageDescription property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainImageDescription Property

This property refers to the information about the image description.

[Visual Basic] Public ReadOnly Property MainImageDescription As String
[C#] public string MainImageDescription {get;}

Property Value

MainImageDescription refers to the character string giving the title of the primary image

Explanation

The MainImageDescription property refers to the information about the image description.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainMake property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainMake Property

This property refers to the information about the manufacturer's name.

[Visual Basic] Public ReadOnly Property MainMake As String
[C#] public string MainMake {get;}

Property Value

MainMake refers to the manufacturer of the recording equipment that generated the primary image

Explanation

The MainMake property refers to the information about the manufacturer's name.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainModel property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainModel Property

This property refers to the information about the model name or model number of the equipment.

[Visual Basic] Public ReadOnly Property MainModel As String
[C#] public string MainModel {get;}

Property Value

MainModel refers to the model name or model number of the equipment that generated the primary image

Explanation

The MainModel property refers to the information about the model name or model number of the equipment.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainSoftware property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainSoftware Property

This property refers to the information about the software.

[Visual Basic] Public ReadOnly Property MainSoftware As String
[C#] public string MainSoftware {get;}

Property Value

MainSoftware refers to the name and version of the software used to generate the primary image

Explanation

The MainSoftware property refers to the information about the software.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainResolutionUnit property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainResolutionUnit Property

This property refers to the units of measurement for focal plane resolution in the primary image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property MainResolutionUnit As Integer
[C#] public int MainResolutionUnit {get;}

Property Value

The MainResolutionUnit is the unit of measurement for MainXResolution and MainYResolution in the primary image.

The MainResolutionUnit is MainXResolution0 / MainXResolution1 and MainYResolution0 / MainYResolution1

Value | Explanation
2 | Inches
3 | Centimeters

Explanation

The MainResolutionUnit property refers to the units of measurement for focal plane resolution in the primary image.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainXResolution0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainXResolution0 Property

This property refers to the number of pixels per resolution unit in the primary images.

[Visual Basic] Public ReadOnly Property MainXResolution0 As Integer
[C#] public int MainXResolution0 {get;}

Property Value

The MainXResolution is the number of pixels per MainResolutionUnit in the primary image in the horizontal direction.

The MainXResolution0 is the numerator for the MainResolutionUnit.

The MainXResolution1 is the denominator for the MainResolutionUnit.

The MainResolutionUnit = MainXResolution0 / MainXResolution1

Explanation

The MainXResolution0 property refers to the number of pixels per resolution unit in the primary images. The property value is derived from the image tags relating to image data structure. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainXResolution1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainXResolution1 Property

This property refers to the number of pixels per resolution unit in the primary images.

[Visual Basic] Public ReadOnly Property MainXResolution1 As Integer
[C#] public int MainXResolution1 {get;}

Property Value

The MainXResolution is the number of pixels per MainResolutionUnit in the primary image in the horizontal direction.

The MainXResolution0 is the numerator for the MainResolutionUnit.

The MainXResolution1 is the denominator for the MainResolutionUnit.

The MainResolutionUnit = MainXResolution0 / MainXResolution1

Explanation

The MainXResolution1 property refers to the number of pixels per resolution unit in the primary images. The property value is derived from the image tags relating to image data structure. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainYCbCrPositioning property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainYCbCrPositioning Property

This property refers to the position of chrominance components (CbCr) in relation to the luminance component (Y).

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property MainYCbCrPositioning As Integer
[C#] public int MainYCbCrPositioning {get;}

Property Value

Value | Explanation
1 | Centered
2 | Co-sited

Explanation

The MainYCbCrPositioning property refers to the position of chrominance components (CbCr) in relation to the luminance component (Y). The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags relating to primary image data structure.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainYResolution0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainYResolution0 Property

This property refers to the number of pixels per resolution unit in the primary images.

[Visual Basic] Public ReadOnly Property MainYResolution0 As Integer
[C#] public int MainYResolution0 {get;}

Property Value

The MainYResolution is the number of pixels per MainResolutionUnit in the primary image in the vertical direction.

The MainYResolution0 is the numerator for the MainResolutionUnit.

The MainYResolution1 is the denominator for the MainResolutionUnit.

The MainResolutionUnit = MainYResolution0 / MainYResolution1

Explanation

The MainYResolution0 property refers to the number of pixels per resolution unit in the primary images. The property value is derived from the image tags relating to image data structure. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainYResolution1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainYResolution1 Property

This property refers to the number of pixels per resolution unit in the primary images.

[Visual Basic] Public ReadOnly Property MainYResolution1 As Integer
[C#] public int MainYResolution1 {get;}

Property Value

The MainYResolution is the number of pixels per MainResolutionUnit in the primary image in the vertical direction.

The MainYResolution0 is the numerator for the MainResolutionUnit.

The MainYResolution1 is the denominator for the MainResolutionUnit.

The MainResolutionUnit = MainYResolution0 / MainYResolution1

Explanation

The MainYResolution1 property refers to the number of pixels per resolution unit in the primary images. The property value is derived from the image tags relating to image data structure. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MakerNote property

Newtone.ImageKit.Win.ImageKit.File.Exif.MakerNote Property

This property value is derived from the image tags relating to user information.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property MakerNote As String
[C#] public string MakerNote {get;}

Property Value

The MakerNote property value is derived from the image tag for manufacturers of Exif writers to record any desired information.

Explanation

The MakerNote property value is derived from the image tags relating to user information.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MapDatum property

Newtone.ImageKit.Win.ImageKit.File.Exif.MapDatum Property

This property refers to the name of the map data used.

[Visual Basic] Public ReadOnly Property MapDatum As String
[C#] public string MapDatum {get;}

Property Value

MapDatum is the name of the map data used

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MaxApertureValue0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.MaxApertureValue0 Property

This property refers to the smallest F value of the lens. This is the numerator.

[Visual Basic] Public ReadOnly Property MaxApertureValue0 As Integer
[C#] public int MaxApertureValue0 {get;}

Property Value

MaxApertureValue0 is the numerator for the smallest F value of the lens

MaxApertureValue1 is the denominator for the smallest F value of the lens

The smallest F value of the lens (unit is the APEX value) = MaxApertureValue0 / MaxApertureValue1

Ordinarily the smallest F value of the lens is given in the range from 00.00 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MaxApertureValue1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.MaxApertureValue1 Property

This property refers to the smallest F value of the lens. This is the denominator.

[Visual Basic] Public ReadOnly Property MaxApertureValue1 As Integer
[C#] public int MaxApertureValue1 {get;}

Property Value

MaxApertureValue0 is the numerator for the smallest F value of the lens

MaxApertureValue1 is the denominator for the smallest F value of the lens

The smallest F value of the lens (unit is the APEX value) = MaxApertureValue0 / MaxApertureValue1

Ordinarily the smallest F value of the lens is given in the range from 00.00 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MeteringMode property

Newtone.ImageKit.Win.ImageKit.File.Exif.MeteringMode Property

This property refers to the metering mode. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

[Visual Basic] Public ReadOnly Property MeteringMode As Integer
[C#] public int MeteringMode {get;}

Property Value

Value | Explanation
0 | Unknown
1 | Average
2 | CounterWeightedAverage
3 | Spot
4 | MultiSpot
5 | Pattern
6 | Partial
255 | Other

Explanation

The MeteringMode property refers to the metering mode. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods. This property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainOrientation property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainOrientation Property

This property refers to the image orientation viewed in terms of rows and columns. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property MainOrientation As Integer
[C#] public int MainOrientation {get;}

Property Value

Value | Explanation
1 | The 0th row is at the visual top of the image, and the 0th column is the visual left hand side
2 | The 0th row is at the visual top of the image, and the 0th column is the visual right hand side
3 | The 0th row is at the visual bottom of the image, and the 0th column is the visual right hand side
4 | The 0th row is at the visual bottom of the image, and the 0th column is the visual left hand side
5 | The 0th row is at the visual left hand side of the image, and the 0th column is the visual top
6 | The 0th row is at the visual right hand side of the image, and the 0th column is the visual top
7 | The 0th row is at the visual right hand side of the image, and the 0th column is the visual bottom
8 | The 0th row is at the visual left hand side of the image, and the 0th column is the visual bottom

Explanation

The MainOrientation property refers to the image orientation viewed in terms of rows and columns.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags relating to primary image data structure.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailOrientation property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailOrientation Property

This property refers to the image orientation viewed in terms of rows and columns. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailOrientation As Integer
[C#] public int ThumbnailOrientation {get;}

Property Value

Value | Explanation
1 | The 0th row is at the visual top of the image, and the 0th column is the visual left hand side
2 | The 0th row is at the visual top of the image, and the 0th column is the visual right hand side
3 | The 0th row is at the visual bottom of the image, and the 0th column is the visual right hand side
4 | The 0th row is at the visual bottom of the image, and the 0th column is the visual left hand side
5 | The 0th row is at the visual left hand side of the image, and the 0th column is the visual top
6 | The 0th row is at the visual right hand side of the image, and the 0th column is the visual top
7 | The 0th row is at the visual right hand side of the image, and the 0th column is the visual bottom
8 | The 0th row is at the visual left hand side of the image, and the 0th column is the visual bottom

Explanation

The ThumbnailOrientation property refers to the image orientation viewed in terms of rows and columns.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags relating to thumbnail image data structure.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


PixelXDimension property

Newtone.ImageKit.Win.ImageKit.File.Exif.PixelXDimension Property

This property refers to the width of the image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property PixelXDimension As Integer
[C#] public int PixelXDimension {get;}

Property Value

PixcelXDimension is the valid width of the image

PixelYDimension is the valid height of the image

Explanation

The PixcelXDimension property refers to the width of the image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to the image configuration.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


PixelYDimension property

Newtone.ImageKit.Win.ImageKit.File.Exif.PixelYDimension Property

This property refers to the height of the image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property PixelYDimension As Integer
[C#] public int PixelYDimension {get;}

Property Value

PixcelXDimension is the valid width of the image

PixelYDimension is the valid height of the image

Explanation

The PixcelYDimension property refers to the height of the image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to the image configuration.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SceneType property

Newtone.ImageKit.Win.ImageKit.File.Exif.SceneType Property

This property refers to the type of scene.

[Visual Basic] Public ReadOnly Property SceneType As Integer
[C#] public int SceneType {get;}

Property Value

SceneType indicates the type of scene. If a DSC recorded the image, this value will be set to 1 indicating that the image was directly photographed.

Explanation

The SceneType property refers to the type of scene. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SensingMethod property

Newtone.ImageKit.Win.ImageKit.File.Exif.SensingMethod Property

This property refers to the image sensor type on the camera or input device. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SensingMethod As Integer
[C#] public int SensingMethod {get;}

Property Value

Value | Explanation
1 | Not defined
2 | One-chip color area sensor
3 | Two-chip color area sensor
4 | Three-chip color area sensor
5 | Color sequential area sensor
7 | Trilinear sensor
8 | Color sequential linear sensor

Explanation

The SensingMethod property refers to the image sensor type on the camera or input device. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ShutterSpeedValue0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ShutterSpeedValue0 Property

This property is the numerator for the shutter speed. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

[Visual Basic] Public ReadOnly Property ShutterSpeedValue0 As Integer
[C#] public int ShutterSpeedValue0 {get;}

Property Value

ShutterSpeedValue0 is the numerator for the shutter speed

ShutterSpeedValue1 is the denominator for the shutter speed

The shutter speed (unit is the APEX value) = ShutterSpeedValue0 / ShutterSpeedValue1

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The ShutterSpeedValue0 property is the numerator for the shutter speed. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ShutterSpeedValue1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ShutterSpeedValue1 Property

This property is the denominator for the shutter speed. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

[Visual Basic] Public ReadOnly Property ShutterSpeedValue1 As Integer
[C#] public int ShutterSpeedValue1 {get;}

Property Value

ShutterSpeedValue0 is the numerator for the shutter speed

ShutterSpeedValue1 is the denominator for the shutter speed

The shutter speed (unit is the APEX value) = ShutterSpeedValue0 / ShutterSpeedValue1

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The ShutterSpeedValue1 property is the denominator for the shutter speed. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SpectralSensitivity property

Newtone.ImageKit.Win.ImageKit.File.Exif.SpectralSensitivity Property

This property refers to the spectral sensitivity of each channel of the camera used. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SpectralSensitivity As String
[C#] public string SpectralSensitivity {get;}

Property Value

The value is an ASCII string commpatible with the standard xiii developed by the ASTM Technical committee.

Explanation

The SpectralSensitivity property referes to the spectral sensitivity of each channel of the camera used. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SubjectDistance0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.SubjectDistance0 Property

This property is the numerator for the distance to the subject. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubjectDistance0 As Integer
[C#] public int SubjectDistance0 {get;}

Property Value

SubjectDistance0 is the numerator for the distance to the subject.

SubjectDistance1 is the denominator for the distance to the subject.

The distance to the subject (in meters) = SubjectDistance0 / SubjectDistance1

Explanation

The SubjectDistance0 property is the numerator for the distance to the subject. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SubjectDistance1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.SubjectDistance1 Property

This property is the denominator for the distance to the subject. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubjectDistance1 As Integer
[C#] public int SubjectDistance1 {get;}

Property Value

SubjectDistance0 is the numerator for the distance to the subject.

SubjectDistance1 is the denominator for the distance to the subject.

The distance to the subject (in meters) = SubjectDistance0 / SubjectDistance1

Explanation

The SubjectDistance1 property is the denominator for the distance to the subject. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SubjectLocationX property

Newtone.ImageKit.Win.ImageKit.File.Exif.SubjectLocationX Property

This property refers to the location of the main subject in the scene. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubjectLocationX As Integer
[C#] public int SubjectLocationX {get;}

Property Value

The SubjectLocationX is the horizontal coordinate of the center of the main subject of the scene

The SubjectLocationY is the vertical coordinate of the center of the main subject of the scene

Explanation

The SubjectLocationX refers to the location of the main subject in the scene. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SubjectLocationY property

Newtone.ImageKit.Win.ImageKit.File.Exif.SubjectLocationY Property

This property refers to the location of the main subject in the scene. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubjectLocationY As Integer
[C#] public int SubjectLocationY {get;}

Property Value

The SubjectLocationX is the horizontal coordinate of the center of the main subject of the scene

The SubjectLocationY is the vertical coordinate of the center of the main subject of the scene

Explanation

The SubjectLocationY refers to the location of the main subject in the scene. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SubSecTime property

Newtone.ImageKit.Win.ImageKit.File.Exif.SubSecTime Property

This property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubSecTime As String
[C#] public string SubSecTime {get;}

Property Value

The SubSecTime property records fractions of seconds for the MainDateTime property.

For example, if the subsecond data is 0.130 then

SubSecTime = "130"

Explanation

The SubSecTime property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to date and time.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SubSecTimeDigitized property

Newtone.ImageKit.Win.ImageKit.File.Exif.SubSecTimeDigitized Property

This property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubSecTimeDigitized As String
[C#] public string SubSecTimeDigitized {get;}

Property Value

The SubSecTimeDigitized property records fractions of seconds for the DateTimeDigitized property.

For example, if the subsecond data is 0.130 then

SubSecTimeDigitized = "130"

Explanation

The SubSecTimeDigitized property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to date and time.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SubSecTimeOriginal property

Newtone.ImageKit.Win.ImageKit.File.Exif.SubSecTimeOriginal Property

This property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubSecTimeOriginal As String
[C#] public string SubSecTimeOriginal {get;}

Property Value

The SubSecTimeOriginal property records fractions of seconds for the DateTimeOriginal property.

For example, if the subsecond data is 0.130 then

SubSecTimeOriginal = "130"

Explanation

The SubSecTimeOriginal property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to date and time.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailCompression property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailCompression Property

This property refers to the compression method for the thumbnail image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailCompression As Integer
[C#] public int ThumbnailCompression {get;}

Property Value

Value | Explanation
1 | Uncompressed
6 | JPEG compression

Explanation

The ThumbnailCompression property refers to the compression method for the thumbnail image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

When the thumbnail is Jpeg compression data, the return value will be 6.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailArtist property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailArtist Property

This property refers to the information about the artist's name. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailArtist As String
[C#] public string ThumbnailArtist {get;}

Property Value

ThumbnailArtist refers to the camera owner, photographer, or creator of the Thumbnail image

Explanation

The ThumbnailArtist property refers to the information about the artist's name. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailCopyright property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailCopyright Property

This property refers to the information about the copyright. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailCopyright As String
[C#] public string ThumbnailCopyright {get;}

Property Value

ThumbnailCopyright refers to the copyright information for the Thumbnail image

Explanation

The ThumbnailCopyright property refers to the information about the copyright. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailDateTime property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailDateTime Property

This property refers to the information about the date and time. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailDateTime As String
[C#] public string ThumbnailDateTime {get;}

Property Value

ThumbnailDateTime refers to the date and time that the Thumbnail image was created. The format is "YYYY:MM:DD HH:MM:SS" with the time shown in 24-hour format and the date and time separated by one blank character

Example: "1996:09:01 09:15:30"

Explanation

The ThumbDateTime property refers to the information about the date and time. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailImageDescription property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailImageDescription Property

This property refers to the information about the image description. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailImageDescription As String
[C#] public string ThumbnailImageDescription {get;}

Property Value

ThumbnailImageDescription refers to the character string giving the title of the Thumbnail image

Explanation

The ThumbnailImageDescription property refers to the information about the image description. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailMake property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailMake Property

This property refers to the information about the manufacturer's name. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailMake As String
[C#] public string ThumbnailMake {get;}

Property Value

ThumbnailMake refers to the manufacturer of the recording equipment that generated the Thumbnail image

Explanation

The ThumbnailMake property refers to the information about the manufacturer's name. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailModel property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailModel Property

This property refers to the information about the model name or model number of the equipment. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailModel As String
[C#] public string ThumbnailModel {get;}

Property Value

ThumbnailModel refers to the model name or model number of the equipment that generated the Thumbnail image

Explanation

The ThumbnailModel property refers to the information about the model name or model number of the equipment. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailSoftware property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailSoftware Property

This property refers to the information about the software. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailSoftware As String
[C#] public string ThumbnailSoftware {get;}

Property Value

ThumbnailSoftware refers to the name and version of the software used to generate the Thumbnail image

Explanation

The ThumbnailSoftware property refers to the information about the software. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailResolutionUnit property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailResolutionUnit Property

This property refers to the units of measurement for focal plane resolution in the thumbnail image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailResolutionUnit As Integer
[C#] public int ThumbnailResolutionUnit {get;}

Property Value

The ThumbnailResolutionUnit is the unit of measurement for ThumbnailXResolution and ThumbnailYResolution in the thumbnail image.

The ThumbResolutionUnit is ThumbnailXResolution0 / ThumbnailXResolution1 and ThumbnailYResolution0 / ThumbnailYResolution1

Value | Explanation
2 | Inches
3 | Centimeters

Explanation

The ThumbResolutionUnit property refers to the units of measurement for focal plane resolution in the thumbnail image.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailXResolution0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailXResolution0 Property

This property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailXResolution0 As Integer
[C#] public int ThumbnailXResolution0 {get;}

Property Value

The ThumbnailXResolution is the number of pixels per ThumbnailResolutionUnit in the thumbnail image in the horizontal direction.

The ThumbnailXResolution0 is the numerator for the ThumbnailResolutionUnit.

The ThumbnailXResolution1 is the denominator for the ThumbnailResolutionUnit.

The ThumbnailResolutionUnit = ThumbnailXResolution0 / ThumbnailXResolution1.

Explanation

The ThumbnailnailXResolution0 property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the resolution of the thumbnail image.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailXResolution1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailXResolution1 Property

This property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailXResolution1 As Integer
[C#] public int ThumbnailXResolution1 {get;}

Property Value

The ThumbnailXResolution is the number of pixels per ThumbnailResolutionUnit in the thumbnail image in the horizontal direction.

The ThumbnailXResolution0 is the numerator for the ThumbnailResolutionUnit.

The ThumbnailXResolution1 is the denominator for the ThumbnailResolutionUnit.

The ThumbnailResolutionUnit = ThumbnailXResolution0 / ThumbnailXResolution1.

Explanation

The ThumbnailXResolution1 property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the resolution of the thumbnail image.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailYCbCrPositioning property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailYCbCrPositioning Property

This property refers to the position of chrominance components (CbCr) in relation to the luminance component (Y). The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailYCbCrPositioning As Integer
[C#] public int ThumbnailYCbCrPositioning {get;}

Property Value

Value | Explanation
1 | Centered
2 | Co-sited

Explanation

The ThumbnailYCbCrPositioning property refers to the position of chrominance components (CbCr) in relation to the luminance component (Y). The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags relating to thumbnail image data structure.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailYResolution0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailYResolution0 Property

This property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailYResolution0 As Integer
[C#] public int ThumbnailYResolution0 {get;}

Property Value

The ThumbnailYResolution is the number of pixels per ThumbnailResolutionUnit in the thumbnail image in the vertical direction.

The ThumbnailYResolution0 is the numerator for the ThumbnailResolutionUnit.

The ThumbnailYResolution1 is the denominator for the ThumbnailResolutionUnit.

The ThumbnailResolutionUnit = ThumbnailYResolution0 / ThumbnailYResolution1.

Explanation

The ThumbnailYResolution0 property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the resolution of the thumbnail image.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailYResolution1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailYResolution1 Property

This property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailYResolution1 As Integer
[C#] public int ThumbnailYResolution1 {get;}

Property Value

The ThumbnailYResolution is the number of pixels per ThumbnailResolutionUnit in the thumbnail image in the vertical direction.

The ThumbnailYResolution0 is the numerator for the ThumbnailResolutionUnit.

The ThumbnailYResolution1 is the denominator for the ThumbnailResolutionUnit.

The ThumbnailResolutionUnit = ThumbnailYResolution0 / ThumbnailYResolution1.

Explanation

The ThumbnailYResolution1 property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the resolution of the thumbnail image.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


UserComment property

Newtone.ImageKit.Win.ImageKit.File.Exif.UserComment Property

This property value is derived from the image tags relating to user information.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property UserComment As String
[C#] public string UserComment {get;}

Property Value

The UserComment tag is identified based on an UserCommentID code in a fixed 8-byte area at the start of the tag data area. The unused portion of the area is padded with NULL("00.H").

Character Code | Code Designation (8 Bytes) | References
ASCII | 0x41,0x53,0x43,0x49,0x49,0x00,0x00,0x00 | ITU-T T.50 IA5x
JIS | 0x4A,0x49,0x53,0x00,0x00,0x00,0x00,0x00 | JIS X0208-1990xi
Unicode | 0x55,0x4E,0x49,0x43,0x4F,0x44,0x45,0x00 | Unicode Standard xii
Undefined | 0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00 | Undefined

In Visual Basic, please replace 0x with &H

Explanation

The UserComment property value is derived from the image tags relating to user information. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


UserCommentID property

Newtone.ImageKit.Win.ImageKit.File.Exif.UserCommentID Property

This property value is derived from the image tags relating to user information.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property UserCommentID As String
[C#] public string UserCommentID {get;}

Property Value

The UserComment tag is identified based on an UserCommentID code in a fixed 8-byte area at the start of the tag data area. The unused portion of the area is padded with NULL("00.H").

Character Code | Code Designation (8 Bytes) | References
ASCII | 0x41,0x53,0x43,0x49,0x49,0x00,0x00,0x00 | ITU-T T.50 IA5x
JIS | 0x4A,0x49,0x53,0x00,0x00,0x00,0x00,0x00 | JIS X0208-1990xi
Unicode | 0x55,0x4E,0x49,0x43,0x4F,0x44,0x45,0x00 | Unicode Standard xii
Undefined | 0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00 | Undefined

In Visual Basic, please replace 0x with &H

Explanation

The UserCommentID property value is derived from the image tags relating to user information. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


Version property

Newtone.ImageKit.Win.ImageKit.File.Exif.Version Property

This property refers to the version of the Exif Standard supported. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property Version As String
[C#] public string Version {get;}

Property Value

Version is the Exif version supported. (Example: "0210")

Explanation

The Version property refers to the version of the Exif Standard supported. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif version.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ImageKit.File.Pdf Members

Newtone.ImageKit.Win.ImageKit.File.Pdf Members

Public Properties

DocumentHeight | Sets the height of the saved PDF document
DocumentSize | Sets the size of the saved PDF document
DocumentWidth | Sets the width of the saved PDF document
Landscape | Sets whether the saved PDF will have a landscape or protrait orientation
SaveFileName | Sets the file name (full path) when saving the PDF document

Public Methods

AddImage | Adds an image to a PDF document
AddPage | Adds a page to the PDF document
End | Completes the PDF document
EndPage | Ends the page that was added with the AddPage method
Start | Starts the PDF document

Also See

ImageKit.File.Pdf Members | Newtone.ImageKit.Win.ImageKit


DocumentHeight property

Newtone.ImageKit.Win.ImageKit.File.Pdf.DocumentHeight Property

This property sets the height of the saved PDF document.

[Visual Basic] Public Property DocumentHeight As int
[C#] public int DocumentHeight {get; set;}

Property Value

The height in mm of the saved PDF document

Explanation

The DocumentHeight property sets the height of the saved PDF document.

Please set this property before executing the AddPage method.

imageKit1.File.Pdf.DocumentHeight = 200;
imageKit1.File.Pdf.AddPage();

To specify a standard height and width for the PDF document, please see the DocumentSize property.

Also See

ImageKit.File.Pdf Members | Newtone.ImageKit.Win.ImageKit


DocumentSize property

Newtone.ImageKit.Win.ImageKit.File.Pdf.DocumentSize Property

This property sets the size of the saved PDF document.

[Visual Basic] Public Property DocumentSize As String
[C#] public String DocumentSize {get; set;}

Property Value

The following are supported setting values:

A0, A1, A2, A3, A4, A5, A6, A7, A8, A9, A10
B0, B1, B2, B3, B4, B5, B6, B7, B8, B9
LETTER, LEGAL

Explanation

The DocumentSize property sets the size of the saved PDF document.

Please set this property before executing the AddPage method.

imageKit1.File.Pdf.DocumentSize = "a4";
imageKit1.File.Pdf.AddPage();

When the DocumentSize property is set, it is not necessary to set the DocumentHeight or DocumentWidth properties.

Also See

ImageKit.File.Pdf Members | Newtone.ImageKit.Win.ImageKit


DocumentWidth property

Newtone.ImageKit.Win.ImageKit.File.Pdf.DocumentWidth Property

This property sets the width of the saved PDF document

[Visual Basic] Public Property DocumentWidth As int
[C#] public int DocumentWidth {get; set;}

Property Value

The width in mm of the saved PDF document

Explanation

The DocumentWidth property sets the width of the saved PDF document

Please set this property before executing the AddPage method.

imageKit1.File.Pdf.DocumentWidth = 200;
imageKit1.File.Pdf.AddPage();

To specify a standard height and width for the PDF document, please see the DocumentSize property.

Also See

ImageKit.File.Pdf Members | Newtone.ImageKit.Win.ImageKit


Landscape property

Newtone.ImageKit.Win.ImageKit.File.Pdf.Landscape Property

This property sets whether the saved PDF will have a landscape or protrait orientation.

[Visual Basic] Public Property Landscape As Boolean
[C#] public bool Landscape {get; set;}

Property Value

True: PDF will have a landscape orientation
False: PDF will have a protrait orientation
Default value is False

Explanation

The Landscape property sets whether the saved PDF will have a landscape or protrait orientation. When this property is True and a PDF is saved whose size is set in the DocumentSizeproperty, the PDF document will have a landscape orientation. If this property is False, the PDF will have a protrait orientation.

Note: After setting the DocumentSize property, if you set the DocumentHeight and DocumentWidth properties, those two settings will take precedence and the DocumentSize property and this Landscape property will be ignored.

Also See

ImageKit.File.Pdf Members | Newtone.ImageKit.Win.ImageKit


SaveFileName property

Newtone.ImageKit.Win.ImageKit.File.Pdf.SaveFileName Property

This property sets the file name (full path) when saving the PDF document

[Visual Basic] Public Property SaveFileName As String
[C#] public String SaveFileName {get; set;}

Property Value

A string containing the file name and path where the pdf will be saved

Explanation

The SaveFileName property sets the file name (full path) when saving the PDF document

Also See

ImageKit.File.Pdf Members | Newtone.ImageKit.Win.ImageKit


AddImage method

Newtone.ImageKit.Win.ImageKit.File.Pdf.AddImage Method

This method adds an image to a PDF document.

[Visual Basic]
Public Function AddImage(ImageFile As String, x As Integer, y As Integer, width As Integer, height As Integer) As Boolean
Public Function AddImage(ImageData As Image, x As Integer, y As Integer, width As Integer, height As Integer) As Boolean
Public Function AddImage(ImageArray As Byte(), x As Integer, y As Integer, width As Integer, height As Integer) As Boolean
[C#]
public bool AddImage(String ImageFile, int x, int y, int width, int height);
public bool AddImage(Image ImageData, int x, int y, int width, int height);
public bool AddImage(Byte[] ImageArray, int x, int y, int width, int height);

Parameters

Parameter Name | Explanation
ImageFilePath | The image file that is to be added to the PDF
ImageData | The image data
ImageArray | The image data
x | The horizontal position of the BOTTOM LEFT corner of the added image (in mm)
y | The vertical position of the BOTTOM LEFT corner of the added image (in mm)
width | The width of the image in mm (Note: This does not denote an x coordinate. It is the width of the image!)
height | The height of the image in mm (Note: This does not denote an y coordinate. It is the height of the image!)

Return Value

Returns True if successful, otherwise returns False

Explanation

The AddImage method adds an image to a PDF document.

The image formats supported are BMP (1, 4, 8, and 24 bit) and JPEG.

The image specified by the SaveFileName property will be saved in pdf format.

The AddImage method should be used with the other PDF methods in the following order: Start, AddPage, AddImage, EndPage, and End.

Example

Also see the example on the Start method page.

AddImage method examples:

[Visual C#.NET]

//Loads an image file and creats a pdf
imageKit1.File.Pdf.AddImage("Image.jpg", 0, 0, 200, 200);

//Loads the image from file
Image img = Image.FromFile("Image.bmp");
//creats the pdf
imageKit1.File.Pdf.AddImage(img, 0, 0, 100, 100);

//Loads the image from file
imageKit1.File.FileName ="sample.jpg";
imageKit1.File.LoadImageFromFile(LoadFileType.Load);
//setts the image data into the imageKit1.File.RawData property
imageKit1.File.SaveImageToRawData(SaveFileType.SaveJPEG, imageKit1.Image);
//Creats the pdf
imageKit1.File.Pdf.AddImage(imageKit1.File.RawData, 0, 0, 100, 100);

Also See

ImageKit.File.Pdf Members | Newtone.ImageKit.Win.ImageKit


AddPage method

Newtone.ImageKit.Win.ImageKit.File.Pdf.AddPage Method

This method adds a page to the PDF document

[Visual Basic] Public Function AddPage() As Boolean
[C#] public bool AddPage();

Parameters

None

Return Value

Returns True if successful, otherwise returns False

Explanation

The AddPage method adds a page to the PDF document. Once the page has been added, use the AddImage method to add an image to the page. The image formats supported are BMP and JPEG.

The PDF document will be saved in the file and path specified by the SaveFileName property.

The AddPage method should be used with the other PDF methods in the following order: Start, AddPage, AddImage, EndPage, End

Example

Also see the example on the Start method page.

AddPage example:

[Visual C#.NET]
imageKit1.File.Pdf.SaveFileName = "test.pdf";
imageKit1.File.Pdf.Start();
//Adds a B5 sized page
imageKit1.File.Pdf.DocumentSize = "B5";
imageKit1.File.Pdf.AddPage();
//adds and image to that page
imageKit1.File.Pdf.AddImage("Image.jpg", 0, 0, 100, 100);
imageKit1.File.Pdf.EndPage();
//adds a A4 sized page
imageKit1.File.Pdf.DocumentSize = "a4";
imageKit1.File.Pdf.AddPage();
//adds an image to that page
imageKit1.File.Pdf.AddImage("Image.bmp", 0, 0, 100, 100);
imageKit1.File.Pdf.EndPage();
imageKit1.File.Pdf.End();

Also See

ImageKit.File.Pdf Members | Newtone.ImageKit.Win.ImageKit


End method

Newtone.ImageKit.Win.ImageKit.File.Pdf.End Method

This method completes the PDF document

[Visual Basic] Public Function End() As Boolean
[C#] public bool End();

Parameters

None

Return Value

Returns True if successful, otherwise returns False

Explanation

The End method completes the PDF document

The PDF document will be saved in the file and path specified by the SaveFileName property.

The End method should be used with the other PDF methods in the following order: Start, AddPage, AddImage, EndPage, End.

Example

See the example on the Start method page.

Also See

ImageKit.File.Pdf Members | Newtone.ImageKit.Win.ImageKit


EndPagee method

Newtone.ImageKit.Win.ImageKit.File.Pdf.EndPage Method

This method ends the page that was added with the AddPage method

[Visual Basic] Public Function EndPage() As Boolean
[C#] public bool EndPage();

Parameters

None

Return Value

Returns True if successful, otherwise returns False

Explanation

The EndPage method ends the page that was added with the AddPage method

The PDF document will be saved in the file and path specified by the SaveFileName property.

The End method should be used with the other PDF methods in the following order: Start, AddPage, AddImage, EndPage, End.

Example

See the example on the Start method page.

Also See

ImageKit.File.Pdf Members | Newtone.ImageKit.Win.ImageKit


Start method

Newtone.ImageKit.Win.ImageKit.File.Pdf.Start Method

This method starts the PDF document

[Visual Basic] Public Function Start() As Boolean
[C#] public bool Start();

Parameters

None

Return Value

Returns True if successful, otherwise returns False

Explanation

The Start method starts the PDF document

The image formats supported are BMP and JPEG

The PDF document will be saved in the file and path specified by the SaveFileName property.

The Start method should be used with the other PDF methods in the following order: Start, AddPage, AddImage, EndPage, End.

Example

Saving a Jpeg image in a PDF file:

[Visual Basic.NET]

'load the image "sample.jpg"
imageKit1.File.FileName = "sample.jpg"
imageKit1.File.LoadImageFromFile(LoadFileType.Load)
'set the image data into the imageKit1.File.RawData property
imageKit1.File.SaveImageToRawData(SaveFileType.SaveJPEG,imageKit1.Image)

'create the pdf
imageKit1.File.Pdf.SaveFileName = "sample.pdf"

imageKit1.File.Pdf.DocumentSize = "a4"
imageKit1.File.Pdf.Start()
imageKit1.File.Pdf.AddPage()
imageKit1.File.Pdf.AddImage(imageKit1.File.RawData, 0, 0, 100, 100)
imageKit1.File.Pdf.EndPage()
imageKit1.File.Pdf.End()

[Visual C#.NET]

//load the image "sample.jpg"
imageKit1.File.FileName ="sample.jpg";
imageKit1.File.LoadImageFromFile(LoadFileType.Load);
//set the image data into the imageKit1.File.RawData property
imageKit1.File.SaveImageToRawData(SaveFileType.SaveJPEG, imageKit1.Image);

//create the pdf
imageKit1.File.Pdf.SaveFileName = "sample.pdf";
imageKit1.File.Pdf.DocumentSize = "a4";
imageKit1.File.Pdf.Start();
imageKit1.File.Pdf.AddPage();
imageKit1.File.Pdf.AddImage(imageKit1.File.RawData, 0, 0, 100, 100);
imageKit1.File.Pdf.EndPage();
imageKit1.File.Pdf.End();

Also See

ImageKit.File.Pdf Members | Newtone.ImageKit.Win.ImageKit


ImageKit Members

Newtone.ImageKit.Win.ImageKit.Layer All Members

Public Properties

BitCount | Refers to the number of bits per pixel in the image set in the Layer(Index).Image property
DXFBlack | Sets whether or not white is displayed as black and black is displayed as white in DXF images
Gray | Determines whether or not the image set in the Layer(Index).Image property is grayscale
Image | Refers to the image handle of the image set in the LayerNumber property
ImageKind | Refers to the type of image set in the Layer(Index).Image property
ImageSize | Refers to the size, in bytes, of the image set in the Layer(Index).Image property
ImageWidthByte | Refers to the number of bytes per line in the image set in the Layer(Index).Image property
PaletteCount | Refers to the number of palette colors for the image set in the Layer(Index).Image property
ShowImage | Sets whether or not the layer image is displayed in the ImageKit Control
ShowPanWindowImage | Sets whether or not the layer image is displayed in the Pan window
StartX | Sets the point (the horizontal position) on the image that will be displayed from the top left corner of the ImageKit Control
StartY | Sets the point (the vertical position) on the image that will be displayed from the top left corner of the ImageKit Control
Transparent | Enables the transparent color in the image set in the Layer(Index).Image property
TransparentBlue | Sets the transparent color's blue value in the image set in the Layer(Index).Image property
TransparentGreen | Sets the transparent color's green value in the image set in the Layer(Index).Image property
TransparentRed | Sets the transparent color's red value in the image set in the Layer(Index).Image property

See Also

Newtone.ImageKit.Win.ImageKit


BitCount property

Newtone.ImageKit.Win.ImageKit.Layer[Index].BitCount Property

This property refers to the number of bits per pixel in the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public ReadOnly Property BitCount As Integer
[C#] public int BitCount {get;}

Property Value

The number of bits per pixel in an image

Value | Explanation
1 | 2 color (i.e. Black and White)
4 | 16 color
8 | 256 color
16 | 16 bit color
24 | 24 bit color
32 | 32 bit color

Explanation

The BitCount property refers to the number of bits per pixel in the image set in the Layer(Index).Image property.

When the Layer(Index).Image property is set the value of the BitCount property is automatically set.

This property is not valid for vector images.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


Gray property

Newtone.ImageKit.Win.ImageKit.Layer[Index].Gray Property

This property determines whether or not the image set in the Layer(Index).Image property is grayscale. The index can range from 0 to 99.
[Visual Basic] Public ReadOnly Property Gray As Boolean
[C#] public bool Gray {get;}

Property Value

Value | Explanation
True | Grayscale
False | Not grayscale

Explanation

The Gray property determines whether or not the image set in the Layer(Index).Image property is grayscale.

After setting the Layer(Index).Image property, the value of the Gray property is automatically set.

This property is not valid for vector images.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


Image property

Newtone.ImageKit.Win.ImageKit.Layer[Index].Image Property

This property refers to the image handle of the image set in the LayerNumber property. The index can range from 0 to 99.

[Visual Basic] Public Property Image As Image
[C#] public Image Image {get; set;}

Property Value

Layer image object

Explanation

The Image property refers to the image handle of the image set in the LayerNumber property.

When the image set in the LayerNumber is loaded, the Image property value is set.

To disable the image referred to by the Image property, set the Image property to 0. By doing this that image data will automatically be freed from the memory.

Example (in Visual Basic)

ImageKit1.LayerNumber = 0
ImageKit1.Layer(0).Transparent = False
ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.Load)

'The image loaded into ImageKit1.Layer(0).Image is set

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


ImageKind property

Newtone.ImageKit.Win.ImageKit.Layer[Index].ImageKind Property

This property refers to the type of image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public ReadOnly Property ImageKind As KindOfImage
[C#] public KindOfImage ImageKind {get;}

Property Value

The number of bits per pixel in an image

Value | Explanation
InvalidImage | Unknown
RasterImage | Raster image
VectorWMF | WMF
VectorEMF | EMF

* The ImageKit.NET3 supports vector image formats WMF and EMF only.

Explanation

The ImageKind property refers to the type of image set in the Layer(Index).Image property.

When the Layer(Index).Image property is set the value of this property is automatically set.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


ImageSize property

Newtone.ImageKit.Win.ImageKit.Layer[index].ImageSize Property

This property refers to the size, in bytes, of the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public ReadOnly Property ImageSize As Integer
[C#] public int ImageSize {get;}

Property Value

The size of the image in bytes

Explanation

The ImageSize property refers to the size, in bytes, of the image set in the Layer(Index).Image property.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


ImageWidthByte property

Newtone.ImageKit.Win.ImageKit.Layer[Index].ImageWidthByte Property

This property refers to the number of bytes per line in the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public ReadOnly Property ImageWidthByte As Integer
[C#] public int ImageWidthByte {get;}

Property Value

The number of bytes per line in the image

Explanation

The ImageWidthByte property refers to the number of bytes per line in the image set in the Layer(Index).Image property.

When the Layer(Index).Image property is set the value of this property is automatically set.

This property is not valid for vector images.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


PaletteCount property

Newtone.ImageKit.Win.ImageKit.Layer[Index].PaletteCount Property

This property refers to the number of palette colors for the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public ReadOnly Property PaletteCount As Integer
[C#] public int PaletteCount {get;}

Property Value

The number of palette colors for the image.

This property value is valid when the BitCount property is less than 8, otherwise 0 is returned.

Explanation

This property refers to the number of palette colors for the image set in the Layer(Index).Image property.

After setting the Layer(Index).Image property, the value of this property is automatically set.

This property is not valid for vector images.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


ShowImage, ShowPanWindowImage property

Newtone.ImageKit.Win.ImageKit.Layer[Index].ShowImage Property

The ShowImage property sets whether or not the layer image is displayed in the ImageKit Control. The index can range from 0 to 99.

[Visual Basic] Public Property ShowImage As Boolean
[C#] public bool ShowImage {get; set;}

Property Value

The ShowImage property sets whether or not the layer image is displayed in the ImageKit Control. The value can range from 0 to 99.

Value | Explanation
True | Displays the layer image
False | Does not display the layer image

Explanation

The ShowImage property sets whether or not the layer image is displayed in the ImageKit Control.

Using this property, you can switch between displaying or hiding the layer image (The layer image is the image pointed to by the Layer(Index).Image property).

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


StartDrawX property

Newtone.ImageKit.Win.ImageKit.Layer[Index].StartX Property

This property sets the point on the image that will be displayed from the top left corner of the ImageKit Control. The index can range from 0 to 99.

[Visual Basic] Public Property StartX As Integer
[C#] public int StartX {get; set;}

Property Value

The horizontal position on the image that will be displayed from the left of the ImageKit Control.

The default value is 0.

Explanation

The StartX property sets the point on the layer image that will be displayed from the top left corner of the ImageKit Control. The image that the StartX property relates to is the image set in the Layer(Index).Image property.

If the base image has not been set this property is disabled.

Example (in Visual Basic)

ImageKit1.Layer(0).StartX = 300
ImageKit1.Layer(0).StartY = 200
ImageKit1.Refresh()

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


StartDrawY property

Newtone.ImageKit.Win.ImageKit.Layer[Index].StartY Property

This property sets the point on the image that will be displayed from the top left corner of the ImageKit Control. The index can range from 0 to 99.

[Visual Basic] Public Property StartY As Integer
[C#] public int StartY {get; set;}

The default value is 0.

Explanation

The StartY property sets the point on the layer image that will be displayed from the top left corner of the ImageKit Control. The image that the StartY property relates to is the image set in the Layer(Index).Image property.

If the base image has not been set this property is disabled.

Example (in Visual Basic)

ImageKit1.Layer(0).StartX = 300
ImageKit1.Layer(0).StartY = 200
ImageKit1.Refresh()

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


Transparent property

Newtone.ImageKit.Win.ImageKit.Layer[Index].Transparent Property

This property enables the transparent color in the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public Property Transparent As Boolean
[C#] public bool Transparent {get; set;}

Property Value

Value | Explanation
True | The transparent color is enabled
False | The transparent color is disabled (default)

Explanation

The Transparent property enables the transparent color in the image set in the Layer(Index).Image property.

The default value is false.

When the Transparent property is True, the color set by the TransparentBlue, TransparentGreen, and TransparentRed properties will be transparent.

To display multiple images without a transparent color, set this property to false.

If the image set in the Layer(Index).Image property is a vector image, then the Transparent property is disabled.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


TransparentBlue property

Newtone.ImageKit.Win.ImageKit.Layer[Index].TransparentBlue Property

This property sets the transparent color in the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public Property TransparentBlue As Byte
[C#] public byte TransparentBlue {get; set;}

Property Value

TransparentBlue is the transparent color's blue value. (Values range from 0 to 255)

Explanation

The TransparentBlue property sets the transparent color in the image set in the Layer(Index).Image property. This property is useful when multiple image are displayed at the same time in the ImageKit Control. When a transparent color is used, the next image layer below the transparent color will appear. The image where the transparent color is set must be 8 bit color or 24 bit color and is specified by the Layer(Index).Image property. If a vector image is set in the base image, this property is disabled.

Example: Setting the transparent color to white (in Visual Basic)

ImageKit1.Layer(0).Transparent = True
ImageKit1.Layer(0).TransparentBlue = 255
ImageKit1.Layer(0).TransparentGreen = 255
ImageKit1.Layer(0).TransparentRed = 255
ImageKit1.LayerNumber = 0
ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.Win.LoadFileType.Load)

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


TransparentGreen property

Newtone.ImageKit.Win.ImageKit.Layer[Index].TransparentGreen Property

This property sets the transparent color in the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public Property TransparentGreen As Byte
[C#] public byte TransparentGreen {get; set;}

Property Value

TransparentGreen is the transparent color's blue value. (Values range from 0 to 255)

Explanation

The TransparentGreen property sets the transparent color in the image set in the Layer(Index).Image property. This property is useful when multiple image are displayed at the same time in the ImageKit Control. When a transparent color is used, the next image layer below the transparent color will appear. The image where the transparent color is set must be 8 bit color or 24 bit color and is specified by the Layer(Index).Image property. If a vector image is set in the base image, this property is disabled.

Example: Setting the transparent color to white (in Visual Basic)

ImageKit1.Layer(0).Transparent = True
ImageKit1.Layer(0).TransparentBlue = 255
ImageKit1.Layer(0).TransparentGreen = 255
ImageKit1.Layer(0).TransparentRed = 255
ImageKit1.LayerNumber = 0
ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.Win.LoadFileType.Load)

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


TransparentRed property

Newtone.ImageKit.Win.ImageKit.Layer[Index].TransparentRed Property

This property sets the transparent color in the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public Property TransparentRed As Byte
[C#] public byte TransparentRed {get; set;}

Property Value

TransparentRed is the transparent color's blue value. (Values range from 0 to 255)

Explanation

The TransparentRed property sets the transparent color in the image set in the Layer(Index).Image property. This property is useful when multiple image are displayed at the same time in the ImageKit Control. When a transparent color is used, the next image layer below the transparent color will appear. The image where the transparent color is set must be 8 bit color or 24 bit color and is specified by the Layer(Index).Image property. If a vector image is set in the base image, this property is disabled.

Example: Setting the transparent color to white (in Visual Basic)

ImageKit1.Layer(0).Transparent = True
ImageKit1.Layer(0).TransparentBlue = 255
ImageKit1.Layer(0).TransparentGreen = 255
ImageKit1.Layer(0).TransparentRed = 255
ImageKit1.LayerNumber = 0
ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.Win.LoadFileType.Load)

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


ImageKit.Magnifier Members

Newtone.ImageKit.Win.ImageKit.Magnifier All Members

Public Properties

Border | Sets whether or not a border is displayed on the magnifier
ShowCursor | Sets whether or not a cursor is displayed in the magnifier
Type | Sets the shape of the magnifier

Public Methods

ShowMagnifier Displays a magnifier in the ImageKit Control. The size of the magnifier is determined by the Height and Width properties.

See Also

Newtone.ImageKit.Win.ImageKit


BorderVisible property

Newtone.ImageKit.Win.ImageKit.Magnifier.Border Property

This property sets whether or not a border is displayed on the magnifier.

[Visual Basic] Public Property Border As Boolean
[C#] public bool Border {get; set;}

Property Value

Value | Explanation
True | A border is displayed on the magnifier (default)
False | A border is not displayed on the magnifier

Explanation

The Border property sets whether or not a border is displayed on the magnifier.

The default value is True. When the Border property is set to True, a black border is displayed on the magnifier.

See Also

ImageKit.Magnifier Members | Newtone.ImageKit.Win.ImageKit


ShowCursor property

Newtone.ImageKit.Win.ImageKit.Magnifier.ShowCursor Property

This property sets whether or not a cursor is displayed in the magnifier.

[Visual Basic] Public Property ShowCursor As Boolean
[C#] public bool ShowCursor {get; set;}

Property Value

Value | Explanation
True | Displays a mouse cursor in the magnifier
False | Does not display a mouse cursor in the magnifier (default)

Explanation

The ShowCursor property sets whether or not a cursor is displayed in the magnifier.

The default value is false. When this property is set to False, no cursor is displayed in the ImageKit Control.

See Also

ImageKit.Magnifier Members | Newtone.ImageKit.Win.ImageKit


Type property

Newtone.ImageKit.Win.ImageKit.Magnifier.Type Property

This property sets the shape of the magnifier.

[Visual Basic] Public Property Type As MagnifierType
[C#] public MagnifierType Type {get; set;}

Property Value

Value | Explanation
RectangleMagnifier | Rectangular magnifier (default)
EllipceMagnifier | Circular magnifier

Explanation

The Type property sets the shape of the magnifier.

When the magnifier is a rectangle, the size of the rectangle is determined by the Width and Height properties. When the magnifier is an ellipse, the Width and Height properties define the rectangle which bounds the ellipse.

See Also

ImageKit.Magnifier Members | Newtone.ImageKit.Win.ImageKit


ShowMagnifier method

Newtone.ImageKit.Win.ImageKit.Magnifier.ShowMagnifier Method

This method displays a magnifier in the ImageKit Control. The size of the magnifier is determined by the Height and Width properties.
[Visual Basic]
Public Function ShowMagnifier(Visible As Boolean, x As Long, y As Long, Scale As Double) As Boolean
[C#]
public bool ShowMagnifier(bool Visible, int x, int y, double Scale)

Parameters

Visible
Sets the display of the magnifier window: True (nonzero) displays the magnifier, False (0) hides the magnifier

x, y
Sets the location of the center of the magnifier (in pixels)

Scale
Sets the magnification of the display in the magnifier (actual size display = 1.0)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The ShowMagnifier method displays a magnifier in the ImageKit Control. The Height and Width properties determine the size of the magnifier and must be set.

When the Visible parameter = False, the x, y, and Scale parameter values are ignored.

The magnifier will be displayed on the image when that image's ShowImage property is set to True. The order in which images are displayed are: base image, layer images (from smallest to largest index).

Note that if the base image has not been set then the layer images are not displayed. The ToolTip property is set to the values other than LengthUnit.None, then the magnifier isn't displayed.

Example

Sample code for displaying the magnifier:

[Visual Basic.NET]
Private Sub ImageKit1_MouseMoveImage(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ImageKit.MouseUpDownEventArgs) Handles ImageKit1.MouseMoveImage
  ImageKit1.Magnifier.Width = 100
  ImageKit1.Magnifier.Height = 100
  ImageKit1.Magnifier.Type = Newtone.ImageKit.Win.MagnifierType.RectangleMagnifier
  ImageKit1.Magnifier.Border = True
  ImageKit1.Magnifier.ShowMagnifier(True, e.X, e.Y, 2)
End Sub

[Visual C#.NET]
private void imageKit1_MouseMoveImage(object sender, Newtone.ImageKit.Win.MouseUpDownEventArgs e)
{
  imageKit1.Magnifier.Width = 100;
  imageKit1.Magnifier.Height = 100;
  imageKit1.Magnifier.Type = Newtone.ImageKit.Win.MagnifierType.EllipseMagnifier;
  imageKit1.Magnifier.Border = true;
  imageKit1.Magnifier.ShowMagnifier(true, e.X, e.Y, 2);
}

See Also

ImageKit.Magnifier Members | Newtone.ImageKit.Win.ImageKit


ImageKit.PanWindow Members

Newtone.ImageKit.Win.ImageKit.PanWindow All Members

Public Properties

Caption | Sets the caption in the Pan Window
CloseBox | Sets whether or not there is a close button on the Pan Window title bar
Color | Sets the color of the Pan Window background
EnableClick | Sets whether or not a mouse click is enabled within the pan window
PWLeft | Sets the left position of the Pan Window
PWShowInTaskbar | Sets whether or not the Pan Window form's icon is displayed in the Windows Taskbar
PWSize | Sets the size of the pan window in pixels
PWTop | Sets the top position of the Pan Window
PWTopMost | Sets whether or not the Pan Window is displayed in the topmost position, above all other windows, regardless of focus.
RectColor | Sets the color of the rectangle border in the Pan Window
RectMouseCursor | Sets the shape of the cursor that is used inside the Pan Window
RectReverse | sets whether the RGB values (the colors) within the selected area in the pan window are normal or reversed

Public Methods

Show Displays the pan window on the screen

See Also

Newtone.ImageKit.Win.ImageKit


Caption property

Newtone.ImageKit.Win.ImageKit.PanWindow.Caption Property

This property sets the caption in the Pan Window.

[Visual Basic] Public Property Caption As String
[C#] public string Caption {get; set;}

Property Value

The string for the caption in the Pan Window

Explanation

The Caption property sets the caption in the Pan Window.

If no text has been entered into the Caption property and the CloseBox property is False then the PanWindow will have no title bar and can not be moved with the mouse.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


CloseBox property

Newtone.ImageKit.Win.ImageKit.PanWindow.CloseBox Property

This property sets whether or not there is a close button on the Pan Window title bar.

[Visual Basic] Public Property CloseBox As Boolean
[C#] public bool CloseBox {get; set;}

Property Value

Value Explanation True Close button is displayed on the title bar of the Pan Window False Close button is not displayed on the title bar of the Pan Window (default)

Explanation

The CloseBox property sets whether or not there is a close button on the Pan Window title bar. When this property is False, the PanWindow can not be moved with the mouse.

If the close button is not displayed on the title bar, the pan window can be hidden using the Show method.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


Color‚’ property

Newtone.ImageKit.Win.ImageKit.PanWindow.Color Property

This property sets the color of the Pan Window background.

[Visual Basic] Public Property Color As Color
[C#] public Color Color {get; set;}

Property Value

The color of the Pan Window background, i.e. that part of the pan window where no image is displayed. (Used when vector images are shown in the pan window)

Explanation

The Color property sets the color of the Pan Window background. Color can be set using RGB (Red, Green, Blue) or the equivalent value.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


EnableClick property

Newtone.ImageKit.Win.ImageKit.PanWindow.EnableClick Property

This property sets whether or not a mouse click is enabled within the pan window.

[Visual Basic] Public Property EnableClick As Boolean
[C#] public bool EnableClick {get; set;}

Property Value

Value Explanation True The mouse click is enabled within the pan window False The mouse click is disabled within the pan window (Default value)

Explanation

The EnableClick property sets whether or not a mouse click is enabled within the pan window.

When True and the left mouse button is clicked inside the pan window (but outside the rectangle in the pan window), the image in the ImageKit Control will be centered at the click location. The rectangle in the pan window will also be centered at the click location.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


PWLeft property

Newtone.ImageKit.Win.ImageKit.PanWindow.PWLeft Property

This property sets the left position of the Pan Window.

[Visual Basic] Public Property PWLeft As Integer
[C#] public integer PWLeft {get; set;}

Property Value

The distance of the top left corner of the Pan Window from the top left corner of the screen (in pixels).

The PWLeft property sets the left position of the Pan Window.

Explanation

The PWLeft property sets where the left position of the Pan Window will be placed on the screen.

The size of the Pan Window is determined by the PWSize property. By using the pan window you can easily view the entire image currently displayed in the ImageKit Control.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


PWShowInTaskbar property

Newtone.ImageKit.Win.ImageKit.PanWindow.PWShowInTaskbar Property

This property sets whether or not the Pan Window form's icon is displayed in the Windows Taskbar

[Visual Basic] Public Property PWShowInTaskbar As Boolean
[C#] public bool PWShowInTaskbar {get; set;}

Property Value

True: Displayed in the Windows Taskbar
False: Not displayed in the Windows Taskbar.

Default value: False

Explanation

The PWShowInTaskbar property sets whether or not the Pan Window form's icon is displayed in the Windows Taskbar.

When the PWShowInTaskbar is true, the Pan Window form's icon is displayed in the Windows Taskbar.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


PWTop property

Newtone.ImageKit.Win.ImageKit.PanWindow.PWTop Property

This property sets the top position of the Pan Window.

[Visual Basic] Public Property PWTop As Integer
[C#] public integer PWTop {get; set;}

Property Value

The distance of the top left corner of the Pan Window from the top left corner of the screen (in pixels).

The PWTop property sets the top position of the Pan Window.

Explanation

The PWTop property sets where the top position of the Pan Window will be placed on the screen.

The size of the Pan Window is determined by the PWSize property. By using the pan window you can easily view the entire image currently displayed in the ImageKit Control.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


PWTopMost property

Newtone.ImageKit.Win.ImageKit.PanWindow.PWTopMost Property

This property sets whether or not the Pan Window is displayed in the topmost position, above all other windows, regardless of focus.

[Visual Basic] Public Property PWTopMost As Boolean
[C#] public bool PWTopMost {get; set;}

Property Value

True: Displayed in the topmost position (above all other windows.)
False: The window that has focus is displayed in the topmost position.

Default value: True

Explanation

The PWTopMost property sets whether or not the Pan Window is displayed in the topmost position, above all other windows, regardless of focus.

When the PWTopMost is true, the Pan Window is displayed in the top most position. It will be above other windows even if those windows have focus. When this property is false, the window that has focus is displayed in the topmost position.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


RectColor property

Newtone.ImageKit.Win.ImageKit.PanWindow.RectColor Property

This property sets the color of the rectangle border in the Pan Window.

[Visual Basic] Public Property RectColor As Color
[C#] public Color RectColor {get; set;}

Property Value

The color of the rectangle border in the Pan Window

Explanation

The RectColor property sets the color of the rectangle border in the Pan Window.Color can be set using RGB (Red, Green, Blue) or the equivalent value.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


RectMouseCursor property

Newtone.ImageKit.Win.ImageKit.PanWindow.RectMouseCursor Property

This property sets the shape of the cursor that is used inside the Pan Window.

[Visual Basic] Public Property RectMouseCursor As Cursor
[C#] public Cursor RectMouseCursor {get; set;}

Property Value

The members of the Cursors class for .NET Framework

The default value is Cursors.SizeAll.

Explanation

The RectMouseCursor property sets the shape of the cursor that is used inside the Pan Window.

The code below illustrates how to set the shape of the cursor to hourglass: (in Visual Basic)

ImageKit1.PanWindow.RectCursor = Cursors.WaitCursor

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


RectReverse property

Newtone.ImageKit.Win.ImageKit.PanWindow.RectReverse Property

This property sets whether the RGB values (the colors) within the selected area in the pan window are normal or reversed.

[Visual Basic] Public Property RectReverse As Boolean
[C#] public bool RectReverse {get; set;}

Property Value

Value Explanation True Reverses the RGB values within the selected area in the pan window. False Does not reverse the RGB values within the selected area in the pan window (default).

Explanation

The RectReverse property sets whether the RGB values (the colors) within the selected area in the pan window are normal or reversed.

When the RectReverse property is True, the RGB values (the colors) inside the selected area will be reversed.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


PWSize property

Newtone.ImageKit.Win.ImageKit.PWPanWindow.PWSize Property

This property sets the size of the pan window in pixels.

[Visual Basic] Public Property PWSize As Integer
[C#] public integer PWSize {get; set;}

Property Value

The size of the pan window in pixels

Explanation

The PWSize property sets the size of the pan window in pixels.

The display of the image in the Pan Window is scaled by taking the longer of either the height or width dimension of the image and scaling that dimension to fit within the size specified in the PWSize property. The other dimension will then be scaled to maintain the original image height to width ratio. Therefore, if the height of the image is the longer than the width, then the value set in the PWSize property will apply to the height of the Pan Window. If the width of the image is the longer than the height, then the value set in the PWSize property will apply to the width of the Pan Window.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


Show method

Newtone.ImageKit.Win.ImageKit.PanWindow.Show Method

This method displays the pan window on the screen.

[Visual Basic] Public Function Show(Visible As Booleana) As Boolean
[C#] public bool Show(bool Visible)

Parameters

Value Explanation Visible Displays or hides the Pan Window
[True (nonzero): the Pan Window is displayed, False(0): the Pan Window is hidden]

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Show method displays the pan window on the screen. The location of the pan window is determined by the PWLeft and PWTop properties. The size of the pan window is determined by the PWSize property.

When the Visible parameter is True, the PWLeft, PWTop, and PWSize properties must be set. This method is only enabled when the image is displayed in actual size.

The Pan Window will be displayed when the image's ShowPanWindowImage property is set to True. The order in which images are displayed are: base image, layer images (from smallest to largest index). Note that if the base image has not been set then the layer images are not displayed.

If the ImageKit Control is placed on a modal form then please display the pan window after the form has been displayed.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


Scan Members

Newtone.ImageKit.Win.ImageKit.Scan All Members

Public Properties

AdjustGamma | Sets the Gamma coefficient.
AutoBright | Sets whether or not automatic brightness is enabled.
BitDepth | Sets the number of bits per pixel in the scanned image
BitDepthReduction | Sets the method used to reduce the bit depth when scanning in 1 bit color
Border | Removes the black borders, formed during scanning or copying, from around the images
BorderColor | Sets the color used during border correction
BorderDetection | Enables automatic border detection
Brightness | Sets the scan brightness
ColorBWRatio | Sets the allowable ratio of color pixels in a document for the scanner to scan in black and white
Compression | Sets the compression method used when an image is transferred via memory
ContainerType | Retrieves the TWAIN container type for the specified capability
Contrast | Sets the scan contrast
Count | Retrieves the number of scanned images
CurrentIndex | Retrieves the index of the current value
DataSourceName | Sets the name of the scan device
DefaultIndex | Retrieves the index of the default value
Deskew | Sets whether or not deskew is enabled
DllFileName | Sets the TWAIN Dll filename
DropoutColor | Sets the dropout color
DynamicThreshold | Sets the dynamic threshold level
ExtendedUserInterface | Sets whether or not the extended user interface is used
FileFormat | Sets the file format when saving a file using file transfer.
FileName | Sets the file name when saving a file using file transfer or using memory transfer with compression
FocusPosition | Sets the focus position of the scan
Gamma | Sets the gamma correction
Halftone | Sets the halftone
Highlight | Sets the scanning highlight
IgnoreBackColor | Sets whether or not the background color of the document is ignored when automatically determining whether to scan in black and white or in color
ImageFilter | Sets the image filter
ImageMerge | Sets the double sided merge mode
Indicator | Sets whether or not the indicator is displayed when scanning
InformationFileName | Sets the information file where the scan settings, set in the scan manufacturer's scan driver interface, are saved
JpegQuality | Sets the JpegQuality when using file or memory transfer with JPEG compression.
Mode | Sets the scanning mode
MoireFilter | Sets the level for the Moire filter
NoiseFilter | Sets the noise reduction filter
Orientation | Sets the orientation of the paper
Overscan | Enables "over scan" capabilities enlarging the scan area
PageCount | Sets the number of images to be scanned
PaperSize | Sets the size of the paper
PixelType | Sets the type of image scanned
Rect | Sets the scanning position
RemoveHole | Sets hole removal
RotateBack | Sets whether or not the back side of the page is rotated when scanning on both sides using an ADF
Rotation | Sets the rotation angle for the scanned image
ScanningSpeed | Increases the speed at which a document is scanned
Shadow | Sets the shadow
Sharpness | Sets the level of sharpness
SkipBlankPage | Sets whether or not a blank page will be skipped
SkipBlankThreshold | Sets the threshold value to determine if a blank page is included with pages to be scanned and whether that blank page will be skipped
TextEnhancement | Sets the type of text enhancement used
Threshold | Sets the scanning threshold
Transfer | Sets whether native, file, or memory transfer is used
Unit | Sets the units of measurement
UserInterface | Sets whether the scan driver's user interface is used or if a custom built user interface is used.
Value | Retrieves the value supported for the specified capability
XResolution | Sets the horizontal scan resolution
XScaling | Sets the horizontal scaling (magnification)
YResolution | Sets the vertical scan resolution
YScaling | Sets the vertical scaling (magnification)

Public Methods

ClearProperty | Resets the scan control properties
CloseDataSource | Closes the scan device
Execute | Retrieves an image from a TWAIN scan device
GetBitDepth | Retrieves the bit depth supported by the scan device
GetCapabilityEnumToSingle | Retrieves the possible setting values for a specified property of the scan device
GetCapabilityEnumToString | Retrieves the possible setting values for a specified property of the scan device
GetCapabilityRange | Retrieves the range of possible setting values for a specified functionality of the scan device
GetCurrentDataSource | Retrieves information about the scan device currently being selected
GetDataSources | Retrieves information about the specified scan device
GetMinimumSize | Retrieves the smallest size that can be scanned with a given scan device
GetPhysicalSize | Retrieves the largest physical size that can be scanned with a given scan device
Initialize | Starts the TWAIN process
IsCapabilitySupported | Confirms whether or not a functionality is supported by the scan device
IsOpenDataSource | Checks whether or not the scan device is open
OpenDataSource | Opens the scan device
SelectDataSource | Selects the scan device
Terminate | Ends the TWAIN process

See Also

Newtone.ImageKit.Win.ImageKit


AdjustGamma property

Newtone.ImageKit.Win.ImageKit.Scan.AdjustGamma Property

This property sets the Gamma coefficient. (UserInterface=Suppress)

[Visual Basic] Public WriteOnly Property AdjustGamma As Integer
[C#] public int AdjustGamma {set;}

Property Values

0: Gamma Coefficient is 1.0

1: Gamma Coefficient is 1.8

The default value is 0

Explanation

The AdjustGamma property sets the Gamma coefficient. This property is enabled for certain Epson scanners. Setting this property to 1 makes the scanned image brighter.

This property is enabled when the UserInterface property is set to Suppress. To find out if your datasource supports gamma adjustment, please refer to the IsCapabilitySupported method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


AutoBright property

Newtone.ImageKit.Win.ImageKit.Scan.AutoBright Property

This property sets whether the automatic brightness adjustment is enabled. (UserInterface=Suppress)

[Visual Basic] Public Property AutoBright As Boolean
[C#] public bool AutoBright {get; set;}

Property Values

True: Brightness is automatically adjusted

False: Brightness adjustment is manual

The default value is False

Explanation

The AutoBright property sets whether the automatic brightness adjustment is enabled. When true, brightness is adjusted automatically. When false or when this capability is not supported, the Brightness property will be enabled.

This property is enabled when the UserInterface property is set to Suppress. To find out if your datasource supports AutoBright, please refer to the IsCapabilitySupported method or the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


BitDepth property

Newtone.ImageKit.Win.ImageKit.Scan.BitDepth Property

This property sets the number of bits per pixel in the scanned image.

[Visual Basic] Public Property BitDepth As Integer
[C#] public int BitDepth {get; set;}

Property Value

When the Pixeltype property is BW, the BitDepth is 1

When the Pixeltype property is Gray, the BitDepth is 4, 8, 12, 14, or 16

When the Pixeltype property is RGB, the BitDepth is 24, 36, 42, or 48

When the Pixeltype property is Palette, the BitDepth is 4 or 8

When the Pixeltype property is Automation, the BitDepth is 24

Retrieve only

Explanation

The BitDepth property sets the number of bits per pixel in the scanned image. This property is only enabled when the UserInterface property is Suppress. Note: If a digital camera image or other scan device does not support this functionality, then this property is disabled.

To retrieve the range of possible bit depth settings for a scan device, execute the GetBitDepth method. When scanning in 12, 14, 16, 36, 42, or 48 bit color, please set the Transfer property to Memory. If an error is returned for a value that the scan device is supposed to support, please set 0 into the BitDepth property in which case the bit depth default value indicated by the PixelType property will be used.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


BitDepthReduction property

Newtone.ImageKit.Win.ImageKit.Scan.BitDepthReduction Property

This property sets the method used to reduce the bit depth when scanning in 1 bit color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property BitDepthReduction As Newtone.ImageKit.ScanBitDepthReduction
[C#] public Newtone.ImageKit.ScanBitDepthReduction BitDepthReduction {set;}

Property Value

This value is of typeScanBitDepthReduction

Explanation

The BitDepthReduction property sets the method used to reduce the bit depth when scanning in 1 bit color. This property is enabled when the UserInterface property is Suppress and the PixelType property is BW. Note: The BitDepthReduction property is disabled when using a digital camera.

When the BitDepthReduction property is Threshold, the Threshold property is enabled (In some scan devices the Brightness property is enabled). When the BitDepthReduction property is Halftone, the HalfTone, Brightness, and Contrast properties are enabled.

To retrieve the value of the BitDepthReduction property that is supported by the scan device, please execute the GetCapabilityEnumToSingle method. In the case where the scan device does not support the BitDepthReduction functionality, but supports either Threshold or HalfTone, then set this property to Threshold or Halftone whichever the case may be.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Border property

Newtone.ImageKit.Win.ImageKit.Scan.Border Property

This property removes the black borders, formed during scanning or copying, from around the images. This property is only enabled when using a custom-built user interface (UserInterface= 2).

[Visual Basic] Public Property Border As Integer
[C#] public int Border {get; set;}

Property Value

Epson Scan Driver (Border Correction for Epson scanners is called "Edge Fill")

Value | Explanation
0 | Border correction is not used
1 | Border correction is used

Panasonic Scan Driver (Border Removal)

Value | Explanation
0 | Border is not removed
1 | Border is removed - automatic mode (Detects the edges of the document area and corrects to the width specified)
2 | Border is removed - fixed mode (Corrects uniformly from the edges of the image to the width specified)

Default value is 0.

Explanation

The Border property removes the black borders, formed during scanning or copying, from around the images and is enabled for Epson and Panasonic scan drivers only. This property sets whether or not border correction is used. For Epson scanners, border correction is known as "Edge Fill". For Panasonic scanners border correction is known as "Border Removal".

If the Border property is 1 or more, then the color set in the BorderColor property is used as the fill color.

The Border property is enabled with the UserInterface property is set to Suppress. To check whether or not border correction is supported, please refer to the IsCapabilitySupported method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


BorderColor property

Newtone.ImageKit.Win.ImageKit.Scan.BorderColor Property

This property sets the color used during border correction. This property is only enabled when using a custom-built user interface (UserInterface= 2).

[Visual Basic] Public Property BorderColor As Integer
[C#] public int BorderColor {get; set;}

Property Value

Epson Scan Driver (Border Correction for Epson scanners is called "Edge Fill")

Value | Explanation
0 | White
1 | Black

Panasonic Scan Driver (Border Removal)

Value | Explanation
0 | Document border color used (the color of the area near the edge of the document)
1 | Document background color used
2 | White

Default value is 0.

Explanation

The Border property sets the color used during border correction. It is enabled for Epson and Panasonic scan drivers only.

If the Border property is 1 or more, then the color set in the BorderColor property is used as the fill color.

The BorderColor property is enabled with the UserInterface property is set to Suppress.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


BorderDetection property

Newtone.ImageKit.Win.ImageKit.Scan.BorderDetection Property

This property enables automatic border detection. This property is only enabled when using a custom-built user interface (UserInterface= 2).

[Visual Basic] Public WriteOnly Property BorderDetection As Boolean
[C#] public bool BorderDetection {set;}

Property Value

Value | Explanation
True | Automatic border detection is enabled
False | Automatic border detection is disabled

Explanation

The BorderDetection property enables automatic border detection. The document plate scan area will automatically be set according to paper size. This property is only enabled when the UserInterface property is Suppress and the PaperSize property is UndefinedSize or set to values of more than 1000. Note: If a digital camera image or other scan device does not support this functionality, then this property is disabled. To find out if the datasource supports this functionality, please execute the IsCapabilitySupported method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Brightness property

Newtone.ImageKit.Win.ImageKit.Scan.Brightness Property

This property sets the scan brightness. Enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property Brightness As Integer
[C#]public int Brightness {set;}

Property Value

From -1000 to 1000. The default value is 0.

For Fujitsu PFU scan devices, when the PixelType property is Automation, GrayAndBW, or RGBAndBW, the value range for Brightness is from -127 to 127.

Explanation

The Brightness property sets the scan brightness. This property is only enabled when the UserInterface property is set to Suppress and the AutoBright property is false.

Note: There are cases when the PixelType property is BW and depending on the BitDepthReduction property value the Brightness property has no affect. See below.

The Brightness property is okay

When PixelType = BW and the BitDepthReduction = Threshold (*) or Halftone.

When the PixelType = Gray, RGB, or Palette

(*) This is only for scan devices that do not support Threshold and use uses Brightness instead.

Note: This property is disabled for digital cameras and scanners that do not support these functions. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ColorBWRatio property

Newtone.ImageKit.Win.ImageKit.Scan.ColorBWRatio Property

This property sets the allowable ratio of color pixels in a document for the scanner to scan in black and white. Beyond this value, the scanner will scan in rgb color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property ColorBWRatio As Single
[C#] public float ColorBWRatio {set;}

Property Value

The value range is from 0.01 to 50.00 in percentage units.

Default value is 1.

Explanation

The ColorBWRatio property is useful in determining whether or not to scan in RGB color or black and white. This property sets the allowable ratio of color pixels in a document for the scanner to scan in black and white. Beyond this value, the scanner will scan in rgb color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

ENABLED FOR PANASONIC SCAN DRIVERS ONLY

The default value is one, meaning that the scanner will scan in rgb color. The allowable range that can be set in the ColorBWRatio property is from 0.01 to 50.00 percent. As the value of this property increases, a larger proportion of pixels in the document must be color before the scanner will scan in rgb color. This property is only enabled when the UserInterface property is Suppress, and the PixelType property is Automation.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Compression property

Newtone.ImageKit.Win.ImageKit.Scan.Compression Property

This property sets the compression method used when an image is transferred via memory.

[Visual Basic] Public Property Compression As Newtone.ImageKit.ScanCompression
[C#] public Newtone.ImageKit.ScanCompression Compression {get; set;}

Property Value

This value is of type ScanCompression

Explanation

The Compression property sets the compression method used when an image is transferred via memory. When scanning with a custom user interface (with the scan driver's user interface suppressed), be sure to set appropriate values in the PixelType and the BitDepth properties. For example, Tiff group 3 or 4 compression images must be 1 bit black and white; JPEG compression images must be either 8 bit grayscale or 24 bit color.

For details about the different methods for transferring images, please refer to the Transfer property. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. Depending on the datasource, uncompressed may be the only file transfer compression method available.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ContainerType property

Newtone.ImageKit.Win.ImageKit.Scan.ContainerType Property

This property retrieves the TWAIN container type for the specified capability.

[Visual Basic] Public ReadOnly Property ContainerType As Integer
[C#] public int ContainerType {get;}

Property Value

Value | Explanation
0 | Failed method
3 | Array Type
4 | Enumeration Type
5 | Single Type
6 | Range Type

Explanation

The ContainerType property retrieves the TWAIN container type for the capability specified. By executing the GetCapabilityEnumToSingle, GetCapabilityEnumToString, and GetCapabilityRange, the values are set in this property.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Brightness property

Newtone.ImageKit.Win.ImageKit.Scan.Contrast Property

This property sets the scan contrast. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Contrast As Integer
[C#] public int Contrast {set;}

Property Value

From -1000 to 1000. The default value is 0

For Fujitsu PFU scan devices, when the PixelType property is Automation, GrayAndBW, or RGBAndBW, the value range for Contrast is from -127 to 127.

Explanation

The Contrast property sets the scan contrast. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

Note: There are cases when the PixelType property is BW and depending on the BitDepthReduction property value the Contrast property has no affect. See below.

The Contrast property is okay

When PixelType = BW and the BitDepthReduction = Halftone.

When the PixelType = Gray, RGB, or Palette

Note: This property is disabled for digital cameras and scanners that do not support these functions. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Count property

Newtone.ImageKit.Win.ImageKit.Scan.Count Property

This property retrieves the number of scanned images.

[Visual Basic] Public ReadOnly Property Count As Integer
[C#] public int Count {get;}

Property Value

The number of scanned images

Explanation

The Count property retrieves the number of scanned images. After executing the Execute method, the value is set in this property.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


CurrentIndex property

Newtone.ImageKit.Win.ImageKit.Scan.CurrentIndex Property

This property retrieves the index of the current value.

[Visual Basic] Public ReadOnly Property CurrentIndex As Integer
[C#] public int CurrentIndex {get;}

Property Value

The index of the current value

Explanation

The CurrentIndex property retrieves the index of the current value. When the GetCapabilityEnumToSingle method, the GetCapabilityEnumToString method, or the GetDataSources method is executed, the retrieved values are set in an array. This property retrieves the index in the array that refers to the current value. If any of the above methods fail, -1 will be set in the CurrentIndex property.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


DataSourceName property

Newtone.ImageKit.Win.ImageKit.Scan.DataSourceName Property

This property sets the name of the scan device.

[Visual Basic] Public Property DataSourceName As String
[C#] public string DataSourceName {set;}

Property Value

The name of the scan device

Explanation

The DataSourceName property sets the name of the scandevice. The DataSourceName property must be set prior to executing the OpenDataSource or the Execute methods. However, if the Execute method is executed after the OpenDataSource method then the DataSourceName property value will be disregarded. If the DataSourceName property is not set, the scan device selected by the SelectDataSource method will be used.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


DefaultIndex property

Newtone.Win.ImageKit

Newtone.ImageKit.Win.ImageKit.Scan.DefaultIndex Property

This property retrieves the index of the default value

[Visual Basic] Public ReadOnly Property DefaultIndex As Integer
[C#] public int DefaultIndex {get;}

Property Value

The index of the default value

Explanation

When the GetCapabilityEnumToSingle method or the GetCapabilityEnumToString method are executed the values are returned in an array. The DefaultIndex property retrieves the index that refers to the default value. If the above methods fail, -1 will be set in this property.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Deskew property

Newtone.ImageKit.Win.ImageKit.Scan.Deskew Property

This method sets whether or not deskew is enabled. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Deskew As Integer
[C#] public int Deskew {set;}

Property Value

Value | Explanation
0 | Deskew is disabled
1 | Deskew is enabled
2 | Deskew is enabled (with smoothing)

Explanation

The Deskew method sets whether or not deskew is enabled when scanning. This property is only enabled when the UserInterface property is Suppress. Note: If a digital camera image or other scan device does not support this functionality, then this property is disabled. The Deskew property is enabled when the PaperSize property is set to UndefinedSize or to values of 1000 or more. However, there are cases, depending on the datasource, when the Deskew property is enabled for other paper sizes as well.

Deskew with smoothing is only available for certain Panasonic scan drivers (memory transfer uncompressed mode only).

To find out if the datasource supports this functionality, please execute the IsCapabilitySupported method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


DllFileName property

Newtone.ImageKit.Win.ImageKit.Scan.DllFileName Property

This property sets the TWAIN Dll filename.

[Visual Basic] Public Property DllFileName As String
[C#] public string DllFileName {get; set;}

Property Value

The TWAIN Dll filename

Explanation

The DllFileName property sets the filename for the TWAIN Dll. If your application is a 32 bit application that uses the twain_32.dll (Windows Folder) or if the application is a 64 bit application that uses the 64 bit TWAINDSM.dll (Windows\System32 Folder), then it is not necessary to set the filename in the DllFileName property. The ImageKit will use these TWAIN DLL files by default. However if your 32 bit application uses the 32 bit TWAINDSM.dll file, then you must set that file name into DllFileName property.

For the DllFileName property to take effect, please set this prior to executing the Initialize method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


DropoutColor property

Newtone.ImageKit.Win.ImageKit.Scan.DropoutColor Property

This Property sets the dropout color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property DropoutColor As Newtone.ImageKit.ScanDropoutColor
[C#] public Newtone.ImageKit.ScanDropoutColor DropoutColor {set;}

Property Value

This value is of type ScanDropoutColor

Explanation

The DropoutColor property sets the dropout color. This property is only enabled when the UserInterface property is Suppress, and the PixelType property is either BW or Gray. Note: If a digital camera image or other scan device does not support this functionality, then this property is disabled. To disable the dropout color, please set this property to None or White. To find out if the datasource supports this functionality, please execute the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


DynamicThreshold property

Newtone.ImageKit.Win.ImageKit.Scan.DynamicThreshold Property

This method sets the dynamic threshold level. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property DynamicThreshold As Integer
[C#] public int DynamicThreshold {set;}

Property Value

Value | Explanation
0 | None
1 | Bright
2 | A little brighter
3 | Standard
4 | A little darker
5 | Dark

Explanation

The DynamicThreshold property sets the dynamic threshold level.

DynamicThreshold is only available on certain Panasonic scan drivers

Dyanamic threshold functionality allows you to scan text and images clearly with optimum quality. This property is enabled when the UserInterface property is Suppress and PixelType property is BW. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. When setting the DynamicThreshold property to 1 or more, then the values set in the BitDepthReduction, HalfTone, Sharpness , and Threshold properties will be disabled.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ExtendedUserInterface property

Newtone.ImageKit.Win.ImageKit.Scan.ExtendedUserInterface Property

This property sets whether or not the extended user interface is used.

[Visual Basic] Public WriteOnly Property ExtendedUserInterface As Integer
[C#] public int ExtendedUserInterface {set;}

Property Value

Value | Explanation
0 | Start up the UserInterface mode that was last used
1 | Start up the professional mode
2 | Start up the automatic mode
3 | Start up the home mode
4 | Start up the automatic mode (with no error messages and supressed UI)
5 | Start up office mode

Explanation

The ExtendedUserInterface property sets whether or not the extended user interface is used.

Extended UserInterface mode is available only for certain Epson scan drivers

The ExtendedUserInterface property settings are only possible when displayed with the standard "EPSON Scan" user interface. For example: In ES Series, all settings except 2 and 4 are possible. In the GT Series, all settings except 5 is possible when not connected to the ADF but if the ADF is connected then settings 2 or 4 are also not possible. The ExtendedUserInterface property is enabled when the UserInterface property is Show or ShowandClose. To retrieve the value supported by your datasource, execute the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


FileFormat property

Newtone.ImageKit.Win.ImageKit.Scan.FileFormat Property

This property sets the file format when saving a file using file transfer.

[Visual Basic] Public Property FileFormat As Newtone.ImageKit.ScanFileFormat
[C#] public Newtone.ImageKit.ScanFileFormat FileFormat {get; set;}

Property Value

This value is of type ScanFileFormat

Explanation

The FileFormat property sets the file format when saving a file using file transfer. Please set at appropriate value in the Compression property for the file format set here. Note that depending on the datasource, only uncompressed mode is possible when using file transfer. To retrieve the values supported by the datasource, please execute the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


FileName property

Newtone.ImageKit.Win.ImageKit.Scan.FileName Property

This property sets the file name when saving a file using file transfer or using memory transfer with compression.

[Visual Basic] Public WriteOnly Property FileName As String
[C#] public string FileName {set;}

Property Value

The file name of the saved file

Explanation

The FileName property sets the file name when saving a file using file transfer or using memory transfer with compression. When the Transfer property is File or Memory and the Compression property is set to values other than None then the file will be saved according to the FileName property. (up to 255 bytes). If the FileName property is set with an empty string, null, or Nothing then the file cannot be saved. When using file transfer mode the a FileName property MUST be set. When the UserInterface property is Suppress and the Mode property is DocumentPlate, the file will be saved according to the FileName property. However, for other settings, a four digit series of numbers will be added just before the file extention. (i.e. Image.bmp will be Image0001.bmp).

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


FocusPosition property

Newtone.ImageKit.Win.ImageKit.Scan.FocusPosition Property

This property sets the focus position of the scan. (UserInterface= Suppress)

[Visual Basic]Public WriteOnly Property FocusPosition As Integer
[C#]public int FocusPosition {set;}

Propery Value

Focal Position
Default value is 0.

Explanation

The FocusPosition property adjusts the focus position of the scan. This property is enabled when using Epson scanners.

Value ranges vary from one scanner to another and are in units of 0.1 mm. For example to move the focus position by 1 mm, set a value of 10 in this property.

The FocusPosition property is enabled when the UserInterface property is set to Suppress. To get information on whether or not the datasource supports focus position, use the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Gamma property

Newtone.ImageKit.Win.ImageKit.Scan.Gamma Property

This property sets the gamma correction. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Gamma As Single
[C#] public float Gamma {set;}

Property Value

The default value is 2.2.

Explanation

The Gamma property sets the gamma correction for the scan. This property is enabled when the UserInterface property is Suppress. However, the Gamma property is disabled when using a digital camera or when the datasource does not support this functionality. To retrieve the values supported, please execute the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Halftone property

Newtone.ImageKit.Win.ImageKit.Scan.Halftone Property

This property sets the halftone. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Halftone As String
[C#] public string Halftone {set;}

Property Value

The halftone name

Explanation

The HalfTone property sets the halftone. This property is enabled when the UserInterface property is Suppress, the PixelType property is BW, and the BitDepthRedution property is Halftone. However, the Halftone property is disabled when using a digital camera or when the datasource does not support this functionality. To retrieve the values supported, please execute the GetCapabilityEnumToString method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Highlight property

Newtone.ImageKit.Win.ImageKit.Scan.Highlight Property

This property sets the scanning highlight. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Highlight As Integer
[C#] public int Highlight {set;}

Property Value

From 0 to 255

The Highlight property sets the highlight. (Default value is 255)

Explanation

The Highlight property sets the scanning highlight. This property is enabled when the UserInterface property is Suppress and the PixelType property value is other than BW. However, the Highlight property is disabled when using a digital camera or when the datasource does not support this functionality. To retrieve the values supported, please execute the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit.Scan


IgnoreBackColor property

Newtone.ImageKit.Win.ImageKit.Scan.IgnoreBackColor Property

This property sets whether or not the background color of the document is ignored when automatically determining whether to scan in black and white or in color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property IgnoreBackColor As Boolean
[C#] public bool IgnoreBackColor {set;}

Property Value

Value | Explanation
True | Ignore the back color
False | Does not ignore the back color (Default)

Explanation

The IgnoreBackColor property sets whether or not the background color of the document is ignored when automatically determining whether to scan in black and white or in color.

IgnoreBackColor is only available with certain Panasonic scan drivers

This property is enabled when the UserInterface property is Suppress and the PixelType property is Automation.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ImageFilter property

Newtone.ImageKit.Win.ImageKit.Scan.ImageFilter Property

This property sets the image filter. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property ImageFilter As Newtone.ImageKit.ScanImageFilter
[C#] public Newtone.ImageKit.ScanImageFilter ImageFilter {set;}

Property Value

This value is of type ScanImageFilter

Explanation

The ImageFilter property sets the image filter, which can improve image quality. LOWPASS is recommended for haftone images, BANDPASS for images that include text, and HIGHPASS for images that include lines. The ImageFilter property is enabled when the UserInterface property is Suppress. Note that the ImageFilter property is disabled when using a digital camera or when the datasource does not support this functionality. To retrieve the values supported, please execute the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ImageMerge property

Newtone.ImageKit.Win.ImageKit.Scan.ImageMerge Property

This property sets the double sided merge mode. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property ImageMerge As Newtone.ImageKit.ScanImageFilter
[C#] public Newtone.ImageKit.ScanImageFilter ImageMerge {set;}

Property Value

This value is of type ScanImageMerge

Explanation

The ImageMerge property sets the double sided merge mode. When using ADF duplex scanning, a value other than None for this property will merge the front and back images into a single image. Default value is None. This property is enabled when the UserInterface property is set to Suppress and the Mode property is set to ADFBothSide. Keep in mind that rotation settings will affect the output.

To find out if the datasource supports this property, execute the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Indicator property

Newtone.ImageKit.Win.ImageKit.Scan.Indicator Property

This property sets whether or not the indicator is displayed when scanning. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Indicator As Boolean
[C#] public bool Indicator {set;}

Property Value

Value | Explanation
True | The indicator is displayed
False | The indicator is not displayed

Explanation

The Indicator property sets whether or not the indicator is displayed when scanning. This property is enabled when the UserInterface property is Suppress.

Note: The Indicator property is disabled for scan devices that do not support this function.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


InformationFileName property

https://www.pinterest.jp/pin/134615476341397847/Newtone.ImageKit.Win

Newtone.ImageKit.Win.ImageKit.Scan.InformationFileName Property

This property sets the information file where the scan settings, set in the scan manufacturer's scan driver interface, are saved. Saved information can be loaded from the InformationFile and used in your custom built scan interface.

[Visual Basic] Public Property InformationFileName As String
[C#] public string InformationFileName {get; set;}

Property Value

The filename of the file where the scan settings are saved

Explanation

The InformationFileName property sets the information file where the scan settings, set in the scan manufacturer's scan driver interface, are saved. Saved information can be loaded from the InformationFile and used in your custom built scan interface. To use the InformationFileName property, the scan driver's user interface must be used once but after that all those settings can be loaded into a custom built scan interface. Also, if an infomation file exists containing previous setting information, the setting information is loaded and displayed in the UI (making it possible to check the previously saved contents).

Examples

The following code will save the settings used in the scan driver's user interface in the information file and load those setting from the file.

[Visual Basic.NET]
Dim Ret As Boolean

ImageKit1.Scan.UserInterface = ScanUserInterface.SetOnly
ImageKit1.Scan.InformationFileName = "ui.dat"
                'If the file already exists, the settings will be loaded and displayed in the
                UI.
Ret = ImageKit1.Scan.Execute()
if Ret = False Then Exit Sub

ImageKit1.Scan.Transfer = ScanTransfer.Memory
ImageKit1.Scan.Compression = ScanCompression.None
ImageKit1.Scan.UserInterface = ScanUserInterface.Suppress
ImageKit1.Scan.Mode = ScanMode.InformationFile
Ret = Scan.Execute()

[Visual C#.NET]
bool Ret;

imageKit1.Scan.UserInterface = ScanUserInterface.SetOnly;
imageKit1.Scan.InformationFileName = "ui.dat";
                //If the file already exists, the settings will be loaded and displayed in the
                UI.
Ret = imageKit1.Scan.Execute();
if (!Ret) return;

imageKit1.Scan.Transfer = ScanTransfer.Memory;
imageKit1.Scan.Compression = ScanCompression.None;
imageKit1.Scan.UserInterface = ScanUserInterface.Suppress;
imageKit1.Scan.Mode = ScanMode.InformationFile;
Ret = imageKit1.Scan.Execute();

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


JpegQuality property

Newtone.ImageKit.Win.ImageKit.Scan.JpegQuality Property

This property sets the JpegQuality when using file or memory transfer with JPEG compression.

[Visual Basic] Public WriteOnly Property JpegQuality As Integer
[C#] public int JpegQuality {set;}

Property Value

Possible setting range is from 0 to 100. Other possible values are:
-4F Undefined
-3F Low quality
-2F Middle quality
-1F High quality

Explanation

The JpegQuality property sets the JpegQuality when using file or memory transfer with JPEG compression. This property is enabled when the Transfer property is File or Memory and the Compression property is Jpeg. The possible setting values supported by a scan device can be retrieved using the the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Mode property

Newtone.ImageKit.Win.ImageKit.Scan.Mode Property

This property sets the scanning mode. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public Property Mode As Newtone.ImageKit.ScanMode
[C#] public Newtone.ImageKit.ScanMode Mode {get; set;}

Property Value

This value is of type ScanMode

Explanation

The Mode property sets the scanning mode. This property is enabled when the UserInterface is Suppress. When the Mode property is CameraArray or CameraThumbnailArray, the array values passed to the Execute method are enabled, otherwise these array values are disabled. When Mode property is PositiveFilm1 or PositiveFilm2, these are enabled when using an Epson scan driver supporting these functions. When Mode property is PositiveFilm2, it is possible to use functions that support a film area guide. When Mode property is InformationFile, the InformationFileName property must contain the name of the file where the scanner manufacturer's interface properties will be saved.

Note: Even if the scan device being used supports duplex scanning, some scan drivers will not fully support duplex scanning when the user interface is suppressed (UserInterface=Suppress).

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


MoireFilter property

Newtone.ImageKit.Win.ImageKit.Scan.MoireFilter Property

This property sets the level for the Moire filter. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property MoireFilter As Integer
[C#] public int MoireFilter {set;}

Property Value

For Epson Scan Drivers
Value | Explanation
0 | None
1 | Standard (This can be used for general settings)
2 | 85 lpi (This can be used for Newspapers)
3 | 133 lpi (This can be used for Magazines and Catalogs)
4 | 175 lpi (This can be used for Pictures)

For Canon DR Scan Drivers
Value | Explanation
1 | None
2 | High scan speed
3 | High scan quality

Explanation

The MoireFilter property sets the level for removal of moire interference. This property is enabled when the UserInterface property is Suppress.

The Moire filter is enabled for certain Epson and Canon DR scan drivers. When using an Epson scanner, the datasource will be "Epson Scan" which will allow the above settings. Note that some Epson scanners, depending on the version, allow for only "on / off" settings. In this case the ImageKit will accept values of 0 or nonzero.

When using a Canon DR scanner, this property is enabled when the scan resolution is set to 300dpi or less. This property is disabled when the scan datasource does not support Moire filter.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


NoiseFilter property

Newtone.ImageKit.Win.ImageKit.Scan.NoiseFilter Property

This property sets the noise reduction filter. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property NoiseFilter As ScanNoiseFilter
[C#] public ScanNoiseFilter NoiseFilter {set;}

Property Value

This value is of type ScanNoiseFilter

Explanation

The NoiseFilter property sets the noise reduction filter for black and white images. This property is enabled when the UserInterface property is Suppress however it is disabled when using a digital camera. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Orientation property

Newtone.ImageKit.Win.ImageKit.Scan.Orientation Property

This property sets the orientation of the paper. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public Property Orientation As Newtone.ImageKit.ScanOrientation
[C#] public Newtone.ImageKit.ScanOrientation Orientation {get; set;}

Property Value

This value is of type ScanOrientation

Explanation

The Orientation property sets the orientation of the paper. This allows you to do things like rotate the scan output from the document plate or scan pages from an ADF where the pages are inserted 'on their side', etc. This property is enabled when the UserInterface property is Suppress.

Note: This property is disabled for digital cameras and scanners that do not support this function. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. To determine whether TextOrientationRecognition is supported by a scan device, please use the IsCapabilitySupported method.

For datasources that support TextOrientationRecognition, if the result of the specified TextOrientationRecognition is not correct, try changing the orientation of the paper.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


OverScan property

Newtone.ImageKit.Win.ImageKit.Scan.OverScan Property

This property enables "over scan" capabilities enlarging the scan area. (UserInterface=Suppress)

[Visual Basic] Public WriteOnly Property OverScan As Newtone.ImageKit.ScanOverScan
[C#] public Newtone.ImageKit.ScanOverScan OverScan {set;}

Property Values

A member of the ScanOverScan enumeration

Explanation

The OverScan property is useful when the scanned paper is not properly centered. This property allows the scan area (the Rect property or the PaperSize property) to be increased.

This property is enabled when the UserInterface property is set to Suppress. This property is disabled when using a digital camera or if the document scanner's driver does not support this capability.

To check if the datasource supports overscan, use the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


PageCount property

Newtone.ImageKit.Win.ImageKit.Scan.PageCount Property

This property sets the number of images to be scanned. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property PageCount As Integer
[C#] public int PageCount {set;}

Property Value

Value | Explanation
0 or less | Scans all images (ADF, digital camera)
1 or more | Scans the specified number of images

Default value is -1.

Explanation

The PageCount property sets the number of images to be scanned. This property is enabled when the UserInterface property is Suppress. To scan all of the images in the ADF or digital camera, set this property to 0 or less. To specify the number of images to be scanned, set that number in the PageCount property. When retrieving images from a digital camera using an array, pleaes refer to the Execute method to be the same as the number of elements in the array. When the Mode property is ADFBothSide, even if an odd number is set into the PageCount property, the number of pages scanned will be an even number (so as to scan both sides of the paper).

The PageCount property is disabled when the UserInterface property is NOT Suppress or when using the document plate to scan. For Panasonic scanners, when the PixelType property is either GrayAndBW or RGBAndBW, even though this property value is set to 1 or more, the scan will occur as if the this property value is 0 or less.

Note: Not all scan devices support this functionality. In some cases where the scan device does not support this function or does not correctly support this function, after the number of images specified by the PageCount property have been scanned, the scanning procedure is canceled. Depending on the type of equipment, paper could be left inside the scan device or ADF.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


PaperSize property

Newtone.ImageKit.Win.ImageKit.Scan.PaperSize Property

This property sets the size of the paper. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property PaperSize As Newtone.ImageKit.ScanPaperSize
[C#] public Newtone.ImageKit.ScanPaperSize PaperSize {set;}

Property Value

This value is of typeScanPaperSize

Explanation

The PaperSize property sets the size of the paper. This property is enabled when the UserInterface property is Suppress. However this property is disabled when using a digital camera. To enable the Rect property, set the PaperSize property to UserSize or a negative value.

Depending on the datasource (scan driver), using a user defined paper size (UserSize) and setting the scan area, may still result in a start position of the scan being incorrect. If that is the case, please use one of the above constant values listed in the ScanPaperSize enum (1 or more) for the paper size and set this to a NEGATIVE value. (Please refer to the example code below).

Note: Please set the PaperSize property to a size supported by the datasource (scan driver) or set it to the largest supported paper size. With some datasources the PaperSize property has no effect. Please refer to the scan manufacturer for details.

The possible PaperSize settings supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. For scan devices that only support a fixed paper size or do not support paper size settings set this property to UserSize.

When PaperSize is set to "UndefinedSize" (1000), the paper size is automatically detected then the document is scanned, however, with scanners that can only detect one dimension (either height or width) there are cases when the automatic detection does not work properly. Also if scanning problems occur when theTransfer property is set to Memory, change the Transfer property setting to Native. To find out if "UndefinedSize" paper size is supported by the datasource, please execute the IsCapabilitySupported method.

If undefined paper size is supported and you have set UndefineSize into the PaperSize property but the auto detection of the paper's size isn't correct, you can try the following:
Set the BorderDetection property to true. If this still doesn't work and you are using a PFU scan driver then try the next step.
Add the largest possible paper size to the end of the UndefinedSize setting in the PaperSize property. For example, if the largest size you can set for the scanner is A3 then set
PaperSize = ScanPaperSize.UndefinedSize + 11. (See ScanPaperSize enum for those values)

Example

( The PaperSize is set to UserSize and the scan area is set but the scan position is wrong )

[Visual Basic.NET]
ImageKit1.Scan.UserInterface = ScanUserInterface.Suppress
ImageKit1.Scan.Unit = ScanUnit.Inch
ImageKit1.Scan.PaperSize = ScanPaperSize.UserSize
ImageKit1.Scan.Rect = new RectangleF(0, 0, CSng(6.9), CSng(10.2))

[Visual C#.NET]
imageKit1.Scan.UserInterface = ScanUserInterface.Suppress;
imageKit1.Scan.Unit = ScanUnit.Inch;
imageKit1.Scan.PaperSize = ScanPaperSize.UserSize;
imageKit1.Scan.Rect = new RectangleF(0, 0, (float)6.9, (float)10.2);

( The PaperSize is set to one of the above constants with a NEGATIVE value --> the scan position is correct)

[Visual Basic.NET]
ImageKit1.Scan.UserInterface = ScanUserInterface.Suppress
ImageKit1.Scan.Unit = ScanUnit.Inch
ImageKit1.Scan.PaperSize = -3 ' US Letter size
ImageKit1.Scan.Rect = new RectangleF(0, 0, CSng(6.9), CSng(10.2))

[Visual C#.NET]
imageKit1.Scan.UserInterface = ScanUserInterface.Suppress;
imageKit1.Scan.Unit = ScanUnit.Inch;
imageKit1.Scan.PaperSize = (ScanPaperSize)(-3); // US Letter size
imageKit1.Scan.Rect = new RectangleF(0, 0, (float)6.9, (float)10.2);

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


PixelType property

Newtone.ImageKit.Win.ImageKit.Scan.PixelType Property

This property sets the type of image scanned. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public Property PixelType As Newtone.ImageKit.ScanPixelType
[C#] public Newtone.ImageKit.ScanPixelType PixelType {get; set;}

Property Value

This value is of type ScanPixelType

Explanation

The PixelType property sets the type of image scanned. This property is enabled when the UserInterface is Suppress. This property is disabled for digital cameras and scanners that do not support this function. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. Whether or not Automation, GrayAndBW, or RGBAndBW is supported, please check with the IsCapabilitySupportedmethod.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Rect property

Newtone.ImageKit.Win.ImageKit.Scan.Rect Property

This property sets the scanning position. This property is enabled when using a custom-built user interface (UserInterface=Suppress).
[Visual Basic] Public Property Rect As System.Drawing.RectangleF
[C#] public System.Drawing.RectangleF Rect {get; set;}

Property Value

The value of this property depends on the Unit property setting. The minimum value is 0.

Explanation

The Rect property sets the scanning position of the area on the image to be scanned. This property value is enabled when the UserInterface property is Suppress and the PaperSize property is 0. This property setting is disabled when theUserInterface property is set to values other than Suppress or when the PaperSize property is 1 or more, or when images are retrieved from a digital camera.

After the scan has completed, the exact dimensions (in the units specified in the Unit property) of the actual area scanned are reset into the value of the Rect property. If the PaperSize property is set to UndefinedSize (or values of 1000 or more) or if the scan driver interface is automatically determining the paper size then actual scan may be the largest possible scan size or some other size depending on the scan driver. When using the default value of the datasource, set the RectangleF constructor with all parameter values set to 0 or use RectangleF.Empty.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


RemoveHole property

Newtone.ImageKit.Win.ImageKit.Scan.RemoveHole Property

This property sets hole removal. (UserInterface=Suppress)

[Visual Basic] Public WriteOnly Property RemoveHole As Integer
[C#] public int RemoveHole {set;}

Property Value

0: Does not remove holes

1: Holes are removed

The default value is 0

Explanation

The RemoveHole property sets whether or not hole removal is performed. This property is enabled for certain Canon DR scan drivers, Epson scanners, and Panasonic scanners.

The UserInterface property must be set to Suppress. If using a digital camera or if this capability is not supported by the scan driver, then this property is disabled.

To check whether the scanner supports this capability, use the IsCapabilitySupported method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


RotateBack property

Newtone.ImageKit.Win.ImageKit.Scan.RotateBack Property

This property sets whether or not the back side of the page is rotated when scanning on both sides using an ADF.

[Visual Basic] Public WriteOnly Property RotateBack As Integer
[C#] public int RotateBack {set;}

Property Value

Value | Explanation
0 | Do not rotate the back side of pages
1 | Rotate the back side of pages 180 degrees

Explanation

The RotateBack property sets whether or not the back side of the page is rotated when scanning on both sides using an ADF.

This property is supported by Canon DR scan drivers or Epson scan driver "EPSON Scan" ("EPSON Scan" Ver.1.x does not support sizes bigger than A4). To rotate the back side of the page, set the RotateBack property is set to 1 and the Cannon DR scan driver's UI is displayed with the option, "Rotate the back side of pages 180 degrees" or the Epson scan driver's "Epson Scan" configuration is "Match front and back images during duplex scanning".

This property is enabled when the UserInterface is Suppress and Mode property is ADFBothSide. This property is disabled for digital cameras and scan devices that do not support this function. The possible setting values supported by a scan device can be retrieved using the IsCapabilitySupported method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Rotation property

Newtone.ImageKit.Win.ImageKit.Scan.Rotation Property

This property sets the angle of rotation for the scanned image.

[Visual Basic] Public WriteOnly Property Rotation As Integer
[C#] public int Rotation {set;}

Property Value

From -360 degrees to 360 degrees
Default value is 0.

Explanation

The Rotationproperty sets the angle of rotation for the scanned image. Positive values rotate the image in a clockwise direction. Negative values rotate the image in a counter clockwise direction.

This property is enabled when the UserInterface property is set to Suppress. The Rotation property is similiar to the Orientation property but when the Orientation property will only accept a value of 0 (ScanOrientation.Rotate0) then use the Rotation property instead.

Some scan devices support both Orientation and Rotation. Depending on the scan device, BOTH property values are used to rotate the image (resulting in a "double rotation") or only the Rotation property value is enabled and the Orientation value is ignored. In such cases, it is recommended to set the Rotation property to values other than zero and set the Orientation property to 0 (ScanOrientation.Rotate0).

If the Orientation property is set to 1000 (ScanOrientation.TextOrientationRecognition), if the datasource is a digital camera, of if the scan device does not support rotation, then the Rotation property is disabled. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ScanningSpeed property

Newtone.ImageKit.Win.ImageKit.Scan.ScanningSpeed Property

This property increases the speed at which a document is scanned. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property ScanningSpeed As Integer
[C#] public int ScanningSpeed {set;}

Property Value

For Epson scan drivers

Value | Explanation
0 | For quality
1 | For speed

For Panasonic scan drivers

Value | Explanation
0 | Slow
1 | Normal
2 | Fast

Explanation

The ScanningSpeedproperty increases the speed at which a document is scanned.

Scanning speed is available only for certain Epson and Panasonic scanners

This property is enabled when the UserInterface is Suppress. Note: Increasing the speed at which the scan drivers scan a document can result in reduced quality. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Shadow property

Newtone.ImageKit.Win.ImageKit.Scan.Shadow Property

This property sets the shadow. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).
[Visual Basic] Public WriteOnly Property Shadow As Integer
[C#] public int Shadow {set;}

Property Value

From 0 to 255 (Default value is 0)

Explanation

The Shadow property sets the shadow. This property is enabled when the UserInterface property is Suppress.

The Shadow property is disabled if the PixelType property is BW.

Note: This property is disabled for digital cameras and scanners that do not support this function. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Sharpness property

Newtone.ImageKit.Win.ImageKit.Scan.Sharpness Property

This property sets the level of sharpness. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Sharpness As Integer
[C#] public int Sharpness {set;}

Property Value

Epson scan driver (unsharp mask)

Value | Explanation
0 | None
1 | Weak
2 | Normal
3 | Strong

Panasonic scan driver (quality)

Value | Explanation
0 | None
1 | Smooth
2 | Low
3 | Standard
4 | High

Explanation

The Sharpness property sets the level of sharpness.

Sharpness is enabled for certain Epson and Panasonic scan drivers only. When using an Epson scanner, the datasource will be "Epson Scan" which will allow the above gradated settings. Note that some Epson scanners, depending on the version, allow for only "on / off" settings. In this case the ImageKit will accept values of 0 or nonzero.

For Epson scanners, the "unsharp mask" is used and for Panasonic scanners "image quality" is used.

This property is enabled when the UserInterface is Suppress. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


SkipBlankPage property

Newtone.ImageKit.Win.ImageKit.Scan.SkipBlankPage Property

This property sets whether or not a blank page will be skipped. (UserInterface=Suppress)

[Visual Basic] Public WriteOnly Property SkipBlankPage As Integer
[C#] public int SkipBlankPage {set;}

Property Value

-2: The blank page is not skipped

-1: The blank page is skipped

For Canon DR scan drivers

0: The blank page is not skipped

1: The blank page is skipped

Epson scan drivers

0: The blank page is not skipped

1: The blank page is skipped (low level)

2: The blank page is skipped (medium level)

3: The blank page is skipped (high level)

Explanation

The SkipBlankPage property sets whether or not a blank page will be skipped. If the datasource supports this capability, setting this property to 1 or to -1 will enable SkipBlankPage.

When using Canon DR scan drivers or Panasonic scan drivers, set the SkipBlankThreshold property. When using a Canon DR scan driver to skip blank pages, the Mode property should be set to ADFOneSide. When SkipBlankPage is enabled, even though the Mode property is ADFOneSide, both sides will be scanned.

When using an Epson scanner and skipping blank pages, set the SkipBlankPage property to a value of -1 or values of 1 or more. When the SkipBlankPage is -1, the default TWAIN capability will be used. Setting the SkipBlankPage property to values of 1 or more will allow the Epson capability to be used. In this case, set the AdjustGamma property to 1. When the AdjustGamma property is 0, the skip blank page functionality does not work properly in all cases. Also, if the AdjustGamma capability is not supported, you can use the default -1 value for SkipBlankPage but because the page may be darker than it should, skipping blank pages may not work as expected. In that case, you can make adjustments to darkness using the Brightnessand Gamma properties.

This property is enabled when the UserInterface property is set to Suppress. If using a digital camera or if the scan driver does not support this capability, this property will be disabled.

To check if the scanner supports this property use the GetCapabilityEnumToSingle or the GetCapabilityRange methods.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


SkipBlankThreshold property

Newtone.ImageKit.Win.ImageKit.Scan.SkipBlankThreshold Property

This property sets the threshold value to determine if a blank page is included with pages to be scanned and whether that blank page will be skipped. (UserInterface= Suppress)

[Visual Basic] Public WriteOnly Property SkipBlankThreshold As Single
[C#] public float SkipBlankThreshold {set;}

Property Value

For Canon DR Scan drivers:

Values can be set in % units from 0.1 to 20.0

For Panasonic scan drivers

Values can be set in % units from 0.01 to 5.00

The default value is 1

Explanation

The SkipBlankThreshold property sets the threshold value to determine if a blank page is included with the pages to be scanned and whether that blank page will be skipped. This property is enabled only for Canon DR scan drivers and Panasonic scan drivers. For Canon DR scanners, when this property value gets smaller, the likelihood that a page is recognized as blank increases. For Panasonic scanners, when this property value gets largers, the likelihood that a page is recognized as blank increases.

This property is enabled when the UserInterface property is set to Suppress and the SkipBlankPage property is set to -1 or 1.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


TextEnhancement property

Newtone.ImageKit.Win.ImageKit.Scan.TextEnhancement Property

This property sets the type of text enhancement used. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public Property TextEnhancement As Integer
[C#] public int TextEnhancement {get; set;}

Property Value

Canon DR Scan Driver

Value | Explanation
0 | Text enhancement is not used (default)
1 | Text enhancement is used
2 | Advanced text enhancement is used
3 | High speed text enhancement is used
4, 5 | Advanced text enhancement II is used. (Value depends on the functions used)
6 | Active Threshold

Epson Scan Driver

Value | Explanation
0 | Character distinction is not used. (default)
1 | Standard character distinction is used
2 | Strong character distinction is used

Explanation

The TextEnhancement property sets what type of text enhancement is used. The default value is 0.

This property is enabled for Canon DR scan drivers and Epson scan drivers only. For Canon DR drivers, the PixelType property must be BW and the BitDepthReduction property must be Threshold. Canon DR drivers refer to this functionality as "text enhancement". Epson scan drivers refer to it as "character distinction". The different levels of character distinction are available on Epson Scan ver 5.0 scan drivers or higher.

This property is enabled when the UserInterface property is set to Suppress. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. For some Epson scanners, only settings of enabled and disabled are allowed. In that case, the ImageKit will accept 0 as disabled and non-zero as enabled. If the datasource doesn't support this function then the value is ignored.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Threshold property

Newtone.ImageKit.Win.ImageKit.Scan.Threshold Property

This property sets the scanning threshold. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Threshold As Integer
[C#] public int Threshold {set;}

Property Value

From 0 to 255 (Default value is 128)

Explanation

The Threshold property sets the scanning threshold. This property is only enabled when the UserInterface property is Suppress.

The Threshold property requires that the PixelType property be BW and the BitDepthReduction property be Threshold. For scan devices that use brightness instead of threshold, the Brightness property value will be used.

Note: This property is disabled for digital cameras and scanners that do not support this function. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Transfer property

Newtone.ImageKit.Win.ImageKit.Scan.Transfer Property

This property sets whether native, file, or memory transfer is used.

[Visual Basic] Public Property ScanTransfer As Newtone.ImageKit.Transfer
[C#] public Newtone.ImageKit.ScanTransfer Transfer {get; set;}

Property Value

This value is of type ScanTransfer

Explanation

The TransferMode property sets whether native, file, or memory transfer is used. It is necessary to set this property prior to executing the Execute method. The possible transfer methods supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. Scanning events are generated for the memory transfer mode only.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Unit property

Newtone.ImageKit.Win.ImageKit.Scan.Unit Property

This property sets the units of measurement when scanning with a custom built user interface (UserInterface=Suppress).

[Visual Basic] Public Property Unit As Newtone.ImageKit.ScanUnit
[C#] public Newtone.ImageKit.ScanUnit Unit {get; set;}

Property Value

This value is of type ScanUnit

Default value is Inch.

Explanation

The Unit property sets the units of measurement used to set the scanning area. This property is enabled when the UserInterface is Suppress. The Rect property values will use the unit of measurement set in the Unit property.

Although the Unit property is disabled when the UserInterface is NOT Suppress, when scanning, the units of measurement of the scan are returned to this property. To retrieve the values of the Unit property supported by the scan device, execute the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


UserInterface property

Newtone.ImageKit.Win.ImageKit.Scan.UserInterface Property

This property sets whether the scan driver's user interface is used when scanning or if a custom built user interface is used.

[Visual Basic] Public Property UserInterface As Newtone.ImageKit.ScanUserInterface
[C#] public Newtone.ImageKit.ScanUserInterface UserInterface {get; set;}

Property Value

This value is of type ScanUserInterface

Explanation

The UserInterface property sets whether the scan driver's user interface is used when scanning or if a custom built user interface is used.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Value property

Newtone.ImageKit.Win.ImageKit.Scan.Value Property

This property retrieves the value supported for the specified capability.
[Visual Basic]
Public ReadOnly Property Value As Integer
[C#]
public int Value {get;}

Property Value

The following values are of type ScanCapability, are set in the capability parameter of the IsCapabilitySupported method.

Parameter | Value
Document feeder function (FeederEnabled) | 0: cannot be used, 1: feeder can be used
The function that checks whether or not there is paper in the document feeder (FeederLoaded) | 0: there is no paper, 1: there is paper
Indicator | 0: cannot use indicator, 1: can use indicator
UI control function (UIControllable) | 0: must use manufacturer's UI only, 1: manufacturer's UI can be suppressed
The function that checks the device's operating state (DeviceOnline) | 0: Device is not responding, 1: Device is operating
The function that transfers thumbnail images (ThumbnailEnabled) | 0: cannot transfer thumbnails, 1: can transfer thumbnails
Duplex scanning with the document feeder (Duplex) | 0: can not scan both sides, 1: can scan both sides at once, 2: can scan both sides but takes two scans
EnableDataSourceOnly | 0: Cannot display setting interface, 1: Setting interface can be displayed
CustomDataSourceData | 0: Not possible to retrieve or set UI value, 1: Can retrieve or set value in UI
Automatic Brightness (AutoBright) | 0: Automatic brightness cannot be used, 1: Automatic brightness can be used.
Undefined scan size (UndefinedImageSize) | For most scanners 0: undefined size cannot be used, 1: undefined size can be used. For certain Epson scanners 0: undefined size cannot be used, 1: possible only with document plate, 2: possible only with ADF, 3: possible with both document plate and ADF
How many images are in a digital camera (ImageDataSet) | The returned number is the number of images
BorderDetection | 0: border detection is not possible, 1: border detection is possible
Deskew | 0: cannot use deskew, 1: can use deskew, 2: can use deskew with smoothing 2 is only available for certain Panasonic scan drivers. In that case, 1 can be used.
Automatic rotation (AutomaticRotate) | 0: Automatic rotation not possible, 1: Automatic rotation possible. Standard TWAIN capability
Automatically recognize color or B&W (AutomaticColorEnabled) | 0: AutomaticColorEnabled is not possible, 1: AutomaticColorEnabled is possible. Standard TWAIN capability.
The maximum resolution when using a moire filter (MoireFilterMaxResolution) | The value is that maximum resolution. Available only for certain Epson scan drivers
RotateBack when using ADF in duplex mode (RotateBack) | 0: rotating the back side is not possible, 1: rotating the back side is possible. Available only for certain Epson "Epson Scan" scan drivers
Automatically detecting ratio of BW/Color (PixelAutomation) | 0: cannot automatically detect BW/Color, 1: can automatically detect BW/Color. Available only for certain Panasonic scan drivers
MultiStream | 0: multi-stream is not possible, 1: multi-stream is possible (Multi-stream is where 1 scan of the document plate results in retrieving two images of different pixel types) Available only for certain Panasonic scan drivers
TextOrientationRecognition or Automatic rotation | 0: Cannot use remove punch hole, 1: Remove punch hole is possible Available only for certain Canon DR or Panasonic scan drivers. Canon DR scan drivers use "Text Orientation Recognition" whereas Panasonic scan drivers use "Automatic Image Orientation".
Punch hole removal (RemoveHole) | 0: Automatic orientation based on text or automatic rotation is not possible, 1: Automatic orientation based on text or automatic rotation is possible. Available only for certain Canon DR, Epson, PFU, or Panasonic scan drivers.
Border adjustment (Border) | 0: Cannot adjust border, 1: Can adjust border Available only for certain Epson or Panasonic scan drivers
Gamma adjustment (AdjustGamma) | 0: Cannot adjust gamma, 1: Can adjust gamma. Available only for certain Epson scan drivers.

Explanation

The property values will be set after the IsCapabilitySupported method is executed. If the return value of the IsCapabilitySupported method is False, then -1 is set in the Value property.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


XResolution property

Newtone.ImageKit.Win.ImageKit.Scan.XResolution Property

This property sets the horizontal scan resolution. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public Property XResolution As Integer
[C#] public int XResolution {get; set;}

Property Value

The horizontal and vertical scan resolution are set in DPI units.

XResolution is the horizontal scan resolution

Explanation

The XResolution property sets the horizontal scan resolution. This property is enabled when the UserInterface property is Suppress. When the UserInterface property is NOT Suppress or when a digital camera is being used, these properties are disabled. The range of resolution and the resolution values supported by the scan device can be retrieved by executing the GetCapabilityEnumToSingle or the GetCapabilityRange method. To use the scan device default resolution values, set this property to -1.

Note: Although it is possible to set different values for the horizontal and vertical resolution, some datasources (scanner drivers) do not support different values for horizontal and vertical resolution. In such cases, either the horizontal resolution or the vertical resolution will be enabled. To retrieve the actual resolution, refer to the XResolution and YResolution properties within the BeforeScan event or after executing the Execute method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


XScaling property

Newtone.ImageKit.Win.ImageKit.Scan.XScaling Property

This property sets the horizontal scaling (magnification). This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property XScaling As Single
[C#] public float XScaling {set;}

Property Value

XScaling is the horizontal scaling

Default value is 1.0

Explanation

The XScaling property sets the horizontal scaling (magnification). This property is only enabled when the UserInterface property is Suppress. If the UserInterface is set to a value other than Suppress or if a digital camera is being used, this property is disabled. The range and values of scaling supported by the scan device can be retrieved by executing the GetCapabilityEnumToSingle or the GetCapabilityRange method.

To scan in actual size, set the XScaling and YScaling properties to 1.0

Note: Although it is possible to set different values for horizontal and vertical scaling some datasources (scan drivers) do not support this. In such cases, either the horizontal scaling value or the vertical scaling value will be used.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


YResolution property

Newtone.ImageKit.Win.ImageKit.Scan.YResolution Property

This property sets the vertical scan resolution. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public Property YResolution As Integer
[C#] public int YResolution {get; set;}

Property Value

The horizontal and vertical scan resolution are set in DPI units.

YResolution is the vertical scan resolution

Explanation

The YResolution property sets the vertical scan resolution. This property is enabled when the UserInterface property is Suppress. When the UserInterface property is NOT Suppress or when a digital camera is being used, this property is disabled. The resolution values and range supported by the scan device can be retrieved by executing the GetCapabilityEnumToSingle or the GetCapabilityRange method. To use the scan device default resolution values, set this property to -1.

Note: Although it is possible to set different values for the horizontal and vertical resolution, some datasources (scanner drivers) do not support different values for horizontal and vertical resolution. In such cases, either the horizontal resolution or the vertical resolution will be enabled. To retrieve the actual resolution, refer to the XResolution and YResolutionproperties within the BeforeScan event or after executing the Execute method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


YScaling property

Newtone.ImageKit.Win.ImageKit.Scan.YScaling Property

This property sets the vertical scaling (magnification). This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property YScaling As Single
[C#] public float YScaling {set;}

Property Value

YScaling is the vertical scaling

Default value is 1.0

Explanation

The YScaling property sets the vertical scaling (magnification). This property is only enabled when the UserInterface property is Suppress. If the UserInterface is set to a value other than Suppress or if a digital camera is being used, this property is disabled. The range and values of scaling supported by the scan device can be retrieved by executing the GetCapabilityEnumToSingle or the GetCapabilityRange method.

To scan in actual size, set the XScaling and YScaling properties to 1.0

Note: Although it is possible to set different values for horizontal and vertical scaling some datasources (scan drivers) do not support this. In such cases, either the horizontal scaling value or the vertical scaling value will be used.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ClearProperty method

Newtone.ImageKit.Win.ImageKit.Scan.ClearProperty Method

This method resets the scan control properties.

[Visual Basic] Public Sub ClearProperty()
[C#] public void ClearProperty();

Return Value

None

Explanation

The ClearProperty method resets all property values to their default values (Doesn't include specialized referenced properties).

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


CloseDataSource method

Newtone.ImageKit.Win.ImageKit.Scan.CloseDataSource Method

This method closes the scan datasource (scan device).

[Visual Basic] Public Function CloseDataSource() As Boolean
[C#] public bool CloseDataSource();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CloseDataSource method closes the datasource that was opened by the OpenDataSource method.

Prior to executing the CloseDataSource and OpenDataSource methods, you must execute the Initialize method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Execute method

Newtone.ImageKit.Win.ImageKit.Scan.Execute Method

This method retrieves an image from a TWAIN datasource (scan device).

[Visual Basic] Public Function Execute() As Boolean
Public Function Execute(ByVal index() As Integer) As Boolean
[C#] public bool Execute();
public bool Execute(int[] index);

Parameters

index
An array containing the image indexes. (used with a digial camera)

Return Value

Returns true if successful. Returns False if unsuccessful.

Explanation

The Execute method retrieves an image from a TWAIN datasource (scan device). Events (BeforeScan, AfterScan, Scanning) are generated before, during, and after the scan so it is possible to write processing code in each of these stages of the scan process.

The Index parameter is enabled only when the UserInterface property is Suppress and the Mode property is set for a digital camera. However, in other situations where this array of index values is not needed, please use methods which doesn't have any parameters. The Index parameter is used to specify which image is retrieved from the digital camera (the index parameter is enabled when the Mode property is CameraArray or CameraThumbnailArray).

For example, to retrieve the 5th and 8th image from a digital camera, set the Index array parameter to

Index(0) = 5

Index(1) = 8

Some scan devices do not support these functions. In such cases, only the supported functions are used to scan the image.

Prior to executing the Execute method, you must execute the Initialize method.

If the OpenDataSource method is executed prior to the Execute method, then while the scan device is open, other applications can not use that scan device and it becomes the exclusive datasource for this execution.

The following properties should be set prior to executing the Execute method

[Required properties]

  • DataSourceName - if this property is blank, then select the scan device by executing the Select method. Note: If the OpenDataSource method is executed prior to setting the DataSourceName property then the DataSourceName is disabled and the open scan device is used.
  • Transfer
  • Compression
  • UserInterface
  • ExtendedUserInterface) - This property is required only when using Epson scanner drivers.

[These properties may be required depending on the settings]

  • FileFormat
  • FileName
  • JpegQuality

[If the UserInterface property is Suppress and the Mode property is InformationFile]

  • Mode
  • PageCount
  • Unit

[If the UserInterface property is Suppress and the Mode property is NOT InformationFile]

  1. When using a scanner, it is recommended that the following properties be set:
    AdjustGamma, AutoBright, BitDepth, BitDepthReduction, Border, BorderColor, BorderDetection, Brightness, ColorBWRatio, Contrast, Deskew , DropoutColor, DynamicThreshold, FocusPosition, Gamma, HalfTone, Highlight, IgnoreBackColor, ImageFilter, ImageMerge, Mode, MoireFilter, NoiseFilter, Orientation, OverScan, PageCount, PaperSize, PixelType, RemoveHole, RotateBack, Rotation, ScanningSpeed, Shadow, Sharpness, SkipBlankPage, SkipBlankThreshold, Threshold, TextEnhancement, Unit, XResolution, XScaling, YResolution, YScaling, PaperSize<=0: Rect

    Note: The AdjustGamma, Border, BorderColor, ColorBWRatio, DynamicThreshold, FocusPosition, IgnoreBackColor, MoireFilter , RemoveHole, RotateBack, ScanningSpeed , Sharpness, SkipBlankThreshold, TextEnhancement properties are sometimes disabled depending on the scan driver.
  2. When using a digital camera, it is recommended that these properties be set:
    Mode, PageCount (when the Index parameter is unnecessary), Unit

<The following properties are set after the scan has executed>

BitDepth, Compression, ErrorStatus, FileFormat (when using file transfer method), PixelType , Rect, Count, Unit, XResolution, YResolution

For details, please refer to the respective properties' explanations.

Important points when using a custom built user interface (UserInterface = Suppress)

When UserInterface is Suppress, depending on the scan device and the property values set, the scan can fail. For the most part the causes for scan failure when the UserInterface is Suppress can be traced to the following:

  1. The scan units set are not supported by the scan device. The supported scan unit values can be retrieved using the GetCapabilityEnumToSingle method.
  2. The pixel type set is not supported by the scan device. The supported pixel type values can be retrieved using the GetCapabilityEnumToSingle method.
  3. The bit count set is not supported by the scan device. The supported bit count values can be retrieved using the GetBitDepth method.
  4. The resolution set is not supported by the scan device. The supported resolution values can be retrieved using the GetCapabilityEnumToSingle or the GetCapabilityRange methods.
  5. The paper size set is not supported by the scan device. The supported values can be retrieved using the GetCapabilityEnumToSingle method.
    1. If settings for paper size are not supported at all, then set the PaperSize property to UserSize and set the appropriate scan area in the Rect property. If the scan area is not correctly set (i.e. it is smaller than the minimum or larger than the maximum), the scan can fail. The proper scan area values can be retrieved using the GetMinimumSize and GetPhysicalSize methods.
    2. If paper size settings are supported and the scan still fails, check to make sure the PaperSize property is set to a value other than UserSize.

Example

Scan using the scan driver's user interface

[Visual Basic.NET]
Dim Ret As Boolean
Ret = ImageKit1.Scan.Initialize(Me.Handle, 1, 0, "1.00", "NEWTONE Corp.", "ImageKit", "ImageKit.NET Scan Sample")
If Ret = false Then Exit Sub
ImageKit1.Scan.ClearProperty()
ImageKit1.Scan.Transfer = ScanTransfer.Memory
ImageKit1.Scan.Compression = ScanCompression.None
ImageKit1.Scan.UserInterface = ScanUserInterface.Show
ImageKit1.Scan.DataSourceName = "EPSON TWAIN Pro"
Ret = ImageKit1.Scan.Execute()
Ret = ImageKit1.Scan.Terminate()

'event
Private Sub ImageKit1_AfterScan(ByVal sender As Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs) Handles ImageKit1.AfterScan
  If (e.Bitmap1 Is Nothing) Then Exit Sub

  ImageKit1.Image = e.Bitmap1.Clone()
  ImageKit1.Display(Newtone.ImageKit.Win.DisplayMode.Stretch)
End Sub

[Visual C#.NET]
bool Ret;
Ret = imageKit1.Scan.Initialize(this.Handle, 1, 0, "1.00", "NEWTONE Corp.", "ImageKit", "ImageKit.NET Scan Sample");
if (!Ret) return;
imageKit1.Scan.ClearProperty();
imageKit1.Scan.Transfer = ScanTransfer.Memory;
imageKit1.Scan.Compression = ScanCompression.None;
imageKit1.Scan.UserInterface = ScanUserInterface.Show;
imageKit1.Scan.DataSourceName = "EPSON TWAIN Pro";
Ret = imageKit1.Scan.Execute();
Ret = imageKit1.Scan.Terminate();

//event
private void imageKit1_AfterScan(object sender, Newtone.ImageKit.AfterScanEventArgs e)
{
  if (e.Bitmap1 == null) return;

  imageKit1.Image = (Image)e.Bitmap1.Clone();
  imageKit1.Display(Newtone.ImageKit.Win.DisplayMode.Stretch);
}

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetBitDepth method

Newtone.ImageKit.Win.ImageKit.Scan.GetBitDepth Method

This method retrieves the bit depth supported by the scan device.

[Visual Basic] Public Function GetBitDepth() As Integer()
[C#] public int[] GetBitDepth();

Return Value

An array containing the bit depths supported by the scan device (Returns null[C#] or Nothing[VB.NET] if unsuccessful).

Explanation

The GetBitDepth method retrieves the bit depth supported by the scan device. To retrieve the bit depth, the PixelType and DataSourceName property must be set. If the DataSourceName property is blank, then prior to executing this method, please execute the SelectDataSource method. (Note: If the OpenDataSource method has been executed then the DataSourceName is disabled and the opened scan device will be used). The supported bit depth retrieved by the GetBitDepth method depends on the value set in the PixelType property. Therefore the PixelType property must also be set. Please set the values supported by the scan device into the PixelType property. Likewise, depending on the type of transfer method that has been set (memory transfer or native transfer) the possible compression methods may be different. You should therefore set the Transfer property value prior to retrieving the possible compression methods.

Prior to executing the GetBitDepth method, you must execute the Initialize method.

If the OpenDataSource method is executed prior to the GetBitDepth method, then while the scan device is open, other applications can not use that scan device and it becomes the exclusive datasource for this execution.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetCapabilityEnumToSingle method

Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityEnumToSingle Method

This method retrieves the possible setting values for a specified property of the scan device.

[Visual Basic] Public Function GetCapabilityEnumToSingle(ByVal capability As Newtone.ImageKit.ScanCapability) As Single()
[C#] public float[] GetCapabilityEnumToSingle(Newtone.ImageKit.ScanCapability capability);

Parameters

capability
The number for the retrieved capability (Values are of typeScanCapability enumeration)

Return Value

An array of supported values (Returns null [C#] or Nothing [Visual Basic] if unsuccessful).

Explanation

The GetCapabilityEnumToSingle method retrieves the possible setting values for a specified property of the scan device. To retrieve the possible setting values for a property it is first necessary to set the DataSourceName property. If the DataSourceName property is blank then please execute the SelectDataSource method prior to executing the GetCapabilityEnumToSingle method. (Note: If the OpenDataSource method is executed prior to the GetCapabilityEnumToSingle method the the DataSourceName is disabled and the open datasource is used).

Although it may vary depending on the scanner you are using, there are cases where the possible resolution values that you retrieve from your scanner may depend upon the values set in the PixelType property (i.e. black & white, 24 bit color, etc.). Because of this, it is recommended that you set the PixelType property prior to retrieving the possible values for horizontal and vertical resolution. Likewise, depending on the type of transfer method that has been set (memory transfer or native transfer) the compression methods that are possible for a given scanner may be different. You should therefore set the Transfer property value prior to retrieving the possible compression methods.

To execute the GetCapEnum method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetCapabilityEnumToSingle method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

After executing the GetCapabilityEnumToSingle method, the values are set into the ContainerType, CurrentIndex, and DefaultIndex properties.

Content of the Returned Value

Parameter | Return Value
Compression | A member of type ScanCompression enumeration
PixelType | A member of type ScanPixelType enumeration
Unit | A member of type ScanUnit enumeration
Transfer | A member of type ScanTransfer enumeration
FeederEnabled | The possible values to enable feeder (0: document plate; 1: feeder) *1
Indicator | The possible Indicator values *1
ThumbnailEnabled | The possible values to enable thumbnails *1
DuplexEnabled | The possible values to enable duplex scanning (0: single side; 1: duplex) *1
AutoBright | The possible values for automatic brightness *1
Brightness | The possible brightness values
Contrast | The possible contrast values
Filter | The possible filter values
Gamma | The possible gamma values
Highlight | The possible highlight values
ImageFileFormat | A member of type ScanFileFormat enumeration
DropoutColor | A member of type ScanDropoutColor enumeration
Orientation | A member of type ScanOrientation enumeration
Shadow | The possible shadow values
XResolution | The possible horizontal resolution values
YResolution | The possible vertical resolution values
Rotation | The possible degrees of rotation
PaperSize | A member of type ScanPaperSize enumeration
Threshold | The possible threshold values
XScaling | The possible horizontal scaling values
YScaling | The possible vertical scaling values
BitDepthReduction | A member of type ScanBitDepthReduction enumeration
UndefinedImageSize | The possible undefined image size values *1
ImageFilter | A member of type ScanImageFilter enumeration
NoiseFilter | A member of type ScanNoiseFilter enumeration
OverScan | A member of type ScanOverScan enumeration
BorderDetection | The possible BorderDetection values *1
Deskew | The possible Deskew values *1
AutomaticRotate | The possible AutomaticRotate values (including TWAIN standard values) *1
JpegQuality | The possible JpegQuality values
AutoSize | The possible page size recognition values
AutomaticColorEnabled | The possible values to enable automatic color *1
ScanningSpeed | This is enabled only for certain Epson and Panasonic scanners (1) Epson Scan Drivers - 0: For Quality, 1: For Speed (2) Panasonic Scan Drivers - 0: Slow, 1: Normal, 2: Fast
MoireFilter | This is enabled only for certain Epson and Canon DR scanners (1) For Epson Scan - 0: None, 1: Standard, 2: 85lpi (For Newspapers), 3: 133lpi (for Magazines and Catalogs), 4: 175lpi (for Photographs) (2) For Canon DR - 1: None, 2: High Speed, 3: High Quality
Sharpness | This is enabled only for certain Epson and Panasonic scanners For Epson scanners, the "unsharp mask" is used and for Panasonic scanners "image quality" is used. (1)Epson Scan Drivers - 0F None, 1: Weak 2: Normal (default), 3: Strong (2)Panasonic Scan Drivers - 0: None, 1: Smooth, 2: Low, 3: Standard, 4: High
ExtendedUserInterface | This is enabled only for certain Epson scanners 0: Starts up the UserInterface that was last used, 1: Starts up the professional mode, 2: Starts up the automatic mode, 3: Starts up the home mode, 4: Starts up the automatic mode (with no error messages and supressed UserInterface), 5: Starts up office mode
DynamicThreshold | This is enabled only for certain Panasonic scanners 0: None, 1: Bright, 2: A little brighter, 3: Standard, 4: A little darker, 5: Dark

When ContainerType = 3, the value is returned but the CurrentIndex and DefaultIndex are not enabled.
When ContainerType = 4, the value is returned and the array index referring to the CurrentIndex and DefaultIndex contain the current and default values.
When ContainerType = 5, the array index 0 contains the current value (default value)
When ContainerType = 6, the array index 0 contains the minimum value, the index 1 contains the maximum value, the index 2 contains the step value, the index 3 contains the default value, the index 4 contains the current value which can be various different values. This is the same result as executing the GetCapabilityRange method.

*1 For TWAIN 2.0 datasources and above the retrieved values will be all the possible settings. For ContainerType 3,4, and 6, the retrieved value will be the value of the current setting.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetCapabilityEnumToString method

Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityEnumToString Method

This method retrieves the possible setting values for a specified property of the scan device.

[Visual Basic] Public Function GetCapabilityEnumToString(ByVal capability As Newtone.ImageKit.ScanCapability) As String()
[C#] public string[] GetCapabilityEnumToString(Newtone.ImageKit.ScanCapability capability);

Parameters

capability
The number for the retrieved capability (Value is of typeScanCapability enumeration)

Return Value

An array of supported values (Returns null [C#] or Nothing [Visual Basic] if unsuccessful).

Explanation

The GetCapabilityEnumToString method retrieves the possible setting values for a specified property of the scan device. To retrieve the possible setting values for a property it is first necessary to set the DataSourceName property. If the DataSourceName property is blank then please execute the SelectDataSource method prior to executing the GetCapabilityEnumToString method. (Note: If the OpenDataSource method is executed prior to the GetCapabilityEnumToString method the the DataSourceName is disabled and the open datasource is used). If the CapNo refers to halftone, then the List array is not used, however you must pass a dummy array or NULL into the List parameter. ListNum is also not used in this case so please set it to 0.

To execute the GetCapabilityEnumToString method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetCapabilityEnumToString method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

After executing this method, the values are set into the ContainerType, CurrentIndex, and DefaultIndex properties.

Content of the Returned Value

When the capability is Halftone, the returned values reflect the possible halftone values that can be set.

When ContainerType = 3, the value is returned but the CurrentIndex and DefaultIndex are not enabled.
When ContainerType = 4, the value is returned and the array index referring to the CurrentIndex and DefaultIndex contain the current and default values.
When ContainerType = 5, the array index 0 contains the current value
When ContainerType = 6, there is no return value.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetCapabilityRange method

Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange Method

This method retrieves the range of possible setting values for a specified functionality of the scan device.

[Visual Basic] Public Function GetCapabilityRange(ByVal capability As Newtone.ImageKit.ScanCapability) As Newtone.ImageKit.CapabilityRange
[C#] public Newtone.ImageKit.CapabilityRange GetCapabilityRange(Newtone.ImageKit.ScanCapability capability);

Parameters

capability
The number for the retrieved functionality in hexidecimal notation (value is of typeScanCapability)

Return Value

The CapabilityRange class (Returns null[C#] or Nothing[Visual Basic] if unsuccessful).

Explanation

The GetCapabilityRange method retrieves the range of possible setting values for a specified functionality of the scan device. To retrieve the range of possible values for a setting, the DataSourceName property must be set. If the DataSourceName property is blank then prior to executing this method, please execute the SelectDataSource method. (If the OpenDataSource method has been executed, the DataSourceName is disabled and the open scan device will be used.)

Depending on your scanner, the resolution values that are possible may be different according to the pixel type value (i.e. according to whether the pixel type is 1 bit color, 24 bit color, etc.) Because of this, it is recommended that you you set the PixelType property prior to retrieving the possible values for horizontal and vertical resolution.

To execute the GetCapabilityRange method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetCapRange method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

After executing this method, the value is set into the ContainerType property.

Contents of the return value

Parameter | Return Value
Brightness | Range Information
Contrast | Range Information
Gamma | Range Information
Highlight | Range Information
Shadow | Range Information
XResolution | Range Information
YResolution | Range Information
Rotation | Range Information
Threshold | Range Information
XScaling | Range Information
YScaling | Range Information
SkipBlankPage (AutoDiscardBlankPages) | Range Information (including Twain Standard Capability)
JpegQuality | Range Information
Sharpness | Range Information Enabled when using Canon DR, Epson, or Panasonic scan drivers. In Canon DR drivers this is called "Edge Adjustment". In Epson drivers, it is called "Unsharpness". In Panasonic drivers, it is called "Image Quality".
SkipBlankPage | Range Information
FocusPosition | Range Information Enabled for Epson scan drivers.

When ContainerType = 3 or 4, then the number of elements in the list is set into the Maximum property for the CapabilityRange class. Use this number and execute the GetCapabilityEnumToSingle method.

When ContainerType = 5, then the current value is set into the Current property for the CapabilityRange class and the default value is set into the Default property.

When ContainerType = 6, then values are set into the Current, Range, Maximum, Minimum, and Step properties.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetCurrentDataSource method

Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource Method

This method retrieves information about the scan device currently being selected.

[Visual Basic] Public Function GetCurrentDataSource() As Newtone.ImageKit.DataSourceInformation
[C#] public Newtone.ImageKit.DataSourceInformation GetCurrentDataSource();

Return Value

The DataSourceInformation class (Returns null[C#] or Nothing[Visual Basic] if unsuccessful).

Explanation

The GetCurrentDataSource method retrieves information about the scan device currently being selected. If successful, information about the scan device is set in the following properties: Manufacturer, ProductFamily, ProductName, ProtocolMajor, ProtocolMinor, MajorVersion, MinorVersion, and Information of the DataSourceInformation class.

To execute the GetCurrentDataSource method, you must first execute the Initialize method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetDataSources method

Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources Method

This method retrieves information about the specified scan device, such as manufacturer, product name, etc.

[Visual Basic] Public Function GetDataSources() As Newtone.ImageKit.DataSourceInformation()
[C#] public Newtone.ImageKit.DataSourceInformation[] GetDataSources();

Return Value

Value is an array of the DataSourceInformation class. (Returns null [C#] or Nothing [Visual Basic] if unsuccessful).

Explanation

The GetDataSources method retrieves information about the specified scan device, such as manufacturer, product name, etc. If successful, the installed datasources (scan devices) are returned and the index of the current datasource is set in the CurrentIndex property.

To execute the GetDataSources method, you must first execute the Initialize method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetMinimumSize method

Newtone.ImageKit.Win.ImageKit.Scan.GetMinimumSize Method

This method retrieves the smallest size that can be scanned with a given scan device.

[Visual Basic]
Public Function GetMinimumSize() As SizeF
Public Function GetMinimumSize(ByVal dpiX As Integer, ByVal dpiY As Integer) As SizeF
[C#]
public SizeF GetMinimumSize();
public SizeF GetMinimumSize(int dpiX, int dpiY);

Parameters

dpiX
The horizontal resolution (in dots per inch)

dpiY
The vertical resolution (in dots per inch)

Return Value

The smallest size that can be scanned (If unsuccessful, the Height and Width properties of the SizeF structure will be 0)

Explanation

The GetMinimumSize method retrieves the smallest size that can be scanned with a given scan device. To retrieve the smallest size the DataSourceName, Mode, and Unit properties must be set. If the DataSourceName property is blank then prior to executing this method, please execute the SelectDataSource method. (If the OpenDataSource method has been executed, the DataSourceName is disabled and the open scan device will be used.) Set the Mode property from 0 to 2 and set the Unit to values supported by the datasource (scan device). The Width and Height parameters of the SizeF structure will return values depending on the Mode and Unit properties.

To execute the GetMinimumSize method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetMinimumSize method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetPhysicalSize method

Newtone.ImageKit.Win.ImageKit.Scan.GetPhysicalSize Method

This method retrieves the largest physical size that can be scanned with a given scan device.

[Visual Basic]
Public Function GetPhysicalSize() As SizeF
Public Function GetPhysicalSize(ByVal dpiX As Integer, ByVal dpiY As Integer) As SizeF
[C#]
public SizeF GetPhysicalSize();
public SizeF GetPhysicalSize(int dpiX, int dpiY);

Parameters

dpiX
Horizontal Resolution (in dots per inch)
dpiY
Vertical Resolution (in dots per inch)

Return Value

The largest physical size that can be scanned. (If unsuccessful, the SizeF structure's Height and Width properties will be 0)

Explanation

The GetPhysicalSize method retrieves the largest physical size that can be scanned with a given scan device. To retrieve the largest physical size the DataSourceName, Mode, and Unit properties must be set. If the DataSourceName property is blank then prior to executing this method, please execute the SelectDataSource method. (If the OpenDataSource method has been executed, the DataSourceName is disabled and the open scan device will be used.) Set the Mode property from 0 to 2 and set the Unit to values supported by the datasource (scan device). The Width and Height parameters of the SizeF structure will return values depending on the Mode and Unit properties. If Unit is set to Pixel and no parameter is passed then the current resolution (dpi) will be used.

To execute the GetPhysicalSize method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetPhysicalSize method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Initialize method

Newtone.ImageKit.Win.ImageKit.Scan.Initialize Method

This method starts the TWAIN process.

[Visual Basic] Public Function Initialize(ByVal hWnd As IntPtr, ByVal majorNumber As Integer, ByVal minorNumber As Integer, ByVal versionInfomation As String, ByVal manufacturer As String, ByVal productFamily As String, ByVal productName As String) As Boolean
[C#] public bool Initialize(IntPtr hWnd, int majorNumber, int minorNumber, string versionInfomation, string manufacturer, string productFamily, string productName);

Parameters

hWnd
The form window handle

majorNumber
The major version number of the application (If the version is 1.00, then this value will be 1)

minorNumber
The minor version number of the application (If the version is 1.00, then this value will be 0)

versionInfomation
The application version information (up to 32 bytes)

manufacturer
The name of the manufacturer of the application (up to 32 bytes)

productFamily
The application's product family name (up to 32 bytes)

productName
The application's product name (up to 32 bytes)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Initialize method starts the TWAIN process. When using TWAIN functions, the Initialize method must be executed. MajorNumber, MinorNumber, VersionInfomation, Manufacturer, ProductFamily, ProductName parameters are used to notify TWAIN of various information about the application.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


IsCapabilitySupported method

Newtone.ImageKit.Win.ImageKit.Scan.IsCapabilitySupported Method

This method confirms whether or not a functionality is supported by the datasource (scan device).

[Visual Basic] Public Function IsCapabilitySupported(ByVal capability As Newtone.ImageKit.ScanCapability) As Boolean
[C#] public bool IsCapabilitySupported(Newtone.ImageKit.ScanCapability capability);

Parameters

capability
The number for the retrieved functionality in hexadecimal (A member ofScanCapability)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The IsCapabilitySupported method confirms whether or not a functionality is supported by the datasource (scan device). To retrieve the supported range for a functionality, the DataSourceName property must be set. If the DataSourceName property is blank then prior to executing this method, please execute the SelectDataSource method. (If the OpenDataSource method has been executed, the DataSourceName is disabled and the open scan device will be used.

To execute the IsCapabilitySupported method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the IsCapSupported method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

After executing this method, the values are set in the Value property.

The values set in the Value property:

Parameter | The setting value
Document feeder function ( FeederEnabled ) | 0: cannot be used (document plate can be used), 1: feeder can be used, 2: both document plate and feeder can be used
The function that checks whether or not there is paper in the document feeder ( FeederLoaded ) | 0: there is no paper, 1: there is paper
Indicator | 0: cannot use indicator, 1: can use indicator
UI control function ( UIControllable ) | 0: must use manufacturer's UI only, 1: manufacturer's UI can be suppressed
The function that checks device's operating state ( DeviceOnline ) | 0: Device does not respond, 1: Device is operating
the function that transfers thumbnail images ( ThumbnailEnabled ) | 0: cannot transfer thumbnails, 1: can transfer thumbnails
Duplex scanning with the document feeder is supported ( Duplex ) | 0: 0: can not scan both sides, 1: can scan both sides at once, 2: can scan both sides but takes two scans
EnableDataSourceOnly | 0: Cannot display setting interface, 1: Setting interface can be displayed
CustomDataSourceData | 0: Not possible to retrieve or set UI value, 1: Can retrieve or set value in UI
Automatic Brightness (AutoBright) | 0: Automatic brightness cannot be used, 1: Automatic brightness can be used.
The undefined size ( UndefinedImageSize ) | In general, 0: undefined size cannot be used, 1: undefined size can be used. However, with certain Epson scan drivers the following values are set, 0: undefined size cannot be used, 1: possible only with document plate, 2: possible only with ADF, 3: possible with both document plate and ADF
How many images are in a digital camera( ImageDataSet ) | the returned number is the number of images
BorderDetection | 0: border detection is not possible, 1: border detection is possible
Deskew | 0: cannot use deskew, 1: can use deskew, 2: can use deskew with smoothing 2 is only available for certain Panasonic scan drivers. In that case, 1 can be used.
The maximum resolution when using a moire filter ( MoireFilterMaxResolution ) | the value is that maximum resolution Available only for certain Epson scan drivers
RotateBack when using ADF in duplex mode ( RotateBack ) | 0: rotating the back side is not possible, 1: rotating the back side is possible Available only for certain Canon DR and Epson "Epson Scan" scan drivers
Automatically detecting ratio of BW/Color ( PixelAutomation ) | 0: cannot automatically detect BW/Color, 1: can automatically detect BW/Color Available only for certain Panasonic, Canon DR, and PFU (Fujitsu) scan drivers
MultiStream | 0: multi-stream is not possible, 1: multi-stream is possible (Multi-stream is where 1 scan of the document plate results in retrieving two images of different pixel types) Available only for certain Panasonic scan drivers
TextOrientationRecognition or Automatic rotation | 0: Cannot use remove punch hole, 1: Remove punch hole is possible Available only for certain Canon DR or Panasonic scan drivers. Canon DR scan drivers use "Text Orientation Recognition" whereas Panasonic scan drivers use "Automatic Image Orientation".
Punch hole removal (RemoveHole) | 0: Automatic orientation based on text or automatic rotation is not possible, 1: Automatic orientation based on text or automatic rotation is possible. Available only for certain Canon DR, Epson, PFU, or Panasonic scan drivers.
Border adjustment (Border) | 0: Cannot adjust border, 1: Can adjust border Available only for certain Epson or Panasonic scan drivers
Gamma adjustment (AdjustGamma) | 0: Cannot adjust gamma, 1: Can adjust gamma. Available only for certain Epson scan drivers.

If the return value of the IsCapabilitySupported method is False, then -1 is set in the Value property.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


IsOpenDataSource method

Newtone.ImageKit.Win.ImageKit.Scan.IsOpenDataSource Method

This method checks whether or not the scan devices are open.

[Visual Basic] Public Function IsOpenDataSource() As Boolean
[C#] public bool IsOpenDataSource();

Return Value

Returns True when open. Returns False when not open.

Explanation

The IsOpenDataSource method checks whether or not the scan devices are open. If the OpenDataSource method is executed prior to the IsOpenDataSource method and the scan devices are open then the return value of this method is True.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


OpenDataSource method

Newtone.ImageKit.Win.ImageKit.Scan.OpenDataSource Method

This method opens the scan datasource (scan device).

[Visual Basic] Public Function OpenDataSource() As Boolean
[C#] public bool OpenDataSource();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The OpenDataSource method opens the datasource set in the DataSourceName property. If the DataSourceName property is blank, please execute the SelectDataSource method prior to executing the OpenDataSource method. (When the DataSourceName property is blank, null, or Nothing, the datasource is selected by the SelectDataSource method).

Note: After the OpenDataSource method has been executed, the datasource remains open until the CloseDataSource method is executed and other applications will not be able to be used.

Prior to executing the OpenDataSource and CloseDataSource methods, you must execute the Initialize method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


SelectDataSource method

Newtone.ImageKit.Win.ImageKit.Scan.SelectDataSource Method

This method selects the scan device.

[Visual Basic] Public Function SelectDataSource() As Newtone.ImageKit.DataSourceInformation
[C#] public Newtone.ImageKit.DataSourceInformation SelectDataSource();

Return Value

The DataSourceInformation class (Returns null[C#] or Nothing[VB.NET] if unsuccessful or canceled.

Explanation

The SelectDataSource method selects the scan device. When this method is executed, the installed TWAIN drivers are listed in a dialog box and can be selected. If successful, information about the scan device is set in the following properties: Manufacturer, ProductFamily, ProductName, ProtocolMajor, ProtocolMinor, MajorVersion, MinorVersion, and Information of the DataSourceInformation class.

Prior to executing the SelectDataSource method, you must execute the Initialize method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Terminate method

Newtone.ImageKit.Win.ImageKit.Scan.Terminate Method

This method ends the TWAIN process.

[Visual Basic] Public Function Terminate() As Boolean
[C#] public bool Terminate();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Terminate method ends the TWAIN process. This method must be used in conjunction with the Initialize method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ImageKitWinToolBarAnnotation Class

Newtone.ImageKit.Win.ToolBarAnnotation Class

The main class for the WinForm ToolBarAnnotation Control.

For a list of all members of this class, see ToolBarAnnotation Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Newtone.ImageKit.Win

public class ToolBarAnnotation : System.Windows.Forms.Control

Explanation

The ToolBarAnnotation control is a user friendly interface housing buttons and other items that provide access to a variety of editing and annotation. The ToolBarAnnotation control is used in conjunction with the ImageKit control allowing the image object in the ImageKit control to be edited and annotated, etc.

The ToolBarAnnotation control looks like this:

The ToolBarAnnotation control contains the following items:

Items Related to Annotation Functions

Item |  | Explanation
Select | Select Button | This button sets the target ImageKit control's Edit.EditKind property to KindOfEdit.Select allowing you to select a single editing or annotation object on the image in the target ImageKit control.
MultiSelect | MultiSelect Button | This button sets the target ImageKit control's Edit.EditKind property to KindOfEdit.MultiSelect allowing you to select all editing or annotation objects within a specified area on the image in the target ImageKit control.
Line | Line Button | This button sets the target ImageKit control's Edit.EditKind property to KindOfEdit.Line allowing you to draw a line on the image in the target ImageKit control.
Polyline | Polyline Button | This button sets the target ImageKit control's Edit.EditKind property to KindOfEdit.Polyline allowing you to draw a polyline on the image in the target ImageKit control.
Polygon | Polygon Button | This button sets the target ImageKit control's Edit.EditKind property to KindOfEdit.Polygon allowing you to draw a polygon on the image in the target ImageKit control.
Rectangle | Rectangle Button | This button sets the target ImageKit control's Edit.EditKind property to KindOfEdit.Rectangle allowing you to draw a rectangle on the image in the target ImageKit control.
RoundRectangle | RoundRectangle Button | This button sets the target ImageKit control's Edit.EditKind property to KindOfEdit.RoundRectangle allowing you to draw a rounded rectangle on the image in the target ImageKit control.
Ellipse | Ellipse Button | This button sets the target ImageKit control's Edit.EditKind property to KindOfEdit.Ellipse allowing you to draw a ellipse on the image in the target ImageKit control.
Pen | Pen Button | This button sets the target ImageKit control's Edit.EditKind property to KindOfEdit.Pen allowing you to draw free hand on the image in the target ImageKit control.
 | Image Button | This button sets the target ImageKit control's Edit.EditKind property to KindOfEdit.Image allowing you to paste an image in the target ImageKit control.
Text | Text Button | This button sets the target ImageKit control's Edit.EditKind property to KindOfEdit.Text allowing you to draw text on the image in the target ImageKit control.
Stamp | Stamp Button | This button sets the target ImageKit control's Edit.EditKind property to KindOfEdit.Stamp allowing you to place a stamp on the image in the target ImageKit control.

Items Related to Editing

By right-clicking on an annotation object, the context menu is displayed. The context menu allows you to perform many of the same functions that are available throught the Editing interface methods. For details about the context menu and the corresponding Editing method, please refer to the ImageKit.Edit.ContextMenuEnable property.

Item |  | Explanation
Select All | Select All/Deselect All | This menu item selects or deselects all annotation objects on the image in the target ImageKit control.
Delete | Delete | This menu item deletes the selected object
Cut | Cut | This menu item cuts the selected object(s)
Copy | Copy | This menu item copies the selected object(s)
Paste | Paste | This menu item pastes objects that have been cut copied. The items will be pasted at the location on the ImageKit control where the right click occurred. If the ImageKit control has not been right clicked then the items will be pasted in the top left corner of the ImageKit control.
Move To Front | Move To Front | This menu item moves the selected object to the front
Move Forward One | Move Forward One | This menu item moves the selected object's Z-Order forward one
Move Back One | Move Back One | This menu item moves the selected object's Z-Order back one
Move To Back | Move To Back | This menu item moves the selected object to the back
Undo | Undo | This menu item removes the last change to the annotation object and returns it to its previous state
Redo | Redo | This menu item reverses an undo step
Properties | Properties | This menu item displays a dialog that allows the selected object's properties to be changed.

Other Items Related to Editing

Item |  | Explanation
Embed Annotation | Embed Annotations Button | This button embeds the annotation objects into the image displayed in the ImageKit control. This works in the same way as the Newtone.ImageKit.Win.ImageKit.Edit.DrawEditedObjectsToImage method.
Clear All Objects | Clear All Objects Button | This button clears all annotation objects currently drawn in the target ImageKit control. This works in the same way as the Newtone.ImageKit.Win.ImageKit.Edit.ClearAllObjects method.

Requirement

Namespace: Newtone.ImageKit.Win

Assembly: Newtone.ImageKit.NETX.ImageKit.dll

See Also

ToolBarAnnotation Members


ToolBarAnnotation Members

Newtone.ImageKit.Win.ToolBarAnnotation Members

ToolBarAnnotation Overview

Public Constructor

ToolBarAnnotation Constructor Creates a new instance of the ToolBarAnnotation class.

Public Properties

BaseImageKitEditKind | Sets or retrieves the "EditKind" of the appropriate ImageKit control
ButtonClearAll | Sets or retrieves the "Clear All Objects" ToolStripButton control
ButtonClearAllVisible | Determines whether or not the "Clear All Objects" button is displayed in the ToolBarAnnotation control.
ButtonCopy | Sets or retrieves the "Copy" ToolStripButton control
ButtonCopyVisible | Determines whether or not the "Copy" button is displayed in the ToolBarAnnotation control.
ButtonCut | Sets or retrieves the "Cut" ToolStripButton control
ButtonCutVisible | Determines whether or not the "Cut" button is displayed in the ToolBarAnnotation control.
ButtonDelete | Sets or retrieves the "Delete" ToolStripButton control
ButtonDeleteVisible | Determines whether or not the "Delete" button is displayed in the ToolBarAnnotation control.
ButtonEllipse | Sets or retrieves the "Ellipse" ToolStripButton control
ButtonEllipseVisible | Determines whether or not the "Ellipse" button is displayed in the ToolBarAnnotation control.
ButtonEmbed | Sets or retrieves the "Embed" ToolStripButton control
ButtonEmbedVisible | Determines whether or not the "Embed Annotations" button is displayed in the ToolBarAnnotation control.
ButtonImage | Sets or retrieves the "Image" ToolStripButton control
ButtonImageVisible | Determines whether or not the Image button is displayed in the ToolBarAnnotation control.
ButtonLine | Sets or retrieves the "Line" ToolStripButton control
ButtonLineVisible | Determines whether or not the Line button is displayed in the ToolBarAnnotation control
ButtonMoveBackOne | Sets or retrieves the "MoveBackOne" ToolStripButton control
ButtonMoveBackOneVisible | Determines whether or not the "Move Back One" button is displayed in the ToolBarAnnotation control.
ButtonMoveForwardOne | Sets or retrieves the "MoveForwardOne" ToolStripButton control
ButtonMoveForwardOneVisible | Determines whether or not the "Move Forward One" button is displayed in the ToolBarAnnotation control
ButtonMoveToBack | Sets or retrieves the "MoveToBack" ToolStripButton control
ButtonMoveToBackVisible | Determines whether or not the "Move To Back" button is displayed in the ToolBarAnnotation control
ButtonMoveToFront | Sets or retrieves the "MoveToFront" ToolStripButton control
ButtonMoveToFrontVisible | Determines whether or not the "Move To Front" button is displayed in the ToolBarAnnotation control
ButtonMultiSelect | Sets or retrieves the "MultiSelect" ToolStripButton control
ButtonMultiSelectVisible | Determines whether or not the MultiSelect button is displayed in the ToolBarAnnotation control
ButtonPaste | Sets or retrieves the "Paste" ToolStripButton control
ButtonPasteVisible | Determines whether or not the "Paste" button is displayed in the ToolBarAnnotation control
ButtonPen | Sets or retrieves the "Pen" ToolStripButton control
ButtonPenVisible | Determines whether or not the "Pen" button is displayed in the ToolBarAnnotation control
ButtonPolygon | Sets or retrieves the "Polygon" ToolStripButton control
ButtonPolygonVisible | Determines whether or not the "Polygon" button is displayed in the ToolBarAnnotation control
ButtonPolyline | Sets or retrieves the "Polyline" ToolStripButton control
ButtonPolylineVisible | Determines whether or not the "Polyline" button is displayed in the ToolBarAnnotation control
ButtonProperties | Sets or retrieves the "Properties" ToolStripButton control
ButtonPropertiesVisible | Determines whether or not the "Properties" button is displayed in the ToolBarAnnotation control
ButtonRectangle | Sets or retrieves the "Rectangle" ToolStripButton control
ButtonRectangleVisible | Determines whether or not the "Rectangle" button is displayed in the ToolBarAnnotation control
ButtonRoundRectangle | Sets or retrieves the "RoundRectangle" ToolStripButton control
ButtonRoundRectangleVisible | Determines whether or not the "RoundRectangle" button is displayed in the ToolBarAnnotation control
ButtonRedo | Sets or retrieves the "Redo" ToolStripButton control
ButtonRedoVisible | Determines whether or not the "Redo" button is displayed in the ToolBarAnnotation control
ButtonSelect | Sets or retrieves the "Select" ToolStripButton control
ButtonSelectAll | Sets or retrieves the "SelectAll" ToolStripButton control
ButtonSelectVisible | Determines whether or not the Select button is displayed in the ToolBarAnnotation control
ButtonSelectAllVisible | Determines whether or not the "Select All" button is displayed in the ToolBarAnnotation control
ButtonSize | Sets the size of the buttons displayed in the ToolBarAnnotation control.
ButtonStamp | Sets or retrieves the "Stamp" ToolStripButton control
ButtonStampVisible | Determines whether or not the "Stamp" button is displayed in the ToolBarAnnotation control
ButtonText | Sets or retrieves the "Text" ToolStripButton control
ButtonTextVisible | Determines whether or not the "Text" button is displayed in the ToolBarAnnotation control
ButtonUndo | Sets or retrieves the "Undo" ToolStripButton control
ButtonUndoVisible | Determines whether or not the "Undo" button is displayed in the ToolBarAnnotation control
GroupAnnotationVisible | Determines whether or not the following group of annotation buttons and its separator is displayed in the ToolBarAnnotation control: "Select", "SelectAll", "Line", "Polyline", "Polygon", "Pen", "Rectangle", "RoundRectangle", "Ellipse", "Image", "Text", and "Stamp"
GroupEditVisible | Determines whether or not the following group of editing buttons and its separator is displayed in the ToolBarAnnotation control: "Select All / Delete All", "Delete", "Copy", "Cut", "Paste", "Move To Front", "Move Forward One", "Move Back One", "Move To Back", "Undo", "Redo", "Properties", "Embed", "Clear All Objects"
Separator1Visible | Determines whether or not the separator between the Annotation group buttons and the Edit group buttons is visible in the ToolBarAnnotation control
Separator2Visible | Determines whether or not the separator between the Edit group buttons and the "Embed" is visible in the ToolBarAnnotation control
TargetImageKit | Sets which ImageKit control is the target for the ToolBarAnnotation control's editing and annotation functions.

Public Events

TargetImageKitChanged Generated whenever the TargetImageKit property changes

See Also

Newtone.ImageKit.Win.ToolBarAnnotation


ImageKit.Win.ToolBarAnnotation Constructor

Newtone.ImageKit.Win.ToolBarAnnotation Constructor

This constructor creates a new instance of the ToolBarAnnotation class.

[Visual Basic] Public Sub New()
[C#] public public ToolBarAnnotation()

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


BaseImageKitEditKind property

Newtone.ImageKit.Win.ToolBarAnnotation.BaseImageKitEditKind Property

This property sets or retrieves the value of the Edit.KindOfEdit property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitEditKind As KindOfEdit
[C#]public KindOfEdit BaseImageKitEditKind {get; set;}

Property Value

A value of type KindOfEdit

Explanation

The BaseImageKitEditKind property sets or retrieves the Edit.KindOfEdit property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitEditKind property to set the Edit.KindOfEdit property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonClearAll property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonClearAll Property

This property sets or retrieves the "Clear All Objects" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonClearAll As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonClearAll {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonClearAll property sets or retrieves the "Clear All Objects" button of the ToolBarAnnotation. The "Clear All Objects" button is a ToolStripButton control. By using the ButtonClearAll property, you can change "Clear All Objects" button settings, generate events, etc. See code examples below.

Examples

(1) To change the image displyed in the "Clear All Objects" button

[Visual Basic.NET]
ToolBarAnnotation1.ButtonClearAll.Image = Image.FromFile("c:\images\button_img1.bmp")

[Visual C#.NET]
toolBarAnnotation1.ButtonClearAll.Image = Image.FromFile("c:\\images\\button_img1.bmp");

(2) To retrieve the "Select" button click event
* It is necessary to determine which button was clicked. This must be done within the ToolBarAnnotation control's ItemClicked event

[Visual Basic.NET]
Private Sub ToolBarAnnotation1_ItemClicked(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolStripItemClickedEventArgs) Handles ToolBarAnnotation1.ItemClicked
If e.ClickedItem Is ToolBarAnnotation1.ButtonSelect Then 'The button clicked was the "select" button
'Here is where you place code that will be executed when this event fires
End If
End Sub

[Visual C#.NET]
private void toolBarAnnotation1_ItemClicked(object sender, ToolStripItemClickedEventArgs e)
{
if (e.ClickedItem == toolBarAnnotation1.ButtonSelect) //The button clicked was the "select" button
{
//Here is where you place code that will be executed when this event fires
}
}

(3) To generate the "Select" button mouse up event

[Visual Basic.NET]
'* In the FormLoad or other event, set the delegate for the ButtonSelect mouse up event.
AddHandler ToolBarAnnotation1.ButtonSelect.MouseUp, AddressOf ButtonSelect_MouseUp

'Event Handler Delegate
Private Sub ButtonSelect_MouseUp(ByVal sender As System.Object, ByVal e As System.EventArgs)
'Here is where you place code that will be executed when this event fires
End Sub

[Visual C#.NET]
'* In the FormLoad or other event, set the delegate for the ButtonSelect mouse up event.
toolBarAnnotation1.ButtonSelect.MouseUp += new MouseEventHandler(ButtonSelect_MouseUp);

//Event Handler Delegate
private void ButtonSelect_MouseUp(object sender, EventArgs e)
{
//Here is where you place code that will be executed when this event fires
}

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonClearAllVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonClearAllVisible Property

This property determines whether or not the "Clear All Objects" button is displayed in the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonClearAllVisible As Boolean
[C#]public bool ButtonClearAllVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Clear All Objects" button is displayed in the ToolBarAnnotation control.
False | The "Clear All Objects" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonClearAllVisible property determines whether or not the "Clear All Objects" button is displayed in the ToolBarAnnotation control. When False, the "Clear All Objects" button is not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonCopy property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonCopy Property

This property sets or retrieves the "Copy" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonCopy As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonCopy {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonCopy property sets or retrieves the "Copy" button of the ToolBarAnnotation. The "Copy" button is a ToolStripButton control. By using the ButtonCopy property, you can change "Copy" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonCopyVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonCopyVisible Property

This property determines whether or not the "Copy" button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonCopyVisible As Boolean
[C#] public bool ButtonCopyVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Copy" button is displayed in the ToolBarAnnotation control.
False | The "Copy" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonCopyVisible property determines whether or not the "Copy" button is displayed in the ToolBarAnnotation control. When False, the "Copy" button is not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonCut property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonCut Property

This property sets or retrieves the "Cut" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonCut As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonCut {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonCut property sets or retrieves the "Cut" button of the ToolBarAnnotation. The "Cut" button is a ToolStripButton control. By using the ButtonCut property, you can change "Cut" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonCutVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonCutVisible Property

This property determines whether or not the "Cut" button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonCutVisible As Boolean
[C#] public bool ButtonCutVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Cut" button is displayed in the ToolBarAnnotation control.
False | The "Cut" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonCutVisible property determines whether or not the "Cut" button is displayed in the ToolBarAnnotation control. When False, the "Cut" button is not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonDelete property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonDelete Property

This property sets or retrieves the "Delete" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonDelete As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonDelete {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonDelete property sets or retrieves the "Delete" button of the ToolBarAnnotation. The "Delete" button is a ToolStripButton control. By using the ButtonDelete property, you can change "Delete" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonDeleteVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonDeleteVisible Property

This property determines whether or not the "Delete" button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonDeleteVisible As Boolean
[C#] public bool ButtonDeleteVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Delete" button is displayed in the ToolBar control.
False | The "Delete" button is not displayed in the ToolBar control.

Explanation

The ButtonDeleteVisible property determines whether or not the "Delete" button is displayed in the ToolBarAnnotation control. When False, the "Delete" button is not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonEllipse property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonEllipse Property

This property sets or retrieves the "Ellipse" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonEllipse As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonEllipse {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonEllipse property sets or retrieves the "Ellipse" button of the ToolBarAnnotation. The "Ellipse" button is a ToolStripButton control. By using the ButtonEllipse property, you can change "Ellipse" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonEllipseVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonEllipseVisible Property

This property determines whether or not the Ellipse button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonEllipseVisible As Boolean
[C#] public bool ButtonEllipseVisible {get; set;}

Property Value

Value | Explanation
True (default) | The Ellipse button is displayed in the ToolBarAnnotation control.
False | The Ellipse button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonEllipseVisible property determines whether or not the "Ellipse" button is displayed in the ToolBarAnnotation control. When False, the "Ellipse" button is not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonEmbed property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonEmbed Property

This property sets or retrieves the "Embed Annotations" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonEmbed As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonEmbed {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonEmbed property sets or retrieves the "Embed Annotations" button of the ToolBarAnnotation. The "Embed Annotations" button is a ToolStripButton control. By using the ButtonEmbed property, you can change "Embed Annotations" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonEmbedVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonEmbedVisible Property

This property determines whether or not the "Embed Annotations" button is displayed in the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonEmbedVisible As Boolean
[C#]public bool ButtonEmbedVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Embed Annotations" button is displayed in the ToolBarAnnotation control.
False | The "Embed Annotations" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonEmbedVisible property determines whether or not the "Embed Annotations" button is displayed in the ToolBarAnnotation control. When False, the "Embed Annotations" button is not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonImage property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonImage Property

This property sets or retrieves the "Image" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonImage As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonImage {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonImage property sets or retrieves the "Image" button of the ToolBarAnnotation. The "Image" button is a ToolStripButton control. By using the ButtonImage property, you can change "Image" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonImageVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonImageVisible Property

This property determines whether or not the Image button is displayed in the ToolBarAnnotation control

[Visual Basic] Public Property ButtonImageVisible As Boolean
[C#] public bool ButtonImageVisible {get; set;}

Property Value

Value | Explanation
True (default) | The Image button is displayed in the ToolBarAnnotation control.
False | The Image button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonImageVisible property determines whether or not the Image button is displayed in the ToolBarAnnotation control. If False, the Image button will not be displayed in the ToolBarAnnotation control.

For more information about drawing lines manually, please refer to the ImageKit.Win.ImageKit.Edit.PasteImage method.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation

>


ButtonLine property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonLine Property

This property sets or retrieves the "Line" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonLine As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonLine {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonLine property sets or retrieves the "Line" button of the ToolBarAnnotation. The "Line" button is a ToolStripButton control. By using the ButtonLine property, you can change "Line" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonLineVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonLineVisible Property

This property determines whether or not the Line button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonLineVisible As Boolean
[C#] public bool ButtonLineVisible {get; set;}

Property Value

Value | Explanation
True (default) | The Line button is displayed in the ToolBarAnnotation control.
False | The Line button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonLineVisible property determines whether or not the Line button is displayed in the ToolBarAnnotation control. If false, the Line button is not displayed.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonMoveBackOne property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonMoveBackOne Property

This property sets or retrieves the "Move Back One" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonMoveBackOne As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonMoveBackOne {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonMoveBackOne property sets or retrieves the "Move Back One" button of the ToolBarAnnotation. The "Move Back One" button is a ToolStripButton control. By using the ButtonMoveBackOne property, you can change "Move Back One" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonMoveBackOneVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonMoveBackOneVisible Property

This property determines whether or not the "Move Back One" button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonMoveBackOneVisible As Boolean
[C#] public bool ButtonMoveBackOneVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Move Back One" button is displayed in the ToolBarAnnotation control.
False | The "Move Back One" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonMoveBackOneVisible property determines whether or not the "Move Back One" button is displayed in the ToolBarAnnotation control. When False, the "Move Back One" button is not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonMoveForwardOne property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonMoveForwardOne Property

This property sets or retrieves the "Move Forward One" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonMoveForwardOne As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonMoveForwardOne {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonMoveForwardOne property sets or retrieves the "Move Forward One" button of the ToolBarAnnotation. The "Move Forward One" button is a ToolStripButton control. By using the ButtonMoveForwardOne property, you can change "Move Forward One" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonMoveForwardOneVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonMoveForwardOneVisible Property

This property determines whether or not the "Move Forward One" button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonMoveForwardOneVisible As Boolean
[C#] public bool ButtonMoveForwardOneVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Move Forward One" button is displayed in the ToolBarAnnotation control.
False | The "Move Forward One" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonMoveForwardOneVisible property determines whether or not the "Move Forward One" button is displayed in the ToolBarAnnotation control. When False, the "Move Forward One" button is not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonMoveToBack property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonMoveToBack Property

This property sets or retrieves the "Move To Back" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonMoveToBack As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonMoveToBack {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonMoveToBack property sets or retrieves the "Move To Back " button of the ToolBarAnnotation. The "Move To Back" button is a ToolStripButton control. By using the ButtonMoveToBack property, you can change "Move To Back" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonMoveToBackVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonMoveToBackVisible Property

This property determines whether or not the "Move To Back" button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonMoveToBackVisible As Boolean
[C#] public bool ButtonMoveToBackVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Move To Back" button is displayed in the ToolBarAnnotation control.
False | The "Move To Back" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonMoveToBackVisible property determines whether or not the "Move To Back" button is displayed in the ToolBarAnnotation control. When False, the "Move To Back" button is not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonMoveToFront property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonMoveToFront Property

This property sets or retrieves the "Move To Front" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonMoveToFront As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonMoveToFront {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonMoveToFront property sets or retrieves the "Move To Front" button of the ToolBarAnnotation. The "Move To Front" button is a ToolStripButton control. By using the ButtonMoveToFront property, you can change "Move To Front" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonMoveToFrontVisible Property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonMoveToFrontVisible Property

This property determines whether or not the "Move To Front" button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonMoveToFrontVisible As Boolean
[C#] public bool ButtonMoveToFrontVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Move To Front" button is displayed in the ToolBarAnnotation control.
False | The "Move To Front" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonMoveToFrontVisible property determines whether or not the "Move To Front" button is displayed in the ToolBarAnnotation control. When False, the "Move To Front" button is not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonMultiSelect property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonMultiSelect Property

This property sets or retrieves the "MultiSelect" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonMultiSelect As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonMultiSelect {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonMultiSelect property sets or retrieves the "MultiSelect" button of the ToolBarAnnotation. The "MultiSelect" button is a ToolStripButton control. By using the ButtonMultiSelect property, you can change "MultiSelect" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonMultiSelectVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonMultiSelectVisible Property

This property determines whether or not the MultiSelect button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonMultiSelectVisible As Boolean
[C#] public bool ButtonMultiSelectVisible {get; set;}

Property Value

Value | Explanation
True (default) | The MultiSelect button is displayed in the ToolBarAnnotation control.
False | The MultiSelect button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonMultiSelectVisible property determines whether or not the MultiSelect button is displayed in the ToolBarAnnotation control. If false, the MultiSelect button is not displayed.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonPaste property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonPaste Property

This property sets or retrieves the "Paste" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonPaste As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonPaste {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonPaste property sets or retrieves the "Paste" button of the ToolBarAnnotation. The "Paste" button is a ToolStripButton control. By using the ButtonPaste property, you can change "Paste" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonPasteVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonPasteVisible Property

This property determines whether or not the Paste button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonPasteVisible As Boolean
[C#] public bool ButtonPasteVisible {get; set;}

Property Value

Value | Explanation
True (default) | The Paste button is displayed in the ToolBarAnnotation control.
False | The Paste button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonPasteVisible property determines whether or not the Paste button is displayed in the ToolBarAnnotation control. If false, the Paste button is not displayed.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonPen property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonPen Property

This property sets or retrieves the "Pen" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonPen As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonPen {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonPen property sets or retrieves the "Pen" button of the ToolBarAnnotation. The "Pen" button is a ToolStripButton control. By using the ButtonPen property, you can change "Pen" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonPenVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonPenVisible Property

This property determines whether or not the Pen button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonPenVisible As Boolean
[C#] public bool ButtonPenVisible {get; set;}

Property Value

Value | Explanation
True (default) | The Pen button is displayed in the ToolBarAnnotation control.
False | The Pen button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonPenVisible property determines whether or not the Pen button is displayed in the ToolBarAnnotation control.. If false, the Pen button is not displayed.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonPolygon property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonPolygon Property

This property sets or retrieves the "Polygon" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonPolygon As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonPolygon {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonPolygon property sets or retrieves the "Polygon" button of the ToolBarAnnotation. The "Polygon" button is a ToolStripButton control. By using the ButtonPolygon property, you can change "Polygon" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonPolygonVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonPolygonVisible Property

This property determines whether or not the Polygon button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonPolygonVisible As Boolean
[C#] public bool ButtonPolygonVisible {get; set;}

Property Value

Value | Explanation
True (default) | The Polygon button is displayed in the ToolBarAnnotation control.
False | The Polygon button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonPolygonVisible property determines whether or not the Polygon button is displayed in the ToolBarAnnotation control. If false, the Polygon button is not displayed.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonPolyline property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonPolyline Property

This property sets or retrieves the "Polyline" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonPolyline As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonPolyline {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonPolyline property sets or retrieves the "Polyline" button of the ToolBarAnnotation. The "Polyline" button is a ToolStripButton control. By using the ButtonPolyline property, you can change "Polyline" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonPolylineVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonPolylineVisible Property

This property determines whether or not the Polyline button is displayed in the ToolBarAnnotation control.

[C#] public bool ButtonPolylineVisible {get; set;}

Property Value

Value | Explanation
True (default) | The Polyline button is displayed in the ToolBarAnnotation control.
False | The Polyline button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonPolylineVisible property determines whether or not the Polyline button is displayed in the ToolBarAnnotation control. If false, the Polyline button is not displayed.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonProperties property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonProperties Property

This property sets or retrieves the "Properties" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonProperties As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonProperties {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonProperties property sets or retrieves the "Properties" button of the ToolBarAnnotation. The "Properties" button is a ToolStripButton control. By using the ButtonProperties property, you can change "Properties" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonPropertiesVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonPropertiesVisible Property

This property determines whether or not the "Properties" button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonPropertiesVisible As Boolean
[C#] public bool ButtonPropertiesVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Properties" button is displayed in the ToolBarAnnotation control.
False | The "Properties" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonPropertiesVisible property determines whether or not the "Properties" button is displayed in the ToolBarAnnotation control. When False, the "Properties" button is not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonRectangle property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonRectangle Property

This property sets or retrieves the "Rectangle" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonRectangle As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonRectangle {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonRectangle property sets or retrieves the "Rectangle" button of the ToolBarAnnotation. The "Rectangle" button is a ToolStripButton control. By using the ButtonRectangle property, you can change "Rectangle" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonRectangleVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonRectangleVisible Property

This property determines whether or not the Rectangle button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonRectangleVisible As Boolean
[C#] public bool ButtonRectangleVisible {get; set;}

Property Value

Value | Explanation
True (default) | The Rectangle button is displayed in the ToolBarAnnotation control.
False | The Rectangle button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonRectangleVisible property determines whether or not the Rectangle button is displayed in the ToolBarAnnotation control. If false, the Rectangle button is not displayed.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonRoundRectangle property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonRoundRectangle Property

This property sets or retrieves the "RoundRectangle" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonRoundRectangle As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonRoundRectangle {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonRoundRectangle property sets or retrieves the "RoundRectangle" button of the ToolBarAnnotation. The "RoundRectangle" button is a ToolStripButton control. By using the ButtonRoundRectangle property, you can change "RoundRectangle" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonRoundRectangleVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonRoundRectangleVisible Property

This property determines whether or not the RoundRectangle button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonRoundRectangleVisible As Boolean
[C#] public bool ButtonRoundRectangleVisible {get; set;}

Property Value

Value | Explanation
True (default) | The RoundRectangle button is displayed in the ToolBarAnnotation control.
False | The RoundRectangle button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonRoundRectangleVisible property determines whether or not the RoundRectangle button is displayed in the ToolBarAnnotation control. If false, the RoundRectangle button is not displayed.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonRedo property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonRedo Property

This property sets or retrieves the "Redo" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonRedo As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonRedo {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonRedo property sets or retrieves the "Redo" button of the ToolBarAnnotation. The "Redo" button is a ToolStripButton control. By using the ButtonRedo property, you can change "Redo" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonRedoVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonRedoVisible Property

This property determines whether or not the "Redo" button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonRedoVisible As Boolean
[C#] public bool ButtonRedoVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Redo" button is displayed in the ToolBarAnnotation control.
False | The "Redo" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonRedoVisible property determines whether or not the "Redo" button is displayed in the ToolBarAnnotation control. When False, the "Redo" button is not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonSelectAll property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonSelectAll Property

This property sets or retrieves the "SelectAll" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonSelectAll As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonSelectAll {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonSelectAll property sets or retrieves the "SelectAll" button of the ToolBarAnnotation. The "SelectAll" button is a ToolStripButton control. By using the ButtonSelectAll property, you can change "SelectAll" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonSelectAllVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonSelectAllVisible Property

This property determines whether or not the "Select All" button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonSelectAllVisible As Boolean
[C#] public bool ButtonSelectAllVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Select All" button is displayed in the ToolBarAnnotation control.
False | The "Select All" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonSelectAllVisible property determines whether or not the "Select All" button is displayed in the ToolBarAnnotation control. When False, the "Select All" button is not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonSelect property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonSelect Property

This property sets or retrieves the "Select" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonSelect As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonSelect {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonSelect property sets or retrieves the "Select" button of the ToolBarAnnotation. The "Select" button is a ToolStripButton control. By using the ButtonSelect property, you can change "Select" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonSelectVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonSelectVisible Property

This property determines whether or not the "Select" button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonSelectVisible As Boolean
[C#] public bool ButtonSelectVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Select" button is displayed in the ToolBarAnnotation control.
False | The "Select" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonSelectVisible property determines whether or not the "Select" button is displayed in the ToolBarAnnotation control. If false, the "Select" button is not displayed.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonSize property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonSize Property

This property sets the size of the buttons displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonSize As ToolBarButtonSize
[C#] public ToolBarButtonSize ButtonSize {get; set;}

Property Value

A ToolBarButtonSize value

Default value is ToolBarButtonSize.Small

Explanation

The ButtonSize property sets the size of the buttons displayed in the ToolBarAnnotation control. Depending on the value set in the property, the width of the ToolBarAnnotation control may change.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonStamp property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonStamp Property

This property sets or retrieves the "Stamp" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonStamp As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonStamp {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonStamp property sets or retrieves the "Stamp" button of the ToolBarAnnotation. The "Stamp" button is a ToolStripButton control. By using the ButtonStamp property, you can change "Stamp" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonStampVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonStampVisible Property

This property determines whether or not the "Stamp" button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonStampVisible As Boolean
[C#] public bool ButtonStampVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Select" button is displayed in the ToolBarAnnotation control.
False | The "Select" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonStampVisible property determines whether or not the "Select" button is displayed in the ToolBarAnnotation control. If false, the "Select" button is not displayed.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonText property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonText Property

This property sets or retrieves the "Text" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonText As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonText {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonText property sets or retrieves the "Text" button of the ToolBarAnnotation. The "Text" button is a ToolStripButton control. By using the ButtonText property, you can change "Text" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonTextVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonTextVisible Property

This property determines whether or not the Text button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonTextVisible As Boolean
[C#] public bool ButtonTextVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Text" button is displayed in the ToolBarAnnotation control.
False | The "Text" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonTextVisible property determines whether or not the "Text" button is displayed in the ToolBarAnnotation control. If false, the Text button is not displayed.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonUndo property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonUndo Property

This property sets or retrieves the "Undo" button of the ToolBarAnnotation control.

[Visual Basic]Public Property ButtonUndo As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonUndo {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonUndo property sets or retrieves the "Undo" button of the ToolBarAnnotation. The "Undo" button is a ToolStripButton control. By using the ButtonUndo property, you can change "Undo" button settings, generate events, etc.

For code examples see ButtonClearAll property

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ButtonUndoVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.ButtonUndoVisible Property

This property determines whether or not the "Undo" button is displayed in the ToolBarAnnotation control.

[Visual Basic] Public Property ButtonUndoVisible As Boolean
[C#] public bool ButtonUndoVisible {get; set;}

Property Value

Value | Explanation
True (default) | The "Undo" button is displayed in the ToolBarAnnotation control.
False | The "Undo" button is not displayed in the ToolBarAnnotation control.

Explanation

The ButtonUndoVisible property determines whether or not the "Undo" button is displayed in the ToolBarAnnotation control. When False, the "Undo" button is not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


GroupAnnotationVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.GroupAnnotationVisible Property

This property determines whether or not the following buttons and their associated separator are displayed in the ToolBarAnnotation control: "Select", "Select All", "Line", "Polyline", "Polygon", "Pen", "Rectangle", "RoundRectangle", "Ellipse", "Image", "Text", "Stamp".

[Visual Basic] Public WriteOnly Property ButtonEditGroupVisible As Boolean
[C#] public bool ButtonEditGroupVisible {set;}

Property Value

Value | Explanation
True (default) | The buttons and associated separator, "Select", "Select All", "Line", "Polyline", "Polygon", "Pen", "Rectangle", "RoundRectangle", "Ellipse", "Image", "Text", and "Stamp", are displayed in the ToolBarAnnotation control.
False | The buttons and associated separator, "Select", "Select All", "Line", "Polyline", "Polygon", "Pen", "Rectangle", "RoundRectangle", "Ellipse", "Image", "Text", and "Stamp", are not displayed in the ToolBarAnnotation control.

Explanation

The ButtonEditGroupVisible property determines whether or not the following buttons and their associated separator are displayed in the ToolBarAnnotation control: "Select", "Select All", "Line", "Polyline", "Polygon", "Pen", "Rectangle", "RoundRectangle", "Ellipse", "Image", "Text", and "Stamp". When False, these buttons are not displayed in the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


GroupEditVisible property

Newtone.ImageKit.Win.ToolBarAnnotation.GroupEditVisible Property

This property determines whether or not the following buttons and associated separator are displayed in the ToolBarAnnotation control: "Select All", "Delete", "Copy", "Cut", "Paste", "Move To Front", "Move Forward One", "Move Back One", "Move To Back", "Undo", "Redo", "Properties", "Embed", and "Clear All".

[Visual Basic] Public WriteOnly Property ButtonEditGroupVisible As Boolean
[C#] public bool ButtonEditGroupVisible {set;}

Property Value

Value | Explanation
True (default) | The buttons and associated separator "Select All", "Delete", "Copy", "Cut", "Paste", "Move To Front", "Move Forward One", "Move Back One", "Move To Back", "Undo", "Redo", "Properties", "Embed", and "Clear All" are displayed in the ToolBar control.
False | The buttons and associated separator "Select All", "Delete", "Copy", "Cut", "Paste", "Move To Front", "Move Forward One", "Move Back One", "Move To Back", "Undo", "Redo", "Properties", "Embed", and "Clear All" are not displayed in the ToolBar control.

Explanation

The ButtonEditGroupVisible property determines whether or not the following buttons and associated separator are displayed in the ToolBarAnnotation control: "Select All", "Delete", "Copy", "Cut", "Paste", "Move To Front", "Move Forward One", "Move Back One", "Move To Back", "Undo", "Redo", "Properties", "Embed", and "Clear All"

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


Separator1Visibile property

Newtone.ImageKit.Win.ToolBarAnnotation.Separator1Visibile Property

This property determines whether or not Separator1 is displayed in the ToolBarAnnotation control. Separator1 is the separator between the "Stamp" and "SelectAll" buttons.

[Visual Basic] Public Property Separator1Visibile As Boolean
[C#] public bool Separator1Visibile {get; set;}

Property Value

Value | Explanation
True (default) | Separator1 is displayed in the ToolBarAnnotation control.
False | Separator1 is not displayed in the ToolBarAnnotation control.

Explanation

The Separator1Visibile property determines whether or not Separator1 is displayed in the ToolBarAnnotation control. Separator1 is the separator between the "Stamp" and "SelectAll" buttons.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


Separator2Visibile property

Newtone.ImageKit.Win.ToolBarAnnotation.Separator2Visibile Property

This property determines whether or not Separator2 is displayed in the ToolBarAnnotation control. Separator1 is the separator between the "Properties" and "Embed" buttons.

[Visual Basic] Public Property Separator2Visibile As Boolean
[C#] public bool Separator2Visibile {get; set;}

Property Value

Value | Explanation
True (default) | Separator2 is displayed in the ToolBarAnnotation control.
False | Separator2 is not displayed in the ToolBarAnnotation control.

Explanation

The Separator2Visibile property determines whether or not Separator2 is displayed in the ToolBarAnnotation control. Separator2 is the separator between the "Properties" and "Embed" buttons.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


SettingsForEachImageKit property

Newtone.ImageKit.Win.ToolBarAnnotation.SettingsForEachImageKit Property

This property determines if the ToolBarAnnotation control's settings apply to each ImageKit Control according to the TargetImageKit property value, or if the ToolBarAnnotation control's settings apply to all ImageKit Controls.

[Visual Basic] Public Property SettingsForEachImageKit As Boolean
[C#] public bool SettingsForEachImageKit {get; set;}

Property Value

Value | Explanation
True (default) | ToolBarAnnotation control settings apply only to the ImageKit control specified by the TargetImageKit property.
False | ToolBarAnnotation control settings apply to all the ImageKit controls regardless of the target specified by the TargetImageKit property.

Explanation

The SettingsForEachImageKit property determines if the ToolBarAnnotation control's settings apply to each ImageKit control according to the TargetImageKit property value, or if the ToolBarAnnotation control's settings apply to all ImageKit controls.

When one ToolBarAnnotation control is set to apply to multiple ImageKit controls, it is possible for that single ToolBarAnnotation control to maintain different settings according to which ImageKit control it targets. When the SettingsForEachImageKit property is True, the ToolBarAnnotation control settings apply only to the target ImageKit as determined by the TargetImageKit property. When the TargetImageKit property changes, the ToolBarAnnotation settings also change.

If the SettingsForEachImageKit property is False, the ToolBarAnnotation control settings apply to all ImageKit controls regardless of the TargetImageKit property value.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


TargetImageKit property

Newtone.ImageKit.Win.ToolBarAnnotation.TargetImageKit Property

This property sets which ImageKit control is targeted by the ToolBarAnnotation control.

[Visual Basic] Public Property TargetImageKit As ImageKit
[C#] public ImageKit TargetImageKit {get; set;}

Property Value

An ImageKit control

Default value is null (Nothing)

Explanation

The TargetImageKit property sets the correspondence between the ToolBarAnnotation control and the ImageKit control(s). This property determines which ImageKit control is targeted by the ToolBarAnnotation control.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


TargetImageKitChanged event

Newtone.ImageKit.Win.ToolBarAnnotation.TargetImageKitChanged Event

This event is generated whenever the TargetImageKit property changes.

[Visual Basic] Public Event TargetImageKitChanged As EventHandler
[C#] public event EventHandler TargetImageKitChanged;

Event Data

This event handler accepts parmeters of type EventArgs

Explanation

The TargetImageKitChanged event is generated whenever the TargetImageKit property changes.

When one ToolBar control is used with multiple ImageKit controls and the focus changes from one ImageKit control to another (i.e. the TargetImageKit property changes), you can use this event to retrieve which ImageKit control has focus.

See Also

ToolBarAnnotation Members | Newtone.ImageKit.Win.ToolBarAnnotation


ImageKitWinToolBarSetUpLines Class

Newtone.ImageKit.Win.ToolBarSetUpLines Class

The main class for the WinForm ToolBarSetUpLines Control.

For a list of all members of this class, see ToolBarSetUpLines Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Newtone.ImageKit.Win

public class ToolBarSetUpLines : System.Windows.Forms.Control

Explanation

The ToolBarSetupLines control is a toolbar that holds buttons and other items related to lines. Annotation objects that use these functions are the Line, Polyline, Polygon, and Pen objects. The ToolBarSetupLines control gives you an easy, user friendly way of accessing and setting properties related to lines.

The ToolBarSetupLines control looks like this:

The ToolBarSetupLines control contains the following items:

Items related to shape and style of Lines

Item |  | Explanation
DoubleLine Button | DoubleLine Button | This button sets the ImageKit.Edit.DoubleLine property. DoubleLine is enabled only for the Line object.
ClosePenLine Button | ClosePenLine Button | This button sets the ImageKit.Edit.ClosePenLine property. ClosePenLine is enabled only for the Pen object.
DashStyle ComboBox | DashStyle ComboBox | This combobox sets the ImageKit.Edit.DashStyle property.
StartLineCap ComboBox | StartLineCap ComboBox | This combobox sets the ImageKit.Edit.StartLineCap property. StartLineCap is enabled for the Line, Polyline, and Pen objects.
EndLineCap ComboBox | EndLineCap ComboBox | This combobox sets the ImageKit.Edit.EndLineCap property. EndLineCap is enabled for the Line, Polyline, and Pen objects.
LineJoin ComboBox | LineJoin ComboBox | This combobox sets the ImageKit.Edit.LineJoin property. LineJoin is enabled for the Polyline, Polygon, and Pen objects.

Items related to arrows (Line and Polyline objects only)

Item |  | Explanation
StartArrowCap Button | StartArrowCap Button | This button sets the ImageKit.Edit.StartArrowCap property.
StartArrowCapFilled Button | StartArrowCapFilled Button | This button sets the ImageKit.Edit.StartArrowCapFilled property.
StartArrowCapSize Box/Button | StartArrowCapSize Box/Button | This is a textbox / button combination sets the ImageKit.Edit.StartArrowCapSize property.
EndArrowCap Button | EndArrowCap Button | This button sets the ImageKit.Edit.EndArrowCap property.
EndArrowCapFilled Button | EndArrowCapFilled Button | This button sets the ImageKit.Edit.EndArrowCapFilled property.
EndArrowCapSize Box/Button | EndArrowCapSize Box/Button | This is a textbox / button combination sets the ImageKit.Edit.EndArrowCapSize property.

Requirement

Namespace: Newtone.ImageKit.Win

Assembly: Newtone.ImageKit.NETX.ImageKit.dll

See Also

ToolBarSetupLines Members


ToolBarSetUpLines Members

Newtone.ImageKit.Win.ToolBarSetUpLines Members

ToolBarSetUpLines Overview

Public Constructor

ToolBarSetUpLines Constructor Creates a new instance of the ToolBarSetUpLines class.

Public Properties

BaseImageKitClosePenLine | Sets or retrieves the value of the Edit.ClosePenLine property for the ImageKit control
BaseImageKitDashStyle | Sets or retrieves the value of the Edit.DashStyle property for the ImageKit control
BaseImageKitDoubleLine | Sets or retrieves the value of the Edit.DoubleLine property for the ImageKit control
BaseImageKitEndArrowCap | Sets or retrieves the value of the Edit.ClosePenLine property for the ImageKit control
BaseImageKitEndArrowCapFilled | Sets or retrieves the value of the Edit.EndArrowCapFille property for the ImageKit control
BaseImageKitEndArrowCapSize | Sets or retrieves the value of the Edit.EndArrowCapSize property for the ImageKit control
BaseImageKitEndLineCap | Sets or retrieves the value of the Edit.EndLineCap property for the ImageKit control
BaseImageKitLineJoin | Sets or retrieves the value of the Edit.LineJoin property for the ImageKit control
BaseImageKitStartArrowCap | Sets or retrieves the value of the Edit.StartArrowCap property for the ImageKit control
BaseImageKitStartArrowCapFilled | Sets or retrieves the value of the Edit.StartArrowCapFilled property for the ImageKit control
BaseImageKitStartArrowCapSize | Sets or retrieves the value of the Edit.StartArrowCapSize property for the ImageKit control
BaseImageKitStartLineCap | Sets or retrieves the value of the Edit.StartLineCap property for the ImageKit control
BoxDashStyleVisible | Sets whether or not the DashStyle combobox/label is displayed.
BoxEndArrowCapSizeVisible | Sets whether or not the EndArrowCapSize box/button/label is displayed
BoxEndLineCapVisible | Sets whether or not the EndLineCapVisible combobox/label is displayed
BoxLineJoinVisible | Sets whether or not the LineJoinVisible combobox/label is displayed
BoxStartArrowCapSizeVisible | Sets whether or not the StartArrowCapSize box/button/label is displayed
BoxStartLineCapVisible | Sets whether or not the StartLineCapVisible combobox/label is displayed
ButtonClosePenLine | Sets or retrieves the ToolStripButton control displaying the "ClosePenLine" item on the ToolBarSetupLines control
ButtonClosePenLineVisible | Sets whether or not the "ClosePenLine" button is displayed
ButtonDoubleLine | Sets or retrieves the ToolStripButton control displaying the "DoubleLine" item on the ToolBarSetupLines control
ButtonDoubleLineVisible | Sets whether or not the "DoubleLine" button is displayed
ButtonEndArrowCap | Sets or retrieves the ToolStripButton control displaying the "EndArrowCap" item on the ToolBarSetupLines control
ButtonEndArrowCapFilled | Sets or retrieves the ToolStripButton control displaying the "EndArrowCapFilled" item on the ToolBarSetupLines control
ButtonEndArrowCapFilledVisible | Sets whether or not the "EndArrowCapFilled" button is displayed
ButtonEndArrowCapSizeDown | Sets or retrieves the ToolStripButton control displaying the "EndArrowCapSizeDown" item on the ToolBarSetupLines control
ButtonEndArrowCapSizeUp | Sets or retrieves the ToolStripButton control displaying the "EndArrowCapSizeUp" item on the ToolBarSetupLines control
ButtonEndArrowCapVisible | Sets whether or not the "EndArrowCap" button is displayed
ButtonSize | Sets or retrieves the size of the buttons on the ToolBarSetupLines control
ButtonStartArrowCap | Sets or retrieves the ToolStripButton control displaying the "StartArrowCap" item on the ToolBarSetupLines control
ButtonStartArrowCapFilled | Sets or retrieves the ToolStripButton control displaying the "StartArrowCapFilled" item on the ToolBarSetupLines control
ButtonStartArrowCapFilledVisible | Sets whether or not the "StartArrowCapFilled" button is displayed
ButtonStartArrowCapSizeDown | Sets or retrieves the ToolStripButton control displaying the "StartArrowCapSizeDown" item on the ToolBarSetupLines control
ButtonStartArrowCapSizeUp | Sets or retrieves the ToolStripButton control displaying the "StartArrowCapSizeUp" item on the ToolBarSetupLines control
ButtonStartArrowCapVisible | Sets whether or not the "StartArrowCap" button is displayed
ComboBoxDashStyle | Sets or retrieves the ToolStripComboBox control displaying the "DashStyle" item of the ToolBarSetupLines control
ComboBoxEndLineCap | Sets or retrieves the ToolStripComboBox control displaying the "EndLineCap" item of the ToolBarSetupLines control
ComboBoxLineJoin | Sets or retrieves theToolStripComboBox control displaying the "LineJoin" item of the ToolBarSetupLines control
ComboBoxStartLineCap | Sets or retrieves the ToolStripComboBox control displaying the "StartLineCap" item the ToolBarSetupLines control
GroupArrowVisible | Sets whether or not the group of "Arrow" related comboboxes, buttons, and labels is displayed
GroupLineStyleVisible | Sets whether or not the group of "Line Style" related comboboxes, buttons, and labels is displayed
LabelDashStyle | Sets or retrieves the ToolStripLabel control displaying the "DashStyle" item on the ToolBarSetupLines control
LabelEndArrowCapSize | Sets or retrieves the ToolStripLabel control displaying the "EndArrowCapSize" item on the ToolBarSetupLines control
LabelEndArrowCapSizeUnit | Sets or retrieves ToolStripLabel control displaying the units for the "EndArrowCapSize" item on the ToolBarSetupLines control
LabelEndLineCap | Sets or retrieves ToolStripLabel control displaying the "EndLineCap" item on the ToolBarSetupLines control
LabelLineJoin | Sets or retrieves ToolStripLabel control displaying the "LineJoin" item on the ToolBarSetupLines control
LabelStartArrowCapSize | Sets or retrieves the ToolStripLabel control displaying the "StartArrowCapSize" item on the ToolBarSetupLines control
LabelStartArrowCapSizeUnit | Sets or retrieves ToolStripLabel control displaying the units for the "StartArrowCapSize" item on the ToolBarSetupLines control
LabelStartLineCap | Sets or retrieves ToolStripLabel control displaying the "StartLineCap" item on the ToolBarSetupLines control
MaxEndArrowCapSize | Sets the maximum value for the "EndArrowCapSize"
MaxStartArrowCapSize | Sets the maximum value for the "StartArrowCapSize"
Separator1Visible | Sets whether or not Separator1 is displayed in the ToolBarSetupLines control
Separator2Visible | Sets whether or not Separator2 is displayed in the ToolBarSetupLines control
Separator3Visible | Sets whether or not Separator3 is displayed in the ToolBarSetupLines control
Separator4Visible | Sets whether or not Separator4 is displayed in the ToolBarSetupLines control
SettingsForEachImageKit | Sets whether or not the ToolBarSetupLines control's settings apply to each ImageKit Control specified by the TargetImageKit property
TargetImageKit | Sets which ImageKit control is targeted by the ToolBarSetupLines control
TextBoxEndArrowCapSize | Sets or retrieves the ToolStripTextBox control displaying the "EndArrowCapSize" item on the ToolBarSetupLines control
TextBoxStartArrowCapSize | Sets or retrieves the ToolStripTextBox control displaying the "StartArrowCapSize" item on the ToolBarSetupLines control

Public Events

TargetImageKitChanged Generated whenever the TargetImageKit property changes

See Also

Newtone.ImageKit.Win.ToolBarSetupLines


ImageKit.Win.ToolBarSetUpLines Constructor

Newtone.ImageKit.Win.ToolBarSetUpLines Constructor

This constructor creates a new instance of the ToolBarSetUpLines class.

[Visual Basic] Public Sub New()
[C#] public public ToolBarSetUpLines()

See Also

ToolBarSetUpLines Members | Newtone.ImageKit.Win.ToolBarSetUpLines


BaseImageKitClosePenLine property

Newtone.ImageKit.Win.ToolBarSetupLines.BaseImageKitClosePenLine Property

This property sets or retrieves the value of the Edit.ClosePenLine property for the ImageKit control.

[Visual Basic]Public Property BaseImageKitClosePenLine As Boolean
[C#]public bool BaseImageKitClosePenLine {get; set;}

Property Value

True: The ImageKit control's ClosePenLine property is set to True
False: The ImageKit control's ClosePenLine property is set to False
The default value is False.

Explanation

The BaseImageKitClosePenLine property sets or retrieves the value of the Edit.ClosePenLine property for the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitClosePenLine property to set the Edit.ClosePenLine property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is false.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


PropertyBaseImageKitDashStyle property

Newtone.ImageKit.Win.ToolBarSetupLines.BaseImageKitDashStyle Property

This property sets or retrieves the value of the Edit.DashStyle property for the ImageKit control.

[Visual Basic]Public Property BaseImageKitDashStyle As System.Drawing.Drawing2D.DashStyle
[C#]public System.Drawing.Drawing2D.DashStyle BaseImageKitDashStyle {get; set;}

Property Value

A value of type System.Drawing.Drawing2D.DashStyle
The default value is System.Drawing.Drawing2D.DashStyle.Solid.

Explanation

The BaseImageKitDashStyle property sets or retrieves the value of the Edit.DashStyle property for the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitDashStyle property to set the Edit.DashStyle property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is false.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BaseImageKitDoubleLine property

Newtone.ImageKit.Win.ToolBarSetupLines.BaseImageKitDoubleLine Property

This property sets or retrieves the value of the Edit.DoubleLine property for the ImageKit control.

[Visual Basic]Public Property BaseImageKitDoubleLine As Boolean
[C#]public bool BaseImageKitDoubleLine {get; set;}

Property Value

True: The ImageKit control's DoubleLine property is set to True
False: The ImageKit control's DoubleLine property is set to False
The default value is False.

Explanation

The BaseImageKitDoubleLine property sets or retrieves the value of the Edit.DoubleLine property for the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitDoubleLine property to set the Edit.DoubleLine property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is false.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BaseImageKitEndArrowCap property

Newtone.ImageKit.Win.ToolBarSetupLines.BaseImageKitEndArrowCap Property

This property sets or retrieves the value of the Edit.EndArrowCap property for the ImageKit control.

[Visual Basic]Public Property BaseImageKitEndArrowCap As Boolean
[C#]public bool BaseImageKitEndArrowCap {get; set;}

Property Value

True: The ImageKit control's EndArrowCap property is set to True
False: The ImageKit control's EndArrowCap property is set to False
The default value is False.

Explanation

The BaseImageKitEndArrowCap property sets or retrieves the value of the Edit.EndArrowCap property for the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitEndArrowCap property to set the Edit.EndArrowCap property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is false.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BaseImageKitEndArrowCapFilled property

Newtone.ImageKit.Win.ToolBarSetupLines.BaseImageKitEndArrowCapFilled Property

This property sets or retrieves the value of the Edit.EndArrowCapFilled property for the ImageKit control.

[Visual Basic]Public Property BaseImageKitEndArrowCapFilled As Boolean
[C#]public bool BaseImageKitEndArrowCapFilled {get; set;}

Property Value

True: The ImageKit control's EndArrowCapFilled property is set to True
False: The ImageKit control's EndArrowCapFilled property is set to False
The default value is False.

Explanation

The BaseImageKitEndArrowCapFilled property sets or retrieves the value of the Edit.EndArrowCapFilled property for the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitEndArrowCapFilled property to set the Edit.EndArrowCapFilled property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is false.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BaseImageKitEndArrowCapSize property

Newtone.ImageKit.Win.ToolBarSetupLines.BaseImageKitEndArrowCapSize Property

This property sets or retrieves the value of the Edit.EndArrowCapSize property for the ImageKit control.

[Visual Basic]Public Property BaseImageKitEndArrowCapSize As Integer
[C#]public int BaseImageKitEndArrowCapSize {get; set;}

Property Value

The size of the EndArrowCap as an integer
The default value is 10.

Explanation

The BaseImageKitEndArrowCapSize property sets or retrieves the value of the Edit.EndArrowCapSize property for the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitEndArrowCapSize property to set the Edit.EndArrowCapSize property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is false.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BaseImageKitEndLineCap property

Newtone.ImageKit.Win.ToolBarSetupLines.BaseImageKitEndLineCap Property

This property sets or retrieves the value of the Edit.EndLineCap property for the ImageKit control.

[Visual Basic]Public Property BaseImageKitEndLineCap As System.Drawing.Drawing2D.LineCap
[C#]public System.Drawing.Drawing2D.LineCap BaseImageKitEndLineCap {get; set;}

Property Value

A value of type System.Drawing.Drawing2D.LineCap
The default value is System.Drawing.Drawing2D.LineCap.Flat.

Explanation

The BaseImageKitEndLineCap property sets or retrieves the value of the Edit.EndLineCap property for the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitEndLineCap property to set the Edit.EndLineCap property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is false.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BaseImageKitLineJoin property

Newtone.ImageKit.Win.ToolBarSetupLines.BaseImageKitLineJoin Property

This property sets or retrieves the value of the Edit.LineJoin property for the ImageKit control.

[Visual Basic]Public Property BaseImageKitLineJoin As System.Drawing.Drawing2D.LineJoin
[C#]public System.Drawing.Drawing2D.LineJoin BaseImageKitLineJoin {get; set;}

Property Value

A value of type System.Drawing.Drawing2D.LineJoin
The default value is System.Drawing.Drawing2D.LineJoin.Round.

Explanation

The BaseImageKitLineJoin property sets or retrieves the value of the Edit.EndLineJoin property for the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitLineJoin property to set the Edit.EndLineJoin property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is false.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BaseImageKitStartArrowCap property

Newtone.ImageKit.Win.ToolBarSetupLines.BaseImageKitStartArrowCap Property

This property sets or retrieves the value of the Edit.StartArrowCap property for the ImageKit control.

[Visual Basic]Public Property BaseImageKitStartArrowCap As Boolean
[C#]public bool BaseImageKitStartArrowCap {get; set;}

Property Value

True: The ImageKit control's StartArrowCap property is set to True
False: The ImageKit control's StartArrowCap property is set to False
The default value is False.

Explanation

The BaseImageKitStartArrowCap property sets or retrieves the value of the Edit.StartArrowCap property for the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitStartArrowCap property to set the Edit.StartArrowCap property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is false.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BaseImageKitStartArrowCapFilled property

Newtone.ImageKit.Win.ToolBarSetupLines.BaseImageKitStartArrowCapFilled Property

This property sets or retrieves the value of the Edit.StartArrowCapFilled property for the ImageKit control.

[Visual Basic]Public Property BaseImageKitStartArrowCapFilled As Boolean
[C#]public bool BaseImageKitStartArrowCapFilled {get; set;}

Property Value

True: The ImageKit control's StartArrowCapFilled property is set to True
False: The ImageKit control's StartArrowCapFilled property is set to False
The default value is False.

Explanation

The BaseImageKitStartArrowCapFilled property sets or retrieves the value of the Edit.StartArrowCapFilled property for the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitStartArrowCapFilled property to set the EditStartArrowCapFilled property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is false.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BaseImageKitStartArrowCapSize property

Newtone.ImageKit.Win.ToolBarSetupLines.BaseImageKitStartArrowCapSize Property

This property sets or retrieves the value of the Edit.StartArrowCapSize property for the ImageKit control.

[Visual Basic]Public Property BaseImageKitStartArrowCapSize As Integer
[C#]public int BaseImageKitStartArrowCapSize {get; set;}

Property Value

The size of the StartArrowCap as an integer
The default value is 10.

Explanation

The BaseImageKitStartArrowCapSize property sets or retrieves the value of the Edit.StartArrowCapFilled property for the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitStartArrowCapSize property to set the Edit.StartArrowCapSize property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is false.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BaseImageKitStartLineCap property

Newtone.ImageKit.Win.ToolBarSetupLines.BaseImageKitStartLineCap Property

This property sets or retrieves the value of the Edit.StartLineCap property for the ImageKit control.

[Visual Basic]Public Property BaseImageKitStartLineCap As System.Drawing.Drawing2D.LineCap
[C#]public System.Drawing.Drawing2D.LineCap BaseImageKitStartLineCap {get; set;}

Property Value

A value of type System.Drawing.Drawing2D.LineCap
The default value is System.Drawing.Drawing2D.LineCap.Flat.

Explanation

The BaseImageKitStartLineCap property sets or retrieves the value of the Edit.StartLineCap property for the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitStartLineCap property to set the Edit.StartLineCap property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is false.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BoxDashStyleVisible property

Newtone.ImageKit.Win.ToolBarSetupLines.BoxDashStyleVisible Property

This property sets whether or not the DashStyle combobox/label of the ToolBarSetupLines control is displayed.

[Visual Basic]Public Property BoxDashStyleVisible As Boolean
[C#]public bool BoxDashStyleVisible {get; set;}

Property Value

True: The DashStyle combobox/label is displayed
False: The DashStyle combobox/label is NOT displayed

Default value is True.

Explanation

The BoxDashStyleVisible property sets whether or not the DashStyle combobox/label of the ToolBarSetupLines control is displayed. When this property is False, the DashStyle combobox/label is not displayed.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BoxEndArrowCapSizeVisible property

Newtone.ImageKit.Win.ToolBarSetupLines.BoxEndArrowCapSizeVisible Property

This property sets whether or not the EndArrowCapSize box/button/label of the ToolBarSetupLines control is displayed.

[Visual Basic]Public Property BoxEndArrowCapSizeVisible As Boolean
[C#]public bool BoxEndArrowCapSizeVisible {get; set;}

Property Value

True: The EndArrowCapSize box/button/label is displayed
False: The EndArrowCapSize box/button/label is NOT displayed

Default value is True.

Explanation

The BoxEndArrowCapSizeVisible property sets whether or not the EndArrowCapSize box/button/label of the ToolBarSetupLines control is displayed. When this property is False, the EndArrowCapSize box/button/label is not displayed.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BoxEndLineCapVisible property

Newtone.ImageKit.Win.ToolBarSetupLines.BoxEndLineCapVisible Property

This property sets whether or not the EndLineCapVisible combobox/label of the ToolBarSetupLines control is displayed.

[Visual Basic]Public Property BoxEndLineCapVisible As Boolean
[C#]public bool BoxEndLineCapVisible {get; set;}

Property Value

True: The EndLineCapVisible combobox/label is displayed
False: The EndLineCapVisible combobox/label is NOT displayed

Default value is True.

Explanation

The BoxEndLineCapVisible property sets whether or not the EndLineCapVisible combobox/label of the ToolBarSetupLines control is displayed. When this property is False, the EndLineCapVisible combobox/label is not displayed.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BoxLineJoinVisible property

Newtone.ImageKit.Win.ToolBarSetupLines.BoxLineJoinVisible Property

This property sets whether or not the LineJoinVisible combobox/label of the ToolBarSetupLines control is displayed.

[Visual Basic]Public Property BoxLineJoinVisible As Boolean
[C#]public bool BoxLineJoinVisible {get; set;}

Property Value

True: The LineJoinVisible combobox/label is displayed
False: The LineJoinVisible combobox/label is NOT displayed

Default value is True.

Explanation

The BoxLineJoinVisible property sets whether or not the LineJoinVisible combobox/label of the ToolBarSetupLines control is displayed. When this property is False, the LineJoinVisible combobox/label is not displayed.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BoxStartArrowCapSizeVisible property

Newtone.ImageKit.Win.ToolBarSetupLines.BoxStartArrowCapSizeVisible Property

This property sets whether or not the StartArrowCapSize box/button/label of the ToolBarSetupLines control is displayed.

[Visual Basic]Public Property BoxStartArrowCapSizeVisible As Boolean
[C#]public bool BoxStartArrowCapSizeVisible {get; set;}

Property Value

True: The StartArrowCapSize box/button/label is displayed
False: The StartArrowCapSize box/button/label is NOT displayed

Default value is True.

Explanation

The BoxStartArrowCapSize property sets whether or not the StartArrowCapSize box/button/label of the ToolBarSetupLines control is displayed. When this property is False, the StartArrowCapSize box/button/label is not displayed.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


BoxStartLineCapVisible property

Newtone.ImageKit.Win.ToolBarSetupLines.BoxStartLineCapVisible Property

This property sets whether or not the StartLineCapVisible combobox/label of the ToolBarSetupLines control is displayed.

[Visual Basic]Public Property BoxStartLineCapVisible As Boolean
[C#]public bool BoxStartLineCapVisible {get; set;}

Property Value

True: The StartLineCapVisible combobox/label is displayed
False: The StartLineCapVisible combobox/label is NOT displayed

Default value is True.

Explanation

The BoxStartLineCapVisible property sets whether or not the StartLineCapVisible combobox/label of the ToolBarSetupLines control is displayed. When this property is False, the StartLineCapVisible combobox/label is not displayed.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonClosePenLine property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonClosePenLine Property

This property sets or retrieves the ToolStripButton control displaying the "ClosePenLine" item on the ToolBarSetupLines control.

[Visual Basic]Public Property ButtonClosePenLine As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonClosePenLine {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonClosePenLine property sets or retrieves the ToolStripButton control displaying the "ClosePenLine" item on the ToolBarSetupLines control.

Because the "ClosePenLine" button is a ToolStripButton control, you can use the ButtonClosePenLine property to change the "ClosePenLine" button settings, generate events, etc.

Please refer to the examples below.

Examples

(1) To change the image displayed in the "ClosePenLine" button

[Visual Basic.NET]
ToolBarSetupLines1.ButtonClosePenLine.Image = Image.FromFile("c:\images\button_img1.bmp")

[Visual C#.NET]
toolBarSetupLines1.ButtonClosePenLine.Image = Image.FromFile("c:\\images\\button_img1.bmp");

(2) Access the "StartArrowCapSizeUp" button's Click event.

[Visual Basic.NET]
Private Sub ToolBarSetupLines1_ItemClicked(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolStripItemClickedEventArgs) Handles ToolBarSetupLines1.ItemClicked
If e.ClickedItem Is ToolBarSetupLines1.ButtonStartArrowCapSizeUp Then 'The button that was clicked is the "ButtonStartArrowCapSizeUp" button
'Write code here that you want to execute when the event fires
End If
End Sub

[Visual C#.NET]
private void toolBarSetUpLines1_ItemClicked(object sender, ToolStripItemClickedEventArgs e)
{
if (e.ClickedItem == toolBarSetUpLines1.ButtonStartArrowCapSizeUp)//The button that was clicked is the "ButtonStartArrowCapSizeUp" button
{
//Write code here that you want to execute when the event fires
}
}

(3) Access the "StartArrowCapSizeUp " button's MouseUp event.

[Visual Basic.NET]
'In the FormLoad event, set the ButtonStartArrowCapSizeUp delegate
AddHandler ToolBarSetupLines1.ButtonStartArrowCapSizeUp.MouseUp, AddressOf ButtonStartArrowCapSizeUp_MouseUp

'event handler delegate
Private Sub ButtonStartArrowCapSizeUp_MouseUp(ByVal sender As System.Object, ByVal e As System.EventArgs)
'Write code here that you want to execute when the event fires
End Sub

[Visual C#.NET]
//In the FormLoad event, set the ButtonStartArrowCapSizeUp delegate
toolBarSetUpLines1.ButtonStartArrowCapSizeUp.MouseUp += new MouseEventHandler(ButtonStartArrowCapSizeUp_MouseUp);

//event handler delegate
private void ButtonStartArrowCapSizeUp_MouseUp(object sender, EventArgs e)
{
//Write code here that you want to execute when the event fires
}

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonClosePenLineVisible Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonClosePenLineVisible Property

This property sets whether or not the "ClosePenLine" button of the ToolBarSetupLines control is displayed.

[Visual Basic]Public Property ButtonClosePenLineVisible As Boolean
[C#]public bool ButtonClosePenLineVisible {get; set;}

Property Value

True: The ClosePenLine button is displayed
False: The ClosePenLine button is NOT displayed

Default value is True.

Explanation

The ButtonClosePenLineVisible property sets whether or not the "ClosePenLine" button of the ToolBarSetupLines control is displayed. When this property is False, the "ClosePenLine" button is not displayed.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonDoubleLine Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonDoubleLine Property

This property sets or retrieves the ToolStripButton control displaying the "DoubleLine" item on the ToolBarSetupLines control.

[Visual Basic]Public Property ButtonDoubleLine As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonDoubleLine {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonDoubleLine property sets or retrieves the ToolStripButton control displaying the "DoubleLine" item on the ToolBarSetupLines control.

Because the "DoubleLine" button is a ToolStripButton control, you can use the ButtonDoubleLine property to change the "DoubleLine" button settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonDoubleLineVisible Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonDoubleLineVisible Property

This property sets whether or not the "DoubleLine" button of the ToolBarSetupLines control is displayed.

[Visual Basic]Public Property ButtonDoubleLineVisible As Boolean
[C#]public bool ButtonDoubleLineVisible {get; set;}

Property Value

True: The DoubleLine button is displayed
False: The DoubleLine button is NOT displayed

Default value is True.

Explanation

The ButtonDoubleLineVisible property sets whether or not the "DoubleLine" button of the ToolBarSetupLines control is displayed. When this property is False, the "DoubleLine" button is not displayed.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonEndArrowCap Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonEndArrowCap Property

This property sets or retrieves the ToolStripButton control displaying the "EndArrowCap" item on the ToolBarSetupLines control.

[Visual Basic]Public Property ButtonEndArrowCap As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonEndArrowCap {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonEndArrowCap property sets or retrieves the ToolStripButton control displaying the "EndArrowCap" item on the ToolBarSetupLines control.

Because the "EndArrowCap" button is a ToolStripButton control, you can use the ButtonEndArrowCap property to change the "EndArrowCap" button settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonEndArrowCapFilled Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonEndArrowCapFilled Property

This property sets or retrieves the ToolStripButton control displaying the "EndArrowCapFilled" item on the ToolBarSetupLines control.

[Visual Basic]Public Property ButtonEndArrowCapFilled As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonEndArrowCapFilled {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonEndArrowCapFilled property sets or retrieves the ToolStripButton control displaying the "EndArrowCapFilled" item on the ToolBarSetupLines control.

Because the "EndArrowCapFilled" button is a ToolStripButton control, you can use the ButtonEndArrowCapFilled property to change the "EndArrowCapFilled" button settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonEndArrowCapFilledVisible Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonEndArrowCapFilledVisible Property

This property sets whether or not the "EndArrowCapFilled" button of the ToolBarSetupLines control is displayed.

[Visual Basic]Public Property ButtonEndArrowCapFilledVisible As Boolean
[C#]public bool ButtonEndArrowCapFilledVisible {get; set;}

Property Value

True: The EndArrowCapFilled button is displayed
False: The EndArrowCapFilled button is NOT displayed

Default value is True.

Explanation

The ButtonEndArrowCapFilledVisible property sets whether or not the "EndArrowCapFilled" button of the ToolBarSetupLines control is displayed. When this property is False, the "EndArrowCapFilled" button is not displayed.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonEndArrowCapSizeDown Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonEndArrowCapSizeDown Property

This property sets or retrieves the ToolStripButton control displaying the "EndArrowCapSizeDown" item on the ToolBarSetupLines control.

[Visual Basic]Public Property ButtonEndArrowCapSizeDown As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonEndArrowCapSizeDown {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonEndArrowCapSizeDown property sets or retrieves the ToolStripButton control displaying the "EndArrowCapSizeDown" item on the ToolBarSetupLines control.

Because the "EndArrowCapSizeDown" button is a ToolStripButton control, you can use the ButtonEndArrowCapSizeDown property to change the "EndArrowCapSizeDown" button settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonEndArrowCapSizeUp Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonEndArrowCapSizeUp Property

This property sets or retrieves the ToolStripButton control displaying the "EndArrowCapSizeUp" item on the ToolBarSetupLines control.

[Visual Basic]Public Property ButtonEndArrowCapSizeUp As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonEndArrowCapSizeUp {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonEndArrowCapSizeUp property sets or retrieves the ToolStripButton control displaying the "EndArrowCapSizeUp" item on the ToolBarSetupLines control.

Because the "EndArrowCapSizeUp" button is a ToolStripButton control, you can use the ButtonEndArrowCapSizeUp property to change the "EndArrowCapSizeUp" button settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonEndArrowCapVisible Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonEndArrowCapVisible Property

This property sets whether or not the "EndArrowCap" button of the ToolBarSetupLines control is displayed.

[Visual Basic]Public Property ButtonEndArrowCapVisible As Boolean
[C#]public bool ButtonEndArrowCapVisible {get; set;}

Property Value

True: The EndArrowCap button is displayed
False: The EndArrowCap button is NOT displayed

Default value is True.

Explanation

The ButtonEndArrowCapVisible property sets whether or not the "EndArrowCap" button of the ToolBarSetupLines control is displayed. When this property is False, the "EndArrowCap" button is not displayed.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonSize Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonSize Property

This property sets or retrieves the size of the buttons on the ToolBarSetupLines control.

[Visual Basic]Public Property ButtonSize As ToolBarButtonSize
[C#]public ToolBarButtonSize ButtonSize {get; set;}

Property Value

A value of type ToolBarButtonSize

Default value is ToolBarButtonSize.Small

Explanation

The ButtonSize property sets or retrieves the size of the buttons on the ToolBarSetupLines control. Depending on the value set in this property, the width of the ToolBarSetupLines control may change.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonStartArrowCap Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonStartArrowCap Property

This property sets or retrieves the ToolStripButton control displaying the "StartArrowCap" item on the ToolBarSetupLines control.

[Visual Basic]Public Property ButtonStartArrowCap As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonStartArrowCap {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonStartArrowCap property sets or retrieves the ToolStripButton control displaying the "StartArrowCap" item on the ToolBarSetupLines control.

Because the "StartArrowCap" button is a ToolStripButton control, you can use the ButtonStartArrowCap property to change the "StartArrowCap" button settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonStartArrowCapFilled Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonStartArrowCapFilled Property

This property sets or retrieves the ToolStripButton control displaying the "StartArrowCapFilled" item on the ToolBarSetupLines control.

[Visual Basic]Public Property ButtonStartArrowCapFilled As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonStartArrowCapFilled {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonStartArrowCapFilled property sets or retrieves the ToolStripButton control displaying the "StartArrowCapFilled" item on the ToolBarSetupLines control.

Because the "StartArrowCapFilled" button is a ToolStripButton control, you can use the ButtonStartArrowCapFilled property to change the "StartArrowCapFilled" button settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonStartArrowCapFilledVisible Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonStartArrowCapFilledVisible Property

This property sets whether or not the "StartArrowCapFilled" button of the ToolBarSetupLines control is displayed.

[Visual Basic]Public Property ButtonStartArrowCapFilledVisible As Boolean
[C#]public bool ButtonStartArrowCapFilledVisible {get; set;}

Property Value

True: The StartArrowCapFilled button is displayed
False: The StartArrowCapFilled button is NOT displayed

Default value is True.

Explanation

The ButtonStartArrowCapFilledVisible property sets whether or not the "StartArrowCapFilled" button of the ToolBarSetupLines control is displayed. When this property is False, the "StartArrowCapFilled" button is not displayed.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonStartArrowCapSizeDown Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonStartArrowCapSizeDown Property

This property sets or retrieves the ToolStripButton control displaying the "StartArrowCapSizeDown" item on the ToolBarSetupLines control.

[Visual Basic]Public Property ButtonStartArrowCapSizeDown As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonStartArrowCapSizeDown {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonStartArrowCapSizeDown property sets or retrieves the ToolStripButton control displaying the "StartArrowCapSizeDown" item on the ToolBarSetupLines control.

Because the "StartArrowCapSizeDown" button is a ToolStripButton control, you can use the ButtonStartArrowCapSizeDown property to change the "StartArrowCapSizeDown" button settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonStartArrowCapSizeUp Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonStartArrowCapSizeUp Property

This property sets or retrieves the ToolStripButton control displaying the "StartArrowCapSizeUp" item on the ToolBarSetupLines control.

[Visual Basic]Public Property ButtonStartArrowCapSizeUp As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonStartArrowCapSizeUp {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonStartArrowCapSizeUp property sets or retrieves the ToolStripButton control displaying the "StartArrowCapSizeUp" item on the ToolBarSetupLines control.

Because the "StartArrowCapSizeUp" button is a ToolStripButton control, you can use the ButtonStartArrowCapSizeUp property to change the "StartArrowCapSizeUp" button settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ButtonStartArrowCapVisible Property

Newtone.ImageKit.Win.ToolBarSetupLines.ButtonStartArrowCapVisible Property

This property sets whether or not the "StartArrowCap" button of the ToolBarSetupLines control is displayed.

[Visual Basic]Public Property ButtonStartArrowCapVisible As Boolean
[C#]public bool ButtonStartArrowCapVisible {get; set;}

Property Value

True: The StartArrowCap button is displayed
False: The StartArrowCap button is NOT displayed

Default value is True.

Explanation

The ButtonStartArrowCapVisible property sets whether or not the "StartArrowCap" button of the ToolBarSetupLines control is displayed. When this property is False, the "StartArrowCap" button is not displayed.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ComboBoxDashStyle Property

Newtone.ImageKit.Win.ToolBarSetupLines.ComboBoxDashStyle Property

This property sets or retrieves the ToolStripComboBox control displaying the "DashStyle" item of the ToolBarSetupLines control.

[Visual Basic]Public Property ComboBoxDashStyle As System.Windows.Forms.ToolStripComboBox
[C#]public System.Windows.Forms.ToolStripComboBox ComboBoxDashStyle {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripComboBox

Explanation

The ComboBoxDashStyle property sets or retrieves the ToolStripComboBox control displaying the "DashStyle" item of the ToolBarSetupLines control.

Because the "DashStyle" combobox is a ToolStripComboBox control, you can use the ComboBoxDashStyle property to change the "DashStyle" combobox settings, generate events, etc.

Please refer to the examples below.

Examples

(1) To change the background color displayed in the "DashStyle" combobox

[Visual Basic.NET]
ToolBarSetupLines1.ComboBoxDashStyle.BackColor = Color.FromArgb(255, 255, 192)

[Visual C#.NET]
toolBarSetUpLines1.ComboBoxDashStyle.BackColor=Color.FromArgb(255, 255, 192);

(2) Access the "DashStyle " combobox's SelectedIndexChanged event.

[Visual Basic.NET]
'In the FormLoad event, set the ComboBoxDashStyle delegate
AddHandler ToolBarSetupLines1.ComboBoxDashStyle.SelectedIndexChanged, AddressOf ComboBoxDashStyle_SelectedIndexChanged

'event handler delegate
Private Sub ComboBoxDashStyle_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs)
'Write code here that you want to execute when the event fires
End Sub

[Visual C#.NET]
//In the FormLoad event, set the ComboBoxDashStyle delegate
toolBarSetUpLines1.ComboBoxDashStyle.SelectedIndexChanged += new EventHandler(ComboBoxDashStyle_SelectedIndexChanged);

//event handler delegate
private void ComboBoxDashStyle_SelectedIndexChanged(object sender, EventArgs e)
{
//Write code here that you want to execute when the event fires
}

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ComboBoxEndLineCap Property

Newtone.ImageKit.Win.ToolBarSetupLines.ComboBoxEndLineCap Property

This property sets or retrieves the ToolStripComboBox control displaying the "EndLineCap" item of the ToolBarSetupLines control.

[Visual Basic]Public Property ComboBoxEndLineCap As System.Windows.Forms.ToolStripComboBox
[C#]public System.Windows.Forms.ToolStripComboBox ComboBoxEndLineCap {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripComboBox

Explanation

The ComboBoxEndLineCap property sets or retrieves the ToolStripComboBox control displaying the "EndLineCap" item of the ToolBarSetupLines control.

Because the "EndLineCap" combobox is a ToolStripComboBox control, you can use the ComboBoxEndLineCap property to change the "EndLineCap" combobox settings, generate events, etc.

For coding examples, please refer to the ComboBoxDashStyle property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ComboBoxLineJoin Property

Newtone.ImageKit.Win.ToolBarSetupLines.ComboBoxLineJoin Property

This property sets or retrieves theToolStripComboBox control displaying the "LineJoin" item of the ToolBarSetupLines control.

[Visual Basic]Public Property ComboBoxLineJoin As System.Windows.Forms.ToolStripComboBox
[C#]public System.Windows.Forms.ToolStripComboBox ComboBoxLineJoin {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripComboBox

Explanation

The ComboBoxLineJoin property sets or retrieves theToolStripComboBox control displaying the "LineJoin" item of the ToolBarSetupLines control.

Because the "LineJoin" combobox is a ToolStripComboBox control, you can use the ComboBoxLineJoin property to change the "LineJoin" combobox settings, generate events, etc.

For coding examples, please refer to the ComboBoxDashStyle property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ComboBoxStartLineCap Property

Newtone.ImageKit.Win.ToolBarSetupLines.ComboBoxStartLineCap Property

This property sets or retrieves the ToolStripComboBox control displaying the "StartLineCap" item the ToolBarSetupLines control.

[Visual Basic]Public Property ComboBoxStartLineCap As System.Windows.Forms.ToolStripComboBox
[C#]public System.Windows.Forms.ToolStripComboBox ComboBoxStartLineCap {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripComboBox

Explanation

The ComboBoxStartLineCap property sets or retrieves the ToolStripComboBox control displaying the "StartLineCap" item the ToolBarSetupLines control.

Because the "StartLineCap" combobox is a ToolStripComboBox control, you can use the ComboBoxStartLineCap property to change the "StartLineCap" combobox settings, generate events, etc.

For coding examples, please refer to the ComboBoxDashStyle property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


GroupArrowVisible Property

Newtone.ImageKit.Win.ToolBarSetupLines.GroupArrowVisible Property

This property sets whether or not the group of "Arrow" related comboboxes, buttons, and labels is displayed.

[Visual Basic]Public Property GroupArrowVisible As Boolean
[C#]public bool GroupArrowVisible {get; set;}

Property Value

True: The group of "Arrow" related items is displayed
False: The group of "Arrow" related items is NOT displayed

Default value is True.

Explanation

The GroupArrowVisible property sets whether or not the group of "Arrow" related comboboxes, buttons, and labels is displayed. When this property is False, the "StartArrowCap", "StartArrowCapFilled", "StartArrowCapSizeDown", "StartArrowCapSizeUp", "EndArrowCap", "EndArrowCapFilled", "EndArrowCapSizeDown", and "EndArrowCapSizeUp" items and the related separators are not displayed.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


GroupLineStyleVisible Property

Newtone.ImageKit.Win.ToolBarSetupLines.GroupLineStyleVisible Property

This property sets whether or not the group of "Line Style" related comboboxes, buttons, and labels is displayed.

[Visual Basic]Public Property GroupLineStyleVisible As Boolean
[C#]public bool GroupLineStyleVisible {get; set;}

Property Value

True: The group of "Line Style" related items is displayed
False: The group of "Line Style" related items is NOT displayed

Default value is True.

Explanation

The GroupLineStyleVisible property sets whether or not the group of "Line Style" related comboboxes, buttons, and labels is displayed. When this property is False, the "DashStyle", "StartLineCap", "EndLineCap", "LineJoin" items and the related separators are not displayed.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


LabelDashStyle Property

Newtone.ImageKit.Win.ToolBarSetupLines.LabelDashStyle Property

This property sets or retrieves the ToolStripLabel control displaying the "DashStyle" item on the ToolBarSetupLines control.

[Visual Basic]Public Property LabelDashStyle As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelDashStyle {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelDashStyle property sets or retrieves the ToolStripLabel control displaying the "DashStyle" item on the ToolBarSetupLines control.

Because the "DashStyle" label is a ToolStripLabel control, you can use the LabelDashStyle property to change the "DashStyle" label settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


LabelEndArrowCapSize Property

Newtone.ImageKit.Win.ToolBarSetupLines.LabelEndArrowCapSize Property

This property sets or retrieves the ToolStripLabel control displaying the "EndArrowCapSize" item on the ToolBarSetupLines control.

[Visual Basic]Public Property LabelEndArrowCapSize As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelEndArrowCapSize {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelEndArrowCapSize property sets or retrieves the ToolStripLabel control displaying the "EndArrowCapSize" item on the ToolBarSetupLines control.

Because the "EndArrowCapSize" label is a ToolStripLabel control, you can use the LabelEndArrowCapSize property to change the "EndArrowCapSize" label settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


LabelEndArrowCapSizeUnit Property

Newtone.ImageKit.Win.ToolBarSetupLines.LabelEndArrowCapSizeUnit Property

This property sets or retrieves ToolStripLabel control displaying the units for the "EndArrowCapSize" item on the ToolBarSetupLines control.

[Visual Basic]Public Property LabelEndArrowCapSizeUnit As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelEndArrowCapSizeUnit {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelEndArrowCapSizeUnit property sets or retrieves ToolStripLabel control displaying the units for the "EndArrowCapSize" item on the ToolBarSetupLines control.

Because the "EndArrowCapSizeUnit" label is a ToolStripLabel control, you can use the LabelEndArrowCapSizeUnit property to change the "EndArrowCapSizeUnit" label settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


LabelEndLineCap Property

Newtone.ImageKit.Win.ToolBarSetupLines.LabelEndLineCap Property

This property sets or retrieves ToolStripLabel control displaying the "EndLineCap" item on the ToolBarSetupLines control.

[Visual Basic]Public Property LabelEndLineCap As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelEndLineCap {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelEndLineCap property sets or retrieves ToolStripLabel control displaying the "EndLineCap" item on the ToolBarSetupLines control.

Because the "EndLineCap" label is a ToolStripLabel control, you can use the LabelEndLineCap property to change the "EndLineCap" label settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


LabelLineJoin Property

Newtone.ImageKit.Win.ToolBarSetupLines.LabelLineJoin Property

This property sets or retrieves ToolStripLabel control displaying the "LineJoin" item on the ToolBarSetupLines control.

[Visual Basic]Public Property LabelLineJoin As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelLineJoin {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelLineJoin property sets or retrieves ToolStripLabel control displaying the "LineJoin" item on the ToolBarSetupLines control.

Because the "LineJoin" label is a ToolStripLabel control, you can use the LabelLineJoin property to change the "LineJoin" label settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


LabelStartArrowCapSize Property

Newtone.ImageKit.Win.ToolBarSetupLines.LabelStartArrowCapSize Property

This property sets or retrieves the ToolStripLabel control displaying the "StartArrowCapSize" item on the ToolBarSetupLines control.

[Visual Basic]Public Property LabelStartArrowCapSize As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelStartArrowCapSize {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelStartArrowCapSize property sets or retrieves the ToolStripLabel control displaying the "StartArrowCapSize" item on the ToolBarSetupLines control.

Because the "StartArrowCapSize" label is a ToolStripLabel control, you can use the LabelStartArrowCapSize property to change the "StartArrowCapSize" label settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


LabelStartArrowCapSizeUnit Property

Newtone.ImageKit.Win.ToolBarSetupLines.LabelStartArrowCapSizeUnit Property

This property sets or retrieves ToolStripLabel control displaying the units for the "StartArrowCapSize" item on the ToolBarSetupLines control.

[Visual Basic]Public Property LabelStartArrowCapSizeUnit As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelStartArrowCapSizeUnit {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelStartArrowCapSizeUnit property sets or retrieves ToolStripLabel control displaying the units for the "StartArrowCapSize" item on the ToolBarSetupLines control.

Because the "StartArrowCapSizeUnit" label is a ToolStripLabel control, you can use the LabelStartArrowCapSizeUnit property to change the "StartArrowCapSizeUnit" label settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


LabelStartLineCap Property

Newtone.ImageKit.Win.ToolBarSetupLines.LabelStartLineCap Property

This property sets or retrieves ToolStripLabel control displaying the "StartLineCap" item on the ToolBarSetupLines control.

[Visual Basic]Public Property LabelStartLineCap As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelStartLineCap {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelStartLineCap property sets or retrieves ToolStripLabel control displaying the "StartLineCap" item on the ToolBarSetupLines control.

Because the "StartLineCap" label is a ToolStripLabel control, you can use the LabelStartLineCap property to change the "StartLineCap" label settings, generate events, etc.

For coding examples, please refer to the ButtonClosePenLine property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


MaxEndArrowCapSize Property

Newtone.ImageKit.Win.ToolBarSetupLines.MaxEndArrowCapSize Property

This property sets the maximum value for the "EndArrowCapSize".

[Visual Basic]Public Property MaxEndArrowCapSize As Integer
[C#]public int MaxEndArrowCapSize {get; set;}

Property Value

An integer the sets the "EndArrowCapSize" maximum value

Default value is 999

Explanation

The MaxEndArrowCapSize property sets the maximum value for the "EndArrowCapSize".

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


MaxStartArrowCapSize Property

Newtone.ImageKit.Win.ToolBarSetupLines.MaxStartArrowCapSize Property

This property sets the maximum value for the "StartArrowCapSize".

[Visual Basic]Public Property MaxStartArrowCapSize As Integer
[C#]public int MaxStartArrowCapSize {get; set;}

Property Value

An integer the sets the "StartArrowCapSize" maximum value

Default value is 999

Explanation

The MaxStartArrowCapSize property sets the maximum value for the "StartArrowCapSize".

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


Separator1Visible Property

Newtone.ImageKit.Win.ToolBarSetupLines.Separator1Visible Property

This property sets whether or not Separator1 is displayed in the ToolBarSetupLines control.

[Visual Basic]Public Property Separator1Visible As Boolean
[C#]public bool Separator1Visible {get; set;}

Property Value

True: Separator1 is displayed
False: Separator1 is NOT displayed

Default value is True

Explanation

The Separator1Visible property sets whether or not Separator1 is displayed in the ToolBarSetupLines control. Separator1 is the separator between the "ClosePenLine" button and the "DashStyle" label, when the ToolBarSetupLines control is in its default state.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


Separator2Visible Property

Newtone.ImageKit.Win.ToolBarSetupLines.Separator2Visible Property

This property sets whether or not Separator2 is displayed in the ToolBarSetupLines control.

[Visual Basic]Public Property Separator2Visible As Boolean
[C#]public bool Separator2Visible {get; set;}

Property Value

True: Separator2 is displayed
False: Separator2 is NOT displayed

Default value is True

Explanation

The Separator2Visible property sets whether or not Separator2 is displayed in the ToolBarSetupLines control. Separator2 is the separator between the "DashStyle" combobox and the "StartLineCapStyle" label, when the ToolBarSetupLines control is in its default state.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


Separator3Visible Property

Newtone.ImageKit.Win.ToolBarSetupLines.Separator3Visible Property

This property sets whether or not Separator3 is displayed in the ToolBarSetupLines control.

[Visual Basic]Public Property Separator3Visible As Boolean
[C#]public bool Separator3Visible {get; set;}

Property Value

True: Separator3 is displayed
False: Separator3 is NOT displayed

Default value is True

Explanation

The Separator3Visible property sets whether or not Separator3 is displayed in the ToolBarSetupLines control. Separator3 is the separator between the "LineJoinStyle" combobox and the "StartArrowCap" button, when the ToolBarSetupLines control is in its default state.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


Separator4Visible Property

Newtone.ImageKit.Win.ToolBarSetupLines.Separator4Visible Property

This property sets whether or not Separator4 is displayed in the ToolBarSetupLines control.

[Visual Basic]Public Property Separator4Visible As Boolean
[C#]public bool Separator4Visible {get; set;}

Property Value

True: Separator4 is displayed
False: Separator4 is NOT displayed

Default value is True

Explanation

The Separator4Visible property sets whether or not Separator4 is displayed in the ToolBarSetupLines control. Separator4 is the separator between the "StartArrowCapSizeDown" and the "EndArrowCap" buttons, when the ToolBarSetupLines control is in its default state.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


SettingsForEachImageKit property

Newtone.ImageKit.Win.ToolBarSetupLines.SettingsForEachImageKit Property

This property determines if the ToolBarSetupLines control's settings apply to each ImageKit Control according to the TargetImageKit property value, or if the ToolBarSetupLines control's settings apply to all ImageKit Controls.

[Visual Basic] Public Property SettingsForEachImageKit As Boolean
[C#] public bool SettingsForEachImageKit {get; set;}

Property Value

Value | Explanation
True (default) | ToolBarSetupLines control settings apply only to the ImageKit control specified by the TargetImageKit property.
False | ToolBarSetupLines control settings apply to all the ImageKit controls regardless of the target specified by the TargetImageKit property.

Explanation

The SettingsForEachImageKit property determines if the ToolBarSetupLines control's settings apply to each ImageKit control according to the TargetImageKit property value, or if the ToolBarSetupLines control's settings apply to all ImageKit controls.

When one ToolBarSetupLines control is set to apply to multiple ImageKit controls, it is possible for that single ToolBarSetupLines control to maintain different settings according to which ImageKit control it targets. When the SettingsForEachImageKit property is True, the ToolBarSetupLines control settings apply only to the target ImageKit as determined by the TargetImageKit property. When the TargetImageKit property changes, the ToolBarSetupLines settings also change.

If the SettingsForEachImageKit property is False, the ToolBarSetupLines control settings apply to all ImageKit controls regardless of the TargetImageKit property value.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


TargetImageKit property

Newtone.ImageKit.Win.ToolBarSetupLines.TargetImageKit Property

This property sets which ImageKit control is targeted by the ToolBarSetupLines control.

[Visual Basic] Public Property TargetImageKit As ImageKit
[C#] public ImageKit TargetImageKit {get; set;}

Property Value

An ImageKit control

Default value is null (Nothing)

Explanation

The TargetImageKit property sets the correspondence between the ToolBarSetupLines control and the ImageKit control(s). This property determines which ImageKit control is targeted by the ToolBarSetupLines control.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


TextBoxEndArrowCapSize Property

Newtone.ImageKit.Win.ToolBarSetupLines.TextBoxEndArrowCapSize Property

This property sets or retrieves the ToolStripTextBox control displaying the "EndArrowCapSize" item on the ToolBarSetupLines control.

[Visual Basic]Public Property TextBoxEndArrowCapSize As System.Windows.Forms.ToolStripTextBox
[C#]public System.Windows.Forms.ToolStripTextBox TextBoxEndArrowCapSize {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripTextBox

Explanation

The TextBoxEndArrowCapSize property sets or retrieves the ToolStripTextBox control displaying the "EndArrowCapSize" item on the ToolBarSetupLines control.

Because the "EndArrowCapSize" textbox is a ToolStripTextBox control, you can use the TextBoxEndArrowCapSize property to change the "EndArrowCapSize" settings, generate events, etc.

For coding examples, please refer to the TextBoxStartArrowCap property explanation.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


TextBoxStartArrowCapSize Property

Newtone.ImageKit.Win.ToolBarSetupLines.TextBoxStartArrowCapSize Property

This property sets or retrieves the ToolStripTextBox control displaying the "StartArrowCapSize" item on the ToolBarSetupLines control.

[Visual Basic]Public Property TextBoxStartArrowCapSize As System.Windows.Forms.ToolStripTextBox
[C#]public System.Windows.Forms.ToolStripTextBox TextBoxStartArrowCapSize {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripTextBox

Explanation

The TextBoxStartArrowCapSize property sets or retrieves the ToolStripTextBox control displaying the "StartArrowCapSize" item on the ToolBarSetupLines control.

Because the "StartArrowCapSize" textbox is a ToolStripTextBox control, you can use the TextBoxStartArrowCapSize property to change the "StartArrowCapSize" settings, generate events, etc.

Please refer to the coding examples below.

Examples

(1) To change the background color displayed in the "StartArrowCapSize" textbox:

[Visual Basic.NET]
ToolBarSetupLines1.TextBoxStartArrowCapSize.BackColor = Color.FromArgb(255, 255, 192)

[Visual C#.NET]
toolBarSetUpLines1.TextBoxStartArrowCapSize.BackColor=Color.FromArgb(255, 255, 192);

(2) Access the "StartArrowCapSize " textbox's Click event.

[Visual Basic.NET]
'In the FormLoad event, set the TextBoxStartArrowCapSize click event delegate
AddHandler ToolBarSetupLines1.TextBoxStartArrowCapSize.Click, AddressOf TextBoxStartArrowCapSize_Click

'event handler delegate
Private Sub TextBoxStartArrowCapSize_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
'Write code here that you want to execute when the event fires
End Sub

[Visual C#.NET]
//In the FormLoad event, set the TextBoxStartArrowCapSize click event delegate
toolBarSetUpLines1.TextBoxStartArrowCapSize.Click += new EventHandler(TextBoxStartArrowCapSize_Click);

//event handler delegate
private void TextBoxStartArrowCapSize_Click(object sender, EventArgs e)
{
//Write code here that you want to execute when the event fires
}

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


TargetImageKitChanged event

Newtone.ImageKit.Win.ToolBarSetupLines.TargetImageKitChanged Event

This event is generated whenever the TargetImageKit property changes.

[Visual Basic] Public Event TargetImageKitChanged As EventHandler
[C#] public event EventHandler TargetImageKitChanged;

Event Data

This event handler accepts parmeters of type EventArgs

Explanation

The TargetImageKitChanged event is generated whenever the TargetImageKit property changes.

When one ToolBar control is used with multiple ImageKit controls and the focus changes from one ImageKit control to another (i.e. the TargetImageKit property changes), you can use this event to retrieve which ImageKit control has focus.

See Also

ToolBarSetupLines Members | Newtone.ImageKit.Win.ToolBarSetupLines


ImageKitWinToolBarSetUpObjects Class

Newtone.ImageKit.Win.ToolBarSetUpObjects Class

The main class for the WinForm ToolBarSetUpObjects Control.

For a list of all members of this class, see ToolBarSetUpObjects Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Newtone.ImageKit.Win

public class ToolBarSetUpObjects : System.Windows.Forms.Control

Explanation

The ToolBarSetUpObjects control is a toolbar that holds buttons and other items related to annotation objects other than lines. Annotation objects that use these functions are the Rectangle, RoundRectangle, Ellipse, Image, Text, and Stamp objects. The ToolBarSetupObjects control gives you an easy, user friendly way of accessing and setting properties related to these objects.

The ToolBarSetupObjects control lools like this:

The ToolBarAnnotation control contains the following items:

Items Related to the Rectangle, RoundRectangle, Ellipse, and Image Objects

Item |  | Explanation
AspectRatio | AspectRatio Button | This button sets the ImageKit.Edit.AspectRatio property for the Rectangle, RoundRectangle, Ellipse, and Image objects.
RoundRectangleRadius | RoundRectangleRadius Textbox and Buttons | These items set the ImageKit Control's ImageKit.Edit.RoundRectangleRadius property

Items Related to the Text and Stamp Objects

Item |  | Explanation
Font | Font Button | This button displays the font dialog and sets the following font related ImageKit Control properties: ImageKit.Edit.FontBold, ImageKit.Edit.FontItalic, ImageKit.Edit.FontName, ImageKit.Edit.FontSize, ImageKit.Edit.FontStrikeout, ImageKit.Edit.FontUnderline.
WordWrap | WordWrap Button | This button sets the ImageKit.Edit.WordWrap property.
VerticalText | VerticalText Button | This button sets the ImageKit.Edit.VerticalText property.
RightToLeft | RightToLeft Button | This button sets the ImageKit.Edit.RightToLeft property.
Border | Border Button | This button sets the ImageKit.Edit.Border property.
BorderColor | BorderColor Button | This button sets the ImageKit.Edit.BorderColor property.
BorderColorOpacity | BorderColorOpacity Textbox and Buttons | These items set the ImageKit.Edit.BorderColorOpacity
BorderShape | BorderShape Combobox | This combobox sets the ImageKit.Edit.BorderShape property for the Stamp object.
TextAlign | TextAlign | This combobox sets the ImageKit.Edit.TextAlign property for the Stamp object.

Requirement

Namespace: Newtone.ImageKit.Win

Assembly: Newtone.ImageKit.NETX.ImageKit.dll

See Also

ToolBarSetUpObjects Members


ToolBarSetUpObjects Members

Newtone.ImageKit.Win.ToolBarSetUpObjects Members

ToolBarSetUpObjects Overview

Public Constructor

ToolBarSetUpObjects Constructor Creates a new instance of the ToolBarSetUpObjects class

Public Properties

BaseImageKitAspectRatio | Sets or retrieves the value of the Edit.AspectRatio property of the ImageKit control.
BaseImageKitBorder | Sets or retrieves the value of the Edit.Border property of the ImageKit control.
BaseImageKitBorderColor | Sets or retrieves the value of the Edit.BorderColor property of the ImageKit control.
BaseImageKitBorderColorOpacity | Sets or retrieves the value of the Edit.BorderColorOpacity property of the ImageKit control.
BaseImageKitBorderShape | Sets or retrieves the value of the Edit.BorderShape property of the ImageKit control.
BaseImageKitFontBold | Sets or retrieves the value of the Edit.FontBold property of the ImageKit control.
BaseImageKitFontItalic | Sets or retrieves the value of the Edit.FontItalic property of the ImageKit control.
BaseImageKitFontName | Sets or retrieves the value of the Edit.FontName property of the ImageKit control.
BaseImageKitFontSize | Sets or retrieves the value of the Edit.FontSize property of the ImageKit control.
BaseImageKitFontStrikeout | Sets or retrieves the value of the Edit.FontStrikeout property of the ImageKit control.
BaseImageKitFontUnderline | Sets or retrieves the value of the Edit.FontUnderline property of the ImageKit control.
BaseImageKitRightToLeft | Sets or retrieves the value of the Edit.RightToLeft property of the ImageKit control.
BaseImageKitRoundRectangleRadius | Sets or retrieves the value of the Edit.RoundRectangleRadius property of the ImageKit control.
BaseImageKitTextAlign | Sets or retrieves the value of the Edit.TextAlign property of the ImageKit control.
BaseImageKitVerticalText | Sets or retrieves the value of the Edit.VerticalText property of the ImageKit control.
BaseImageKitWordWrap | Sets or retrieves the value of the Edit.WordWrap property of the ImageKit control.
BoxBorderColorOpacityVisible | Sets whether or not the items related to BorderColorOpacity are displayed on the ToolBarSetupObjects control
BoxBorderShapeVisible | Sets whether or not the items related to BorderShape are displayed on the ToolBarSetupObjects control
BoxRoundRectangleRadiusVisible | Sets whether or not the items related to RoundRectangleRadius are displayed on the ToolBarSetupObjects control
BoxTextAlignVisible | sets whether or not the items related to "text alignment" are displayed on the ToolBarSetupObjects control
ButtonAspectRatio | Sets or retrieves the ToolStripButton control displaying the "Aspect Ratio" item on the ToolBarSetupObjects control
ButtonAspectRatioVisible | Sets whether or not the "Aspect Ratio" button is displayed on the ToolBarSetupObjects control
ButtonBorder | Sets or retrieves the ToolStripButton control displaying the "Border" item on the ToolBarSetupObjects control
ButtonBorderColor | Sets or retrieves the ToolStripButton control displaying the "BorderColor" item on the ToolBarSetupObjects control
ButtonBorderColorOpacityDown | Sets or retrieves the ToolStripButton control displaying the "BorderColorOpacityDown" item on the ToolBarSetupObjects control
ButtonBorderColorOpacityUp | Sets or retrieves the ToolStripButton control displaying the "BorderColorOpacityUp" item on the ToolBarSetupObjects control
ButtonBorderColorVisible | Sets whether or not the "BorderColor" button is displayed on the ToolBarSetupObjects control
ButtonBorderVisible | Sets whether or not the "Border" button is displayed on the ToolBarSetupObjects control
ButtonFont | Sets or retrieves the ToolStripButton control displaying the "Font" item on the ToolBarSetupObjects control
ButtonFontVisible | Sets whether or not the "Font" button is displayed on the ToolBarSetupObjects control
ButtonRightToLeft | Sets or retrieves the ToolStripButton control displaying the "RightToLeft" item on the ToolBarSetupObjects control
ButtonRightToLeftVisible | Sets whether or not the "RightToLeft" button is displayed on the ToolBarSetupObjects control
ButtonRoundRectangleRadiusDown | Sets or retrieves the ToolStripButton control displaying the "RoundRectangleRadiusDown" item on the ToolBarSetupObjects control
ButtonRoundRectangleRadiusUp | Sets or retrieves the ToolStripButton control displaying the "RoundRectangleRadiusUp" item on the ToolBarSetupObjects control
ButtonSize | Sets the size of the buttons displayed on the ToolBarSetupObjects control
ButtonVerticalText | Sets or retrieves the ToolStripButton control displaying the "VerticalText" item on the ToolBarSetupObjects control
ButtonVerticalTextVisible | Sets whether or not the "VerticalText" button is displayed on the ToolBarSetupObjects control
ButtonWordWrap | Sets or retrieves the ToolStripButton control displaying the "WordWrap" item on the ToolBarSetupObjects control
ButtonWordWrapVisible | Sets whether or not the "WordWrap" button is displayed on the ToolBarSetupObjects control
ComboBoxBorderShape | Sets or retrieves the ToolStripComboBox control displaying the "BorderShape" item of the ToolBarSetupObjects control
ComboBoxTextAlign | Sets or retrieves the ToolStripComboBox control displaying the "Text Alignment" items of the ToolBarSetupObjects control
GroupTextVisible | Sets whether or not the group of "Text" related comboboxes, buttons, and labels is displayed
LabelBorderColorOpacity | Sets or retrieves the ToolStripLabel control displaying the "BorderColorOpacity" label on the ToolBarSetupObjects control
LabelBorderColorOpacityUnit | Sets or retrieves the ToolStripLabel control displaying the "BorderColorOpacityUnit" label on the ToolBarSetupObjects control
LabelBorderShape | Sets or retrieves the ToolStripLabel control displaying the "BorderShape" label on the ToolBarSetupObjects control
LabelRoundRectangleRadius | Sets or retrieves the ToolStripLabel control displaying the "RoundRectangleRadius" label on the ToolBarSetupObjects control
LabelRoundRectangleRadiusUnit | Sets or retrieves the ToolStripLabel control displaying the "RoundRectangleRadiusUnit" label on the ToolBarSetupObjects control
LabelTextAlign | Sets or retrieves the ToolStripLabel control displaying the "TextAlign" label on the ToolBarSetupObjects control
MaxRoundRectangleRadius | Sets the maximum value for the "RoundRectangleRadius".
Separator1Visible | Sets whether or not Separator1 is displayed in the ToolBarSetupObjects control
Separator2Visible | Sets whether or not Separator2 is displayed in the ToolBarSetupObjects control
Separator3Visible | Sets whether or not Separator3 is displayed in the ToolBarSetupObjects control
Separator4Visible | Sets whether or not Separator4 is displayed in the ToolBarSetupObjects control
SettingsForEachImageKit | Determines if the ToolBarSetupObjects control's settings apply to each ImageKit Control according to the TargetImageKit property value, or if the ToolBarSetupObjects control's settings apply to all ImageKit Controls
TargetImageKit | Sets which ImageKit control is targeted by the ToolBarSetupObjects control
TextBoxBorderColorOpacity | Sets or retrieves the ToolStripTextBox control displaying the "BorderColorOpacity" item on the ToolBarSetupObjects control
TextBoxRoundRectangleRadius | Sets or retrieves the ToolStripTextBox control displaying the "RoundRectangleRadius" textbox on the ToolBarSetupObjects control

Public Events

TargetImageKitChanged Generated whenever the TargetImageKit property changes

See Also

Newtone.ImageKit.Win.ToolBarSetUpObjects


ImageKit.Win.ToolBarSetUpObjects Constructor

Newtone.ImageKit.Win.ToolBarSetUpObjects Constructor

This constructor creates a new instance of the ToolBarSetUpObjects class.

[Visual Basic] Public Sub New()
[C#] public public ToolBarSetUpObjects()

See Also

ToolBarSetUpObjects Members | Newtone.ImageKit.Win.ToolBarSetUpObjects


BaseImageKitAspectRatio property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitAspectRatio Property

This property sets or retrieves the value of the Edit.AspectRatio property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitAspectRatio As Boolean
[C#]public bool BaseImageKitAspectRatio {get; set;}

Property Value

True: Original image aspect ratio maintained
False: Original image aspect ratio NOT maintained
Default value is False.

Explanation

The BaseImageKitAspectRatio property sets or retrieves the Edit.AspectRatio property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitAspectRatio property to set the Edit.AspectRatio property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitBorder property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitBorder Property

This property sets or retrieves the value of the Edit.Border property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitBorder As Boolean
[C#]public bool BaseImageKitBorder {get; set;}

Property Value

True: Border is added
False: Border is not added
Default value is False.

Explanation

The BaseImageKitBorder property sets or retrieves the Edit.Border property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitBorder property to set the Edit.Border property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitBorderColor property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitBorderColor Property

This property sets or retrieves the value of the Edit.BorderColor property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitBorderColor As Color
[C#]public Color BaseImageKitBorderColor {get; set;}

Property Value

A value of type Color
Default value is white.

Explanation

The BaseImageKitBorderColor property sets or retrieves the Edit.BorderColor property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitBorderColor property to set the Edit.BorderColor property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitBorderColorOpacity property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitBorderColorOpacity Property

This property sets or retrieves the value of the Edit.BorderColorOpacity property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitBorderColorOpacity As Integer
[C#]public int BaseImageKitBorderColorOpacity {get; set;}

Property Value

An integer representing the level of opacity
Default value is 100.

Explanation

The BaseImageKitBorderColorOpacity property sets or retrieves the Edit.BorderColorOpacity property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitBorderColorOpacity property to set the Edit.BorderColorOpacity property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitBorderShape property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitBorderShape Property

This property sets or retrieves the value of the Edit.BorderShape property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitBorderShape As Shape
[C#]public Shape BaseImageKitBorderShape {get; set;}

Property Value

A value of type Shape
Default value is Shape.RoundRectangle

Explanation

The BaseImageKitBorderShape property sets or retrieves the Edit.BorderShape property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitBorderShape property to set the Edit.BorderShape property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitFontBold property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitFontBold Property

This property sets or retrieves the value of the Edit.FontBold property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitFontBold As Boolean
[C#]public bool BaseImageKitFontBold {get; set;}

Property Value

True: Bold font is used
False: Bold font is NOT used
Default value is False.

Explanation

The BaseImageKitFontBold property sets or retrieves the Edit.FontBold property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitFontBold property to set the Edit.FontBold property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitFontItalic property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitFontItalic Property

This property sets or retrieves the value of the Edit.FontItalic property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitFontItalic As Boolean
[C#]public bool BaseImageKitFontItalic {get; set;}

Property Value

True: Italic font is used
False: Italic font is NOT used
Default value is False.

Explanation

The BaseImageKitFontItalic property sets or retrieves the Edit.FontItalic property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitFontItalic property to set the Edit.FontItalic property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitFontName property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitFontName Property

This property sets or retrieves the value of the Edit.FontName property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitFontName As String
[C#]public string BaseImageKitFontName {get; set;}

Property Value

The FontName as type String
Default value is "Arial".

Explanation

The BaseImageKitFontName property sets or retrieves the Edit.FontName property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitFontName property to set the Edit.FontName property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitFontSize property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitFontSize Property

This property sets or retrieves the value of the Edit.FontSize property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitFontSize As Single
[C#]public float BaseImageKitFontSize {get; set;}

Property Value

A value representing the font size
Default value is 16.0

Explanation

The BaseImageKitFontSize property sets or retrieves the Edit.FontSize property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitFontSize property to set the Edit.FontSize property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitFontStrikeout property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitFontStrikeout Property

This property sets or retrieves the value of the Edit.FontStrikeout property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitFontStrikeout As Boolean
[C#]public bool BaseImageKitFontStrikeout {get; set;}

Property Value

True: Strikeout font is used
False: Strikeout font is NOT used
Default value is False.

Explanation

The BaseImageKitFontStrikeout property sets or retrieves the Edit.FontStrikeout property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitFontStrikeout property to set the Edit.FontStrikeout property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitFontUnderline property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitFontUnderline Property

This property sets or retrieves the value of the Edit.FontUnderline property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitFontUnderline As Boolean
[C#]public bool BaseImageKitFontUnderline {get; set;}

Property Value

True: Underline font is used
False: Underline font is NOT used
Default value is False.

Explanation

The BaseImageKitFontUnderline property sets or retrieves the Edit.FontUnderline property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitFontUnderline property to set the Edit.FontUnderline property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitRightToLeft property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitRightToLeft Property

This property sets or retrieves the value of the Edit.RightToLeft property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitRightToLeft As Boolean
[C#]public bool BaseImageKitRightToLeft {get; set;}

Property Value

True: Text is drawn right to left
False: Text is drawn left to right
Default value is False.

Explanation

The BaseImageKitRightToLeft property sets or retrieves the Edit.RightToLeft property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitRightToLeft property to set the Edit.RightToLeft property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitRoundRectangleRadius property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitRoundRectangleRadius Property

This property sets or retrieves the value of the Edit.RoundRectangleRadius property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitRoundRectangleRadius As Integer
[C#]public int BaseImageKitRoundRectangleRadius {get; set;}

Property Value

A value representing the radius of the rounded rectangle
Default value is 10

Explanation

The BaseImageKitRoundRectangleRadius property sets or retrieves the Edit.RoundRectangleRadius property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitRoundRectangleRadius property to set the Edit.RoundRectangleRadius property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitTextAlign property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitTextAlign Property

This property sets or retrieves the value of the Edit.TextAlign property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitTextAlign As Align
[C#]public Shape BaseImageKitTextAlign {get; set;}

Property Value

A value of type Align
Default value is Align.Center

Explanation

The BaseImageKitTextAlign property sets or retrieves the Edit.TextAlign property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitTextAlign property to set the Edit.TextAlign property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitVerticalText property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitVerticalText Property

This property sets or retrieves the value of the Edit.VerticalText property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitVerticalText As Boolean
[C#]public bool BaseImageKitVerticalText {get; set;}

Property Value

True: Text is drawn vertically
False: Text is drawn horizontally
Default value is False.

Explanation

The BaseImageKitVerticalText property sets or retrieves the Edit.VerticalText property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitVerticalText property to set the Edit.VerticalText property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BaseImageKitWordWrap property

Newtone.ImageKit.Win.ToolBarSetupObjects.BaseImageKitWordWrap Property

This property sets or retrieves the value of the Edit.WordWrap property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitWordWrap As Boolean
[C#]public bool BaseImageKitWordWrap {get; set;}

Property Value

True: Text is wrapped within the drawing space
False: Text is not wrapped. Enter key starts a new line
Default value is False.

Explanation

The BaseImageKitWordWrap property sets or retrieves the Edit.WordWrap property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitWordWrap property to set the Edit.WordWrap property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BoxBorderColorOpacityVisible property

Newtone.ImageKit.Win.ToolBarSetupObjects.BoxBorderColorOpacityVisible Property

This property sets whether or not the items related to BorderColorOpacity are displayed on the ToolBarSetupObjects control.

[Visual Basic]Public Property BoxBorderColorOpacityVisible As Boolean
[C#]public bool BoxBorderColorOpacityVisible {get; set;}

Property Value

True: The BorderColorOpacity items are displayed
False: The BorderColorOpacity items are NOT displayed

Default value is True.

Explanation

The BoxBorderColorOpacityVisible property sets whether or not the items related to BorderColorOpacity are displayed on the ToolBarSetupObjects control. When this property is False, the BorderColorOpacity textbox, buttons, and label are not displayed.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BoxBorderShapeVisible property

Newtone.ImageKit.Win.ToolBarSetupObjects.BoxBorderShapeVisible Property

This property sets whether or not the items related to BorderShape are displayed on the ToolBarSetupObjects control.

[Visual Basic]Public Property BoxBorderShapeVisible As Boolean
[C#]public bool BoxBorderShapeVisible {get; set;}

Property Value

True: The BorderShape items are displayed
False: The BorderShape items are NOT displayed

Default value is True.

Explanation

The BoxBorderShapeVisible property sets whether or not the items related to BorderShape are displayed on the ToolBarSetupObjects control. When this property is False, the BorderShape combobox and label are not displayed.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BoxRoundRectangleRadiusVisible property

Newtone.ImageKit.Win.ToolBarSetupObjects.BoxRoundRectangleRadiusVisible Property

This property sets whether or not the items related to RoundRectangleRadius are displayed on the ToolBarSetupObjects control.

[Visual Basic]Public Property BoxRoundRectangleRadiusVisible As Boolean
[C#]public bool BoxRoundRectangleRadiusVisible {get; set;}

Property Value

True: The RoundRectangleRadius items are displayed
False: The RoundRectangleRadius items are NOT displayed

Default value is True.

Explanation

The BoxRoundRectangleRadiusVisible property sets whether or not the items related to RoundRectangleRadius are displayed on the ToolBarSetupObjects control. When this property is False, the RoundRectangleRadius textbox, buttons, and labels are not displayed.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


BoxTextAlignVisible property

Newtone.ImageKit.Win.ToolBarSetupObjects.BoxTextAlignVisible Property

This property sets whether or not the items related to "text alignment" are displayed on the ToolBarSetupObjects control.

[Visual Basic]Public Property BoxTextAlignVisible As Boolean
[C#]public bool BoxTextAlignVisible {get; set;}

Property Value

True: The "text alignment" items are displayed
False: The "text alignment" items are NOT displayed

Default value is True.

Explanation

The BoxTextAlignVisible property sets whether or not the items related to "text alignment" are displayed on the ToolBarSetupObjects control. When this property is False, the "text alignment" combobox and label are not displayed.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonAspectRatio property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonAspectRatio Property

This property sets or retrieves the ToolStripButton control displaying the "Aspect Ratio" item on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonAspectRatio As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonAspectRatio {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonAspectRatio property sets or retrieves the ToolStripButton control displaying the "Aspect Ratio" item on the ToolBarSetupObjects control.

Because the "Aspect Ratio" button is a ToolStripButton control, you can use the ButtonAspectRatio property to change the "Aspect Ratio" button settings, generate events, etc.

Please refer to the coding examples below.

Examples

(1) To change the image displayed in the "Aspect Ratio" button

[Visual Basic.NET]
ToolBarSetupObjects1.ButtonAspectRatio.Image = Image.FromFile("c:\images\button_img1.bmp")

[Visual C#.NET]
toolBarSetUpObjects1.ButtonAspectRatio.Image = Image.FromFile("c:\\images\\button_img1.bmp");

(2) Access the "BorderColorOpacityUp" button's Click event.

* Use the ToolbarSetupObjects control's ItemClicked event to determine if the button that was clicked was the target button

[Visual Basic.NET]
Private Sub ToolBarSetupObjects1_ItemClicked(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolStripItemClickedEventArgs) Handles ToolBarSetupObjects1.ItemClicked
If e.ClickedItem Is ToolBarSetupObjects1.ButtonBorderColorOpacityUp Then 'The button that was clicked is the "ButtonStartArrowCapSizeUp" button
'Write code here that you want to execute when the event fires
End If
End Sub

[Visual C#.NET]
private void toolBarSetUpObjects1_ItemClicked(object sender, ToolStripItemClickedEventArgs e)
{
if (e.ClickedItem == toolBarSetUpObjects1.ButtonBorderColorOpacityUp)//The button that was clicked is the "ButtonBorderColorOpacityUp" button
{
//Write code here that you want to execute when the event fires
}
}

(3) Access the "ButtonBorderColorOpacityUp" button's MouseUp event.

[Visual Basic.NET]
'In the FormLoad event, set the ButtonBorderColorOpacityUp delegate
AddHandler ToolBarSetupObjects1.ButtonBorderColorOpacityUp.MouseUp,
                AddressOf ButtonBorderColorOpacityUp_MouseUp

'event handler delegate
Private Sub ButtonBorderColorOpacityUp_MouseUp(ByVal sender As
                System.Object, ByVal e As System.EventArgs)
'Write code here that you want to execute when the event fires
End Sub

[Visual C#.NET]
//In the FormLoad event, set the ButtonBorderColorOpacityUp delegate
toolBarSetUpObjects1.ButtonBorderColorOpacityUp.MouseUp += new
                MouseEventHandler(ButtonBorderColorOpacityUp_MouseUp);

//event handler delegate
private void ButtonBorderColorOpacityUp_MouseUp(object sender, EventArgs e)
{
//Write code here that you want to execute when the event fires
}

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonAspectRatioVisible property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonAspectRatioVisible Property

This property sets whether or not the "Aspect Ratio" button is displayed on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonAspectRatioVisible As Boolean
[C#]public bool ButtonAspectRatioVisible {get; set;}

Property Value

True: The "Aspect Ratio" button is displayed
False: The "Aspect Ratio" button is NOT displayed

Default value is True.

Explanation

The ButtonAspectRatioVisible property sets whether or not the "Aspect Ratio" button is displayed on the ToolBarSetupObjects control. When this property is False, the "Aspect Ratio" button is not displayed.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonBorder property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonBorder Property

This property sets or retrieves the ToolStripButton control displaying the "Border" item on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonBorder As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonBorder {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonBorder property sets or retrieves the ToolStripButton control displaying the "Border" item on the ToolBarSetupObjects control.

Because the "Border" button is a ToolStripButton control, you can use the ButtonBorder property to change the "Border" button settings, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonBorderColor property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonBorderColor Property

This property sets or retrieves the ToolStripButton control displaying the "BorderColor" item on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonBorderColor As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonBorderColor {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonBorderColor property sets or retrieves the ToolStripButton control displaying the "BorderColor" item on the ToolBarSetupObjects control.

Because the "BorderColor" item is a ToolStripButton control, you can use the ButtonBorderColor property to change the "BorderColor" item settings, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonBorderColorOpacityDown property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonBorderColorOpacityDown Property

This property sets or retrieves the ToolStripButton control displaying the "BorderColorOpacityDown" item on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonBorderColorOpacityDown As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonBorderColorOpacityDown {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonBorderColorOpacityDown property sets or retrieves the ToolStripButton control displaying the "BorderColorOpacityDown" item on the ToolBarSetupObjects control.

Because the "BorderColorOpacityDown" item is a ToolStripButton control, you can use the ButtonBorderColorOpacityDown property to change the "BorderColorOpacityDown" item settings, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonBorderColorOpacityUp property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonBorderColorOpacityUp Property

This property sets or retrieves the ToolStripButton control displaying the "BorderColorOpacityUp" item on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonBorderColorOpacityUp As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonBorderColorOpacityUp {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonBorderColorOpacityUp property sets or retrieves the ToolStripButton control displaying the "BorderColorOpacityUp" item on the ToolBarSetupObjects control.

Because the "BorderColorOpacityUp" item is a ToolStripButton control, you can use the ButtonBorderColorOpacityUp property to change the "BorderColorOpacityUp" item settings, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonBorderColorVisible property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonBorderColorVisible Property

This property sets whether or not the "BorderColor" button is displayed on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonBorderColorVisible As Boolean
[C#]public bool ButtonBorderColorVisible {get; set;}

Property Value

True: The "BorderColor" button is displayed
False: The "BorderColor" button is NOT displayed

Default value is True.

Explanation

The ButtonBorderColorVisible property sets whether or not the "BorderColor" button is displayed on the ToolBarSetupObjects control. When this property is False, the "BorderColor" button is not displayed.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonBorderVisible property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonBorderVisible Property

This property sets whether or not the "Border" button is displayed on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonBorderVisible As Boolean
[C#]public bool ButtonBorderVisible {get; set;}

Property Value

True: The "Border" button is displayed
False: The "Border" button is NOT displayed

Default value is True.

Explanation

The ButtonBorderVisible property sets whether or not the "Border" button is displayed on the ToolBarSetupObjects control. When this property is False, the "Border" button is not displayed.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonFont property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonFont Property

This property sets or retrieves the ToolStripButton control displaying the "Font" item on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonFont As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonFont {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonFont property sets or retrieves the ToolStripButton control displaying the "Font" item on the ToolBarSetupObjects control.

Because the "Font" button is a ToolStripButton control, you can use the ButtonFont property to change the "Font" button settings, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonFontVisible property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonFontVisible Property

This property sets whether or not the "Font" button is displayed on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonFontVisible As Boolean
[C#]public bool ButtonFontVisible {get; set;}

Property Value

True: The "Font" button is displayed
False: The "Font" button is NOT displayed

Default value is True.

Explanation

The ButtonFontVisible property sets whether or not the "Font" button is displayed on the ToolBarSetupObjects control. When this property is False, the "Font" button is not displayed.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonRightToLeft property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonFont Property

This property sets or retrieves the ToolStripButton control displaying the "RightToLeft" item on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonRightToLeft As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonRightToLeft {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonRightToLeft property sets or retrieves the ToolStripButton control displaying the "RightToLeft" item on the ToolBarSetupObjects control.

Because the "RightToLeft" button is a ToolStripButton control, you can use the ButtonRightToLeft property to change the "RightToLeft" button settings, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonRightToLeftVisible property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonRightToLeftVisible Property

This property sets whether or not the "RightToLeft" button is displayed on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonRightToLeftVisible As Boolean
[C#]public bool ButtonRightToLeftVisible {get; set;}

Property Value

True: The "RightToLeft" button is displayed
False: The "RightToLeft" button is NOT displayed

Default value is True.

Explanation

The ButtonRightToLeftVisible property sets whether or not the "RightToLeft" button is displayed on the ToolBarSetupObjects control. When this property is False, the "RightToLeft" button is not displayed.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonRoundRectangleRadiusDown property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonRoundRectangleRadiusDown Property

This property sets or retrieves the ToolStripButton control displaying the "RoundRectangleRadiusDown" item on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonRoundRectangleRadiusDown As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonRoundRectangleRadiusDown {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonRoundRectangleRadiusDown property sets or retrieves the ToolStripButton control displaying the "RoundRectangleRadiusDown" item on the ToolBarSetupObjects control.

Because the "RoundRectangleRadiusDown" button is a ToolStripButton control, you can use the ButtonRoundRectangleRadiusDown property to change the "RoundRectangleRadiusDown" button settings, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonRoundRectangleRadiusUp property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonRoundRectangleRadiusUp Property

This property sets or retrieves the ToolStripButton control displaying the "RoundRectangleRadiusUp" item on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonRoundRectangleRadiusUp As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonRoundRectangleRadiusUp {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonRoundRectangleRadiusUp property sets or retrieves the ToolStripButton control displaying the "RoundRectangleRadiusUp" item on the ToolBarSetupObjects control.

Because the "RoundRectangleRadiusUp" button is a ToolStripButton control, you can use the ButtonRoundRectangleRadiusUp property to change the "RoundRectangleRadiusUp" button settings, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonSize property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonSize Property

This property sets the size of the buttons displayed on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonSize As ToolBarButtonSize
[C#]public ToolBarButtonSize ButtonSize {get; set;}

Property Value

A value of type ToolBarButtonSize

Default value is ToolBarButtonSize.Small

Explanation

The ButtonSize property sets the size of the buttons displayed on the ToolBarSetupObjects control. Depending on the value set in this property, the size of the ToolBar may change.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonVerticalText property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonVerticalText Property

This property sets or retrieves the ToolStripButton control displaying the "VerticalText" item on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonVerticalText As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonVerticalText {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonVerticalText property sets or retrieves the ToolStripButton control displaying the "VerticalText" item on the ToolBarSetupObjects control.

Because the "VerticalText" button is a ToolStripButton control, you can use the ButtonVerticalText property to change the "VerticalText" button settings, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonVerticalTextVisible property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonVerticalTextVisible Property

This property sets whether or not the "VerticalText" button is displayed on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonVerticalTextVisible As Boolean
[C#]public bool ButtonVerticalTextVisible {get; set;}

Property Value

True: The "VerticalText" button is displayed
False: The "VerticalText" button is NOT displayed

Default value is True.

Explanation

The ButtonVerticalTextVisible property sets whether or not the "VerticalText" button is displayed on the ToolBarSetupObjects control. When this property is False, the "VerticalText" button is not displayed.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonWordWrap property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonWordWrap Property

This property sets or retrieves the ToolStripButton control displaying the "WordWrap" item on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonWordWrap As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonWordWrap {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonWordWrap property sets or retrieves the ToolStripButton control displaying the "WordWrap" item on the ToolBarSetupObjects control.

Because the "WordWrap" button is a ToolStripButton control, you can use the ButtonWordWrap property to change the "WordWrap" button settings, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ButtonWordWrapVisible property

Newtone.ImageKit.Win.ToolBarSetupObjects.ButtonWordWrapVisible Property

This property sets whether or not the "WordWrap" button is displayed on the ToolBarSetupObjects control.

[Visual Basic]Public Property ButtonWordWrapVisible As Boolean
[C#]public bool ButtonWordWrapVisible {get; set;}

Property Value

True: The "WordWrap" button is displayed
False: The "WordWrap" button is NOT displayed

Default value is True.

Explanation

The ButtonWordWrapVisible property sets whether or not the "WordWrap" button is displayed on the ToolBarSetupObjects control. When this property is False, the "WordWrap" button is not displayed.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ComboBoxBorderShape Property

Newtone.ImageKit.Win.ToolBarSetupObjects.ComboBoxBorderShape Property

This property sets or retrieves the ToolStripComboBox control displaying the "BorderShape" item of the ToolBarSetupObjects control.

[Visual Basic]Public Property ComboBoxBorderShape As System.Windows.Forms.ToolStripComboBox
[C#]public System.Windows.Forms.ToolStripComboBox ComboBoxBorderShape {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripComboBox

Explanation

The ComboBoxBorderShape property sets or retrieves the ToolStripComboBox control displaying the "BorderShape" item of the ToolBarSetupObjects control.

Because the "BorderShape" combobox is a ToolStripComboBox control, you can use the ComboBoxBorderShape property to change the "BorderShape" combobox settings, generate events, etc.

Please refer to the examples below.

Examples

(1) To change the background color displayed in the "BorderShape" combobox

[Visual Basic.NET]
ToolBarSetupObjects1.ComboBoxBorderShape.BackColor = Color.FromArgb(255,
                255, 192)

[Visual C#.NET]
toolBarSetUpObjects1.ComboBoxBorderShape.BackColor=Color.FromArgb(255,
                255, 192);

(2) Access the "BorderShape" combobox's SelectedIndexChanged event.

[Visual Basic.NET]
'In the FormLoad event, set the ComboBoxBorderShape's SelectedIndexChanged event handler
AddHandler ToolBarSetupObjects1.ComboBoxBorderShape.SelectedIndexChanged, AddressOf ComboBoxBorderShape_SelectedIndexChanged

'event
Private Sub ComboBoxBorderShape_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs)
'Write code here that you want to execute when the event fires
End Sub

[Visual C#.NET]
//In the FormLoad event, set the ComboBoxBorderShape's SelectedIndexChanged event handler
toolBarSetUpObjects1.ComboBoxBorderShape.SelectedIndexChanged += new EventHandler(ComboBoxBorderShape_SelectedIndexChanged);

//event
private void ComboBoxBorderShape_SelectedIndexChanged(object sender, EventArgs e)
{
//Write code here that you want to execute when the event fires
}

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ComboBoxTextAlign Property

Newtone.ImageKit.Win.ToolBarSetupObjects.ComboBoxTextAlign Property

This property sets or retrieves the ToolStripComboBox control displaying the "Text Alignment" items of the ToolBarSetupObjects control.

[Visual Basic]Public Property ComboBoxTextAlign As System.Windows.Forms.ToolStripComboBox
[C#]public System.Windows.Forms.ToolStripComboBox ComboBoxTextAlign {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripComboBox

Explanation

The ComboBoxTextAlign property sets or retrieves the ToolStripComboBox control displaying the "Text Alignment" items of the ToolBarSetupObjects control.

Because the "Text Alignment" combobox is a ToolStripComboBox control, you can use the ComboBoxTextAlign property to change the "Text Alignment" combobox settings, generate events, etc.

For coding examples, please refer to the ComboBoxBorderShape property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


GroupTextVisible Property

Newtone.ImageKit.Win.ToolBarSetupObjects.GroupTextVisible Property

This property sets whether or not the group of "Text" related comboboxes, buttons, and labels is displayed.

[Visual Basic]Public Property GroupTextVisible As Boolean
[C#]public bool GroupTextVisible {get; set;}

Property Value

True: The group of "Text" related items is displayed
False: The group of "Text" related items is NOT displayed

Default value is True.

Explanation

The GroupTextVisible property sets whether or not the group of "Text" related comboboxes, buttons, and labels is displayed. When this property is False, the "Font", "WordWrap", "VerticalText", "RightToLeft", "Border", "BorderColor", "BorderColorOpacity", "BorderShape", and "TextAlignment" items and the related separators are not displayed.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


LabelBorderColorOpacity property

Newtone.ImageKit.Win.ToolBarSetupObjects.LabelBorderColorOpacity Property

This property sets or retrieves the ToolStripLabel control displaying the "BorderColorOpacity" label on the ToolBarSetupObjects control.

[Visual Basic]Public Property LabelBorderColorOpacity As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelBorderColorOpacity {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelBorderColorOpacity property sets or retrieves the ToolStripLabel control displaying the "BorderColorOpacity" label on the ToolBarSetupObjects control.

Because the "BorderColorOpacity" label is a ToolStripLabel control, you can use the LabelBorderColorOpacity property to change the "BorderColorOpacity" label text, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


LabelBorderColorOpacityUnit property

Newtone.ImageKit.Win.ToolBarSetupObjects.LabelBorderColorOpacityUnit Property

This property sets or retrieves the ToolStripLabel control displaying the "BorderColorOpacityUnit" label on the ToolBarSetupObjects control.

[Visual Basic]Public Property LabelBorderColorOpacityUnit As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelBorderColorOpacityUnit {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelBorderColorOpacityUnit property sets or retrieves the ToolStripLabel control displaying the "BorderColorOpacityUnit" label on the ToolBarSetupObjects control.

Because the "BorderColorOpacityUnit" label is a ToolStripLabel control, you can use the LabelBorderColorOpacityUnit property to change the "BorderColorOpacityUnit" label text, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


LabelBorderShape property

Newtone.ImageKit.Win.ToolBarSetupObjects.LabelBorderShape Property

This property sets or retrieves the ToolStripLabel control displaying the "BorderShape" label on the ToolBarSetupObjects control.

[Visual Basic]Public Property LabelBorderShape As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelBorderShape {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelBorderShape property sets or retrieves the ToolStripLabel control displaying the "BorderShape" label on the ToolBarSetupObjects control.

Because the "BorderShape" label is a ToolStripLabel control, you can use the LabelBorderShape property to change the "BorderShape" label text, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


LabelRoundRectangleRadius property

Newtone.ImageKit.Win.ToolBarSetupObjects.LabelRoundRectangleRadius Property

This property sets or retrieves the ToolStripLabel control displaying the "RoundRectangleRadius" label on the ToolBarSetupObjects control.

[Visual Basic]Public Property LabelRoundRectangleRadius As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelRoundRectangleRadius {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelRoundRectangleRadius property sets or retrieves the ToolStripLabel control displaying the "RoundRectangleRadius" label on the ToolBarSetupObjects control.

Because the "RoundRectangleRadius" label is a ToolStripLabel control, you can use the LabelRoundRectangleRadius property to change the "RoundRectangleRadius" label text, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


LabelRoundRectangleRadiusUnit property

Newtone.ImageKit.Win.ToolBarSetupObjects.LabelRoundRectangleRadiusUnit Property

This property sets or retrieves the ToolStripLabel control displaying the "RoundRectangleRadiusUnit" label on the ToolBarSetupObjects control.

[Visual Basic]Public Property LabelRoundRectangleRadiusUnit As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelRoundRectangleRadiusUnit {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelRoundRectangleRadiusUnit property sets or retrieves the ToolStripLabel control displaying the "RoundRectangleRadiusUnit" label on the ToolBarSetupObjects control.

Because the "RoundRectangleRadiusUnit" label is a ToolStripLabel control, you can use the LabelRoundRectangleRadiusUnit property to change the "RoundRectangleRadiusUnit" label text, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


LabelTextAlign property

Newtone.ImageKit.Win.ToolBarSetupObjects.LabelTextAlign Property

This property sets or retrieves the ToolStripLabel control displaying the "TextAlign" label on the ToolBarSetupObjects control.

[Visual Basic]Public Property LabelTextAlign As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelTextAlign {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelTextAlign property sets or retrieves the ToolStripLabel control displaying the "TextAlign" label on the ToolBarSetupObjects control.

Because the "TextAlign" label is a ToolStripLabel control, you can use the LabelTextAlign property to change the "TextAlign" label text, generate events, etc.

For coding examples, please refer to the ButtonAspectRatio property explanation

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


MaxRoundRectangleRadius Property

Newtone.ImageKit.Win.ToolBarSetupObjects.MaxRoundRectangleRadius Property

This property sets the maximum value for the "RoundRectangleRadius".

[Visual Basic]Public Property MaxRoundRectangleRadius As Integer
[C#]public int MaxRoundRectangleRadius {get; set;}

Property Value

An integer the sets the "RoundRectangleRadius" maximum value

Default value is 999

Explanation

The MaxRoundRectangleRadius property sets the maximum value for the "RoundRectangleRadius".

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


Separator1Visible Property

Newtone.ImageKit.Win.ToolBarSetupObjects.Separator1Visible Property

This property sets whether or not Separator1 is displayed in the ToolBarSetupObjects control.

[Visual Basic]Public Property Separator1Visible As Boolean
[C#]public bool Separator1Visible {get; set;}

Property Value

True: Separator1 is displayed
False: Separator1 is NOT displayed

Default value is True

Explanation

The Separator1Visible property sets whether or not Separator1 is displayed in the ToolBarSetupObjects control. Separator1 is the separator between the "AspectRatio" button and the "RoundRectangleRadius" label, when the ToolBarSetupObjects control is in its default state.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


Separator2Visible Property

Newtone.ImageKit.Win.ToolBarSetupObjects.Separator2Visible Property

This property sets whether or not Separator2 is displayed in the ToolBarSetupObjects control.

[Visual Basic]Public Property Separator2Visible As Boolean
[C#]public bool Separator2Visible {get; set;}

Property Value

True: Separator2 is displayed
False: Separator2 is NOT displayed

Default value is True

Explanation

The Separator2Visible property sets whether or not Separator2 is displayed in the ToolBarSetupObjects control. Separator2 is the separator between the "RoundRectangleRadiusDown" button and the "Font" button, when the ToolBarSetupObjects control is in its default state.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


Separator3Visible Property

Newtone.ImageKit.Win.ToolBarSetupObjects.Separator3Visible Property

This property sets whether or not Separator3 is displayed in the ToolBarSetupObjects control.

[Visual Basic]Public Property Separator3Visible As Boolean
[C#]public bool Separator3Visible {get; set;}

Property Value

True: Separator3 is displayed
False: Separator3 is NOT displayed

Default value is True

Explanation

The Separator3Visible property sets whether or not Separator3 is displayed in the ToolBarSetupObjects control. Separator3 is the separator between the "RightToLeft" button and the "Border" button, when the ToolBarSetupObjects control is in its default state.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


Separator4Visible Property

Newtone.ImageKit.Win.ToolBarSetupObjects.Separator4Visible Property

This property sets whether or not Separator4 is displayed in the ToolBarSetupObjects control.

[Visual Basic]Public Property Separator4Visible As Boolean
[C#]public bool Separator4Visible {get; set;}

Property Value

True: Separator4 is displayed
False: Separator4 is NOT displayed

Default value is True

Explanation

The Separator4Visible property sets whether or not Separator4 is displayed in the ToolBarSetupObjects control. Separator4 is the separator between the "BorderColorOpacityDown" button and the "BorderShape" label, when the ToolBarSetupObjects control is in its default state.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


SettingsForEachImageKit property

Newtone.ImageKit.Win.ToolBarSetupObjects.SettingsForEachImageKit Property

This property determines if the ToolBarSetupObjects control's settings apply to each ImageKit Control according to the TargetImageKit property value, or if the ToolBarSetupObjects control's settings apply to all ImageKit Controls.

[Visual Basic] Public Property SettingsForEachImageKit As Boolean
[C#] public bool SettingsForEachImageKit {get; set;}

Property Value

Value | Explanation
True (default) | ToolBarSetupObjects control settings apply only to the ImageKit control specified by the TargetImageKit property.
False | ToolBarSetupObjects control settings apply to all the ImageKit controls regardless of the target specified by the TargetImageKit property.

Explanation

The SettingsForEachImageKit property determines if the ToolBarSetupObjects control's settings apply to each ImageKit control according to the TargetImageKit property value, or if the ToolBarSetupObjects control's settings apply to all ImageKit controls.

When one ToolBarSetupObjects control is set to apply to multiple ImageKit controls, it is possible for that single ToolBarSetupObjects control to maintain different settings according to which ImageKit control it targets. When the SettingsForEachImageKit property is True, the ToolBarSetupObjects control settings apply only to the target ImageKit as determined by the TargetImageKit property. When the TargetImageKit property changes, the ToolBarSetupObjects settings also change.

If the SettingsForEachImageKit property is False, the ToolBarSetupObjects control settings apply to all ImageKit controls regardless of the TargetImageKit property value.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


TargetImageKit property

Newtone.ImageKit.Win.ToolBarSetupObjects.TargetImageKit Property

This property sets which ImageKit control is targeted by the ToolBarSetupObjects control.

[Visual Basic] Public Property TargetImageKit As ImageKit
[C#] public ImageKit TargetImageKit {get; set;}

Property Value

An ImageKit control

Default value is null (Nothing)

Explanation

The TargetImageKit property sets the correspondence between the ToolBarSetupObjects control and the ImageKit control(s). This property determines which ImageKit control is targeted by the ToolBarSetupObjects control.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


TextBoxBorderColorOpacity Property

Newtone.ImageKit.Win.ToolBarSetupObjects.TextBoxBorderColorOpacity Property

This property sets or retrieves the ToolStripTextBox control displaying the "BorderColorOpacity" item on the ToolBarSetupObjects control.

[Visual Basic]Public Property TextBoxBorderColorOpacity As System.Windows.Forms.ToolStripTextBox
[C#]public System.Windows.Forms.ToolStripTextBox TextBoxBorderColorOpacity {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripTextBox

Explanation

The TextBoxBorderColorOpacity property sets or retrieves the ToolStripTextBox control displaying the "BorderColorOpacity" item on the ToolBarSetupObjects control.

Because the "BorderColorOpacity" textbox is a ToolStripTextBox control, you can use the TextBoxEndArrowCapSize property to change the "BorderColorOpacity" settings, generate events, etc.

Please refer to the coding examples below.

Examples

(1) To change the background color displayed in the "BorderColorOpacity" textbox:

[Visual Basic.NET]
ToolBarSetupObjects1.TextBoxBorderColorOpacity.BackColor =
                Color.FromArgb(255, 255, 192)

[Visual C#.NET]
toolBarSetUpObjects1.TextBoxBorderColorOpacity.BackColor=Color.FromArgb(255,
                255, 192);

(2) Access the "BorderColorOpacity" textbox's Click event.

[Visual Basic.NET]
'In the FormLoad event, set the TextBoxBorderColorOpacity click event handler
AddHandler ToolBarSetupObjects1.TextBoxBorderColorOpacity.Click, AddressOf
                TextBoxBorderColorOpacity_Click

'event
Private Sub TextBoxBorderColorOpacity_Click(ByVal sender As System.Object,
                ByVal e As System.EventArgs)
'Write code here that you want to execute when the event fires
End Sub

[Visual C#.NET]
//In the FormLoad event, set the TextBoxBorderColorOpacity click event handler
toolBarSetUpObjects1.TextBoxBorderColorOpacity.Click += new
                EventHandler(TextBoxBorderColorOpacity_Click);

//event
private void TextBoxBorderColorOpacity_Click(object sender, EventArgs e)
{
//Write code here that you want to execute when the event fires
}

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


TextBoxRoundRectangleRadius Property

Newtone.ImageKit.Win.ToolBarSetupObjects.TextBoxRoundRectangleRadius Property

This property sets or retrieves the ToolStripTextBox control displaying the "RoundRectangleRadius" textbox on the ToolBarSetupObjects control.

[Visual Basic]Public Property TextBoxRoundRectangleRadius As System.Windows.Forms.ToolStripTextBox
[C#]public System.Windows.Forms.ToolStripTextBox TextBoxRoundRectangleRadius {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripTextBox

Explanation

The TextBoxRoundRectangleRadius property sets or retrieves the ToolStripTextBox control displaying the "RoundRectangleRadius" textbox on the ToolBarSetupObjects control.

Because the "RoundRectangleRadius" textbox is a ToolStripTextBox control, you can use the TextBoxRoundRectangleRadius property to change the "RoundRectangleRadius" settings, generate events, etc.

For coding examples, please refer to the TextBoxBorderColorOpacity property explanation.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


TargetImageKitChanged event

Newtone.ImageKit.Win.ToolBarSetupObjects.TargetImageKitChanged Event

This event is generated whenever the TargetImageKit property changes.

[Visual Basic] Public Event TargetImageKitChanged As EventHandler
[C#] public event EventHandler TargetImageKitChanged;

Event Data

This event handler accepts parmeters of type EventArgs

Explanation

The TargetImageKitChanged event is generated whenever the TargetImageKit property changes.

When one ToolBar control is used with multiple ImageKit controls and the focus changes from one ImageKit control to another (i.e. the TargetImageKit property changes), you can use this event to retrieve which ImageKit control has focus.

See Also

ToolBarSetupObjects Members | Newtone.ImageKit.Win.ToolBarSetupObjects


ImageKitWinToolBarStandard Class

Newtone.ImageKit.Win.ToolBarStandard Class

The main class for the WinForm ToolBarStandard Control.

For a list of all members of this class, see ToolBarStandard Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Newtone.ImageKit.Win

public class ToolBarStandard : System.Windows.Forms.Control

Explanation

The ToolBarStandard control is a user friendly toolbar interface housing buttons and other items that provide basic editing and annotation functions including setting pen functions, loading and saving image files, and loading and saving annotation files.

The ToolBarStandard control lools like this:

The ToolBarStandard control contains the following items:

Item |  | Explanation
Enable Annotation | Enable Annotation Button | This button enables annotation functions. The button appears pushed or unpressed to reflect True/False. Using this button sets the ImageKit.Edit.EditEnabled property.
Open File | Open Image File Button | This button opens an image file in the specified ImageKit control. Using this button is the same as executing the ImageKit.File.LoadImageFromFile method.
Save File | Save Image File Button | This button saves the image file from the specified ImageKit control to file. Using this button is the same as executing the ImageKit.File.SaveImageFromFile method.
Open Annotation File | Open Annotation File | This button loads the specified annotation file and draws the annotation objects on top of the image displayed in the ImageKit control. Using this button is the same as executing the ImageKit.Edit.LoadAnnotationFile method.
Save Annotation File | Save Annotation File | This button saves the annotation objects currently drawn on the specified ImageKit control into an annotation file. This button is the same thing as executing the ImageKit.Edit.SaveAnnotationFile method.
Pen Width | Pen Width | This button / textbox sets the pen width which determines the width of lines and borders. The pen width can be entered into the textbox or can be increased or decreased using the arrow buttons. Setting the pen width this way is the same as executing the ImageKit.Edit.PenWidth property.
Fore Color | Fore Color | This button displays the color dialog and allows you to set the fore color which determines the color of lines, borders, and text. Setting the fore color this way is the same as executing the ImageKit.Edit.ForeColor property. The color of this button is the selected fore color.
Fore Color Opacity | Fore Color Opacity | This button / textbox sets the opacity level for the fore color. The opacity level can be entered into the textbox or can be increased or decreased using the arrow buttons. Setting the fore color opacity this way is the same as executing the ImageKit.Edit.ForeColorOpacity property.
Back Color | Back Color | This button displays the color dialog and allows you to set the back color. Setting the back color this way is the same as executing the ImageKit.Edit.BackColor property. The color of this button is the selected back color.
Back Color Opacity | Back Color Opacity | This button / textbox sets the opacity level for the back color. The opacity level can be entered into the textbox or can be increased or decreased using the arrow buttons. Setting the back color opacity this way is the same as executing the ImageKit.Edit.BackColorOpacity property.
Fill | Fill | This button sets the fill property. It is the same as setting the ImageKit.Edit.Fill property. The button's "pressed status" reflects whether fill is True or False

Requirement

Namespace: Newtone.ImageKit.Win

Assembly: Newtone.ImageKit.NETX.ImageKit.dll

See Also

ToolBarStandard Members


ToolBarStandard Members

Newtone.ImageKit.Win.ToolBarStandard Members

ToolBarStandard Overview

Public Constructor

ToolBarStandard Constructor Creates a new instance of the ToolBarStandard class.

Public Properties

AnnotationFileExtension | Sets the default file extention that appears in the Open Annotation File and Save Annotation File dialog when an annotation file is being opened or saved
AnnotationFilePath | Sets the default folder that appears in the Open Annotation File and Save Annotation File dialog when an annotation file is being opened or saved
BaseImageKitBackColor | Sets or retrieves the value of the Edit.BackColor property of the ImageKit control.
BaseImageKitBackColorOpacity | Sets or retrieves the value of the Edit.BackColorOpacity property of the ImageKit control
BaseImageKitEditEnabled | Sets or retrieves the value of the Edit.EditEnabled property of the ImageKit control
BaseImageKitFill | Sets or retrieves the value of the Edit.Fill property of the ImageKit control
BaseImageKitForeColor | Sets or retrieves the value of the Edit.ForeColor property of the ImageKit control
BaseImageKitForeColorOpacity | Sets or retrieves the value of the Edit.ForeColorOpacity property of the ImageKit control
BaseImageKitPenWidth | Sets or retrieves the value of the Edit.PenWidth property of the ImageKit control
BoxBackColorOpacityVisible | Sets whether or not the items related to "BackColorOpacity" are displayed on the ToolBarStandard control
BoxForeColorOpacityVisible | Sets whether or not the items related to "ForeColorOpacity" are displayed on the ToolBarStandard control
BoxPenWidthVisible | Sets whether or not the items related to "Pen Width" are displayed on the ToolBarStandard control
ButtonBackColor | Sets or retrieves the "BackColor" button of the ToolBarStandard control
ButtonBackColorOpacityDown | Sets or retrieves the "BackColorOpacityDown" button of the ToolBarStandard control
ButtonBackColorOpacityUp | Sets or retrieves the "BackColorOpacityUp" button of the ToolBarStandard control
ButtonBackColorVisible | Sets whether or not the items related to "BackColor" are displayed on the ToolBarStandard control
ButtonEditEnabled | Sets or retrieves the "Enable Annotation" button of the ToolBarStandard control
ButtonEditEnabledVisible | Sets whether or not the "Enable Annotation" button is displayed on the ToolBarStandard control
ButtonFill | Sets or retrieves the "Fill" button of the ToolBarStandard control
ButtonFillVisible | Sets whether or not the items related to "Fill" are displayed on the ToolBarStandard control
ButtonForeColor | Sets or retrieves the "ForeColor" button of the ToolBarStandard control
ButtonForeColorOpacityDown | Sets or retrieves the "ForeColorOpacityDown" button of the ToolBarStandard control
ButtonForeColorOpacityUp | Sets or retrieves the "ForeColorOpacityUp" button of the ToolBarStandard control
ButtonForeColorVisible | Sets whether or not the items related to "ForeColor" are displayed on the ToolBarStandard control
ButtonOpenAnnotationFile | Sets or retrieves the "Open Annotation File" button of the ToolBarStandard control
ButtonOpenAnnotationFileVisible | Sets whether or not the items related to "Open Annotation File" are displayed on the ToolBarStandard control
ButtonOpenFile | Sets or retrieves the "Open File" button of the ToolBarStandard control
ButtonOpenFileVisible | Sets whether or not the items related to "Open File" are displayed on the ToolBarStandard control
ButtonPenWidthDown | Sets or retrieves the "Pen Width Down" button of the ToolBarStandard control
ButtonPenWidthUp | Sets or retrieves the "Pen Width Up" button of the ToolBarStandard control
ButtonSaveAnnotationFile | Sets or retrieves the "Save Annotation File" button of the ToolBarStandard control
ButtonSaveAnnotationFileVisible | Sets whether or not the items related to "Save Annotation File" are displayed on the ToolBarStandard control
ButtonSaveFile | Sets or retrieves the "Save File" button of the ToolBarStandard control
ButtonSaveFileVisible | Sets whether or not the items related to "Save File" are displayed on the ToolBarStandard control
ButtonSize | Sets or retrieves the size of the buttons displayed in the ToolBarStandard control
GroupFileVisible | Sets whether or not the group of "File" related buttons, is displayed the ToolBarStandard control
GroupSetUpVisible | Sets whether or not the group of "Setup" related buttons, is displayed the ToolBarStandard control
LabelBackColorOpacity | Sets or retrieves the "BackColorOpacity" label of the ToolBarStandard control
LabelBackColorOpacityUnit | Sets or retrieves the "BackColorOpacityUnit" label of the ToolBarStandard control
LabelForeColorOpacity | Sets or retrieves the "ForeColorOpacity" label of the ToolBarStandard control
LabelForeColorOpacityUnit | Sets or retrieves the "ForeColorOpacityUnit" label of the ToolBarStandard control
LabelPenWidth | Sets or retrieves the "PenWidth" label of the ToolBarStandard control
LabelPenWidthUnit | Sets or retrieves the "PenWidthUnit" label of the ToolBarStandard control
MaxPenWidth | Sets the maximum value of the PenWidth
SaveFormatDialogEnabled | Sets whether or not the dialog, which allows you to choose different image formats, is displayed when saving an image using the Save File button
SaveType | Sets the file format that will be used when an image is saved using the "Save File" button
Separator1Visible | Determines whether or not Separator1 is displayed in the ToolBarStandard control. Separator1 is the separator between the "Save File" and "Open Annotation File" buttons
Separator2Visible | Determines whether or not Separator2 is displayed in the ToolBarStandard control. Separator2 is the separator between the "Save Annotation File" and "PenWidth" buttons
Separator3Visible | Determines whether or not Separator3 is displayed in the ToolBarStandard control. Separator3 is the separator between the "PenWidth Down" and "ForeColor" buttons
Separator4Visible | Determines whether or not Separator4 is displayed in the ToolBarStandard control. Separator4 is the separator between the "ForeColorOpacity Down" and "BackColor" buttons
Separator5Visible | Determines whether or not Separator5 is displayed in the ToolBarStandard control. Separator5 is the separator between the "BackColorOpacity Down" and "Fill" buttons
SettingsForEachImageKit | Determines if the ToolBarStandard control's settings apply to each ImageKit Control according to the TargetImageKit property value, or if the ToolBarStandard control's settings apply to all ImageKit Controls
TargetImageKit | Sets which ImageKit control is targeted by the ToolBarStandard control
TextBoxBackColorOpacity | Sets the "BackColorOpacity" textbox of the ToolBarStandard control
TextBoxForeColorOpacity | Sets the "ForeColorOpacity" textbox of the ToolBarStandard control
TextBoxPenWidth | Sets the "PenWidth" textbox of the ToolBarStandard control

Public Events

TargetImageKitChanged Generated whenever the TargetImageKit property changes

See Also

Newtone.ImageKit.Win.ToolBarStandard


ImageKit.Win.ToolBarStandard Constructor

Newtone.ImageKit.Win.ToolBarStandard Constructor

This constructor creates a new instance of the ToolBarStandard class.

[Visual Basic] Public Sub New()
[C#] public public ToolBarStandard()

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


AnnotationFileExtension property

Newtone.ImageKit.Win.ToolBarStandard.AnnotationFileExtension Property

This property sets the default file extention that appears in the Open Annotation File and Save Annotation File dialog when an annotation file is being opened or saved.

[Visual Basic]Public Property AnnotationFileExtension As String
[C#]public string AnnotationFileExtension {get; set;}

Property Value

A string that represents the file extension

Explanation

The AnnotationFileExtension property sets sets the default file extention that appears in the Open Annotation File and Save Annotation File dialog when an annotation file is being opened or saved. When the Open / Save Annotation File button is pressed and the Open / Save Annotation File dialog appears, this property sets the file types that appear in the dialog.

The first item is the file description followed by a vertical bar separator. The next item is the file extension followed by a vertical bar separator. The final item is the file type. For multiple entries, separate file extensions with a semicolon.

Example

The default folder is "C:\Images". File extensions are "xml", "dat", and "All Files".

[Visual Basic.NET]
ToolBarStandard1.AnnotationFilePath = "c:\images"
ToolBarStandard1.AnnotationFileExtension = "xml,dat Files｜*.xml;*.dat｜All Files|*.*"

[Visual C#.NET]
ToolBarStandard1.AnnotationFilePath = "c:\images";
ToolBarStandard1.AnnotationFileExtension = "xml,dat Files｜*.xml;*.dat｜All Files|*.*";

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


AnnotationFilePath property

Newtone.ImageKit.Win.ToolBarStandard.AnnotationFilePath Property

This property sets the default folder that appears in the Open Annotation File and Save Annotation File dialog when an annotation file is being opened or saved.

[Visual Basic]Public Property AnnotationFilePath As String
[C#]public string AnnotationFilePath {get; set;}

Property Value

A string that represents the folder

Explanation

The AnnotationFilePath property sets sets the default folder that appears in the Open Annotation File and Save Annotation File dialog when an annotation file is being opened or saved. If an blank string, "", is set, the current path will be used.

Example

The default folder is "C:\Images". File extensions are "xml", "dat", and "All Files".

[Visual Basic.NET]
ToolBarStandard1.AnnotationFilePath = "c:\images"
ToolBarStandard1.AnnotationFileExtension = "xml,dat Files｜*.xml;*.dat｜All Files|*.*"

[Visual C#.NET]
ToolBarStandard1.AnnotationFilePath = "c:\images";
ToolBarStandard1.AnnotationFileExtension = "xml,dat Files｜*.xml;*.dat｜All Files|*.*";

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


BaseImageKitBackColor property

Newtone.ImageKit.Win.ToolBarStandard.BaseImageKitBackColor Property

This property sets or retrieves the value of the Edit.BackColor property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitBackColor As Color
[C#]public Color BaseImageKitBackColor {get; set;}

Property Value

A value of type Color
The default value is White

Explanation

The BaseImageKitBackColor property sets or retrieves the value of the Edit.BackColor property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitBackColor property to set the Edit.BackColor property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


BaseImageKitBackColorOpacity property

Newtone.ImageKit.Win.ToolBarStandard.BaseImageKitBackColorOpacity Property

This property sets or retrieves the value of the Edit.BackColorOpacity property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitBackColorOpacity As Integer
[C#]public int BaseImageKitBackColorOpacity {get; set;}

Property Value

An integer that represents the level of opacity
Default value is 100.

Explanation

The BaseImageKitBackColorOpacity property sets or retrieves the value of the Edit.BackColorOpacity property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitBackColorOpacity property to set the Edit.BackColorOpacity property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


BaseImageKitEditEnabled property

Newtone.ImageKit.Win.ToolBarStandard.BaseImageKitEditEnabled Property

This property sets or retrieves the value of the Edit.EditEnabled property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitEditEnabled As Boolean
[C#]public bool BaseImageKitEditEnabled {get; set;}

Property Value

True: Enables edit and annotation functions
False: Disables edit and annotation functions
Default value is False.

Explanation

The BaseImageKitEditEnabled property sets or retrieves the Edit.EditEnabled property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitEditEnabled property to set the Edit.EditEnabled property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


BaseImageKitFill property

Newtone.ImageKit.Win.ToolBarStandard.BaseImageKitFill Property

This property sets or retrieves the value of the Edit.Fill property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitFill As Boolean
[C#]public bool BaseImageKitFill {get; set;}

Property Value

True: Annotation object filled with background color
False: Annotation object NOT filled with background color
Default value is False.

Explanation

The BaseImageKitFill property sets or retrieves the Edit.Fill property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitFill property to set the Edit.Fill property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


BaseImageKitForeColor property

Newtone.ImageKit.Win.ToolBarStandard.BaseImageKitForeColor Property

This property sets or retrieves the value of the Edit.ForeColor property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitForeColor As Color
[C#]public Color BaseImageKitForeColor {get; set;}

Property Value

A value of type Color
The default value is White

Explanation

The BaseImageKitForeColor property sets or retrieves the value of the Edit.ForeColor property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitForeColor property to set the Edit.ForeColor property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


BaseImageKitForeColorOpacity property

Newtone.ImageKit.Win.ToolBarStandard.BaseImageKitForeColorOpacity Property

This property sets or retrieves the value of the Edit.ForeColorOpacity property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitForeColorOpacity As Integer
[C#]public int BaseImageKitForeColorOpacity {get; set;}

Property Value

An integer that represents the level of opacity
Default value is 100.

Explanation

The BaseImageKitForeColorOpacity property sets or retrieves the value of the Edit.ForeColorOpacity property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitForeColorOpacity property to set the Edit.ForeColorOpacity property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


BoxBackColorOpacityVisible property

Newtone.ImageKit.Win.ToolBarStandard.BoxBackColorOpacityVisible Property

This property sets whether or not the items related to "BackColorOpacity" are displayed on the ToolBarStandard control.

[Visual Basic]Public Property BoxBackColorOpacityVisible As Boolean
[C#]public bool BoxBackColorOpacityVisible {get; set;}

Property Value

True: The "BackColorOpacity" items are displayed
False: The "BackColorOpacity" items are NOT displayed

Default value is True.

Explanation

The BoxBackColorOpacityVisible property sets whether or not the items related to "BackColorOpacity" are displayed on the ToolBarStandard control. When this property is False, the BackColorOpacity combobox, button, label and other related items are not displayed.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


BoxForeColorOpacityVisible property

Newtone.ImageKit.Win.ToolBarStandard.BoxForeColorOpacityVisible Property

This property sets whether or not the items related to "ForeColorOpacity" are displayed on the ToolBarStandard control.

[Visual Basic]Public Property BoxForeColorOpacityVisible As Boolean
[C#]public bool BoxForeColorOpacityVisible {get; set;}

Property Value

True: The "ForeColorOpacity" items are displayed
False: The "ForeColorOpacity" items are NOT displayed

Default value is True.

Explanation

The BoxForeColorOpacityVisible property sets whether or not the items related to "ForeColorOpacity" are displayed on the ToolBarStandard control. When this property is False, the ForeColorOpacity combobox, button, label and other related items are not displayed.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


BoxPenWidthVisible property

Newtone.ImageKit.Win.ToolBarStandard.BoxPenWidthVisible Property

This property sets whether or not the items related to "Pen Width" are displayed on the ToolBarStandard control.

[Visual Basic]Public Property BoxPenWidthVisible As Boolean
[C#]public bool BoxPenWidthVisible {get; set;}

Property Value

True: The "Pen Width" items are displayed
False: The "Pen Width" items are NOT displayed

Default value is True.

Explanation

The BoxPenWidthVisible property sets whether or not the items related to "Pen Width" are displayed on the ToolBarStandard control. When this property is False, the PenWidth combobox, button, label and other related items are not displayed.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonBackColor property

Newtone.ImageKit.Win.ToolBarStandard.ButtonBackColor Property

This property sets or retrieves the "BackColor" button of the ToolBarStandard control.

[Visual Basic]Public Property ButtonBackColor As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonBackColor {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonBackColor property sets or retrieves the "BackColor" button of the ToolBarStandard. The "BackColor" button is a ToolStripButton control. By using the ButtonBackColor property, you can change "BackColor" button settings, generate events, etc. See code examples below.

Examples

(1) To change the image displayed in the "Fill" button

[Visual Basic.NET]
ToolBarStandard1.ButtonFill.Image = Image.FromFile("c:\images\button_img1.bmp")

[Visual C#.NET]
ToolBarStandard1.Fill.Image = Image.FromFile("c:\\images\\button_img1.bmp");

(2) To retrieve the "PenWidthUp" button click event
* It is necessary to determine which button was clicked. This must be done within the ToolBarStandard control's ItemClicked event

[Visual Basic.NET]
Private Sub ToolBarStandard1_ItemClicked(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolStripItemClickedEventArgs) Handles ToolBarStandard1.ItemClicked
If e.ClickedItem Is ToolBarStandard1.ButtonPenWidthUp Then 'The button clicked was the "PenWidthUp" button
'Here is where you place code that will be executed when this event fires
End If
End Sub

[Visual C#.NET]
private void ToolBarStandard1_ItemClicked(object sender, ToolStripItemClickedEventArgs e)
{
if (e.ClickedItem == ToolBarStandard1.ButtonPenWidthUp) //The button clicked was the "PenWidthUp" button
{
//Here is where you place code that will be executed when this event fires
}
}

(3) To generate the "PenWidthUp" button mouse up event

[Visual Basic.NET]
'* In the FormLoad or other event, set the delegate for the ButtonPenWidthUp mouse up event.
AddHandler ToolBarStandard1.ButtonPenWidthUp.MouseUp, AddressOf ButtonPenWidthUp_MouseUp

'Event Handler Delegate
Private Sub ButtonPenWidthUp_MouseUp(ByVal sender As System.Object, ByVal e As System.EventArgs)
'Here is where you place code that will be executed when this event fires
End Sub

[Visual C#.NET]
'* In the FormLoad or other event, set the delegate for the ButtonPenWidthUp mouse up event.
ToolBarStandard1.ButtonPenWidthUp.MouseUp += new MouseEventHandler(ButtonPenWidthUp_MouseUp);

//Event Handler Delegate
private void ButtonPenWidthUp_MouseUp(object sender, EventArgs e)
{
//Here is where you place code that will be executed when this event fires
}

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonBackColorOpacityDown property

Newtone.ImageKit.Win.ToolBarStandard.ButtonBackColorOpacityDown Property

This property sets or retrieves the "BackColorOpacityDown" button of the ToolBarStandard control.

[Visual Basic]Public Property ButtonBackColorOpacityDown As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonBackColorOpacityDown {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonBackColorOpacityDown property sets or retrieves the "BackColorOpacityDown" button of the ToolBarStandard. The "BackColorOpacityDown" button is a ToolStripButton control. By using the ButtonBackColorOpacityDown property, you can change "BackColorOpacityDown" button settings, generate events, etc.

For code examples, see the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonBackColorOpacityUp property

Newtone.ImageKit.Win.ToolBarStandard.ButtonBackColorOpacityUp Property

This property sets or retrieves the "BackColorOpacityUp" button of the ToolBarStandard control.

[Visual Basic]Public Property ButtonBackColorOpacityUp As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonBackColorOpacityUp {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonBackColorOpacityUp property sets or retrieves the "BackColorOpacityUp" button of the ToolBarStandard. The "BackColorOpacityUp" button is a ToolStripButton control. By using the ButtonBackColorOpacityUp property, you can change "BackColorOpacityUp" button settings, generate events, etc.

For code examples, see the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonBackColorVisible property

Newtone.ImageKit.Win.ToolBarStandard.ButtonBackColorVisible Property

This property sets whether or not the items related to "BackColor" are displayed on the ToolBarStandard control.

[Visual Basic]Public Property ButtonBackColorVisible As Boolean
[C#]public bool ButtonBackColorVisible {get; set;}

Property Value

True: The "BackColor" items are displayed
False: The "BackColor" items are NOT displayed

Default value is True.

Explanation

The ButtonBackColorVisible property sets whether or not the items related to "BackColor" are displayed on the ToolBarStandard control. When this property is False, the BackColor button is not displayed.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonEditEnabled property

Newtone.ImageKit.Win.ToolBarStandard.ButtonEditEnabled Property

This property sets or retrieves the "Enable Annotation" button of the ToolBarStandard control.

[Visual Basic]Public Property ButtonEditEnabled As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonEditEnabled {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonEditEnabled property sets or retrieves the "Enable Annotation" button of the ToolBarStandard toolbar. The "Enable Annotation" button is a ToolStripButton control. Using the ButtonEditEnabled property sest the ImageKit.Edit.EditEnabled property.

For code examples, please refer to the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonEditEnabledVisible property

Newtone.ImageKit.Win.ToolBarStandard.ButtonEditEnabledVisible Property

This property sets whether or not the "Enable Annotation" button is displayed on the ToolBarStandard control.

[Visual Basic]Public Property ButtonEditEnabledVisible As Boolean
[C#]public bool ButtonEditEnabledVisible {get; set;}

Property Value

True: The "Edit Annotation" button is displayed
False: The "Edit Annotation" button is NOT displayed

Default value is True.

Explanation

The ButtonEditEnabledVisible property sets whether or not the "Enable Annotation" button is displayed on the ToolBarStandard control. When this property is False, the "Enable Annotation" button is not displayed.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonFill property

Newtone.ImageKit.Win.ToolBarStandard.ButtonFill Property

This property sets or retrieves the "Fill" button of the ToolBarStandard control.

[Visual Basic]Public Property ButtonFill As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonFill {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonFill property sets or retrieves the "Fill" button of the ToolBarStandard. The "Fill" button is a ToolStripButton control. By using the ButtonFill property, you can change "Fill" button settings, generate events, etc.

For code examples, please refer to the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonFillVisible property

Newtone.ImageKit.Win.ToolBarStandard.ButtonFillVisible Property

This property sets whether or not the items related to "Fill" are displayed on the ToolBarStandard control.

[Visual Basic]Public Property ButtonFillVisible As Boolean
[C#]public bool ButtonFillVisible {get; set;}

Property Value

True: The "Fill" items are displayed
False: The "Fill" items are NOT displayed

Default value is True.

Explanation

The ButtonFillVisible property sets whether or not the items related to "Fill" are displayed on the ToolBarStandard control. When this property is False, the Fill button is not displayed.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonForeColor property

Newtone.ImageKit.Win.ToolBarStandard.ButtonForeColor Property

This property sets or retrieves the "ForeColor" button of the ToolBarStandard control.

[Visual Basic]Public Property ButtonForeColor As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonForeColor {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonForeColor property sets or retrieves the "ForeColor" button of the ToolBarStandard. "ForeColor" determines the color of lines and text.

The "ForeColor" button is a ToolStripButton control. By using the ButtonForeColor property, you can change "ForeColor" button settings, generate events, etc.

For code examples, please refer to the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonForeColorOpacityDown property

Newtone.ImageKit.Win.ToolBarStandard.ButtonForeColorOpacityDown Property

This property sets or retrieves the "ForeColorOpacityDown" button of the ToolBarStandard control.

[Visual Basic]Public Property ButtonForeColorOpacityDown As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonForeColorOpacityDown {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonForeColorOpacityDown property sets or retrieves the "ForeColorOpacityDown" button of the ToolBarStandard. The "ForeColorOpacityDown" button is a ToolStripButton control. By using the ButtonForeColorOpacityDown property, you can change "ForeColorOpacityDown" button settings, generate events, etc.

For code examples, see the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonForeColorOpacityUp property

Newtone.ImageKit.Win.ToolBarStandard.ButtonForeColorOpacityUp Property

This property sets or retrieves the "ForeColorOpacityUp" button of the ToolBarStandard control.

[Visual Basic]Public Property ButtonForeColorOpacityUp As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonForeColorOpacityUp {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonForeColorOpacityUp property sets or retrieves the "ForeColorOpacityUp" button of the ToolBarStandard. The "ForeColorOpacityUp" button is a ToolStripButton control. By using the ButtonForeColorOpacityUp property, you can change "ForeColorOpacityUp" button settings, generate events, etc.

For code examples, see the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonForeColorVisible property

Newtone.ImageKit.Win.ToolBarStandard.ButtonForeColorVisible Property

This property sets whether or not the items related to "ForeColor" are displayed on the ToolBarStandard control.

[Visual Basic]Public Property ButtonForeColorVisible As Boolean
[C#]public bool ButtonForeColorVisible {get; set;}

Property Value

True: The "ForeColor" items are displayed
False: The "ForeColor" items are NOT displayed

Default value is True.

Explanation

The ButtonForeColorVisible property sets whether or not the items related to "ForeColor" are displayed on the ToolBarStandard control. When this property is False, the ForeColor button is not displayed.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonOpenAnnotationFile property

Newtone.ImageKit.Win.ToolBarStandard.ButtonOpenAnnotationFile Property

This property sets or retrieves the "Open Annotation File" button of the ToolBarStandard control.

[Visual Basic]Public Property ButtonOpenAnnotationFile As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonOpenAnnotationFile {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonOpenAnnotationFile property sets or retrieves the "Open Annotation File" button of the ToolBarStandard. The "Open Annotation File" button is a ToolStripButton control. By using the ButtonOpenAnnotationFile property, you can change "Open Annotation File" button settings, generate events, etc.

For code examples, please refer to the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonOpenAnnotationFileVisible property

Newtone.ImageKit.Win.ToolBarStandard.ButtonOpenAnnotationFileVisible Property

This property sets whether or not the items related to "Open Annotation File" are displayed on the ToolBarStandard control.

[Visual Basic]Public Property ButtonOpenAnnotationFileVisible As Boolean
[C#]public bool ButtonOpenAnnotationFileVisible {get; set;}

Property Value

True: The "Open Annotation File" items are displayed
False: The "Open Annotation File" items are NOT displayed

Default value is True.

Explanation

The ButtonOpenAnnotationFileVisible property sets whether or not the items related to "Open Annotation File" are displayed on the ToolBarStandard control. When this property is False, the Open Annotation File button is not displayed.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonOpenFile property

Newtone.ImageKit.Win.ToolBarStandard.ButtonOpenFile Property

This property sets or retrieves the "Open File" button of the ToolBarStandard control.

[Visual Basic]Public Property ButtonOpenFile As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonOpenFile {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonOpenFile property sets or retrieves the "Open File" button of the ToolBarStandard. The "Open File" button is a ToolStripButton control. By using the ButtonOpenFile property, you can change "Open File" button settings, generate events, etc.

For code examples, please refer to the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonOpenFileVisible property

Newtone.ImageKit.Win.ToolBarStandard.ButtonOpenFileVisible Property

This property sets whether or not the items related to "Open File" are displayed on the ToolBarStandard control.

[Visual Basic]Public Property ButtonOpenFileVisible As Boolean
[C#]public bool ButtonOpenFileVisible {get; set;}

Property Value

True: The "Open File" items are displayed
False: The "Open File" items are NOT displayed

Default value is True.

Explanation

The ButtonOpenFileVisible property sets whether or not the items related to "Open File" are displayed on the ToolBarStandard control. When this property is False, the Open File button is not displayed.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonPenWidthDown property

Newtone.ImageKit.Win.ToolBarStandard.ButtonPenWidthDown Property

This property sets or retrieves the "Pen Width Down" button of the ToolBarStandard control.

[Visual Basic]Public Property ButtonPenWidthDown As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonPenWidthDown {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonPenWidthDown property sets or retrieves the "Pen Width Down" button of the ToolBarStandard. The "Pen Width Down" button is a ToolStripButton control. By using the ButtonPenWidthDown property, you can change "Pen Width Down" button settings, generate events, etc.

For code examples, see the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonPenWidthUp property

Newtone.ImageKit.Win.ToolBarStandard.ButtonPenWidthUp Property

This property sets or retrieves the "Pen Width Up" button of the ToolBarStandard control.

[Visual Basic]Public Property ButtonPenWidthUp As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonPenWidthUp {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonPenWidthUp property sets or retrieves the "Pen Width Up" button of the ToolBarStandard. The "Pen Width Up" button is a ToolStripButton control. By using the ButtonPenWidthUp property, you can change "Pen Width Up" button settings, generate events, etc.

For code examples, see the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonSaveAnnotationFile property

Newtone.ImageKit.Win.ToolBarStandard.ButtonSaveAnnotationFile Property

This property sets or retrieves the "Save Annotation File" button of the ToolBarStandard control.

[Visual Basic]Public Property ButtonSaveAnnotationFile As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonSaveAnnotationFile {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonSaveAnnotationFile property sets or retrieves the "Save Annotation File" button of the ToolBarStandard. The "Save Annotation File" button is a ToolStripButton control. By using the ButtonSaveAnnotationFile property, you can change "Save Annotation File" button settings, generate events, etc.

For code examples, please refer to the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonSaveAnnotationFileVisible property

Newtone.ImageKit.Win.ToolBarStandard.ButtonSaveAnnotationFileVisible Property

This property sets whether or not the items related to "Save Annotation File" are displayed on the ToolBarStandard control.

[Visual Basic]Public Property ButtonSaveAnnotationFileVisible As Boolean
[C#]public bool ButtonSaveAnnotationFileVisible {get; set;}

Property Value

True: The "Save Annotation File" items are displayed
False: The "Save Annotation File" items are NOT displayed

Default value is True.

Explanation

The ButtonSaveAnnotationFileVisible property sets whether or not the items related to "Save Annotation File" are displayed on the ToolBarStandard control. When this property is False, the Save Annotation File button is not displayed.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonSaveFile property

Newtone.ImageKit.Win.ToolBarStandard.ButtonSaveFile Property

This property sets or retrieves the "Save File" button of the ToolBarStandard control.

[Visual Basic]Public Property ButtonSaveFile As System.Windows.Forms.ToolStripButton
[C#]public System.Windows.Forms.ToolStripButton ButtonSaveFile {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripButton

Explanation

The ButtonSaveFile property sets or retrieves the "Save File" button of the ToolBarStandard. The "Save File" button is a ToolStripButton control. By using the ButtonSaveFile property, you can change "Save File" button settings, generate events, etc.

For code examples, please refer to the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonSaveFileVisible property

Newtone.ImageKit.Win.ToolBarStandard.ButtonSaveFileVisible Property

This property sets whether or not the items related to "Save File" are displayed on the ToolBarStandard control.

[Visual Basic]Public Property ButtonSaveFileVisible As Boolean
[C#]public bool ButtonSaveFileVisible {get; set;}

Property Value

True: The "Save File" items are displayed
False: The "Save File" items are NOT displayed

Default value is True.

Explanation

The ButtonSaveFileVisible property sets whether or not the items related to "Save File" are displayed on the ToolBarStandard control. When this property is False, the Save File button is not displayed.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ButtonSize property

Newtone.ImageKit.Win.ToolBarStandard.ButtonSize Property

This property sets or retrieves the size of the buttons displayed in the ToolBarStandard control.

[Visual Basic]Public Property ButtonSize As ToolBarButtonSize
[C#]public ToolBarButtonSize ButtonSize {get; set;}

Property Value

A value of type ToolBarButtonSize

The default value is ToolBarButtonSize.Small

Explanation

The ButtonSize property sets or retrieves the size of the buttons displayed in the ToolBarStandard control. Depending on the value set in the property, the width of the ToolBarStandard control may change.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


GroupFileVisible property

Newtone.ImageKit.Win.ToolBarStandard.GroupFileVisible Property

This property sets whether or not the group of "File" related buttons, is displayed the ToolBarStandard control.

[Visual Basic]Public Property GroupFileVisible As Boolean
[C#]public bool GroupFileVisible {get; set;}

Property Value

True: The "File" related items are displayed
False: The "File" related items are NOT displayed

Default value is True.

Explanation

The GroupFileVisible property sets whether or not the group of "File" related buttons, is displayed the ToolBarStandard control. When this property is False, the "Open File", "Save File", "Open Annotation File", and "Save Annotation File" buttons and their associated separator will not be displayed.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


GroupSetUpVisible property

Newtone.ImageKit.Win.ToolBarStandard.GroupSetUpVisible Property

This property sets whether or not the group of "Setup" related buttons, is displayed the ToolBarStandard control.

[Visual Basic]Public Property GroupSetUpVisible As Boolean
[C#]public bool GroupSetUpVisible {get; set;}

Property Value

True: The "Setup" related items are displayed
False: The "Setup" related items are NOT displayed

Default value is True.

Explanation

The GroupSetUpVisible property sets whether or not the group of "Setup" related buttons, is displayed the ToolBarStandard control. When this property is False, the "PenWidth", "ForeColor", "ForeColorOpacity", "BackColor", "BackColorOpacity", and "Fill" buttons, labels, and comboboxes and their associated separator will not be displayed.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


LabelBackColorOpacity Property

Newtone.ImageKit.Win.ToolBarStandard.LabelBackColorOpacity Property

This property sets or retrieves the "BackColorOpacity" label of the ToolBarStandard control.

[Visual Basic]Public Property LabelBackColorOpacity As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelBackColorOpacity {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelBackColorOpacity property sets or retrieves the "BackColorOpacity" label of the ToolBarStandard. The "BackColorOpacity" label is a ToolStripLabel control. By using the LabelBackColorOpacity property, you can change "BackColorOpacity" label settings, generate events, etc.

For code examples, please refer to the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


LabelBackColorOpacityUnit Property

Newtone.ImageKit.Win.ToolBarStandard.LabelBackColorOpacityUnit Property

This property sets or retrieves the "BackColorOpacityUnit" label of the ToolBarStandard control.

[Visual Basic]Public Property LabelBackColorOpacityUnit As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelBackColorOpacityUnit {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelBackColorOpacityUnit property sets or retrieves the "BackColorOpacityUnit" label of the ToolBarStandard. The "BackColorOpacityUnit" label is a ToolStripLabel control. By using the LabelBackColorOpacityUnit property, you can change "BackColorOpacityUnit" label settings, generate events, etc.

For code examples, please refer to the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


LabelForeColorOpacity Property

Newtone.ImageKit.Win.ToolBarStandard.LabelForeColorOpacity Property

This property sets or retrieves the "ForeColorOpacity" label of the ToolBarStandard control.

[Visual Basic]Public Property LabelForeColorOpacity As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelForeColorOpacity {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelForeColorOpacity property sets or retrieves the "ForeColorOpacity" label of the ToolBarStandard. The "ForeColorOpacity" label is a ToolStripLabel control. By using the LabelForeColorOpacity property, you can change "ForeColorOpacity" label settings, generate events, etc.

For code examples, please refer to the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


LabelForeColorOpacityUnit Property

Newtone.ImageKit.Win.ToolBarStandard.LabelForeColorOpacityUnit Property

This property sets or retrieves the "ForeColorOpacityUnit" label of the ToolBarStandard control.

[Visual Basic]Public Property LabelForeColorOpacityUnit As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelForeColorOpacityUnit {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelForeColorOpacityUnit property sets or retrieves the "ForeColorOpacityUnit" label of the ToolBarStandard. The "ForeColorOpacityUnit" label is a ToolStripLabel control. By using the LabelForeColorOpacityUnit property, you can change "ForeColorOpacityUnit" label settings, generate events, etc.

For code examples, please refer to the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


LabelPenWidth Property

Newtone.ImageKit.Win.ToolBarStandard.LabelPenWidth Property

This property sets or retrieves the "PenWidth" label of the ToolBarStandard control.

[Visual Basic]Public Property LabelPenWidth As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelPenWidth {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelPenWidth property sets or retrieves the "PenWidth" label of the ToolBarStandard. The "PenWidth" label is a ToolStripLabel control. By using the LabelPenWidth property, you can change "PenWidth" label settings, generate events, etc.

For code examples, please refer to the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


LabelPenWidthUnit Property

Newtone.ImageKit.Win.ToolBarStandard.LabelPenWidthUnit Property

This property sets or retrieves the "PenWidthUnit" label of the ToolBarStandard control.

[Visual Basic]Public Property LabelPenWidthUnit As System.Windows.Forms.ToolStripLabel
[C#]public System.Windows.Forms.ToolStripLabel LabelPenWidthUnit {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripLabel

Explanation

The LabelPenWidthUnit property sets or retrieves the "PenWidthUnit" label of the ToolBarStandard. The "PenWidthUnit" label is a ToolStripLabel control. By using the LabelPenWidthUnit property, you can change "PenWidthUnit" label settings, generate events, etc.

For code examples, please refer to the ButtonBackColor property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


MaxPenWidth property

Newtone.ImageKit.Win.ToolBarStandard.MaxPenWidth Property

This property sets the maximum value of the PenWidth.

[Visual Basic]Public Property MaxPenWidth As Integer
[C#]public int MaxPenWidth {get; set;}

Property Value

An integer representing the maximum PenWidth

The default value is 999

Explanation

The MaxPenWidth property sets the maximum value of the PenWidth.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


SaveFormatDialogEnabled property

Newtone.ImageKit.Win.ToolBarStandard.SaveFormatDialogEnabled Property

This property sets whether or not the dialog, which allows you to choose different image formats, is displayed when saving an image using the Save File button.

[Visual Basic]Public Property SaveFormatDialogEnabled As Boolean
[C#]public bool SaveFormatDialogEnabled {get; set;}

Property Value

True: The image format dialog is displayed
False: The image format dialog is NOT displayed

Default value is True.

Explanation

The SaveFormatDialogEnabled property sets whether or not the dialog, which allows you to choose different image formats, is displayed when saving an image using the ToolBarStandard "Save File" button. The TargetImageKit property sets which ImageKit control is associated with the ToolBarStandard control. When the SaveFormatDialogEnabled property is False, the image will be saved in the format set by the SaveType property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


SaveType property

Newtone.ImageKit.Win.ToolBarStandard.SaveType Property

This property sets the file format that will be used when an image is saved using the "Save File" button.

[Visual Basic]Public Property SaveType As Newtone.ImageKit.SaveFileType
[C#]public Newtone.ImageKit.SaveFileType SaveType {get; set;}

Property Value

A value of type Newtone.ImageKit.SaveFileType

Default value is Newtone.ImageKit.SaveFileType.SaveBMP

Explanation

The SaveType property sets the file format that will be used when an image is saved using the "Save File" button. The TargetImageKit property sets which ImageKit control is associated with the ToolBarStandard control.

If the SaveFormatDialogEnabled is true, the "SaveFormat" dialog will be displayed and the choice of file formats made in this dialog will determine the value of the SaveType property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


Separator1Visibile property

Newtone.ImageKit.Win.ToolBarStandard.Separator1Visibile Property

This property determines whether or not Separator1 is displayed in the ToolBarStandard control. Separator1 is the separator between the "Save File" and "Open Annotation File" buttons.

[Visual Basic] Public Property Separator1Visibile As Boolean
[C#] public bool Separator1Visibile {get; set;}

Property Value

Value | Explanation
True (default) | Separator1 is displayed in the ToolBarStandard control.
False | Separator1 is not displayed in the ToolBarStandard control.

Explanation

The Separator1Visibile property determines whether or not Separator1 is displayed in the ToolBarStandard control. Separator1 is the separator between the "Save File" and "Open Annotation File" buttons

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


Separator2Visibile property

Newtone.ImageKit.Win.ToolBarStandard.Separator2Visibile Property

This property determines whether or not Separator2 is displayed in the ToolBarStandard control. Separator2 is the separator between the "Save Annotation File" and "PenWidth" buttons.

[Visual Basic] Public Property Separator2Visibile As Boolean
[C#] public bool Separator2Visibile {get; set;}

Property Value

Value | Explanation
True (default) | Separator2 is displayed in the ToolBarStandard control.
False | Separator2 is not displayed in the ToolBarStandard control.

Explanation

The Separator2Visibile property determines whether or not Separator2 is displayed in the ToolBarStandard control. Separator2 is the separator between the "Save Annotation File" and "PenWidth" buttons

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


Separator3Visibile property

Newtone.ImageKit.Win.ToolBarStandard.Separator3Visibile Property

This property determines whether or not Separator3 is displayed in the ToolBarStandard control. Separator3 is the separator between the "PenWidth Down" and "ForeColor" buttons.

[Visual Basic] Public Property Separator3Visibile As Boolean
[C#] public bool Separator3Visibile {get; set;}

Property Value

Value | Explanation
True (default) | Separator3 is displayed in the ToolBarStandard control.
False | Separator3 is not displayed in the ToolBarStandard control.

Explanation

The Separator3Visibile property determines whether or not Separator3 is displayed in the ToolBarStandard control. Separator3 is the separator between the "PenWidth Down" and "ForeColor" buttons

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


Separator4Visibile property

Newtone.ImageKit.Win.ToolBarStandard.Separator4Visibile Property

This property determines whether or not Separator4 is displayed in the ToolBarStandard control. Separator4 is the separator between the "ForeColorOpacity Down" and "BackColor" buttons.

[Visual Basic] Public Property Separator4Visibile As Boolean
[C#] public bool Separator4Visibile {get; set;}

Property Value

Value | Explanation
True (default) | Separator4 is displayed in the ToolBarStandard control.
False | Separator4 is not displayed in the ToolBarStandard control.

Explanation

The Separator4Visibile property determines whether or not Separator4 is displayed in the ToolBarStandard control. Separator4 is the separator between the "ForeColorOpacity Down" and "BackColor" buttons

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


Separator5Visibile property

Newtone.ImageKit.Win.ToolBarStandard.Separator5Visibile Property

This property determines whether or not Separator5 is displayed in the ToolBarStandard control. Separator5 is the separator between the "BackColorOpacity Down" and "Fill" buttons.

[Visual Basic] Public Property Separator5Visibile As Boolean
[C#] public bool Separator5Visibile {get; set;}

Property Value

Value | Explanation
True (default) | Separator5 is displayed in the ToolBarStandard control.
False | Separator5 is not displayed in the ToolBarStandard control.

Explanation

The Separator5Visibile property determines whether or not Separator5 is displayed in the ToolBarStandard control. Separator5 is the separator between the "BackColorOpacity Down" and "Fill" buttons

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


SettingsForEachImageKit property

Newtone.ImageKit.Win.ToolBarStandard.SettingsForEachImageKit Property

This property determines if the ToolBarStandard control's settings apply to each ImageKit Control according to the TargetImageKit property value, or if the ToolBarStandard control's settings apply to all ImageKit Controls.

[Visual Basic] Public Property SettingsForEachImageKit As Boolean
[C#] public bool SettingsForEachImageKit {get; set;}

Property Value

Value | Explanation
True (default) | ToolBarStandard control settings apply only to the ImageKit control specified by the TargetImageKit property.
False | ToolBarStandard control settings apply to all the ImageKit controls regardless of the target specified by the TargetImageKit property.

Explanation

The SettingsForEachImageKit property determines if the ToolBarStandard control's settings apply to each ImageKit control according to the TargetImageKit property value, or if the ToolBarStandard control's settings apply to all ImageKit controls.

When one ToolBarStandard control is set to apply to multiple ImageKit controls, it is possible for that single ToolBarStandard control to maintain different settings according to which ImageKit control it targets. When the SettingsForEachImageKit property is True, the ToolBarStandard control settings apply only to the target ImageKit as determined by the TargetImageKit property. When the TargetImageKit property changes, the ToolBarStandard settings also change.

If the SettingsForEachImageKit property is False, the ToolBarStandard control settings apply to all ImageKit controls regardless of the TargetImageKit property value.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


TargetImageKit property

Newtone.ImageKit.Win.ToolBarStandard.TargetImageKit Property

This property sets which ImageKit control is targeted by the ToolBarStandard control.

[Visual Basic] Public Property TargetImageKit As ImageKit
[C#] public ImageKit TargetImageKit {get; set;}

Property Value

An ImageKit control

Default value is null (Nothing)

Explanation

The TargetImageKit property sets the correspondence between the ToolBarStandard control and the ImageKit control(s). This property determines which ImageKit control is targeted by the ToolBarStandard control.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


TextBoxBackColorOpacity Property

Newtone.ImageKit.Win.ToolBarStandard.TextBoxBackColorOpacity Property

This property sets or retrieves the "BackColorOpacity" textbox of the ToolBarStandard control.

[Visual Basic]Public Property TextBoxBackColorOpacity As System.Windows.Forms.ToolStripTextBox
[C#]public System.Windows.Forms.ToolStripTextBox TextBoxBackColorOpacity {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripTextBox

Explanation

The TextBoxBackColorOpacity property sets or retrieves the "BackColorOpacity" textbox of the ToolBarStandard. The "BackColorOpacity" textbox is a ToolStripTextBox control. By using the TextBoxBackColorOpacity property, you can change "BackColorOpacity" textbox settings, generate events, etc.

For code examples, please refer to the TextBoxPenWidth property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


TextBoxForeColorOpacity Property

Newtone.ImageKit.Win.ToolBarStandard.TextBoxForeColorOpacity Property

This property sets or retrieves the "ForeColorOpacity" textbox of the ToolBarStandard control.

[Visual Basic]Public Property TextBoxForeColorOpacity As System.Windows.Forms.ToolStripTextBox
[C#]public System.Windows.Forms.ToolStripTextBox TextBoxForeColorOpacity {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripTextBox

Explanation

The TextBoxForeColorOpacity property sets or retrieves the "ForeColorOpacity" textbox of the ToolBarStandard. The "ForeColorOpacity" textbox is a ToolStripTextBox control. By using the TextBoxForeColorOpacity property, you can change "ForeColorOpacity" textbox settings, generate events, etc.

For code examples, please refer to the TextBoxPenWidth property.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


TextBoxPenWidth property

Newtone.ImageKit.Win.ToolBarStandard.TextBoxPenWidth Property

This property sets or retrieves the "PenWidth" textbox of the ToolBarStandard control.

[Visual Basic]Public Property TextBoxPenWidth As System.Windows.Forms.ToolStripTextBox
[C#]public System.Windows.Forms.ToolStripTextBox TextBoxPenWidth {get; set;}

Property Value

A value of type System.Windows.Forms.ToolStripTextBox

Explanation

The TextBoxPenWidth property sets or retrieves the "PenWidth" textbox of the ToolBarStandard. The "PenWidth" textbox is a ToolStripTextBox control. By using the TextBoxPenWidth property, you can change "PenWidth" textbox settings, generate events, etc. See code examples below.

Examples

(1) To change the background color of the "PenWidth" textbox

[Visual Basic.NET]
ToolBarStandard1.TextBoxPenWidth.BackColor = Color.FromArgb(255, 255, 192)

[Visual C#.NET]
toolBarStandard1.TextBoxPenWidth.BackColor=Color.FromArgb(255, 255, 192);

(2) To retrieve the "PenWidth" textbox click event

[Visual Basic.NET]
* Set the delegate for the TextBoxPenWidth click event in the FormLoad event.
AddHandler ToolBarStandard1.TextBoxPenWidth.Click, AddressOf TextBoxPenWidth_Click

'Event Handler delegate
Private Sub TextBoxPenWidth_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
'Here is where you place code that will be executed when this event fires
End Sub

[Visual C#.NET]
* Set the delegate for the TextBoxPenWidth click event in the FormLoad event.
toolBarStandard1.TextBoxPenWidth.Click += new EventHandler(TextBoxPenWidth_Click);

//Event Handler delegate
private void TextBoxPenWidth_Click(object sender, EventArgs e)
{
//Here is where you place code that will be executed when this event fires
}

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


TargetImageKitChanged event

Newtone.ImageKit.Win.ToolBarStandard.TargetImageKitChanged Event

This event is generated whenever the TargetImageKit property changes.

[Visual Basic] Public Event TargetImageKitChanged As EventHandler
[C#] public event EventHandler TargetImageKitChanged;

Event Data

This event handler accepts parmeters of type EventArgs

Explanation

The TargetImageKitChanged event is generated whenever the TargetImageKit property changes.

When one ToolBar control is used with multiple ImageKit controls and the focus changes from one ImageKit control to another (i.e. the TargetImageKit property changes), you can use this event to retrieve which ImageKit control has focus.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard


ImageKitWinThumbnail class

Newtone.ImageKit.Win.Thumbnail Class

The main class for the WinForm Thumbnail Control

For a list of all members of this type, see Thumbnail Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Newtone.ImageKit.Win

public class Thumbnail : System.Windows.Forms.Control

Explanation

The Thumbnail Control allows you to display multiple image files as thumbnail images simply by specifying the image directories and image file types. Events are generated when thumbnails are selected either by the mouse, the keyboard, or by executing Thumbnail methods.

Requirement

Namespace : Newtone.ImageKit.Win

Assembly : Newtone.ImageKit.Win.Thumbnail.dll

See Also

Thumbnail Members


Thumbnail Members

Newtone.ImageKit.Win.Thumbnail All Members

Thumbnail Overview

Public Constructor

Thumbnail Constructor Initializes a new instance of the Thumbnail class

Public Properties

AllowDrag | Sets whether or not a thumbnail image can be dragged from the thumbnail control and dropped into the ImageKit Control or into another Thumbnail Control
Appearance | Sets the appearance of the Thumbnail Control
ArrayDirectoryName | Retrieves the image file's directory name from the thumbnail image specified by the ArrayImageNumber property
ArrayFileName | Retrieves the image file's filename from the thumbnail image specified by the ArrayImageNumber property
ArrayImageNumber | Uses the thumbnail image number to retrieve the image file's filename, directory name, and page number
ArrayPageNumber | Retrieves the image file's page number from the thumbnail image specified by the ArrayImageNumber property
BorderColor | Sets the color for the border of the Thumbnail Control
BorderVisible | Sets whether or not the Thumbnail Control border is displayed
BorderWidth | Sets the size of the area between the edge of the Thumbnail Control and the display of the thumbnails
Button3D | Sets whether or not the individual frames of the Thumbnail Control are shown in 3D
Cancel | Sets whether or not the process of displaying images in the Thumbnail Control is canceled
CellSmallMargin | Sets whether to reduce the margin between the displayed thumbnail image and the cell border.
CellSpacing | Sets the amount of space (in pixels) between the thumbnail cells
ClearOnLoad | Sets whether or not previously loaded images are cleared when an image is loaded into the Thumbnail Control
ColumnNumber | Sets the number of columns displayed in the Thumbnail Control
EnableArrowKeys | Sets whether or not the arrow keys and the PageUp, PageDown keys on the keyboard can be used to scroll the images in the Thumbnail Control
EnableMouseMoveButton | Sets whether or not the thumbnail image is selected when the mouse moves over that thumbnail image frame
EnableMouseWheel | Sets whether or not the mouse wheel is enabled
EnableSelectMultiFiles | Sets whether or not multiple thumbnail images can be selected
ErrorStatus | Refers to the types of errors that can occur when using the Thumbnail Control
ExifAutoRotate | Sets whether to automatically adjust and display the direction of photos taken with a smartphone.
FileExtension | Sets the the image type that can be displayed in the Thumbnail Control
FileName | Refers to the filename of the image when the thumbnail image is selected
FilePath | Sets the file path to the directories containing the images
ForeColorDown | Sets the color of the thumbnail image frame when the image is selected
ForeColorUp | Sets the color of the thumbnail frame when the thumbnail image is not selected
Image | Refers to the image handle of the image loaded into the Thumbnail Control
ImageSize | Sets the size of the thumbnail image when it is displayed
ListOfFileNames | Sets the list of file names of the images to be displayed in the Thumbnail control.
LoadMode | Sets how images are loaded and displayed in the Thumbnail Control
PictureDown | Sets a background image displayed on the the display area of the thumbnail image
PictureUp | Sets a background image displayed on the display area of the thumbnail image when the thumbnail has not been clicked
RowNumber | Sets the number of rows displayed in the Thumbnail Control
ScrollBar | Sets whether or not scroll bars are enabled on the Thumbnail Control
ScrollDirection | Sets whether the Thumbnail Control can be scrolled horizontally or vertically
ScrollStep | Sets the size of the scroll step
SelectTextBackColor | Sets the background color of the text (either filename or comment) for the selected thumbnail image
SelectTextColor | Sets the color of the text (either filename or comment) for the selected thumbnail image
SelectTextTransparent | Sets whether or not the transparency is enabled when the filename or comment is displayed in the thumbnail cell that has been selected
ShowFileName | Sets whether or not the file name of the image in the Thumbnail Control is displayed under the image
Sort | Sets the sorting method for the image files contained in the folder(s) specified by the FilePath property
SortDate | Sets how the files will be sorted when the Sort property is set to SortDate
SortOrder | Sets whether the image files set in the FilePath property are sorted in ascending or descending order
StartNumber | Sets the image number of the thumbnail image displayed in the top left corner of the Thumbnail Control
Style | Sets the style of the thumbnail image frame
TextBackColor | Sets the background color for the text (either the filename or comment) for a thumbnail image
TextColor | Sets the color of the text (either the filename or comment) for a thumbnail image
TextTransparent | Sets whether or not the transparency is enabled when the filename or comment is displayed in the thumbnail cell
ThumbnailFile | Sets the thumbnail file used by the Thumbnail Control
TotalImageNumber | Retrieves the total image number of the thumbnail images

Public Methods

Clear | Clears the Thumbnail Control
DeleteImage | Deletes the specified thumbnail image from Thumbnail Control
DeSelectImage | Deselects a thumbnail image that has been selected
Display | Displays the thumbnail images
GetFiles | Acquires the thumbnail image
IsSelected | Determines if the specified thumbnail image is selected
Scroll | Scrolls the thumbnail images
SelectImage | Selects a thumbnail image
SortImage | Sorts images in the Thumbnail Control according to values set in the Sort, SortDate, and SortOrder properties.
UpdateThumbnailFile | Updates the thumbnail file

Public Events

EndLoadFile | Generated after each image is loaded into the Thumbnail Control
MouseMoveOnThumbnail | Generated when the mouse is moved over a thumbnail image in the Thumbnail Control
SelectFile | Generated when a thumbnail image is selected. Thumbnail images can be selected by clicking the mouse, using the keyboard, or executing the SelectImage method
ShowThumbnailImage | Generated just after a thumbnail image is displayed in the Thumbnail Control
StartLoadFile | Generated before each image is loaded on the Thumbnail Control

See Also

Newtone.ImageKit.Win.Thumbnail


ImageKit.Win.Thumbnail Constructor

Newtone.ImageKit.Win.Thumbnail Constructor

This initializes a new instance of the Thumbnail class.

[Visual Basic] Public Sub New()
[C#] public Thumbnail()

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


AllowDrag property

Newtone.ImageKit.Win.Thumbnail.AllowDrag Property

This property sets whether or not a thumbnail image can be moved within the Thumbnail control or dragged from the Thumbnail control into the ImageKit control or into another Thumbnail control.

[Visual Basic] Public Property AllowDrag As Boolean
[C#] public bool AllowDrag {get; set;}

Property Value

Value | Explanation
True | Enables the ability to move a thumbnail images within the Thumbnail control or dragged into the ImageKit control or another Thumbnail control
False | Disables the ability to move thumbnail images within the Thumbnail control or drag images into the ImageKit control or another Thumbnail control (default)

Explanation

The AllowDrag property sets whether or not a thumbnail image can be moved within the Thumbnail control or dragged from the Thumbnail control into the ImageKit control or into another Thumbnail control.

Set this property to True to all an image to be moved within the Thumbnail control or dragged into the ImageKit control or another Thumbnail control.

To enable dropping from another control to the Thumbnail Control, please set the AllowDrop property to True. (AllowDrop is a standard .NET Framework property. See appropriate .NET Framework help for details)

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Appearance property

Newtone.ImageKit.Win.Thumbnail.Appearance Property

This property sets the appearance of the Thumbnail Control.

[Visual Basic] Public Property Appearance As ThumbnailAppearance
[C#] public ThumbnailAppearance Appearance {get; set;}

Property Value

This value is of type ThumbnailAppearance

Explanation

The Appearance property sets the appearance of the Thumbnail Control. The Appearance property is enabled when the BorderVisible property is set to True. When the Appearance property is set to Flat, the border color is determined by the BorderColor property.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ArrayDirectoryName property

Newtone.ImageKit.Win.Thumbnail.ArrayDirectoryName Property

This property retrieves the image file's directory name from the thumbnail image specified by the ArrayImageNumber property.

[Visual Basic] Public ReadOnly Property ArrayDirectoryName As String
[C#] public string ArrayDirectoryName {get;}

Property Value

The name of the directory containing the image file

Explanation

The ArrayDirectoryName property retrieves the image file's directory name from the thumbnail image specified by the ArrayImageNumber property. If the ArrayImageNumber property refers to an image that is not loaded from file, then the ArrayDirectoryName property will be an empty string (String.Empty) or null (in Visual Basic, Nothing).

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ArrayFileName property

Newtone.ImageKit.Win.Thumbnail.ArrayFileName Property

This property retrieves the image file's filename from the thumbnail image specified by the ArrayImageNumber property.

[Visual Basic] Public ReadOnly Property ArrayFileName As String
[C#] public string ArrayFileName {get;}

Property Value

The filename of the image file

Explanation

The ArrayFileName property retrieves the image file's filename from the thumbnail image specified by the ArrayImageNumber property. If the ArrayImageNumber property refers to an image that is not loaded from file, then sequential image numbers are retrieved.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ArrayImageNumber property

Newtone.ImageKit.Win.Thumbnail.ArrayImageNumber Property

This property uses the thumbnail image number to retrieve the image file's filename, directory name, and page number.

[Visual Basic] Public WriteOnly Property ArrayImageNumber As Integer
[C#] public int ArrayImageNumber {set;}

Property Value

The sequential number of the thumbnail image (starts from 1)

Explanation

The ArrayImageNumber property uses the thumbnail image number to retrieve the image file's filename, the path and name of the directory containing the image file, and the image file's page number. By setting the appropriate thumbnail image number in the ArrayImageNumber property, the image file's information will be set in the ArrayFileName, ArrayPageNumber, and ArrayDirectoryName properties.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ArrayPageNumber property

Newtone.ImageKit.Win.Thumbnail.ArrayPageNumber Property

This property retrieves the image file's page number from the thumbnail image specified by the ArrayImageNumber property.

[Visual Basic] Public ReadOnly Property ArrayPageNumber As Integer
[C#] public int ArrayPageNumber {get;}

Property Value

The image file's page number (starts from 0)

Explanation

The ArrayPageNumber property retrieves the image file's page number from the thumbnail image specified by the ArrayImageNumber property. If theArrayImageNumber property refers to an image that is not loaded from file, then the ArrayPageNumber property will be an empty string or 0.

The ArrayPageNumber property is used for multipage image files. If a single page image file is specified then the ArrayPageNumber property will be 0.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


BorderColor property

Newtone.ImageKit.Win.Thumbnail.BorderColor Property

This property sets the color for the border of the Thumbnail Control.

[Visual Basic] Public Property BorderColor As System.Drawing.Color
[C#] public System.Drawing.Color BorderColor {get; set;}

Property Value

BorderColor is the color for the border of the Thumbnail Control. The default value is Color.Black.

Explanation

The BorderColor property sets the color for the border of the Thumbnail Control. To set color, please use the appropriate RGB(Red, Green, Blue) value. The BorderColor property is enable when the Appearance property is Flat and the BorderVisible property is True.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


BorderVisible property

Newtone.ImageKit.Win.Thumbnail.BorderVisible Property

This property sets whether or not the Thumbnail Control border is displayed.

[Visual Basic] Public Property BorderVisible As Boolean
[C#] public bool BorderVisible {get; set;}

Property Value

Value | Explanation
True | The border is displayed
False | The border is not displayed (default)

Explanation

The BorderVisible property sets whether or not the Thumbnail Control border is displayed.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


BorderWidth property

Newtone.ImageKit.Win.Thumbnail.BorderWidth Property

This property sets the size of the area between the edge of the Thumbnail Control and the display of the thumbnails.

[Visual Basic] Public Property BorderWidth As Integer
[C#] public int BorderWidth {get; set;}

Property Value

The size of the area between the edge of the Thumbnail Control and the display of the thumbnails.

The default value is 5.

Explanation

The BorderWidth property sets the size of the area between the edge of the Thumbnail Control and the display of the thumbnails.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Button3D property

Newtone.ImageKit.Win.Thumbnail.Button3D Property

This property sets whether or not the individual cells of the Thumbnail Control are shown in 3D.

[Visual Basic] Public Property Button3D As Boolean
[C#] public bool Button3D {get; set;}

Property Value

Value | Explanation
True | Displays the cells of the thumbnail control as 3D (default)
False | Displays the cells of the thumbnail control as flat

Explanation

The Button3D property sets whether or not the individual cells of the Thumbnail Control are shown in 3D. This property is enabled when the Style property is Button.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Cancel property

Newtone.ImageKit.Win.Thumbnail.Cancel Property

This property sets whether or not the process of displaying images in the Thumbnail Control is canceled.

[Visual Basic] Public WriteOnly Property Cancel As Boolean
[C#] public bool Cancel {set;}

Property Value

Value | Explanation
True | Cancels the process
False | Does not cancel the process (default)

Explanation

The Cancel property sets whether or not the process of displaying images in the Thumbnail Control is canceled. To cancel, set this property to True.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


CellSmallMargin property

Newtone.ImageKit.Win.Thumbnail.CellSmallMargin Property

This property sets whether to reduce the margin between the displayed thumbnail image and the cell border.

[Visual Basic] Public Property CellSmallMargin As Boolean
[C#] public bool CellSmallMargin {get; set;}

Property Value

Value | Explanation
True | The marging is reduced
False | The margin is not reduced (default)

Explanation

The CellSmallMargin property sets whether to reduce the margin between the displayed thumbnail image and the cell border.

When set to true, the space around the thumbnail image of each cell is reduced. However, this is not applicable when the Style property is set to Film.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


CellSpacing property

Newtone.ImageKit.Win.Thumbnail.CellSpacing Property

This property sets the amount of space between thumbnail cells.

[Visual Basic] Public Property CellSpacing As Integer
[C#] public int CellSpacing {get; set;}

Property Value

The number of pixels between thumbnail cells

The default value is 5.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ClearOnLoad property

Newtone.ImageKit.Win.Thumbnail.ClearOnLoad Property

This property sets whether or not previously loaded images are cleared when an image is loaded into the Thumbnail Control.

[Visual Basic] Public Property ClearOnLoad As Boolean
[C#] public bool ClearOnLoad {get; set;}

Property Value

Value | Explanation
True | When an image is loaded, the previously loaded image is cleared (default)
False | When an image is loaded, the previously loaded image is not cleared

Explanation

The ClearOnLoad property sets whether or not previously loaded images are cleared when an image is loaded into the Thumbnail Control. True is the default value. When False, the image loaded is added to the previously loaded images. A good example of when to use this property is when using an ADF to continuously scan images or when retrieving multiple images, one by one, from a datasource.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ColumnNumber property

Newtone.ImageKit.Win.Thumbnail.ColumnNumber Property

This property sets the number of columns displayed in the Thumbnail Control.

[Visual Basic] Public Property ColumnNumber As Integer
[C#] public int ColumnNumber {get; set;}

Property Value

The ColumnNumber sets the number of columns displayed (1 or more)

The default value is 2.

Explanation

The ColumnNumber property sets the number of columns displayed in the Thumbnail Control. The ColumnNumber and RowNumber properties determine the total number of images displayed at one time as thumbnails.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


EnableArrowKeys property

Newtone.ImageKit.Win.Thumbnail.EnableArrowKeys Property

This property sets whether or not the arrow keys and the PageUp, PageDown keys on the keyboard can be used to scroll the images in the Thumbnail Control.

[Visual Basic] Public Property EnableArrowKeys As Boolean
[C#] public bool EnableArrowKeys {get; set;}

Property Value

Value | Explanation
True | The arrow keys and the PageUp and PageDown keys are enabled
False | The arrow keys and the PageUp and PageDown keys are disabled

Explanation

The EnableArrowKeys property sets whether or not the arrow keys and the PageUp, PageDown keys on the keyboard can be used to scroll the images in the Thumbnail Control.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


EnableMouseMoveButton property

Newtone.ImageKit.Win.Thumbnail.EnableMouseMoveButton Property

This property sets whether or not the thumbnail image is selected when the mouse moves over that thumbnail image frame.

[Visual Basic] Public Property EnableMouseMoveButton As Boolean
[C#] public bool EnableMouseMoveButton {get; set;}

Property Value

Value | Explanation
True | The thumbnail image frame is selected on mouse over
False | The thumbnail image frame is not selected on mouse over (default)

Explanation

The EnableMouseMoveButton property sets whether or not the thumbnail image is selected when the mouse moves over that thumbnail image frame.

Note that when the mouse moves over the thumbnail, this does not generate the SelectFile event even though the thumbnail image is selected. When the EnableMouseMoveButton property is set to True, it is still possible to click the thumbnail image or use the keyboard which will generate the SelectFile event.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


EnableMouseWheel property

Newtone.ImageKit.Win.Thumbnail.EnableMouseWheel Property

This property sets whether or not the mouse wheel is enabled.

[Visual Basic] Public Property EnableMouseWheel As Boolean
[C#] public bool EnableMouseWheel {get; set;}

Property Value

Value | Explanation
True | Mouse wheel is enabled
False | Mouse wheel is disabled (default)

Explanation

The EnableMouseWheel property sets whether or not the mouse wheel is enabled.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


EnableSelectMultiFiles property

Newtone.ImageKit.Win.Thumbnail.EnableSelectMultiFiles Property

This property sets whether or not multiple thumbnail images can be selected.

[Visual Basic] Public Property EnableSelectMultiFiles As Boolean
[C#] public bool EnableSelectMultiFiles {get; set;}

Property Value

Value | Explanation
True | Multiple thumbnail images can be selected
False | Single thumbnail images can be selected (default)

Explanation

The EnableSelectMultiFiles property sets whether or not multiple thumbnail images can be selected.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ErrorStatus property

Newtone.ImageKit.Win.Thumbnail.ErrorStatus Property

This property refers to the types of errors that can occur when using the Thumbnail Control.

[Visual Basic] Public ReadOnly Property ErrorStatus As Newtone.ImageKit.Error
[C#] public Newtone.ImageKit.Error ErrorStatus {get;}

Property Value

Read only

The value is of type Error.

Explanation

The ErrorStatus property refers to the types of errors that can occur when using the Thumbnail Control.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ExifAutoRotate property

Newtone.ImageKit.Win.Thumbnail.ExifAutoRotate Property

This property sets whether to automatically adjust and display the direction of photos taken with a smartphone.
[Visual Basic] Public Property ExifAutoRotate As Boolean
[C#] public bool ExifAutoRotate {get; set;}

Property Value

Value | Explanation
True | Adjusts the orientation automatically
False | Display in the original orientation. (Default)

Explanation

The ExifAutoRotate property sets whether to automatically adjust and display the direction of photos taken with a smartphone.

When this property is True, the orientation of the photo taken with a smartphone or digital camera is automatically adjusted and displayed based on the information of MainOrientation of Exif.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


FileExtension property

Newtone.ImageKit.Win.Thumbnail.FileExtension Property

This property sets the image type that can be displayed in the Thumbnail Control.

[Visual Basic] Public Property FileExtension As String
[C#] public string FileExtension {get; set;}

Property Value

String value denoting the file extention

Explanation

The FileExtension property sets the image type that can be displayed in the Thumbnail Control. This property is enabled when the FilePath property is not an empty string or null (Nothing in Visual Basic). When setting multiple image file types in the FileExtension property, separate the entries with a semicolon. Note: The FileExtension property is not case sensitive so "BMP" and "bmp" are treated as identical.

Example

Thumbnail1.FileExtension = "BMP;JPG;PNG;"

This will load all JPEG and PNG files and BMP files from the specifed directory.

When using a wildcard, you cannot set the same file extension twice. So Thumbnail1.FileExtension = "*.bmp;001.bmp" will result in an error. You must enter either "*1.bmp" or "001.bmp".

Example

Correct: Thumbnail1.FileExtension = "002.bmp;001.bmp"

Incorrect: Thumbnail1.FileExtension = "*.bmp;001.bmp"

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


FileName property

Newtone.ImageKit.Win.Thumbnail.FileName Property

This property refers to the filename of the image when the thumbnail image is selected.

[Visual Basic] Public ReadOnly Property FileName As String
[C#] public string FileName {get;}

Property Value

The image file name

Explanation

The FileName property refers to the filename of the image when the thumbnail image is selected. A thumbnail image can be selected using a mouse click, the keyboard, the SelectImage method, the SelectFile or MouseMoveOnThumbnail events (When EnableMouseMoveButton property is true.

Note: if more than one thumbnail are selected at the same time, the FileName property will contain the filename of the last image in that group of selected images.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


FilePath property

Newtone.ImageKit.Win.Thumbnail.FilePath Property

This property sets the file path to the directories containing images to be displayed in the Thumbnail Control.

[Visual Basic] Public Property FilePath As String
[C#] public string FilePath {get; set;}

Property Value

A string value denoting the path to the image files

Default value is an empty string (String.Empty)

Explanation

The FilePath property sets the file path to the directories containing images to be displayed in the Thumbnail Control. When setting multiple directories in the FilePath property, please separate the entries with a semicolon. Which image file will be displayed is determined by this property and the FileExtension property. If you want to specify the files within a folder that you want to display, you can use the ListOfFileNames property to set those files. In that case, set the FilePath property to an empty string (String.Empty) or null (Nothing in Visual Basic)

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ForeColorDown property

Newtone.ImageKit.Win.Thumbnail.ForeColorDown Property

This property sets the color of the thumbnail image cell when the image is selected.

[Visual Basic] Public Property ForeColorDown As System.Drawing.Color
[C#] public System.Drawing.Color ForeColorDown {get; set;}

Property Value

The color of the thumbnail cell

The default value is Color.Gray.

Explanation

The ForeColorDown property sets the color of the thumbnail image cell when the image is selected. To set the color, please use an RGB(Red, Green, Blue) value. This property is enabled when the Style property is set to Button or Film.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ForeColorUp property

Newtone.ImageKit.Win.Thumbnail.ForeColorUp Property

This property sets the color of the thumbnail cell when the thumbnail image is not selected (default color).

[Visual Basic] Public Property ForeColorUp As System.Drawing.Color
[C#] public System.Drawing.Color ForeColorUp {get; set;}

Property Value

The color of the thumbnail cell (default color)

The default value is Color.Gainsboro.

Explanation

The ForeColorUp property sets the color of the thumbnail cell when the thumbnail image is not selected (default color). To set the color, please use am RGB(Red, Green, Blue) value. This property is enabled when the Style property is set to Button or Film.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Image property

Newtone.ImageKit.Win.Thumbnail.Image Property

This property refers to the image handle of the image loaded into the Thumbnail Control

[Visual Basic] Public WriteOnly Property Image As System.Drawing.Image
[C#] public System.Drawing.Image Image {set;}

Property Value

The Image object

Explanation

The Image property refers to the image handle of the image loaded into the Thumbnail Control. This property is used, for example, to display the results of continuous scanning as thumbnail images.

Example

[Visual Basic.NET]
Private Sub ImageKit1_AfterScan(ByVal sender As Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs) Handles ImageKit.AfterScan
    If e.Bitmap1 = Nothing Then Exit Sub
    Thumbnail1.Image = e.Bitmap1.Clone()
End Sub

[Visual C#.NET]
private void ImageKit1_AfterScan(object sender, Newtone.ImageKit.AfterScanEventArgs e)
{
    if (e.Bitmap1 == null) return;
    Thumbnail1.Image = e.Bitmap1.Clone();
}

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ImageSize property

Newtone.ImageKit.Win.Thumbnail.ImageSize Property

This property sets the size of the thumbnail image when it is displayed.

[Visual Basic] Public Property ImageSize As Integer
[C#] public int ImageSize {get; set;}

Property Value

The size of the thumbnail image in pixels

The default size is 96

Explanation

The ImageSize property sets the size of the thumbnail image when it is displayed. The length or width dimension (whichever is larger) of the original image is set to the size specified in this property and the other dimension is scaled in size.

Note: the available display area of the thumbnail control determines the maximum value of the ImageSize property. Setting the ImageSize property to values larger than the area available to display the thumbnail image will have no effect.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ListOfFileNames property

Newtone.ImageKit.Win.Thumbnail.ListOfFileNames Property

This property sets the list of file names of the images to be displayed in the Thumbnail control.

[Visual Basic] Public Property ListOfFileNames As String
[C#] public string ListOfFileNames {get; set;}

Property Value

The list of FileNames (One filename is possible)

Default value is null (Nothing in Visual Basic)

Explanation

The ListOfFileNames property the list of file names of the images to be displayed in the Thumbnail control.

Use this property to set specified image files from multiple folders or specific image files from a single folder. To use the ListOfFileNames property, set an empty string (String.Empty) or null (Nothing in Visual Basic) in the FilePath property. When the ListOfFileNames property is enabled, the FileExtension property will be ignored. NOTE: The full path or absolute path to the image files must be set in the ListOfFileNames property.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


LoadMode property

Newtone.ImageKit.Win.Thumbnail.LoadMode Property

This property sets how images are loaded and displayed in the Thumbnail Control.

[Visual Basic] Public Property LoadMode As ThumbnailLoadMode
[C#] public ThumbnailLoadMode LoadMode {get; set;}

Property Value

This value is of type ThumbnailLoadMode

Explanation

The LoadMode property sets how images are loaded and displayed in the Thumbnail Control. When the LoadMode property is set to LoadFile or LoadMulti , the GetFiles method loads the appropriate file from the folder set in the FilePath property or the ListOfFileNames property into the memory. The Display method displays the file on the control.

When the LoadMode property is set to LoadFileDisplay or LoadMultiDisplay, by executing the Display method, the appropriate files from folders set in the FilePath property or the ListOfFileNames property are displayed on the control while they are being loaded.

* Multi-image is only for GIF and TIFF.

When the LoadMode property is set to "LoadImageProperty", by executing the Display method, the image set in the Image property is displayed on the control. In order to display multiple images at once, please set the ClearOnLoad property to False and set each memory handle to the Image property.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


PictureDown property

Newtone.ImageKit.Win.Thumbnail.PictureDown Property

This property sets a background image displayed on the display area of the thumbnail image.

[Visual Basic] Public Property PictureDown As System.Drawing.Image
[C#] public System.Drawing.Image PictureDown {get; set;}

Property Value

The background image displayed on the thumbnail image

The default value is null (in Visual Basic, Nothing)

Explanation

The PictureDown property sets a background image displayed on the display area of the thumbnail image (the black portions of the display area) when the mouse is clicked. This property could be used to create the effect of window blinds being opened to reveal a thumbnail image when the mouse is clicked on that thumbnail image frame.

This property is enabled when the Style property is Custom. The black RGB(0,0,0) portions of the background image is set as a transparent color. The thumbnail image will be displayed through this portion of the background image.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


PictureDown property

Newtone.ImageKit.Win.Thumbnail.PictureUp Property

This property sets a background image displayed on the display area of the thumbnail image when the thumbnail has not been clicked.

[Visual Basic] Public Property PictureUp As System.Drawing.Image
[C#] public System.Drawing.Image PictureDown {get; set;}

Property Value

The background image displayed on the thumbnail image when the thumbnail hasn't been clicked

The default value is null (in Visual Basic, Nothing)

Explanation

The PictureUp property sets a background image displayed on the the display area of the thumbnail image (the black portions of the display area) when the thumbnail hasn't been clicked. This property could be used to create the effect of window blinds being opened to reveal a thumbnail image when the mouse is clicked on that thumbnail image frame.

This property is enabled when the Style property is Custom. The black RGB(0,0,0) portions of the foreground image is set as a transparent color. The thumbnail image will be displayed through this portion of the background image.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


RowNumber property

Newtone.ImageKit.Win.Thumbnail.RowNumber Property

This property sets the number of rows displayed in the Thumbnail Control.

[Visual Basic] Public Property RowNumber As Integer
[C#] public int RowNumber {get; set;}

Property Value

The number of rows displayed (1 or more)

The default value is 2

Explanation

The RowNumber property sets the number of rows displayed in the Thumbnail Control. The RowNumber and ColumnNumber properties determine the total number of images displayed at one time as thumbnails.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ScrollBar property

Newtone.ImageKit.Win.Thumbnail.ScrollBar Property

This property sets whether or not scroll bars are enabled in the Thumbnail Control.

[Visual Basic]Public Property ScrollBar As Boolean
[C#]public bool ScrollBar {get; set;}

Property Value

Value | Explanation
True | Scroll bars are enabled in the Thumbnail Control (default)
False | Scroll bars are not enabled in the Thumbnail Control

Explanation

The ScrollBar property sets whether or not scroll bars are enabled in the Thumbnail Control.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ScrollDirection property

Newtone.ImageKit.Win.Thumbnail.ScrollDirection Property

This property sets whether the Thumbnail Control can be scrolled horizontally or vertically.

[Visual Basic]Public Property ScrollDirection As ThumbnailScrollDirection
[C#]public ThumbnailLoadMode ScrollDirection {get; set;}

Property Value

This value is of type ThumbnailScrollDirection

Explanation

The ScrollDirection property sets whether the Thumbnail Control can be scrolled horizontally or vertically. If set to Horizontal, the thumbnail control can be scrolled horizontally. If set to Vertical, the Thumbnail Control can be scrolled vertically.

Note: If set to Vertical, the thumbnail images are displayed horizontally (starting from top left toward right). If set to Horizontal, the thumbnail images are displayed vertically (starting from top left downwards).

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ScrollStep property

Newtone.ImageKit.Win.Thumbnail.ScrollStep Property

This property sets the size of the scroll step.

[Visual Basic]Public Property ScrollStep As Integer
[C#]public int ScrollStep {get; set;}

Property Value

The scroll size for Thumbnail Control in number of rows or columns

The default value is 1

Explanation

The ScrollStep property sets the size of the scroll step for the Thumbnail Control. By setting this property to positive values, the scroll moves forward, by setting it to negative values, the scroll moves backward. The ScrollDirection property determines if the scroll moves horizontally or vertically.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SelectTextBackColor property

Newtone.ImageKit.Win.Thumbnail.SelectTextBackColor Property

This property sets the background color of the text (either filename or comment) for the selected thumbnail image.

[Visual Basic]Public Property SelectTextBackColor As System.Drawing.Color
[C#]public System.Drawing.Color SelectTextBackColor {get; set;}

Property Value

The background color of the text

The default value is Color.White

Explanation

The SelectTextBackColor property sets the background color of the text (either filename or comment) for the selected thumbnail image.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SelectTextColor property

Newtone.ImageKit.Win.Thumbnail.SelectTextColor Property

This property sets the color of the text (either filename or comment) for the selected thumbnail image.

[Visual Basic]Public Property SelectTextColor As System.Drawing.Color
[C#]public System.Drawing.Color SelectTextColor {get; set;}

Property Value

The color of the text

The default value is Color.Black

Explanation

The SelectTextColor property sets the color of the text (either filename or comment) for the selected thumbnail image.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SelectTextTransparent property

Newtone.ImageKit.Win.Thumbnail.SelectTextTransparent Property

This property sets whether or not transparency is enabled when the filename or comment is displayed in the selected thumbnail cell.

[Visual Basic]Public Property SelectTextTransparent As Boolean
[C#]public bool SelectTextTransparent {get; set;}

Property Value

Value | Explanation
True | Transparency is enabled (default)
False | Transparency is disabled

Explanation

The SelectTextTransparent property sets whether or not transparency is enabled when the filename or comment is displayed in the selected thumbnail cell. When this property is True, the background color set in the SelectTextBackColor property will be transparent.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ShowFileName property

Newtone.ImageKit.Win.Thumbnail.ShowFileName Property

This property sets whether or not the filename or comment is displayed under the thumbnail image in the Thumbnail Control.

[Visual Basic]Public Property ShowFileName As Boolean
[C#]public bool ShowFileName {get; set;}

Property Value

Value | Explanation
True | Displays the filename or comment
False | Does not display the filename or comment (default)

Explanation

The ShowFileName property sets whether or not the filename or comment is displayed under the thumbnail image in the Thumbnail Control. If this property is True, the filename is displayed under the thumbnail image. In order to display a comment under the thumbnail image, you must set this property to true, then in the ShowThumbnailImage event, set the comment that you would like to display in the Text property.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Sort property

Newtone.ImageKit.Win.Thumbnail.Sort Property

This property sets the sorting method for the image files contained in the folder(s) specified by the FilePath property.

[Visual Basic]Public Property Sort As ThumbnailSort
[C#]public ThumbnailSort Sort {get; set;}

Property Value

This value is of type ThumbnailSort

Explanation

The Sort property sets the sorting method for the image files contained in the folder(s) specified by the FilePath property. The files will be sorted according to the value set in the SortDate property.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SortDate property

Newtone.ImageKit.Win.Thumbnail.SortDate Property

This property sets how the files will be sorted when the Sort property is set to Date.

[Visual Basic]Public Property SortDate As ThumbnailSortDate
[C#]public ThumbnailSortDate SortDate {get; set;}

Property Value

This value is of type ThumbnailSortDate

Explanation

The SortDate property sets how the files will be sorted when the Sort property is set to Date.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SortOrder property

Newtone.ImageKit.Win.Thumbnail.SortOrder Property

This property sets whether the image files specified by the FilePath property and in the ListOfFileNames property are sorted in ascending or descending order.

[Visual Basic]Public Property SortOrder As ThumbnailSortOrder
[C#]public ThumbnailSortOrder SortOrder {get; set;}

Property Value

This value is of type System.Windows.Forms.SortOrder

Explanation

The SortOrder property sets whether the image files specified by the FilePath property and in the ListOfFileNames property are sorted in ascending or descending order.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


StartNumber property

Newtone.ImageKit.Win.Thumbnail.StartNumber Property

This property uses the image number to set the thumbnail image displayed in the top left corner of the Thumbnail Control.

[Visual Basic]Public Property StartNumber As Integer
[C#]public int StartNumber {get; set;}

Property Value

The image number of the thumbnail image displayed in the top left corner of the Thumbnail Control (image numbers start from 0)

The default value is 0

Explanation

The StartNumber property uses the image number to set the thumbnail image displayed in the top left corner of the Thumbnail Control. Note that if you set a number that cannot be evenly divided by the ColumnNumber property or the RowNumber property the nearest value that is divisible will be used.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Style property

Newtone.ImageKit.Win.Thumbnail.Style Property

This property sets the style of the thumbnail image cell.

[Visual Basic]Public Property Style As ThumbnailStyle
[C#]public ThumbnailStyle Style {get; set;}

Property Value

This value is of type ThumbnailStyle

Explanation

The Style property sets the style of the thumbnail image cell. Changes to the Style property during execution are not enabled until the Display method is executed. If set to Custom, the Image object must be set in the PictureDown or PictureUp property.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


TextBackColor property

Newtone.ImageKit.Win.Thumbnail.TextBackColor Property

This property sets the background color for the text (either the filename or comment) for a thumbnail image.

[Visual Basic] Public Property TextBackColor As System.Drawing.Color
[C#] public System.Drawing.Color TextBackColor {get; set;}

Property Value

The background color of the text

The default value is Color.White

Explanation

The TextBackColor property sets the background color for the text (either the filename or comment) for a thumbnail image.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


TextColor property

Newtone.ImageKit.Win.Thumbnail.TextColor Property

This property sets the color of the text (either the filename or comment) for a thumbnail image.

[Visual Basic]Public Property TextColor As System.Drawing.Color
[C#]public System.Drawing.Color TextColor {get; set;}

Property Value

The color of the text

The default value is Color.Black

Explanation

The TextColor property sets the color of the text (either the filename or comment) for a thumbnail image.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


TextTransparent property

Newtone.ImageKit.Win.Thumbnail.TextTransparent Property

This property sets whether or not transparency is enabled when the filename or comment is displayed in the thumbnail cell.

[Visual Basic]Public Property TextTransparent As Boolean
[C#]public bool TextTransparent {get; set;}

Property Value

Value | Explanation
True | Transparency is enabled (default)
False | Transparency is disabled

Explanation

The TextTransparent property sets whether or not transparency is enabled when the filename or comment is displayed in the thumbnail cell. When this property is True, the background color set in the TextBackColor property will be transparent.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailFile property

Newtone.ImageKit.Win.Thumbnail.ThumbnailFile Property

This property sets the thumbnail file used by the Thumbnail Control.

[Visual Basic]Public Property ThumbnailFile As String
[C#]public string ThumbnailFile {get; set;}

Property Value

The thumbnail file name (full path)

Explanation

The ThumbnailFile property sets the thumbnail file used by the Thumbnail Control. By setting the filename and path in this property, the thumbnail control creates a thumbnail.dat file that is used to make subsequent loading of the thumbnail images faster. The Thumbnail file will load the images in the folders specified by the FilePath property. If the FilePath property is changed be sure to change the ThumbnailFile property accordingly.

To display only the images set in the ListOfFileNames property (to not display other images that may be set in the ThumbnailFile property), set the ThumbnailFile property to an empty string (String.Empty) or null (Nothing in Visual Basic).

This property is not compatible with the ImageKit ActiveX or VCL thumbnail file.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


TotalImageNumber property

Newtone.ImageKit.Win.Thumbnail.TotalImageNumber Property

This property retrieves the total number of thumbnail images.

[Visual Basic]Public ReadOnly Property TotalImageNumber As Integer
[C#]public int TotalImageNumber {get;}

Property Value

Total number of thumbnail images

Explanation

The TotalImageNumber property retrieves the total number of thumbnail images.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Clear method

Newtone.ImageKit.Win.Thumbnail.Clear Method

This method clears the Thumbnail Control.

[Visual Basic] Public Sub Clear()
[C#] public void Clear();

Return Value

None

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


DeleteImage method

Newtone.ImageKit.Win.Thumbnail.DeleteImage Method

This method deletes the specified thumbnail image from Thumbnail Control.

[Visual Basic] Public Function DeleteImage(imageNumber As Integer) As Boolean
[C#] public bool DeleteImage(int imageNumber);

Parameters

imageNumber
The sequential number of the thumbnail image (starts from 1)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DeleteImage method deletes the specified thumbnail image from Thumbnail Control (the actual file remains). If you don't want to display the thumbnail image next time (ex. when reloading it), please delete the actual file after executing this method and when the return value is True.

By setting the sequential number of the thumbnail image into the ArrayImageNumber property prior to executing this method, the actual filename will be set in the ArrayFileName, ArrayPageNumber, and ArrayDirectoryName properties.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


DeSelectImage method

Newtone.ImageKit.Win.Thumbnail.DeSelectImage Method

This method deselects a thumbnail image that has been selected.

[Visual Basic] Public Function DeSelectImage(imageNumber As Integer) As Boolean
[C#] public bool DeSelectImage(int imageNumber);

Parameters

imageNumber
The sequential number of the thumbnail image (starts from 1)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DeSelectImage method deselects a thumbnail image that has been selected. Thumbnail images can be selected with a mouse click, the keyboard, or the SelectImage method.

If no thumbnail image has been selected, executing the DeSelectImage method will not do anything. By setting the ImageNumber parameter value in the ArrayImageNumber property, the ArrayFileName, ArrayPageNumber, and ArrayDirectoryName properties can be retrieved.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Display method

Newtone.ImageKit.Win.Thumbnail.Display Method

This method displays the thumbnail images.

[Visual Basic] Public Function Display() As Boolean
[C#] public bool Display();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Display method displays the thumbnail images. To execute this method, it is necessary to first execute the GetFiles method to retrieve the data from the image files that will be displayed as thumbnails. The ColumnNumber and RowNumber properties must also be set.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


GetFiles method

Newtone.ImageKit.Win.Thumbnail.GetFiles Method

This method acquires the thumbnail image.

[Visual Basic] Public Function GetFiles() As Boolean
[C#] public bool GetFiles();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetFiles method acquires the thumbnail image. To execute this method, it is necessary to set LoadMode property and the following properties:

To use the folder name and file extension | Set the FilePath and the FileExtension properties
To set specific file names from one or more folders | Set the ListOfFileNames property and set a empty string (String.Empty) or null (Nothing in Visual Basic) into the FilePath property

Note: If the Thumbnail file (see ThumbnailFile property) does not exist or is not being used to retrieve thumbnail images, then the Sort, SortDate, and SortOrder properties can be used to sort thumbnail images in the Thumbnail Control

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


IsSelected method

Newtone.ImageKit.Win.Thumbnail.IsSelected Method

This method determines if the specified thumbnail image is selected.

[Visual Basic] Public Function IsSelected(imageNumber As Integer) As Boolean
[C#] public bool IsSelected(int imageNumber);

Parameters

imageNumber
The sequential number of the thumbnail image (starts from 1)

Return Value

Returns True if successful. Returns False when the thumbnail is not selected or the method is not successful.

Explanation

The IsSelected method determines if the specified thumbnail image is selected. This method is used to retrieve information about a thumbnail image that has been selected by the mouse, by the keyboard, or by the SelectImage method. By passing the value returned in the ImageNumber parameter of this method to the ArrayImageNumber property, the image filename, page number (for multi-page images), and full path can be retrieved from the ArrayFileName, ArrayPageNumber, and ArrayDirectoryName properties.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Scroll method

Newtone.ImageKit.Win.Thumbnail.Scroll Method

This method scrolls the thumbnail images.

[Visual Basic] Public Function Scroll() As Boolean
[C#] public bool Scroll();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Scroll method scrolls the thumbnail images. The size of the scroll steps depends on the value set in the ScrollStep property and the direction of the scroll depends on the value set in the ScrollDirection property. To execute this method, the appropriate values must be set in the ScrollStep and ScrollDirection properties.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SelectImage method

Newtone.ImageKit.Win.Thumbnail.SelectImage Method

This method selects a thumbnail image.

[Visual Basic] Public Function SelectImage(imageNumber As Integer) As Boolean
[C#] public bool SelectImage(int imageNumber);

Parameters

imageNumber
The sequential number of the thumbnail image (starts from 1)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SelectImage method selects a thumbnail image. When the EnableSelectMultiFiles property is False, the last selected thumbnail image is selected, all previously selected thumbnail images will be deselected. By setting the ImageNumber parameter value in the ArrayImageNumber property, the ArrayFileName, ArrayPageNumber, and ArrayDirectoryName properties can be retrieved.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SortImage method

Newtone.ImageKit.Win.Thumbnail.SortImage Method

This method sorts the thumbnail image files according to the values set in the Sort, SortDate, and SortOrder properties.

[Visual Basic] Public Function SortImage() As Boolean
[C#] public bool SortImage();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SortImage method sorts the thumbnail image files according to the values set in the Sort, SortDate, and SortOrder properties.

When executing this method, be sure the appropriate values are set in the Sort, SortDate, and SortOrder properties. This may be useful after images have been dragged from Explorer into the Thumbnail Control or when loading images into the Thumbnail Control using the GetFiles method. If you have moved files within the Thumbnail Control or loaded files using the ThumbnailFile, then executing the SortImage method may change the order in which the thumbnails appear in the Thumbnail Control.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


UpdateThumbnailFile method

Newtone.ImageKit.Win.Thumbnail.UpdateThumbnailFile Method

This method updates the thumbnail file.

[Visual Basic] Public Sub UpdateThumbnailFile()
[C#] public void UpdateThumbnailFile();

Return Value

None

Explanation

The UpdateThumbnailFile method updates the thumbnail file set in the ThumbnailFile property. Please execute this method when the FilePath property is changed to display thumbnails from a different directory or when the thumbnail program is finished, etc. Also, the thumbnail image set in the Image property is not set in the thumbnail file.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


EndLoadFile event

Newtone.ImageKit.Win.Thumbnail.EndLoadFile Event

This event is generated after each image is loaded into the Thumbnail Control.

[Visual Basic] Public Event EndLoadFile As ThumbnailLoadEventHandler
[C#] public event ThumbnailLoadEventHandler EndLoadFile;

Event Data

The event handler retrieves arguments of type ThumbnailLoadEventArgs

Explanation

The EndLoadFile event is generated after each image is loaded into the Thumbnail Control. Note: This event is NOT generated if a thumbnail file (ThumbnailFile property) is used to load the images. To cancel processing in the thumbnail control, set the Cancel property to True within this event.

Information about files loaded during this event can be referred to within the ThumbnailLoadEventArgs arguments.

Regarding properties for the ThumbnailLoadEventArgs class

If an image is unable to be loaded, the ImageNumber parameter will be 0. When multi-page image files are loaded, the page number is appended to the FileName parameter (If the page number is 0 then it is omitted).

Example: When page 2 of the file ABC.TIF is loaded into the Thumbnail Control, the FileName parameter will return the string "ABC.TIF 2".

Example

Displays some information about images loaded.

[Visual Basic.NET]
Private Sub Thumbnail1_EndLoadFile(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ThumbnailLoadEventArgs) Handles Thumbnail1.EndLoadFile
    Label1.Text = e.ImageNumber.ToString() + " / " + e.TotalImageNumber.ToString();
End Sub

[Visual C#.NET]
private void thumbnail1_EndLoadFile(object sender, Newtone.ImageKit.Win.ThumbnailLoadEventArgs e)
{
    label1.Text = e.ImageNumber.ToString() + " / " + e.TotalImageNumber.ToString();
}

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


MouseMoveOnThumbnail event

Newtone.ImageKit.Win.Thumbnail.MouseMoveOnThumbnail Event

This event is generated when the mouse is moved over a thumbnail image in the Thumbnail Control.

[Visual Basic] Public Event MouseMoveOnThumbnail As ThumbnailEventHandler
[C#] public event ThumbnailEventHandler MouseMoveOnThumbnail;

Event Data

The event handler retrieves arguments of type ThumbnailEventArgs

Explanation

The MouseMoveOnThumbnail event is generated when the mouse is moved over a thumbnail image in the Thumbnail Control. If the thumbnail image is not completely displayed on the thumbnail control then this event is not generated or if the AllowDrag property is true and the thumbnail image is being dragged within the Thumbnail Control.

Information about files loaded during this event can be referred to within the ThumbnailLoadEventArgs arguments.

Regarding properties for the ThumbnailEventArgs class

When the thumbnail image isn't displayed into the thumbnail frame that was moved over with the mouse, the DirectoryName and FileName parameters will return an empty string (String.Empty) and the ImageNumber and the PageNumber will return -1.

When multi-page image files are loaded, the page number is appended to the FileName parameter (If the page number is 0 then it is omitted).

Example: When page 2 of the file ABC.TIF is loaded into the thumbnail control, the FileName parameter will return the string "ABC.TIF 2"

Example

Displays the filename of the destination cell

[Visual Basic.NET]
Private Sub
Thumbnail1_MouseMoveOnThumbnail(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ThumbnailEventArgs) Handles Thumbnail1.MouseMoveOnThumbnail If e.ImageNumber
    = -1 Then Exit Sub ' disabled  cell Label1.Text
    = e.FileName; End
Sub [Visual

C#.NET] private
void thumbnail1_MouseMoveOnThumbnail(object sender, Newtone.ImageKit.Win.ThumbnailEventArgs e) {
if
    (e.ImageNumber == -1) return; //  disabled cell
    label1.Text = e.FileName;
}

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SelectFile event

Newtone.ImageKit.Win.Thumbnail.SelectFile Event

This event is generated when a thumbnail image is selected. Thumbnail images can be selected by clicking the mouse, using the keyboard, or executing the SelectImage method.

[Visual Basic] Public Event SelectFile As ThumbnailEventHandler
[C#] public event ThumbnailEventHandler SelectFile;

Event Data

The event handler retrieves arguments of type ThumbnailEventArgs

Explanation

The SelectFile event is generated when a thumbnail image is selected. Thumbnail images can be selected by clicking the mouse, using the keyboard, or executing the SelectImage method. If the thumbnail image is not displayed on the Thumbnail Control then this event is not generated.

By pressing the Ctrl key while clicking with the mouse, several thumbnails can be selected or deselected. In either case, this event is generated. To determine whether or not a particular thumbnail image is selected, please use the IsSelected method.

Thumbnail images can be selected by clicking the mouse, using the keyboard, or executing the SelectImage method. By pressing the Shift key while clicking with the mouse, a series of thumbnails can be selected. This event is generated multiple times for each thumbnail image that has been selected.

Information about files loaded during this event can be referred to within the ThumbnailLoadEventArgs arguments.

Regarding the properties for the ThumbnailEventArgs class

If the selected thumbnail frame has no thumbnail displayed then the DirectoryName and FileName parameters will contain empty strings (String.Empty) and the ImageNumber and PageNumber parameter will return -1. When multi-page image files are loaded, the page number is appended to the FileName parameter (If the page number is 0 then it is omitted).

Example: When page 2 of the file ABC.TIF is loaded into the thumbnail control, the FileName parameter will return the string "ABC.TIF 2".

Example

Displays the filename of the selected thumbnail

[Visual Basic.NET]
Private Sub Thumbnail1_SelectFile(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ThumbnailEventArgs) Handles Thumbnail1.SelectFile
    If e.ImageNumber = -1 Then Exit Sub  ' disabled cell

    Label1.Text = e.FileName;
End Sub

[Visual C#.NET]
private void thumbnail1_SelectFile(object sender, Newtone.ImageKit.Win.ThumbnailEventArgs e)
{
    if (e.ImageNumber == -1) return;  //disabled cell
    label1.Text = e.FileName;
}

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ShowThumbnailImage event

Newtone.ImageKit.Win.Thumbnail.ShowThumbnailImage Event

This event is generated just after a thumbnail image is displayed in the Thumbnail Control.

[Visual Basic] Public Event ShowThumbnailImage As ThumbnailEventHandler
[C#] public event ThumbnailEventHandler ShowThumbnailImage;

Event Data

The event handler retrieves arguments of type ThumbnailEventArgs

Explanation

The ShowThumbImage event is generated just after a thumbnail image is displayed in the thumbnail control.

Information about files loaded during this event can be referred to within the ThumbnailLoadEventArgs arguments.

Regarding property for the ThumbnailEventArgs class

When multi-page image files are loaded, the page number is appended to the FileName parameter (If the page number is 0 then it is omitted).

Example: When page 2 of the file ABC.TIF is loaded into the thumbnail control, the FileName parameter will return the string "ABC.TIF 2".

Example

Displays image numbers

[Visual Basic.NET]
Private Sub Thumbnail1_ShowThumbnailImage(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ThumbnailEventArgs) Handles Thumbnail1.ShowThumbnailImage
    Thumbnail1.Text = e.ImageNumber.ToString()
End Sub

[Visual C#.NET]
private void thumbnail1_ShowThumbnailImage(object sender, Newtone.ImageKit.Win.ThumbnailEventArgs e)
{
    Thumbnail1.Text = e.ImageNumber.ToString();
}

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


StratLoadFile event

Newtone.ImageKit.Win.Thumbnail.StratLoadFile Event

This event is generated before each image is loaded on the Thumbnail Control.

[Visual Basic] Public Event StratLoadFile As ThumbnailLoadEventHandler
[C#] public event ThumbnailLoadEventHandler StratLoadFile;

Event Data

The event handler retrieves arguments of type ThumbnailLoadEventArgs

Explanation

The StartLoadFile event is generated before each image is loaded on the Thumbnail Control. Note: This event is NOT generated if a thumbnail file (ThumbnailFile property) is used to load the images. To cancel processing in the Thumbnail Control, set the Cancel property to True within this event.

Information about files loaded during this event can be referred to within the ThumbnailLoadEventArgs arguments.

Regarding property for the ThumbnailLoadEventArgs class

When multi-page image files are loaded, the page number is appended to the FileName parameter (If the page number is 0 then it is omitted).

Example: When page 2 of the file ABC.TIF is loaded into the thumbnail control, the FileName parameter will return the string "ABC.TIF 2".

Example

Displays some information about images loaded.

[Visual Basic.NET]
Private Sub Thumbnail1_StartLoadFile(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ThumbnailLoadEventArgs) Handles Thumbnail1.StratLoadFile
    Label1.Text = e.ImageNumber.ToString() + " / " + e.TotalImageNumber.ToString();
End Sub

[Visual C#.NET]
private void thumbnail1_StartLoadFile(object sender, Newtone.ImageKit.Win.ThumbnailLoadEventArgs e)
{
    label1.Text = e.ImageNumber.ToString() + " / " + e.TotalImageNumber.ToString();
}

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailEventHandler delegate

Newtone.ImageKit.Win.ThumbnailEventHandler Delegate

This delegate refers to the MouseMoveOnThumbnail, SelectFile, or ShowThumbnailImage events.

[Visual Basic] Public Delegate Sub ThumbnailEventHandler(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ThumbnailEventArgs)
[C#] public delegate void ThumbnailEventHandler(object sender, Newtone.ImageKit.Win.ThumbnailEventArgs e);

Parameters

sender
Event Source

e
ThumbnailEventArgs containing event arguments

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailLoadEventHandler delegate

Newtone.ImageKit.Win.ThumbnailLoadEventHandler Delegate

This delegate refers to the StartLoadFile or EndLoadFile events.

[Visual Basic] Public Delegate Sub ThumbnailLoadEventHandler(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ThumbnailLoadEventArgs)
[C#] public delegate void ThumbnailLoadEventHandler(object sender, Newtone.ImageKit.Win.ThumbnailLoadEventArgs e);

Parameters

sender
Event Source

e
ThumbnailLoadEventArgs containing event data

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailAppearance enum

Newtone.ImageKit.Win.ThumbnailAppearance Enum

This enumeration sets the appearance of the Thumbnail Control.

public enum ThumbnailAppearance

Public Members

Member | Value | Explanation
Flat | 0 | Flat
Lowered | 1 | Lowered
Raised | 2 | Raised

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailAppearance enum

Newtone.ImageKit.Win.ThumbnailLoadMode Enum

This enumeration refers to how images are loaded and displayed in the Thumbnail Control.

public enum ThumbnailLoadMode

Public Members

Member | Value | Explanation
LoadFile | 0 | Loads files
LoadFileDisplay | 1 | Loads and displays them while loading
LoadMulti | 2 | Loads (for multi-page image files)
LoadMultiDisplay | 3 | Loads (for multi-page image files) and displays them while loading
LoadImageProperty | 4 | Loads image objects

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailScrollDirection enum

Newtone.ImageKit.Win.ThumbnailScrollDirection Enum

This enumeration refers to the scroll direction of Thumbnail Control.

public enum ThumbnailScrollDirection

Public Members

Member | Value | Explanation
Vertical | 0 | Scrolls vertically
Horizontal | 1 | Scrolls horizontally

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailSort enum

Newtone.ImageKit.Win.ThumbnailSort Enum

This enumeration refers to the sorting method for the image files contained in the folder(s) specified by the FilePath property and in the ListOfFileNames property.

public enum ThumbnailSort

Public Members

Member | Value | Explanation
None | 0 | No sorting
FileName | 1 | Sorted by file name
Date | 2 | Sorted by date
FileExtName | 3 | Sorted by file extension + file name
FileExtDate | 4 | Sorted by file extension + date
DirFileName | 5 | Sorted by directory name + file name
DirDate | 6 | Sorted by directory name + date
DirFileExtName | 7 | Sorted by directory name + file extension + file name
DirFileExtDate | 8 | Sorted by directory name + file extension + date

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailSortDate enum

Newtone.ImageKit.Win.ThumbnailSortDate Enum

This enumeration refers the datetime used to sort thumbnail images.

public enum ThumbnailSortDate

Public Members

Member | Value | Explanation
CreationTime | 0 | The datetime that the file was created
LastWriteTime | 1 | The datetime that the file was last modified
LastAccessTime | 2 | The datetime that the file was last accessed

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailStyle enum

Newtone.ImageKit.Win.ThumbnailStyle Enum

This enumeration refers to the style of the thumbnail image cell.

public enum ThumbnailStyle

Public Members

Member | Value | Explanation
Button | 0 | Button
Film | 1 | Film
Custom | 2 | Custom

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailEventArgs class

Newtone.ImageKit.Win.ThumbnailEventArgs Class

This class exposes properties for the MouseMoveOnThumbnail, SelectFile, and ShowThumbnailImage events.

[Visual Basic] Public Class ThumbnailEventArgs Inherits System.EventArgs
[C#] public class ThumbnailEventArgsFSystem.EventArgs

Explanation

Property | Type | Explanation
DirectoryName | [Visual Basic] String [C#] string | Retrieves the name of the directory containing the images.
FileName | [Visual Basic] String [C#] string | Refers to the filename of the original image when its thumbnail image is selected.
ImageNumber | [Visual Basic] Integer [C#] int | Retrieves the thumbnail image number (Starts from 1).
PageNumber | [Visual Basic] Integer [C#] int | Retrieves the thumbnail image's page number (Starts from 1).
Rect | System.Drawing.Rectangle | Retrieves the pixel coordinates for the cell that corresponds to a thumbnail image.
TotalImageNumber | [Visual Basic] Integer [C#] int | Retrieves the total number of thumbnail images.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailLoadEventArgs class

Newtone.ImageKit.Win.ThumbnailLoadEventArgs Class

This class exposes properties for the StartLoadFile and EndLoadFile events.

[Visual Basic] Public Class ThumbnailLoadEventArgs Inherits System.EventArgs
[C#] public class ThumbnailLoadEventArgsFSystem.EventArgs

Explanation

Property | Type | Explanation
DirectoryName | [Visual Basic] String [C#] string | Retrieves the directory name for the thumbnail image.
FileName | [Visual Basic] String [C#] string | Retrieves the filename for the thumbnail image.
ImageNumber | [Visual Basic] Integer [C#] int | Retrieves the thumbnail image number (Starts from 1).
PageNumber | [Visual Basic] Integer [C#] int | Retrieves the thumbnail image's page number (Starts from 1).
TotalImageNumber | [Visual Basic] Integer [C#] int | Retrieves the total number of thumbnail images.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ImageKit.Win.WebCamera.Play class

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play Class

The main class for the WinForm Play Control

For a list of all members of this class, see Play Members

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Newtone.ImageKit.Win.WebCamera.Play

public class Play : System.Windows.Forms.Control

Explanation

The Play class opens a video file and displays the output in the specified control. Play can be started, stopped, paused, resumed, and a snapshot can be taken.

Requirement

Namespace: Newtone.ImageKit.Win.WebCamera

Assembly: Newtone.ImageKit.Win.WebCamera.dll

See Also

Play Members


Thumbnail Members

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play Members

Play Overview

Public Contructor

Play Constructor Creates a new instance of the Play class

Public Properties

BorderColor | Sets the color of the border
BorderStyle | Sets the border style
Duration | Retrieves the duration of the video (in seconds)
ErrorStatus | Retrieves the type of error that has occurred
State | Retrieves the current state of the Play control
VideoSize | Retrieves the video size

Public Methods

Close | Closes the video file
Open | Opens the video file
Pause | Pauses or resumes playing of the video
SetWindowPosition | Sets the window position within the control
Start | Starts the video
StartFrom | Defines the start location (in seconds) of the video
Stop | Stops the video
TakeSnapshot | Takes a snapshot while the video is playing

Public Events

End | Generated when the video ends
Snapshot | Generated when the TakeSnapshot method successfully executes

See Also

Newtone.ImageKit.Win.WebCamera.Play


ImageKit.Win.WebCamera.Play Constructor

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play Constructor

Creates a new instance of the Play class

[Visual Basic] Public Sub New()
[C#] public Play()

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


BorderColor property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.BorderColor Property

This property sets the color of the border.

[Visual Basic] Public Property BorderColor As System.Drawing.Color
[C#] public System.Drawing.Color BorderColor {get; set;}

Property Value

A Color value. Default value is Color.Black

Explanation

The BorderColor property sets the color of the border.

This property is enabled when the BordeStyle property is set to BorderStyle.FixedSingle

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


BorderStyle property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.BorderStyle Property

This property sets the border style.

[Visual Basic] Public Property BorderStyle As System.Windows.Forms.BorderStyle
[C#] public System.Windows.Forms.BorderStyle BorderStyle {get; set;}

Property Value

A BorderStyle value. Default is BorderStyle.None

Explanation

The BorderStyle property sets the border style.

By default the Play control does not display a border.

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


VideoSize property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.Duration Property

This property retrieves the duration of the video. (in seconds)

[Visual Basic] Public ReadOnly Property Duration As Double
[C#] public double Duration {get;}

Property Value

Read Only

Explanation

The Duration property retrieves the duration of the video. (in seconds). This property value is updated after the Open method is executed.

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


ErrorStatus property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.ErrorStatus Property

This property retrieves the type of error that has occurred.

[Visual Basic] Public ReadOnly Property ErrorStatus As Newtone.ImageKit.Error
[C#] public Newtone.ImageKit.Error ErrorStatus {get;}

Property Value

Read Only

Explanation

The ErrorStatus property retrieves the type of error that has occurred.

The value retrieved will refer to a Error enum value. The property value is updated after a method is executed.

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


State property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.State Property

This property retrieves the current state of the Play control.

[Visual Basic] Public ReadOnly Property State As Newtone.ImageKit.Win.WebCamera.State
[C#] public Newtone.ImageKit.Win.WebCamera.State State {get;}

Property Value

Read Only

Explanation

The State property retrieves the current state of the Play control. The value retrieved will refer to a State enum value. The property value is updated after a method is executed.

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


VideoSize property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.VideoSize Property

This property retrieves the video size.

[Visual Basic] Public ReadOnly Property VideoSize As System.Drawing.Size
[C#] public System.Drawing.Size VideoSize {get;}

Property Value

Read Only

Explanation

The VideoSize property retrieves the video size.

The VideoSize property is updated after the Open method executes.

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


Close method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.Close Method

This method closes the file.

[Visual Basic] Public Function Close() As Boolean
[C#] public bool Close();

Return Value

Returns True if successful, otherwise returns False

Explanation

The Close method closes the file by the Open method.

If successful, the State property will be changed. If unsuccessful, then "Step" will be set in the ErrorStatus property. (Usually this indicates that the Close method has been executed before the Open method.)

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


Open method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.Open Method

This method opens the video file.

[Visual Basic]
Public Function Open(ByVal fileName As String) As Boolean
Public Function Open(ByVal fileName As String, ByVal outputControl As System.Windows.Forms.Control) As Boolean
[C#]
public bool Open(string fileName);
public bool Open(string fileName, System.Windows.Forms.Control outputControl);

Parameters

fileName

The name of the video file

outputControl

The control that displays the output

Return Value

Returns True if successful, otherwise returns False

Explanation

The Open method opens the video file.

The fileName parameter holds the name of the video file that will be played.

The outputControl parameter holds the control that displays the output. If no control is passed to the outputControl parameter, the output will be displayed in the Play control.

If successful, the State property will be changed. If unsuccessful, then "DirectX", "Step", "FileOpen" or "Interface" will be set in the ErrorStatus property.

IMPORTANT: The Play Control uses DirectShow which supports only general media format filters by default. It is possible to use some other codecs. However, if you want to open a file in one of these other formats that is not supported by default, you will first need to obtain and install the appropriate codec.

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


Pause method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.Pause Method

This method pauses or resumes playing of the video

[Visual Basic] Public Function Pause() As Boolean
[C#] public bool Pause();

Return Value

Returns True if successful, otherwise returns False

Explanation

The Pause method pauses the playing of the video that was started with the Start method. When play is paused, executing this method again will resume the video.

If successful, the State property will be changed. If unsuccessful, then "Step" or "ETC" will be set in the ErrorStatus property.

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


SetWindowPosition method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.SetWindowPosition Method

This method sets the window position within the control.

[Visual Basic] Public Function SetWindowPosition() As Boolean
[C#] public bool SetWindowPosition();

Return Value

Returns True if successful, otherwise returns False

Explanation

The SetWindowPosition method sets the window position within the control. This method should be executed when the window size changes and a control other than the Play control is used.

Execute this method when the Open method is used to output video to a control other than the Play control and that control's size changes. If video is output to the Play control, then this method need not be executed.

If unsuccessful, then "DirectX" or "ETC" will be set in the ErrorStatus property.

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


Start method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.Start Method

This method starts the video.
[Visual Basic]
Public Function Start(ByVal mode As DisplayMode) As Boolean
Public Function Start(ByVal mode As DisplayMode, ByVal rate As Double) As Boolean
[C#]
public bool Start(DisplayMode mode);
public bool Start(DisplayMode mode, double rate);

Parameters

mode

The display mode

rate

The playing speed

Return Value

Returns True if successful, otherwise returns False

Explanation

The mode parameter passes the type of display mode to the output control

The rate parameter passes the playing speed. Normal speed is 1.0. 0 or a minus value are not possible. If no value is set in the rate parameter then the speed will be 1.0. Sometimes, when replaying a file (for example a WMV format file), the rate value may not be enabled. In this case the rate will be 1.0.

If successful, the State property will be changed. If unsuccessful, then "Step", "ETC" or "Value" will be set in the ErrorStatus property.

To start the video from a particular location use the StartFrom method to define the start location in seconds.

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


StartFrom method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.StartFrom Method

This method defines the start location (in seconds) of the video.

[Visual Basic] Public Function StartFrom(ByVal time As Double) As Boolean
[C#] public bool StartFrom(double time);

Parameters

time

The start location (in seconds)

Return Value

Returns True if successful, otherwise returns False

Explanation

The StartFrom method defines the start location (in seconds) of the video. The time parameter contains the start location. The default value is 0. (A minus value is not possible).

If unsuccessful, then "Step", "ETC", or "Value" will be set in the ErrorStatus property.

If after executing the Open method, you execute the Start method without executing the StartFrom method, the video will start at the beginning. However, to avoid the possiblity of replaying a video, it is advisable to always execute the StartFrom method prior to executing the Start method.

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


Stop method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.Stop Method

This method stops the video.

[Visual Basic] Public Function Stop() As Boolean
[C#] public bool Stop();

Return Value

Returns True if successful, otherwise returns False

Explanation

The Stop method stops the video that was started by the Start method.

If successful, the State property will be changed. If unsuccessful, then "Step" will be set in the ErrorStatus property.

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


TakeSnapshot method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.TakeSnapshot Method

This method takes a snapshot while the video is playing.
[Visual Basic] Public Function TakeSnapshot() As Boolean
[C#] public bool TakeSnapshot();

Return Value

Returns True if successful, otherwise returns False

Explanation

The TakeSnapshot method takes a snapshot from a video started with the Start method. The snapshot can be retrieved in the Snapshot event.

If unsuccessful, "ETC", "Step" or "Support" will be set in the ErrorStatus property. In the case that "Support" is set in the ErrorStatus property, a scanshot cannot be taken from the video.

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


SelectFile event

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.End Event

This event is generated when the video ends.

[Visual Basic]Public Event End As System.EventHandler
[C#]public event System.EventHandler End;

Event Data

Event Handler receives arguments of type SnapshotEventArgs

Explanation

The End event is generated when the video ends. When the Start method is executed and the video has been playing and then stops playing without the Stop method being executed, then this event is generated.

Example

[Visual Basic.NET]
Private Sub Play1_End(ByVal sender As Object, ByVal e As System.EventArgs)
                Handles Play1.End
MessageBox.Show("The End")
End Sub

[Visual C#.NET]
private void play1_End(object sender, System.EventArgs e)
{
MessageBox.Show("The End");
}

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


SelectFile event

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Play.Snapshot Event

This event is generated when the TakeSnapshot method successfully executes.
[Visual Basic]Public Event Snapshot As SnapshotEventHandler
[C#]public event SnapshotEventHandler Snapshot;

Event Data

Event Handler receives arguments of type SnapshotEventArgs

Explanation

The Snapshot event is generated when the TakeSnapshot method successfully executes.

The snapshot retrieved within this event can be referred to in the SnapshotEventArgs arguments

Regarding the SnapshotEventArgs Class property:
When Dispose is True, the retrieved snapshot's Bitmap is freed from the memory when the event finishes. To keep the Bitmap, it is necessary to execute the Clone method and save the Bitmap to file.

Example

Displaying the retrieved snapshot in a PictureBox:

[Visual Basic.NET]
Private Sub Play1_Snapshot(ByVal sender As Object, ByVal e As
                Newtone.ImageKit.Win.WebCamera.SnapshotEventArgs) Handles Play1.Snapshot
e.Dispose = False
If Not (PictureBox1.Image Is Nothing) Then
PictureBox1.Image.Dispose()
PictureBox1.Image =
                Nothing
End If

'if e.Dispose is False then
PictureBox1.Image = e.Bitmap
'if e.Dispose is True then
'PictureBox1.Image = e.Bitmap.Clone()
End Sub

[Visual C#.NET]
private void preview1_Snapshot(object sender,
                Newtone.ImageKit.Win.WebCamera.SnapshotEventArgs e)
{
e.Dispose = false;
if (pictureBox1.Image != null)
{
pictureBox1.Image.Dispose();
pictureBox1.Image =
                null;
}

//if e.Dispose is false then
pictureBox1.Image = (Image)e.Bitmap;
//if e.Dispose is true then
//pictureBox1.Image = (Image)e.Bitmap.Clone();
}

See Also

Play Members | Newtone.ImageKit.Win.WebCamera.Play


ImageKit.Win.WebCamera.Preview Class

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview Class

The main class for the WinForm Preview Control

For a list of all members of this class, see Preview Members

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Newtone.ImageKit.Win.WebCamera.Preview

public class Preview : System.Windows.Forms.Control

Explanation

The Preview control connects to a Web(USB) camera and displays the video output in the specified container. The video output can be started, stopped, paused, resumed, and a snapshot can be taken.

Requirement

Namespace: Newtone.ImageKit.Win.WebCamera

Assembly: Newtone.ImageKit.Win.WebCamera.dll

See Also

Preview Members


Preview Members

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview Members

Preview Overview

Public Contructor

Preview Constructor Creates a new instance of the Preview class

Public Properties

BorderColor | Sets the color of the border
BorderStyle | Sets the border style
ErrorStatus | Retrieves the type of error that has occurred
State | Retrieves the current state of the preview
VideoSize | Retrieves the video size.

Public Methods

Close | Closes the connection to the Web(USB) camera
GetVideoDevices | Retrieves the name of the video device
Open | Opens the Web(USB) camera in preview mode
Pause | Pauses or resumes the preview
SetWindowPosition | Sets the window position within the control
ShowFilterDialog | Displays the Filter Dialog.
ShowPinDialog | Displays the Pin Dialog
Start | Starts the preview
Stop | Stops the preview
TakeSnapshot | Takes a snapshot from the preview

Public Events

Snapshot Generated when the TakeSnapshot method successfully executes

See Also

Newtone.ImageKit.Win.WebCamera.Preview


ImageKit.Win.WebCamera.Preview Constructor

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview Constructor

Creates a new instance of the Preview class.

[Visual Basic] Public Sub New()
[C#] public Preview()

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


BitCount property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.BitCount Property

This property retrieves the bitcount per pixel for the preview image.

[Visual Basic] Public ReadOnly Property BitCount As Integer
[C#] public int BitCount {get;}

Property Value

An integer representing the bitcount. ReadOnly

Explanation

The BitCount property retrieves the bitcount per pixel for the preview image.

This property is refreshed after executing the Open, SetStreamFormat, or ShowPenDialog methods.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


BorderColor property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.BorderColor Property

This property sets the color of the border.

[Visual Basic] Public Property BorderColor As System.Drawing.Color
[C#] public System.Drawing.Color BorderColor {get; set;}

Property Value

A Color value. Default value is Color.Black

Explanation

The BorderColor property sets the color of the border.

This property is enabled when the BordeStyle property is set to BorderStyle.FixedSingle

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


BorderStyle property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.BorderStyle Property

This property sets the border style.

[Visual Basic] Public Property BorderStyle As System.Windows.Forms.BorderStyle
[C#] public System.Windows.Forms.BorderStyle BorderStyle {get; set;}

Property Value

A BorderStyle value. Default is BorderStyle.None.

Explanation

The BorderStyle property sets the border style.

By default the Preview control does not display a border.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


Compression property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.Compression Property

This property retrieves the compression format for the preview image.

[Visual Basic] Public ReadOnly Property Compression As Integer
[C#] public int Compression {get;}

Property Value

An integer representing the compression format. ReadOnly

Explanation

The Compression property retrieves the compression format for the preview image.

This property is refreshed after executing the Open, SetStreamFormat, or ShowPenDialog methods.

If the image is uncompressed then 0(BI_RGB) or 3(BI_BITFIELDS) is retrieved. For details about the constants within the parentheses, please refer to Windows API. If the image is compressed, an appropriate FourCC code will be retrieved.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


ErrorStatus property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.ErrorStatus Property

This property retrieves the type of error that has occurred.

[Visual Basic] Public ReadOnly Property ErrorStatus As Newtone.ImageKit.Error
[C#] public Newtone.ImageKit.Error ErrorStatus {get;}

Property Value

Read Only

Explanation

The ErrorStatus property retrieves the type of error that has occurred.

The value retrieved will refer to a Error enum value. The property value is updated after a method is executed.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


FrameRate property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.FrameRate Property

This property sets the frame rate.

[Visual Basic] Public Property FrameRate As Double
[C#] public double FrameRate {get; set;}

Property Value

The frame rate (in frames per second)

Explanation

The FrameRate property sets the frame rate.

This property is refreshed after executing the Open and ShowPenDialog methods.

If this property is set before executing the SetStreamFormat method, that frame rate will be used.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


State property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.State Property

This property retrieves the current state of the preview.

[Visual Basic] Public ReadOnly Property State As Newtone.ImageKit.Win.WebCamera.State
[C#] public Newtone.ImageKit.Win.WebCamera.State State {get;}

Property Value

Read Only

Explanation

The State property retrieves the current state of the preview. The value retrieved will refer to a State enum value. The property value is updated after a method is executed.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


VideoSize property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.VideoSize Property

This property retrieves the video size.

[Visual Basic] Public ReadOnly Property VideoSize As System.Drawing.Size
[C#] public System.Drawing.Size VideoSize {get;}

Property Value

Read Only

Explanation

The VideoSize property retrieves the video size.

The VideoSize property is updated after the Open or the ShowPinDialog methods execute.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


VideoSubType property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.VideoSubType Property

This property retrieves the GUID for the media sample subtype.

[Visual Basic] Public ReadOnly Property VideoSubType As Guid
[C#] public Guid VideoSubType {get;}

Property Value

A Guid representing th emedia sample subtype. ReadOnly

Explanation

The VideoSubType property retrieves the GUID for the media sample subtype.

This property is refreshed after executing the Open, SetStreamFormat, or ShowPenDialog methods.

If the image is compressed, the compression FourCC code, written in hexidecimal notation, will be the first 8 digits of the Guid.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


Close method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.Close Method

This method closes the connection to the Web(USB) camera.

[Visual Basic] Public Function Close() As Boolean
[C#] public bool Close();

Return Value

Returns True if successful, otherwise returns False

Explanation

The Close method closes the connection to the Web(USB) camera established by the Open method.

If successful, the State property will be changed. If unsuccessful, then "Step" will be set in the ErrorStatus property.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


GetStreamFormats method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.GetStreamFormats Method

This method pauses or resumes the preview

[Visual Basic] Public Function GetStreamFormats() As VideoStreamInformation
[C#] public VideoStreamInformation GetStreamFormats();

Return Value

an array of type VideoStreamInformation class.

Explanation

The Pause method pauses the preview that was started with the Start method. When a preview is paused, executing this method again will resume the preview.

If successful, the State property will be changed. If unsuccessful, then "Step" or "ETC" will be set in the ErrorStatus property.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


GetVideoDevices method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.GetVideoDevices Method

This method retrieves the name of the video device.

[Visual Basic] Public Function GetVideoDevices() As String()
[C#] public string[] GetVideoDevices();

Return Value

Returns an array of type String if successful, otherwise returns null[C#] or nothing[Visual Basic]

Explanation

The GetVideoDevices method retrieves the name of the video device. If unsuccessful, "DirectX" or "Connect" will be set in the ErrorStatus property.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


Open method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.Open Method

This method opens the Web(USB) camera in preview mode.

[Visual Basic]
Public Function Open() As Boolean
Public Function Open(ByVal videoDevice As String) As Boolean
Public Function Open(ByVal index As Integer) As Boolean
Public Function Open(ByVal outputControl As System.Windows.Forms.Control) As Boolean
Public Function Open(ByVal videoDevice As String, ByVal outputControl As System.Windows.Forms.Control) As Boolean
Public Function Open(ByVal index As Integer, ByVal outputControl As System.Windows.Forms.Control) As Boolean
[C#]
public bool Open();
public bool Open(string videoDevice);
public bool Open(int index);
public bool Open(System.Windows.Forms.Control outputControl);
public bool Open(string videoDevice, System.Windows.Forms.Control
                outputControl);
public bool Open(int index, System.Windows.Forms.Control outputControl);

Parameters

videoDevice

The name of the Web(USB) camera

index

The index of the Web(USB) camera

outputControl

The control that displays the output

Return Value

Returns True if successful, otherwise returns False

Explanation

The Open method opens the Web(USB) camera in preview mode.

The videoDevice parameter holds the name of the device, the index parameter holds a string array index for the device as returned by the GetVideoDevices method. (If multiple devices are returned it will be one of them). When using a method that doesn't have the videoDevice parameter or an index parameter, use the first device returned by the GetVideoDevices method.

The outputControl parameter holds the control that displays the output. If no control is passed to the outputControl parameter, the output will be displayed in the Preview control.

If successful, the State property will be changed. If unsuccessful, then "Step", "Connect" or "Interface" will be set in the ErrorStatus property.

Important: Recording (Record Class) and Preview cannot be used at the same time. When using Preview, be sure to close the Web(USB) camera with the Record.Close method and then reconnect to the camera using Preview.Open.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


Pause method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.Pause Method

This method pauses or resumes the preview

[Visual Basic] Public Function Pause() As Boolean
[C#] public bool Pause();

Return Value

Returns True if successful, otherwise returns False

Explanation

The Pause method pauses the preview that was started with the Start method. When a preview is paused, executing this method again will resume the preview.

If successful, the State property will be changed. If unsuccessful, then "Step" or "ETC" will be set in the ErrorStatus property.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


SetStreamFormat Method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.SetStreamFormat Method

This method sets the format functions, like output size, etc.

[Visual Basic] Public Function SetStreamFormat(ByVal index As Integer) As Boolean
[C#] public bool SetStreamFormat(int index);

Parameters

index
Index (from 0 to the number of elements in the array returned by the GetStreamFormats method - 1)

Return Value

Returns True if successful, otherwise returns False

Explanation

The SetStreamFormat method sets the format functions, like output size, etc. The output size and other format functions can be changed even if the ShowPinDialogmethod is executed.

After changing output size, etc., these changes will not be reflected in the preview until the preview is stopped (by executing the Stop method). To set a format function, pass a value into the index parameter that correspondes to the function you'd like to set. Index values range from 0 to the number of elements returned by executing the GetStreamFormatsmethod - 1.

If successful (if true is returned), the BitCount, Compression, VideoSize, and VideoSubType properties will be changed.

If unsuccessful (if false is returned), the ETC, Value, and Step will be set in the ErrorStatusproperty.

To execute the SetStreamFormat method, you must first execute the Open and GetStreamFormats methods.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


SetWindowPosition method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.SetWindowPosition Method

This method sets the window position within the control.

[Visual Basic] Public Function SetWindowPosition() As Boolean
[C#] public bool SetWindowPosition();

Return Value

Returns True if successful, otherwise returns False

Explanation

The SetWindowPosition method sets the window position within the control. This method should be executed when the window size changes and a control other than the Preview control is used.

Execute this method when the Open method is used to output video to a control other than the Preview control and that control's size changes. If video is output to the Preview control, then this method need not be executed.

If unsuccessful, then "DirectX" or "ETC" will be set in the ErrorStatus property.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


ShowFilterDialog method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.ShowFilterDialog Method

This method displays the Filter Dialog.

[Visual Basic] Public Function ShowFilterDialog() As Boolean
[C#] public bool ShowFilterDialog();

Return Value

Returns True if successful, otherwise returns False

Explanation

The ShowFilterDialog method displays the Filter Dialog.

To execute this method it is first necessary to execute the Open method and establishing a connection to the Web(USB) camera.

If unsuccessful, then "Step", "Connect" or "ETC" will be set in the ErrorStatus property.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


ShowPinDialog method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.ShowPinDialog Method

This method displays the Pin Dialog.

[Visual Basic] Public Function ShowPinDialog() As Boolean
[C#] public bool ShowPinDialog();

Return Value

Returns True if successful, otherwise returns False

Explanation

The ShowPinDialog method displays the Pin Dialog.

To execute this method it is first necessary to execute the Open method and establishing a connection to the Web(USB) camera.

If unsuccessful, then "Step", "Connect" or "ETC" will be set in the ErrorStatus property.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


Start method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.Start Method

This method starts the preview.

[Visual Basic] Public Function Start(ByVal mode As DisplayMode) As Boolean
[C#] public bool Start(DisplayMode mode);

Parameters

mode

The display mode

Return Value

Returns True if successful, otherwise returns False

Explanation

The Start method starts the preview. The mode parameter determines whether the display mode will be "stretch" or "scale".

If successful, the State property will be changed. If unsuccessful, then "Step" or "ETC" will be set in the ErrorStatus property.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


Stop method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.Stop Method

This method stops the preview.

[Visual Basic] Public Function Stop() As Boolean
[C#] public bool Stop();

Return Value

Returns True if successful, otherwise returns False

Explanation

The Stop method stops the preview that was started by the Start method.

If successful, the State property will be changed. If unsuccessful, then "Step" will be set in the ErrorStatus property.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


TakeSnapshot method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.TakeSnapshot Method

This method takes a snapshot from the preview.

[Visual Basic] Public Function TakeSnapshot() As Boolean
[C#] public bool TakeSnapshot();

Return Value

Returns True if successful, otherwise returns False

Explanation

The TakeSnapshot method takes a snapshot from the preview started with the Start method. The snapshot can be retrieved in the Snapshot event.

If unsuccessful, "ETC", "Step", or "Support" will be set in the ErrorStatus property depending on the circumstances. If "Support" is set in the ErrorStatus, please execute the ShowPinDialog method and check the color space/compression.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


SelectFile event

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Preview.Snapshot Event

This event is generated when the TakeSnapshot method successfully executes.

[Visual Basic]Public Event Snapshot As SnapshotEventHandler
[C#] public event SnapshotEventHandlerSnapshot;

Event Data

Event Handler receives arguments of type SnapshotEventArgs

Explanation

The Snapshot event is generated when the TakeSnapshot method successfully executes.

The snapshot retrieved within this event can be referred to in the SnapshotEventArgs arguments

Regarding the SnapshotEventArgs Class property:
When Dispose is True, the retrieved snapshot's Bitmap is freed from the memory when the event finishes. To keep the Bitmap, it is necessary to execute the Clone method and save the Bitmap to file.

Example

Displaying the retrieved snapshot in a PictureBox:

[Visual Basic.NET]
Private Sub Preview1_Snapshot(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.WebCamera.SnapshotEventArgs) Handles Preview1.Snapshot
e.Dispose = False
If Not (PictureBox1.Image Is Nothing) Then
PictureBox1.Image.Dispose()
PictureBox1.Image = Nothing
End If
'if e.Dispose is False then
PictureBox1.Image = e.Bitmap
'if e.Dispose is True then
'PictureBox1.Image = e.Bitmap.Clone()
End Sub
[Visual C#.NET]
private void preview1_Snapshot(object sender,
                Newtone.ImageKit.Win.WebCamera.SnapshotEventArgs e)
{
e.Dispose = false;
if (pictureBox1.Image != null)
{
pictureBox1.Image.Dispose();
pictureBox1.Image =
                null;
}
//if e.Dispose is false then
pictureBox1.Image = (Image)e.Bitmap;
//if e.Dispose is true then
//pictureBox1.Image = (Image)e.Bitmap.Clone();
}

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


ImageKit.Win.WebCamera.Record class

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record Class

The main class for the WinForm Record Control

For a list of all members of this class, see Record Members

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Newtone.ImageKit.Win.WebCamera.Record

public class Record : System.Windows.Forms.Control

Explanation

The Record control connects to a Web(USB) camera and while displaying the video output, it saves the output in the specified file. The recording can be started, stopped, paused, and resumed.

Necessary conditions

Namespace: Newtone.ImageKit.Win.WebCamera

Assembly: Newtone.ImageKit.Win.WebCamera.dll

See Also

Record Members


Thumbnail Members

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record Members

Record Overview

Public Constructor

Record Constructor Creates a new instance of the Record class.

Public Properties

BorderColor | Sets the color of the border.
BorderStyle | Sets the border style.
ErrorStatus | Retrieves the type of error that has occurred.
State | Retrieves the current state of the recording.
VideoSize | Retrieves the video size.

Public Methods

Close | Closes the connection to the Web(USB) camera
GetVideoDevices | Retrieves the name of the video device
Open | Opens the Web(USB) camera in capture (recording) mode
Pause | Pauses or resumes the recording
SetWindowPosition | Sets the window position within the control
ShowFilterDialog | Displays the Filter Dialog.
ShowPinDialog | Displays the Pin Dialog
Start | Starts the capture (recording)
Stop | Stops the capture (recording)

See Also

Newtone.ImageKit.Win.WebCamera.Record


ImageKit.Win.WebCamera.Record Constructor

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record Constructor

Creates a new instance of the Record class.

[Visual Basic] Public Sub New()
[C#] public Record()

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


BitCount property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.BitCount Property

This property retrieves the bitcount per pixel for the video.

[Visual Basic] Public ReadOnly Property BitCount As Integer
[C#] public int BitCount {get;}

Property Value

An integer representing the bitcount. ReadOnly

Explanation

The BitCount property retrieves the bitcount per pixel for the video.

This property is refreshed after executing the Open, SetStreamFormat, or ShowPenDialog methods.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


BitRate property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.BitRate Property

This property sets the bitrate in bits per second.

[Visual Basic] Public Property BitRate As Integer
[C#] public int BitRate {get; set;}

Property Value

An integer representing the bitrate (in bit per second)

Explanation

The BitRate property sets the bitrate in bits per second. When saving in compressed formats, a larger bitrate will mean a higher quality image. A smaller bitrate will mean a lower quality image. The BitRate property is enabled when the Format property is Asf.

This property is refreshed after executing the Open or ShowPenDialog methods. If the BitRate property is set prior to executing the SetStreamFormat, that value will be used.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


BorderColor property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.BorderColor Property

This property sets the color of the border.

[Visual Basic] Public Property BorderColor As System.Drawing.Color
[C#] public System.Drawing.Color BorderColor {get; set;}

Property Value

A Color value. Default value is Color.Black

Explanation

The BorderColor property sets the color of the border.

This property is enabled when the BordeStyle property is set to BorderStyle.FixedSingle

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


BorderStyle property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.BorderStyle Property

This property sets the border style.

[Visual Basic] Public Property BorderStyle As System.Windows.Forms.BorderStyle
[C#] public System.Windows.Forms.BorderStyle BorderStyle {get; set;}

Property Value

A BorderStyle value. Default is BorderStyle.None.

Explanation

The BorderStyle property sets the border style.

By default the Record control does not display a border.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


Compression property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.Compression Property

This property retrieves the compression format for the video.

[Visual Basic] Public ReadOnly Property Compression As Integer
[C#] public int Compression {get;}

Property Value

An integer representing the compression format. ReadOnly

Explanation

The Compression property retrieves the compression format for the video.

This property is refreshed after executing the Open, SetStreamFormat, or ShowPenDialog methods.

If the image is uncompressed then 0(BI_RGB) or 3(BI_BITFIELDS) is retrieved. For details about the constants within the parentheses, please refer to Windows API. If the image is compressed, an appropriate FourCC code will be retrieved.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


ErrorStatus property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.ErrorStatus Property

This property retrieves the type of error that has occurred.

[Visual Basic] Public ReadOnly Property ErrorStatus As Newtone.ImageKit.Error
[C#] public Newtone.ImageKit.Error ErrorStatus {get;}

Property Value

Read Only

Explanation

The ErrorStatus property retrieves the type of error that has occurred.

The value retrieved will refer to a Error enum value. The property value is updated after a method is executed.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


Format property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.Format Property

This property sets the format for saving the video.

[Visual Basic] Public Property Format As Newtone.ImageKit.Win.WebCamera.VideoFormat
[C#] public Newtone.ImageKit.Win.WebCamera.VideoFormat Format {get; set;}

Property Value

An value of type Newtone.ImageKit.Win.WebCamera.VideoFormatrepresenting the video format.

Explanation

The Format property sets the format for saving the video.

Please set this property value before executing the Open method. Default value is Avi. When saving in WMV format, be sure to set an appropriate value in the BitRate property.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


FrameRate property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.FrameRate Property

This property sets the frame rate.

[Visual Basic] Public Property FrameRate As Double
[C#] public double FrameRate {get; set;}

Property Value

The frame rate (in frames per second)

Explanation

The FrameRate property sets the frame rate.

This property is refreshed after executing the Open and ShowPenDialog methods.

If this property is set before executing the SetStreamFormat method, that frame rate will be used.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


State property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.State Property

This property retrieves the current state of the recording.

[Visual Basic] Public ReadOnly Property State As Newtone.ImageKit.Win.WebCamera.State
[C#] public Newtone.ImageKit.Win.WebCamera.State State {get;}

Property Value

Read Only

Explanation

The State property retrieves the current state of the recording. The value retrieved will refer to a State enum value. The property value is updated after a method is executed.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


VideoSize property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.VideoSize Property

This property retrieves the video size

[Visual Basic] Public ReadOnly Property VideoSize As System.Drawing.Size
[C#] public System.Drawing.Size VideoSize {get;}

Property Value

Read Only

Explanation

The VideoSize property retrieves the video size.

The VideoSize property is updated after the Open or the ShowPinDialog methods execute.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


VideoSubType property

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.VideoSubType Property

This property retrieves the GUID for the media sample subtype.

[Visual Basic] Public ReadOnly Property VideoSubType As Guid
[C#] public Guid VideoSubType {get;}

Property Value

A Guid representing th emedia sample subtype. ReadOnly

Explanation

The VideoSubType property retrieves the GUID for the media sample subtype.

This property is refreshed after executing the Open, SetStreamFormat, or ShowPenDialog methods.

If the image is compressed, the compression FourCC code, written in hexidecimal notation, will be the first 8 digits of the Guid.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


Close method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.Close Method

This method closes the connection to the Web(USB) camera.

[Visual Basic] Public Function Close() As Boolean
[C#] public bool Close();

Return Value

Returns True if successful, otherwise returns False

Explanation

The Close method closes the connection to the Web(USB) camera established by the Open method.

If successful, the State property will be changed. If the Close method is executed without executing the Open method then "Step" will be set in the ErrorStatus property.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


GetStreamFormats method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.GetStreamFormats Method

This method pauses or resumes the recording

[Visual Basic] Public Function GetStreamFormats() As VideoStreamInformation
[C#] public VideoStreamInformation GetStreamFormats();

Return Value

an array of type VideoStreamInformation class.

Explanation

The Pause method pauses the recording that was started with the Start method. When a recording is paused, executing this method again will resume the recording.

If successful, the State property will be changed. If unsuccessful, then "Step" or "ETC" will be set in the ErrorStatus property.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


GetVideoDevices method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.GetVideoDevices Method

This method retrieves the name of the video device.

[Visual Basic] Public Function GetVideoDevices() As String()
[C#] public string[] GetVideoDevices();

Return Value

Returns an array of type String if successful, otherwise returns null[C#] or nothing[Visual Basic]

Explanation

The GetVideoDevices method retrieves the name of the video device. If unsuccessful, "DirectX" or "Connect" will be set in the ErrorStatus property.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


Open method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.Open Method

This method opens the Web(USB) camera in capture (recording) mode.

[Visual Basic]
Public Function Open(ByVal fileName As String) As Boolean
Public Function Open(ByVal fileName As String, ByVal videoDevice As String) As Boolean
Public Function Open(ByVal fileName As String, ByVal index As Integer) As Boolean
Public Function Open(ByVal fileName As String, ByVal outputControl As System.Windows.Forms.Control) As Boolean
Public Function Open(ByVal fileName As String, ByVal videoDevice As String, ByVal outputControl As System.Windows.Forms.Control) As Boolean
Public Function Open(ByVal fileName As String, ByVal index As Integer, ByVal outputControl As System.Windows.Forms.Control) As Boolean
[C#]
public bool Open(string fileName);
public bool Open(string fileName, string videoDevice);
public bool Open(string fileName, int index);
public bool Open(string fileName, System.Windows.Forms.Control outputControl);
public bool Open(string fileName, string videoDevice,
                System.Windows.Forms.Control outputControl);
public bool Open(string fileName, int index, System.Windows.Forms.Control
                outputControl);

Parameters

fileName

The name of the file where the recording is saved.

videoDevice

The name of the Web(USB) camera

The index of the Web(USB) camera

outputControl

outputControl

The control that displays the output

Return Value

Returns True if successful, otherwise returns False

Explanation

The Open method opens the Web(USB) camera in capture (recording) mode.

The fileName parameter sets the file where the capture will be saved. The Format property will determine if the capture will be saved in AVI format or in WMV format.

The videoDevice parameter holds the name of the device, the index parameter holds a string array index for the device as returned by the GetVideoDevices method. (If multiple devices are returned it will be one of them). When using a method that doesn't have the videoDevice parameter or an index parameter, use the first device returned by the GetVideoDevices method.

The outputControl parameter holds the control that displays the output. If no control is passed to the outputControl parameter, the output will be displayed in the Preview control.

If successful, the State property will be changed. If unsuccessful, then "DirectX", "Step", "Connect" or "Interface" will be set in the ErrorStatus property.

Important: Preview (Preview Class) and Record cannot be used at the same time. When using Record, be sure to close the Web(USB) camera with the Preview.Close method and then reconnect to the camera using Record.Open.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


Pause method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.Pause Method

This method pauses or resumes the video capture (recording).

[Visual Basic] Public Function Pause() As Boolean
[C#] public bool Pause();

Return Value

Returns True if successful, otherwise returns False

Explanation

The Pause method pauses the preview that was started with the Start method. When a preview is paused, executing this method again will resume the preview.

If successful, the State property will be changed. If unsuccessful, then "Step" or "ETC" will be set in the ErrorStatus property.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


SetStreamFormat Method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.SetStreamFormat Method

This method sets the format functions, like output size, etc.

[Visual Basic] Public Function SetStreamFormat(ByVal index As Integer) As Boolean
[C#] public bool SetStreamFormat(int index);

Parameters

index
Index (from 0 to the number of elements in the array returned by the GetStreamFormats method - 1)

Return Value

Returns True if successful, otherwise returns False

Explanation

The SetStreamFormat method sets the format functions, like output size, etc. The output size and other format functions can be changed even if the ShowPinDialogmethod is executed.

After changing output size, etc., these changes will not be reflected in the recording until the recording is stopped (by executing the Stop method). To set a format function, pass a value into the index parameter that correspondes to the function you'd like to set. Index values range from 0 to the number of elements returned by executing the GetStreamFormatsmethod - 1.

If successful (if true is returned), the BitCount, Compression, VideoSize, and VideoSubType properties will be changed.

If unsuccessful (if false is returned), the ETC, Value, and Step will be set in the ErrorStatusproperty.

To execute the SetStreamFormat method, you must first execute the Open and GetStreamFormats methods.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


SetWindowPosition method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.SetWindowPosition Method

This method sets the window position within the control.

[Visual Basic] Public Function SetWindowPosition() As Boolean
[C#] public bool SetWindowPosition();

Return Value

Returns True if successful, otherwise returns False

Explanation

The SetWindowPosition method sets the window position within the control. This method should be executed when the window size changes and a control other than the Record control is used.

Execute this method when the Open method is used to output to a control other than the Record control and that control's size changes. If movie is output to the Record control, then this method need not be executed.

If unsuccessful, then "DirectX" or "ETC" will be set in theErrorStatus property.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


ShowFilterDialog method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.ShowFilterDialog Method

This method displays the Filter Dialog.

[Visual Basic] Public Function ShowFilterDialog() As Boolean
[C#] public bool ShowFilterDialog();

Return Value

Returns True if successful, otherwise returns False

Explanation

The ShowFilterDialog method displays the Filter Dialog.

To execute this method it is first necessary to execute the Open method and establishing a connection to the Web(USB) camera.

If unsuccessful, then "Step", "Connect" or "ETC" will be set in the ErrorStatus property.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


ShowPinDialog method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.ShowPinDialog Method

This method displays the Pin Dialog.

[Visual Basic] Public Function ShowPinDialog() As Boolean
[C#] public bool ShowPinDialog();

Return Value

Returns True if successful, otherwise returns False

Explanation

The ShowPinDialog method displays the Pin Dialog.

To execute this method it is first necessary to execute the Open method and establishing a connection to the Web(USB) camera.

If unsuccessful, then "Step", "Connect" or "ETC" will be set in the ErrorStatus property.

Note: Changing resolution and other settings during capture will not alter the recording. You must first stop the capture (execute the Stop method) then make your resolution and other setting changes.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


Start method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.Start Method

This method starts the video capture (recording).

[Visual Basic] Public Function Start(ByVal mode As DisplayMode) As Boolean
[C#] public bool Start(DisplayMode mode);

Parameters

mode

The display mode

Return Value

Returns True if successful, otherwise returns False

Explanation

The Start method starts the video capture (recording). The mode parameter determines whether the display mode will be "stretch" or "scale".

If successful, the State property will be changed. If unsuccessful, then "Step" or "ETC" will be set in the ErrorStatus property.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


Stop method

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.Record.Stop Method

This method stops the video capture (recording).

[Visual Basic] Public Function Stop() As Boolean
[C#] public bool Stop();

Return Value

Returns True if successful, otherwise returns False

Explanation

The Stop method stops the video capture that was started by the Start method.

If successful, the State property will be changed. If unsuccessful, then "Step" will be set in the ErrorStatus property.

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


DisplayMode enum

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.DisplayMode Enumeration

This enumeration refers to the type of video display modes available

public enum DisplayMode

Public Members

Member Name | Value | Explanation
Scale | 0 | The video is displayed with a height to width ratio equal to that of the output control.
Stretch | 1 | The video is displayed so that it fits the height and width of the ouput control.

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


State enum

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.State Enumeration

This enumeration refers to the current state of the WebCamera controls

This enumeration has a FlagsAttribute that allows a bitwise combination of its member values.

[Flags]
public enum State

Public Members

Member Name | Value | Explanation
Closed | 0 | The connection is closed or there was no connection
Open | 1 | The connection is open
Running | 2 | Running
Paused | 4 | Paused
Stopped | 8 | Stopped

See Also

Preview Members | Newtone.ImageKit.Win.WebCamera.Preview


State enum

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.State Enumeration

This enumeration refers to the type of format for saving the video.

Public Members

Member Name | Value | Explanation
Avi | 0 | AVI format (Uncompressed)
Asf | 1 | WMV format (Compressed)

See Also

Record Members | Newtone.ImageKit.Win.WebCamera.Record


SnapshotEventArgs class

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.SnapshotEventArgs Class

This class provides the data for the Snapshot events of the Preview and Play classes.

[Visual Basic] Public Class SnapshotEventArgs Inherits System.EventArgs
[C#] public class SnapshotEventArgsFSystem.EventArgs

Explanation

Property | Type | Explanation
Bitmap | [Visual Basic] System.Drawing.Bitmap [C#] System.Drawing.Bitmap | Retrieves the snapshot.
Dispose | [Visual Basic] Boolean [C#] bool | Sets whether or not the Bitmap resource is freed from the memory after the event fires. True frees the Bitmap, False does not free the Bitmap. Default value is True.

See Also

Newtone.ImageKit.Win.WebCamera


SnapshotEventHandler delegate

Newtone.ImageKit.Win.WebCamera

Newtone.ImageKit.Win.WebCamera.SnapshotEventHandler Delegate

This delegate refers to the method that processes Snapshot Events for the Preview and Play Classes

[Visual Basic] Public Delegate Sub SnapshotEventHandler(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.WebCamera.SnapshotEventArgs)
[C#] public delegate void SnapshotEventHandler(object sender, Newtone.ImageKit.Win.WebCamera.SnapshotEventArgs e);

Parameters

sender

Event Source

e

Event data contained in the SnapshotEventArgs

See Also

Newtone.ImageKit.Win.WebCamera


ScanMode enum

Newtone.ImageKit

Newtone.ImageKit.Error Enum

This enumeration refers to the type of error that has occurred in the ImageKit Control.

public enum Error

Public Members

Member | Value | Explanation
None | 0 | No error has occurred
Cancel | 1 | The process was canceled
ETC | 2 | An unspecified error has occurred
Memory | 3 | A memory error has occurred
Support | 4 | This function is not supported
Value | 5 | An incorrect value has been set
File | 6 | The file is incorrect or corrupted
Image | 7 | The image is incorrect or corrupted
Twain32Load | 8 | Twain_32.dll can not load. This is no longer supported but is here for backward compatibility. In the ImageKit.NET3, use TwainLoad
TwainLoad | 8 | Twain_32.dll or the TwainDSM.dll could not load.
Draw | 9 | An error has occurred while drawing on or displaying an image
ImageSupport | 10 | That image format is not supported
Step | 11 | The order of execution is incorrect
ADFNoPaper | 12 | There is no paper in the ADF
DigitalCameraNoImage | 13 | There are no images in the digital camera (UI suppressed only)
DllUnload | 14 | The DLL is not loaded
Trans | 15 | Transmission error
FileNotFound | 16 | Cannot find file
FileCorrupt | 17 | The file is corrupted
Timeout | 18 | A timeout has occurred. The process has been cancelled
TransDenied | 19 | The username and/or password is incorrect. Access denied.
FileOpen | 20 | Cannot open file
FileCreate | 21 | Cannot create file
FileWrite | 22 | Cannot save file
FileRead | 23 | Cannot load file
NoImage | 24 | There is no image data to display
Directory | 25 | Directory related error
FileSave | 26 | File could not be saved
PDFFileCreate | 27 | PDF file could not be created
PDFAddPage | 28 | Page could not be added to PDF file
PDFAddImage | 29 | Image could not be added to PDF file
ThumbnailConfigFile | 50 | The ConfigFile is not set
ThumbnailImageDirectory | 51 | The ImageDirectory is not set
ThumbnailThumbImageDirectory | 52 | The ThumbnailImageDirectory is not set
ThumbnailImageFileExtension | 53 | The ImageFileExtension is not set
ThumbnailImageWidth | 54 | The Imagewidth is not set
ThumbnailImageHeight | 55 | The Imageheight is not set
Twain32Entry | 101 | There is no entry point for the Twain_32.dll. This is no longer used but is kept for backward compatibility. Use TwainEntry instead.
TwainEntry | 101 | There is no entry point for the Twain_32.dll or the TwainDSM.dll
DsmOrDsOpen | 102 | The data source manager and the data source haven't been opened or can't be open
NoDataSource | 103 | There is no data source
MaxConnections | 104 | The data source is already connected to the maximum number of applications
Operation | 105 | An error has occurred in the data source or in the data source manager
BadProtocol | 106 | An unconfirmed triplet has occurred (TWAIN - DG_XXX/DAT_XXX/MSG_XXX)
DeviceOnline | 107 | Check the scan device's operating state
PaperJam | 108 | Paper is jammed in the feeder
PaperDoubleFeed | 109 | Multiple sheets of paper have been fed into the feeder
BadResolution | 110 | The resolution is incorrect
CoverOpen | 111 | The cover is open
DamagedCorner | 112 | A corner of the document is damaged
FocusError | 113 | A focus error occurred during the scan
DocTooLight | 114 | The document is too light
DocTooDark | 115 | The document is too dark
NoMedia | 116 | Image information could not retrieved or transferred
DirectX | 201 | The DirectX environment is not correct
Connect | 202 | Unable to connect to the device
Interface | 203 | COM interface related error has occurred
TrialExpired | 900 | The trial version has been expired
Activation | 901 | License confirmation failed


ScanNoiseFilter enum

Newtone.ImageKit

Newtone.ImageKit.AreaSelectMode Enum

This enumeration refers to the type of area that will be processed on the image.

public enum AreaSelectMode

Public Members

Member | Value | Explanation
EffectMask | 0 | A mask handle is used to determine the area to be processed. (The value set in the SourceMask property is enabled)
EffectAll | 1 | The total image is processed
EffectPolygon | 2 | A polygonal area, selected on the image, is processed. (The value set in the Point property is enabled)
EffectEllipse | 3 | An elliptical shape, selected on the image, is processed. (The value set in the Rect property is enabled)

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


JpegSubsamplingKind enum

Newtone.ImageKit

Newtone.ImageKit.JpegSubsamplingKind Enum

This enumeration refers to the type of YCrCb subsampling used when images are saved in JPEG format.

public enum JpegSubsamplingKind

Public Members

Member | Value | Explanation
JS411 | 0 | Y:Cr:Cb 4:1:1
JS422 | 1 | Y:Cr:Cb 4:2:2
JS444 | 2 | Y:Cr:Cb 4:4:4

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LoadFileType enum

Newtone.ImageKit

Newtone.ImageKit.LoadFileType Enum

This enumeration refers to the type of image format that can be loaded.

public enum LoadFileType

Public Members

Member | Value | Explanation
Load | 0 | All supported types
LoadBMP | 1 | BMP
LoadJPEG | 2 | JPEG
LoadGIF | 3 | GIF
LoadTIFF | 4 | TIFF
LoadPNG | 5 | PNG
LoadFPX | 6 | FPX
LoadPCX | 7 | PCX
LoadWMF | 8 | WMF
LoadEMF | 9 | EMF
LoadDXF | 10 | DXF
LoadSVG | 11 | SVG
LoadJPEG2000 | 12 | JPEG2000
LoadSXFP21 | 13 | SXF p21
LoadSXFSFC | 14 | SXF sfc

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


SaveFileType enum

Newtone.ImageKit

Newtone.ImageKit.SaveFileType Enum

This enumeration refers to the type of format the image will be saved.

public enum SaveFileType

Public Members

Member | Value | Explanation
SaveBMP | 0 | BMP - Uncompressed
SaveBMPRLE | 1 | BMP - Compressed
SaveJPEG | 2 | JPEG - Standard DCT
SaveJPEGProgress | 3 | JPEG - Progressive DCT
SaveGIF | 4 | GIF
SaveTIFFNoncompressed | 5 | TIFF - Uncompressed
SaveTIFFCcittrle | 6 | Not supported by the ImageKit.NET3
SaveTIFFGroup3_1D | 7 | TIFF Group3-1D
SaveTIFFGroup3_2D | 8 | Not supported by the ImageKit.NET3
SaveTIFFGroup4 | 9 | TIFF Group4
SaveTIFFPackbits | 10 | TIFF Packbits
SaveTIFFLZW | 11 | TIFF LZW
SavePNG | 12 | PNG
SaveFPXNoncompressed | 13 | FPX - Uncompressed
SaveFPXSingleColor | 14 | FPX - Single Color Compressed
SaveFPXJpeg | 15 | FPX - JPEG Compression
SavePCX | 16 | Not supported by the ImageKit.NET3
SaveWMF | 17 | Not supported by the ImageKit.NET3
SaveEMF | 18 | Not supported by the ImageKit.NET3
SaveDXF | 19 | Not supported by the ImageKit.NET3
SaveSVG | 20 | Not supported by the ImageKit.NET3
SaveJPEG2000 | 21 | JPEG2000 Part1
SaveJPEG2000Stream | 22 | JPEG2000 Code Stream
SaveSXFP21 | 23 | Not supported by the ImageKit.NET3
SaveSXFSFC | 24 | Not supported by the ImageKit.NET3
SaveTiffJpeg | 25 | Tiff Jpeg Compression

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


TiffColorSpaceKind enum

Newtone.ImageKit

Newtone.ImageKit.TiffColorSpaceKind Enum

This enumeration refers to the type of full color mode when saving images in TIFF format.

public enum TiffColorSpaceKind

Public Members

Member | Value | Explanation
RGB | 0 | RGB
CMYK | 1 | CMYK

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


TypeOfFile enum

Newtone.ImageKit

Newtone.ImageKit.TypeOfFile Enum

This enumeration refers to the type of image format
public enum TypeOfFile

Public Members

Member | Value | Explanation
TypeBMP | 1 | BMP
TypeBMPRLE4 | 2 | BMP RLE4
TypeBMPRLE8 | 3 | BMP RLE8
TypeJPEG | 4 | JPEG - Standard DCT
TypeJPEGProgress | 5 | JPEG - Progressive DCT
TypeGIF | 6 | GIF
TypeGIF89 | 7 | GIF 89a
TypeTIFFNoncompressed | 8 | TIFF - Uncompressed
TypeTIFFCcittrle | 9 | TIFF Ccittrle
TypeTIFFGroup3_1D | 10 | TIFF Group3-1D
TypeTIFFGroup3_2D | 11 | TIFF Group3-2D
TypeTIFFGroup4 | 12 | TIFF Group4
TypeTIFFPackbits | 13 | TIFF Packbits
TypeTIFFLZW | 14 | TIFF LZW
TypePNG | 15 | PNG
TypeFPXNoncompressed | 16 | FPX - Uncompressed
TypeFPXSingleColor | 17 | FPX - Single Color Compressed
TypeFPXJpeg | 18 | FPX - JPEG Compression
TypePCX | 19 | PCX
TypeWMF | 20 | WMF
TypeEMF | 21 | EMF
TypeDXF | 22 | DXF
TypeEXIF | 23 | Exif (JPEG)
TypeSVG | 24 | SVG
TypeJPEG2000 | 25 | JPEG2000 Part1
TypeJPEG2000Stream | 26 | JPEG2000 Code Stream
TypeSXFP21 | 27 | SXF p21
TypeSXFSFC | 28 | SXF sfc
TypeTIFFJPEG | 29 | TIFF JPEG
TypeTIFFZIP | 30 | TIFF ZIP

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CapabilityRange Members

Newtone.ImageKit

Newtone.ImageKit.CapabilityRange All Members

CapabilityRange Overview

Constructor

CapabilityRange Constructor Initializes a new instance of the CapabilityRange class

Public Properties

Current | Refers to the current setting for a specified functionality
Default | Refers to the default setting for a specified functionality
Maximum | Refers to the maximum setting for a specified functionality
Minimum | Refers to the minimum setting for a specified functionality
Step | Refers to a range of possible setting values for the specified functionality

See Also

Scan Members | Newtone.ImageKit


Current property

Newtone.ImageKit

Newtone.ImageKit.CapabilityRange.Current Property

This property refers to the current setting for a specified functionality as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

[Visual Basic] Public ReadOnly Property Current As Single
[C#] public float Current {get;}

Property Value

The current setting for that functionality

Explanation

The RangeCurrent property refers to the current setting for a specified functionality as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

See Also

CapabilityRange Members | Newtone.ImageKit.Win.ImageKit


Default property

Newtone.ImageKit

Newtone.ImageKit.CapabilityRange.Default Property

This property refers to the default setting for a specified functionality as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

[Visual Basic] Public ReadOnly Property Default As Single
[C#] public float Default {get;}

Property Value

The default setting for that functionality. (The setting when the device is turned on.)

Explanation

The RangeDefault property refers to the default setting for a specified functionality as retrieved by the the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

See Also

CapabilityRange Members | Newtone.ImageKit.Win.ImageKit


Maximum property

Newtone.ImageKit

Newtone.ImageKit.CapabilityRange.Maximum Property

This property refers to the maximum setting for a specified functionality as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

[Visual Basic] Public ReadOnly Property Maximum As Single
[C#] public float Maximum {get;}

Property Value

The maximum setting for that functionality

Explanation

The Maximum property refers to the maximum setting for a specified functionality as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

See Also

CapabilityRange Members | Newtone.ImageKit.Win.ImageKit


Minimum property

Newtone.ImageKit

Newtone.ImageKit.CapabilityRange.Minimum Property

This property refers to the minimum setting for a specified functionality as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

[Visual Basic] Public ReadOnly Property Minimum As Single
[C#] public float Minimum {get;}

Property Value

The minimum setting for that functionality

Explanation

The Minimum property refers to the minimum setting for a specified functionality as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

See Also

CapabilityRange Members | Newtone.ImageKit.Win.ImageKit


Step property

Newtone.ImageKit

Newtone.ImageKit.CapabilityRange.Step Property

This property refers to the information retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method, which can retrieve a range of possible setting values for the specified functionality in the scan device.

[Visual Basic] Public ReadOnly Property Step As Single
[C#] public float Step {get;}

Property Value

The size of the steps in the settings from Minimum to Maximum

Explanation

The Step property refers to the information retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method, which can retrieve a range of possible setting values for the specified functionality in the scan device.

See Also

CapabilityRange Members | Newtone.ImageKit.Win.ImageKit


DataSourceInformation Members

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation All Members

DataSourceInformation Overview

Constructor

DataSourceInformation Constructor Initializes a new instance of the DataSourceInformation class

Public Properties

Information | Refers to the scan device's version information
MajorVersion | Refers to the major version number of the scan device
Manufacturer | Refers to to the scan device manufacturer's name
MinorVersion | Refers to the minor version number of the scan device
ProductFamily | Refers to the scan device product family name
ProductName | Refers to the scan device product name
ProtocolMajor | Refers to the TWAIN major version number
ProtocolMinor | Refers to the TWAIN minor version number

See Also

Scan Members | Newtone.ImageKit


Information property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.Information Property

This property refers to the scan device's version information as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property Information As String
[C#] public string Information {get;}

Property Value

The scan device's version information

Explanation

The SourceVersionInfo property refers to the scan device's version information as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method, the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method, or the Newtone.ImageKit.Win.ImageKit.Scan.SelectDataSource method.

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


MajorVersion property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.MajorVersion Property

This property refers to various information about the scan device as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property MajorVersion As Integer
[C#] public int MajorVersion {get;}

Property Value

The major version number of the scan device

Explanation

This property refers to various information about the scan device as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


Manufacturer property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.Manufacturer Property

This property refers to to the scan device manufacturer's name as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property Manufacturer As String
[C#] public string Manufacturer {get;}

Property Value

The scan device manufacturer's name

Explanation

The Manufacturer property refers to various information about the scan device as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


MinorVersion property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.MinorVersion Property

This property refers to the minor version number of the scan device as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property MinorVersion As Integer
[C#] public int MinorVersion {get;}

Property Value

The minor version number of the scan device

Explanation

The MinorVersion property refers to the minor version number of the scan device as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


ProductFamily property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.ProductFamily Property

This property refers to the scan device product family name as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property ProductFamily As String
[C#] public string ProductFamily {get;}

Property Value

The scan device product family name

Explanation

This property refers to the scan device product family name as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


ProductName property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.ProductName Property

This property refers to the scan device product name as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property ProductName As String
[C#] public string ProductName {get;}<

Property Value

The scan device product name

Explanation

The ProductName property refers to the scan device product name as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


ProtocolMajor property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.ProtocolMajor Property

This property refers to the TWAIN major version number as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property ProtocolMajor As Integer
[C#] public int ProtocolMajor {get;}

Property Value

The the major version number of the TWAIN specification supported by the scan device

Explanation

The ProtocolMajor property refers to the TWAIN major version number as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


ProtocolMinor property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.ProtocolMinor Property

This property refers to the TWAIN minor version number as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property ProtocolMinor As Integer
[C#] public int ProtocolMinor {get;}

Property Value

The minor version number of the TWAIN specification supported by the scan device

Explanation

The ProtocolMinor property refers to the TWAIN minor version number as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


ScanBitDepthReduction enum

Newtone.ImageKit

Newtone.ImageKit.ScanBitDepthReduction Enum

This enumeration refers to the type of values for BitDepthReduction.

public enum ScanBitDepthReduction

Public Members

Member | Value | Explanation
Threshold | 0 | Threshold value
Halftone | 1 | Halftone value
Custom Halftone | 2 | Custom value *1
Diffusion | 3 | Diffusion value
DynamicThreshold | 4 | DynamicThreshold value
FeederLoaded | 4099 | The function that checks whether or not there is paper in the document feeder

ImageKit.NET3 does not support this value

See Also

Scan Members | Newtone.ImageKit


ScanCapability enum

Newtone.ImageKit

Newtone.ImageKit.ScanCapability Enum

This enumeration refers to the type of scan capability.

public enum ScanCapability

Public Members

Member | Value | Explanation
Compression | 256 | Compression method
PixelType | 257 | Pixel type
Unit | 258 | The units of measurement
Transfer | 259 | Transfer method
FeederEnabled | 4098 | Document feeder function
FeederLoaded | 4099 | The function that checks whether or not there is paper in the document feeder
Indicator | 4107 | Indicator
UIControllable | 4110 | UI control function
DeviceOnline | 4111 | The function that checks the device's operating state
ThumbnailEnabled | 4113 | The function that transfers thumbnail images
Duplex | 4114 | Duplex scanning with the document feeder is supported
DuplexEnabled | 4115 | Duplex scanning with the document feeder is enabled
EnableDataSourceUIOnly | 4116 | Display setting interface
CustomDataSourceData | 4117 | Retrieve or set UI values
AutoBright | 4352 | Automatic brightness adjustment
Brightness | 4353 | Brightness
Contrast | 4355 | Contrast
Fiter | 4358 | Filter
Gamma | 4360 | Gamma
Halftone | 4361 | Halftone
Highlight | 4362 | Highlight
ImageFileFormat | 4364 | ImageFileFormat
DropoutColor | 4366 | DropoutColor
Orientation | 4368 | Paper orientation
Shadow | 4371 | Shadow
XResolution | 4376 | The horizontal scan resolution
YResolution | 4377 | The vertical scan resolution
Rotation | 4385 | Rotation
PaperSize | 4386 | PaperSize
Threshold | 4387 | Threshold
XScaling | 4388 | The horizontal scaling
YScaling | 4389 | The vertical scaling
BitDepthReduction | 4396 | The method used to reduce the bit depth when scanning in 1 bit color
UndefinedImageSize | 4397 | The undefined size
ImageDataSet | 4398 | How many images are in a digital camera
AutoDiscardBlankPages | 4404 | Automatically skip blank pages (Standard Twain Capability)
ImageFilter | 4423 | ImageFilter
NoiseFilter | 4424 | NoiseFilter
BorderDetection | 4432 | BorderDetection
Deskew | 4433 | Deskew
JpegQuality | 4435 | JpegQuality
ScanningSpeed | 61441 | ScanningSpeed
MoireFilter | 61442 | MoireFilter
MoireFilterMaxResolution | 61443 | The maximum resolution when using a moire filter
Sharpness | 61444 | Sharpness
RotateBack | 61445 | RotateBack when using ADF in duplex mode
ExtendedUserInterface | 61446 | ExtendedUserInterface
DynamicThreshold | 61447 | DynamicThreshold
PixelAutomation | 61448 | Automatically detecting ratio of BW/Color
MultiStream | 61449 | MultiStream
TextOrientationRecognition | 61450 | Automatically recognizes orientation from text.
SkipBlankPage | 61451 | Automatically skips blank pages.
RemoveHole | 61452 | Automatically removes punch holes.
FocusPosition | 61453 | FocusPostion
TextEnhancement | 61454 | TextEnhancement
Border | 61455 | Border Functions
AdjustGamma | 61456 | Gamma Adjustmen

See Also

Scan Members | Newtone.ImageKit


ScanCompression enum

Newtone.ImageKit

Newtone.ImageKit.ScanCompression Enum

This enumeration refers to the compression method used when an image is transferred via memory.

public enum ScanCompression

Public Members

Member | Value | Explanation
None | 0 | Uncompressed
Packbits | 1 | PACKBITS (TIFF or PICT)
Group3_1D | 2 | GROUP3 1D (TIFF)
Group3_1D_EOL | 3 | GROUP3 1D End Of Line (TIFF)
Group3_2D | 4 | GROUP3 2D (TIFF)
Group4 | 5 | GROUP4 (TIFF)
Jpeg | 6 | JPEG (TIFF or JFIF or SPIFF)
Lzw | 7 | LZW (TIFF)
Jbig | 8 | JBIG (TIFF or SPIFF)
Png | 9 | PNG
Rle4 | 10 | RLE4 (BMP)
Rle8 | 11 | RLE8 (BMP)
BitFields | 12 | BITFIELDS (BMP)

Explanation

The values 2, 3, 4, and 5 are in FAX[CCITT] format. The values 10, 11 and 12 are in BMP format. Parenthesis () in the explanation section refers to the image file format when the file is transferred.

See Also

Scan Members | Newtone.ImageKit


ScanDropoutColor enum

Newtone.ImageKit

Newtone.ImageKit.ScanDropoutColor Enum

This enumeration refers to the dropout color.

public enum ScanDropoutColor

Public Members

Member | Value | Explanation
Red | 0 | Red
Green | 1 | Green
Blue | 2 | Blue
None | 3 | None
White | 4 | White
UV | 5 |
IR | 6 |

See Also

Scan Members | Newtone.ImageKit


ScanFileFormat enum

Newtone.ImageKit

Newtone.ImageKit.ScanFileFormat Enum

This enumeration refers to the file format when saving a file using file transfer.

public enum ScanFileFormat

Public Members

Member | Value | Explanation
Tiff | 0 | TIFF
Pict | 1 | PICT
Bmp | 2 | BMP
Xbm | 3 | XBM
Jfif | 4 | JPEG
Fpx | 5 | FlashPix
TiffMulti | 6 | TIFF Multi
Png | 7 | PNG
Spiff | 8 | JPEG, JBIG
Exif | 9 | EXIF
Pdf | 10 | Pdf
Jp2 | 11 | JPEG 2000 Part 1
Jpx | 13 | JPEG 2000 Part 2
Dejavu | 14 | Dejavu

See Also

Scan Members | Newtone.ImageKit


ScanImageFilter enum

Newtone.ImageKit

Newtone.ImageKit.ScanImageFilter Enum

This enumeration refers to the image filter.

public enum ScanImageFilter

Public Members

Member | Value | Explanation
None | 0 | None
Auto | 1 | Automation
LowPass | 2 | LOWPASS is recommended for haftone images
BandPass | 3 | BANDPASS is recommended for images that include text
HighPass | 4 | HIGHPASS is recommended for images that include lines
Text | 3 | BANDPASS is recommended for images that include text
FineLine | 4 | HIGHPASS is recommended for images that include lines

See Also

Scan Members | Newtone.ImageKit


ScanImageMerge enum

Newtone.ImageKit

Newtone.ImageKit.ScanImageMerge Enum

This enumeration refers to the image merge.

public enum ScanImageMerge

Public Members

Member | Value | Explanation
None | 0 | Images from both sides of the document are not merged
FrontOnTop | 1 | The front image is on top and the back image is on the bottom
BottomOnTop | 2 | The back image is on top and the front image is on the bottom
FontOnLeft | 3 | The front image is on the right and the back image is on the left
FontOnRight | 4 | The front image is on the left and the back image is on the right

See Also

Scan Members | Newtone.ImageKit


ScanMode enum

Newtone.ImageKit

Newtone.ImageKit.ScanMode Enum

This enumeration refers to the scanning mode.

public enum ScanMode

Public Members

Member | Value | Explanation
DocumentPlate | 0 | Document plate
ADFOneSide | 1 | ADF Simplex
ADFBothSide | 2 | ADF Duplex
Camera | 3 | The original images in the digital camera
CameraArray | 4 | The original images in the digital camera (using an array)
CameraThumbnail | 5 | The thumbnail images in the digital camera
CameraThumbnailArray | 6 | The thumbnail images in the digital camera (using an array)
PositiveFilm1 | 7 | Transparent document - positive film, uses film holder *1
PositiveFilm2 | 8 | Transparent document - positive film, uses film area guide *1 *2
InformationFile | 100 | Use the scan information file to set properties in scanner manufacturer's scan interface

*1 Enabled when using Epson scan drivers supporting the film holder
*2 Enabled when using scanners that support film area guide

See Also

Scan Members | Newtone.ImageKit


ScanNoiseFilter enum

Newtone.ImageKit

Newtone.ImageKit.ScanNoiseFilter Enum

This enumeration refers to the noise reduction filter.

public enum ScanNoiseFilter

Public Members

Member | Value | Explanation
None | 0 | None
Auto | 1 | Automatic
LonePixel | 2 |
MajorityRule | 3 |

See Also

Scan Members | Newtone.ImageKit


ScanOrientation enum

Newtone.ImageKit

Newtone.ImageKit.ScanOrientation Enum

This enumeration refers to the orientation of the paper.

public enum ScanOrientation

Public Members

Member | Value | Explanation
Rotate0 | 0 | 0 degrees
Rotate90 | 1 | 90 degrees
Rotate180 | 2 | 180 degrees
Rotate270 | 3 | 270 degrees
Portrait | 0 | Portrait
Landscape | 3 | Landscape
TextOrientationRecognition | 1000 | Automatically recognizes orientation from text (*1, *2) or automatic rotation

Explanation

TextOrientationRecognition detects the text orientation in scanned images and rotates the images in 90 degree increments to normalize text orientation. Canon DR scan drivers use "Text Orientation Recognition" whereas Panasonic scan drivers use "Automatic Image Orientation".

*1 Enabled for certain Canon DR scan drivers.
*2 Enabled for cetain Panasonic scan drivers.

See Also

Scan Members | Newtone.ImageKit


ScanOverScan enum

Newtone.ImageKit

Newtone.ImageKit.ScanOverScan Enum

This enumeration lists the possible overscan values.

public enum ScanOverScan

Public Members

member Name | Value | Explanation
None | 0 | No overscan will occur
Auto | 1 | The device controls what kind of overscan will occur
TopBottom | 2 | Vertical overscan will occur
LeftRight | 3 | Horizontal overscan will occur
All | 4 | Both horizontal and vertical overscan will occur.

See Also

Scan Members | Newtone.ImageKit


ScanPaperSize enum

Newtone.ImageKit

Newtone.ImageKit.ScanPaperSize Enum

This enumeration refers to the size of the paper.

public enum ScanPaperSize

Public Members

Member | Value | Explanation
UserSize | 0 | User defined size
A4Letter | 1 | A4 letter 210mm x 297mm
B5Letter | 2 | B5 letter 182mm x 257mm
USLetter | 3 | US letter 8.5" x 11.0" (216mm x 280mm)
USLegal | 4 | US legal 11.0" x 17.0" (216mm x 356mm)
A5 | 5 | A5 148mm x 210mm
B4 | 6 | ISO B4 250mm x 353mm
B6 | 7 | ISO B6 125mm x 176mm
USLedger | 9 | US ledger 11.0" x 17.0" (280mm x 432mm)
USExecutive | 10 | US exective 7.25" x 10.5" (184mm x 267mm)
A3 | 11 | A3 297mm x 420mm
B3 | 12 | ISO B3 353mm x 500mm
A6 | 13 | A6 105mm x 148mm
C4 | 14 | C4 229mm x 324mm
C5 | 15 | C5 162mm x 229mm
C6 | 16 | C6 114mm x 162mm
FourA0 | 17 | 4A0 1682mm x 2378mm
TwoA0 | 18 | 2A0 1189mm x 1682mm
A0 | 19 | A0 841mm x 1189mm
A1 | 20 | A1 594mm x 841mm
A2 | 21 | A2 420mm x 594mm
A4 | 1 | A4 210mm x 297mm
A7 | 22 | A7 74mm x 105mm
A8 | 23 | A8 52mm x 74mm
A9 | 24 | A9 37mm x 52mm
A10 | 25 | A10 26mm x 37mm
ISOB0 | 26 | ISO B0 1000mm x 1414mm
ISOB1 | 27 | ISO B1 707mm x 1000mm
ISOB2 | 28 | ISO B2 500mm x 707mm
ISOB3 | 12 | ISO B3 353mm x 500mm
ISOB4 | 6 | ISO B4 250mm x 353mm
ISOB5 | 29 | ISO B5 176mm x 250mm
ISOB6 | 7 | ISO B6 125mm x 176mm
ISOB7 | 30 | ISO B7 88mm x 125mm
ISOB8 | 31 | ISO B8 62mm x 88mm
ISOB9 | 32 | ISO B9 44mm x 62mm
ISOB10 | 33 | ISO B10 31mm x 44mm
JISB0 | 34 | JIS B0 1030mm x 1456mm
JISB1 | 35 | JIS B1 728mm x 1030mm
JISB2 | 36 | JIS B2 515mm x 728mm
JISB3 | 37 | JIS B3 364mm x 515mm
JISB4 | 38 | JIS B4 257mm x 364mm
JISB5 | 2 | JIS B5 182mm x 257mm
JISB6 | 39 | JIS B6 128mm x 182mm
JISB7 | 40 | JIS B7 91mm x 128mm
JISB8 | 41 | JIS B8 64mm x 91mm
JISB9 | 42 | JIS B9 45mm x 64mm
JISB10 | 43 | JIS B10 32mm x 45mm
C0 | 44 | C0 917mm x 1297mm
C1 | 45 | C1 648mm x 917mm
C2 | 46 | C2 458mm x 648mm
C3 | 47 | C3 324mm x 458mm
C7 | 48 | C7 81mm x 114mm
C8 | 49 | C8 57mm x 81mm
C9 | 50 | C9 40mm x 57mm
C10 | 51 | C10 28mm x 40mm
USStatement | 52 | US statement 5.5" x 8.5" (140mm x 216mm)
BusinessCard | 53 | Business card 90mm x 55mm
UndefinedSize | 1000 | Undefined size

See Also

Scan Members | Newtone.ImageKit


ScanPixelType enum

Newtone.ImageKit

Newtone.ImageKit.ScanPixelType Enum

This enumeration refers to the type of image scanned.

public enum ScanPixelType

Public Members

Member | Value | Explanation
BW | 0 | Black and White
Gray | 1 | Grayscale
RGB | 2 | RGB color
Palette | 3 | Palette color
CMY | 4 | CMY color *1
CMYK | 5 | CMYK color *1
YUV | 6 | YUV color *1
YUVK | 7 | YUVK color *1
CIEXYZ | 8 | CIEXYZ color *1
Automation | 1000 | Automation (1 bit or 24 bit)
GrayAndBW | 1001 | Black and White 1 bit Color and Grayscale *2, *5
RGBAndBW | 1002 | Black and White 1 bit Color and RGB *2, *5

Explanation

Automation distinguishes between "black and white" or RGB color when scanning the document plate. GrayAndBW and RGBAndBW scans one document in both Black and White and in either Grayscale or RGB color. The scan order is first Grayscale or RGB and then Black and White.

*1 Not supported when the UserInterface property is suppressed.
*2 Enabled for certain Panasonic scanners.
*3 Enabled for certain Canon DR scanners.
*4 Enabled for certain Epson scanners.
*5 Enabled for certain PFU (Fujitsu) scan drivers.

See Also

Scan Members | Newtone.ImageKit


ScanTransfer enum

Newtone.ImageKit

Newtone.ImageKit.ScanTransfer Enum

This enumeration refers to the scan transfer method.

public enum ScanTransfer

Public Members

Member | Value | Explanation
Native | 0 | Native (Transferred as DIB)
File | 1 | File
Memory | 2 | Memory (Transferred in block units)
File2 | 3 | File2 *

Explanation

* The ImageKit does not support transfer method 3

See Also

Scan Members | Newtone.ImageKit


ScanUnit enum

Newtone.ImageKit

Newtone.ImageKit.ScanUnit Enum

This enumeration refers to the scan units of measurement.

public enum ScanUnit

Public Members

Member | Value | Explanation
Inch | 0 | Inches
Centimeter | 1 | Centimeters
Pica | 2 | Pica
Point | 3 | Points
Twip | 4 | twips
Pixel | 5 | Pixels

See Also

Scan Members | Newtone.ImageKit


ScanUserInterface enum

Newtone.ImageKit

Newtone.ImageKit.ScanUserInterface Enum

This enumeration refers to the scan driver's user interface and whether it will displayed, displayed and closed, or totally suppressed.

public enum ScanUserInterface

Public Members

Member | Value | Explanation
Show | 0 | The scan driver's user interface is displayed. It is not closed after the scan is complete
ShowandClose | 1 | The scan driver's user interface is displayed. It is closed after the scan is complete
Suppress | 2 | The scan driver's user interface is totally suppressed. A custom built user interface will be used

See Also

Scan Members | Newtone.ImageKit


AfterScanEventArgs class

Newtone.ImageKit

Newtone.ImageKit.AfterScanEventArgs Class

This class exposes properties for the AfterScan event.

[Visual Basic] Public Class AfterScanEventArgs Inherits System.EventArgs
[C#] public class AfterScanEventArgsFSystem.EventArgs

Explanation

Property | Type | Explanation
Bitmap1 | System.Drawing.Bitmap | Retrieves the Bitmap Class for storing 1, 4, 8, and 24 bit images. During file transfers, this is null (Nothing in Visual Basic)
Bitmap2 | System.Drawing.Bitmap | Retrieves the Bitmap Class for storing 16 bit grayscale and 48 bit images. During file transfers, this is null (Nothing in Visual Basic)
BitOrder | [Visual Basic] Integer [C#] int | Refers to whether the bits in each byte of the scanned image start from the left or start from the right. 0: Start from the right (LSB), 1: Start from the left (MSB)
Cancel | [Visual Basic] Boolean [C#] bool | Sets whether or not the scan process is canceled. By setting this property to True, the process can be canceled.
Dispose | [Visual Basic] Boolean [C#] bool | Sets whether or not the Bitmap1 and Bitmap2 resource will be disposed after the event has finished. When this arguement is set to true, the Bitmap1 and Bitmap2 resource will be disposed. When this arguement is set to false, these resources will not be disposed. The default value is true.
FileName | [Visual Basic] String [C#] string | Sets the file name when saving a file using file transfer
ImageNumber | [Visual Basic] Integer [C#] int | The number of images scanned
RawData | [Visual Basic] Byte() [C#] byte[] | Retrieves the scanned data (byte array) when using memory transfer compression mode. This is null (Nothing in Visual Basic) when using native transfer or uncompression file transfer

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


AnnotationDrawEventArgs Class

Newtone.ImageKit.Win.ImageKit.AnnotationDrawEventArgs Class

This class provides data for the StartDrawObject event and the EndDrawObject event.

[Visual Basic] Public Class AnnotationDrawEventArgs Inherits EventArgs
[C#] public class AnnotationDrawEventArgs : EventArgs

Explanation

Property | Type | Explanation
Index | Integer (Visual Basic) int(C#) | Retrieves the object number of the object drawn (this is the same as the object's Z-Order)
DrawPoint | Point() (Visual Basic) Point[](C#) | Retrieves the completed coordinate points for the object * For the StartDrawObject event, this refers to the initial point (the first point drawn). The Point array will retrieve this initial point only. * For the EndDrawObject event, this refers to the coordinate points needed to draw the completed object. (For the Line object, that would be the start point and the end point. For the Rectangle, Ellipse, Text, and Image objects, that would be the top, left and bottom, right points. For the Polyline, Polygon, and Pen, that would be all points contained in the object.)

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


BeforeScanEventArgs class

Newtone.ImageKit

Newtone.ImageKit.BeforeScanEventArgs Class

This class exposes properties for the BeforeScan event.

[Visual Basic] Public Class BeforeScanEventArgs Inherits System.EventArgs
[C#] public class BeforeScanEventArgsFSystem.EventArgs

Explanation

Property | Type | Explanation
BitDepth | [Visual Basic] Integer [C#] int | Retrieves the number of bits per pixel. Note: 12 and 14 grayscale will be resolved to 16 bits; 36 and 42 bit color will be resolved to 48 bits.
Cancel | [Visual Basic] Boolean [C#] bool | Sets whether or not the scan process is canceled. By setting this property to True, the process can be canceled.
Compression | Newtone.ImageKit.ScanCompression | Sets the compression method used when an image is transferred via memory
Height | [Visual Basic] Integer [C#] int | The height of the image that will be transferred in pixels
ImageNumber | [Visual Basic] Integer [C#] int | Refers to the number of images that have been scanned
PixelType | Newtone.ImageKit.ScanPixelType | Sets the type of image scanned
Width | [Visual Basic] Integer [C#] int | The width of the image that will be transferred in pixels
XResolution | [Visual Basic] Single [C#] float | Sets the horizontal scan resolution *1
YResolution | [Visual Basic] Single [C#] float | Sets the vertical scan resolution *1

*1

Although the TWAIN specifications allow scan units to be inches or centimeters, depending on the datasource (scan device) the scan units settings are ignored and DPI is used. Furthermore, if scan units are set to pixels, there are cases where the datasource will return a value of 1 in these resolution properties.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DispEventArgs class

Newtone.ImageKit.Win.ImageKit.DispEventArgs Class

This class exposes properties for the StartDispImage and EndDispImage events.

[Visual Basic] Public Class DispEventArgs Inherits EventArgs
[C#] public class DispEventArgs : EventArgs

Explanation

Property | Type | Explanation
OriginX | Integer (Visual Basic) int (C#) | The horizontal distance from the left side of the ImageKit Control to the left side of the image. (If the image is larger than the ImageKit Control in the horizontal direction, OriginX will equal 0.)
OriginY | Integer (Visual Basic) int (C#) | The vertical distance from the top of the ImageKit Control to the top of the image. (If the image is larger than the ImageKit Control in the vertical direction, OriginY will equal 0.)
Left | Integer (Visual Basic) int (C#) | The horizontal distance from the left side of the actual image to the left side of that portion of the image currently being displayed.
Top | Integer (Visual Basic) int (C#) | The vertical distance from the top of the actual image to the top of that portion of the image currently being displayed.
Right | Integer (Visual Basic) int (C#) | The horizontal distance from the left side of the actual image to the right side of that portion of the image currently being displayed.
Bottom | Integer (Visual Basic) int (C#) | The vertical distance from the top of the actual image to the top of that portion of the image currently being displayed.
ScaleWidth | Double (Visual Basic) double (C#) | The horizontal scale between the displayed portion of the image and the actual image.
ScaleHeight | Double (Visual Basic) double (C#) | The vertical scale between the original image and the displayed image.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


FileEventArgs class

Newtone.ImageKit.Win.ImageKit.FileEventArgs Class

This class exposes properties for the StartLoad, EndLoad, StartSave, EndSave, and the GetDragDropFileName events.

[Visual Basic] Public Class FileEventArgs Inherits EventArgs
[C#] public class FileEventArgsF EventArgs

Explanation

Property | Type | Explanation
FileName | String (Visual Basic) string(C#) | Sets the name of the image file (full path) to be loaded, saved, or dragged and dropped

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseButtonEventArgs class

Newtone.ImageKit.Win.ImageKit.MouseButtonEventArgs Class

This class exposes properties for the MagnifierMouseDown, MagnifierMouseMove, and MagnifierMouseUp events.

[Visual Basic] Public Class MouseButtonEventArgs Inherits EventArgs
[C#] public class MouseButtonEventArgsF EventArgs

Explanation

Property | Type | Explanation
Button | Integer (Visual Basic) int (C#) | The type of button clicked (1: Left Button, 2: Right Button, 4: Center Button)
Shift | Integer (Visual Basic) int (C#) | The type of key pressed (0: None, 1: Shift Key, 2: Ctrl Key, 4: Alt Key)
X | Integer (Visual Basic) int (C#) | X coordinates for the center of the Magnifier (in pixcels)
Y | Integer (Visual Basic) int (C#) | Y coordinates for the center of the Magnifier (in pixcels)

If multiple keys are pressed, the values of Shift are combined in a bitwise OR operation.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseSelectEventArgs class

Newtone.ImageKit.Win.ImageKit.MouseSelectEventArgs Class

This class exposes properties for the MouseDownSelectLayerImage and MouseUpSelectLayerImage events.

[Visual Basic] Public Class MouseSelectEventArgs Inherits EventArgs
[C#] public class MouseSelectEventArgsF EventArgs

Explanation

Property | Type | Explanation
Index | integer (Visual Basic) int (C#) | Retrieves the index (from 0 to 99) of the layer-interface image that exists in the location where the mouse button was pressed (or released)
X | integer (Visual Basic) int (C#) | Retrieves the horizontal offset (in pixels) of the layer-interface image referred to by the Index parameter
Y | integer (Visual Basic) int (C#) | Retrieves the vertical offset (in pixels) of the layer-interface image referred to by the Index parameter

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseUpDownEventArgs class

Newtone.ImageKit.Win.ImageKit.MouseUpDownEventArgs Class

This class exposes properties for the MouseDownImage, MouseMoveImage, and MouseUpImage events.

[Visual Basic] Public Class MouseUpDownEventArgs Inherits EventArgs
[C#] public class MouseUpDownEventArgsF EventArgs

Explanation

Property | Type | Explanation
Button | Integer (Visual Basic) int (C#) | The type of button clicked (1: Left Button, 2: Right Button, 4: Center Button)
Shift | Integer (Visual Basic) int (C#) | The type of key pressed (0: None, 1: Shift Key, 2: Ctrl Key, 4: Alt Key) *1
OriginX | Integer (Visual Basic) int (C#) | The horizontal distance from the left side of the ImageKit Control to the left side of the image. (If the image is larger than the ImageKit Control in the horizontal direction, OriginX will equal 0.)
OriginY | Integer (Visual Basic) int (C#) | The vertical distance from the top of the ImageKit Control to the top of the image. (If the image is larger than the ImageKit Control in the vertical direction, OriginY will equal 0.)
Left | Integer (Visual Basic) int (C#) | The horizontal distance from the left side of the actual image to the left side of that portion of the image currently being displayed .
Top | Integer (Visual Basic) int (C#) | The vertical distance from the top of the actual image to the top of that portion of the image currently being displayed.
Right | Integer (Visual Basic) int (C#) | The horizontal distance from the left side of the actual image to the right side of that portion of the image currently being displayed.
Bottom | Integer (Visual Basic) int (C#) | The vertical distance from the top of the actual image to the top of that portion of the image currently being displayed.
ScaleWidth | Double (Visual Basic) double (C#) | The horizontal scale between the displayed portion of the image and the actual image .
ScaleHeight | Double (Visual Basic) double (C#) | The vertical scale between the original image and the displayed image.
X | Integer (Visual Basic) int (C#) | X coordinates on the image where the mouse button was pressed.
Y | Integer (Visual Basic) int (C#) | Y coordinates on the image where the mouse button was pressed.

The values are in pixels.

*1 When multiple keys are pressed at the same time, the Shift value is a bitwise OR operation

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseWheelEventArgs class

Newtone.ImageKit.Win.ImageKit.MouseWheelEventArgs Class

This class provides data of the MouseWheelDownImage and MouseWheelUpImage events.

[Visual Basic] Public Class MouseWheelEventArgs Inherits EventArgs
[C#] public class MouseWheelEventArgsF EventArgs

Explanation

Property | Type | Explanation
Shift | integer (Visual Basic) int (C#) | This parameter retrieves (in hexadecimal notation) the other types of buttons that are pressed at the time this event is generated. 0x0001: Left mouse button 0x0002: Right mouse button 0x0004: Shift key 0x0008: Ctrl key 0x0010: Middle mouse button If multiple buttons are pressed, the above values are combined in a bitwise OR operation. * The above hexadecimal notation is for VC++ or C++Builder For Delphi, please change the above 0x to $ For Visual Basic, please change the above 0x to &H
Direction | WheelDirection (Visual Basic) WheelDirection (C#) | Direction of the scroll (Vertical or Horizontal)

Direction refers to the value set in the MouseWheel property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


PointEventArgs class

Newtone.ImageKit.Win.ImageKit.PointEventArgs Class

This class exposes properties for the ClickOnPanWindow events.

[Visual Basic] Public Class PointEventArgs Inherits EventArgs
[C#] public class PointEventArgsF EventArgs

Explanation

Property | Type | Explanation
X | Integer (Visual Basic) int (C#) | Retrieves the x coordinate (in pixels) for the location of a mouse click in the Pan Window.
Y | Integer (Visual Basic) int (C#) | Retrieves the y coordinate (in pixels) for the location of a mouse click in the Pan Window.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ProgressEventArgs class

Newtone.ImageKit.Win.ImageKit.ProgressEventArgs Class

This class exposes properties for the Progress event.

[Visual Basic] Public Class ProgressEventArgs Inherits EventArgs
[C#] public class ProgressEventArgsF EventArgs

Explanation

Property | Type | Explanation
Cancel | Boolean (Visual Basic) bool (C#) | Sets whether or not the load or save process is canceled
Percent | Integer (Visual Basic) int (C#) | The percent of completion of the current process

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollDispEventArgs class

Newtone.ImageKit.Win.ImageKit.ScrollDispEventArgs Class

This class exposes properties for the ScrollDispImage event.

[Visual Basic] Public Class ScrollDispEventArgs Inherits EventArgs
[C#] public class ScrollDispEventArgsF EventArgs

Explanation

Property | Type | Explanation
Shift | integer (Visual Basic) int (C#) | This parameter returns different values depending on how the scrollbar was used 0: The up arrow on the vertical scroll box or the left arrow on the horizontal scroll box was clicked 1: The down arrow on the vertical scroll box or the right arrow on the horizontal scroll box was clicked 2: The vertical scroll box was clicked above the scroll bar or the horizontal scroll box was clicked to the left of the scroll bar 3: The vertical scroll box was clicked below the scroll bar or the horizontal scroll box was clicked to the right of the scroll bar 5: The scroll bar itself was moved 6: The scroll bar was moved to the top position (or the far left position) 7: The scroll bar was moved to the bottom position (or the far right position)
Pos | integer (Visual Basic) int (C#) | Returns the current position of the scroll bar
Direction | WheelDirection (Visual Basic) WheelDirection (C#) | The scroll direction: (Vertical or Horizontal)

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


AfterScanEventHandler delegate

Newtone.ImageKit.Win.ImageKit.AfterScanEventHandler Delegate

This delegate represents the method that handles the AfterScan
[Visual Basic] Public Delegate Sub AfterScanEventHandler(ByVal sender As Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs)
[C#] public delegate void AfterScanEventHandler(object sender, Newtone.ImageKit.AfterScanEventArgs e);

Parameters

sender
Event Source

e
Event data contained in AfterScanEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


AnnotationDrawEventHandler Delegate

Newtone.ImageKit.Win.ImageKit.AnnotationDrawEventHandler Delegare

This delegate represents the method that handles the StartDrawObject event and the EndDrawObject event.

[Visual Basic] Public Delegate Sub AnnotationDrawEventHandler(ByVal sender As Object, ByVal e As AnnotationDrawEventArgs)
[C#] public delegate void AnnotationDrawEventHandler(object sender, AnnotationDrawEventArgs e);

Parameters

sender
Event Source

e
Event data contained in AnnotationDrawEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


BeforeScanEventHandler delegate

Newtone.ImageKit.Win.ImageKit.BeforeScanEventHandler Delegate

This delegate represents the method that handles the BeforeScan event.
[Visual Basic] Public Delegate Sub BeforeScanEventHandler(ByVal sender As Object, ByVal e As Newtone.ImageKit.BeforeScanEventArgs)
[C#] public delegate void BeforeScanEventHandler(object sender, Newtone.ImageKit.BeforeScanEventArgs e);

Parameters

sender
Event Source

e
Event data contained in BeforeScanEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DispEventHandler delegate

Newtone.ImageKit.Win.ImageKit.DispEventHandler Delegate

This delegate represents the method that handles the StartDispImage event and the EndDispImage event.

[Visual Basic] Public Delegate Sub DispEventHandler(ByVal sender As Object, ByVal e As DispEventArgs)
[C#] public delegate void DispEventHandler(object sender, DispEventArgs e);

Parameters

sender
Event Source

e
Event data contained in DispEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


FileEventHandler delegate

Newtone.ImageKit.Win.ImageKit.FileEventHandler Delegate

This delegate represents the method that handles the StartLoad event, the EndLoad event, the StartSave event, the EndSave event, and the GetDragDropFileName event.
[Visual Basic] Public Delegate Sub FileEventHandler(ByVal sender As Object, ByVal e As FileEventArgs)
[C#] public delegate void FileEventHandler(object sender, FileEventArgs e);

Parameters

sender
Event Source

e
Event data contained in FileEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseButtonEventHandler delegate

Newtone.ImageKit.Win.ImageKit.MouseButtonEventHandler Delegate

This delegate represents the method that handles the MagnifierMouseDown event, the MagnifierMouseMove event, and the MagnifierMouseUp event.
[Visual Basic] Public Delegate Sub MouseButtonEventHandler(ByVal sender As Object, ByVal e As MouseButtonEventArgs)
[C#] public delegate void MouseButtonEventHandler(object sender, MouseButtonEventArgs e);

Parameters

sender
Event Source

e
Event data contained in MouseButtonEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseSelectEventHandler delegate

Newtone.ImageKit.Win.ImageKit.MouseSelectEventHandler Delegate

This delegate represents the method that handles the MouseDownSelectLayerImage event and theMouseUpSelectLayerImage event.
[Visual Basic] Public Delegate Sub MouseSelectEventHandler(ByVal sender As Object, ByVal e As MouseSelectEventArgs)
[C#] public delegate void MouseSelectEventHandler(object sender, MouseSelectEventArgs e);

Parameters

sender
Event Source

e
Event data contained in MouseSelectEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseUpDownEventHandler delegate

Newtone.ImageKit.Win.ImageKit.MouseUpDownEventHandler Delegate

This delegate represents the method that handles the MouseDownImage event, the MouseMoveImage event, and the MouseUpImage event.
[Visual Basic] Public Delegate Sub MouseUpDownEventHandler(ByVal sender As Object, ByVal e As MouseUpDownEventArgs)
[C#] public delegate void MouseUpDownEventHandler(object sender, MouseUpDownEventArgs e);

Parameters

sender
Event Source

e
Event data contained in MouseUpDownEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseWheelEventHandler delegate

Newtone.ImageKit.Win.ImageKit.MouseWheelEventHandler Delegate

This delegate represents the method that handles the MouseWheelDownImage event and the MouseWheelUpImage event.
[Visual Basic] Public Delegate Sub MouseWheelEventHandler(ByVal sender As Object, ByVal e As MouseWheelEventArgs)
[C#] public delegate void MouseWheelEventHandler(object sender, MouseWheelEventArgs e);

Parameters

sender
Event Source

e
Event data contained in MouseWheelEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


PointEventHandler delegate

Newtone.ImageKit.Win.ImageKit.PointEventHandler Delegate

This delegate represents the method that handles the ClickOnPanWindow event.
[Visual Basic] Public Delegate Sub PointEventHandler(ByVal sender As Object, ByVal e As PointEventArgs)
[C#] public delegate void PointEventHandler(object sender, PointEventArgs e);

Parameters

sender
Event Source

e
Event data contained in PointEventArgs

Return Value

Returns True if successful. Returns False if unsuccessful.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ProgresstEventHandler delegate

Newtone.ImageKit.Win.ImageKit.ProgresstEventHandler Delegate

This delegate represents the method that handles the Progress event.
[Visual Basic] Public Delegate Sub ProgresstEventHandler(ByVal sender As Object, ByVal e As ProgressEventArgs)
[C#] public delegate void ProgresstEventHandler(object sender, ProgressEventArgs e);

Parameters

sender
Event Source

e
Event data contained in ProgressEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollDispEventHandler delegate

Newtone.ImageKit.Win.ImageKit.ScrollDispEventHandler Delegate

This delegate represents the method that handles the ScrollDispImageevent.
[Visual Basic] Public Delegate Sub ScrollDispEventHandler(ByVal sender As Object, ByVal e As ScrollDispEventArgs)
[C#] public delegate void ScrollDispEventHandler(object sender, ScrollDispEventArgs e);

Parameters

sender
Event Source

e
Event data contained in ScrollDispEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DeleteMultiSelectedObjects method

Newtone.ImageKit.Win.ImageKit.Edit.DeleteMultiSelectedObjects Method

This method deletes all objects selected when the EditKind property is set to KindOfEdit .MultiSelect .

[Visual Basic] Public Function DeleteMultiSelectedObjects() As Boolean
[C#] public bool DeleteMultiSelectedObjects();

Parameters

None

Return Value

Returns True if successful, otherwise returns False.

Explanation

The DeleteMultiSelectedObjects method deletes all objects selected when the EditKind property is set to KindOfEdit .MultiSelect .

When the EditKind property is set to KindOfEdit.MultiSelect and objects are selected, executing this method will delete those objects. Right clicking on the objects to display the context menu and selecting "Undo" or executing the Undo method will bring the objects back.

To perform the same function as executing this method, right click the object and display the context menu then select "Delete". For more details about the context menu, please refer to ContextMenuEnabled property.

See also

ImageKit.Edit Members | Newtone.ImageKit.Win.ImageKit


Cancel property

Newtone.ImageKit.Win.ImageKit.Effect.Cancel Property

This property sets whether or not the effect processing is canceled.

[Visual Basic] Public WriteOnly Property Cancel As Boolean
[C#] public bool Cancel {set;}

Property Value

Value | Explanation
True | The Effect process is canceled
False | The Effect process is not canceled

Explanation

The Cancel property sets whether or not the effect processing is canceled.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


DXFBlack property

Newtone.ImageKit.Win.ImageKit.Layer[Index].DXFBlack Property

This property sets whether or not white is displayed as black and black is displayed as white in DXF images. The index can range from 0 to 99.

[Visual Basic] Public Property DXFBlack As Boolean
[C#] public bool DXFBlack {get; set;}

Property Value

Value | Explanation
True | Black is displayed as white and white is displayed as black in DXF images (default)
False | The DXF images is displayed as normal

Explanation

The DXFBlack property sets whether or not white is displayed as black and black is displayed as white in DXF images. The default value is True. When this property is true, black and white are exchanged when the DXF image is displayed. This is useful when white lines are draw in DXF data. If they are displayed normally on a white display control then the white lines will not appear.

To use this property, you must have the appropriate ImageKit.NET3 plugin Dll files (Win32 Dlls).

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


BaseImageKitPenWidth property

Newtone.ImageKit.Win.ToolBarStandard.BaseImageKitPenWidth Property

This property sets or retrieves the value of the Edit.PenWidth property of the ImageKit control.

[Visual Basic]Public Property BaseImageKitPenWidth As Integer
[C#]public int BaseImageKitPenWidth {get; set;}

Property Value

An integer that represents the width of the pen
Default value is 1.

Explanation

The BaseImageKitPenWidth property sets or retrieves the value of the Edit.PenWidth property of the ImageKit control. When the SettingsForEachImageKit property is False, use the BaseImageKitPenWidth property to set the Edit.PenWidth property for all ImageKit controls on the form.

This property is enabled when the SettingsForEachImageKit property is False.

See Also

ToolBarStandard Members | Newtone.ImageKit.Win.ToolBarStandard