Newtone.ImageKit.Web

ImageKit.NET

ImageKit.NET Reference

ImageKit.NET Reference

Newtone Corporation
1-6-43 Kotobuki
Nagaoka City, Niigata Prefecture, 940-0015
JAPAN
Fax: +81-258-24-7905
http://www.imagekit.com
iksupport@imagekit.com


Installation

ImageKit.NET

How To Install The ImageKit.NET

To install the trial version of the ImageKit.NET, please run one of the following install programs:

For VS2003 - ImageKitNETVS2003e.msi
For VS2005 - ImageKitNETVS2005e.msi
For VS2008 - ImageKitNETVS2008e.msi

To install the retail version of the ImageKit.NET, first install the trial version.

Once the trial version has been installed, run the ImageKit.NET License installation program:
ImageKitNETLICe.msi

IMPORTANT: If you have purchased the ImageKit.NET and have not received the ImageKit.NET License installer,
please contact Newtone Corporation or your software vendor immediately.


LicenseKey

ImageKit.NET

How To Set The ImageKit.NET License Key

When deploying applications that contain the ImageKit.NET to a target machine or when creating ImageKit.NET objects using the class reference, you may enable the retail version by setting the ImageKit.NET license key. Without the license key your application will run as the trial verison.

The licensekey takes the following syntax:

<controlname>.LicenseKey = "xxx-xxx-xxx"

The values to enable the ImageKit.NET license can be found in the "Doc" folder under the directory where the ImageKit.NET license is installed.

To set the ImageKit.NET license key in your application, in the very beginning of your program, do the following...

In WinForm Applictions

// In C#
private void Form1_Load(object sender, System.EventArgs e)
{
<controlname>.LicenseKey = "xxx-xxx-xxx";
.
.
.
}

'In VB.NET
Private Sub Form1_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
<controlname>.LicenseKey = "xxx-xxx-xxx"
.
.
.
End Sub

In WebForm Applications

// In C#
private void Page_Load(object sender, System.EventArgs e)
{
<controlname>.LicenseKey = "xxx-xxx-xxx";
.
.
.
}

' In VB.NET
Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
<controlname>.LicenseKey = "xxx-xxx-xxx"
.
.
End Sub

For example, if the <controlname> for the ImageKit Control is ImageKit1, and for the Thumbnail Control is Thumbnail1 then the following will allow your application to run the ImageKit.NET retail version.

//In C#
ImageKit1.LicenseKey = "xxx-xxx-xxx";
Thumbnail1.LicenseKey = "xxx-xxx-xxx";

'In VB.NET
ImageKit1.LicenseKey = "xxx-xxx-xxx"
Thumbnail1.LicenseKey = "xxx-xxx-xxx"

You must set the license key for each ImageKit.NET object is instantiated. For example, if you WinForm application has more than one ImageKit control on the form, then enable each ImageKit like this...

//In C#
ImageKit1.LicenseKey = "xxx-xxx-xxx";
ImageKit2.LicenseKey = "xxx-xxx-xxx";
ImageKit3.LicenseKey = "xxx-xxx-xxx";

'In VB.NET
ImageKit1.LicenseKey = "xxx-xxx-xxx"
ImageKit2.LicenseKey = "xxx-xxx-xxx"
ImageKit3.LicenseKey = "xxx-xxx-xxx"

When using the class reference set the license key in this way....
//In C#
private void Form1_Load(object sender, System.EventArgs e)
{
Ik_File = new IkFile();
Ik_File.LicenseKey = "xxx-xxx-xxx";
}

' In VB.NET
Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
Dim Ik_File as new IkFile()
Ik_File.LicenseKey = "xxx-xxx-xxx"
End Sub


Deployment

ImageKit.NET

How To Deploy Applications Containing ImageKit.NET Functionality

After you have created an application containing ImageKit.NET functionality, be sure to include the following files when you deploy the application....

Using the ImageKit Control in a WinForm Application, include the following files:
Newtone.ImageKit.Win.ImageKit.dll
Newtone.ImageKit.Common.dll
Newtone.ImageKit.Effect.dll
Newtone.ImageKit.File.dll
Newtone.ImageKit.Scan.dll

Using the Thumbnail Control in a WinForm Application, include the following files
Newtone.ImageKit.Win.Thumbnail.dll
Newtone.ImageKit.Common.dll
Newtone.ImageKit.File.dll

Using the ImageKit Control in a WebForm Application, include the following files
Newtone.ImageKit.Web.ImageKit.dll
Newtone.ImageKit.Common.dll
Newtone.ImageKit.File.dll

Using the Thumbnail Control in a WebForm Application, include the following files
Newtone.ImageKit.Web.Thumbnail.dll
Newtone.ImageKit.Common.dll
Newtone.ImageKit.File.dll

Distributing applications that DO NOT have the ImageKit Control, include the following files
Newtone.ImageKit.Common.dll (Absolutely necessary)
Newtone.ImageKit.File.dll (Absolutely necessary)
Newtone.ImageKit.Effect.dll (Necessary if processing an effect)
Newtone.ImageKit.Scan.dll (Necessary if using a TWAIN device to retrieve image data)

IMPORTANT: Make sure that the ImageKit.NET license key has been set in your application.

For details see Setting the License Key


Contacting Us

ImageKit.NET

Where To Get Technical Support

Please feel free to contact us if you have any questions or comments about us or our products.

Newtone Corporation
1-6-43 Kotobuki
Nagaoka City, Niigata Prefecture, 940-0015
JAPAN
Fax: +81-258-24-7905

Website: http://www.imagekit.com

Email: iksupport@imagekit.com

When contacting us for technical support, please include the following information.

User Information

Name - The name of the person who is registered to receive support.

Product Information

Product name
Version number
Product Serial Number - provided by the vendor when the ImageKit was purchased.
The DLL file time stamp.

Development Environment Information

Operating system
Development container
If your inquiry involves a scanner or digital camera, please include the model and version number of that TWAIN device.

Inquiries

Please explain the circumstances or conditions under which the problem or question exists. This explanation should be made as clearly and concisely as possible. If it is difficult to explain the problem in writing, please feel free to attach a small sample program that illustrates the problem. However, make sure that all programming not directly related to the issue at hand is eliminated from the program before sending it to us. Furthermore, please compress all sample programs into ZIP compression format before sending.

Note

Support is only available to REGISTERED users. For more information about user registration,see our web site at http://www.imagekit.com/registration.html


Newtone.ImageKit.Web

ImageKit.NET

ImageKit.NET Structure

ImageKit.NET Assembly Files

The following are the ImageKit.NET assembly files

Newtone.ImageKit.Win.ImageKit.dll (WindowsForm ImageKit Control)
Newtone.ImageKit.Win.Thumbnail.dll (WindowsForm Thumbnail Control)
Newtone.ImageKit.Web.ImageKit.dll (WebForm ImageKit Control)
Newtone.ImageKit.Web.Thumbnail.dll (WebForm Thumbnail Control)

Newtone.ImageKit.Common.dll (WindowsForm and WebForm Class Library)
Newtone.ImageKit.Effect.dll (WindowsForm and WebForm Class Library)
Newtone.ImageKit.File.dll (WindowsForm and WebForm Class Library)
Newtone.ImageKit.Scan.dll (WindowsForm and WebForm Class Library)

ImageKit.NET Assembly Structure

Each Control is associated with the following files:

The WindowsForm Controls:

Newtone.ImageKit.Win.ImageKit.dll
|--- Newtone.ImageKit.Common.dll
|--- Newtone.ImageKit.File.dll
|--- Newtone.ImageKit.Scan.dll
|--- Newtone.ImageKit.Effect.dll

Newtone.ImageKit.Win.Thumbnail.dll
|--- Newtone.ImageKit.Common.dll
|--- Newtone.ImageKit.File.dll

The WebForm Controls:

Newtone.ImageKit.Web.ImageKit.dll
|--- Newtone.ImageKit.Common.dll
|--- Newtone.ImageKit.File.dll

Newtone.ImageKit.Web.Thumbnail.dll
|--- Newtone.ImageKit.Common.dll
|--- Newtone.ImageKit.File.dll

IkStream.ashx is required in ImageKit Web Applications

The IkStream.ashx file is required when using the ImageKit.Web.ImageKit Control, to stream image data from the server to the client browser.


Newtone.ImageKit.Web

ImageKit.NET

Increase The Power Of The ImageKit.NET

Increase the power of the ImageKit.Net

You can increase the functionality of the ImageKit.NET by including the ImageKit ActiveX DLL files (sold seperately) with your executable file. By simply placing the appropriate ImageKit ActiveX DLL files in the same folder as your executable file, you will be able to load and save image formats that are not supported by .NET framework.

Note that using ImageKit Active DLL files will result in unmanaged code.

The current version of the ImageKit ActiveX is ImageKit7:

Ik7Com.dll (The DLL for general image processing done by the ImageKit7)
Ik7VectCom.dll (The DLL for general vector file processing)
Ik7File.dll (The main DLL for processing image files)
| raster formats
|--- Ik7Bmp.dll
|--- Ik7Fpx.dll
|--- Ik7Gif.dll
|--- Ik7J2k.dll
|--- Ik7Jpeg.dll
|--- Ik7Pcx.dll
|--- Ik7Png.dll
|--- Ik7Tiff.dll
| vector formats
|--- Ik7Dxf.dll
|--- Ik7Emf.dll
|--- Ik7Svg.dll
|--- IK7SxfP21.dll
|--- IK7SxfSfc.dll
|--- Ik7Wmf.dll

For more information about each of the above ImageKit7 DLL files, please refer to the ImageKit7 Reference documentation available on our web site at www.imagekit.com


GettingStartedASPNet.htm

ImageKit.NET

When using browsers other than Microsoft Internet Explorer

ImageKit.NET requires HTML 4.0 or above

When using Visual Studio.NET to develop web applications, the actual HTML generated by .NET framework depends on the browser. For "uplevel" browsers, HTML version 4.0 or above is generated. For "downlevel", HTML 3.2 is generated.

Unfortunately, when using browsers other than Internet Explorer, the "definition" of what constitues an "uplevel" browser often lags far behind the actual functionality of the browser. Because the ImageKit.NET requires HTML 4.0 or above, in order for your web application to run properly on browsers other than Internet Explorer, you must do either one of the following things:

1. Alter your ASPX file to specify "uplevel" browsers:

Change the page definition from

  <%@ Page language="c#" %>
to
  <%@ Page ClientTarget="uplevel" language="c#" %>

2. Update the browserCaps section of the Web.config file:

In your project folder, update the Web.config file as follows: place the browserCaps section below (including the <browserCaps> and </browserCaps> tags) into the section in your Web.config file between the <system.web> tag and the </system.web> tag.

For convenience, there is a sample Web.config file provided with the ImageKit.NET. It can be found in the subdirectory called "System" under the directory where the ImageKit.NET is installed.

    <browserCaps>
            <!--
             Name: BrowserCaps update for modern browsers, http://slingfive.com/pages/code/browserCaps/
             Author: Rob Eberhardt, http://slingfive.com/
             History:
             2004-11-19 improved detection of Safari, Konqueror &amp; Mozilla variants, added Opera detection
             2003-12-21 updated TagWriter info
             2003-12-03 first published
             -->

             <!-- GECKO Based Browsers (Netscape 6+, Mozilla/Firefox, ...) //-->
             <case match="^Mozilla/5\.0 \([^)]*\) (Gecko/[-\d]+)(?'VendorProductToken' (?'type'[^/\d]*)([\d]*)/(?'version'(?'major'\d+)(?'minor'\.\d+)(?'letters'\w*)))?">
             browser=Gecko
             <filter>
             <case match="(Gecko/[-\d]+)(?'VendorProductToken' (?'type'[^/\d]*)([\d]*)/(?'version'(?'major'\d+)(?'minor'\.\d+)(?'letters'\w*)))">
             type=${type}
             </case>
             <case> <!-- plain Mozilla if no VendorProductToken found -->
             type=Mozilla
             </case>
             </filter>
             frames=true
             tables=true
             cookies=true
             javascript=true
             javaapplets=true
             ecmascriptversion=1.5
             w3cdomversion=1.0
             css1=true
             css2=true
             xml=true
             tagwriter=System.Web.UI.HtmlTextWriter
             <case match="rv:(?'version'(?'major'\d+)(?'minor'\.\d+)(?'letters'\w*))">
             version=${version}
             majorversion=0${major}
             minorversion=0${minor}
             <case match="^b" with="${letters}">
             beta=true
             </case>
             </case>
             </case>

             <!-- AppleWebKit Based Browsers (Safari...) //-->
             <case match="AppleWebKit/(?'version'(?'major'\d?)(?'minor'\d{2})(?'letters'\w*)?)">
             browser=AppleWebKit
             version=${version}
             majorversion=0${major}
             minorversion=0.${minor}
             frames=true
             tables=true
             cookies=true
             javascript=true
             javaapplets=true
             ecmascriptversion=1.5
             w3cdomversion=1.0
             css1=true
             css2=true
             xml=true
             tagwriter=System.Web.UI.HtmlTextWriter
             <case match="AppleWebKit/(?'version'(?'major'\d)(?'minor'\d+)(?'letters'\w*))(.* )?(?'type'[^/\d]*)/.*( |$)">
             type=${type}
             </case>
             </case>

             <!-- Konqueror //-->
             <case match=".+[K|k]onqueror/(?'version'(?'major'\d+)(?'minor'(\.[\d])*)(?'letters'[^;]*));\s+(?'platform'[^;\)]*)(;|\))">
             browser=Konqueror
             version=${version}
             majorversion=0${major}
             minorversion=0${minor}
             platform=${platform}
             type=Konqueror
             frames=true
             tables=true
             cookies=true
             javascript=true
             javaapplets=true
             ecmascriptversion=1.5
             w3cdomversion=1.0
             css1=true
             css2=true
             xml=true
             tagwriter=System.Web.UI.HtmlTextWriter
             </case>

             <!-- Opera //-->
             <case match="Opera[ /](?'version'(?'major'\d+)(?'minor'\.(?'minorint'\d+))(?'letters'\w*))">
             <filter match="[7-9]" with="${major}">
             tagwriter=System.Web.UI.HtmlTextWriter
             </filter>
             <filter>
             <case match="7" with="${major}">
             <filter>
             <case match="[5-9]" with="${minorint}">
             ecmascriptversion=1.5
             </case>
             <case>
             ecmascriptversion=1.4
             </case>
             </filter>
             </case>
             <case match="[8-9]" with="${major}">
             ecmascriptversion=1.5
             </case>
             </filter>
             </case>
  </browserCaps>

Note:

The ImageKit and PanWindow may not work correctly on all browsers

Also See

ImageKit Members | Newtone.ImageKit.Web.ImageKit


ImageKitWebImageKit.htm

ImageKit.NET

Using the WebForm ImageKit Control

Using the ImageKit.Web ImageKit Control

1. Add the ImageKit Control to the toolbox

When the install program executes, the ImageKit.NET Controls are automatically added to the toolbox. However, you can add them to the toolbox manually using the following steps:

Right click your mouse in the "Toolbox" and choose to "Add Tab".
After naming the new tab, right click it and choose "Add/Remove Items". (In Visual Studio 2005 or 2008, select "Choose Items")
Click the "Browse" button and select "Newtone.ImageKit.Web.ImageKit.dll"
Click the "OK" button

The WebForm ImageKit and PanWindow Controls are now registered in the toolbox.

2. Virtual Directory

In the explanation below, the file name is set in the ImageKit1.Url property. Note that this is a virtual path and not a physical path. For more information, please refer to the Url property.

3. Streaming images

By default, images are streamed to the browser and displayed. To enable streaming, the IkStream.ashx file must be copied into the root directory of the web application. You can find the IkStream.ashx file in the folder called "System" under the directory where you installed the ImageKit.NET.

Below is an example of how to steam a TIF file from the server to the client browser:

  1. Create a new ASP.NET web application project in Visual Studio
  2. Drag the ImageKit Control from the toolbox onto the WebForm and resize it.
  3. Copy the "IkStream.ashx" file into the web application's root directory.
  4. Under the WebForm's Page_Load event, copy the following code:
  5. [Visual Basic]
    Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        ImageKit1.Url = "abc.tif"
        ImageKit1.LoadFile(Newtone.ImageKit.Web.LoadFormatConstants.Load)
        ImageKit1.Display(Newtone.ImageKit.Web.DispModeConstants.ActualSize)
    End Sub
    [C#]
    private void Page_Load(object sender, System.EventArgs e)
    {
        ImageKit1.Url="abc.tif";
        ImageKit1.LoadFile(Newtone.ImageKit.Web.LoadFormatConstants.Load);
        ImageKit1.Display(Newtone.ImageKit.Web.DispModeConstants.ActualSize);
    }
  6. Confirm the the virtual path to the image, set in the Url property is correct, and run the application. In the client browser and image is displayed (in Jpeg format) in the "scrollable" ImageKit Control.


ImageKitWebThumbnail.htm

ImageKit.NET

Using the ImageKit.Web Thumbnail Control

Thumbnail Images

Displaying a large number of images in a web application presents a number of challanges. The Thumbnail Control allows you to easily display numberous images as thumbnail images.

Using the ImageKit.Web Thumbnail Control

Below is an explanation of how to use the Thumbnail Control in a Microsoft ASP.NET web application

Registering the ImageKit.Web Thumbnail Control in the toolbox

By running the ImageKit.NET installation program, the Thumbnail Control is automatically added to the toolbox. Below is an explanation of how to add the Thumbnail Control to the toolbox manually:

  1. Place the mouse cursor over the toolbox and right click. Select "Add Tab"
  2. Place the mouse cursor over the new tab and right click. Select the "Add/Remove Items". (In Visual Studio 2005 or 2008, select "Choose Items").)
  3. In the displayed dialog, click the "Browse" button and navigate to the directory where the ImageKit.NET is installed. Select the "Newtone.ImageKit.Web.Thumbnail.dll".
  4. Click Ok

The WebForm Thumbnail Control has now be registered in the toolbox.

Virtual Directory

The directory containing the image files and the directory where the thumbnail image files will be created are both virtual directories. For more information please refer to the Newtone.ImageKit.Web.Thumbnail Class.

Creating a project

Below is an explanation for creating a simple project that uses the ImageKit.Web.Thumbnail Control

  1. Create a new ASP.NET web application project in Visual Studio
  2. From the toolbox, place the Thumbnail Control on the WebForm.
  3. Set the Thumbnail Controls size and location. Also set the ColumnNumber, RowNumber, ImageWidth, ImageHeight, CellSpacing and other properties.
  4. In the Page_Load event, copy the following code:
    [Visual Basic]
    Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
      If IsPostBack = False Then
    'Set the virtual path to the directory containing the images...
    Thumbnail1.ImageDirectory = "/SampleImages/1"
    Thumbnail1.ThumbnailImageDirectory = "/SampleImages/1/ThumbnailImages"
    Thumbnail1.ShowThumbnailImages()
  End If
End Sub
    [C#]
    private void Page_Load(object sender, System.EventArgs e)
    {
      Thumbnail1.ImageDirectory="/SampleImages/1";
  Thumbnail1.ThumbnailImageDirectory="/SampleImages/1/ThumbnailImages";
  Thumbnail1.ShowThumbnailImages();
}
  5. Confirm that the virtual path to the SampleImages directory is correct and run the application. The Thumbnail Control will automatically create the thumbnail images and display them in a table in the client browser.

In the above, the directory containing the images is "/SampleImageS/1" and the thumbnail image directory (where created thumbnail images are saved) is the "/SampleImages/1/ThumbnailImages" directory. Be sure that these directories exist and the IIS settings for them are correct.

Server Resources

Like all server components, when using the Thumbnail Control, conserving server resources is always a consideration. The following items can be recommended when server resources are scarce:

  1. As much as possible, do not call the DeleteThumbnailDirectory method. If the thumbnail directory does not exist then all thumbnail images must be created. Needless calls to the DeleteThumbnailDirectory method forces the server to recreate thumbnail images when this is not needed.
  2. Keep the size of the thumbnail images as small as is practical.
  3. Keep changes to the thumbnail file to a minimum.

Using the Thumbnail Control with the ImageKit Control

When using the Thumbnail Control on one WebForm and the ImageKit Control on another WebForm, set the Thumbnail Control's EnablePaging property to False.

Below is an example where the Thumbnail Control is on WebForm1 and the selected thumbnail's corresponding image is displayed in the ImageKit Control on WebForm2.

[Visual Basic.NET]
Private Sub Thumbnail1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles Thumbnail1.Click
    Server.Transfer("WebForm2.aspx?str=" + Thumbnail1.ImageDirectory + "/" + Thumbnail1.FileName)
End Sub

[Visual C#.NET]
private void Thumbnail1_Click(object sender, System.EventArgs e)
{
    Response.Redirect("WebForm2.aspx?str=" + Thumbnail1.ImageDirectory + "/" + Thumbnail1.FileName, false);
}

Also See

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ImageKit class

Newtone.ImageKit.Win

Newtone.ImageKit.Win.ImageKit Class

The main class for the WinForm ImageKit Control.

For a list of all members of this type, see ImageKit Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Newtone.ImageKit.Win
public class ImageKit : System.Windows.Forms.Control

Explanation

This ImageKit Control allows you to add image processing functionality to your applications. Load and save images, retrieve images from TWAIN scan devices, display images, apply image effects and transformations, draw to image, print and much more.

Requirements

Namespace : Newtone.ImageKit.Win

Assembly : Newtone.ImageKit.Win.ImageKit.dll

See Also

ImageKit Members


ImageKit Members

Newtone.ImageKit.Win.ImageKit All Members

ImageKit Overview

Constructor

ImageKit Constructor Initializes a new instance of the ImageKit class.

Public Properties

Appearance | Sets the appearance of the ImageKit Control border
AutoSize | Sets whether or not the ImageKit Control will be resized to fit the size of the image
BitCount | The number of bits per pixel in the image
BorderColor | Sets the color of the ImageKit Control border when the Appearance property is Newtone.ImageKit.Win.AppearanceStyle.Flat
BorderVisible | Sets whether or not the ImageKit Control border is visible
ClickPointBlue | Refers to the blue value of the pixel at the clicked location in the base image in the ImageKit Control
ClickPointGreen | Refers to the green value of the pixel at the clicked location in the base image in the ImageKit Control
ClickPointRed | Refers to the red value of the pixel at the clicked location in the base image in the ImageKit Control
DefaultMouseCursor | Sets the default mouse cursor in the ImageKit Control
DrawCenterX | Sets the x-coordinate of a point on an image that will be displayed from the center of the ImageKit Control
DrawCenterY | Sets the y-coordinate of a point on an image that will be displayed from the center of the ImageKit Control
DrawOnlyBaseImage | Sets whether or not only the base image is displayed in the ImageKit Control
DrawScaleX | Sets the horizontal magnification at which and image is displayed in the ImageKit Control
DrawScaleY | Sets the vertical magnification at which and image is displayed in the ImageKit Control
DXFBlack | Sets whether or not white is displayed as black and black is displayed as white in DXF images
ErrorStatus | Refers to the types of errors that can occur when using the ImageKit Control
Gray | Determines whether or not the image is grayscale
Image | Sets or retrieves the base image
ImageKind | Refers to the image type
ImageSize | Refers to the size of the image in bytes
ImageWidthByte | Refers to the number of bytes per line in the image
InvalidHatchColor | Sets the color of the hatch pattern shown in the ImageKit Control when an image is not displayed
InvalidHatchPattern | Sets the pattern that is displayed in that portion of the ImageKit control not covered by an image
LayerNumber | Sets the image to be processed (either the base image or one of the layer images)
MouseDragImage | Sets whether or not the image in the ImageKit Control can be scrolled by dragging it with the mouse
MouseWheelDirection | Sets whether the mouse wheel can be used to scroll
PaletteCount | Refers to the number of palette colors for the image
Rect | Sets the rectangle selected on the base image with the mouse in the ImageKit Control
RectColor1 | Sets the one of the colors of the dotted line that distinguishes the selected area in the ImageKit Control
RectColor2 | Sets the one of the colors of the dotted line that distinguishes the selected area in the ImageKit Control
RectDraw | Sets whether an area can be selected on the base image in the ImageKit Control
RectDrawFix | Sets whether or not the selected area drawn on the base image in the ImageKit Control can be resized with the mouse
RectDrawRatio | Sets the ratio of the height to the width in the selected area drawn on the base image in the ImageKit Control
RectMouseCursor | Sets the shape of the mouse cursor when the mouse is dragged within the ImageKit Control
Refine1BitImage | Sets whether or not a 1 bit color image will be displayed in high quality in the ImageKit Control
ScrollBar | Sets whether or not scroll bars are displayed on the ImageKit Control
ScrollValueH | Sets the horizontal value (in pixels) of the scroll for the image displayed in the ImageKit Control
ScrollValueV | Sets the vertical value (in pixels) of the scroll for the image displayed in the ImageKit Control
ShowImage | Sets whether or not the base image is displayed in the ImageKit Control
ShowPanWindowImage | Sets whether or not the base image is displayed in the Pan window
StartDrawX | Sets the point on the image that will be displayed from the top left corner of the ImageKit Control
StartDrawY | Sets the point on the image that will be displayed from the top left corner of the ImageKit Control
ToolTip | Sets the units of measurement at which the tool tip coordinates are displayed
Transparent | Enables the transparent color in the base image
TransparentBlue | Sets the blue value for the transparent color in the base (raster) image
TransparentGreen | Sets the green value for the transparent color in the base (raster) image
TransparentRed | Sets the red value for the transparent color in the base (raster) image

Public Methods

ClearClipBoard | Clears the clipboard
Display | Displays the image
GetFromClipBoard | Retrieves the raster image or the vector image from the clipboard
GetImageType | Sets the image information into various ImageKit properties
GetOneBitPaletteCount | Retrieves the number of 0 pixels and 1 pixels from a 1 bit color image
GetPalette | Retrieves the palette information for a raster image
IsClipBoardData | Checks whether or not there is clipboard data
ScrollImage | Scrolls the image
SetToClipBoard | Copies a raster image to the clipboard
Zoom | Zooms in on the area specified in the image

Public Events

AfterScan | Generated after an image is scanned with the scan device
BeforeScan | Generated just before an image is scanned with the scan device
ClickOnPanWindow | Generated when the mouse cursor is inside the pan window and the left mouse button is pressed
EndDispImage | Generated just after the image has been displayed
EndLoad | Generated after a file has loaded
EndRasterToVector | Generated after a raster image has been converted to a vector image
EndSave | Generated after a file has finished being saved
EndVectorToRaster | Generated after a vector image has been converted to a raster image
GetDragDropFileName | Generated after an image is dragged and dropped into the ImageKit Control
MagnifierMouseDown | Generated when the mouse button is pressed inside the Magnifier
MagnifierMouseMove | Generated when the mouse cursor is moved within the Magnifier
MagnifierMouseUp | Generated when the mouse button is released inside the Magnifier
MouseDownImage | Generated when the mouse cursor is inside the image and the mouse button has been pressed
MouseDownSelectLayerImage | Generated when the mouse cursor is over a layer image and the mouse button is been pressed
MouseMoveImage | Generated when the mouse moves over the image
MouseUpImage | Generated when the mouse cursor is inside the image and the mouse button has been released
MouseUpSelectLayerImage | Generated when the mouse cursor is over a layer image and the mouse button is been released
MouseWheelDownImage | Generated when the mouse wheel is rolled down
MouseWheelUpImage | Generated when the mouse wheel is rolled up
Progress | Generated when an effect is being processed or a file is being loaded or saved
Scanning | Generated when an image is being scanned by the scan device
ScrollDispImage | Generated when a scroll bar is used to scroll the image
StartDispImage | Generated just before the image is displayed
StartLoad | Generated before a file has started to load
StartRasterToVector | Generated when a raster image is converted to a vector image.
StartSave | Generated when a file is saved
StartVectorToRaster | Generated when a vector image is converted to a raster image

Hierarchical Properties

Effect | Exposes properties and methods for processing imaging effects (effect filters, transformations, conversions, etc)
File | Exposes properties and methods for processing image files
Layer | Exposes properties related to the 100 distinct image layers possible when displaying images in the ImageKit Control
Magnifier | Exposes properties and methods related to the magnifying glass display
PanWindow | Exposes properties and methods related to the pan window display
Scan | Exposes properties and methods related to using scan devices and digital cameras
Vector | Exposes properties and methods related to creating vector images or converting raster images to vector images and vice versa

See Also

Newtone.ImageKit.Win.ImageKit


ImageKit Constructor

Newtone.ImageKit.Win.ImageKit Constructor

This initializes a new instance of the ImageKit class.
[Visual Basic] Public Sub New()
[C#] public ImageKit()

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Appearance property

Newtone.ImageKit.Win.ImageKit.Appearance Property

This property sets the appearance of the ImageKit Control border.

[Visual Basic] Public Property Appearance As AppearanceStyle
[C#] public AppearanceStyle Appearance {get; set;}

Property Value

This value is of type AppearanceStyle

Explanation

The Appearance property sets the appearance of the ImageKit Control border. This property is only enabled when the BorderVisible property is set to True. When the Apperance property is set to Flat, the color is the border is determined by the BorderColor property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


AutoSize property

Newtone.ImageKit.Win.ImageKit.AutoSize Property

This property sets whether or not the ImageKit Control will be resized to fit the size of the image.

[Visual Basic] Public Property AutoSize As Boolean
[C#] public bool AutoSize {get; set;}

Property Value

Value | Explanation
True | The ImageKit Control will be resized to fit the size of the image
False (default) | The size of the ImageKit Control, as determined at design-time or at run-time by the Height and Width properties, will be maintained

Explanation

The AutoSize property sets whether or not the ImageKit Control will be resized to fit the size of the image. When true, the ImageKit Control's top, left position is maintained and the ImageKit Control's height and width are changed to fit the size of the image.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


BitCount property

Newtone.ImageKit.Win.ImageKit.BitCount Property

This property refers to the number of bits per pixel in the image set in the Image property.

[Visual Basic] Public ReadOnly Property BitCount As Integer
[C#] public int BitCount {get;}

Property Value

The number of bits per pixel in an image

Value | Explanation
1 | 2 color (i.e. Black and White)
4 | 16 color
8 | 256 color
16 | 16 bit color
24 | 24 bit color
32 | 32 bit color

Explanation

The BitCount property refers to the number of bits per pixel in the image. After setting the Image property, the BitCount property value is automatically updated. This property is not valid for vector images.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


BorderColor property

Newtone.ImageKit.Win.ImageKit.BorderColor Property

This property sets the color of the ImageKit Control border.

[Visual Basic] Public Property BorderColor As Color
[C#] public Color BorderColor {get; set;}

Property Value

The default value is "Black".

Explanation

The BorderColor property sets the color for the border of the ImageKit Control. This property is only enabled when the BorderVisible property is set to True. When the Appearance property is set to AppearanceStyle.Flat, the color set into this property is used.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


BorderVisible property

Newtone.ImageKit.Win.ImageKit.BorderVisible Property

This property sets whether or not the ImageKit Control border is visible.

[Visual Basic] Public Property BorderVisible As Boolean
[C#] public bool BorderVisible {get; set;}

Property Value

Value | Explanation
True | The ImageKit Control border is visible
False (default) | The ImageKit Control border is not visible

Explanation

This property sets whether or not the ImageKit Control border is visible. When this property is set to True, the value set into theAppearance property is used.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ClickPointBlue property

Newtone.ImageKit.Win.ImageKit.ClickPointBlue Property

This property, ClickPointRed and ClickPointGreen properties refers to the RGB value of the pixel at the clicked location in the base image in the ImageKit Control.

[Visual Basic] Public ReadOnly Property ClickPointBlue As Byte
[C#] public byte ClickPointBlue {get;}

Property Value

Values range from 0 to 255

Read Only

Explanation

You can easily retrieve color information from the base image displayed in the ImageKit Control. All you need to do is to click on the color in the base image that you want to retrieve and the respective RGB values for that pixel are set in the ClickPointRed, ClickPointGreen and ClickPointBlue properties. The ClickPointBlue property refers to the blue value of the pixel at the clicked location in the base image in the ImageKit Control.

This property is used most often to make transparent GIF files. In order to set a color to be transparent in a GIF image you must use the File.TransparentRed, File.TransGreen, and File.TransparentBlue properties. Although you can set these properties directly, it is sometimes difficult to know the exact color to set. One easy way is to click on the color in the image that you want to be transparent, then pass the retrieved RGB values from the ClickPointRed, ClickPointGreen and ClickPointBlue properties to the File.TransparentRed, File.TransGreen, and File.TransparentBlue properties.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ClickPointGreen property

Newtone.ImageKit.Win.ImageKit.ClickPointGreen Property

This property, ClickPointRed and ClickPointBlue refers to the RGB value of the pixel at the clicked location in the base image in the ImageKit Control.

[Visual Basic] Public ReadOnly Property ClickPointGreen As Byte
[C#] public byte ClickPointGreen {get;}

Property Value

Values range from 0 to 255

Read Only

Explanation

You can easily retrieve color information from the base image displayed in the ImageKit Control. All you need to do is to click on the color in the base image that you want to retrieve and the respective RGB values for that pixel are set in the ClickPointRed, ClickPointGreen and ClickPointBlue properties. The ClickPointGreen property refers to the green value of the pixel at the clicked location in the base image in the ImageKit Control.

This property is used most often to make transparent GIF files. In order to set a color to be transparent in a GIF image you must use the File.TransparentRed, File.TransparentGreen, and File.TransparentBlue properties. Although you can set these properties directly, it is sometimes difficult to know the exact color to set. One easy way is to click on the color in the image that you want to be transparent, then pass the retrieved RGB values from the ClickPointRed, ClickPointGreen and ClickPointBlue properties to the File.TransparentRed, File.TransparentGreen, and File.TransparentBlue properties.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ClickPointRed property

Newtone.ImageKit.Win.ImageKit.ClickPointRed Property

This property, ClickPointGreen and ClickPointBlue properties refers to the blue value of the pixel at the clicked location in the base image in the ImageKit Control.

[Visual Basic] Public ReadOnly Property ClickPointRed As Byte
[C#] public byte ClickPointRed {get;}

Property Value

Values range from 0 to 255

Read only

Explanation

You can easily retrieve color information from the base image displayed in the ImageKit Control. All you need to do is to click on the color in the base image that you want to retrieve and the respective RGB values for that pixel are set in the ClickPointRed, ClickPointGreen and ClickPointBlue properties. The ClickPointRed property refers to the blue value of the pixel at the clicked location in the base image in the ImageKit Control.

This property is used most often to make transparent GIF files. In order to set a color to be transparent in a GIF image you must use the File.TransparentRed, File.TransparentGreen, and File.TransparentBlue properties. Although you can set these properties directly, it is sometimes difficult to know the exact color to set. One easy way is to click on the color in the image that you want to be transparent, then pass the retrieved RGB values from the ClickPointRed, ClickPointGreen and ClickPointBlue properties to the File.TransparentRed, File.TransparentGreen, and File.TransparentBlue properties.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DefaultMouseCursor property

Newtone.ImageKit.Win.ImageKit.DefaultMouseCursor Property

This property sets the shape of the default cursor used within the ImageKit Control
[Visual Basic] Public Property DefaultMouseCursor As Cursor
[C#] public Cursor DefaultMouseCursor {get; set;}

Property Value

Values are of the .NET Framework Cursors Class

Default value: Cursors.Default

Explanation

This property sets the shape of the default cursor used within the ImageKit Control.

Example:

ImageKit1.DefaultMouseCurser = Cursors.WaitCursor

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DrawCenterX property

Newtone.ImageKit.Win.ImageKit.DrawCenterX Property

The DrawCenterX and DrawCenterY properties get or set the coordinates of a point on an image that will be displayed from the center of the ImageKit Control.

[Visual Basic] Public Property DrawCenterX As Integer
[C#] public int DrawCenterX {get; set;}

Property Values

DrawCenterX gets or sets the horizontal position of a point on an image that will be displayed from the center of the ImageKit Control (In pixels)

Explanation

The DrawCenterX and DrawCenterY properties get or set the coordinates of a point on an image that will be displayed from the center of the ImageKit Control. The DrawCenterX property determines the horizontal distance from the left side of the image. (Shown as X in the diagram below) and the DrawCenterY property determines the vertical distance from the top of the image (Shown as Y in the diagram below). To display the image, the Display method must be called.

To use the DrawCenterX and DrawCenterY properties, the image must be displayed in Actual Size and the StartDrawX and StartDrawY properties must not be set or must be set to 0. Furthermore, once the image is displayed, if the image is scolled, the DrawCenterX and DrawCenterY properties will be cleared and the point on the image shown at the top left corner of the ImageKit Control will be set in the StartDrawX and StartDrawY properties. To use the DrawCenterX and DrawCenterY properties again, you must reset the StartDrawX and StartDrawY properties to 0.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DrawCenterY property

Newtone.ImageKit.Win.ImageKit.DrawCenterY Property

The DrawCenterXand DrawCenterY properties get or set the coordinates of a point on an image that will be displayed from the center of the ImageKit Control.

[Visual Basic] Public Property DrawCenterY As Integer
[C#] public int DrawCenterY {get; set;}

Property Values

DrawCenterY gets or sets the vertical position of a point on an image that will be displayed from the center of the ImageKit Control (In pixels)

Explanation

The DrawCenterX and DrawCenterY properties get or set the coordinates of a point on an image that will be displayed from the center of the ImageKit Control. The DrawCenterY property determines the vertical distance from the top of the image. (Shown as Y in the diagram below) and the DrawCenterX property determines the horizontal distance from the left side of the image (Shown as X in the diagram below). To display the image, the Display method must be called.

To use the DrawCenterX and DrawCenterY properties, the image must be displayed in Actual Size and the StartDrawX and StartDrawY properties must not be set or must be set to 0. Furthermore, once the image is displayed, if the image is scolled, the DrawCenterX and DrawCenterY properties will be cleared and the point on the image shown at the top left corner of the ImageKit Control will be set in the StartDrawX and StartDrawY properties. To use the DrawCenterX and DrawCenterY properties again, you must reset the StartDrawX and StartDrawY properties to 0.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DrawOnlyBaseImage property

Newtone.ImageKit.Win.ImageKit.DrawOnlyBaseImage Property

This property sets whether or not only the base image is displayed in the ImageKit Control.

[Visual Basic] Public Property DrawOnlyBaseImage As Boolean
[C#] public bool DrawOnlyBaseImage {get; set;}

Property Value

Value | Explanation
True | Only the base image is displayed
False (default) | The base images and layer images are displayed

Explanation

The DrawOnlyBaseImage property sets whether or not only the base image is displayed in the ImageKit Control. If only the base image is displayed (the layer image isn't used), it increases the drawing speed.

The base image is the image pointed to by the Image property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DrawScaleX property

Newtone.ImageKit.Win.ImageKit.DrawScaleX Property

This property and DrawScalY property set the magnification at which and image is displayed in the ImageKit Control. (Actual size display is 1 by default).

[Visual Basic] Public Property DrawScaleX As Double
[C#] public double DrawScaleX {get; set;}

Property Value

The magnification at which an image is displayed

Explanation

The DrawScaleX and DrawScaleY properties set the magnification at which and image is displayed in the ImageKit Control. (Actual size display is 1 by default). If the DrawScaleX and DrawScaleY properties equal 2, for example, then the image will be displayed a twice actual size. Likewise, if the the DrawScaleX and DrawScaleY properties equal 0.5, then the image will be displayed at half actual size. The DrawScaleX and DrawScaleY properties are only effective when the image is displayed at actual size.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DrawScaleY property

Newtone.ImageKit.Win.ImageKit.DrawScaleY Property

This property and DrawScalX property set the magnification at which and image is displayed in the ImageKit Control. (Actual size display is 1 by default).

[Visual Basic] Public Property DrawScaleY As Double
[C#] public double DrawScaleY {get; set;}

Property Value

The magnification at which an image is displayed

Explanation

The DrawScaleXand DrawScaleY properties set the magnification at which and image is displayed in the ImageKit Control. (Actual size display is 1 by default). If the DrawScaleX and DrawScaleY properties equal 2, for example, then the image will be displayed a twice actual size. Likewise, if the the DrawScaleX and DrawScaleY properties equal 0.5, then the image will be displayed at half actual size. The DrawScaleX and DrawScaleY properties are only effective when the image is displayed at actual size.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DXFBlack property

Newtone.ImageKit.Win.ImageKit.DXFBlack Property

This property gets or sets whether or not white is displayed as black and black is displayed as white in DXF images.

[Visual Basic] Public Property DXFBlack As Boolean
[C#] public bool DXFBlack {get; set;}

Property Value

Value | Explanation
True (default) | Black is displayed as white and white is displayed as black in DXF images (default)
False | The DXF images is displayed as normal.

Explanation

The DXFBlack property gets or sets whether or not white is displayed as black and black is displayed as white in DXF images. When the default value, True, is used, black is displayed as white and white is displayed as black in DXF images.

Note: This property requires the ImageKit ActiveX dlls.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ErrorStatus property

Newtone.ImageKit.Win.ImageKit.ErrorStatus Property

This property refers to the types of errors that can occur when using the ImageKit Control.

[Visual Basic] Public ReadOnly Property ErrorStatus As Newtone.ImageKit.Error
[C#] public Newtone.ImageKit.Error ErrorStatus {get;}

Property Value

The values are of type Error

Read only

Explanation

This property refers to the types of errors that can occur when using the ImageKit Control.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Gray property

Newtone.ImageKit.Win.ImageKit.Gray Property

This property determines whether or not the image set in the Image property is grayscale.

[Visual Basic] Public ReadOnly Property Gray As Boolean
[C#] public bool Gray {get;}

Property Value

Value | Explanation
True | The image is grayscale
False | The image is not grayscale

Explanation

The Gray property determines whether or not the image set in the Image property is grayscale. When the Image property is set the Gray property is automatically refreshed. The Gray property is not enabled for vector images.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Image property

Newtone.ImageKit.Win.ImageKit.Image Property

This property sets or retrieves the base image.
[Visual Basic] Public Property Image As Image
[C#] public Image Image {get; set;}

Property Value

Base image object

Explanation

The Image property sets or retrieves the base image. Although it is possible to set the image directly into the Image property, if the LayerNumber property is set to -1 and the file is loaded then the image is automatically set in the Image property. To disable the image data, set the Image property to 0 (Nothing in Visual Basic).

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ImageKind property

Newtone.ImageKit.Win.ImageKit.ImageKind Property

This property refers to the image type.

[Visual Basic] Public ReadOnly Property ImageKind As KindOfImage
[C#] public KindOfImage ImageKind {get;}

Property Value

This value is of type KindOfImage

Explanation

The ImageKind property refers to the image type. When the Image property is set the values of the ImageKind property are automatically set.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ImageSize property

Newtone.ImageKit.Win.ImageKit.ImageSize Property

This property refers to the size of the image in bytes.

[Visual Basic] Public ReadOnly Property ImageSize As Integer
[C#] public int ImageSize {get;}

Property Value

The size of the image in bytes

Explanation

The ImageSize property refers to the size of the image in bytes. When the Image property is set the values of this property are automatically set.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ImageWidthByte property

Newtone.ImageKit.Win.ImageKit.ImageWidthByte Property

This property refers to the number of bytes per line in the image.

[Visual Basic] Public ReadOnly Property ImageWidthByte As Integer
[C#] public int ImageWidthByte {get;}

Property Value

The number of bytes per line in the image

Explanation

The ImageWidthByte property refers to the number of bytes per line in the image. When the Image property is set the values of the ImageWidthByte property are automatically set.

This property is not valid for vector data.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


InvalidHatchColor property

Newtone.ImageKit.Win.ImageKit.InvalidHatchColor Property

This property sets the color of the hatch pattern shown in the ImageKit Control when an image is not displayed.

[Visual Basic] Public Property InvalidHatchColor As Color
[C#] public Color InvalidHatchColor {get; set;}

Property Value

InvalidHatchColor - the color of the hatch pattern shown in the ImageKit Control when an image is not displayed

Explanation

The InvalildHatchColor property sets the color of the hatch pattern shown in the ImageKit Control when an image is not displayed. Color can be set using RGB (Red, Green, Blue) or the equivalent value. This property is enabled when the value of the InvalidHatchPattern property is more than 1.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


InvalidHatchPattern property

Newtone.ImageKit.Win.ImageKit.InvalidHatchPattern Property

This property sets the pattern that is displayed in that portion of the ImageKit control not covered by an image. You can see this pattern most clearly before you load an image.

[Visual Basic] Public Property InvalidHatchPattern As HatchPattern
[C#] public HatchPattern InvalidHatchPattern {get; set;}

Property Value

This value is of type HatchPattern

Explanation

This is the pattern that is displayed in that portion of the ImageKit control not covered by an image. You can see this pattern most clearly before you load an image. The default value is ShowHatch. When the InvallidHatchPattern property is set to ShowHatch, the hatch pattern is displayed in the color set in the InvalidHatchColor property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


LayerNumber property

Newtone.ImageKit.Win.ImageKit.LayerNumber Property

The ImageKit Control allows you to load, save, and process several images simultaneously. This property gets and sets the image number for the image that has been or will be processed.

[Visual Basic] Public Property LayerNumber As Integer
[C#] public int LayerNumber {get; set;}

Property Value

The number of the image (default is -1). A value of -1 refers to the base image. Values from 0 to 99 refer to the various image layers

Explanation

The ImageKit Control allows you to load, save, and process several images simultaneously. The LayerNumber property property refers to the image number for the image that will be processed (or has been processed) when loading, saving, or applying an effect to an image. If you set the LayerNumber property to -1 and load the image, then the loaded image's image handle will be set into the Image property. If you set the LayerNumber property to a value other than -1 (i.e. from 0 to 99), then the image handle of the loaded image will be set into the Layer(LayerNumber).Image property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseDragImage property

Newtone.ImageKit.Win.ImageKit.MouseDragImage Property

This property sets whether or not the image in the ImageKit Control can be scrolled by dragging it with the mouse.

[Visual Basic] Public Property MouseDragImage As Boolean
[C#] public bool MouseDragImage {get; set;}

Property Value

Value | Explanation
True | The image can be scrolled with the mouse
False | The image cannot be scrolled with the mouse

Explanation

The MouseDragImage property sets whether or not the image in the ImageKit Control can be scrolled by dragging it with the mouse. When this property is set to True, the image can be scrolled with the mouse.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseWheelDirection property

Newtone.ImageKit.Win.ImageKit.MouseWheelDirection Property

This property sets whether the mouse wheel can be used to scroll.

[Visual Basic] Public Property MouseWheelDirection As WheelDirection
[C#] public WheelDirection MouseWheelDirection {get; set;}

Property Valule

Value | Explanation
Disable | Disables scrolling with the mouse wheel
Vertical | Mouse scrolls in a vertical direction
Horizontal | Mouse scrolls in a horizontal direction

Explanation

The MouseWheelDirection property sets whether the mouse wheel can be used to scroll. To enable the mouse wheel to scroll, set this property to a value other than Disable.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


PaletteCount property

Newtone.ImageKit.Win.ImageKit.PaletteCount Property

This property refers to the number of palette colors for the image set to the Image property.

[Visual Basic] Public ReadOnly Property PaletteCount As Integer
[C#] public int PaletteCount {get;}

Property Value

The number of palette colors for the image

This property value is valid when the BitCount property is less than 8, otherwise 0 is returned.

Explanation

The PaletteCount property refers to the number of palette colors for the image. After setting the Image property, the value of the PaletteCount property is automatically set. This property is not valid for vector data.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Rect property

Newtone.ImageKit.Win.ImageKit.Rect Property

This property sets the rectangle selected on the base image in the ImageKit Control.

[Visual Basic]
Public Property Rect As Rectangle
[C#]
public Rectangle RectBottom {get; set;}

Property Value

The value is of type System.Drawing.Rectangle and represents a rectangle selected on the image displayed in the ImageKit Control

Explanation

The Rect property sets the rectangle selected on the image in the ImageKit Control. This property is enabled by setting the RectDraw property to True. In that case, the mouse can be used to select an area on the base image. The coordinates of this selected area are set into the Rect property.

It is also possible to set the Rect property directly. For example

ImageKit1.Rect = new Rectangle(100,100,200,200)

will set an selected area on the image whose top left corner is at (100,100) and that has a height and width of 200 respectively. For more information, please refer to the System.Drawing.Rectangle.

The color of the border for the selected area can be set using the RectColor1 and the RectColor2 properties.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


RectColor1 property

Newtone.ImageKit.Win.ImageKit.RectColor1 Property

This property and the RectColor2 property set the colors of the dotted line that distinguishes the selected area in the ImageKit Control.

[Visual Basic] Public Property RectColor1 As Color
[C#] public Color RectColor1 {get; set;}

Property Value

RectColor1 - one of the colors in the dotted line that distinguishes the selected area in the ImageKit Control.
RectColor2 - the other color in the dotted line that distinguishes the selected area in the ImageKit Control.

Explanation

The RectColor1 and the RectColor2 property set the colors of the dotted line that distinguishes the selected area in the ImageKit Control.

The RectColor1 and RectColor2 properties are enabled when the RectDraw property is true.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


RectColor2 property

Newtone.ImageKit.Win.ImageKit.RectColor2 Property

This property and the RectColor1 property set the colors of the dotted line that distinguishes the selected area in the ImageKit Control.

[Visual Basic] Public Property RectColor2 As Color
[C#] public Color RectColor2 {get; set;}

Property Value

RectColor1 - one of the colors in the dotted line that distinguishes the selected area in the ImageKit Control.
RectColor2 - the other color in the dotted line that distinguishes the selected area in the ImageKit Control.

Explanation

The RectColor1 and the RectColor2 property set the colors of the dotted line that distinguishes the selected area in the ImageKit Control.

The RectColor1 and the RectColor2 properties are enabled when the RectDraw property is true.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


RectDraw property

Newtone.ImageKit.Win.ImageKit.RectDraw Property

This property sets whether an area on the base image displayed in the ImageKit Control can be selected with the mouse.

[Visual Basic]
Public Property RectDraw As Boolean
[C#]
public bool RectDraw {get; set;}

Property Value

Value | Explanation
True (default) | An area on the image can be selected with the mouse
False | An area on the image cannot be selected with the mouse

Explanation

The RectDraw property sets whether an area on the base image displayed in the ImageKit Control can be selected with the mouse. When the RectDraw property is True, an area on the base image can be selected by dragging the mouse over the image. The coordinates of this selected area will be set into the Rect property.

The color of the selected area can be set using the RectColor1 and the RectColor2 properties.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


RectDrawFix property

Newtone.ImageKit.Win.ImageKit.RectDrawFix Property

This property sets whether or not the selected area drawn on the base image in the ImageKit Control can be resized with the mouse.

[Visual Basic] Public Property RectDrawFix As Boolean
[C#] public bool RectDrawFix {get; set;}

Property Value

Value | Explanation
True | The selected area cannot be resized with the mouse
False | The selected area can be resized with the mouse

Explanation

The RectDrawFix property sets whether or not the selected area drawn on the base image in the ImageKit Control can be resized with the mouse. If the RectDrawFix property is True, the RectDraw property must also be True. This will fix the size of the selected area drawn on the base image in the ImageKit Control. It cannot be resized using the mouse. (It can however be moved with the mouse.) If this property is not set, the rectangular area can be resized with the mouse (Default value is False).

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


RectMouseCursor property

Newtone.ImageKit.Win.ImageKit.RectMouseCursor Property

This property sets the shape of the mouse cursor when the mouse is dragged within the ImageKit Control.

[Visual Basic] Public Property RectMouseCursor As Cursor
[C#] public Cursor RectMouseCursor {get; set;}

Property Value

The members of the Cursors class for .NET Framework

The default value is Cursors.SizeAll.

Explanation

The RectMouseCursor property sets the shape of the mouse cursor when the mouse is dragged within the ImageKit Control.

The following code illustrates how to set the shape of the mouse cursor to Hourglass:

ImageKit1.RectCursor = Cursors.WaitCursor

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


RectDrawRatio property

Newtone.ImageKit.Win.ImageKit.RectDrawRatio Property

When using the mouse to select an area on the image, this property sets the ratio of the height to the width in that selected area.

[Visual Basic] Public Property RectDrawRatio As Double
[C#] public double RectDrawRatio {get; set;}

Property Value

The ratio of the height to the width in the selected area (default value is 0 meaning ratio is not set)

Explanation

When using the mouse to select an area on the image, RectDrawRatio property sets the ratio of the height to the width in that selected area. For this property to be enabled, the RectDraw property must be True. When the RectDrawRatio property is 0 (default value) there is no set ratio between the height and width of the selected area. Since the ratio is defined as heigth/width, values of more than 1 mean that the height of the selected area will be greater than the width. Likewise values less than 1 mean the width will be greater than the length.

Example

Below is a code snippet that illustrates how to set the ratio of the height and width in the selected area to be the same as in the currently displayed image.

[Visual Basic]
Dim Ret As Boolean

ImageKit1.LayerNumber = -1
Ret = ImageKit1.GetImageType()
If Ret = False Then Exit Sub
ImageKit1.RectDrawRatio = ImageKit1.Height / ImageKit1.Width

[C#]
bool Ret;

ImageKit1.LayerNumber = -1;
Ret = ImageKit1.GetImageType();
if (Ret == False) return Ret;
ImageKit1.RectDrawRatio = ImageKit1.Height / ImageKit1.Width;

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Refine1BitImage

Newtone.ImageKit.Win.ImageKit.Refine1BitImage Property

This property sets whether or not a 1 bit color image will be displayed in high quality in the ImageKit Control.

[Visual Basic] Public Property Refine1BitImage As Boolean
[C#] public bool Refine1BitImage {get; set;}

Property Value

Value | Explanation
True | 1 bit color images will be displayed in high quality
False (default) | 1 bit color images will be displayed as normal

Explanation

This property sets whether or not a 1 bit color image will be displayed in high quality in the ImageKit Control. This property is enabled only if the image is displayed by reducing its size to less than the actual size.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollBar property

Newtone.ImageKit.Win.ImageKit.ScrollBar Property

This property sets whether or not scroll bars are displayed on the ImageKit Control.

[Visual Basic] Public Property ScrollBar As Boolean
[C#] public bool ScrollBar {get; set;}

Property Value

Value | Explanation
True | Displays scroll bars on the Imagekit Control
False (default) | Does not display scroll bars on the Imagekit Control

Explanation

The ScrollBar property sets whether or not scroll bars are displayed on the ImageKit Control. When the ScrollBar property is True, if an image does not fit within the ImageKit Control, scroll bars will appear and can be used to scroll the image.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollValueH property

Newtone.ImageKit.Win.ImageKit.ScrollValueH Property

This property sets the horizontal value (in pixels) of the scroll for the image displayed in the ImageKit Control.

[Visual Basic] Public Property ScrollValueH As Integer
[C#] public int ScrollValueH {get; set;}

Property Value

The size of the scroll in pixels (must be 1 or more)

Explanation

The ScrollValueH property sets the horizontal value (in pixels) of the scroll for the image displayed in the ImageKit Control. To scroll vertically, set the ScrollValueV property. To scroll diagonally, set both of these properties. After setting these properties, execute the ScrollImage method.

These functions are particularly useful to link scrolling to a button click or other event. When the ScrollBar property is set to True to use scroll bars, the value of this property will be set into the SmallChange property for the scroll bars.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollValueV property

Newtone.ImageKit.Win.ImageKit.ScrollValueV Property

This property sets the vertical value (in pixels) of the scroll for the image displayed in the ImageKit Control.

[Visual Basic] Public Property ScrollValueV As Integer
[C#] public int ScrollValueV {get; set;}

Property Value

The size of the scroll in pixels (must be 1 or more)

Explanation

The ScrollValueV property sets the vertical value (in pixels) of the scroll for the image displayed in the ImageKit Control. To scroll horizontally, set the ScrollValueH property. To scroll diagonally, set both of these properties. After setting these properties, execute the ScrollImage method.

These functions are particularly useful to link scrolling to a button click or other event. When the ScrollBar property is set to True to use scroll bars, the value of this property will be set into the SmallChange property for the scroll bars.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ShowImage property

Newtone.ImageKit.Win.ImageKit.ShowImage Property

This property sets whether or not the base image is displayed in the ImageKit Control.

[Visual Basic] Public Property ShowImage As Boolean
[C#] public bool ShowImage {get; set;}

Property Value

The ShowImage property sets whether or not the base image is displayed in the ImageKit Control.

Value | Explanation
True | Displays the base image
False | Does not display the base image

Explanation

The ShowImage property sets whether or not the base image is displayed in the ImageKit Control. The base image is the image pointed to by the Image property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartDrawX property

Newtone.ImageKit.Win.ImageKit.StartDrawX Property

The StartDrawX and StartDrawY properties get or set the point on the image that will be displayed from the top left corner of the ImageKit Control.

[Visual Basic] Public Property StartDrawX As Integer
[C#] public int StartDrawX {get; set;}

Property Value

The horizontal position on the image that will be displayed from the left of the ImageKit Control.

Explanation

The StartDrawX and StartDrawY properties get or set the point on the image that will be displayed from the top left corner of the ImageKit Control. By setting the StartDrawX and StartDrawY properties, large images can be loaded into the ImageKit Control and displayed from a specified position on the image. StartDrawX and StartDrawY are enabled when the image is displayed in actual size. Furthermore, if DrawCenterX and DrawCenterY properties are set to values other than 0 then StartDrawX and StartDrawY properties are disabled.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartDrawY property

Newtone.ImageKit.Win.ImageKit.StartDrawY Property

The StartDrawX and StartDrawY properties get or set the point on the image that will be displayed from the top left corner of the ImageKit Control.

[Visual Basic] Public Property StartDrawY As Integer
[C#] public int StartDrawY {get; set;}

Property Value

The vertical position on the image that will be displayed from the left of the ImageKit Control.

Explanation

The StartDrawX and StartDrawY properties get or set the point on the image that will be displayed from the top left corner of the ImageKit Control. By setting the StartDrawX and StartDrawY properties, large images can be loaded into the ImageKit Control and displayed from a specified position on the image. StartDrawX and StartDrawY are enabled when the image is displayed in actual size. Furthermore, if DrawCenterX and DrawCenterY properties are set to values other than 0 then StartDrawX and StartDrawY properties are disabled.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ToolTip property

Newtone.ImageKit.Win.ImageKit.ToolTip Property

This property sets the units of measurement at which the tool tip coordinates are displayed.

[Visual Basic] Public Property ToolTip As LengthUnit
[C#] public LengthUnit ToolTip {get; set;}

Property Value

Value | Explanation
Non (default) | None (Does not display a tool tip)
Pixel | Pixels
mm | Millimeters
Inch | Inches

Explanation

The ToolTip property displays a tool tip when the mouse moves over the image in the ImageKit Control. The tool tip shows the x y coordinates for the location of the mouse cursor. When this property is set to Non, the tool tip will not be displayed. Values other than Non will set the tool tip units to pixels, millimeters, or inches respectively.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Transparent property

Newtone.ImageKit.Win.ImageKit.Transparent Property

This property enables the transparent color in the base (raster) image.

[Visual Basic] Public Property Transparent As Boolean
[C#] public bool Transparent {get; set;}

Property Value

Value | Explanation
True | The transparent color is enabled
False (default) | The transparent color is disabled

Explanation

The Transparent property enables the transparent color in the base (raster) image. When True, the color set in the TransparentBlue, TransparentGreen, and TransparentRed properties will appear as transparent when the base image is displayed in the ImageKit Control.

If the base image referred to by the Image property is a vector image then transparency is disabled.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


TransparentBlue property

Newtone.ImageKit.Win.ImageKit.TransparentBlue Property

The TransparentRed, TransparentGreen, and TransparentBlue properties are used to set a transparent color in the base (raster) image.

[Visual Basic] Public Property TransparentBlue As Byte
[C#] public byte TransparentBlue {get; set;}

Property Value

Values range from 0 to 255

Explanation

The TransparentRed, TransparentGreen, and TransparentBlue properties are used to set a transparent color in the base (raster) image. The ImageKit Control background will be seen in the areas of the image that are set to transparent. To set a transparent color in an image, the image must be either 8 bit color or 24 bit color. If a vector image is set in the base image, these properties are disabled.

Example

Below the code snippet illustrates how to set the transparent color to white: (in Visual Basic)

ImageKit1.Transparent = True
ImageKit1.TransparentBlue = 255
ImageKit1.TransparentGreen = 255
ImageKit1.TransparentRed = 255
ImageKit1.LayerNumber = -1
ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.Win.LoadFileType.Load)

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


TransparentGreen property

Newtone.ImageKit.Win.ImageKit.TransparentGreen Property

The TransparentRed, TransparentGreen, and TransBlue properties are used to set a transparent color in the base (raster) image.

[Visual Basic] Public Property TransparentGreen As Byte
[C#] public byte TransparentGreen {get; set;}

Property Value

Values range from 0 to 255

Explanation

The TransparentRed, TransparentGreen, and TransBlue properties are used to set a transparent color in the base (raster) image. The ImageKit Control background will be seen in the areas of the image that are set to transparent. To set a transparent color in an image, the image must be either 8 bit color or 24 bit color. If a vector image is set in the base image, these properties are disabled.

Example

Below the code snippet illustrates how to set the transparent color to white: (in Visual Basic)

ImageKit1.Transparent = True
ImageKit1.TransparentBlue = 255
ImageKit1.TransparentGreen = 255
ImageKit1.TransparentRed = 255
ImageKit1.LayerNumber = -1
ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.Win.LoadFileType.Load)

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


TransparentRed property

Newtone.ImageKit.Win.ImageKit.TransparentRed Property

The TransparentRed, TransparentGreen, and TransBlue properties are used to set a transparent color in the base (raster) image.

[Visual Basic] Public Property TransparentRed As Byte
[C#] public byte TransparentRed {get; set;}

Property Value

Values range from 0 to 255

Explanation

The TransparentRed, TransparentGreen, and TransBlue properties are used to set a transparent color in the base (raster) image. The ImageKit Control background will be seen in the areas of the image that are set to transparent. To set a transparent color in an image, the image must be either 8 bit color or 24 bit color. If a vector image is set in the base image, these properties are disabled.

Example

Below the code snippet illustrates how to set the transparent color to white: (in Visual Basic)

ImageKit1.Transparent = True
ImageKit1.TransparentBlue = 255
ImageKit1.TransparentGreen = 255
ImageKit1.TransparentRed = 255
ImageKit1.LayerNumber = -1
ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.Win.LoadFileType.Load)

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ClearClipBoard method

Newtone.ImageKit.Win.ImageKit.ClearClipBoard Method

This method clears the clipboard.

[Visual Basic] Public Function ClearClipBoard()
[C#] public void ClearClipBoard() ;

Parameters

None

Return Value

None

Explanation

The ClearClipBoard method clears the clipboard.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Display method

Newtone.ImageKit.Win.ImageKit.Display Method

This method displays the image.

[Visual Basic] Public Function Display(ShowMode As DisplayMode) As Boolean
[C#] public bool Display(DisplayMode ShowMode) ;

Parameters

ShowMode
The display mode (DisplayModeValue)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Display method displays the image. When the ShowMode parameter is Clear, the image displayed within the ImageKit Control is cleared. To display images in the ImageKit Control you must execute the Display method again.

When the ShowMode parameter is other than Clear and the ShowImage property is true, the image is displayed. (base image or layer image)

Images are displayed in the following order: the base image first then the Layer images (the images with lower indexes are displayed before the image with higher indexes)

Note that if the base image is not set, then the Layer images are not displayed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GetFromClipBoard method

Newtone.ImageKit.Win.ImageKit.GetFromClipBoard Method

This method retrieves a raster image from the clipboard.

[Visual Basic] Public Function GetFromClipBoard() As Boolean
[C#] public bool GetFromClipBoard() ;

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetFromClipBoard method retrieves a raster image from the clipboard.

If successful, the image will be set in the property referred to by the LayerNumber property (either the Image property or the Layer(LayerNumber).Image property)

Note: This method retrieves only raster images from the clipboard.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GetImageType method

Newtone.ImageKit.Win.ImageKit.GetImageType Method

The GetImageType method sets the various image information into the image's related property values.

[Visual Basic] Public Function GetImageType() As Boolean
[C#] public bool GetImageType() ;

Parameters

None

Return Value

Return True if successful. Return False if unsuccessful.

Explanation

The GetImageType method sets the various image information into the image's related property values. Depending on the LayerNumber property value, the information will be related to the image set in the Image property or the Layer(LayerNumber).Image property.

For the image referred to by the Image property

The following properties will be set: BitCount, Gray, ImageKind, ImageSize, ImageWidthByte, and PaletteCount

For the image referred to by the Layer(LayerNo).Image property

The following properties will be set: Layer(LayerNumber).BitCount, Layer(LayerNumber).Gray, Layer(LayerNumber).ImageKind, Layer(LayerNumber).ImageSize,
Layer(LayerNumber).ImageWidthByte, and Layer(LayerNumber).PaletteCount

Note: Even if you do not execute the GetImageType method, when an image is set into the Image property or the Layer(LayerNo).Image property, the image information is automatically set into these various properties.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GetOneBitPaletteCount method

Newtone.ImageKit.Win.ImageKit.GetOneBitPaletteCount Method

This method retrieves the number of 0 pixels and 1 pixels from a 1 bit color image.

[Visual Basic] Public Function GetOneBitPaletteCount(Pal0 As Integer, Pal1 As Integer, GetImg As Image) As Boolean
[C#] public bool GetOneBitPaletteCount(ref int Pal0, ref int Pal1, Image GetImg) ;

Parameters

Pal0
The number of 0 pixels retrieved from a 1 bit color image palette

Pal1
The number of 1 pixels retrieved from a 1 bit color image palette

GetImg
The raster image

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetOneBitPaletteCount method retrieves the number of 0 pixels and 1 pixels from a 1 bit color image. This method is enabled for 1 bit color images only.

When the GetImg parameter contains a valid image

The image data that the GetImg parameter refers to will be processed.

When the GetImg parameter contains 0

The image data determined by the LayerNumber property will be processed. If the LayerNumber property is -1 (the base image) then the image data referred to by the Image property will be processed. If the value of the LayerNumber property is between 0 and 99 then the image data referred to by the Layer(LayerNumber).Imgae property will be processed.

For Palette color, please refer to the GetPalette method.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GetPalette method

Newtone.ImageKit.Win.ImageKit.GetPalette Method

This method retrieves the palette information for a raster image.

[Visual Basic] Public Function GetPalette(Red As Byte, Green As Byte, Blue As Byte, GetImg As Image) As Boolean
[C#] public bool GetPalette(ref byte []Red, ref byte []Green, ref byte []Blue, Image GetImg) ;

Parameters

Red
Array of the retrieved red palette information
(1)Visual Basic: the syntax of the argument is Red(0)
(2)C#: the syntax of the argument is ref Red[]

Green
Array of the retrieved green palette information
(1)Visual Basic: the syntax of the argument is Green(0)
(2)C#: the syntax of the argument is ref Green[]

Blue
Array of the retrieved blue palette information
(1)Visual Basic: the syntax of the argument is Blue(0)
(2)C#: the syntax of the argument is ref Blue[]

GetImg
The raster image

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetPalette method retrieves the palette information for a raster image.

When the GetImg parameter contains a valid image

The image data that the GetImg parameter refers to will be processed.

When the GetImg parameter contains 0

The image data determined by the LayerNumber property will be processed. If the LayerNumber property is -1 (the base image) then the image data referred to by the Image property will be processed. If the value of the LayerNumber property is between 0 and 99 then the image data referred to by the Layer(LayerNumber).Image property will be processed.

To find out how many items are in the various RGB arrays, please refer to the PaletteCount property. The PaletteCount property value is refreshed when ever an image handle is set into the Image property of the Layer(LayerNo).Image property. Use the GetImageType method to retrieve the PaletteCount property value.

Example

[Visual Basic]
Dim r() As Byte
Dim g() As Byte
Dim b() As Byte

ImageKit1.LayerNumber = -1
If ImageKit1.PaletteCount = 1 Then
  Exit Sub
End If

ReDim r(0 To ImageKit1.PaletteCount - 1)
ReDim g(0 To ImageKit1.PaletteCount - 1)
ReDim b(0 To ImageKit1.PaletteCount - 1)

ImageKit1.GetPalette r(0), g(0), b(0), Nothing

[C#]
byte[] r = new byte[imageKit1.PaletteCount];
byte[] g = new byte[imageKit1.PaletteCount];
byte[] b = new byte[imageKit1.PaletteCount];

imageKit1.LayerNumber := -1;
if (imageKit1.PaletteCount == 1) return false;
imageKit1.GetPalette(ref r, ref g, ref b, null);

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


IsClipBoardData method

Newtone.ImageKit.Win.ImageKit.IsClipBoardData Method

This method checks whether or not there is clipboard data.

[Visual Basic] Public Function IsClipBoardData()
[C#] public void IsClipBoardData() ;

Parameters

None

Return Value

Returns True (nonzero) if there is clipboard data, otherwise returns False.

Explanation

The IsClipBoardData method checks whether or not there is clipboard data.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollImage method

Newtone.ImageKit.Win.ImageKit.ScrollImage Method

This method scrolls the image according to the values set in the ScrollValueH and ScrollValueV properties.

[Visual Basic] Public Function ScrollImage(Direc As ScrollDirection) As Boolean
[C#] public bool ScrollImage(ScrollDirection Direc) ;

Parameters

Direc
This value is of ScrollDirection type.

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

This method scrolls the image according to the values set in the ScrollValueH and ScrollValueV properties.

The ScrollValueH and ScrollValueV properties must be set prior to executing this method.

Note: This method is only enabled when the image is displayed in actual size.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


SetToClipBoard method

Newtone.ImageKit.Win.ImageKit.SetToClipBoard Method

This method copies a raster image to the clipboard.

[Visual Basic] Public Function SetToClipBoard() As Boolean
[C#] public bool SetToClipBoard() ;

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetToClipBoard method copies a raster image to the clipboard.

If successful, the image referred to by the LayerNumber property (either the Image property or the Layer(LayerNumber).Image property) will be copied to the clipboard.

If the image is a vector image, it will be converted to a raster image.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Zoom method

Newtone.ImageKit.Win.ImageKit.Zoom Method

This method zooms in on the area specified by the Left, Top, Right and Bottom parameters.

[Visual Basic] Public Function Zoom(Left As Integer, Top As Integer, Right As Integer, Bottom As Integer) As Boolean
[C#] public bool Zoom(int Left, int Top, int Right, int Bottom) ;

Parameters

Left
The left coordinate of the zoom area (in pixels)
Top
The top coordinate of the zoom area (in pixels)
Right
The right coordinate of the zoom area (in pixels)
Bottom
The bottom coordinate of the zoom area (in pixels)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Zoom method zooms (in or out) on the area specified by the above four parameters so that the area fills the ImageKit Control while maintaining the height to width aspect of the specified area. After the Zoom method has executed the DrawScaleX and DrawScaleY property values are recalculated.

Note: This method is only enabled when the image is displayed at actual size.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


AfterScan event

Newtone.ImageKit.Win.ImageKit.AfterScan Event

This event is generated after an image is scanned with the scan device.

[Visual Basic] Public Event AfterScan As AfterScanEventHandler
[C#] public event AfterScanEventHandler AfterScan;

Event Data

The event handler receives arguments of type AfterScanEventArgs.

Explanation

The AfterScanevent is generated after an image is scanned with the scan device. Information about the actual image data transfered in this event can be referenced through the AfterScanEventArgs arguments.

Regarding properties of the AfterScanEventArgs class:

This event is generated after an image is scanned with the scan device. The scanned image data (Bitmap1 and Bitmap2) is freed after this event fires so if you want to use this image data in any way, you must make a copy of the scanned image in the memory or save it in an image file.

(1) When using native transfer or when using memory transfer without compression:

If the scanned image is 1, 4, 8, or 24 bits then the image is set in Bitmap1 and Bitmap2 will be null (Nothing in Visual Basic). If the scanned image is 12, 14, or 16 bit grayscale or 36, 42, or 48 bit color then the image will be set in Bitmap2 and the Bitmap2 image data will be converted to 8 bit grayscale or 24 bit color and that will be set in Bitmap1. In this case, if the Bitmap1 memory cannot be allocated it will be null (Nothing in Visual Basic)

(2) When using memory transfer with compression:

The scanned image is set into RawData. Both Bitmap1 and Bitmap2 will be null (Nothing in Visual Basic)

(3) When using file transfer:

Both Bitmap1 and Bitmap2 will be null (Nothing in Visual Basic). The file will be saved in the location specified by FileName

When Scan.UserInterface property is set to Suppress and the Scan.Unit property is Pixel, there are cases in which the resolution of Bitmap1 and Bitmap2 will be 1. To cancel scanning set the Cancel property to True.

Example

The following code displays the image scanned.

[Visual Basic.NET]
Private Sub ImageKit1_AfterScan(ByVal sender As Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs) Handles ImageKit1.AfterScan
   If (e.Bitmap1 Is Nothing) Then Exit Sub
   If Not (ImageKit1.Image Is Nothing) Then
      ImageKit1.Image.Dispose()
   End If
   ImageKit1.Image = e.Bitmap1.Clone()
   ImageKit1.Display(Newtone.ImageKit.Win.DisplayMode.Stretch)
End Sub

[Visual C#.NET]
private void imageKit1_AfterScan(object sender, Newtone.ImageKit.AfterScanEventArgs e)
{
   if (e.Bitmap1 == null) return;
   if (imageKit1.Image != null)
      imageKit1.Image.Dispose();

   imageKit1.Image = (Image)e.Bitmap1.Clone();
   imageKit1.Display(Newtone.ImageKit.Win.DisplayMode.Stretch);
}

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


BeforeScan event

Newtone.ImageKit.Win.ImageKit.BeforeScan Event

This event is generated just before an image is scanned with the scan device.

[Visual Basic] Public Event BeforeScan As BeforeScanEventHandler
[C#] public event BeforeScanEventHandler BeforeScan;

Event Data

The event handler receives arguments of type BeforeScanEventArgs

Explanation

The BeforeScan event is generated just before an image is scanned with the scan device. Information about the actual image data transfered in this event can be referenced through the BeforeScanEventArgs arguments.

Regarding properties of the BeforeScanEventArgs class:

When the Scan.PaperSize property is set to UndefinedSize, the values for the Width and Height properties of this class may become -1 in some cases. It is also possible that the values of the Width and Height properties become larger than the actual size of the document plate. Scan.PixelType property is set to Automation the BitDepth and PixelType values may be different from the actual image.

To cancel, set the Scan.Cancel property to True within this event.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ClickOnPanWindow event

Newtone.ImageKit.Win.ImageKit.ClickOnPanWindow Event

This event is generated when the mouse cursor is inside the pan window and the left mouse button is pressed.

[Visual Basic] Public Event ClickOnPanWindow As PointEventHandler
[C#] public event PointEventHandler ClickOnPanWindow;

Event Data

The event handler receives arguments of type PointEventArgs

Explanation

The ClickOnPanWindow event is generated when the mouse cursor is inside the pan window and the left mouse button is pressed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


EndDispImage event

Newtone.ImageKit.Win.ImageKit.EndDispImage Event

This event is generated just after the image has been displayed.

[Visual Basic] Public Event EndDispImage As DispEventHandler
[C#] public event DispEventHandler EndDispImage;

Event Data

The event handler receives arguments of type DispEventArgs

Explanation

The EndDispImage event is generated just after the image has been displayed.

If there are processes that you want to occur just after an image is displayed, then place that code within this event.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


EndLoad event

Newtone.ImageKit.Win.ImageKit.EndLoad Event

This event is generated after a file has loaded.

[Visual Basic] Public Event EndLoad As FileEventHandler
[C#] public event FileEventHandler EndLoad;

Event Data

The event handler receives arguments of type FileEventArgs

Explanation

This event is generated after a file has loaded, i.e. when theFile.LoadRawDataFromFile or the File.LoadImageFromFile methods are executed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


EndRasterToVector event

Newtone.ImageKit.Win.ImageKit.EndRasterToVector Event

This event is generated after a raster image has been converted to a vector image.

[Visual Basic] Public Event EndRasterToVector As EventHandler
[C#] public event EventHandler EndRasterToVector;

Event Data

The event handler receives arguments of type EventArgs

Explanation

The EndRasterToVector event is generated after a raster image has been converted to a vector image, i.e. after the Vector.RasterToVector method has executed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


EndSave event

Newtone.ImageKit.Win.ImageKit.EndSave Event

This event is generated after a file has finished being saved.

[Visual Basic] Public Event EndSave As FileEventHandler
[C#] public event FileEventHandler EndSave;

Event Data

The event handler receives arguments of type FileEventArgs

Explanation

The EndSave event is generated after a file has finished being saved, i.e. when theFile.SaveRawDataToFile method or the File.SaveImageToFile method have executed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


EndVectorToRaster event

Newtone.ImageKit.Win.ImageKit.EndVectorToRaster Event

This event is generated after a vector image has been converted to a raster image.

[Visual Basic] Public Event EndVectorToRaster As EventHandler
[C#] public event EventHandler EndVectorToRaster;

Event Data

The event handler receives arguments of type EventArgs

Explanation

The EndVectorToRaster event is generated after a vector image has been converted to a raster image, i.e. after the Vector.VectorToRaster method has been executed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


GetDragDropFileName event

Newtone.ImageKit.Win.ImageKit.GetDragDropFileName Event

This event is generated after an image is dragged and dropped into the ImageKit Control.

[Visual Basic] Public Event GetDragDropFileName As FileEventHandler
[C#] public event FileEventHandler GetDragDropFileName;

Event Data

The event handler receives arguments of type FileEventArgs

Explanation

The GetDragDropFileName event is generated after an image is dragged and dropped into the ImageKit Control. This event will be generated when an image file is dragged from Windows Explorer or the thumbnail control and dropped into the ImageKit Control.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MagnifierMouseDown event

Newtone.ImageKit.Win.ImageKit.MagnifierMouseDown Event

This event is generated when the mouse button is pressed inside the Magnifier.

[Visual Basic] Public Event MagnifierMouseDown As MouseButtonEventHandler
[C#] public event MouseButtonEventHandler MagnifierMouseDown;

Event Data

The event handler receives arguments of type MouseButtonEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MagnifierMouseMove event

Newtone.ImageKit.Win.ImageKit.MagnifierMouseMove Event

This event is generated when the mouse cursor is moved within the Magnifier.

[Visual Basic] Public Event MagnifierMouseMove As MouseButtonEventHandler
[C#] public event MouseButtonEventHandler MagnifierMouseMove;

Event Data

The event handler receives arguments of type MouseButtonEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MagnifierMouseUp event

Newtone.ImageKit.Win.ImageKit.MagnifierMouseUp Event

This event is generated when the mouse button is released inside the Magnifier.

[Visual Basic] Public Event MagnifierMouseUp As MouseButtonEventHandler
[C#] public event MouseButtonEventHandler MagnifierMouseUp;

Event Data

The event handler receives arguments of type MouseButtonEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseDownImage event

Newtone.ImageKit.Win.ImageKit.MouseDownImage Event

This event is generated when the mouse cursor is inside the image and the mouse button has been pressed.

[Visual Basic] Public Event MouseDownImage As MouseUpDownEventHandler
[C#] public event MouseUpDownEventHandler MouseDownImage;

Event Data

The event handler receives arguments of type MouseUpDownEventArgs

Explanation

The MouseDownImage event is generated when the mouse cursor is inside the image and the mouse button has been pressed.

Note: The MouseDownImage event is generated before the standard MouseDown event.

This event is enabled when a valid image handle is set in the Image property or the Layer(LayerNumber).Image property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseDownSelectLayerImage event

Newtone.ImageKit.Win.ImageKit.MouseDownSelectLayerImage Event

This event is generated when the mouse cursor is over a layer image and the mouse button is been pressed.

[Visual Basic] Public Event MouseDownSelectLayerImage As MouseSelectEventHandler
[C#] public event MouseSelectEventHandler MouseDownSelectLayerImage;

Event Data

The event handler receives arguments of type MouseSelectEventArgs

Explanation

The MouseDownSelectLayerImage event is generated when the mouse cursor is over a layer image and the mouse button is been pressed. This event is enabled when an image is set in the Layer interface's Image property and the image exists in the location where the mouse is pressed. If there is more than one image layer at the location where the mouse button was pressed, the top most image will be selected.

For example if at the mouse down location there are two image layers as indicated by the Layer property index 0 and 3, the image layer corresponding to index 3 will be selected. (image layers with larger indexes are displayed above image layers with smaller indexes).

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseMoveImage event

Newtone.ImageKit.Win.ImageKit.MouseMoveImage Event

This event is generated when the mouse moves over the image.

[Visual Basic] Public Event MouseMoveImage As MouseUpDownEventHandler
[C#] public event MouseUpDownEventHandler MouseMoveImage;

Event Data

The event handler receives arguments of type MouseUpDownEventArgs

Explanation

The MouseMoveImage event is generated when the mouse moves over the image.

Note: The MouseMoveImage event is generated before the standard MouseMove event.

This event is enabled when a valid image handle is set in the Image property or the Layer(LayerNumber).Imgae property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseUpImage event

Newtone.ImageKit.Win.ImageKit.MouseUpImage Event

This event is generated when the mouse cursor is inside the image and the mouse button has been released.

[Visual Basic] Public Event MouseUpImage As MouseUpDownEventHandler
[C#] public event MouseUpDownEventHandler MouseUpImage;

Event Data

The event handler receives arguments of type MouseUpDownEventArgs

Explanation

The MouseUpImage event is generated when the mouse cursor is inside the image and the mouse button has been released.

Note: The MouseUpImage event is generated before the standard MouseUp event.

This event is enabled when the Image property or the Layer(LayerNumber).Image property contains a valid image handle.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseUpSelectLayerImage event

Newtone.ImageKit.Win.ImageKit.MouseUpSelectLayerImage Event

Generated when the mouse cursor is placed over a layer image and the mouse button is released.

[Visual Basic] Public Event MouseUpSelectLayerImage As MouseSelectEventHandler
[C#] public event MouseSelectEventHandler MouseUpSelectLayerImage;

Event Data

The event handler receives arguments of type MouseSelectEventArgs

Explanation

The MouseUpSelectLayerImage event is generated when the mouse cursor is over a layer image and the mouse button is released. This event is enabled when an image is set in the Layer interface's Image property and the image exists in the location where the mouse is released. If there is more than one layer image at the location where the mouse button was released, the top most image will be selected.

For example if at the mouse release location there are two image layers as indicated by the Layer property index 0 and 3, the image layer corresponding to index 3 will be selected. (image layers with larger indexes are displayed above image layers with smaller indexes).

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseWheelDownImage event

Newtone.ImageKit.Win.ImageKit.MouseWheelDownImage Event

This event is generated when the mouse wheel is rolled down.

[Visual Basic] Public Event MouseWheelDownImage As MouseWheelEventHandler
[C#] public event MouseWheelEventHandler MouseWheelDownImage;

Event Data

The event handler receives arguments of type MouseWheelEventArgs

Explanation

The MouseWheelDownImage event is generated when the mouse wheel is rolled down.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseWheelUpImage event

Newtone.ImageKit.Win.ImageKit.MouseWheelUpImage Event

This event is generated when the mouse wheel is rolled up.

[Visual Basic] Public Event MouseWheelUpImage As MouseWheelEventHandler
[C#] public event MouseWheelEventHandler MouseWheelUpImage;

Event Data

The event handler receives arguments of type MouseWheelEventArgs

Explanation

The MouseWheelUpImage event is generated when the mouse wheel is rolled up.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Progress event

Newtone.ImageKit.Win.ImageKit.Progress Event

This event is generated when an effect is being processed or a file is being loaded or saved.

[Visual Basic] Public Event Progress As ProgressEventHandler
[C#] public event ProgressEventHandler Progress;

Event Data

The event handler receives arguments of type ProgressEventArgs

Explanation

This event is generated when an Effect method is executed or when a File method, such as theLoadRawDataFromFile, SaveRawDataFromFile, LoadImageFromFile, or SaveImageFromFile methods are executed.

To cancel a process, set the Effect.Cancel or File.Cancel property to True.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Scanning event

Newtone.ImageKit.Win.ImageKit.Scanning Event

This event is generated when an image is being scanned by the scan device.

[Visual Basic] Public Event Scanning As ProgressEventHandler
[C#] public event ProgressEventHandler Scanning;

Event Data

The event handler receives arguments of type ProgressEventArgs

Explanation

This event is generated when an image is being scanned by the scan device. To retreive the percentage that the current process has completed within this event, refer to the ProgressEventArgs arguments.

The Scanning event is only enabled when using memory transfer. It is not generated when native transfer or file transfer is used. Also, when memory transfer is used, if compression is used and the BeforeScan event's Width and Height properties of the BeforeScanEventArgs class have a value of -1, then the Scanning event is not generated.

Regarding properties of the ProgressEventArgs class: the Percent property can retrieve the percentage of process completed; to cancel, set the Cancel property to True within this event.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollDispImage event

Newtone.ImageKit.Win.ImageKit.ScrollDispImage Event

This event is generated when a scroll bar is used to scroll the image.

[Visual Basic] Public Event ScrollDispImage As ScrollDispEventHandler
[C#] public event ScrollDispEventHandler ScrollDispImage;

Event Data

The event handler receives arguments of type ScrollDispEventArgs.

Explanation

To generate this event, the image must be displayed in actual size and the ScrollBar property must be True.

Note: This event is not generated when a mouse drag is used to scroll the image (when the MouseDragImage property is true).

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartDispImage event

Newtone.ImageKit.Win.ImageKit.StartDispImage Event

This event is generated just before the image is displayed.

[Visual Basic] Public Event StartDispImage As DispEventHandler
[C#] public event DispEventHandler StartDispImage;

Event Data

The event handler receives arguments of type DispEventArgs.

Explanation

The StartDispImage event is generated just before the image is displayed.

If there are processes that you want to occur just before an image is displayed, place that code within this event.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartLoad event

Newtone.ImageKit.Win.ImageKit.StartLoad Event

This event is generated before a file has started to load.

[Visual Basic] Public Event StartLoad As FileEventHandler
[C#] public event FileEventHandler StartLoad;

Event Data

The event handler receives arguments of type FileEventArgs.

Explanation

The StartLoad event is generated before a file has started to load.

It is generated when the File.LoadRawDataFromFile or the File.LoadImageFromFile methods are executed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartRasterToVector event

Newtone.ImageKit.Win.ImageKit.StartRasterToVector Event

This event is generated when a raster image is converted to a vector image.

[Visual Basic] Public Event StartRasterToVector As EventHandler
[C#] public event EventHandler StartRasterToVector;

Event Data

The event handler receives arguments of type EventArgs.

Explanation

The StartRasterToVector event is generated when a raster image is converted to a vector image, i.e. when the Vector.RasterToVector method is executed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartSave event

Newtone.ImageKit.Win.ImageKit.StartSave Event

This event is generated when a file is saved.

[Visual Basic] Public Event StartSave As FileEventHandler
[C#] public event FileEventHandler StartSave;

Event Data

The event handler receives arguments of type FileEventArgs.

Explanation

The StartSave event is generated when a file is saved, i.e. when the File.SaveRawDataToFile method or the File.SaveImageToFile method are executed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


StartVectorToRaster event

Newtone.ImageKit.Win.ImageKit.StartVectorToRaster Event

This event is generated when a vector image is converted to a raster image.

[Visual Basic] Public Event StartVectorToRaster As EventHandler
[C#] public event EventHandler StartVectorToRaster;

Event Data

The event handler receives arguments of type EventArgs

Explanation

The StartVectorToRaster event is generated when a vector image is converted to a raster image, i.e. when the Vector.VectorToRaster method is executed.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


AfterScanEventHandler delegate

Newtone.ImageKit.Win.ImageKit.AfterScanEventHandler Delegate

This delegate represents the method that handles the AfterScan
[Visual Basic] Public Delegate Sub AfterScanEventHandler(ByVal sender As Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs)
[C#] public delegate void AfterScanEventHandler(object sender, Newtone.ImageKit.AfterScanEventArgs e);

Parameters

sender
Event Source

e
Event data contained in AfterScanEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


BeforeScanEventHandler delegate

Newtone.ImageKit.Win.ImageKit.BeforeScanEventHandler Delegate

This delegate represents the method that handles the BeforeScan event.
[Visual Basic] Public Delegate Sub BeforeScanEventHandler(ByVal sender As Object, ByVal e As Newtone.ImageKit.BeforeScanEventArgs)
[C#] public delegate void BeforeScanEventHandler(object sender, Newtone.ImageKit.BeforeScanEventArgs e);

Parameters

sender
Event Source

e
Event data contained in BeforeScanEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DispEventHandler delegate

Newtone.ImageKit.Win.ImageKit.DispEventHandler Delegate

This delegate represents the method that handles the StartDispImage event and the EndDispImage event.
[Visual Basic] Public Delegate Sub DispEventHandler(ByVal sender As Object, ByVal e As DispEventArgs)
[C#] public delegate void DispEventHandler(object sender, DispEventArgs e);

Parameters

sender
Event Source

e
Event data contained in DispEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


FileEventHandler delegate

Newtone.ImageKit.Win.ImageKit.FileEventHandler Delegate

This delegate represents the method that handles the StartLoad event, the EndLoad event, the StartSave event, the EndSave event, and the GetDragDropFileName event.
[Visual Basic] Public Delegate Sub FileEventHandler(ByVal sender As Object, ByVal e As FileEventArgs)
[C#] public delegate void FileEventHandler(object sender, FileEventArgs e);

Parameters

sender
Event Source

e
Event data contained in FileEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


FilePageEventHandler delegate

Newtone.ImageKit.Win.ImageKit.FilePageEventHandler Delegate

This delegate represents the method that handles the GetDragDropFileName event.
[Visual Basic] Public Delegate Sub FilePageEventHandler(ByVal sender As Object, ByVal e As FilePageEventArgs)
[C#] public delegate void FilePageEventHandler(object sender, FilePageEventArgs e);

Parameters

sender
Event Source

e
Event data contained in FilePageEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseButtonEventHandler delegate

Newtone.ImageKit.Win.ImageKit.MouseButtonEventHandler Delegate

This delegate represents the method that handles the MagnifierMouseDown event, the MagnifierMouseMove event, and the MagnifierMouseUp event.
[Visual Basic] Public Delegate Sub MouseButtonEventHandler(ByVal sender As Object, ByVal e As MouseButtonEventArgs)
[C#] public delegate void MouseButtonEventHandler(object sender, MouseButtonEventArgs e);

Parameters

sender
Event Source

e
Event data contained in MouseButtonEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseSelectEventHandler delegate

Newtone.ImageKit.Win.ImageKit.MouseSelectEventHandler Delegate

This delegate represents the method that handles the MouseDownSelectLayerImage event and theMouseUpSelectLayerImage event.
[Visual Basic] Public Delegate Sub MouseSelectEventHandler(ByVal sender As Object, ByVal e As MouseSelectEventArgs)
[C#] public delegate void MouseSelectEventHandler(object sender, MouseSelectEventArgs e);

Parameters

sender
Event Source

e
Event data contained in MouseSelectEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseUpDownEventHandler delegate

Newtone.ImageKit.Win.ImageKit.MouseUpDownEventHandler Delegate

This delegate represents the method that handles the MouseDownImage event, the MouseMoveImage event, and the MouseUpImage event.
[Visual Basic] Public Delegate Sub MouseUpDownEventHandler(ByVal sender As Object, ByVal e As MouseUpDownEventArgs)
[C#] public delegate void MouseUpDownEventHandler(object sender, MouseUpDownEventArgs e);

Parameters

sender
Event Source

e
Event data contained in MouseUpDownEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseWheelEventHandler delegate

Newtone.ImageKit.Win.ImageKit.MouseWheelEventHandler Delegate

This delegate represents the method that handles the MouseWheelDownImage event and the MouseWheelUpImage event.
[Visual Basic] Public Delegate Sub MouseWheelEventHandler(ByVal sender As Object, ByVal e As MouseWheelEventArgs)
[C#] public delegate void MouseWheelEventHandler(object sender, MouseWheelEventArgs e);

Parameters

sender
Event Source

e
Event data contained in MouseWheelEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


PointEventHandler delegate

Newtone.ImageKit.Win.ImageKit.PointEventHandler Delegate

This delegate represents the method that handles the ClickOnPanWindow event.
[Visual Basic] Public Delegate Sub PointEventHandler(ByVal sender As Object, ByVal e As PointEventArgs)
[C#] public delegate void PointEventHandler(object sender, PointEventArgs e);

Parameters

sender
Event Source

e
Event data contained in PointEventArgs

Return Value

Returns True if successful. Returns False if unsuccessful.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ProgresstEventHandler delegate

Newtone.ImageKit.Win.ImageKit.ProgresstEventHandler Delegate

This delegate represents the method that handles the Progress event.
[Visual Basic] Public Delegate Sub ProgresstEventHandler(ByVal sender As Object, ByVal e As ProgressEventArgs)
[C#] public delegate void ProgresstEventHandler(object sender, ProgressEventArgs e);

Parameters

sender
Event Source

e
Event data contained in ProgressEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScanningEventHandler delegate

Newtone.ImageKit.Win.ImageKit.ScanningEventHandler Delegate

This delegate represents the method that handles the Scanning event.
[Visual Basic] Public Delegate Sub ScanningEventHandler(ByVal sender As Object, ByVal e As Newtone.ImageKit.ScanningEventArgs)
[C#] public delegate void ScanningEventHandler(object sender, Newtone.ImageKit.ScanningEventArgs e);

Parameters

sender
Event Source

e
Event data contained in ScanningEventArgs

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


AppearanceStyle enum

Newtone.ImageKit.Win.AppearanceStyle Enum

This refers to the appearance style of the ImageKit Control border.
public enum AppearanceStyle

Public Members

Member | Value | Explanation
Flat | 0 | Flat
Lowered | 1 | Lowered
Raised | 2 | Raised

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DisplayMode enum

Newtone.ImageKit.Win.DisplayMode Enum

This refers to the types of the display mode.

public enum DisplayMode

Public Members

Member | Value | Explanation
Clear | 0 | Clears the image within the ImageKit Control
Scale | 1 | Scale display mode
Stretch | 2 | Stretch display mode
ActualSize | 3 | Actual size display mode
FitToWidth | 4 | Fit to Width
FitToHeight | 5 | Fit to Height

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


HatchPattern enum

Newtone.ImageKit.Win.HatchPattern Enum

This refers to the hatchpattern that is displayed in that portion of the ImageKit control not covered by an image.

public enum HatchPattern

Public Members

Member | Value | Explanation
NonHatch | 0 | Does not display the hatch pattern, instead, the color set in the BackColor property is used.
ShowHatch | 1 | Displays the hatch pattern
TransparentHatch | 2 | Does not display the hatch pattern, instead, the area is set to transparent

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


KindOfImage enum

Newtone.ImageKit.Win.KindOfImage Enum

This refers to the image types set into the Image property.

public enum KindOfImage

Public Members

Member | Value | Explanation
InvalidImage | 0 | Unknown
RasterImage | 1 | Raster image
VectorWMF | 2 | WMF
VectorEMF | 3 | EMF
VectorDXF | 4 | DXF
VectorSVG | 5 | SVG
VectorSXFP21 | 6 | SXF p21
VectorSXFSFC | 7 | SXF sfc

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


LengthUnit enum

Newtone.ImageKit.Win.LengthUnit Enum

This refers to the units of measurement at which the tool tip coordinates are displayed.

public enum LengthUnit

Public Members

Member | Value | Explanation
None | 0 | None
Pixel | 1 | Pixels
mm | 2 | Millimeters
Inch | 3 | Inches

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MagnifierType enum

Newtone.ImageKit.Win.MagnifierType Enum

This refers to the shapes of the magnifier.

public enum MagnifierType

Public Members

Member | Value | Explanation
RectangleMagnifier | 0 | Rectangle
EllipseMagnifier | 2 | Ellipse

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollDirection enum

Newtone.ImageKit.Win.ScrollDirection Enum

This refers to the direction to scroll the image.

public enum ScrollDirection

Public Members

Member | Value | Explanation
UpLeft | 0 | UpLeft
Up | 1 | Up
UpRight | 2 | UpRight
Right | 3 | Right
DownRight | 4 | DownRight
Down | 5 | Down
DownLeft | 6 | DownLeft
Left | 7 | Left

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


WheelDirection enum

Newtone.ImageKit.Win.WheelDirection Enum

This refers to the direction of the mouse wheel.

public enum WheelDirection

Public Members

Member | Value | Explanation
Disable | 0 | Disables scrolling with the mouse wheel
Vertical | 1 | Mouse scrolls in a vertical direction
Horizontal | 2 | Mouse scrolls in a horizontal direction

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Effect Members

Newtone.ImageKit.Win.ImageKit.Effect All Members

Public Properties

DestinationMask | Retrieves the mask image used when processing an effect
Inside | Determines whether the area inside the selected area will be processed or the area outside the selected area will be processed
Point | Sets the coordinates values for the points defining the polygon area on the image to be processed
Rect | Sets the coordinates of a rectangle on the image
SelectMode | Sets the type of area that will be processed on the image
SourceMask | Refers to the image handle for the input mask image

Public methods

Affine | Corrects a warped raster image
AntiAlias | Smoothes edges in raster images
AutoSelectImage | Uses a specified color (RGB value), compares this value to pixels in the image and selects areas of the image that have that color. From this selection, this method creates a new image and mask image.
Blur | Blurs a raster image
Canvas | Produces a canvas effect on the raster image
CheckSecretImage | Retrieves the digital watermark from a raster image
Chroma | Adjusts the chrominance of a raster image
CombineRGBAImage | Creates a 32-bit RGBA image from an image and an alpha channel
ConvertColor | Converts images from one bit count to another
CustomFilter | Creates a custom effects filter for raster images
CutRectImage | Copies that portion of a raster image that is specified by the selected rectangle
Emboss | Creates an emboss effect on a raster image
EndBitmapAccess | Allows access to pixels in the Device Independent Bitmap (DIB)
GetBitmapPixel | Retrieves the RGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB)
GlassTile | Creates an glass tile effect on a raster image
Layer | Layers two raster images together
Lens | Creates a lens like effect on a raster image
Mosaic | Creates a mosiac effect on a raster image
MotionBlur | Creates a motion blur effect on a raster image
OilPaint | Produces an effect similar to an oil painting on the image
Outline | Produces an outline effect on the image
Panorama | Composes a panorama image from two raster images
PasteImage | Pastes a raster image into another raster image
RedEyeRemoval | Removes "red eye" from images by converting reddish colors within the selected area to another specified color
RemoveNoise | Reduces the image noise in raster images
Resize | Changes the size of a raster image
RGBGamma | Uses gamma correction to adjust the RGB values of a raster image
RGBLevel | Increases (or decreases) the RGB values of a raster image
RGBReverse | Reverses the RGB values of a raster image
RGBSpline | Uses spline function to modifiy the RGB values of a raster image
Ripple | Produces a ripple like effect on a raster image
Rotation | Rotates a raster image
SelectImage | Defines an area on a raster image and create a new image and mask image from that area
SetBitmapPixel | Sets the RGB value and the palette number of a specified pixel in the Device Independent Bitmap (DIB)
SetGray | Changes a raster image to gray
SetSecretImage | Sets a digital watermark image or digital watermark text into a raster image
Sharp | Modifies sharpness in a raster image
SplitRGBAImage | Splits a 32 bit RGBA image into a 24 bit RGB image and a 8 bit alpha channel
StartBitmapAccess | Allows access to pixels in the Device Independent Bitmap (DIB)
UnifyColor | Allows you to convert a range in colors in a raster image into one color
Waves | Creates a wave like effect on a raster image
WhirlPinch | Produces an interesting effect similar to pinching a raster image then twisting your fingers
YCCGamma | Uses gamma correction to adjust the YCrCb values of a raster image
YCCLevel | Increases (or decreases) the YCrCb values of a raster image
YCCReverse | Reverses the YCrCb values of a raster image
YCCSpline | Uses spline function to modifiy the YCrCb values of a raster image

See Also

Newtone.ImageKit.Win.ImageKit


DestinationMask property

Newtone.ImageKit.Win.ImageKit.Effect.DestinationMask Property

This property retrieves the mask image used when processing an effect.
[Visual Basic] Public ReadOnly Property DestinationMask As Image
[C#] public Image DestinationMask {get;}

Property Value

Image class

Explanation

This property retrieves the mask image used when processing an effect. The mask image must be a 1-bit color black and white image which is the same size as the image it masks.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Inside property

Newtone.ImageKit.Win.ImageKit.Effect.Inside Property

This property determines whether the area inside the selected area will be processed or the area outside the selected area will be processed.

[Visual Basic]
Public Property Inside As Boolean
[C#]
public bool Inside {get; set;}

Property Value

When true, the area inside the selected area will be processed. When false, the area outside the selected area will be processed.

Explanation

The Inside property determines whether the area inside the selected area will be processed or the area outside the selected area will be processed. This property is enabled when the SelectMode property is set to EffectMask, EffectPolygon, or EffectEllipse.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Point property

Newtone.ImageKit.Win.ImageKit.Effect.Point Property

This property sets the coordinates values for the points defining the polygon area on the image that will be processed by an effect.
[Visual Basic]
Public Property Point As Point
[C#]
public Point[] Point {get; set;}

Property Value

The values of the coordinate points of a polygon on the image (must be 2 or more points) Explanation

The Point property sets the coordinates values for the points defining the polygon area on the image that will be processed by an effect. This property is enabled when the SelectMode property is set to EffectPolygon. The origin (0,0) for the coordinate space is at the top left.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Rect property

Newtone.ImageKit.Win.ImageKit.Effect.Rect Property

This property sets the coordinates of a rectangle on the image. This rectangle is used by the CutRectImage method or used to process an elliptical area on the image.

[Visual Basic]
Public Property Rect As Rectangle
[C#]
public Rectangle Rect {get; set;}

Property Value

The coordinates of the rectangle

Explanation

The Rect property sets the coordinates of a rectangle on the image. This rectangle is used by the CutRectImage method or used to process an elliptical area on the image.

The origin (0,0) for the coordinate space is at the top left. The Rect property can be set directly, for example,

ImageKit1.Effect.Rect = new Rectangle(100,100,200,200)

will set an area on the image whose top left corner is at (100,100) and that has a height and width of 200 respectively. For more information, please refer to the System.Drawing.Rectangle.

If the ImageKit.Rect property is set, it is possible to pass this rectangle directly into the Rect property like this:

ImageKit.Effect.Rect = ImageKit.Rect

The Rect property is used by the CutRectImage method or used to process an elliptical area on the image when the SelectMode property is set to EffectEllipse.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SelectMode property

Newtone.ImageKit.Win.ImageKit.Effect.SelectMode Property

This property sets the type of area that will be processed on the image.

[Visual Basic]
Public Property SelectMode As AreaSelectMode
[C#]
public AreaSelectMode SelectMode {get; set;}

Property Value

The value is of type AreaSelectMode

Explanation

The SelectMode property sets the type of area that will be processed on the image.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SourceMask property

Newtone.ImageKit.Win.ImageKit.Effect.SourceMask Property

This property refers to the image handle for the input mask image.

[Visual Basic]
Public Property SourceMask As Image
[C#]
public Image SourceMask {get; set;}

Property Value

Image class

Explanation

The SourceMask property refers to the image handle for the input mask image.

The mask image should be a black and white, 1 bit color image that is the same size as the image it masks. The white portions of the mask are enabled, the black portion are masked.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Affine method

Newtone.ImageKit.Win.ImageKit.Effect.Affine Method

This method corrects a warped raster image.

[Visual Basic] Public Function Affine() As Boolean
[C#] public bool Affine();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Affine method corrects a warped raster image. To execute the Affine method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The area on the image to be processed is determined by the coordinates for 4 points which are set in the Point property.

The Affine method supports 1, 4, 8, 16, 24, and 32 bit color images. If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image property).

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


AntiAlias method

Newtone.ImageKit.Win.ImageKit.Effect.AntiAlias Method

This method smoothes edges in raster images.

[Visual Basic] Public Function AntiAlias() As Boolean
[C#] public bool AntiAlias();

Parameters

Nane

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The AntiAlias method smoothes edges in raster images. To execute the AntiAlias method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The AntiAlias method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the AntiAlias method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


AutoSelectImage method

Newtone.ImageKit.Win.ImageKit.Effect.AutoSelectImage Method

This method uses a specified color (RGB value), compares this value to pixels in the image and selects areas of the image that have that color. From this selection, This method creates a new image and mask image.

[Visual Basic] Public Function AutoSelectImage(red As Byte, green As Byte, blue As Byte, mode As Integer, level As Integer) As Boolean
[C#] public bool AutoSelectImage(byte red, byte green, byte blue, int mode, int level);

Parameters

red
Specifies the red value of the color that will be selected (From 0 to 255)

green
Specifies the green value of the color that will be selected (From 0 to 255)

blue
Specifies the blue value of the color that will be selected (From 0 to 255)

mode
Comparison mode (0:RGB, 1:CrCb, 2:Y)

level
Level of Allowance (From 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The AutoSelectImage method uses a specified color (RGB value), and selects areas of the image that have that color. To execute the AutoSelectImage method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The AutoSelectImage method supports 1, 4, 8, 16, 24, and 32 bit images.

The Mode parameter sets the type of color comparison used to select portions of the image. When the Mode parameter is other than 0 (i.e. CrCb or Y) then all RGB values are converted to YCrCb values and compared. The Level parameter controls the range of RGB values that will be selected. If the Level value is 0, then only those pixels that have the save RGB value as that specified in the Red, Green, and Blue parameters will be selected. As the Level parameter increases, the range of RGB values that will be selected increases. For example, if Level = 10 and Red, Green, and Blue = 100 respectively, then all pixels with an RGB value between (90, 90, 90) and (110, 110, 110) will be selected.

Before executing the AutoSelectImage method, you must set the area on the image that will be affected. There are 3 ways to do this.

  1. To process the total image, set the SelectMode property to EffectAll
  2. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  3. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Set the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property, and the mask image set in the DesinationMask property will be set.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Blur method

Newtone.ImageKit.Win.ImageKit.Effect.Blur Method

This method blurs a raster image.

[Visual Basic] Public Function Blur(level As Integer) As Boolean
[C#] public bool Blur(int level);

Parameters

plevel
The strength of the bluring function (From 1 to 20). As the Level increases, the strength of the blur increases.

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Blur method blurs a raster image. As the Level parameter increases, the strength of the blur increases. To execute the Blur method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Blur method supports 8-bit grayscale, 16, 24, and 32 bit images.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Set the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Canvas method

Newtone.ImageKit.Win.ImageKit.Effect.Canvas Method

This method produces a canvas effect on the raster image.

[Visual Basic] Public Function Canvas(direction As Integer, depth As Integer) As Boolean
[C#] public bool Canvas(int direction, int depth);

Parameters

direction
The direction of the canvas pattern (0:From top to right, 1: From top to left, 2: From bottom to left, 3: From bottom to right)

depth
Depth of the canvas pattern (From 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Canvas method produces a canvas effect on the raster image. To execute the Canvas method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Canvas method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the Canvas method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


CheckSecretImage method

Newtone.ImageKit.Win.ImageKit.Effect.CheckSecretImage Method

This method retrieves the digital watermark from a raster image.

[Visual Basic] Public Function CheckSecretImage(keyImage As Image, Image secretImage, level As Integer) As Boolean
[C#] public bool CheckSecretImage(Image keyImage, Image secretImage, int level);

Parameters

keyImage
The original image.
This is the image without a digital watermark.
It is used as a key to compare to another image and check if a watermark exists (24 bit color images only).

secretImage
The image that contains the watermark (24 bit color images only)

level
The level at which to retrieve the watermark (From -20 to 20)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CheckSecretImage method retrieves the digital watermark from an image whose watermark has been set with the SetSecretImage method. It CANNOT retrieve other types of watermarks.

The Level parameter should be set to a value that is the same as or slighly smaller than the Level at which the watermark was embedded into the image using the SetSecretImage method. Using a Level to retrieve the watermark that differs significantly from the Level at which the watermark was set will result in no watermark being retrieved. Furthermore, the orginal image and the watermarked image must be exactly the same size. If either image has been resized, no watermark can be retrieved.

If successful the resulting raster image handle is set in the Image property or the Layer(LayerNumber).Image property dpending on the value set in the LayerNumber property. The CheckSecretImage method supports only 24 bit color images. The resulting image has a black background with the digital watermark appearing in white. (It is a 1-bit image that is the same size as the images set in keyImage and secretImage.)

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Chroma method

Newtone.ImageKit.Win.ImageKit.Effect.Chroma Method

This method adjusts the chrominance of a raster image.

[Visual Basic] Public Function Chroma(level As Integer) As Boolean
[C#] public bool Chroma(int level);

Parameters

level
Chrominance Level (-100 to 1000)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Chroma method adjusts the chrominance of the image. Chrominance refers to the color element of the image whereas Luminance refers to the brightness element. You can adjust the chrominance by using the Level parameter which can have a value ranging from -100 to 1000. When the Level parameter is 0, there is no change in the image color. As the level becomes negative, the colors in the image become less vivid. When the Level parameter reaches -100 the chrominance element is negated leaving only the Luminance element. This is grayscale. Conversely, as the Level parmeter increases from 0, the colors become more vivid.

To execute the Chroma method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Chroma method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the Chroma method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


CombineRGBAImage method

Newtone.ImageKit.Win.ImageKit.Effect.CombineRGBAImage Method

This method creates a 32-bit RGBA image from an image and an alpha channel.

[Visual Basic] Public Function CombineRGBAImage As Boolean
[C#] public bool CombineRGBAImage();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CombineRGBAImage method creates a 32-bit RGBA image from an image and an alpha channel. To execute the CombineRGBAImage method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property (1, 4, 8, 16, 24, or 32 bit image) and set the alpha channel image handle into the SourceMask property (1 bit color or 8 bit grayscale image).

If successful the resulting RGBA 32-bit image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


ConvertColor method

Newtone.ImageKit.Win.ImageKit.Effect.ConvertColor Method

This method converts images from one bit count to another.

[Visual Basic] Public Function ConvertColor( pixelType As Integer, fixPalette As Boolean, dithering As Boolean, level As Integer ) As Boolean
[C#] public bool ConvertColor( int PixelType, bool FixedPal, bool dithering, int level );

Parameters

pixelType
The number of bits per pixel (1, 4, 8, 16, 24, 32, 40, 80) after the conversion
* 4 represents 4 bit color, 40 is for 4 bit grayscale, 8 is for 8 bit color, and 80 is for 8 bit grayscale.

fixPalette
Fixed palette settings (Use when decreasing or increasing to 1, 4, or 8 bit color)
False: Uses a created palette most suitable for the image
True: Uses a fixed palette

dithering
Sets the dither (error diffusion) (Use when decreasing to 1, 4, or 8 bit color or 4 bit grayscale)
False(0): Does not dither
True(nonzero): Dithers

level
Threshold value settings (Use when decreasing to 1 bit images)
0 to 255

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The ConvertColor method changes the number of colors (also known as the bit count) of a raster image.

To execute the ConvertColor method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. When decreasing the number of colors of an image to 1 bit color, if the RGB value (an average of the red, green, and blue values) is less than the threshold value, the palette is set to 0, otherwise it is set to 1. If successful the resulting raster image data is set in the Image property or the Layer(LayerNumber).Image property depending on the value of the LayerNumber property.

The ConvertColor method supports 1, 4, 8, 16, 24, and 32 bit images.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


CustomFilter method

Newtone.ImageKit.Win.ImageKit.Effect.CustomFilter Method

This method allows you to create a custom effects filter for raster images.

[Visual Basic] Public Function CustomFilter( matrix(,) As Integer, div As Integer, level As Integer, red As Boolean, green As Boolean, blue As Boolean ) As Boolean
[C#] public bool CustomFilter( int[,] matrix, int div, int level, bool red, bool green, bool blue );

Parameters

matrix
9x9 matrix (an array of 81 items ranging from 0 to 80)

div
The division factor

level
The bias factor (from 0 to 255, as this factor increases, the color becomes brighter)

red
To process the red plane, set to True, otherwise set to False

green
To process the green plane, set to True, otherwise set to False

blue
To process the blue plane, set to True, otherwise set to False

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CustomFilter method allows you to create a custom effects filter for raster images. An effects filter alters each pixel's color based on its current color and the colors of any neighboring pixels. (See the explanation of the filter matrix below.)

To execute the CustomFilter method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The CustomFilter method supports 8-bit grayscale, 16, 24, and 32 bit images.

When processing a grayscale image the Red, Green and Blue parameter values are disabled.

Before executing the CustomFilter method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

The filter consists of an array of coefficients called a filter matrix. A filter processes an image on a pixel-by-pixel basis. Each pixel's color value is multiplied by the coefficient in the matrix center, and any pixels within the matrix are multiplied by the corresponding coefficients. The sum of the products becomes the target pixel's new value. To make the filter matrix, it is necessary to create an array containing 80 elements and set the appropriate coefficient values in the array elements. The formula used to calculate the target pixel's value is given below:

Where F is the output value of the target pixel, Pi is a pixel in the grid, and Ci is a coefficient in the matrix. Div is the division factor which allows you to achieve effects that would otherwise require decimal coefficients. Level is a bias factor. You use the bias to shift the value of each pixel by a fixed amount. As the bias factor increases, the resultant color is brighter. Bias adjustments are particularly useful for creating embossing effects.

Some sample matrix are given below:

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


CutRectImage method

Newtone.ImageKit.Win.ImageKit.Effect.CutRectImage Method

This method copies that portion of a raster image that is specified by the selected rectangle.

[Visual Basic] Public Function CutRectImage As Boolean
[C#] public bool CutRectImage();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CutRectImage method allows you to copy a portion of a raster image without using a mask image. (If you wish to use a mask image, please refer to the SelectImage method).

To execute the CutRectImage method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property and specify the area to be copied by setting the Rect property. The CutRectImage method supports 1, 4, 8, 16, 24, and 32 bit images.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Emboss method

Newtone.ImageKit.Win.ImageKit.Effect.Emboss Method

This method creates an emboss effect on a raster image.

[Visual Basic] Public Function Emboss(pattern As Integer, edge As Integer, level As Integer) As Boolean
[C#] public bool Emboss(int pattern, int edge, int level);

Parameters

pattern
Sets the direction of the emboss (0: Left to Right, 1: Top Left to Bottom Right, 2: Top to Bottom, 3: Top Right to Bottom Left, 4: Right to Left, 5: Bottom Right to Top Left, 6: Bottom to Top, 7: Bottom Left to Top Right)

edge
Sets the depth of the emboss (from 1 to 5; where 5 is the deepest emboss)

level
Sets the brightness of the emboss (from 0 to 255; where 255 is the brightest)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Emboss method creates an emboss effect on a raster image. To execute the Emboss method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Emboss method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the Emboss method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


EndBitmapAccess method

Newtone.ImageKit.Win.ImageKit.Effect.EndBitmapAccess Method

This method is used to allow access to pixels in the Device Independent Bitmap (DIB). This method is to be used in conjunction with the StartBitmapAccess method.

[Visual Basic] Public Function EndBitmapAccess() As Boolean
[C#] public bool EndBitmapAccess();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The EndBitmapAccess method is to be used in conjunction with the StartBitmapAccess method.

To execute the EndBitmapAccess method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The EndBitmapAccess method supports 1, 4, 8, 16, 24, and 32 bit images.

To access the bitmap and manipulate pixel data, you must use the following methods as a group:

StartBitmapAccess
|
GetBitmapPixel, SetBitmapPixel
|
EndBitmapAccess

Example

The following code starts access to the DIB, then loops through each pixel in the image, using the GetBitmapPixel method to retrieve the pixels' rgb values. Then those values are reversed and set using the SetBitmapPixel method. (For 1, 16, 24, or 32 bit images)

[Visual Basic]
Dim Ret As Boolean
Dim i As Long, j As Long
Dim PalNo As Integer, Red As Integer, Green As Integer, Blue As Integer

Ret = ImageKit1.GetImageType()
If Ret = False Then Exit Sub
Ret = ImageKit1.Effect.StartBitmapAccess()
If Ret = False Then Exit Sub

For i = 0 To ImageKit1.Image.Height - 1
  For j = 0 To ImageKit1.Image.Width - 1
    Ret = ImageKit1.Effect.GetBitmapPixel(j, i, PalNo, Red, Green, Blue)
    If ImageKit1.BitCount = 1 Then
      If PalNo <> 0 Then
        PalNo = 0
      Else
        PalNo = 1
      End If
    Else If ImageKit1.BitCount > 8 Then
      Blue = 255 - Blue
      Green = 255 - Green
      Red = 255 - Red
    End If
    Ret = ImageKit1.Effect.SetBitmapPixel(j, i, PalNo, Red, Green, Blue)
  Next j
Next i

Ret = ImageKit1.Effect.EndBitmapAccess()
ImageKit1.Refresh()

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


GetBitmapPixel method

Newtone.ImageKit.Win.ImageKit.Effect.GetBitmapPixel Method

This method retrieves the RGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB).

[Visual Basic] Public Function GetBitmapPixel(x As Integer, y As Integer, palette As Byte, red As Byte, green As Byte, blue As Byte) As Boolean
[C#] public bool GetBitmapPixel( int x, int y, ref byte palette, ref byte red, ref byte green, ref byte blue );

Parameters

x,y
The x,y coordinates of the specified pixel

palette
The palette number of the specified pixel

red
The red component of the RGB value of the specified pixel

green
The green component of the RGB value of the specified pixel

blue
The blue component of the RGB value of the specified pixel

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetBitmapPixel method retrieves the RGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB). For 1, 4, and 8 bit images, the applicable values are set in the Palette parameter. For 16, 24, and 32 bit images, the applicable values are set in the red, green, and blue parameters.

The image to be processed is determined by the values set in the LayerNumber property.

To access the bitmap and manipulate pixel data, you must use the following methods as a group:

StartBitmapAccess
|
GetBitmapPixel, SetBitmapPixel
|
EndBitmapAccess

Example

The following code starts access to the DIB, then loops through each pixel in the image, using the GetBitmapPixel method to retrieve the pixels' rgb values. Then those values are reversed and set using the SetBitmapPixel method (For 1, 16, 24, or 32 bit images).

[Visual Basic]
Dim Ret As Boolean
Dim i As Long, j As Long
Dim PalNo As Integer, Red As Integer, Green As Integer, Blue As Integer

Ret = ImageKit1.GetImageType()
If Ret = False Then Exit Sub
Ret = ImageKit1.Effect.StartBitmapAccess()
If Ret = False Then Exit Sub

For i = 0 To ImageKit1.Image.Height - 1
  For j = 0 To ImageKit1.Image.Width - 1
    Ret = ImageKit1.Effect.GetBitmapPixel(j, i, PalNo, Red, Green, Blue)
    If ImageKit1.BitCount = 1 Then
      If PalNo <> 0 Then
        PalNo = 0
      Else
        PalNo = 1
      End If
    Else If ImageKit1.BitCount > 8 Then
      Blue = 255 - Blue
      Green = 255 - Green
      Red = 255 - Red
    End If
    Ret = ImageKit1.Effect.SetBitmapPixel(j, i, PalNo, Red, Green, Blue)
  Next j
Next i

Ret = ImageKit1.Effect.EndBitmapAccess()
ImageKit1.Refresh()

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


GlassTile method

Newtone.ImageKit.Win.ImageKit.Effect.GlassTile Method

This method creates an glass tile effect on a raster image.

[Visual Basic] Public Function GlassTile(xSize As Integer, ySize As Integer) As Boolean
[C#] public bool GlassTile(int xSize, int ySize);

Parameters

xSize
Sets the width of each glass tile (from 10 to 100)

ySize
Sets the height of each glass tile (from 10 to 100)

Return Value

Returns True if successful. Returns False if successful.

Explanation

The GlassTile method produces an effect similar to glass tile on the image. To execute the GlassTile method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The GlassTile method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the GlassTile method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Set the appropriate values in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

Note: When the SelectMode property is set to EffectPolygon or EffectEllipse, the values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Layer method

Newtone.ImageKit.Win.ImageKit.Effect.Layer Method

This method layers two raster images together.

[Visual Basic] Public Function Layer( bottomImage As Image, topImage As Image, transLevel As Integer, transColor As Boolean, transRed As Byte, transGreen As Byte, transBlue As Byte, backRed As Byte, backGreen As Byte, backBlue As Byte, x As Integer, y As Integer, clip As Boolean, alpha As Boolean ) As Boolean
[C#] public bool Layer( Image bottomImage, Image topImage, int transLevel, bool transColor, byte transRed, byte transGreen, byte transBlue, byte backRed, byte backGreen, byte backBlue, int x, int y, bool clip, bool alpha );

Parameters

bottomImage
The image on which another image is layered (The image on the bottom). Supports 1, 4, 8, 16, 24, 32 bit images.

topImage
The image to be layered (The image on the top). Supports 1, 4, 8, 16, 24, 32 bit images.

transLevel
The level of transparency of topImage (From 0 to 255, as this value increases the image of topImage becomes visible)

transColor
Sets whether or not topImage has a transparent color. (False(0): No transparent color, True(non zero): Has transparent color)

transRed
Sets the red component of the RGB value of the transparent color for topImage (from 0 to 255)

transGreen
Sets the green component of the RGB value of the transparent color for topImage (from 0 to 255)

transBlue
Sets the blue component of the RGB value of the transparent color for topImage (from 0 to 255)

backRed
Sets the red component of the RGB value of the background color (from 0 to 255) This is the area of the image that is not part of either bottomImage or topImage

backGreen
Sets the green component of the RGB value of the background color (from 0 to 255) This is the area of the image that is not part of either bottomImage or topImage

backBlue
Sets the blue component of the RGB value of the background color (from 0 to 255) This is the area of the image that is not part of either bottomImage or topImage

x,y
The coordinates of the attachment location (in pixels)

clip
Sets whether or not the image is clipped (False(0): No clipping, True(nonzero) clipping)

alpha
Sets whether or not alpha channel is used ifalse: Does not use alpha channel, True: Uses alpha channelj

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Layer method layers two raster images together. The upper left corner of the TopImage is attached to the BottomImage at the x,y coordinate location.

If the Clip parameter is set to True, the size of the created image is the same as the BottomImage. Any portions of the TopImage that extend beyond the BottomImage will be clipped. If the Clip parameter is set to False, the size of the created image is the same as the combination of the two images. Any areas of the created image that are not in either the BottomImage or the TopImage will be the color set in the BackRed, BackGreen, and BackBlue parameters. If the TransColor parameter is set to True, the color set by the TransRed, TransGreen, and TransBlue parameters will be a transparent color.

When the Alpha parameter is True, the raster image set in the TopImage parameter must be a 32-bit RGBA image (A refers to an alpha channel containing a mask image). Note: When the Aalpha parameter is True, the TransLevel parameter is disabled.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

The output will be a 24 bit image. However, if either bottomImage or topImage is a 32 bit image, then the output will be a 32 bit image.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Lens method

Newtone.ImageKit.Win.ImageKit.Effect.Lens Method

This method creates a lens like effect on a raster image.

[Visual Basic] Public Function Lens( refract As Double, backColor As Boolean, red As Byte, green As Byte, blue As Byte ) As Boolean
[C#] public bool Lens( double refract, bool backColor, byte red, byte green, byte blue );

Parameters

refract
Sets the lens magnification (Greater than 1)

backColor
Sets whether or not the area outside of the lens effect is painted a particular color [True: the area is painted, False: the area is not painted]

red
Sets the red component of the color painted in the area outside the lens (from 0 to 255)

green
Sets the green component of the color painted in the area outside the lens (from 0 to 255)

blue
Sets the Blue component of the color painted in the area outside the lens (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Lens method produces a lens like effect on a raster image. To execute the Lens method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Lens method supports 8-bit grayscale, 16, 24, and 32 bit images.

Before executing the Lens method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Mosaic method

Newtone.ImageKit.Win.ImageKit.Effect.Mosaic Method

This method creates a mosaic effect on a raster image.

[Visual Basic] Public Function Mosaic(xSize As Integer, ySize As Integer) As Boolean
[C#] public bool Mosaic(int xSize, int ySize);

Parameters

xSize
The width of the mosaic (in pixels)

ySize
The height of the mosaic (in pixels)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Mosaic method creates a mosaic effect on a raster image. To execute the Mosaic method, set the image handle of the image in the Image property
or the Layer(LayerNumber).Image property. The Mosaic method supports 1, 4, 8, 16, 24, and 32 bit images.

If both of the values set in the XSize and YSize parameters are less than 1, this method does not produce an mosaic effect on a raster image.

Before executing the Mosaic method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


MotionBlur method

Newtone.ImageKit.Win.ImageKit.Effect.MotionBlur Method

This method creates a motion blur effect on a raster image.

[Visual Basic] Public Function MotionBlur(mode As Integer, length As Integer, angle As Integer) As Boolean
[C#] public bool MotionBlur(int mode, int length, int angle);

Parameters

mode
Sets the type of blur (0: Linear, 1: Radial, 2: Zoom)

length Sets the length of the blur (from 0 to 255)

angle Sets the angle of the blur (in degrees from 0 to 360)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The MotionBlur method creates a motion blur effect on a raster image. The Mode parameter determines the type of motion blur.

Mode=0 (Linear blur)
This motion blur simulates the image shifting. The Length parameter sets the magnitude of the shift. The Angle parameter determines the direction of the shift. The major directions of the Angle parameter are as follows: Angle=0 -> a shift to the left; Angle= 90 -> a shift down; Angle= 180 -> ashift to the right; Angle= 270-> a shift up.

Mode=1 (Radial blur)
This motion blur simulates the image spinning by the number of degrees set in the Angle parameter. The Length parameter is ineffective.

Mode=2 (Zoom blur)
This motion blur simulates the image zooming in by the length set in the Length parameter. The Angle parameter is ineffective.

To execute the MotionBlur method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The MotionBlur method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the MotionBlur method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


OilPaint method

Newtone.ImageKit.Win.ImageKit.Effect.OilPaint Method

This method produces an effect similar to an oil painting on the image.

[Visual Basic] Public Function OilPaint(mode As Integer, size As Integer) As Boolean
[C#] public bool OilPaint(int mode, int size);

Parameters

mode
Sets the processing mode (0:Process by RGB, 1:Process by Luminance (Brightness))

size
Sets brush stroke size (from 1 to 100)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The OilPaint method produces an effect similar to an oil painting on the image.

To execute the OilPaint method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The OilPaint method supports
8 bit grayscale, 16, 24, and 32 bit images.

Before executing the OilPaint method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Outline method

Newtone.ImageKit.Win.ImageKit.Effect.Outline Method

This method produces an outline effect on the image.

[Visual Basic] Public Function Outline(plane As Integer, mode As Integer, level As Integer) As Boolean
[C#] public bool Outline(int plane, int mode, int level);

Parameters

plane
Sets which plane will be used to process the outline (0:Y, 1:R, 2:G, 3:B)

mode
Sets the edge filtering function used to process the outline (0:Differential, 1:Roberts, 2:Sobel)

level
Sets the brightness at which an outline is drawn (from 0 to 100)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Outline method produces an outline of a raster image by identifying and displaying only the "edges" within the image. In general, the luminance plane is most commonly used. (Plane parameter = 0). In this case, differences in brightness are used to identify edges. However, the red plane, green plane or blue plane can also be used to identify an edge So, for example, if the red plane is used (Plane parameter = 1) then differences in the R values would be used to identify the edges within an image.

The Mode parameter determines how an edge is identified. The Level parameter determines at which value an edge will be displayed. When the Differential Operator is used, the differences between the pixel values (either brightness, red, green, or blue) are calculated and then depending on the value of the Level parameter, the edges are displayed. The Differential Operator evaluates these difference in a horizontal and/or vertical direction. The Roberts Operator also uses a differential calculation, but evaluates these differences at a 45 degree orientation. The Sorbel Operator is very similar to the above two operators except that with Sorbel there is an additional correction for images that have a lot of complexity.

To execute the Outline method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Outline method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the Outline method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Panorama method

Newtone.ImageKit.Win.ImageKit.Effect.Panorama Method

This method composes a panorama image from two raster images.

[Visual Basic] Public Function Panorama(bottomImage As Image, topImage As Image, cutMode As Integer, x11 As Integer, y11 As Integer, x12 As Integer, y12 As Integer, x21 As Integer, y21 As Integer, x22 As Integer, y22 As Integer, red As Byte, green As Byte, blue As Byte) As Boolean
[C#] public bool Panorama(Image bottomImage, Image topImage, int cutMode, int x11, int y11, int x12, int y12, int x21, int y21, int x22, int y22, int red, byte green, byte blue);

Parameters

bottomImage
the image on which another image is attached (24 bit only)

topImage
the raster image that is attached (24 bit only)

cutMode
Sets whether or not topImage parameter will be cut at the attachment location and if so which portion of topImage parameter will be cut
For horizontal attachments (0: no cut, 1: cut left portion, 2: cut right portion)
For vertical attachments (0: no cut, 1: cut lower portion, 2: cut upper portion)

x11,y11
The location of the first point of attachment for bottomImage (in pixels)

x12,y12
The location of the second point of attachment for bottomImage (in pixels)

x21,y21
The location of the first point of attachment for topImage (in pixels)

x22,y22
The location of the second point of attachment for topImage (in pixels)

red
Sets the red component of the RGB value of the background color (from 0 to 255).
This is the area of the panorama image that is not part of either bottomImage or topImage

green
Sets the green component of the RGB value of the background color (from 0 to 255).
This is the area of the panorama image that is not part of either bottomImage or topImage

blue
Sets the blue component of the RGB value of the background color (from 0 to 255).
This is the area of the panorama image that is not part of either bottomImage or topImage

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Panorama method composes a panorama from two raster images.

To execute the Panorama method, set the image handle of the base image into the BottomImage parameter. Set the image handle of the image you wish to attach to the base image into the TopImage parameter. Set the attachment location on BottomImage and TopImage. The Panorama method will attach the TopImage to the BottomImage at the location specified.

The cutMode parameter determines if any portion of TopImage will be cut off. If CutMode=0 then no portion of TopImage will be cut.

If the attachment is horizontal, i.e. the first attachment point is to the left of the second attachment point, then if CutMode=1, the portion of topImage to the left of the attachment location will be cut off. If CutMode=2, the portion of topImage to the right of the attachment location will be cut off.

If the attachment is vertical, i.e. the first attachment point is to the above the second attachment point, then if CutMode=1, the portion of topImage below the attachment location will be cut off. If CutMode=2, the portion of topImage above the attachment location will be cut off.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

This method only supports 24 bit images.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


PasteImage method

Newtone.ImageKit.Win.ImageKit.Effect.PasteImage Method

This method pastes a raster image into another raster image.

[Visual Basic] Public Function PasteImage( bottomImage As Image, angle As Integer, xTurn As Boolean, yTurn As Boolean, transLevel As Integer, transColor As Boolean, transRed As Byte, transGreen As Byte, transBlue As Byte, backRed As Byte, backGreen As Byte, backBlue As Byte, x As Integer, y As Integer, clip As Boolean ) As Boolean
[C#] public bool PasteImage( Image bottomImage, int angle, bool xTurn, bool yTurn, int transLevel, bool transColor, byte transRed, byte transGreen, byte transBlue, byte backRed, byte backGreen, byte backBlue, int x, int y, bool clip );

Parameters

bottomImage
The handle of the bottom image. This is the image onto which another image is pasted (supports 1, 4, 8, 16, 24, 32 bit images)

angle
Angle of rotation (-35999 to 35999, in 1/100 degree units)

xTurn
Reversal of the x axis (False(0): no reversal, True (nonzero): reversal)

yTurn
Reversal of the y axis (False(0): no reversal, True (nonzero): reversal)

transLevel
The level of transparency (from 0 to 255, as this value increases, the top image becomes visible)

transColor
Sets whether or not there is a transparent color in the top image
(False(0)No transparent color, True(nonzero):transparent color)

transRed
Sets the red component of the transparent color in the top image (from 0 to 255)

transGreen
Sets the green component of the transparent color in the top image (from 0 to 255)

transBlue
Sets the blue component of the transparent color in the top image (from 0 to 255)

backRed
Sets the red component of the background color.
This color is drawn in the area not in either the top image bottom image (from 0 to 255)

backGreen
Sets the green component of the background color.
This color is drawn in the area not in either the top image bottom image (from 0 to 255)

backBlue
Sets the blue component of the background color.
This color is drawn in the area not in either the top image bottom image (from 0 to 255)

x,y
The attachment coordinates (in pixels)

Clip
Sets whether or not the image is clipped (False(0): no clipping, True (nonzero): clipping)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The PasteImage method pastes one raster image into another raster image. The bottom image, (the image that another image is pasted into) is set into the BottomImage parameter. The image you want to paste into the bottom image is set in the LayerNumber property (either the Image property or the Layer(LayerNumber).Image property). If using a mask image (to determine an area on the image to be processed), then set the image handle of the mask image in the SourceMask property. The PasteImage method supports 1, 4, 8, 16, 24, 32 bit images.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

The Angle, xTurn, and yTurn parameters apply to the images in the LayerNumber property and SourceMask property. The x,y parameters determine the coordinates on the bottom image (the image in the bottomImage parameter) where the CENTER of the LayerNumber and SourceMask images are pasted. When the Clip parameter is True, the result is the same size as the bottom image (the image in the BottomImage parameter) and any excess is clipped. When the TransColor parameter is True, the color specified in the TransRed, TransGreen and TransBlue parameters is transparent.

The output image will be a 24 bit image. However, if either the bottom image or the top image are a 32 bit image, then the output image will be a 32 bit image.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


RedEyeRemoval method

Newtone.ImageKit.Win.ImageKit.Effect.RedEyeRemoval Method

This method removes "red eye" from images by converting reddish colors within the selected area to another specified color.

[Visual Basic] Public Function RedEyeRemoval(red As Byte, green As Byte, blue As Byte, error As Integer) As Boolean
[C#] public bool RedEyeRemoval(byte red, byte green, byte blue, int error);

Parameters

red
Sets the red component for the specified color after the red eye removal (from 0 to 255)

green
Sets the green component for the specified color after the red eye removal (from 0 to 255)

blue
Sets the blue component for the specified color after the red eye removal (from 0 to 255)

error
Sets a margin of error for converting colors within the selected area. Any colors falling outside this margin of error will be converted to the color specifed by the Red, Green, and Blue parameters (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RedEyeRemoval method removes "red eye" from images by converting colors within the selected area to another specified color. The error parameter sets a margin of error for colors within the selected area. Any color whose red value falls outside this margin of error will be converted to the color specifed by the Red, Green and Blue parameters. As the Error parameter value increases only colors closer to pure red will be converted. As the Error parameter decreases, a wider and wider range of "reddish" colors will be converted.

To execute the RedEyeRemoval method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The RedEyeRemoval method supports 16, 24, and 32 bit images.

Before executing the RedEyeRemoval method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


RemoveNoise method

Newtone.ImageKit.Win.ImageKit.Effect.RemoveNoise Method

This method reduces the image noise in raster images.

[Visual Basic] Public Function RemoveNoise(mode As Integer, level As Integer) As Boolean
[C#] public bool RemoveNoise(int mode, int level);

Parameters

mode
Sets the mode of noise reduction (0: Median luminance method, 1:Noise reduction for each RGB plane)

level
Sets the level of noise reduction for the RGB mode (from 0 to 255, effective when Mode is 1)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RemoveNoise method reduces the image noise in raster images. When Mode is 1, the value of the level is enabled. As the Level parameter value increases the level of noise decreases.

To execute the RemoveNoise method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The RemoveNoise method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the RemoveNoise method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Resize method

Newtone.ImageKit.Win.ImageKit.Effect.Resize Method

This method changes the size of a raster image.

[Visual Basic] Public Function Resize(xSize As Integer, ySize As Integer, mode As Boolean) As Boolean
[C#] public bool Resize(int xSize, int ySize, bool mode);

Parameters

xSize
The width of the new image (in pixels)

ySize
The height of the new image (in pixels)

mode
Sets whether Interpolation is used (False (0): does not interpolate, True (nonzero): interpolates)
When enlarging the image, the linear interpolation method is used, when reducing the image, the average method is used
The interpolation can be used for 8 bit grayscale, 16, 24, and 32 bit images

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Resize method changes the size of the original image to the size specified. When the Mode parameter is false (No interpolation) then changes in size can adversely affect the quality of the Image.

To execute the Resize method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Resize method supports 1, 4, 8, 16, 24, and 32 bit color images. If using mask image, set the image handle into the SourceMask property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image property). If the SourceMask property contains a valid image handle, then the resulting mask image will be set in the DesinationMask property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


RGBGamma method

Newtone.ImageKit.Win.ImageKit.Effect.RGBGamma Method

This method uses gamma correction to adjust the RGB values of a raster image.

[Visual Basic] Public Function RGBGamma(red As Double, green As Double, blue As Double) As Boolean
[C#] public bool RGBGamma(double red, double green, double blue);

Parameters

red
The gamma factor for the red plane

green
The gamma factor for the green plane

blue
The gamma factor for the blue plane

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBGamma method uses gamma correction to adjust the RGB values and overall brightness of a raster image. The formula used to calculate the output is given below:

Where x is the input RGB value, y is the output RGB value and bright is the gamma factor for the red, green and blue planes. (The Red, Green, and Blue parameters respectively).

When the Red, Green, and Blue parameters all equal 0, the input RGB values and output RGB values are equal meaning there is no change in the image. As the Red, Green, or Blue parameters increase in a positive direction, the output RGB values become lower than the input RGB values. As the Red, Green, or Blue parameters increase in a negative direction, the output RGB values become higher than the input RGB values. Please refer to the diagram below which shows the change in RGB values for a gamma factor of 1 and also for a gamma factor of -1.

To execute the RGBGama method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The RGBGamma method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the RGBGamma method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


RGBLevel method

Newtone.ImageKit.Win.ImageKit.Effect.RGBLevel Method

This method increases (or decreases) the RGB values of a raster image.

[Visual Basic] Public Function RGBLevel(red As Integer, green As Integer, blue As Integer) As Boolean
[C#] public bool RGBLevel(int red, int green, int blue);

Parameters

red
Sets the shift in the red component of the RGB value (from -255 to 255)

green
Sets the shift in the green component of the RGB value (from -255 to 255)

blue
Sets the shift in the blue component of the RGB value (from -255 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBLevel method increases or decreases the RGB values in a raster image. As the values of the Red, Green, or Blue parameters increase, the image becomes brighter. As those values decrease, the image becomes darker. If the Red, Green, or Blue parameters are 0, the image is not altered.

To execute the RGBLevel method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The RGBLevel method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the RGBLevel method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


RGBReverse method

Newtone.ImageKit.Win.ImageKit.Effect.RGBReverse Method

This method reverses the RGB values of a raster image.

[Visual Basic] Public Function RGBReverse(red As Boolean, green As Boolean, blue As Boolean) As Boolean
[C#] public bool RGBReverse(bool red, bool green, bool blue);

Parameters

red
Reverses the red component of the RGB value (False: does not reverse value, True: reverses value)

green<
Reverses the green component of the RGB value (False: does not reverse value, True: reverses value)

blue
Reverses the blue component of the RGB value (False: does not reverse value, True: reverses value)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBReverse method reverses the RGB values of a raster image. If the Red, Green, or Blue parameters are True, then that component of the RGB value is reversed. So, for example, the reverse of a red component = 255 would be a red component = 0 (Red = 255 - Red).

To execute the RGBReverse method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The RGBReverse method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the RGBReverse method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


RGBSpline method

Newtone.ImageKit.Win.ImageKit.Effect.RGBSpline Method

This method uses spline function to modifiy the RGB values of a raster image.

[Visual Basic] Public Function RGBSpline(spline As Point, red As Boolean, green As Boolean, blue As Boolean) As Boolean
[C#] public bool RGBSpline(Point[] spline, bool red, bool green, bool blue);

Parameters

spline
Arrays of RGB values defining the x and y coordinates of points on the RGBSpline curve (from 0 to 255). The number of coordinates in the array ranges from 3 to 10

red
Affects the red component of the RGB value (False: does not affect the red component, True: affects the red component)

green
Affects the green component of the RGB value (False: does not affect the red component, True: affects the green component)

blue
Affects the blue component of the RGB value (False: does not affect the red component, True: affects the blue component)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBSpline method uses a spline function to modify the RGB values of a raster image.

The RGBSpline method uses a spline function to modify the RGB values of a raster image. A spline function is a method of interpolating values that lay in between data points. In other words it produces a smooth curve from a limited set of points.

The RGBSpline method allows you to define the relationship between the input RGB values in the original image and output RGB values in the newly created image. You do this by specifying a set of coordinate points where the input RGB values are the x coordinates and the output RGB values are the y coordinates. These coordinate points are stored in arrays and passed to the RGBSpline method through the Spline parameter. The RGBSpline method then interpolates a "smooth" curve from these coordinate points. The graphic representation of this relationship between input RGB and output RGB values is known as the RGBSpline curve. A sample RGBSpline curve is shown in the diagram below:

In the above diagram, the default RGBSpline curve represents no change between input RGB values and output RGB values. In this case, the newly created image is exactly the same as the orginal image. The red RGBSpline curve represents an increase in contrast between the original image and the newly created image. It was generated from the following points:

Point (x values,y values)
-----------------------------------------------------
Point A (0,0)
Point B (64,32)
Point C (128,128)
Point D (192,160)
Point E (255,255)

At the midpoint of the RGBSpline curve, the input RGB value of 128 equals the output RGB value of 128. At points below the midpoint, however, the output RGB values are lower than the input RGB values. This means that dark colors become darker. Conversely, at points above the midpoint, output RGB values are higher than input RGB values. This means that light colors become lighter. This particular RGBSpline curve therefore increases the contrast of the image.

An RGBSpline curve that decreases contrast could be defined with the following points:

Point (x values,y values)
----------------------------------------------------
Point A (0,0)
Point B (64, 96)
Point C (128,128)
Point D (225, 192)
Point E (255,255)

To execute the RGBSpline method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The RGBSpline method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the RGBSpline method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Ripple method

Newtone.ImageKit.Win.ImageKit.Effect.Ripple Method

This method produces a ripple like effect on a raster image.

[Visual Basic]Public Function Ripple(amplitude As Double, waveLength As Double, phase As Double, backColor As Boolean, reflect As Boolean, red As Byte, green As Byte, blue As Byte) As Boolean
[C#]public bool Ripple(double amplitude, double waveLength, double phase, bool backColor, bool reflect, byte red, byte green, byte blue);

Parameters

amplitude
Sets the amplitude or height of the ripples. As this value increases the ripples become higher

waveLength
Sets the wavelength or distance from the crest of one wave to the crest of the next wave. As this value increases there are few ripples produced

phase
Sets the phase or shift in the wave cycle

backColor
Sets whether empty spaces are filled with color from adjacent pixels or from the color set as a background color [False: spaces filled with background color, True:spaces filled with the color of the adjacent pixels]

reflect
Causes a reflective effect from one ripple to the next (Best used with small amplitudes) [False:No reflection, True: reflection]

red
The red component of the background color (from 0 to 255)

green
The green component of the background color (from 0 to 255)

blue
The blue component of the background color (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Ripple method produces a ripple like effect on a raster image.

To execute the Ripple method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Ripple method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the Ripple method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Rotation method

Newtone.ImageKit.Win.ImageKit.Effect.Rotation Method

This method rotates a raster image.

[Visual Basic]Public Function Rotation(angle As Integer, xTurn As Boolean, yTurn As Boolean, mode As Boolean, red As Byte, green As Byte, blue As Byte, clip As Boolean) As Boolean
[C#]public bool Rotation(int angle, bool xTurn, bool yTurn, bool mode, byte red, byte green, byte blue, bool clip);

Parameters

angle
Angle of rotation (-35999 to 35999, in 1/100 degree units)

xTurn
Reverses image along the x axis (False: no reversal, True: reversal)

yTurn
Reverses image along the y axis (False: no reversal, True: reversal)

mode
Sets whether on not linear interpolation is used (False: does not interpolate, True: interpolates)
Interpolation is enabled for 8 bit grayscale, 16, 24, and 32 bit images only

red
The red component of the background color (from 0 to 255)

green
The green component of the background color (from 0 to 255)

blue
The blue component of the background color (from 0 to 255)

clip
Sets whether or not the image is clipped (False: no clipping, True: clipping)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Rotation method rotates a raster image. If the Angle parameter value is positive, the image is rotated counterclockwise, if the Angle parameter value is negative, the image is rotated clockwise. When the Clip parameter is True and the rotated image is larger than the original, the excess areas are cut.

To execute the Rotation method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Rotation method supports 1, 4, 8, 16, 24, and 32 bit images. It is possible to rotate a mask image at the same time that the image is rotated. If this is the case, set the image handle of the mask image to be processed in the SourceMask property.

If successful the resulting raster image data is set in the LayerNo property (the ImageHandle property or the Layer(LayerNo).ImageHandle property. If a mask image is used, the mask image should be set in the SourceMask property. The resulting mask image will be set in the DesinationMask property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SelectImage method

Newtone.ImageKit.Win.ImageKit.Effect.SelectImage Method

This method allows you to define an area on a raster image and create a new image and mask image from that area.

[Visual Basic] Public Function SelectImage(red As Byte, green As Byte, blue As Byte) As Boolean
[C#] public bool SelectImage(byte red, byte green, byte blue);

Parameters

red
The red component of the color painted outside the area selected (from 0 to 255)

green
The green component of the color painted outside the area selected (from 0 to 255)

blue
The blue component of the color painted outside the area selected (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SelectImage method allows you to select an area on a raster image and create a new image and mask image from this selected area.

To execute the SelectImage method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The SelectImage method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the SelectImage method, you must set the area on the image that will be affected.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image property. The resulting mask image is set in the DesinationMask property. The color defined by the Red, Green, and Blue parameters wil be painted in the resulting image in the area that is outside the selected area. The resulting mask image will be a black and white, 1 bit color image where the selected area is white and the area outside of the select area is black.

Note: To select a portion of an image, without creating a mask image, please use the CutRectImage method. This method is much faster than the SelectImage method.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SetBitmapPixel method

Newtone.ImageKit.Win.ImageKit.Effect.SetBitmapPixel Method

This method sets the RGB value and the palette number of a specified pixel in the Device Independent Bitmap (DIB)

[Visual Basic] Public Function SetBitmapPixel( x As Integer, y As Integer, palette As Byte, red As Byte, green As Byte, blue As Byte ) As Boolean
[C#] public bool SetBitmapPixel( int x, int y, byte palette, byte red, byte green, byte blue );

Parameters

x,y
The x,y coordinates of the specified pixel

palette
The palette number of the specified pixel

red
The red component of the RGB value of the specified pixel

green
The green component of the RGB value of the specified pixel

blue
The blue component of the RGB value of the specified pixel

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetBitmapPixel method sets the RGB values and palette number of the specified pixel in the Device Independent Bitmap (DIB). For 1, 4, and 8 bit images, the applicable values are set in the Palette parameter. For 16, 24, and 32 bit images, the applicable values are set in the Red, Green, and Blue parameters.

The image to be processed is determined by the values set in the LayerNumber property.

To access the DIB and manipulate pixel data, you must use the following methods as a group:

StartBitmapAccess
|
GetBitmapPixel, SetBitmapPixel
|
EndBitmapAccess

Example

The following code starts access to the DIB, then loops through each pixel in the image, using the GetBitmapPixel method to retrieve the pixels' rgb values. Then those values are reversed and set using the SetBitmapPixel method (For 1, 16, 24, or 32 bit images).

[Visual Basic]
Dim Ret As Boolean
Dim i As Long, j As Long
Dim PalNo As Integer, Red As Integer, Green As Integer, Blue As Integer

Ret = ImageKit1.GetImageType()
If Ret = False Then Exit Sub
Ret = ImageKit1.Effect.StartBitmapAccess()
If Ret = False Then Exit Sub

For i = 0 To ImageKit1.Image.Height - 1
  For j = 0 To ImageKit1.Image.Width - 1
    Ret = ImageKit1.Effect.GetBitmapPixel(j, i, PalNo, Red, Green, Blue)
    If ImageKit1.BitCount = 1 Then
      If PalNo <> 0 Then
        PalNo = 0
      Else
        PalNo = 1
      End If
    Else If ImageKit1.BitCount > 8 Then
      Blue = 255 - Blue
      Green = 255 - Green
      Red = 255 - Red
    End If
    Ret = ImageKit1.Effect.SetBitmapPixel(j, i, PalNo, Red, Green, Blue)
  Next j
Next i

Ret = ImageKit1.Effect.EndBitmapAccess()
ImageKit1.Refresh()

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SetGray method

Newtone.ImageKit.Win.ImageKit.Effect.SetGray Method

This method changes a raster image to gray.

[Visual Basic] Public Function SetGray As Boolean
[C#] public bool SetGray();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetGray method allows you to convert a raster image to gray.

To execute the SetGray method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The SetGray method supports 1, 4, 8, 16, 24, and 32 bit images. Note: the SetGray method will convert a raster image to gray without changing the bitcount. A 24 bit color image, for example, is coverted to gray but is still 24 bit color. To change an image to 8-bit grayscale, please use the ConvertColor method.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SetSecretImage method

Newtone.ImageKit.Win.ImageKit.Effect.SetSecretImage Method

This method sets a digital watermark image or digital watermark text into a raster image.

[Visual Basic] Public Function SetSecretImage( sourceImage As Image, maskImage As Image, text As String, font As Font, rect As Rectangle, level As Long, ) As Boolean
[C#] public bool SetSecretImage( Image sourceImage, Image maskImage, String text, Font font, Rectangle rect, int level );

Parameters

sourceImage
The image handle of the original image (24 bit color images only) The watermark will be set on this image

maskImage
The image handle of the digital watermark (1 bit color image)

text
Sets the digital watermark text (the length of text can be up to 127 bytes)

font
Sets the font

rect
The coordinates of the rectangle where the text is to be attached to sourceImage (in pixels)

level
Sets the level of "detection" for the watermark (-20 to 20)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SetSecretImage method sets a digital watermark into a raster image. It can set either a 1 bit color image or text as the watermark. The value of the Level parameter determines how "detectable" the digitable watermark will be. As the Level parameter increases in a positive direction, the digital watermark becomes brighter. As it increases in a negative direction, the digital watermark becomes darker.

If the maskImage parameter is set, the image referred to by the maskImage parameter will be set as the digital watermark. In this case the top left corner of the maskImage will be attached to the sourceImage at the coordinate location determined by the Rect parameter. If the maskImage parameter is 0, then the Text set in the Text parameter will be used as the digital watermark. It will be placed within a rectangular area on the sourceImage as determined by the Rect parameter.

If successful the resulting raster image handle is set in the Image property or the Layer(LayerNumber).Image property dpending on the value set in the LayerNumber property. The resulting image is a 24 bit image.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Sharp method

Newtone.ImageKit.Win.ImageKit.Effect.Sharp Method

This method modifies sharpness in a raster image.

[Visual Basic] Public Function Sharp(level As Integer) As Boolean
[C#] public bool Sharp(int level);

Parameters

level
Sets the degree of sharpness (from 0 to 100, sharpness increases as the level increases)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Sharp method modifies the sharpness of a raster image. As the Level parameter value increase the sharpness increases and the image becomes clearer.

To execute the Sharp method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Sharp method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the Sharp method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


SplitRGBAImage method

Newtone.ImageKit.Win.ImageKit.Effect.SplitRGBAImage Method

This method splits a 32 bit RGBA image into a 24 bit RGB image and a 8 bit alpha channel.

[Visual Basic] Public Function SplitRGBAImage As Boolean
[C#] public bool SplitRGBAImage();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SplitRGBAImage method splits a 32 bit RGBA image into a 24 bit RGB image and a 8 bit alpha channel. To execute the SplitRGBAImage method, set the image handle of the 32-bit RGBA image in the Image property or the Layer(LayerNumber).Image property.

If successful the resulting RGB 24-bit image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image property) and the alpha channel 8-bit grayscale image is set in the DesinationMask property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


StartBitmapAccess method

Newtone.ImageKit.Win.ImageKit.Effect.StartBitmapAccess Method

The StartBitmapAccess method is used to allow access to pixels in the Device Independent Bitmap (DIB). This method is to be used in conjunction with the EndBitmapAccess method.

[Visual Basic] Public Function StartBitmapAccess As Boolean
[C#] public bool StartBitmapAccess();

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The StartBitmapAccess method is used to allow access to pixels in the Device Independent Bitmap (DIB). This method is to be used in conjunction with the EndBitmapAccess method.

To execute the StartBitmapAccess method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. This method supports 1, 4, 8, 16, 24, and 32 bit images.

To access the DIB and manipulate pixel data, you must use the following methods as a group:

StartBitmapAccess
|
GetBitmapPixel, SetBitmapPixel
|
EndBitmapAccess

Example

The following code starts access to the DIB, then loops through each pixel in the image, using the GetBitmapPixel method to retrieve the pixels' rgb values. Then those values are reversed and set using the SetBitmapPixel method (For 1, 16, 24, or 32 bit images).

[Visual Basic]
Dim Ret As Boolean
Dim i As Long, j As Long
Dim PalNo As Integer, Red As Integer, Green As Integer, Blue As Integer

Ret = ImageKit1.GetImageType()
If Ret = False Then Exit Sub
Ret = ImageKit1.Effect.StartBitmapAccess()
If Ret = False Then Exit Sub

For i = 0 To ImageKit1.Image.Height - 1
  For j = 0 To ImageKit1.Image.Width - 1
    Ret = ImageKit1.Effect.GetBitmapPixel(j, i, PalNo, Red, Green, Blue)
    If ImageKit1.BitCount = 1 Then
      If PalNo <> 0 Then
        PalNo = 0
      Else
        PalNo = 1
      End If
    Else If ImageKit1.BitCount > 8 Then
      Blue = 255 - Blue
      Green = 255 - Green
      Red = 255 - Red
    End If
    Ret = ImageKit1.Effect.SetBitmapPixel(j, i, PalNo, Red, Green, Blue)
  Next j
Next i

Ret = ImageKit1.Effect.EndBitmapAccess()
ImageKit1.Refresh()

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


UnifyColor method

Newtone.ImageKit.Win.ImageKit.Effect.UnifyColor Method

This method allows you to convert a range in colors in a raster image into one color. This method is useful when using transparent colors.

[Visual Basic] Public Function UnifyColor( red As Byte, green As Byte, blue As Byte, error As Integer ) As Boolean
[C#] public bool UnifyColor( byte red, byte green, byte blue, int error );

Parameters

red
The red component of the color to be unified (from 0 to 255)

green
The green component of the color to be unified (from 0 to 255)

blue
The blue component of the color to be unified (from 0 to 255)

error
Sets the range of RGB values that will be unified (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The UnifyColor method allows you to unify a range of colors in a raster image. This is very useful when using transparancy. The Red, Green, and Blue parameters define the unified color. The Error parameter sets the range of colors that will be unified into the single color. So, for example, if you set the Red, Green and Blue parameter each to 128 and the Error parameter to 10, all colors ranging from RGB(118,118,118) to RGB(138,138,138) will be changed to RGB(128,128,128).

To execute the UnifyColor method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The UnifyColor method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the UnifyColor method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


Waves method

Newtone.ImageKit.Win.ImageKit.Effect.Waves Method

This method creates a wave like effect on a raster image.

[Visual Basic] Public Function Waves( direction As Integer, type As Integer, period As Integer, amplitude As Integer, phase As Double, edge As Integer, red As Byte, green As Byte, blue As Byte ) As Boolean
[C#] public bool Waves( int direction, int type, int period, int amplitude, double phase, int edge, byte red, byte green, byte blue );

Parameters

direction
Sets the direction of the waves (0: horizontal, 1: vertical)

type
Sets the type of wave (0:sin wave, 1: sawtooth)

period
Sets the length of the wave (more than 0)

amplitude
Sets the size of the wave (more than 0)

phase
Sets the phase or shift in the wave cycle.(from 0.0 to 1.0)

edge
Sets the type of edge(0: background color, 1:adjoining pixel color, 2 wrap around)

red
Sets the red component of the background color (from 0 to 255)

green
Sets the green component of the background color (from 0 to 255)

blue
Sets the blue component of the background color (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Waves method creates a wave like effect on a raster image.

To execute the Waves method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The Waves method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the Waves method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


WhirlPinch method

Newtone.ImageKit.Win.ImageKit.Effect.WhirlPinch Method

This method produces an interesting effect similar to pinching a raster image then twisting your fingers.

[Visual Basic] Public Function WhirlPinch( whirl As Double, pinch As Double, radius As Double, red As Integer, green As Integer, blue As Integer ) As Boolean
[C#] public bool WhirlPinch( double whirl, double pinch, double radius, short red, short green, short blue );

Parameters

whirl
Sets the number of degrees of the twisting effect

pinch
Sets the "strength" of the pinch

radius
Sets the size of the area affected by the twisting effect (more than 0)

red
Sets the red component of the background color (from 0 to 255)

green
Sets the green component of the background color (from 0 to 255)

blue
Sets the blue component of the background color (from 0 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The WhirlPinch method creates an effect similar to pinching a raster image and then twisting your fingers. The Whirl parameter sets the number of degrees of the twisting effect. A value of 360 would mean that the twisting effect makes one complete revolution. The Radius parameter sets the size of the twisting effect on the image. As the Radius parameter increases in size, it affects larger areas on the image. Values of 2 or more could mean the the radius of the twisting effect is larger than the image itself. In this case the background color is used to fill any spaces that are outside of the orginal image. It is recommended that you set a Radius value of less than 1 so that the area affected remains within the image, then experiment with the Whirl parameter to get the desired effect. The Pinch parameter does exactly that, it pinches the area in the center of the twisting effect. A Pinch parameter of 1 will bring all of the colors together in the center. Values greater than 1 can "tear" the image in which case the background color is painted in the center.

To execute the WhirlPinch method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The WhirlPinch method supports 8 bit grayscale, 16, 24, and 32 bit images.

Before executing the WhirlPinch method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


YCCGamma method

Newtone.ImageKit.Win.ImageKit.Effect.YCCGamma Method

This method uses gamma correction to adjust the YCrCb values of a raster image.

[Visual Basic] Public Function YCCGamma(yb As Double, cr As Double, cb As Double) As Boolean
[C#] public bool YCCGamma(double yb, double cr, double cb);

Parameters

yb
The gamma factor for the Y plane

cr
The gamma factor for the Cr plane

cb
The gamma factor for the Cb plane

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCGamma method uses gamma correction to adjust the YCrCb values and overall brightness of a raster image. The formula used to calculate the output is given below:

Where x is the input YCrCb value, y is the output YCrCb value and bright is the gamma factor for the Y, Cr and Cb planes. (The Yb, Cr, and Cb parameters respectively).

When the Yb, Cr, and Cb parameters all equal 0, the input RGB values and output YCrCb values are equal meaning there is no change in the image. As the Yb, Cr, and Cb parameters increase in a positive direction, the output YCrCb values become lower than the input YCrCb values. As the Yb, Cr, and Cb parameters increase in a negative direction, the output YCrCb values become higher than the input YCrCb values. Please refer to the diagram below which shows the change in YCrCb values for a gamma factor of 1 and also for a gamma factor of -1.

To execute the YCCGamma method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The YCCGamma method supports 1, 4, 8, 16, 24, and 32 bit images.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


YCCLevel method

Newtone.ImageKit.Win.ImageKit.Effect.YCCLevel Method

This method increases (or decreases) the YCrCb values of a raster image.

[Visual Basic] Public Function YCCLevel(yb As Integer, cr As Integer, cb As Integer) As Boolean
[C#] public bool YCCLevel(int yb, int cr, int cb);

Parameters

yb
Sets the shift in the Y component (luminance) of the YCrCb value (from -255 to 255)

cr
Sets the shift in the Cr component (chrominance) of the YCrCb value (from -255 to 255)

cb
Sets the shift in the Cb component (chrominance) of the YCrCb value (from -255 to 255)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCLevel method increases or decreases the YCrCb values in a raster image. Y represents luminance, Cr and Cb represent chrominance. As the values of the Yb, Cr, or Cb parameters increase, the image becomes brighter. As those values decrease, the image becomes darker. If the Yb, Cr, or Cb parameters are 0, the image is not altered.

To execute the YCCLevel method, set the image handle of the image in theImage property or the Layer(LayerNumber).Image property. The YCCLevel method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the YCCLevel method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


YCCReverse method

Newtone.ImageKit.Win.ImageKit.Effect.YCCReverse Method

This method reverses the YCrCb values of a raster image.

[Visual Basic] Public Function YCCReverse(yb As Boolean, cr As Boolean, cb As Boolean) As Boolean
[C#] public bool YCCReverse(bool yb, bool cr, bool cb);

Parameters

yb
Reverses the Y component (luminance) of the YCrCb value (False: does not reverse value, True: reverses value)

cr
Reverses the Cr component (chrominance) of the YCrCb value (False: does not reverse value, True: reverses value)

cb
Reverses the Cb component (chrominance) of the YCrCb value (False: does not reverse value, True: reverses value)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCReverse method reverses the YCrCb values of a raster image. If the Yb, Cr, or Cb parameters are True, then that component of the YCrCb value is reversed. So, for example, the reverse of a Yb component = 255 would be a Yb component = 0 (Yb = 255 - Yb).

To execute the YCCReverse method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The YCCReverse method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the YCCReverse method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


YCCSpline method

Newtone.ImageKit.Win.ImageKit.Effect.YCCSpline Method

This method uses spline function to modifiy the YCrCb values of a raster image.

[Visual Basic] Public Function YCCSpline(spline As Point, yb As Boolean, cr As Boolean, cb As Boolean) As Boolean
[C#] public bool YCCSpline(Point[] spline, bool yb, bool cr, bool cb);

Parameters

spline
Arrays of YCrCb values defining the x and y coordinates of points on the YCCSpline curve (from 0 to 255).
The number of coordinates in the array ranges from 3 to 10

yb
Affects the Y component (luminance) of the YCrCb value (False(0): does not affect the Y component, True( nonzero): affects the Y component)

cr
Affects the Cr component (chrominance) of the YCrCb value (False(0): does not affect the Cr component, True( nonzero): affects the Cr component)

cb
Affects the Cb component (chrominance) of the YCrCb value (False(0): does not affect the Cb component, True( nonzero): affects the Cb component)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCSpline method uses a spline function to modify the YCrCb values of a raster image. A spline function is a method of interpolating values that lay in between data points. In other words it produces a smooth curve from a limited set of points.

The YCCSpline method allows you to define the relationship between the input YCrCb values in the original image and output YCrCb values in the newly created image. You do this by specifying a set of coordinate points where the input YCrCb values are the x coordinates and the output YCrCb values are the y coordinates. These coordinate points are stored in arrays and passed to the YCCSpline method through the Spline parameter. The YCCSpline method then interpolates a "smooth" curve from these coordinate points. The graphic representation of this relationship between input YCrCb and output YCrCb values is known as the YCCSpline curve. A sample YCCSpline curve is shown in the diagram below:

In the above diagram, the default YCCSpline curve represents no change between input YCrCb values and output YCrCb values. In this case, the newly created image is exactly the same as the orginal image. The red YCCSpline curve represents an increase in contrast between the original image and the newly created image. It was generated from the following points:

Point (x values,y values)
-----------------------------------------------------
Point A (0,0)
Point B (64,32)
Point C (128,128)
Point D (192,160)
Point E (255,255)

At the midpoint of the YCCSpline curve, the input YCrCb value of 128 equals the output YCrCb value of 128. At points below the midpoint, however, the output YCrCb values are lower than the input YCrCb values. This means that dark colors become darker. Conversely, at points above the midpoint, output YCrCb values are higher than input YCrCb values. This means that light colors become lighter. This particular YCCSpline curve therefore increases the contrast of the image.

An YCCSpline curve that decreases contrast could be defined with the following points:

Point (x values,y values)
----------------------------------------------------
Point A (0,0)
Point B (64, 96)
Point C (128,128)
Point D (225, 192)
Point E (255,255)

To execute the YCCSpline method, set the image handle of the image in the Image property or the Layer(LayerNumber).Image property. The YCCSpline method supports 1, 4, 8, 16, 24, and 32 bit images.

Before executing the YCCSpline method, you must set the area on the image that will be affected. There are 4 ways to do this.

  1. To use a mask image, set the SelectMode property to EffectMask. Set the mask image handle in the SourceMask property
  2. To process the total image, set the SelectMode property to EffectAll
  3. To process the polygonal area on the image, set the SelectMode property to EffectPolygon. Select the polygon by setting the appropriate coordinate values for the points of the polygon in the Point property
  4. To process an elliptical area on the image, set the SelectMode property to EffectEllipse. Select the ellipse by setting the appropriate values for the bounding rectangle in the Rect property

When the SelectMode property is set to EffectPolygon or EffectEllipse, the appropriate values must be set in the Inside property. When a 1, 4, or 8 bit image is processed, the total image will be processed regardless of the value set in the SelectMode property.

If successful the resulting raster image data is set in the LayerNumber property (the Image property or the Layer(LayerNumber).Image) property.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


ImageKit.File Members

Newtone.ImageKit.Win.ImageKit.File All Members

Public Properties

BackgroundBlue | Sets the blue component (RGB) of the background color in a vector image.
BackgroundGreen | Sets the green component (RGB) of the background color in a vector image.
BackgroundPaint | Sets the background color for a vector image.
BackgroundRed | Set the red component (RGB) of the background color for a vector image.
Cancel | Sets whether or not the process is canceled
Comment | Sets and retrieves a comment in certain image files
CreationTimeDay | Refers to the day when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeHour | Refers to the hour when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeMinute | Refers to the minute when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeMonth | Refers to the month when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeSecond | Refers to the second when the file was created. Retrieved after executing the GetImageFileType method.
CreationTimeYear | Refers to the year when the file was created. Retrieved after executing the GetImageFileType method.
FileBitCount | Refers to the bit count of the image. Retrieved after executing the GetImageFileType or GetImagefileTypeFromRawData methods.
FileExtension | Sets the file type initially displayed by the OpenFileDialog and SaveFileDialog methods
FileHeight | Refers to the height of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileImageSize | Refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileMaxPage | Refers to the number of pages of a multi-page image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileName | Sets the name of the image file (full path) to be loaded or saved
FilePath | Sets the folder initially displayed by the OpenFileDialog and SaveFileDialog methods
FileSize | Refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileType | Refers to the type of image format. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileWidth | Refers to the width of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileWidthByte | Refers to the number of bytes per line in the image. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileXdpi | Refers to the horizontal resolution of the image. (number of pixels per horizontal inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
FileYdpi | Refers to the vertical resolution of the image. (number of pixels per vertical inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.
GifAnimation | Sets whether or not the GIF image is a multi-page GIF (GIF animation)
GifAnimationDelay | Sets the length of time a single page of a mult-page GIF image is displayed
Interlace | Sets interlacing when saving an image as a GIF or PNG image. By executing the GetImageFileType or GetImageFileTypeFromRawData method, the Interlace property value can be retrieved.
JPEG2000CodeBlockHeight | Sets the height of the JPEG2000 format code block size
JPEG2000CodeBlockWidth | Sets the width of the JPEG2000 format code block size
JPEG2000NumResLevel | Sets the level of the JPEG2000 format resolution
JPEG2000PrecinctHeight | Sets the height of the JPEG2000 format precinct size
JPEG2000PrecinctWidth | Sets the width of the JPEG2000 format precinct size
JPEG2000Reversible | Sets whether or not the JPEG2000 lossless compression is reversible
JPEG2000Size | Sets the size of the file when saved in JPEG2000 format
JPEG2000TileHeight | Sets the height of the JPEG2000 format tile size
JPEG2000TileWidth | Sets the width of the JPEG2000 format tile size
JpegQuality | Sets the quality coefficient when an image is saved in JPEG or FPX (JPEG compression) file formats
JpegSubsampling | Sets the YCrCb subsampling ratios when saving an image in JPEG format
LastAccessTimeDay | Refers to the day when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeHour | Refers to the hour when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeMinute | Refers to the number of minutes when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeMonth | Refers to the month when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeSecond | Refers to the number of seconds when the file was last accessed. Retrieved after executing the GetImageFileType method
LastAccessTimeYear | Refers to the year when the file was last accessed. Retrieved after executing the GetImageFileType method
LastWriteTimeDay | Refers to the day when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeHour | Refers to the hour when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeMinute | Refers to the number of minutes when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeMonth | Refers to the month when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeSecond | Refers to the number of seconds when the file was last modified. Retrieved after executing the GetImageFileType method
LastWriteTimeYear | Refers to the year when the file was last modified. Retrieved after executing the GetImageFileType method
LoadPage | Sets the page to be loaded when a multi-page image file (FPX, GIF, or TIFF) image is loaded
PngAlphaChannel | Sets the alpha channel when loading and saving a PNG image
RawData | Sets the byte array of the Raw data for the image to be loaded or saved
TiffAppend | Sets whether or not an image saved in TIFF format is appended to an existing multi-page TIFF image or saved as a separate image
TiffColorSpace | Defines the color space when saving images in TIFF file format
TiffSaveOneStrip | Sets whether or not a TIFF image is saved as one strip or multiple strips
Transparent | Sets whether or not the transparent color in GIF or PNG images is enabled
TransparentBlue | Sets the blue component (RGB values) of the transparent color when saving an image as a GIF or PNG image
TransparentGreen | Sets the greem component (RGB values) of the transparent color when saving an image as a GIF or PNG image
TransparentRed | Sets the red component (RGB values) of the transparent color when saving an image as a GIF or PNG image
VectorHeight | Sets the height of a vector image when the image is loaded
VectorWidth | Sets the width of a vector image when the image is loaded

Public Methods

CloseMultiTiff | Closes the multipage tiff file after it has been saved
CMYKBmpPlaneFileLoad | Loads a bmp file that has been saved in seperate CMYK planes
CMYKBmpPlaneFileSave | Saves a raster image into seperate CMYK planes. The saved images are in BMP format.
GetImageFileType | Retrieves various information aobut the image file
GetImageFileTypeFromRawData | Retrieves various information from raw image data
LoadImageFromFile | Loads image data from a file
LoadImageFromRawData | Loads DIB image data from raw data
LoadRawDataFromFile | Loads raw image data from file
LoadRawDataFromStream | Loads raw image data from stream
OpenFileDialog | Displays the "Open" dialog box which includes the file preview and information functions. This dialog box is used to select an image file to be opened.
RGBBmpPlaneFileLoad | Loads a bmp file that has been saved in seperate RGB planes
RGBBmpPlaneFileSave | Saves a raster image into seperate RGB planes. The saved images are in BMP format.
SaveFileDialog | Displays the "Save" dialog box which includes the file preview function. This dialog box is used to select an image file to be saved.
SaveImageToFile | Saves image data to a file
SaveImageToRawData | Saves image data as raw data
SaveRawDataToFile | Saves raw data to a file
SaveRawDataToStream | Saves the raw image data to stream.
YCCBmpPlaneFileLoad | Loads a bmp file that has been saved in seperate YCrCb planes
YCCBmpPlaneFileSave | Saves a raster image into seperate YCrCb planes. The saved images are in BMP format.

Hierarchy Property

Exif Exposes properties of the Exif(JPEG) file's main and thumbnail image

See Also

Newtone.ImageKit.Win.ImageKit


BackgroundRGB property

Newtone.ImageKit.Win.ImageKit.File.BackgroundBlue Property

This property sets the blue component (RGB) of the background color in a vector image.

[Visual Basic] Public WriteOnly Property BackgroundBlue As Byte
[C#] public byte BackgroundBlue {set;}

Property Value

The values can range from 0 to 255

Explanation

The BackgroundBlue property sets the blue component (RGB) of the background color in a vector image.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


BackgroundRGB property

Newtone.ImageKit.Win.ImageKit.File.BackgroundGreen Property

This property sets the green component (RGB) of the background color in a vector image.

[Visual Basic] Public WriteOnly Property BackgroundGreen As Byte
[C#] public byte BackgroundGreen {set;}

Property Value

The values can range from 0 to 255

Explanation

The BackgroundGreen property sets the green component (RGB) of the background color in a vector image.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


BackgroundPaint property

Newtone.ImageKit.Win.ImageKit.File.BackgroundPaint Property

This property sets the background color for a vector image.

[Visual Basic] Public WriteOnly Property BackgroundPaint As Boolean
[C#] public bool BackgroundPaint {set;}

Property Value

Value | Explanation
True | Sets the background color
False | Does not set the background color

Explanation

The BackgroundPaint property sets the background color when saving a vector image. To set the background color, set the appropriate values in the BackgroundBlue, BackgroundGreen, and BackgroundRed properties.

To use DXF, SVG, or SXF images, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


BackgroundRGB property

Newtone.ImageKit.Win.ImageKit.File.BackgroundRed Property

This property set the red component (RGB) of the background color for a vector image.

[Visual Basic] Public WriteOnly Property BackgroundRed As Byte
[C#] public byte BackgroundRed {set;}

Property Value

The values can range from 0 to 255

Explanation

The BackgroundRed property set the red component (RGB) of the background color for a vector image.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Comment property

Newtone.ImageKit.Win.ImageKit.File.Comment Property

This property sets the comment that can be saved in some types of image files. By executing the GetImageFileType or the GetImagefileTypeFromRawData methods, any comments that exist in an image are retrieved.

[Visual Basic] Public Property Comment As String
[C#] public string Comment {get; set;}

Property Value

The comment string (Maximum length:1023 bytes)

Explanation

The Comment property sets the comment that can be saved in some types of image files. By executing the GetImageFileType or the GetImageFileTypeFromRawData method, any comments that exist in an image are retrieved.

The type of comment and its syntax depends on the file format. The following image file formats support comments and their syntax is given below. If the particular image file does not support a comment, then this property is ignored for those image files.

Name | Explanation
FPX | Title+0x0d+Subtitle+0x0d+Author+0x0d+Comment+0x0d
GIF | Comment
JPEG | Comment
JPEG2000 | Title+0x0d+Subtitle+0x0d+Author+0x0d+Comment+0x0d
PNG | Title+0x0d+Author+0x0d+Explanation+0x0d+Copyright+0x0d+DateTime+0x0d+Software+0x0d+Waiver+0x0d+Warning+0x0d+Input Devices+0x0d+Comment+0x0d
TIFF | Document Name+0x0d+Image Explanation+0x0d+Page Name+0x0d+Software+0x0d+Date Time+0x0d+Author+0x0d

Note: please enter a blank string into any unnecessary fields. In Visual Basic, replace the 0x with &H.

To use this property, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CreationTime property

Newtone.ImageKit.Win.ImageKit.File.CreationTimeDay Property

This property refers to the day when the file was created. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property CreationTimeDay As Integer
[C#] public int CreationTimeDay {get;}

Property Value

The day when the file was created

Explanation

The CreationTimeDay property refers to the day when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CreationTime property

Newtone.ImageKit.Win.ImageKit.File.CreationTimeHour Property

This property refers to the hour when the file was created. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property CreationTimeHour As Integer
[C#] public int CreationTimeHour {get;}

Property Value

The hour when the file was created

Explanation

The CreationTimeHour property refers to the hour when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CreationTime property

Newtone.ImageKit.Win.ImageKit.File.CreationTimeMinute Property

This property refers to the number of minutes when the file was created. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property CreationTimeMinute As Integer
[C#] public int CreationTimeMinute {get;}

Property Value

The minute when the file was created

Explanation

The CreationTimeMinute property refers to the number of minutes when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CreationTime property

Newtone.ImageKit.Win.ImageKit.File.CreationTimeMonth Property

This property refers to the month when the file was created. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property CreationTimeMonth As Integer
[C#] public int CreationTimeMonth {get;}

Property Value

The month when the file was created

Explanation

The CreationTimeMonth property refers to the month when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CreationTime property

Newtone.ImageKit.Win.ImageKit.File.CreationTimeSecond Property

This property refers to the number of seconds when the file was created. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property CreationTimeSecond As Integer
[C#] public int CreationTimeSecond {get;}

Property Value

The number of seconds when the file was created

Explanation

The CreationTimeSecond property refers to the number of seconds when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CreationTime property

Newtone.ImageKit.Win.ImageKit.File.CreationTimeYear Property

This property refers to the year when the file was created. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property CreationTimeYear As Integer
[C#] public int CreationTimeYear {get;}

Property Value

The year when the file was created

Explanation

The CreationTimeYear property refers to the year when the file was created. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileBitCount property

Newtone.ImageKit.Win.ImageKit.File.FileBitCount Property

This property refers to the bit count of the image. Retrieved after executing the GetImageFileType or GetImageFileTypeFromRawData methods.

[Visual Basic] Public ReadOnly Property FileBitCount As Integer
[C#] public int FileBitCount {get;}

Property Value

1F 2 colors (i.e.Black and White)
4F 16 colors
8F 256 colors
16F 16 bit color
24F 24bit color
32F 32bit color

Explanation

This property is disabled for vector images.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileExtension property

Newtone.ImageKit.Win.ImageKit.File.FileExtension Property

This property sets the file type initially displayed by the OpenFileDialog and SaveFileDialog methods.

[Visual Basic] Public Property FileExtension As String
[C#] public string FileExtension {get; set;}

Property Value

The FileExtension is the file type (i.e. jpg, bmp)

Explanation

The FileExtension property sets the file type initially displayed by the OpenFileDialog and SaveFileDialog methods. When you execute the OpenFileDialog and SaveFileDialog methods, the "Open" dialog box and "Save" dialog box will be displayed. The FileExtension property sets which file extentions will be listed in the "Files of type" drop down menu at the bottom of the dialog box.

By default the "Open" dialog box and the "Save" dialog box display all file types in a given folder. They also display the term "All Files" along with all individual file extentions supported by the ImageKit in the "Files of type" drop down menu at the bottom of the dialog box. By setting the FileExtension property, you can determine which file extentions will be listed in this drop down menu and thereby influence the types of files that can be selected in the "Open" dialog box and "Save" dialog box.

To set the FileExtension property, start with the file explanation followed by a "|" symbol as a delimeter and the the file extensions to be displayed. When listing multiple file extensions, use a comma (;) to delimit them. If an empty string ("") is set into the FileExtension property then the file types will be "all files". If an empty string is set into the FilePath property, then the current direct directory will be displayed when the dialog opens.

There is no distinction made between upper case or lower case letters so that "BMP" is treated as the same as "bmp".

Example

The code below illustlates how to set the default folder to "C:\Images" and to set the file types to "BMP", "JPG and PNG", and "All Files":

[Visual Basic.NET]
ImageKit1.File.FilePath = "c:\images"
ImageKit1.File.FileExtension = "Bitmap filesb*.bmpbJpeg,Png filesb*.jpg;*.pngbAll Files|*.*"

[Visual C#.NET]
ImageKit1.File.FilePath = "c:\\Images";
ImageKit1.File.FileExtension = "Bitmap filesb*.bmpbJpeg,Png filesb*.jpg;*.pngbAll Files|*.*";

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileHeightWidth property

Newtone.ImageKit.Win.ImageKit.File.FileHeight Property

This property refers to the height of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileHeight As Integer
[C#] public int FileHeight {get;}

Property Value

The height of the image in pixels

Explanation

The FileHeight property refers to the height of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.

If the information cannot be retrieved from the file, 0 will be set in this property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileImageSize property

Newtone.ImageKit.Win.ImageKit.File.FileImageSize Property

This property refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileImageSize As Integer
[C#] public int FileImageSize {get;}

Property Value

The size of the image file

Explanation

TheFileImageSize property refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

This property is only enabled for raster images.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileMaxPage property

Newtone.ImageKit.Win.ImageKit.File.FileMaxPage Property

This property refers to the number of pages of a multi-page image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileMaxPage As Integer
[C#] public int FileMaxPage {get;}

Property Value

The number of pages of a multi-page image file

Explanation

The FileMaxPage property refers to the number of pages of a multi-page image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

This property is enabled for raster images.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileName property

Newtone.ImageKit.Win.ImageKit.File.FileName Property

This property sets the name of the image file (full path) to be loaded or saved.

[Visual Basic] Public Property FileName As String
[C#] public string FileName {get; set;}

Property Value

The name of the image file (full path)

Explanation

The FileName property sets the name of the image file (full path) to be loaded or saved.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FilePath property

Newtone.ImageKit.Win.ImageKit.File.FilePath Property

This property sets the folder initially displayed by the OpenFileDialog and SaveFileDialog methods.

[Visual Basic] Public Property FilePath As String
[C#] public string FilePath {get; set;}

Property Value

The FilePath is the folder name

Explanation

The FilePath property sets the folder initially displayed by the OpenFileDialog and SaveFileDialog methods.

When you execute the OpenFileDialog and SaveFileDialog methods, the "Open" dialog box and "Save" dialog box will be displayed. The FilePath property allows you to set the folder that is accessed when the "Open" dialog box and "Save" dialog box are displayed.

When setting the FileExtension property, start with the file explanation followed by a "|" symbol as a delimeter and the the file extensions to be displayed. When listing multiple file extensions, use a comma (;) to delimit them. If an empty string ("") is set into the FileExtension property then the file types will be "all files". If an empty string is set into the FilePath property, then the current direct directory will be displayed when the dialog opens.

There is no distinction made between upper case or lower case letters so that "BMP" is treated as the same as "bmp".

Example

The code below illustlates how to set the default folder to "C:\Images" and to set the file types to "BMP", "JPG and PNG", and "All Files":

[Visual Basic.NET]
ImageKit1.File.FilePath = "c:\images"
ImageKit1.File.FileExtension = "Bitmap files|*.bmp|Jpeg,Png files|*.jpg;*.png|All Files|*.*"

[Visual C#.NET]
ImageKit1.File.FilePath = "c:\\Images";
ImageKit1.File.FileExtension = "Bitmap files|*.bmp|Jpeg,Png files|*.jpg;*.png|All Files|*.*";

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileSize property

Newtone.ImageKit.Win.ImageKit.File.FileSize Property

This property refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileSize As Integer
[C#] public int FileSize {get;}

Property Value

The size of the image file

Explanation

The FileSize property refers to the size of the image file. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

If the information cannot be retrieved from the file, 0 will be set into this property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileType property

Newtone.ImageKit.Win.ImageKit.File.FileType Property

This property refers to the image format. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileType As Newtone.ImageKit.TypeOfFile
[C#] public Newtone.ImageKit.TypeOfFile FileType {get;}

Property Value

This value is of type Newtone.ImageKit.TypeOfFile

Explanation

The FileType property refers to image format. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

Note: TIFF(GROUP3-1D) is the same as MH. TIFF(GROUP3-2D) is the same as MR. TIFF(GROUP4) is the same as MMR. The ImageKit.NET supports Exif version 2.1

If an unsupported image format is loaded into the ImageKit Control, the FileType property will return 0.

To use JPEG2000, FPX, PCX, DXF, SVG, or SXF images, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileHeightWidth property

Newtone.ImageKit.Win.ImageKit.File.FileWidth Property

This property refers to the width of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileWidth As Integer
[C#] public int FileWidth {get;}

Property Value

The width of the image in pixels

Explanation

The FileWidth property refers to the width of the image in pixels. To set the value of this property, execute the GetImageFileType or GetImageFileTypeFromRawData method.

If the information cannot be retrieved from the file, 0 will be set into this property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileWidthByte property

Newtone.ImageKit.Win.ImageKit.File.FileWidthByte Property

This property refers to the number of bytes per line in the image. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileWidthByte As Integer
[C#] public int FileWidthByte {get;}

Property Value

The number of bytes per line in the image

Explanation

The FileWidthByte property refers to the number of bytes per line in the image. To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

This property is enabled for raster images.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileXdpi property

Newtone.ImageKit.Win.ImageKit.File.FileXdpi Property

The FileXdpi property refers to the horizontal resolution of the image. (number of pixels per horizontal inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileXdpi As Integer
[C#] public int FileXdpi {get;}

Property Value

The horizontal resolution of the image (number of pixels per horizontal inch)

Explanation

The FileXdpi property refers to the horizontal resolution of the image. (number of pixels per horizontal inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

If the information cannot be retrieved from the file, 0 will be set in this property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Credentials property

Newtone.ImageKit.Win.ImageKit.File.FtpCredentials Property

This property gets or sets the credentials used to communicate with the FTP server.
[Visual Basic] Public Property FtpCredentials As ICredentials
[C#] public ICredentials FtpCredentials {get; set;}

Property Value

An ICredentials instance; otherwise, a null reference (Nothing in Visual Basic) if the property has not been set.

Explanation

The FtpCredentials property gets or sets the credentials used to communicate with the FTP server.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Passive property

Newtone.ImageKit.Win.ImageKit.File.FtpPassive Property

This property sets whether or not passive mode connectivity is enabled.
[Visual Basic] Public Property FtpPassive As Integer
[C#] public int FtpPassive {get; set;}

Property Value

Value | Explanation
True | Passive mode connectivity
False | Active mode connectivity (default)

Explanation

The FtpPassive property sets whether or not passive mode connectivity is enabled.

This property is refered to by executing the FtpDownload or FtpUploadFile method.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Proxy property

Newtone.ImageKit.Win.ImageKit.File.FtpProxy Property

This property gets or sets the proxy used to communicate with the FTP server.
[Visual Basic] Public Property FtpProxy As IWebProxy
[C#] public IWebProxy FtpProxy {get; set;}

Property Value

An WebProxy instance responsible for communicating with the FTP server. The default value is null (Nothing in Visual Basic).

Explanation

The FtpProxy property gets or sets the proxy used to communicate with the FTP server.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Timeout property

Newtone.ImageKit.Win.ImageKit.File.FtpTimeout Property

This property gets or sets the number of milliseconds to wait for a request.
[Visual Basic] Public Property FtpTimeout As Integer
[C#] public int FtpTimeout {get; set;}

Property Value

The number of milliseconds to wait before a request times out. The default value is 60000 milliseconds.

Explanation

The FtpTimeout property gets or sets the number of milliseconds to wait for a request. Timeout is the number of milliseconds that a synchronous request waits for a response.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FileYdpi property

Newtone.ImageKit.Win.ImageKit.File.FileYdpi Property

The FileYdpi property refers to the vertical resolution of the image. (number of pixels per vertical inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FileYdpi As Integer
[C#] public int FileYdpi {get;}

Property Value

The vertical resolution of the image (number of pixels per vertical inch)

Explanation

The FileYdpi property refers to the vertical resolution of the image. (number of pixels per vertical inch). To retrieve the value of this property, first execute the GetImageFileType or GetImageFileTypeFromRawData method.

If the information cannot be retrieved from the file, 0 will be set into this property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


GifAnimation property

Newtone.ImageKit.Win.ImageKit.File.GifAnimation Property

This property sets whether or not the GIF image is a multi-page GIF (GIF animation).

[Visual Basic] Public Property GifAnimation As Boolean
[C#] public bool GifAnimation {get; set;}

Property Value

Value | Explanation
True | Multi-page GIF image (GIF animation)
False | Single image

Explanation

The GifAnimation property sets whether or not the GIF image is a multi-page GIF (GIF animation). Set this property when saving an image as a multi-page GIF file.

To use Gif animation, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


GifAnimationDelay property

Newtone.ImageKit.Win.ImageKit.File.GifAnimationDelay Property

This property sets the length of time a single page of a mult-page GIF image is displayed.

[Visual Basic] Public Property GifAnimationDelay As Integer
[C#] public int GifAnimationDelay {get; set;}

Property Value

The length of time after one page of a multi-page GIF image has been displayed and before the next page is displayed. (1/100 second units)

Explanation

The GifAnimationDelay property sets the length of time a single page of a mult-page GIF image is displayed.

Set this property when saving an image in a muti-page GIF file. This property is only enabled if the GifAnimation property is True.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpCredentials property

Newtone.ImageKit.Win.ImageKit.File.HttpCredentials Property

This property gets or sets authentication information for the request.
[Visual Basic] Public Property HttpCredentials As ICredentials
[C#] public ICredentials HttpCredentials {get; set;}

Property Value

This value contains the authentication credentials associated with the request. The default is a null reference (Nothing in Visual Basic).

Explanation

The HttpCredentials property gets or sets authentication information for the request. For more information please refer to the .NET Framework ICredentials interface.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpProxy property

Newtone.ImageKit.Win.ImageKit.File.HttpProxy Property

This property gets or sets proxy information for the request.
[Visual Basic] Public Property HttpProxy As IWebProxy
[C#] public IWebProxy HttpProxy {get; set;}

Property Value

The WebProxy instance used to proxy the request. The default value is null (Nothing in Visual Basic).

Explanation

The HttpProxy property identifies the WebProxy object to use to process requests to Internet resources.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpTimeout property

Newtone.ImageKit.Win.ImageKit.File.HttpTimeout Property

This property gets or sets the time-out value for the request.
[Visual Basic] Public Property HttpTimeout As Integer
[C#] public int HttpTimeout {get; set;}

Property Value

The number of milliseconds to wait before the request times out. The default value is 60000 milliseconds.

Explanation

The HttpTimeout property gets or sets the time-out value for the request. Timeout is the number of milliseconds that a subsequent synchronous request waits for a response

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Interlace property

Newtone.ImageKit.Win.ImageKit.File.Interlace Property

This property sets interlacing when saving an image as a GIF or PNG image. By executing the GetImageFileType or GetImageFileTypeFromRawData method, the Interlace property value can be retrieved.

[Visual Basic] Public Property Interlace As Boolean
[C#] public bool Interlace {get; set;}

Property Value

Value | Explanation
True | Interlace
False | Non interlace

Explanation

The Interlace property sets interlacing when saving an image as a GIF or PNG image. By executing the GetImageFileType or GetImageFileTypeFromRawData method, the Interlace property value can be retrieved.

To use this property, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000CodeBlockSize property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000CodeBlockHeight Property

This property sets the height of the JPEG2000 format code block size.

[Visual Basic] Public Property JPEG2000CodeBlockHeight As Integer
[C#] public int JPEG2000CodeBlockHeight {get; set;}

Property Value

The height of the JPEG2000 code block size

Explanation

The JPEG2000CodeBlockHeight property sets or retrieves the height of the JPEG2000 format code block size. The default value is 0.

The JPEG2000 format code block size is measured by 2 to certain power (from 2 to 10). So setting the JPEG2000CodeBlockHeight property to 3 would mean the vertical code block size is 23 . This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000CodeBlockSize property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000CodeBlockWidth Property

This property sets the width of the JPEG2000 format code block size.

[Visual Basic] Public Property JPEG2000CodeBlockWidth As Integer
[C#] public int JPEG2000CodeBlockWidth {get; set;}

Property Value

The width of the JPEG2000 code block size

Explanation

The JPEG2000CodeBlockWidth property sets or retrieves the height of the JPEG2000 format code block size. The default value is 0.

The JPEG2000 format code block size is measured by 2 to certain power (from 2 to 10). So setting the JPEG2000CodeBlockWidth property to 3 would mean the horizontal code block size is 23 . This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000NumResLevel property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000NumResLevel Property

This property sets the level of the JPEG2000 format resolution.

[Visual Basic] Public Property JPEG2000NumResLevel As Integer
[C#] public int JPEG2000NumResLevel {get; set;}

Property Value

The resolution level (from 0)

Explanation

The JPEG2000NumResLevel property sets the level of the JPEG2000 format resolution. The default value is 0.

This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000PrecinctHeight property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000PrecinctHeight Property

This property sets the height of the JPEG2000 format precinct size.

[Visual Basic] Public Property JPEG2000PrecinctHeight As Integer
[C#] public int JPEG2000PrecinctHeight {get; set;}

Property Value

The height of the JPEG2000 precinct size

Explanation

The JPEG2000PrecinctHeight property sets or retrieves the height of the JPEG2000 format precinct size. The default value is 0.

The JPEG2000 format precinct size is measured by 2 to certain power (from 0 to 15). So setting the JPEG2000PrecinctHeight property to 3 would mean the vertical precinct size is 23. This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000PrecinctWidth property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000PrecinctWidth Property

This property sets the width of the JPEG2000 format precinct size.

[Visual Basic] Public Property JPEG2000PrecinctWidth As Integer
[C#] public int JPEG2000PrecinctWidth {get; set;}

Property Value

The width JPEG2000 precinct size

Explanation

The JPEG2000PrecinctWidth property sets or retrieves the height of the JPEG2000 format precinct size. The default value is 0.

The JPEG2000 format precinct size is measured by 2 to certain power (from 0 to 15). So setting the JPEG2000PrecinctWidth property to 3 would mean the vertical precinct size is 23. This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000Reversible property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000Reversible Property

This property sets whether or not the JPEG2000 lossless compression is reversible.

[Visual Basic] Public Property JPEG2000Reversible As Boolean
[C#] public bool JPEG2000Reversible {get; set;}

Property Value

Value | Explanation
True | The compression is reversible
False | The compression is not reversible

Explanation

The JPEG2000Reversible property sets whether or not the JPEG2000 lossless compression is reversible. When true, file size will be bigger but since lossless compression is used there will be no degradation in image quality.

This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000Size property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000Size Property

This property sets the size of the file when saved in JPEG2000 format.

[Visual Basic] Public Property JPEG2000Size As Double
[C#] public double JPEG2000Size {get; set;}

Property Value

The size of the saved image as a factor of the size of the uncompressed image

Explanation

The JPEG2000Size property sets the size of the file when saved in JPEG2000 format.

When this property is 0.01, for example, it means that the file size will be 1/100th the size of the uncompressed file. The default value is 0 meaning no compression is used.

The JPEG2000Size property is enabled when the JPEG2000Reversible property is false. This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000TileHeight property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000TileHeight Property

This property sets the height of the JPEG2000 format tile size.

[Visual Basic] Public Property JPEG2000TileHeight As Integer
[C#] public int JPEG2000TileHeight {get; set;}

Property Value

The height of the JPEG2000 tile size (in pixels)

Explanation

The JPEG2000TileHeight property sets or retrieves the height of the JPEG2000 format tile size. The default value is 0.

This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JPEG2000TileWidth property

Newtone.ImageKit.Win.ImageKit.File.JPEG2000TileWidth Property

This property sets the width of the JPEG2000 format tile size.

[Visual Basic] Public Property JPEG2000TileWidth As Integer
[C#] public int JPEG2000TileWidth {get; set;}

Property Value

The width of the JPEG2000 tile size (in pixels)

Explanation

The JPEG2000TileWidth property sets or retrieves the width of the JPEG2000 format tile size. The default value is 0.

This property value is used when images are saved in JPEG2000 file format.

To use JPEG2000 files, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JpegQuality property

Newtone.ImageKit.Win.ImageKit.File.JpegQuality Property

This property sets the quality coefficient when an image is saved in JPEG or FPX (JPEG compression) file formats.
[Visual Basic] Public Property JpegQuality As Integer
[C#] public int JpegQuality {get; set;}

Property Value

0 to 100 (75 is recommended)

Explanation

The JpegQuality property sets the quality coefficient when an image is saved in JPEG or FPX (JPEG compression) file formats.

Default value is 75. As this value decreases the size of the image file decreases but so does the quality of the image. Conversely, as the quality coefficient increase the quality of the iamge and the image file size also increase.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


JpegSubsampling property

Newtone.ImageKit.Win.ImageKit.File.JpegSubsampling Property

This property sets the YCrCb subsampling ratios when saving an image in JPEG format.

[Visual Basic] Public Property JpegSubsampling As Newtone.ImageKit.JpegSubsamplingKind
[C#] public Newtone.ImageKit.JpegSubsamplingKind JpegSubsampling {get; set;}

Property Value

This value is of type Newtone.ImageKit.JpegSubsamplingKind

Explanation

The JpegSubsampling property sets the YCrCb subsampling ratios when saving an image in JPEG format. Since the Y (luminance or brightness) plane contains more important information about the image than does the CrCb (chrominance or color) planes, it is possible to reduce the size of the CrCb planes without a great sacrifice in quality thereby reducing the size of the image. A ratio for Y:Cr:Cb of 4:4:4 represents no reduction in size whereas a ratio of 4:1:1 represents a reduction in size of 50%.

This property is enabled when the image is 24 bit color and the image is saved as a JPEG image.

This property can only be used when loading or saving JPEG images with the ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastAccessTimeDay property

Newtone.ImageKit.Win.ImageKit.File.LastAccessTimeDay Property

This property refers to the day when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastAccessTimeDay As Integer
[C#] public int LastAccessTimeDay {get;}

Property Value

The day when the file was last accessed

Explanation

The LastAccessTimeDay property refers to the day when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastAccessTimeHour property

Newtone.ImageKit.Win.ImageKit.File.LastAccessTimeHour Property

This property refers to the hour when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastAccessTimeHour As Integer
[C#] public int LastAccessTimeHour {get;}

Property Value

The hour when the file was last accessed

Explanation

The LastAccessTimeHour property refers to the hour when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastAccessTimeMinute property

Newtone.ImageKit.Win.ImageKit.File.LastAccessTimeMinute Property

This property refers to the minute when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastAccessTimeMinute As Integer
[C#] public int LastAccessTimeMinute {get;}

Property Value

The number of minutes when the file was last accessed

Explanation

The LastAccessTimeMinute property refers to the minute when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastAccessTimeMonth property

Newtone.ImageKit.Win.ImageKit.File.LastAccessTimeMonth Property

This property refers to the month when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastAccessTimeMonth As Integer
[C#] public int LastAccessTimeMonth {get;}

Property Value

The month when the file was last accessed

Explanation

The LastAccessTimeMonth property refers to the month when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastAccessTimeSecond property

Newtone.ImageKit.Win.ImageKit.File.LastAccessTimeSecond Property

This property refers to the number of seconds when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastAccessTimeSecond As Integer
[C#] public int LastAccessTimeSecond {get;}

Property Value

The number of seconds when the file was last accessed

Explanation

The LastAccessTimeSecond property refers to the number of seconds when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastAccessTimeYear property

Newtone.ImageKit.Win.ImageKit.File.LastAccessTimeYear Property

This property refers to the year when the file was last accessed. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastAccessTimeYear As Integer
[C#] public int LastAccessTimeYear {get;}

Property Value

The year when the file was last accessed

Explanation

The LastAccessTimeYear property refers to the year when the file was last accessed. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastWriteTimeDay property

Newtone.ImageKit.Win.ImageKit.File.LastWriteTimeDay Property

This property refers to the day when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastWriteTimeDay As Integer
[C#] public int LastWriteTimeDay {get;}

Property Value

The day when the file was last modified

Explanation

The LastWriteTimeDay property refers to the day when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastWriteTimeHour property

Newtone.ImageKit.Win.ImageKit.File.LastWriteTimeHour Property

This property refers to the hour when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastWriteTimeHour As Integer
[C#] public int LastWriteTimeHour {get;}

Property Value

The hour when the file was last modified

Explanation

The LastWriteTimeDay property refers to the hour when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastWriteTime property

Newtone.ImageKit.Win.ImageKit.File.LastWriteTimeMinute Property

This property refers to the number of minutes when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastWriteTimeMinute As Integer
[C#] public int LastWriteTimeMinute {get;}

Property Value

The number of minutes when the file was last modified

Explanation

The LastWriteTimeDay property refers to the number of minutes when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastWriteTime property

Newtone.ImageKit.Win.ImageKit.File.LastWriteTimeMonth Property

This property refers to the month when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastWriteTimeMonth As Integer
[C#] public int LastWriteTimeMonth {get;}

Property Value

The month when the file was last modified

Explanation

The LastWriteTimeMonth property refers to the month when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastWriteTimeSecond property

Newtone.ImageKit.Win.ImageKit.File.LastWriteTimeSecond Property

This property refers to the number of seconds when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastWriteTimeSecond As Integer
[C#] public int LastWriteTimeSecond {get;}

Property Value

The number of seconds when the file was last modified

Explanation

The LastWriteTimeSecond property refers to the number of seconds when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LastWriteTimeYear property

Newtone.ImageKit.Win.ImageKit.File.LastWriteTimeYear Property

This property refers to the year when the file was last modified. Retrieved after executing the GetImageFileType method.

[Visual Basic] Public ReadOnly Property LastWriteTimeYear As Integer
[C#] public int LastWriteTimeYear {get;}

Property Value

The year when the file was last modified

Explanation

The LastWriteTimeYear property refers to the year when the file was last modified. This value is retrieved after executing the GetImageFileType method. If the GetImageFileTypeFromRawData method is executed, 0 will be returned.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LoadPage property

Newtone.ImageKit.Win.ImageKit.File.LoadPage Property

This property sets the page to be loaded when a multi-page image file (FPX, GIF, or TIFF) image is loaded.

[Visual Basic] Public Property LoadPage As Integer
[C#] public int LoadPage {get; set;}

Property Value

The number of the page of a mutli-page image file.

The first page is 0. (For FPX format the base image is also 0)

Explanation

The LoadPage property sets the page to be loaded when a multi-page image file (FPX, GIF, or TIFF) image is loaded.

In the GIF and TIFF file formats, numerous images can be stored in one multi-page image file. In the FPX file format, images of different resolutions can be stored in one multi-resolution image file.

The LoadPage property is used when loading a particular page from a multi-page image file into the memory. If there is no page set in the LoadPage property, after executing the LoadImageFromFile method or the LoadImageFromRawData method, False(0) is returned.

To use FPX files, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


PngAlphaChannel property

Newtone.ImageKit.Win.ImageKit.File.PngAlphaChannel Property

This property sets the alpha channel when loading and saving a PNG image.

[Visual Basic] Public Property PngAlphaChannel As Boolean
[C#] public bool PngAlphaChannel {get; set;}

Property Value

Value | Explanation
True | Sets the alpha channel in a independent plane (RGBA format)
False | Incorporates the alpha channel to produce a RGB image (default)

Explanation

The PngAlphaChannel property sets the alpha channel when loading or saving a PNG image.

To use this property, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


RawData property

Newtone.ImageKit.Win.ImageKit.File.RawData Property

This property refers to the byte array of raw image data to be loaded or saved.

[Visual Basic] Public Property RawData As Byte()
[C#] public byte[] RawData {get; set;}

Property Value

A byte array of the raw image data

Explanation

The RawData property refers to the byte array of raw image data to be loaded or saved.

After executing the LoadRawDataFromFile method, the raw data is set to this property. After executing the SaveRawDataToFile method, the raw data set to this property is saved to a file.

To disable the image referred to by this property, please set null (in Visual Basic, Nothing) to this property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


TiffAppend property

Newtone.ImageKit.Win.ImageKit.File.TiffAppend Property

This property sets whether or not an image saved in TIFF format is appended to an existing multi-page TIFF image or saved as a separate image.

[Visual Basic] Public Property TiffAppend As Boolean
[C#] public bool TiffAppend {get; set;}

Property Value

Value | Explanation
True | Multi-page TIFF image (The image will be appended to the end of an existing TIFF image)
False | Single TIFF image (Each image file contains only one image)

Explanation

The TiffAppend property sets whether or not an image saved in TIFF format is appended to an existing multi-page TIFF image or saved as a separate image.

This property can be set when saving an image in TIFF format. When this property is set to True and the SaveImageToFile method is executed, you must then execute the CloseMultiTiff method.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


TiffColorSpace property

Newtone.ImageKit.Win.ImageKit.File.TiffColorSpace Property

This property defines the color space when saving images in TIFF file format.

[Visual Basic] Public Property TiffColorSpace As Newtone.ImageKit.TiffColorSpaceKind
[C#] public Newtone.ImageKit.TiffColorSpaceKind TiffColorSpace {get; set;}

Property Value

Newtone.ImageKit.TiffColorSpaceKind Value

Explanation

The TiffColorSpace property defines the color space when saving images in TIFF file format. This property is enabled when the image to be saved is 24 or 32 bit color. If the TiffColorSpace property is set to CMYK then the image file will be converted to 32 bit. This property can be set when using Uncompressed TIFF, PACKBITS or LZW file formats.

To use this property, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


TiffSaveOneStrip property

Newtone.ImageKit.Win.ImageKit.File.TiffSaveOneStrip Property

This property sets whether or not a TIFF image is saved as one strip or multiple strips.

[Visual Basic] Public Property TiffSaveOneStrip As Boolean
[C#] public bool TiffSaveOneStrip {get; set;}

Property Value

Value | Explanation
True | The TIFF image is saved in a single strip
False | The TIFF image is saved in multiple strips (default)

Explanation

The TiffSaveOneStrip property sets whether or not a TIFF image is saved as one strip or multiple strips. The default value is False. This property is enabled for all TIFF file formats except TIFF GROUP4. (GROUP4 files must be single strip).

To use this property, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Transparent property

Newtone.ImageKit.Win.ImageKit.File.Transparent Property

This property sets whether or not the transparent color in GIF and PNG images is enabled.

[Visual Basic] Public Property Transparent As Boolean
[C#] public bool Transparent {get; set;}

Property Value

Value | Explanation
True | The transparent color is enabled
False | The transparent color is disabled

Explanation

The Transparent property sets whether or not the transparent color, as set in the TransparentBlue, TransparentGreen, and TransparentRed properties, is enabled in GIF or PNG images.

To use this property, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


TransparentBlue property

Newtone.ImageKit.Win.ImageKit.File.TransparentBlue Property

This property sets the blue component (RGB values) of the transparent color when saving an image as a GIF or PNG image.

[Visual Basic] Public Property TransparentBlue As Byte
[C#] public byte TransparentBlue {get; set;}

Property Value

The values can range from 0 to 255

Explanation

The TransparentBlue property sets the blue component (RGB values) of the transparent color when saving an image as a GIF or PNG image.

When saving an image as a GIF or PNG image, a color can be transparent by setting the appropriate RGB values in each of the TransparentBlue, TransparentGreen, and TransparentRed properties. This property value is valid when the Transparent property is True.

To use this property, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


TransparentGreen property

Newtone.ImageKit.Win.ImageKit.File.TransparentGreen Property

This property sets the green component (RGB values) of the transparent color when saving an image as a GIF or PNG image.

[Visual Basic] Public Property TransparentGreen As Byte
[C#] public byte TransparentGreen {get; set;}

Property Value

The values can range from 0 to 255

Explanation

The TransparentGreen property sets the green component (RGB values) of the transparent color when saving an image as a GIF or PNG image.

When saving an image as a GIF or PNG image, a color can be transparent by setting the appropriate RGB values in each of the TransparentBlue, TransparentGreen, and TransparentRed properties. This property value is valid when the Transparent property is True.

To use this property, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


TransparentRed property

Newtone.ImageKit.Win.ImageKit.File.TransparentRed Property

This property sets the red component (RGB values) of the transparent color when saving an image as a GIF or PNG image.

[Visual Basic] Public Property TransparentRed As Byte
[C#] public byte TransparentRed {get; set;}

Property Value

The values can range from 0 to 255

Explanation

The TransparentRed property sets the red component (RGB values) of the transparent color when saving an image as a GIF or PNG image.

When saving an image as a GIF or PNG image, a color can be transparent by setting the appropriate RGB values in each of the TransparentBlue, TransparentGreen, and TransparentRed properties. This property value is valid when the Transparent property is True.

To use this property, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


VectorHeight property

Newtone.ImageKit.Win.ImageKit.File.VectorHeight Property

This property sets the height of a vector image when the image is loaded.

[Visual Basic] Public Property VectorHeight As Integer
[C#] public int VectorHeight {get; set;}

Property Value

The VectorHeight property sets the height of the vector image (in pixels). Default value is 0.

Explanation

The VectorHeight property property sets the height of a vector image when the image is loaded.

For DXF and SXF images

If the VectorHeight property or the VectorWidth property is set to a value of 0 or less, 800x600 will be used.

For EMF, SVG, and WMF images

If the VectorHeight property or the VectorWidth property is set to a value of 0 or less, the size defined in each file header will be used.

Note: When the vector image is loaded, the ratio of the height and width of the original image is maintained and the largest pixel size of the image is scaled within the area defined by the VectorHeight and VectorWidth properties.

To use DXF, SVG, or SXF images, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


VectorWidth property

Newtone.ImageKit.Win.ImageKit.File.VectorWidth Property

This property sets the width of a vector image when the image is loaded.

[Visual Basic] Public Property VectorWidth As Integer
[C#] public int VectorWidth {get; set;}

Property Value

The VectorWidth property sets the width of the vector image (in pixels). Default value is 0.

Explanation

The VectorWidth property sets the width of a vector image when the image is loaded.

For DXF and SXF images

If the VectorHeight property or the VectorWidth property is set to a value of 0 or less, 800x600 will be used.

For EMF, SVG, and WMF images

If the VectorHeight property or the VectorWidth property is set to a value of 0 or less, the size defined in each file header will be used.

Note: When the vector image is loaded, the ratio of the height and width of the original image is maintained and the largest pixel size of the image is scaled within the area defined by the VectorHeight property or the VectorWidth properties.

To use DXF, SVG, or SXF images, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CMYKBmpPlaneFileLoad method

Newtone.ImageKit.Win.ImageKit.File.CMYKBmpPlaneFileLoad Method

This method loads a bmp file that has been saved in seperate CMYK planes.

[Visual Basic] Public Function CMYKBmpPlaneFileLoad(CFileName As String, MFileName As String, YFileName As String, KFileName As String) As Boolean
[C#] public bool CMYKBmpPlaneFileLoad(string CFileName, string MFileName, string YFileName, string KFileName) ;

Parameters

CFileName
The filename of the C plane image to be loaded

MFileName
The filename of the M plane image to be loaded

YFileName
The filename of the Y plane image to be loaded

KFileName
The filename of the K plane image to be loaded

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CMYKBmpPlaneFileLoad method loads a bmp file that has been saved in seperate CMYK planes. The individual CMYK plane images must be 8 bit grayscale. The output image will be 24 bit color.

If successful, the output image will be set in the Image property or the Layer(LayerNumber).Imgae property according to the value set in the LayerNumber property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CMYKBmpPlaneFileSave method

Newtone.ImageKit.Win.ImageKit.File.CMYKBmpPlaneFileSave Method

This method saves a raster image into seperate CMYK planes. The saved images are in BMP format.

[Visual Basic] Public Function CMYKBmpPlaneFileSave(CFileName As String, MFileName As String, YFileName As String, KFileName As String, SaveImage As Image) As Boolean
[C#] public bool CMYKBmpPlaneFileSave(string CFileName, string MFileName, string YFileName, string KFileName, Image SaveImage) ;

Parameters

CFileName
The filename of the saved C plane image

MFileName
The filename of the saved M plane image

YFileName
The filename of the saved Y plane image

KFileName
The filename of the saved K plane image

SaveImage
The saved image

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CMYKBmpPlaneFileSave method saves a raster image into seperate CMYK planes. The saved images are in BMP format.

When the SaveImage parameter contains a valid image handle

The image set in the SaveImage parameter will be saved as four seperate images each corresponding to the various CMYK planes.

When the SaveImage parameter contains 0

The image referred to by the LayerNumber property (either the image set in the Image property or the image set in the Layer(LayerNumber).Imgae property as the case may be) will be saved as four seperate images each corresponding to the various CMYK planes.

Note: When the LayerNumber property is -1, the image set in the Image property is enabled. When the LayerNumber property has values from 0 to 99, the image set in the Layer(LayerNumber).Image property is enabled.

The input image (that image set in the SaveImage parameter) must be 24 bit color. The output images (corresponding to the various CMYK planes) will be 8 bit grayscale.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDeleteFile Methods

This method deletes the file on the FTP server.

Overload List

This method deletes a file on an FTP server specifying the remote URI.

[Visual Basic] Public Function FtpDeleteFile(String) As Boolean
[C#] public bool FtpDeleteFile(string)

This method deletes a file on an FTP server specifying the remote URI.

[Visual Basic] Public Function FtpDeleteFile(System.Uri) As Boolean
[C#] public bool FtpDeleteFile(System.Uri)

This method deletes a file on an FTP server specifying the host name and the remote URI.

[Visual Basic] Public Function FtpDeleteFile(String, String) As Boolean
[C#] public bool FtpDeleteFile(string, string)

This method deletes a file on an FTP server specifying the host name and the remote URI, and the port number.

[Visual Basic] Public Function FtpDeleteFile(String, String, Integer) As Boolean
[C#] public bool FtpDeleteFile(string, string, int)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDeleteFile Method

This method deletes a file on an FTP server specifying the remote URI.

[Visual Basic] Public Function FtpDeleteFile(ByVal remoteAddress As String) As Boolean
[C#] public bool FtpDeleteFile(string remoteAddress);

Parameters

remoteAddress

URI

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDeleteFile method deletes a file on an FTP server specifying the remote URI.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = ImageKit.File.FtpDeleteFile("ftp://www.newtone.co.jp/test/test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = ImageKit.File.FtpDeleteFile("ftp://www.newtone.co.jp/test/test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDeleteFile Method

This method deletes a file on an FTP server specifying the remote URI.

[Visual Basic] Public Function FtpDeleteFile(ByVal remoteAddress As System.Uri) As Boolean
[C#] public bool FtpDeleteFile(System.Uri remoteAddress);

Parameters

remoteAddress
URI

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDeleteFile method deletes a file on an FTP server specifying the remote URI.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = ImageKit.File.FtpDeleteFile(New Uri("ftp://www.newtone.co.jp/test/test.jpg"))

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = ImageKit.File.FtpDeleteFile(new Uri("ftp://www.newtone.co.jp/test/test.jpg"));

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDeleteFile Method

This method deletes a file on an FTP server specifying the host name and the remote URI.

[Visual Basic] Public Function FtpDeleteFile(ByVal remoteHost As String, ByVal remotePath As String) As Boolean
[C#] public bool FtpDeleteFile(string remoteHost, string remotePath);

Parameters

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDeleteFile method deletes a file on an FTP server specifying the host name and the remote URI..

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Deletes a file
Ret = ImageKit.File.FtpDeleteFile("www.newtone.co.jp", "test/test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Deletes a file
Ret = ImageKit.File.FtpDeleteFile("www.newtone.co.jp", "test/test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDeleteFile Method

This method deletes a file on an FTP server specifying the host name, the remote URI, and the port number.

[Visual Basic] Public Function FtpDeleteFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal remotePort As Integer) As Boolean
[C#] public bool FtpDeleteFile(string remoteHost, string remotePath, int remotePort);

Parameters

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

remotePort
IP port number

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDeleteFile method deletes a file on an FTP server specifying the host name, the remote URI, and the port number.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user","password")
'Deletes the file
Ret = ImageKit.File.FtpDeleteFile("www.newtone.co.jp", "test/test.jpg",21)

[C#]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = ImageKit.File.FtpDeleteFile("www.newtone.co.jp", "test/test.jpg", 21);

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFile Methods

These methods download a file from an FTP server.

Overload List

This method downloads a file from an FTP server specifying the remote URI and the local filename.

[Visual Basic] Public Function FtpDownloadFile(String, String) As Boolean
[C#] public bool FtpDownloadFile(string, string)

This method downloads a file from an FTP server specifying the remote URI and the local filename

[Visual Basic] Public Function FtpDownloadFile(System.Uri, String) As Boolean
[C#] public bool FtpDownloadFile(System.Uri, string)

This method downloads a file from an FTP server specifying the host name, the remote URI and the local filename

[Visual Basic] Public Function FtpDownloadFile(String, String, String) As Boolean
[C#] public bool FtpDownloadFile(string, string, string)

This method downloads a file from an FTP server specifying the host name, the remote URI, the port number, and the local filename

[Visual Basic] Public Function FtpDownloadFile(String, String, Integer, String) As Boolean
[C#] public bool FtpDownloadFile(string, string, int, string)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFile Method

This method downloads a file from an FTP server specifying the remote URI, and the local filename.

[Visual Basic] Public Function FtpDownloadFile(ByVal remoteAddress As String, ByVal localFileName As String) As Boolean
[C#] public bool FtpDownloadFile(string remoteAddress, string localFileName);

Parameters

remoteAddress
The URI of the file to be downloaded

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDownloadFile method downloads a file from an FTP server specifying the remote URI, and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Downloads the file
Ret = ImageKit.File.FtpDownloadFile("ftp://www.newtone.co.jp/test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Downloads the file
Ret = ImageKit.File.FtpDownloadFile("ftp://www.newtone.co.jp/test/test.jpg", @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFile Method

This method downloads a file from an FTP server specifying the remote URI, and the local filename.

[Visual Basic] Public Function FtpDownloadFile(ByVal remoteAddress As System.Uri, ByVal localFileName As String) As Boolean
[C#] public bool FtpDownloadFile(System.Uri remoteAddress, string localFileName);

Parameters

remoteAddress
The URI of the file to be downloaded

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDownloadFile method downloads a file from an FTP server specifying the remote URI, and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Downloads the file
Ret = ImageKit.File.FtpDownloadFile(New Uri("ftp://www.newtone.co.jp/test/test.jpg"), "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Downloads the file
Ret = ImageKit.File.FtpDownloadFile(new Uri("ftp://www.newtone.co.jp/test/test.jpg"), @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFile Method

This method downloads a file from an FTP server specifying the host name, the remote URI, and the local filename.

[Visual Basic] Public Function FtpDownloadFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal localFileName As String) As Boolean
[C#] public bool FtpDownloadFile(string remoteHost, string remotePath, string localFileName);

Parameters

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDownloadFile method downloads a file from an FTP server specifying the host name, the remote URI, and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'User name and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Downloads the file
Ret = ImageKit.File.FtpDownloadFile("www.newtone.co.jp", "test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//User name and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Downloads the file
Ret = ImageKit.File.FtpDownloadFile("www.newtone.co.jp", "test/test.jpg", @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpDownloadFile Method

This method downloads a file from an FTP server specifying the host name, the remote URI, the port number, and the local filename.

[Visual Basic] Public Function FtpDownloadFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal remotePort As Integer, ByVal localFileName As String) As Boolean
[C#] public bool FtpDownloadFile(string remoteHost, string remotePath, int remotePort, string localFileName);

Parameters

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

remotePort
IP port number

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpDownloadFile method downloads a file from an FTP server specifying the host name, the remote URI, the port number, and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'User name and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Downloads the file
Ret = ImageKit.File.FtpDownloadFile("www.newtone.co.jp", "test/test.jpg", 21, "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//User name and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Downloads the file
Ret = ImageKit.File.FtpDownloadFile("www.newtone.co.jp", "test/test.jpg", 21, @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpRenameFile method

Newtone.ImageKit.Win.ImageKit.File.FtpRenameFile Methods

These methods rename a file that exists on the FTP server.

Overload List

This method renames a file on an FTP server specifying the remote URI and the new remote filename.

[Visual Basic] Public Function FtpRenameFile(String, String) As Boolean
[C#] public bool FtpRenameFile(string, string)

This method renames a file on an FTP server specifying the remote URI and the new remote filename.

[Visual Basic] Public Function FtpRenameFile(System.Uri, String) As Boolean
[C#] public bool FtpRenameFile(System.Uri, string)

This method renames a file on an FTP server specifying the host, the remote URI and the new remote filename.

[Visual Basic] Public Function FtpRenameFile(String, String, String) As Boolean
[C#] public bool FtpRenameFile(string, string, string)

This method renames a file on an FTP server specifying the host name, the remote URI, the port number and the new remote filename

[Visual Basic] Public Function FtpRenameFile(String, String, Integer, String) As Boolean
[C#] public bool FtpRenameFile(string, string, int, string)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpRenameFile method

Newtone.ImageKit.Win.ImageKit.File.FtpRenameFile Method

This method renames a file on an FTP server specifying the remote URI and the new remote filename.
[Visual Basic] Public Function FtpRenameFile(ByVal remoteAddress As String, ByVal newRemotePath As String) As Boolean
[C#] public bool FtpRenameFile(string remoteAddress, string newRemotePath);

Parameters

remoteAddress
URI

newRemotePath
The new remote filename

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpRenameFile method renames a file on an FTP server specifying the remote URI and the new remote filename. This method is enabled for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret
As Boolean 'Username
and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Renames the file
Ret = ImageKit.File.FtpRenameFile("ftp://www.newtone.co.jp/test/test.jpg", "test/test1.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Renames the file
Ret = ImageKit.File.FtpRenameFile("ftp://www.newtone.co.jp/test/test.jpg", "test/test1.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpRenameFile method

Newtone.ImageKit.Win.ImageKit.File.FtpRenameFile Method

This method renames a file on an FTP server specifying the remote URI and the new remote filename.
[Visual Basic] Public Function FtpRenameFile(ByVal remoteAddress As System.Uri, ByVal newRemotePath As String) As Boolean
[C#] public bool FtpRenameFile(System.Uri remoteAddress, string newRemotePath);

Parameters

remoteAddress
URI

newRemotePath
The new remote filename

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpRenameFile method renames a file on an FTP server specifying the remote URI and the new remote filename. This method is enabled for the FTP proptocol.

Example

 [Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Renames the file
Ret = ImageKit.File.FtpRenameFile(New Uri("ftp://www.newtone.co.jp/test/test.jpg"), "test/test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Renames the file
Ret = ImageKit.File.FtpRenameFile(new Uri("ftp://www.newtone.co.jp/test/test.jpg"), "test/test1.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpRenameFile method

Newtone.ImageKit.Win.ImageKit.File.FtpRenameFile Method

This method renames a file on an FTP server specifying the host, the remote URI and the new remote filename.
[Visual Basic] Public Function FtpRenameFile(ByVal remoteHost As String, ByVal oldRemotePath As String, ByVal newRemotePath As String) As Boolean
[C#] public bool FtpRenameFile(string remoteHost, string oldRemotePath, string newRemotePath);

Parameters

remoteHost
Domain name in DNS style, or IP address

oldRemotePath
The remote URI

newRemotePath
The new remote filename

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpRenameFile method renames a file on an FTP server specifying the host name, the remote URI and the new remote filename. This method is enabled for the FTP proptocol.

Example

 [Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Renames the file
Ret = ImageKit.File.FtpRenameFile("www.newtone.co.jp", "test/test.jpg", "test/test1.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Renames the file
Ret = ImageKit.File.FtpRenameFile("www.newtone.co.jp", "test/test.jpg", "test/test1.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpRenameFile method

Newtone.ImageKit.Win.ImageKit.File.FtpRenameFile Method

This method renames a file on an FTP server specifying the host name, the remote URI, the port number and the new remote filename
[Visual Basic] Public Function FtpRenameFile(ByVal remoteHost As String, ByVal oldRemotePath As String, ByVal remotePort As Integer, ByVal newRemotePath As String) As Boolean
[C#] public bool FtpRenameFile(string remoteHost, string oldRemotePath, int remotePort, string newRemotePath);

Parameters

remoteHost
Domain name in DNS style, or IP address

oldRemotePath
The remote URI

remotePort
The IP port number

newRemotePath
The new remote filename

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpRenameFile method renames a file on an FTP server specifying the host name, the remote URI, the port number and the new remote filename. This method is enabled for the FTP proptocol.

Example

 [Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Renames the file
Ret = ImageKit.File.FtpRenameFile("www.newtone.co.jp", "test/test.jpg", 21,"test/test1.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Renames the file
Ret = ImageKit.File.FtpRenameFile("www.newtone.co.jp", "test/test.jpg", 21, "test/test1.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadFile Methods

These methods upload a file to an FTP server.

Overload List

This method uploads a file to an FTP server specifying the remote URI and the local filename.

[Visual Basic] Public Function FtpUploadFile(String, String) As Boolean
[C#] public bool FtpUploadFile(string, string)

This method uploads a file to an FTP server specifying the remote URI and the local filename.

[Visual Basic] Public Function FtpUploadFile(System.Uri, String) As Boolean
[C#] public bool FtpUploadFile(System.Uri, string)

This method uploads a file to an FTP server specifying the host name, the remote URI, and the local filename.

[Visual Basic] Public Function FtpUploadFile(String, String, String) As Boolean
[C#] public bool FtpUploadFile(string, string, string)

This method uploads a file to an FTP server with specifying the host name, the remote URI, the port number, and the local filename.

[Visual Basic] Public Function FtpUploadFile(String, String, Integer, String) As Boolean
[C#] public bool FtpUploadFile(string, string, int, string)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadFile Method

This method uploads a file to an FTP server specifying the remote URI and the local filename.

[Visual Basic] Public Function FtpUploadFile(ByVal remoteAddress As String, ByVal localFileName As String) As Boolean
[C#] public bool FtpUploadFile(string remoteAddress, string localFileName);

Parameters

remoteAddress
The URI where the file will be uploaded

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpUploadFile method uploads a file to an FTP server specifying the remote URI and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Uploads the file
Ret = ImageKit.File.FtpUploadFile("ftp://www.newtone.co.jp/test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Uploads the file
Ret = ImageKit.File.FtpUploadFile("ftp://www.newtone.co.jp/test/test.jpg", @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadFile Method

This method uploads a file to an FTP server specifying the remote URI and the local filename.

[Visual Basic] Public Function FtpUploadFile(ByVal remoteAddress As System.Uri, ByVal localFileName As String) As Boolean
[C#] public bool FtpUploadFile(System.Uri remoteAddress, string localFileName);

Parameters

remoteAddress
The URI where the file will be uploaded

localFileName
The filename and path of the local file to be uploaded

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpUploadFile method uploads a file to an FTP server specifying the remote URI and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Uploads the file
Ret = ImageKit.File.FtpUploadFile(New Uri("ftp://www.newtone.co.jp/test/test.jpg"), "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Uploads the file
Ret = ImageKit.File.FtpUploadFile(new Uri("ftp://www.newtone.co.jp/test/test.jpg"), @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadFile Method

This method uploads a file to an FTP server specifying the host name, the remote URI, and the local filename.

[Visual Basic] Public Function FtpUploadFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal localFileName As String) As Boolean
[C#] public bool FtpUploadFile(string remoteHost, string remotePath, string localFileName);

Parameters

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpUploadFile method uploads a file to an FTP server specifying the host name, the remote URI, and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Uploads the file
Ret = ImageKit.File.FtpUploadFile("www.newtone.co.jp", "test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Uploads the file
Ret = ImageKit.File.FtpUploadFile("www.newtone.co.jp", "test/test.jpg", @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


FtpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.FtpUploadFile Method

This method

[Visual Basic] Public Function FtpUploadFile(ByVal remoteHost As String, ByVal remotePath As String, ByVal remotePort As Integer, ByVal localFileName As String) As Boolean
[C#] public bool FtpUploadFile(string remoteHost, string remotePath, int remotePort, string localFileName);

Parameters

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

remotePort
IP port number

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The FtpUploadFile method uploads a file to an FTP server with specifying the host name, the remote URI, the port number, and the local filename.

This method is effective for the FTP protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.FtpCredentials = New NetworkCredential("user", "password")
'Enables passive mode connectivity
ImageKit.File.FtpPassive = True
'Uploads the file
Ret = ImageKit.File.FtpUploadFile("www.newtone.co.jp", "test/test.jpg", 21, "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.FtpCredentials = new NetworkCredential("user", "password");
//Enables passive mode connectivity
ImageKit.File.FtpPassive = true;
//Uploads the file
Ret = ImageKit.File.FtpUploadFile("www.newtone.co.jp", "test/test.jpg", 21, @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


GetImageFileType method

Newtone.ImageKit.Win.ImageKit.File.GetImageFileType Method

This method retrieves information about the image and sets this into the following properties:
Comment, CreationTimeDay, CreationTimeHour, CreationTimeMinute, CreationTimeMonth, CreationTimeSecond, CreationTimeYear, Exif, FileBitCount, FileHeight, FileWidth, FileImageSize, FileMaxPage, FileSize, FileType, FileWidthByte, FileXdpi, FileYdpi, Interlace, LastAccessTimeDay, LastAccessTimeHour, LastAccessTimeMinute, LastAccessTimeMonth, LastAccessTimeSecond, LastAccessTimeYear, LastWriteTimeDay, LastWriteTimeHour, LastWriteTimeMinute, LastWriteTimeMonth, LastWriteTimeSecond, LastWriteTimeYear

[Visual Basic] Public Function GetImageFileType() As Boolean
[C#] public bool GetImageFileType() ;

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetImageFileType method retrieves information about the image and sets this into the following properties:
Comment, CreationTimeDay, CreationTimeHour, CreationTimeMinute, CreationTimeMonth, CreationTimeSecond, CreationTimeYear, Exif, FileBitCount, FileHeight, FileWidth, FileImageSize, FileMaxPage, FileSize, FileType, FileWidthByte, FileXdpi, FileYdpi, Interlace, LastAccessTimeDay, LastAccessTimeHour, LastAccessTimeMinute, LastAccessTimeMonth, LastAccessTimeSecond, LastAccessTimeYear, LastWriteTimeDay, LastWriteTimeHour, LastWriteTimeMinute, LastWriteTimeMonth, LastWriteTimeSecond, LastWriteTimeYear

To execute this method the appropriate value must first be set into the FileName property. If the image is a multi-page image file then the LoadPage property must also be set. If the image is a multi-page image file then properties other than FileMaxPage and FileSize will relate to the page specified in the LoadPage property. For all image file formats except TIFF, the Comment property relates to the whole image file, regardless of whether it is a multi-page image file or not. For more details, please refer to the specific property information.

Note: Even if the file format is supported, if no value has been set then that property will return a 0 or an empty string.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


GetImageFileTypeFromRawData method

Newtone.ImageKit.Win.ImageKit.File.GetImageFileTypeFromRawData Method

This method retrieves information from the raw image data and sets that information into the following properties:
Comment, CreationTimeDay, CreationTimeHour, CreationTimeMinute, CreationTimeMonth, CreationTimeSecond, CreationTimeYear, Exif, FileBitCount, FileHeight, FileWidth, FileImageSize, FileMaxPage, FileSize, FileType, FileWidthByte, FileXdpi, FileYdpi, Interlace

[Visual Basic] Public Function GetImageFileTypeFromRawData() As Boolean
[C#] public bool GetImageFileTypeFromRawData() ;

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetImageFileTypeFromRawData method retrieves information from the raw image data and sets that information into the following properties:
Comment, CreationTimeDay, CreationTimeHour, CreationTimeMinute, CreationTimeMonth, CreationTimeSecond, CreationTimeYear, Exif, FileBitCount, FileHeight, FileWidth, FileImageSize, FileMaxPage, FileSize, FileType, FileWidthByte, FileXdpi, FileYdpi, Interlace

To execute this method the appropriate value must first be set into the RawData and LoadPage property. If the image is a multi-page image file then properties other than FileMaxPage and FileSize will relate to the page specified in the LoadPage property. For all image file formats except TIFF, the Comment property relates to the whole image file, regardless of whether it is a multi-page image file or not. For more details, please refer to the specific property information.

Note: Even if the file format is supported, if no value has been set then that property will return a 0 or an empty string.

This method is the same as retrieving information from the image file using the GetImageFileType, however the properties related to "File Created", "File Accessed", and "File Modified" will have a value of 0.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDeleteFile Methods

This method deletes a file from an Http server.

Overload List

This method deletes a file from an Http server specifying the remote URI.

[Visual Basic] Public Function HttpDeleteFile(String) As Boolean
[C#] public bool HttpDeleteFile(string)

This method deletes a file from an Http server specifying the remote URI.

[Visual Basic] Public Function HttpDeleteFile(System.Uri) As Boolean
[C#] public bool HttpDeleteFile(System.Uri)

This method deletes a file from an Http server specifying the protocol scheme, the host name and remote URI.

[Visual Basic] Public Function HttpDeleteFile(String, String, String) As Boolean
[C#] public bool HttpDeleteFile(string, string, string)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDeleteFile Method

This method deletes a file from an Http server specifying the remote URI.

[Visual Basic] Public Function HttpDeleteFile(ByVal remoteAddress As String) As Boolean
[C#] public bool HttpDeleteFile(string remoteAddress);

Parameters

remoteAddress
URI

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpDeleteFile method deletes a file from an Http server specifying the remote URI.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = ImageKit.File.HttpDeleteFile("http://www.newtone.co.jp/test/test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = ImageKit.File.HttpDeleteFile("http://www.newtone.co.jp/test/test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDeleteFile Method

This method deletes a file from an Http server specifying the remote URI.

[Visual Basic] Public Function HttpDeleteFile(ByVal remoteAddress As System.Uri) As Boolean
[C#] public bool HttpDeleteFile(System.Uri remoteAddress);

Parameters

remoteAddress
URI

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpDeleteFile method deletes a file from an Http server specifying the remote URI.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = ImageKit.File.HttpDeleteFile(New Uri("http://www.newtone.co.jp/test/test.jpg"))

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = ImageKit.File.HttpDeleteFile(new Uri("http://www.newtone.co.jp/test/test.jpg"));

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDeleteFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDeleteFile Method

This method deletes a file from an Http server specifying the protocol scheme, the host name and remote URI

[Visual Basic] Public Function HttpDeleteFile(ByVal scheme As String, ByVal remoteHost As String, ByVal remotePath As String) As Boolean
[C#] public bool HttpDeleteFile(string scheme, string remoteHost, string remotePath);

Parameters

scheme
Internet access protocol ("http" or "https")

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpDeleteFile method deletes a file from an Http server specifying the protocol scheme, the host name and remote URI.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Deletes the file
Ret = ImageKit.File.HttpDeleteFile("http", "www.newtone.co.jp", "test/test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Deletes the file
Ret = ImageKit.File.HttpDeleteFile("http", "www.newtone.co.jp", "test/test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDownloadFile Methods

This method downloads a file from an Http server.

Overload List

This method downloads a file from an Http server specifying the remote URI and a local filename.

[Visual Basic] Public Function HttpDownloadFile(String, String) As Boolean
[C#] public bool HttpDownloadFile(string, string)

This method downloads a file from an Http server specifying the remote URI and a local filename

[Visual Basic] Public Function HttpDownloadFile(System.Uri, String) As Boolean
[C#] public bool HttpDownloadFile(System.Uri, string)

This method downloads a file from an Http server specifying the potocol scheme, the host name, the remote URI, and a local filename.

[Visual Basic] Public Function HttpDownloadFile(String, String, String, String) As Boolean
[C#] public bool HttpDownloadFile(string, string, string, string)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDownloadFile Method

This method downloads a file from an Http server specifying the remote URI and a local filename

[Visual Basic] Public Function HttpDownloadFile(ByVal remoteAddress As String, ByVal localFileName As String) As Boolean
[C#] public bool HttpDownloadFile(string remoteAddress, string localFileName);

Parameters

remoteAddress
The URI of the file on the server

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpDownloadFile method downloads a file from an Http server specifying the remote URI and a local filename

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Downloads the file
Ret = ImageKit.File.HttpDownloadFile("http://www.newtone.co.jp/test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Downloads the file
Ret = ImageKit.File.HttpDownloadFile("http://www.newtone.co.jp/test/test.jpg", @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDownloadFile Method

This method downloads a file from an Http server specifying the remote URI and a local filename

[Visual Basic] Public Function HttpDownloadFile(ByVal remoteAddress As System.Uri, ByVal localFileName As String) As Boolean
[C#] public bool HttpDownloadFile(System.Uri remoteAddress, string localFileName);

Parameters

remoteAddress
The URI of the file on the server

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpDownloadFile method downloads a file from an Http server specifying the remote URI and a local filename

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Downloads the file
Ret = ImageKit.File.HttpDownloadFile(New Uri("http://www.newtone.co.jp/test/test.jpg"), "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Downloads the file
Ret = ImageKit.File.HttpDownloadFile(new Uri("http://www.newtone.co.jp/test/test.jpg"), @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpDownloadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpDownloadFile Method

This method downloads a file from an Http server specifying the potocol scheme, the host name, the remote URI, and a local filename.

[Visual Basic] Public Function HttpDownloadFile(ByVal scheme As String, ByVal remoteHost As String, ByVal remotePath As String, ByVal localFileName As String) As Boolean
[C#] public bool HttpDownloadFile(string scheme, string remoteHost, string remotePath, string localFileName);

Parameters

scheme
Internet access protocol ("http" or "https")

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

localFileName
Local file name

Return Value

Returns True if successful. Returns False if successful.

Explanation

The HttpDownloadFile method downloads a file from an Http server specifying the potocol scheme, the host name, the remote URI, and a local filename.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Downloads the file
Ret = ImageKit.File.HttpDownloadFile("http", "www.newtone.co.jp", "test/test.jpg", @"c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Downloads the file
Ret = ImageKit.File.HttpDownloadFile("http", "www.newtone.co.jp", "test/test.jpg", @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpUploadFile Method

This method uploads a file to an Http server.

Overload List

This method uploads a file to an Http server specifying the remote URI and the local filename.

[Visual Basic] Public Function HttpUploadFile(String, String) As Boolean
[C#] public bool HttpUploadFile(string, string)

This method uploads a file to an Http server specifying the remote URI and the local filename.

[Visual Basic] Public Function HttpUploadFile(System.Uri, String) As Boolean
[C#] public bool HttpUploadFile(System.Uri, string)

This method uploads a file to an Http server specifying the access protocol, the remote host, the remote URI, and the local filename.

[Visual Basic] Public Function HttpUploadFile(String, String, String, String) As Boolean
[C#] public bool HttpUploadFile(string, string, string, string)

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpUploadFile Method

This method uploads a file to an Http server specifying the remote URI and the local filename.

[Visual Basic] Public Function HttpUploadFile(ByVal remoteAddress As String, ByVal localFileName As String) As Boolean
[C#] public bool HttpUploadFile(string remoteAddress, string localFileName);

Parameters

remoteAddress
The URI where the file is to be uploaded

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpUploadFile method uploads a file to an Http server specifying the remote URI and the local filename.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Uploads the file
Ret = ImageKit.File.HttpUploadFile("http://www.newtone.co.jp/test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Uploads the file
Ret = ImageKit.File.HttpUploadFile("http://www.newtone.co.jp/test/test.jpg", @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpUploadFile Method

This method uploads a file to an Http server specifying the remote URI and the local filename.

[Visual Basic] Public Function HttpUploadFile(ByVal remoteAddress As System.Uri, ByVal localFileName As String) As Boolean
[C#] public bool HttpUploadFile(System.Uri remoteAddress, string localFileName);

Parameters

remoteAddress
The URI where the file is to be uploaded

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpUploadFile method uploads a file to an Http server specifying the remote URI and the local filename.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Uploads the file
Ret = ImageKit.File.HttpUploadFile(New Uri("http://www.newtone.co.jp/test/test.jpg"), "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Uploads the file
Ret = ImageKit.File.HttpUploadFile(new Uri("http://www.newtone.co.jp/test/test.jpg"), @"c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


HttpUploadFile method

Newtone.ImageKit.Win.ImageKit.File.HttpUploadFile Method

This method uploads a file to an Http server specifying the access protocol, the remote host, the remote URI, and the local filename.

[Visual Basic] Public Function HttpUploadFile(ByVal scheme As String, ByVal remoteHost As String, ByVal remotePath As String, ByVal localFileName As String) As Boolean
[C#] public bool HttpUploadFile(string scheme, string remoteHost, string remotePath, string localFileName);

Parameters

scheme
Internet access protocol ("http" or "https")

remoteHost
Domain name in DNS style, or IP address

remotePath
The name of the remote path

localFileName
Local file name

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The HttpUploadFile method uploads a file to an Http server specifying the access protocol, the remote host, the remote URI, and the local filename.

This method is effective for the HTTP or HTTPS protocol.

Example

[Visual Basic.NET]
Dim Ret As Boolean
'Username and password
ImageKit.File.HttpCredentials = New NetworkCredential("user", "password")
'Uploads the file
Ret = ImageKit.File.HttpUploadFile("http", "www.newtone.co.jp", "test/test.jpg", "c:\test\test.jpg")

[Visual C#.NET]
bool Ret;
//Username and password
ImageKit.File.HttpCredentials = new NetworkCredential("user", "password");
//Uploads the file
Ret = ImageKit.File.HttpUploadFile("http", "www.newtone.co.jp", "test/test.jpg", "c:\test\test.jpg");

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LoadImageFromFile method

Newtone.ImageKit.Win.ImageKit.File.LoadImageFromFile Method

This method loads image data from a file.

[Visual Basic] Public Function LoadImageFromFile(Val As Newtone.ImageKit.LoadFileType) As Boolean
[C#] public bool LoadImageFromFile(Newtone.ImageKit.LoadFileType Val) ;

Parameters

Val
The format of the image to be loaded
The value is of type Newtone.ImageKit.LoadFileType

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The LoadImageFromFile method loads image data from a file. The FileName property sets the file to be loaded. If successful, the image data is set in either the Image property or the Layer(LayerNumber).Imgae property as determined by the value set in the LayerNumber property. If the image is a multi-page image file, set the page to be loaded in the LoadPage property.

Note: Although the LoadImageFromFile method can load the primary image in an Exif(JPEG) image file, to retrieve the thumbnail image or image information, please use the GetImageFileType method. The ImageKit.NET supports Exif version 2.1

Note: Because standard .NET Framework does not support the following image formats, the ImageKit7 Dll files are required when using JPEG2000, FPX, PCX, DXF, SVG, or SXF formats.

Regarding FlashPix:

Flashpix image files are multi-resolution image files with a tiled composition. Flashpix files store image data in a hierarchy from the original image at the highest level. Each subsequent level contains the same image with horizontal and vertical resolution half that of the image in the level above. This allows editing and printing at the optimum resolution. Each resolution image is divided in to 64x64 tiles. Each tiled image can be uncompressed, JPEG compression, or single color compression.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LoadImageFromRawData method

Newtone.ImageKit.Win.ImageKit.File.LoadImageFromRawData Method

This method loads DIB image data from raw data.

[Visual Basic] Public Function LoadImageFromRawData(Val As Newtone.ImageKit.LoadFileType) As Boolean
[C#] public bool LoadImageFromRawData(Newtone.ImageKit.LoadFileType Val) ;

Parameters

Val
The format of the image to be loaded
This value is of type Newtone.ImageKit.LoadFileType

Return Value

Returns True if successful. Returns False if successful.

Explanation

The LoadImageFromRawData method uses the raw image data set into the RawData property and converts it to DIB image data. This DIB image data is then set into either the Image or the Layer(LayerNumber).Imgae property depending on the value of the LayerNumber property.

When the raw image data is a multipage image, set the page to be loaded in the LoadPage property.

Although the LoadImageFromRawData method can load the primary image in an Exif(JPEG) image file, to retrieve the thumbnail image or image information, please use the GetImageFileTypeFromRawData method. The ImageKit.NET supports Exif version 2.1

Note: Because standard .NET Framework does not support the following image formats, the ImageKit7 Dll files are required when using JPEG2000, FPX, PCX, DXF, SVG, or SXF formats.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LoadRawDataFromFile method

Newtone.ImageKit.Win.ImageKit.File.LoadRawDataFromFile Method

This method loads image data from a file without altering it (i.e. converting it to DIB data)
[Visual Basic] Public Function LoadRawDataFromFile() As Boolean
[C#] public bool LoadRawDataFromFile() ;

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The LoadRawDataFromFile method loads image data from a file without altering it. The file to be loaded is determined by the FileName property. The loaded image data is set into the RawData property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LoadRawDataFromStream method

Newtone.ImageKit.Win.ImageKit.File.LoadRawDataFromStream Method

This method loads an image from stream

[Visual Basic] Public Function LoadRawDataFromStream(Val As MemoryStream)
[C#] public void LoadRawDataFromStream(MemoryStream Val) ;

Parameters

Val
The data loaded from the MemoryStream

Return Value

None

Explanation

This method loads an image from stream. The data returned in the Val parameter is set into the RawData property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


OpenFileDialog method

Newtone.ImageKit.Win.ImageKit.File.OpenFileDialog Method

This methods displays the "Open" dialog box which includes the file preview and information functions. This dialog box is used to select an image file to be opened.

[Visual Basic] Public Function OpenFileDialog() As Boolean
[C#] public bool OpenFileDialog() ;

Parameters

None

Return Value

Returns True if "Open" is selected. Returns False if "Cancel" is selected.

Explanation

The OpenFileDialog method displays the "Open" dialog box which includes the file preview and information functions. This dialog box is used to select an image file to be opened.

If the Open button is clicked, then the file name and path are set into the FileName property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


RGBBmpPlaneFileLoad method

Newtone.ImageKit.Win.ImageKit.File.RGBBmpPlaneFileLoad Method

This method loads a bmp file that has been saved in seperate RGB planes.

[Visual Basic] Public Function RGBBmpPlaneFileLoad(RedFileName As String, GreenFileName As String, BlueFileName As String) As Boolean
[C#] public bool RGBBmpPlaneFileLoad(string RedFileName, string GreenFileName, string BlueFileName) ;

Parameters

RedFileName
The filename of the R plane image to be loaded

GreenFileName
The filename of the G plane image to be loaded

BlueFileName
The filename of the B plane image to be loaded

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBBmpPlaneFileLoad method loads a bmp file that has been saved in seperate RGB planes. The individual RGB plane images are 8 bit grayscale and the output image is 24 bit color.

If successful, the output image will be set in the Image property or the Layer(LayerNumber).Imgae property according to the value set in the LayerNumber property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


RGBBmpPlaneFileSave method

Newtone.ImageKit.Win.ImageKit.File.RGBBmpPlaneFileSave Method

This method saves a raster image into seperate RGB planes. The saved images are in BMP format.

[Visual Basic] Public Function RGBBmpPlaneFileSave(RedFileName As String, GreenFileName As String, BlueFileName As StringASaveImage As Image) As Boolean
[C#] public bool RGBBmpPlaneFileSave(string RedFileName, string GreenFileName, string BlueFileName, Image SaveImage) ;

Parameters

RedFileName
The filename of the saved R plane image

GreenFileName
The filename of the saved G plane image

BlueFileName
The filename of the saved B plane image

SaveImage
The image handle of the image to be saved in 3 seperate RGB planes

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RGBBmpPlaneFileSave method saves a raster image into seperate RGB planes. The saved images are in BMP format.

When the SaveImage parameter contains a valid image handle

The image set in the SaveImage parameter will be saved as three seperate images each corresponding to the various RGB planes.

When the SaveImage parameter contains 0

The image referred to by the LayerNumber property (either the image set in the Image property or the image set in the Layer(LayerNumber).Image property as the case may be) will be saved as three seperate images each corresponding to the various RGB planes.

Note: When the LayerNumber property is -1, the image set in the Image property is enabled. When the LayerNumber property has values from 0 to 99, the image set in the Layer(LayerNumber).Image property is enabled.

The input image (that image set in the SaveImage parameter) must be 24 bit color. The output images (corresponding to the various RGB planes) will be 8 bit grayscale.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


SaveFileDialog method

Newtone.ImageKit.Win.ImageKit.File.SaveFileDialog Method

This methods displays the "Save" dialog box which includes the file preview function. This dialog box is used to select an image file to be saved.

[Visual Basic] Public Function SaveFileDialog() As Boolean
[C#] public bool SaveFileDialog() ;

Parameters

None

Return Value

Returns True if "Save" is selected. Returns False if "Cancel" is selected.

Explanation

The SaveFile method displays the "Save" dialog box which includes the file preview function. This dialog box is used to select a directory and file name into which the image date is to be saved.

When the "Save" button is clicked the file name and path are set into the FileName property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


SaveImageToFile method

Newtone.ImageKit.Win.ImageKit.File.SaveImageToFile Method

This methods saves image data to a file.

[Visual Basic] Public Function SaveImageToFile(Val As Newtone.ImageKit.SaveFileType, SaveImage As Image) As Boolean
[C#] public bool SaveImageToFile(Newtone.ImageKit.SaveFileType Val, Image SaveImage) ;

Parameters

Val
The image format used to save the image
This value is of type Newtone.ImageKit.SaveFileType

SaveImage
The saved image

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SaveImageToFile method saves image data to a file.

When the SaveImage parameter contains a valid image handle

The image set in the SaveImage parameter will be saved in the location specified by the FileName property.

When the SaveImage parameter contains 0

The image referred to by the LayerNumber property (either the image set in the Image property or the image set in the Layer(LayerNumber).Image property as the case may be) will be saved in the location specified by the FileName property.

Note: When the LayerNumber property is -1, the image set in the Image property is enabled. When the LayerNumber property has values from 0 to 99, the image set in the Layer(LayerNumber).Image property is enabled.

Below is a list of other properties that should be set when saving files in the these formats...

Format | Explanation
FPX | The Comment property should be set. If the Val parameter is SaveFPXJpeg then the JpegQuality property should also be set.
GIFAnimation | The Comment, GifAnimation, GifAnimationDelay, Interlace, TransparentBlue, TransparentGreen, TransparentRed, and Transparent properties should be set.
JPEG | The Comment, JpegQuality, and JpegSubsampling properties should be set.
JPEG Progress | The Comment, JpegQuality, and JpegSubsampling properties should be set.
JPEG2000 | The Comment, JPEG2000CodeBlockHeight, JPEG2000CodeBlockWidth, JPEG2000NumResLevel, JPEG2000PrecinctHeight, JPEG2000PrecinctWidth, JPEG2000Reversible, JPEG2000Size, JPEG2000TileHeight, and JPEG2000TileWidth properties should be set.
PNG | The Comment, Interlace, TransparentBlue, TransparentGreen, TransparentRed, PngAlphaChannel, and Transparent properties should be set. When the PngAlphaChannel property is True, pass the image handle of the 32 bit RGBA image to the SaveImage parameter.
TIFF | The TiffAppend property should be set. After the image has been saved, please execute the CloseMultiTiff method. If the Val parameter is SaveTIFFNoncompressed, SaveTIFFPackbits, or SaveTIFFLZW then the TiffColorSpace property should be set. For all Tiff images other than GROUP4 (i.e. if the Val parameter is Group3-2D or CCITTRLE), the Comment and TiffSaveOneStrip properties should be set.

In order to save vector image data as raster image data, the Vector.VectorToRaster method must be executed PRIOR to executing the SaveImageToFile method. In other words, the vector image data must be converted to DIB image data before it can be saved in a raster image format.

With certain raster image formats, it is only possible to save images of a particular bitcount. Errors can be generated if an image of unsupported bitcount is saved. Below is a list of supported bitcounts when saving each type of raster image.

Name | Explanation
BMP (Uncompressed) | 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
BMP (Compressed) | 4,8
JPEG (Standard DCT) | 8 bit grayscale, 24 Note: When the ImageKit7 Dll files are present, 8 bit grayscale and 24 bit color images can be saved in JPEG. Attempting to save images of other bitcounts will result in an error. If the ImageKit7 Dll files are not present, all images will be converted to 24 bit color and saved in JPEG.
JPEG (Progressive DCT) | 8 bit grayscale, 24
GIF | 1, 4, 8 Note: If the ImageKit7 Dll files are not present, all images will be saved in 8 bit GIF
TIFF (Uncompressed) | 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
TIFF (CCITTRLE) | 1
TIFF (GROUP3-1D) | 1
TIF (iGROUP3-2D) | 1
TIFF (GROUP4) | 1
TIFF (PACKBITS) | 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale) Note: The ImageKit7 Dll files must be present to save in bitcounts other than 1 bit
TIFF (LZW) | 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
PNG | 1,4,8,24
FPX (Uncompressed) | 8 bit grayscale, 24
FPX (Single Color Compressed) | 8 bit grayscale, 24
FPX (JPEG Compression) | 8 bit grayscale, 24
PCX | 1,4,8,24
JPEG2000 (Part1) | 8 bit grayscale, 24
JPEG2000 (Code Stream) | 8 bit grayscale, 24

Note: TIFF GROUP3-1D is the same as MH. TIFF GROUP3-2D is the same as MR. TIFF GROUP4 is the same as MMR. If images are saved in uncompressed TIFF, TIFF PACKBITS, or TIFF LZW formats as 16 bit images, they will be converted to 24 bit.

The following image formats are not supported by standard .NET Framework. Therefore, the ImageKit7 Dll files are required when saving images in: BMP Compressed, JpegProgressive, GifAnimation, TIFF CCITTRLE, TIFFGroup3_2D, JPEG2000, FPX, PCX, WMF, EMF, DXF, SVG, or SXF file formats.

WMF and EMF images cannot be read and displayed in standard .NET framework but rather are converted to raster image data and displayed. As such, even though the file extensions are .wmf or .emf, these images can only be saved as raster images.

Example

Sample code for converting a BMP image file into a 24 bit JPEG image file:

[Visual Basic.NET]
ImageKit1.File.FileName = "Newtone.bmp"
If ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.LoadBMP) = False Then Exit Sub
If ImageKit1.GetImageType() = False Then Exit Sub
If ImageKit1.BitCount <> 24 Then
If ImageKit1.Effect.ConvertColor(24, False, False, 0) = False Then Exit Sub
End If

ImageKit1.File.FileName = "Newtone.jpg"
ImageKit1.File.SaveImageToFile(Newtone.ImageKit.SaveFileType.SaveJPEG, Nothing)

[Visual C#.NET]
ImageKit1.File.FileName = "Newtone.bmp";
if (!ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.LoadBMP)) return;
if (!ImageKit1.GetImageType()) return;
if (ImageKit1.BitCount <> 24))
{
    if (!ImageKit1.Effect.ConvertColor(24, false, false, 0)) return;
}

ImageKit1.File.FileName = "Newtone.jpg";
ImageKit1.File.SaveImageToFile(Newtone.ImageKit.SaveFileType.SaveJPEG, null);

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


SaveImageToRawData method

Newtone.ImageKit.Win.ImageKit.File.SaveImageToRawData Method

This method saves image data as raw data.

[Visual Basic] Public Function SaveImageToRawData(Val As Newtone.ImageKit.SaveFileType, SaveImage As Image) As Boolean
[C#] public bool SaveImageToRawData(Newtone.ImageKit.SaveFileType Val, Image SaveImage) ;

Parameters

Val
The image format used to save the image
This value is of type Newtone.ImageKit.SaveFileType

SaveImage
The saved image

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SaveImageToRawData method saves image data as raw data.

When the SaveImage parameter contains a valid image handle

The image set in the SaveImage parameter will be saved as raw data and set into the RawData property.

When the SaveImage parameter contains 0

The image referred to by the LayerNumber property (either the image set in the Image property or the image set in the Layer(LayerNumber).Image property as the case may be) will be saved as raw data and set into the RawData property.

Note: When the LayerNumber property is -1, the image set in the Image property is enabled. When the LayerNumber property has values from 0 to 99, the image set in the Layer(LayerNumber).Image property is enabled.

Below is a list of other properties that should be set when saving files in the these formats...

Format | Explanation
FPX | The Comment property should be set. If the Val parameter is SaveFPXJpeg then the JpegQuality property should also be set.
GIFAnimation | The Comment, GifAnimation, GifAnimationDelay, Interlace, TransparentBlue, TransparentGreen, TransparentRed, and Transparent properties should be set.
JPEG | The Comment, JpegQuality, and JpegSubsampling properties should be set.
JPEG Progress | The Comment, JpegQuality, and JpegSubsampling properties should be set.
JPEG2000 | The Comment, JPEG2000CodeBlockHeight, JPEG2000CodeBlockWidth, JPEG2000NumResLevel, JPEG2000PrecinctHeight, JPEG2000PrecinctWidth, JPEG2000Reversible, JPEG2000Size, JPEG2000TileHeight, and JPEG2000TileWidth properties should be set.
PNG | The Comment, Interlace, TransBlue, TransparentGreen, TransparentRed, PngAlphaChannel, and Transparent properties should be set. When the PngAlphaChannel property is True, pass the image handle of the 32 bit RGBA image to the SaveImage parameter.
TIFF | The TiffAppend property should be set. If the Val parameter is SaveTIFFNoncompressed, SaveTIFFPackbits, or SaveTIFFLZW then the TiffColorSpace property should be set. For all Tiff images other than GROUP4 (i.e. if the Val parameter is Group3-2D or CCITTRLE), the Comment and TiffSaveOneStrip properties should be set.

In order to save vector image data as raster image data, the Vector.VectorToRaster method must be executed PRIOR to executing the SaveImageToFile method. In other words, the vector image data must be converted to DIB image data before it can be saved in a raster image format.

Though there are differences when saving raw image data, the process is nearly the same as the SaveImageToFile method.

With certain raster image formats, it is only possible to save images of a particular bitcount. Errors can be generated if an image of unsupported bitcount is saved. Below is a list of supported bitcounts when saving each type of raster image.

Name | Explanation
BMP (Uncompressed) | 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
BMP (Compressed) | 4, 8
JPEG (Standard DCT) | 8 bit grayscale, 24 bit color. Note: When the ImageKit7 Dll files are present, 8 bit grayscale and 24 bit color images can be saved in JPEG. Attempting to save images of other bitcounts will result in an error. If the ImageKit7 Dll files are not present, all images will be converted to 24 bit color and saved in JPEG.
JPEG (Progressive DCT) | 8 bit grayscale, 24
GIF | 1, 4, 8 Note: If the ImageKit7 Dll files are not present, all images will be saved in 8 bit GIF
TIFF (Uncompressed) | 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
TIFF (CCITTRLE) | 1
TIFF (GROUP3-1D) | 1
TIFF (GROUP3-2D) | 1
TIFF (GROUP4) | 1
TIFF (PACKBITS) | 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale) Note: The ImageKit7 Dll files must be present to save in bitcounts other than 1 bit
TIFF (LZW) | 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
PNG | 1,4,8,24
FPX (Uncompressed) | 8 bit grayscale, 24
FPX (Single Color Compressed) | 8 bit grayscale, 24
FPX (JPEG Compression) | 8 bit grayscale, 24
PCX | 1, 4, 8, 24
JPEG2000 (Part1) | 8 bit grayscale, 24
JPEG2000 (Code Stream) | 8 bit grayscale, 24

Note: TIFF GROUP3-1D is the same as MH. TIFF GROUP3-2D is the same as MR. TIFF GROUP4 is the same as MMR. If images are saved in uncompressed TIFF, TIFF PACKBITS, or TIFF LZW formats as 16 bit images, they will be converted to 24 bit.

The following image formats are not supported by standard .NET Framework. Therefore, the ImageKit7 Dll files are required when saving images in: BMP Compressed, JpegProgressive, GifAnimation, TIFF CCITTRLE, TIFFGroup3_2D, JPEG2000, FPX, PCX, WMF, EMF, DXF, SVG, or SXF file formats.

WMF and EMF images cannot be read and displayed in standard .NET framework but rather are converted to raster image data and displayed. As such, even though the file extensions are .wmf or .emf, these images can only be saved as raster images.

Example

Sample code for converting a BMP image file into a 24 bit JPEG image file:

[Visual Basic.NET]
ImageKit1.File.FileName = "Newtone.bmp"
If ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.LoadBMP) = False Then Exit Sub
If ImageKit1.GetImageType() = False Then Exit Sub
If ImageKit1.BitCount <> 24 Then
If ImageKit1.Effect.ConvertColor(24, False, False, 0) = False Then Exit Sub
End If

ImageKit1.File.FileName = "Newtone.jpg"
ImageKit1.File.SaveImageToRawData(Newtone.ImageKit.SaveFileType.SaveJPEG, Nothing)

[Visual C#.NET]
ImageKit1.File.FileName = "Newtone.bmp";
if (!ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.LoadBMP)) return;
if (!ImageKit1.GetImageType()) return;
if (ImageKit1.BitCount <> 24))
{
  if (!ImageKit1.Effect.ConvertColor(24, false, false, 0)) return;
}

ImageKit1.File.FileName = "Newtone.jpg";
ImageKit1.File.SaveImageToRawData(Newtone.ImageKit.SaveJPEG, null);

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


SaveRawDataToFile method

Newtone.ImageKit.Win.ImageKit.File.SaveRawDataToFile Method

This methods saves raw data to a file.

[Visual Basic] Public Function SaveRawDataToFile() As Boolean
[C#] public bool SaveRawDataToFile() ;

Parameters

None

Return Value

Returns True if successful. Returns False if successful.

Explanation

The SaveRawDataToFile method saves raw data to a file. The raw data set in the RawData property is saved to a file set in the FileName property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


SaveRawDataToStream method

Newtone.ImageKit.Win.ImageKit.File.SaveRawDataToStream Method

This method saves the raw image data to stream.
[Visual Basic] Public Function SaveRawDataToStream() As MemoryStream
[C#] public MemoryStream SaveRawDataToStream() ;

Parameters

None

Return Value

Returns the content of the RawData property in a memory stream

Explanation

The SaveRawDataToStream method saves the raw image data to stream.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


YCCBmpPlaneFileLoad method

Newtone.ImageKit.Win.ImageKit.File.YCCBmpPlaneFileLoad Method

This method loads a bmp file that has been saved in seperate YCrCb planes.

[Visual Basic] Public Function YCCBmpPlaneFileLoad(YFileName As String, CrFileName As String, CbFileName As String) As Boolean
[C#] public bool YCCBmpPlaneFileLoad(string YFileName, string CrFileName, string CbFileName) ;

Parameters

YFileName
The filename of the Y plane image to be loaded

CrFileName
The filename of the Cr plane image to be loaded

CbFileName
The filename of the Cb plane image to be loaded

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCBmpPlaneFileLoad method loads a bmp file that has been saved in seperate YCrCb planes. The individual YCrCb plane images are 8 bit grayscale and the output image is 24 bit color.

If successful, the output image will be set in the Image property or the Layer(LayerNumber).Image property according to the value set in the LayerNumber property.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


YCCBmpPlaneFileSave method

Newtone.ImageKit.Win.ImageKit.File.YCCBmpPlaneFileSave Method

This method saves a raster image into seperate YCrCb planes. The saved images are in BMP format.

[Visual Basic] Public Function YCCBmpPlaneFileSave(YFileName As String, CrFileName As String, CbFileName As String, SaveImage As Image) As Boolean
[C#] public bool YCCBmpPlaneFileSave(string YFileName, string CrFileName, string CbFileName, Image SaveImage) ;

Parameters

YFileName
The filename of the saved Y plane image

CrFileName
The filename of the saved Cr plane image

CbFileName
The filename of the saved Cb plane image

SaveImage
The image handle of the image to be saved in 4 seperate YCrCb planes

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The YCCBmpPlaneFileSave method saves a raster image into seperate YCrCb planes. The saved images are in BMP format.

When the SaveImage parameter contains a valid image handle

The image set in the SaveImage parameter will be saved as three seperate images each corresponding to the various YCrCb planes.

When the SaveImage parameter contains 0

The image referred to by the LayerNumber property (either the image set in the Image property or the image set in the Layer(LayerNumber).Image property as the case may be) will be saved as three seperate images each corresponding to the various YCrCb planes.

Note: When the LayerNumber property is -1, the image set in the Image property is enabled. When the LayerNumber property has values from 0 to 99, the image set in the Layer(LayerNumber).Image property is enabled.

The input image (that image set in the SaveImage parameter) must be 24 bit color. The output images (corresponding to the various YCrCb planes) will be 8 bit grayscale.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


ImageKit.File Members

Newtone.ImageKit.Win.ImageKit.File.Exif All Members

Public Properties

Altitude0 | The altitude in meters where the image was taken. This is the numerator.
Altitude1 | The altitude in meters where the image was taken. This is the denominator.
ApertureValue0 | The numerator for the lens aperature value
ApertureValue1 | The denominator for the lens aperature value
BrightnessValue0 | The numerator for the brightness value
BrightnessValue1 | The denominator for the brightness value
ColorSpace | Color space information
ComponentsConfiguration | Refers to the color of each color plane in the Exif image arranged in order from the 1st plane to the 4th plane
CompressedBitsPerPixel0 | The numerator for the compression mode used for a compressed image. (bits/pixel)
CompressedBitsPerPixel1 | The denominator for the compression mode used for a compressed image. (bits/pixel)
DateTimeDigitized | The date and time of digital data generation
DateTimeOriginal | The date and time of original data generation
ExposureBiasValue0 | The numerator for the exposure bias value
ExposureBiasValue1 | The denominator for the exposure bias value
ExposureIndex0 | The numerator for the exposure index selected on the camera or input device at the time the image was captured
ExposureIndex1 | The denominator for the exposure index selected on the camera or input device at the time the image was captured
ExposureProgram | Refers to the class of the program used by the camera to set exposure when the image was taken
ExposureTime0 | The numerator for the exposure time
ExposureTime1 | The denominator for the exposure time
FileSource | Indicates the image source
Flash | Indicates the flash firing status and the flash return status
FlashEnergy0 | The numerator for the strobe energy at the time the image was captured
FlashEnergy1 | The denominator for the strobe energy at the time the image was captured
FlashPixVersion | Refers to the version of the FlashPix format supported
FNumber0 | The numerator for the F number value
FNumber1 | The denominator for the F number value
FocalLength0 | The numerator for the focal length of the lens
FocalLength1 | The denominator for the focal length of the lens
FocalPlaneResolutionUnit | The units of measurement of the focal plane
FocalPlaneXResolution0 | The numerator of the horizontal focal plane resolution
FocalPlaneXResolution1 | The denominator of the horizontal focal plane resolution
FocalPlaneYResolution0 | The numerator of the vertical focal plane resolution
FocalPlaneYResolution1 | The denominator of the vertical focal plane resolution
GPSVersion | Refers to the GPS tag version (i.e. "2000")
ISOSpeedRatings | Indicates the ISO Speed and ISO Latitude of the camera or input device
Latitude | Refers to the latitude direction where the image was taken. (i.e. "N" or "S")
LatitudeD0 | The latitude in degrees where the image was taken. This is the numerator
LatitudeD1 | The latitude in degrees where the image was taken. This is the denominator
LatitudeM0 | The latitude in minutes where the image was taken. This is the numerator
LatitudeM1 | The latitude in minutes where the image was taken. This is the denominator
LatitudeS0 | The latitude in seconds where the image was taken. This is the numerator
LatitudeS1 | The latitude in seconds where the image was taken. This is the denominator
LightSource | Refers to the type of light source
Longitude | Refers to the longitude direction where the image was taken. (i.e. "E" or "W")
LongitudeD0 | The longitude in degrees where the image was taken. This is the numerator
LongitudeD1 | The longitude in degrees where the image was taken. This is the denominator
LongitudeM0 | The longitude in minutes where the image was taken. This is the numerator
LongitudeM1 | The longitude in minutes where the image was taken. This is the denominator
LongitudeS0 | The longitude in seconds where the image was taken. This is the numerator
LongitudeS1 | The longitude in seconds where the image was taken. This is the denominator
MainArtist | Refers to the camera owner, photographer, or creator of the primary image
MainCopyright | Refers to the copyright information for the primary image
MainDateTime | Refers to the date and time that the primary image was created
MainImageDescription | Refers to the character string giving the title of the primary image
MainMake | Refers to the manufacturer of the recording equipment that generated the primary image
MainModel | Refers to the model name or model number of the equipment that generated the primary image
MainOrientation | Refers to the image orientation of the primary image as viewed in terms of rows and columns
MainResolutionUnit | The unit of measurement for XResolution and YResolution in the primary image
MainSoftware | Refers to the name and version of the software used to generate the primary image
MainXResolution0 | Refers to the number of pixels per MainResolutionUnit in the primary image in the horizontal direction. (This value is the numerator)
MainXResolution1 | Refers to the number of pixels per MainResolutionUnit in the primary image in the horizontal direction. (This value is the denominator)
MainYCbCrPositioning | Refers to the position of chrominance components (CbCr) in relation to the luminance component (Y) in the primary image
MainYResolution0 | Refers to the number of pixels per MainResolutionUnit in the primary image in the vertical direction. (This value is the numerator)
MainYResolution1 | Refers to the number of pixels per MainResolutionUnit in the primary image in the vertical direction. (This value is the denominator)
MakerNote | Comments of the manufacturer of the Exif writer
MapDatum | Refers to the name of the map data used
MaxApertureValue0 | The numerator for the smallest F value of the lens
MaxApertureValue1 | The denominator for the smallest F value of the lens
MeteringMode | Refers to the metering mode
PixelXDimension | Refers to the width of the image
PixelYDimension | Refers to the height of the image
SceneType | Indicates the type of scene
SensingMethod | Refers to the image sensor type on the camera or input device
ShutterSpeedValue0 | The numerator for the shutter speed
ShutterSpeedValue1 | The denominator for the shutter speed
SpectralSensitivity | Refers to the spectral sensitivity of each channel of the camera used
SubjectDistance0 | The numerator for the distance to the subject
SubjectDistance1 | The denominator for the distance to the subject
SubjectLocationX | Refers to the horizontal location of the main subject in the scene
SubjectLocationY | Refers to the vertical location of the main subject in the scene
SubSecTime | Records fractions of a second for the MainDateTime property
SubSecTimeDigitized | Records fractions of a second for the DateTimeDigitized property
SubSecTimeOriginal | Records fractions of a second for the DateTimeOriginal property
ThumbnailArtist | Refers to the camera owner, photographer, or creator of the thumbnail image
ThumbnailCompression | Refers to the compression method for the thumbnail image
ThumbnailCopyright | Refers to the copyright information for the thumbnail image
ThumbnailDateTime | Refers to the date and time that the thumbnail image was created
ThumbnailImageDescription | Refers to the character string giving the title of the thumbnail image
ThumbnailMake | Refers to the manufacturer of the recording equipment that generated the thumbnail image
ThumbnailModel | Refers to the model name or model number of the equipment that generated the thumbnail image
ThumbnailOrientation | Refers to the image orientation of the thumbnail image as viewed in terms of rows and columns
ThumbnailResolutionUnit | The unit of measurement for XResolution and YResolution in the thumbnail image
ThumbnailSoftware | Refers to the name and version of the software used to generate the thumbnail image
ThumbnailXResolution0 | Refers to the number of pixels per ThumbResolutionUnit in the thumbnail image in the horizontal direction. (This value is the numerator)
ThumbnailXResolution1 | Refers to the number of pixels per ThumbResolutionUnit in the thumbnail image in the horizontal direction. (This value is the denominator)
ThumbnailYCbCrPositioning | Refers to the position of chrominance components (CbCr) in relation to the luminance component (Y) in the thumbnail image
ThumbnailYResolution0 | Refers to the number of pixels per ThumbResolutionUnit in the thumbnail image in the vertical direction. (This value is the numerator)
ThumbnailYResolution1 | Refers to the number of pixels per ThumbResolutionUnit in the thumbnail image in the vertical direction. (This value is the denominator)
UserComment | Comments or keywords that the Exif user can place on the image
UserCommentID | An identification code (8 bytes) that occurs at the start of the UserComment tag
Version | Refers to the version of the Exif Standard supported

See Also

Newtone.ImageKit.Win.ImageKit


Altitude0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.Altitude0 Property

The altitude in meters where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property Altitude0 As Integer
[C#] public int Altitude0 {get;}

Property Value

Altitude0 is the numerator for altitude in meters

Altitude1 is the denominator for altitude in meters

Altitude = Altitude0 / Altitude1

Explanation

The Altitude0 property refers to the altitude in meters where the image was taken. This is the numerator. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property is related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


Altitude1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.Altitude1 Property

The altitude in meters where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property Altitude1 As Integer
[C#] public int Altitude1 {get;}

Property Value

Altitude0 is the numerator for altitude in meters

Altitude1 is the denominator for altitude in meters

Altitude = Altitude0 / Altitude1

Explanation

The Altitude1 property refers to the altitude in meters where the image was taken. This is the denominator. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property is related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ApertureValue0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ApertureValue0 Property

The property value can be retrieved by executing the File.GetImageFileType or theFile.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ApertureValue0 As Integer
[C#] public int ApertureValue0 {get;}

Property Value

ApertureValue0 is the numerator for the lens aperature value
ApertureValue1 is the denominator for the lens aperature value
The lens aperature value (unit is the APEX value) = ApertureValue0 / ApertureValue1

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ApertureValue1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ApertureValue1 Property

The property value can be retrieved by executing the File.GetImageFileType or theFile.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ApertureValue1 As Integer
[C#] public int ApertureValue1 {get;}

Property Value

ApertureValue0 is the numerator for the lens aperature value

ApertureValue1 is the denominator for the lens aperature value

The lens aperature value (unit is the APEX value) = ApertureValue0 / ApertureValue1

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


BrightnessValue0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.BrightnessValue0 Property

This property refers to the brightness value. This is the numerator.

[Visual Basic] Public ReadOnly Property BrightnessValue0 As Integer
[C#] public int BrightnessValue0 {get;}

Property Value

BrightnessValue0 is the numerator for the brightness value

BrightnessValue1 is the denominator for the brightness value

The brightness value (unit is the APEX value) = BrightnessValue0 / BrightnessValue1

Ordinarily brightness is given in the range from -99.99 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


BrightnessValue1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.BrightnessValue1 Property

This property refers to the brightness value. This is the denominator.

[Visual Basic] Public ReadOnly Property BrightnessValue1 As Integer
[C#] public int BrightnessValue1 {get;}

Property Value

BrightnessValue0 is the numerator for the brightness value

BrightnessValue1 is the denominator for the brightness value

The brightness value (unit is the APEX value) = BrightnessValue0 / BrightnessValue1

Ordinarily brightness is given in the range from -99.99 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ColorSpace property

Newtone.ImageKit.Win.ImageKit.File.Exif.ColorSpace Property

This property refers to the color space information in the Exif image.

[Visual Basic] Public ReadOnly Property ColorSpace As Integer
[C#] public int ColorSpace {get;}

Property Value

Value | Explanation
1 | sRGB

Explanation

The ColorSpace property refers to the color space information in the Exif image.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the special characteristics of the image.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ComponentsConfiguration property

Newtone.ImageKit.Win.ImageKit.File.Exif.ComponentsConfiguration Property

This property refers to the color of each color plane in the Exif image arranged in order from the 1st plane to the 4th plane.

[Visual Basic] Public ReadOnly Property ComponentsConfiguration As String
[C#] public string ComponentsConfiguration {get;}

Property Value

Value | Explanation
0 | does not exist
1 | Y
2 | Cb
3 | Cr
4 | R
5 | G
6 | B

The default value for RGB is "4560" , for JPEG is "1230".

Explanation

The ComponentsConfiguration property refers to the color of each color plane in the Exif image arranged in order from the 1st plane to the 4th plane.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the image color planes. This tag is provided for cases when image data uses planes other than Y,Cr,Cb and to enable support of other sequences.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


CompressedBitsPerPixel0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.CompressedBitsPerPixel0 Property

This property refers to the compression mode used for a compressed Exif image. This is the numerator.

[Visual Basic] Public ReadOnly Property CompressedBitsPerPixel0 As Integer
[C#] public int CompressedBitsPerPixel0 {get;}

Property Value

CompressedBitsPerPixel0 is the numerator for the compression mode

CompressedBitsPerPixel1 is the denominator for the compression mode

The compression mode = CompressedBitsPerPixel0 / CompressedBitsPerPixel1 (bit/pixel units)

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property refers to the compression mode used for a compressed Exif image.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


CompressedBitsPerPixel1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.CompressedBitsPerPixel1 Property

This property refers to the compression mode used for a compressed Exif image. This is the denominator.

[Visual Basic] Public ReadOnly Property CompressedBitsPerPixel1 As Integer
[C#] public int CompressedBitsPerPixel1 {get;}

Property Value

CompressedBitsPerPixel0 is the numerator for the compression mode

CompressedBitsPerPixel1 is the denominator for the compression mode

The compression mode = CompressedBitsPerPixel0 / CompressedBitsPerPixel1 (bit/pixel units)

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property refers to the compression mode used for a compressed Exif image.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


DateTimeDigitized property

Newtone.ImageKit.Win.ImageKit.File.Exif.DateTimeDigitized Property

This property refers to the time when the image data was stored as digital data.

[Visual Basic] Public ReadOnly Property DateTimeDigitized As String
[C#] public string DateTimeDigitized {get;}

Property Value

DateTimeDigitized is the date and time when the image was stored as digital data.

The format is "YYYY:MM:DD HH:MM:SS" with the time shown in 24 hour format, and the date and time separated by one blank character.

Example: "1996:09:01 09:15:30"

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the date and time.

the DateTimeDigitized and the DateTimeOriginal properties refer to the time when the original image data was generated and when this data was stored as digital data. If, for example, an image was captured by a DSC (Digital Still Camera) and at the same the the file was recorded, then the DateTimeDigitized and the DateTimeOriginal will have the same contents.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


DateTimeOriginal property

Newtone.ImageKit.Win.ImageKit.File.Exif.DateTimeOriginal Property

This property refers to the time when the original image data was generated.

[Visual Basic] Public ReadOnly Property DateTimeOriginal As String
[C#] public string DateTimeOriginal {get;}

Property Value

DateTimeOriginal is the data and time when the original image data was generated.

The format is "YYYY:MM:DD HH:MM:SS" with the time shown in 24 hour format, and the date and time separated by one blank character.

Example: "1996:09:01 09:15:30"

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the date and time.

The DateTimeDigitized and the DateTimeOriginal properties refer to the time when the original image data was generated and when this data was stored as digital data. If, for example, an image was captured by a DSC (Digital Still Camera) and at the same the the file was recorded, then the DateTimeDigitized and the DateTimeOriginal will have the same contents.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ExposureBiasValue0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ExposureBiasValue0 Property

This property relates to the exposure bias. This is the numerator.

[Visual Basic] Public ReadOnly Property ExposureBiasValue0 As Integer
[C#] public int ExposureBiasValue0 {get;}

Property Value

ExposureBiasValue0 is the numerator for the exposure bias value

ExposureBiasValue1 is the denominator for the exposure bias value

The exposure bias value (unit is the APEX value) = ExposureBiasValue0 / ExposureBiasValue1

Ordinarily exposure bias is given in the range from -99.99 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ExposureBiasValue1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ExposureBiasValue1 Property

This property relates to the exposure bias. This is the denominator.

[Visual Basic] Public ReadOnly Property ExposureBiasValue1 As Integer
[C#] public int ExposureBiasValue1 {get;}

Property Value

ExposureBiasValue0 is the numerator for the exposure bias value

ExposureBiasValue1 is the denominator for the exposure bias value

The exposure bias value (unit is the APEX value) = ExposureBiasValue0 / ExposureBiasValue1

Ordinarily exposure bias is given in the range from -99.99 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ExposureIndex0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ExposureIndex0 Property

This property relates to the exposure index selected on the camera or input device at the time the image was captured. This is the numerator.

[Visual Basic] Public ReadOnly Property ExposureIndex0 As Integer
[C#] public int ExposureIndex0 {get;}

Property Value

ExposureIndex0 is the numerator for the exposure index.

ExposureIndex1 is the denominator for the exposure index.

The exposure index = ExposureIndex0 / ExposureIndex1. This indicates the exposure index selected on the camera or input device at the time the image was captured.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ExposureIndex1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ExposureIndex1 Property

This property relates to the exposure index selected on the camera or input device at the time the image was captured. This is the denominator.

[Visual Basic] Public ReadOnly Property ExposureIndex1 As Integer
[C#] public int ExposureIndex1 {get;}

Property Value

ExposureIndex0 is the numerator for the exposure index.

ExposureIndex1 is the denominator for the exposure index.

The exposure index = ExposureIndex0 / ExposureIndex1. This indicates the exposure index selected on the camera or input device at the time the image was captured.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ExposureProgram property

Newtone.ImageKit.Win.ImageKit.File.Exif.ExposureProgram Property

This property refers to the class of the program used by the camera to set exposure when the image was taken.

[Visual Basic] Public ReadOnly Property ExposureProgram As Integer
[C#] public int ExposureProgram {get;}

Property Value

Value | Explanation
0 | Not defined
1 | Manual
2 | Normal program
3 | Aperture priority
4 | Shutter priority
5 | Creative program (biased toward depth of field)
6 | Action program (biased toward fast shutter speed)
7 | Portrait mode (for clsoeup photos with the background out of focus)
8 | Landscape mode (for landscapes with the background in focus

Explanation

The ExposureProgram property refers to the class of the program used by the camera to set exposure when the image was taken.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ExposureTime0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ExposureTime0 Property

This property is the numerator for the exposure time.

[Visual Basic] Public ReadOnly Property ExposureTime0 As Integer
[C#] public int ExposureTime0 {get;}

Property Value

ExposureTime0 is the numerator for the exposure time.

ExposureTime1 is the denominator for the exposure time.

Exposure time (in seconds) = ExposureTime0 / ExposureTime1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ExposureTime1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ExposureTime1 Property

This property is the denominator for the exposure time.

[Visual Basic] Public ReadOnly Property ExposureTime1 As Integer
[C#] public int ExposureTime1 {get;}

Property Value

ExposureTime0 is the numerator for the exposure time.

ExposureTime1 is the denominator for the exposure time.

Exposure time (in seconds) = ExposureTime0 / ExposureTime1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FileSource property

Newtone.ImageKit.Win.ImageKit.File.Exif.FileSource Property

This property refers to the image source.

[Visual Basic] Public ReadOnly Property FileSource As Integer
[C#] public int FileSource {get;}

Property Value

FileSource indicates the image source. If a DSC (Digital Still Camera) recorded the image, this value will be set to 3 indicating that the image was recorded on a DSC.

Explanation

The FileSource property refers to the image source.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


Flash property

Newtone.ImageKit.Win.ImageKit.File.Exif.Flash Property

This property indicates the flash firing status and the flash return status.

[Visual Basic] Public ReadOnly Property Flash As Integer
[C#] public int Flash {get;}

Property Value

This property value is recorded when the image is taken with a strobe light (flash).

Bit 0 indicates the flash firing status, and bits 1 and 2 indicate the flash return status.

Values for bit 0 indicate whether the flash fired.

0b = Flash did not fire

1b = Flash fired

Values for bits 1 and 2 indicate the return status

00b = No strobe return detection function

01b = Reserved

10b = Strobe return light not detected

11b = Strobe return light detected

Resulting flash tag values (in hexadecimal notation)

0x0000 = Flash did not fire

0x0001 = Flash fired

0x0005 = Strobe return light not detected

0x0007 = Strobe return light detected

* In Visual Basic an &H is used instead of 0x.

Explanation

The Flash property indicates the flash firing status and the flash return status.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FlashEnergy0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FlashEnergy0 Property

This property is the numerator for the strobe energy at the time the image was captured.

[Visual Basic] Public ReadOnly Property FlashEnergy0 As Integer
[C#] public int FlashEnergy0 {get;}

Property Value

FlashEnergy0 is the numerator for the flash energy.

FlashEnergy1 is the denominator for the flash energy.

Flash energy (in BCPS) = FlashEnergy0 / FlashEnergy1. This indicates the strobe energy at the time the image was captured as measured in Beam Candle Power Seconds.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FlashEnergy1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FlashEnergy1 Property

This property is the denominator for the strobe energy at the time the image was captured.

[Visual Basic] Public ReadOnly Property FlashEnergy1 As Integer
[C#] public int FlashEnergy1 {get;}

Property Value

FlashEnergy0 is the numerator for the flash energy.

FlashEnergy1 is the denominator for the flash energy.

Flash energy (in BCPS) = FlashEnergy0 / FlashEnergy1. This indicates the strobe energy at the time the image was captured as measured in Beam Candle Power Seconds.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FlashPixVersion property

Newtone.ImageKit.Win.ImageKit.File.Exif.FlashPixVersion Property

This property refers to the version of the FlashPix format supported. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FlashPixVersion As String
[C#] public string FlashPixVersion {get;}

Property Value

FlashPixVersion is the FlashPix format version supported by a FPRX file (i.e. "1000").

Explanation

The FlashPixVersion property refers to the version of the FlashPix format supported. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif version.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FNumber0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FNumber0 Property

This property is the numerator for the F number value.

[Visual Basic] Public ReadOnly Property FNumber0 As Integer
[C#] public int FNumber0 {get;}

Property Value

FNumber0 is the numerator for the FNumber

FNumber1 is the denominator for the FNumber

The FNumber = FNumber0 / FNumber1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeMem methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FNumber1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FNumber1 Property

This property is the denominator for the F number value.

[Visual Basic] Public ReadOnly Property FNumber1 As Integer
[C#] public int FNumber1 {get;}

Property Value

FNumber0 is the numerator for the FNumber

FNumber1 is the denominator for the FNumber

The FNumber = FNumber0 / FNumber1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeMem methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FocalLength0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FocalLength0 Property

This property is the numerator for the focal length of the lens.

[Visual Basic] Public ReadOnly Property FocalLength0 As Integer
[C#] public int FocalLength0 {get;}

Property Value

FocalLength0 is the numerator for the focal length of the lens

FocalLength1 is the denominator for the focal length of the lens

The actual focal length of the lens (in mm) = FocalLength0 / FocalLength1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FocalLength1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FocalLength1 Property

This property is the numerator for the focal length of the lens.

[Visual Basic] Public ReadOnly Property FocalLength1 As Integer
[C#] public int FocalLength1 {get;}

Property Value

FocalLength0 is the numerator for the focal length of the lens

FocalLength1 is the denominator for the focal length of the lens

The actual focal length of the lens (in mm) = FocalLength0 / FocalLength1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FocalPlaneResolutionUnit property

Newtone.ImageKit.Win.ImageKit.File.Exif.FocalPlaneResolutionUnit Property

This property refers to the units of measurement for focal plane resolution in the primary and thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property FocalPlaneResolutionUnit As Integer
[C#] public int FocalPlaneResolutionUnit {get;}

Property Value

The FocalPlaneResolutionUnit is the unit of measurement for FocalPlaneXResolution and FocalPlaneYResolution.

The FocalPlaneResolutionUnit is FocalPlaneXResolution0 / FocalPlaneXResolution1 and FocalPlaneYResolution0 / FocalPlaneYResolution1.

Value | Explanation
2 | Inches
3 | Centimeters

Explanation

The FocalPlaneResolutionUnit property refers to the units of measurement for focal plane resolution in the primary and thumbnail images.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FocalPlaneXResolution0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FocalPlaneXResolution0 Property

This property refers to the horizontal focal plane resolution.

[Visual Basic] Public ReadOnly Property FocalPlaneXResolution0 As Integer
[C#] public int FocalPlaneXResolution0 {get;}

Property Value

The FocalPlaneXResolution is the number of pixels in the image horizontal direction per FocalPlaneResolutionUnit on the camera focal plane.

The FocalPlaneXResolution0 is the numerator for the FocalPlaneXResolution.

The FocalPlaneXResolution1 is the denominator for the FocalPlaneXResolution.

The FocalPlaneResolutionUnit = FocalPlaneXResolution0 / FocalPlaneXResolution1

Explanation

The FocalPlaneXResolution0 property refers to the horizontal focal plane resolution.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FocalPlaneXResolution1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FocalPlaneXResolution1 Property

This property refers to the horizontal focal plane resolution. This is the denominator.

[Visual Basic] Public ReadOnly Property FocalPlaneXResolution1 As Integer
[C#] public int FocalPlaneXResolution1 {get;}

Property Value

The FocalPlaneXResolution is the number of pixels in the image horizontal direction per FocalPlaneResolutionUnit on the camera focal plane.

The FocalPlaneXResolution0 is the numerator for the FocalPlaneXResolution.

The FocalPlaneXResolution1 is the denominator for the FocalPlaneXResolution.

The FocalPlaneResolutionUnit = FocalPlaneXResolution0 / FocalPlaneXResolution1

Explanation

The FocalPlaneXResolution1 property refers to the horizontal focal plane resolution.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FocalPlaneYResolution0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FocalPlaneYResolution0 Property

This property refers to the vertical focal plane resolution.

[Visual Basic] Public ReadOnly Property FocalPlaneYResolution0 As Integer
[C#] public int FocalPlaneYResolution0 {get;}

Property Value

The FocalPlaneYResolution is the number of pixels in the image vertical direction per FocalPlaneResolutionUnit on the camera focal plane.

The FocalPlaneYResolution0 is the numerator for the FocalPlaneYResolution.

The FocalPlaneYResolution1 is the denominator for the FocalPlaneYResolution.

The FocalPlaneResolutionUnit = FocalPlaneYResolution0 / FocalPlaneYResolution1

Explanation

The FocalPlaneYResolution0 property refers to the vertical focal plane resolution.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


FocalPlaneYResolution1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.FocalPlaneYResolution1 Property

This property refers to the vertical focal plane resolution. This is the denominator.

[Visual Basic] Public ReadOnly Property FocalPlaneYResolution1 As Integer
[C#] public int FocalPlaneYResolution1 {get;}

Property Value

The FocalPlaneYResolution is the number of pixels in the image vertical direction per FocalPlaneResolutionUnit on the camera focal plane.

The FocalPlaneYResolution0 is the numerator for the FocalPlaneYResolution.

The FocalPlaneYResolution1 is the denominator for the FocalPlaneYResolution.

The FocalPlaneResolutionUnit = FocalPlaneYResolution0 / FocalPlaneYResolution1

Explanation

The FocalPlaneYResolution1 property refers to the vertical focal plane resolution.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


GPSVersion property

Newtone.ImageKit.Win.ImageKit.File.Exif.GPSVersion Property

This property refers to the GPS tag version (i.e. "2000"). The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property GPSVersion As String
[C#] public string GPSVersion {get;}

Property Value

The GPS tag version (i.e. "2000")

Explanation

The GPSVersion property refers to the GPS tag version (i.e. "2000"). The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif version.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ISOSpeedRatings property

Newtone.ImageKit.Win.ImageKit.File.Exif.ISOSpeedRatings Property

This property indicates the ISO Speed and ISO Latitude of the camera or input device.

[Visual Basic] Public ReadOnly Property ISOSpeedRatings As Integer
[C#] public int ISOSpeedRatings {get;}

Property Value

Indicates the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232xiv

Explanation

The ISOSpeedRatings property indicates the ISO Speed and ISO Latitude of the camera or input device.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LatitudeD0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LatitudeD0 Property

This property refers to latitude in degrees where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LatitudeD0 As Integer
[C#] public int LatitudeD0 {get;}

Property Value

LatitudeD0 is the latitude in degrees where the image was taken. This is the numerator.

LatitudeD1 is the latitude in degrees where the image was taken. This is the denominator.

The latitude in degrees = LatitudeD0 / LatitudeD1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LatitudeD1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LatitudeD1 Property

This property refers to latitude in degrees where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LatitudeD1 As Integer
[C#] public int LatitudeD1 {get;}

Property Value

LatitudeD0 is the latitude in degrees where the image was taken. This is the numerator.

LatitudeD1 is the latitude in degrees where the image was taken. This is the denominator.

The latitude in degrees = LatitudeD0 / LatitudeD1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LatitudeM0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LatitudeM0 Property

This property refers to latitude in minutes where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LatitudeM0 As Integer
[C#] public int LatitudeM0 {get;}

Property Value

LatitudeM0 is the latitude in minutes where the image was taken. This is the numerator.

LatitudeM1 is the latitude in minutes where the image was taken. This is the denominator.

The latitude in minutes = LatitudeM0 / LatitudeM1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LatitudeM1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LatitudeM1 Property

This property refers to latitude in minutes where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LatitudeM1 As Integer
[C#] public int LatitudeM1 {get;}

Property Value

LatitudeM0 is the latitude in minutes where the image was taken. This is the numerator.

LatitudeM1 is the latitude in minutes where the image was taken. This is the denominator.

The latitude in minutes = LatitudeM0 / LatitudeM1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LatitudeS0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LatitudeS0 Property

This property refers to latitude in seconds where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LatitudeS0 As Integer
[C#] public int LatitudeS0 {get;}

Property Value

LatitudeS0 is the latitude in minutes where the image was taken. This is the numerator.

LatitudeS1 is the latitude in minutes where the image was taken. This is the denominator.

The latitude in minutes = LatitudeS0 / LatitudeS1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LatitudeS1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LatitudeS1 Property

This property refers to latitude in seconds where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LatitudeS1 As Integer
[C#] public int LatitudeS1 {get;}

Property Value

LatitudeS0 is the latitude in seconds where the image was taken. This is the numerator.

LatitudeS1 is the latitude in seconds where the image was taken. This is the denominator.

The latitude in minutes = LatitudeS0 / LatitudeS1

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


Latitude property

Newtone.ImageKit.Win.ImageKit.File.Exif.Latitude Property

This property refers to the latitude direction where the image was taken. (i.e. "N" or "S")

[Visual Basic] Public ReadOnly Property Latitude As String
[C#] public string Latitude {get;}

Property Value

Latitude is the latitude direction where the image was taken. (i.e. "N" or "S")

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LongitudeD0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LongitudeD0 Property

This property refers to longitude in degrees where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LongitudeD0 As String
[C#] public string LongitudeD0 {get;}

Property Value

LongitudeD0 is the longitude in degrees where the image was taken. This is the numerator.

LongitudeD1 is the latitude in degrees where the image was taken. This is the denominator.

The longitude in degrees = LongitudeD0 / LongitudeD1

Explanation

The LongitudeD0 property refers to longitude in degrees where the image was taken. This is the numerator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LongitudeD1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LongitudeD1 Property

This property refers to longitude in degrees where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LongitudeD1 As String
[C#] public string LongitudeD1 {get;}

Property Value

LongitudeD0 is the longitude in degrees where the image was taken. This is the numerator.

LongitudeD1 is the latitude in degrees where the image was taken. This is the denominator.

The longitude in degrees = LongitudeD0 / LongitudeD1

Explanation

The LongitudeD1 property refers to longitude in degrees where the image was taken. This is the denominator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LongitudeM0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LongitudeM0 Property

This property refers to longitude in minutes where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LongitudeM0 As String
[C#] public string LongitudeM0 {get;}

Property Value

LongitudeM0 is the longitude in minutes where the image was taken. This is the numerator.

LongitudeM1 is the latitude in minutes where the image was taken. This is the denominator.

The longitude in minutes = LongitudeM0 / LongitudeM1

Explanation

The LongitudeM0 property refers to longitude in minutes where the image was taken. This is the numerator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LongitudeM1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LongitudeM1 Property

This property refers to longitude in minutes where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LongitudeM1 As String
[C#] public string LongitudeM1 {get;}

Property Value

LongitudeM0 is the longitude in minutes where the image was taken. This is the numerator.

LongitudeM1 is the latitude in minutes where the image was taken. This is the denominator.

The longitude in minutes = LongitudeM0 / LongitudeM1

Explanation

The LongitudeM1 property refers to longitude in minutes where the image was taken. This is the denominator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LongitudeS0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LongitudeS0 Property

This property refers to longitude in seconds where the image was taken. This is the numerator.

[Visual Basic] Public ReadOnly Property LongitudeS0 As String
[C#] public string LongitudeS0 {get;}

Property Value

LongitudeS0 is the longitude in seconds where the image was taken. This is the numerator.

LongitudeS1 is the latitude in seconds where the image was taken. This is the denominator.

The longitude in minutes = LongitudeS0 / LongitudeS1

Explanation

The LongitudeS0 property refers to longitude in seconds where the image was taken. This is the numerator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LongitudeS1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.LongitudeS1 Property

This property refers to longitude in seconds where the image was taken. This is the denominator.

[Visual Basic] Public ReadOnly Property LongitudeS1 As String
[C#] public string LongitudeS1 {get;}

Property Value

LongitudeS0 is the longitude in seconds where the image was taken. This is the numerator.

LongitudeS1 is the latitude in seconds where the image was taken. This is the denominator.

The longitude in minutes = LongitudeS0 / LongitudeS1

Explanation

The LongitudeS1 property refers to longitude in seconds where the image was taken. This is the denominator.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MapDatum property

Newtone.ImageKit.Win.ImageKit.File.Exif.MapDatum Property

This property refers to the name of the map data used.

[Visual Basic] Public ReadOnly Property MapDatum As String
[C#] public string MapDatum {get;}

Property Value

MapDatum is the name of the map data used

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


LightSource property

Newtone.ImageKit.Win.ImageKit.File.Exif.LightSource Property

This property refers to the type of light source.

[Visual Basic] Public ReadOnly Property LightSource As Integer
[C#] public int LightSource {get;}

Property Value

Value | Explanation
0 | Unknown
1 | Daylight
2 | Fluorescent
3 | Tungsten
17 | Standard light A
18 | Standard light B
19 | Standard light C
20 | D55
21 | D65
22 | D75
255 | Other

Explanation

The LightSource property refers to the type of light source.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


Longitude property

Newtone.ImageKit.Win.ImageKit.File.Exif.Longitude Property

This property refers to the longitude direction where the image was taken. (i.e. "E" or "W")

[Visual Basic] Public ReadOnly Property Longitude As String
[C#] public string Longitude {get;}

Property Value

Longitude is the longitude direction where the image was taken. (i.e. "E" or "W")

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif GPS tag.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainArtist property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainArtist Property

This property refers to the information about the artist's name.

[Visual Basic] Public ReadOnly Property MainArtist As String
[C#] public string MainArtist {get;}

Property Value

MainArtist refers to the camera owner, photographer, or creator of the primary image

Explanation

The MainArtist property refers to the information about the artist's name.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainCopyright property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainCopyright Property

This property refers to the information about the copyright.

[Visual Basic] Public ReadOnly Property MainCopyright As String
[C#] public string MainCopyright {get;}

Property Value

MainCopyright refers to the copyright information for the primary image

Explanation

The MainCopyright property refers to the information about the copyright.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainDateTime property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainDateTime Property

This property refers to the information about the date and time.

[Visual Basic] Public ReadOnly Property MainDateTime As String
[C#] public string MainDateTime {get;}

Property Value

MainDateTime refers to the date and time that the primary image was created. The format is "YYYY:MM:DD HH:MM:SS" with the time shown in 24-hour format and the date and time separated by one blank character

Example: "1996:09:01 09:15:30"

Explanation

The MainDateTime property refers to the information about the date and time.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainImageDescription property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainImageDescription Property

This property refers to the information about the image description.

[Visual Basic] Public ReadOnly Property MainImageDescription As String
[C#] public string MainImageDescription {get;}

Property Value

MainImageDescription refers to the character string giving the title of the primary image

Explanation

The MainImageDescription property refers to the information about the image description.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainMake property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainMake Property

This property refers to the information about the manufacturer's name.

[Visual Basic] Public ReadOnly Property MainMake As String
[C#] public string MainMake {get;}

Property Value

MainMake refers to the manufacturer of the recording equipment that generated the primary image

Explanation

The MainMake property refers to the information about the manufacturer's name.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainModel property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainModel Property

This property refers to the information about the model name or model number of the equipment.

[Visual Basic] Public ReadOnly Property MainModel As String
[C#] public string MainModel {get;}

Property Value

MainModel refers to the model name or model number of the equipment that generated the primary image

Explanation

The MainModel property refers to the information about the model name or model number of the equipment.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainSoftware property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainSoftware Property

This property refers to the information about the software.

[Visual Basic] Public ReadOnly Property MainSoftware As String
[C#] public string MainSoftware {get;}

Property Value

MainSoftware refers to the name and version of the software used to generate the primary image

Explanation

The MainSoftware property refers to the information about the software.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainResolutionUnit property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainResolutionUnit Property

This property refers to the units of measurement for focal plane resolution in the primary image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property MainResolutionUnit As Integer
[C#] public int MainResolutionUnit {get;}

Property Value

The MainResolutionUnit is the unit of measurement for MainXResolution and MainYResolution in the primary image.

The MainResolutionUnit is MainXResolution0 / MainXResolution1 and MainYResolution0 / MainYResolution1

Value | Explanation
2 | Inches
3 | Centimeters

Explanation

The MainResolutionUnit property refers to the units of measurement for focal plane resolution in the primary image.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainXResolution0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainXResolution0 Property

This property refers to the number of pixels per resolution unit in the primary images.

[Visual Basic] Public ReadOnly Property MainXResolution0 As Integer
[C#] public int MainXResolution0 {get;}

Property Value

The MainXResolution is the number of pixels per MainResolutionUnit in the primary image in the horizontal direction.

The MainXResolution0 is the numerator for the MainResolutionUnit.

The MainXResolution1 is the denominator for the MainResolutionUnit.

The MainResolutionUnit = MainXResolution0 / MainXResolution1

Explanation

The MainXResolution0 property refers to the number of pixels per resolution unit in the primary images. The property value is derived from the image tags relating to image data structure. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainXResolution1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainXResolution1 Property

This property refers to the number of pixels per resolution unit in the primary images.

[Visual Basic] Public ReadOnly Property MainXResolution1 As Integer
[C#] public int MainXResolution1 {get;}

Property Value

The MainXResolution is the number of pixels per MainResolutionUnit in the primary image in the horizontal direction.

The MainXResolution0 is the numerator for the MainResolutionUnit.

The MainXResolution1 is the denominator for the MainResolutionUnit.

The MainResolutionUnit = MainXResolution0 / MainXResolution1

Explanation

The MainXResolution1 property refers to the number of pixels per resolution unit in the primary images. The property value is derived from the image tags relating to image data structure. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainYCbCrPositioning property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainYCbCrPositioning Property

This property refers to the position of chrominance components (CbCr) in relation to the luminance component (Y).

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property MainYCbCrPositioning As Integer
[C#] public int MainYCbCrPositioning {get;}

Property Value

Value | Explanation
1 | Centered
2 | Co-sited

Explanation

The MainYCbCrPositioning property refers to the position of chrominance components (CbCr) in relation to the luminance component (Y). The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags relating to primary image data structure.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainYResolution0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainYResolution0 Property

This property refers to the number of pixels per resolution unit in the primary images.

[Visual Basic] Public ReadOnly Property MainYResolution0 As Integer
[C#] public int MainYResolution0 {get;}

Property Value

The MainYResolution is the number of pixels per MainResolutionUnit in the primary image in the vertical direction.

The MainYResolution0 is the numerator for the MainResolutionUnit.

The MainYResolution1 is the denominator for the MainResolutionUnit.

The MainResolutionUnit = MainYResolution0 / MainYResolution1

Explanation

The MainYResolution0 property refers to the number of pixels per resolution unit in the primary images. The property value is derived from the image tags relating to image data structure. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainYResolution1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainYResolution1 Property

This property refers to the number of pixels per resolution unit in the primary images.

[Visual Basic] Public ReadOnly Property MainYResolution1 As Integer
[C#] public int MainYResolution1 {get;}

Property Value

The MainYResolution is the number of pixels per MainResolutionUnit in the primary image in the vertical direction.

The MainYResolution0 is the numerator for the MainResolutionUnit.

The MainYResolution1 is the denominator for the MainResolutionUnit.

The MainResolutionUnit = MainYResolution0 / MainYResolution1

Explanation

The MainYResolution1 property refers to the number of pixels per resolution unit in the primary images. The property value is derived from the image tags relating to image data structure. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MakerNote property

Newtone.ImageKit.Win.ImageKit.File.Exif.MakerNote Property

This property value is derived from the image tags relating to user information.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property MakerNote As String
[C#] public string MakerNote {get;}

Property Value

The MakerNote property value is derived from the image tag for manufacturers of Exif writers to record any desired information.

Explanation

The MakerNote property value is derived from the image tags relating to user information.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MaxApertureValue0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.MaxApertureValue0 Property

This property refers to the smallest F value of the lens. This is the numerator.

[Visual Basic] Public ReadOnly Property MaxApertureValue0 As Integer
[C#] public int MaxApertureValue0 {get;}

Property Value

MaxApertureValue0 is the numerator for the smallest F value of the lens

MaxApertureValue1 is the denominator for the smallest F value of the lens

The smallest F value of the lens (unit is the APEX value) = MaxApertureValue0 / MaxApertureValue1

Ordinarily the smallest F value of the lens is given in the range from 00.00 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MaxApertureValue1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.MaxApertureValue1 Property

This property refers to the smallest F value of the lens. This is the denominator.

[Visual Basic] Public ReadOnly Property MaxApertureValue1 As Integer
[C#] public int MaxApertureValue1 {get;}

Property Value

MaxApertureValue0 is the numerator for the smallest F value of the lens

MaxApertureValue1 is the denominator for the smallest F value of the lens

The smallest F value of the lens (unit is the APEX value) = MaxApertureValue0 / MaxApertureValue1

Ordinarily the smallest F value of the lens is given in the range from 00.00 to 99.99

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MeteringMode property

Newtone.ImageKit.Win.ImageKit.File.Exif.MeteringMode Property

This property refers to the metering mode. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.
[Visual Basic] Public ReadOnly Property MeteringMode As Integer
[C#] public int MeteringMode {get;}

Property Value

Value | Explanation
0 | Unknown
1 | Average
2 | CounterWeightedAverage
3 | Spot
4 | MultiSpot
5 | Pattern
6 | Partial
255 | Other

Explanation

The MeteringMode property refers to the metering mode. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods. This property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


MainOrientation property

Newtone.ImageKit.Win.ImageKit.File.Exif.MainOrientation Property

This property refers to the image orientation viewed in terms of rows and columns. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property MainOrientation As Integer
[C#] public int MainOrientation {get;}

Property Value

Value | Explanation
1 | The 0th row is at the visual top of the image, and the 0th column is the visual left hand side
2 | The 0th row is at the visual top of the image, and the 0th column is the visual right hand side
3 | The 0th row is at the visual bottom of the image, and the 0th column is the visual right hand side
4 | The 0th row is at the visual bottom of the image, and the 0th column is the visual left hand side
5 | The 0th row is at the visual left hand side of the image, and the 0th column is the visual top
6 | The 0th row is at the visual right hand side of the image, and the 0th column is the visual top
7 | The 0th row is at the visual right hand side of the image, and the 0th column is the visual bottom
8 | The 0th row is at the visual left hand side of the image, and the 0th column is the visual bottom

Explanation

The MainOrientation property refers to the image orientation viewed in terms of rows and columns.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags relating to primary image data structure.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailOrientation property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailOrientation Property

This property refers to the image orientation viewed in terms of rows and columns. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailOrientation As Integer
[C#] public int ThumbnailOrientation {get;}

Property Value

Value | Explanation
1 | The 0th row is at the visual top of the image, and the 0th column is the visual left hand side
2 | The 0th row is at the visual top of the image, and the 0th column is the visual right hand side
3 | The 0th row is at the visual bottom of the image, and the 0th column is the visual right hand side
4 | The 0th row is at the visual bottom of the image, and the 0th column is the visual left hand side
5 | The 0th row is at the visual left hand side of the image, and the 0th column is the visual top
6 | The 0th row is at the visual right hand side of the image, and the 0th column is the visual top
7 | The 0th row is at the visual right hand side of the image, and the 0th column is the visual bottom
8 | The 0th row is at the visual left hand side of the image, and the 0th column is the visual bottom

Explanation

The ThumbnailOrientation property refers to the image orientation viewed in terms of rows and columns.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags relating to thumbnail image data structure.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


PixelXDimension property

Newtone.ImageKit.Win.ImageKit.File.Exif.PixelXDimension Property

This property refers to the width of the image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property PixelXDimension As Integer
[C#] public int PixelXDimension {get;}

Property Value

PixcelXDimension is the valid width of the image

PixelYDimension is the valid height of the image

Explanation

The PixcelXDimension property refers to the width of the image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to the image configuration.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


PixelYDimension property

Newtone.ImageKit.Win.ImageKit.File.Exif.PixelYDimension Property

This property refers to the height of the image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property PixelYDimension As Integer
[C#] public int PixelYDimension {get;}

Property Value

PixcelXDimension is the valid width of the image

PixelYDimension is the valid height of the image

Explanation

The PixcelYDimension property refers to the height of the image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to the image configuration.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SceneType property

Newtone.ImageKit.Win.ImageKit.File.Exif.SceneType Property

This property refers to the type of scene.

[Visual Basic] Public ReadOnly Property SceneType As Integer
[C#] public int SceneType {get;}

Property Value

SceneType indicates the type of scene. If a DSC recorded the image, this value will be set to 1 indicating that the image was directly photographed.

Explanation

The SceneType property refers to the type of scene. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SensingMethod property

Newtone.ImageKit.Win.ImageKit.File.Exif.SensingMethod Property

This property refers to the image sensor type on the camera or input device. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SensingMethod As Integer
[C#] public int SensingMethod {get;}

Property Value

Value | Explanation
1 | Not defined
2 | One-chip color area sensor
3 | Two-chip color area sensor
4 | Three-chip color area sensor
5 | Color sequential area sensor
7 | Trilinear sensor
8 | Color sequential linear sensor

Explanation

The SensingMethod property refers to the image sensor type on the camera or input device. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ShutterSpeedValue0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ShutterSpeedValue0 Property

This property is the numerator for the shutter speed. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

[Visual Basic] Public ReadOnly Property ShutterSpeedValue0 As Integer
[C#] public int ShutterSpeedValue0 {get;}

Property Value

ShutterSpeedValue0 is the numerator for the shutter speed

ShutterSpeedValue1 is the denominator for the shutter speed

The shutter speed (unit is the APEX value) = ShutterSpeedValue0 / ShutterSpeedValue1

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The ShutterSpeedValue0 property is the numerator for the shutter speed. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ShutterSpeedValue1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ShutterSpeedValue1 Property

This property is the denominator for the shutter speed. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

[Visual Basic] Public ReadOnly Property ShutterSpeedValue1 As Integer
[C#] public int ShutterSpeedValue1 {get;}

Property Value

ShutterSpeedValue0 is the numerator for the shutter speed

ShutterSpeedValue1 is the denominator for the shutter speed

The shutter speed (unit is the APEX value) = ShutterSpeedValue0 / ShutterSpeedValue1

*APEX is the Additive System of Photographic Exposure, a standard unit for expressing exposure.

Explanation

The ShutterSpeedValue1 property is the denominator for the shutter speed. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SpectralSensitivity property

Newtone.ImageKit.Win.ImageKit.File.Exif.SpectralSensitivity Property

This property refers to the spectral sensitivity of each channel of the camera used. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SpectralSensitivity As String
[C#] public string SpectralSensitivity {get;}

Property Value

The value is an ASCII string commpatible with the standard xiii developed by the ASTM Technical committee.

Explanation

The SpectralSensitivity property referes to the spectral sensitivity of each channel of the camera used. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SubjectDistance0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.SubjectDistance0 Property

This property is the numerator for the distance to the subject. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubjectDistance0 As Integer
[C#] public int SubjectDistance0 {get;}

Property Value

SubjectDistance0 is the numerator for the distance to the subject.

SubjectDistance1 is the denominator for the distance to the subject.

The distance to the subject (in meters) = SubjectDistance0 / SubjectDistance1

Explanation

The SubjectDistance0 property is the numerator for the distance to the subject. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData methods.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SubjectDistance1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.SubjectDistance1 Property

This property is the denominator for the distance to the subject. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubjectDistance1 As Integer
[C#] public int SubjectDistance1 {get;}

Property Value

SubjectDistance0 is the numerator for the distance to the subject.

SubjectDistance1 is the denominator for the distance to the subject.

The distance to the subject (in meters) = SubjectDistance0 / SubjectDistance1

Explanation

The SubjectDistance1 property is the denominator for the distance to the subject. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SubjectLocationX property

Newtone.ImageKit.Win.ImageKit.File.Exif.SubjectLocationX Property

This property refers to the location of the main subject in the scene. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubjectLocationX As Integer
[C#] public int SubjectLocationX {get;}

Property Value

The SubjectLocationX is the horizontal coordinate of the center of the main subject of the scene

The SubjectLocationY is the vertical coordinate of the center of the main subject of the scene

Explanation

The SubjectLocationX refers to the location of the main subject in the scene. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SubjectLocationY property

Newtone.ImageKit.Win.ImageKit.File.Exif.SubjectLocationY Property

This property refers to the location of the main subject in the scene. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubjectLocationY As Integer
[C#] public int SubjectLocationY {get;}

Property Value

The SubjectLocationX is the horizontal coordinate of the center of the main subject of the scene

The SubjectLocationY is the vertical coordinate of the center of the main subject of the scene

Explanation

The SubjectLocationY refers to the location of the main subject in the scene. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SubSecTime property

Newtone.ImageKit.Win.ImageKit.File.Exif.SubSecTime Property

This property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubSecTime As String
[C#] public string SubSecTime {get;}

Property Value

The SubSecTime property records fractions of seconds for the MainDateTime property.

For example, if the subsecond data is 0.130 then

SubSecTime = "130"

Explanation

The SubSecTime property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to date and time.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SubSecTimeDigitized property

Newtone.ImageKit.Win.ImageKit.File.Exif.SubSecTimeDigitized Property

This property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubSecTimeDigitized As String
[C#] public string SubSecTimeDigitized {get;}

Property Value

The SubSecTimeDigitized property records fractions of seconds for the DateTimeDigitized property.

For example, if the subsecond data is 0.130 then

SubSecTimeDigitized = "130"

Explanation

The SubSecTimeDigitized property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to date and time.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


SubSecTimeOriginal property

Newtone.ImageKit.Win.ImageKit.File.Exif.SubSecTimeOriginal Property

This property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property SubSecTimeOriginal As String
[C#] public string SubSecTimeOriginal {get;}

Property Value

The SubSecTimeOriginal property records fractions of seconds for the DateTimeOriginal property.

For example, if the subsecond data is 0.130 then

SubSecTimeOriginal = "130"

Explanation

The SubSecTimeOriginal property records fractions of seconds for the related date time properties. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

This property value is derived from the image tags relating to date and time.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailCompression property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailCompression Property

This property refers to the compression method for the thumbnail image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailCompression As Integer
[C#] public int ThumbnailCompression {get;}

Property Value

Value | Explanation
1 | Uncompressed
6 | JPEG compression

Explanation

The ThumbnailCompression property refers to the compression method for the thumbnail image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

When the thumbnail is Jpeg compression data, the return value will be 6.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailArtist property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailArtist Property

This property refers to the information about the artist's name. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailArtist As String
[C#] public string ThumbnailArtist {get;}

Property Value

ThumbnailArtist refers to the camera owner, photographer, or creator of the Thumbnail image

Explanation

The ThumbnailArtist property refers to the information about the artist's name. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailCopyright property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailCopyright Property

This property refers to the information about the copyright. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailCopyright As String
[C#] public string ThumbnailCopyright {get;}

Property Value

ThumbnailCopyright refers to the copyright information for the Thumbnail image

Explanation

The ThumbnailCopyright property refers to the information about the copyright. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailDateTime property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailDateTime Property

This property refers to the information about the date and time. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailDateTime As String
[C#] public string ThumbnailDateTime {get;}

Property Value

ThumbnailDateTime refers to the date and time that the Thumbnail image was created. The format is "YYYY:MM:DD HH:MM:SS" with the time shown in 24-hour format and the date and time separated by one blank character

Example: "1996:09:01 09:15:30"

Explanation

The ThumbDateTime property refers to the information about the date and time. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailImageDescription property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailImageDescription Property

This property refers to the information about the image description. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailImageDescription As String
[C#] public string ThumbnailImageDescription {get;}

Property Value

ThumbnailImageDescription refers to the character string giving the title of the Thumbnail image

Explanation

The ThumbnailImageDescription property refers to the information about the image description. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailMake property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailMake Property

This property refers to the information about the manufacturer's name. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailMake As String
[C#] public string ThumbnailMake {get;}

Property Value

ThumbnailMake refers to the manufacturer of the recording equipment that generated the Thumbnail image

Explanation

The ThumbnailMake property refers to the information about the manufacturer's name. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailModel property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailModel Property

This property refers to the information about the model name or model number of the equipment. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailModel As String
[C#] public string ThumbnailModel {get;}

Property Value

ThumbnailModel refers to the model name or model number of the equipment that generated the Thumbnail image

Explanation

The ThumbnailModel property refers to the information about the model name or model number of the equipment. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailSoftware property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailSoftware Property

This property refers to the information about the software. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailSoftware As String
[C#] public string ThumbnailSoftware {get;}

Property Value

ThumbnailSoftware refers to the name and version of the software used to generate the Thumbnail image

Explanation

The ThumbnailSoftware property refers to the information about the software. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the thumbnail image information.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailResolutionUnit property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailResolutionUnit Property

This property refers to the units of measurement for focal plane resolution in the thumbnail image. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailResolutionUnit As Integer
[C#] public int ThumbnailResolutionUnit {get;}

Property Value

The ThumbnailResolutionUnit is the unit of measurement for ThumbnailXResolution and ThumbnailYResolution in the thumbnail image.

The ThumbResolutionUnit is ThumbnailXResolution0 / ThumbnailXResolution1 and ThumbnailYResolution0 / ThumbnailYResolution1

Value | Explanation
2 | Inches
3 | Centimeters

Explanation

The ThumbResolutionUnit property refers to the units of measurement for focal plane resolution in the thumbnail image.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the picture taking conditions.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailXResolution0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailXResolution0 Property

This property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailXResolution0 As Integer
[C#] public int ThumbnailXResolution0 {get;}

Property Value

The ThumbnailXResolution is the number of pixels per ThumbnailResolutionUnit in the thumbnail image in the horizontal direction.

The ThumbnailXResolution0 is the numerator for the ThumbnailResolutionUnit.

The ThumbnailXResolution1 is the denominator for the ThumbnailResolutionUnit.

The ThumbnailResolutionUnit = ThumbnailXResolution0 / ThumbnailXResolution1.

Explanation

The ThumbnailnailXResolution0 property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the resolution of the thumbnail image.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailXResolution1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailXResolution1 Property

This property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailXResolution1 As Integer
[C#] public int ThumbnailXResolution1 {get;}

Property Value

The ThumbnailXResolution is the number of pixels per ThumbnailResolutionUnit in the thumbnail image in the horizontal direction.

The ThumbnailXResolution0 is the numerator for the ThumbnailResolutionUnit.

The ThumbnailXResolution1 is the denominator for the ThumbnailResolutionUnit.

The ThumbnailResolutionUnit = ThumbnailXResolution0 / ThumbnailXResolution1.

Explanation

The ThumbnailXResolution1 property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the resolution of the thumbnail image.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailYCbCrPositioning property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailYCbCrPositioning Property

This property refers to the position of chrominance components (CbCr) in relation to the luminance component (Y).

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailYCbCrPositioning As Integer
[C#] public int ThumbnailYCbCrPositioning {get;}

Property Value

Value | Explanation
1 | Centered
2 | Co-sited

Explanation

The ThumbnailYCbCrPositioning property refers to the position of chrominance components (CbCr) in relation to the luminance component (Y). The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags relating to thumbnail image data structure.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailYResolution0 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailYResolution0 Property

This property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailYResolution0 As Integer
[C#] public int ThumbnailYResolution0 {get;}

Property Value

The ThumbnailYResolution is the number of pixels per ThumbnailResolutionUnit in the thumbnail image in the vertical direction.

The ThumbnailYResolution0 is the numerator for the ThumbnailResolutionUnit.

The ThumbnailYResolution1 is the denominator for the ThumbnailResolutionUnit.

The ThumbnailResolutionUnit = ThumbnailYResolution0 / ThumbnailYResolution1.

Explanation

The ThumbnailYResolution0 property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the resolution of the thumbnail image.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ThumbnailYResolution1 property

Newtone.ImageKit.Win.ImageKit.File.Exif.ThumbnailYResolution1 Property

This property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property ThumbnailYResolution1 As Integer
[C#] public int ThumbnailYResolution1 {get;}

Property Value

The ThumbnailYResolution is the number of pixels per ThumbnailResolutionUnit in the thumbnail image in the vertical direction.

The ThumbnailYResolution0 is the numerator for the ThumbnailResolutionUnit.

The ThumbnailYResolution1 is the denominator for the ThumbnailResolutionUnit.

The ThumbnailResolutionUnit = ThumbnailYResolution0 / ThumbnailYResolution1.

Explanation

The ThumbnailYResolution1 property refers to the number of pixels per resolution unit in the thumbnail images. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the resolution of the thumbnail image.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


UserComment property

Newtone.ImageKit.Win.ImageKit.File.Exif.UserComment Property

This property value is derived from the image tags relating to user information.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property UserComment As String
[C#] public string UserComment {get;}

Property Value

The UserComment tag is identified based on an UserCommentID code in a fixed 8-byte area at the start of the tag data area. The unused portion of the area is padded with NULL("00.H").

Character Code | Code Designation (8 Bytes) | References
ASCII | 0x41,0x53,0x43,0x49,0x49,0x00,0x00,0x00 | ITU-T T.50 IA5x
JIS | 0x4A,0x49,0x53,0x00,0x00,0x00,0x00,0x00 | JIS X0208-1990xi
Unicode | 0x55,0x4E,0x49,0x43,0x4F,0x44,0x45,0x00 | Unicode Standard xii
Undefined | 0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00 | Undefined

In Visual Basic, please replace 0x with &H

Explanation

The UserComment property value is derived from the image tags relating to user information. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


UserCommentID property

Newtone.ImageKit.Win.ImageKit.File.Exif.UserCommentID Property

This property value is derived from the image tags relating to user information.

The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property UserCommentID As String
[C#] public string UserCommentID {get;}

Property Value

The UserComment tag is identified based on an UserCommentID code in a fixed 8-byte area at the start of the tag data area. The unused portion of the area is padded with NULL("00.H").

Character Code | Code Designation (8 Bytes) | References
ASCII | 0x41,0x53,0x43,0x49,0x49,0x00,0x00,0x00 | ITU-T T.50 IA5x
JIS | 0x4A,0x49,0x53,0x00,0x00,0x00,0x00,0x00 | JIS X0208-1990xi
Unicode | 0x55,0x4E,0x49,0x43,0x4F,0x44,0x45,0x00 | Unicode Standard xii
Undefined | 0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00 | Undefined

In Visual Basic, please replace 0x with &H

Explanation

The UserCommentID property value is derived from the image tags relating to user information. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


Version property

Newtone.ImageKit.Win.ImageKit.File.Exif.Version Property

This property refers to the version of the Exif Standard supported. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

[Visual Basic] Public ReadOnly Property Version As String
[C#] public string Version {get;}

Property Value

Version is the Exif version supported. (Example: "0210")

Explanation

The Version property refers to the version of the Exif Standard supported. The property value can be retrieved by executing the File.GetImageFileType or the File.GetImageFileTypeFromRawData method.

The property value is derived from the image tags related to the Exif version.

See Also

ImageKit.File.Exif Members | Newtone.ImageKit.Win.ImageKit


ImageKit Members

Newtone.ImageKit.Win.ImageKit.Layer All Members

Public Properties

BitCount | Refers to the number of bits per pixel in the image set in the Layer(Index).Image property
DXFBlack | Sets whether or not white is displayed as black and black is displayed as white in DXF images
Gray | Determines whether or not the image set in the Layer(Index).Image property is grayscale
Image | Refers to the image handle of the image set in the LayerNumber property
ImageKind | Refers to the type of image set in the Layer(Index).Image property
ImageSize | Refers to the size, in bytes, of the image set in the Layer(Index).Image property
ImageWidthByte | Refers to the number of bytes per line in the image set in the Layer(Index).Image property
PaletteCount | Refers to the number of palette colors for the image set in the Layer(Index).Image property
ShowImage | Sets whether or not the layer image is displayed in the ImageKit Control
ShowPanWindowImage | Sets whether or not the layer image is displayed in the Pan window
StartX | Sets the point (the horizontal position) on the image that will be displayed from the top left corner of the ImageKit Control
StartY | Sets the point (the vertical position) on the image that will be displayed from the top left corner of the ImageKit Control
Transparent | Enables the transparent color in the image set in the Layer(Index).Image property
TransparentBlue | Sets the transparent color's blue value in the image set in the Layer(Index).Image property
TransparentGreen | Sets the transparent color's green value in the image set in the Layer(Index).Image property
TransparentRed | Sets the transparent color's red value in the image set in the Layer(Index).Image property

See Also

Newtone.ImageKit.Win.ImageKit


BitCount property

Newtone.ImageKit.Win.ImageKit.Layer[Index].BitCount Property

This property refers to the number of bits per pixel in the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public ReadOnly Property BitCount As Integer
[C#] public int BitCount {get;}

Property Value

The number of bits per pixel in an image

Value | Explanation
1 | 2 color (i.e. Black and White)
4 | 16 color
8 | 256 color
16 | 16 bit color
24 | 24 bit color
32 | 32 bit color

Explanation

The BitCount property refers to the number of bits per pixel in the image set in the Layer(Index).Image property.

When the Layer(Index).Image property is set the value of the BitCount property is automatically set.

This property is not valid for vector images.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


DXFBlack property

Newtone.ImageKit.Win.ImageKit.Layer[Index].DXFBlack Property

This property sets whether or not white is displayed as black and black is displayed as white in DXF images. The index can range from 0 to 99.

[Visual Basic] Public Property DXFBlack As Boolean
[C#] public bool DXFBlack {get; set;}

Property Value

Value | Explanation
True | Black is displayed as white and white is displayed as black in DXF images (default)
False | The DXF images is displayed as normal

Explanation

The DXFBlack property sets whether or not white is displayed as black and black is displayed as white in DXF images. The default value is True. When this property is true, black and white are exchanged when the DXF image is displayed. This is useful when white lines are draw in DXF data. If they are displayed normally on a white display control then the white lines will not appear.

To use this property, you must have the appropriate ImageKit7 Dll files.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


Gray property

Newtone.ImageKit.Win.ImageKit.Layer[Index].Gray Property

This property determines whether or not the image set in the Layer(Index).Image property is grayscale. The index can range from 0 to 99.
[Visual Basic] Public ReadOnly Property Gray As Boolean
[C#] public bool Gray {get;}

Property Value

Value | Explanation
True | Grayscale
False | Not grayscale

Explanation

The Gray property determines whether or not the image set in the Layer(Index).Image property is grayscale.

After setting the Layer(Index).Image property, the value of the Gray property is automatically set.

This property is not valid for vector images.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


Image property

Newtone.ImageKit.Win.ImageKit.Layer[Index].Image Property

This property refers to the image handle of the image set in the LayerNumber property. The index can range from 0 to 99.

[Visual Basic] Public Property Image As Image
[C#] public Image Image {get; set;}

Property Value

Layer image object

Explanation

The Image property refers to the image handle of the image set in the LayerNumber property.

When the image set in the LayerNumber is loaded, the Image property value is set.

To disable the image referred to by the Image property, set the Image property to 0. By doing this that image data will automatically be freed from the memory.

Example (in Visual Basic)

ImageKit1.LayerNumber = 0
ImageKit1.Layer(0).Transparent = False
ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.LoadFileType.Load)

'The image loaded into ImageKit1.Layer(0).Image is set

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


ImageKind property

Newtone.ImageKit.Win.ImageKit.Layer[Index].ImageKind Property

This property refers to the type of image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public ReadOnly Property ImageKind As KindOfImage
[C#] public KindOfImage ImageKind {get;}

Property Value

The number of bits per pixel in an image

Value | Explanation
InvalidImage | Unknown
RasterImage | Raster image
VectorWMF | WMF
VectorEMF | EMF
VectorDXF | DXF
VectorSVG | SVG
VectorSXF | SXF

Explanation

The ImageKind property refers to the type of image set in the Layer(Index).Image property.

When the Layer(Index).Image property is set the value of this property is automatically set.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


ImageSize property

Newtone.ImageKit.Win.ImageKit.Layer[index].ImageSize Property

This property refers to the size, in bytes, of the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public ReadOnly Property ImageSize As Integer
[C#] public int ImageSize {get;}

Property Value

The size of the image in bytes

Explanation

The ImageSize property refers to the size, in bytes, of the image set in the Layer(Index).Image property.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


ImageWidthByte property

Newtone.ImageKit.Win.ImageKit.Layer[Index].ImageWidthByte Property

This property refers to the number of bytes per line in the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public ReadOnly Property ImageWidthByte As Integer
[C#] public int ImageWidthByte {get;}

Property Value

The number of bytes per line in the image

Explanation

The ImageWidthByte property refers to the number of bytes per line in the image set in the Layer(Index).Image property.

When the Layer(Index).Image property is set the value of this property is automatically set.

This property is not valid for vector images.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


PaletteCount property

Newtone.ImageKit.Win.ImageKit.Layer[Index].PaletteCount Property

This property refers to the number of palette colors for the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public ReadOnly Property PaletteCount As Integer
[C#] public int PaletteCount {get;}

Property Value

The number of palette colors for the image.

This property value is valid when the BitCount property is less than 8, otherwise 0 is returned.

Explanation

This property refers to the number of palette colors for the image set in the Layer(Index).Image property.

After setting the Layer(Index).Image property, the value of this property is automatically set.

This property is not valid for vector images.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


ShowImage, ShowPanWindowImage property

Newtone.ImageKit.Win.ImageKit.Layer[Index].ShowImage Property

The ShowImage property sets whether or not the layer image is displayed in the ImageKit Control. The index can range from 0 to 99.

[Visual Basic] Public Property ShowImage As Boolean
[C#] public bool ShowImage {get; set;}

Property Value

The ShowImage property sets whether or not the layer image is displayed in the ImageKit Control. The value can range from 0 to 99.

Value | Explanation
True | Displays the layer image
False | Does not display the layer image

Explanation

The ShowImage property sets whether or not the layer image is displayed in the ImageKit Control.

Using this property, you can switch between displaying or hiding the layer image (The layer image is the image pointed to by the Layer(Index).Image property).

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


StartDrawX property

Newtone.ImageKit.Win.ImageKit.Layer[Index].StartX Property

This property sets the point on the image that will be displayed from the top left corner of the ImageKit Control. The index can range from 0 to 99.

[Visual Basic] Public Property StartX As Integer
[C#] public int StartX {get; set;}

Property Value

The horizontal position on the image that will be displayed from the left of the ImageKit Control.

The default value is 0.

Explanation

The StartX property sets the point on the layer image that will be displayed from the top left corner of the ImageKit Control. The image that the StartX property relates to is the image set in the Layer(Index).Image property.

If the base image has not been set this property is disabled.

Example (in Visual Basic)

ImageKit1.Layer(0).StartX = 300
ImageKit1.Layer(0).StartY = 200
ImageKit1.Refresh()

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


StartDrawY property

Newtone.ImageKit.Win.ImageKit.Layer[Index].StartY Property

This property sets the point on the image that will be displayed from the top left corner of the ImageKit Control. The index can range from 0 to 99.

[Visual Basic] Public Property StartY As Integer
[C#] public int StartY {get; set;}

Property Value

The vertical position on the image that will be displayed from the left of the ImageKit Control.

The default value is 0.

Explanation

The StartY property sets the point on the layer image that will be displayed from the top left corner of the ImageKit Control. The image that the StartY property relates to is the image set in the Layer(Index).Image property.

If the base image has not been set this property is disabled.

Example (in Visual Basic)

ImageKit1.Layer(0).StartX = 300
ImageKit1.Layer(0).StartY = 200
ImageKit1.Refresh()

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


Transparent property

Newtone.ImageKit.Win.ImageKit.Layer[Index].Transparent Property

This property enables the transparent color in the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public Property Transparent As Boolean
[C#] public bool Transparent {get; set;}

Property Value

Value | Explanation
True | The transparent color is enabled
False | The transparent color is disabled (default)

Explanation

The Transparent property enables the transparent color in the image set in the Layer(Index).Image property.

The default value is false.

When the Transparent property is True, the color set by the TransparentBlue, TransparentGreen, and TransparentRed properties will be transparent.

To display multiple images without a transparent color, set this property to false.

If the image set in the Layer(Index).Image property is a vector image, then the Transparent property is disabled.

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


TransparentBlue property

Newtone.ImageKit.Win.ImageKit.Layer[Index].TransparentBlue Property

This property sets the transparent color in the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public Property TransparentBlue As Byte
[C#] public byte TransparentBlue {get; set;}

Property Value

TransparentBlue is the transparent color's blue value. (Values range from 0 to 255)

Explanation

The TransparentBlue property sets the transparent color in the image set in the Layer(Index).Image property. This property is useful when multiple image are displayed at the same time in the ImageKit Control. When a transparent color is used, the next image layer below the transparent color will appear. The image where the transparent color is set must be 8 bit color or 24 bit color and is specified by the Layer(Index).Image property. If a vector image is set in the base image, this property is disabled.

Example: Setting the transparent color to white (in Visual Basic)

ImageKit1.Layer(0).Transparent = True
ImageKit1.Layer(0).TransparentBlue = 255
ImageKit1.Layer(0).TransparentGreen = 255
ImageKit1.Layer(0).TransparentRed = 255
ImageKit1.LayerNumber = 0
ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.Win.LoadFileType.Load)

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


TransparentGreen property

Newtone.ImageKit.Win.ImageKit.Layer[Index].TransparentGreen Property

This property sets the transparent color in the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public Property TransparentGreen As Byte
[C#] public byte TransparentGreen {get; set;}

Property Value

TransparentGreen is the transparent color's blue value. (Values range from 0 to 255)

Explanation

The TransparentGreen property sets the transparent color in the image set in the Layer(Index).Image property. This property is useful when multiple image are displayed at the same time in the ImageKit Control. When a transparent color is used, the next image layer below the transparent color will appear. The image where the transparent color is set must be 8 bit color or 24 bit color and is specified by the Layer(Index).Image property. If a vector image is set in the base image, this property is disabled.

Example: Setting the transparent color to white (in Visual Basic)

ImageKit1.Layer(0).Transparent = True
ImageKit1.Layer(0).TransparentBlue = 255
ImageKit1.Layer(0).TransparentGreen = 255
ImageKit1.Layer(0).TransparentRed = 255
ImageKit1.LayerNumber = 0
ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.Win.LoadFileType.Load)

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


TransparentRed property

Newtone.ImageKit.Win.ImageKit.Layer[Index].TransparentRed Property

This property sets the transparent color in the image set in the Layer(Index).Image property. The index can range from 0 to 99.

[Visual Basic] Public Property TransparentRed As Byte
[C#] public byte TransparentRed {get; set;}

Property Value

TransparentRed is the transparent color's blue value. (Values range from 0 to 255)

Explanation

The TransparentRed property sets the transparent color in the image set in the Layer(Index).Image property. This property is useful when multiple image are displayed at the same time in the ImageKit Control. When a transparent color is used, the next image layer below the transparent color will appear. The image where the transparent color is set must be 8 bit color or 24 bit color and is specified by the Layer(Index).Image property. If a vector image is set in the base image, this property is disabled.

Example: Setting the transparent color to white (in Visual Basic)

ImageKit1.Layer(0).Transparent = True
ImageKit1.Layer(0).TransparentBlue = 255
ImageKit1.Layer(0).TransparentGreen = 255
ImageKit1.Layer(0).TransparentRed = 255
ImageKit1.LayerNumber = 0
ImageKit1.File.LoadImageFromFile(Newtone.ImageKit.Win.LoadFileType.Load)

See Also

ImageKit.Layer Members | Newtone.ImageKit.Win.ImageKit


ImageKit.Magnifier Members

Newtone.ImageKit.Win.ImageKit.Magnifier All Members

Public Properties

Border | Sets whether or not a border is displayed on the magnifier
ShowCursor | Sets whether or not a cursor is displayed in the magnifier
Type | Sets the shape of the magnifier

Public Methods

ShowMagnifier Displays a magnifier in the ImageKit Control. The size of the magnifier is determined by the Height and Width properties.

See Also

Newtone.ImageKit.Win.ImageKit


BorderVisible property

Newtone.ImageKit.Win.ImageKit.Magnifier.Border Property

This property sets whether or not a border is displayed on the magnifier.

[Visual Basic] Public Property Border As Boolean
[C#] public bool Border {get; set;}

Property Value

Value | Explanation
True | A border is displayed on the magnifier (default)
False | A border is not displayed on the magnifier

Explanation

The Border property sets whether or not a border is displayed on the magnifier.

The default value is True. When the Border property is set to True, a black border is displayed on the magnifier.

See Also

ImageKit.Magnifier Members | Newtone.ImageKit.Win.ImageKit


ShowCursor property

Newtone.ImageKit.Win.ImageKit.Magnifier.ShowCursor Property

This property sets whether or not a cursor is displayed in the magnifier.

[Visual Basic] Public Property ShowCursor As Boolean
[C#] public bool ShowCursor {get; set;}

Property Value

Value | Explanation
True | Displays a mouse cursor in the magnifier
False | Does not display a mouse cursor in the magnifier (default)

Explanation

The ShowCursor property sets whether or not a cursor is displayed in the magnifier.

The default value is false. When this property is set to False, no cursor is displayed in the ImageKit Control.

See Also

ImageKit.Magnifier Members | Newtone.ImageKit.Win.ImageKit


Type property

Newtone.ImageKit.Win.ImageKit.Magnifier.Type Property

This property sets the shape of the magnifier.

[Visual Basic] Public Property Type As MagnifierType
[C#] public MagnifierType Type {get; set;}

Property Value

Value | Explanation
RectangleMagnifier | Rectangular magnifier (default)
EllipceMagnifier | Circular magnifier

Explanation

The Type property sets the shape of the magnifier.

When the magnifier is a rectangle, the size of the rectangle is determined by the Width and Height properties. When the magnifier is an ellipse, the Width and Height properties define the rectangle which bounds the ellipse.

See Also

ImageKit.Magnifier Members | Newtone.ImageKit.Win.ImageKit


ShowMagnifier method

Newtone.ImageKit.Win.ImageKit.Magnifier.ShowMagnifier Method

This method displays a magnifier in the ImageKit Control. The size of the magnifier is determined by the Height and Width properties.
[Visual Basic]
Public Function ShowMagnifier(Visible As Boolean, x As Long, y As Long, Scale As Double) As Boolean
[C#]
public bool ShowMagnifier(bool Visible, int x, int y, double Scale)

Parameters

Visible
Sets the display of the magnifier window: True (nonzero) displays the magnifier, False (0) hides the magnifier

x, y
Sets the location of the center of the magnifier (in pixels)

Scale
Sets the magnification of the display in the magnifier (actual size display = 1.0)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The ShowMagnifier method displays a magnifier in the ImageKit Control. The Height and Width properties determine the size of the magnifier and must be set.

When the Visible parameter = False, the x, y, and Scale parameter values are ignored.

The magnifier will be displayed on the image when that image's ShowImage property is set to True. The order in which images are displayed are: base image, layer images (from smallest to largest index).

Note that if the base image has not been set then the layer images are not displayed. The ToolTip property is set to the values other than LengthUnit.None, then the magnifier isn't displayed.

Example

Sample code for displaying the magnifier:

[Visual Basic.NET]
Private Sub ImageKit1_MouseMoveImage(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ImageKit.MouseUpDownEventArgs) Handles ImageKit1.MouseMoveImage
  ImageKit1.Magnifier.Width = 100
  ImageKit1.Magnifier.Height = 100
  ImageKit1.Magnifier.Type = Newtone.ImageKit.Win.MagnifierType.RectangleMagnifier
  ImageKit1.Magnifier.Border = True
  ImageKit1.Magnifier.ShowMagnifier(True, e.X, e.Y, 2)
End Sub

[Visual C#.NET]
private void imageKit1_MouseMoveImage(object sender, Newtone.ImageKit.Win.MouseUpDownEventArgs e)
{
  imageKit1.Magnifier.Width = 100;
  imageKit1.Magnifier.Height = 100;
  imageKit1.Magnifier.Type = Newtone.ImageKit.Win.MagnifierType.EllipseMagnifier;
  imageKit1.Magnifier.Border = true;
  imageKit1.Magnifier.ShowMagnifier(true, e.X, e.Y, 2);
}

See Also

ImageKit.Magnifier Members | Newtone.ImageKit.Win.ImageKit


ImageKit.PanWindow Members

Newtone.ImageKit.Win.ImageKit.PanWindow All Members

Public Properties

Caption | Sets the caption in the Pan Window
CloseBox | Sets whether or not there is a close button on the Pan Window title bar
Color | Sets the color of the Pan Window background
EnableClick | Sets whether or not a mouse click is enabled within the pan window
PWLeft | Sets the left position of the Pan Window
PWSize | Sets the size of the pan window in pixels
PWTop | Sets the top position of the Pan Window
RectColor | Sets the color of the rectangle border in the Pan Window
RectMouseCursor | Sets the shape of the cursor that is used inside the Pan Window
RectReverse | sets whether the RGB values (the colors) within the selected area in the pan window are normal or reversed

Public Methods

Show Displays the pan window on the screen

See Also

Newtone.ImageKit.Win.ImageKit


Caption property

Newtone.ImageKit.Win.ImageKit.PanWindow.Caption Property

This property sets the caption in the Pan Window.

[Visual Basic] Public Property Caption As String
[C#] public string Caption {get; set;}

Property Value

The string for the caption in the Pan Window

Explanation

The Caption property sets the caption in the Pan Window.

If no text has been entered into the Caption property and the CloseBox property is False then the PanWindow will have no title bar and can not be moved with the mouse.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


CloseBox property

Newtone.ImageKit.Win.ImageKit.PanWindow.CloseBox Property

This property sets whether or not there is a close button on the Pan Window title bar.

[Visual Basic] Public Property CloseBox As Boolean
[C#] public bool CloseBox {get; set;}

Property Value

Value | Explanation
True | Close button is displayed on the title bar of the Pan Window
False | Close button is not displayed on the title bar of the Pan Window (default)

Explanation

The CloseBox property sets whether or not there is a close button on the Pan Window title bar. When this property is False, the PanWindow can not be moved with the mouse.

If the close button is not displayed on the title bar, the pan window can be hidden using the Show method.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


Clo‚’ property

Newtone.ImageKit.Win.ImageKit.PanWindow.Color Property

This property sets the color of the Pan Window background.

[Visual Basic] Public Property Color As Color
[C#] public Color Color {get; set;}

Property Value

The color of the Pan Window background, i.e. that part of the pan window where no image is displayed. (Used when vector images are shown in the pan window)

Explanation

The Color property sets the color of the Pan Window background. Color can be set using RGB (Red, Green, Blue) or the equivalent value.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


EnableClick property

Newtone.ImageKit.Win.ImageKit.PanWindow.EnableClick Property

This property sets whether or not a mouse click is enabled within the pan window.

[Visual Basic] Public Property EnableClick As Boolean
[C#] public bool EnableClick {get; set;}

Property Value

Value | Explanation
True | The mouse click is enabled within the pan window
False | The mouse click is disabled within the pan window (Default value)

Explanation

The EnableClick property sets whether or not a mouse click is enabled within the pan window.

When True and the left mouse button is clicked inside the pan window (but outside the rectangle in the pan window), the image in the ImageKit Control will be centered at the click location. The rectangle in the pan window will also be centered at the click location.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


PWLeft property

Newtone.ImageKit.Win.ImageKit.PanWindow.PWLeft Property

This property sets the left position of the Pan Window.

[Visual Basic] Public Property PWLeft As Integer
[C#] public integer PWLeft {get; set;}

Property Value

The distance of the top left corner of the Pan Window from the top left corner of the screen (in pixels).

The PWLeft property sets the left position of the Pan Window.

Explanation

The PWLeft property sets where the left position of the Pan Window will be placed on the screen.

The size of the Pan Window is determined by the PWSize property. By using the pan window you can easily view the entire image currently displayed in the ImageKit Control.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


RectColor property

Newtone.ImageKit.Win.ImageKit.PanWindow.RectColor Property

This property sets the color of the rectangle border in the Pan Window.

[Visual Basic] Public Property RectColor As Color
[C#] public Color RectColor {get; set;}

Property Value

The color of the rectangle border in the Pan Window

Explanation

The RectColor property sets the color of the rectangle border in the Pan Window.Color can be set using RGB (Red, Green, Blue) or the equivalent value.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


PWTop property

Newtone.ImageKit.Win.ImageKit.PanWindow.PWTop Property

This property sets the top position of the Pan Window.

[Visual Basic] Public Property PWTop As Integer
[C#] public integer PWTop {get; set;}

Property Value

The distance of the top left corner of the Pan Window from the top left corner of the screen (in pixels).

The PWTop property sets the top position of the Pan Window.

Explanation

The PWTop property sets where the top position of the Pan Window will be placed on the screen.

The size of the Pan Window is determined by the PWSize property. By using the pan window you can easily view the entire image currently displayed in the ImageKit Control.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


RectMouseCursor property

Newtone.ImageKit.Win.ImageKit.PanWindow.RectMouseCursor Property

This property sets the shape of the cursor that is used inside the Pan Window.

[Visual Basic] Public Property RectMouseCursor As Cursor
[C#] public Cursor RectMouseCursor {get; set;}

Property Value

The members of the Cursors class for .NET Framework

The default value is Cursors.SizeAll.

Explanation

The RectMouseCursor property sets the shape of the cursor that is used inside the Pan Window.

The code below illustrates how to set the shape of the cursor to hourglass: (in Visual Basic)

ImageKit1.PanWindow.RectCursor = Cursors.WaitCursor

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


RectReverse property

Newtone.ImageKit.Win.ImageKit.PanWindow.RectReverse Property

This property sets whether the RGB values (the colors) within the selected area in the pan window are normal or reversed.

[Visual Basic] Public Property RectReverse As Boolean
[C#] public bool RectReverse {get; set;}

Property Value

Value | Explanation
True | Reverses the RGB values within the selected area in the pan window.
False | Does not reverse the RGB values within the selected area in the pan window (default).

Explanation

The RectReverse property sets whether the RGB values (the colors) within the selected area in the pan window are normal or reversed.

When the RectReverse property is True, the RGB values (the colors) inside the selected area will be reversed.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


PWSize property

Newtone.ImageKit.Win.ImageKit.PWPanWindow.PWSize Property

This property sets the size of the pan window in pixels.

[Visual Basic] Public Property PWSize As Integer
[C#] public integer PWSize {get; set;}

Property Value

The size of the pan window in pixels

Explanation

The PWSize property sets the size of the pan window in pixels.

The display of the image in the Pan Window is scaled by taking the longer of either the height or width dimension of the image and scaling that dimension to fit within the size specified in the PWSize property. The other dimension will then be scaled to maintain the original image height to width ratio. Therefore, if the height of the image is the longer than the width, then the value set in the PWSize property will apply to the height of the Pan Window. If the width of the image is the longer than the height, then the value set in the PWSize property will apply to the width of the Pan Window.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


Show method

Newtone.ImageKit.Win.ImageKit.PanWindow.Show Method

This method displays the pan window on the screen.

[Visual Basic] Public Function Show(Visible As Booleana) As Boolean
[C#] public bool Show(bool Visible)

Parameters

Value | Explanation
Visible | Displays or hides the Pan Window [True (nonzero): the Pan Window is displayed, False(0): the Pan Window is hidden]

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Show method displays the pan window on the screen. The location of the pan window is determined by the PWLeft and PWTop properties. The size of the pan window is determined by the PWSize property.

When the Visible parameter is True, the PWLeft, PWTop, and PWSize properties must be set. This method is only enabled when the image is displayed in actual size.

The Pan Window will be displayed when the image's ShowPanWindowImage property is set to True. The order in which images are displayed are: base image, layer images (from smallest to largest index). Note that if the base image has not been set then the layer images are not displayed.

If the ImageKit Control is placed on a modal form then please display the pan window after the form has been displayed.

See Also

ImageKit.PanWindow Members | Newtone.ImageKit.Win.ImageKit


Scan Members

Newtone.ImageKit.Win.ImageKit.Scan All Members

Public Properties

BitDepth | Sets the number of bits per pixel in the scanned image
BitDepthReduction | Sets the method used to reduce the bit depth when scanning in 1 bit color
BorderDetection | Enables automatic border detection
Brightness | Sets the scan brightness
ColorBWRatio | Sets the allowable ratio of color pixels in a document for the scanner to scan in black and white
Compression | Sets the compression method used when an image is transferred via memory
ContainerType | Retrieves the TWAIN container type for the specified capability
Contrast | Sets the scan contrast
Count | Retrieves the number of scanned images
CurrentIndex | Retrieves the index of the current value
DataSourceName | Sets the name of the scan device
DefaultIndex | Retrieves the index of the default value
Deskew | Sets whether or not deskew is enabled
DropoutColor | Sets the dropout color
DynamicThreshold | Sets the dynamic threshold level
ExtendedUserInterface | Sets whether or not the extended user interface is used
FileFormat | Sets the file format when saving a file using file transfer.
FileName | Sets the file name when saving a file using file transfer or using memory transfer with compression
Gamma | Sets the gamma correction
Halftone | Sets the halftone
Highlight | Sets the scanning highlight
IgnoreBackColor | Sets whether or not the background color of the document is ignored when automatically determining whether to scan in black and white or in color
ImageFilter | Sets the image filter
Indicator | Sets whether or not the indicator is displayed when scanning
JpegQuality | Sets the JpegQuality when using file or memory transfer with JPEG compression.
Mode | Sets the scanning mode
MoireFilter | Sets the level for the Moire filter
NoiseFilter | Sets the noise reduction filter
Orientation | Sets the orientation of the paper
PageCount | Sets the number of images to be scanned
PaperSize | Sets the size of the paper
PixelType | Sets the type of image scanned
Rect | Sets the scanning position
RotateBack | Sets whether or not the back side of the page is rotated when scanning on both sides using an ADF
ScanningSpeed | Increases the speed at which a document is scanned
Shadow | Sets the shadow
Sharpness | Sets the level of sharpness
Threshold | Sets the scanning threshold
Transfer | Sets whether native, file, or memory transfer is used
Unit | Sets the units of measurement
UserInterface | Sets whether the scan driver's user interface is used or if a custom built user interface is used.
Value | Retrieves the value supported for the specified capability
XResolution | Sets the horizontal scan resolution
XScaling | Sets the horizontal scaling (magnification)
YResolution | Sets the vertical scan resolution
YScaling | Sets the vertical scaling (magnification)

Public Methods

ClearProperty | Resets the scan control properties
CloseDataSource | Closes the scan device
Execute | Retrieves an image from a TWAIN scan device
GetBitDepth | Retrieves the bit depth supported by the scan device
GetCapabilityEnumToSingle | Retrieves the possible setting values for a specified property of the scan device
GetCapabilityEnumToString | Retrieves the possible setting values for a specified property of the scan device
GetCapabilityRange | Retrieves the range of possible setting values for a specified functionality of the scan device
GetCurrentDataSource | Retrieves information about the scan device currently being selected
GetDataSources | Retrieves information about the specified scan device
GetMinimumSize | Retrieves the smallest size that can be scanned with a given scan device
GetPhysicalSize | Retrieves the largest physical size that can be scanned with a given scan device
Initialize | Starts the TWAIN process
IsCapabilitySupported | Confirms whether or not a functionality is supported by the scan device
IsOpenDataSource | Checks whether or not the scan device is open
OpenDataSource | Opens the scan device
SelectDataSource | Selects the scan device
Terminate | Ends the TWAIN process

See Also

Newtone.ImageKit.Win.ImageKit


BitDepth property

Newtone.ImageKit.Win.ImageKit.Scan.BitDepth Property

This property sets the number of bits per pixel in the scanned image.

[Visual Basic] Public Property BitDepth As Integer
[C#] public int BitDepth {get; set;}

Property Value

When the Pixeltype property is BW, the BitDepth is 1

When the Pixeltype property is Gray, the BitDepth is 4, 8, 12, 14, or 16

When the Pixeltype property is RGB, the BitDepth is 24, 36, 42, or 48

When the Pixeltype property is Palette, the BitDepth is 4 or 8

When the Pixeltype property is Automation, the BitDepth is 24

Retrieve only

Explanation

The BitDepth property sets the number of bits per pixel in the scanned image. This property is only enabled when the UserInterface property is Suppress. Note: If a digital camera image or other scan device does not support this functionality, then this property is disabled.

To retrieve the range of possible bit depth settings for a scan device, execute the GetBitDepth method. When scanning in 12, 14, 16, 36, 42, or 48 bit color, please set the Transfer property to Memory. If an error is returned for a value that the scan device is supposed to support, please set 0 into the BitDepth property in which case the bit depth default value indicated by the PixelType property will be used.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


BitDepthReduction property

Newtone.ImageKit.Win.ImageKit.Scan.BitDepthReduction Property

This property sets the method used to reduce the bit depth when scanning in 1 bit color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property BitDepthReduction As Newtone.ImageKit.ScanBitDepthReduction
[C#] public Newtone.ImageKit.ScanBitDepthReduction BitDepthReduction {set;}

Property Value

This value is of typeScanBitDepthReduction

Explanation

The BitDepthReduction property sets the method used to reduce the bit depth when scanning in 1 bit color. This property is enabled when the UserInterface property is Suppress and the PixelType property is BW. Note: The BitDepthReduction property is disabled when using a digital camera.

When the BitDepthReduction property is Threshold, the Threshold property is enabled (In some scan devices the Brightness property is enabled). When the BitDepthReduction property is Halftone, the HalfTone, Brightness, and Contrast properties are enabled.

To retrieve the value of the BitDepthReduction property that is supported by the scan device, please execute the GetCapabilityEnumToSingle method. In the case where the scan device does not support the BitDepthReduction functionality, but supports either Threshold or HalfTone, then set this property to Threshold or Halftone whichever the case may be.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


BorderDetection property

Newtone.ImageKit.Win.ImageKit.Scan.BorderDetection Property

This property enables automatic border detection. This property is only enabled when using a custom-built user interface (UserInterface= 2).

[Visual Basic] Public WriteOnly Property BorderDetection As Boolean
[C#] public bool BorderDetection {set;}

Property Value

Value | Explanation
True | Automatic border detection is enabled
False | Automatic border detection is disabled

Explanation

The BorderDetection property enables automatic border detection. The document plate scan area will automatically be set according to paper size. This property is only enabled when the UserInterface property is Suppress and the PaperSize property is UndefinedSize. Note: If a digital camera image or other scan device does not support this functionality, then this property is disabled. To find out if the datasource supports this functionality, please execute the IsCapabilitySupported method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Brightness property

Newtone.ImageKit.Win.ImageKit.Scan.Brightness Property

This property sets the scan brightness. Enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic]Public WriteOnly Property Brightness As Integer
[C#]public int Brightness {set;}

Property Value

From -1000 to 1000. The default value is 0.

Explanation

The Brightness property sets the scan brightness. This property is only enabled when the UserInterface property is set to Suppress.

Note: There are cases when the PixelType property is BW and depending on the BitDepthReduction property value the Brightness property has no affect. See below.

The Brightness property is okay

When PixelType = BW and the BitDepthReduction = Threshold (*) or Halftone.

When the PixelType = Gray, RGB, or Palette

(*) This is only for scan devices that do not support Threshold and use uses Brightness instead.

Note: This property is disabled for digital cameras and scanners that do not support these functions. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ColorBWRatio property

Newtone.ImageKit.Win.ImageKit.Scan.ColorBWRatio Property

This property sets the allowable ratio of color pixels in a document for the scanner to scan in black and white. Beyond this value, the scanner will scan in rgb color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property ColorBWRatio As Single
[C#] public float ColorBWRatio {set;}

Property Value

The value range is from 0.01 to 50.00 in percentage units.

Default value is 1.

Explanation

The ColorBWRatio property is useful in determining whether or not to scan in RGB color or black and white. This property sets the allowable ratio of color pixels in a document for the scanner to scan in black and white. Beyond this value, the scanner will scan in rgb color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

ENABLED FOR PANASONIC SCAN DRIVERS ONLY

The default value is one, meaning that the scanner will scan in rgb color. The allowable range that can be set in the ColorBWRatio property is from 0.01 to 50.00 percent. As the value of this property increases, a larger proportion of pixels in the document must be color before the scanner will scan in rgb color. This property is only enabled when the UserInterface property is Suppress, and the PixelType property is Automation.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Compression property

Newtone.ImageKit.Win.ImageKit.Scan.Compression Property

This property sets the compression method used when an image is transferred via memory.

[Visual Basic] Public Property Compression As Newtone.ImageKit.ScanCompression
[C#] public Newtone.ImageKit.ScanCompression Compression {get; set;}

Property Value

This value is of type ScanCompression

Explanation

The Compression property sets the compression method used when an image is transferred via memory. For details about the different methods for transferring images, please refer to the Transfer property. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. Depending on the datasource, uncompressed may be the only file transfer compression method available.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ContainerType property

Newtone.ImageKit.Win.ImageKit.Scan.ContainerType Property

This property retrieves the TWAIN container type for the specified capability.

[Visual Basic] Public ReadOnly Property ContainerType As Integer
[C#] public int ContainerType {get;}

Property Value

Value | Explanation
0 | Failed method
3 | Array Type
4 | Enumeration Type
5 | Single Type
6 | Range Type

Explanation

The ContainerType property retrieves the TWAIN container type for the capability specified. By executing the GetCapabilityEnumToSingle, GetCapabilityEnumToString, and GetCapabilityRange, the values are set in this property.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Brightness property

Newtone.ImageKit.Win.ImageKit.Scan.Contrast Property

This property sets the scan contrast. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Contrast As Integer
[C#] public int Contrast {set;}

Property Value

From -1000 to 1000. The default value is 0

Explanation

The Contrast property sets the scan contrast. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

Note: There are cases when the PixelType property is BW and depending on the BitDepthReduction property value the Contrast property has no affect. See below.

The Contrast property is okay

When PixelType = BW and the BitDepthReduction = Halftone.

When the PixelType = Gray, RGB, or Palette

Note: This property is disabled for digital cameras and scanners that do not support these functions. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Count property

Newtone.ImageKit.Win.ImageKit.Scan.Count Property

This property retrieves the number of scanned images.
[Visual Basic] Public ReadOnly Property Count As Integer
[C#] public int Count {get;}

Property Value

The number of scanned images

Explanation

The Count property retrieves the number of scanned images. After executing the Execute method, the value is set in this property.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


CurrentIndex property

Newtone.ImageKit.Win.ImageKit.Scan.CurrentIndex Property

This property retrieves the index of the current value.

[Visual Basic] Public ReadOnly Property CurrentIndex As Integer
[C#] public int CurrentIndex {get;}

Property Value

The index of the current value

Explanation

The CurrentIndex property retrieves the index of the current value. When the GetCapabilityEnumToSingle method, the GetCapabilityEnumToString method, or the GetDataSources method is executed, the retrieved values are set in an array. This property retrieves the index in the array that refers to the current value. If any of the above methods fail, -1 will be set in the CurrentIndex property.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


DataSourceName property

Newtone.ImageKit.Win.ImageKit.Scan.DataSourceName Property

This property sets the name of the scan device.

[Visual Basic] Public Property DataSourceName As String
[C#] public string DataSourceName {set;}

Property Value

The name of the scan device

Explanation

The DataSourceName property sets the name of the scandevice. The DataSourceName property must be set prior to executing the OpenDataSource or the Execute methods. However, if the Execute method is executed after the OpenDataSource method then the DataSourceName property value will be disregarded. If the DataSourceName property is not set, the scan device selected by the SelectDataSource method will be used.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


DefaultIndex property

Newtone.Win.ImageKit

Newtone.ImageKit.Win.ImageKit.Scan.DefaultIndex Property

This property retrieves the index of the default value

[Visual Basic] Public ReadOnly Property DefaultIndex As Integer
[C#] public int DefaultIndex {get;}

Property Value

The index of the default value

Explanation

When the GetCapabilityEnumToSingle method or the GetCapabilityEnumToString method are executed the values are returned in an array. The DefaultIndex property retrieves the index that refers to the default value. If the above methods fail, -1 will be set in this property.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Deskew property

Newtone.ImageKit.Win.ImageKit.Scan.Deskew Property

This method sets whether or not deskew is enabled. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Deskew As Integer
[C#] public int Deskew {set;}

Property Value

Value | Explanation
0 | Deskew is disabled
1 | Deskew is enabled
2 | Deskew is enabled (with smoothing)

Explanation

The Deskew method sets whether or not deskew is enabled when scanning. This property is only enabled when the UserInterface property is Suppress. Note: If a digital camera image or other scan device does not support this functionality, then this property is disabled. The Deskew property is enabled when the PaperSize property is set to UndefinedSize. However, there are cases, depending on the datasource, when the Deskew property is enabled for other paper sizes as well.

Deskew with smoothing is only available for certain Panasonic scan drivers (memory transfer uncompressed mode only).

To find out if the datasource supports this functionality, please execute the IsCapabilitySupported method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


DropoutColor property

Newtone.ImageKit.Win.ImageKit.Scan.DropoutColor Property

This Property sets the dropout color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property DropoutColor As Newtone.ImageKit.ScanDropoutColor
[C#] public Newtone.ImageKit.ScanDropoutColor DropoutColor {set;}

Property Value

This value is of type ScanDropoutColor

Explanation

The DropoutColor property sets the dropout color. This property is only enabled when the UserInterface property is Suppress, and the PixelType property is either BW or Gray. Note: If a digital camera image or other scan device does not support this functionality, then this property is disabled. To disable the dropout color, please set this property to None or White. To find out if the datasource supports this functionality, please execute the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


DynamicThreshold property

Newtone.ImageKit.Win.ImageKit.Scan.DynamicThreshold Property

This method sets the dynamic threshold level. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property DynamicThreshold As Integer
[C#] public int DynamicThreshold {set;}

Property Value

Value | Explanation
0 | None
1 | Bright
2 | A little brighter
3 | Standard
4 | A little darker
5 | Dark

Explanation

The DynamicThreshold property sets the dynamic threshold level.

DynamicThreshold is only available on certain Panasonic scan drivers

Dyanamic threshold functionality allows you to scan text and images clearly with optimum quality. This property is enabled when the UserInterface property is Suppress and PixelType property is BW. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. When setting the DynamicThreshold property to 1 or more, then the values set in the BitDepthReduction, HalfTone, Sharpness , and Threshold properties will be disabled.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ExtendedUserInterface property

Newtone.ImageKit.Win.ImageKit.Scan.ExtendedUserInterface Property

This property sets whether or not the extended user interface is used.

[Visual Basic] Public WriteOnly Property ExtendedUserInterface As Integer
[C#] public int ExtendedUserInterface {set;}

Property Value

Value | Explanation
0 | Start up the UserInterface mode that was last used
1 | Start up the professional mode
2 | Start up the automatic mode
3 | Start up the home mode
4 | Start up the automatic mode (with no error messages and supressed UI)
5 | Start up office mode

Explanation

The ExtendedUserInterface property sets whether or not the extended user interface is used.

Extended UserInterface mode is available only for certain Epson scan drivers

The ExtendedUserInterface property settings are only possible when displayed with the standard "EPSON Scan" user interface. For example: In ES Series, all settings except 2 and 4 are possible. In the GT Series, all settings except 5 is possible when not connected to the ADF but if the ADF is connected then settings 2 or 4 are also not possible. The ExtendedUserInterface property is enabled when the UserInterface property is Show or ShowandClose.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


FileFormat property

Newtone.ImageKit.Win.ImageKit.Scan.FileFormat Property

This property sets the file format when saving a file using file transfer.

[Visual Basic] Public Property FileFormat As Newtone.ImageKit.ScanFileFormat
[C#] public Newtone.ImageKit.ScanFileFormat FileFormat {get; set;}

Property Value

This value is of type ScanFileFormat

Explanation

The FileFormat property sets the file format when saving a file using file transfer. Please set at appropriate value in the Compression property for the file format set here. Note that depending on the datasource, only uncompressed mode is possible when using file transfer. To retrieve the values supported by the datasource, please execute the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


FileName property

Newtone.ImageKit.Win.ImageKit.Scan.FileName Property

This property sets the file name when saving a file using file transfer or using memory transfer with compression.

[Visual Basic] Public WriteOnly Property FileName As String
[C#] public string FileName {set;}

Property Value

The file name of the saved file

Explanation

The FileName property sets the file name when saving a file using file transfer or using memory transfer with compression. When the Transfer property is File or Memory and the Compression property is set to values other than None then the file will be saved according to the FileName property. (up to 255 bytes). If the FileName property is set with an empty string, null, or Nothing then the file cannot be saved. When using file transfer mode the a FileName property MUST be set. When the UserInterface property is Suppress and the Mode property is DocumentPlate, the file will be saved according to the FileName property. However, for other settings, a four digit series of numbers will be added just before the file extention. (i.e. Image.bmp will be Image0001.bmp).

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Gamma property

Newtone.ImageKit.Win.ImageKit.Scan.Gamma Property

This property sets the gamma correction. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Gamma As Single
[C#] public float Gamma {set;}

Property Value

The default value is 2.2.

Explanation

The Gamma property sets the gamma correction for the scan. This property is enabled when the UserInterface property is Suppress and the PixelType propery is other than BW. However, the Gamma property is disabled when using a digital camera or when the datasource does not support this functionality. To retrieve the values supported, please execute the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Halftone property

Newtone.ImageKit.Win.ImageKit.Scan.Halftone Property

This property sets the halftone. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Halftone As String
[C#] public string Halftone {set;}

Property Value

The halftone name

Explanation

The HalfTone property sets the halftone. This property is enabled when the UserInterface property is Suppress, the PixelType property is BW, and the BitDepthRedution property is Halftone. However, the Halftone property is disabled when using a digital camera or when the datasource does not support this functionality. To retrieve the values supported, please execute the GetCapabilityEnumToString method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Highlight property

Newtone.ImageKit.Win.ImageKit.Scan.Highlight Property

This property sets the scanning highlight. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Highlight As Integer
[C#] public int Highlight {set;}

Property Value

From 0 to 255

The Highlight property sets the highlight. (Default value is 255)

Explanation

The Highlight property sets the scanning highlight. This property is enabled when the UserInterface property is Suppress and the PixelType property value is other than BW. However, the Highlight property is disabled when using a digital camera or when the datasource does not support this functionality. To retrieve the values supported, please execute the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit.Scan


IgnoreBackColor property

Newtone.ImageKit.Win.ImageKit.Scan.IgnoreBackColor Property

This property sets whether or not the background color of the document is ignored when automatically determining whether to scan in black and white or in color. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property IgnoreBackColor As Boolean
[C#] public bool IgnoreBackColor {set;}

Property Value

Value | Explanation
True | Ignore the back color
False | Does not ignore the back color (Default)

Explanation

The IgnoreBackColor property sets whether or not the background color of the document is ignored when automatically determining whether to scan in black and white or in color.

IgnoreBackColor is only available with certain Panasonic scan drivers

This property is enabled when the UserInterface property is Suppress and the PixelType property is Automation.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ImageFilter property

Newtone.ImageKit.Win.ImageKit.Scan.ImageFilter Property

This property sets the image filter. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property ImageFilter As Newtone.ImageKit.ScanImageFilter
[C#] public Newtone.ImageKit.ScanImageFilter ImageFilter {set;}

Property Value

This value is of type ScanImageFilter

Explanation

The ImageFilter property sets the image filter, which can improve image quality. LOWPASS is recommended for haftone images, BANDPASS for images that include text, and HIGHPASS for images that include lines. The ImageFilter property is enabled when the UserInterface property is Suppress. Note that the ImageFilter property is disabled when using a digital camera or when the datasource does not support this functionality. To retrieve the values supported, please execute the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Indicator property

Newtone.ImageKit.Win.ImageKit.Scan.Indicator Property

This property sets whether or not the indicator is displayed when scanning. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Indicator As Boolean
[C#] public bool Indicator {set;}

Property Value

Value | Explanation
True | The indicator is displayed
False | The indicator is not displayed

Explanation

The Indicator property sets whether or not the indicator is displayed when scanning. This property is enabled when the UserInterface property is Suppress.

Note: The Indicator property is disabled for scan devices that do not support this function.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


JpegQuality property

Newtone.ImageKit.Win.ImageKit.Scan.JpegQuality Property

This property sets the JpegQuality when using file or memory transfer with JPEG compression.

[Visual Basic] Public WriteOnly Property JpegQuality As Integer
[C#] public int JpegQuality {set;}

Property Value

Possible setting range is from 0 to 100. Other possible values are:
-4F Undefined
-3F Low quality
-2F Middle quality
-1F High quality

Explanation

The JpegQuality property sets the JpegQuality when using file or memory transfer with JPEG compression. This property is enabled when the Transfer property is File or Memory and the Compression property is Jpeg. The possible setting values supported by a scan device can be retrieved using the the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Orientation property

Newtone.ImageKit.Win.ImageKit.Scan.Orientation Property

This property sets the orientation of the paper. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public Property Orientation As Newtone.ImageKit.ScanOrientation
[C#] public Newtone.ImageKit.ScanOrientation Orientation {get; set;}

Property Value

This value is of type ScanOrientation

Explanation

The Orientation property sets the orientation of the paper. This allows you to do things like rotate the scan output from the document plate or scan pages from an ADF where the pages are inserted 'on their side', etc. This property is enabled when the UserInterface property is Suppress.

Note: This property is disabled for digital cameras and scanners that do not support this function. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. To determine whether TextOrientationRecognition is supported by a scan device, please use the IsCapabilitySupported method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Mode property

Newtone.ImageKit.Win.ImageKit.Scan.Mode Property

This property sets the scanning mode. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public Property Mode As Newtone.ImageKit.ScanMode
[C#] public Newtone.ImageKit.ScanMode Mode {get; set;}

Property Value

This value is of type ScanMode

Explanation

The Mode property sets the scanning mode. This property is enabled when the UserInterface is Suppress. When the Mode property is CameraArray or CameraThumbnailArray, the array values passed to the Execute method are enabled, otherwise these array values are disabled.

Note: Even if the scan device being used supports duplex scanning, some scan drivers will not fully support duplex scanning when the user interface is suppressed (UserInterface=Suppress).

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


MoireFilter property

Newtone.ImageKit.Win.ImageKit.Scan.MoireFilter Property

This property sets the level for the Moire filter. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property MoireFilter As Integer
[C#] public int MoireFilter {set;}

Property Value

For Epson Scan Drivers
Value | Explanation
0 | None
1 | Standard (This can be used for general settings)
2 | 85 lpi (This can be used for Newspapers)
3 | 133 lpi (This can be used for Magazines and Catalogs)
4 | 175 lpi (This can be used for Pictures)

For Canon DR Scan Drivers
Value | Explanation
1 | None
2 | High scan speed
3 | High scan quality

Explanation

The MoireFilter property sets the level for removal of moire interference. This property is enabled when the UserInterface property is Suppress.

The Moire filter is enabled for certain Epson and Canon DR scan drivers. When using an Epson scanner, the datasource will be "Epson Scan" which will allow the above settings. Note that some Epson scanners, depending on the version, allow for only "on / off" settings. In this case the ImageKit will accept values of 0 or nonzero.

When using a Canon DR scanner, this property is enabled when the scan resolution is set to 300dpi or less. This property is disabled when the scan datasource does not support Moire filter.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


NoiseFilter property

Newtone.ImageKit.Win.ImageKit.Scan.NoiseFilter Property

This property sets the noise reduction filter. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property NoiseFilter As ScanNoiseFilter
[C#] public ScanNoiseFilter NoiseFilter {set;}

Property Value

This value is of type ScanNoiseFilter

Explanation

The NoiseFilter property sets the noise reduction filter for black and white images. This property is enabled when the UserInterface property is Suppress however it is disabled when using a digital camera. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


PageCount property

Newtone.ImageKit.Win.ImageKit.Scan.PageCount Property

This property sets the number of images to be scanned. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property PageCount As Integer
[C#] public int PageCount {set;}

Property Value

Value | Explanation
0 or less | Scans all images (ADF, digital camera)
1 or more | Scans the specified number of images

Explanation

The PageCount property sets the number of images to be scanned. This property is enabled when the UserInterface property is Suppress. To scan all of the images in the ADF or digital camera, set this property to 0 or less. To specify the number of images to be scanned, set that number in the PageCount property. When retrieving images from a digital camera using an array, pleaes refer to the Execute method to be the same as the number of elements in the array. When the Mode property is ADFBothSide, even if an odd number is set into the PageCount property, the number of pages scanned will be an even number (so as to scan both sides of the paper).

The PageCount property is disabled when the UserInterface property is NOT Suppress or when using the document plate to scan. When the PixelType property is either GrayAndBW or RGBAndBW, even though this property value is set to 1 or more, the scan will occur as if the this property value is 0 or less.

Note: Not all scan devices support this functionality. In some cases where the scan device does not support this function or does not correctly support this function, after the number of images specified by the PageCount property have been scanned, the scanning procedure is canceled. Depending on the type of equipment, paper could be left inside the scan device or ADF.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


PaperSize property

Newtone.ImageKit.Win.ImageKit.Scan.PaperSize Property

This property sets the size of the paper. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property PaperSize As Newtone.ImageKit.ScanPaperSize
[C#] public Newtone.ImageKit.ScanPaperSize PaperSize {set;}

Property Value

This value is of typeScanPaperSize

Explanation

The PaperSize property sets the size of the paper. This property is enabled when the UserInterface property is Suppress. However this property is disabled when using a digital camera. To enable the Rect property, set the PaperSize property to UserSize or a negative value.

Depending on the datasource (scan driver), using a user defined paper size (UserSize) and setting the scan area, may still result in a start position of the scan being incorrect. If that is the case, please use one of the above constant values listed in the ScanPaperSize enum (1 or more) for the paper size and set this to a NEGATIVE value. (Please refer to the example code below).

Note: Please set the PaperSize property to a size supported by the datasource (scan driver) or set it to the largest supported paper size. With some datasources the PaperSize property has no effect. Please refer to the scan manufacturer for details.

The possible PaperSize settings supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. For scan devices that only support a fixed paper size or do not support paper size settings set this property to UserSize.

When PaperSize is set to "UndefinedSize" (1000), the paper size is automatically detected then the document is scanned, however, with scanners that can only detect one dimension (either height or width) there are cases when the automatic detection does not work properly. Also if scanning problems occur when theTransfer property is set to Memory, change the Transfer property setting to Native. To find out if "UndefinedSize" paper size is supported by the datasource, please execute the IsCapabilitySupported method.

Example

( The PaperSize is set to UserSize and the scan area is set but the scan position is wrong )

[Visual Basic.NET]
ImageKit1.Scan.UserInterface = ScanUserInterface.Suppress
ImageKit1.Scan.Unit = ScanUnit.Inch
ImageKit1.Scan.PaperSize = ScanPaperSize.UserSize
ImageKit1.Scan.Rect = new RectangleF(0, 0, CSng(6.9), CSng(10.2))

[Visual C#.NET]
imageKit1.Scan.UserInterface = ScanUserInterface.Suppress;
imageKit1.Scan.Unit = ScanUnit.Inch;
imageKit1.Scan.PaperSize = ScanPaperSize.UserSize;
imageKit1.Scan.Rect = new RectangleF(0, 0, (float)6.9, (float)10.2);

( The PaperSize is set to one of the above constants with a NEGATIVE value --> the scan position is correct)

[Visual Basic.NET]
ImageKit1.Scan.UserInterface = ScanUserInterface.Suppress
ImageKit1.Scan.Unit = ScanUnit.Inch
ImageKit1.Scan.PaperSize = -3 ' US Letter size
ImageKit1.Scan.Rect = new RectangleF(0, 0, CSng(6.9), CSng(10.2))

[Visual C#.NET]
imageKit1.Scan.UserInterface = ScanUserInterface.Suppress;
imageKit1.Scan.Unit = ScanUnit.Inch;
imageKit1.Scan.PaperSize = (ScanPaperSize)(-3); // US Letter size
imageKit1.Scan.Rect = new RectangleF(0, 0, (float)6.9, (float)10.2);

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


PixelType property

Newtone.ImageKit.Win.ImageKit.Scan.PixelType Property

This property sets the type of image scanned. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public Property PixelType As Newtone.ImageKit.ScanPixelType
[C#] public Newtone.ImageKit.ScanPixelType PixelType {get; set;}

Property Value

This value is of type ScanPixelType

Explanation

The PixelType property sets the type of image scanned. This property is enabled when the UserInterface is Suppress. This property is disabled for digital cameras and scanners that do not support this function. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. Whether or not Automation, GrayAndBW, or RGBAndBW is supported, please check with the IsCapabilitySupportedmethod.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Rect property

Newtone.ImageKit.Win.ImageKit.Scan.Rect Property

This property sets the scanning position. This property is enabled when using a custom-built user interface (UserInterface=Suppress).
[Visual Basic] Public Property Rect As System.Drawing.RectangleF
[C#] public System.Drawing.RectangleF Rect {get; set;}

Property Value

The value of this property depends on the Unit property setting. The minimum value is 0.

Explanation

The Rect property sets the scanning position of the area on the image to be scanned. This property value is enabled when the UserInterface property is Suppress and the PaperSize property is 0. This property setting is disabled when theUserInterface property is set to values other than Suppress or when the PaperSize property is 1 or more, or when images are retrieved from a digital camera.

After the scan has completed, the exact dimensions (in the units specified in the Unit property) of the actual area scanned are reset into the value of the Rect property. (This dimension may be slightly different than the value set by the user prior to the scan). When using the default value of the datasource, set the RectangleF constructor with all parameter values set to 0 or use RectangleF.Empty.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


RotateBack property

Newtone.ImageKit.Win.ImageKit.Scan.RotateBack Property

This property sets whether or not the back side of the page is rotated when scanning on both sides using an ADF.

[Visual Basic] Public WriteOnly Property RotateBack As Integer
[C#] public int RotateBack {set;}

Property Value

Value | Explanation
0 | Do not rotate the back side of pages
1 | Rotate the back side of pages 180 degrees

Explanation

The RotateBackproperty sets whether or not the back side of the page is rotated when scanning on both sides using an ADF.

Enabled for Epson scan drivers "EPSON Scan", however "EPSON Scan" Ver.1.x does not support sizes bigger than A4. "Epson Scan" configuration "Match front and back images during duplex scanning" is the same as RotateBack = 1.

This property is enabled when the UserInterface is Suppress and Mode property is ADFBothSide. This property is disabled for digital cameras and scan devices that do not support this function. The possible setting values supported by a scan device can be retrieved using the IsCapabilitySupported method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ScanningSpeed property

Newtone.ImageKit.Win.ImageKit.Scan.ScanningSpeed Property

This property increases the speed at which a document is scanned. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property ScanningSpeed As Integer
[C#] public int ScanningSpeed {set;}

Property Value

For Epson scan drivers

Value | Explanation
0 | For quality
1 | For speed

For Panasonic scan drivers

Value | Explanation
0 | Slow
1 | Normal
2 | Fast

Explanation

The ScanningSpeedproperty increases the speed at which a document is scanned.

Scanning speed is available only for certain Epson and Panasonic scanners

This property is enabled when the UserInterface is Suppress. Note: Increasing the speed at which the scan drivers scan a document can result in reduced quality. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Shadow property

Newtone.ImageKit.Win.ImageKit.Scan.Shadow Property

This property sets the shadow. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).
[Visual Basic] Public WriteOnly Property Shadow As Integer
[C#] public int Shadow {set;}

Property Value

From 0 to 255 (Default value is 0)

Explanation

The Shadow property sets the shadow. This property is enabled when the UserInterface property is Suppress.

The Shadow property is disabled if the PixelType property is BW.

Note: This property is disabled for digital cameras and scanners that do not support this function. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Sharpness property

Newtone.ImageKit.Win.ImageKit.Scan.Sharpness Property

This property sets the level of sharpness. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Sharpness As Integer
[C#] public int Sharpness {set;}

Property Value

Epson scan driver (unsharp mask)

Value | Explanation
0 | None
1 | Weak
2 | Normal
3 | Strong

Panasonic scan driver (quality)

Value | Explanation
0 | None
1 | Smooth
2 | Low
3 | Standard
4 | High

Explanation

The Sharpness property sets the level of sharpness.

Sharpness is enabled for certain Epson and Panasonic scan drivers only. When using an Epson scanner, the datasource will be "Epson Scan" which will allow the above gradated settings. Note that some Epson scanners, depending on the version, allow for only "on / off" settings. In this case the ImageKit will accept values of 0 or nonzero.

For Epson scanners, the "unsharp mask" is used and for Panasonic scanners "image quality" is used.

This property is enabled when the UserInterface is Suppress. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Threshold property

Newtone.ImageKit.Win.ImageKit.Scan.Threshold Property

This property sets the scanning threshold. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property Threshold As Integer
[C#] public int Threshold {set;}

Property Value

From 0 to 255 (Default value is 128)

Explanation

The Threshold property sets the scanning threshold. This property is only enabled when the UserInterface property is Suppress.

The Threshold property requires that the PixelType property be BW and the BitDepthReduction property be Threshold. For scan devices that use brightness instead of threshold, the Brightness property value will be used.

Note: This property is disabled for digital cameras and scanners that do not support this function. The possible setting values supported by a scan device can be retrieved using the GetCapabilityEnumToSingle or the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Transfer property

Newtone.ImageKit.Win.ImageKit.Scan.Transfer Property

This property sets whether native, file, or memory transfer is used.

[Visual Basic] Public Property ScanTransfer As Newtone.ImageKit.Transfer
[C#] public Newtone.ImageKit.ScanTransfer Transfer {get; set;}

Property Value

This value is of type ScanTransfer

Explanation

The TransferMode property sets whether native, file, or memory transfer is used. It is necessary to set this property prior to executing the Execute method. The possible transfer methods supported by a scan device can be retrieved using the GetCapabilityEnumToSingle method. Scanning events are generated for the memory transfer mode only.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Unit property

Newtone.ImageKit.Win.ImageKit.Scan.Unit Property

This property sets the units of measurement when scanning with a custom built user interface (UserInterface=Suppress).

[Visual Basic] Public Property Unit As Newtone.ImageKit.ScanUnit
[C#] public Newtone.ImageKit.ScanUnit Unit {get; set;}

Property Value

This value is of type ScanUnit

Explanation

The Unit property sets the units of measurement used to set the scanning area. This property is enabled when the UserInterface is Suppress. The Rect property values will use the unit of measurement set in the Unit property.

Although the Unit property is disabled when the UserInterface is NOT Suppress, when scanning, the units of measurement of the scan are returned to this property. To retrieve the values of the Unit property supported by the scan device, execute the GetCapabilityEnumToSingle method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


UserInterface property

Newtone.ImageKit.Win.ImageKit.Scan.UserInterface Property

This property sets whether the scan driver's user interface is used when scanning or if a custom built user interface is used.

[Visual Basic] Public Property UserInterface As Newtone.ImageKit.ScanUserInterface
[C#] public Newtone.ImageKit.ScanUserInterface UserInterface {get; set;}

Property Value

This value is of type ScanUserInterface

Explanation

The UserInterface property sets whether the scan driver's user interface is used when scanning or if a custom built user interface is used.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Value property

Newtone.ImageKit.Win.ImageKit.Scan.Value Property

This property retrieves the value supported for the specified capability.
[Visual Basic]
Public ReadOnly Property Value As Integer
[C#]
public int Value {get;}

Property Value

The following values are of type ScanCapability, are set in the capability parameter of the IsCapabilitySupported method.

Parameter | Value
Document feeder function (FeederEnabled) | 0: cannot be used, 1: feeder can be used
The function that checks whether or not there is paper in the document feeder (FeederLoaded) | 0: there is no paper, 1: there is paper
Indicator | 0: cannot use indicator, 1: can use indicator
UI control function (UIControllable) | 0: must use manufacturer's UI only, 1: manufacturer's UI can be suppressed
The function that checks whether the power is on (DeviceOnline) | 0: Power is off, 1: Power is on
The function that transfers thumbnail images (ThumbnailEnabled) | 0: cannot transfer thumbnails, 1: can transfer thumbnails
Duplex scanning with the document feeder (Duplex) | 0: can not scan both sides, 1: can scan both sides at once, 2: can scan both sides but takes two scans
Undefined scan size (UndefinedImageSize) | For most scanners 0: undefined size cannot be used, 1: undefined size can be used. For certain Epson scanners 0: undefined size cannot be used, 1: possible only with document plate, 2: possible only with ADF, 3: possible with both document plate and ADF
How many images are in a digital camera (ImageDataSet) | The returned number is the number of images
BorderDetection | 0: border detection is not possible, 1: border detection is possible
Deskew | 0: cannot use deskew, 1: can use deskew, 2: can use deskew with smoothing 2 is only available for certain Panasonic scan drivers. In that case, 1 can be used.
The maximum resolution when using a moire filter (MoireFilterMaxResolution) | The value is that maximum resolution. Available only for certain Epson scan drivers
RotateBack when using ADF in duplex mode (RotateBack) | 0: rotating the back side is not possible, 1: rotating the back side is possible. Available only for certain Epson "Epson Scan" scan drivers
Automatically detecting ratio of BW/Color (PixelAutomation) | 0: cannot automatically detect BW/Color, 1: can automatically detect BW/Color. Available only for certain Panasonic scan drivers

Explanation

The property values will be set after the IsCapabilitySupported method is executed. If the return value of the IsCapabilitySupported method is False, then -1 is set in the Value property.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


XResolution property

Newtone.ImageKit.Win.ImageKit.Scan.XResolution Property

This property sets the horizontal scan resolution. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public Property XResolution As Integer
[C#] public int XResolution {get; set;}

Property Value

The horizontal and vertical scan resolution are set in DPI units.

XResolution is the horizontal scan resolution

Explanation

The XResolution property sets the horizontal scan resolution. This property is enabled when the UserInterface property is Suppress. When the UserInterface property is NOT Suppress or when a digital camera is being used, these properties are disabled. The range of resolution and the resolution values supported by the scan device can be retrieved by executing the GetCapabilityEnumToSingle or the GetCapabilityRange method. To use the scan device default resolution values, set this property to -1.

Note: Although it is possible to set different values for the horizontal and vertical resolution, some datasources (scanner drivers) do not support different values for horizontal and vertical resolution. In such cases, either the horizontal resolution or the vertical resolution will be enabled. To retrieve the actual resolution, refer to the XResolution and YResolution properties within the BeforeScan event or after executing the Execute method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


XScaling property

Newtone.ImageKit.Win.ImageKit.Scan.XScaling Property

This property sets the horizontal scaling (magnification). This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property XScaling As Single
[C#] public float XScaling {set;}

Property Value

XScaling is the horizontal scaling

Default value is 1.0

Explanation

The XScaling property sets the horizontal scaling (magnification). This property is only enabled when the UserInterface property is Suppress. If the UserInterface is set to a value other than Suppress or if a digital camera is being used, this property is disabled. The range and values of scaling supported by the scan device can be retrieved by executing the GetCapabilityEnumToSingle or the GetCapabilityRange method.

To scan in actual size, set the XScaling and YScaling properties to 1.0

Note: Although it is possible to set different values for horizontal and vertical scaling some datasources (scan drivers) do not support this. In such cases, either the horizontal scaling value or the vertical scaling value will be used.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


YResolution property

Newtone.ImageKit.Win.ImageKit.Scan.YResolution Property

This property sets the vertical scan resolution. This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public Property YResolution As Integer
[C#] public int YResolution {get; set;}

Property Value

The horizontal and vertical scan resolution are set in DPI units.

YResolution is the vertical scan resolution

Explanation

The YResolution property sets the vertical scan resolution. This property is enabled when the UserInterface property is Suppress. When the UserInterface property is NOT Suppress or when a digital camera is being used, this property is disabled. The resolution values and range supported by the scan device can be retrieved by executing the GetCapabilityEnumToSingle or the GetCapabilityRange method. To use the scan device default resolution values, set this property to -1.

Note: Although it is possible to set different values for the horizontal and vertical resolution, some datasources (scanner drivers) do not support different values for horizontal and vertical resolution. In such cases, either the horizontal resolution or the vertical resolution will be enabled. To retrieve the actual resolution, refer to the XResolution and YResolutionproperties within the BeforeScan event or after executing the Execute method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


YScaling property

Newtone.ImageKit.Win.ImageKit.Scan.YScaling Property

This property sets the vertical scaling (magnification). This property is only enabled when using a custom-built user interface (UserInterface=Suppress).

[Visual Basic] Public WriteOnly Property YScaling As Single
[C#] public float YScaling {set;}

Property Value

YScaling is the vertical scaling

Default value is 1.0

Explanation

The YScaling property sets the vertical scaling (magnification). This property is only enabled when the UserInterface property is Suppress. If the UserInterface is set to a value other than Suppress or if a digital camera is being used, this property is disabled. The range and values of scaling supported by the scan device can be retrieved by executing the GetCapabilityEnumToSingle or the GetCapabilityRange method.

To scan in actual size, set the XScaling and YScaling properties to 1.0

Note: Although it is possible to set different values for horizontal and vertical scaling some datasources (scan drivers) do not support this. In such cases, either the horizontal scaling value or the vertical scaling value will be used.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ClearProperty method

Newtone.ImageKit.Win.ImageKit.Scan.ClearProperty Method

This method resets the scan control properties.

[Visual Basic] Public Sub ClearProperty()
[C#] public void ClearProperty();

Return Value

None

Explanation

The ClearProperty method resets all property values to their default values (Doesn't include specialized referenced properties).

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


CloseDataSource method

Newtone.ImageKit.Win.ImageKit.Scan.CloseDataSource Method

This method closes the scan datasource (scan device).

[Visual Basic] Public Function CloseDataSource() As Boolean
[C#] public bool CloseDataSource();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CloseDataSource method closes the datasource that was opened by the OpenDataSource method.

Prior to executing the CloseDataSource and OpenDataSource methods, you must execute the Initialize method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Execute method

Newtone.ImageKit.Win.ImageKit.Scan.Execute Method

This method retrieves an image from a TWAIN datasource (scan device).

[Visual Basic] Public Function Execute() As Boolean
Public Function Execute(ByVal index() As Integer) As Boolean
[C#] public bool Execute();
public bool Execute(int[] index);

Parameters

index
An array containing the image indexes. (used with a digial camera)

Return Value

Returns true if successful. Returns False if unsuccessful.

Explanation

The Execute method retrieves an image from a TWAIN datasource (scan device). Events are generated before, during, and after the scan so it is possible to write processing code in each of these stages of the scan process.

The Index parameter is enabled only when the UserInterface property is Suppress and the Mode property is set for a digital camera. However, in other situations where this array of index values is not needed, please use methods which doesn't have any parameters. The Index parameter is used to specify which image is retrieved from the digital camera (the index parameter is enabled when the Mode property is CameraArray or CameraThumbnailArray).

For example, to retrieve the 5th and 8th image from a digital camera, set the Index array parameter to

Index(0) = 5

Index(1) = 8

Some scan devices do not support these functions. In such cases, only the supported functions are used to scan the image.

Prior to executing the Execute method, you must execute the Initialize method.

If the OpenDataSource method is executed prior to the Execute method, then while the scan device is open, other applications can not use that scan device and it becomes the exclusive datasource for this execution.

The following properties should be set prior to executing the Execute method

[Required properties]

  • DataSourceName - if this property is blank, then select the scan device by executing the Select method. Note: If the OpenDataSource method is executed prior to setting the DataSourceName property then the DataSourceName is disabled and the open scan device is used.
  • Transfer
  • Compression
  • UserInterface
  • ExtendedUserInterface) - This property is required only when using Epson scanner drivers.

[These properties may be required depending on the settings]

  • FileFormat
  • FileName
  • JpegQuality

[If the UserInterface property is Suppress]

  1. When using a scanner, it is recommended that the following properties be set when the UserInterface property is Suppress:
    BitDepth, BitDepthReduction, BorderDetection, Brightness, ColorBWRatio, Contrast, Deskew , DropoutColor, DynamicThreshold , Gamma, HalfTone, Highlight, IgnoreBackColor, ImageFilter, Indicator, Mode, MoireFilter, NoiseFilter, Orientation , PageCount, PaperSize, PixelType, ScanningSpeed, Shadow, Sharpness , Threshold, Unit, Unit, XResolution, XScaling, YResolution, YScaling, PaperSize<=0: Rect

    Note: TheColorBWRatio, DynamicThreshold, IgnoreBackColor, MoireFilter , RotateBack, ScanningSpeed , Sharpness properties are sometimes disabled depending on the scan driver.
  2. When using a digital camera, it is recommended that these properties be set when the UserInterface property is Suppress:
    Mode, PageCount (when the Index parameter is unnecessary), Unit

<The following properties are set after the scan has executed>

BitDepth, Compression, ErrorStatus, FileFormat (when using file transfer method), PixelType , Rect, Count, Unit, XResolution, YResolution

For details, please refer to the respective properties' explanations.

Important points when using a custom built user interface (UserInterface = Suppress)

When UserInterface is Suppress, depending on the scan device and the property values set, the scan can fail. For the most part the causes for scan failure when the UserInterface is Suppress can be traced to the following:

  1. The scan units set are not supported by the scan device. The supported scan unit values can be retrieved using the GetCapabilityEnumToSingle method.
  2. The pixel type set is not supported by the scan device. The supported pixel type values can be retrieved using the GetCapabilityEnumToSingle method.
  3. The bit count set is not supported by the scan device. The supported bit count values can be retrieved using the GetBitDepth method.
  4. The resolution set is not supported by the scan device. The supported resolution values can be retrieved using the GetCapabilityEnumToSingle or the GetCapabilityRange methods.
  5. The paper size set is not supported by the scan device. The supported values can be retrieved using the GetCapabilityEnumToSingle method.
    1. If settings for paper size are not supported at all, then set the PaperSize property to UserSize and set the appropriate scan area in the Rect property. If the scan area is not correctly set (i.e. it is smaller than the minimum or larger than the maximum), the scan can fail. The proper scan area values can be retrieved using the GetMinimumSize and GetPhysicalSize methods.
    2. If paper size settings are supported and the scan still fails, check to make sure the PaperSize property is set to a value other than UserSize.

Example

Scan using the scan driver's user interface

[Visual Basic.NET]
Dim Ret As Boolean
Ret = ImageKit1.Scan.Initialize(Me.Handle, 1, 0, "1.00", "NEWTONE Corp.", "ImageKit", "ImageKit.NET Scan Sample")
If Ret = false Then Exit Sub
ImageKit1.Scan.ClearProperty()
ImageKit1.Scan.Transfer = ScanTransfer.Memory
ImageKit1.Scan.Compression = ScanCompression.None
ImageKit1.Scan.UserInterface = ScanUserInterface.Show
ImageKit1.Scan.DataSourceName = "EPSON TWAIN Pro"
Ret = ImageKit1.Scan.Execute()
Ret = ImageKit1.Scan.Terminate()

[Visual C#.NET]
bool Ret;
Ret = imageKit1.Scan.Initialize(this.Handle, 1, 0, "1.00", "NEWTONE Corp.", "ImageKit", "ImageKit.NET Scan Sample");
if (!Ret) return;
imageKit1.Scan.ClearProperty();
imageKit1.Scan.Transfer = ScanTransfer.Memory;
imageKit1.Scan.Compression = ScanCompression.None;
imageKit1.Scan.UserInterface = ScanUserInterface.Show;
imageKit1.Scan.DataSourceName = "EPSON TWAIN Pro";
Ret = imageKit1.Scan.Execute();
Ret = imageKit1.Scan.Terminate();

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetBitDepth method

Newtone.ImageKit.Win.ImageKit.Scan.GetBitDepth Method

This method retrieves the bit depth supported by the scan device.

[Visual Basic] Public Function GetBitDepth() As Integer()
[C#] public int[] GetBitDepth();

Return Value

An array containing the bit depths supported by the scan device (Returns null[C#] or Nothing[VB.NET] if unsuccessful).

Explanation

The GetBitDepth method retrieves the bit depth supported by the scan device. To retrieve the bit depth, the PixelType and DataSourceName property must be set. If the DataSourceName property is blank, then prior to executing this method, please execute the SelectDataSource method. (Note: If the OpenDataSource method has been executed then the DataSourceName is disabled and the opened scan device will be used). The supported bit depth retrieved by the GetBitDepth method depends on the value set in the PixelType property. Therefore the PixelType property must also be set. Please set the values supported by the scan device into the PixelType property.

Prior to executing the GetBitDepth method, you must execute the Initialize method.

If the OpenDataSource method is executed prior to the GetBitDepth method, then while the scan device is open, other applications can not use that scan device and it becomes the exclusive datasource for this execution.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetCapabilityEnumToSingle method

Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityEnumToSingle Method

This method retrieves the possible setting values for a specified property of the scan device.

[Visual Basic] Public Function GetCapabilityEnumToSingle(ByVal capability As Newtone.ImageKit.ScanCapability) As Single()
[C#] public float[] GetCapabilityEnumToSingle(Newtone.ImageKit.ScanCapability capability);

Parameters

capability
The number for the retrieved capability (Values are of typeScanCapability enumeration)

Return Value

An array of supported values (Returns null [C#] or Nothing [Visual Basic] if unsuccessful).

Explanation

The GetCapabilityEnumToSingle method retrieves the possible setting values for a specified property of the scan device. To retrieve the possible setting values for a property it is first necessary to set the DataSourceName property. If the DataSourceName property is blank then please execute the SelectDataSource method prior to executing the GetCapabilityEnumToSingle method. (Note: If the OpenDataSource method is executed prior to the GetCapabilityEnumToSingle method the the DataSourceName is disabled and the open datasource is used).

To execute the GetCapEnum method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetCapabilityEnumToSingle method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

After executing the GetCapabilityEnumToSingle method, the values are set into the ContainerType, CurrentIndex, and DefaultIndex properties.

Content of the Returned Value

Parameter | Return Value
Compression | A member of type ScanCompression enumeration
PixelType | A member of type ScanPixelType enumeration
Unit | A member of type ScanUnit enumeration
Transfer | A member of type ScanTransfer enumeration
Brightness | The possible brightness values
Contrast | The possible contrast values
Gamma | The possible gamma values
Highlight | The possible highlight values
ImageFileFormat | A member of type ScanFileFormat enumeration
DropoutColor | A member of type ScanDropoutColor enumeration
Orientation | A member of type ScanOrientation enumeration
Shadow | The possible shadow values
XResolution | The possible horizontal resolution values
YResolution | The possible vertical resolution values
PaperSize | A member of type ScanPaperSize enumeration
Threshold | The possible threshold values
XScaling | The possible horizontal scaling values
YScaling | The possible vertical scaling values
BitDepthRedution | A member of type ScanBitDepthReduction enumeration
ImageFilter | A member of type ScanImageFilter enumeration
NoiseFilter | A member of type ScanNoiseFilter enumeration
JpegQuality | The possible JpegQuality values
ScanningSpeed | This is enabled only for certain Epson and Panasonic scanners (1) Epson Scan Drivers - 0: For Quality, 1: For Speed (2) Panasonic Scan Drivers - 0: Slow, 1: Normal, 2: Fast
MoireFilter | This is enabled only for certain Epson and Canon DR scanners (1) For Epson Scan - 0: None, 1: Standard, 2: 85lpi (For Newspapers), 3: 133lpi (for Magazines and Catalogs), 4: 175lpi (for Photographs) (2) For Canon DR - 1: None, 2: High Speed, 3: High Quality
Sharpness | This is enabled only for certain Epson and Panasonic scanners For Epson scanners, the "unsharp mask" is used and for Panasonic scanners "image quality" is used. (1)Epson Scan Drivers - 0F None, 1: Weak 2: Normal (default), 3: Strong (2)Panasonic Scan Drivers - 0: None, 1: Smooth, 2: Low, 3: Standard, 4: High
ExtendedUserInterface | This is enabled only for certain Epson scanners 0: Starts up the UserInterface that was last used, 1: Starts up the professional mode, 2: Starts up the automatic mode, 3: Starts up the home mode, 4: Starts up the automatic mode (with no error messages and supressed UserInterface), 5: Starts up office mode
DynamicThreshold | This is enabled only for certain Panasonic scanners 0: None, 1: Bright, 2: A little brighter, 3: Standard, 4: A little darker, 5: Dark

When ContainerType = 3, the value is returned but the CurrentIndex and DefaultIndex are not enabled.
When ContainerType = 4, the value is returned and the array index referring to the CurrentIndex and DefaultIndex contain the current and default values.
When ContainerType = 5, the array index 0 contains the current value (default value)
When ContainerType = 6, the array index 0 contains the minimum value, the index 1 contains the maximum value, the index 2 contains the step value, the index 3 contains the default value, the index 4 contains the current value which can be various different values. This is the same result as executing the GetCapabilityRange method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetCapabilityEnumToString method

Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityEnumToString Method

This method retrieves the possible setting values for a specified property of the scan device.

[Visual Basic] Public Function GetCapabilityEnumToString(ByVal capability As Newtone.ImageKit.ScanCapability) As String()
[C#] public string[] GetCapabilityEnumToString(Newtone.ImageKit.ScanCapability capability);

Parameters

capability
The number for the retrieved capability (Value is of typeScanCapability enumeration)

Return Value

An array of supported values (Returns null [C#] or Nothing [Visual Basic] if unsuccessful).

Explanation

The GetCapabilityEnumToString method retrieves the possible setting values for a specified property of the scan device. To retrieve the possible setting values for a property it is first necessary to set the DataSourceName property. If the DataSourceName property is blank then please execute the SelectDataSource method prior to executing the GetCapabilityEnumToString method. (Note: If the OpenDataSource method is executed prior to the GetCapabilityEnumToString method the the DataSourceName is disabled and the open datasource is used). If the CapNo refers to halftone, then the List array is not used, however you must pass a dummy array or NULL into the List parameter. ListNum is also not used in this case so please set it to 0.

To execute the GetCapabilityEnumToString method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetCapabilityEnumToString method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

After executing this method, the values are set into the ContainerType, CurrentIndex, and DefaultIndex properties.

Content of the Returned Value

When the capability is Halftone, the returned values reflect the possible halftone values that can be set.

When ContainerType = 3, the value is returned but the CurrentIndex and DefaultIndex are not enabled.
When ContainerType = 4, the value is returned and the array index referring to the CurrentIndex and DefaultIndex contain the current and default values.
When ContainerType = 5, the array index 0 contains the current value (default value)
When ContainerType = 6, there is no return value.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetCapabilityRange method

Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange Method

This method retrieves the range of possible setting values for a specified functionality of the scan device.

[Visual Basic] Public Function GetCapabilityRange(ByVal capability As Newtone.ImageKit.ScanCapability) As Newtone.ImageKit.CapabilityRange
[C#] public Newtone.ImageKit.CapabilityRange GetCapabilityRange(Newtone.ImageKit.ScanCapability capability);

Parameters

capability
The number for the retrieved functionality in hexidecimal notation (value is of typeScanCapability)

Return Value

The CapabilityRange class (Returns null[C#] or Nothing[Visual Basic] if unsuccessful).

Explanation

The GetCapabilityRange method retrieves the range of possible setting values for a specified functionality of the scan device. To retrieve the range of possible values for a setting, the DataSourceName property must be set. If the DataSourceName property is blank then prior to executing this method, please execute the SelectDataSource method. (If the OpenDataSource method has been executed, the DataSourceName is disabled and the open scan device will be used.)

To execute the GetCapabilityRange method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetCapRange method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

After executing this method, the value is set into the ContainerType property.

Contents of the return value

Parameter | Return Value
Brightness | Range Information
Contrast | Range Information
Gamma | Range Information
Highlight | Range Information
Shadow | Range Information
XResolution | Range Information
YResolution | Range Information
Threshold | Range Information
XScaling | Range Information
YScaling | Range Information
JpegQuality | Range Information

When ContainerType = 3 or 4, then the number of elements in the list is set into the Maximum property for the CapabilityRange class. Use this number and execute the GetCapabilityEnumToSingle method.

When ContainerType = 5, then the current value is set into the Current property for the CapabilityRange class and the default value is set into the Default property.

When ContainerType = 6, then values are set into the Current, Range, Maximum, Minimum, and Step properties.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetCurrentDataSource method

Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource Method

This method retrieves information about the scan device currently being selected.

[Visual Basic] Public Function GetCurrentDataSource() As Newtone.ImageKit.DataSourceInformation
[C#] public Newtone.ImageKit.DataSourceInformation GetCurrentDataSource();

Return Value

The DataSourceInformation class (Returns null[C#] or Nothing[Visual Basic] if unsuccessful).

Explanation

The GetCurrentDataSource method retrieves information about the scan device currently being selected. If successful, information about the scan device is set in the following properties: Manufacturer, ProductFamily, ProductName, ProtocolMajor, ProtocolMinor, MajorVersion, MinorVersion, and Information of the DataSourceInformation class.

To execute the GetCurrentDataSource method, you must first execute the Initialize method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetDataSources method

Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources Method

This method retrieves information about the specified scan device, such as manufacturer, product name, etc.

[Visual Basic] Public Function GetDataSources() As Newtone.ImageKit.DataSourceInformation()
[C#] public Newtone.ImageKit.DataSourceInformation[] GetDataSources();

Return Value

Value is an array of the DataSourceInformation class. (Returns null [C#] or Nothing [Visual Basic] if unsuccessful).

Explanation

The GetDataSources method retrieves information about the specified scan device, such as manufacturer, product name, etc. If successful, the installed datasources (scan devices) are returned and the index of the current datasource is set in the CurrentIndex property.

To execute the GetDataSources method, you must first execute the Initialize method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetMinimumSize method

Newtone.ImageKit.Win.ImageKit.Scan.GetMinimumSize Method

This method retrieves the smallest size that can be scanned with a given scan device.

[Visual Basic] Public Function GetMinimumSize() As SizeF Public Function GetMinimumSize(ByVal dpiX As Integer, ByVal dpiY As Integer) As SizeF
 [C#]
public SizeF GetMinimumSize();
public SizeF GetMinimumSize(int dpiX, int dpiY);

Parameters

dpiX
The horizontal resolution (in dots per inch)

dpiY
The vertical resolution (in dots per inch)

Return Value

The smallest size that can be scanned (If unsuccessful, the Height and Width properties of the SizeF structure will be 0)

Explanation

The GetMinimumSize method retrieves the smallest size that can be scanned with a given scan device. To retrieve the smallest size the DataSourceName, Mode, and Unit properties must be set. If the DataSourceName property is blank then prior to executing this method, please execute the SelectDataSource method. (If the OpenDataSource method has been executed, the DataSourceName is disabled and the open scan device will be used.) Set the Mode property from 0 to 2 and set the Unit to values supported by the datasource (scan device). The Width and Height parameters of the SizeF structure will return values depending on the Mode and Unit properties.

To execute the GetMinimumSize method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetMinimumSize method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


GetPhysicalSize method

Newtone.ImageKit.Win.ImageKit.Scan.GetPhysicalSize Method

This method retrieves the largest physical size that can be scanned with a given scan device.

[Visual Basic] Public Function GetPhysicalSize() As SizeF Public Function GetPhysicalSize(ByVal dpiX As Integer, ByVal dpiY As Integer) As SizeF
[C#] public SizeF GetPhysicalSize();
public SizeF GetPhysicalSize(int dpiX, int dpiY);

Parameters

dpiX
Horizontal Resolution (in dots per inch)
dpiY
Vertical Resolution (in dots per inch)

Return Value

The largest physical size that can be scanned. (If unsuccessful, the SizeF structure's Height and Width properties will be 0)

Explanation

The GetPhysicalSize method retrieves the largest physical size that can be scanned with a given scan device. To retrieve the largest physical size the DataSourceName, Mode, and Unit properties must be set. If the DataSourceName property is blank then prior to executing this method, please execute the SelectDataSource method. (If the OpenDataSource method has been executed, the DataSourceName is disabled and the open scan device will be used.) Set the Mode property from 0 to 2 and set the Unit to values supported by the datasource (scan device). The Width and Height parameters of the SizeF structure will return values depending on the Mode and Unit properties. If Unit is set to Pixel and no parameter is passed then the current resolution (dpi) will be used.

To execute the GetPhysicalSize method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the GetPhysicalSize method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Initialize method

Newtone.ImageKit.Win.ImageKit.Scan.Initialize Method

This method starts the TWAIN process.

[Visual Basic] Public Function Initialize( ByVal hWnd As IntPtr, ByVal majorNumber As Integer, ByVal minorNumber As Integer, ByVal versionInfomation As String, ByVal manufacturer As String, ByVal productFamily As String, ByVal productName As String ) As Boolean
[C#] public bool Initialize( IntPtr hWnd, int majorNumber, int minorNumber, string versionInfomation, string manufacturer, string productFamily, string productName );

Parameters

hWnd
The form window handle
majorNumber
The major version number of the application (If the version is 1.00, then this value will be 1)
minorNumber
The minor version number of the application (If the version is 1.00, then this value will be 0)
versionInfomation
The application version information (up to 32 bytes)
manufacturer
The name of the manufacturer of the application (up to 32 bytes)
productFamily
The application's product family name (up to 32 bytes)
productName
The application's product name (up to 32 bytes)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Initialize method starts the TWAIN process. When using TWAIN functions, the Initialize method must be executed. MajorNumber, MinorNumber, VersionInfomation, Manufacturer, ProductFamily, ProductName parameters are used to notify TWAIN of various information about the application.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


IsCapabilitySupported method

Newtone.ImageKit.Win.ImageKit.Scan.IsCapabilitySupported Method

This method confirms whether or not a functionality is supported by the datasource (scan device).

[Visual Basic] Public Function IsCapabilitySupported(ByVal capability As Newtone.ImageKit.ScanCapability) As Boolean
[C#] public bool IsCapabilitySupported(Newtone.ImageKit.ScanCapability capability);

Parameters

capability
The number for the retrieved functionality in hexadecimal (A member ofScanCapability)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The IsCapabilitySupported method confirms whether or not a functionality is supported by the datasource (scan device). To retrieve the supported range for a functionality, the DataSourceName property must be set. If the DataSourceName property is blank then prior to executing this method, please execute the SelectDataSource method. (If the OpenDataSource method has been executed, the DataSourceName is disabled and the open scan device will be used.

To execute the IsCapabilitySupported method you must first execute the Initialize method. If the OpenDataSource method is executed prior to executing the IsCapSupported method then the open datasource cannot be used by another application until that datasource (scan device) is closed.

After executing this method, the values are set in the Value property.

The values set in the Value property:

Parameter | The setting value
Document feeder function ( FeederEnabled ) | 0: cannot be used, 1: feeder can be used
The function that checks whether or not there is paper in the document feeder ( FeederLoaded ) | 0: there is no paper, 1: there is paper
Indicator | 0: cannot use indicator, 1: can use indicator
UI control function ( UIControllable ) | 0: must use manufacturer's UI only, 1: manufacturer's UI can be suppressed
The function that checks whether the power is on ( DeviceOnline ) | 0: Power is off, 1: Power is on
the function that transfers thumbnail images ( ThumbnailEnabled ) | 0: cannot transfer thumbnails, 1: can transfer thumbnails
Duplex scanning with the document feeder ( Duplex ) | 0: 0: can not scan both sides, 1: can scan both sides at once, 2: can scan both sides but takes two scans
The undefined size ( UndefinedImageSize ) | In general, 0: undefined size cannot be used, 1: undefined size can be used. However, with certain Epson scan drivers the following values are set, 0: undefined size cannot be used, 1: possible only with document plate, 2: possible only with ADF, 3: possible with both document plate and ADF
How many images are in a digital camera( ImageDataSet ) | the returned number is the number of images
BorderDetection | 0: border detection is not possible, 1: border detection is possible
Deskew | 0: cannot use deskew, 1: can use deskew, 2: can use deskew with smoothing 2 is only available for certain Panasonic scan drivers. In that case, 1 can be used.
the maximum resolution when using a moire filter ( MoireFilterMaxResolution ) | the value is that maximum resolution Available only for certain Epson scan drivers
RotateBack when using ADF in duplex mode ( RotateBack ) | 0: rotating the back side is not possible, 1: rotating the back side is possible Available only for certain Epson "Epson Scan" scan drivers
Automatically detecting ratio of BW/Color ( PixelAutomation ) | 0: cannot automatically detect BW/Color, 1: can automatically detect BW/Color Available only for certain Panasonic and Canon DR scan drivers
MultiStream | 0: multi-stream is not possible, 1: multi-stream is possible (Multi-stream is where 1 scan of the document plate results in retrieving two images of different pixel types) Available only for certain Panasonic scan drivers
TextOrientationRecognition | 0: Automatic orientation based on text is not possible, 1: Automatic orientation based on text is possible Available only for certain Canon DR scan drivers

If the return value of the IsCapabilitySupported method is False, then -1 is set in the Value property.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


IsOpenDataSource method

Newtone.ImageKit.Win.ImageKit.Scan.IsOpenDataSource Method

This method checks whether or not the scan devices are open.

[Visual Basic] Public Function IsOpenDataSource() As Boolean
[C#] public bool IsOpenDataSource();

Return Value

Returns True when open. Returns False when not open.

Explanation

The IsOpenDataSource method checks whether or not the scan devices are open. If the OpenDataSource method is executed prior to the IsOpenDataSource method and the scan devices are open then the return value of this method is True.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


OpenDataSource method

Newtone.ImageKit.Win.ImageKit.Scan.OpenDataSource Method

This method opens the scan datasource (scan device).

[Visual Basic] Public Function OpenDataSource() As Boolean
[C#] public bool OpenDataSource();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The OpenDataSource method opens the datasource set in the DataSourceName property. If the DataSourceName property is blank, please execute the SelectDataSource method prior to executing the OpenDataSource method. (When the DataSourceName property is blank, null, or Nothing, the datasource is selected by the SelectDataSource method).

Note: After the OpenDataSource method has been executed, the datasource remains open until the CloseDataSource method is executed and other applications will not be able to be used.

Prior to executing the OpenDataSource and CloseDataSource methods, you must execute the Initialize method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


SelectDataSource method

Newtone.ImageKit.Win.ImageKit.Scan.SelectDataSource Method

This method selects the scan device.

[Visual Basic] Public Function SelectDataSource() As Newtone.ImageKit.DataSourceInformation
[C#] public Newtone.ImageKit.DataSourceInformation SelectDataSource();

Return Value

The DataSourceInformation class (Returns null[C#] or Nothing[VB.NET] if unsuccessful or canceled.

Explanation

The SelectDataSource method selects the scan device. When this method is executed, the installed TWAIN drivers are listed in a dialog box and can be selected. If successful, information about the scan device is set in the following properties: Manufacturer, ProductFamily, ProductName, ProtocolMajor, ProtocolMinor, MajorVersion, MinorVersion, and Information of the DataSourceInformation class.

Prior to executing the SelectDataSource method, you must execute the Initialize method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


Terminate method

Newtone.ImageKit.Win.ImageKit.Scan.Terminate Method

This method ends the TWAIN process.

[Visual Basic] Public Function Terminate() As Boolean
[C#] public bool Terminate();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Terminate method ends the TWAIN process. This method must be used in conjunction with the Initialize method.

See Also

Scan Members | Newtone.ImageKit.Win.ImageKit


ImageKit.File Members

Newtone.ImageKit.Win.ImageKit.Vector All Members

Public Methods

RasterToVector | Converts a raster image to a vector image
VectorToRaster | Converts a vector image to a raster image

See Also

Newtone.ImageKit.Win.ImageKit


RasterToVector method

Newtone.ImageKit.Win.ImageKit.Vector.RasterToVector Method

This method converts a raster image to a vector image.

[Visual Basic] Public Function RasterToVector(BlackOnWhite As Boolean, Tolerance As Integer, TimeOutSeconds As Integer) As Boolean
[C#] public bool RasterToVector(bool BlackOnWhite, int Tolerance, int TimeOutSeconds) ;

Parameters

BlackOnWhite
False(0): White characters on a black background
True(nonzero): Black characters on a white background

Tolerance
From 0 (high sensativity) to 10 (low sensativity)

TimeOutSeconds
The number of seconds before the process is canceled

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The RasterToVector method converts a raster image to a vector image. Supports black and white (1 bit) images. The raster image to be processed is set in the Image property or the Layer(LayerNumber).Image property (Depending on the value of the LayerNumber property).

If successful the input raster image handle is freed from the memory and the new vector image handle is set into the Image property or the Layer(LayerNumber).Image property (Depending on the value of the LayerNumber property). If the time to process exceeds the value set in the TimeOutSeconds parameter, the process will be canceled.

To use this method, you must have the appropriate ImageKit7 Dlls files.

See Also

ImageKit.Vector Members | Newtone.ImageKit.Win.ImageKit


VectorToRaster method

Newtone.ImageKit.Win.ImageKit.Vector.VectorToRaster Method

This method converts a vector image to a raster image.

[Visual Basic] Public Function VectorToRaster(BitCount As Integr, DxfBlack As Boolean, BackRed As Integer, BackGreen As Integer, BackBlue As Integer) As Boolean
[C#] public bool VectorToRaster(int BitCount, bool DxfBlack, int BackRed, int BackGreen, int BackBlue) ;

Parameters

BitCount
The bitcount of the raster image at time of conversion (1, 4, 8, 16, 24, 32)

DxfBlack
Reverses black and white in DXF images.
[ True(nonzero): Reverses color, False(0): does not reverse color]

BackRed
Background color (RGB red value)

BackGreen
Background color (RGB green value)

BackBlue
Background color (RGB blue value)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The VectorToRaster method converts a vector image to a raster image. The vector image to be processed is set in the Image property
or the Layer(LayerNumber).Image property (Depending on the value of the LayerNumber property).

If successful the input vector image handle is freed from the memory and the new raster image handle is set into the Image property or the Layer(LayerNumber).Image property (Depending on the value of the LayerNumber property).

To use this method, you must have the appropriate ImageKit7 Dlls files.

See Also

ImageKit.Vector Members | Newtone.ImageKit.Win.ImageKit


ImageKitWinThumbnail class

Newtone.ImageKit.Win.Thumbnail Class

The main class for the WinForm Thumbnail Control

For a list of all members of this type, see Thumbnail Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Newtone.ImageKit.Win
public class Thumbnail : System.Windows.Forms.Control

Explanation

The Thumbnail Control allows you to display multiple image files as thumbnail images simply by specifying the image directories and image file types. Events are generated when thumbnails are selected either by the mouse, the keyboard, or by executing Thumbnail methods.

Requirement

Namespace : Newtone.ImageKit.Win

Assembly : Newtone.ImageKit.Win.Thumbnail.dll

See Also

Thumbnail Members


Thumbnail Members

Newtone.ImageKit.Win.Thumbnail All Members

Thumbnail Overview

Public Constructor

Thumbnail Constructor Initializes a new instance of the Thumbnail class

Public Properties

AllowDrag | Sets whether or not a thumbnail image can be dragged from the thumbnail control and dropped into the ImageKit Control or into another Thumbnail Control
Appearance | Sets the appearance of the Thumbnail Control
ArrayDirectoryName | Retrieves the image file's directory name from the thumbnail image specified by the ArrayImageNumber property
ArrayFileName | Retrieves the image file's filename from the thumbnail image specified by the ArrayImageNumber property
ArrayImageNumber | Uses the thumbnail image number to retrieve the image file's filename, directory name, and page number
ArrayPageNumber | Retrieves the image file's page number from the thumbnail image specified by the ArrayImageNumber property
BorderColor | Sets the color for the border of the Thumbnail Control
BorderVisible | Sets whether or not the Thumbnail Control border is displayed
BorderWidth | Sets the size of the area between the edge of the Thumbnail Control and the display of the thumbnails
Button3D | Sets whether or not the individual frames of the Thumbnail Control are shown in 3D
Cancel | Sets whether or not the process of displaying images in the Thumbnail Control is canceled
CellSpacing | Sets the amount of space (in pixels) between the thumbnail cells
ClearOnLoad | Sets whether or not previously loaded images are cleared when an image is loaded into the Thumbnail Control
ColumnNumber | Sets the number of columns displayed in the Thumbnail Control
EnableArrowKeys | Sets whether or not the arrow keys and the PageUp, PageDown keys on the keyboard can be used to scroll the images in the Thumbnail Control
EnableMouseMoveButton | Sets whether or not the thumbnail image is selected when the mouse moves over that thumbnail image frame
EnableMouseWheel | Sets whether or not the mouse wheel is enabled
EnableSelectMultiFiles | Sets whether or not multiple thumbnail images can be selected
ErrorStatus | Refers to the types of errors that can occur when using the Thumbnail Control
FileExtension | Sets the the image type that can be displayed in the Thumbnail Control
FileName | Refers to the filename of the image when the thumbnail image is selected
FilePath | Sets the file path to the directories containing the images
ForeColorDown | Sets the color of the thumbnail image frame when the image is selected
ForeColorUp | Sets the color of the thumbnail frame when the thumbnail image is not selected
Image | Refers to the image handle of the image loaded into the Thumbnail Control
ImageSize | Sets the size of the thumbnail image when it is displayed
LoadMode | Sets how images are loaded and displayed in the Thumbnail Control
PictureDown | Sets a background image displayed on the the display area of the thumbnail image
PictureUp | Sets a background image displayed on the display area of the thumbnail image when the thumbnail has not been clicked
RowNumber | Sets the number of rows displayed in the Thumbnail Control
ScrollBar | Sets whether or not scroll bars are enabled on the Thumbnail Control
ScrollDirection | Sets whether the Thumbnail Control can be scrolled horizontally or vertically
ScrollStep | Sets the size of the scroll step
SelectTextBackColor | Sets the background color of the text (either filename or comment) for the selected thumbnail image
SelectTextColor | Sets the color of the text (either filename or comment) for the selected thumbnail image
SelectTextTransparent | Sets whether or not the transparency is enabled when the filename or comment is displayed in the thumbnail cell that has been selected
ShowFileName | Sets whether or not the file name of the image in the Thumbnail Control is displayed under the image
Sort | Sets the sorting method for the image files contained in the folder(s) specified by the FilePath property
SortDate | Sets how the files will be sorted when the Sort property is set to SortDate
SortOrder | Sets whether the image files set in the FilePath property are sorted in ascending or descending order
StartNumber | Sets the image number of the thumbnail image displayed in the top left corner of the Thumbnail Control
Style | Sets the style of the thumbnail image frame
TextBackColor | Sets the background color for the text (either the filename or comment) for a thumbnail image
TextColor | Sets the color of the text (either the filename or comment) for a thumbnail image
TextTransparent | Sets whether or not the transparency is enabled when the filename or comment is displayed in the thumbnail cell
ThumbnailFile | Sets the thumbnail file used by the Thumbnail Control
TotalImageNumber | Retrieves the total image number of the thumbnail images

Public Methods

Clear | Clears the Thumbnail Control
DeleteImage | Deletes the specified thumbnail image from Thumbnail Control
DeSelectImage | Deselects a thumbnail image that has been selected
Display | Displays the thumbnail images
GetFiles | Acquires the thumbnail image
IsSelected | Determines if the specified thumbnail image is selected
Scroll | Scrolls the thumbnail images
SelectImage | Selects a thumbnail image
UpdateThumbnailFile | Updates the thumbnail file

Public Events

EndLoadFile | Generated after each image is loaded into the Thumbnail Control
MouseMoveOnThumbnail | Generated when the mouse is moved over a thumbnail image in the Thumbnail Control
SelectFile | Generated when a thumbnail image is selected. Thumbnail images can be selected by clicking the mouse, using the keyboard, or executing the SelectImage method
ShowThumbnailImage | Generated just after a thumbnail image is displayed in the Thumbnail Control
StartLoadFile | Generated before each image is loaded on the Thumbnail Control

See Also

Newtone.ImageKit.Win.Thumbnail


ImageKit.Win.Thumbnail Constructor

Newtone.ImageKit.Win.Thumbnail Constructor

This initializes a new instance of the Thumbnail class.

[Visual Basic] Public Sub New()
[C#] public Thumbnail()

See Also

Thumbnail Members | Newtone.ImageKit.Win. Thumbnail


AllowDrag property

Newtone.ImageKit.Win.Thumbnail.AllowDrag Property

This property sets whether or not a thumbnail image can be dragged from the thumbnail control and dropped into the ImageKit Control or into another Thumbnail Control.

[Visual Basic] Public Property AllowDrag As Boolean
[C#] public bool AllowDrag {get; set;}

Property Value

Value | Explanation
True | Enables the ability to drag and drop thumbnail images into the ImageKit Control or another Thumbnail Control
False | Disables the ability to drag and drop thumbnail images into the ImageKit Control or another Thumbnail Control (default)

Explanation

The AllowDrag property sets whether or not a thumbnail image can be dragged from the thumbnail control and dropped into the ImageKit Control or into another Thumbnail Control. Set this property to True to enable drag and drop.

To enable dragging and dropping from another control to the Thumbnail Control, please set the AllowDrop property to True. (AllowDrop is a standard .NET Framework property. See appropriate .NET Framework help for details)

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Appearance property

Newtone.ImageKit.Win.Thumbnail.Appearance Property

This property sets the appearance of the Thumbnail Control.

[Visual Basic] Public Property Appearance As ThumbnailAppearance
[C#] public ThumbnailAppearance Appearance {get; set;}

Property Value

This value is of type ThumbnailAppearance

Explanation

The Appearance property sets the appearance of the Thumbnail Control. The Appearance property is enabled when the BorderVisible property is set to True. When the Appearance property is set to Flat, the border color is determined by the BorderColor property.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ArrayDirectoryName property

Newtone.ImageKit.Win.Thumbnail.ArrayDirectoryName Property

This property retrieves the image file's directory name from the thumbnail image specified by the ArrayImageNumber property.

[Visual Basic] Public ReadOnly Property ArrayDirectoryName As String
[C#] public string ArrayDirectoryName {get;}

Property Value

The name of the directory containing the image file

Explanation

The ArrayDirectoryName property retrieves the image file's directory name from the thumbnail image specified by the ArrayImageNumber property. If the ArrayImageNumber property refers to an image that is not loaded from file, then the ArrayDirectoryName property will be an empty string or null (in Visual Basic, Nothing).

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ArrayFileName property

Newtone.ImageKit.Win.Thumbnail.ArrayFileName Property

This property retrieves the image file's filename from the thumbnail image specified by the ArrayImageNumber property.

[Visual Basic] Public ReadOnly Property ArrayFileName As String
[C#] public string ArrayFileName {get;}

Property Value

The filename of the image file

Explanation

The ArrayFileName property retrieves the image file's filename from the thumbnail image specified by the ArrayImageNumber property. If the ArrayImageNumber property refers to an image that is not loaded from file, then an empty string or null (in Visual Basic, Nothing) is retrieved.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ArrayImageNumber property

Newtone.ImageKit.Win.Thumbnail.ArrayImageNumber Property

This property uses the thumbnail image number to retrieve the image file's filename, directory name, and page number.

[Visual Basic] Public WriteOnly Property ArrayImageNumber As Integer
[C#] public int ArrayImageNumber {set;}

Property Value

The sequential number of the thumbnail image (starts from 1)

Explanation

The ArrayImageNumber property uses the thumbnail image number to retrieve the image file's filename, the path and name of the directory containing the image file, and the image file's page number. By setting the appropriate thumbnail image number in the ArrayImageNumber property, the image file's information will be set in the ArrayFileName, ArrayPageNumber, and ArrayDirectoryName properties.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ArrayPageNumber property

Newtone.ImageKit.Win.Thumbnail.ArrayPageNumber Property

This property retrieves the image file's page number from the thumbnail image specified by the ArrayImageNumber property.

[Visual Basic] Public ReadOnly Property ArrayPageNumber As Integer
[C#] public int ArrayPageNumber {get;}

Property Value

The image file's page number (starts from 0)

Explanation

The ArrayPageNumber property retrieves the image file's page number from the thumbnail image specified by the ArrayImageNumber property. If theArrayImageNumber property refers to an image that is not loaded from file, then the ArrayPageNumber property will be an empty string or 0.

The ArrayPageNumber property is used for multipage image files. If a single page image file is specified then the ArrayPageNumber property will be 0.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


BorderColor property

Newtone.ImageKit.Win.Thumbnail.BorderColor Property

This property sets the color for the border of the Thumbnail Control.

[Visual Basic] Public Property BorderColor As System.Drawing.Color
[C#] public System.Drawing.Color BorderColor {get; set;}

Property Value

BorderColor is the color for the border of the Thumbnail Control. The default value is Color.Black.

Explanation

The BorderColor property sets the color for the border of the Thumbnail Control. To set color, please use the appropriate RGB(Red, Green, Blue) value. The BorderColor property is enable when the Appearance property is Flat and the BorderVisible property is True.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


BorderVisible property

Newtone.ImageKit.Win.Thumbnail.BorderVisible Property

This property sets whether or not the Thumbnail Control border is displayed.

[Visual Basic] Public Property BorderVisible As Boolean
[C#] public bool BorderVisible {get; set;}

Property Value

Value | Explanation
True | The border is displayed
False | The border is not displayed (default)

Explanation

The BorderVisible property sets whether or not the Thumbnail Control border is displayed.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


BorderWidth property

Newtone.ImageKit.Win.Thumbnail.BorderWidth Property

This property sets the size of the area between the edge of the Thumbnail Control and the display of the thumbnails.

[Visual Basic] Public Property BorderWidth As Integer
[C#] public int BorderWidth {get; set;}

Property Value

The size of the area between the edge of the Thumbnail Control and the display of the thumbnails.

The default value is 5.

Explanation

The BorderWidth property sets the size of the area between the edge of the Thumbnail Control and the display of the thumbnails.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Button3D property

Newtone.ImageKit.Win.Thumbnail.Button3D Property

This property sets whether or not the individual cells of the Thumbnail Control are shown in 3D.

[Visual Basic] Public Property Button3D As Boolean
[C#] public bool Button3D {get; set;}

Property Value

Value | Explanation
True | Displays the cells of the thumbnail control as 3D (default)
False | Displays the cells of the thumbnail control as flat

Explanation

The Button3D property sets whether or not the individual cells of the Thumbnail Control are shown in 3D. This property is enabled when the Style property is Button.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Cancel property

Newtone.ImageKit.Win.Thumbnail.Cancel Property

This property sets whether or not the process of displaying images in the Thumbnail Control is canceled.

[Visual Basic] Public WriteOnly Property Cancel As Boolean
[C#] public bool Cancel {set;}

Property Value

Value | Explanation
True | Cancels the process
False | Does not cancel the process (default)

Explanation

The Cancel property sets whether or not the process of displaying images in the Thumbnail Control is canceled. To cancel, set this property to True.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


CellSpacing property

Newtone.ImageKit.Win.Thumbnail.CellSpacing Property

This property sets the amount of space between thumbnail cells.
[Visual Basic] Public Property CellSpacing As Integer
[C#] public int CellSpacing {get; set;}

Property Value

The number of pixels between thumbnail cells

The default value is 5.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ClearOnLoad property

Newtone.ImageKit.Win.Thumbnail.ClearOnLoad Property

This property sets whether or not previously loaded images are cleared when an image is loaded into the Thumbnail Control.

[Visual Basic] Public Property ClearOnLoad As Boolean
[C#] public bool ClearOnLoad {get; set;}

Property Value

Value | Explanation
True | When an image is loaded, the previously loaded image is cleared (default)
False | When an image is loaded, the previously loaded image is not cleared

Explanation

The ClearOnLoad property sets whether or not previously loaded images are cleared when an image is loaded into the Thumbnail Control. True is the default value. When False, the image loaded is added to the previously loaded images. A good example of when to use this property is when using an ADF to continuously scan images or when retrieving multiple images, one by one, from a datasource.

When this property is False, the ThumbnailFile property will be disabled and the thumbnail file will not be created.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ColumnNumber property

Newtone.ImageKit.Win.Thumbnail.ColumnNumber Property

This property sets the number of columns displayed in the Thumbnail Control.

[Visual Basic] Public Property ColumnNumber As Integer
[C#] public int ColumnNumber {get; set;}

Property Value

The ColumnNumber sets the number of columns displayed (1 or more)

The default value is 2.

Explanation

The ColumnNumber property sets the number of columns displayed in the Thumbnail Control. The ColumnNumber and RowNumber properties determine the total number of images displayed at one time as thumbnails.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


EnableArrowKeys property

Newtone.ImageKit.Win.Thumbnail.EnableArrowKeys Property

This property sets whether or not the arrow keys and the PageUp, PageDown keys on the keyboard can be used to scroll the images in the Thumbnail Control.

[Visual Basic] Public Property EnableArrowKeys As Boolean
[C#] public bool EnableArrowKeys {get; set;}

Property Value

Value | Explanation
True | The arrow keys and the PageUp and PageDown keys are enabled
False | The arrow keys and the PageUp and PageDown keys are disabled

Explanation

The EnableArrowKeys property sets whether or not the arrow keys and the PageUp, PageDown keys on the keyboard can be used to scroll the images in the Thumbnail Control.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


EnableMouseMoveButton property

Newtone.ImageKit.Win.Thumbnail.EnableMouseMoveButton Property

This property sets whether or not the thumbnail image is selected when the mouse moves over that thumbnail image frame.

[Visual Basic] Public Property EnableMouseMoveButton As Boolean
[C#] public bool EnableMouseMoveButton {get; set;}

Property Value

Value | Explanation
True | The thumbnail image frame is selected on mouse over
False | The thumbnail image frame is not selected on mouse over (default)

Explanation

The EnableMouseMoveButton property sets whether or not the thumbnail image is selected when the mouse moves over that thumbnail image frame.

Note that when the mouse moves over the thumbnail, this does not generate the SelectFile event even though the thumbnail image is selected. When the EnableMouseMoveButton property is set to True, it is still possible to click the thumbnail image or use the keyboard which will generate the SelectFile event.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


EnableMouseWheel property

Newtone.ImageKit.Win.Thumbnail.EnableMouseWheel Property

This property sets whether or not the mouse wheel is enabled.

[Visual Basic] Public Property EnableMouseWheel As Boolean
[C#] public bool EnableMouseWheel {get; set;}

Property Value

Value | Explanation
True | Mouse wheel is enabled
False | Mouse wheel is disabled (default)

Explanation

The EnableMouseWheel property sets whether or not the mouse wheel is enabled.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


EnableSelectMultiFiles property

Newtone.ImageKit.Win.Thumbnail.EnableSelectMultiFiles Property

This property sets whether or not multiple thumbnail images can be selected.

[Visual Basic] Public Property EnableSelectMultiFiles As Boolean
[C#] public bool EnableSelectMultiFiles {get; set;}

Property Value

Value | Explanation
True | Multiple thumbnail images can be selected
False | Single thumbnail images can be selected (default)

Explanation

The EnableSelectMultiFiles property sets whether or not multiple thumbnail images can be selected.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ErrorStatus property

Newtone.ImageKit.Win.Thumbnail.ErrorStatus Property

This property refers to the types of errors that can occur when using the Thumbnail Control.

[Visual Basic] Public ReadOnly Property ErrorStatus As Newtone.ImageKit.Error
[C#] public Newtone.ImageKit.Error ErrorStatus {get;}

Property Value

Read only

The value is of type Error.

Explanation

The ErrorStatus property refers to the types of errors that can occur when using the Thumbnail Control.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


FileExtension property

Newtone.ImageKit.Win.Thumbnail.FileExtension Property

This property sets the image type that can be displayed in the Thumbnail Control.

[Visual Basic] Public Property FileExtension As String
[C#] public string FileExtension {get; set;}

Property Value

String value denoting the file extention

Explanation

The FileExtension property sets the image type that can be displayed in the Thumbnail Control. When setting multiple image file types in the FileExtension property, separate the entries with a semicolon. Note: The FileExtension property is not case sensitive so "BMP" and "bmp" are treated as identical.

Example

Thumbnail1.FileExtension = "BMP;JPG;PNG;"

This will load all JPEG and PNG files and BMP files from the specifed directory.

When using a wildcard, you cannot set the same file extension twice. So Thumbnail1.FileExtension = "*.bmp;001.bmp" will result in an error. You must enter either "*1.bmp" or "001.bmp".

Example

Correct: Thumbnail1.FileExtension = "002.bmp;001.bmp"

Incorrect: Thumbnail1.FileExtension = "*.bmp;001.bmp"

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


FileName property

Newtone.ImageKit.Win.Thumbnail.FileName Property

This property refers to the filename of the image when the thumbnail image is selected.

[Visual Basic] Public ReadOnly Property FileName As String
[C#] public string FileName {get;}

Property Value

The image file name

Explanation

The FileName property refers to the filename of the image when the thumbnail image is selected. A thumbnail image can be selected using a mouse click, the keyboard, the SelectImage method, the SelectFile or MouseMoveOnThumbnail event. The filename of the image is retrieved by the SelectFile event when the thumbnail image is selected. For multipage image files, the FileName property will have the page number appended to the end (If the page number is 0 then this is omitted).

Example: If the page number of ABC.TIF is 2 then the FileName property will contain the string, "ABC.TIF 2".

Note: if more than one thumbnail are selected at the same time, the FileName property will contain the filename of the last image in that group of selected images.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


FilePath property

Newtone.ImageKit.Win.Thumbnail.FilePath Property

This property sets the file path to the directories containing images to be displayed in the Thumbnail Control.

[Visual Basic] Public Property FilePath As String
[C#] public string FilePath {get; set;}

Property Value

A string value denoting the path to the image files

Explanation

The FilePath property sets the file path to the directories containing images to be displayed in the Thumbnail Control. When setting multiple directories in the FilePath property, please separate the entries with a semicolon.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ForeColorDown property

Newtone.ImageKit.Win.Thumbnail.ForeColorDown Property

This property sets the color of the thumbnail image cell when the image is selected.

[Visual Basic] Public Property ForeColorDown As System.Drawing.Color
[C#] public System.Drawing.Color ForeColorDown {get; set;}

Property Value

The color of the thumbnail cell

The default value is Color.Gray.

Explanation

The ForeColorDown property sets the color of the thumbnail image cell when the image is selected. To set the color, please use an RGB(Red, Green, Blue) value. This property is enabled when the Style property is set to Button or Film.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ForeColorUp property

Newtone.ImageKit.Win.Thumbnail.ForeColorUp Property

This property sets the color of the thumbnail cell when the thumbnail image is not selected (default color).

[Visual Basic] Public Property ForeColorUp As System.Drawing.Color
[C#] public System.Drawing.Color ForeColorUp {get; set;}

Property Value

The color of the thumbnail cell (default color)

The default value is Color.Gainsboro.

Explanation

The ForeColorUp property sets the color of the thumbnail cell when the thumbnail image is not selected (default color). To set the color, please use am RGB(Red, Green, Blue) value. This property is enabled when the Style property is set to Button or Film.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Image property

Newtone.ImageKit.Win.Thumbnail.Image Property

This property refers to the image handle of the image loaded into the Thumbnail Control

[Visual Basic] Public WriteOnly Property Image As System.Drawing.Image
[C#] public System.Drawing.Image Image {set;}

Property Value

The Image object

Explanation

The Image property refers to the image handle of the image loaded into the Thumbnail Control. This property is used, for example, to display the results of continuous scanning as thumbnail images.

Example

[Visual Basic.NET]
Private Sub ImageKit1_AfterScan(ByVal sender As Object, ByVal e As Newtone.ImageKit.AfterScanEventArgs) Handles ImageKit.AfterScan
    If e.Bitmap1 = Nothing Then Exit Sub
    Thumbnail1.Image = e.Bitmap1.Clone()
End Sub

[Visual C#.NET]
private void ImageKit1_AfterScan(object sender, Newtone.ImageKit.AfterScanEventArgs e)
{
    if (e.Bitmap1 == null) return;
    Thumbnail1.Image = e.Bitmap1.Clone();
}

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ImageSize property

Newtone.ImageKit.Win.Thumbnail.ImageSize Property

This property sets the size of the thumbnail image when it is displayed.

[Visual Basic] Public Property ImageSize As Integer
[C#] public int ImageSize {get; set;}

Property Value

The size of the thumbnail image in pixels

The default size is 96

Explanation

The ImageSize property sets the size of the thumbnail image when it is displayed. The length or width dimension (whichever is larger) of the original image is set to the size specified in this property and the other dimension is scaled in size.

Note: the available display area of the thumbnail control determines the maximum value of the ImageSize property. Setting the ImageSize property to values larger than the area available to display the thumbnail image will have no effect.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


LoadMode property

Newtone.ImageKit.Win.Thumbnail.LoadMode Property

This property sets how images are loaded and displayed in the Thumbnail Control.

[Visual Basic] Public Property LoadMode As ThumbnailLoadMode
[C#] public ThumbnailLoadMode LoadMode {get; set;}

Property Value

This value is of type ThumbnailLoadMode

Explanation

The LoadMode property sets how images are loaded and displayed in the Thumbnail Control. When the LoadMode property is set to LoadFile or LoadMulti , the GetFiles method loads the appropriate file from the folder set in the FilePath property into the memory. The Display method displays the file on the control.

When the LoadMode property is set to LoadFileDisplay or LoadMultiDisplay, by executing the Display method, the appropriate files from folders set in the FilePath property are displayed on the control while they are being loaded.

* Multi-image is only for GIF and TIFF.

When the LoadMode property is set to "LoadImageProperty", by executing the Display method, the image set in the Image property is displayed on the control. In order to display multiple images at once, please set the ClearOnLoad property to False and set each memory handle to the Image property.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


PictureDown property

Newtone.ImageKit.Win.Thumbnail.PictureDown Property

This property sets a background image displayed on the display area of the thumbnail image.

[Visual Basic] Public Property PictureDown As System.Drawing.Image
[C#] public System.Drawing.Image PictureDown {get; set;}

Property Value

The background image displayed on the thumbnail image

The default value is null (in Visual Basic, Nothing)

Explanation

The PictureDown property sets a background image displayed on the display area of the thumbnail image (the black portions of the display area) when the mouse is clicked. This property could be used to create the effect of window blinds being opened to reveal a thumbnail image when the mouse is clicked on that thumbnail image frame.

This property is enabled when the Style property is Custom. The black RGB(0,0,0) portions of the background image is set as a transparent color. The thumbnail image will be displayed through this portion of the background image.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


PictureDown property

Newtone.ImageKit.Win.Thumbnail.PictureUp Property

This property sets a background image displayed on the display area of the thumbnail image when the thumbnail has not been clicked.

[Visual Basic] Public Property PictureUp As System.Drawing.Image
[C#] public System.Drawing.Image PictureDown {get; set;}

Property Value

The background image displayed on the thumbnail image when the thumbnail hasn't been clicked

The default value is null (in Visual Basic, Nothing)

Explanation

The PictureUp property sets a background image displayed on the the display area of the thumbnail image (the black portions of the display area) when the thumbnail hasn't been clicked. This property could be used to create the effect of window blinds being opened to reveal a thumbnail image when the mouse is clicked on that thumbnail image frame.

This property is enabled when the Style property is Custom. The black RGB(0,0,0) portions of the foreground image is set as a transparent color. The thumbnail image will be displayed through this portion of the background image.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


RowNumber property

Newtone.ImageKit.Win.Thumbnail.RowNumber Property

This property sets the number of rows displayed in the Thumbnail Control.

[Visual Basic] Public Property RowNumber As Integer
[C#] public int RowNumber {get; set;}

Property Value

The number of rows displayed (1 or more)

The default value is 2

Explanation

The RowNumber property sets the number of rows displayed in the Thumbnail Control. The RowNumber and ColumnNumber properties determine the total number of images displayed at one time as thumbnails.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ScrollBar property

Newtone.ImageKit.Win.Thumbnail.ScrollBar Property

This property sets whether or not scroll bars are enabled in the Thumbnail Control.

[Visual Basic] Public Property ScrollBar As Boolean
[C#] public bool ScrollBar {get; set;}

Property Value

Value | Explanation
True | Scroll bars are enabled in the Thumbnail Control (default)
False | Scroll bars are not enabled in the Thumbnail Control

Explanation

The ScrollBar property sets whether or not scroll bars are enabled in the Thumbnail Control.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ScrollDirection property

Newtone.ImageKit.Win.Thumbnail.ScrollDirection Property

This property sets whether the Thumbnail Control can be scrolled horizontally or vertically.

[Visual Basic] Public Property ScrollDirection As ThumbnailScrollDirection
[C#] public ThumbnailLoadMode ScrollDirection {get; set;}

Property Value

This value is of type ThumbnailScrollDirection

Explanation

The ScrollDirection property sets whether the Thumbnail Control can be scrolled horizontally or vertically. If set to Horizontal, the thumbnail control can be scrolled horizontally. If set to Vertical, the Thumbnail Control can be scrolled vertically.

Note: If set to Vertical, the thumbnail images are displayed horizontally (starting from top left toward right). If set to Horizontal, the thumbnail images are displayed vertically (starting from top left downwards).

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ScrollStep property

Newtone.ImageKit.Win.Thumbnail.ScrollStep Property

This property sets the size of the scroll step.

[Visual Basic] Public Property ScrollStep As Integer
[C#] public int ScrollStep {get; set;}

Property Value

The scroll size for Thumbnail Control in number of rows or columns

The default value is 1

Explanation

The ScrollStep property sets the size of the scroll step for the Thumbnail Control. By setting this property to positive values, the scroll moves forward, by setting it to negative values, the scroll moves backward. The ScrollDirection property determines if the scroll moves horizontally or vertically.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SelectTextBackColor property

Newtone.ImageKit.Win.Thumbnail.SelectTextBackColor Property

This property sets the background color of the text (either filename or comment) for the selected thumbnail image.

[Visual Basic] Public Property SelectTextBackColor As System.Drawing.Color
[C#] public System.Drawing.Color SelectTextBackColor {get; set;}

Property Value

The background color of the text

The default value is Color.White

Explanation

The SelectTextBackColor property sets the background color of the text (either filename or comment) for the selected thumbnail image.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SelectTextColor property

Newtone.ImageKit.Win.Thumbnail.SelectTextColor Property

This property sets the color of the text (either filename or comment) for the selected thumbnail image.

[Visual Basic] Public Property SelectTextColor As System.Drawing.Color
[C#] public System.Drawing.Color SelectTextColor {get; set;}

Property Value

The color of the text

The default value is Color.Black

Explanation

The SelectTextColor property sets the color of the text (either filename or comment) for the selected thumbnail image.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SelectTextTransparent property

Newtone.ImageKit.Win.Thumbnail.SelectTextTransparent Property

This property sets whether or not transparency is enabled when the filename or comment is displayed in the selected thumbnail cell.

[Visual Basic] Public Property SelectTextTransparent As Boolean
[C#] public bool SelectTextTransparent {get; set;}

Property Value

Value | Explanation
True | Transparency is enabled (default)
False | Transparency is disabled

Explanation

The SelectTextTransparent property sets whether or not transparency is enabled when the filename or comment is displayed in the selected thumbnail cell. When this property is True, the background color set in the SelectTextBackColor property will be transparent.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ShowFileName property

Newtone.ImageKit.Win.Thumbnail.ShowFileName Property

This property sets whether or not the filename or comment is displayed under the thumbnail image in the Thumbnail Control.

[Visual Basic] Public Property ShowFileName As Boolean
[C#] public bool ShowFileName {get; set;}

Property Value

Value | Explanation
True | Displays the filename or comment
False | Does not display the filename or comment (default)

Explanation

The ShowFileName property sets whether or not the filename or comment is displayed under the thumbnail image in the Thumbnail Control. If this property is True, the filename is displayed under the thumbnail image. In order to display a comment under the thumbnail image, you must set this property to true, then in the ShowThumbnailImage event, set the comment that you would like to display in the Text property.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Sort property

Newtone.ImageKit.Win.Thumbnail.Sort Property

This property sets the sorting method for the image files contained in the folder(s) specified by the FilePath property.

[Visual Basic] Public Property Sort As ThumbnailSort
[C#] public ThumbnailSort Sort {get; set;}

Property Value

This value is of type ThumbnailSort

Explanation

The Sort property sets the sorting method for the image files contained in the folder(s) specified by the FilePath property. The files will be sorted according to the value set in the SortDate property.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SortDate property

Newtone.ImageKit.Win.Thumbnail.SortDate Property

This property sets how the files will be sorted when the Sort property is set to Date.

[Visual Basic] Public Property SortDate As ThumbnailSortDate
[C#] public ThumbnailSortDate SortDate {get; set;}

Property Value

This value is of type ThumbnailSortDate

Explanation

The SortDate property sets how the files will be sorted when the Sort property is set to Date.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SortOrder property

Newtone.ImageKit.Win.Thumbnail.SortOrder Property

This property sets whether the image files specified by the FilePath property are sorted in ascending or descending order.

[Visual Basic] Public Property SortOrder As ThumbnailSortOrder
[C#] public ThumbnailSortOrder SortOrder {get; set;}

Property Value

This value is of type System.Windows.Forms.SortOrder

Explanation

The SortOrder property sets whether the image files specified by the FilePath property are sorted in ascending or descending order.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


StartNumber property

Newtone.ImageKit.Win.Thumbnail.StartNumber Property

This property uses the image number to set the thumbnail image displayed in the top left corner of the Thumbnail Control.

[Visual Basic] Public Property StartNumber As Integer
[C#] public int StartNumber {get; set;}

Property Value

The image number of the thumbnail image displayed in the top left corner of the Thumbnail Control (image numbers start from 0)

The default value is 0

Explanation

The StartNumber property uses the image number to set the thumbnail image displayed in the top left corner of the Thumbnail Control. Note that if you set a number that cannot be evenly divided by the ColumnNumber property or the RowNumber property the nearest value that is divisible will be used.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Style property

Newtone.ImageKit.Win.Thumbnail.Style Property

This property sets the style of the thumbnail image cell.

[Visual Basic] Public Property Style As ThumbnailStyle
[C#] public ThumbnailStyle Style {get; set;}

Property Value

This value is of type ThumbnailStyle

Explanation

The Style property sets the style of the thumbnail image cell. Changes to the Style property during execution are not enabled until the Display method is executed. If set to Custom, the Image object must be set in the PictureDown or PictureUp property.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


TextBackColor property

Newtone.ImageKit.Win.Thumbnail.TextBackColor Property

This property sets the background color for the text (either the filename or comment) for a thumbnail image.

[Visual Basic] Public Property TextBackColor As System.Drawing.Color
[C#] public System.Drawing.Color TextBackColor {get; set;}

Property Value

The background color of the text

The default value is Color.White

Explanation

The TextBackColor property sets the background color for the text (either the filename or comment) for a thumbnail image.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


TextColor property

Newtone.ImageKit.Win.Thumbnail.TextColor Property

This property sets the color of the text (either the filename or comment) for a thumbnail image.

[Visual Basic] Public Property TextColor As System.Drawing.Color
[C#] public System.Drawing.Color TextColor {get; set;}

Property Value

The color of the text

The default value is Color.Black

Explanation

The TextColor property sets the color of the text (either the filename or comment) for a thumbnail image.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


TextTransparent property

Newtone.ImageKit.Win.Thumbnail.TextTransparent Property

This property sets whether or not transparency is enabled when the filename or comment is displayed in the thumbnail cell.

[Visual Basic] Public Property TextTransparent As Boolean
[C#] public bool TextTransparent {get; set;}

Property Value

Value | Explanation
True | Transparency is enabled (default)
False | Transparency is disabled

Explanation

The TextTransparent property sets whether or not transparency is enabled when the filename or comment is displayed in the thumbnail cell. When this property is True, the background color set in the TextBackColor property will be transparent.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailFile property

Newtone.ImageKit.Win.Thumbnail.ThumbnailFile Property

This property sets the thumbnail file used by the Thumbnail Control.

[Visual Basic] Public Property ThumbnailFile As String
[C#] public string ThumbnailFile {get; set;}

Property Value

The thumbnail file name (full path)

Explanation

The ThumbnailFile property sets the thumbnail file used by the Thumbnail Control. By setting the filename and path in this property, the thumbnail control creates a thumbnail.dat file that is used to make subsequent loading of the thumbnail images faster. The Thumbnail file will load the images in the folders specified by the FilePath property. If the FilePath property is changed be sure to change the ThumbnailFile property accordingly.

This property is not compatible with the ImageKit ActiveX or VCL thumbnail file.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


TotalImageNumber property

Newtone.ImageKit.Win.Thumbnail.TotalImageNumber Property

This property retrieves the total number of thumbnail images.

[Visual Basic] Public ReadOnly Property TotalImageNumber As Integer
[C#] public int TotalImageNumber {get;}

Property Value

Total number of thumbnail images

Explanation

The TotalImageNumber property retrieves the total number of thumbnail images.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Clear method

Newtone.ImageKit.Win.Thumbnail.Clear Method

This method clears the Thumbnail Control.

[Visual Basic] Public Sub Clear()
[C#] public void Clear();

Return Value

None

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


DeleteImage method

Newtone.ImageKit.Win.Thumbnail.DeleteImage Method

This method deletes the specified thumbnail image from Thumbnail Control.

[Visual Basic] Public Function DeleteImage(imageNumber As Integer) As Boolean
[C#] public bool DeleteImage(int imageNumber);

Parameters

imageNumber
The sequential number of the thumbnail image (starts from 1)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DeleteImage method deletes the specified thumbnail image from Thumbnail Control (the actual file remains). If you don't want to display the thumbnail image next time (ex. when reloading it), please delete the actual file after executing this method and when the return value is True.

By setting the sequential number of the thumbnail image into the ArrayImageNumber property prior to executing this method, the actual filename will be set in the ArrayFileName, ArrayPageNumber, and ArrayDirectoryName properties.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


DeSelectImage method

Newtone.ImageKit.Win.Thumbnail.DeSelectImage Method

This method deselects a thumbnail image that has been selected.

[Visual Basic] Public Function DeSelectImage(imageNumber As Integer) As Boolean
[C#] public bool DeSelectImage(int imageNumber);

Parameters

imageNumber
The sequential number of the thumbnail image (starts from 1)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DeSelectImage method deselects a thumbnail image that has been selected. Thumbnail images can be selected with a mouse click, the keyboard, or the SelectImage method.

If no thumbnail image has been selected, executing the DeSelectImage method will not do anything. By setting the ImageNumber parameter value in the ArrayImageNumber property, the ArrayFileName, ArrayPageNumber, and ArrayDirectoryName properties can be retrieved.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Display method

Newtone.ImageKit.Win.Thumbnail.Display Method

This method displays the thumbnail images.

[Visual Basic] Public Function Display() As Boolean
[C#] public bool Display();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Display method displays the thumbnail images. To execute this method, it is necessary to first execute the GetFiles method to retrieve the data from the image files that will be displayed as thumbnails. The ColumnNumber and RowNumber properties must also be set.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


GetFiles method

Newtone.ImageKit.Win.Thumbnail.GetFiles Method

This method acquires the thumbnail image.

[Visual Basic] Public Function GetFiles() As Boolean
[C#] public bool GetFiles();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The GetFiles method acquires the thumbnail image. To execute this method, it is necessary to first set the FileExtension, FilePath, and LoadMode properties.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


IsSelected method

Newtone.ImageKit.Win.Thumbnail.IsSelected Method

This method determines if the specified thumbnail image is selected.

[Visual Basic] Public Function IsSelected(imageNumber As Integer) As Boolean
[C#] public bool IsSelected(int imageNumber);

Parameters

imageNumber
The sequential number of the thumbnail image (starts from 1)

Return Value

Returns True if successful. Returns False when the thumbnail is not selected or the method is not successful.

Explanation

The IsSelected method determines if the specified thumbnail image is selected. This method is used to retrieve information about a thumbnail image that has been selected by the mouse, by the keyboard, or by the SelectImage method. By passing the value returned in the ImageNumber parameter of this method to the ArrayImageNumber property, the image filename, page number (for multi-page images), and full path can be retrieved from the ArrayFileName, ArrayPageNumber, and ArrayDirectoryName properties.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Scroll method

Newtone.ImageKit.Win.Thumbnail.Scroll Method

This method scrolls the thumbnail images.

[Visual Basic] Public Function Scroll() As Boolean
[C#] public bool Scroll();

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The Scroll method scrolls the thumbnail images. The size of the scroll steps depends on the value set in the ScrollStep property and the direction of the scroll depends on the value set in the ScrollDirection property. To execute this method, the appropriate values must be set in the ScrollStep and ScrollDirection properties.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SelectImage method

Newtone.ImageKit.Win.Thumbnail.SelectImage Method

This method selects a thumbnail image.

[Visual Basic] Public Function SelectImage(imageNumber As Integer) As Boolean
[C#] public bool SelectImage(int imageNumber);

Parameters

imageNumber
The sequential number of the thumbnail image (starts from 1)

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SelectImage method selects a thumbnail image. When the EnableSelectMultiFiles property is False, the last selected thumbnail image is selected, all previously selected thumbnail images will be deselected. By setting the ImageNumber parameter value in the ArrayImageNumber property, the ArrayFileName, ArrayPageNumber, and ArrayDirectoryName properties can be retrieved.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


UpdateThumbnailFile method

Newtone.ImageKit.Win.Thumbnail.UpdateThumbnailFile Method

This method updates the thumbnail file.

[Visual Basic] Public Sub UpdateThumbnailFile()
[C#] public void UpdateThumbnailFile();

Return Value

None

Explanation

The UpdateThumbnailFile method updates the thumbnail file set in the ThumbnailFile property. Please execute this method when the FilePath property is changed to display thumbnails from a different directory or when the thumbnail program is finished, etc.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


EndLoadFile event

Newtone.ImageKit.Win.Thumbnail.EndLoadFile Event

This event is generated after each image is loaded into the Thumbnail Control.

[Visual Basic] Public Event EndLoadFile As ThumbnailLoadEventHandler
[C#] public event ThumbnailLoadEventHandler EndLoadFile;

Event Data

The event handler retrieves arguments of type ThumbnailLoadEventArgs

Explanation

The EndLoadFile event is generated after each image is loaded into the Thumbnail Control. Note: This event is NOT generated if a thumbnail file (ThumbnailFile property) is used to load the images. To cancel processing in the thumbnail control, set the Cancel property to True within this event.

Information about files loaded during this event can be referred to within the ThumbnailLoadEventArgs arguments.

Regarding properties for the ThumbnailLoadEventArgs class

If an image is unable to be loaded, the ImageNumber parameter will be 0. When multi-page image files are loaded, the page number is appended to the FileName parameter (If the page number is 0 then it is omitted).

Example: When page 2 of the file ABC.TIF is loaded into the Thumbnail Control, the FileName parameter will return the string "ABC.TIF 2".

Example

Displays some information about images loaded.

[Visual Basic.NET]
Private Sub Thumbnail1_EndLoadFile(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ThumbnailLoadEventArgs) Handles Thumbnail1.EndLoadFile
    Label1.Text = e.ImageNumber.ToString() + " / " + e.TotalImageNumber.ToString();
End Sub

[Visual C#.NET]
private void thumbnail1_EndLoadFile(object sender, Newtone.ImageKit.Win.ThumbnailLoadEventArgs e)
{
    label1.Text = e.ImageNumber.ToString() + " / " + e.TotalImageNumber.ToString();
}

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


MouseMoveOnThumbnail event

Newtone.ImageKit.Win.Thumbnail.MouseMoveOnThumbnail Event

This event is generated when the mouse is moved over a thumbnail image in the Thumbnail Control.

[Visual Basic] Public Event MouseMoveOnThumbnail As ThumbnailEventHandler
[C#] public event ThumbnailEventHandler MouseMoveOnThumbnail;

Event Data

The event handler retrieves arguments of type ThumbnailEventArgs

Explanation

The MouseMoveOnThumbnail event is generated when the mouse is moved over a thumbnail image in the Thumbnail Control. To enable this event the EnableMouseMoveButton property must be set to True. If the thumbnail image is not displayed on the thumbnail control then this event is not generated. ]

Information about files loaded during this event can be referred to within the ThumbnailLoadEventArgs arguments.

Regarding properties for the ThumbnailLoadEventArgs class

When the thumbnail image isn't displayed into the thumbnail frame that was moved over with the mouse, the DirectoryName and FileName parameters will return empty string and theImageNumber will return -1.

When multi-page image files are loaded, the page number is appended to the FileName parameter (If the page number is 0 then it is omitted).

Example: When page 2 of the file ABC.TIF is loaded into the thumbnail control, the FileName parameter will return the string "ABC.TIF 2"

Example

Displays the filename of the destination cell

[Visual Basic.NET]
Private Sub
Thumbnail1_MouseMoveOnThumbnail(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ThumbnailEventArgs) Handles Thumbnail1.MouseMoveOnThumbnail If e.ImageNumber
    = -1 Then Exit Sub ' disabled  cell Label1.Text
    = e.FileName; End
Sub [Visual

C#.NET] private
void thumbnail1_MouseMoveOnThumbnail(object sender, Newtone.ImageKit.Win.ThumbnailEventArgs e) {
if
    (e.ImageNumber == -1) return; //  disabled cell
    label1.Text = e.FileName;
}

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


SelectFile event

Newtone.ImageKit.Win.Thumbnail.SelectFile Event

This event is generated when a thumbnail image is selected. Thumbnail images can be selected by clicking the mouse, using the keyboard, or executing the SelectImage method.

[Visual Basic] Public Event SelectFile As ThumbnailEventHandler
[C#] public event ThumbnailEventHandler SelectFile;

Event Data

The event handler retrieves arguments of type ThumbnailEventArgs

Explanation

The SelectFile event is generated when a thumbnail image is selected. Thumbnail images can be selected by clicking the mouse, using the keyboard, or executing the SelectImage method. If the thumbnail image is not displayed on the Thumbnail Control then this event is not generated.

By pressing the Ctrl key while clicking with the mouse, several thumbnails can be selected or deselected. In either case, this event is generated. To determine whether or not a particular thumbnail image is selected, please use the IsSelected method.

Thumbnail images can be selected by clicking the mouse, using the keyboard, or executing the SelectImage method. By pressing the Shift key while clicking with the mouse, a series of thumbnails can be selected. This event is generated multiple times for each thumbnail image that has been selected.

Information about files loaded during this event can be referred to within the ThumbnailLoadEventArgs arguments.

Regarding the properties for the ThumbnailLoadEventArgs class

If the selected thumbnail frame has no thumbnail displayed then the DirectoryName and FileName parameters will contain empty strings and the ImageNumber parameter will return -1. When multi-page image files are loaded, the page number is appended to the FileName parameter (If the page number is 0 then it is omitted).

Example: When page 2 of the file ABC.TIF is loaded into the thumbnail control, the FileName parameter will return the string "ABC.TIF 2".

Example

Displays the filename of the selected thumbnail

[Visual Basic.NET]
Private Sub Thumbnail1_SelectFile(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ThumbnailEventArgs) Handles Thumbnail1.SelectFile
    If e.ImageNumber = -1 Then Exit Sub  ' disabled cell

    Label1.Text = e.FileName;
End Sub

[Visual C#.NET]
private void thumbnail1_SelectFile(object sender, Newtone.ImageKit.Win.ThumbnailEventArgs e)
{
    if (e.ImageNumber == -1) return;  //disabled cell
    label1.Text = e.FileName;
}

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ShowThumbnailImage event

Newtone.ImageKit.Win.Thumbnail.ShowThumbnailImage Event

This event is generated just after a thumbnail image is displayed in the Thumbnail Control.

[Visual Basic] Public Event ShowThumbnailImage As ThumbnailEventHandler
[C#] public event ThumbnailEventHandler ShowThumbnailImage;

Event Data

The event handler retrieves arguments of type ThumbnailEventArgs

Explanation

The ShowThumbImage event is generated just after a thumbnail image is displayed in the thumbnail control.

Information about files loaded during this event can be referred to within the ThumbnailLoadEventArgs arguments.

Regarding property for the ThumbnailLoadEventArgs class

When multi-page image files are loaded, the page number is appended to the FileName parameter (If the page number is 0 then it is omitted).

Example: When page 2 of the file ABC.TIF is loaded into the thumbnail control, the FileName parameter will return the string "ABC.TIF 2".

Example

Displays image numbers

[Visual Basic.NET]
Private Sub Thumbnail1_ShowThumbnailImage(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ThumbnailEventArgs) Handles Thumbnail1.ShowThumbnailImage
    Thumbnail1.Text = e.ImageNumber.ToString()
End Sub

[Visual C#.NET]
private void thumbnail1_ShowThumbnailImage(object sender, Newtone.ImageKit.Win.ThumbnailEventArgs e)
{
    thumbnail1.Text = e.ImageNumber.ToString();
}

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


StratLoadFile event

Newtone.ImageKit.Win.Thumbnail.StratLoadFile Event

This event is generated before each image is loaded on the Thumbnail Control.

[Visual Basic] Public Event StratLoadFile As ThumbnailLoadEventHandler
[C#] public event ThumbnailLoadEventHandler StratLoadFile;

Event Data

The event handler retrieves arguments of type ThumbnailLoadEventArgs

Explanation

The StartLoadFile event is generated before each image is loaded on the Thumbnail Control. Note: This event is NOT generated if a thumbnail file (ThumbnailFile property) is used to load the images. To cancel processing in the Thumbnail Control, set the Cancel property to True within this event.

Information about files loaded during this event can be referred to within the ThumbnailLoadEventArgs arguments.

Regarding property for the ThumbnailLoadEventArgs class

When multi-page image files are loaded, the page number is appended to the FileName parameter (If the page number is 0 then it is omitted).

Example: When page 2 of the file ABC.TIF is loaded into the thumbnail control, the FileName parameter will return the string "ABC.TIF 2".

Example

Displays some information about images loaded.

[Visual Basic.NET]
Private Sub Thumbnail1_StartLoadFile(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ThumbnailLoadEventArgs) Handles Thumbnail1.StratLoadFile
    Label1.Text = e.ImageNumber.ToString() + " / " + e.TotalImageNumber.ToString();
End Sub

[Visual C#.NET]
private void thumbnail1_StartLoadFile(object sender, Newtone.ImageKit.Win.ThumbnailLoadEventArgs e)
{
    label1.Text = e.ImageNumber.ToString() + " / " + e.TotalImageNumber.ToString();
}

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailEventHandler delegate

Newtone.ImageKit.Win.ThumbnailEventHandler Delegate

This delegate refers to the MouseMoveOnThumbnail, SelectFile, or ShowThumbnailImage events.

[Visual Basic] Public Delegate Sub ThumbnailEventHandler(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ThumbnailEventArgs)
[C#] public delegate void ThumbnailEventHandler(object sender, Newtone.ImageKit.Win.ThumbnailEventArgs e);

Parameters

sender
Event Source
e
ThumbnailEventArgs containing event arguments

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailLoadEventHandler delegate

Newtone.ImageKit.Win.ThumbnailLoadEventHandler Delegate

This delegate refers to the StartLoadFile or EndLoadFile events.

[Visual Basic] Public Delegate Sub ThumbnailLoadEventHandler(ByVal sender As Object, ByVal e As Newtone.ImageKit.Win.ThumbnailLoadEventArgs)
[C#] public delegate void ThumbnailLoadEventHandler(object sender, Newtone.ImageKit.Win.ThumbnailLoadEventArgs e);

Parameters

sender
Event Source
e
ThumbnailLoadEventArgs containing event data

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailAppearance enum

Newtone.ImageKit.Win.ThumbnailAppearance Enum

This enumeration sets the appearance of the Thumbnail Control.

public enum ThumbnailAppearance

Public Members

Member | Value | Explanation
Flat | 0 | Flat
Lowered | 1 | Lowered
Raised | 2 | Raised

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailAppearance enum

Newtone.ImageKit.Win.ThumbnailLoadMode Enum

This enumeration refers to how images are loaded and displayed in the Thumbnail Control.

public enum ThumbnailLoadMode

Public Members

Member | Value | Explanation
LoadFile | 0 | Loads files
LoadFileDisplay | 1 | Loads and displays them while loading
LoadMulti | 2 | Loads (for multi-page image files)
LoadMultiDisplay | 3 | Loads (for multi-page image files) and displays them while loading
LoadImageProperty | 4 | Loads image objects

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailScrollDirection enum

Newtone.ImageKit.Win.ThumbnailScrollDirection Enum

This enumeration refers to the scroll direction of Thumbnail Control.

public enum ThumbnailScrollDirection

Public Members

Member | Value | Explanation
Vertical | 0 | Scrolls vertically
Horizontal | 1 | Scrolls horizontally

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailSort enum

Newtone.ImageKit.Win.ThumbnailSort Enum

This enumeration refers to the sorting method for the image files contained in the folder(s) specified by the FilePath property.

public enum ThumbnailSort

Public Members

Member | Value | Explanation
None | 0 | No sorting
FileName | 1 | Sorted by file name
Date | 2 | Sorted by date
FileExtName | 3 | Sorted by file extension + file name
FileExtDate | 4 | Sorted by file extension + date
DirFileName | 5 | Sorted by directory name + file name
DirDate | 6 | Sorted by directory name + date
DirFileExtName | 7 | Sorted by directory name + file extension + file name
DirFileExtDate | 8 | Sorted by directory name + file extension + date

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailSortDate enum

Newtone.ImageKit.Win.ThumbnailSortDate Enum

This enumeration refers the datetime used to sort thumbnail images.

public enum ThumbnailSortDate

Public Members

Member | Value | Explanation
CreationTime | 0 | The datetime that the file was created
LastWriteTime | 1 | The datetime that the file was last modified
LastAccessTime | 2 | The datetime that the file was last accessed

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailStyle enum

Newtone.ImageKit.Win.ThumbnailStyle Enum

This enumeration refers to the style of the thumbnail image cell.

public enum ThumbnailStyle

Public Members

Member | Value | Explanation
Button | 0 | Button
Film | 1 | Film
Custom | 2 | Custom

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailEventArgs class

Newtone.ImageKit.Win.ThumbnailEventArgs Class

This class exposes properties for the MouseMoveOnThumbnail, SelectFile, and ShowThumbnailImage events.

[Visual Basic] Public Class ThumbnailEventArgs Inherits System.EventArgs
[C#] public class ThumbnailEventArgsFSystem.EventArgs

Explanation

Property | Type | Explanation
DirectoryName | [Visual Basic] String [C#] string | Retrieves the name of the directory containing the images.
FileName | [Visual Basic] String [C#] string | Refers to the filename of the original image when its thumbnail image is selected.
ImageNumber | [Visual Basic] Integer [C#] int | Retrieves the thumbnail image number (Starts from 1).
Rect | System.Drawing.Rectangle | Retrieves the pixel coordinates for the cell that corresponds to a thumbnail image.
TotalImageNumber | [Visual Basic] Integer [C#] int | Retrieves the total number of thumbnail images.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


ThumbnailLoadEventArgs class

Newtone.ImageKit.Win.ThumbnailLoadEventArgs Class

This class exposes properties for the StartLoadFile and EndLoadFile events.

[Visual Basic] Public Class ThumbnailLoadEventArgs Inherits System.EventArgs
[C#] public class ThumbnailLoadEventArgsFSystem.EventArgs

Explanation

Property | Type | Explanation
DirectoryName | [Visual Basic] String [C#] string | Retrieves the directory name for the thumbnail image.
FileName | [Visual Basic] String [C#] string | Retrieves the filename for the thumbnail image.
ImageNumber | [Visual Basic] Integer [C#] int | Retrieves the thumbnail image number (Starts from 1).
TotalImageNumber | [Visual Basic] Integer [C#] int | Retrieves the total number of thumbnail images.

See Also

Thumbnail Members | Newtone.ImageKit.Win.Thumbnail


Newtone.ImageKit.Web.ImageKit Class

The class for the Webform ImageKit Control.

For a list of all members of this type, see ImageKit Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Newtone.ImageKit.Web
public class ImageKit : Object

Explanation

The ImageKit Control is a web server control that displays images in a web browser. Images can be displayed in the ImageKit Control in actual size, scale, or stretch display modes. Images displayed in actual size can be scrolled within the ImageKit Control. Images can be streamed directly to the browser without being saved on the server or they can be saved in a temporary cache on the server and referenced by the ImageKit Control. By default, the images are streamed directly to the browser. In this case it is necessary that the IkStream.ashx file be copied to the same directory as your application. This IkStream.ashx file is the HttpHandler allowing images to be streamed via the assembly's IkStream Class. For more information, please refer to the "Using the ImageKit Control in a WebForm".

The ImageKit Control can load a variety of image formats. To load images, set the virtual path to the image into the Url property and execute the Load method. The ImageKit Control's BrowserImageFormat property sets the image format that will be used to display the image in the browser, either Jpeg, Png or Gif.

Tiff, Bmp, Fxp, and other raster images, as well as Emf, Wmf, Dxf, and Svg vector images will be displayed in the browser in the format specified by the BrowserImageFormat property.

Requirements

Namespace : Newtone.ImageKit.Web

Assembly : Newtone.ImageKit.Web.ImageKit.dll

See Also

ImageKit Members


(ImageKitWebImageKit) Members.htm

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit All Members

ImageKit Overview

Constructors

ImageKit Constructor Initializes a new instance of the ImageKit class

Public Methods

CloseMultiTiff | Closes a multipage tiff file after it has been saved
Display | Displays the image
LoadImageFromFile | Loads image data from a file
LoadImageFromRawData | Loads the image from raw image data
LoadRawDataFromFile | Loads the image from file as raw data (without converting it to DIB)
LoadRawDataFromStream | Loads the image from stream
SaveImageToFile | Saves image data to file
SaveImageToRawData | Saves the image as raw data
SaveRawDataToFile | Saves the raw image data to file
SaveRawDataToStream | Saves the raw image data to stream
ShowPanWindow | Displays the image in the Pan Window

Public Properties

BackColor | Sets the color for the background of the ImageKit Control
BackgroundBlue | Sets the blue value (RGB) for the background color of the vector image when it is loaded.
BackgroundGreen | Sets the green value (RGB) for the background color of the vector image when it is loaded.
BackgroundPaint | Sets whether or not to paint a background color when a vector image is loaded
BackgroundRed | Sets the red value (RGB) for the background color of the vector image when it is loaded
BrowserImageFormat | Sets the format that is used when the image is displayed in the browser
Comment | Sets the comment that can be saved in some types of image files
DXFBlack | Gets or sets whether or not white is displayed as black and black is displayed as white in DXF image
EnableImagePopupMenu | Sets whether or not the popup menu is displayed when the mouse cursor moves over an image
ErrorStatus | Refers to the types of errors that can occur when using the ImageKit Control
GifAnimation | Sets whether or not the GIF image is a multi-page GIF (GIF animation)
GifAnimationDelay | Sets the length of time a single page of a mult-page GIF image is displayed
Interlace | Sets interlacing when saving an image as a GIF or PNG image
JPEG2000CodeBlockHeight | Sets the height of the JPEG2000 format code block
JPEG2000CodeBlockWidth | Sets the width of the JPEG2000 format code block
JPEG2000NumResLevel | Sets the level of the JPEG2000 format resolution
JPEG2000PrecinctHeight | Sets the height of the JPEG2000 format precinct size
JPEG2000PrecinctWidth | Sets the width of the JPEG2000 format precinct size
JPEG2000Reversible | Sets whether or not the JPEG2000 lossless compression is reversible
JPEG2000Size | Sets the size of the file when saved in JPEG2000 format
JPEG2000TileHeight | Sets the height of the JPEG2000 format tile size
JPEG2000TileWidth | Sets the width of the JPEG2000 format tile size
JpegQuality | Sets the quality coefficient when an image is saved in JPEG or FPX (JPEG compression) file formats
JpegSubsampling | Sets the YCrCb subsampling ratios when saving an image in JPEG format
Link | Establishes the link between the PanWindow and the ImageKit Control
LoadPage | Sets the page to be loaded when a multi-page image file (FPX, GIF, or TIFF) image is loaded
PngAlphaChannel | Sets the alpha channel in a PNG image
RawData | Sets or receives the image data as a byte array when images are loaded or saved in raw data
ScrollBars | Sets whether or not scroll bars are displayed on the ImageKit Control
TiffAppend | Sets whether or not an image saved in TIFF format is appended to an existing multi-page TIFF image or saved as a separate image
TiffColorSpace | Defines the color space when saving images in TIFF file format
TiffSaveOneStrip | Sets whether or not a TIFF image is saved as one strip or multiple strips
Transparent | Sets whether or not the transparent color in GIF and PNG images is enabled
TransparentBlue | Sets the blue component (RGB values) of the transparent color when saving an image as a GIF or PNG image
TransparentGreen | Sets the green component (RGB values) of the transparent color when saving an image as a GIF or PNG image
TransparentRed | Sets the red component (RGB values) of the transparent color when saving an image as a GIF or PNG image
Url | Sets the virtual path to the image that will be displayed in the ImageKit Control.
VectorHeight | Sets the height of a vector image when the image is loaded
VectorWidth | Sets the Width of a vector image when the image is loaded

See Also

Newtone.ImageKit.Web.ImageKit


ImageKitWebImageKit Constructor

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit Constructor

This initializes a new instance of the ImageKit class.

Visual Basic] Public Sub New()
[C#] public ImageKit()

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


BackColor property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.BackColor Property

This property sets the color for the background of the ImageKit Control.
[Visual Basic] Public Property BackColor As Color
[C#] public Color BackColor {get; set;}

Property Value

The ImageKit Control's background color is of type System.Drawing.Color

Default is Color.Gainsboro

Explanation

The BackColor property sets the color for the background of the ImageKit Control. This property is set using System.Drawing.Color object.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


BackgroundBlue property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.BackgroundBlue Property

This property sets the blue value (RGB) for the background color of the vector image when it is loaded.
[Visual Basic] Public Property BackgroundBlue As Integer
[C#] public int BackgroundBlue {get; set;}

Property Value

The value range is from 0 to 255. Default value is 255.

Explanation

This property sets the blue value (RGB) for the background color of the vector image when it is loaded.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


BackgroundGreen property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.BackgroundGreen Property

This property sets the green value (RGB) for the background color of the vector image when it is loaded.
[Visual Basic] Public Property BackgroundGreen As Integer
[C#] public int BackgroundGreen {get; set;}

Property Value

The value range is from 0 to 255. Default value is 255.

Explanation

This property sets the green value (RGB) for the background color of the vector image when it is loaded.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


BackgroundPaint property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.BackgroundPaint Property

This property sets whether or not to paint a background color when a vector image is loaded.
[Visual Basic] Public Property BackgroundPaint As Boolean
[C#] public bool BackgroundPaint {get; set;}

Property Value

True Sets the background color (default)
False Does not set the background color

Explanation

This property sets whether or not to paint a background color when a vector image is loaded.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


BackgroundRed property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.BackgroundRed Property

This property sets the red value (RGB) for the background color of the vector image when it is loaded.
[Visual Basic] Public Property BackgroundRed As Integer
[C#] public int BackgroundRed {get; set;}

Property Value

The value range is from 0 to 255. Default value is 255.

Explanation

This property sets the red value (RGB) for the background color of the vector image when it is loaded.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


BrowserImageFormat property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.BrowserImageFormat Property

This property sets the format that is used when the image is displayed in the browser
[Visual Basic] Public Property BrowserImageFormat As BrowserImageFormat
[C#] public BrowserImageFormat BrowserImageFormat {get; set;}

Property Value

The image file format can be either jpg, png, or gif.
Default is jpg. This value is of type BrowserImageFormat

Explanation

The BrowserImageFormat property sets the format used when the image is displayed in the browser.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


Comment property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.Comment Property

This property sets the comment that can be saved in some types of image files.
[Visual Basic] Public Property Comment As String
[C#] public string Comment {get; set;}

Property Value

The comment string (Maximum length:1023 bytes)

Explanation

The Comment property sets the comment that can be saved in some types of image files. The type of comment and its syntax depends on the file format.
The following image file formats support comments and their syntax is given below. If the particular image file does not support a comment, then this property is ignored for those image files.

Name | Explanation
FPX | Title+0x0d+Subtitle+0x0d+Author+0x0d+Comment+0x0d
GIF | Comment
JPEG | Comment
JPEG2000 | Title+0x0d+Subtitle+0x0d+Author+0x0d+Comment+0x0d
PNG | Title+0x0d+Author+0x0d+Explanation+0x0d+Copyright+0x0d+DateTime+0x0d+Software+0x0d+Waiver+0x0d+Warning+0x0d+Input Devices+0x0d+Comment+0x0d
TIFF | Document Name+0x0d+Image Explanation+0x0d+Page Name+0x0d+Software+0x0d+Date Time+0x0d+Author+0x0d

Note: please enter a blank string into any unnecessary fields.

* In Visual Basic, replace the 0x with &H.

Note: To use this property, you need the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


DXFBlack property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.DXFBlack Property

This property sets whether or not white and black colors are reversed in DXF images.
[Visual Basic] Public Property DXFBlack As Boolean
[C#] public bool DXFBlack {get; set;}

Property Value

Value | Explanation
True(default) | Black is displayed as white and white is displayed as black in DXF images (default).
False | The DXF images is displayed as normal.

Explanation

The DXFBlack property sets whether or not white and black colors are reversed in DXF images. The default value is true, meaning that white is displayed as black and black is displayed as white in DXF images.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


EnableImagePopupMenu property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.EnableImagePopupMenu Property

This property sets whether or not the popup menu is displayed when the mouse cursor moves over an image.
[Visual Basic] Public Property EnableImagePopupMenu As Boolean
[C#] public bool EnableImagePopupMenu {get; set;}

Property Value

Value | Explanation
True | Enables the image popup menu
False(default) | Disables the image popup menu

Explanation

The EnableImagePopupMenu property sets whether or not the popup menu is displayed when the mouse cursor moves over the image. By setting this property to True, the browser's image popup menu is displayed allowing the image to be printed, saved or sent in an Email.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


ErrorStatus property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.ErrorStatus Property

This property refers to the types of errors that can occur when using the ImageKit Control.
[Visual Basic] Public Property ErrorStatus As Newtone.ImageKit.Error
[C#] public Newtone.ImageKit.Error ErrorStatus {get;}

Property Value

Read only

Explanation

This property refers to the types of errors that can occur when using the ImageKit Control. This property refers to the Error Enum members.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


GifAnimation property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.GifAnimation Property

This property sets whether or not a GIF image is a multi-page GIF (GIF animation).
[Visual Basic] Public Property GifAnimation As Boolean
[C#] public bool GifAnimation {get; set;}

Property Value

Value | Explanation
True | Multi-page GIF image (GIF animation)
False (default) | Single image

Explanation

This property sets whether or not a GIF image is a multi-page GIF (GIF animation). Set this property when saving an image as a multi-page GIF file.

Note: To use multi-page GIF images (GIF animation), you must have the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


GifAnimationDelay property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.GifAnimationDelay Property

This property sets the length of time a single page of a multi-page GIF image is displayed

[Visual Basic] Public Property GifAnimationDelay As Integer
[C#] public int GifAnimationDelay {get; set;}

Property Value

The length of time one page of a multi-page GIF image is displayed. (1/100 second units)

Explanation

This property sets the length of time a single page of a multi-page GIF image is displayed. Set this property when saving an image in a multi-page GIF file. This property is only enabled if theGifAnimation property is True.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


Interlace property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.Interlace Property

This property sets interlacing when saving an image in GIF or PNG format.
[Visual Basic] Public Property Interlace As Boolean
[C#] public bool Interlace {get; set;}

Property Value

Value | Explanation
True | Interlace
False (Default) | Non interlace

Explanation

This property sets interlacing when saving an image in GIF or PNG format.

See Also

ImageKit.File Members | Newtone.ImageKit.Web.ImageKit


JPEG2000CodeBlockHeight property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.JPEG2000CodeBlockHeight Property

This property sets the height of the code block size in JPEG2000 images.

[Visual Basic] Public Property JPEG2000CodeBlockHeight As Integer
[C#] public int JPEG2000CodeBlockHeight {get; set;}

Property Value

The height of the JPEG2000 code block size

The default value is 0.

Explanation

The JPEG2000CodeBlockHeight property sets or retrieves the height of the code block size in JPEG2000 images. The default value is 0.

The JPEG2000 format code block size is measured by 2 to a certain power (from 2 to 10). For example, setting the JPEG2000CodeBlockHeight property to 3 means that the vertical code block size is 23 . This property value is used when images are saved in JPEG2000 file format.

Note: To use JPEG2000 images, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


JPEG2000CodeBlockWidth property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.JPEG2000CodeBlockWidth Property

This property sets the width of the code block size in JPEG2000 images.

[Visual Basic] Public Property JPEG2000CodeBlockWidth As Integer
[C#] public int JPEG2000CodeBlockWidth {get; set;}

Property Value

The width of the JPEG2000 code block size

The default value is 0.

Explanation

The JPEG2000CodeBlockWidth property sets or retrieves the width of the code block size in JPEG2000 images. The default value is 0.

The JPEG2000 format code block size is measured by 2 to a certain power (from 2 to 10). For example, by setting the JPEG2000CodeBlockWidth property to 3, the horizontal code block size would be 23 . This property value is used when images are saved in JPEG2000 file format.

Note: To use JPEG2000 images, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


JPEG2000NumResLevel property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.JPEG2000NumResLevel Property

This property sets the level of resolution in JPEG2000 images.

[Visual Basic] Public Property JPEG2000NumResLevel As Integer
[C#] public int JPEG2000NumResLevel {get; set;}

Property Value

The resolution level (from 0)

The default value is 0.

Explanation

The JPEG2000NumResLevel property sets the level of resolution in JPEG2000 images. The default value is 0.

This property value is used when images are saved in JPEG2000 file format.

Note: To use JPEG2000 images, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


JPEG2000PrecinctHeight property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.JPEG2000PrecinctHeight Property

This property sets the height of the precinct size in JPEG2000 images.

[Visual Basic] Public Property JPEG2000PrecinctHeight As Integer
[C#] public int JPEG2000PrecinctHeight {get; set;}

Property Value

The height JPEG2000 precinct size

The default value is 0.

Explanation

The JPEG2000PrecinctHeight property sets or retrieves the height of the precinct size in JPEG2000 images. The default value is 0.

The JPEG2000 format precinct size is measured by 2 to a certain power (from 0 to 15). For example, by setting the JPEG2000PrecinctHeight property to 3, the vertical precinct size would be 23. This property value is used when images are saved in JPEG2000 file format.

Note: To use JPEG2000 images, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


JPEG2000PrecinctWidth property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.JPEG2000PrecinctWidth Property

This property sets the width of the precinct size in JPEG2000 images.

[Visual Basic] Public Property JPEG2000PrecinctWidth As Integer
[C#] public int JPEG2000PrecinctWidth {get; set;}

Property Value

The width JPEG2000 precinct size

The default value is 0.

Explanation

The JPEG2000PrecinctWidth property sets or retrieves the width of the precinct size in JPEG2000 images. The default value is 0.

The JPEG2000 format precinct size is measured by 2 to a certain power (from 0 to 15). For example, setting the JPEG2000PrecinctWidth property to 3 would mean the horizontal precinct size is 23. This property value is used when images are saved in JPEG2000 file format.

Note: To use JPEG2000 images, requires the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


JPEG2000Reversible property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.JPEG2000Reversible Property

This property sets whether or not the JPEG2000 lossless compression is reversible.

[Visual Basic] Public Property JPEG2000Reversible As Boolean
[C#] public bool JPEG2000Reversible {get; set;}

Property Value

Value | Explanation
True (Default) | The compression is reversible (lossless compression)
False | The compression is not reversible (lossy compression)

Explanation

The JPEG2000Reversible property sets whether or not the JPEG2000 lossless compression is reversible.

Setting this property to true, results in larger file size but without loss of image quality. This property value is used when images are saved in JPEG2000 file format.

Note: To use JPEG2000 images, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


JPEG2000Size property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.JPEG2000Size Property

This property sets the size of the file when saving images in JPEG2000 format.

[Visual Basic] Public Property JPEG2000Size As Double
[C#] public double JPEG2000Size {get; set;}

Property Value

The size of the saved image as a factor of the size of the uncompressed image

The default value is 0 (no compression is used).

Explanation

The JPEG2000Size property sets the size of the file when saving images in JPEG2000 format.

When the JPEG2000Size property is 0.01, for example, it means that the file size will be 1/100th the size of the uncompressed file. The default value is 0 meaning no compression is used. This property is enabled when the JPEG2000Reversible property is false. This property value is used when images are saved in JPEG2000 file format.

Note: To use JPEG2000 images, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


JPEG2000TileHeight property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.JPEG2000TileHeight Property

This property sets the height of the tile size in JPEG2000 images.

[Visual Basic] Public Property JPEG2000TileHeight As Integer
[C#] public int JPEG2000TileHeight {get; set;}

Property Value

The height of the JPEG2000 tile size (in pixels)

The default value is 0.

Explanation

The JPEG2000TileHeight property sets or retrieves the height of the tile size in JPEG2000 images. The default value is 0.

This property value is used when images are saved in JPEG2000 file format.

Note: To use JPEG2000 images, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


JPEG2000TileWidth property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.JPEG2000TileWidth Property

This property sets the width of the tile size in JPEG2000 images.

[Visual Basic] Public Property JPEG2000TileHeight As Integer
[C#] public int JPEG2000TileHeight {get; set;}

Property Value

The width of the JPEG2000 tile size. (in pixels)

The default value is 0.

Explanation

The JPEG2000TileWidth property sets or retrieves the width of the tile size in JPEG2000 images. The default value is 0.

This property value is used when images are saved in JPEG2000 file format.

Note: To use JPEG2000 images, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit Member | Newtone.ImageKit.Web.ImageKit


JpegQuality property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.JpegQuality Property

This property sets the quality coefficient when an image is saved in JPEG or FPX (JPEG compression) file formats.

[Visual Basic] Public Property JpegQuality As Integer
[C#] public int JpegQuality {get; set;}

Property Value

From 0 to 100 (75 is recommended).

Explanation

The JpegQuality property sets the quality coefficient when an image is saved in JPEG or FPX (JPEG compression) file formats.

Default value is 75.

There is a tradeoff between the quality of a JPEG image and file size. Lowering this property value will result in a smaller file size however at the expense of image quality. Conversely, increasing the property value results in a high quality image but at the expense of larger file size.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


JpegSubsampling property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.JpegSubsampling Property

This property sets the YCrCb subsampling ratios when saving an image in JPEG format.

[Visual Basic] Public Property JpegSubsampling As Newtone.ImageKit.JpegSubsamplingKind
[C#] public Newtone.ImageKit.JpegSubsamplingKind JpegSubsampling {get; set;}

Property Value

A Newtone.ImageKit.JpegSubsamplingKind value

Explanation

The JpegSubsampling property sets the YCrCb subsampling ratios when saving an image in JPEG format. Since the Y (luminance or brightness) plane contains more important information about the image than does the CrCb (chrominance or color) planes, it is possible to reduce the size of the CrCb planes without a great sacrifice in quality thereby reducing the size of the image. A ratio for Y:Cr:Cb of 4:4:4 represents no reduction in size whereas a ratio of 4:1:1 represents a reduction in size of 50%.

This property is enabled when the image is 24 bit color and the image is saved as a JPEG image.

Note: To use this property, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


Link property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.Link Property

This property establishes the link between the PanWindow and the ImageKit Control.
[Visual Basic] Public Property Link As Newtone.ImageKit.Web.PanWindow
[C#] public Newtone.ImageKit.Web.PanWindow Link {set; get;}

Property Value

The default value is null.

Explanation

When using the PanWindow, set this property as follows: ImageKit1.Link = PanWindow1.Link. This establishes a link between the PanWindow and the ImageKit Control.

See Also

ImageKit Member | Newtone.ImageKit.Web.ImageKit


LoadPage property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.LoadPage Property

This property sets which page of a multi-page image file is loaded. (FPX, GIF, or TIFF file formats only)

[Visual Basic] Public Property LoadPage As Integer
[C#] public int LoadPage {get; set;}

Property Value

The page index of a mutli-page image file.

The first page is 0 (For FPX format the base image is 0).

Explanation

The LoadPage property sets which page of a muli-page image is loaded. For FPX, GIF, or TIFF file formats only.

In GIF and TIFF file formats, numerous images can be stored in one multi-page image file. In FPX file format, images of different resolutions can be stored in one multi-resolution image file.

The LoadPage property is used when loading a particular page from a multi-page image file.

Note: To use FPX images, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


PngAlphaChannel property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.PngAlphaChannel Property

This property sets the alpha channel in a PNG image.

[Visual Basic] Public Property PngAlphaChannel As Boolean
[C#] public bool PngAlphaChannel {get; set;}

Property Value

Value | Explanation
True | Sets the alpha channel as an independent plane (RGBA format)
False (default) | Incorporates the alpha channel to produce an RGB image

Explanation

The PngAlphaChannel property sets the alpha channel in a PNG image. The default value is False.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


RawData property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKitRawData Property

This property sets or receives the image data as a byte array when images are loaded or saved in raw data
[Visual Basic] Public Property RawData As Byte()
[C#] public byte[] RawData {get; set;}

Property Value

The image data as a byte array

Explanation

When the LoadRawDataFromFile method is executed the image data is set into this RawData property. When the SaveRawDataToFile method is executed the image data contained in this RawData property is saved to file. To free the image data referred to by this RawData property, set the property to null (In VisualBasic set to Nothing).

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


ScrollBars property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.ScrollBars Property

This property sets whether or not scroll bars are displayed in the ImageKit Control.

[Visual Basic] Public Property ScrollBars As Boolean
[C#] public bool ScrollBars {get; set;}

Property Value

Value | Explanation
True (default) | Displays scroll bars in the Imagekit Control
False | Does not display scroll bars in the Imagekit Control

Explanation

The ScrollBar property sets whether or not scroll bars are displayed in the ImageKit Control. When the ScrollBar property is True, if an image does not fit within the ImageKit Control, scroll bars will appear and can be used to scroll the image.

Important: Setting this property to false can result in the PanWindow not working properly in some browsers.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


TiffAppend property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.TiffAppend Property

This property sets whether or not an image, saved in TIFF format, is appended to an existing multi-page TIFF image or saved as a separate image.

[Visual Basic] Public Property TiffAppend As Boolean
[C#] public bool TiffAppend {get; set;}

Property Value

Value | Explanation
True | Multi-page TIFF image (The image will be appended to the end of an existing TIFF image)
False (default) | Single TIFF image (Each image file contains only one image)

Explanation

The TiffAppend property sets whether or not an image, saved in TIFF format, is appended to an existing multi-page TIFF image or saved as a separate image.

This property is enabled only when saving images in TIFF format. When the TiffAppend property is True and the SaveImageToFile method has been executed be sure to execute the CloseMultiTiff method.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


TiffColorSpace property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.TiffColorSpace Property

This property defines the color space used when saving images in TIFF file format.

[Visual Basic] Public Property TiffColorSpace As Newtone.ImageKit.TiffColorSpaceKind
[C#] public Newtone.ImageKit.TiffColorSpaceKind TiffColorSpace {get; set;}

Property Value

This value is of type Newtone.ImageKit.TiffColorSpaceKind

Explanation

The TiffColorSpace property defines the color space used saving images in TIFF file format. This property is enabled when the image to be saved is either 24 or 32 bit color. If the TiffColorSpace property is set to 1 (CMYK) then the image file will be converted to 32 bit. This property can be set when using Uncompressed TIFF, PACKBITS or LZW file formats.

Note: To use this property, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


TiffSaveOneStrip property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.TiffSaveOneStrip Property

This property sets whether or not TIFF images are saved as single-strip or multi-strip images.

[Visual Basic] Public Property TiffSaveOneStrip As Boolean
[C#] public bool TiffSaveOneStrip {get; set;}

Property Value

Value | Explanation
True | TIFF images are saved as a single-strip image
False (default) | TIFF images are saved as a multi-strip image

Explanation

The TiffSaveOneStrip property sets whether or not TIFF images are saved as single-strip or multi-strip images. The default value is False. This property is enabled for all TIFF file formats except TIFF GROUP4 (GROUP4 files must be single-strip images).

Note: To use this property, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


Transparent property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.Transparent Property

This property sets whether or not the transparent color in GIF and PNG images is enabled.

[Visual Basic] Public Property Transparent As Boolean
[C#] public bool Transparent {get; set;}

Property Value

Value | Explanation
True | The transparent color is enabled
False (default) | The transparent color is disabled

Explanation

The Transparent property sets whether or not the transparent color, as set in the TransparentRed, TransparentGreen, and TransparentBlue properties, is enabled in GIF or PNG images.

Note: To use this property, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


TransparentBlue property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.TransparentBlue Property

This property sets the blue component (RGB values) of the transparent color when saving an image as a GIF or PNG image.

[Visual Basic] Public Property TransparentBlue As Byte
[C#] public byte TransparentBlue {get; set;}

Property Value

The values can range from 0 to 255

Explanation

The TransparentBlue property sets the blue component (RGB values) of the transparent color when saving an image as a GIF or PNG image. When saving an image as a GIF or PNG image, a color can be transparent by setting the appropriate RGB values in each of the TransparentBlue, TransparentGreen, and TransparentRed properties.
This property value is valid when the Transparent property is True.

Note: To use this property, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit.File Members | Newtone.ImageKit.Web.ImageKit


TransparentGreen property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.TransparentGreen Property

This property sets the green component (RGB values) of the transparent color when saving an image as a GIF or PNG image.

[Visual Basic] Public Property TransparentGreen As Byte
[C#] public byte TransparentGreen {get; set;}

Property Value

The values can range from 0 to 255

Explanation

The TransparentGreen property sets the Green component (RGB values) of the transparent color when saving an image as a GIF or PNG image. When saving an image as a GIF or PNG image, a color can be transparent by setting the appropriate RGB values in each of the TransparentBlue, TransparentGreen, and TransparentRed properties.
This property value is valid when the Transparent property is True.

Note: To use this property, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit.File Members | Newtone.ImageKit.Web.ImageKit


TransparentRed property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.TransparentRed Property

This property sets the red component (RGB values) of the transparent color when saving an image as a GIF or PNG image.

[Visual Basic] Public Property TransparentRed As Byte
[C#] public byte TransparentRed {get; set;}

Property Value

The values can range from 0 to 255

Explanation

The TransparentRed property sets the red component (RGB values) of the transparent color when saving an image as a GIF or PNG image. When saving an image as a GIF or PNG image, a color can be transparent by setting the appropriate RGB values in each of the TransparentBlue, TransparentGreen, and TransparentRed properties.
This property value is valid when the Transparent property is True.

Note: To use this property, you must have the appropriate ImageKit7 dlls.

See Also

ImageKit.File Members | Newtone.ImageKit.Web.ImageKit


Url property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.Url Property

This property sets the virtual path to the image that will be displayed in the ImageKit Control.
[Visual Basic]
Public Property Url As String
[C#]
public string Url {get; set;}

Property Value

The virtual path to the image file

Explanation

The Url property sets the virtual path to the image that will be displayed in the ImageKit Control. This property uses a relative virtual path.

For example, if the image resides in the following virtual path:
"http://myserver/myfolder/myimage.jpg"

Set the Url property as follows:
ImageKit1.Url = "/myfolder/myimage.jpg"

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


VectorHeight property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.VectorHeight Property

This property sets the height of a vector image when the image is loaded.

[Visual Basic] Public Property VectorHeight As Integer
[C#] public int VectorHeight {get; set;}

Property Value

The VectorHeight property sets the height of the vector image (in pixels). Default value is 0.

Explanation

The VectorHeight property sets the height of the vector image (in pixels).

For DXF and SXF images

If the VectorHeight property is set to a value of 0 or less, the 600 will be used.

For EMF, SVG, and WMF images

If the VectorHeight property is set to a value of 0 or less, the size defined in the file header will be used.

Regarding image size: When a vector image is loaded, the ratio of the height and width of the original image is maintained and the image is scaled within the area defined by the VectorHeight and VectorWidth properties.

Note: The ImageKit7 dlls are required when loading DXF, SXF, or SVG images.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


VectorWidth property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.VectorWidth Property

This property sets the width of a vector image when the image is loaded.

[Visual Basic] Public Property VectorWidth As Integer
[C#] public int VectorWidth {get; set;}

Property Value

The VectorWidth property sets the width of the vector image (in pixels). Default value is 0.

Explanation

The VectorWidth property property sets the width of a vector image when the image is loaded.

For DXF and SXF images

If the VectorWidth property is set to a value of 0 or less, 800 will be used.

For EMF, SVG, and WMF images

If the VectorWidth property is set to a value of 0 or less, the size defined in the file header will be used.

Regarding image size: When the vector image is loaded, the ratio of the height and width of the original image is maintained and the image is scaled within the area defined by the VectorHeight and the VectorWidth properties.

Note: The ImageKit7 dlls are required when loading DXF, SXF, or SVG images.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


CloseMultiTiff method

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.CloseMultiTiff Method

This method closes the multipage tiff file after the file has been saved.

[Visual Basic] Public Function CloseMultiTiff() As Boolean
[C#] public bool CloseMultiTiff() ;

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CloseMultiTiff method closes the multipage tiff file after the file has been saved. This method must be executed when the TiffAppend property is True, and the multipage tiff image has been saved using the SaveImageToFile method. For example code, please refer to the TiffAppend property.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


Display method

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.Display Method

This method displays the image.
[Visual Basic] ublic Function Display(ByVal Value As DisplayMode) As Boolean
[C#] ublic bool Display( DisplayMode Value) ;

Parameters

Specifies the Display mode. This is of type DisplayMode.
Note: The DisplayMode values of FitToWidth and FitToHeight are not supported in the ImageKit.Web component.

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

When the DisplayMode is 0 (Clear), the image displayed within the ImageKit Control is cleared. To display images in the ImageKit Control you must execute the Display method again. When the DisplayMode is 1 or more, the image is displayed.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


LoadImageFromFile method

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.LoadImageFromFile Method

This method loads image data from a file.
[Visual Basic] Public Function LoadImageFromFile(Val As Newtone.ImageKit.LoadFileType) As Boolean
[C#] public bool LoadImageFromFile(Newtone.ImageKit.LoadFileType Val) ;

Parameters

Specifies the type of image to be loaded. This value is of type Newtone.ImageKit.LoadFileType

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The LoadImageFromFile method loads image data from a file. The file set in the Url property is loaded. To load a multi-page image file, set the page to be loaded into the LoadPage property.

The following formats require the appropriate ImageKit7 dlls: JPEG2000, FPX, PCX, DXF, SVG, SXF.

Regarding FlashPix:

Flashpix image files are multi-resolution image files with a tiled composition. Flashpix files store image data in a hierarchy from the original image at the highest level. Each subsequent level contains the same image with horizontal and vertical resolution half that of the image in the level above. This allows editing and printing at the optimum resolution. Each resolution image is divided in to 64x64 tiles. Each tiled image can be uncompressed, JPEG compression, or single color compression.

See Also

ImageKit Member | Newtone.ImageKit.Web.ImageKit


LoadImageFromRawData method

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.LoadImageFromRawData Method

This method loads the image from raw data.
[Visual Basic] Public Function LoadImageFromRawData(Val As Newtone.ImageKit.LoadFileType) As Boolean
[C#] public bool Newtone.ImageKit.LoadImageFromRawData(Newtone.ImageKit.LoadFileType Val) ;

Parameters

Specifies the types of image to be loaded. This value is of type Newtone.ImageKit.LoadFileType.

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

This method loads the image from the raw data set in the RawData property. To load a multi-page image file, set the page to be loaded into the LoadPage property.

Note: The following formats require the appropriate ImageKit7 dlls: JPEG2000, FPX, PCX, DXF, SVG, SXF.

Though there are differences in loading images from raw data and loading images from file, the procedure is the same as in the LoadImageFromFile method

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


LoadRawDataFromFile method

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.LoadRawDataFromFile Method

This method loads the raw image directly from file without converting it to DIB.
[Visual Basic] Public Function LoadRawDataFromFile() As Boolean
[C#] public bool LoadRawDataFromFile() ;

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

This method loads raw data directly from file without converting it to DIB. The raw data is loaded from the file specified by the Url property. Once loaded, the raw data is set into the RawData property.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


LoadRawDataFromStream method

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.LoadRawDataFromStream Method

This method loads image data from stream and sets it into the RawData property.
[Visual Basic] Public Function LoadRawDataFromStream(Val As MemoryStream)
[C#] public void LoadRawDataFromStream(MemoryStream Val) ;

Parameters

Image data of type MemoryStream

Return Value

None

Explanation

This method loads image data from stream and sets it into the RawData property.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


SaveImageToFile method

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.SaveImageToFile Method

This methods saves image data to a file

[Visual Basic]
Public Function SaveImageToFile(Val As Newtone.ImageKit.SaveFileType, Url As String) As Boolean
[C#]
public bool Newtone.ImageKit.SaveImageToFile(Newtone.ImageKit.SaveFileType Val, string Url) ;

Parameters

The format in which the image is to be saved. This value is of type Newtone.ImageKit.SaveFileType

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The SaveImageToFile method saves image data to a file.

The string set in the Url parameter determines the location where the image will be saved. This parameter uses a relative virtual path.

For example, if the image should be saved in the following virtual path:
"http://myserver/myfolder/myimage.jpg"

Set the Url parameter as follows:
ImageKit1.Url = "/myserver/myfolder/myimage.jpg"

Below is a list image formats and the properties that should be set when saving files in that format

FPX | The Comment property should be set. If the Val parameter is SaveFPXJpeg then the JpegQuality property should also be set.
GIFAnimation | The Comment, GifAnimation, GifAnimationDelay, Interlace, TransparentBlue, TransparentGreen, TransparentRed, and Transparent property should be set.
JPEG | The Comment, JpegQuality, and JpegSubsamp properties should be set.
JPEG Progress | The Comment, JpegQuality, and JpegSubsamp properties should be set.
JPEG2000 | The Comment, JPEG2000CodeBlockHeight, JPEG2000CodeBlockWidth, JPEG2000NumResLevel, JPEG2000PrecinctHeight, JPEG2000PrecinctWidth, JPEG2000Reversible, JPEG2000Size, JPEG2000TileHeight, and JPEG2000TileWidth properties should be set.
PNG | The Comment, Interlace, TransparentBlue, TransparentGreen, TransparentRed, PngAlphaChannel, and Transparent properties should be set. When the PngAlphaChannel property is True, pass the image handle of the 32 bit RGBA image to the Image property.
TIFF | The TiffAppend property should be set. If the TiffAppend property is True, then after executing this method, be sure to execute the CloseMultiTiff method. If the Val parameter is SaveTIFFNoncompressed, SaveTIFFPackbits, or SaveTIFFLZW then the TiffColorSpace property should be set. If Tiff images are saved as Group3-2D or CCITTRLE (other than GROUP4), the Comment and TiffSaveOneStrip properties should be set.

With certain raster image formats, it is only possible to save images of a particular bitcount. Errors can be generated it an image of unsupported bitcount is saved in an image format. Below is a list of supported bitcounts when saving each type of raster image.

Image File Format: Supported bitcounts when saving image
BMP(Uncompressed): 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
BMP(Compressed): 4, 8
JPEG(Standard DCT): 8 bit grayscale, 24
JPEG(Progressive DCT): 8 bit grayscale, 24
GIF: 1, 4, 8
TIFF(Uncompressed): 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
TIFF(CCITTRLE): 1
TIFF(GROUP3-1D): 1
TIFF(GROUP3-2D): 1
TIFF(GROUP4): 1
TIFF(PACKBITS): 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
TIFF(LZW): 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
PNG: 1, 4, 8, 24
FPX(Uncompressed): 8 bit grayscale, 24
FPX(Single Color Compressed): 8 bit grayscale, 24
FPX(JPEG Compression): 8 bit grayscale, 24
PCX: 1, 4, 8, 24
JPEG2000(Part1): 8 bit grayscale, 24
JPEG2000(Code Stream): 8 bit grayscale, 24

Note: TIFF Group 3 - 1D is the same as MH. TIFF Group 3 - 2D is the same as MR. TIFF Group 4 is the same as MMR.
If images are saved in uncompressed TIFF, TIFF Packbits, or TIFF Lzw formats as 16 bit images, they will be converted to 24 bit.

The following image formats require the appropriate ImageKit7 dll files in order to be saved: BMP(Compressed), JpegProgress,GifAnimation, TIFF CCITTRLE, TIFFGroup3_2D, JPEG2000, FPX, PCX, WMF, EMF, DXF, SVG, SXF.

WMF and EMF images cannot ordinarilly be loaded and displayed in .NET but rather are converted to raster images when displayed. For that reason, even though the file extension is .emf or .wmf, the images can only be saved as raster images.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


SaveImageToRawData method

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.SaveImageToRawData Method

The image is saved as raw data.
[Visual Basic] Public Function SaveImageToRawData(Val As Newtone.ImageKit.SaveFileType, Image As Image) As Boolean
[C#] public bool SaveImageToRawData(Newtone.ImageKit.SaveFileType Val, Image Image) ;

Parameters

Specifies the type of image format to save the image. This is a Newtone.ImageKit.SaveFileType value.

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

This method saves the image as raw data. The image set in the Image parameter is saved into the RawData property.

When the Image parameter contains a valid image handle

The image set in the Image parameter will be saved in the location specified by the Url property.

Below is a list of other properties that should be set when saving files in the these formats...

FPX | The Comment property should be set. If the Val parameter is SaveFPXJpeg then the JpegQuality property should also be set.
GIFAnimation | The Comment, GifAnimation, GifAnimationDelay, Interlace, TransparentBlue, TransparentGreen, TransparentRed, and Transparent property should be set.
JPEG | The Comment, JpegQuality, and JpegSubsamp properties should be set.
JPEG Progress | The Comment, JpegQuality, and JpegSubsamp properties should be set.
JPEG2000 | The Comment, JPEG2000CodeBlockHeight, JPEG2000CodeBlockWidth, JPEG2000NumResLevel, JPEG2000PrecinctHeight, JPEG2000PrecinctWidth, JPEG2000Reversible, JPEG2000Size, JPEG2000TileHeight, and JPEG2000TileWidth properties should be set.
PNG | The Comment, Interlace, TransparentBlue, TransparentGreen, TransparentRed, PngAlphaChannel, and Transparent properties should be set. When the PngAlphaChannel property is True, pass the image handle of the 32 bit RGBA image to the Image property.
TIFF | The TiffAppend property should be set. If the Val parameter is SaveTIFFNoncompressed, SaveTIFFPackbits, or SaveTIFFLZW then the TiffColorSpace property should be set. If Tiff images are saved as Group3-2D or CCITTRLE (other than GROUP4), the Comment and TiffSaveOneStrip property should be set.

Although there are some differences between saving an image to file and saving an image to raw data, essentially the process is the same as in the SaveImageToFile method. With certain raster image formats, it is only possible to save images of a particular bitcount. Errors can be generated if an image of an unsupported bitcount is saved in an particular image format. A good example of this is trying to save a 1 bit black and white image in JPEG format. (JPEG only supports 8 bit grayscale and 24 bit color.)

Below is a list of supported bitcounts for each type of raster image.

Image File Format: Supported bitcounts when saving image
BMP(Uncompressed): 1,4,8,16,24,32 (Does not include 16 bit grayscale)
BMP(Compressed): 4,8
JPEG(Standard DCT): 8 bit grayscale,24
JPEG(Progressive DCT): 8 bit grayscale,24
GIF: 1,4,8
TIFF(Uncompressed): 1,4,8,16,24,32 (Does not include 16 bit grayscale)
TIFF(CCITTRLE): 1
TIFF(GROUP3-1D): 1
TIFF(GROUP3-2D): 1
TIFF(GROUP4): 1
TIFF(PACKBITS): 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
TIFF(LZW): 1, 4, 8, 16, 24, 32 (Does not include 16 bit grayscale)
PNG: 1, 4, 8, 24
FPX(Uncompressed): 8 bit grayscale, 24
FPX(Single Color Compressed): 8 bit grayscale, 24
FPX(JPEG Compression): 8 bit grayscale, 24
PCX: 1, 4, 8, 24
JPEG2000(Part1): 8 bit grayscale, 24
JPEG2000(Code Stream): 8 bit grayscale, 24

TIFF GROUP3-1D is the same as MH. TIFF GROUP3-2D is the same as MR. TIFF GROUP4 is the same as MMR.
If images are saved in uncompressed TIFF, TIFF Packbits, or TIFF Lzw formats as 16 bit images, they will be converted to 24 bit.

Note: The following image formats require the appropriate ImageKit7 dll files in order to be saved: BMP(Compressed), JpegProgress,GifAnimation, TIFF CCITTRLE, TIFFGroup3_2D, JPEG2000, FPX, PCX, WMF, EMF, DXF, SVG, SXF.

WMF and EMF images cannot ordinarilly be loaded and displayed in .NET but rather are converted to raster images when displayed. For that reason, even though the file extension is .emf or .wmf, the images can only be saved as raster images.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


SaveRawDataToFile method

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.SaveRawDataToFile Method

This method saves raw image data to file.
[Visual Basic] Public Function SaveRawDataToFile() As Boolean
[C#] public bool SaveRawDataToFile() ;

Parameters

None

Return Value

Returns True if successful. Return False if unsuccessful.

Explanation

This method saves the raw data set in the RawData property into the file specified by the Url property.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


SaveRawDataToStream method

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.SaveRawDataToStream Method

This method saves raw data to stream.

[Visual Basic] Public Function SaveRawDataToStream() As MemoryStream
[C#] public MemoryStream SaveRawDataToStream() ;

Parameters

None

Return Value

Memory stream

Explanation

The SaveRawDataToStream method saves raw data to stream. The value in the RawData property is returned as a memory stream.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


ShowPanWindow method

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ImageKit.ShowPanWindow Method

This method displays the image in the Pan Window.
[Visual Basic] Public Function ShowPanWindow() As Boolean
[C#] public bool ShowPanWindow() ;

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

This method displays the image in the Pan Window. To link the ImageKit Control with the Pan Window Control set the link property as follows: ImageKit1.Link = PanWindow1.Link.

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


BrowserImageFormat.htm

Newtone.ImageKit.Web

Newtone.ImageKit.Web.BrowserImageFormat Enum

This refers to the image format to be displayed in a browser.

public enum BrowserImageFormat

Public Members

Member | Value | Explanation
jpg | jpg | JPEG format
png | png | PNG format
gif | gif | GIF format

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


DisplayMode enum

Newtone.ImageKit.Web

Newtone.ImageKit.Web.DisplayMode Enum

This refers to the display mode of the image.

public enum DisplayMode

Public Members

Member | Value | Explanation
Clear | 0 | Clears the ImageKit Control
Scale | 1 | Scale display mode
Stretch | 2 | Stretch display mode
ActualSize | 3 | Actual size display mode

See Also

ImageKit Members | Newtone.ImageKit.Web.ImageKit


Newtone.ImageKit.Web.PanWindow Class

The main class for the web server version of the PanWindow Control.

For a list of all members of this type, see PanWindow Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Newtone.ImageKit.Web
public class PanWindow : Object

Explanation

The ImageKit.Web.PanWindow Control is used in conjuction with the ImageKit.Web.ImageKit Control. The PanWindow Control is a web server control that displays the entire image while only a portion of the image is begin displayed in the ImageKit Control. By clicking the PanWindow control, that location on the image is displayed in the center of the ImageKit Control and the viewer in the PanWindow Control can be moved with the mouse. By moving the viewer with the mouse, the image displayed within the ImageKit Control is scrolled. To stop the scrolling action and release the viewer in the PanWindow, click the PanWindow Control again. The viewer will be released by the mouse and scrolling stops.

To use the PanWindow the following two conditions must be met:
1. The ImageKit Control and PanWindow Control must be linked using their Link properties as follows: ImageKit1.Link = PanWindow1.Link
2. For images displayed in the ImageKit Control to appear in the PanWindow Control, set the ImageKit Control's DisplayMode to ActualSize.

Example

[Visual Basic.NET]
ImageKit1.Url = Thumbnail1.ImageDirectory + "/" + Thumbnail1.FileName
ImageKit1.LoadFile(Newtone.ImageKit.LoadFileType.Load)
ImageKit1.Display(Newtone.ImageKit.Web.DisplayMode.ActualSize)
ImageKit1.Link = PanWindow1.Link
ImageKit1.ShowPanWindow()

[C#]
ImageKit1.Url = Thumbnail1.ImageDirectory + "/" + Thumbnail1.FileName;
ImageKit1.LoadFile(Newtone.ImageKit.LoadFileType.Load);
ImageKit1.Display(Newtone.ImageKit.Web.DisplayMode.ActualSize);
ImageKit1.Link = PanWindow1.Link;
ImageKit1.ShowPanWindow();

Note:
Under the conditions below, some browsers will not correctly display the PanWindow:
1. When the ImageKit Control's ScrollBars property is set to False
2. When the size of the viewer in the PanWindow is less than 20 X 20 pixels. (The size of the viewer is determined by the relationship between the size of the PanWindow Control, the size of the ImageKit Control, and the size of the image being displayed)

Requirements

Namespace : Newtone.ImageKit.Web

Assembly : Newtone.ImageKit.Web.ImageKit.dll

See Also

PanWindow Members


ImageKitWebPanWindow Members

Newtone.ImageKit.Web

Newtone.ImageKit.Web.PanWindow All Members

PanWindow Overview

Constructor

PanWindow Constructor Initializes a new instance of the PanWindow class

Public Properties

BackColor | Sets the color for the background of the PanWindow Control
Cursor | Sets the shape of the mouse cursor used in the PanWindow Control
EnableViewer | Displays or hides the view finder within the Pan Window Control
ViewerBorderColor | Sets the color of the rectangle border in the Pan Window

See Also

Newtone.ImageKit.Web.PanWindow


ImageKitWebPanWindow Constructor

Newtone.ImageKit.Web

Newtone.ImageKit.Web.PanWindow Constructor

This initializes a new instance of the PanWindow class.

[Visual Basic] Public Sub New()
[C#] public PanWindow()

See Also

PanWindow Members | Newtone.ImageKit.Web.PanWindow


BackColor property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.PanWindow.BackColor Property

This property sets the background color of the PanWindow Control.

[Visual Basic] Public Property BackColor As Color
[C#] public Color BackColor {get; set;}

Property Value

The default value is Color.Gainsboro.

Explanation

The BackColor property sets the background color of the PanWindow Control. This property is set using System.Drawing.Color object.

See Also

PanWindow Members | Newtone.ImageKit.Web.PanWindow


Cursor property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.PanWindow.Cursor Property

This property sets the shape of the mouse cursor used in the PanWindow Control.

[Visual Basic] Public Property Cursor As PanCursor
[C#] public PanCursor Cursor {get; set;}

Property Value

The default value is Hand.

Explanation

The Cursor property sets the shape of the mouse cursor used in the PanWindow Control.

See the PanCursor Enum for details.

See Also

PanWindow Members | Newtone.ImageKit.Web.PanWindow


EnableViewer property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.PanWindow.EnableViewer Property

This property displays or hides the view finder within the Pan Window Control.
[Visual Basic] Public Property EnableViewer As Boolean
[C#] public bool ViewerBorderColor EnableViewer {get; set;}

Property Value

The default value is True.

Explanation

This property displays or hides the view finder within the Pan Window Control. By moving the view finder with the mouse, the image displayed within the ImageKit Control can be scrolled. Depending on the browser, the view finder in the pan window may not be displayed properly. In that case, please set this property to False.

See Also

PanWindow Members | Newtone.ImageKit.Web.PanWindow


ViewerBorderColor property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.PanWindow.ViewerBorderColor Property

This property sets the color of the rectangle border of the view finder in the Pan Window.

[Visual Basic] Public Property ViewerBorderColor As Color
[C#] public Color ViewerBorderColor {get; set;}

Property Value

The default value is Color.Black.

Explanation

The ViewerBorderColor property sets the color of the rectangle border of the view finder in the Pan Window. This property is set using System.Drawing.Color object.

See Also

PanWindow Members | Newtone.ImageKit.Web.PanWindow


PanCursor enum

Newtone.ImageKit.Web

Newtone.ImageKit.Web.PanCursor Enum

This property sets the shape of the cursor that is used inside the Pan Window.

public enum PanCursor

Public Members

Member | Value | Explanation
Hand | Hand | Hand
AllScroll | AllScroll | Arrows pointing up, down, left, and right with a dot in the middle, indicating that the page can be scrolled in any direction. Microsoft Internet Explorer 6 and later.
Auto | Auto | Browser determines which cursor to display based on the current context.
ColResize | ColResize | Arrows pointing left and right with a vertical bar separating them, indicating that the item/column can be resized horizontally. Internet Explorer 6 and later.
CrossHair | CrossHair | Crosshair
Default | Default | Default cursor. Standard arrow is used by default.
Help | Help | Standard arrow and question mark
Move | Move | Crossed arrows, indicating something is to be moved.
NoDrop | NoDrop | Hand and slashed circle. Microsoft Internet Explorer 6 and later.
NotAllowed | NotAllowed | Slashed circle. Microsoft Internet Explorer 6 and later.
Pointer | Pointer | Hand with the first finger pointing up, as when the user moves the pointer over a link. Identical to hand. Internet Explorer 6 and later.
Progress | Progress | Standard arrow and hourglass. Internet Explorer 6 and later.
RowResize | RowResize | Arrows pointing up and down with a horizontal bar separating them, indicating that the item/row can be resized vertically. Internet Explorer 6 and later.
Text | Text | I-beam
VerticalText | VerticalText | Editable vertical text, indicated by a horizontal I-bar. Internet Explorer 6 and later.
Wait | Wait | Hourglass
NResize | NResize | Arrows where the asterisk (*) can be N, NE, NW, S, SE, SW, E, or W—each representing a compass direction.
NEResize | NEResize | Arrows where the asterisk (*) can be N, NE, NW, S, SE, SW, E, or W—each representing a compass direction.
NWResize | NWResize | Arrows where the asterisk (*) can be N, NE, NW, S, SE, SW, E, or W—each representing a compass direction.
SResize | SResize | Arrows where the asterisk (*) can be N, NE, NW, S, SE, SW, E, or W—each representing a compass direction.
SEResize | SEResize | Arrows where the asterisk (*) can be N, NE, NW, S, SE, SW, E, or W—each representing a compass direction.
SWResize | SWResize | Arrows where the asterisk (*) can be N, NE, NW, S, SE, SW, E, or W—each representing a compass direction.
EResize | EResize | Arrows where the asterisk (*) can be N, NE, NW, S, SE, SW, E, or W—each representing a compass direction.
WResize | WResize | Arrows where the asterisk (*) can be N, NE, NW, S, SE, SW, E, or W—each representing a compass direction.

Note: Depending on the browser, these settings can be disabled.

See Also

PanWindow Members | Newtone.ImageKit.Web.ImageKit


ImageKitWebThumbnail class

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail Class

This is the main class for the ImageKit Web Thumbnail Control.

For a list of all members of this type, see Thumbnail Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.BaseDataList
System.Web.UI.WebControls.DataList
Newtone.ImageKit.Web
public class Thumbnail : Object

Explanation

The ImageKit Web Thumbnail Control is a web server control that automatically displays multiple images as thumbnails. Use the ImageDirectory property to set the directory that contains the images you would like to display and then execute the ShowThumbnailImages method. The Thumbnail Control will load these images and automatically create thumbnail images from the images, saving the thumbnail images (JPEG format) in the directory specified by the ThumbnailImageDirectory. The thumbnail images are then displayed in the WebForm.

Virtual Directories: Both directories, the image directory (specified by the ImageDirectory property) and the thumbnail image directory (specified by the ThumbnailImageDirectory property), must exist on the server where the Thumbnail Control application runs. The thumbnail image directory must have write permission. The paths to both directories must be virtual paths but omits the server name. For example:

If the image directory is in the following virtual path: "http://MyServer/SampleImages/1"

then the ImageDirectory property should be set to "/SampleImages/1". (without "http://MyServer" )

Likewise, when the thumbnail image directory is in the following virtual path: "http://localhost/SampleImages/1/ThumbnailImages"

then the ThumbnailImageDirectory property should be set to "/SampleImages/1/ThumbnailImages" (without "http://MyServer")

The Thumbnail Control creates thumbnail images on the server as 24 bit color JPEG images. This is true regardless of the original image's bitcount or image format. This is true even if 1 bit color images or vector images are loaded into the Thumbnail Control.

If the directory, specified by the ThumbnailImageDirectory property, does not exist, the Thumbnail Control will create that directory along with the thumbnail images. IMPORTANT: This thumbnail image directory must have write permission. The thumbnail images will be recreated if the original image directory's datetime stamp is newer than the thumbnail image directory's datetime stamp.

Information about the created thumbnail images is stored in a thumbnail configuration file (an xml file called Config.xml by default). This file is specified by the ConfigFile property. When the information in the ConfigFile changes, the thumbnail images will be recreated.

The thumbnail images will be created with the name of the original image + ".jpg". So if the original image is named "ABC123.jpg", the Thumbnail Control will create a thumbnail for this image called "ABC123.jpg.jpg"

DataList

ShowFileNameText property

By default, the Thumbnail Control displays the original image's filename in the cell under the thumbnail image. By using the ShowFileNameText property, you can set an xml file that allows seperate comments to be displayed under each thumbnail image. For example, if the following xml file, named "FileNameText.xml", exists in the same directory as these images "001.jpg", "abc.tif", "002.jpg", then the following comments will be displayed under the corresponding thumbnail images.

FileNameText.xml
<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<FileNameText>
<_001.jpg>Image_1</_001.jpg>
<abc.tif-1>Image_2</abc.tif-1>
<abc.tif-2>Image_3</abc.tif-2>
<_002.jpg>Image_4</_002.jpg>
</FileNameText>

Note: Because xml tags cannot contain a numeral as the first character, an underbar is added at the beginning of the xml tags for images "001.jpg" and "002.jpg". The Thumbnail Control will ignore the initial underbar in any tag within the FileNameText.xml file. Also, image abc.tif is a multipage tiff image. In the xml tag, the second page of this multipage tiff image is designated in as and the third page is designated as (The page index starts with 0).

Although we recommend that you keep the FileNameText.xml file in the same directory as the images that it modifies, it is possible to change the directory of the FileNameText.xml file. To do this, set a virtual path from the FileNameText.xml file to the directory containing the images that it modifies. In other words, setting the ShowFileNameText property to "../../FileNameText.xml" means that the FileNameText.xml file is contained in the virtual directory two directories above the directory containing the images.

HyperLinkURLFile property

By default, clicking a thumbnail image displays the original image file. By using the HyperLinkURLFile property, you can set an xml file that allows seperate hyperlinks to be used when different thumbnail images are clicked. For example, if the following xml file, named "URL.xml", exists in the same directory as these images "001.jpg", "abc.tif", and "002.jpg", then the following hyperlinks will be enabled when the corresponding thumbnail images are clicked.

URL.xml"
<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<UrlData>
<_001.jpg>http://www.newtone.co.jp/</_001.jpg>
<abc.tif-1>http://msdn.microsoft.com/library/ja/</abc.tif-1>
<abc.tif-2>http://www.yahoo.co.jp/</abc.tif-2>
<_002.jpg>http://www.google.co.jp/</_002.jpg>
</UrlData>

Note: Because xml tags cannot contain a numeral as the first character, an underbar is added at the beginning of the xml tags for images "001.jpg" and "002.jpg". The Thumbnail Control will ignore the initial underbar in any tag within the xml file. Also, the image abc.tif is a multipage tiff image. The xml tag that designates the second page of this multipage tiff image is <abc.tif-1> and the xml tag designating the third page is <abc.tif-2> (The page index starts with 0).

Although we recommend that you keep the xml file in the same directory as the images that it modifies, it is possible to change the directory of the xml file. To do this, set a virtual path from the xml file to the directory containing the images that it modifies. In other words, setting the HyperLinkURLFile property to "../../URL.xml" means that the xml file called "URL.xml" is contained in the directory two directories above the directory containing the images.

Requirements

Namespace : Newtone.ImageKit.Web

Assembly : Newtone.ImageKit.Web.Thumbnail.dll

See Also

Thumbnail Members


ImageKitWebThumbnail Members

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail All Members

Thumbnail Overview

Constructor

Thumbnail Constructor Initializes a new instance of the Thumbnail class

Public Properties

ColumnNumber | Sets the number of columns displayed in the Thumbnail Control
ConfigFile | Sets the configuration file for the Thumbnail Control
CurrentPage | Refers to the page of the currently displayed thumbnail image
EnableHyperLink | Sets the hyperlink to the image file
EnableMultiPageImage | Sets whether or not multipage images can be loaded into the Thumbnail Control.
EnablePaging | Sets whether or not default paging is used in the Thumbnail Control.
ErrorStatus | Refers to the types of errors that can occur when using the thumbnail control
FileName | Refers to the filename of the image when the thumbnail image is selected
FileNameSetText | Sets text that will be displayed under the thumbnail images. If no value is set, the filename of each image will be displayed under the thumbnails.
HyperLinkURLFile | Sets an xml file containing seperate hyperlinks for each thumbnail image displayed in the Thumbnail Control.
ImageBevelDepth | Sets the depth of the bevel
ImageBevelWidth | Sets the width of the bevel
ImageDirectory | Sets the path to the directory containing the images to be displayed as thumbnails
ImageFileExtension | Sets the the image type that can be displayed in the thumbnail control
ImageHeight | Sets the height of the thumbnail cell.
ImageWidth | Sets the width of the thumbnail cell.
PageOfMultiPageImage | Refers to the page number of the page selected in a multipage file.
RowNumber | Sets the number of rows displayed in the Thumbnail Control
ShowFileName | Sets whether or not the file name of the image is displayed under the thunbnail image in the Thumbnail Control
ShowFileNameText | Sets a comment and that is displayed under the thumbnail images
SortDirection | Sets the order in which the thumbnail images are displayed.
ThumbnailImageDirectory | Sets the directory where the thumbnail images are created.
TotalImageNo | Refers to the total number of thumbnail images.
TotalPageNo | Refers to the number of pages of thumbnail images

Public Methods

DeleteThumbnailDirectory | Deletes the thumbnail images and the their directory
ShowThumbnailImages | Displays the thumbnail images

Public Events

ShowThumbnail | Generated just after a thumbnail image is displayed in the thumbnail control
Click | Generated when a thumbnail image is clicked

See Also

Newtone.ImageKit.Web.Thumbnail


ImageKitWebThumbnail Constructor

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail Constructor

This initializes a new instance of the Thumbnail class.

[Visual Basic] Public Sub New()
[C#] public Thumbnail()

See Also

Thumbnail Members | Newtone.ImageKit.Web. Thumbnail


ColumnNumber property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.ColumnNumber Property

This property sets the number of columns displayed in the Thumbnail Control.

[Visual Basic] Public Property ColumnNumber As Integer
[C#] public int ColumnNumber {get; set;}

Property Value

The default value is 2

Explanation

The ColumnNumber property sets the number of columns displayed in the Thumbnail Control.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ConfigFile property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.ConfigFile Property

This property sets the Thumbnail Control's ConfigFile when contains information about creating thumbnail images.
[Visual Basic] Public Property ConfigFile String
[C#] public string ConfigFile {get; set;}

Property Value

The default value is "Config.xml".

Explanation

If any of the items in the ConfigFile are changed, the thumbnail images will be recreated.

The ConfigFile will be created in the image directory (according to theImageDirectory property value).

The following property values are saved in the ConfigFile:

TotalImageNo
ImageWidth
ImageHeight
ImageBevelDepth
ImageBevelWidth
EnableMultiPageImage

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


CurrentPage property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.CurrentPage Property

This property refers to the current page of thumbnail images being displayed in the Thumbnail Control.

[Visual Basic] Public ReadOnly Property CurrentPage As Integer
[C#] public int CurrentPage {get;}

Property Value

Read only

Explanation

The CurrentPage property refers to the current page of thumbnail images being displayed in the Thumbnail Control.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


EnableHyperLink property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.EnableHyperLink Property

This property sets the hyperlink to the thumbnail image file.

[Visual Basic] Public Property EnableHyperLink As Boolean
[C#] public bool EnableHyperLink {get; set;}

Property Value

The default value is True.

Explanation

The EnableHyperLink property sets the hyperlink to the thumbnail image file. When true, and the thumbnail image is clicked, the image corresponding to this thumbnail is displayed.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


EnableMultiPageImage property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.EnableMultiPageImage Property

This property enables multipage images to be loaded into the Thumbnail Control.
[Visual Basic] Public Property EnableMultiPageImage As Boolean
[C#] public bool EnableMultiPageImage {get; set;}

Property Value

The default value is False.

Explanation

The EnableMultiPageImage property enables multipage images to be loaded into the Thumbnail Control. When this property is true, each page of the multipage image will be displayed in the Thumbnail Control.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


EnablePaging property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.EnablePaging Property

This property sets whether or not default paging is used in the Thumbnail Control.

[Visual Basic] Public Property EnablePaging As Boolean
[C#] public bool EnablePaging {get; set;}

Property Value

The default value is True.

Explanation

The EnablePaging property sets whether or not default paging is enabled in the Thumbnail Control. When this property is false, (when default paging is not used), the page parameter of the ShowThumbnailImages(int page) method is enabled.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ErrorStatus property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.ErrorStatus Property

This property refers to the types of errors that can occur when using the Thumbnail Control.

[Visual Basic] Public ReadOnly Property ErrorStatus As Newtone.ImageKit.Error
[C#] public Newtone.ImageKit.Error ErrorStatus {get;}

Property Value

The value is an Error Enum value.

Read only

Explanation

The ErrorStatus property refers to the types of errors that can occur when using the Thumbnail Control. This property refers to the members of the Error Enum.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


FileName property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.FileName Property

This property refers to the filename of the image when the thumbnail image is selected.

[Visual Basic] Public ReadOnly Property FileName As String
[C#] public string FileName {get;}

Property Value

Read only

Explanation

The FileName property refers to the filename of the image when the thumbnail image is selected.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


FileNameSetText property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.FileNameSetText Property

This property sets text that will be displayed under the thumbnail images. If no value is set, the filename of each image will be displayed under the thumbnails.

[Visual Basic] Public Property FileNameSetText String
[C#] public string FileNameSetText {get; set;}

Property Value

The default value is "". If no value is set, the filename of each image will be displayed under the thumbnail images.

Explanation

The FileNameSetText property sets text that will be displayed under the thumbnail images. If no value is set, the filename of each image will be displayed under the thumbnails.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


HyperLinkURLFile property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.HyperLinkURLFile Property

This property sets an xml file that allows hyperlinks to be used when thumbnail images are clicked.
[Visual Basic] Public Property HyperLinkURLFile String
[C#] public string HyperLinkURLFile {get; set;}

Property Value

The default value is "URL.xml".

Explanation

The HyperLinkURLFile property sets an xml file that allows hyperlinks to be used when thumbnail images are clicked. Without this xml file, clicking a thumbnail image displays the original image file. When this xml file is used, hyperlinks can be set so that clicking the thumbnail images executes the hyperlinks.

The default name of this xml file is "URL.xml". It should be placed in the same directory as the images whose hyperlinks it sets. The xml tags in the xml file must correspond to the file names of the images.

For example, if the following xml file, named "URL.xml", exists in the same directory as these images "001.jpg", "abc.tif", and "002.jpg", then the following hyperlinks will be enabled when the corresponding thumbnail images are clicked.

URL.xml"
<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<UrlData>
<_001.jpg>http://www.newtone.co.jp/</_001.jpg>
<abc.tif-1>http://msdn.microsoft.com/library/ja/</abc.tif-1>
<abc.tif-2>http://www.yahoo.co.jp/</abc.tif-2>
<_002.jpg>http://www.google.co.jp/</_002.jpg>
</UrlData>

Note: Because xml tags cannot contain a numeral as the first character, an underbar is added at the beginning of the xml tags for images "001.jpg" and "002.jpg". The Thumbnail Control will ignore the initial underbar in any tag within the xml file. Also, the image abc.tif is a multipage tiff image. The xml tag that designates the second page of this multipage tiff image is <abc.tif-1> and the xml tag designating the third page is <abc.tif-2> (The page index starts with 0).

Although we recommend that you keep the xml file in the same directory as the images that it modifies, it is possible to change the directory of the xml file. To do this, set a virtual path from the xml file to the directory containing the images that it modifies. In other words, setting the HyperLinkURLFile property to "/../../URL.xml" means that the xml file called "URL.xml" is contained in the directory two directories above the directory containing the images.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ImageBevelDepth property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.ImageBevelDepth Property

This property sets the depth of the bevel in the thumbnail image.

[Visual Basic] Public Property ImageBevelDepth As Integer
[C#] public int ImageBevelDepth {get; set;}

Property Value

The value can range from 0 to 10. The default value is 10.

When the value is 0, bevel is disabled.

Explanation

The ImageBevelDepth property sets the depth of the bevel in the thumbnail image. When the Thumbnail Control first loads images, it creates thumbnail images for those images and saves these thumbnail images in the directory specified by the ThumbnailImageDirectory property. The ImageBevelWidth and ImageBevelDepth properties relate to the appearance of these thumbnail images and set the size and depth of the bevel effect when these thumbnail images are created.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ImageBevelWidth property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.ImageBevelWidth Property

This property sets the width of the bevel in the thumbnail image.

[Visual Basic] Public Property ImageBevelWidth As Integer
[C#] public int ImageBevelWidth {get; set;}

Property Value

The value can range from 0 to 20. The default value is 10.

When the value is 0, bevel is disabled.

Explanation

The ImageBevelWidth property sets the width of the bevel in the thumbnail image. When the Thumbnail Control first loads images, it creates thumbnail images for those images and saves these thumbnail images in the directory specified by the ThumbnailImageDirectory property. The ImageBevelWidth and ImageBevelDepth properties relate to the appearance of these thumbnail images and set the size and depth of the bevel effect when these thumbnail images are created.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ImageDirectory property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.ImageDirectory Property

This property sets the path to the image directory used by the Thumbnail Control. (This is a virtual path)

[Visual Basic] Public Property ImageDirectory String
[C#] public string ImageDirectory {get; set;}

Property Value

The virtual path to the image directory

Explanation

The ImageDirectory property sets the path to the image directory used by the Thumbnail Control. The path must be a virtual path.

Note: The Thumbnail ConfigFile is created in this directory. Please refer to the ConfigFile property.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ImageFileExtension property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.ImageFileExtension Property

This property sets the type of image that will be displayed in the Thumbnail Control.

[Visual Basic] Public Property ImageFileExtension String
[C#] public string ImageFileExtension {get; set;}

Property Value

The default value is BMP;JPG;TIF;PNG;GIF;WMF;EMF;ICO;PCX;FPX;JP2;JPC;J2K;DXF;SVG;P21;SFC. (all supported image types)

Explanation

The ImageFileExtension property sets the type of image that will be displayed in the Thumbnail Control.

The supported image types for thumbnail images are BMP; JPG; TIF; PNG; GIF; WMF; EMF; ICO. When used in conjunction with the ImageKit7 file dlls, the following image types are also supported: PCX; FPX; JP2; JPC; J2K; DXF; SVG; P21; SFC.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ImageHeight property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.ImageHeight Property

This property sets the height of the thumbnail image cell.

[Visual Basic] Public Property ImageHeight As Integer
[C#] public int ImageHeight {get; set;}

Property Value

The values can be set in pixels.

The default value is 100.

Explanation

The ImageHeight property sets the height of the thumbnail image cell.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ImageWidth property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail. Property

This property sets the width of the thumbnail image cell.

[Visual Basic] Public Property ImageWidth As Integer
[C#] public int ImageWidth {get; set;}

Property Value

The value can be set in pixels.

The default value is 100.

Explanation

The ImageWidth property sets the width of the thumbnail image cell.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


PageOfMultiPageImage property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.PageOfMultiPageImage Property

This property refers to the page number for the selected file when the selected file is part of a multipage image.

[Visual Basic] Public ReadOnly Property PageOfMultiPageImage As Boolean
[C#] public bool PageOfMultiPageImage {get;}

Property Value

The page number starts from 0.

This property is read only

Explanation

The PageOfMultiPageImage property refers to the page number for the selected file when the selected file is part of a multipage image.
If a single file is selected, this returns 0.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


RowNumber property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.RowNumber Property

This property sets the number of rows displayed in the Thumbnail Control.

[Visual Basic] Public Property RowNumber As Integer
[C#] public int RowNumber {get; set;}

Property Value

The default value is 2.

Explanation

The RowNumber property sets the number of rows displayed in the Thumbnail Control.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ShowFileName property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.ShowFileName Property

This property sets whether or not the file name of the image is displayed under the thumbnail image in the Thumbnail Control.

[Visual Basic] Public Property ShowFileName As Boolean
[C#] public bool ShowFileName {get; set;}

Property Value

This is a ButtonMode Enum value.

The default value is Hyperlink.

Explanation

The ShowFileName property sets whether or not the file name of the image is displayed under the thumbnail image in the Thumbnail Control. By clicking the file name under the thumbnail image, an event can be generated.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ShowFileNameText property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.ShowFileNameText Property

This property sets an xml file that allows seperate comments to be displayed under each thumbnail image.

[Visual Basic] Public Property ShowFileNameText String
[C#] public string ShowFileNameText {get; set;}

Property Value

The default value is "FileNameText.xml".

Explanation

The ShowFileNameText property sets an xml file that allows seperate comments to be displayed under each thumbnail image. The default name for this xml file is "FileNameText.xml". It should be placed in the same directory as the images whose comments it sets. The xml tags in the FileNameText.xml file must correspond to the file names of the images.

For example, if the following xml file, named "FileNameText.xml", exists in the same directory as these images "001.jpg", "abc.tif", "002.jpg", then the following comments will be displayed under the corresponding thumbnail images.

FileNameText.xml
<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<FileNameText>
<_001.jpg>Image_1</_001.jpg>
<abc.tif-1>Image_2</abc.tif-1>
<abc.tif-2>Image_3</abc.tif-2>
<_002.jpg>Image_4</_002.jpg>
</FileNameText>

Note: Because xml tags cannot contain a numeral as the first character, an underbar is added at the beginning of the xml tags for images "001.jpg" and "002.jpg". The Thumbnail Control will ignore the initial underbar in any tag within the FileNameText.xml file. Also, image abc.tif is a multipage tiff image. In the xml tag, the second page of this multipage tiff image is designated in as <abc.tif-1> and the third page is designated as <abc.tif-2> (The page index starts with 0).

Although we recommend that you keep the FileNameText.xml file in the same directory as the images that it modifies, it is possible to change the directory of the FileNameText.xml file. To do this, set a virtual path from the FileNameText.xmlfile to the directory containing the images that it modifies. In other words, setting the ShowFileNameText property to "/../../FileNameText.xml" means that the FileNameText.xml file is contained in the virtual directory two directories above the directory containing the images.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


SortDirection property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.SortDirection Property

This property sets the sort order for the thumbnail images.

[Visual Basic] Public Property SortDirection Sort
[C#] public Sort SortDirection {get; set;}

Property Value

This value a SortOrder Enum value.

The default value is Ascending.

Explanation

The SortDirection property sets the sort order for the thumbnail images. Please set this property before executing the ShowThumbnailImages method.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ThumbnailImageDirectory property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.ThumbnailImageDirectory Property

This property sets the path to the directory where the thumbnail images are created.

[Visual Basic] Public Property ThumbnailImageDirectory String
[C#] public string ThumbnailImageDirectory {get; set;}

Property Value

The default value is "".

This property must be set. If no value is set, the Thumbnail Control will be disabled.

Explanation

The ThumbnailImageDirectory property sets the path to the directory where the thumbnail images are created. When the Thumbnail Control loads the images specified by the ImageDirectory property, it creates thumbnail images and saves these thumbnails in the directory specifed by the ThumbnailImageDirectory property. If no value is set in this property, the Thumbnail Control will be disabled.

IMPORTANT: The directory specified as the thumbnail image directory must have write permission.

Note: The Thumbnail Control creates all thumbnail images in 24 bit JPEG format, this is true even for 1 bit color images and vector images. If the directory specified by the ThumbnailImageDirectory property does not exist or if the thumbnail image directory's datetime stamp is older than the image directory's datetime stamp, the thumbnail images will be (re)created.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


TotalImageNo property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.TotalImageNo Property

This property refers to the total number of thumbnail images.

[Visual Basic] Public ReadOnly Property TotalImageNo As Integer
[C#] public int TotalImageNo {get;}

Property Value

Read only

Explanation

The TotalImageNo property refers to the total number of thumbnail images.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


TotalPageNo property

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.TotalPageNo Property

This property refers to the number of pages of thumbnail images.

[Visual Basic] Public ReadOnly Property TotalPageNo As Integer
[C#] public int TotalPageNo {get;}

Property Value

Read only

Explanation

The TotalPageNo property refers to the number of pages of thumbnail images.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


DeleteThumbnailDirectory method

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.DeleteThumbnailDirectory Method

This method deletes the thumbnail directory and all of the thumbnail images it contains.

[Visual Basic] Public Function DeleteThumbnailDirectory() As Boolean
[C#] public bool DeleteThumbnailDirectory() ;

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The DeleteThumbnailDirectory method deletes the thumbnail directory and all of the thumbnail images it contains. It is not usually necessary to use this method unless you wish to force the thumbnail directory to be deleted. Under normal circumstances, the Thumbnail Control automatically deletes the thumbnail directory when thumbnail images are recreated.

Thumbnail images are automatically created when the ShowThumbnailImages method is executed and: the thumbnail directory does not exist; when the Thumbnail Control's ConfigFile has been changed; or when the thumbnail directory's timestamp is older then the image directory's timestamp. Since deleting and recreating thumbnail images produces a load on the server, please only use this method unless you need to force the thumbnail directory to be deleted.

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ShowThumbnailImages method

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.ShowThumbnailImages Method

This method displays thumbnail images in the Thumbnail Control.

[Visual Basic] Public Function ShowThumbnailImages() As Boolean Public Function ShowThumbnailImages(ByVal page As Integer) As Boolean
[C#]
public  bool ShowThumbnailImages() ;
public  bool ShowThumbnailImages(int page) ;

Parameters

page (optional) - the page of thumbnail images to be displayed in the Thumbnail Control

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The ShowThumbnailImages method displays the thumbnail images in the Thumbnail Control. When the EnablePaging property is true, the page parameter of this ShowThumbnailImages method is disabled and default paging is used. When the EnablePaging property is false the page parameter of the ShowThumbnailImages method can be used to display a particular page of thumbnail images. Use the SortDirection property to set the display order of the thumbnail images.

Note: Thumbnail images are automatically created when this method is executed and: 1. the thumbnail directory does not exist; 2. when the Thumbnail Control's ConfigFile has been changed; 3. when the thumbnail directory's timestamp is older then the image directory's timestamp.

Example

To display the previous page of thumbnail images:

[Visual Basic.NET]
page = page - 1
If page < 1 Then
    page = 1
End If
Thumbnail1.ShowThumbnailImages(page)

[Visual C#.NET]
page--;
if (page < 1)
    page = 1;
Thumbnail1.ShowThumbnailImages(page);

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


Click event

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.Click Event

This event is generated when a thumbnail image is clicked.

[Visual Basic]Public Event Click As EventHandler
[C#] public event EventHandler Click;

Explanation

The Click event is generated when a thumbnail image is clicked.

Example

This sample demonstrates how to show the file name selected in the Click event.

[Visual Basic.NET]
Private Sub Thumbnail1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles Thumbnail1.Click
  Label1.Text = Thumbnail1.FileName
End Sub

[Visual C#.NET]
private void Thumbnail1_Click(object sender, System.EventArgs e)
{
    Label1.Text = Thumbnail1.FileName;
}

Note:

When using the Thumbnail Control on one form and displaying the images in an ImageKit Control on another form, the Thumbnail Control's EnablePaging property should be set to False.

For Example: When a thumbnail image in the Thumbnail Control on WebForm1 is selected, display the image in the ImageKit Control on WebForm2....

[Visual Basic.NET]
Private Sub Thumbnail1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles Thumbnail1.Click
    Server.Transfer("WebForm2.aspx?str=" + Thumbnail1.ImageDirectory + "/" + Thumbnail1.FileName)
End Sub

[Visual C#.NET]
private void Thumbnail1_Click(object sender, System.EventArgs e)
{
    Response.Redirect("WebForm2.aspx?str=" + Thumbnail1.ImageDirectory + "/" + Thumbnail1.FileName, false);
}

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ShowThumbnail event

Newtone.ImageKit.Web

Newtone.ImageKit.Web.Thumbnail.ShowThumbnail Event

This event is generated just after a thumbnail image is displayed in the Thumbnail Control.

[Visual Basic]Public Event ShowThumbnail As EventHandler
[C#]public event EventHandler ShowThumbnail;

Explanation

This event is generated just after a thumbnail image is displayed in the Thumbnail Control

Example

Display the total number of images...

[Visual Basic.NET]
Private Sub Thumbnail1_ShowThumbnail(ByVal sender As Object, ByVal e As System.EventArgs) Handles Thumbnail1.ShowThumbnailImages
    Label1.Text = Thumbnail1.TotalImageNo.ToString()
End Sub

[Visual C#.NET]
private void Thumbnail1_ShowThumbnail(object sender, System.EventArgs e)
{
    Label1.Text = Thumbnail1.TotalImageNo.ToString();
}

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ButtonMode enum

Newtone.ImageKit.Web

Newtone.ImageKit.Web.ButtonMode Enum

This enumeration determines how the file name will be displayed under the thumbnail image in the Thumbnail Control.
public enum ButtonMode

Public Members

Member | Value | Explanation
None | 0 | The filename is not displayed
Label | 1 | The filename is displayed as a label
Hyperlink | 2 | The filename is displayed as a hyperlink (generates the Click event)
Button | 3 | The filename is displayed as a button (generates the Click event)

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


SortOrder enum

Newtone.ImageKit.Web

Newtone.ImageKit.Web.SortOrder Enum

This enumeration refers to the thumbnail sorting order.

public enum SortOrder

Public Members

Member | Value | Explanation
None | 0 | Does not sort
Ascending | 1 | Ascending
Descending | 2 | Descending

See Also

Thumbnail Members | Newtone.ImageKit.Web.Thumbnail


ScanMode enum

Newtone.ImageKit

Newtone.ImageKit.Error Enum

This enumeration refers to the type of error that has occurred in the ImageKit Control.

public enum Error

Public Members

Member | Value | Explanation
None | 0 | No error has occurred
Cancel | 1 | The process was canceled
ETC | 2 | An unspecified error has occurred
Memory | 3 | A memory error has occurred
Support | 4 | This function is not supported
Value | 5 | An incorrect value has been set
File | 6 | The file is incorrect or corrupted
Image | 7 | The image is incorrect or corrupted
Twain32Load | 8 | Twain_32.dll can not load
Draw | 9 | An error has occurred while drawing on or displaying an image
ImageSupport | 10 | That image format is not supported
Step | 11 | The order of execution is incorrect
ADFNoPaper | 12 | There is no paper in the ADF
DigitalCameraNoImage | 13 | There are no images in the digital camera (UI suppressed only)
DllUnload | 14 | The DLL is not loaded
Trans | 15 | Transmission error
FileNotFound | 16 | Cannot find file
FileCorrupt | 17 | The file is corrupted
Timeover | 18 | A timeout has occurred. The process has been cancelled
TransDenied | 19 | The username and/or password is incorrect. Access denied.
FileOpen | 20 | Cannot open file
FileCreate | 21 | Cannot create file
FileWrite | 22 | Cannot save file
FileRead | 23 | Cannot load file
NoImage | 24 | There is no image data to display
DirectoryCreate | 25 | Cannot create directory
ThumbnailConfigFile | 50 | ConfigFile has not been set
ThumbnailImageDirectory | 51 | ImageDirectory has not been set
ThumbnailThumbImageDirectory | 52 | ThumbnailImageDirectory has not been set
ThumbnailImageFileExtension | 53 | ImageFileExtension has not been set
ThumbnailImageWidth | 54 | Image width has not been set
ThumbnailImageHeight | 55 | Image height has not been set
Twain32Entry | 101 | There is no entry point for the Twain_32.dll
DsmOrDsOpen | 102 | The data source manager and the data source haven't been opened or can't be open
NoDataSource | 103 | There is no data source
MaxConnections | 104 | The data source is already connected to the maximum number of applications
Operation | 105 | An error has occurred in the data source or in the data source manager
BadProtocol | 106 | An unconfirmed triplet has occurred (TWAIN - DG_XXX/DAT_XXX/MSG_XXX)
DeviceOnline | 107 | Check the scan device's power source
PaperJam | 108 | Paper is jammed in the feeder
PaperDoubleFeed | 109 | Multiple sheets of paper have been fed into the feeder
BadResolution | 110 | The resolution is incorrect
TrialExpired | 900 | The trial version has been expired


ScanNoiseFilter enum

Newtone.ImageKit

Newtone.ImageKit.AreaSelectMode Enum

This enumeration refers to the type of area that will be processed on the image.

public enum AreaSelectMode

Public Members

Member | Value | Explanation
EffectMask | 0 | A mask handle is used to determine the area to be processed. (The value set in the SourceMask property is enabled)
EffectAll | 1 | The total image is processed
EffectPolygon | 2 | A polygonal area, selected on the image, is processed. (The value set in the Point property is enabled)
EffectEllipse | 3 | An elliptical shape, selected on the image, is processed. (The value set in the Rect property is enabled)

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


ScanNoiseFilter enum

Newtone.ImageKit

Newtone.ImageKit.InOutSelectMode Enum

This enumeration determines whether the area inside the selected area will be processed or the area outside the selected area will be processed.

public enum InOutSelectMode

Public Members

Member | Value | Explanation
Outside | 0 | The area outside the selected area will be processed (does not include the border)
Inside | 1 | The area inside the selected area will be processed (includes the border)

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


JpegSubsamplingKind enum

Newtone.ImageKit

Newtone.ImageKit.JpegSubsamplingKind Enum

This enumeration refers to the type of YCrCb subsampling used when images are saved in JPEG format.

public enum JpegSubsamplingKind

Public Members

Member | Value | Explanation
JS411 | 0 | Y:Cr:Cb 4:1:1
JS422 | 1 | Y:Cr:Cb 4:2:2
JS444 | 2 | Y:Cr:Cb 4:4:4

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


LoadFileType enum

Newtone.ImageKit

Newtone.ImageKit.LoadFileType Enum

This enumeration refers to the type of image format that can be loaded.

public enum LoadFileType

Public Members

Member | Value | Explanation
Load | 0 | All supported types
LoadBMP | 1 | BMP
LoadJPEG | 2 | JPEG
LoadGIF | 3 | GIF
LoadTIFF | 4 | TIFF
LoadPNG | 5 | PNG
LoadFPX | 6 | FPX
LoadPCX | 7 | PCX
LoadWMF | 8 | WMF
LoadEMF | 9 | EMF
LoadDXF | 10 | DXF
LoadSVG | 11 | SVG
LoadJPEG2000 | 12 | JPEG2000
LoadSXFP21 | 13 | SXF p21
LoadSXFSFC | 14 | SXF sfc

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


SaveFileType enum

Newtone.ImageKit

Newtone.ImageKit.SaveFileType Enum

This enumeration refers to the type of format the image will be saved.

public enum SaveFileType

Public Members

Member | Value | Explanation
SaveBMP | 0 | BMP - Uncompressed
SaveBMPRLE | 1 | BMP - Compressed
SaveJPEG | 2 | JPEG - Standard DCT
SaveJPEGProgress | 3 | JPEG - Progressive DCT
SaveGIF | 4 | GIF
SaveTIFFNoncompressed | 5 | TIFF - Uncompressed
SaveTIFFCcittrle | 6 | TIFF Ccittrle
SaveTIFFGroup3_1D | 7 | TIFF Group3-1D
SaveTIFFGroup3_2D | 8 | TIFF Group3-2D
SaveTIFFGroup4 | 9 | TIFF Group4
SaveTIFFPackbits | 10 | TIFF Packbits
SaveTIFFLZW | 11 | TIFF LZW
SavePNG | 12 | PNG
SaveFPXNoncompressed | 13 | FPX - Uncompressed
SaveFPXSingleColor | 14 | FPX - Single Color Compressed
SaveFPXJpeg | 15 | FPX - JPEG Compression
SavePCX | 16 | PCX
SaveWMF | 17 | WMF
SaveEMF | 18 | EMF
SaveDXF | 19 | DXF
SaveSVG | 20 | SVG
SaveJPEG2000 | 21 | JPEG2000 Part1
SaveJPEG2000Stream | 22 | JPEG2000 Code Stream
SaveSXFP21 | 23 | SXF p21
SaveSXFSFC | 24 | SXF sfc

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


TiffColorSpaceKind enum

Newtone.ImageKit

Newtone.ImageKit.TiffColorSpaceKind Enum

This enumeration refers to the type of full color mode when saving images in TIFF format.

public enum TiffColorSpaceKind

Public Members

Member | Value | Explanation
RGB | 0 | RGB
CMYK | 1 | CMYK

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


TypeOfFile enum

Newtone.ImageKit

Newtone.ImageKit.TypeOfFile Enum

This enumeration refers to the type of image format
public enum TypeOfFile

Public Members

Member | Value | Explanation
TypeBMP | 1 | BMP
TypeBMPRLE4 | 2 | BMP RLE4
TypeBMPRLE8 | 3 | BMP RLE8
TypeJPEG | 4 | JPEG - Standard DCT
TypeJPEGProgress | 5 | JPEG - Progressive DCT
TypeGIF | 6 | GIF
TypeGIF89 | 7 | GIF 89a
TypeTIFFNoncompressed | 8 | TIFF - Uncompressed
TypeTIFFCcittrle | 9 | TIFF Ccittrle
TypeTIFFGroup3_1D | 10 | TIFF Group3-1D
TypeTIFFGroup3_2D | 11 | TIFF Group3-2D
TypeTIFFGroup4 | 12 | TIFF Group4
TypeTIFFPackbits | 13 | TIFF Packbits
TypeTIFFLZW | 14 | TIFF LZW
TypePNG | 15 | PNG
TypeFPXNoncompressed | 16 | FPX - Uncompressed
TypeFPXSingleColor | 17 | FPX - Single Color Compressed
TypeFPXJpeg | 18 | FPX - JPEG Compression
TypePCX | 19 | PCX
TypeWMF | 20 | WMF
TypeEMF | 21 | EMF
TypeDXF | 22 | DXF
TypeEXIF | 23 | Exif (JPEG)
TypeSVG | 24 | SVG
TypeJPEG2000 | 25 | JPEG2000 Part1
TypeJPEG2000Stream | 26 | JPEG2000 Code Stream
TypeSXFP21 | 27 | SXF p21
TypeSXFSFC | 28 | SXF sfc

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


CapabilityRange Members

Newtone.ImageKit

Newtone.ImageKit.CapabilityRange All Members

CapabilityRange Overview

Constructor

CapabilityRange Constructor Initializes a new instance of the CapabilityRange class

Public Properties

Current | Refers to the current setting for a specified functionality
Default | Refers to the default setting for a specified functionality
Maximum | Refers to the maximum setting for a specified functionality
Minimum | Refers to the minimum setting for a specified functionality
Step | Refers to a range of possible setting values for the specified functionality

See Also

Scan Members | Newtone.ImageKit


Current property

Newtone.ImageKit

Newtone.ImageKit.CapabilityRange.Current Property

This property refers to the current setting for a specified functionality as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

[Visual Basic] Public ReadOnly Property Current As Single
[C#] public float Current {get;}

Property Value

The current setting for that functionality

Explanation

The RangeCurrent property refers to the current setting for a specified functionality as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

See Also

CapabilityRange Members | Newtone.ImageKit.Win.ImageKit


Default property

Newtone.ImageKit

Newtone.ImageKit.CapabilityRange.Default Property

This property refers to the default setting for a specified functionality as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

[Visual Basic] Public ReadOnly Property Default As Single
[C#] public float Default {get;}

Property Value

The default setting for that functionality. (The setting when the device is turned on.)

Explanation

The RangeDefault property refers to the default setting for a specified functionality as retrieved by the the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

See Also

CapabilityRange Members | Newtone.ImageKit.Win.ImageKit


Maximum property

Newtone.ImageKit

Newtone.ImageKit.CapabilityRange.Maximum Property

This property refers to the maximum setting for a specified functionality as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

[Visual Basic] Public ReadOnly Property Maximum As Single
[C#] public float Maximum {get;}

Property Value

The maximum setting for that functionality

Explanation

The Maximum property refers to the maximum setting for a specified functionality as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

See Also

CapabilityRange Members | Newtone.ImageKit.Win.ImageKit


Minimum property

Newtone.ImageKit

Newtone.ImageKit.CapabilityRange.Minimum Property

This property refers to the minimum setting for a specified functionality as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

[Visual Basic] Public ReadOnly Property Minimum As Single
[C#] public float Minimum {get;}

Property Value

The minimum setting for that functionality

Explanation

The Minimum property refers to the minimum setting for a specified functionality as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method.

See Also

CapabilityRange Members | Newtone.ImageKit.Win.ImageKit


Step property

Newtone.ImageKit

Newtone.ImageKit.CapabilityRange.Step Property

This property refers to the information retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method, which can retrieve a range of possible setting values for the specified functionality in the scan device.

[Visual Basic] Public ReadOnly Property Step As Single
[C#] public float Step {get;}

Property Value

The size of the steps in the settings from Minimum to Maximum

Explanation

The Step property refers to the information retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCapabilityRange method, which can retrieve a range of possible setting values for the specified functionality in the scan device.

See Also

CapabilityRange Members | Newtone.ImageKit.Win.ImageKit


DataSourceInformation Members

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation All Members

DataSourceInformation Overview

Constructor

DataSourceInformation Constructor Initializes a new instance of the DataSourceInformation class

Public Properties

Information | Refers to the scan device's version information
MajorVersion | Refers to the major version number of the scan device
Manufacturer | Refers to to the scan device manufacturer's name
MinorVersion | Refers to the minor version number of the scan device
ProductFamily | Refers to the scan device product family name
ProductName | Refers to the scan device product name
ProtocolMajor | Refers to the TWAIN major version number
ProtocolMinor | Refers to the TWAIN minor version number

See Also

Scan Members | Newtone.ImageKit


Information property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.Information Property

This property refers to the scan device's version information as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property Information As String
[C#] public string Information {get;}

Property Value

The scan device's version information

Explanation

The SourceVersionInfo property refers to the scan device's version information as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


MajorVersion property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.MajorVersion Property

This property refers to various information about the scan device as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property MajorVersion As Integer
[C#] public int MajorVersion {get;}

Property Value

The major version number of the scan device

Explanation

This property refers to various information about the scan device as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


Manufacturer property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.Manufacturer Property

This property refers to to the scan device manufacturer's name as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property Manufacturer As String
[C#] public string Manufacturer {get;}

Property Value

The scan device manufacturer's name

Explanation

The Manufacturer property refers to various information about the scan device as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


MinorVersion property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.MinorVersion Property

This property refers to the minor version number of the scan device as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property MinorVersion As Integer
[C#] public int MinorVersion {get;}

Property Value

The minor version number of the scan device

Explanation

The MinorVersion property refers to the minor version number of the scan device as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


ProductFamily property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.ProductFamily Property

This property refers to the scan device product family name as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property ProductFamily As String
[C#] public string ProductFamily {get;}

Property Value

The scan device product family name

Explanation

This property refers to the scan device product family name as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


ProductName property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.ProductName Property

This property refers to the scan device product name as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property ProductName As String
[C#] public string ProductName {get;}<

Property Value

The scan device product name

Explanation

The ProductName property refers to the scan device product name as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


ProtocolMajor property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.ProtocolMajor Property

This property refers to the TWAIN major version number as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property ProtocolMajor As Integer
[C#] public int ProtocolMajor {get;}

Property Value

The the major version number of the TWAIN specification supported by the scan device

Explanation

The ProtocolMajor property refers to the TWAIN major version number as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


ProtocolMinor property

Newtone.ImageKit

Newtone.ImageKit.DataSourceInformation.ProtocolMinor Property

This property refers to the TWAIN minor version number as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

[Visual Basic] Public ReadOnly Property ProtocolMinor As Integer
[C#] public int ProtocolMinor {get;}

Property Value

The minor version number of the TWAIN specification supported by the scan device

Explanation

The ProtocolMinor property refers to the TWAIN minor version number as retrieved by the Newtone.ImageKit.Win.ImageKit.Scan.GetCurrentDataSource method or the Newtone.ImageKit.Win.ImageKit.Scan.GetDataSources method.

See Also

DataSourceInformation Members | Newtone.ImageKit.Win.ImageKit


ScanBitDepthReduction enum

Newtone.ImageKit

Newtone.ImageKit.ScanBitDepthReduction Enum

This enumeration refers to the method used to reduce the bit depth when scanning in 1 bit color.

public enum ScanBitDepthReduction

Public Members

Member | Value | Explanation
Threshold | 0 | Threshold
Halftone | 1 | Halftone
CustomHalftone | 2 | Custom halftone *1
Diffusion | 3 | Diffusion

Explanation

*1 This is a TWAIN setting that is not supported by the ImageKit.NET.

See Also

Scan Members | Newtone.ImageKit


ScanCapability enum

Newtone.ImageKit

Newtone.ImageKit.ScanCapability Enum

This enumeration refers to the type of scan capability.

public enum ScanCapability

Public Members

Member | Value | Explanation
Compression | 256 | Compression method
PixelType | 257 | Pixel type
Unit | 258 | The units of measurement
Transfer | 259 | Transfer method
FeederEnabled | 4098 | Document feeder function
FeederLoaded | 4099 | The function that checks whether or not there is paper in the document feeder
Indicator | 4423 | Indicator
UIControllable | 4110 | UI control function
DeviceOnline | 4111 | The function that checks whether the power is on
ThumbnailEnabled | 4113 | The function that transfers thumbnail images
Duplex | 4114 | Duplex scanning with the document feeder
Brightness | 4353 | Brightness
Contrast | 4355 | Contrast
Gamma | 4360 | Gamma
Halftone | 4361 | Halftone
Highlight | 4362 | Highlight
ImageFileFormat | 4364 | ImageFileFormat
DropoutColor | 4366 | DropoutColor
Orientation | 4368 | Paper orientation
Shadow | 4371 | Shadow
XResolution | 4376 | The horizontal scan resolution
YResolution | 4377 | The vertical scan resolution
PaperSize | 4386 | PaperSize
Threshold | 4387 | Threshold
XScaling | 4388 | The horizontal scaling
YScaling | 4389 | The vertical scaling
BitDepthReduction | 4396 | The method used to reduce the bit depth when scanning in 1 bit color
UndefinedImageSize | 4397 | The undefined size
ImageDataSet | 4398 | How many images are in a digital camera
ImageFilter | 4423 | ImageFilter
NoiseFilter | 4424 | NoiseFilter
BorderDetection | 4432 | BorderDetection
Deskew | 4433 | Deskew
JpegQuality | 4435 | JpegQuality
ScanningSpeed | 61441 | ScanningSpeed
MoireFilter | 61442 | MoireFilter
MoireFilterMaxResolution | 61443 | The maximum resolution when using a moire filter
Sharpness | 61444 | Sharpness
RotateBack | 61445 | RotateBack when using ADF in duplex mode
ExtendedUserInterface | 61446 | ExtendedUserInterface
DynamicThreshold | 61447 | DynamicThreshold
PixelAutomation | 61448 | Automatically detecting ratio of BW/Color
MultiStream | 61449 | MultiStream
TextOrientationRecognition | 61450 | Automatically recognizes orientation from text.

See Also

Scan Members | Newtone.ImageKit


ScanCompression enum

Newtone.ImageKit

Newtone.ImageKit.ScanCompression Enum

This enumeration refers to the compression method used when an image is transferred via memory.

public enum ScanCompression

Public Members

Member | Value | Explanation
None | 0 | Uncompressed
Packbits | 1 | PACKBITS (TIFF or PICT)
Group3_1D | 2 | GROUP3 1D (TIFF)
Group3_1D_EOL | 3 | GROUP3 1D End Of Line (TIFF)
Group3_2D | 4 | GROUP3 2D (TIFF)
Group4 | 5 | GROUP4 (TIFF)
Jpeg | 6 | JPEG (TIFF or JFIF or SPIFF)
Lzw | 7 | LZW (TIFF)
Jbig | 8 | JBIG (TIFF or SPIFF)
Png | 9 | PNG
Rle4 | 10 | RLE4 (BMP)
Rle8 | 11 | RLE8 (BMP)
BitFields | 12 | BITFIELDS (BMP)

Explanation

The values 2, 3, 4, and 5 are in FAX[CCITT] format. The values 10, 11 and 12 are in BMP format. Parenthesis () in the explanation section refers to the image file format when the file is transferred.

See Also

Scan Members | Newtone.ImageKit


ScanDropoutColor enum

Newtone.ImageKit

Newtone.ImageKit.ScanDropoutColor Enum

This enumeration refers to the dropout color.

public enum ScanDropoutColor

Public Members

Member | Value | Explanation
Red | 0 | Red
Green | 1 | Green
Blue | 2 | Blue
None | 3 | None
White | 4 | White
UV | 5 |
IR | 6 |

See Also

Scan Members | Newtone.ImageKit


ScanFileFormat enum

Newtone.ImageKit

Newtone.ImageKit.ScanFileFormat Enum

This enumeration refers to the file format when saving a file using file transfer.

public enum ScanFileFormat

Public Members

Member | Value | Explanation
Tiff | 0 | TIFF
Pict | 1 | PICT
Bmp | 2 | BMP
Xbm | 3 | XBM
Jfif | 4 | JPEG
Fpx | 5 | FlashPix
TiffMulti | 6 | TIFF Multi
Png | 7 | PNG
Spiff | 8 | JPEG, JBIG
Exif | 9 | EXIF

See Also

Scan Members | Newtone.ImageKit


ScanImageFilter enum

Newtone.ImageKit

Newtone.ImageKit.ScanImageFilter Enum

This enumeration refers to the image filter.

public enum ScanImageFilter

Public Members

Member | Value | Explanation
None | 0 | None
Auto | 1 | Automation
LowPass | 2 | LOWPASS is recommended for haftone images
BandPass | 3 | BANDPASS is recommended for images that include text
HighPass | 4 | HIGHPASS is recommended for images that include lines
Text | 3 | BANDPASS is recommended for images that include text
FineLine | 4 | HIGHPASS is recommended for images that include lines

See Also

Scan Members | Newtone.ImageKit


ScanMode enum

Newtone.ImageKit

Newtone.ImageKit.ScanMode Enum

This enumeration refers to the scanning mode.

public enum ScanMode

Public Members

Member | Value | Explanation
DocumentPlate | 0 | Document plate
ADFOneSide | 1 | ADF Simplex
ADFBothSide | 2 | ADF Duplex
Camera | 3 | The original images in the digital camera
CameraArray | 4 | The original images in the digital camera (using an array)
CameraThumbnail | 5 | The thumbnail images in the digital camera
CameraThumbnailArray | 6 | The thumbnail images in the digital camera (using an array)

See Also

Scan Members | Newtone.ImageKit


ScanNoiseFilter enum

Newtone.ImageKit

Newtone.ImageKit.ScanNoiseFilter Enum

This enumeration refers to the noise reduction filter.

public enum ScanNoiseFilter

Public Members

Member | Value | Explanation
None | 0 | None
Auto | 1 | Automatic
LonePixel | 2 |
MajorityRule | 3 |

See Also

Scan Members | Newtone.ImageKit


ScanOrientation enum

Newtone.ImageKit

Newtone.ImageKit.ScanOrientation Enum

This enumeration refers to the orientation of the paper.

public enum ScanOrientation

Public Members

Member | Value | Explanation
Rotate0 | 0 | 0 degrees
Rotate90 | 1 | 90 degrees
Rotate180 | 2 | 180 degrees
Rotate270 | 3 | 270 degrees
Portrait | 0 | Portrait
Landscape | 3 | Landscape
TextOrientationRecognition | 1000 | Automatically recognizes orientation from text. *1

Explanation

TextOrientationRecognition detects the text orientation in scanned images and rotates the images in 90 degree increments to normalize text orientation

*1 Enabled for certain Canon DR scan drivers.

See Also

Scan Members | Newtone.ImageKit


ScanPaperSize enum

Newtone.ImageKit

Newtone.ImageKit.ScanPaperSize Enum

This enumeration refers to the size of the paper.

public enum ScanPaperSize

Public Members

Member | Value | Explanation
UserSize | 0 | User defined size
A4Letter | 1 | A4 letter 210mm x 297mm
B5Letter | 2 | B5 letter 182mm x 257mm
USLetter | 3 | US letter 8.5" x 11.0" (216mm x 280mm)
USLegal | 4 | US legal 11.0" x 17.0" (216mm x 356mm)
A5 | 5 | A5 148mm x 210mm
B4 | 6 | ISO B4 250mm x 353mm
B6 | 7 | ISO B6 125mm x 176mm
USLedger | 9 | US ledger 11.0" x 17.0" (280mm x 432mm)
USExecutive | 10 | US exective 7.25" x 10.5" (184mm x 267mm)
A3 | 11 | A3 297mm x 420mm
B3 | 12 | ISO B3 353mm x 500mm
A6 | 13 | A6 105mm x 148mm
C4 | 14 | C4 229mm x 324mm
C5 | 15 | C5 162mm x 229mm
C6 | 16 | C6 114mm x 162mm
FourA0 | 17 | 4A0 1682mm x 2378mm
TwoA0 | 18 | 2A0 1189mm x 1682mm
A0 | 19 | A0 841mm x 1189mm
A1 | 20 | A1 594mm x 841mm
A2 | 21 | A2 420mm x 594mm
A4 | 1 | A4 210mm x 297mm
A7 | 22 | A7 74mm x 105mm
A8 | 23 | A8 52mm x 74mm
A9 | 24 | A9 37mm x 52mm
A10 | 25 | A10 26mm x 37mm
ISOB0 | 26 | ISO B0 1000mm x 1414mm
ISOB1 | 27 | ISO B1 707mm x 1000mm
ISOB2 | 28 | ISO B2 500mm x 707mm
ISOB3 | 12 | ISO B3 353mm x 500mm
ISOB4 | 6 | ISO B4 250mm x 353mm
ISOB5 | 29 | ISO B5 176mm x 250mm
ISOB6 | 7 | ISO B6 125mm x 176mm
ISOB7 | 30 | ISO B7 88mm x 125mm
ISOB8 | 31 | ISO B8 62mm x 88mm
ISOB9 | 32 | ISO B9 44mm x 62mm
ISOB10 | 33 | ISO B10 31mm x 44mm
JISB0 | 34 | JIS B0 1030mm x 1456mm
JISB1 | 35 | JIS B1 728mm x 1030mm
JISB2 | 36 | JIS B2 515mm x 728mm
JISB3 | 37 | JIS B3 364mm x 515mm
JISB4 | 38 | JIS B4 257mm x 364mm
JISB5 | 2 | JIS B5 182mm x 257mm
JISB6 | 39 | JIS B6 128mm x 182mm
JISB7 | 40 | JIS B7 91mm x 128mm
JISB8 | 41 | JIS B8 64mm x 91mm
JISB9 | 42 | JIS B9 45mm x 64mm
JISB10 | 43 | JIS B10 32mm x 45mm
C0 | 44 | C0 917mm x 1297mm
C1 | 45 | C1 648mm x 917mm
C2 | 46 | C2 458mm x 648mm
C3 | 47 | C3 324mm x 458mm
C7 | 48 | C7 81mm x 114mm
C8 | 49 | C8 57mm x 81mm
C9 | 50 | C9 40mm x 57mm
C10 | 51 | C10 28mm x 40mm
USStatement | 52 | US statement 5.5" x 8.5" (140mm x 216mm)
BusinessCard | 53 | Business card 90mm x 55mm
UndefinedSize | 1000 | Undefined size

See Also

Scan Members | Newtone.ImageKit


ScanPixelType enum

Newtone.ImageKit

Newtone.ImageKit.ScanPixelType Enum

This enumeration refers to the type of image scanned.

public enum ScanPixelType

Public Members

Member | Value | Explanation
BW | 0 | Black and White
Gray | 1 | Grayscale
RGB | 2 | RGB color
Palette | 3 | Palette color
CMY | 4 | CMY color *1
CMYK | 5 | CMYK color *1
YUV | 6 | YUV color *1
YUVK | 7 | YUVK color *1
CIEXYZ | 8 | CIEXYZ color *1
Automation | 1000 | Automation (1 bit or 24 bit) *2, *3
GrayAndBW | 1001 | Black and White 1 bit Color and Grayscale *2
RGBAndBW | 1002 | Black and White 1 bit Color and RGB *2

Explanation

Automation distinguishes between "black and white" or RGB color when scanning the document plate. GrayAndBW and RGBAndBW scans one document in both Black and White and in either Grayscale or RGB color. The scan order is first Grayscale or RGB and then Black and White.

*1 Not supported when the UserInterface property is suppressed.
*2 Enabled for certain Panasonic scanners.
*3 Enabled for certain Canon DR scanners.

See Also

Scan Members | Newtone.ImageKit


ScanTransfer enum

Newtone.ImageKit

Newtone.ImageKit.ScanTransfer Enum

This enumeration refers to the scan transfer method.

public enum ScanTransfer

Public Members

Member | Value | Explanation
Native | 0 | Native (Transferred as DIB)
File | 1 | File
Memory | 2 | Memory (Transferred in block units)
File2 | 3 | File2 *

Explanation

* The ImageKit does not support transfer method 3

See Also

Scan Members | Newtone.ImageKit


ScanUnit enum

Newtone.ImageKit

Newtone.ImageKit.ScanUnit Enum

This enumeration refers to the scan units of measurement.

public enum ScanUnit

Public Members

Member | Value | Explanation
Inch | 0 | Inches
Centimeter | 1 | Centimeters
Pica | 2 | Pica
Point | 3 | Points
Twip | 4 | twips
Pixel | 5 | Pixels

See Also

Scan Members | Newtone.ImageKit


ScanUserInterface enum

Newtone.ImageKit

Newtone.ImageKit.ScanUserInterface Enum

This enumeration refers to the scan driver's user interface and whether it will displayed, displayed and closed, or totally suppressed.
public enum ScanUserInterface

Public Members

Member | Value | Explanation
Show | 0 | The scan driver's user interface is displayed. It is not closed after the scan is complete
ShowandClose | 1 | The scan driver's user interface is displayed. It is closed after the scan is complete
Suppress | 2 | The scan driver's user interface is totally suppressed. A custom built user interface will be used

See Also

Scan Members | Newtone.ImageKit


AfterScanEventArgs class

Newtone.ImageKit

Newtone.ImageKit.AfterScanEventArgs Class

This class exposes properties for the AfterScan event.

[Visual Basic] Public Class AfterScanEventArgs Inherits System.EventArgs
[C#] public class AfterScanEventArgsFSystem.EventArgs

Explanation

Property | Type | Explanation
Bitmap1 | System.Drawing.Bitmap | Retrieves the Bitmap Class for storing 1, 4, 8, and 24 bit images. During file transfers, this is null (Nothing in Visual Basic)
Bitmap2 | System.Drawing.Bitmap | Retrieves the Bitmap Class for storing 16 bit grayscale and 48 bit images. During file transfers, this is null (Nothing in Visual Basic)
BitOrder | [Visual Basic] Integer [C#] int | Refers to whether the bits in each byte of the scanned image start from the left or start from the right. 0: Start from the right (LSB), 1: Start from the left (MSB)
Cancel | [Visual Basic] Boolean [C#] bool | Sets whether or not the scan process is canceled. By setting this property to True, the process can be canceled.
FileName | [Visual Basic] String [C#] string | Sets the file name when saving a file using file transfer
ImageNumber | [Visual Basic] Integer [C#] int | The number of images scanned
RawData | [Visual Basic] Byte() [C#] byte[] | Retrieves the scanned data (byte array) when using memory transfer compression mode. This is null (Nothing in Visual Basic) when using native transfer or uncompression file transfer

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


BeforeScanEventArgs class

Newtone.ImageKit

Newtone.ImageKit.BeforeScanEventArgs Class

This class exposes properties for the BeforeScan event.

[Visual Basic] Public Class BeforeScanEventArgs Inherits System.EventArgs
[C#] public class BeforeScanEventArgsFSystem.EventArgs

Explanation

Property | Type | Explanation
BitDepth | [Visual Basic] Integer [C#] int | Retrieves the number of bits per pixel. Note: 12 and 14 grayscale will be resolved to 16 bits; 36 and 42 bit color will be resolved to 48 bits.
Cancel | [Visual Basic] Boolean [C#] bool | Sets whether or not the scan process is canceled. By setting this property to True, the process can be canceled.
Compression | Newtone.ImageKit.ScanCompression | Sets the compression method used when an image is transferred via memory
Height | [Visual Basic] Integer [C#] int | The height of the image that will be transferred in pixels
ImageNumber | [Visual Basic] Integer [C#] int | Refers to the number of images that have been scanned
PixelType | Newtone.ImageKit.ScanPixelType | Sets the type of image scanned
Width | [Visual Basic] Integer [C#] int | The width of the image that will be transferred in pixels
XResolution | [Visual Basic] Single [C#] float | Sets the horizontal scan resolution *1
YResolution | [Visual Basic] Single [C#] float | Sets the vertical scan resolution *1

*1

Although the TWAIN specifications allow scan units to be inches or centimeters, depending on the datasource (scan device) the scan units settings are ignored and DPI is used. Furthermore, if scan units are set to pixels, there are cases where the datasource will return a value of 1 in these resolution properties.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


DispEventArgs class

Newtone.ImageKit.Win.ImageKit.DispEventArgs Class

This class exposes properties for the StartDispImage and EndDispImage events.

[Visual Basic] Public Class DispEventArgs Inherits EventArgs
[C#] public class DispEventArgsF EventArgs

Explanation

Property | Type | Explanation
OriginX | Integer (Visual Basic) int (C#) | The horizontal distance from the left side of the ImageKit Control to the left side of the image. (If the image is larger than the ImageKit Control in the horizontal direction, OriginX will equal 0.)
OriginY | Integer (Visual Basic) int (C#) | The vertical distance from the top of the ImageKit Control to the top of the image. (If the image is larger than the ImageKit Control in the vertical direction, OriginY will equal 0.)
Left | Integer (Visual Basic) int (C#) | The horizontal distance from the left side of the actual image to the left side of that portion of the image currently being displayed.
Top | Integer (Visual Basic) int (C#) | The vertical distance from the top of the actual image to the top of that portion of the image currently being displayed.
Right | Integer (Visual Basic) int (C#) | The horizontal distance from the left side of the actual image to the right side of that portion of the image currently being displayed.
Bottom | Integer (Visual Basic) int (C#) | The vertical distance from the top of the actual image to the top of that portion of the image currently being displayed.
ScaleWidth | Double (Visual Basic) double (C#) | The horizontal scale between the displayed portion of the image and the actual image.
ScaleHeight | Double (Visual Basic) double (C#) | The vertical scale between the original image and the displayed image.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


FileEventArgs class

Newtone.ImageKit.Win.ImageKit.FileEventArgs Class

This class exposes properties for the StartLoad, EndLoad, StartSave, EndSave, and the GetDragDropFileName events.

[Visual Basic] Public Class FileEventArgs Inherits EventArgs
[C#] public class FileEventArgsF EventArgs

Explanation

Property | Type | Explanation
FileName | String (Visual Basic) string(C#) | Sets the name of the image file (full path) to be loaded, saved, or dragged and dropped

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


FilePageEventArgs class

Newtone.ImageKit.Win.ImageKit.FileEventArgs Class

This class exposes properties for the GetDragDropFileName event.

[Visual Basic] Public Class FilePageEventArgs Inherits EventArgs
[C#] public class FilePageEventArgsF EventArgs

Explanation

Property | Type | Explanation
FileName | String (Visual Basic) string (C#) | Retrieves the filename of the file dropped into the ImageKit Control
Page | Integer (Visual Basic) int (C#) | Retrieves the page number of the multipage image file. (starts from 0)

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseButtonEventArgs class

Newtone.ImageKit.Win.ImageKit.MouseButtonEventArgs Class

This class exposes properties for the MagnifierMouseDown, MagnifierMouseMove, and MagnifierMouseUp events.

[Visual Basic] Public Class MouseButtonEventArgs Inherits EventArgs
[C#] public class MouseButtonEventArgsF EventArgs

Explanation

Property | Type | Explanation
Button | Integer (Visual Basic) int (C#) | The type of button clicked (1: Left Button, 2: Right Button, 4: Center Button)
Shift | Integer (Visual Basic) int (C#) | The type of key pressed (0: None, 1: Shift Key, 2: Ctrl Key, 4: Alt Key)
X | Integer (Visual Basic) int (C#) | X coordinates for the center of the Magnifier (in pixcels)
Y | Integer (Visual Basic) int (C#) | Y coordinates for the center of the Magnifier (in pixcels)

If multiple keys are pressed, the values of Shift are combined in a bitwise OR operation.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseSelectEventArgs class

Newtone.ImageKit.Win.ImageKit.MouseSelectEventArgs Class

This class exposes properties for the MouseDownSelectLayerImage and MouseUpSelectLayerImage events.

[Visual Basic] Public Class MouseSelectEventArgs Inherits EventArgs
[C#] public class MouseSelectEventArgsF EventArgs

Explanation

Property | Type | Explanation
Index | integer (Visual Basic) int (C#) | Retrieves the index (from 0 to 99) of the layer-interface image that exists in the location where the mouse button was pressed (or released)
X | integer (Visual Basic) int (C#) | Retrieves the horizontal offset (in pixels) of the layer-interface image referred to by the Index parameter
Y | integer (Visual Basic) int (C#) | Retrieves the vertical offset (in pixels) of the layer-interface image referred to by the Index parameter

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseUpDownEventArgs class

Newtone.ImageKit.Win.ImageKit.MouseUpDownEventArgs Class

This class exposes properties for the MouseDownImage, MouseMoveImage, and MouseUpImage events.

[Visual Basic] Public Class MouseUpDownEventArgs Inherits EventArgs
[C#] public class MouseUpDownEventArgsF EventArgs

Explanation

Property | Type | Explanation
Button | Integer (Visual Basic) int (C#) | The type of button clicked (1: Left Button, 2: Right Button, 4: Center Button)
Shift | Integer (Visual Basic) int (C#) | The type of key pressed (0: None, 1: Shift Key, 2: Ctrl Key, 4: Alt Key)
OriginX | Integer (Visual Basic) int (C#) | The horizontal distance from the left side of the ImageKit Control to the left side of the image. (If the image is larger than the ImageKit Control in the horizontal direction, OriginX will equal 0.)
OriginY | Integer (Visual Basic) int (C#) | The vertical distance from the top of the ImageKit Control to the top of the image. (If the image is larger than the ImageKit Control in the vertical direction, OriginY will equal 0.)
Left | Integer (Visual Basic) int (C#) | The horizontal distance from the left side of the actual image to the left side of that portion of the image currently being displayed .
Top | Integer (Visual Basic) int (C#) | The vertical distance from the top of the actual image to the top of that portion of the image currently being displayed.
Right | Integer (Visual Basic) int (C#) | The horizontal distance from the left side of the actual image to the right side of that portion of the image currently being displayed.
Bottom | Integer (Visual Basic) int (C#) | The vertical distance from the top of the actual image to the top of that portion of the image currently being displayed.
ScaleWidth | Double (Visual Basic) double (C#) | The horizontal scale between the displayed portion of the image and the actual image .
ScaleHeight | Double (Visual Basic) double (C#) | The vertical scale between the original image and the displayed image.
X | Integer (Visual Basic) int (C#) | X coordinates on the image where the mouse button was pressed.
Y | Integer (Visual Basic) int (C#) | Y coordinates on the image where the mouse button was pressed.

The values are in pixels.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


MouseWheelEventArgs class

Newtone.ImageKit.Win.ImageKit.MouseWheelEventArgs Class

This class provides data of the MouseWheelDownImage and MouseWheelUpImage events.

[Visual Basic] Public Class MouseWheelEventArgs Inherits EventArgs
[C#] public class MouseWheelEventArgsF EventArgs

Explanation

Property | Type | Explanation
ScrollCode | integer (Visual Basic) int (C#) | This parameter retrieves (in hexadecimal notation) the other types of buttons that are pressed at the time this event is generated. 0x0001: Left mouse button 0x0002: Right mouse button 0x0004: Shift key 0x0008: Ctrl key 0x0010: Middle mouse button If multiple buttons are pressed, the above values are combined in a bitwise OR operation. * The above hexadecimal notation is for VC++ or C++Builder For Delphi, please change the above 0x to $ For Visual Basic, please change the above 0x to &H
Direction | WheelDirection (Visual Basic) WheelDirection (C#) | Direction of the scroll (Vertical or Horizontal)

Direction refers to the value set in the MouseWheel property.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


PointEventArgs class

Newtone.ImageKit.Win.ImageKit.PointEventArgs Class

This class exposes properties for the ClickOnPanWindow events.

[Visual Basic] Public Class PointEventArgs Inherits EventArgs
[C#] public class PointEventArgsF EventArgs

Explanation

Property | Type | Explanation
X | Integer (Visual Basic) int (C#) | Retrieves the x coordinate (in pixels) for the location of a mouse click in the Pan Window.
Y | Integer (Visual Basic) int (C#) | Retrieves the y coordinate (in pixels) for the location of a mouse click in the Pan Window.

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ProgressEventArgs class

Newtone.ImageKit.Win.ImageKit.ProgressEventArgs Class

This class exposes properties for the Progress event.

[Visual Basic] Public Class ProgressEventArgs Inherits EventArgs
[C#] public class ProgressEventArgsF EventArgs

Explanation

Property | Type | Explanation
Cancel | Boolean (Visual Basic) bool (C#) | Sets whether or not the load or save process is canceled
Percent | Integer (Visual Basic) int (C#) | The percent of completion of the current process

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScanningScanEventArgs class

Newtone.ImageKit

Newtone.ImageKit.ScanningEventArgs Class

This class exposes properties for the Scanning event.

[Visual Basic] Public Class ScanningEventArgs Inherits System.EventArgs
[C#] public class ScanningEventArgsFSystem.EventArgs

Explanation

Property | Type | Explanation
Cancel | [Visual Basic] Boolean [C#] bool | Sets whether or not the scan process is canceled. By setting this property to True, he scan process can be canceled.
Percent | [Visual Basic] Integer [C#] int | Refers to the percent of scan completed (0`100%)

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollDispEventArgs class

Newtone.ImageKit.Win.ImageKit.ScrollDispEventArgs Class

This class exposes properties for the ScrollDispImage event.

[Visual Basic] Public Class ScrollDispEventArgs Inherits EventArgs
[C#] public class ScrollDispEventArgsF EventArgs

Explanation

Property | Type | Explanation
ScrollCode | integer (Visual Basic) int (C#) | This parameter returns different values depending on how the scrollbar was used 0: The up arrow on the vertical scroll box or the left arrow on the horizontal scroll box was clicked 1: The down arrow on the vertical scroll box or the right arrow on the horizontal scroll box was clicked 2: The vertical scroll box was clicked above the scroll bar or the horizontal scroll box was clicked to the left of the scroll bar 3: The vertical scroll box was clicked below the scroll bar or the horizontal scroll box was clicked to the right of the scroll bar 5: The scroll bar itself was moved 6: The scroll bar was moved to the top position (or the far left position) 7: The scroll bar was moved to the bottom position (or the far right position)
Pos | integer (Visual Basic) int (C#) | Returns the current position of the scroll bar
Direction | WheelDirection (Visual Basic) WheelDirection (C#) | The scroll direction: (Vertical or Horizontal)

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


ScrollDispEventHandler delegate

Newtone.ImageKit.Win.ImageKit.ScrollDispEventHandler Delegate

This delegate represents the method that handles the ScrollDispImageevent.
[Visual Basic] Public Delegate Sub ScrollDispEventHandler(ByVal sender As Object, ByVal e As ScrollDispEventArgs)
[C#] public delegate void ScrollDispEventHandler(object sender, ScrollDispEventArgs e);

Parameters

sender
Event Source

e
Event data contained in ScrollDispEventArgs

See Also

ImageKit Members | Newtone.ImageKit.Win.ImageKit


Cancel property

Newtone.ImageKit.Win.ImageKit.Effect.Cancel Property

This property sets whether or not the effect processing is canceled.

[Visual Basic] Public WriteOnly Property Cancel As Boolean
[C#] public bool Cancel {set;}

Property Value

Value | Explanation
True | The Effect process is canceled
False | The Effect process is not canceled

Explanation

The Cancel property sets whether or not the effect processing is canceled.

See Also

ImageKit.Effect Members | Newtone.ImageKit.Win.ImageKit


CloseMultiTiff Method

Newtone.ImageKit.Win.ImageKit.File.CloseMultiTiff Method

This method closes the file when a multipage tiff file is saved.
[Visual Basic] Public Function CloseMultiTiff() As Boolean
[C#] public bool CloseMultiTiff() ;

Parameters

None

Return Value

Returns True if successful. Returns False if unsuccessful.

Explanation

The CloseMultiTiff method closes the file when a multipage tiff file is saved. This method should by used when the TiffAppend property is set to True and after the SaveImageToFile method has been executed.

Please refer to the sample code on the TiffAppend property page.

Also See

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit


Cancel property

Newtone.ImageKit.Win.ImageKit.File.Cancel Property

This property sets whether or not the file control load or save process is canceled.

[Visual Basic] Public WriteOnly Property Cancel As Boolean
[C#] public bool Cancel {set;}

Property Value

Value | Explanation
True | The load or save process is canceled
False | The load or save process is not canceled

Explanation

The Cancel property sets whether or not the file control load or save process is canceled. When the Cancel property is True, the file control load or save process is canceled.

See Also

ImageKit.File Members | Newtone.ImageKit.Win.ImageKit